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1 SVDynamic Introduction
Welcome to the use of the SVDYNAMIC slope stability modeling software. SVDYNAMIC is a sophisticated
modeling tool that searches for the critical slip surface through use of the dynamic programming method.
SVDYNAMIC allows for easy searching for not only the most critical factor of safety but also the optimal
location of the slip surface. SVDYNAMIC allows geotechnical engineers, soil scientists, and hydrogeologists
to solve a wide variety of slope stability problems commonly found in engineering practice. Our software is
constantly maintained by a team of world-class programmers, geological and geotechnical engineers in order
to provide a cutting edge product.

SVDYNAMIC is currently being used by the major geological/geotechnical consulting firms and has been
subjected to professional peer review.

FEATURES
The following features distinguish SVDYNAMIC from other numerical modeling packages. 

· Searching for the optimum slip surface location (i.e., circular or noncircular)
· Solution of factor of safety using limit equilibrium methodology
· Easy-to-use
· Stress-deformation analysis for increased realism in the representation of the stress state
· Import of pore-water pressures from SVFLUX

A list of detailed features of the SVDYNAMIC software is presented in this User's Manual.

APPLICATIONS
Implementation of the SVDYNAMIC software allows solutions to be generated for the following types of
problems.

· Slope stability of mining open pits
· Slope stability related to road embankments and excavations
· Slope stability of earth dams
· Slope stability related to infrastructure development

An attempt has been made to minimize the complexity normally associated with numerical modeling. It is our
sincere hope that your use of the SVDYNAMIC software will prove to be a pleasant one. I welcome any
comments and suggestions you may have.

Best regards,

Murray Fredlund, P.Eng., Ph.D.
President/CEO
SoilVision Systems Ltd.
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2 Getting Started
This chapter provides information to help you get started with SVDYNAMIC.

2.1 About Documentation
Documentation for SVDYNAMIC consists of two separate manuals: namely, the User’s Manual and the
Tutorial Manual. The Tutorial Manual guides the user through a series of standard example models detailing
how to define and solve a model. Modeling tips are provided to assist the user. The Tutorial Manual is
designed to familiarize the user with the basics of using SVDYNAMIC for the creation of their own models. 

SVDYNAMIC is primarily based on the research work of Ha Pham performed at the University of
Saskatchewan, Saskatoon, SK. The theory and verification of the programming method implemented in the
software is presented in his thesis, as well as in the Theory section of the SVDYNAMIC Manual.

The features and capabilities specific to SVDYNAMIC are provided in the User's Manual. It is intended that
SVDYNAMIC be used in conjunction with the SVSOLID software. Reference should  also be made to the
SVSOLID User's Manual since many of the features are the same for the two software packages. 

THIS MANUAL IS INTENDED TO BE USED IN CONJUNCTION WITH THE
SVSOLID USER'S MANUAL

2.2 Basic Windows Skills
The following will provide directions on the overall operation of dialogs and menus within SVDYNAMIC.

2.2.1 Windows Fundamentals
SVDYNAMIC adopts many of the standards that have been implemented within Microsoft Windows.  The
SVDYNAMIC interface consists of the main workspace and many other dialogs that can be opened by
clicking buttons, selection from the menu, or other actions. One of the standard features in Windows is the
provision of a “tool tip” for every command button.  SVDYNAMIC has also adopted this standard.  The “tool
tip” is accessible by holding the mouse over the command button for a few seconds.  A “tool tip” will appear,
giving a description for the command button.  It is also a standard procedure to duplicate all of the command
buttons with an option in a drop down menu.  The descriptions that appear in the “tool tip” will be the same as
the description used in the menus to allow the users to easily match command buttons and its equivalent menu
option.  The menu options are included to allow the software to be fully functional through use of the
keyboard.

2.2.2 Locating Files and Directories
The ability to locate files and directories is essential to operating SVDYNAMIC.  The standard Windows file
dialog is used to locate files on your computer. To open a file from this dialog, the User can do any one of the
following:

· Type the name of the file in the File name control area and then click Open.  You may want to include
the path to the file if the file name is not currently displayed in the window.

· Select a file from the window by clicking on it and then click the Open button.
· Open a file by double clicking on its name in the window.

The program that is currently running on your computer opens the file you selected.
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2.2.3 System Messages
If a program encounters an action that it cannot perform it will provide a system message that will allow you to
try to continue with the desired action or cancel the desired action. This is a standard Microsoft Windows
feature. SVDYNAMIC has adopted the same standard and will provide you with detailed messages if the
program encounters an action it cannot perform. A detailed message will also be provided if you have not
supplied sufficient information to perform a specific task.

2.2.4 Copy and Paste
Data from external sources such as spreadsheets, text documents, and other SoilVision software can be pasted
into SVDYNAMIC in one of several ways. Any single number or text can be pasted into an appropriate single
field in most dialogs. Select the text in the text editor and press Ctrl + C on the keyboard. Then select the
destination field in SVDYNAMIC and press Ctrl + V on the keyboard. 

SVDYNAMIC allows the copying and pasting of columns of data directly into certain dialogs. This action
increases the speed at which models can be created. Instructions for pasting information into these dialogs are
located in the corresponding sections.
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3 Use of Engineering Judgment
The results of a SVDYNAMIC analysis should not be applied to an engineering design without first being
filtered through professional engineering judgment.  It has been a priority at SoilVision Systems Ltd. to
benchmark the results produced by SVDYNAMIC against solutions that are well known.  The results of these
comparisons may be found in the verification manual included with the SVDYNAMIC software.

It is recommended that the simple-to-complex methodology be applied when solving a particular problem with
SVDYNAMIC.  The simple-to-complex approach involves beginning all modeling projects with a simple
representation of the physical system that can be verified using hand calculations.  A variety of further
complexities can then be added to the model while the user carefully observes the change in results created by
added level of complexity. The reasonableness of changes in the computed results must be subjected to
professional engineering judgement.
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4 Historical Development
The first version of SVDYNAMIC was released in September 2003.  SVDYNAMIC has been developed
based on the research work performed in this area by Baker (1980), Yamagami and Ueta (1988), as well as
Pham and Fredlund (2003), and Fredlund and Gitirana (2003). SVDYNAMIC appears to be the first
commercial software to utilize the dynamic programming methodology for determining the critical slip surface
and the corresponding factor of safety.
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5 The Workspace
The workspace represents the drawing CAD window as well as the buttons and menus that allow access to the
primary functionality of the software. It is through this interface that the user can interact with the software.
The following sections outline details related to using the SVDYNAMIC user interface.

5.1 Workspace Sections
The workspace is divided into five main sections.  Each of these sections will be discussed starting at the top
of the dialog and working downward.

5.1.1 Title Bar
The title bar is used to display the project and problem that are currently open. The title bar also indicates the
current authorization level of the software (e.g., Student or Full).

5.1.2 Menu Bar
The menu system for SVDYNAMIC is first designed to provide an intuitive to the end user and secondly to
guide the user through the logical progression of model creation and solution. In general the menu system is
designed around a logical left-to-right and top-to-bottom progression. In other words, if a user progresses
through the menu options in a left-to-right and a top-to-bottom manner, they will automatically be guided
through the logical steps of model creation. 
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5.1.3 Toolbars
Command buttons are located on the floating toolbars implemented in SVOffice 2006. A description of the
purpose of each toolbar button can be obtained by moving the mouse over the button. Additional description
related to the toolbar will then appear as a tool-tip.

The following toolbars are available:

Toolbars may be displayed or hidden through the View > Toolbars menu.

5.1.4 Drawing Space
The drawing space is comprised of the CAD control used to present various 1D, 2D, and 3D views
representing model design. All editing of the model can be done using graphical drawing commands in the
drawing space. Objects represented in the drawing space are either graphical artwork (which do not affect
model output), or model geometries which are directly used in model creation. Double-clicking on any
particular graphical object will open the Properties dialog associated with that particular graphical object.

SVDYNAMIC provides the ability to describe geological features that naturally occur.  Regions and other
objects can be drawn in the two-dimensional/axisymmetric drawing space in cross-sectional view. The plan
view system operates as a 2D or Axisymmetric analysis except that the regions and objects are drawn in plan
view.  

The drawing space is the area where geometry is added, edited, and displayed, as well as where other objects
such as water tables, illustration objects, and features are viewed.  The main features of the drawing space are
the grid, limits, and view.  The Workspace grid can be edited by changing the spacing between grid points or
by turning the grid spacing on and off.  The grid spacing is controlled from the Workspace Grid Button
located on the View toolbar, while the Workspace grid is turned on and off using the GRID option in the
status bar.  

The limits of the drawing space are set using the View Settings dialog, located in the View > Settings menu. 
When an object is selected in the drawing space, the Region Selector is updated to show the region that has
been selected.  For three-dimensional problems, the surface selector always displays the active surface.

5.1.4.1 Workspace Object Hierarchy

SVDYNAMIC has an established hierarchy for displaying objects in the drawing space. Objects higher in the
list will appear over top of objects that are lower in the list. The hierarchy is as follows:

1. Sketching text and lines (top layer)
2. Boundary condition graphics
3. Flux sections
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4. Features
5. Regions (order specified by region ID: if Boundary Condition graphics are ON, the region

geometry does not need to show)

5.1.4.2 Command Buttons

The following information summarizes the functionality of each command button specific to the
SVDYNAMIC interface.  The description that appears beside each command button is the name of the menu
followed by the command name.  For example, the Search Boundary command can be found in the Model
menu. 

· Model > Ground Surface
The Ground Surface button opens the Ground Surface dialog that allows entry and editing of the ground
surface coordinates.

· Model > Search Boundary
The Search Boundary button opens the Search Boundary dialog that defines the search boundary
coordinates.

· Results > Critical Slip Surface
The Critical Slip Surface button opens the Critical Slip Surface dialog that provides a list of the search
boundary coordinates. The Critical Slip Surface button can be used after a model has been solved.

· Results > Distance Plots
A Distance Plot can be generated for the input and output variables. Any selected variable can be plotted
versus the distance along the slip surface. This option is available after the problem has been solved.

5.1.5 Status Bar
The Status Bar consists of controls that aid in drawing and viewing objects in the workspace. The current
coordinates of the mouse icon are also displayed. The Status Bar settings allow the user access to CAD
drawing functions which can greatly simplify the input of the model geometry. The command settings can be
changed by clicking on the Status Bar. The drawing settings are also available from the View > Options dialog
under the Grid tab.
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6 Tutorial Models
Tutorial example models for SVDYNAMIC can be found in the separate Tutorial Manual. The Tutorial
Manual for each software package can be found under the Help menu for each respective package.
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7 Modeling Concepts
SVDYNAMIC is designed to make slope stability analyses fast, simple, and easy to visualize.

7.1 Beginning with an SVSOLID Analysis
In order to run a slope stability analysis using SVDYNAMIC, a stress analysis must first be performed using
SVSOLID. The geometry, boundary conditions, and soil properties of the model are all defined within
SVSOLID. Different stress versus strain and shear strength parameters can be provided for each soil in
SVSOLID.

The first step in a SVDYNAMIC analysis is to import the geometry of the SVSOLID analysis. Secondly, the
stress state data generated by the SVSOLID solver is then loaded to SVDYNAMIC.

Pore-water pressure conditions can either be imported from the results of the SVSOLID analysis or from an
SVFLUX seepage analysis that was set up using the same geometry.

7.2 Regions
A region in SVDYNAMIC is the same as described in the SVSOLID User’s Manual. The differences in
SVDYNAMIC are that a default layer is provided on which art objects can be organized. Also, the ground
surface, model grid, search boundary, and slip surface modeling objects are independent of regions defined in
SVSOLID.

7.3 Minimum Requirements
SVDYNAMIC requires that certain information be provided before a slope stability analysis can be
performed. 

· Geometry
The geometry is imported from an SVSOLID analysis.

· Stress State Data
Stress state data is loaded from a .TBL file generated by the SVSOLID solver. The stress state data

includes stresses in the x-direction, sx, stress in the y-direction, sy, shear stress, sxy, cohesion, c, and the

angle of internal friction, f.

SVDYNAMIC can load pore-water pressure conditions from an SVSOLID or
SVFLUX analysis.

· Ground Surface
The ground surface elevation over the extent of the model must be defined. 

· Search Boundary
The search boundary defines the area of the model to be considered for a potential slip surface. 
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8 Model Creation
Organizing models by project and problem is the same as in SVSOLID with the exception that SVDYNAMIC
has only one system of analysis (i.e., a 2D analysis). For further information, please refer to the SVSOLID
User’s Manual.

8.1 Model Properties Dialog
Select Model > Properties to open the Model Properties dialog. This dialog provides a summary of the
organization of the Model. The description can be updated in the Model Properties dialog. This dialog can
also be used to record notes on the problem as the problem is being defined and solved. 

8.2 Importing Geometry from SVSolid
The geometry for an SVDYNAMIC analysis must be defined in SVSOLID. The geometry is then imported
into SVDYNAMIC by selecting Window > SVDYNAMIC in the menu. The import includes regions, region
shapes, world coordinate system settings, and water tables.  The units for the SVDYNAMIC model are set to
the SVSOLID model units during import.

To import the geometry from a SVSOLID problem:

1. Define all geometry, initial and final conditions, boundary conditions, and soil properties.
2. Select Window > SVDYNAMIC.

8.3 Defining Initial Conditions
Initial Conditions can be defined as either Stress State data or as Pore-Water Pressure data. The initial
conditions are defined in the Model > Initial Conditions > Stress Field... menu.

· Stress State Data
Stress state data can be imported from a .TBL file generated by the SVSOLID solver. The stress state data

include stresses in the x-direction, sx, stress in the y-direction, sy, shear stress, sxy, cohesion, c, and the

angle of internal friction, f. Click Browse to specify the path to the .TBL file corresponding to the
SVSOLID geometry that is being imported.

The file will be of the format: 

C:\SVS\Model_Files\Tutorial\2D\SteadyState\Tutorial_SVDynamic\Tutorial_Tutorial_SVDynamic_Slope
StabilityData.tbl

· Pore-Water Pressure Data
Pore-water pressure, uw can be imported from a .TBL file generated by the SVSOLID or SVFLUX
solver. Click Browse to specify the path to a .TBL file. Pore-water pressure data are not required in order
to analyze a problem. If pore-water pressures are not input, they are assumed to be equal to zero
throughout the problem.

Specifying a Table Plot in the Plot Manager form can create a pore-water pressure
file in SVSOLID or SVFLUX.
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· Data Tab
The Data tab allows users to define stresses in the form of a table. The variables that can be defined

include x-coordinate, y-coordinate, sx, sy, sxy, uw, c, and f. 

The stress data and pore-water pressure .TBL files must have the same gridlines.
Ensure the gridlines settings are the same on the Plot Manager form in SVSOLID or
SVFLUX. The solver default is a 51 X 51 grid.
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9 Menu System
The menu system for SVDYNAMIC is designed to be: first, intuitive to the end user and second, to guide the
user through the logical progression of model creation and solution. In general the menu system is designed
around a logical left-to-right and top-to-bottom progression. In other words, if a user progresses through the
menu options in a left-to-right and a top-to-bottom manner they will automatically be guided through the
logical steps of model creation. 

9.1 File Menu
The following operations are available for files in SVDYNAMIC. The SVOffice 2006 software maintains the
traditional folder structure found in previous versions of the software. The following functions are provided in
the software for saving, opening, exporting, and printing models.

More information on file storage can be found under the Help system contained with the SVOffice Manager
dialog.

Description of specific functions is as follows.

Recent Files: Provides a list of the most recently opened models.

Exit: Closes the current model and exits the program.

9.1.1 Open/Close/Save
Model data in SVDYNAMIC is stored in XML text files which may be opened by the user for viewing.

Open: The open command opens a new XML model file. Files are tagged with a .SVM file
extension. Only one model can be opened at a time. Double-clicking on a file from within
Windows Explorer will automatically start the SVOffice application and load the
designated model.

SVOffice Manager: This command opens the Manager dialog which is the primary method of performing
file operations in the context of the modeling software. The SVOffice Manager loosely
enforces the established directory structure such that models are organized in a logical
manner.

Close: Closes the current model.

Save: Saves the current model to the <model_name>.SVM file. It should be noted that in
previous versions models were continually saved in the database format. The current
design works similar to Microsoft Word in that any changes made to a model which are
not specifically saved will be lost. It is recommended that the save command be initiated
every 15 to 30 minutes during model creation.

Save As: Allows the user to save the current model under a new name. Once a model is saved under
a new name, the software: i) creates a new folder on the same level as the current folder,
and ii) saves the current newly named model to the created folder. 
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9.1.2 Exporting
It is important that the graphics in the modeling software be exported in a professional quality format. The
export menu options provide a high quality format to the user.

Export Geometry: This function provides a method for exporting current model geometry to a text file.
Only the geometry is exported. Flux sections, artwork, boundary conditions, soil
properties and other non-geometry objects are not exported. The purpose of this function
is to allow the export of the geometry for import into a different numerical model for
comparison purposes. The following should also be noted with this feature:

· Circle objects are not exported.
· Comma-separated formatting is used which can easily be imported into Excel.
· Column titles in the export file are: Region, Shape, x- and  y-coordinates (a closing point should be

written out for each region: the starting and ending points are the same)
· File is always written out to the current model folder.
· 3D: Surface files are written out to a separate file within the same folder. The title of this file is

<Selectedname_Surface>.txt". Format of the file is: Surface, x, y, z.

Export As: Exporting of the current model in the form it is displayed in the CAD window can be
accomplished with the Export As function. Supported raster formats are .BMP, .EMF,.
GIF, .JPG, .PNG, .TIF. High quality vector output is available by performing the export
function using the EPS format.

9.1.3 Printing
Functions associated with printing the model design are as follows:

Page Setup: Standard Windows printer setup dialog.

Print: Opens the Windows standard print dialog so that the image in the CAD window can be
sent to the currently selected printer. The image will automatically be scaled to fit on the
current page.

Print Preview: Opens the standard Windows print preview dialog.

9.1.4 Send Email
This option allows the user to quickly email the model that is currently opened to another person. This option
is particularly useful if the file is being sent to SoilVision Systems Ltd. in order to receive technical support on
a particular issue. A duplicate of the sent email is always emailed to the sender. It should also be noted that the
return email will be set to "soilvisionsystems@gmail.com". The user should not reply to this email as it is
never checked by the staff at SoilVision Systems Ltd.

If the model being attached requires any .TRI or .TBI files as input, these files will also be attached to the
email provided they are present in the local directory.

9.1.5 Check USB Security Key
Use this option to quickly check the status of your USB Security Key. The security routine will be executed
and any errors in accessing the security key or authorizing the current software will be provided.

This option is useful if you unplug your security key often or are accessing a network security key where
multiple licenses may be in use.
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9.2 Model Menu
The modeling menu contains the primary commands for the creation of a numerical model. The user should
progress through the menu in a top-to-bottom fashion in order to successfully create a numerical model.

9.2.1 Model Properties
The model properties dialog contains general information related to the current model. The project under
which the current model is organized as well as the System and the Type of the current model are recorded.
None of the parameters in this dialog can be edited. The proper procedure for changing any of the model
properties is to save a copy of the current model under a new folder / model name.

9.2.2 Model Settings
Select Model > Settings to open the Settings dialog. The Settings dialog controls information related to model
definition, as well as analysis parameters.

· Slope Direction
SVDYNAMIC allows the flexibility to solve a model with a slope oriented in either direction (i.e., slopes
facing the right or left). Select either: 'Right to Left' or 'Left to Right' from the Slope Direction combo
box. This setting determines the orientation of the search boundary and assumes that the geometry and
ground surface are defined accordingly. The default  slope direction is 'Right to Left'.

· Initial Factor of Safety Estimate
SVDYNAMIC will use the designated initial factor of safety at the beginning of an analysis. The closer
this value is to the final factor of safety, the faster the analysis will converge. The default initial factor of
safety is 1.5.

· Convergence Tolerance
This parameter controls the desired accuracy of the converged solution. A smaller convergence tolerance
results in a solution with greater accuracy. The smaller tolerance may take longer to converge. The default
tolerance is 0.001.

· Convergence Factor
The Convergence Factor controls the number of interactions that will be attempted to reach convergence.
A factor of 1 provides the fastest solution time, but will be less stable in some cases. It is recommended
that the default value of 1 be used. 

9.2.3 Geometry Definition
The Geometry Definition for SVDYNAMIC models is defined in SVSOLID. Please refer to the SVSOLID
Geometry Definition section for further details.

9.2.4 Initial Conditions
Initial Conditions such as Initial Stresses and Pore-water Pressures can be imported or defined as data. Please
check the Model Creation section for more information on defining initial conditions in SVDYNAMIC.

9.2.5 SVDynamic Boundary Conditions
Boundary Conditions for SVDYNAMIC models are defined using SVSOLID. Please refer to the SVSOLID
Boundary Conditions section for further details.
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9.2.6 SVDynamic Soil Properties
Soil Properties for SVDYNAMIC models are defined using SVSOLID. Please refer to the SVSOLID Soil
Properties section for further details.

9.3 Draw Menu
The purpose of the Draw menu is to present the options by which the user can draw objects in the CAD
workspace. Various objects that can be drawn are listed in the menu system. The following topics provide a
brief overview for drawing various objects. A full description of the properties of each object can be found
under the Help section of the object dialog.

9.3.1 Artwork
The Draw > Artwork menu allows the drawing of lines, text, as well as allowing bitmaps to be inserted into
the drawing space. When an artwork command is selected, the shape of the cursor will change to signify the
drawing mode. The user can cancel the drawing mode and go back to the select mode by pressing the Select
icon on the toolbar or proceeding to View > Select in the menu system. Art Objects are drawn on the region
displayed in the region selector. Art objects are for visualization purposes and do not affect the model
solution. If art objects are deleted from a specific region the objects will also be deleted.

All artwork geometry does not affect the model outcome and is for illustrative purposes only. Lines can
include an arrow at either or both ends. The properties of a line or text object can be edited by double-clicking
on that object. It should be noted that artwork is located using only x-, y-coordinates. This means that when
artwork is placed on a 3D image it is not located in 3D space and will not rotate with the model.

9.3.1.1 Draw Text

Use the following steps to add text to a model.

1. Select the Draw > Artwork > Text button from the menu.
2. The cursor will turn into a cross hair. Click the insertion point in the drawing space with the

mouse.
3. The Format Text dialog will appear.

4. Enter the text in the space provided and select the desired properties for your text.

5. Click OK and the text is added to the model.

Textbox properties include a border, fill, various font settings and orientations. Set
the World Coordinate System location for the center of the textbox by specifying the
coordinates.

Double-click on any textbox in the workspace to bring up the dialog to change the properties or define a new
location for the textbox. Setting a property to automatic will reset to the defaults. A custom setting indicates
that the properties are different from the defaults.

9.3.1.2 Draw Line Art

Line art can be drawn for any model.  Line art does not change the geometry of a model and will not be added
to any plots.  To enter line art, click on the Line Art button and draw in the line.  Double-click the last point to
finish the line.
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9.3.1.3 Insert Image

To insert an image to the model workspace, select Draw > Artwork > Insert Image. A window will pop up,
prompting the user to Browse for the desired image file that is to be placed. Once the image is placed, it can be
dragged anywhere on the workspace.

9.4 Edit Menu
The edit menu implements standard Microsoft Windows editing functions such as the delete, undo, and redo
functions. These functions are implemented in a manner consistent with established Windows standards. 

Delete: The Delete function deletes the object currently selected in the CAD window. The
deleted object is then moved to a temporary file on the hard disk such that the
deleted object can be recovered through the use of the Undo function.

Undo: The Undo function reverses the changes made with the last primary command.
This command could be applied to undo the deletion or addition of an object
added to the CAD window. It could also be applied to reverse the changes made
in the last-edited dialog.

It should be noted that a list of all model changes for a particular session are
stored in temporary files in the current model directory. Multiple Undo commands
will continue to reverse the changes made to the current model in the order they
were implemented.

The Undo feature by default is disabled when a 3D model is loaded in the
AcuMesh software because of the added time required to store changes when
editing large models. The Undo feature can be enabled for large models in
AcuMesh through the Options > Settings dialog in the SVOffice Manager dialog.

Redo: The Redo command reverses the changes made with the last Undo command. For
example, if the user adds a feature to a model and then presses Undo, the object
will be removed. Pressing Redo will bring the object back.

9.5 Format Menu
Formatting options related to viewing data in the CAD window are contained in the Format menu. The
functions contained in this menu do not change the model solution. A particular emphasis was placed on
adding functions to this menu which allowed reasonable views of the data in the context of the current
coordinate system. In a 1D or 2D model, or a 2D plan view of a 3D model, there will appear two sets of axis
indicating the coordinates for the current system. Descriptions of the methods used to place the current model
in space are described in detail in the following sections.

9.5.1 Format Axis
The axes are by default displayed at the edge of the currently specified world coordinate system. These axes
are displayed inside the current CAD window and, as such, are included on any exported visualization of the
CAD window. Full control over the details such as the axis labels, the axis title, the tic mark locations, the
spacing of the labels and other details can be found under the Format > Axis dialog. The dialog is detailed and
allows detailed control over how the axis are visualized. Control of the details of the axes are valuable for the
production of professional report-ready graphics.

The following specific axis functions should be noted.

Choose the Axis to Format: In this option group, the user can select the axis to edit. All data below this
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option group are updated immediately upon selection. The user also has the option to hide the current axis.

Remaining controls on the dialog may be edited through the use of the following tabs:

Patterns
Tab:

The purpose of this tab is primarily to allow control over the look of the line and
tic marks representing the axis. Under the X Axis Line group box the style of the
line can be set to None (no line), Auto (default), or Custom (allows the user to
specify custom settings). If Custom is selected then the user can specify the style,
color and weight of the axis line.

Option boxes on the right hand side of this page of the dialog allow the user to set
the display of major and minor tic marks as well as the location of the tic mark
labels.

Scale Tab: The scale tab operates in a manner similar to its operation in ExcelÒ. The
maximum and minimum values of the current axis, as well as the crossing point
for the opposite axis, can be specified. The major division setting controls the
number of divisions between the specified minimum and maximum values. The
minor division setting controls how many tic marks will be placed within each
major division.

Numbers
Tab:

The formatting of the labels associated with each major tic mark can be
accomplished using this tab. The category list box displays the major categories
of number formatting. Specific settings such as the number of decimal points and
the font used for the labels can be designated. 

Title Tab: The settings on the title tab allow the text as well as the formatting of the text for
the axis titles to be adjusted. The font can be specified using the
Windows-standard font selection dialog. A bounding box can also be placed
around the text using options under the Title Text Box option group.

9.5.2 Format Rulers
Rulers are displayed along the edge of the CAD window. The Rulers are not included in any export of the
CAD window and are provided as a drawing aid only. Full control over details such as ruler labels, tic mark
style, spacing of the labels, and other details can be found under the Format > Rulers dialog. 

The following specific ruler functions should be noted.

Choose the Ruler to Format: In this option group the user can select the ruler to edit. All data below this
option group is updated immediately upon selection. The user also has the option to hide the current ruler.

Remaining controls on the dialog can be edited through the use of the following tabs:

Patterns
Tab:

The purpose of this tab is primarily to allow control over the look of the line and
tic marks represented by the ruler. Under the Horizontal Ruler Line group box,
the style of the line can be set as well as the color and weight of the line. 

Option boxes on the right hand side of this page of the dialog allow the user to set
the display of major and minor tic marks and the weight of the lines used to
represent the tic marks.

The Minor Division sets the number of displayed tic marks between each label.

Numbers The formatting of the labels associated with each major tic mark can be
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Tab: accomplished using this tab. The category list box displays the major categories
for number formatting. Specific settings such as the number of decimal points and
the font used for the labels can be designated. 

9.6 View Menu
SVDYNAMIC provides advanced functionality to allow the user to view the numerical model in a variety of
ways. Many of the view commands can also be accessed from the View toolbar. New to SVOffice 2006 is the
ability to view a 3D numerical model in 3D mode prior to obtaining a solution.

None of the settings on the view menu affect the output of the numerical model.

The various selections on the view menu can be detailed as follows:

Select: The select function switches the cursor to the standard select mode. Objects can be
selected for making changes. 

Double-clicking on most objects will bring up the object properties. Clicking
the right mouse button on most objects will bring up a context-sensitive menu
which will list available commands relevant to that object.

Artwork: This menu item allows the display of artwork to be turned on or off. Artwork does not
affect model results in any way but is provided for display purposes only. Turning off the
display of artwork does not delete any artwork from the system but simply makes the
artwork invisible. Turning on artwork will re-display existing artwork.

Pan: The panning function allows the translation of the CAD viewing window within the world
coordinate system. Selecting the pan function switches the cursor to a small hand icon
which will allow dragging of the model "paper" workspace. 

Zoom: The zoom function allows current view of the model design to be magnified or expanded.
Typically the zoom function is useful zooming in on a model that has been drawn smaller.

Holding down the Shift key while pressing the zoom in/out toolbar button will
cause the current model to be zoomed out. By default pressing the zoom
toolbar button will always zoom in.

Rotate: The rotate functions are only applicable to 3D model viewing when in 3D viewing mode.
These functions allow a 3D model to be rotated around one of the coordinate axis.

A free-form rotate functionality is also provided in order to allow numerical models to be
rotated in any direction based on the movement of the mouse cursor.

Lighting: The lighting function determines whether the effects of lighting from a single arbitrary
light source are applied to the visualization of a 3D model. This function is only
applicable when viewing a 3D model in 3D mode. Turning off lighting will remove the
advanced shading of surface polygons.

Translucency: The translucency function controls the way 3D model surfaces and sidewalls are
displayed. If translucency is turned on, the surfaces and sidewalls are displayed as being
translucent. In other words, the user will be able to see through the surfaces and sidewalls.



Menu System 24 30of

If translucency is turned off, then all sidewalls and surfaces are displayed as a solid color.
Turning translucency on is useful when viewing the inner workings of a complex 3D
numerical model.

Translucency is only applicable to 3D numerical models which are viewed in 3D mode.

Toolbars: The use of floating toolbars is a feature added in the release of SVOffice 2006. The
toolbars allow program operations often used by the user to be summarized in logical
"groups" of common functionality. Use of the View > Toolbars menu option allows the
various toolbar groups to be turned off or on. 

It should be noted that toolbar buttons are also turned off or on depending on the currently
loaded numerical model. For example, all toolbar buttons with 3D functionality are turned
off (greyed out) when a 2D numerical model is loaded.

Turning off certain toolbars in some instances can be useful in reducing the clutter on the
display.

9.6.1 Settings
The View Settings dialog is the central dialog for changing the settings of the view coordinate system or the
drawing space, and the aspect ratio used to display the current model. Setting the size of the coordinate system
is one of the first steps the user would likely do when a model is being created. The specifics of each area of
the View Settings dialog can be seen in the following sections. It should be noted that the look of the form and
the setting contained therein change on this dialog depending if the user is working on a 2D or a 3D model.

2D Model
In a 2D model there is defined both a World Coordinate System, WCS, and a View Coordinate System,
VCS. The World Coordinate System is generally the extents of the numerical model in terms of real-world
coordinates. The View Coordinates System represents the coordinates of the current CAD window.

View Coordinate System: The View Coordinate System (VCS) represents the range of coordinates
displayed in the current CAD window.

Constrain Proportions: This setting locks the proportions of the view coordinate system. The
Constrain Proportions cannot be adjusted if the CAD window is re-sized. If Constrain Proportions is not
checked then the current model will be stretched or compressed each time the CAD window is re-sized.

Drawing Space in Pixels: This group box contains the physical settings of the current drawing space
or CAD window.

Aspect Ratio: This group box contains the ratio of coordinate lengths in the x : y directions. For
example, specifying an aspect ratio of 1:2 will mean that each y unit length will be twice as long as each x
unit length.

9.6.2 Options
The View > Options dialog contains general options related to the grid used in model design, drawing modes,
and certain global formatting settings.

Grid Tab
The options on this tab primarily control the options for the Status Bar. The current horizontal and vertical
grid spacing options can also be specified. Grid spacing is always assumed to start from the origin of 0,0.
A description of commands is as follows:
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Mouse
Coordinates:

The coordinates of the current location of the mouse in the drawing space
are located at the left of the status bar.

Aspect Ratio: Indicates the aspect ratio at which the problem is being viewed.

Grid On/Off: The GRID control turns the Workspace grid on or off in the drawing
space. Bold text indicates this control is on. If it is displayed a point will
be plotted at each grid intersection point. When the grid is off, the Snap
control is not in effect. Select the View > Grid Spacing button to open the
Grid Spacing dialog, which allows you to specify the spacing between
grid points in the drawing space. The grid is used to provide the user with
coordinate locations at regular intervals. For example, the user may want
to see grid points plotted every half meter in the x-direction or every 1
meter in the y-direction in order to simplify the drawing of geometry. The
grid spacing can be set under the View > Options dialog on the Grid tab.

If the user-defined grid space is too dense (less than 5 pixels after
converted into screen coordinates),  the grid points will not be displayed.
If the canvas is Zoomed In, as soon as the grid spacing > 5 pixels, the grid
points will be shown automatically.

Snap On/Off: When an object is being drawn, the lines or points will snap to the grid
point nearest the mouse cursor. Bold text indicates this control is on. If
snapping is turned on then any point drawn using the mouse in the CAD
control will snap to the nearest grid point. Snapping applies to all drawn
geometry including regions, features, flux sections, and artwork.

OSnap On/Off: If the OSnap control is turned on and your cursor is placed on a region,
clicking the right mouse button will cause the cursor to snap to the
nearest region point. Bold text indicates this control is on. Object
snapping allows snapping to the line end-points of other objects already
drawn in the CAD control. Use of this setting is recommended when
drawing regions which touch each other or drawing flux sections which
must start or end at a region boundary.

Ortho On/Off: The Ortho control will restrict lines in the drawing space to be drawn at
angles of 0 or 90 degrees. Bold text indicates this control is on. 

Sticky On/Off: The Sticky setting will cause adjacent region node points to move
together when adjacent points are moved. For example, if two regions
represented by boxes are side-by-side and share two node points, moving
the one region will cause the node in contact with this region to be moved
along with it.

Sizing The
Drawing Space:

SVDYNAMIC allows you to size the Workspace - drawing space such
that the maximum area is available.  The size of the drawing space can be
adjusted by dragging the lower right corner of the drawing space.

Format Tab
The Format tab contains options regarding the method by which boundary conditions and region node
points are displayed in the CAD window. 

Boundary
Condition
Graphics: 

This group box contains options regarding whether or not to display
boundary conditions graphics. Symbols and colored line segments are
used to represent the various types of boundary conditions. These
symbols and their meaning is defined in the Boundary Conditions



Menu System 26 30of

section of the user's manual.

The size of the displayed boundary condition symbols is determined by
the B.C. Graphics Scale text box as specified in percent of the total x
distance of the world coordinate system.

Node Dimension: Turning on node dimensioning displays the x and y coordinate of each
region node point when viewing a model in 2D mode. The font used for
this dimensioning can be selected. The default for this feature is off.

Node Symbol: The symbols used to represent node points can be selected in this group
box as well as the color and the weight of the lines.

9.6.3 World Coordinate System
The World Coordinate System (WCS) represents the range of coordinates in the current model that will be
considered active in model description. Typically WCS boundaries should be selected that are at least 10%
larger than the maximum and minimums of the selected model geometry. All finite element software codes are
designed to function correctly in all four quadrants therefore model solution should be independent of the
quadrant in which it is drawn.

9.7 Analyze
Once a model has been created the next step is to analyze the model. From the menu select Solve > Analyze or
press the Analyze button in the toolbar. SVDYNAMIC will begin solving the problem and will open the
Analysis Message Window.

9.7.1 Analysis Message Window
At each iteration of the solver, a new assumed factor of safety will be displayed along with the current analysis
time. If any errors occur the corresponding message will be displayed and the solving will stop.

The Stop button can be pressed in order to stop the solver after finishing the current iteration.

9.7.2 Analysis Completion
After the SVDYNAMIC solver has analyzed a problem it will display the final factor of safety and analysis
time in the Message Window. The resulting Slip Surface will also be drawn in the workspace and the factor of
safety for the slip surface will be shown in the upper right portion of the workspace.

9.7.3 Analysis Report Dialog
The analysis report is a summary of the messages provided while the problem is being solved. Select Solve >
Report from the menu to open the Analysis Report Form.

To print the report, press the Print Report button to open a printable format of the report. Press the printer icon
to send the report to the printer.

9.8 Results Menu
SVDYNAMIC provides advanced functionality that allows the user various options in order to view model
output in a number of different ways. In particular, model output related to the FlexPDE plots created during
model solution can be viewed, or the results exported to a .DAT file can be viewed using the AcuMesh
software. 
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AcuMesh: The AcuMesh command calls activates the AcuMesh back-end visualization
software module. A dialog will appear asking the user which .DAT file to open in
the current model directory. A .DAT file must first be specified in the Model >
Reporting > Output Manager in order for this option to be available for the end
user. Please refer to the AcuMesh user's manual for full details on the operation of
the AcuMesh visualization software.

FlexPDE
Plots:

When the FlexPDE solver is called using the Analyze function, all output which
has been designated type PLOT  and which have been selected by the user in the
Model > Reporting > Plot Manager dialog is saved to a .PG5 file in the current
modeling directory. This function calls the FlexPDE solver in viewing mode and
opens the .PG5 file in the current modeling directory. It should be noted that
MONITORS are not saved in the .PG5 file.

Verification
:

Verification is a necessary part of any modeling exercise. This menu contains the
functions that can  be used for verification and validation of the current numerical
model.

Node
History:

Plots of the total number of nodes in a problem as a function of time or stage can
be obtained using this function. It is often interesting to view the mode history in
a transient problem. If, for example, a numerical model is being subjected to
excitations at various time-steps this may be reflected in increased node density. It
should be noted that it is easier for the solver to justify creating nodes than
releasing them through a relaxation. Therefore, created nodes may remain even if
the original excitation which caused the introduction of the modes disappears.

The Results menu also provides QA/QC functionality for exploring the quality of the obtained solution. View
the following sections for further details.

9.8.1 Results
This section explains how to view the results of a slope stability analysis.

9.8.1.1 AcuMesh

The AcuMesh command starts the AcuMesh back-end visualization software module. A dialog will appear
asking the user which .DAT file is to be opened in the current model directory. A .DAT file must first be
specified in the Model > Reporting > Output Manager in order for this option to be available to the end user.
Please refer to the AcuMesh User's Manual for full details on the operation of the AcuMesh visualization
software.

9.8.1.2 Slip Surface Dialog

The Slip Surface dialog has a list of the slip surface points generated by SVDYNAMIC. To open the Slip
Surface dialog, use the Slip Surface button or select Model > Slip Surface from the menu. Click on a point in
the list to highlight it in the workspace.

9.8.1.3 Slip Surface Considerations

The slip surface generated by SVDYNAMIC is primarily dependent on the stress state in the soil, but other
modeling factors can influence the solution.

1. A slip surface that reaches the base of the problem may not be a good representation of the actual
slip surface unless the base is considered to be bedrock. To allow the slip surface to be fully
defined, increase the depth of the problem.

2. It is recommended that the slip surface be allowed to have a horizontal portion of a least 2 stages
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(i.e., a stage is the distance between vertical gridlines) on both the left and right sides of the
problem. By extending the search boundary width, more of the problem can be taken into
consideration to allow a fully developed slip surface.

9.8.1.4 Distance Graphs

Once an analysis has been completed and the slip surface generated distance graphs can be plotted. A distance
graph is an input or output variable versus distance along the slip surface. The variables that can be plotted
are:

Input Variables: Stress in the x direction, sx

Stress in the y direction, sy

Shear stress, sxy

Cohesion, c
Friction angle, f
Pore-water Pressure, uw

Output Variables: Shear Resistance, tr

Acting Shear Force, tf

Shear strength, ts

Acting Shear Strength, ta

Slip surface segment angle, a

Press the Plots button or select Model > Plots to open the Distance Graph form.

When the form is first opened a graph of the x-direction stress will be plotted. Use the Select Plot combo box
to select a graph of another variable.

Distance graph values are plotted at the slip surface points and midpoints for the
input variables and at the slip surface midpoints for the output variables.

9.8.1.4.1   Formatting the Distance Graph

The axis, gridlines, titles, and data series can all be formatted on the distance graph. Select the appropriate
button on the right side of the form or double-click an item on the graph to open the corresponding formatting
form. 

Each Distance graph formatting form has an automatic, custom, and none setting.
Automatic is the SVDYNAMIC default, custom is the user defined settings, and
none will cause the item to not be displayed. The formatting settings are retained for
every graph in every problem in the database.

9.9 Window Menu
Part of the new integrated design of SVOffice includes the ability to switch back and forth between the various
component software packages. For example, if the user is solving a slope stability model using SVDYNAMIC,
they may want to go to SVSOLID to change the stress model and then go back to SVDYNAMIC to obtain a
better solution. This functionality of switching between the various components is provided in the Window
menu as well as the Application Selector toolbar.
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9.10 Help Menu
The help menu of our software provides links to resources which will aid in successful model creation. The
help menu for each software package brings up help related to the particular software at hand. Help in creating
and opening numerical models can be found in the help menu of the SVOffice Manager dialog.
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