
1 

 
  
  

Online Help for Project Managers and 

Translators 

  
  

  

  

 

Copyright © Wordfast, LLC 2015. All rights reserved. 

 



2 

 Table of Contents 
About Wordfast Pro ....................................................................................................................................... 9 

Overview .................................................................................................................................................... 9 

Key advantages ......................................................................................................................................... 9 

Project Manager plug-in workflow ............................................................................................................. 9 

TXML editor workflow .............................................................................................................................. 10 

Getting started with Wordfast Pro ............................................................................................................... 11 

System requirements ............................................................................................................................... 11 

Installing and activating Wordfast Pro 3 .................................................................................................. 11 

Opening Wordfast Pro 3 .......................................................................................................................... 12 

Wordfast Pro 3 homepage....................................................................................................................... 13 

PM perspective .................................................................................................................................... 13 

TXML editor perspective ...................................................................................................................... 14 

Using PM plug-in ......................................................................................................................................... 17 

Receiving files and conversion rules ....................................................................................................... 18 

Setting up filters ....................................................................................................................................... 18 

Selecting filter settings ......................................................................................................................... 20 

Viewing default file filters ..................................................................................................................... 21 

Adding new file filters ........................................................................................................................... 23 

Selecting FrameMaker filter preferences ............................................................................................. 25 

Selecting ICML filter preferences ......................................................................................................... 27 

Adding an Excel file filter ......................................................................................................................... 29 

Simple wizard ....................................................................................................................................... 33 

Advanced wizard .................................................................................................................................. 36 

Adding a PowerPoint filter ....................................................................................................................... 43 

Adding a PPT file filter ......................................................................................................................... 43 

Adding a PPTX file filter ....................................................................................................................... 44 

Adding a Word filter ................................................................................................................................. 45 



3 

Adding a default Word filter ................................................................................................................. 46 

Adding a Word 2007 filter .................................................................................................................... 47 

Adding a SubRip Text filter .................................................................................................................. 49 

Adding an IDML filter ............................................................................................................................... 53 

Default IDML filter ................................................................................................................................ 53 

IDML Filter (newer version) ................................................................................................................. 55 

Adding a Quark Documents filter ............................................................................................................ 57 

Adding a new text-based (XML) filter ...................................................................................................... 60 

Selecting INX filter preferences ............................................................................................................... 64 

Selecting SDLXLIFF filter preferences .................................................................................................... 65 

Analyzing files .......................................................................................................................................... 66 

Analyzing files ...................................................................................................................................... 67 

Selecting Analysis output options ........................................................................................................ 72 

Extracting frequents ................................................................................................................................. 75 

Populating frequents ................................................................................................................................ 78 

Transcheck .............................................................................................................................................. 80 

Export notes ......................................................................................................................................... 87 

Segment Changes Report ................................................................................................................... 87 

Cleaning up and updating TM ................................................................................................................. 89 

Selecting Cleanup options ................................................................................................................... 92 

Bilingual Export ........................................................................................................................................ 94 

Export Only... ....................................................................................................................................... 96 

Export files for review........................................................................................................................... 98 

Import reviewed files .......................................................................................................................... 102 

Split/Merge TXML .................................................................................................................................. 104 

Splitting TXML .................................................................................................................................... 106 

Merge TXML ...................................................................................................................................... 107 

Show/Hide 100% ................................................................................................................................... 108 

Swap Source/Target .............................................................................................................................. 111 



About Wordfast Pro 

4 

Pseudotranslation .................................................................................................................................. 114 

TXML editor menu options ........................................................................................................................ 119 

File ......................................................................................................................................................... 119 

Edit ......................................................................................................................................................... 120 

Translation Memory ............................................................................................................................... 122 

Terminology ........................................................................................................................................... 123 

Window .................................................................................................................................................. 124 

Help ....................................................................................................................................................... 124 

Managing projects ..................................................................................................................................... 127 

Creating or opening a project ................................................................................................................ 127 

Creating a project ............................................................................................................................... 127 

Opening a project ............................................................................................................................... 130 

Creating or opening a TM ...................................................................................................................... 131 

Selecting translation memory settings ............................................................................................... 132 

Creating a local TM ............................................................................................................................ 135 

Adding a local TM .............................................................................................................................. 138 

Exporting a local TM .......................................................................................................................... 140 

Adding a remote TM to WFServer ..................................................................................................... 141 

Changing TM Priority ......................................................................................................................... 146 

Importing and exporting glossaries ....................................................................................................... 147 

Importing a glossary ........................................................................................................................... 148 

Creating a new glossary .................................................................................................................... 149 

Import into existing glossary .............................................................................................................. 150 

Adding a remote glossary .................................................................................................................. 151 

Editing a remote glossary .................................................................................................................. 160 

Exporting a glossary .......................................................................................................................... 160 

Changing Glossary Priority ................................................................................................................ 162 

Defining penalties .................................................................................................................................. 163 

Defining color codes .............................................................................................................................. 165 



5 

Enabling spell check .............................................................................................................................. 169 

Using Spell Check ................................................................................................................................. 171 

Translating in a project .............................................................................................................................. 172 

Opening a file ........................................................................................................................................ 173 

Translating a file .................................................................................................................................... 175 

Clearing a target segment ................................................................................................................. 178 

Viewing last edited segment .............................................................................................................. 178 

Finding and replacing content ............................................................................................................ 178 

Enabling translation options ............................................................................................................... 180 

Enabling Machine Translation ........................................................................................................... 182 

Enabling Auto-Propagation ................................................................................................................ 189 

Enabling Auto-Suggest ...................................................................................................................... 191 

Leveraging repetitive content ............................................................................................................. 193 

Working with TM .................................................................................................................................... 196 

Leveraging translation memory ......................................................................................................... 196 

Using Replaceables ........................................................................................................................... 198 

Translation memory default color representation .............................................................................. 199 

Using TM Lookup window .................................................................................................................. 199 

Viewing TM leverage results .............................................................................................................. 199 

TM Lookup default color representation ............................................................................................ 200 

Using TM lookup ................................................................................................................................ 201 

Updating translation memory ............................................................................................................. 202 

Working with terminology ...................................................................................................................... 202 

Setting copy term option .................................................................................................................... 203 

Highlighting terms .............................................................................................................................. 205 

Auto-propagating terms ..................................................................................................................... 206 

Using a term wildcard ........................................................................................................................ 207 

Leveraging a glossary ........................................................................................................................ 207 

Adding terms ...................................................................................................................................... 208 



About Wordfast Pro 

6 

Editing terms ...................................................................................................................................... 213 

Copy a term ....................................................................................................................................... 215 

Adding a blacklist ............................................................................................................................... 216 

Editing blacklist .................................................................................................................................. 217 

Using Wordfast Pro and Wordfast Classic glossaries ....................................................................... 220 

Working with tags .................................................................................................................................. 221 

Viewing tags ....................................................................................................................................... 222 

Copying tags ...................................................................................................................................... 224 

Editing tags ........................................................................................................................................ 225 

Deleting tags ...................................................................................................................................... 226 

Removing tags in current segment .................................................................................................... 226 

Removing all tags .............................................................................................................................. 227 

Editing source segment ......................................................................................................................... 227 

Using Transcheck .................................................................................................................................. 229 

Enabling Transcheck ......................................................................................................................... 229 

Configuring Transcheck ..................................................................................................................... 231 

Viewing Transcheck warning ............................................................................................................. 235 

Using Outline window ............................................................................................................................ 236 

Navigating using Outline window ....................................................................................................... 237 

Sorting segments ............................................................................................................................... 237 

Outline window default color representation ...................................................................................... 238 

Viewing TXML Context .......................................................................................................................... 239 

Using notes ............................................................................................................................................... 239 

Adding notes .......................................................................................................................................... 239 

Editing notes .......................................................................................................................................... 242 

Deleting notes ........................................................................................................................................ 242 

Exporting notes ...................................................................................................................................... 242 

Viewing segment changes ........................................................................................................................ 244 

Using shortcut icons .................................................................................................................................. 245 



7 

Modifying colors and fonts ........................................................................................................................ 247 

Confirming or Unconfirming segments ...................................................................................................... 252 

Saving a file ............................................................................................................................................... 253 

Closing a file .............................................................................................................................................. 254 

Deleting a project ...................................................................................................................................... 254 

Working with advanced options ................................................................................................................ 257 

Selecting memory preferences .............................................................................................................. 257 

Selecting AutoSave Preferences ........................................................................................................... 258 

Defining segmentation settings ............................................................................................................. 259 

Managing shortcut keys ......................................................................................................................... 262 

Viewing shortcut keys ........................................................................................................................ 263 

Modifying shortcut key schemes ........................................................................................................ 268 

Modifying shortcut keys ..................................................................................................................... 269 

Creating shortcut keys ........................................................................................................................... 269 

Managing licenses ................................................................................................................................. 270 

Re-installing license certificate .......................................................................................................... 270 

Verifying current license certificate .................................................................................................... 271 

Update notification ............................................................................................................................. 272 

Updating Wordfast Pro 3 dictionaries ....................................................................................................... 272 

Accented characters and shortcuts ........................................................................................................... 274 

Font mapping ............................................................................................................................................ 275 

Troubleshooting errors .............................................................................................................................. 277 

Working with Wordfast Aligner .................................................................................................................. 285 

Using Wordfast Aligner .......................................................................................................................... 285 

Basic Aligner menu options ................................................................................................................... 288 

Using Aligner shortcut icons .................................................................................................................. 290 

TM Administration perspective .................................................................................................................. 293 

Using TM Administration perspective .................................................................................................... 293 

Updating TM Administration preferences .......................................................................................... 293 



About Wordfast Pro 

8 

Connecting to a remote TM ............................................................................................................... 295 

Modifying TM content......................................................................................................................... 296 

Purging private TUs ........................................................................................................................... 297 

Adding an administrative password ................................................................................................... 300 

Finding and Replacing Translation Units (TUs) ................................................................................. 301 

Merging local translation memories (TMs)......................................................................................... 303 

Deleting Translation Units (TUs) ........................................................................................................ 304 

Marking Translation Units (TUs) ........................................................................................................ 305 

Removing all tags from selected Translation Units (TUs) ................................................................. 306 

Searching TUs ................................................................................................................................... 307 

Reorganizing a local TM .................................................................................................................... 308 

Basic menu options ............................................................................................................................... 309 

Using shortcut icons .............................................................................................................................. 312 

 

 

 



9 

About Wordfast Pro 
Overview 

Wordfast Pro 3 is a Java-based translation and editing application designed to improve the way in which 

translators work. It presents translators with a collaborative environment where translation memory (TM) 

files can be accessed quickly and efficiently. Wordfast Pro 3 is a flexible application that can work with 

desktop TM files or interact directly with a powerful TM server application. It can also operate as a stand-

alone tool to supplement existing translation workflows. 

Key advantages 

The key advantages of Wordfast Pro 3 are as follows: 

• TM compatibility: Tabular TM format allows for simple integration of Trados, SDLX, Translation 

Memory eXchange, or Déjà Vu TM files. 

• Format flexibility: Native format is TXML, an XML-based pivot format. Filters exist for DOC, PPT, 

XLS, PDF, HTML, MIF, INX, JSP, RC, TMX, and TTX files. Wordfast Pro 3 supports only those 

TTX files that are translated and segmented using tag editor. 

• Collaborative environment: Users can interact with TM Server and share translation memory 

assets in real-time. 

• Automated editing: Multi-lingual spell checkers and terminology recognition improves the speed 

and accuracy in the review process. 

• Administrative security: Managers can assign specific rights and privileges to individual 

translators or linguistic teams. 

Wordfast Pro 3 provides an intuitive, collaborative environment where translators can deliver higher 

quality in-language content with greater consistency and efficiency. 

Project Manager plug-in workflow 

Find below the workflow diagram for PM plug-in: 
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TXML editor workflow 

Find below the workflow diagram for TXML editor: 
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Getting started with Wordfast Pro 
This section includes basic information that will help you get started with Wordfast Pro 3. 

• System requirements 

• Installing and activating Wordfast Pro 3 

• Opening Wordfast Pro 3 

• Wordfast Pro 3 homepage 

System requirements 

The minimum system requirements are: 

• Operating system: Windows XP or higher, Windows 7, Windows 8.1, Mac OS 7 or higher 

(including OS X) or Linux 

• Processor: 1.6 GHz 

• RAM: 1GB 

• Hard disk space: 200MB 

Installing and activating Wordfast Pro 3 

To install Wordfast Pro 3: 

1. Download Wordfast Pro 3 from the Wordfast webpage 

(http://www.wordfast.com/store_download.html) to your computer. 

2. Open Wordfast Pro, and run the installer. 

The Wordfast Pro 3 Demo Mode appears. 

 
Note: Wordfast Pro 3 requires a Java JRE to be installed on your PC. During installation, if Java 

JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro 3 will refer to it when 

running. 

In the Demo Mode, you can view and test all the functions of the software. You can purchase a 

Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html. 

If you do not purchase a license, you are limited to storing up to 500 translation units in your 

translation memories. 

3. Go to Help > License Management. 

The Activation Dialog appears. 

http://www.wordfast.com/store_download.html
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4. Copy the Install number as it appears in the Activation Dialog box.  

5. Log in to the Wordfast website with your email address and password. 

6. Paste the Install number from the Activation Dialog box in the field Your Wordfast Professional 
Install Number. The license file is emailed to you. Alternatively, right-click the link appearing on 

the Confirmation Page, and save the target as. The license file has a .lic file extension. Save the 

file in a secure location. 

7. Open Wordfast Pro, and go to Help > License Management. 
8. Click License Manager. 
9. Click Re-install a License Certificate. 

10. Click Next > Browse, and browse to the .lic file. 

11. Click Open > Next > Next > Finish. 

12. Restart Wordfast Pro 3. 

The license is active. If you have any problems with the license and require support, please log 

into the Wordfast Pro 3 support hotline at www.wordfast.com. Alternatively, refer to the Wordfast 

wiki page, How to license Wordfast Pro. 

Opening Wordfast Pro 3 

To open Wordfast Pro 3, there are two options: 

Double-click the Wordfast Pro 3 shortcut on the desktop. 

OR 

Go to Start Menu > All Programs > Wordfast > Wordfast. 

The Wordfast Pro 3 homepage appears. Wordfast Pro opens in TXML Editor perspective. 

  

https://www.wordfast.net/
https://www.wordfast.net/wiki/How_to_license_Wordfast_Pro
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Wordfast Pro 3 homepage 

The Wordfast Pro 3 homepage is the work space for translators to work on translation projects. The 

homepage directs you to two perspectives: 

• PM perspective 

• TXML editor perspective 

PM perspective 

Find below a sample PM perspective screenshot: 

  

Find below the description for the various components of the PM perspective: 

  

Number Use to... 

 

PM 

perspective 

icon 

view the PM perspective. The PM perspective is the workspace 

for project managers to process files before and after 

translation. Refer to Using PM plug-in. 

 

Analyze analyze files for translation against a TM to leverage reusable 

content and pre-translate files. Refer to Analyzing files. 
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Number Use to... 

 

Extract freq extract recurring segments in the files. Refer to Extracting 

frequents. 

 

Populate 

freq 

populates source TXML files  with extracted recurring 

segments. Refer to Populating frequents. 

 

Transcheck check the translated content for missing tags, empty target, 

numbers, untranslated segment and/or terminology. Refer to 

Transcheck 

 

Cleanup clean up the file and update the TM after translation is 

complete. Refer to Cleaning up. 

 

Pseudotrans copy source content to target. Pseudotranslated target content 

will have accented characters and the text will be expanded by 

20%. This will help you preview what content will be selected as 

translatable and how complex formatting will appear in the 

target. Either source files or TXML files can be 

pseudotranslated. Refer to Pseudotranslate. 

 

Bilingual 

Export 

export the TXML file into RTF format, edit using MS Word and 

import back the edited file. Refer to Bilingual Export. 

 

Split/Merge split or merge a TXML file. The split options available are: 

• Split after selected number of TUs 

• Split to selected number of parts 

• Split after selected number of words) 

Refer to Split/Merge TXML. 

 

Show/Hide 

100% 

show or hide 100% translation memory matches in the TXML 

file(s). Refer to Show/Hide 100% matches. 

 

Swap 

Src/Tgt 

swap source with target or vice versa. Refer to Swap 

Source/Target. 

 

TM 

Preferences 

create or open a translation memory. 

  

  

TXML editor perspective 

Find below a sample TXML editor perspective screenshot: 
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Find below the description for the various components of the TXML editor perspective: 

  

Number Use to... 

 

Title bar view the project name. 

 

Menu bar carry out all the functions, some of which are 

also included in the tool bar. Refer to TXML 

editor menu options. 

 

Tool bar quickly complete common functions. Point to 

the shortcut icon to see its function. 

 

TXML 

perspective 

icon 

view the TXML editor perspective. The 

TXML editor perspective is the workspace 

for managing translation projects. This 

perspective allows you to translate files by 

leveraging translation memory and 

terminology. Refer to Managing projects. 

 

Main 

translation 

window 

translate a file. This is the work space for 

translating files. Refer to Translating in a 

project. 
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Number Use to... 

 

TM Lookup 

window 

view TM leverage results and context 

searching. You can either search for a term 

or a phrase and the source and target 

segments appear in a table format. Refer to 

Using TM Lookup window. 

 

TXML 

Context 

view the TXML context of the currently open 

file. Refer to Viewing TXML Context. 

  
Notes view, edit and delete notes specific to each 

segment. Refer to Using notes. 

  
Segment 

Changes 

view the segment changes in the currently 

open file. Refer to Viewing segment 

changes. 

 

TXML 

Attributes 

view the custom attributes applicable to a 

particular segment. To enable this tab, go to 

the Windows menu and click Show View > 
TXML Attributes. 

 

Outline 

window 

  

quickly navigate a file from one source 

segment to another. Refer to Using Outline 

window. 
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Using PM plug-in 
The Project Manager plug-in includes tasks that prepare files for translation. The preparation process 

includes the following tasks: 

• Receiving files and conversion rules 

• Setting up filters 

• Analyzing files 

• Extracting frequents 

• Populating frequents 

• Cleaning up and updating translation memory 

• Pseudotranslate 

• Split/Merge TXML 

• Bilingual Export 

• Show/Hide 100% matches 

• Transcheck 

• Swap Source/Target 

Note: The user name used for notes, TM, segment changes is the user's login name, by default. To 

change or add a new name, go to Preferences >General > User Name, and edit the User Name as 
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shown in the example below. 

 

Receiving files and conversion rules 

This is the first step towards preparing files for translation. Find below a brief description of files and 

conversion rules: 

• Files: These are received from clients for translation. They may be in any format, such as DOC, 

XLS, PPT, INX, HTML, JSP, and so on. When you open any one of these files in Wordfast Pro 3, 

it is automatically converted to TXML. 

• Conversion rules: These rules are required for creating a new XML filter to convert XML files to 

TXML. The rules file is provided to you by the client. 

Setting up filters 

A filter defines the working parameters for different types of files received for translation. A filter can be 

selected from the available list or a new format created. Find below a list of available filters. 

  

Default Filter Name File 
type/extension 

      

ASP Active Server Pages .asp 

Excel 2007 Microsoft Excel 2007 and 

2010 documents 

.xlsx, .xlsm 
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Default Filter Name File 
type/extension 

Excel  Microsoft Excel documents .xls 

HTM HTM files .htm 

HTML HTML files .html 

ICML Adobe InCopy ICML files .icml 

IDML Adobe InDesign IDML files .idml 

INX Adobe InDesign INX files .inx 

JSP Java Server Pages .jsp 

Java Properties Java.properties files .properties 

MIF Adobe Frame Maker files .mif 

PDF Adobe PDF files .pdf 

Portable Object    .po 

PowerPoint 2007 Microsoft PowerPoint 2007 

and 2010 files 

.pptx 

PowerPoint  Microsoft PowerPoint files .ppt 

Quark Quark documents .tag 

RTF Rich Text Format files .rtf 

SDLXLIFF SDLXLIFF files .sdlxliff 

SRT SubRip Text .srt 

TTX TRADOS Bilingual files .ttx 

TXLF Wordfast XLIFF files .txlf 

TXT Text files .txt 

VDX Microsoft Visio files .vdx 

Word 2007 Microsoft Word 2007 and 

2010 files 

.docx, .docm, 

.dot, .dotm, dotx 

Word Microsoft Word  files .doc 

XLIFF XLIFF files .xlf, .xliff 

XML XML files .xml 

  

  

Please note that the process to add MS Excel files is different from the other file filters. Additionally, 

Wordfast Pro 3 supports only those TTX files that are translated and segmented using tag editor. The 

TTX files must be renamed to match the source format if they need to be viewed in tag editor. 
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Find below the procedures for the following tasks: 

• Selecting filter settings 

• Viewing default file filters 

• Adding new file filters 

• Adding a new text-based (XML) filter 

• Adding an Excel file filter 

• Adding a PowerPoint filter 

• Adding a Word filter 

• Adding a SubRip Text filter 

• Adding an IDML filter 

• Adding a Quark Documents filter 

• Selecting FrameMaker filter preferences 

• Selecting ICML filter preferences 

• Selecting INX filter preferences 

• Selecting SDLXLIFF filter preferences 

Selecting filter settings 

There are two common filter settings that can be enabled by navigating to Edit > Preferences > 
Translations > Filters as shown in the screenshot below. 

• Numbers extraction: Select to extract all number-only segments to the translatable TXML file. 

Select to clear the checkbox, and to exclude number only segments to the translatable TXML file 

• Segmentation on break: Select to segment the text at every logical break such as period (.) or 

soft return. 
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Viewing default file filters 



Using PM plug-in 

22 

A number of text-based filters (.htm, .html, .xml, .txt, .asp, .jsp) are pre-configured for your convenience. 

For example, if you select the Default Java Properties Filter, the Encoding UTF-8 is automatically 

selected. 

  

To view a default file filter: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Filters > Formats. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 

 

 
  

2. Select a default filter of your choice. For example, if you select Default HTML Filter, the options 

for HTML files appear in the Options box as shown below. 
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3. If required, you can modify the default options. Default filters cannot be removed. 

Adding new file filters 

If the filter of your choice is not available in the default option, you can add a new filter. For XML and 

Excel filters you will need to provide additional information. 

Note: if a filter cannot be customized, it will not appear in the list of filters that can be added. 
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To add a new file filter: 

1. Follow steps 1 and 2 from Viewing default file filters. 

The Formats dialog box appears. The default filters appear in the Available formats box. 

 
  

2. Click New. 

The New Format dialog box appears. 
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3. Select the desired filter from the list, and click OK. 

  

Selecting FrameMaker filter preferences 

The FrameMaker filter preferences must be set before using this filter option. 

To set FrameMaker filter preferences: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Filters >Formats. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 

2. Select Format Type as Default MIF Filter. 

The FrameMaker Filter options appear. 
Note: The MIF versions supported are 8, 9, 10, and 12. 
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3. Select the required FrameMaker filter preferences. 

  

Select to... 

Translate 

Reference Pages 

send reference pages for translation 

Translate Master 

Pages 

send master pages for translation 



27 

Select to... 

Translate 

Variables 

send text marked as variable for 

translation. 

Translate Cross 

References 

send text marked as cross reference 

for translation 

Translate 

Autonumber 

Formatting 

send text with number formatting for 

translation. 

Translate Hidden 

Conditional Text 

send text marked as hidden and 

conditional for translation. 

Translate Tab as 

Text: 

send text containing tab spaces for 

translation. If unchecked, a tag 

appears in the TXML instead of the 

tab. 

Translate 

Discretionary 

Hyphen as Tag: 

send text with discretionary hyphens 

for translation. Discretionary hyphens 

are part of the source language, and 

are removed by default. (Hard 

hyphens are always translated as 

tags in TXML extraction.) If 

unchecked, these hyphens will be 

removed from the file when sent for 

translation. 

Translate Marker 

Types 

send text marked with a FrameMaker 

marker type for translation. 

4. Enter the Marker Type(s) that should be included in the translation. 

5. Enter the Table IDs of the tables in the IDML that should be excluded in the translation.  
Note: Use comma-separated values for Table IDs that are to be included. 

6. Click Apply and OK, to confirm the FrameMaker filter preferences. 

Selecting ICML filter preferences 

The InCopy (ICML) filter preferences must be set before using this filter option 

To set the ICML filter preferences: 

1. Open TransStudio and click Edit > Preferences > Translations > Filters >Formats. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 
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2. Select Format Type as Default ICML Filter. 

The ICML Filter options appear. 

 
 

  

3. Select the properties for the filter. 

Select to... 

Translate Hidden 

Text 

translate hidden text. 
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Select to... 

Translate Line 

Break as Tag 

add tags to line breaks, resulting in 

merged segments. 

Translate Locked 

Layers 

translate text in locked layers. 

Translate Hidden 

Layers 

translate hidden layers 

4. Enter the names of the Hidden Layers to be translated. 

5. Select the method for handling tabs: None, Tag or Break. 

6. Select the method for handling line separators: None, Tag or Break. 

7. Enter or browse to the Fontmapping file for the filter. 

8. Rename the filter if desired. 

9. Click OK. 

  

Adding an Excel file filter 

There are two default filters for Excel: Default Excel filter, and Default Excel 2007 filter. The steps for 

adding both filters are the same. In the example below, a Default Excel filter will be added. 

  

To add an Excel file filter: 

1. Follow steps 1 and 2 from Viewing default file filters. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 

2. Select Format Type as Default Excel Filter. 

The Excel Filter options appear. 
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3. Click Setup. 

The Choose Excel File... dialog box appears. 
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4. Select an Excel file and click Open. 

The Excel Column Selection Wizard  appears. 
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5. Read the instructions carefully and click Next. 

The Select Wizard type page appears. 
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6. Select the wizard type. You have two options: 

• Simple Wizard: selects all rows with content for translation 

• Advanced Wizard: allows you to choose the columns for translation. It also creates a 

Target column where the translated text will appear. 

Simple wizard 

To run the Simple wizard: 

1. Follow steps 1 to 6 from Adding an Excel file filter. 

2. Select Simple Wizard and click Next. 

The Preview page appears. 
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The content in the Preview page is selected for translation. 

The Preview page models an Excel file. 

  

Number Use   

 

Please choose 

number of preview 

rows drop down 

list: 

select the number of rows to show 

on the preview page. 

 

Use headers check 

box: 

use the column headers of the 

Excel sheet. If not selected, the 

column letter (A,B, C) appears in 

the next step. 

 

Table with the 

Excel sheet 

contents 

select the first row for translation. 

Rows above the selected row will 

not be translated. 
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3. Click Finish. 

The configuration and sample file path appears in the Formats options box as shown in the 

screenshot below. 

 

 
  

• Select the Translate Sheet Names checkbox to include sheet names as translatable text. 

Selected by default. 
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• Select Translate Comments to clear it, and not include comments as translatable text. Selected 

by default. 

• Select the Translate hidden rows and columns checkbox to include rows and columns hidden 

in the Excel file as translatable text. 

• Select Translate hidden sheets to include hidden Excel sheets. 

• Select the Translate cell with formulas checkbox to include cells with notes and formulas as 

translatable text. 

• Select Translate Data Validation comment to clear it, and not include columns in the Excel 

sheet used to record comments validating the data, for example, columns recording vaccination 

data by date applied and dosage. Selected by default. 

• Select the Treat numbers stored in text format as real numbers checkbox to include numbers 

as translatable text. Selected by default. 

• Select Translate Drop-down list contents to include the drop-down list contents in the 

translation. Selected by default. 

• Select Translate cell order by column to extract cells by columns, instead of by rows. 

5. Click Apply and OK. 

An Excel file filter is set up. 
Note: You can now directly open Excel files using this filter. While opening files you must choose the 

correct filter, when prompted. You can also rename the filter using the Rename button. 

Advanced wizard 

To run the Advanced wizard: 

1. Follow steps 1 to 6 from Adding an Excel file filter. 

2. The Preview page appears. 
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The content in the Preview page is selected for translation. 

The Preview page models an Excel file. 

  

Number Use   

 

Please choose 

number of preview 

rows drop down 

list: 

select the number of rows to show 

on the preview page. 

 

Use headers check 

box: 

use the column headers of the 

Excel sheet. If not selected, the 

column letter (A,B, C) appears in 

the next step. 

 

Table with the 

Excel sheet 

contents 

select the first row for translation. 

Rows above the selected row will 

not be translated. 
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3. Click Next 
The Selection page appears. If you have selected the Use header checkbox, the Excel sheet 

headers appear as column names, in the Column Name column. 

In the example below, the Excel sheet headers are Source Translation, Length Restriction, and 

Target. An example of the source Excel spreadsheet appears below. 
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4. In the Translate column on the Selection page, select the columns for translation. 

• Select the starting row number. The content extract begins with this row number, and ends at the 

selected end row number. 

• Select the end row number. The content extract ends with this row number, having begun at the 

selected end row number. 

 

The corresponding Column name appears in the Target column as shown in the example. 
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5. Click Next. 

The Regular expression page appears. 
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6. Enter a Regular Expression for the Excel analysis. 
Note: A regular expression provides a pattern to mark up any embedded HTML tags or variables in a 

column as tags. 

7. Click Finish. 

The configuration and sample file path appears in the Formats Options box as shown in the screenshot 

below. 
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• Select the Translate Sheet Names checkbox to include sheet names as translatable text. 

Selected by default. 

• Select Translate Comments to include comments as translatable text. Selected by default. 
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• Select the Translate hidden rows and columns checkbox to include rows and columns hidden 

in the Excel file as translatable text. 

• Select Translate hidden sheets to include hidden Excel sheets. 

• Select the Translate cell with formulas checkbox to include cells with notes and formulas as 

translatable text. 

• Select Translate Data Validation comment to clear it, and not include columns in the Excel 

sheet used to record comments validating the data, for example, columns recording vaccination 

data by date applied and dosage. Selected by default. 

• Select the Treat numbers stored in text format as real numbers checkbox to clear it, and not 

include numbers as translatable text. Selected by default. 

• Select Translate Drop-down list contents to include the drop-down list contents in the 

translation. Selected by default. 

• Select Translate cell order by column to extract cells by columns, instead of by rows. 

8. Click Apply and OK. 

An Excel file filter is set up. 
Note: You can now directly open Excel files using this filter. While opening files you must choose the 

correct filter, when prompted. You can also rename the filter using the Rename button. 

  

Adding a PowerPoint filter 

There are two default filters for PowerPoint: 

• Default PowerPoint Filter 

• Default PowerPoint 2007 Filter 

Adding a PPT file filter 

1. Follow steps 1-3 from  Adding_new_file_filters. 

2. Select Format Type as Default PowerPoint Filter. 

The PowerPoint Filter options appear. 
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3. Clear the Translate slide content checkbox to include slide content as translatable text. 

4. Clear the Translate slide notes checkbox to exclude slide notes as translatable text. 

5. Select Translate hidden slides to include hidden slides as translatable content. 

6. Clear the Translate master slide checkbox to exclude master slide content as translatable text 

7. Click Apply and OK, to confirm the PPT filter preferences. 

Adding a PPTX file filter 

1. Follow steps 1-3 from  Adding_new_file_filters. 
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2. Select Format Type as Default PowerPoint 2007 Filter. 

The PowerPoint Filter options appear. 

 
3. Clear the Translate slide content checkbox to include slide content as translatable text. 

4. Clear the Translate slide notes checkbox to exclude slide notes as translatable text. 

5. Select Translate hidden slides to include hidden slides as translatable content. 

6. Clear the Translate master slides checkbox to exclude master slide content as translatable text 

7. Select the Translate master slide notes checkbox to include master slide notes as translatable 

text. 

8. Click Apply and OK, to confirm the PPT filter preferences. 

  

Adding a Word filter 

There are two default filters for Word: 

• Default Word Filter 
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• Default Word 2007 Filter 

Adding a default Word filter 

To add a Word filter: 

1. Follow steps 1-3 from Adding_new_file_filters. 

2. Select Format Type as Default Word Filter. 

The Word Filter options appear. 

 

 
  

3. Enable the following options, if required: 
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Select to... 

Translate hidden text include hidden text as translatable text. 

Accept track changes include tracked changes as translatable text. 

Translate index include Index text as translatable text. 

Translate smart tags include smart tags as translatable text. 

Ignore Bilingual styles Ignore bilingual styles (Wordfast 

Classic/Trados  Workbench-style files) Selected by 

default. 

Translate comments translate comments in the document. Selected by 

default. 

4. Click Apply and OK, to confirm the Word filter preferences. 

Adding a Word 2007 filter 

To add a Word 2007 filter: 

1. Follow steps 1-3 from  Adding_new_file_filters. 
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2. Select Format Type as Default Word 2007 Filter. 

The Word Filter options appear. 

 
3. Enable the following options, if required: 

  

Select to... 

Translate 

hidden text 

include hidden text as 

translatable text. 

Accept track 

changes 

include tracked changes as 

translatable text. 

Translate include Index text as 
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Select to... 

index translatable text. 

Translate 

smart tags 

include smart tags as 

translatable text. 

Ignore 

Bilingual 

styles 

Ignore bilingual styles (Wordfast 

Classic/Trados Workbench-

style files).Selected by default. 

Translate 

comments 

translate comments in the 

document. Selected by default. 

Translate 

drop-down list 

translate content from drop-

down lists in the document. 

4. Click OK. 

  

Adding a SubRip Text filter 

1. Follow steps 1-3 from Adding_new_file_filters. 

2. Select Format Type as Default SRT Filter. 

The SRT Filter options appear. 
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3. Click New. The New Format Dialog box appears. 

 
  

4. Select the SRT filter. and click OK. 
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The new SRT filter appears in the Available Formats box. 

 
5. Rename the filter if desired. 

6. Select the following options if required: 

  

Select to... 

Set max length to () 

characters per 

set the maximum number (length) of characters per 

segment. 
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Select to... 

segment 

Use Paragraph 

Segmentation 

segment sentences by paragraph, overriding any 

other segmentation markers. 

  

Adding an IDML filter 

1. Follow steps 1-3 from Adding new file filters. 

2. Select the IDML filter from the list. There are two versions: 

• Default IDML filter (older version) 

• IDML Filter (newer version) 

Default IDML filter 

1. Select IDML filter (older version) from the list of formats. 
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2. Click OK. 

The new IDML filter appears in the list.  

 
3. Select the properties for the filter. 

  

Select to... 

    

Translate Line 

Break as Tag 

add tags to line breaks, resulting in 

merged segments 
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4. Enter or browse to the Fontmapping file for the filter. 

5. Rename the filter if desired. 

6. Click OK. 

  

IDML Filter (newer version) 

1. Click New. 
2. Select IDML Filter (newer version) from the list of formats. 
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3. Click OK. 

The new IDML filter appears in the list. 

 
4. Select the properties for the filter. 

  

Select to... 

Translate Hidden 

Text 

translate hidden text. 

Translate Line add tags to line breaks, resulting in 
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Select to... 

Break as Tag merged segments. 

Translate Locked 

Layers 

translate text in locked layers. 

Translate Hidden 

Layers 

translate hidden layers 

 

5. Enter the names of the Hidden Layers to be translated. 

6. Select the method for handling tabs: None, Tag or Break. 

7. Enter or browse to the Fontmapping file for the filter. 

8. Rename the filter if desired. 

9. Click OK. 

Adding a Quark Documents filter 

1. Follow steps 1-3 from Adding new file filters. 

2. Select Format Type as Default Quark Documents Filter 

The Quark Documents Filter options appear. 
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3. Click New. The New Format Dialog box appears. 

 
  

4. Select the Quark Documents Filter and click OK. 

 
 

The new Quark filter appears in the Available Formats box. 
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5. Rename the filter if desired. 

  

Adding a new text-based (XML) filter 

To add a new text-based filter: 
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1. Follow steps 1 and 2 from Viewing default file filters. 

The Formats dialog box appears. The default filters appear in the Available formats box. 

 
2. Click New. 

The New Format dialog box appears. 
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3. Select the Text based Filter type and click OK. 

 
The New Text Based Filter appears in the Available Formats box. 
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4. Select the filter and click Rename, to change the filter name. 

5. Select any other requirements. In this example, you will Select the Encoding as UTF-8. 

6. Browse and select the Conversion rules file. 
Note: The conversion rules file includes commands describing the content to be translated in the 

XML files. Find below an example rules file. 
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7. Click Apply and OK. 

A new XML filter is set up. 

Selecting INX filter preferences 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Filters >Formats. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 

2. Select filter type as Default INX Filter. 

The INX filter options appear. 
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3. Enter or browse to the Fontmapping file for the filter. 

Selecting SDLXLIFF filter preferences 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Filters >Formats. 

The Formats dialog box appears. The default filters appear in the Available Formats box. 

2. Select filter type as Default SDLXLIFF Filter. 

The SDLXLIFF filter options appear. 
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3. Select Change segment status to Translated to save the translation as Translated. 

Analyzing files 

In the Analyzing files process, files for translation are analyzed against a translation memory to leverage 

reusable content and pre-translate files. This process can greatly improve efficiency and reduce time and 

effort spent on translation. Find below the procedures for the following tasks: 
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• Analyzing files 

• Selecting Analysis output option 

Analyzing files 

To analyze files: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears 

2. Click Analyze. 

The Analyze window appears. 

 

 
 

Note: The TM counter shows the number of selected TMs and the available TMs. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 

   

 
4. If the added folders contain files of multiple formats, the Choose Format Dialog box appears. 

Choose the format for the files to be analyzed. Only one format can be selected at a time. 
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Note: You can analyze up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to 

analyze more files you will need to purchase the Wordfast Pro 3 license from www.wordfast.com. 

5. Select one or more translation memories for analyzing the files.  
Note: You will need to add at least one translation memory (TM) before analyzing files. To add a 

local or remote TM, click TM Preferences. Go to Creating or opening a TM for more information. 

You can click in the TM Options column header to sort the TMs in ascending or descending 

order. You can unselect all chosen TMs by clicking Unselect All. 

 
6. Select the following options if required: 

Select to... 

Pretranslate pretranslate the translatable segments and enter 

the percentage of TM matches. 

Note: This is an optional step. The percentage 

defines the minimum leverage required to pre-
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Select to... 

translate a specific segment. 

You can also specify the analysis output option. For 

more information, refer Selecting Analysis output 

option. 

Ignore translated 

segments from report 

exclude already-translated segments from the 

analysis report. 

Ignore translated exact 

segments from report 

exclude already-translated exact segments from the 

analysis report. 

Copy all tags from the source to the target segments for blank 

segments. 

Copy Source on no 

match 

copy source segments to target only for no match 

segments. 

Calculate Internal 

Fuzzy Matches 

calculate internal fuzzy matches in source files. For 

example, if there is a partial repetition of segments 

in a source file, it will be calculated as an internal 

fuzzy match. 

Select the percentage that should be calculated for 

such segments. 

Include Internal Fuzzy 

matches as TM 

Matches 

include internal repetitions as a TM match. 

7. Select format for the output report. You have two options: 

Output in CSV or XLS format: Select this option and click Browse to select a location and provide 

a file name as shown in the example below. 
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8. Click Save, to save the CSV file. The Analyze window appears with the location of the CSV file as 

shown in the example below. 

 
Output only report summary: Select this option to view the output report on-screen 

  

9. Click Analyze. 
Note: When Excel files with sheetnames exceeding 31 characters are analyzed a warning 

message will appear. The warning message will prompt you to shorten the sheetnames that 

exceed 31 characters. 

The analyzed TXML files are saved in the same folder as the source files. According to the output 

report format, either a CSV file is saved at the chosen location or the Analysis and Translation 

report appears as shown below. The report for files analyzed against separate TMs appears in 
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separate tabs. 

 
 

The TM analysis report will display either % Segments or % Words based on the option selected 

in step 9 of Selecting translation memory settings. 

Selecting Analysis output options 

When a file is analyzed, an analysis output is generated in the same folder as the source files. The 

analysis output is the pretranslated TXML file. The analysis output options allow you to choose whether 

the pretranslated TXML file should be renamed to add the language suffix or placed in a separate folder 

with a language suffix or both. 
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To select analysis output option: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Edit > Preferences > Translations > PM Plug-in. 

The Preferences (Filtered) PM Plug-in dialog box appears. 
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3. Select a condition to be followed when analyzing files. The options are as follows: 

Select to... 

Add language suffix add the language code (for example ES_MX) as a 

suffix to the analysis output file. An example 

screenshot of the source folder and the source and 
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Select to... 

analysis output file is given below. 

 

 
Subfolder creation place the analysis output file within a subfolder. An 

example screenshot of the source and analysis 

output folder and file is given below. 

 

 
Subfolder creation with 

language suffix 

place the analysis output file within a subfolder. The 

subfolder and analysis output file will also include the 

language code as suffix. An example screenshot of 

the analysis output folder and file is given below. 

 

 

 

Extracting frequents 

In the Extracting frequents process, repetitive source segments are extracted from the files for translation. 

Extracting frequents helps reduce the total number of segments to be translated. This is useful when 

translating in large jobs with many source files, containing repetitive content. 

  

To extract frequents: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Extract Freq. 

The Extract Freq window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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Note: Ensure all files selected or added are TXML files. 

  

4. Under Extract files Options, select one of two options: 

Select Make a new file after (#) segments. Enter the maximum number of segments per file. 

The default is 250 segments. To produce only one frequents file, set the maximum number of 

segments per file to 10000. 

OR 

Select Make one frequents file per TXML. 
Note: The number signifies the minimum number of times a segment must be repeated in the set 

of files to be extracted. For example, if this value is 1, Wordfast Pro 3 will extract one unique 

occurrence of all segments that appear once or more. 
 
Note: Frequents will be extracted in the order in which the files were added. 

  

5. Under Extract Location Options, select Extract Frequents to TXML folder to save the 

frequents file to the TXML folder. 

OR 
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Select the radio button for Location, and browse to another location for the frequents file. The file 

prefix will be repetitions. 

6. Under Extract Frequents Options, select Ignore exact matches from frequents analysis to 

ignore exact matches. 

Select Ignore numeric differences from frequents analysis to ignore numeric differences. 

7. Click Extract. 
The repetitive segments are extracted and saved at the location selected. 

 
Note: The TXML files with extracted frequent segments are sent to the translator for translation. 

After translated files are received from the translators, they are cleaned up and saved into the 

TM. The TM is then applied to the original TXML files, to complete the translation process. 

Populating frequents 

In the Populating frequents process, the original TXML file is populated by the frequents file containing all 

translated content 

  

To populate frequents: 

1. Extract frequents from the files as explained in Extracting frequents. 

2. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

3. Click Populate Freq. 

The Populate Freq window appears. 
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4. In the Select Frequents File panel, click  to browse to the frequents file created by extracting 

frequents. 

5. In the Select Original TXML File panel, add the source TXML file(s) for the frequents file. 

  

Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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6. To show the folder path in the report, select Show folder path in the report. 
7. To populate frequents in a new folder, select Populate TXML in new folder. 
8. Click Populate Frequents. 

When the process is complete, a confirmation message appears. The translated content from the 

frequents file populates the original source TXML file. A Frequents Population Log is generated 

saved in the same folder as the original source TXML file. 

 

 
  

Transcheck 

The Transcheck option allows you to check the translated content for missing tags, empty target, 

numbers, untranslated segments, and/or terminology. 

  

To transcheck TXML files: 
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1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Transcheck. 

The Transcheck window appears. 

 
 

 

  

3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 
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Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 

   

 
 
Note: You can check 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to check 

more than 20 files, you will need to purchase the Wordfast Pro 3 license from www.wordfast.com. 

4. Under Segment Changes/Transcheck Report options, select Add Notes column to report to 

add notes added to the segment in the TXML file. 

5. Select the following Transcheck options, if required. To configure individual Transcheck options, 

go to Configuring Transcheck. 

Select to check... 

Partial Check the character count between the source and target 

segments. Go to Edit > Preferences > 
Translations >Transcheck> Partial or click 

Configure to enter the minimum and maximum % 

of allowed character count for the target segment. 

Empty target Check for empty target segments. 
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Select to check... 

Numerical Check if the numerals in the source segment match the 

target segment. The numbers with hyphens will be 

read as two separate numbers. Click Configure to 

set the option in Preferences. 

Tag Check for missing tags in the target segments. 

Forbidden Characters 

check 

check if the target segment includes forbidden 

characters. Go to Edit > Preferences > 
Translations >Transcheck> Forbidden 
Characters or click Configure to add the forbidden 

characters that should not be included in the target 

segment. 

Punctuations Check for consistency in punctuation between source and 

target segments. Go to Edit > Preferences > 
Translations >Transcheck> Punctuations or click 

Configure to add the punctuation marks that 

should not be included in the target segment 

Untranslatable Check if the untranslatable content in source and target 

segments is consistent. Go to Edit > Preferences 
> Translations >Transcheck>Untranslatable or 

click Configure to add untranslatable text that must 

be retained in the target segment. 

Copied Source Check if the source segment has been copied to the target 

segment. 

Character Limit Check if the characters in the segment or paragraph 

exceeds the maximum number of allowable 

characters (length). 

First word 

capitalization Check 

if the first word of each segment is capitalized. 

Edited Exact match 

Check 

if any exact match segments from the TM have 

been edited. 

Unedited Fuzzy Match 

Check 

if any fuzzy match segments from the TM have 

been left unedited. 

Source Consistency 

Check 

consistency between source segments if the target 

is repeated. 

Target Consistency consistency between target segments if the source 
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Select to check... 

Check is repeated. 

Terminology Check if the terms in the source segment are translated 

correctly based on the glossary. 

Blacklist check if any terms in the translation are blacklisted. 

6. If Terminology Check is enabled, a glossary must be selected. To select a glossary: 

• Click the Glossary list tab. Select one or more glossaries from the list of glossaries. 

 

 

• To create or add another glossary, click Glossary list preference to go to Preferences. 
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8. If Blacklist check is enabled, a blacklist must be selected. To select a blacklist: 

Click the Blacklist tab and select a blacklist from the list. 

OR 
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Click Blacklist List Preferences to browse to a blacklist. 

 
9. If the TXML language and glossary language do not match, the following dialog box appears: 

 
Select the correct TXML language and glossary language match from the list. 

10. Click Transcheck. 

The TransCheck Error Report appears. A summary of the report is at the top, followed by a summary of 

the files in the report. An example is shown below. 

 
 
Note: The TransCheck Error Report is saved automatically as an html file in the same folder as the TXML 

file, with the following prefix: TranscheckError_date-time.html. 
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Note: The Unedited Fuzzy Check report includes the score for the segment. An example is shown below. 

 

Export notes 

The Export Notes function allows you to export notes in a separate Word file. 

To export notes as a Word file, click Export Notes. 

The notes are exported in a Word table. By default, the notes are saved in the same folder as the TXML 

file. 

An example of exported notes is given below. 

 
  

  

Segment Changes Report 

The Segment Changes report enables you to export segment changes in a separate TXML file. 

To generate a Segment Changes report, click Segment Changes on the Transcheck tab.. 

The following message appears: 
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If there are no segment changes, the following message appears: 

 
 

By default the report is saved in the same folder as the TXML files. 
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A sample report appears below. 

 
  

   

Cleaning up and updating TM 

After files are translated by the translator, they are sent back to the project manager. The PM then 

completes the final step of cleaning up the files and updating the TM. Cleaning up is an automated 

process, where the source segments are removed and the files are restored to their original format. 

  

To clean up and update TM: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Cleanup. 

The Cleanup window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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Note: You can clean up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to 

clean up more than files you will need to purchase the Wordfast Pro 3 license from 

www.wordfast.com. 

4. Select Update TM check box for updating files to a TM. (Optional). 

5. Select the translation memory. 
Note: You will need to add at least one TM before cleaning up files. To add a local or remote TM, 

click TM Preferences. Go to Creating or opening a TM for more information. 

6. Select an Update option. The options are as follows: 

Select to... 

Overwrite existing 

TU (default) 

overwrite the existing translation unit. 

Do not overwrite TU not overwrite existing translation unit. 

Overwrite if 

attributes are 

identical 

overwrite the existing translation unit only if custom 

attributes for new and existing translation units are 

identical. 

Do not add to TM not add to the translation memory. 

7. Select Add Attributes checkbox, to enter custom attributes for the translation unit. 

8. Select Add File Name as Attribute, to add file name as a custom attribute. 
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9. Select Overwrite private TUs (WFServer TM Only), to overwrite private TUs with public TUs. 

Note: All workgroup ID TUs will be overwritten with public TUs. 

10. Select format for the output report. You have two options: 

• Output in comma-separated format: Select this option and click Browse to select a 

location and provide a file name 

• Output only report summary: Select this option to view the output report on-screen 

  

11. Click Cleanup. 

A Cleanup report appears, showing the results of the cleanup and any errors. In the example 

below, the report shows that two segments in the cleaned-up Excel files have the same name, 

and identifies the segments. 

 

 

Selecting Cleanup options 

To select cleanup output options: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Edit > Preferences > Translations > PM Plug-in. 

The Preferences (Filtered) PM Plug-in dialog box appears. 
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3. Select a condition to be followed when cleaning up  files. The options are as follows: 

Select to... 

Add language suffix add the language code (for example ES_MX) as a 

suffix to the cleanup. An example screenshot of the 

source folder and the source and cleanup file is 
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Select to... 

given below. 

 

 
Subfolder creation place the cleanup  file within a subfolder. An 

example screenshot of the source and cleanup 

folder and file is given below. 

 

 
Subfolder creation with 

language suffix 

place the cleanup file within a subfolder. The 

subfolder and cleanup file will also include the 

language code as suffix. An example screenshot of 

the cleanup folder and file is given below. 

 

 

 

Bilingual Export 

The Bilingual export option allows you to export the bilingual document file into DOC format, edit using 

Microsoft Word, and import the DOC file back into the TXML file. 

  

To complete bilingual export of files: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Bilingual Export. 

The Bilingual Export window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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You can either export the selected file(s), export for review or import the reviewed file(s). 

Export Only... 

The Export Only... feature allows you export file(s) to Wordfast Classic (WFC). 

  

To use export only: 

1. Select the TXML file(s), as shown in the example below. 

 

 
  

2. Click Export Only.... 

The Select export type dialog box appears. 
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3. Select one of the following export types from the drop-down menu: 

 
4. Click Export.. 

If the export is successful, a confirmation message appears: 

 
 

If the export fails, a failure message appears: 

 
  

5. Click View Report. The log appears. This log and the exported file in the chosen format are 

saved in the same folder as the selected TXML file(s). 
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Export files for review 

To export files for review: 

1. Select the TXML file(s) from uploaded folder as shown in the example below. 

 

 
  

2. Select the following Export Review options, if required: 

Select to... 

Exclude the notes 
column 

exclude the notes content when the TXML file is 

exported to RTF. 

Track changes track changes in the RTF. 

Protect document 
(Word 2003 and 
above) 

protect the file if using MS Word 2003 and above. 
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3. Browse to the file containing any Custom Instructions for the exported review, and click Open 
File to attach the file to the exported document.  

Note: The exported review document contains default instructions, Custom instructions, or no 

instructions.  

4. Select the checkboxes for the following options, to clear them. All options are selected by default. 

If all options are cleared, the exported file contains only segment tables for review.  

Select to... 

App Name add the name of the review application to the 

exported review document. 

Instructions add default instructions to the exported review 

document in .rtf, .doc or .docx format to the file for 

review. 

• If selected, default instructions are added to 
the exported review document. 

• If selected, and Custom Instructions are 
added, custom instructions are added to 
the exported review document. 

• If Instructions is not selected, no 
instructions are added to the exported 
review document. Custom Instructions 
and the Browse button appear shaded, 
and cannot be activated.  

Legend show or hide the legend in the exported review 

document. 

This Document show details of the exported review document, such 

as source and target locale. 

 

5. Click Export Review.. 

If the export is successful, a confirmation message appears: 
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If the export fails, a failure message appears: 

 
  

6. Click View Report. The log appears. This log and the exported file in the chosen format are 

saved in the same folder as the selected TXML file(s). 

 

 
7. To view the exported DOC, access the same folder where the selected TXML file(s) was located. 

An example of the exported DOC, and the corresponding Export Review options, appears below. 

. 
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8. Complete the review of the file before importing the review back to Wordfast Pro 3. 

Import reviewed files 

To import the reviewed DOC: 

1. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 
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Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 

  

2. Select the DOC file(s) as shown in the example below. 

 

 

  

3. Select the following Import Review options, if required: 

  

Select to... 

Accept tracked 

changes 

automatically accept the tracked changes. 

Create merged TXML create a TXML document containing the merged 
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Select to... 

files. 

4. Click Import Review. 
If the import is successful, a confirmation message appears: 

 
If the import fails, a failure message appears: 

 

 

5. Click View Report. 

The log appears. The review changes are imported into a new TXML file with the suffix 

.merge.txml. This log and the exported file in the chosen format are saved in the same folder as 

the selected TXML file(s). 

Split/Merge TXML 

The Split/Merge option can be used to split or merge a TXML file. The split options available are: 

• Split after selected number of TUs 

• Split to selected number of parts 

• Split after selected number of word(s) 

To split/merge files: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 
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2. Click Split/Merge. 

The Split/Merge window appears. 

 

 
  

3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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You can either split a TXML file or merge multiple TXML files. 

Splitting TXML 

To split a TXML file: 

1. Select one of the files from uploaded folder as shown in the screenshot below. 

The Split TXML option will be active. 

 

 
  

2. Select one of the split options. TUs are rounded to the nearest block, to avoiding splitting into 

different files. 

• Split after selected number of TUs (approx.) 

• Split to selected number of parts (approx.) 
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• Split after selected number of word(s) (approx.) 

3. Click Split TXML. 

A confirmation message appears. 

 

 
 

The TXML file is split, based on the selected Split options. Split files are saved with suffix -001, -

002, et cetera, and placed in the same folder as the source file. 

Merge TXML 

To merge two or more TXML files: 

1. Select two or more files from uploaded folder as shown in the screenshot below. 

The Merge TXML option will be active. 
 

 
 
Note: You can merge up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to 

merge more than 20 files you will need to purchase the Wordfast Pro 3 license from 

www.wordfast.com. 

2. Click Merge TXML. 

The selected file(s) are merged. 
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The merged TXML files are placed in the same folder as the source files. 

Show/Hide 100% 

The Show/Hide 100% option allows you to hide or show 100% translation memory matches in the 

leveraged TXML file(s). 

  

To hide 100% matches from the TXML file: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Show/Hide. 

The Show/Hide window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 

   

 
 
Note: You can show/hide 100 % matches for 20 files at a time using Wordfast Pro 3 in Demo 

mode. If you want to do so for more than 20 files, you will need to purchase the Wordfast Pro 3 

license from www.wordfast.com. 

4. Click Hide 100% matches. 

A summary appears. New TXML file(s) with the suffix .hidden.txml is saved at the same location 

as the source TXML file(s). 
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5. To show hidden 100% matches, add and select the hidden file(s) and click Show Hidden. 

 
A warning appears: 

 
  

Select Yes  to overwrite the files. Select No to skip the files. 



111 

  

A summary appears. The hidden.txml files are overwritten. 

  

   

 

Swap Source/Target 

The Swap Source/Target option allows you to swap source with target or vice versa. 

  

To swap source/target: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Swap Src/Tgt. 
The Swap Src/Tgt window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 
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Note: You can swap up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to 

swap more than 20 files, you will need to purchase the Wordfast Pro 3 license from 

www.wordfast.com. 

4. Click Swap Source/Target. 

A summary appears. New TXML file(s) with the suffix .swapped.txml is saved at the same 

location as the source TXML file(s). 
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Pseudotranslation 

The Pseudotranslation option copies source content to target. Pseudotranslated target content will have 

accented characters and the text will be expanded by 20%. This will help you preview what content will be 

selected as translatable and how complex formatting will appear in the target. Either source files or TXML 

files can be pseudotranslated. 

  

To pseudotranslate files: 

1. Open Wordfast Pro 3 and click . 

The PM perspective appears. 

2. Click Pseudotrans. 

The Pseudotranslation window appears. 
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3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and 

select the files. 

OR  

Click  to add an entire folder. Once a folder is selected, the following message appears. 

 

 
  

Click Yes to add files recursively. This ensures that all files within a folder, including the files in 

the sub folders are added. 

The files appear. Files are selected by default when added. 

  

4. The Choose Format dialog box appears. Choose the format for the files to be analyzed. Only one 

format can be selected at a time. 
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5. Click OK. 

The files appear. 

 
Note: You can pseudotranslate up to 20 files at a time using Wordfast Pro 3 in Demo mode. If 

you want to pseudotranslate more than 20 files, you will need to purchase the Wordfast Pro 3 

license from www.wordfast.com. 

6. Select Source and Target Language. 

7. Select Create pseudotranslated target file to create a pseudo translated file in the chosen 

language and source format. For example, if you pseudotranslate a Word document from English 

(US) to German (Germany), then the PM plugin will create a pseudotranslated TXML file and 

word document. These files will be placed in the same folder as the source file. 

Note: The Create pseudotranslated target file retains the last used selection.. 
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8. Click Pseudotranslate. 

The selected file(s) are pseudotranslated and the summary appears. 

 

 
 

The pseudotranslated files are placed in the same folder as the source file. An example of a 

pseudotranslated TXML and a pseudotranslated source file are below. 
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TXML editor menu options 
The Wordfast Pro 3 basic menu options are as follows: 

• File 

• Edit 

• Translation Memory 

• Terminology 

• Window 

• Help 

File 

The options in the File menu are as follows: 

Use to... 

Create Project... create a new project. 

Open Project... 

(Ctrl+Shift+P) 

open an existing project. 

Open File (Ctrl+O) open a new file. 

Open in New 

Window 

open a new file in a new Wordfast Pro 3 window. 

Close (Ctrl+W) 

  

close the currently open file. If there are unsaved 

changes, a warning message appears asking if you 

want to save the changes before closing. 

Close All 

(Ctrl+Shift+W) 

close all open files. If there are any unsaved changes, 

a warning message appears asking if you want to save 

the changes before closing. 

Save (Ctrl+S) save the currently open file. 

Save Translated 

File (Ctrl+Alt+S) 

save PPT, XLS or DOC files. 

Note: This menu option is activated only when PPT, 

XLS or DOC files are saved. 

Save As... save and rename the currently open file. 

Save All 

(Ctrl+Shift+S) 

save all the currently open files. 
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Use to... 

Print (Ctrl+P) print the file that is currently open. 

Properties view information related to the currently open file, such 

as the original file format. 

Exit (Alt+Shift+X) exit Wordfast Pro 3. If there are any files open with 

unsaved changes, a warning message appears asking 

if you want to save the changes before exiting. 

  

Edit 

The options in the Edit menu are as follows: 

Use to... 

Undo (Ctrl+Z) undo most recently entered text or performed function. 

Redo (Ctrl+Y) redo most recently deleted text or re-perform undone 

function. 

Cut (Ctrl+X) cut the selected text. This action can be performed only 

in the target segment. 

Copy (Ctrl+C) copy the selected text. 

Paste (Ctrl+V) paste the copied text at the location of your cursor. This 

action can be performed only in the target segment. 

Select All (Ctrl+A) select all the text in the main Translation window. 

Find/Replace 

(Ctrl+F) 

search the current file for text and replace that text with 

another text. This action can be performed only in the 

target segment. 

Spell Check (F7) check spelling. 

Preferences... (F9) set translation, translation memory, penalties and 

terminology preferences. 

Show Whitespace 

Characters 

(Ctrl+Shift+8) 

show or hide whitespace characters. 

Insert LTR Mark insert Left To Right mark for languages that use left to 

right script. 

Insert RTL Mark insert Right To Left mark for languages that use right to 

left script. 

Clear Target clear the text in the target segment. 
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Use to... 

Segment 

(Ctrl+Alt+X) 

Clear All Target 

Segments 

(Alt+Shift+Delete) 

clear the text in all the target segments 

Edit Source edit the source segment. 

Revert to original 

source 

revert any edits made to the source segment. 

Copy Source 

(Alt+Insert) 

copy the source from the current segment into the 

target segment. 

Copy All Sources 

(Ctrl+Alt+Insert) 

copy all source content to the target for all segments. 

Expand Segment 

(Alt+PageDown) 

combine the currently selected source segment with 

the next segment. 

Note: This function can be accomplished only with 

segments in the same paragraph. Segments that have 

a paragraph break between them cannot be combined. 

Shrink Segment 

(Alt+PageUp) 

split the source segment into two segments, at the 

location of the cursor. 

Remove All Tags remove all tags in the document 

Copy All Tags copy all tags in the document 

Remove Tags in 

current segment 

(Ctrl+Shift+V) 

remove tags in the current segment 

Copy Tags in 

current segment 

(Ctrl+Shift+A) 

copy tags from the source to the target segment. 

Previous Tag 

(Alt+Shift+Left) 

select the previous tag in the source segment. The 

selected tag will be highlighted in red by default. 

Copy Tag 

(Alt+Shift+Down) 

copy the currently selected tag into the target 

Next Tag 

(Alt+Shift+Right) 

select the next tag in the source segment. The selected 

tag will be highlighted in red by default. 

Edit Note... 

(Alt+Shift+E) 

edit a note for a particular segment. 
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Use to... 

Delete Note 

(Alt+Shift+D) 

delete a note added for a particular segment. 

Add Note... 

(Alt+Shift+N) 

add a note for a particular segment. 

Last Modified 

Segment 

(Shift+F5) 

navigate to the last modified segment. 

Go To Segment 

(Ctrl+G) 

navigate to a specific segment. 

Translation Memory 

The options in the Translation Memory menu are as follows: 

Use to... 

New/Select TM 

(Ctrl+Shift+N) 

create or select a translation memory. 

Machine Translation translate a segment using machine translation 

software. 

Retrieve Selected Tu 

(Alt+F12) 

copy the TM lookup target segment into the file 

target segment. 

Leverage Previous Tu 

(Alt+Left) 

leverage the previous target segment. 

Leverage Next Tu 

(Alt+Right) 

leverage the next target segment. 

Next Segment 

(Alt+Down) 

navigate to the next segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

Previous Segment 

(Alt+Up) 

navigate to the previous segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

Current Segment 

Leverage (Alt+ -) 

leverage the TM for the current source segment. 

Translate Until Fuzzy 

(Ctrl+Alt+F) 

translate the source segments until there is a fuzzy 

match. 

Translate Until No translate the source segments until there is no 
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Use to... 

Match 

(Ctrl+Shift+PageDown) 

match. 

Translate All 

(Ctrl+Shift+End) 

translate all source segments. 

Confirm All confirm all unconfirmed segments. 

Unconfirm All unconfirm all confirmed segments. 

Confirm/Unconfirm 

(Alt+Enter) 

confirm or unconfirm a segment. 

Commit current 

segment to TM 

(Alt+End) 

save the current segment to the TM. 

Commit all segments 

to TM 

(Ctrl+Alt+End) 

save all the translated segments to the TM and 

close the file. This action is typically carried out 

when you have completed translation. 

TM Lookup 

(Crtl+Shift+T) 

  

look up the selected source text in the translation 

memory. This action leverages all segments that 

include that text. 

Analyze analyze the file for translation against a TM to 

leverage reusable content and pre-translate 

content. 

Transcheck 

(Ctrl+Shift+Q) 

verify target segments and view warning messages 

about missing or incorrect text or variables. 

Terminology 

The options in the Terminology menu are as follows: 

Use to... 

New/Select Glossary (Alt+N) create or select a glossary. 

Add Term (Ctrl+Alt+T) add a term to the glossary. 

Previous Term (Ctrl+Alt+8) navigate to the previous term in the source 

segments. 

Copy Term (Ctrl+Alt+0) copy the selected term. 

Next Term (Ctrl+Alt+9) navigate to the next term in the source 

segments. 

Run/Stop Term Highlighting toggle between highlighting terms in entire 
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Use to... 

(Ctrl+F5) TXML file or only segment in translation when 

Stopped (terms will still be highlighted for the 

currently selected segment)s). 

Edit modify the glossary. 

Import import a glossary to the open project. 

Export export a glossary to a location, either on your 

computer or a common server. 

Edit Blacklist modify the blacklist. 

Window 

The options in the Window menu are as follows: 

Use to... 

New Window open a new Wordfast Pro 3 window. 

Show View preview a file in Word, HTML in a web browser, 

view notes and the source context. This option also 

allows you to add or remove the TXML Attributes, 

Segment Changes, TXML Context, Outline and TM 

Lookup tabs. 

Toggle Toolbar hide or view the toolbar. 

Help 

The options in the Help menu are as follows: 

Use to... 

Online Help (F1) view the Wordfast Pro 3 help. 

Bug Report... view or send the error log. 

Check for a new 

version 

find and install new versions. 

Wordfast Pro 3 

Dictionary Updates 

update dictionaries that can be used during 

translation. 

Shortcut List... 

(Ctrl+Shift+L) 

view all Wordfast Pro 3 functions and keyboard 

shortcuts. 

License Management complete activation of Wordfast Pro 3 and manage 

license. 
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Use to... 

About Wordfast Pro 3 view plug-in and configuration details of Wordfast 

Pro 3. 
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Managing projects 
Translation projects can be managed both by project managers and translators. Managing a project 

includes the following tasks: 

• Creating or opening a project 

• Creating or opening a translation memory 

• Importing and exporting terminology lists 

• Defining penalties 

• Defining color codes 

• Enabling spell check 

• Translating in a project 

• Deleting a project 

Creating or opening a project 

In Wordfast Pro 3, it is necessary to create a project before translating a file. You can open a TXML file 

for translation only if a project is created or opened. The project is a working environment that defines 

settings for the source and target language, translation memory, glossary, and other user information. 

Find below the procedures for the following tasks: 

• Creating a project 

• Opening a project 

Creating a project 

To create a project: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click File > Create Project. 
The Create Project dialog box appears. 
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3. Enter a unique Project name. 
Note: A unique project name enables differentiation. Naming the project according to the client 

name is a good practice. If a unique name is not given, an error message appears at the bottom 

of the dialog box. 

4. Select Source and Target Language. 
Note: It is important to select the correct source and target languages. If either of them is 

incorrect, Wordfast Pro 3 will not allow you to open files for translation. The languages that you 

provide now will be the default language selection for all project files. 

5. Click OK. 

The Open Project dialog box appears. The project name appears in the Project List and the 

project properties appear at the bottom of the dialog box. 
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6. Select project name and click OK. 

The Preferences (Filtered) dialog box appears. 
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The Preferences (Filtered ) dialog box is used for the following tasks: 

• Selecting translation memory settings. Go to Selecting translation memory settings for more 

information. 

• Creating or opening translation memory. Go to Creating or opening translation memory for 

more information. 

• Importing, exporting, adding, editing, and deleting terms. Go to Importing and exporting 

glossaries and Working with glossaries for more information. 

• Defining penalties. Go to Defining penalties for more information. 

• Defining color codes. Go to Defining color codes for more information. 

• Enabling spell check. Go to Enabling spell check for more information. 

Opening a project 
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To open a project: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click File > Open Project. 

The Open Project dialog box appears. The project names appear in the Project list and the 

project properties appear at the bottom of the dialog box. 

3. Select a project name and click OK. 

The Wordfast Pro 3 screen appears with the project name on the title bar and the source and 

target languages at the bottom of the screen. 

 

 
  

Creating or opening a TM 

Translation memory (TM) is designed to provide maximum content re-use to and facilitate collaboration 

between globally distributed localization resources. Translators can leverage reusable content in two 

ways: 

• Local TM: The local TM is located in your system and can only be accessed and updated by you. 
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• Remote TM: The remote TM is located on a server that can be accessed by several translators at 

the same time. The translators can leverage the available content and also update the TM with 

new reusable content. 

Note: Generic users with only Read privilege cannot select the Read-Only checkbox in the TM List to 

write to a remote TM. Generic Users with Read and Write privileges can select the Read-Only checkbox 

in the TM List, and enable read/write privileges to the remote TM. 

Find below the procedures for the following tasks: 

• Selecting translation memory settings 

• Creating a local TM 

• Adding a local TM 

• Exporting a local TM 

• Adding a remote TM 

• Changing TM priority 

Selecting translation memory settings 

To select translation memory settings: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Follow steps 1 to 6 from Creating a project. 

OR 

Click Translation Memory > New/Select TM. 

The Preferences (Filtered) dialog box appears. 

3. In the left pane, click Translation Memory. 

The Translation Memory dialog box appears. 
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4. Select Write unedited fuzzy and exact matches to a TM,  to write unedited fuzzy and exact 

matches to a TM. 
Note: This option creates a local TM that can be used on your desktop for local concordance 

searching. In this local TM, Machine Translated and fuzzy matches appear as 100% matches. 

Therefore, it is suggested that a new local TM be created for this purpose. 

5. Select Copy source on no match in editor checkbox, to copy the source to the target segment, 

if there is no match when the TM is leveraged. 
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6. Select Perform TM Lookup automatically, when navigating from one segment to the other. 
Warning: Automatic TM lookup may affect system performance. 

7. Select the percentage that should be calculated for such segments. 

8. Enter the Fuzzy Match Threshold in (%). 
Note: This value signifies the TM leverage percentage limit for a fuzzy match. For example, if you 

enter a value of 75%, the tool will mark all the translations which are leveraged below 75% match 

as a 'No match' segment. 

9. Select the Analysis report settings: 

Select to... 

Calculate analysis 
report percentage by 
options: Segment or 
Words. 

show either % Segments or % Words based on this 

selection as shown in the example below. Refer to 

Analyzing files. 

Ignore translated 
segments from report 

ignore translated segments. 

Ignore translated 
exact segments from 
report 

ignore exact segments. 

Calculate Internal 
fuzzy matches in (%) 
checkbox 

calculate internal fuzzy matches in source files. For 

example, if there is a partial repetition of segments in 

a source file, it will be calculated as an internal fuzzy 

match. 

Include Internal Fuzzy 
matches as TM 
Matches 

include internal repetitions as a TM match. 

  

10. Select a condition to be followed when editing an existing Translation Unit. The options are as 

follows: 

Select to... 

Add to TM by 

overwriting the existing 

TU 

overwrite the existing translation unit. 

Add TM; overwrite 

existing TU if attributes 

overwrite the existing translation unit only if custom 

attributes for new and existing TU are identical. This 
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Select to... 

are identical (default) option is selected by default. 

Add to TM: do not 

overwrite existing TU 

add to translation memory and not overwrite existing 

TU 

Do not add to TM not update the TM. 

 

11. Select the number of TM Lookup Hits, to increase or decrease the number of TM Lookup results 

based on the selected value.. The default is set to 100.  

12. Select Use Replaceables for higher TM matches checkbox to replace the selected terms in the 

translation with terms from the selected TM. 
Note: Selecting this option selects all suboptions by default. Select the checkbox to clear it, for 

the terms you do not want to select for replacement from the TM. 

  

Select to... 

Number replacement consider all numbers appearing in the source as a 

100% match. All decimals and mathematical 

notifications are considered numbers. Alphanumeric 

values are not considered numbers, for example, 

562HH. 

URL replacement consider all URLs appearing in the source as a 

100% match. 

Punctuation 

replacement 

consider all punctuation appearing in the source as a 

100% match. 

Email address consider all email addresses appearing in the source 

as a 100% match. 

 

13. Click OK. 

The translation memory properties for the project are set up. 

Creating a local TM 

To create a local TM: 

1. Follow steps 1 to 2 from section Selecting translation memory settings. 

2. In the left pane, select Translation Memory > TM List. 

The Translation Memory - TM List dialog box appears. 
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3. Click Create TM. 

The Create Local TM dialog box appears. 

4. Enter or browse the location for the local TM. 

5. Enter a file name for the new local TM and click Save. 

6. Enter a Symbolic name for the Local TM. 
Note: Ensure that the name is unique and easily recognizable. If a unique name is not given, an 

error message appears at the bottom of the dialog box. 

7. Select Source and Target Language. 
Note: The default source and target languages are the same as the currently open project. 

Ensure that the selected TM and project have the same language pair assigned. If either of them 

is incorrect, the TM will not be leveraged in the project. 
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An example is shown below.  

 
8. Click OK. 

The newly created local TM name appears in the TM List and the properties appear at the bottom 

of the dialog box. 
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9. Select the Active check box to use the newly created local TM during translation. 

10. Select Read-Only check box if you do not want to update the local TM. (Optional) 

11. Click OK. 

A new local TM is created for the project. 

Adding a local TM 

To add a local TM: 

1. Follow steps 1 to 2 from section Creating a local TM. 

2. Click Add TM. 

The Add Local TM dialog box appears. 
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3. Enter or browse to the location of the local TM, and select the TM format from the drop-down list: 

• WF Classic TM format (.txt) 

• Translation Memory Exchange format (.tmx) 

 

In the example below, the selected format is TMX. 

 
6. Select a local TM file and click Open. 

Note: Ensure that the correct local TM is selected. The local TM file must have a correct header, 

which typically includes the creation date, user ID, source and target language, and so on. If an 

error occurs, please log in to the Wordfast Pro 3 support hotline at www.wordfast.com. 
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If the source and target languages of the selected TM do not match the locales for the project, the 

following message appears: 

 
 

Select the correct locales from the Add TM dialog box. 

  

7. Follow steps 6 to 10 from section Creating a Local TM. 

An existing local TM is selected for the project, and appears in the TM List. 

Exporting a local TM 

To export a local TM: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Translation Memory > New/Select TM. 

The Preferences (Filtered) dialog box appears. 

3. In the left pane, click Translation Memory > TM List. 
4. Select a local TM and click Export TM. 

The Export Local TM dialog box appears. 

 

 
  

5. If required, select another TM from the drop-down list. 
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6. Select the Export Type format of the TM. 
Note: You can either choose the default Wordfast Pro 3 TM format or TMX format. 

7. Browse to the location where you want to save the exported TM and provide a file name. 

8. Click OK. 

The TM is exported to the specified location in the chosen format. 

 

Adding a remote TM to WFServer 

To add a remote TM to WFServer: 

1. Follow steps 1 to 2 from section Selecting translation memory settings. 

2. In the left pane, select Translation Memory > TM List. 

The Translation Memory - TM List dialog box appears. 

3. Click Add TM. 

The Add TM dialog box appears. 

4. Click the WFServer tab. 

The WFServer options appear. 
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5. Enter the remote TM URL. 

The remote TM information is populated automatically when the username, password and Project 

Short Code are contained within the URL string. 

Alternatively, enter each of the remote TM properties. 

The remote TM URL is populated automatically. 
Note: The remote TM URL and login details are provided to you by the client, if they are using a 

Wordfast TM server. 

6. After entering all remote TM information, click Test. 
Connection to the remote TM is established and a message appears. 

7. Modify the Symbolic name for the remote TM, if required. 
Note: The default symbolic name is a combination of the user name, address and port details. 
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8. Enter Workgroup ID and Search Depth. (Optional) 
Note: The Workgroup ID is a 10 digit number and is provided to you by the Wordfast Pro 3 

administrator. If a Workgroup ID is not entered, you can only read from the remote TM. The 

Workgroup ID is required if you need to update the remote TM. 

Ensure that the user name is unique and easily recognizable. 

Search depth signifies the number of results that can be viewed for a particular search. For 

example, if you are looking for segments containing the word "hotel", only the first 200 segments 

in the remote TM containing that word will appear. 

9. Enter Timeout Properties. 

There are three types of timeouts: 

• Connection Timeout: controls the connection or disconnection timeout. 

• Short Timeout: controls commands that are expected to be completed immediately 

• Long Timeout: controls commands that get serialized in the server's TM queue and 

possibly take a long time to complete: searches, updates, concordance searches and so 

on. 

10. Select Use TM Admin Password to provide password to clean up target content and update the 

TM. 

The example below shows the reminder that appears when the mouse is pointed to the password 

properties.  
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Note: The password will be provided to you if you have Project Manager role access rights. 
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Find below a possible setup for a remote TM. 

 
11. Click OK. 

The newly created or added remote TM name appears in the TM List and the properties appear 

at the bottom of the dialog box. An example appears below. 

Click the TM List column name to view the list in ascending, descending or default order. If any of 

the TMs are selected, then the list will be sorted based on selected and unselected TMs. 
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12. Select the Active check box, to use the new remote TM during translation. 

13. Select the Read-Only check box, if you do not want to update the remote TM. (Optional) 

14. Click OK. 

A new or existing remote TM is created or opened for the project. 

Changing TM Priority 

1. Click TM Priority under Translation Memory. 

The Translation Memory - TM Priority dialog box appears. 
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2. Click   or  to prioritize newly created or available local and remote TMs. 
Note: Prioritizing TMs will ensure that the first TM in the list is leveraged first, followed by the 

remaining TMs. 

Importing and exporting glossaries 

A glossary is a list of source terms and their preferred translations. For example, a terminology list could 

include information as follows: 

Source Target 

translation memory mémoire de traduction 

translation unit unité de traduction 
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Source Target 

data transfer rate taux de transfert de données 

International Translators Federation Fédération Internationale des 

Traducteurs 

The glossary is stored as a tab-delimited list of source and target terms on your computer or a common 

server. To use a glossary, you need to import it into Wordfast Pro 3. After completing a translation project, 

you also have an option to add new terms and export the glossary to your computer or a common server. 

Find below the procedures for the following tasks: 

• Importing a glossary 

• Adding a remote glossary 

• Editing a remote glossary 

• Exporting a glossary 

• Changing Glossary Priority 

Importing a glossary 

To import a glossary: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Terminology > Import. 

The Import Glossary dialog box appears. 
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3. Choose File type. You have two options: 

• Tab delimited text file (.txt) 

• Term Base eXchange (.tbx) 

4. Enter or browse for the glossary. 

5. Select checkbox to ensure that the first row of the glossary is viewed as headings. 

6. Next, you have two options: 

• Select Create new Glossary if you are importing the first terminology file for the project. 

• Select Import into existing terminology, if you have already imported a glossary and want 

to combine both the files. 

Creating a new glossary 

To create a new glossary: 

1. Follow steps 1 to 4 from Importing a glossary. 

2. Click Create new glossary. 

3. Click OK. 

The Create Glossary dialog box appears. The Symbolic Name will be populated based on the 

imported glossary file name. The Source and Target Language Code will be populated based on 

the language of the currently open project. 
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4. If required, enter a different Symbolic name, Source Language Code, and Target Language 
Code. 

5. Click OK. 

The terms from the local terminology list are imported and a new terminology file is created. 

Import into existing glossary 

To import a new glossary into an existing glossary: 

1. Follow steps 1 to 4 from Importing a glossary. 

2. Select Import into existing Glossary. 

The Import into existing Glossary option is activated. 
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3. Select the Existing Glossary for the open project. 

4. In the If term already exists prompt, select an action to perform if there is an overlap between 

the existing and new terminology list. 

5. Click OK. 

The Glossary import report dialog box appears. This describes the number of terms that will be 

imported. 

6. Click OK. 

The new glossary is imported and the following message will appear: 

 

Adding a remote glossary 

A glossary can be added using the following: 

• Term Manager 

• WF Server 

• Wordfast Anywhere 

Term Manager 

To add a glossary from Term Manager: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 
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2. Open the Terminology menu and click New/Select Glossary. 

The Preferences - Glossary List appears. 

 
3. Click Add. 

The Add Glossary dialog box appears. 
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4. Give the glossary a Symbolic Name and assign a Source and Target Language Code. 

5. Enter the URL of the Term Manager instance. 

The remote TMGR information is populated automatically, when the username, password and 

Project Short Code are contained within the URL string. 

Alternatively, enter each of the remote TM properties. 

  

Option Description 

URL Enter the Term Manager URL. 

Username Enter the username to access 

Term Manager. 

Password Enter the corresponding 

password for the username. 
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Option Description 

Project Short 

Codes 

Enter the Term Manager project 

shortcodes. If multiple Project 

Short Codes are needed, 

separate them with a comma. 

6. Select the Synchronization Properties. 

  

Option Description 

Synchronize 

blacklist terms: 

synchronize blacklisted terms in Term Manager with TransStudio 

blacklist. Selected by default. 

Automatic 

Synchronization 

enable automatic synchronization with GlobalLink® Term Manager 

(TMGR) whenever a term is added or deleted. Selected by default. 

Synchronize on 

Glossary Startup: 

enable Term Manager synchronization when the Glossary dialog box 

is opened. 

Note: TransStudio can connect to Term Manager versions running 

4.3.1 or above. Version 4.3.1 supports read access only, and 

read/write access is supported as of Version 4.5. Selected by default. 

Synchronize 

interval (seconds): 

enter the interval for Term Manager synchronization. 

 
Note: If the remote glossary was not set up to be synchronized, it can be synchronized from the glossary.  

7. Click Synchronize.

 

 

When the glossary synchronization is complete, a confirmation message appears. A report 

appears showing the number of terms added, updated or removed. 
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8. Click Test... to test the Term Manager connection status. 

The following message appears when Wordfast successfully connects to the Term Manager 

instance. 

 

 
  

9. Click OK. 

10. Click OK on the Add Glossary dialog box. 

The new glossary is added to the glossary list. 
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Note: Wordfast can connect to Term Manager versions running 4.3.1 or above. Version 4.3.1 

supports read access only, and read/write access is supported as of Version 4.5. 

WF Server 

To add a glossary from WF Server: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Open the Terminology menu and click New/Select Glossary. 

The Preferences - Glossary List appears. 

3. Click Add. 

The Add Glossary dialog box appears. 

4. Click the WFServer tab. 

The WFServer details appear. 
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5. Give the glossary a Symbolic Name. 

6. Enter the URL of the WFServer to autopopulate the WF Server properties 

OR 

Enter the Address, Port, Username, and Password for the WFServer to autopopulate the URL. 

7. Enter the Workgroup ID. 

8. Click Test... to test the WFServer connection status. 

The following message appears when Wordfast successfully connects to the WFServer. 
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9. Click OK on the Add Glossary dialog box. 

The new glossary is added to the glossary list. 

Wordfast Anywhere 

To add a glossary from Wordfast Anywhere (WFA): 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Open the Terminology menu and click New/Select Glossary. 

The Preferences - Glossary List appears. 

3. Click Add. 

The Add Glossary dialog box appears. 

4. Click the Wordfast Anywhere tab. 

The Wordfast Anywhere details appear. 
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5. Give the glossary a Symbolic Name. 

6. Enter the URL of Wordfast Anywhere. 

7. Enter Workgroup ID. 
Note: The Workgroup ID is mandatory to connect to Wordfast Anywhere glossary. The 

Workgroup ID can be found in the WFA TM details. 

8. Click Test... to test the Wordfast Anywhere connection status. 

The following message appears when Wordfast successfully connects to Wordfast Anywhere. 
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9. Click OK. 

10. Click OK on the Add Glossary dialog box. 

The new glossary is added to the glossary list. 

Editing a remote glossary 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Open the Terminology menu and click Edit, then select the appropriate glossary. 

The glossary appears. 

3. Click Search to search through the glossary. Both Source and Target search options are 

available. 

4. Click Add to add a term to the glossary. 

5. Click Synchronization to synchronize any added terms to the glossary. 

Note: Wordfast can connect to Term Manager versions running 4.3.1 or above. Version 4.3.1 supports 

read access only, and read/write access is supported as of Version 4.5. 

Exporting a glossary 

Local and remote glossaries can be exported, with the exception of Term Manager glossaries. To export 

a glossary: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 
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2. Click Terminology > Export. 

 
OR 

Select the glossary from the drop-down menu. 

 
The glossary appears. 

 
3. Click Export. 

The Export Glossary dialog box appears. 

 



Managing projects 

162 

 
  

4. Select Glossary name. 

5. Select Export type. You have two options: 

• Tab delimited: a TXT file 

• TBX: an XML file 

6. Enter or browse the location for the glossary. 

7. Click OK. 

The glossary is exported and saved at the specified location. 

 
  

Changing Glossary Priority 

1. Click on Glossary Priority under Terminology. 

The Terminology - Glossary Priority dialog box appears. 

 



163 

 
  

2. Click  or  to prioritize newly created or available local and remote glossaries. 
Note: Prioritizing glossaries will ensure that the first glossary in the list is leveraged first, followed 

by the remaining glossaries. 

Defining penalties 

Penalties are defined to maintain high quality of the content leveraged from translation memory. A value 

is assigned to each of the penalties, which are taken into account to calculate the translation score. This 

score is used to differentiate between golden or 100 %, fuzzy and no match. 

  

To define penalties: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 
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2. Click Edit > Preferences > Translations > Translation Memory > Penalties. 

The Preferences (Filtered) Penalties dialog box appears. 

 

 
  

3. Enter values for penalties. Find below the list of penalties and description: 

Penalty Description 

Case penalizes different case in letters. 
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Penalty Description 

Non literal penalization is for punctuations, space, special characters 

like apostrophes, dashes, quotes and so on. 

Tag penalizes different tags. 

Align penalizes TUs coming from an alignment. 

Machine 

translation 

penalizes TUs coming from MT. 

  

Multiple 

translations 

penalizes TUs if there are duplicates within the TM with 

different translations. 

Local TM penalizes TU from local desktop copy. 

Remote TM penalizes TU from remote TM. 

Private TU 

(Remote) 

penalizes workgroup Translation Unit (TU) from remote TM. 

Public TU 

(Remote) 

penalizes non-workgroup TU from remote TM. 

Attribute penalizes if attributes differ. 

If attribute is not: consider this attribute name for penalization when the 

custom attribute in the TU does not match the text box 

attribute. 

If filename 

attribute does 

not match 

consider filename as an attribute for penalization when the 

filename attribute in the TU does not match the TXLF 

filename. 

  

Defining color codes 

The color codes are used to differentiate between different types of content in the TXML editor 

workspace. 

  

To define color codes: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Colors. 

The Preferences (Filtered) Colors dialog box appears. This displays the default colors assigned to 

different content types. 
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3. If you want to change the default color for any of the content types, click the colored box. 

For example, click the colored box next to Tag color. 



167 

 
A color palette appears. 
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4. Select a color, for example, purple and click OK. 

The color code for the selected content changes from blue to purple. 
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Enabling spell check 

Enabling the spell check option is a good practice to ensure high quality. Spell check is supported in 

Windows and if you have MS Office installed. Spell check is enabled by default. 

  

To disable spell check: 
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1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Spelling. 

The Preferences (Filtered) Spelling dialog appears. 

 

 
  

3. Select Enable spell checking checkbox. 

All spelling preferences are cleared. To select spelling preferences, select the Enable spell 
checking checkbox. The Hunspell spellcheck engine is automatically selected. To view all 

dictionaries available in the Hunspell spell check engine, click Spelling > Hunspell in the left 

pane. 

4. Select the Check Spelling as you type checkbox. (Optional) 

5. If enabling spell checking for Portuguese, select Portuguese Modes from the drop down list. The 

options are: 

• Pre-Reform: traditional spellings 

• Post-Reform: new spellings 

• Both: traditional and new spellings 

6. Select Microsoft Office Spellcheck to select Microsoft Office Spellcheck. 
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7. Click OK. 

The Spell check option is enabled. 
Note: The option for choosing spell check languages is available during installation. 

8. To use spell check, click Edit > Spell Check or press F7. 

The Spelling options appear. An example is shown below. 

 

 
  

9. The options available are: 

Use to... 

Ignore once ignore the suggestions for the highlighted word or 

phrase. 

Ignore All ignore the suggestions for highlighted word or phrase in 

the entire file. 

Add to Dictionary add the word or phrase to the dictionary. 

Change change the existing word or phrase to the selected 

suggestion. 

Change All change all instances of the existing word or phrase to 

the selected suggestion. 

Cancel cancel spell checking. 

Using Spell Check 

Click the Spell Check icon, or Press F7. 

The Spelling dialog box appears if a spelling error is found. An example is shown below.   



Translating in a project 

172 

 
  

• To ignore this instance of the spelling, click Ignore once. 

• To ignore all instances of the spelling, click Ignore all. 

• To add the spelling, click Add to Dictionary. 

• To accept the highlighted suggestion, click Change. 

• To accept the highlighted suggestion for all instances of the spelling, click Change All. 

Note: Navigate the dialog box using the Tab and Enter keys in addition to the mouse. 

Translating in a project 
After you have completed the initial steps of creating project, opening translation memory, importing 

glossary and defining penalties and colors, the Wordfast Pro 3 workspace is ready to be used for 

translation. The translation process broadly includes the following tasks: 

• Opening a file 

• Translating a file 
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• Finding and replacing content 

• Enabling translation options 

• Enabling Machine Translation 

• Enabling Auto Propagation 

• Leveraging repetitive content 

• Working with translation memory 

• Working with glossaries 

• Working with tags 

• Editing source segment 

• Using Transcheck 

• Confirming or Unconfirming segments 

• Using Outline window 

• Viewing TXML Context 

• Using notes 

• Viewing segment changes 

• Saving and closing a file 

• Using shortcut icons 

• Modifying colors and fonts 

Opening a file 

To open a file for translation: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click File > Open File, select file for translation and click Open. 

OR 

Left-click on the file, and drag it to the Translation window (drag_and_drop). 

The file appears in the Translation window. 
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Note: the file name appears in the tab. To view the file location (file path), point to the tab with the 

mouse. The file location appears in a popup.  
 
Note: Wordfast Pro 3 supports only those TTX files that are translated and segmented using tag 

editor. The TTX files must be renamed to match the source format if they need to be viewed in 

tag editor. 

 

Find below the description for the various components of the Wordfast Pro 3 workspace: 

Number Component Description 

 

File name The TXML file name appears here. You can open multiple files, which appear 

as tabs. 
Note: the file name appears in the tab. To view the file location (file path), 

point to the tab with the mouse. The file location appears in a popup.
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Number Component Description 

 

Source 

segment 

The segment that requires translation appears here. 

 

Translation 

score 

The translation score, which is the percentage of match found in the TM 

appears here. 

 

Target 

segment 

The translated content is entered here by the translator. 

 

Views The TXML file can be viewed in two ways, as plain text and in a table format. 

 

TM Lookup 

window 

The TM leverage results appear here. You can also search the TM for a term 

or a phrase. Refer to Using TM Lookup window. 

 

Txml 

Context 

The TXML context of the currently open file appears here. Refer to Viewing 

TXML Context. 

  
Notes The notes specific to each segment. Refer to Using notes. 

  
Segment 

Changes 

The segment changes in the currently open file appear here. Refer to Viewing 

segment changes. 

 

TXML 

Attributes 

The attributes of the TXML per segment appear here. 

 

Outline 

window 

The color coded list of all source segments appears here. The colors signify 

the translation score. Refer to Using Outline window. 

  

  

Translating a file 

This section describes the steps for translating a TXML file when there are no TMs available for leverage. 

After entering the new translation for a file, you can save the translation to a new TM, which can be 

leveraged at a later stage. 

  

To translate a file: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a blue 

background, and your cursor will be in the target segment by default. Go to Enabling translation 

options for information on enabling and disabling different translation options. 
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Note: The tags in the source segment are marked in grey. For example, {ut1}. These tags should 

be either copied and pasted or typed into the target segment. They should not be edited or 

deleted.  

Segment IDs from the same paragraph appear in gray, but are segmented according to the 

Segmentation preferences.  

  

2. Type the target segment. 

The typed target segment will appear in a pink background as shown in the screenshot below. 
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Note: the source characters and the target are counted in the Status bar, under the TM Lookup 

window: If a maximum character length has been set, segments or block/paragraph exceeding 

the maximum show the count in red. 

In the example below, the character count of the source segment is 74-74, where the first 74 is 

the segment character count, and the second 74 is the block/paragraph, character count. 

The character count of the target segment and block or paragraph is 84-84. 

The maximum length for the target segment is N/A. No maximum length was set. 

The block or paragraph count is set to 50 characters, exceeding the maximum length by 34 

characters. The block/paragraph count appears in red. 

For more information, go to Adding an Excel Filter. 

 

 

3. Select Translation Memory > Next Segment or click  or press Alt+Down. 

The typed target segment is saved to the TM and the cursor moves to the next segment. 
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Note: If you need help creating or opening a TM, go to Creating or opening a TM. To update 

translation memory with new content, ensure the TM has Read only check box is not selected, 

and update options are selected. Go to Selecting translation memory settings for more 

information. 

Also note that, the TM will not be leveraged or updated if you press the Enter or Tab keys or if 

you click into another segment in the Translation window or the Outline window. 

4. After translating all the source segments, select Translation Memory > Commit all segments 

to TM, or click   or press Ctrl+Alt+End, to update the TM before closing the file. 

Clearing a target segment 

To clear a target segment, place the cursor over the target segment, right-click and select Clear Target, 
or select Edit > Clear Target Segment, or press Ctrl+Alt+X. 

Viewing last edited segment 

You can view the last segment that was worked on by reopening the file and pressing Shift+F5. The 

cursor will be placed in the target segment that was last worked on. 

Finding and replacing content 

You can find and replace the translated content using the find and replace option. 

  

To find and replace content: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. 

2. Click Edit > Find/Replace or press Ctrl+F. 

The Find/Replace dialog box appears. 
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3. Type the content in the Find and Replace with fields. 

4. Enable the following options, if required: 

Select to find and replace... 

Direction 

Forward content after of the cursor location. 

Backward content before of the cursor location. 

Segment 

Source source segments only. 

Target target segments only. 

Source and Target both source and target segments. 

Options 

Case sensitive content with matching case. 

Whole word whole words only. 

Wrap search starting from and returning to the start location. 

Ignore non-breaking 

space 

content containing non-breaking spaces, and ignore the 

non-breaking space. 
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Select to find and replace... 

Scope 

From cursor from the cursor location to end of the file. 

Current file from the beginning to the end of the current file only. 

Open files in all open files. 

5. Click Find to find the first instance of the content or click Replace All to replace all instances. 

6. Click Replace/Find to replace the searched content and find the next instance, or click Replace 

to replace the searched content only. 

OR 

Drag content from source to target (drag-and-drop) . 

Enabling translation options 

Before or during translation, you can enable or disable some generic translation options. 

To enable translations specific preferences: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations. 

The Translations dialog box appears. 
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3. Enable the following translations options, if required: 

Select to... 

Use ,,smart quotes” enable smart quotes. Depending on the target 

language Wordfast Pro 3 will automatically change 

the quote (straight or curly)  that is used when the 

user presses the quote button on the keyboard. 

 

A non-breaking space (&nbsp) will be added before 

the following punctuation when the target language 

is French-France (fr-FR): 

:, ;, <<, >>, !, ?, %, $, #, € 

Disable segment not 

committed to TM 

warning 

disable the warning that appears when a translated 

segment is not committed to the TM before moving 

to the next segment. 



Translating in a project 

182 

Select to... 

Disable commit fuzzy 

segments to TM 

warning 

disable the warning that appears when a fuzzy or 

partial match segment is committed to the TM. 

Disable target 

overwrite warning 

disable the warning that appears when a target 

segment is overwritten. 

Merge across 

paragraphs 

enable segments from adjacent paragraphs to 

merge. A paragraph tag appears between 

segments merged from different paragraphs, in 

source and target. 

Track segment change 

revisions 

track revisions to segments. Selected by default. 

Next segment (TM 

Commit) shortcut 

leverages next 

segment 

use the Next Segment shortcut to leverage the next 

segment. Selected by default. 

 

Enabling Machine Translation 

Wordfast Pro 3 includes an automated machine translation feature which populates translations 

whenever a file is open or when there are no translation memory segment matches. 

  

To enable Machine Translation: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Machine Translation. 

The Machine Translation Preferences dialog box appears. 
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2. Select one of the following: 

• Always perform Machine Translation, if you want machine translated content to appear 

when you leverage a segment. TM matches will appear in TM Lookup, along with the MT 

matches. 

• Perform when there is no TM Match, if you want machine translated content to appear 

when there are no match segments. 

• Perform MT manually, if you want machine translated content to appear only when the 

MT is performed manually, using the MT icon in TXML editor. 

3. Select check boxes if you wish to allow all unedited segments in active document to be leveraged 

with MT and to remove MT score from score column when segment is edited. 

4. Please read the disclaimer carefully. 

5. Click Apply. 

6. You can enable either Google Translate, Microsoft Translate, and/or WorldLingo. 

Google Translate 

To enable Google Translate: 
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1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Machine Translation > 
Google Translate. 

The Google Translate Preferences dialog box appears. 

 

 
  

2. Select Enable Google Translator checkbox to populate preset translations. 

3. Enter the API key, which is mandatory to use Google Translate. Click the You can also look at 
the video How to obtain a Google Translate API key for more information. 

4. Select Use Google Translator as primary checkbox to give Google MT preference over other 

Machine Translation service. 

5. Click Test to test the service. 

6. Click Apply to save the selection and OK if you wish to close the Preferences dialog box. 

Microsoft Translate 

To enable Microsoft Translate: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Machine Translation > 
Microsoft Translate. 

The Microsoft Translate Preferences dialog box appears. 
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2. Select Enable Microsoft Translator checkbox to populate preset translations. 

3. Enter the Client Id and Client Secret, which are mandatory to use Microsoft Translate. Click the 

Click here to obtain Microsoft Translator Client Secret link for more information. 

4. Optional: Select Category Search and enter a category name, to conduct a more context-

sensitive search for a preset translation. For more information on using Category Search, see the 

Microsoft Translator Hub User Guide. 

5. Select Use Microsoft Translator as primary checkbox to give Microsoft MT preference over 

other Machine Translation service. 

6. Click Test, to test the service. 

https://hub.microsofttranslator.com/Help/Download/Microsoft%20Translator%20Hub%20User%20Guide.pdf


Translating in a project 

186 

7. Click Apply to save the selection and OK if you wish to close the Preferences dialog box. 

An example is shown below. 

 
  

WorldLingo 

To enable WorldLingo: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Machine Translation > 
WorldLingo. 

The WorldLingo Preferences dialog box appears. 
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2. Select Enable WorldLingo checkbox, to populate preset translations. 

3. Select Use WorldLingo as primary checkbox to give WorldLingo preference over other Machine 

Translation service. 
Note: WorldLingo MT is limited to the following languages: 

• English ↔ Spanish 

• English ↔ German 

• English ↔ Italian 

• English ↔ Portuguese 

• English ↔ Dutch 

• English ↔ Greek 

• English ↔ French 

• English ↔ Swedish 

• English ↔ Japanese 
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• English ↔ Korean 

• French ↔ Spanish 

• French ↔ German 

• French ↔ Italian 

• French ↔ Portuguese 

• French ↔ Dutch 

• French ↔ Greek 

• English ↔ Russian 

• English ↔ Arabic 

• English ↔ Simplified Chinese 

• English ↔ Traditional Chinese 

4. Click Test, to test the service. 

5. Click Apply to save the selection and OK if you wish to close the Preferences dialog box. 

Using machine translation 

To use machine translation: 

1. In the TXML Editor, open a file for translation. 

2. Click  or press Alt+-, click  or press Alt+Down or click  or press Alt+Up. 

The machine translation will appear in the TM Lookup window. 

3. To populate the machine translation in the target segment, click  or right-click in the target 

segment and click Machine Translation. Find below and example screenshot of a machine 

translated file. 
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Note: Machine translated content is highlighted in orange by default and marked as MT in the 

Score column. If required, the default color code can be modified. Refer to Defining color codes. 

Enabling Auto-Propagation 

You can choose to propagate translations for segments in the document automatically when you commit 

a segment to translation memory. The Auto-Propagation option allows you to enable or disable this 

feature. Enabling the Auto Propagation option will also allow you to leverage previous translation of 

repetitive content. For more information, refer to Leveraging repetitive content. 

  

To enable Auto-Propagation: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Auto-Propagation. 

The Auto-Propagation dialog box appears. 
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3. Select Enable autopropagation checkbox to automatically propagate translation based on 

previous translation completed in the file. 

4. Select Enable autopropagation across all open files to automatically propagate all open files 

in TXML editor. 

5. Enable the following autopropagation options, if required: 

Select to overwrite... 

100% matches 100% translation memory (TM) matches. 

Fuzzy matches partial translation memory matched. 

Autopropagated 

matches 

all autopropagated matches. This means that if 

there are multiple segments that have the same 

content then editing one segment will auto 

propagate the change in all matching segments. 

Modified segments edited autopropagated matches. This means that if 

there are multiple segments that have the same 

content and the first and second repetitions are 

edited, then the following matching segments will 

be updated based on the second segment that was 

changed. 

Machine Translated 

segments 

machine translated content. 
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Select to overwrite... 

Committed segments translated content that is committed to the TM. 

6. Click Apply and OK. 

The Auto-Propagation option is enabled. 

Enabling Auto-Suggest 

The Auto-Suggest option populates suggestions based on content or numeric values from source and 

terminology matches. 

  

To enable Auto-Suggest: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Auto-Suggest. 

The Auto-Suggest dialog box appears. 
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3. Select the Enable Auto-Suggest checkbox. 

4. Enable the following auto-suggest options, if required: 

Select to view suggestions in target segment for... 

Numbers from source numbers that appear in the source segment. 

Number conversions number conversions based on different rules. For 

example: If the file is being translated from English 

(United States) to German (Germany), $1,000 

appearing in source segment will be suggested as 

$1.000 in the target segment. 

Uppercase words from 

source 

upper case words that appear in the source 

segment. 

URLs from source URLs that appear in the source segment. 

Email addresses from email addresses that appear in the source 
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Select to view suggestions in target segment for... 

source segment. 

Glossary matches term matches from synchronized glossary found in 

the source segment. 

5. Click Apply and OK. 

The Auto-Suggest option is enabled. 

6. To view suggested terms, begin typing in the target segment. An example is given in the 

screenshot below. 

 

Leveraging repetitive content 

The leveraging repetitive content option can be used when there are repetitive segments in a file. For 

example, if there are multiple instances of the phrase "Our Process" then the translator needs to type the 

translation only once. The remaining segments are leveraged automatically. To use this feature you must 

enable the Auto Propagation option. For more information, refer to Enabling Auto Propagation. 

  

To leverage repetitive content: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a blue 

background, and your cursor will be in the target segment by default. 
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Note: There are three instances of the source segment "Auto Prop". 

  

2. Type the target segment for the first instance. 

The typed target segment will appear in a pink background as shown in the screenshot below. 
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3. Select Translation Memory > Next Segment or click  or press Alt+Down. 

The typed target segment is saved to the TM and the subsequent repetitive segments are 

leveraged. The segments appear in an orange background as shown in the screenshot below.  
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Note: The remaining two instances of "Auto Prop" are translated automatically. 

Working with TM 

Translation memory (TM) is designed to provide maximum content re-use and facilitate collaboration 

between globally distributed localization resources. Find below the procedures for the following tasks: 

• Leveraging translation memory 

• Using TM Lookup window 

• Updating translation memory 

Leveraging translation memory 

To leverage translation memory: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will be open, and your 

cursor will be in the target segment by default. 
 



197 

 
  

2. Select Translation Memory > Current Segment Leverage or click  or press Alt+-. 

The TM will be leveraged and the target segment appears. 
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Using Replaceables 

You can leverage the TM to replace numbers, URLs, punctuation and email addresses in the translation. 

If Use Replaceables for higher TM matches was selected in Preferences, the leveraged segment will 

overwrite the translation. For more information, go to Selecting Translation Memory Settings. 

 

In the example below, the numbers differ in the source and target segments. 
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1. Select Translation Memory > Current Segment Leverage or click  or press Alt+-. 
The TM overwrites the number in the target segment. 

 

Translation memory default color representation 

Find below the list of default color representations for source and target segments in the Translation 

window: 

Color Representation 

Blue Source segment 

Yellow Fuzzy match 

Grey No match or NA 

Green 100% match 

Pink Segment modified since 

the original file was 

created 

Purple Segment modified and 

updated to translation 

memory 

Go to Defining color codes for more information. 

Using TM Lookup window 

The TM Lookup window is used to view TM leverage results and context searching. Find below the 

procedure for the following tasks: 

• Viewing TM leverage results 

• Using TM lookup 

Viewing TM leverage results 
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The TM Lookup window displays the leverage results for the current source segment, if Perform TM 

Lookup Automatically is selected in Preferences. The results display the segment ID, Source and Target 

segments, leverage score, TM Name, User Name, and Date/Time of update to TM. 

  

 

TM Lookup default color representation 

Find below the list of default color representations for source and target segments and translation score in 

the TM Lookup window: 

Color Representation 

Blue Source segment 

Yellow Fuzzy match 

Green 100% match on word or 

phrase in target 

segment 

Highlighted 

text 

Words or phrases that 

do not match the source 

segment. This appears 

if Diff highlight is not 

selected. 

Diff Highlight 

Add 

Word or phrases that 

appear in the source but 

not in the TM. This 

appears if Diff Highlight 
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Color Representation 

is selected. 

Diff Highlight 

Remove 

Word or phrases that 

appear in the TM but 

not in the source. This 

appears if Diff Highlight 

is selected. 

Go to Defining color codes for more information. 

Using TM lookup 

TM lookup is a process that searches for specific source segment text in the translation memory. The 

results display source and target segments. 

  

To perform TM lookup: 

1. Enter a word or phrase in the TM Lookup text box. For example, 

• Our Process: searches segments with either word available in lower, upper and sentence 

case. 

• "Our Process": searches only those segments that include both words in the same order 

and case. 

• Our+Process: searches segments which include both the words available in lower, upper 

and sentence case. 

2. Select the Case sensitive check box  to match case. 

3. Click Find In Source or Find In Target. 
Note: If you want matches that only have all the words in your phrase, use + signs between each 

word instead of spaces. If you use spaces in the search string, then results will show segments 

that have any of the words in them. 

 

OR 

1. Select a word or phrase in the source segment. 

2. Press Ctrl+Shift+T or . 

The TM Lookup results appear. The results display the segment ID, Source, and Target 

segments, TM Name, Username and Date/Time of update to TM. 
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Note: The words or phrases that match the searched context are highlighted. 

If no TM is selected, the following dialog box appears: 

 
  

Click TM List to select a TM from the list of TMs. 

To continue without selecting a TM, click OK or close the dialog box. 

Updating translation memory 

To update translation memory with new content, ensure the TM has the Read only checkbox clear and 

update options are selected. Go to Creating or opening a translation memory and Selecting translation 

memory settings for more information. 

When you navigate source segments by pressing Alt+Down or Alt+Up or clicking  or , segments are 

saved automatically to the TM. 

Note: If you have changed the target segment, and you navigate using other methods (for example, 

clicking other segments to navigate directly to them), a warning message appears asking if you want to 

save the target segment. 

Working with terminology 

Find below the procedures for the following tasks: 

• Setting copy term option 

• Highlighting terms 

• Auto propagating terms 

• Using terminology wildcard 
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• Leveraging a glossary 

• Adding terms 

• Editing terms 

• Copy a term 

• Adding blacklist 

• Editing blacklist 

• Using Wordfast Pro and Wordfast Classic glossaries  

Setting copy term option 

The copy term option copies the source segment to the target segment. 

  

To set copy term option: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

  

2. Click Terminology > New/Select Glossary > Translations > Terminology. 

The Preferences (Filtered) Terminology dialog box appears. 
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3. Select one of the following copy term options: 

• Copy only source: to copy source term from the source segment to the target segment. 

• Copy only target terms: to copy target term to the target segment. 

• Copy both source and target glossary terms: to copy both source and target terms to the 

target segment. 

  

4. Select Enable automatic fuzzy term recognition checkbox to clear it, if you do not want to 

see  fuzzy matches from the glossary highlighted. 

5. Select Highlight terms in Editor with Box to clear it, if you do not want to enable highlighting of 

terms with a box in the TXML Editor. 
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6. Select Ignore case for term highlights to clear it, if you do not want to ignore case when 

highlighting terms. 

7. Click Apply and OK. 

Highlighting terms 

To highlight terms: 

1. Click Terminology > New/Select Glossary > Translations > Terminology. 

The Preferences (Filtered) Terminology dialog box appears. 

2. Select Highlight terms in Editor with Box checkbox to highlight terms in the TXML editor in 

different colors with a box as explained below.   

Green 100% match in source 

and target 

Orange (fuzzy in source or 

target) 

Red match in source but no 

match in target 

3. Click Apply and OK. 

The terms are highlighted as shown in the screenshot below. 
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Under the Terminology menu click Run/Stop Term Highlighting (Ctrl+F5) to highlight terms 

and  to turn off highlighting for all segments. The terms will still be highlighted for the currently 

selected segment. 

Auto-propagating terms 

To auto-propagate terms: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a term from the glossary exists in the source 

segment, it will appear in red by default. 
Note: Ensure that a glossary is imported and selected for the project. For more information, refer 

to Importing a glossary. 

2. Select Edit > Copy Source or click   or press Alt+Insert, to copy the text from the source 

segment into the target segment. 

The glossary term translation is auto propagated as shown in the screenshot below. 
 

 
 
Note: The term 'Process' is followed by its translation 'Proceso'. 
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Using a term wildcard 

To add and use a term wildcard: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a term from the glossary exists in the source 

segment, it will appear in red by default. 

2. Click Terminology > Edit. 
3. Select the glossary that you want to edit. 

The glossary appears. 

4. Double-click the entry you want to modify. 

The Edit term dialog box appears. 

 

 
  

5. Type a '*' after the term to populate all variations of the selected term. For example, the wildcard 

term 'Process*' will populate the target 'Proceso' for all term variations such as 'Processes', 

'Processing', and so on. 

6. Click Modify. 

The terminology wildcard is activated. 

Leveraging a glossary 

To leverage a glossary: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a term from the glossary exists in the source 

segment, it will appear in red by default. 
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2. Select Terminology > Previous Term / Next Term or click   or  or press Ctrl+Alt+8 / 
Ctrl+Alt+9. 

The term is highlighted and selected. 

3. In the target segment, place the cursor at the location where you want the translated term to 

appear. 

4. Select Terminology > Copy Term or click   or press Ctrl+Alt+0. 

The translated term appears in the target segment. 

 

 

Adding terms 

Terms can be added to glossaries, if permitted. If a selected glossary is read-only, you will be prompted 

to set up a new glossary.  

 

 
There are two ways to add terms to a local or remote glossary: 
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1. Click Terminology > Add Term or click . 

The Add to glossary dialog box appears. 

 

 
  

2. Enter the term in the Source or Target field. 

3. Enter a Description of the term if desired. 

4. Select the glossary to which you want to add the term. 

5. Click OK. 

 

OR 

  

1. Select text from the source or target segment. Press Ctrl+Alt+T, or click Terminology > Add 

Term or click . 

2. The Add to Glossary dialog box appears. The selected text appears in the source or target field, 

depending on whether it is in the source or target segment. In the example below, the selected 

text appears in the source field. 
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3. Enter a Description of the term if desired. 

4. Select the glossary to which you want to add the term. 

5. Click OK. 

 

OR 

1. To continue and add text to the target field, keep the Add to Glossary dialog box open. Select 

text from the target segment. Press Ctrl+Alt+T, or click Terminology > Add Term or click .The 

selected text appears in the target field. 
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2. Enter a Description of the term if desired. 

3. Select the glossary to which you want to add the term. 

4. Click OK. 

The new term is added. 

Alternatively, 

1. Click Terminology > Edit  or click . 

2. Select the glossary list to which you want to add terms. 

The glossary list appears. 
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Note: To expand or shrink a column, point to the right edge of the column's header with the 

mouse. 

A two-directional arrow appears. 

 
Drag the arrow to the right to shrink the column. 

Drag the arrow to the left to shrink the column. 

  

3. Click . 

The Add term dialog box appears. 
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4. Enter Source, Target, and Description of the term. 
Note: If you are adding a term to a remote glossary, the Description field will not be available. 

5. Click Add. 

The new term is added. 

 

Editing terms 

To edit terms: 

1. Click Terminology > Edit  or click   or Ctrl+Alt+Enter. 
2. Select the glossary list that you want to edit. 

The glossary list appears. 
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Note: To expand or shrink a column, point to the right edge of the column's header with the 

mouse. 

A two-directional arrow appears. 

 
Drag the arrow to the right to shrink the column. 

Drag the arrow to the left to shrink the column. 

  

3. Double-click the term you want to modify. 

OR 

Select a term and click . 

OR 

Right-click a term. The terminology editor submenu appears: 

 
 

  

4. Click Modify. 
The Edit term dialog box appears. 
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5. Enter the necessary changes and click Modify. 

The modified term appears in the glossary. 

Copy a term 

1. Click Terminology > Edit  or click   or press Ctrl+Alt+Enter. 
2. Select the glossary list that you want to edit. 

The glossary list appears. 
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3. Right-click a term. The terminology editor submenu appears: 

 
4. Click Copy. 

The term is copied from the Terminology Editor. 

  

Adding a blacklist 

A blacklist includes words or phrases that should not be used in the target segment. 

  

To add a blacklist: 

1. Click Edit > Preferences > Terminology > Blacklist. 
The Blacklist dialog box appears. 

2. Click Create, to create a new blacklist or Add, to add an existing blacklist. 
Note: the blacklist must be a tab-delimited file. 

3. Browse and select the location of the new blacklist or existing blacklist. 

4. Type a symbolic name and select the language code of the blacklist. 

5. Click OK. 

The newly created or selected blacklist appears in the Blacklist List. 
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6. Select Selected check box to use the blacklist during translation. 

7. Select Read only check box, if you do not want to update the blacklist. (Optional) 

8. Click OK. 

A new or existing blacklist is created or opened for the project. 

Editing blacklist 

To edit an existing blacklist: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 
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2. Click the Edit blacklist icon and select the blacklist as shown in the screenshot below. 

 
 

The Blacklist appears as a separate tab. 

 

 
  

Note: To expand or shrink a column, point to the right edge of the column's header with the 

mouse. 

A two-directional arrow appears. 

 
Drag the arrow to the right to shrink the column. 

Drag the arrow to the left to shrink the column. 

  

3. To add a term to the blacklist, click Add. 

The Add Term dialog box appears. 
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4. Enter the Forbidden and Suggested term. 

5. Click Add. 

The forbidden term and suggestion appears in the blacklist. 

6. To modify a term from the blacklist, select the term and click Modify. 

The Modify Term dialog box appears. 

 

 
  

7. Edit the Forbidden and Suggested term and click Modify. 

8. To delete a term from the blacklist, select the term and click Remove. 

A warning message appears. 
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9. Click Yes to delete the blacklisted term. 

Using Wordfast Pro and Wordfast Classic glossaries 

  

Wordfast Professional (WF Pro) and Wordfast Classic (WFC) can share project glossaries. The WF Pro 

glossary .txt file is located with your glossary files. WFC must connect to this text glossary file. Once the 

WF Pro glossary is created, WF Pro must be closed to permit WFC to connect to the WF Pro glossary. 

The example below shows how a glossary is shared between Wordfast Pro and Wordfast Classic. 

  

1. Open a project in Wordfast Pro 

2. Click Terminology. 
3. Click New/Select Glossary or press Alt+N. 

The Glossary List appears. 

 
4. Click Import. 

5. Locate the glossary to be shared. 
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6. Close Wordfast Pro. Failure to close Wordfast Pro leaves the glossary file locked,  and it cannot 

be opened or modified. 

7. Activate Wordfast Classic in the Word document by clicking the Wordfast Classic button, or 

pressing Ctrl+Alt+W. 

8. Click the Wordfast Classic button. 

9. Add the <glossary_name>.txt file located in Wordfast Pro above. 

10. Select the glossary, and click Reorganize. 

11. Select the terms to be added, and press Ctrl+Alt+T to add terms to the glossary in Wordfast 

Classic. 

The Edit Entry dialog box appears. 

12. Enter the source term, or the target term, and an optional comment. 

An example is shown below. 

 
13. Click OK. 

14. Finish working in Wordfast Classic, and close the Word document. 

15. Open Terminology in Wordfast Pro. 

16. Open the glossary. 

The added term appears in the glossary. 

Working with tags 
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A tag is inline text that is not translatable, for example, HTML code within a sentence. Target segments 

should have the same tags as the source segment. However, depending on the language,  sometimes a 

tag is not needed. If you try to save a target segment with missing tags, a warning message appears. 

Find below an example of a source segment with two tags: 

  

Please contact the hotel for further information at {ut1}info@companyname.com{ut2}. 

  

The {ut1} and {ut2} text strings represent tags. 

  

Find below the procedures for the following tasks: 

• Viewing tags 

• Copying tags 

• Editing tags 

• Deleting tags 

• Removing all tags 

Viewing tags 

To view tags: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a tag exists in the source segment, it will appear in 

gray by default. 

2. Point to the tag with the mouse. 

The actual text in the tag appears. Find below an example of the popup for the {ut1} tag. 
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3. The first tag in the source segment is highlighted in red as soon as the cursor is placed in the 

target segment. 
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Copying tags 

To copy tags: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a tag exists in the source segment, it will appear in 

gray by default. 

2. In the target segment, type the tag as it appears in the source segment, for example {ut1}. 

OR 

1. In the source segment, place the cursor before the tag and drag the mouse to select it. 

2. Drag the selected tag to the target segment (drag-and-drop). 

OR 

1. In the source segment, place the cursor before the tag and drag the mouse to select it. 

2. Right-click and select Copy or use the Ctrl+C shortcut key to copy the tag. 

3. In the target segment, place the cursor where you want to paste the tag. 

4. Right-click and select Paste or use the Ctrl+V shortcut key to paste the tag. 

OR 

1. Select Edit > Tags > Previous Tag / Next Tag or click  or  or press Alt+Shift+Left / 
Alt+Shift+Right. 
The tag is highlighted in red and selected. The first tag in a segment is highlighted when the 

segment is clicked. 

 

 
  

• If you type the same tag twice, the following error message appears. 

 

 
  

• If the target segment does not contain tags, the following error message appears. 

 



225 

 
  

2. Place the cursor where you want the tag in the target segment. 

3. Select Edit > Tags > Copy Tag or click  or press Alt+Shift+Down and type the characters of 

the tag. 

The tag appears in the target segment. 

4. To copy all tags from the source segment to the target segment, click Edit > Tags > Copy Tags 

in Current Segment or click  or press Ctrl+Shift+A. 

Editing tags 

To edit tags: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a tags exists in the source segment, it will appear in 

gray by default. 

2. Place your cursor in the tag's text in the target segment, right click, and select Edit Tag. 

The Edit Tag dialog box appears. 
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3. Modify the tag as required and click OK. 
Note: The tag in the source segment should not be modified. Ensure that the modifications are 

valid. If not, the TXML file could get corrupted. 

Deleting tags 

The tag can be deleted only in the target segment. To delete tags, in the target segment place the cursor 

before the tag and drag the mouse to select it. Right-click and select Cut (or press the Ctrl+X shortcut 

key or Backspace on your keyboard). 

  

Removing tags in current segment 

Tags can be removed only in the target segment. 

To remove tags from the target segment: 

  

1. Select the segment from which you want to remove tags. 

The segment is highlighted in pink. 

 
2. Click Edit > Tags > Remove tags in current segment. 

OR 

Press Ctrl+Shift+V. 
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The tags are removed from the current segment. 

 

Removing all tags 

Tags can be removed only in the target segment. 

To remove all tags in the target segment: 

1. Click Edit > Tags > Remove all tags. 

The following dialog box appears. 

 
  

2. Click Yes to confirm and remove all tags from the target segment. 

  

  

Editing source segment 

The Edit Source option allows you to modify the source content of the file being translated. The original 

source content is stored in the TXML and can be restored at any time. 
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To edit the source segment: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. 

2. Select a segment and click Edit > Edit Source or  on the dashboard. 

The Edit Source dialog box appears. 

 

 
  

3. Edit the source content in the Modified Source box and click OK. 

The source segment is modified and a Modified Source icon  appears before the segment as 

shown in the screenshot below. 
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To revert to original source, click Edit > Revert to original source or  on the dashboard. 

Using Transcheck 

The Transcheck option verifies certain elements in the target segments and warns you about missing or 

incorrect text or variables. For example, if you do not insert a tag or type incorrect text, a warning signal 

will appear before the target segment. You will be able to view the warning on mouse over. 

  

Find below the procedures for the following tasks: 

• Enabling Transcheck 

• Configuring Transcheck 

• Viewing Transcheck warning 

Enabling Transcheck 

To enable Transcheck: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Transcheck. 

The Transcheck dialog box appears. 
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3. Select Enable Transcheck checkbox. 

4. Select Transcheck during translation checkbox, if you want Transcheck to be activated before 

the translation is updated to the TM. 
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5. To check for specific errors in the target segments, select the different Configuration options. 

The options available are: 

 

Select to check... 

Partial the character count between the source and target 

segments. 

Empty target for empty target segments. 

Numerical Check if the numerals in the source segment match the 

target segment. The numbers with hyphens will be 

read as two separate numbers. 

Tag for missing tags in the target segments. 

Forbidden Characters check if the target segment includes forbidden 

characters. 

Punctuations for consistency in punctuation between source and 

target segments. 

Note: The punctuation transcheck only works on 

end of segmentation punctuation. 

Untranslatable check if the untranslatable content in source and 

target segments is consistent. 

Copied Source Check if the source segment has been copied to the target 

segment. 

Terminology Check if the terms in the source segment are translated 

correctly based on the glossary. 

Blacklists if the target segment includes blacklisted terms. 

Note: The blacklisted term list must be a tab-

delimited file. 

First word 

capitalization Check 

if the first word of each segment is capitalized. 

 

6. Choose the display option from the drop down list. You can view Transcheck as an error or 

warning. 

7. Click OK. 

The Transcheck option is enabled. 

Configuring Transcheck 

To configure individual Transcheck options: 
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1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Transcheck. 

The Transcheck dialog box appears. 

 
  

3. In the left pane, under Transcheck, select the following options: 
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Select to ... 

Consistency check 

 

ignoredifferences 

in  case, 

whitespace, tags 

and numbers. 

Copied Source Check 

 

check segments 

in upper case. 

Forbidden Characters check 

 
  

add, edit or 

remove 

Forbidden 

Characters to the 

check. 

Numerical 

 

treat numbers 

with hyphens or 

dashes as single 

numbers. 
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Select to ... 

Partial 

 

enter the 

minimum and 

maximum % of 

allowed 

character count 

for the target 

segment. 

Punctuations 

 

add, edit or 

remove 

punctuation 

characters to the 

check. 

Terminology 

 

select options for 

checking the 

glossary used in 

the translation. 
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Select to ... 

Untranslatable 

 

add, edit or 

remove content 

that should not 

be translated, 

such as a 

company name. 

   

Viewing Transcheck warning 

To view Transcheck warning: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. 

2. Type the target segment. 

A warning message and a warning signal appear before the target segment as shown in the 

screenshot below. 

 

 
  



Translating in a project 

236 

3. Point to the warning signal with the mouse. 

The text in the warning appears as shown in the screenshot below. 
 

 
 
Note: The Transcheck warning appeared because the first letter in the first word of the target 

segment was not capitalized. The warning disappears when the segment is corrected as shown 

in the screenshot below. 

 

 

Using Outline window 

The Outline window is used for source segment navigation. The source for each translatable segment is 

listed with color-coded icons that represent the translation score. The segments that need to be confirmed 

are also marked by an asterisk (*) in the Outline window. Find below an example of an Outline window: 
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Navigating using Outline window 

To view a source segment, in the Outline window, place the cursor on a source segment and left-click. 

The source segment is selected and highlighted. 

Sorting segments 

To sort the source segments, click the drop down list. 

The following options appear: 

Select to view... 

Show all all segments. 

100% only 100% translation memory matches. 

Fuzzy only fuzzy or partial translation memory matches. 

No match no matches only. 

Modified 

Segments 

modified segments only. 

All Except 

100% 

all segments except 100% translation memory matches. 

With Notes segments with notes. Go to Using notes for more information. 

Empty target segments with empty targets. 

Autopropagated segments that are autopropagated. Go to Enabling Auto Propagation for more 

information. 

With transcheck 

errors 

segments with transcheck errors. Go to Using Transcheck for more information. 

Unconfirmed segments that are unconfirmed. Go to Confirming or Unconfirming segments for 

more information. 
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Select to view... 

With edited 

source 

segments with modified source content. Go to Editing source segment for more 

information. 

With revisions revised segments. Go to Viewing segment changes for more information. 

  

 

Outline window default color representation 

Find below the list of default color representations for source and target segments in the Translation 

window: 

Color Representation 

Yellow Fuzzy match 

Grey No match or NA 

Green 100% match 

Pink Segment modified since 

the original file was 

created 

Purple Segment modified and 

updated to translation 

memory 

 

Go to Defining color codes for more information. 
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Viewing TXML Context 

The TXML Context window is used to view the TXML context of the currently open file. You also have the 

option to view the XML Source. Find below an example of a TXML Context window: 

  

 

Using notes 
While translating or reviewing translated content, you have the option of adding notes specific to each 

segment. Find below the procedures for the following tasks: 

• Adding notes 

• Editing notes 

• Deleting notes 

• Exporting Notes 

Adding notes 
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To add a note: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a blue 

background, and your cursor will be in the target segment by default. 

2. Click the Notes tab. 

3. Place your cursor in the segment where you want to add a note.  

4. Click Add under the Notes tab or select Edit > Add Note... or click . 

The Add Note dialog box appears. 
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5. Select the type of note. 

 
Note: The last option selected appears at the top of the list. The last option selected is the default 

type for the next new note. 

6. Enter the note in the box and click OK. 

The note appears in the Notes tab and an 'i' symbol appears next to the segment in the Outline 

window as shown in the screenshot below. 
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Editing notes 

To edit notes, click Edit in the Notes tab, select Edit > Edit Note... or right-click the note in the Notes tab 

and select Edit Note or click . 

Deleting notes 

To delete notes, click Delete in the Notes tab, select Edit > Delete Note... or right-click a note in the 

Notes tab and select Delete Note or click . To delete all notes, select all notes and click Delete. 

Exporting notes 

To export notes in Word format, 

1. Click Export Notes in the Notes tab.  

The Save As dialog box appears: 
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By default, notes are saved to the same folder that contains the original files. 

2. Click Save. 

The following message appears. 
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The notes are formatted as a Word table, as shown in the screenshot below. 

 

Viewing segment changes 
The Segment Changes window is used to view the segment changes in the currently open file. The 

recent changes will appear on top of the list. The segment changes appear only when a file is saved. Find 

below an example of the Segment Changes window: 
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Using shortcut icons 
Wordfast Pro 3 includes a number of shortcut icons that help you quickly complete common tasks. Find 

below a list of all the shortcut icons available in the TXML Editor and their functionality. 

  

Use to... 

(Ctrl+O) 
open a new file. 

Note: When you browse your PC, only the file 

types listed in your File Associations setup 

(Window > System Options...> General > Editors 
> File Associations) will appear. 

(Ctrl+S) 
save the currently open file. 

(Ctrl+P) 
print the file that is currently open. 

(Ctrl+Shift+8) show or hide whitespace characters. 

 

translate a segment using machine translation 

software. 

(Ctrl+Shift+N) 
create or select a translation memory (TM). 

(Alt+Down) 
navigate to the next segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

(Alt+Up) 
navigate to the previous segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

(Alt+-) 
leverage the TM for the current source segment. 

(Ctrl+Alt+F) 
translate the source segments until there is a fuzzy 

match. 

(Ctrl+Shift+PageDown) 
translate the source segments until there is no 

match. 

(Ctrl+Shift+End) 
translate all source segments. 

(Alt+Insert) 
copy the text from the source segment into the 

target segment. 

(Alt+PageDown) 
combine the currently selected source segment 

with the next segment. 
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Use to... 

If segments are merged across paragraphs, a tag 

appears between the merged segments in the 

source and the target. 

(Alt+PageUp) 
split the source segment into two segments, at the 

location of the cursor. 

(Alt+Enter) 
mark a segment as confirmed or unconfirmed. 

(Alt+End) save the current translated segment to the TM. 

(Ctrl+Alt+End) save the translated segments to the TM and close 

the file. This action is typically carried out when you 

have completed translation. 

 

insert left to right mark. 

 

insert right to left mark for languages that are 

written in that direction, such as Arabic. 

(Ctrl+Shift+A) copies all tags from the current source segment to 

the target segment. 

(Alt+Shift+Left) 
select the previous tag in the source segment. The 

selected tag will be highlighted in red by default. 

 

delete the currently selected tag. 

(Altl+Shift+Down) 
copy the currently selected tag into the target 

segment at the location of the cursor. 

(Alt+Shift+Right) select the next tag in the source segment. The 

selected tag will be highlighted in red by default. 

 

analyze the file for translation against a TM to 

leverage reusable content and pre-translate 

content. 

(Ctrl+Shift+T) 
look up the selected source text in the translation 

memory. This action leverages all segments that 

include that text. 

(F7) 
check spelling. 

(Ctrl+Alt+P) 
preview the file in MS Word. 

(Ctrl+Alt+8) 
navigate to the previous term in the source 

segments. 
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Use to... 

(Ctrl+Alt+0) 
copy the selected term. 

(Ctrl+Alt+9) 
navigate to the next term in the source segments. 

 

edit the blacklist for the open project. 

 

modify the glossary. 

(Ctrl+Alt+T) 
add a term to the glossary. 

(Alt+Shift+E) edit a note. 

(Alt+Shift+D) delete a note. 

(Alt+Shift+N) add a note. 

(Ctrl+Shift+Q) process file for transcheck warnings. 

  

Modifying colors and fonts 
You can modify the existing colors and fonts for tool layout, TXML editor, and View and Editor folders. 

  

To modify colors and fonts: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > General > Appearance > Colors and Fonts. 

OR 

Press F9 to go to Preferences. 

The Preferences (Filtered) Colors and Fonts dialog box appears. 
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3. Click each folder to show the colors and fonts. 

 
OR 
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Enter a term to locate the color or font, and show a preview as shown in the example below: 

 
4. If you want to change the default color for any of the content types, click the content type. 

For example, select the Translation folder to expand it, and scroll to the Tooltip font. 
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5. Select the Tooltip font, to preview the font. 

 
  

6. Click Edit to select another font,font style, size, or color. Click Use System Font to accept the 

default font. 

7. Click Apply and OK. 

  

Confirming or Unconfirming segments 
The Confirm/Unconfirm Segment option allows the translator to mark a segment for future reference. For 

example, if the translator wants to check and confirm a segment after referring to some resources, he or 

she can mark the segment and review it at a later stage. 

  

To confirm or unconfirm a segment: 
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1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a blue 

background, and your cursor will be in the target segment by default. 

2. Type or leverage the target segment from the translation memory. 

The target segment will appear. 

3. Click Translation Memory > Confirm/Unconfirm or , to mark the segment. 

A  symbol appears next to the segment in the Outline window as shown in the 

screenshot below. 
 

 

Note: The  symbol will disappear only when you click Translation Memory > 

Confirm/Unconfirm or  or Alt+Enter again to confirm the segment. Unconfirmed segments 

are not committed to the TM when you click Translation Memory > Next Segment, or  or 

press Alt+Down, or click Translation Memory > Commit current segment to TM, or  or 

press Alt+End. 

Saving a file 
To save a file: 
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• Click File > Save or Ctrl+S, to save the currently open file. 

• Click File > Save translated file or Ctrl+Alt+S, to save a translated file to its original format. 
Note: When an Excel file is saved, any sheet names exceeding 31 characters will be truncated to 

31 characters. Any segments having the same sheet name will result in a filter error: 

 
The following languages require special font rules when translated. Wordfast Pro automatically 

changes the target font output when it identifies characters from the following languages into the 

listed fonts. 

• Japanese: MS Gothic UI 

• Chinese: SimSun for Chinese characters, Arial for Western characters 

• Korean: Batang for Times New Roman, Gulim for Arial 

• Arabic: Arial 

• Click File > Save As, to save and rename the file. 

• Click File > Save All or Ctrl+Shift+S, to save all open files. 

Closing a file 
To close a file: 

• Click File > Close or click , to close the currently open file. 

• Click File > Close All, to close all open files. 
 
Note: If you close a file without saving the most recent changes, a warning message appears 

querying if you want to save the file. 

Deleting a project 
To delete a project: 
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1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click File > Open Project. 

The Open Project dialog box appears. 

 

 
  

3. Select a project name and click Delete. 

A confirmation message appears, asking if you want to delete the file. 

4. Click Yes. 

The project is deleted and removed from the Project list. 
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Working with advanced options 
The Wordfast Pro 3 advanced options are as follows: 

• Selecting memory preferences 

• Selecting AutoSave preferences 

• Defining segmentation settings 

• Managing shortcut keys 

• Managing licenses 

• Updating Wordfast Pro 3 dictionaries 

• Accented characters 

• Font mapping 

  

Selecting memory preferences 

You can select the maximum memory that Wordfast Pro 3 will use to ensure you can open and work with 

large files with ease. 

  

To select memory preferences: 

1. Open Wordfast Pro 3 and click Edit > Preferences > General > Memory Preferences. 

The Memory Preferences dialog box appears. 
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2. Select the amount of memory Wordfast Pro 3 will use on your machine and click OK. 
Note: Maximum memory is the Java heap size. If the memory size selected here is more than the 

available memory, you may get a Java heap size error. 

Selecting AutoSave Preferences 

You can select the default AutoSave setting. This setting saves the file to a temp folder whenever a 

change is made. Once the file is saved manually, the file is removed from the temp folder and saved in 

the user file. 

If the application crashes or is closed without saving the file, the file can be located in Auto Saved files, 

and then saved to the path of the original file 

To select Auto Save preferences: 

1. Open TransStudio and click Edit >Preferences or press F9 to go to Preferences. 

2. Click General >AutoSave. 
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3. The AutoSave Preferences dialog box appears. 

 
3. Default time period for AutoSave is set to 10 minutes. The minimum is one minute. 

4. Click the spin box   to set a time greater than one minute for Autosave. 

5. Click Browse to select another location for AutoSaved files.   

6. Cick OK. 

Defining segmentation settings 

The Wordfast Pro 3 workspace (.wf_workspace folder) includes a number of default properties files that 

are used for file segmentation. You can either use the default properties files or export and edit these 

files. 

  

To define segmentation settings: 

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Segmentation Settings. 

The Segmentation Settings Preferences dialog box appears. 
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2. Select the preset segmentation of your choice. The options are: 

• breaksegmentation.properties 

• idiomsegmentation.properties 

• srxsegmentation.properties 

• wfsegmentation.properties 

3. To edit any of the preset segmentations, select the properties file and click Export. 
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4. Open the properties file and edit as required. 
Note: The commonly used properties file that can be modified is the wfsegmentation.properties 

file. 

Find below some examples of segmentation settings: 

  

UI description Options Configuration setting 

A number 

followed by an 

ESM ends a 

segment 

  segmenter.strategy.trados.rule1enabled=true 

An ESM without a 

trailing space 

ends a segment. 

This should be 

marked true for 

Chinese or 

Japanese 

projects 

True/False segmenter.strategy.trados.rule2enabled=false 

An ESM followed 

by a space 

followed by a 

lower-case letter 

ends a segment 

True/False 

  

segmenter.strategy.trados.rule3enabled=false 

Simple Tag 

Handling 

False: causes 

tags after the 

break to 

associate left to 

the current 

segment 

True: causes 

Tags after the 

break to 

associate right to 

the next segment 

True/False segmenter.text.simpletaghandling=false 
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UI description Options Configuration setting 

Remove 2 

surrounding tags 

rule. 

False: for 

backwards 

compatibility 

True: for new 

projects 

True/False segmenter.simplifier.trados.strict=false 

Remove trailing 

tags that are 

preceded by 

ESMs. 

False: for 

backwards 

compatibility 

True: for new 

projects 

True/False segmenter.simplifier.trados.noesp=false 

End of segment 

punctuation for 

Trados sentence 

iterator 

(any 

punctuation 

separated by 

a comma) 

ex.  .,:,?,!,tab 

breakiterator.strategy.sentence.trados.esps=.,:,?,!,tab 

 

5. After editing the properties file, click Import to use the edited properties file. 

Managing shortcut keys 

Wordfast Pro 3 includes a number of shortcut keys that help you quickly complete common tasks. You 

can also modify and create new shortcut keys. Find below the procedures for the following tasks: 

• Viewing shortcut keys 

• Modifying shortcut key schemes 

• Modifying shortcut keys 

• Creating shortcut keys 
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Viewing shortcut keys 

To view shortcut keys: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Help > Shortcut List... or press Ctrl+Shift+L. A list of actions and shortcut keys appear. 

The default short cut keys for Windows are as follows: 
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The default shortcut keys for OSX are as follows: 
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Modifying shortcut key schemes 

To view or modify shortcut key schemes: 

1. Open Wordfast Pro 3 and click . 

The TXML perspective appears. 

2. Click Edit > Preferences. 

The Preferences (Filtered) screen appears. 

3. Click General > Shortcut Keys. 

The Shortcut Keys option appears. 

 

 
  

4. Select a Scheme from the drop down list. 
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Note: You can change the shortcut key scheme to Emacs, SDLX, Trados, Wordfast, or Wordfast 

Classic. You can also create a default scheme of your own. 

Modifying shortcut keys 

To modify a shortcut keys: 

1. Follow step 1 and 3 from Modifying shortcut key schemes. 

The Keys option appears. 

 

 
  

2. Left-click and select a Command. 

• To copy the command, click Copy Command. 

• To remove the existing binding, click Unbind Command if the shortcut key is bound. 

• To restore the binding, click Restore Command. 

The shortcut key is modified. 

Creating shortcut keys 

To create a new shortcut key: 
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1. Follow step 1 and 3 from Modifying shortcut key schemes. 

The commands appear. 

 
2. Left-click and select a command. 

3. Enter a Description. (Optional). 

4. Place the cursor in the Binding field and press a sequence of keys. 

A new shortcut key is created. 

  

Managing licenses 

Refer to procedures for the following tasks: 

• Re-installing license certificate 

• Verifying current license certificate 

• Update notification 

Re-installing license certificate 

The Wordfast Pro license must be re-installed, if the license has expired.  

To re-install a license certificate: 
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1. Remove the current version of Wordfast Pro 3 from your PC by running the Uninstaller located at 

Start > All Programs > Wordfast > Uninstall. 
Note: The Uninstaller runs automatically when you re-install Wordfast Pro 3. 

2. Download the Wordfast Pro 3 installer from the webpage 

http://www.wordfast.com/store_download.html to your PC. 

3. Run the installer. 

The Wordfast Pro 3 Demo Mode appears. 
Note: Wordfast Pro 3 requires a Java JRE to be installed on your PC. During installation, if Java 

JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro 3 will refer to it when 

running. 

In the Demo Mode, you can view and test all the functions of the software. You can purchase a 

Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html. 

If you do not purchase a license, you are limited to storing up to 500 translation units in your 

translation memories. 

4. Log in to the Wordfast website with your email address and password. 

5. Click License application to obtain a license file for the new install number. The license file is 

emailed to you. Alternatively, right-click the link appearing on the Confirmation Page, and save 

the target as. The license file has a .lic file extension. Save the file in a secure location. 

6. Open the Wordfast Pro 3 Demo Mode. 

7. Click Help > License Management. 

The Activation dialog box appears. 

8. Click License Manager. 
9. Select (Re-)Install a license certificate and click Next. 

10. Browse and navigate to C:\Program files\Wordfast and select the license file. 

11. Click Next twice and then Finish. 

12. Restart Wordfast Pro 3. 

Your license is re-activated. If you have any problems with the license and require support, 

please log in to the Wordfast Pro 3 support hotline at www.wordfast.com. Alternatively, refer to 

the Wordfast wiki page, How to license Wordfast Pro. 

Verifying current license certificate 

To verify the current license certificate: 

1. Open Wordfast Pro 3 and go to Help > License Management. 

The Activation dialog appears. 

2. Click License Manager. 
3. Select Verify the current license certificate. 

The license certificate appears. It includes details of the current license. 

https://www.wordfast.net/
https://www.wordfast.net/wiki/How_to_license_Wordfast_Pro
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Update notification 

When you open Wordfast Pro 3, you will see an update notification if there are new version updates 

available. 

Alternatively, you can go to the Help menu and click the Check for a new version option. 

Updating Wordfast Pro 3 dictionaries 
The Update Wordfast Pro 3 option updates the dictionaries that can be used during translation. 

  

To update Wordfast Pro 3 dictionaries: 

1. Open Wordfast Pro 3 and click Help > Wordfast Dictionary Updates. Wordfast Pro 3 searches 

for new updates and the search results appear. 

 

 
  

2. Select the features to be installed and click Next. 

The license agreement appears. 
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3. Select "I accept the terms in the license agreements" and click Next. 

The list of features that will be installed appears. 

 

 
  

4. If required, change the location where the features should be installed and click Finish. 

The new features are downloaded and your current installation is automatically updated. 

5. Restart Wordfast Pro 3 to activate the new dictionaries. 
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Accented characters and shortcuts 
The table below lists the letters with accents supported by Wordfast Pro 3. 

  

Accent Sample Shortcut Notes 

Acute Ó ó Ctrl+', V '= 

apostrophe 

key 

V= any 

vowel 

Circumflex Ô ô Shift+Ctrl+^, 

V 

  

Grave Ò ò Ctrl+`, V   

Tilde Ñ ñ Shift+Ctrl+~, 

V 

Only works 

with "n, N, 

o, O, a, A" 

Umlaut Ö ö Shift+Ctrl+:, 

V 

:= colon 

key 

  

Example 1: To type the letter ó, hold down the Control key, then press the apostrophe key. Release both 

keys and type o. The accented letter should appear. 

Example 2: To type the letter Ó, hold down the Control key, then press the apostrophe key. Release both 

keys and type O. The accented letter should appear. 

Example 3: To type ñ, hold down the Shift key, then the Control key, then the ~ key. Release all three 

keys, then type n. 

  

The table below lists the other foreign characters supported by Wordfast Pro 3. 

  

Symbol Name Shortcut Notes 

¡ Upside-down 

exclamation point 

Alt+Shift+Ctrl+! Either Alt key works. 

¿ Upside-down 

question mark 

Alt+Shift+Ctrl+? Either Alt key works. 

Ç, ç French C cedille 

(caps/lowercase) 

Ctrl+, ,c 

Ctrl+, ,C 

For ç, press Control, then 

the comma key. Release 

then press c. 
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Symbol Name Shortcut Notes 

Œ, œ OE ligature 

(caps/lowercase) 

Shift+Ctrl+&,o 

Shift+Ctrl+&,O 

  

ß German 

Sharp/Double S 

Shift+Ctrl+&,S   

Ø, ø Nordic O slash 

(caps/lowercase) 

Ctrl+/,o 

Ctrl+/,O 

  

Å, å Nordic A-ring, 

Angstrom sign 

(caps/lowercase) 

Shift+Ctrl+@,a 

Shift+Ctrl+@,A 

A with ring/Angstrom Sign 

Æ, æ Old English AE 

ligature 

(caps/lowercase) 

Shift+Ctrl+&,a 

Shift+Ctrl+&,A 

  

Ð, ð Old English eth 

(caps/lowercase) 

Ctrl+',d 

Ctrl+',D 

Icelandic/Old English eth 

' = apostrophe key 

  

Example 1: To input Spanish upside down exclamation point ¡ (Alt+Shift+Ctrl+!), hold down the Alt key, 

then the Shift key, then the Control key, then the ! key. Release all four keys, and the ¡ punctuation will 

appear. 

Example 2: To input French oe ligature œ (Shift+Ctrl+&,o), hold down the Shift key, then the Control 

key, then the & key. Release all three keys and then type o to make the letter appear. 

Font mapping 
The fonts for the listed Indic, Afrikaans and CJK languages are hard-coded and cannot be changed by 

the user: 

• Bengali: Bangla 

• Malayalam: Kartika 

• Telugu: Gautami 

• Kannada: Tunga 

• Tamil: Latha 

• Afrikaans: Arial 

• Afrikaans (South Africa): Arial 

• Chinese: SimSun 
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• Chinese (Taiwan): PMingLiU 

• Chinese (China): SimSun 

• Thai: Tahoma 

• Thai (Thailand): Tahoma 

• Hebrew: Arial 

• Hebrew (Israel): Arial 

• Vietnamese: Arial 

• Vietnamese (Vietnam): Arial 

• Japanese: MS Gothic UI 

• Japanese (Japan): MS Gothic UI 

• Korean: Batang 
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Troubleshooting errors 
This section includes a list of common errors, their cause and steps that you can follow to solve them. 

  
Problem: Error message: Invalid license certificate 
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Cause: These error messages appear due to the following reasons: 

 

• License certificate is not a Wordfast Pro 3 license certificate 

• License certificate has an incorrect file name or user name 

• License certificate is edited or some information is missing from the file 

• License certificate has expired 

Solution: Contact the administrator for a new license certificate. You can contact the administrator by 

logging into the Wordfast Pro 3 support hotline at www.wordfast.com. 

  

  

Problem: Error message: TXML source files missing 
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Cause: The TXML file and the original file are not at the same location or do not have the same file name. 

Solution: Ensure that the TXML files and the original files are at the same location. If not, the cleanup 

process cannot be completed. 

  

  

Problem: Error message: Translation memory header is invalid 
  

 
  

Cause: The local TM file that is being opened does not have the correct header, which typically includes 

the creation date, user ID, source and target language and so on. 

Solution: Ensure that the correct local TM is opened. If the error persists, please log into the Wordfast 

Pro 3 support hotline at www.wordfast.com. 
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Problem: Error message: Terminology skipped during import 

  

 
Cause: The source or target segment is missing from the glossary. 

Solution: Ensure that the imported glossary contains the source and target segments of all the terms. 

  

  

Problem: Error message: Unable to connect to remote TM 
Cause: The URL to the remote TM server is incorrect or invalid. 

Solution: 

1. Go to Edit > Preferences > Translations > Translation Memory > TM List. 

2. Check if the remote TM URL is correct. This is an example of  a URL string: 

wf://french_user:french_password@63.246.29.190:47110 

3. Check if there are trailing spaces at the end. 

Problem: Error message: Current project and local TM have different source and target languages 
Cause: The source and target languages associated with the currently open project does not match the 

local TM language pair. 

Solution: 
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1. Go to Edit > Preferences > Translations > Translation Memory > TM List. 
2. Select the local TM and click Edit TM. 

3. Change the source and target languages to match the current project language pair. 

  
  
Problem: Error message: Current project and remote TM have different source and target 
languages 

 
  

Cause: The source and target languages associated with the currently open project does not match the 

remote TM language pair. 

Solution: 

1. Go to Edit > Preferences > Translations > Translation Memory > TM List. 
2. Select the remote TM and click Edit TM. 

3. Change the source and target languages to match the current project language pair. 

  
  
Problem: Error message: Current project and file for translation have different source and target 
languages. 

 
Cause: The source and target languages associated with the currently open project does not match the 

file language pair. 

Solution 1: Check that you are opening the correct file. If necessary, open the file in a text editor and 

view/verify the source and target language specifications. 

Solution 2: Create a new project with source and target languages matching the file for translation. Go to 

Creating a project for more information. 
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Problem: Error message: Current project and selected Glossary do not have the same source and 
target language code 

 
Cause: The source and target languages associated with the currently open project does not match the 

glossary pair. 

Solution: 

1. Go to Edit > Preferences > Translations > Terminology > Glossary List. 
2. Select the glossary and click Edit. 
3. Change the source and target languages to match the current project language pair. 

  
  
Problem: Translation Memory is not leveraged during translation 
Cause: A local or remote TM is not selected. 
Solution: Ensure that you are connected to a TM. To confirm go to Translation Memory > New/Select 
TM > Local or Remote and check the Selected check box next to the TM you wish to use. If you have 

Read only selected, you will not be able to leverage or copy into the TM. 

  

  

Problem: Shortcut keys not working for key strokes 

Cause: The correct scheme is not selected or the shortcut key is not configured. 

Solution: 

1. Go to Edit > Preferences > General > Shortcut Keys > Scheme. 

2. Choose the correct scheme: Wordfast Pro 3, Emacs, SDLX, Trados, Wordfast or Wordfast 

Classic. 

3. Check the shortcut key list to ensure that all shortcut keys are configured correctly. If not, edit 

accordingly. Go to Managing shortcut keys for more information on viewing, modifying and 

creating shortcut keys. 

4. Click Apply and OK. 
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Working with Wordfast Aligner 
Wordfast Aligner is an add-on tool that converts existing translated documents into a format that is 

compatible with the Wordfast TM. This enables reuse of content translated using other translation tools 

and available in different formats. Wordfast Aligner is supported by all operating systems. This section 

includes the following: 

• Using Wordfast Aligner 

• Basic menu options 

• Using shortcut icons 

Using Wordfast Aligner 

In Wordfast Aligner a project file (.glp) must be created for each source and target pair. A .glp includes 

the source and target documents that need alignment. Alignment is a process by which the source 

document segments are matched with the target document segments correctly. Once aligned, the 

documents can be exported to create a Wordfast compatible TM. 

  

Wordfast Aligner supports TXML, DOC, PPT and XLS file formats. 

  

To align source and target files and create a Wordfast TM using Wordfast Aligner: 

1. Open Wordfast Aligner and click File > New Project or  or Ctrl+N. 

The New Project dialog box appears. 

2. Complete the following entries: 

Option Description 

Project Name Enter a unique project name. 

Project Location Enter the path or click  to select a location for 

the project. 

Source Path Enter the path or click  to select the location of 

the source files. 
Note: The source files can be in TXML, DOC, PPT 

and XLS file formats. 

Source Language Select the source language of the source documents 

from the drop down list. 

Target Path Enter the path or click  to select the location of 
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Option Description 

the target files. 

Note: The target files can be in TXML, DOC, PPT and 

XLS file formats. 

Target Language Select the target language of the target documents 

from the drop down list. 

3. Click Next. 

The File Alignment page dialog box appears. 

 

 
4. Review the aligned source and target files and update the JDiagram links, if required. 

Note: You can select the link and press the Delete button to delete them or drag the cursor to 

create new links. 

5. Click Finish. 

A new project file (.glp) is created and the first document (.gld) in the project appears in the 

Project Aligner window as shown in the screenshot below. 



287 

 
 
Note: The file alignment is a back-end process that creates automated system links (JDiagram 

links) between source and target segments of a document. 

6. Review the aligned source and target segments and update the JDiagram links, if required. 
Note: You can select the link and press the Delete button to delete them or drag the cursor to 

create new manual links. 

7. Click on the Project Explorer button to review all the documents. 
Note: In the Project Explorer you can right click on a document name to complete the following 

actions: delete, mark as complete or pending. An example screenshot is shown below. 
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8. After reviewing all documents click Tools > Export TM or , to create a Wordfast Pro 3 

compatible TM. 

The Export TM dialog box appears. 

 

 
9. Select the Export Type from the drop down list. The options are:  

• All documents: includes open, pending and completed documents 

• Current document: includes currently open document only 

• Completed documents: includes documents that are marked as complete 

  

10. Enter the TM Name and TM Location. 
Note: These options are automatically populated based on the project file name. 

11. Enter the TM User. 
Note: The TM User is a penalty string that is added to the TM. This will help the user identify 

aligned source and target content. 

12. Click Finish. 

A Wordfast TM is created at the specified location. 

  

Basic Aligner menu options 

The Wordfast Aligner basic menu options are as follows: 
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Use to... 

File 

New Project 

(Ctrl+N) 

create a new project. 

Open Project 

(Ctrl+O) 

open an existing project. 

Open Document 

(Ctrl+D) 

open a document. 

Save Document 

(Ctrl+S) 

save the currently open document. 

Close close currently open project or document. 

Exit exit from the tool. 

Align 

Align All align all segments in the document. 

Align Down align all segments below the cursor 

position. 

Align Up align all segments above the cursor 

position. 

Reset Alignment remove existing alignment. 

Reset Manual 

Links 

remove existing manual alignment. 

Reset System 

Links 

remove existing system generated 

alignment. 

Reset Alignment 

Up 

remove all alignment above the cursor 

position. 

Reset Alignment 

Down 

remove all alignment below the cursor 

position. 

View 

Increase Font increase the font size. 

Decrease Font decrease the font size. 

Previous 

Document 

navigate to the previous document. 

Next Document navigate to the next document. 

Project Explorer View or hide the Project Explorer tab. 

Tools 
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Use to... 

Disable Sync 

Scroll 

enable or disable sync control. This 

option highlights the source and the 

corresponding target segment(s). 

Export TM export the aligned documents to create a 

Wordfast TM. 

Options 

(Ctrl+Alt+L) 

edit manual and system JDiagram link 

color, choose TM Export Format and edit 

fonts based on locales. 

Help 

Online Help view the online help. 

About Wordfast 

Aligner 

view build and version details for 

Wordfast Aligner. 

  

Using Aligner shortcut icons 

Wordfast Aligner includes a number of shortcut icons that help you quickly complete common tasks. Find 

below a list of all the shortcut icons available in Wordfast Aligner and their functionality. 

Use to... 

(Ctrl+N) create a new project. 

(Ctrl+O) open an existing project. 

(Ctrl+D) open a document. 

(Ctrl+S) save the currently open document. 

 

align all segments in the document. 

 

align all segments above the cursor position. 

 

align all segments below the cursor position. 

 

remove existing alignment. 

 

remove existing manual alignment. 

 

remove existing system generated alignment. 

 

remove all alignment above the cursor position. 

 

remove all alignment below the cursor position. 

 

remove selected alignment link. 
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Use to... 

 

enable or disable sync control. This option highlights the source and the 

corresponding target segment(s). 

 

export the aligned documents to create a  Wordfast TM. 

 

refresh the project aligner. This option saves changes and reloads the open 

projects. 

 

increase the font size. 

 

decrease the font size. 

 navigate to the previous document. 

 navigate to the next document. 
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TM Administration perspective 
Translation Memory Administration perspective provides a simple and user friendly interface to edit and 

update translation memories. This section includes the following: 

• Using TM Administration perspective 

• Basic menu options 

• Using shortcut icons 

Using TM Administration perspective 

Using TM Administration perspective, users can view, edit and update both local and remote translation 

memories. Find below the procedures for the following tasks: 

• Updating TM Administration preferences 

• Connecting to a remote TM 

• Modifying TM content 

• Purging private TUs 

• Reorganizing a local TM 

• Finding and Replacing Translation Units (TUs) 

• Merging translation memories (TMs) 

• Deleting Translation Units (TUs) 

• Marking Translation Units (TUs) 

Updating TM Administration preferences 

To update TM Administration preferences: 

1. Open Wordfast Pro 3 and click . 

The TM Administration perspective appears. 
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2. Click Edit > Preferences. 

The TM Administration dialog box appears. 
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3. Update the preferences as required. The TM Administration preferences are: 

Option Description 

Connect first TM 

automatically at 

startup 

Select checkbox to view the TM content for the first 

TM in the TM Servers list. 

Ignore case for 

mark options 

Ignore case for all mark options, except Mark TUs 

containing tags. 

Maximum 

segments that can 

be retrieved at a 

time 

Enter the number of segments that you wish to view at 

a time. 

Changed target 

color 

Click on the color box and choose a color to represent 

edited TM content. 

Ut tag color Click on the color box and choose a color to represent 

tags. 

Keyword match 

highlight color 

Click on the color box and choose a color to represent 

keyword search match. 

  

Connecting to a remote TM 

1. Open Wordfast Pro 3 and click . 

The TM Administration perspective appears. 

 
  

2. Right-click the TM. 

To connect only, select Connect. 
To connect as an administrator, Connect as Admin. 
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The TM Admin password dialog box appears. To update a remote TM, it is necessary to have an 

admin password. . 

 
  

3. Enter the Admin password, and click OK. 

  

Modifying TM content 

To modify TM content: 

1. Double-click a TM server on the left pane or select a TM and click . 

The TM content appears in the right pane. 

2. Select or double-click the segment that you wish to modify. 

The segment is selected and highlighted in pink. You can change the color by updating the TM 

Administration preferences. 
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3. Type the new translation and click . 

If the remote TM does not include an administrative password, the following dialog box appears. 

 
4. Click OK or close the dialog box. 

The remote TM connection is initiated. 

 

Purging private TUs 
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TM administrators can purge private TUs as part of the cleanup process. 

  

1. Connect to a remote TM as Admin as explained in Connecting to a remote TM. 

The TM content appears. 

 
2. Click Purge Private TUs on the toolbar,  

 
or click TM Content > Purge Private TUs 
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.  

 

The Purge Private TUs dialog box appears. 

 
3. Enter the workgroup ID and the TM name 

 

 
 

The Purging TUs message appears. 
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The private TUs are purged from the remote TM. 

Adding an administrative password 

When updating a remote TM, you must ensure the Administrative Password is entered in the Add TM or 

Edit TM dialog box. 

To add an administrative password: 

1. Go to the Edit menu and click Preferences or press F9. 

The Preferences (Filtered) dialog box appears. 

2. Go to Translations > Translation Memory > TM List. 
3. Click Add TM to add a new remote TM and enter the Administrative Password. 

OR 

Select an existing remote TM and click Edit TM to enter the Password. 

An example is shownbelow. 



301 

 

 
  

Finding and Replacing Translation Units (TUs) 

You can find and replace TUs within a TM using the find and replace option. 

  

To find and replace TUs: 

1. Double-click a TM server on the left pane 

OR 

Select a TM and click . 

The TM content appears in the right pane. 

2. Click TM Content > Find/Replace or press Ctrl+F. 

The Find/Replace dialog box appears. 
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3. Type the content in the Find and Replace with fields. 

4. Enable the following options, if required: 

Select to find and replace... 

Direction 

Forward content after of the cursor location. 

Backward content before of the cursor location. 

Segment 

Source source segments only. 

Target target segments only. 

Source and Target both source and target segments. 

Options 

Case sensitive content with matching case. 

Whole word whole words only. 

Wrap search starting from and returning to the start location. 

5. Click Find to find the first instance of the content or click Replace All to replace all instances. 

6. Click Replace/Find to replace the searched content and find the next instance or click Replace 

to replace the searched content only. 
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Merging local translation memories (TMs) 

To merge local TMs: 

1. Double-click a TM server in the left pane. 

OR 

Select a TM and click . 

2. Click TM Content > Merge TM or . 

The Select TM to merge dialog box appears. 

3. Select the local TM to merge and click Open. 

The Merge TM options appear. 

 

 
  

4. Select one of the Merge TM options and click OK. 

The two local TMs are merged and the following confirmation message appears. 

 

 
 
Note: Ensure that the source and target language codes of the both the local TMs to be merged 

match. If not the following error message appears. 
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Deleting Translation Units (TUs) 

To delete TUs: 

1. Select the checkbox to select TUs as shown in the screenshot below. 

 

 
  

2. Click TM Content > Delete or click  or press Alt+D on the keyboard. A confirmation message 

appears: 
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3. To delete the TUs click Yes. To cancel the operation click No.  

The selected TM is updated. 

Marking Translation Units (TUs) 

You can select TUs based on different criteria to edit them. 

To mark TUs: 

1. Double-click a TM server on the left pane or select a TM and click . 

2. Click TM Content > Mark and choose one of the options or click the Mark TUs icon   as 

shown in the screenshot below. 

 

 
  

3. Select one of the options. 

A confirmation message appears. 

The Mark Same Source TUs option results in the following message: 
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The Mark TUs containing tags option results in the following message: 

 

 
  

4. Click Yes, to sort the marked TUs and display it on top of the TM Content panel. 
Note: The first TU in the group of redundant TUs will not be checked. The remaining redundant 

TUs are checked, allowing for easy viewing and deleting of TUs. 

   

Removing all tags from selected Translation Units (TUs) 

1. Select the TU(s) from which you want to remove tags. 

 
 

  

2. Click TM Content> Remove All Tags. 
Or 

Click   on the TM Admin toolbar. 

The tags are removed from the selected segment(s). 
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To remove tags from all segments, select all segments. 

Searching TUs 

To search for a term or word within a TU: 

1. Click the Search drop-down menu to select Source, Target, or Source and Target. 

 

 
2. Enter the term to be searched in the search box. 

3. Check Case  to specify if the term is case-sensitive. 

4. Check Exact  to restrict the search to exact matches. 

5. Enter Creator to search by creator of the term. 

6. Click Attribute to search by attribute added to the TXML file. 

7. Specify the From and To dates for terms that were modified w/in a certain time period. 

8. Click Search. 

An example of a completed search is provided below. 
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Reorganizing a local TM 

To reflect updated indexes, and to remove unusable TUs (deprecated TUs, beginning with xx in the 

TXML file), a local TM can be reorganized. 

  

In TM Administration perspective: 

1. Right-click the local TM to be reorganized. 

 
 

  

2. Click Reorganize TM. 

The Reorganize TM dialog box appears. 

 
3. Click Yes to reorganize the selected local TM. Click No to cancel the operation. 

 

If the reorganization is successful, a confirmation message appears: 
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If the reorganization is not successful, the following message appears, showing the reason for the 

failure. 

 
  

Basic menu options 

The Wordfast Pro 3 Translation Memory Administration perspective basic menu options are as follows: 

Use to... 

File 

Exit exit from the tool. 

Edit 

Preferences... set general, spelling, translation, 

translation memory, penalties and 

terminology preferences. 

TM Server 

Connect connect to a Translation Memory (TM) 

server. 

Disconnect disconnect from a TM server. 

Change Languages create a new local TM with different 
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Use to... 

languages. 

Reorganize TM remove all tags beginning with xx 

(deprecated )in the TXML file and 

reorganize a local TM. 

Invert Languages create a new local TM with the current 

TM languages inverted. For example, if 

the source and target language codes 

for the current TM is en-US and de-DE, 

then the source and target language 

codes for the new TM will be switched 

to de-DE and en-US. 

Reversed Sort Order reverse the TM Servers order in the left 

pane. 

Sort By sort TM Servers based on different 

criteria. 

TM Content 

Previous Tag 

(Alt+Shift+Left) 

select the previous tag in the source or 

target segment. The selected tag will 

be highlighted in red by default. 

Remove Tag delete the currently selected tag in the 

source or target segment or press 

Backspace on the keyboard. 

Copy Tag 

(Alt+Shift+Down) 

copy the currently selected tag into the 

source or target segment at the 

location of the cursor. 

Next Tag 

(Alt+Shift+Right) 

select the next tag in the source or 

target segment. The selected tag will 

be highlighted in red by default. 

Remove All Tags. remove all tags in the source or target. 

Find/Replace 

(Ctrl+F) 

find a replace source and/or target 

content. 

Mark 
• Mark Same Source Translation 

Units (TUs) 

• Mark Same Source & Target TUs 
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Use to... 

• Mark Same Source & Attribute 

TUs 

• Mark Same Source, Target & 

Attribute TUs 

• Mark TUs containing tags 

Delete (Alt+D) delete selected TUs. 

Merge TM merge two local TMs. 

Discard All 

(Ctrl+Alt+Home) 

undo all segment changes. 

Discard Selected 

(Ctrl+Alt+PageUp) 

undo selected segment changes. 

Update Selected 

(Ctrl+Alt+PageDown) 

update selected segment changes to 

the TM. 

Update All 

(Ctrl+Alt+End) 

update all segment changes to the TM. 

Window 

New Window open a new Wordfast Pro 3 window. 

System Options view and change the system 

preferences. 

Toggle Toolbar hide or view the toolbar. 

Help 

Online Help (F1) view the Wordfast Pro 3 help. 

Bug Report... view or send the error log. 

Check for a new 

version 

find and install new versions. 

Wordfast Dictionary 

Updates 

update dictionaries that can be used 

during translation. 

Shortcut List... 

(Ctrl+Shift+L) 

view all Wordfast Pro 3 functions and 

keyboard shortcuts. 

License 

Management 

complete activation of Wordfast Pro 3 

and manage license. 

About Wordfast view plug-in and configuration details 

of Wordfast Pro 3. 
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Using shortcut icons 

Wordfast Pro 3 TM Administration perspective includes a number of shortcut icons that help you quickly 

complete common tasks. Find below a list of all the shortcut icons available in Wordfast Pro 3 

Administration perspective and their functionality. 

Use to... 

 

open TM administration preferences. 

(Ctrl+Shift+C) create a TM server connection. 

(Ctrl+Shift+D close a TM server connection. 

(Ctrl+Alt+Home) 

  

undo all segment changes. 

(Ctrl+Alt+PageUp) undo selected segment changes. 

  

(Ctrl+Alt+PageDown) 
update selected segment changes to the TM. 

  

(Ctrl+Alt+End) 

  

update all segment changes to the TM. 

(Alt+Shift+Left) 
select the previous tag in the source or target segment. The selected 

tag will be highlighted in red by default. 

 

delete the currently selected tag in the source or target segment or 

press Backspace on the keyboard. 

(Alt+Shift+Down) 
copy the currently selected tag into the source or target segment at the 

location of the cursor. 

(Alt+Shift+Right) select the next tag in the source or target segment. The selected tag will 

be highlighted in red by default. 

 

merge two local TMs. 

(Alt+D) 
delete selected segment. 

 
• Mark Same Source Translation Units (TUs) 

• Mark Same Source & Target TUs 

• Mark Same Source & Attribute TUs 
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Use to... 

• Mark Same Source, Target & Attribute TUs 

• Mark TUs containing tags 

  

 

remove all tags from the selected segment. 
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