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This guide will help you with setting up an Apple Macintosh 
for a GPRS connection to O2 Mobile Web… 
 
Recommended System Requirements: 
MacOS 8.6 through to 9.2.x 
MacOS X  10.2.x 
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Guidelines and connectivity options for GPRS access… 
 
IMPORTANT: Before you begin, please be aware that this guide is provided on a ‘best endeavours’ basis. 
Whilst the information contained within this guide may prove helpful for Apple Macintosh GPRS connectivity to 
the O2 network, it cannot however be guaranteed. 
 
Connectivity options 
There are 4 connectivity options open to the Mac user for GPRS access to O2 Mobile Web – Bluetooth, Infrared, USB and 
Type II PCMCIA GPRS cards. 
This of course, is dependant on what your particular Mac computer supports. 

Infrared 
The latest Apple Powerbooks and iBooks do not have Infrared functionality built in, although if you have an earlier model, 
you may find that you do have Infrared functionality. 
Bluetooth 
Bluetooth is also supported on the latest Macs – either built-in (if you have one of the latest models), or by way of a 
‘Bluetooth USB adapter’. There are various Bluetooth USB adapters available, and they all offer similar functionality – ie. 
plug and play without the need for USB drivers etc., but please check with the Bluetooth adapter manufacturer for any 
possible set-up instructions for your particular device. 

Whichever Bluetooth type that you have, this will only work in Mac OS X 10.2 or above, as Bluetooth functionality is built 
directly into the operating system itself. You will be unable to use Bluetooth if you are running classic Mac OS9 etc. 

For a connection to work over Bluetooth, you will need to create a secure link between your Mac and mobile device – this is 
termed as ‘pairing’ or ‘bonding’. For instructions on how to pair your devices, see page 21. 
USB 
USB connectivity solutions are currently available from a wide variety of 3rd party vendors. These options allow users, who 
do not have either infrared or Bluetooth capability on their Mac, to create a GSM/GPRS connection by way of a USB cable, 
connected between their Mac and a mobile device. 

USB solutions are normally supplied as a complete package, usually comprising of a USB cable + CD containing modem 
drivers/scripts developed specifically for use with the supplied cable and a particular mobile device. If you are using one of 
these packages, then you will need to follow the manufacturer’s instructions for installation and configuration. If however, 
you are experiencing connectivity problems using this product, then you will need to contact the manufacturer directly for 
advice with your problem. 

PCMCIA GPRS Cards 
There are various GPRS cards available on the market – please check for compatibility for use with your Mac before 
purchasing. One such card is the GlobeTrotter card from Option International. 

For more information and support for this product visit: www.option.com or www.novamedia.de

 

Setting up your mobile device 
In order to create a GPRS connection it will be necessary to enter an Access Point Name (APN) on your mobile device (this 
may not be the case if you are using a 3rd party USB solution – please refer to the manufacturer’s instructions if this is the 
case). 
On current GPRS handsets, it may be possible to enter a data account for the GPRS Modem settings directly on the 
handset – please be aware that this is dependant on the device being used.  
This GPRS data account could then be referenced by a GPRS dial-up number. 
There are 2 ways of implementing a GPRS dial-up number: 

• *99#  - this means "make GPRS connection using default Context ID [CID1]" 
• *99***1# - this means "make GPRS connection using Context ID 1" 
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Sony Ericsson 
On Sony Ericsson GPRS handsets, create and set up a new O2 Mobile Web GPRS data account and make a note of 
the CID number (this can be found by going back into the account after firstly creating and saving it) – then enter the 
dial-up number as *99***1#  (Replace the ‘1’ with whatever the data account CID is). 

 
Nokia 
For Nokia GPRS handsets, enter a new GPRS Access Point in the GPRS Modem Settings and make it Active. This 
works slightly differently on the Nokia. Because the data account is actually activated (unlike Sony Ericsson data 
accounts), it is possible to reference it by entering *99# only (references the default account). On the Nokia (dependant 
on which particular model you have), select either: 

Menu > Settings > GPRS Modem Settings 
Menu > Connectivity > GPRS > GPRS modem settings 

Enter a new active access point by selecting ‘Active Access Point’ > press ‘Select’ > choose an Access Point and press 
‘Activate’. Now scroll down and select ‘Edit active access point’. Rename the Alias to something like ‘MobileWeb’. Now 
scroll down again to ‘GPRS access point’ and press ‘Edit’ and enter mobile.o2.co.uk and then press OK. 
(NOTE: This process may not apply to all Nokia devices – please consult your User Manual for more information). 

 
Siemens and Motorola 
There are currently no Mac GPRS drivers available for Siemens and Motorola except possibly through 3rd party 
developers. There are however Mac USB modem drivers available, but these can normally only be obtained when 
purchasing specific 3rd party USB cables for the device (see USB connectivity options on page 2 for more information). If 
you have one of these, then you will need to check with the manufacturer for modem driver compatibility for MacOS9.x 
and MacOSX (normally 2 separate drivers may be available). 

 
Other GPRS handset manufacturers 
You may need to check with the handset manufacturer for Mac drivers… if there are none available, then there may be 
3rd party drivers / USB cables available via the Internet… 

 
3rd party Modem Scripts 
You may find that one of the modem scripts which are installed as part of MacOS & OS X are suitable for a GPRS 
connection, but this is dependant on the mobile device that you are using. 
If the supplied modem scripts are unable to create a GPRS connection, then you may find an extensive range of 3rd 
party modem scripts at  www.taniwha.org.uk
From this location, download the modem scripts for your particular device and follow the informative instructions in the 
enclosed ‘Read Me’ file. 
In MacOS X, setup usually consists of dragging the appropriate script into your top level Library > Modem Scripts folder. 
The only important difference when using these scripts, is to make sure that you change the Phone number in your PPP 
settings. 
In the phone number field enter: MOBILE.O2.CO.UK – this is in place of *99# that you may have been using previously. 
It will not be necessary to enter or change any settings on your mobile device for this to work. 
Finally, within the Modem settings for either your Infrared or Bluetooth connection, select the recommended Modem 
script that you have just installed. 
For a connection to the O2 network, use the following scripts as a starting point: 

Nokia : Nokia GPRS CID1 
Sony Ericsson : Ericsson GPRS CID1 
Siemens : Siemens GPRS CID1 
Motorola : Motorola GPRS CID1 
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MacOS 8.6 / 9.x set-up 

For a ‘Dial-up’ connection, there are 3 Control panels that you will need to configure…

*Please note that the following screenshots are from MacOS 9.2 

Modem Set-up TCP/IP Remote Access 

How to select Control panels… 

Click and hold the Apple menu  

Select Control Panels
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Modem Set-up 

Select File > Configurations 

Double click on the Modem control panel 

The Modem control panel 
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Modem Set-up 

Click Make Active 

Rename & Click OK 

Click Duplicate 

*NOTE 1: For other connection methods eg. USB, 
then select whatever is being used.. (See Page 2 for 
more info on alternative connection methods) 
 
*NOTE 2: If these settings are ‘greyed out’ and 
unable to be edited, please follow the instructions on 
page 15 

From the ‘Connect via:’ drop-down menu, 
select Infrared Port
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Modem Set-up 

From the ‘Modem:’ drop-down menu, select either 
Ericsson Infrared or Nokia Infrared 

*Please note: 
If a modem is not listed for your device, or for using 
other manufacturers GPRS modem devices, please 
refer to the guidelines on Page 2 

Click the Close box 

*TIP – When connecting, if you 
receive a ’modem not responding’ 
error message, tick the Ignore dial 
tone box and try again… 

Click Save – the Modem is now set up 
 
You will now need to configure TCP/IP… 
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TCP/IP 

Select Control panels and double click o
the TCP/IP control panel 

n 

Select File > Configurations 

The TCP/IP Control Panel…

Click Duplicate 
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TCP/IP 

Click Make Active 

*NOTE: If these settings are ‘greyed 
out’ and unable to be edited, please 
follow the instructions on page 15 

1. From the ‘Connect via:’ drop-down 
menu, select PPP 
2. From the ‘Configure:’ drop-down menu, 
select Using PPP Server 
3. In the ‘Name server addr..” box enter: 

193.113.200.200 
193.113.200.201 

4. Click Options 

Rename & Click OK 
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Check that TCP/IP is Active & Click OK 

TCP/IP 

Click the Close box 

Click Save – TCP/IP is now set up 
 
 
You will now need to configure Remote Access… 
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Remote Access 

Select Control panels and double 
click on the Remote Access control 
panel 

Select File > Configurations 

The Remote Access Control panel 

Click Duplicate 
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Remote Access 

Rename & Click OK 

Click Make Active 

*NOTE: If these settings are ‘greyed 
out’ and unable to be edited, please 
follow the instructions on page 15 

1. Enter web 
2. Enter password 
3. Enter dialup number *99# 
IMPORTANT: This number initiates a 
GPRS connection via the GPRS modem on 
your mobile phone. You will need to 
configure your mobile phone with the O2 
MobileWeb Access Point Name (APN) in 
order for this to connect. See the guidelines 
on Page 2 for more information on using this 
number with different make/models of mobile 
phones. 
4. Click Options 

*99# 
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Remote Access 

Click the Connection tab and untick all the boxes 

Click the Protocol tab and untick 
all the boxes except the top box, 
then click OK 

Click the Close box 

*99# 

Click Save – Remote Access is now set up 
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Making the connection 

*99# 
Switch on Infrared on the mobile 
device and line it’s IR port up with the 
IR port on your Mac 
Open the Remote Access control 
panel again, as described on page 10, 
and click on Connect 
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Control panel accessibility 

If editing either the Modem, TCP/IP or Remote Access 
control panel is not possible, (similar to the picture on 
the left), then carry out the following process… 

 
Select User Mode from the Edit menu… 

Select Administration 
(The user will need to enter their password 
if this has been set) 
Click OK 

In Administration mode, you can see which of 
the settings are locked… 

Click on each ‘lock’ icon to unlock… 
It is now possible to edit the settings 
If required, re-lock the settings or change the User 
Mode back to it’s original setting.. 
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MacOS X 10.2.x set-up 

NOTE: This set-up guide for Mac OS X is based on an Infrared connection to the mobile 
device. Whilst it can be appreciated that not all Macs have Infrared installed, the 
following configuration guide equally applies to Bluetooth connections… 

Select System Preferences from the Apple Menu 

Click on Network 

OS X Network Preferences… 
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Select New Location 

Enter a name and click OK 

Configuring TCP/IP: 
Select Using PPP from the 
Configure: drop-down menu 
& enter the DNS server 
addresses in the Domain 
Name Servers box: 
  193.113.200.200 
  193.113.200.201 

Select IrDA Modem Port from the Show: 
drop-down menu 
 
*Select Bluetooth modem if you are using 
Bluetooth. (See Page 2 for more info on 
alternative connection methods) 
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*99# 

Configuring PPP: 
1. Select the PPP tab 
2. Enter Telephone Number *99# 
IMPORTANT: This number initiates a G
connection via the GPRS modem on your 
mobile phone. You will need to configure your 
mobile phone with the O2 MobileWeb Acces
Point Name (APN) in order for this to connect.
See the guidelines on Page 2 for more 
information on using this number with 
different make/models of mobile phones. 

PRS 

s 
 

3. Enter web 
4. Enter password 
5. Click PPP Options… 

Proxies: 
Click the Proxies tab… 
Check that all boxes are 
unticked… 

PPP Options: 
Leave all boxes unticked… 
‘Redial if busy’ can be set to 
user requirements… 
Click OK when finished 
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Untick Enable modem error correction 
& compression… 
Tick Show IrDA & Modem status in 
menu bar 
Click Apply Now 

From the ‘Modem:’ drop-down menu, 
select either Ericsson Infrared or 
Nokia Infrared (These modems can 
also be used when using Bluetooth) 

*Please note: 
If a modem is not listed for your device, 
or for using other manufacturers GPRS 
modem devices, please refer to the 
guidelines on Page 2 

Modem: 
Click the IrDA Modem tab 
*This will be labelled as 
‘Bluetooth’ if you have 
chosen to use the Bluetooth 
Modem… 

Click System Prefs on the Menu bar & select Quit… 

December 2003                              19  



 
GPRS Set-up for Apple Macintosh               
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Making the connection 

Activate Infrared on your mobile device 
 
Click the IrDA icon on the Menu bar and 
select Turn IrDA On. 

The above step can be ignored for Bluetooth 
connections. 
Instead you will need to first ‘pair’ your mobile 
device with the Mac (see page 21 for instructions 
on how to do this) and then select the Bluetooth 
Modem from the Modem Status menu. 

Click the Modem Status phone icon on the 
Menu bar and select Connect 

For Bluetooth connections, make sure that Bluetooth is 
powered on and ‘Discoverable’  
 
Follow the pairing instructions on page 21 to pair your 
Mac with your mobile device. 

Connecting using Bluetooth 

Once your devices are paired, check that 
you are connecting via Bluetooth from 
the Modem Status menu. 
 
Select Connect 
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Bluetooth pairing 
 
Setting up your mobile device 
 
Check the Bluetooth settings on your mobile device and make sure that Bluetooth is On (or ‘Discoverable’) and 
that the device is ‘shown to all’. This will ensure that your Mac will be able to detect the device when it’s within 
range. Please check your mobile device user manual if you are unsure how to do this. 
 
 
Pairing a USB Bluetooth adapter with your mobile device 
 

 

 

1. Insert the USB Bluetooth adapter into a USB port on your Mac

 

 

 

 

 

 

2. Select System Preferences from the Apple menu

3. Under Hardware, click on Bluetooth
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5. Click the Devices tab 
 
6. Click Pair New Device 

7. Your Mac will now search for any Bluetooth devices 
within range and when your mobile device is detected, 
it will show up in the Device window 

*IMPORTANT - wait until the search completes before 
continuing… 

4. Click the Settings tab and make sure that 
Bluetooth power is turned on. 
 
Check that the ‘Discoverable’ and ‘Show 
Bluetooth Status in  the menu bar’ options 
are ticked. If you require more security, then 
tick the ‘Require Authentication’ and ‘Use 
Encryption’ boxes. 
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8. Once the search has completed, select the 
device that you are using eg. Nokia 8910i, and 
Click on Pair. 

 

 

Your Mac will now attempt to pair with your 
mobile device. 
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 10. Your mobile device will now prompt you 
to Pair with your Mac. 

Depending on which particular mobile device 
that you are using, you will be prompted to 
accept the pairing and enter your passcode. 
(This is the same passcode that you entered 
on your Mac) 

IMPORTANT NOTE for Nokia 6310i users: 
If you receive a ‘Disconnected’ error 
message on the device, then disregard this 
and proceed. 
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11. On your Mac, choose Internet Access for 
the service, and click OK. 

Your Mac is now paired to your mobile 
device. It will now be possible to create a 
GPRS connection. See page 20 for 
information on how to connect. 
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