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This manual describes the functions and operating procedures of GateOPC.  To ensure 
correct use, please read this manual thoroughly before beginning operation.  After 
reading the manual, keep it in a convenient location for quick reference in the event a 
question arises.
GateOPC is a software program that uses the OPC (OLE for process control) protocol to 
acquire measurement data and pass that data to DAQLOGGER or Remote Monitor.

Note
•	 The contents of this manual are subject to change without prior notice as a result of 

improvements in the software’s performance and functions.  
•	 Every effort has been made in the preparation of this manual to ensure the accuracy 

of its contents.  However, should you have any questions or find any errors, please 
contact your nearest YOKOGAWA representative as listed on the back cover of this 
manual.  

•	 Copying or reproducing all or any part of the contents of this manual without the 
permission of Yokogawa Electric Corporation is strictly prohibited.  

•	 Use of this product (software and this manual) on more than one computer at the 
same time is prohibited. Use by more than one user is also prohibited.

•	 Transfer or lending of this product to any third party is prohibited.
•	 Yokogawa Electric Corporation provides no guarantees other than for physical 

deficiencies found on the original disk or this manual upon opening the product 
package.

•	 License numbers will not be reissued. Please keep the license number in a safe 
place.

Copyrights
•	 Copyrights for the programs included on the CD-ROM are attributable to Yokogawa 

Electric Corporation.

Trademarks
•	 DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or 

trademarks of Yokogawa Electric Corporation.
•	 Microsoft, Windows, and Windows Vista are registered trademarks or trademarks of 

Microsoft Corporation in the United States and/or other countries.
•	 Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems 

Incorporated.
•	 Company and product names that appear in this manual are registered trademarks or 

trademarks of their respective holders.
•	 The company and product names used in this manual are not accompanied by the 

registered trademark or trademark symbols (® and ™).

Revisions
•	 1st Edition		 June 2003
•	 2nd Edition		 February 2003
•	 3rd Edition		 June 2007
•	 4th Edition		 March 2008
•	 5th Edition		 January 2009
•	 6th Edition		 January 2011
•	 7th Edition		 October 2011
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Software License Agreement

IMPORTANT - PLEASE READ CAREFULLY BEFORE INSTALLING OR USING:
THANK YOU VERY MUCH FOR SELECTING SOFTWARE OF YOKOGAWA ELECTRIC CORPORATION ("YOKOGAWA"). BY INSTALLING OR OTHERWISE USING THE 
SOFTWARE PRODUCT, YOU AGREE TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO NOT AGREE, DO NOT INSTALL NOR USE 
THE SOFTWARE PRODUCT AND PROMPTLY RETURN IT TO THE PLACE OF PURCHASE FOR A REFUND, IF APPLICABLE. 

Software License Agreement
1. Scope
This Agreement applies to the following software products and associated documentation of Yokogawa (collectively, "Software Product"). Unless otherwise provided by 
Yokogawa, this Agreement applies to the updates and upgrades of the Software Product which may be provided by Yokogawa.
Software Product:  DAQWORX (It is limited to each software that you bought).

2. Grant of License
2.1	Subject to the terms and conditions of this Agreement, Yokogawa hereby grants to you a non-exclusive and non-transferable right to use the Software Product on a 

single or, the following specified number of, computer(s) and solely for your internal operation use, in consideration of full payment by you to Yokogawa of the license fee 
separately agreed upon.

	 Granted number of License:  1 (one)
2.2	Unless otherwise agreed or provided by Yokogawa in writing, the following acts are prohibited:
	 a)	 to reproduce the Software Product, except for one archival copy for backup purpose, which shall be maintained with due care subject to this Agreement;
	 b)	� to sell, lease, distribute, transfer, pledge, sublicense, make available via the network or otherwise convey the Software Product or the license granted herein to any 

other person or entity;
	 c)	 to use the Software Product on any unauthorized computer via the network;
	 d)	� to cause, permit or attempt to dump, disassemble, decompile, reverse-engineer, or otherwise translate or reproduce the Software Product into source code or other 

human readable format, or to revise or translate the Software Product into other language and change it to other formats than that in which Yokogawa provided;
	 e)	 to cause, permit or attempt to remove any copy protection used or provided in the Software Product; or
	 f)	 to remove any copyright notice, trademark notice, logo or other proprietary notices or identification shown in the Software Product.
2.3	Any and all technology, algorithms, know-how and process contained in the Software Product are the property or trade secret of Yokogawa or licensors to Yokogawa. 

Ownership of and all the rights in the Software Product shall be retained by Yokogawa or the licensors and none of the rights will be transferred to you hereunder. 
2.4	You agree to maintain the aforementioned property and trade secret of Yokogawa or licensors and key codes in strict confidence, not to disclose it to any party other 

than your employees, officers, directors or similar staff who have a legitimate need to know to use the Software Product and agreed in writing to abide by the obligations 
hereunder.

2.5	Upon expiration or termination of this Agreement, the Software Product and its copies, including extracts, shall be returned to Yokogawa and any copies retained in your 
computer or media shall be deleted irretrievably. If you dispose of media in which the Software Product or its copy is stored, the contents shall be irretrievably deleted.

2.6	The Software Product may contain software which Yokogawa is granted a right to sublicense or distribute by third party suppliers, including affiliates of Yokogawa ("Third 
Party Software"). If suppliers of the Third Party Software ("Supplier") provide special terms and conditions for the Third Party Software which differ from this Agreement, 
the special terms and conditions separately provided by Yokogawa shall prevail over this Agreement. Some software may be licensed to you directly by Supplier. 

2.7	The Software Product may contain open source software ("OSS"), for which the special terms and conditions separately provided by Yokogawa shall take precedence 
over this Agreement.

3. Restrictions on Application
3.1	Unless otherwise agreed in writing between you and Yokogawa, the Software Product is not intended, designed, produced or licensed for use in relation to aircraft 

operation or control, ship navigation or marine equipment control, or ground facility or device for support of the aforesaid operation or control, or for use in relation to rail 
facility, nuclear related facility, radiation-related equipment, or medical equipment or facility, or under any other circumstances which may require high safety standards.

3.2	If the Software Product is used for the abovementioned purposes, neither Yokogawa nor Supplier assumes liability for any claim or damage arising from the said use 
and you shall indemnify and hold Yokogawa, Supplier, their affiliates, subcontractors, officers, directors, employees and agents harmless from any liability or damage 
whatsoever, including any court costs and attorney's fees, arising out of or related to the said use.

4. Limited Warranty
4.1	The Software Product shall be provided to you on an "as is" basis at the time of delivery and except for physical damage to the recording medium containing the Software 

Product, Yokogawa and Supplier shall disclaim all of the warranties whatsoever, express or implied, and all liabilities therefrom.  If any physical defect is found on the 
recording medium not later than twelve (12) months from delivery, Yokogawa shall replace such defective medium free of charge, provided that the defective medium 
shall be returned to the service office designated by Yokogawa at your expense within the said twelve (12) months.  THIS LIMITED WARRANTY PROVIDED IN THIS 
CLAUSE IS IN LIEU OF ALL OTHER WARRANTIES OF ANY KIND WHATSOEVER AND YOKOGAWA HEREBY DISCLAIMS ALL OTHER WARRANTIES RELATING 
TO THE SOFTWARE PRODUCT, WHETHER EXPRESSED OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR ANY PARTICULAR PURPOSE, NON-INFRINGEMENT, QUALITY, FUNCTIONALITY, APPROPRIATENESS, ACCURACY, RELIABILITY AND RECENCY.  
IN NO EVENT SHALL YOKOGAWA WARRANT THAT THERE IS NO INCONSISTENCY OR INTERFERENCE BETWEEN THE SOFTWARE PRODUCT AND OTHER 
SOFTWARE NOR SHALL BE LIABLE THEREFOR. The warranty provisions of the applicable law are expressly excluded to the extent permitted.

4.2	At the sole discretion of Yokogawa, Yokogawa may upgrade the Software Product to the new version number ("Upgrade") and make it available to you at your expense 
or free of charge as Yokogawa deems fit.  In no event shall Yokogawa be obliged to upgrade the Software Product or make the Upgrade available to you.

4.3	Certain maintenance service may be available for some types of Software Product at Yokogawa's current list price. Scope and terms and conditions of the maintenance 
service shall be subject to those separately provided by Yokogawa. Unless otherwise provided in Yokogawa catalogues or General Specifications, maintenance services 
will be available only for the latest version and the immediately preceding version. In no event will service for the immediately preceding version be available for more than 
5 years after the latest version has been released. In addition, no service will be provided by Yokogawa for the Software Product which has been discontinued for more 
than 5 years. Notwithstanding the foregoing, maintenance service may not be available for non-standard Software Product. Further, in no event shall Yokogawa provide 
any service for the Software Product which has been modified or changed by any person other than Yokogawa.
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5. Infringement
5.1	If you are warned or receive a claim by a third party that the Software Product in its original form infringes any third party's patent (which is issued at the time of delivery 

of the Software Product), trade mark, copyright or other intellectual property rights ("Claim"), you shall promptly notify Yokogawa thereof in writing.
5.2	If the infringement is attributable to Yokogawa, Yokogawa will defend you from the Claim at Yokogawa's expense and indemnify you from the damages finally granted by 

the court or otherwise agreed by Yokogawa out of court. The foregoing obligation and indemnity of Yokogawa shall be subject to that i) you promptly notify Yokogawa of 
the Claim in writing as provided above, ii) you grant to Yokogawa and its designees the full authority to control the defense and settlement of such Claim and iii) you give 
every and all necessary information and assistance to Yokogawa upon Yokogawa's request.

5.3	If Yokogawa believes that a Claim may be made or threatened, Yokogawa may, at its option and its expense, either a) procure for you the right to continue using the 
Software Product, b) replace the Software Product with other software product to prevent infringement, c) modify the Software Product, in whole or in part, so that it 
become non-infringing, or d) if Yokogawa believes that a) through c) are not practicable, terminate this Agreement and refund you the paid-up amount of the book value 
of the Software Product as depreciated.

5.4	Notwithstanding the foregoing, Yokogawa shall have no obligation nor liability for, and you shall defend and indemnify Yokogawa and its suppliers from, the Claim, if the 
infringement is arising from a) modification of the Software Product made by a person other than Yokogawa, b) combination of the Software Product with hardware or 
software not furnished by Yokogawa, c) design or instruction provided by or on behalf of you, d) not complying with Yokogawa's suggestion, or e) any other causes not 
attributable to Yokogawa.

5.5	This section states the entire liability of Yokogawa and its suppliers and the sole remedy of you with respect to any claim of infringement of a third party's intellectual 
property rights. Notwithstanding anything to the contrary stated herein, with respect to the claims arising from or related to the Third Party Software or OSS, the special 
terms and conditions separately provided for such Third Party Software or OSS shall prevail.

6. Limitation of Liability
6.1	EXCEPT TO THE EXTENT THAT LIABILITY MAY NOT LAWFULLY BE EXCLUDED IN CONTRACT, YOKOGAWA AND SUPPLIERS SHALL NOT BE LIABLE TO ANY 

PERSON OR LEGAL ENTITY FOR LOSS OR DAMAGE, WHETHER DIRECT, INDIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES, 
OR OTHER SIMILAR DAMAGES OF ANY KIND, INCLUDING WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, 
LOSS OR DESTRUCTION OF DATA, LOSS OF AVAILABILITY AND THE LIKE, ARISING OUT OF THE USE OR INABILITY TO USE OF THE SOFTWARE PRODUCT, 
OR ARISING OUT OF ITS GENERATED APPLICATIONS OR DATA, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, WHETHER BASED IN 
WARRANTY (EXPRESS OR IMPLIED), CONTRACT, STRICT LIABILITY, TORT (INCLUDING NEGLIGENCE), OR ANY OTHER LEGAL OR EQUITABLE GROUNDS.  
IN NO EVENT YOKOGAWA AND SUPPLIER'S AGGREGATE LIABILITY FOR ANY CAUSE OF ACTION WHATSOEVER (INCLUDING LIABILITY UNDER CLAUSE 
5) SHALL EXCEED THE DEPRECIATED VALUE OF THE LICENSE FEE PAID TO YOKOGAWA FOR THE USE OF THE CONCERNED PART OF THE SOFTWARE 
PRODUCT. If the Software Product delivered by Yokogawa is altered, modified or combined with other software or is otherwise made different from Yokogawa catalogues, 
General Specifications, basic specifications, functional specifications or manuals without Yokogawa's prior written consent, Yokogawa shall be exempted from its 
obligations and liabilities under this Agreement or law.

6.2	Any claim against Yokogawa based on any cause of action under or in relation to this Agreement must be given in writing to Yokogawa within three (3) months after the 
cause of action accrues. 

7. Export Control
You agree not to export or provide to any other countries, whether directly or indirectly, the Software Product, in whole or in part, without prior written consent of Yokogawa. 
If Yokogawa agrees such exportation or provision, you shall comply with the export control and related laws, regulations and orders of Japan, the United States of America, 
and any other applicable countries and obtain export/import permit and take all necessary procedures under your own responsibility and at your own expense. 

8. Audit; Withholding
8.1	Yokogawa shall have the right to access and audit your facilities and any of your records, including data stored on computers, in relation to the use of the Software Product 

as may be reasonably necessary in Yokogawa's opinion to verify that the requirements of this Agreement are being met.
8.2	Even after license being granted under this Agreement, should there be any change in circumstances or environment of use which was not foreseen at the time of delivery 

and, in Yokogawa's reasonable opinion, is not appropriate for using the Software Product, or if Yokogawa otherwise reasonably believes it is too inappropriate for you to 
continue using the Software Product, Yokogawa may suspend or withhold the license provided hereunder.

9. Assignment
If you transfer or assign the Software Product to a third party, you shall expressly present this Agreement to the assignee to ensure that the assignee comply with this 
Agreement, transfer all copies and whole part of the Software Product to the assignee and shall delete any and all copy of the Software Product in your possession 
irretrievably. This Agreement shall inure to the benefit of and shall be binding on the assignees and successors of the parties.

10. Termination
Yokogawa shall have the right to terminate this Agreement with immediate effect upon notice to you, if you breach any of the terms and conditions hereof. Upon termination of 
this Agreement, you shall promptly cease using the Software Product and, in accordance with sub-clause 2.5, return or irretrievably delete all copies of the Software Product, 
certifying the same in writing. In this case the license fee paid by you for the Software Product shall not be refunded. Clauses 2.4 and 2.5, 3, 5, 6 and 11 shall survive any 
termination of this Agreement.

11. Governing Law; Disputes
This Agreement shall be governed by and construed in accordance with the laws of Japan. 
 Any dispute, controversies, or differences which may arise between the parties hereto, out of, in relation to or in connection with this Agreement ("Dispute") shall be resolved 
amicably through negotiation between the parties based on mutual trust. Should the parties fail to settle the Dispute within ninety (90) days after the notice is given from either 
party to the other, the Dispute shall be addressed in the following manner:
	 (i)	 If you are a Japanese individual or entity, the Dispute shall be brought exclusively in the Tokyo District Court (The Main Court) in Japan.
	 (ii)	� If you are not a Japanese individual or entity, the Dispute shall be finally settled by arbitration in Tokyo, Japan in accordance with the Commercial Arbitration Rules 

of the Japan Commercial Arbitration Association. All proceedings in arbitration shall be conducted in the English language, unless otherwise agreed. The award of 
arbitration shall be final and binding upon both parties, however, each party may make an application to any court having jurisdiction for judgment to be entered on 
the award and/or for enforcement of the award.

12. Miscellaneous
12.1	 This Agreement supersedes all prior oral and written understandings, representations and discussions between the parties concerning the subject matter hereof to 

the extent such understandings, representations and discussions should be discrepant or inconsistent with this Agreement.
12.2	 If any part of this Agreement is found void or unenforceable, it shall not affect the validity of the balance of the Agreement, which shall remain valid and enforceable 

according to its terms and conditions. The parties hereby agree to attempt to substitute for such invalid or unenforceable provision a valid or enforceable provision that 
achieves to the greatest extent possible the economic, legal and commercial objectives of the invalid or unenforceable provision.

12.3	 Failure by either party to insist on performance of this Agreement or to exercise a right when entitled does not prevent such party from doing so at a later time, either 
in relation to that default or any subsequent one.

End of document

Software License Agreement
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Overview of This Manual

Structure of This Manual
This user’s manual consists of the following chapters.
Chapter Title Description
1 Overview Gives an overview of the GateOPC software.

Lists the PC requirements for running GateOPC and 
gives information about system configuration.

2 Operating Procedure Lists procedures for entering environment and data 
acquisition interval settings, running the program, and 
viewing the status display.

3 Detailed Description of 
Functions

Provides a detailed description of the functions of 
GateOPC.
Lists error messages, their causes, and their corrective 
actions.

Index An alphabetical index of the manual’s contents.

Scope of This Manual
This manual does not explain the basic operations of your PC's operating system (OS).
For information regarding the basic operations of Windows, see the Windows user’s 
manual.

Conventions Used in This Manual
•	 Units
	 K	 Denotes 1024.	 Example: 10 KB
	 M	 Denotes 1024K.	 Example: 10 MB
	 G	 Denotes 1024M.	 Example:   2 GB

•	 Boldface Type
	 Hardware and software controls that the user manipulates such as dialog boxes, 

buttons, and menu commands are often set in boldface type.

•	 Subheadings
	 On pages in chapters 1 through 3 that describe operating procedures, the following 

subheadings are used to distinguish the procedure from their explanations.

			 

Procedure This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are
written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

			   Note Calls attention to information that is important for proper operation 
of the instrument.
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Chapter 1	 Overview

1.1	 Overview of GateOPC Functions

GateOPC is a software program that uses the OPC (OLE for process control) protocol—
Microsoft’s data exchange technology that is supported in a wide range of industries—to 
acquire measurement data and pass that data to Yokogawa’s DAQLOGGER or Remote 
Monitor. Using GateOPC allows you to acquire and monitor data on DAQLOGGER or 
Remote Monitor that comes from Yokogawa recorders or other companies’DCS and PLC 
devices with OPC server functionality.
Yokogawa’s DAQLOGGER is a software program that allows users to open a connection 
from their PC to various kinds of Yokogawa recorders (the µR, VR, DARWIN, DX, MV, 
and CX) and perform data logging and monitoring.
Yokogawa’s Remote Monitor is application software that enables monitoring of data 
logged by recorders or data logging software.

Features
•	 Acts as an OPC client, connecting to an OPC DA (data access) server (hereinafter 

OPC server).
•	 Can acquire data from 16 OPC servers simultaneously.
•	 Measurement can be performed at intervals of up to 0.5 seconds*.

*	 However, DAQLOGGER’s shortest interval is 1 second. Also, the maximum speed of 0.5 
seconds may not be attainable depending on the amount of data being read, the response 
time of the device, and the communication speed. 
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1.2	 System Overview

System
This software can acquire data from OPC DA revision 2.0 servers.

Required Operating Systems
Run DAQWORX under any of the following operating systems.
•	 Windows 2000 Professional SP4
•	 Windows XP Home Edition SP3
•	 Windows XP Professional SP3 (excluding Windows XP Professional x64 Editions)
•	 Windows Vista Home Premium SP2 (excluding the 64-bit editions)
•	 Windows Vista Business SP2 (excluding the 64-bit editions)
•	 Windows 7 Home Premium, SP1 (32-bit and 64-bit editions)
•	 Windows 7 Professional, SP1 (32-bit and 64-bit editions)
The language displayed by the software under different language versions of the OS are 
as follows.
OS Language Software Language
Japanese Japanese
Other English

Hardware Requirements
The following hardware and software are required to use GateOPC.
•	 PC:						�      A PC that runs one of the OS above, and that meets the 

following CPU and memory requirements.
								        When Using Windows 2000 or Windows XP
								        Pentium 4, 1.6 GHz or faster Intel x64 or x86 processor; 512 	

							       MB or more of memory
								        When Using Windows Vista
								        Pentium 4, 3 GHz or faster Intel x64 or x86 processor; 2 GB or 	

							       more of memory
								        When Using Windows 7
								        32-bit edition: Intel Pentium 4, 3 GHz or faster x64 or x86 	

							       processor; 2 GB or more of memory 
								        64-bit edition: Intel x64 processor that is equivalent to Intel 	

							       Pentium 4, 3 GHz or faster; 2 GB or more of memory
•	 Free disk space: 	 200 MB or more
•	 Communication device:  �An Ethernet (when connecting to DAQLOGGER or Remote 

Monitor) port that is recognized by the operating system.
•	 CD-ROM drive: 		  Used to install the software
•	 Peripheral devices:	 A mouse supported by the operating system
•	 GP-IB port:				�   Required for GPIB communications between the software and 

a WT series instrument
•	 Monitor:					    A video card that is recommended for the OS and a display 	

							       that is supported by the OS, has a resolution of 1024×768 or 	
							       higher, and that can show 65,536 colors (16-bit, high color) or 	
							       more.
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1.2  System Overview

System Configuration

		
OPC ServerOPC connection

Data transfer

PLC, DCS etc

Monitor server protocol
TCP/IP connection

Data acquisition Remote Monitor

GateOPC

It is recommended that you run GateOPC and DAQLOGGER or Remote Monitor on 
separate PCs depending on the number of devices that the system supports and other 
factors affecting the load.

Software Configuration

	

DAQLOGGER

Ethernet

Ethernet

GateOPC

Writes to file

File read out

OPC server OPC server OPC server OPC server

OPC interface

Remote Monitor

Environment setting 
functions

Displays execution 
status

Environment
settings file

Executable
function

Status information

GateOPC Configurator consists of three separate software functions. The role of each 
function within the configurator is as follows:
•	 Environment Setting Functions
	 These functions allow the user to enter various settings required by the executable 

function for communications with OPC servers, as well as those required for data 
transfers to and from DAQLOGGER and Remote Monitor. The user can also use 
the environment setting functions to start/stop the executable function, or view the 
execution status.

•	 Executable Function
	 The function reads data from OPC servers at fixed intervals. Up to 16 OPC servers 

can be linked. It also acts as a monitor server, transferring data to DAQLOGGER and 
Remote Monitor.

•	 Status Display Function
	 The execution status of the executable software can be displayed, as well as the 

connection status of DAQLOGGER and Remote Monitor.
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Chapter 2	 Operating Procedure

2.1	 Running and Exiting GateOPC

Running the Software
Procedure

1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
GateOPC > GateOPC.

	 The GateOPC Configurator dialog box opens.

					   

Note
•	 When you start GateOPC it is restored to the same status that was active during the 

previous session.
•	 If the program is closed while a process or service is running, the license will be considered 

to be “in use.” If the message, “Invalid license number. Please reinstall.” appears when 
restarting the program, it may indicate that the user is attempting to run a Gate program in 
excess of the number of available licenses.

Starting GateMX/MW in Acquisition Start Mode
Procedure

1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
GateOPC > GateOPC, then right-click GateOPC and select Create Shortcut.  

2.	 Right-click the shortcut icon and select Properties.
3.	 Choose the Shortcut tab, then add /START to the right of the path in the Target 

box and click OK.

					   

4.	 Choose the shortcut from the Windows Start menu. The connection status of the 
previous session is restored, and acquisition begins.

Exiting the Software
Procedure

1.	 Choose File > Exit from the menu bar, or click the X button at the right end of 
the title bar.

	 GateOPC closes.



2-2 IM WX1-04E

2.2	 Entering Environment Settings

When you start GateOPC, the configurator opens allowing you to perform the following:
•	 Specify an OPC server
•	 Connect to an OPC server
•	 Edit an OPC server item
•	 Create/delete groups
•	 Add/delete group items
•	 Set item properties
•	 Test acquisition
•	 Run/stop the executable function (see section 2.3)
•	 Enter TCP/IP port numbers for monitor servers (see section 2.3)

Specifying an OPC Server
Procedure

1.	 Click the Addition of an OPC server button or choose File > Addition of an OPC 
server from the menu bar.

					   
The Addition of an OPC server button

	 The Select OPC Server dialog box opens.

					   

Browse button

Click to display a list and 
select a system number

2.	 Enter settings for each item.

	 Computer:	 Select either Local or Remote.

	 Computer Name:	� Specify if you selected a remote computer.  Enter the name of 
the computer when using DCOM.  Click Browse to open the 
Browse Computers dialog box. Select a computer.
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2.2  Entering Environment Settings

	 ProgID:		�  Click the Search button to display the ProgID list, then make a 
selection.

				�   If Local was selected above, the software searches for an OPC 
server on the local computer, then displays the results.

				�   If you selected Remote above, the software searches for a 
remote computer having the specified name, then searches 
that computer for an OPC server. Up to 80 characters can be 
entered for a computer name. However, if Local was selected, 
the ProgID of the local computer is displayed.

	 System No:	� Select the system number to assign to the OPC server. You 
can display the OPC server list (see “Browsing OPC Server 
Items” in chapter 3) to see which OPC servers are assigned to 
which systems.

				   Up to 16 OPC servers can be connected.

3.	 Click OK.

	 A list showing system numbers assigned to OPC servers is shown in the bottom 
of the GateOPCConfiguration screen.

Connecting/Disconnecting OPC Servers
Procedure

Connecting to Servers
1.	 Click the Connection button or choose File > Connection from the menu bar.

					   
Connection button

	 A connection is opened with all active OPC servers.

Note
	 If the connection to an OPC server is cut, the causes may include the following:

•	 The software disconnected from the OPC server (see “Disconnecting from the Servers” 
below).

•	 The connection was cut due to the execution of a process or service.
•	 The connection was cut due to a problem on the OPC server.

Disconnecting from Servers
1.	 Choose File > Disconnection from the menu bar.
	 Connections with the active OPC servers are closed.

Note
	 The following restrictions apply if the connections to OPC servers are cut.

•	 OPC server items can not be displayed.
•	 Groups can not be added or deleted.
•	 Group names can not be changed.
•	 Groups items can not be added or deleted.
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2.2  Entering Environment Settings

Displaying the OPC Server List, Changing Settings, and Deleting Servers
Procedure

Displaying the OPC Server List
1.	 Click the Show or hide OPC server list button or choose View > OPC Server List 

from the menu bar.

	 The OPC server list is displayed.

					   

Click a system number to display that system’s 
window in the front of the screen

OPC server listUse button Click a cell to select it for editing

The show/hide OPC server list button

Changing OPC Server Settings
2.	 Click the button in the Use column to turn the item ON or OFF (Use/Don’t use).

	 ON (blue)

	 OFF (gray)

Note
The Use button is active when running as a process or a service (see section 2.3). When 
running as a process or service, you can not connect to OPC servers that are turned OFF.

3.	 Click the Scan Interval box and change the value.

4.	 Click the button in the Use Retry column to turn communication retry ON or OFF. 
If turned ON, enter a Retry Interval.

	 ON (blue)

	 OFF (gray)

	 Retry interval setting range: 30–3600 seconds.

Deleting OPC Servers
2.	 Select the system number of the OPC server you wish to delete.

3.	 Click the Delete button.

	 The selected OPC server is deleted from the list.
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Displaying the OPC Server and Group Trees, and Editing Settings
1.	 You can add new OPC servers (see page 2-2, “Specifying an OPC Server”).

	 The OPC Server window is displayed in the GateOPCConfigurator screen, and 
the OPC Server Tree and Group Tree are displayed to the left of that window.

Note
The device, group, tag, items, and other information specified for the connected OPC servers is 
displayed.

OPC server tree
OPC group tree

Drag the mouse pointer on these locations to change column widths

Displaying the OPC Server Tree
2.	 Click the Server Root folder located to the left of the OPC server window inside 

the GateOPCConfigurator screen.

	 The server list is displayed.

					   

	 The following items are displayed.

	 Item ID: 		�  The added item IDs (see “Adding and Deleting Items”, 2 pages 
down) are displayed.

	 Data Type: 	� The type indicated by property ID1 (item canonical data type) 
(see “Adding Items to Groups” in section 3.2 for the symbol).

	 Access Right: 	� The access restrictions indicated by property ID5 (item access 
rights).

				   OPC_READABLE			   Read

				   OPC_WRITEABLE			   Write

				   OPC_READABLE|OPC_WRITEABLE	 Read/Write

		 Unit:		�  The string obtained from property ID100 (EU Unit).

				   If no property ID100 exists for the item, this cell is blank.

		 Description:	 The string obtained from property ID101 (item description).

				   If no property ID101 exists for the item, this cell is blank.

2.2  Entering Environment Settings



2-6 IM WX1-04E

Displaying OPC Groups
2.	 Click the Group Root folder located to the left of the OPC server dialog box inside 

the GateOPCConfigurator screen.

	 The group list is displayed.

					   
Click

	 The following Information is displayed in the list.

	 Group Name: 	 Specified names of each group

	 UpdateRate (ms): 	Display update interval (in units of msec)

	 Deadband (%): 	 Deadband expressed as a percentage

Changing OPC Group Settings
3.	 Click the cell of the item you wish to change then enter the new setting value.

Displaying and Changing Item Properties and Adding and Deleting Items
Displaying Item Properties

1.	 Click the group name located in the Group Root folder to the left of the OPC 
server window.

	 The item properties are displayed in the OPC server window.

Click a group to display item properties Click to display the color setting dialog box

	 The following information is displayed.

	 Item ID:		  The specified item ID is displayed.

	 Span Hight:	 The setting range is -1E16 to 1E16.

				�   The number of digits before the decimal point is determined by 
the decimal place setting.

				�   The initial value is that of the item’s property ID102 (High EU).  
If this property ID has not been defined on the OPC server, the 
value is set to 10.000.

	 Span Low:	 The setting range is -1E16 to 1E16.

				�   The number of digits before the decimal point is determined by 
the decimal place setting.

				�   The initial value is that of the item’s property ID103 (Low EU).  
If this property ID has not been defined on the OPC server, the 
value is set to -10.000.

	 Tag Name:	 Up to 16 alphanumeric characters can be input.

	 Unit:		�  Up to 6 alphanumeric characters can be input. Enter only 
English alphanumeric characters.

				   The default value is obtained from property ID100 (EU Unit).

2.2  Entering Environment Settings
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	 Dec Pos: 	 Select a decimal place from 0 to 4.

	 Color:  		  Select from the color selection dialog box.

	 Value:  		�  Displays the values during test execution. The number of digits 
before the decimal point is determined by the decimal place 
setting.

Changing Item Properties
2.	 Click a Span Hight, Span Low, Tag Name, or Unit cell, then change the setting.

3.	 If you click a Dec Pos cell a list appears.  Make a selection from the list.

4.	 If you click a Color cell, the Color setting dialog box appears.  Select a color in the 
dialog box.

					   

Adding and Deleting Items

Note
If the item does not exist on the OPC server, it cannot be added or deleted.

•	 Adding and Deleting Items from the Menu Bar
1.	 Click the group name containing the item you wish to add or delete in the Group 

Root folder on the left side of the OPC server window.

2.	 Choose Edit > Add Item or Delete.

•	 Adding and Deleting Items from the Group Name List
1.	 Right-click the group name containing the item you wish to add or delete in the 

Group Root folder on the left side of the OPC server window.

	 The following menu is displayed.

2.	 Choose Add Item or Delete.

2.2  Entering Environment Settings



2-8 IM WX1-04E

Creating and Deleting Groups, and Changing Group Names
Procedure

Creating Groups
•	 Using a Tool Button or Menu Command to Create Groups

1.	 Click the Group creation button or choose Edit > Group Creation from the menu 
bar.

					   
Group creation button

	 The Group creation dialog box opens.

					   

2.	 Enter settings for each item.

	 Group Name: 	� Up to 30 alphanumeric characters can be input. Up to 50 
groups can be created.  However, fewer than 50 groups may 
be allowed depending on the OPC server.  The default value is 
GroupN (where N indicates the order in which the group was 
created).  If the software fails to create the group, an error is 
displayed.  groups can not have the same name.

	 UpdateRate: 	� The setting range depends on the connected OPC server.  See 
the specifications for the OPC server.

	 Deadband: 	� You can enter the percent deadband, specifying when the 
groups will be updated. The setting range depends on the 
connected OPC server. See the specifications for the OPC 
server.

3.	 Click OK.

	 The group is created.

•	 Using the Group List to Create Groups
1.	 Right-click the Group Root folder name located in the left side of the OPC server 

dialog box.

	 The shortcut menu is displayed.

					   

2.	 Click Create New Group.

2.2  Entering Environment Settings
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Deleting Groups
•	 Using the Menu Bar to Delete Groups

1.	 Select the group you wish to delete.

2.	 Choose Edit > Delete from the menu bar.

	 The group is deleted.

•	 Using the Group List to Delete Groups
1.	 Right-click the group name located in the Group Root folder on the left side of the 

OPC server window.

	 The shortcut menu is displayed.

					   

2.	 Select Delete.

Changing a Group Name
•	 Using the Group List to Change a Group Name

1.	 Click a cell in the group list containing a group name.

					   

Click to change the group name

2.	 Change the name.

•	 Using the Group List to Change Group Names
1.	 Select a group name located in the Group Root folder to the left of the OPC server 

window.

2.	 Click the selected group name.

	 The name can now be changed.

					   

Click to select for editing

3.	 Change the group name.

2.2  Entering Environment Settings
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 Adding and Deleting Group Items
Note

These procedures are available only when connected with the OPC server.

Procedure
Adding Items
Up to 32 group items can be added.

•	 Using the Menu Bar to Add Items
1.	 Select the group to which you wish to add an item.

2.	 Choose Edit > Add Item.

	 The Add Item dialog box opens.

					   

3.	 Enter an item ID.

4.	 Click OK.

	 The item is added.

•	 Using the Group List to Add Items
1.	 Right-click the group name located in the Group Root folder on the left side of the 

OPC server window.

	 The following menu is displayed.

					   

2.	 Choose Add Item.

	 The Add Item window opens.

3.	 Follow steps 3 and 4 above under “Using the Menu Bar to Add Items.”

Deleting Items
•	 Using the Menu to Delete Items

1.	 Right-click the item you wish to delete.

	 The following menu is displayed.

2.	 Select Delete.

•	 Using the Delete Key to Delete Items
1.	 Click the item ID you wish to delete.

2.	 Press the Delete key on the PC.

2.2  Entering Environment Settings
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Executing the Test
Procedure

Executing the Test
1.	 Click the group name located in the Group Root folder to the left of the OPC 

server window.

	 The item properties are displayed in the right of the window.

					   

Test execution button Stop button

2.	 Select the item ID for which you wish to perform the test.

3.	 Click the Test Execution button on the tool bar or choose Execute > Test from the 
menu bar.

	 The test results are displayed in the value column of the item properties.

		

Stop button Test results are displayed here

Scrolls the screen

Stops the execution of the test
4.	 Click the Stop button on the tool bar or choose Execute > Stop from the menu 

bar.

2.2  Entering Environment Settings
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2.3	 Loading Data from the OPC Server and 
Transferring It to DAQLOGGER or Remote 
Monitor

By running the executable function, you can connect to and acquire data from the 
OPC server, then transfer that data to DAQLOGGER or Remote Monitor via Ethernet. 
GateOPC’s executable function acts as the client of a DAQLOGGER or Remote Monitor 
that is running as the monitor server.

Procedure
Connecting to OPC Servers

1.	 Turn ON the OPC servers you wish to connect to in the Use column of the OPC 
server list.

			 

2.	 Connect to the OPC servers (see page 2-3, “Connecting/Disconnecting OPC 
Servers”).

Entering TCP/IP Port Numbers for Monitor Servers 
3.	 Choose File > Port number from the menu bar.

	 The PortSetting dialog box opens.

					   

4.	 Enter the port number of the DAQLOGGER or Remote Monitor to which you wish 
to connect.

Note
•	 See the DAQLOGGER and Remote Monitor user’s manuals to obtain the correct port 

numbers.
•	 Up to 16 GateOPCs can be connected simultaneously to DAQLOGGER or Remote Monitor.
•	 DAQLOGGER’s recorder model determination function identifies the system number only.
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Running as a Service or as a Process
5.	 Click the Service execution or Process execution button on the tool bar, or choose 

Execute > Process or Service from the menu bar.

	 A dialog box appears asking you whether or not to save before execution.

6.	 Click OK.

	 Data is loaded at the specified scan interval. The data is displayed in the value 
column.

Note
Execution occurs on OPC servers whose Use buttons are turned ON (blue) in the OPC server 
list. 

Process execution button
Service execution button

Stop button

OPC server list Communication retry is performed on all systems 
whose buttons are turned ON

All systems whose Use buttons are turned ON (blue) are run as a service or process

	 The GateOPC Information Software dialog box appears, and “Service” or “Process” 
is displayed under Practice Status.

					   
Process or Service is displayed 
for the status
· Process
· Service
· Stop

Stopping a Service or Process
7.	 Click the Stop button on the tool bar or choose Execute > Stop from the menu 

bar.

	 “Stop” appears as the practice status in the Status Display dialog box.

Note
•	 Service execution can only be specified by users with Administrator privileges.
•	 Services cannot be executed when using Windows Vista.

2.3  Loading Data from the OPC Server and Transferring It to DAQLOGGER or Remote Monitor
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2.4	 Viewing the Status of the Executable Function

Displaying the Connection Status
Procedure

1.	 Choose View > State Display.

	 The GateOPC Information Software dialog box opens, allowing you to see the 
method under which the executable function may be running (as a process or as 
a service), whether or not it is running, and with which PCs communications are 
open.

					   

Displays the names 
of connected clients

Double-click to display 
the Error Indicator dialog box

Displays the communications status with the client
Gray: Stopped
Red: Error
Green: Normal

					   

	 See section 3.3 for error messages.

Note
•	 If a warning message is displayed (code Wxxxx), the lamp that displays the connection 

status by color does not blink red.
•	 When an error occurs and the lamp blinks red, the Error Indicator dialog box appears. If you 

close the dialog box, the lamp turns green.
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2.5	 Viewing Version Information

Procedure
1.	 Click the About button or choose Help > About from the menu bar.

					   
About button

	 The Version dialog box opens.

					   

Version

Company name
User name
License number
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Chapter 3	 Detailed Description of Functions

3.1	 Overview

GateOPC performs COM or DCOM communications with OPC servers and acquires data 
at regular intervals. Through the monitor server function, the acquired data is transferred 
to DAQLOGGER or Remote Monitor via TCP/IP.
The following is a list of the features of each software function.

Environment Setting Functions
Environment setting functions are used to enter all environment settings required to run 
the executable function, to run/stop the executable function, and to run the status display 
function.
•	 Specification of OPC Servers
	 Specification of the remote PC name
	 Selection/setting of the ProgID1

•	 Connection to OPC Servers
	 Up to 16 OPC servers can be connected
•	 Browsing OPC server items2

	 Display of item tree/list
	 Display of item properties
•	 Creation/Deletion of Groups
	 Up to 50 groups can be created3

	 Entering of group names
	 Setting of acquisition interval for each group4

	 Setting of the percent deadband for each group4

•	 Adding/Deleting of Group Items
	 Up to 32 items can be added to each group5

•	 Setting of Item Properties
	 Setting of upper/lower span
	 Entering of tag names (up to 16 characters)
	 Entering of units (up to 6 characters)
	 Setting of the decimal places (0 to 4)
	 Setting of colors
•	 Tests Execution (Data Acquisition)
•	 Running/Stopping of the Executable Function
	 Running of the executable function as a service
	 (Services cannot be executed when using Windows Vista.)
	 Running of the executable function as a process
	 Stopping the executable function
•	 Setting of the TCP/IP Port Number for the Monitor Server
•	 Executable Function Status Display

1.	 The identifier for the OPC server (COM/DCOM server).
2.	 Possible if the IOPCBrowseServerAddressSpace interface (optional) is installed on the OPC 

server.
3.	 The number of allowable groups may be less than 50 depending on the server.
4.	 The valid range depends on restrictions on the OPC server.
5.	 The number of items that can be added to groups may be less than 32 depending on the 

server.
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Executable Function
Features of the executable function are as follows:
•	 Running as a process and as a service is possible.
•	 Data is acquired from OPC servers at regular intervals.
•	 Runs as a monitor server if DAQLOGGER or Remote Monitor is the client.

Status Display Function
Features of the Status Display function are as follows:
•	 Executable Function Status Display
	 Practice status display (stopped, running as a service, running as a process).
	 The client connection status is displayed if DAQLOGGER or Remote Monitor is the 

client.

3.1  Overview
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3.2	 Detailed Description of Functions

OPC Server
GateOPC utilizes the OPC (OLE for process control) DA (data access) revision 2.0 
server and COM/DCOM technology on the local machine or remote machine to form a 
connection and acquire data.

Interfaces Used
The interfaces for the OPC server are defined as shown in the figures below.
OPC Server Object

		

IOPCCommon

IOPCServer

IOPCItemProperties

[IOPCServerPublicGroup]

[IOPCBrowseServerAddressSpace]

[IPersistFile]

IConnectionPointContainer

Standard
OPC Server

Object

IUnknown

OPC Group Object

		

IOPCItemMgt

IUnknown

IOPCGroupStateMgt

[IOPCPublicGroupeStateMgt]

IOPCSvncIO

IOPCASvncIO2

[IOPCASvncIO] old

IConnectionPointContainer

[I DataObject] old

Standard
OPC Group

Object
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The interfaces used by GateOPC are as follows:
•	 OPC Server Object
	 IOPCCommon
	 IOPCServer
	 IOPCItemProperties
	 IConnectionPointContainer
	 IOPCBrowseServerAddressSpace
•	 OPC Group Object
	 IOPCItemMgt
	 IOPCGroupStateMgt
	 IOPCSyncIO

Note
According to OPC DA version 2 conventions IOPCBrowseServerAddressSpace is optional, 
so GateOPC can run even if the OPC server does not have this interface.  However, the OPC 
server item browse function is not available without this interface.

Name of Remote PC
When connecting to the OPC server on a remote PC, you must specify the PC name. Up 
to 80 characters can be entered for a PC name. In this case, the local PC must be able 
to access the remote PC.
The conditions for connecting with an OPC server on a remote PC are as follows:  For 
details, see the user’s manual for the OPC server.
•	 That the client can use DCOM on the server side computer.
•	 That the server grants remote access
•	 That OPCENUM.EXE is running on the server side computer

Selecting/Setting the ProgID
An OPC server is a type of COM server, so a ProgID is used to identify individual OPC 
servers.
GateOPC lists the ProgID of the OPC revision 2 server installed on the local PC or 
Remote PC from the registry categories. The user must select one of the ProgIDs from 
the list to specify an OPC server.  Furthermore, to search the ProgIDs on the remote PC, 
opcenum.exe must be running on the remote PC. If unable to search for ProgIDs on the 
remote PC, see the OPC server’s user’s manual.

Simultaneous Connections of Up to 16 OPC Servers
With GateOPC, you can connect with up to 16 OPC servers and acquire data. You can 
also acquire data even when connecting to a combination of OPC servers residing on 
both remote and local PCs.
GateOPC assigns a system number to each OPC server to be connected. When 
connecting to GateOPC from DAQLOGGER or Remote Monitor and then acquiring data, 
this number is used to identify each OPC server.

Interval at Which Data Is Acquired from the OPC Servers
You can specify the interval at which data GateOPC acquires data from the OPC servers.  
The setting range is 0.5–3600 seconds. When connecting to multiple OPC servers, you 
can specify different acquisition intervals for each.
Depending on the server performance and quality of connection, the data acquisition 
interval may be insufficient, causing a data “Lack.” If this occurs, lengthen the acquisition 
interval as needed.

3.2  Detailed Description of Functions
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Browsing OPC Server Items
This function not available if the IOPCBrowseServerAddressSpace 
interface is not installed on the OPC server.
You can search through all items on the OPC servers and display them in a format similar 
to the Windows explorer. You can display the layered structure of branch items, and all 
leaf items on each layer. The data type, access rights (read/write), units, and details are 
displayed for each leaf item.

Note
Units and details are optional properties, so they are not displayed if not installed on the OPC 
servers.

Creating Groups/Group Names
Up to 50 groups can be created on GateOPC. These groups support OPC server group 
objects. Therefore, fewer than 50 groups may be allowed depending on the OPC server 
configuration.
You can assign a name to each group. GateOPC limits the number of characters in a 
name to 30 characters. However, fewer than 30 characters may be allowed depending 
on the OPC server.

Note
•	 Per OPC DA conventions, each group name must be unique. No two groups may have the 

same name.
•	 While the groups created here correspond to the OPC server settings as well as the group 

settings when GateOPC is connected from Remote Monitor. These group settings are not 
reflected on DAQLOGGER.

Group Data Update Interval
You can specify the data update interval for each group. The setting range depends on 
the OPC servers. The interval is expressed in milliseconds.

Note
These settings correspond to the OPC server settings. See the OPC DA specifications for 
details.

Group Percent Deadband
You can enter the percent deadband, specifying when the groups will be updated. The 
setting range depends on the OPC servers. The deadband is expressed as a percentage.

Note
These settings correspond to the OPC server settings. See the OPC DA specifications for 
details.

3.2  Detailed Description of Functions
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Adding Items to Groups
You can add an item to a group. GateOPC limits the number of characters to 32. 
However, fewer than 32 may be allowed depending on the OPC server.

Note
These settings correspond to the OPC server settings and define GateOPC acquisition items.

An item may not be able to be added depending on its type. Data for each OPC DA item 
are of the VARIANT type, but whether or not addition of items to that type and group is 
allowed is as follows:
Data Type Description Group Add Allowed/Not Allowed 

([YES]: Allowed, [NO]: Not Allowed)
VT_I2 Single precision integer YES
VT_I4 Double precision integer YES (or SHORT and LONG?)
VT_UI2 Single precision integer, no symbols YES
VT_UI4 Double precision integer, no symbols YES
VT_INT Integer YES
VT_UINT Integer, no symbols YES
VT_R4 Single precision floating point number YES
VT_R8 Double precision floating point number YES
VT_DATE Day and time from 1899/12/30 NO
VT_BSTR Character string NO
VT_BOOL 0:FALSE  –1:TRUE YES
Other NO

Setting Item Properties
You can specify the upper and lower limit of span, tag name (up to 16 characters), unit (up 
to 6 characters), decimal place (0 to 4), and color for each item registered to groups.

Note
These settings do not involve the OPC server; they are used when sending data from GateOPC 
to DAQLOGGER or Remote Monitor.
Colors are ignored by DAQLOGGER and Remote Monitor.  Also, you can download tag names 
using tag setting software.

A decimal place is defined as a significant digit behind the decimal point. The following is 
an example of decimal place and data.

Actual data Decimal places: 0 Decimal places: 1 Decimal places: 2 Decimal places: 3 Decimal places: 4
0.12345 0 0.1 0.12 0.123 0.1234

3.2  Detailed Description of Functions
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Acquiring Data at Fixed Intervals
The OPC server loads data from devices connected to the OPC server, stores it in the 
data buffer (cache), and updates it at the interval set in the procedure on page 3-5 and 
2-7, “Data Update Interval for Groups.” (Actually, the data is updated if the value set in 
the procedure under “Percent Deadband for Groups” (page 3-5) changes to a larger 
value. If the deadband is 0%, updating occurs each time.)
GateOPC loads the value stored in the internal buffer (cache) on the OPC server in 
synch with the update interval specified in “Interval at Which Data is Acquired from the 
OPC Server” (page 3-5 and 2-7).
The OPC server data loading operation and the GateOPC data loading operation when 
the deadband is 0% is shown in the figure below.

		

Time

Device (PLC etc.)

Group data 
update interval

Group data 
update interval

Group data 
update interval

Cached data Cached data Cached data Cached data

Interval at which data 
is acquired from the 
OPC servers

Interval at which data 
is acquired from the 
OPC servers

GateOPC internal buffer

OPC
Data Access

GateOPC

Time of GateOPC internal data
The time of GateOPC internal data (timestamp), is the time on the PC on which 
GateOPC is running at the time point at which GateOPC read data at synchronized IO 
(IOPCSyncIO).
If data was monitored by Remote Monitor, GateOPC’s data time is used.
If data was acquired from GateOPC by DAQLOGGER, it is the time at which data was 
loaded by DAQLOGGER.

Test Acquisition
Using the configurator, you can connect to an OPC server and perform a test acquisition 
using the synch IO (IOPSyncIO) after registering new items to groups.

Communication Retry
If the OPC server is shut down for reasons such as the PC power supply becoming 
disconnected, or being closed by the user, GateOPC retries communication with all OPC 
servers for which Use Retry is turned ON in the GateOPCConfigurator dialog box. The 
retry time is from 30 to 3600 seconds. At the point that communication is restored, the 
OPC server is created, the necessary information is retrieved from OPC, and data is 
acquired.

3.2  Detailed Description of Functions
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Scan Mode
When connecting with DAQLOGGER to acquire OPC data, if the number of channels 
in the GateOPC Configurator exceeds 1600, 1600 channels of data is sent to 
DAQLOGGER, starting with the first channel of the instrument of the smallest system 
number. Also, if an error occurs on an OPC during the first communication and 
communication is restored by executing a communication retry, connection is possible 
with that OPC in 1 scan mode without any channels being cut out.

Monitor Server Function
GateOPC takes data read in from devices and transfers the data to DAQLOGGER or 
Remote Monitor.
The maximum number of DAQLOGGERs or Remote Monitors that can be connected at 
once is 16.

Executable Function Status Display
The status display function allows you to display the following status items for the 
executable function.
•	 The executable function’s practice status (running as a service, running as a process)
•	 The name of PCs running DAQLOGGERs and Remote Monitors connected to a 

monitor server.

3.2  Detailed Description of Functions
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3.3	 Message and Corrective Actions

Error
No. Message Corrective Actions
E211 Cannot write to file. Check if the disk capacity is sufficient or if the file systems is 

normal.
E212 Cannot read file. Check if the file exists and is supported by the software or if the file 

system is normal.
E213 Cannot open file. Check if the file exists and is supported by the software or if the file 

system is normal
E401 Communication error. Check if the recorder connected for communication is powered on 

and if the cable is properly connected.  Also check the following 
items according the communication type.
• For Ethernet
  �Check if address settings are correct; the TCP/IP protocol is 
installed in Windows; the Ethernet card is properly installed.

• For RS-232 and RS-422
  �Check if the baud rate settings match; the port (COM1 to COM9) 

settings match, the address settings are correct (RS-422); the 
serial port of the PC is active and the appropriate cable is being 
used.

E402 Communication timeout. –
E403 Cannot open a communication port. Same as E401.
E501 Invalid license number.

Please reinstall the software.
Install the software again.

E1010 Execution of a process failed. Check whether an executable function exists, or whether its files 
are damaged. If this error appears frequently, reinstall the software.

E1011 Execution of a service failed. Check whether an executable function exists, or whether its files 
are damaged. If this error appears frequently, reinstall the software.

E1301 Cannot connect OPC server. Check whether the OPC server is available.
E1302 Execution of status display function failed. Check whether an executable function exists, or whether its files 

are damaged. If this error appears frequently, reinstall the software.
E1303 Failed to create group. An error was returned from the OPC server when creating a group. 

Check the status of the OPC server.
E1304 Failed to create item. An error was returned from the OPC server when creating an item. 

Check the status of the OPC server.

Warning
No. Message Corrective Actions
E1401 Computer not found. Check whether the specified computer exists on the network, or 

whether the network is functioning normally.

Message
No. Message
M1201 Model determination was successful.
M1210 Setting changes saved before execution.
M1501 Delete server?
M1502 Delete selected item?
M1503 Delete selected group?
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Executable Function Messages
No. Message Corrective Actions
W[631] Data Lack Reduce the number of acquired data points or connected 

instruments, or lengthen the scan interval.
E[637] Cannot open communication Same as E401.
E[674] Communication error Same as E401.
E[675] Communication time out Same as E401.
E[750] Cannot create OPC server Same as E1301.
E[751] Cannot create Interface OPC Check whether the OPC server is functioning correctly.
E[752] Cannot create Interface 

Shutdown
Check whether the OPC server is functioning correctly.

E[753] Cannot create Group Same as E1301.
E[754] Cannot create Item Same as E1304.
E[755] Shutdown OPC Server The OPC server was shut down during communication. Check the 

status of the OPC server.
I[606] Recovery Communication Connection recovered.

3.3  Message and Corrective Actions
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