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1. Product Overview 

CodeWarrior for Microcontrollers v10.0 is a major new release of CodeWarrior Development Studio. 
It integrates the development tools for the RS08, HCS08 and ColdFire

®
 architectures into a single 

product based on the Eclipse open development platform. Eclipse offers an excellent framework for 
building software development environments and is becoming a standard framework used by many 
embedded software vendors.  The product features include the following: 

1.1 IDE 

• Eclipse IDE 3.4 

• New Project Wizard to create a new project in as few as 6 clicks 

• MCU Change Wizard to retarget a project to a new device in as few as 6 clicks 

1.2 Build Tools  

• Optimizing ANSI C compilers for HCS08, RS08 and ColdFire that: 

o Operate off a standard front-end for consistent syntax 

o Generate standard ELF/DWARF files for execution and debugging  

o Include ANSI C compatible standard libraries and compact runtime libraries 

• HCS08 C++ compiler includes support for EC++ guidelines 

• ColdFire Embedded Warrior Libraries provide scalable C/C++ standard libraries and a 

librarian with a simple interface to select functionality 

• Macro assemblers for HCS08, RS08 and ColdFire derivativess 

• Linkers that dead-strip unused code for the optimal code size 

1.3 Debugger 

• C and assembly source code windows provide debug support for HCS08, RS08, and 

ColdFire derivatives 

• Precise breakpoints help solve sophisticated problems 

• Complex, emulator-like debug capability using HCS08 and V1 ColdFire on-chip trace 

features 

• Display of data values, complex data structures and expressions to speed run-time 

analysis, without stopping or single stepping the processor 

• Detailed information on every aspect of your project: break points, watch points, stack, 

symbol table 

• Full-chip simulation for most HCS08 and RS08 microcontrollers including CPU instruction 

set, peripherals, interrupts and I/O 

• Kernel-aware debugging with OSEK, MQX* or Linux real-time operating systems 

• Fast flash programming support 

• Support for open-source BDM connection interfaces 

• Support for CodeWarrior USB TAP and CodeWarrior Ethernet TAP connection interfaces 

• Support for P&E Microcomputer Systems’ Cyclone Pro/Max stand-alone programmers 

and Multilink  hardware interfaces (Rev C or later) 

• Ability to program user-selectable TRIM values with P&E Microcomputer Systems’ 

Multililnk and Cyclone Pro connection interfaces 

• Ability to download a binary file (S12, BIN or ELF) to a target without a project. 

• Support for multi-chip debugging by providing the ability to connect to multiple devices on 
a board.  
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• Project import utility to import projects created with CW MCU v6.x. and CW CF v7.x  

• Scripting capability (TCL, PERL, COMM) for stand-alone, command-line debugging 

• SDK explains how to create custom flash programming files for on-chip memory. 
 
* Available as a separate download. 

 

1.4 Software Analysis 

• Display trace in a dedicated Trace Viewer, with: address, assembly, source code, 
function, raw bytes, corresponding target FIFO entry 

• Display the trace flow within a dedicated timeline view; ability to zoom in/out, scroll, 
synchronize to trace 

• Display the profile and coverage information in a dedicated Critical Code viewer, with: 
assembly/source/mixed modes; statistics per functions, per assembly and per source 
line; code coverage, number of passes, code size 

• Ability to set start/stop trace points in Source, Assembly, Variables and Memory windows 

• Support overwrite and continuous trace modes 

• Support expert settings mode 

• Support sampling mode for CFv1 

• Support data trace for both HCS08 and CFv1 targets 

• Support start/stop/reset trace on demand during execution 

• Support re-configure trace after execution starts 
 

1.5 Processor Expert  

• Processor Expert support for HCS08, RS08, and V1-V4 ColdFire derivatives. 

• Device Initialization 

• Component Wizard utility with support for any embedded components purchased for use 
with the CodeWarrior Classic 

• Even though the CodeWarrior can be run on Linux, the current version of Processor 

Expert core  still needs to be run in Windows environment. It's necessary to have a 

working  windows CodeWarrior installation. There is also possibility to run Processor 

Expert core on Linux using "wine" (http://www.winehq.org/) For more details see:   

CodeWarrior documentation: CodeWarrior for Microcontrollers V10.0 Processor Expert 

Help > Introduction > Linux  

Web: http://www.winehq.org/ 

1.6 Documentation  

CodeWarrior Development Studio for Microcontrollers V10.0 contains a significant amount of 
new documentation.  

1.6.1 Getting Started  

o Microcontrollers V10.x Getting Started Guide 
o Quick Start for Microcontrollers V10.0 
o Quick Start for CodeWarrior Project Importer 
o Eclipse Quick Reference Card  
o HCS08 Profiling and Analysis for Microcontrollers V10.0 Quick Start  
o ColdFire V1 Profiling and Analysis for Microcontrollers V10.0 Quick Start  

1.6.2 Users Guides 

o Freescale Eclipse Extensions Guide  
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o Microcontrollers V10.x Targeting Manual 
o HCS08 Build Tools Reference Manual for Microcontrollers V10.x 
o RS08 Build Tools Reference Manual for Microcontrollers V10.x 
o ColdFire Build Tools Reference Manual for Microcontrollers V10.x 
o MISRA-C:2004 Compliance Exceptions for the HC(S)08, RS08 and ColdFire 

Libraries Reference Manual for Microcontrollers V10.x 
o EWL C Reference Manual 
o EWL C++ Reference Manual 
o HCS08/RS08 Assembler Reference Manual for Microcontrollers V10.x  
o ColdFire Assembler Reference Manual for Microcontrollers V10.x  
o Profiling and Analysis User Guide for Microcontrollers V10.x  
o USB TAP Probe Users Guide  
o Ethernet TAP Probe Users Guide  
o Open Source BDM-JM60 Users Guide 
o Processor Expert User Manual 
o Device Initialization User Manual 
o Processor Expert Components 

1.6.3 Application Notes 

o AN3859 – Adding Device(s) to the CodeWarrior Flash Programmer for 
Microcontrollers V10.x 

o AN3967 – How to Write Flash Programming Applets 
o AN4104 – Converting ColdFire Projects to CodeWarrior Development Studio for 

Microcontrollers V10.x 

1.6.4 Supporting Information 

o Microcontrollers V10.x FAQ Guide  

1.6.5 Cheat Sheets 

o Microcontroller V10.x Specific 

• Building Library (HCS08)  

• Creating, Building and Debugging a Project  

• Creating New Project from Example Project  

• Changing P&E Connections Setting  

• Configuring Perspectives  

• Creating, Debugging, Collecting, and Viewing Data for the ColdFire V1 
Target  

• Creating, Debugging, Collecting, and Viewing Data for the HCS08 Target  

• Debugging Projects in ROM  

• Debugging Project Using Command Line  

• Examples:Porting Classic IDE Projects to Eclipse  

• Importing and Debugging Externally Built Executable File  

• Using Memory View  

• Using Microcontrollers Change Wizard  

• Using Registers View  

• Working with Build Configurations  

o Core (Common to other CodeWarrior products)  

• Importing Archive Files  

• Importing Break Points  

• Importing Classic CodeWarrior Projects  

• Importing Existing Projects into Workspace  

• Importing Preferences  



CodeWarrior Development Studio for Microcontrollers, v10.0 

 

  5 

• Importing Resources from Local File Systems  

• Importing Team Project Set  

• Making C/C++ the IDE's Default Perspective  

• Using the Flash Programmer 

2 System Requirements  

2.1 Recommended Configuration 

o 1.8 GHz Pentium® compatible processor or better  
o Microsoft Windows XP/Vista  
o 1 GB RAM  
o 2 GB hard disk space, 400 MB on Windows system disk 
o CD-ROM drive for installation  
o USB port for communications with target hardware 
o Ethernet port for communications with target hardware (optional) 

2.2 Operational Minimum Configuration 

o 1.4 GHz Pentium® compatible processor or better  
o Microsoft Windows XP  
o 512 MB RAM  
o 1 GB hard disk space, 400 MB on Windows system disk  
o CD-ROM drive for installation  
o USB port for communications with target hardware  

2.3 Host Operating System Support 

o Microsoft® Windows XP 32-bit and 64-bit (Professional Edition) 
o Microsoft Windows Vista® 32-bit and 64-bit (Home Premium Edition and Business 

Edition) 
o Microsoft Windows 7 32-bit and 64-bit (Home Premium Edition and Professional 

Edition) 
o Red Hat Enterprise Edition 5.2 (32-bit) 

3 Product WEB page 

CodeWarrior Development Studio for Microcontrollers v10.0 is available for download at 
http://www.freescale.com/cwmcu10. This web page also includes product information, task based 
videos and all related documentation.   

4 Installation and Licensing 

To install CodeWarrior Development Studio for Microcontrollers v10.0, double-click the installation 
package and a wizard will guide you through the installation process.  For specific installation 
instructions on Linux, Windows Vista and Windows 7 systems, see Appendix C and Appendix D. 
 
If you are installing the Special Edition, the Special Edition license is automatically installed with your 
product and you do not need to register it. This license allows you to develop projects with unlimited 
assembly code, up to 32KB of C code for HCS08/RS08 derivatives, up to 64KB of C code for V1 
ColdFire derivatives and up to 128KB of C code for V2-V4 ColdFire derivatives. 
 
If you are installing the Evaluation Edition, the Evaluation license is automatically installed with your 
product and you do not need to register it. This license allows you to develop projects as 
Professional Edition within the 30-day evaluation period. After 30 days, the license works as Special 
Edition license (free permanent, but feature limited) which supports unlimited assembly code, up to 
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32KB of C code for HCS08/RS08 derivatives, up to 64KB of C code for V1 ColdFire derivatives and 
up to 128KB of C code for V2-V4 ColdFire derivatives. 
 
If you are installing the Basic, Standard, or Professional Editions, the Evaluation license will be 
installed with your product. You will need to register your product to receive the appropriate license 
file. 

5 Technical Support  

All CodeWarrior issues are tracked through Freescale's normal Service Request Process. To report 
feature requests (enhancements) or defects for CodeWarrior Development Studio for 
Microcontrollers v10.0, please submit a Service Request.    

1. Go to http://www.freescale.com/support  
2. Log in.  
3. On the resulting MyFreescale page, click Enter a Service Request  
4. Choose category Technical Request  
5. Choose topic CodeWarrior  
6. Click Continue.  
7. Provide the required information. An attachment up to 10 MB may be attached to the SR. You 

may also specify email addresses of people you would like to keep notified on the progress of 
the SR. Separate multiple email addresses with commas.  

o Type:  pick from Query (Question), Change Request (Enhancement) or Problem Report 
(Bug) 

o Target:  specify the hardware microcontroller/microprocessor family involved 
o Product: CW for Microcontrollers 
o Major: 10 
o Minor: 0 
o Priority:  choose from Normal, High, or Highest 
o Subject:  be short and descriptive 
o Description:  details about whatever it is you're filing the SR about 

  
Please note: The Product field must be set to CW for Microcontrollers. This will allow Freescale 
to find SRs related to this project very easily, report on them, and gather statistics on how the 
project is doing.  

8. When finished, click Submit.  

After Submit is selected, a confirmation page will be displayed with the SR number. You will also 
receive a confirming email sent to the address specified in your Freescale account. 
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Appendix A:  Known issues and Workarounds 

Issue ID Description 

Debugger    

MTWX31779  Issue: MCU Flash Programmer does not provide the ability to protect sections of 
memory. 
Workaround: Use restrict address range to protect memory sections. 
Ensure the sector that should be protected is outside the address range for 
programming. The Flash programmer will write only in the specified area 

MTWX41032 
  

Issue: Cannot connect to TWR-LL64 board with using OSBDM if target is in STOP 
mode 
Workaround: Add functionality to the application to exit STOP mode and to enter 
RUN mode, so OSBDM is able to connect (e.g. adding functionality to a button on the 
board to exit STOP mode) 

MTWX41255 Issue: A breakpoint at the program entry point cannot be removed. 
Workaround: There are two possible workarounds: 1) Specify Stop on startup at 
program entry point instead of specifying the entry point in the "user specified field;” 
or 2) Remove the breakpoint using the Debugger Shell: 
 
bp #x off 
where x is the breakpoint ID (obtained by using the bp command) 

MTWX41383 
  

Issue: Thread stays in “stepping” state for ColdFire C++ class constructors 
Workaround: There are two possible workarounds: 1) Put a breakpoint on the first 
instruction from the constructor (where “step over” should get) and resume the target;  
or 2) Use “step into” from the beginning of the function to the first instruction. 

MTWX41559 
  

Issue: Debugger does not run correctly when a breakpoint or trigger is set 
Workaround: The Debugger and Software Analysis tools use the device’s resources 
(hardware breakpoints) to set breakpoints and triggers. Therefore, the limited 
resources on the target may not allow breakpoints to be active and executed in the 
debugger while trace is active. 

IDE  

MTWX40228 Issue: A classic CodeWarrior project built in Windows and imported into Linux will 
not build correctly. 
Workaround: Ensure all filenames included in the project match exactly since Linux 
filenames are case sensitive. Change all backward slashes in the project build 
artifact settings to forward (‘/’) slashes to comply with the Linux host.  

MTWX40447 
  

Issue: No error message is displayed when a project is imported into an overlapping 
workspace location when “Copy project into workspace” is selected. 
Workaround: Do not check “Copy project into workspace” 

MTWX41438 
  

Issue: Syntax error is displayed in the editor for C++ files even though the HCS08 
project built correctly 
Workaround: In the project properties, under the section "C/C++ General | File 
Types", add the following entry: 
 
Filename:  *.h 
Description:  C++ Header file 
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MTWX41674 
  

Issue:   Importing a classic CodeWarrior *text* based project is not possible.  
Workaround:  The Project Importer does not import text based classic CodeWarrior 
projects (e.g. from CW for MCU 6.3 or CW for ColdFire 7.2). In order to import the 
project, open the project in the classic CodeWarrior product. Open the IDE General 
Preferences (menu Edit > Preferences) and deselect the option in General > IDE 
Extras > Use text based projects. Rebuild the project. 

MTWX41677 
  

Issue:   Creation of a project inside the current workspace with 'use default location' 
checked results in an error. 
Workaround:  Always check ‘use default location’  when a project is created inside 
the current workspace. 

MTWX41724 
  

Issue:   Preprocess for S08/RS08 does not open output file. 
Workaround:  Open the generated listing file (*.lst). The location/file name of the file 
is listed in the output window. 

MTWX41902 
  

Issue:  The Activate button in the Help > Freescale Licenses dialog opens a dialog, 
but I don’t know what to enter in the dialog. 
Workaround:  No workaround. The Activate button is no longer needed as part of 
the WEB Licensing process for CodeWarrior so it should NOT be used. 

MTWX42153 Issue:  Switching the eclipse workspace in Linux, may not work correctly – the 
eclipse IDE does not restart automatically with the new workspace.  
Workaround:  Restart the eclipse IDE with the new workspace. 

MTWX42164 Issue:  Using the device/connection wizard to retarget a Linux application project to a 
new device results in a Windows bare board project. 
Workaround:  No workaround. The device/connection wizard can only be used with 
Windows bare board projects. 

Build Tools  

MTWX40668 
 

Issue: Not all HCS08 build tool options are present in the build tool settings 
Workaround: Launch the build tool binaries and use -h option to display all options. 
This information is also listed in the manual. Add the option manually to the options in 
the 'other options' field. 

MTWX41972 
 

Issue: CW MCU v10.0 reacts and refreshes slowly in the following situations: 

• Lots of projects are open in the workspace  

• A project includes several hundred files 

• A project includes files that are on a high latency file system 
Workaround: This is a known eclipse problem. To improve performance go to the 
menu in Window > Preferences > General > High Latency File System and disable 
one or more features to improve the editor performance. 

Software 
Analysis 

 

MTWX40870 
 

Issue: Trigger point B not hit as expected for "Instruction at Address A or at Address 
B is Executed" 
Workaround: Perform the following actions: 
 
[Precondition]: Debug session started. 
[Action]: Resume the target. 
[Event]: Target is suspended when trigger A is hit. 
[Action]: Perform a target step from the Debug View. 
[Event]: The target step is performed. 
[Action]: Resume the target. 
[Event]: Trigger B is hit and the target is suspended. 

MTWX41259 
 

Issue: Launching Eclipse is slow.  
Workaround: When Eclipse is first started the Software Analysis engine is initialized. 
After the initialization is finished Eclipse performance is no longer impacted. For large 
projects and big files, you might disable the eclipse indexer in the eclipse settings in 
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the menu Window > Preferences > C++ > Indexer. Additionally close any not needed 
projects in the workspace. 

MTWX41696 
 

Issue: Cannot collect trace with  #define TRACE_MODE TRACE_CONTINUOUS 
(trace user configuration) 
Workaround: This issue only appears if the trace debug block is controlled directly 
from application code. To collect trace in continuous mode on V1 ColdFire, use the 
configuration user interface for software analysis. 

Processor 
Expert 

 

MTWX42165 Issue: If MCU Change Wizard is used to retarget a V1 ColdFire Processor Expert 
project to V2-V4 ColdFire device, the new project will not build due to incorrect build 
tool settings. 
Workaround: 

• Compiler Input Settings should not refer to the V1 ColdFire project path. If it 
exists, this path should be deleted. 

• All files in the Generated_Code folder should be deleted from the new project 
after project creation. Processor Expert will regenerate these files for the new 
device when Generate Code is selected.  

Run Control  

MTWX38114 
 

Issue: Conditional watchpoints do not work with an OSBDM connection. 
Workaround: No workaround. OSBDM does not support conditional watchpoints. 

MTWX41634 
 

Issue: Can’t establish communication with the OSBDM on the TWR-CN128 REV B 
board. 
Workaround: CW MCU v10.0 needs the latest OSBDM firmware (B26 or later) on 
the board (e.g. TOWER boards), so the firmware may need to be updated. The             
firmware and instructions can be found in <installation_folder>\Drivers\osbdm-JM60. 
Note: OSBDM does not support connecting to a device in low power mode (e.g. 
STOP mode).  
 
OSBDM does not support connecting to or reprogramming a device that has flash 
blocks secured. To reprogram a secured device solder the BDM header on the board 
and program the device using an external BDM cable. 

MTWX41833 Issue: Project Importer fails to import debug configuration for OSBDM connection 
from classic CW projects 
Workaround: CW MCU v10.0 does not support the older OSBDM connections 
based on the JB16 platform. These connections are called “HCS08 Open Source 
BDM” and “CF Open Source BDM” in the classic CW products. 

Installer  

MTWX41724 
 

Issue: It takes too long to uninstall CW MCU v10.0 on Linux. 
Workaround: After about 10 minutes, invoke xkill and point to the installer window. 
The uninstall process is complete at this point, but the installer does not close. 

MTWX41994 
 

Issue: A service pack cannot be installed for CW MCU v10.0 (Linux) in user mode. 
Workaround: Perform service pack installations as ROOT user. 
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Appendix B:  Installing P&E Microcomputer Systems’ USB drivers on a Linux system 

To properly install P&E USB drivers to be on a Linux system, the user should verify the following 
requirements are satisfied before installation (either manually or via Codewarrior): 
 

A. root access must be used during install. 
B. kernel source must be included in the distribution (same version used to build the kernel). 
C. GCC must be installed on the machine (same version as used to build the kernel). 

 
See Section 2 for directions how to manually install the kernel source and GCC. 

1. Determining whether the drivers have been installed properly 

If driver installation fails, a warning message should be displayed during installation. The user can also 
look in the /usr/lib directory for the file libwdusb1002.so. If this file exists, driver installation was 
successful. 

If the driver installation was unsuccessful, the drivers must be manually installed. 

2. Manually installing GCC and kernel source on redhat 5 

The same version of GCC, which was used to build the kernel, must be installed in the distribution. The 
same kernel source files, which were used to build the kernel, must also be installed (or at least the 
headers). The following steps demonstrate how to install the necessary resources on Red Hat 5 
Enterprise Edition (32-bit).* 

A. Open a console (terminal) window and use the 'su' command to enter root mode 

B. Use the 'cat /proc/version' command to display the kernel version number and the GCC version 
number used to build the kernel. 

C. Use the 'yum list gcc' command to display the version number of GCC in the yum repository. If it 
matches the version used to build the kernel, install it with the 'yum install gcc' command. 
Otherwise, download and install the appropriate GCC version from an on-line repository. 

D. Use the 'yum list kernel-devel' command display the version number of the kernel source files in 
the yum repository. If it matches the kernel version number, install it with the 'yum install kernel-
version' command. Otherwise, download and install the source from an on-line repository. 

E. Change directory to the distribution source directory with the 'cd /usr/src' command. 

F. Create a symbolic link which points to the source for this kernel. This is done by first using the 'ls 
kernels' command while in the /usr/src directory. This will display the version of source installed, 
such as 2.6.18-128.2.1.el5-i686. create the symbolic link with the command 'ln -s kernels/2.6.18-
128.2.1.el5-i686 linux' where the version number of the kernel source would be replaced with the 
appropriate version number listed by the previous command. 

For information about the driver installation requirements visit Jungo's website at: 
http://www.jungo.com/st/support/installation_instructions.html 

3. Manually installing the Jungo USB driver on redhat 5 

After making sure that GCC and kernel source have been installed, the Jungo driver should be 
rebuilt/installed. The following are directions for doing this on redhat 5. 

A. Open a console (terminal) window and use the 'su' command to enter root mode 
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B. If codewarrior has not been installed, install it. This should install the Jungo USB driver (see 
section 2 to determine if it has been properly installed). 

C. To re-install the Jungo USB driver, change the console directory to the 
[CodewarriorInstallDir]/Drivers/pemicro. Run the driver build script by using the 'sh setup.sh' 
command. This will indicate success or failure. 

* There are many ways to install the kernel source and GCC, and the methodology is different based on 
the distribution used. 

 

Appendix C:  CodeWarrior Eclipse usage on a Linux system 

1. The CodeWarrior installer must be run from a root account. CodeWarrior service packs are installed 
with the Eclipse Updater. The updater must also be run from a root account. To start the Eclipse 
Updater select ‘Window > Install new software’ in the menu.  

2. Eclipse needs read/write access to the installation folder. Make sure the eclipse installation folder has 
the appropriate permissions for all users. 

3. Make sure your project workspace has read and write permissions. 

4. If the CodeWarrior software does not restart automatically after a successful CodeWarrior update 
operation, run './cwide –clean’ to launch the CodeWarrior software. 

 

Appendix D:  CodeWarrior Eclipse usage on a Windows Vista / Windows 7 system 

1. Administrator rights are required to install CodeWarrior software on Microsoft Windows Vista and 
Windows 7 systems, since the installer copies files into the System and Program Files folders.  

The default CodeWarrior installation folder is C:\Program Files\Freescale\CW MCU v10.0. To protect 
against malware, Windows Vista and Windows 7 do not allow normal processes to change files in the 
Program Files folder; therefore, you must have administrator rights to install and run the CodeWarrior 
software from this location. If you will be running the CodeWarrior software with a non-administrative 
user account, then you need to install the CodeWarrior software in another folder (e.g. 
C:\Freescale\CW MCU v10.0).  

2. Your project workspace needs to be setup in any folder that you can fully access. 

 


