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1 Introduction 

Please read the installation instructions carefully and follow them step by step. 

1.1 Overview 

The purpose of this document is to describe the installation and setup process for the 
program OpenPowerNet. It explains the pre-conditions required on the target system for 
usage of OpenPowerNet. This document corresponds to OpenPowerNet release 1.4.0. 

Some of the used package names are brand names registered by other companies than IFB. 
Please refer to the license descriptions coming with that software packages. 

1.2 Configuration 

OpenPowerNet requires the following versions of associated applications. Additionally the 
OpenPowerNet software and documentation have their own version. 

Applications / Documents Version 

Java runtime environment 6u32 

MATLAB runtime environment R2012a 

Microsoft Excel 2007 SP3 

Maria DB 5.2.10 

MySQL ODBC driver 5.1.5 & 3.51.27 

OpenPowerNet 1.4.0 

OpenTrack 1.6.6 (2012-03-29) 

OPN Database 16 

OPN User Manual 1.4.0 

Windows Operating System XP SP3 or higher 

Table 1 Configuration table of documents and application versions 
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1.3 Acronyms and abbreviations 

The following abbreviations are used within this document. 

Abbreviation Description 

ATM Advanced Train Model 

CD Compact Disc 

DSN Data Source Name 

DVD Digital Versatile Disc 

GB Giga Byte 

GUI Graphical User Interface 

HDD Hard Disc Drive 

ODBC Open Database Connection 

OPN OpenPowerNet 

PSC Power Supply Calculation 

RAM Random Access Memory 

UAC User Account Control (Windows Vista or higher) 

Table 2 Acronymes and abbreviations 

2 Installation under Microsoft Windows 

OpenPowerNet and the associated software packages are designed for 32 Bit (x86) and 
64 Bit (x64) target systems running Microsoft Windows XP SP3 or higher utilising the latest 
updates. 

 

Note: Before starting the installation make sure that you have sufficient 
administration rights on the target system. Under Microsoft Windows Vista, 7 and 
Server 2008 some operations may require elevated rights if User Account Control 
is enabled. 

2.1 System requirements 

The performance demands of OpenPowerNet significantly depend on the size and 
complexity of the electrical network to simulate. It is important that all data fits into RAM to 
prevent a notable performance drop caused by memory swapping to HDD. A powerful 
computer with at least 2 GB of RAM is required. For large networks a 64 Bit operating 
system, 4 GB of RAM and a fast HDD are recommended. 

The following software needs to be installed but is not provided with the installation DVD. 

 A program to unzip files, 

 Microsoft Excel 2007 SP3 needs to be installed to be able to analyse the simulation 
results. 
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2.2 Update from previous versions 

First off all check the actual installed version. For this start OpenPowerNet and see the 
printout in the console view of the GUI. The printout should look like: 

OpenPowerNet 1.2.1 (Module PSC) | built Dec 11 2009, 15:39:34 

Institut fuer Bahntechnik GmbH 

then stop OpenPowerNet. 

Next is to check Table 3 for the relevant chapters to follow. The table contains old version 
numbers of OpenPowerNet in the table header. Please use the column with the actual 
installed version, e.g. 1.2.1, and follow all chapters marked with “X” or follow the short 
description. 

For instance the already installed version is 1.2.1 than follow all chapters marked in column 
1.2.1. 

 actual installed OpenPowerNet Version 

Chapter 1.2.0 1.2.1 1.3.0 1.3.1 / 1.3.2 

2.2.1 Update 
OpenPowerNet 

    

2.2.2 Update 
HASP SRM 
dongle 

X X X X 

2.3.1 Installation 
of JAVA runtime 
environment 

    

2.3.2 Installation 
of Microsoft 
Visual C++ 
runtime libraries 

X X X X 

2.3.3 Installation 
of HASP SRM 
runtime 
environment 

X X X X 

2.3.4 Installation 
of OpenStep and 
OpenTrack 

    

2.3.5 Update of 
OpenTrack 

X X X X 

2.3.6 Installation 
of MariaDB 

    

2.3.6.1 Delete 
OpenPowerNet 
user account 

Delete all 
OpenPowerNet 
user accounts. 

Delete all 
OpenPowerNet 
user accounts. 

  

2.3.6.2 Create 
OpenPowerNet 
user account 

X X   

2.3.7 Installation 
of MyODBC 
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 actual installed OpenPowerNet Version 

Chapter 1.2.0 1.2.1 1.3.0 1.3.1 / 1.3.2 

2.3.8 Installation 
of MATLAB 
runtime 
environment 

X X X X 

2.4 Installation of 
OpenPowerNet 

delete previous installation and install new version from DVD 

2.5 Creation of 
OpenPowerNet 
database 

X X X X 

2.6 Definition of 
Data Source 
Names 

Delete the 
default user’s 
password in 

ODBC 
connections. 

Delete the 
default user’s 
password in 

ODBC 
connections. 

  

2.7 Firewall 
settings 

    

2.8 Dongle ID 
configuration 

if necessary if necessary if necessary  if necessary 

Table 3 Lists the chapters which shall be followed to update OpenPowerNet corresponding to the 

actual installed version. 

Previous OpenPowerNet installations may have used MySQL. You do not need to change to 
the new MariaDB but you can do if you wish. If you install the new MariaDB uninstall MySQL 
first! Right now both databases are supported. 
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2.2.1 Update OpenPowerNet 

To update OpenPowerNet the functionality provided in the GUI is used. 

Start OpenPowerNet and then go to menu Help > Software Updates…. 

 

Figure 1 The available software tab lists all available software to be installed. 

Use the button Add Site… from the dialog in Figure 1 to specify the update directory of the 

installation DVD. Then the dialog from Figure 2 will open. Use the button Local… to add the 

update folder from DVD, e.g. F:\update in case the DVD drive is mounted as F. Press OK to 

close the dialog. 

 

Figure 2 The dialog to specify the update folder. 

Change to tab Installed Software, select the software as in Figure 3 and press 

Update…. The update will be installed and then the GUI needs to be restarted. 
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Figure 3 This dialog lists the installed software versions within the GUI. 

2.2.2 Update HASP SRM dongle 

To execute the new version of OpenPowerNet it may be necessary to update the hardware 
dongle that was purchased with the OpenPowerNet license. If not stated differently, an 

executable update file HaspUpdate_xx_<dongle_number>.exe can be found on the 

separate Dongle Update CD. Please run this file on the computer the dongle is connected to 
and follow the instructions of the update wizard. 
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2.3 Preparing the OpenPowerNet environment 

2.3.1 Installation of JAVA runtime environment 

If not already available install the Java runtime environment version 6u32. The installation file 
can be found on DVD under 

ThirdPartyPrograms/jre-6u32-windows-i586.exe. 

2.3.2 Installation of Microsoft Visual C++ runtime libraries 

OpenPowerNet needs the Microsoft Visual C++ runtime libraries. The installation file can be 
found on DVD under 

ThirdPartyPrograms/vcredist_[x86/x64].exe. 

Under 32 Bit environment choose the x86 file. Under 64 Bit environment the installation of 
both files is recommended to enable the usage of 32 Bit and 64 Bit executables. 

 

Note: When updating OpenPowerNet it might be necessary to also update the 
runtime libraries. 

2.3.3 Installation of HASP SRM runtime environment 

To enable the execution of the OpenPowerNet the runtime environment for the HASP SRM 
dongle is needed. The installation file can be found on DVD under 

ThirdPartyPrograms/HASPUserSetup.exe. 

Remove the dongle if connected and run the installer. Connect the dongle afterwards, the 
driver should be installed automatically. 

In case the dongle is connected to another computer than at the OpenPowerNet installation 
computer the port 1947 needs to be opened for TCP and UDP connections in the firewall. 

2.3.4 Installation of OpenStep and OpenTrack 

Install the OpenTrack application from OpenTrack CD according to the separate instructions 
coming with OpenTrack. OpenPowerNet is tested with OpenTrack version 1.6.6 (2012-03-
29). 

2.3.4.1 Installation of OpenStep 

Run the program Setup.exe in the OpenStep directory. Follow the instructions given by the 

installation program and accept the default settings. Restart the computer. 

 

Note: The setting of the PATH environment variable should be saved as 

OpenStep is liable to overwrite this variable with its own settings. After reboot 
copy the save path in front of the new path. 

2.3.4.2 Installation of OpenTrack 

Run the program Setup.exe in the OpenTrack directory. Follow the instructions given by 

the installation program and accept the default settings. 
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Note: The path to OpenTrack executables should not be changed on a later 
stage, e.g. during software update. 

The following system setting is recommended to get the full multitasking functionality of 
OpenTrack:  

In Control Panel > System > Advanced > Performance Settings > 

Advanced set Adjust for best performance of: to Background services. 

2.3.5 Update of OpenTrack 

The OpenPowerNet DVD contains the latest OpenTrack version. OpenPowerNet is tested 
against this version and it is recommended to use it. Newer OpenTrack versions should work 
as well but note that OpenPowerNet is tested only with the version on DVD. 

The folder DVD:/OpenTrack contains a zip file with the folder OpenTrack.app. Close 

OpenTrack in case it is running and copy the folder in the zip-file into the OpenTrack 

installation directory and overwrite the already existing folder OpenTrack.app. 

Start OpenTrack and check the version via menu Info > Info Panel … . 

2.3.6 Installation of MariaDB 

The MariaDB installation file is on the DVD at 

ThirdPartyPrograms/mariadb-5.2.10-[win32/win64].msi. 

Choose the right file according to your operating system architecture. In case that there is no 
MariaDB installed yet on your computer or only an old version of MariaDB, please install the 
MariaDB version 5.2.10 but remove an old MariaDB first. OpenPowerNet is tested with this 
version and may have problems with other versions, particularly with older versions. 

In the MariaDB installer follow the installer and use the default options but set a database 
administrator (root) password, see Figure 4. 

 

Figure 4 MariaDB default instance settings. 

MariaDB setup installs the MariaDB and HeidiSQL. 

Replace my.ini: 

 Stop the running database:  go to Control Panel > Administration > 

Services > MySQL and stop the service from the context menu. 
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 Replace the MariaDB configuration file my.ini in MariaDB_Install_Dir/ 

MariaDB 5.2/data/my.ini with the provided my.ini file. The file delivered with 

OpenPowerNet is available on the DVD under OpenPowerNet/my.ini. The delivered 

configuration file is optimised for the needs of OpenPowerNet.  

 Replace the path E:/MySQL in my.ini with the path where you want to store the data 

of the database.  

 Copy the folder MariaDB_Install_Dir/MariaDB 5.2/data/mysql to this path 

specified for variable datadir. 

 Set the variable key_buffer_size as large as possible according to the available 

RAM to maximise the database performance. 

 Restart the database service using the context menu at service MySQL. 

Modify PATH variable: 

 Go to Control Panel > System > Advance system settings> 

Environment Variables ... > System variables 

 Edit the Path variable by adding MariaDB_Install_Dir/MariaDB 5.2/bin at the 

end (use “;” in front of the new added path). 

 Close the dialog. 

Modify Service: 

 This is necessary to upload dump files from user profile folder (C:\Users\...). 

 Stop the running database:  go to Control Panel > Administration > 

Services > MySQL and stop the service from the context menu. 

 Open to Tab Log On. 

 Select Local System account, see below Figure 5, and click OK. 

 Restart the database service using the context menu at service MySQL. 

 

Figure 5 Service properties dialog. 
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2.3.6.1 Delete OpenPowerNet user account 

Open HeidiSQL, login as root (using the password from MariaDB installation) via the session 

manager (Figure 6) and open the user management via menu Tools > User manager. 

The dialog as in Figure 7 opens. 

 

Figure 6 HeidiSQL session manager. 

 

Figure 7 MariaDB user manager. 

2.3.6.2 Create OpenPowerNet user account 

A script is available to create a MariaDB database user for OpenPowerNet with/without 

password and all necessary rights. The default user is opndbusr without a password. 

 Open the command line window.  

 Change the directory to DVD:\OpenPowerNet 

 Type “createUser.bat”, press Enter and follow the instructions. 
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Each user shall have an own MariaDB database user name and password, but the database 
is the same for all users on this computer. The user account is needed to save the simulation 
results of the program to the database for later analysis. 

2.3.7 Installation of MyODBC 

OpenPowerNet uses ODBC to connect to the MariaDB database. The MySQL ODBC driver 
shall be installed after installation of the MariaDB database.  

Start the installation wizard from the DVD by executing the file 

ThirdPartyPrograms\ 

mysql-connector-odbc-[5.1.5/3.51.27]-[win32/winx64].msi. 

Follow the installer instructions and use the default options. 

Choose the right file according to your operating system architecture for the new driver. The 
64 Bit version includes the connector for 64 Bit and 32 Bit applications. Follow the 
instructions given by the installation program and accept the default settings. 

Install the old version 3.51.27 32 Bit as well as the new version 5.1.5 because 

MSQuery integrated into Excel will not work with the new version. 

 

Figure 8 The use of ODBC by OpenPowerNet. 
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2.3.8 Installation of MATLAB runtime environment 

The OpenPowerNet Analysis Tool requires the MATLAB runtime environment. 

The installation file can be found on DVD under 

ThirdPartyPrograms/ MCRInstaller_R2012a_xxx_win32.exe. 

Follow the installer instructions and use the default options. 

 

Note: Install the 32Bit version also at 64Bit systems. 

2.4 Installation of OpenPowerNet 

Extract the zip file OpenPowerNet/OpenPowerNet-1.4.0.zip from DVD. This file 

contains all program files and documentation of OpenPowerNet. 

There are two options to install OpenPowerNet. Option 1 is to have a shared installation for 
all users and option 2 is to have an individual installation for each user. 

OpenPowerNet uses the Eclipse framework. Eclipse is based on plugins and features. The 
installation resp. update of the features and plugins is stored in the installation directory. For 
option 1 all users share the same features. For option 2 each user is able to update and 
install plugins and features by himself and to adapt Eclipse, e.g. by adding an XML editor or 
other features. It is recommended to use option 2 and to provide the above mentioned zip file 
to each user. 

After unpacking of the zip file create a link to openpowernet.exe on the desktop or start 
menu. 

2.5 Creation of OpenPowerNet database 

Start OpenPowerNet and select Create new empty OpenPowerNet database from 

menu OpenPowerNet. The dialog in Figure 9 opens. Insert the schema name pscresults, 

login as default user opndbusr enter the no password and click Create new database. 

 

Figure 9 The GUI dialog to create a new database. 
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2.6 Definition of Data Source Names 

Follow the steps below to create and configure two ODBC data source names: 

1. Step: 

Open Control Panel/Administrative Tools/Data Sources (ODBC). A dialog 

similar to in Figure 10 will appear. 

 

 

Figure 10 ODBC Data Source Administrator dialog. 

 

Note: Under 64 Bit environment the ODBC connection partially has to be set up 

twice. Using the 64 Bit control panel C:\Windows\System32\odbcad32.exe 

all data sources utilising MyODBC 5.1.5 can be configured. To set up a data 

source for MyODBC 3.51.27 use the 32 Bit version of the control panel 

C:\Windows\SysWOW64\odbcad32.exe. 

2. Step: 

Select either tab ⌐User DSN or tab ⌐System DSN. A per user configuration is 

recommended to enable the user to create own databases. 

3. Step: 

To add the new data source for Excel open the 32 Bit ODBC control panel and use the Add 

button, the Create New Data Source dialog appears, see Figure 11. Select MySQL 

ODBC 3.51 Driver and press Finish. 

 

 

Figure 11 Create New Data Source dialog. 



OPN/33/1.4.0 

  

Page 16 of 19 Installation Instruction Issue 2012-05-07 
 

IFB DD, II_OPN_33_01.04.00.doc Page 16 of 19 DMJ, 2012-05-07 

4. Step: 

A dialog to configure the new data source appears, see Figure 12. Fill in the empty fields as 
shown in the figure. Any OpenPowerNet database is selectable, but the data source name 

has to be pscresults, otherwise an error occurs during data analysing with the prepared 

Excel files! Use the default MariaDB user opndbusr and no password as configured in 

2.3.6.1. 

 

Figure 12 Configure Data Source Name dialog, tab Login. 

It is not necessary to configure any connection options. So the fields in Figure 13 do not 
need to be configured. 

 

Figure 13 Configure Data Source Name dialog, tab Connection Options. 
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The last step to configure the data source is to open the Advanced tab, see Figure 14. Only 

the option selected in the figure has to be used. The options in the other tabs shall not be 
selected. 

 

Figure 14 Configure Data Source Name dialog, tab Advanced. 

After finishing configuration press OK. Now a new data source with name pscresults 

should appear, see Figure 10.  

5. Step: 

Add a new data source for usage with OpenPowerNet and Analysis tool using the native 

ODBC control panel and pressing the Add button. The Create New Data Source dialog 

appears, see Figure 11. Select MySQL ODBC 5.1 Driver and press Finish. 

6. Step: 

A dialog to configure the new data source appears, see Figure 15. Fill in the empty fields as 
shown in the figure. Any database and data source name may be chosen. 

 

Figure 15 The ODBC data source configuration version 5.1 dialog. 

7. Step: 

Click OK to create the DSN. 
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2.7 Firewall settings 

In order to allow the TCP/IP communication from OpenPowerNet to OpenTrack it is 

necessary to open the port 9004 for apserver.exe and port 9002 for OpenTrack.exe. 

This has to be done for both, the 32 Bit and the 64 Bit executables in folder 
OpenPowerNet_Install_Dir/plugins/de.bahntechnik.dd.opn.bin_1.4.0.v_Y

YYYMMDDHHmm\bin. 

Make sure to update the Firewall setting if OpenPowerNet is updated because the folder of 

apserver.exe will be changed. 

In case you use a dongle on another computer in the LAN open the port 1947 for TCP and 
UDP to enable OpenPowerNet to connect to the dongle, see also chapter 2.3.3. 

2.8 Dongle ID configuration 

In case OpenPowerNet is used with different licenses it might be necessary to specify the 
dongle per installation. 

To get the dongle IDs attach all dongles to your PC and open the HASP SRM Control Center 

in your browser (http://localhost:1947/_int_/devices.html).  

The configuration needs to be done in the GUI (Figure 16) and Analysis Tool (Figure 17). 
The following options are available: 

 Any dongle: => do not insert anything 

 One dongle: => enter one dongle ID 

 Multiple dongles => enter multiple IDs separated by “;” 

 

Figure 16 The OpenPowerNet preferences (Menu: Window => Preferences). 
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Figure 17 The Analysis Tool preferences (Menu: Setup) 
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