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1.0   Introduction

Agricultural Drainage Planning Program (ADPP) View is a menu-driven computer program that assists 
in analysis and design of existing and proposed drainage systems. There are two components to ADPP 
View, a Transient-State Analysis Component which is used to compute drain spacings from field data and 
an Uncertainty Analysis Component which can be used to evaluate the potential costs and performance of 
a particular drain design or a range of possible drain spacings.

The Transient-State Component uses the Bureau of Reclamation Transient-State equation to compute 
drain spacings.  Essentially, the program uses a deep percolation schedule with hydraulic conductivity and 
specific yield inputs to adjust drain spacings so that the field in question achieves a “dynamic equilibrium” 
over the course of a year with the water table build-up not exceeding the level specified.

The Uncertainty Analysis Component uses Donnan's Steady-State Equation to compute the water 
table's response to inflow from percolation and outflow to the drains to determine the reliability of the 
drains. It also uses various equations and the user's input to determine the cost per acre for the drain design 
specified. Both of these methods of analysis are explained in detail in the Bureau of Reclamation’s Drainage 
Manual.

One way to use the transient and risk analysis components of this program is to develop a design spacing 
in the Transient-State Analysis Component, and then use this design spacing or range of spacings in the 
Uncertainty Analysis Component to evaluate the reliability of the design.

1.1 Hardware and Software Requirements

The most current version of ADPP View runs of a Windows 95/98/NT platform and is best used on 
machines with at least a Pentium processor. No additional hardware or software requirements are necessary.

1.2  Installation of the ADPP View

1. The ADPP View software can be downloaded with the documentation from the Internet web page:

http://www.ids.colostate.edu/projects/adpp

2. Select the adpp.zip file on the download page and save it to your local system. You may need to 
download winzip to uncompress the file if you don’ t already have it. There is a link provided on the 
download page.

3. Save the adpp.zip file to your local system and select the file in Microsoft Explorer  by double 
clicking on it. This will open the winzip program.

4. Select the install button in the winzip program and follow the instructions in the setup utili ty.
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2.0   Quick Star t for ADPP View

2.1 Star ting ADPP View

1. Select Programs > ADPPView >ADPPView from the start menu, the main ADPP View window 
will be opened.

2. Select the File > Open option in the main window.

Figure 1: Opening an Example Input File

3. Open the Projects > ADPPView > Examples directory by using the look in feature of the Open 
Window, see Figure 1. 

4. Select the file in this directory called example.trn by double clicking the mouse on the file name 
in the Open Window. The example transient wil l be opened in the main window, see Figure 2.
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Figure 2: Main Window with Transient Input File Display

The Transient-State Analysis Component can be used to obtain a drain spacing based on field and 
deep percolation data. A data check list for this component is in Appendix B. This check list is a 
complete list of all the data required for ADPP View to calculate a drain spacing. The main window 
displays all the information needed to build a transient-state input file, for specific instructions on 
how to use this window, see “Section 3.0: Transient-State Analysis Component” . 

5. The input data can be edited, plotted, and saved as can be seen from Figure 2.

6. Select the Model > Bench & Bottomlands option to enter a value for the Available Water Holding 
Capacity (AWHC). This information will be used to set the criteria for bench and bottomlands, see 
“Section 5.3: Model Pull-Down Menu” . 

7. When all the information required is entered, select the  icon or Model > Run Transient 
Model.

8. An output file for the transient model run will be created and displayed in the main window. For 
information on this window, see “Section 3.0: Transient-State Analysis Component” .

9. The output file will have an “ .otr” extension and will be saved into the same directory as the input 
file. Output can be viewed, plotted, printed, or saved into a text file, see “Section 3.7: Transient 
Model Output Window” .
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3.0   Transient-State Analysis Component

3.1 Transient-State Drain Spacing

The Transient-State Analysis Component uses the transient-state equation for drain spacing as 
developed by Lee Dumm, Ray Winger, Jr., and Robert Glover of the U.S.  Bureau of Reclamation.  The 
Hooghoudt's Correction for Convergence is used to account for convergence loss.

The program will calculate a drain spacing and provide a number of tables summarizing the results of 
the calculation.  One of these tables shows projected water table fluctuation using a drain spacing computed 
by the program or entered by the user.  

A data check list for this component is in Appendix B. This check list is a complete list of all the data 
required for ADPP View to calculate a drain spacing.

3.2 Running the Transient-State Component

1. Click on the File pull-down menu, options will be displayed for opening and creating new files, see 
Figure 3.

Figure 3: New File Selection.

2. Select the File > New Transient option and the OK  button. For information on the ADPP Risk 
option see “Section 4.0: Uncertainty Analysis Component” .

3. A new transient input file editor window will be displayed, as shown in Figure 4.
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Figure 4: New Main Window for Transient Model Input.

3.3 Title for Transient Input File

A title for the input file can be entered here to document details relevant to the individual user. This field 
can contain any text relevant to the input file and will be saved as part of the input to the model. Additional 
comments can be entered in the Comments section of the window and will also be stored with the input file, 
as shown in Figure 4.

3.4 Input Mode for Transient Input File

The model can be run in design mode or analysis mode using the radio button and it also has the option 
of using English or metric units, as shown in Figure 5. 

3.4.1 Input Modes
Design mode is for a hypothetical drainage design or to design a new drainage system. The program 

uses a deep percolation schedule, hydraulic conductivity, specific yield, and maximum water table above 
the drain to adjust drain spacings so that the water table reaches a “dynamic equilibrium” over the course of 
a year, see Figure 6. 

From the field data, a determination is made whether to use on-barrier or off-barrier case, based on the 
calculation of d/Yo (Yo is the height of the water table, relative to the drain depth, at midpoint between 
drains after each irrigation event and d is the depth to the barrier). If the ratio is less than 0.1, the program 
will use the on-barrier case. If the ratio is greater than 0.1, the program will use the off-barrier case. 

If Analysis mode is selected, it is assumed that the you are evaluating an existing system, therefore the 
Existing Drain Spacing is entered directly. In this case, the model does not determine the “dynamic 
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equilibrium” of the water table, but instead computes the water table elevation.

Note - When the Input Mode is set to Analysis or Design, the input for the other mode is grayed out, 
indicating that it can’ t be entered.

Figure 5: Selecting Unit Type and Input Mode.

3.4.2 Unit Type
You can enter your data in metric or English units, see Figure 5:

• English - (acres, feet, and inches)

• Metric - (hectares, meters, and centimeters)

3.5 Field Data for Transient Input File

All data fields will be zero unless data were previously entered or viewed. There are the following data 
entry fields for the field data, see Figure 6

:

Figure 6: Field Data for the Transient Model.

1. Permeabil ity - Also, called hydraulic conductivity, permeability is how far water can move in a 
given time period. This quantity is typically calculated using Darcy’s Law, see the glossary for more 
information. This quantity is expressed in feet or meters per day.

2. Maximum Water Table Above the Drain at M id-Spacing - Used in the design input mode.

3. Drain to Barr ier - This is the distance from the drain to an impermeable barrier below and can be 
entered in meters or feet.

4. Specific Yield - This is the ratio of the volume of water yielded by gravity drainage from a saturated 
volume of porous media to the initial volume of saturated porous media and is entered as a fraction.

5. Drain Radius - This is the radius of the installed or proposed drain, including drain pipe and gravel 
envelope.

6. Depth to the Drain - This is the distance from the ground surface to the drain.
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7. Existing Drain Spacing - If the input mode is set to Analysis, the existing drain spacing can be 
entered.

8. AWHC for top 5 ft of Soil - AWHC (Available Water Holding Capacity) is defined as the 
difference between the amount of soil water at field capacity and the amount at wilting point and is 
entered as centimeters or inches.

Note - This option is only available if the Bench and Bottomlands selection is made in the Model 
pull-down menu, see “ Section 5.3: Model Pull -Down Menu” .

3.6 Deep Percolation Schedule for the Transient Input File

This option can be used to enter the dates and amounts of each deep percolation event, either from an 
irrigation or rainfall event.

Figure 7: Deep Percolation Schedule Example.

3.6.1 Add Button For the Deep Percolation Schedule
 You can add as many deep percolation events as you want by putting the number of events to add under 

the Add button (i.e. # to add field) and pressing Add, see Figure 7.

3.6.2 Delete Button For the Deep Percolation Schedule
This button can be used to delete deep percolation events using a window with the current events. To 

delete an event select the event and the OK  button in the Delete window, see Figure 8.
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Figure 8: Deleting Deep Percolation Events.

3.6.3 Plot Button For the Deep Percolation Schedule
This option will display a graph that shows the deep percolation schedule, this graph can be printed or 

imported into a word processing program, see Figure 9.

Figure 9: Typical Plot of Deep Percolation Schedule.
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3.7 Transient Model Output Window

Figure 10: Output Window for Transient Model.

The Output Window has the following options:

1. Plot - Plots the output data in a graphing package, as shown on the cover.

2. Print via Wordpad - Opens the output file in wordpad and you can print the output using different 
fonts or settings.

3. Write - Writes a text file.

4. Done - This closes the output window.

5. Help - Opens a help file for the output window.
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4.0   Uncertainty Analysis Component

4.1 Drainage Design Under Uncer tainty

The Uncertainty Analysis Component uses the variability in the data to arrive at a reliabil ity for the drain 
design. This method is based on Donnan's Steady-State Equation. The Uncertainty Analysis Component 
uses two methods to model uncertainty in drainage design. The Risk Analysis Method measures the 
uncertainty associated with soil characteristics and the Loss Function Analysis measures the uncertainty 
with different crop characteristics. To give an idea of the data needed for computing Uncertainty, a data 
check list for this component (see “Section 7.2: Uncertainty Analysis Component Check List” ).

There are two classes of uncertainty in drain design problems: the natural spatial variability and 
information uncertainty.  The natural spatial variability assumes some inherent uncertainty that cannot be 
reduced by sampling.  The information uncertainty represents the lack of information, in quantity or quality 
or both.

Simple methods have been developed to deal with the uncertainty. To deal with large-scale spatial 
variability, fields are divided into subareas based on trends in soil properties. To account for the small -scale 
spatial variations and informational uncertainty in soil properties, guidelines for drainage design using an 
average value as an estimate of soil parameters have been implemented. 

1. Click on the File pull-down menu, options will be displayed for opening and creating new files, see 
Figure 11.

Figure 11: New Risk File Selection.

2. Select the File > New Risk option and the OK  button. For information on the ADPP Transient 
option see “Section 3.0: Transient-State Analysis Component” .

3. A new uncertainty risk analysis input file editor window wil l be displayed, as shown in Figure 4.
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Figure 12: New Main Window for Uncertainty Risk Analysis Input.

4.2 Uncer tainty Risk Analysis Model Options

There are three selections for overall model options along the top of the input file data entry window as 
shown in Figure 12.

4.2.1 Analysis Evaluation
There are two options for the type of analysis you want to preform, these options work like toggle 

switches only one can be selected at a time:

1. Risk evaluation for a given design - This approach allows you to determine the uncertainty and 
risk with a given drainage designed entered into the data tab sheets. The Single Design Evaluation 
tab wil l be displayed in the input window, when this option is selected.

2. Analysis of a range of designs for a cer tain r isk - This approach will allow for parameters that 
are flexible within a certain prespecified risk. The Analysis of a Range of Designs tab will be 
displayed in the input window, when this option is selected.

4.2.2 Uncertainty Analysis Option
These options allow you to set a certain reliability for the model or to specify a range of benefits based 

on typical mathematical relationships:

1. Loss Function Analysis - This option will display the Loss Function Analysis tab for data entry.

2. Risk Analysis - This option will display the Risk Analysis tab for data entry.

Model Options

Data Entry



Uncertainty Analysis Component

Version 1.0 13 Data Entry Tabs for Uncertainty Risk Analysis

4.2.3 Units
All the units for data entry and displaying model results can be set to metric or standard using this 

option. The model does not allow the mixing of unit types.

4.3 Data Entry Tabs for Uncertainty Risk Analysis

All the data for this model is arranged in tabs for easy entry. Some of the tabs can change depending on 
the model options selected in “Section 4.2: Uncertainty Risk Analysis Model Options” . 

4.3.1 Field Data Tab

Figure 13: Uncertainty Risk Field Data Tab

This tab has the following eight fields and options for field data:

1. Type of Pipe - There are three options for the type of pipe including plastic, concrete, or clay.

2. Drain Radius (r ) - in meters or feet.

3. Depth to barr ier (d) - This is the depth to an impermeable barrier in meters or feet. Typically drains 
are needed in agricultural lands with an impermeable barrier that does not allow for the proper 
drainage of the land.

4. Standard deviation of (d) - Since the distance to the barrier may fluctuate across the field the 
distribution can be modeled by using the standard deviation in meters or feet.

5. Hydraulic conductivity of soil (K ) - This should be entered as the best estimate of the average 
hydraulic conductivity in the soil in m/day.

6. Standard deviation of (K) - This option can be used to characterized the distribution of hydraulic 
conductivity in the soil.

7. Recharge rate (Qd) - This field specifies how long it takes to recharge the soil after it has been 
drained. This value may be different then the rate at which the water drains specified by the 
hydraulic conductivity and can be entered as meters per day.

8. Standard deviation of (Qd) - As with the other parameters the standard deviation of the recharge 
rate can be specified.
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4.3.2 Cost Data Tab

Figure 14: Cost Data Uncertainty Risk Tab

The Cost Data tab is used to calculate the cost of the drainage system, it has the following data fields:

1. Interest rate to be used - Enter this value as a whole number (i.e. 8 and not 0.08), this is the interest 
rate for the loan to build the drainage system.

2. Cost of O and M  - This is the cost that can be expected for the operation and maintenance of the 
system per linear meter or foot. This value should be entered per year.

3. Life of the system - The life of the system should be estimated in years.

4. Average of pipe costs - This is an entered value for the average pipe cost per linear meter or foot. 
The cost for different pipe categories can be entered by using the distribution of various pipe sizes 
by using the next option.

5. Distr ibution of var ious pipe sizes - This option can be used to enter different costs for different 
pipe sizes. For each pipe size the gravel envelope and pipe costs can be entered separately. The 
percentage should correspond to the amount of total pipe length represented by the different pipe 
sizes. The following parameters can be entered:

• Pipe Diameter - The listed pipe sizes are standard and are the only pipe sizes that can be used.

• Pipe Cost - This is the cost per linear foot for the diameter of the pipe specified.

• Gravel envelope cost - This cost can include a higher cost for excavation and gravel.

• % of lateral - This should be entered as the percent of the total pipe lengths represented by the 
pipe diameter size.
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4.3.3 Trenching Machine Tab

Figure 15: Trenching Machines Uncertainty Risk Tab

Two options are available for the trenching machine:

1. Constant Speed - For the constant speed trenching machine the speed and cost can be entered. 

• Rate of installation - This field specifies the rate of the trenching machine in meters/minute.

• Cost per minute of installation - This field specifies the cost per minute of operation and 
maintenance of the trenching machine.

2. Var iable Speed - Variable speed trenching machines have different speeds and/or costs depending 
on the depth of the installation, the following fields can be entered:

• Maximum depth of installation - This field specifies the maximum depth the machine can be 
used in meters or feet.

• Minimum rate of installation - This field specifies the intercept for the linear equation to be used 
to determine the cost of the trenching machine based on depth.

• Slope of depth vs. installation - This field specifies the slope of the linear equation for 
determining the cost of the trenching machine.
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4.3.4 Analysis of a Range of Designs Tab

Figure 16: Analysis of Design Range Uncertainty Risk Tab

If the analysis of a range of designs is selected as one of the model options, see “Section 4.2.2: 
Uncertainty Analysis Option” . There are two sections of fields that can be entered for the Analysis of 
Design Range Tab:

1. Depth Information - The following parameters can be used to limit the designs to be considered:

• Minimum depth to be considered - Only designs with a depth greater than that entered in this 
field wil l be displayed in the output.

• Maximum depth to be considered - Only designs with a depth less than that entered in this field 
will be displayed in the output.

• Increment in depth to be considered - This field can be used to specify the scale of designs that 
will be considered.

2. Spacing Information - The following parameters can be used to limit the designs to be considered:

• Minimum spacing to be considered - Only designs with a spacing greater than that entered in 
this field will be displayed in the output.

• Maximum space to be considered - Only designs with a spacing less than that entered in this 
field wil l be displayed in the output.

• Increment in space to be considered - This field can be used to specify the scale of designs that 
will be considered.
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4.3.5 Loss Function Range Tab

Figure 17: Loss Function Range Uncertainty Risk Tab

The loss function analysis calculates benefits derived from irrigation against losses that occur with 
inadequate drainage. The loss function is one way to determine the parameters for a risk assessment, the 
other option is to use the reliability of the system and the depth to the water table to calculate a cost. This 
option is described in “Section 4.3.7: Risk Analysis Tab”, the choice of analysis functions is set as one of 
the modeling options “Section 4.2.2: Uncertainty Analysis Option” .

All curves rise to the optimal dewatering zone in a parabolic curve with the percent of root zone above 
water table (x axis) versus crop yield (y axis). Once a type of loss function has been chosen, the program 
prompts for depth to water table for maximum yield. For Bureau of Reclamation projects, the depth to water 
table is 4 feet. On very few occasions and only with very good, data-related reasons does Bureau of 
Reclamation allow the water table to be less than 4 feet below ground surface in design of subsurface drains.

1. The left curve shows the percent of root zone above water table (x axis) versus crop yield (y axis). 
After the optimum is reached, the yield remains at the optimum as the dewatering zone increases. 
This represents the condition when the supply of irrigation water to the crops is provided at frequent 
intervals with more aeration for the roots. After the optimal depth is achieved, the deeper depth 
increases aeration. With frequent irrigation, the water for the plants comes from downward 
percolation and the water table does not contribute to crop water use.

If the left curve has been chosen, the coefficients of the loss function should be entered. The default 
value for A is -.500 and for B is 1.514. Pressing the enter key accepts these default values. The user 
may, of course, use different values for A and B.

2. The middle curve shows the percent of root zone above water table (x axis) versus crop yield (y 
axis). Once the optimum is reached, the yield declines to an asymptotic value. This case represents 
two possible conditions. The first is where there are frequent irrigations applied to a very porous 
soil. The water percolates very rapidly to the ground-water table and the time of downward 
percolation is not sufficient to meet the plant's need, so upward capillary movement is important. 
As the dewatering zone increases, the water available from upward capillary movement decreases 
and yields decline to that which is supported by the downward percolation. A second condition 
occurs with infrequent, intensive irrigation on a soil with high capillarity, such as clay. The 
downward percolation takes relatively longer to reach the water table. However, since the time 
between irrigation events is long, the groundwater becomes an important supply of water for the 
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plants at the end of the non-irrigation periods. As the dewatering zone becomes larger, water is 
unable to reach the root zone and yields decline to those that can be supported by the downward 
percolation.

3. The curve on the right shows the percent of root zone above water table (x axis) versus crop yield 
(y axis). This curve represents the condition of infrequent irrigation on a very porous soil where the 
irrigation water percolates very rapidly to the water table. Groundwater is a main source of water 
supply for the plants. As the dewatering zone becomes larger, less and less water is available to 
sustain the plants.

These curves represent the crop yield based on the depth to the water table and will be used to calculate 
a loss in crop yields due to conditions in the root zone.

4.3.6 Single Design Evaluation Tab

Figure 18: Single Design Evaluation Uncertainty Risk Tab

This option is used to enter the criteria for a single design, multiple designs can be used by changing the 
model option (see “Section 4.2.1: Analysis Evaluation”) to a multiple design and the Analysis of a Range 
of Designs tab will be displayed (see “Section 4.3.4: Analysis of a Range of Designs Tab” ). The Single 
Design tab has the following data fields:

1. Spacing to be considered - This field specifies the spacing between drains in meters or feet.

2. Depth to be considered - This field specifies the depth to the drains in meters feet.

3. Critical depth to water table - This field specifies the depth to the water table that should be 
maintained by the design.

A single drainage design will be created based on these three criteria. There is a limit to options for the 
risk analysis when this option is selected since multiple designs cannot be created, the loss function should 
be used for the analysis (see “Section 4.3.5: Loss Function Range Tab” ).
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4.3.7 Risk Analysis Tab

Figure 19: Risk Analysis Uncertainty Risk Tab

The Risk Analysis tab should be used for analysis of a range of designs and not for a single design. This 
option is used to enter the criteria for a risk analysis, loss functions can be used by changing the model 
option (see “Section 4.2.2: Uncertainty Analysis Option” ) to a multiple design and the Loss Function 
Range tab will be displayed (see “Section 4.3.5: Loss Function Range Tab”). The Risk Analysis tab has the 
following data fields:

1. Critical depth to water table - This field specifies the depth to the water table from the surface 
that should be maintained by drainage designs in meters or feet.

2. Given reliability to find - This field specifies the reliabili ty that should be maintained as a 
percentage of the total (i.e. enter 80 and not 0.8 for 80% reliable).

3. Produce a table and graph of reliabili ty vs. cost -

• Minimum reliability - This field specifies the minimum reliability that should be considered for 
a design to be included.

• Maximum reliability - This field specifies the maximum reliability that should be considered 
for a design to be included.

• Increment - This field specifies the resolution to include designs, for example designs that were 
70%, 80%, and 90%, could be included by setting the increment at 10%.
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5.0   Pull-Down Menus

5.1 Subwindow options

Figure 20: Subwindow Options

For each subwindow in the main window there are options for managing the window features that can 
be accessed by the  icon or by using the options in the upper right of each window. 

Note - Input file windows can be iconified, displayed in full-view, or closed using the buttons on the 
upper right of each window. The horizontal line iconifies a window, the square or double 
square displays the window in full or partial view, respectively and the “ x” symbol closes the 
window.
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5.2 File Menu

Figure 21: File Pull-Down Menu for the Main Input File Window.

1. File > New Transient - The new option displays a blank transient model input file editor window 
in which all the data must be entered by hand or pasted from a spreadsheet program.

2. File > New Risk - The new option displays a blank risk analysis input file editor window in which 
all the data must be entered by hand or pasted from a spreadsheet program.

3. File > Open - When the software is installed it wil l create example files in the directory where the 
program is installed (See Section 2.0 “Quick Start for ADPP View”). The Open Window can be 
used to open transient or risk analysis input and output files. Options for the types of f iles that can 
be opened can be changed in the Open Type field, see Figure 22.

Figure 22: Open Files of Type Option.

There are four types of files that can be opened in ADPP View:

• Transient Input files (* .trn) - Input files for the transient model.

• Risk Analysis Input Files (* .rsk) - Input files for the risk analysis model.

• Transient Output Files (* .otr) - Output files for the transient model.

• Risk Analysis Output Files (* .unc) - Output files for the risk analysis model.

4. Close - Closes the current file with an option to save.

5. Save - Saves the current version of the input file with the same name.

6. Save As - This option allows you to change the name and location of the file when you save it.
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Figure 23: Save As Window

7. Display of Recently Opened Files - The files in the list on the bottom of the File pull-down 
window can be opened by clicking on them with the mouse.

8. Exit - Exits ADPP View with an option to save.

5.3 Model Pull -Down Menu

Figure 24: Model Pull-Down Menu

The Model pull-down menu is not displayed until an input file is opened. You can open an input file be 
selecting Open in the File pull-down menu or you can create a new file by clicking on the icons “Section 
5.4: View Pull-Down Menu” . Two options will be displayed for the transient model:

1. Run Transient Model - This option creates a new transient input file, called “Transient1” , the 
name should be changed before it is saved. 

2. Bench & Bottomlands - This option adds an additional input field to specify the AWHC (Available 
Water Holding Capacity). AWHC is defined as the difference between the amount of soil water at 
field capacity and the amount at wilting point and it is basically the capacity of the soils to hold 
water that would be available for plants, see Figure 25. This option is used to specify the first five 
feet of soil below the surface of the field being modeled.

Figure 25: Additional Option for Specifying AWHC for Bench and Bottomlands Criteria.

Additional Option for AWHC
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If an uncertainty file is open, then the menu will show an option for running the uncertainty model:

3. Run Uncertainty Model - This option runs an uncertainty model using the current input file.

5.4 View Pull-Down Menu

Figure 26: View Pull-Down Menu

The View pull-down menu has two options, that are toggle switches to change the ADPP View display:

1. View > Toolbar  - This displays the tool bar with the following options:

Figure 27: ADPP View Toolbar

• New Transient Input File - Opens new input file for the transient model.

• New Risk Input File - Opens a new input file for the Risk Analysis model.

• Open File - Opens existing input file.

• Save File - Saves current version of input file.

• Run Model - Runs the current ADPP Model input file (i.e. Risk or Transient).

2. View > Status Bar  - The status bar contains information about the workings of the program and 
can be displayed or not depending on the setting of the option. It is located in the lower left corner 
of the main window.

5.5 Window Pull -Down Menu

Figure 28: The Window Pull-Down Menu

Options for the Window pull-down menu:

1. Window > New Window - This option opens a new window displaying the same file.

New Transient
Save FileOpen File Run ModelNew Risk



Pull-Down Menus

Version 1.0 25 Help Pull-Down Menu

Note - This new window cannot be seen if the current window is maximized, to view the new window 
select the iconify option (See Section 5.1 “ Subwindow options” ).

2. Window > Cascade - If there are multiple file windows open, this option will cascade the windows 
in the main window.

3. Window > Tile - If there are multiple file windows open, this option will tile the windows in the 
main window.

4. Window > Arr ange Icons - If there are multiple file windows iconified, this option will arrange 
the icons in the main window.

5. Subwindow Selection - The subwindows that are currently open are displayed along the bottom of 
the menu and can be selected with the mouse.

5.6 Help Pull-Down Menu

Figure 29: The Help Pull-Down Menu

The Help pull-down menu option are:

1. Help > Help Topics - Displays the on-line version of the help documentation. This on-line help file 
parallels this document. There is an index and search features available with the on-line help files.

2. Help > About ADPP View - Displays the current version number of ADPP View.
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6.0   Appendix A: Glossary of Terms

This section is intended to provide the user with definitions of terms and units for the data input to and 
output from the program.  Many of these are common terms in the ground-water and drainage fields.

ADPP - 
Acronym for Advanced Drainage Planning Program

Barr ier - 
A layer which has a hydraulic conductivity of one-fifth or less the weighted conductivity of the strata 
above it.

Critical Depth to Water - 
The elevation below the ground surface that the user would like to keep the ground water below.  In 
many cases this elevation is the depth of the root zone.

Deep percolation - 
Water which percolates below the root zone and cannot be used by plants.

Donnan’s Steady-State Equation - 
The steady-state drain spacing formula generally used in the irrigated areas of the United States.  
Donnan's formula is: 

 where:

L = drain spacing (L) 

K = hydraulic conductivity (L/T) 

a = distance between drain depth and barrier (L)

 b = distance between maximum allowable water table height between drains 

and the barrier (L)

 Qd = recharge rate (L/T)

Donnan's formula is valid for any consistent set of units.

Drain radius - 
The radius of the installed drain, including drain pipe and gravel envelope.

L2 4K b2 a2–( )
Qd

------------------------------=
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Drainage Manual - 
Technical publication of Bureau of Reclamation, Denver, Colorado, which includes technical policy 
guidelines on drain investigations, design, construction, and operation and maintenance.

Hydraulic conductivity -
 The constant of proportionality (K) in Darcy's Law (Q=KiA) that relates the product of the hydraulic 
gradient (i) and the cross sectional area through which flow takes place (A) to the ground-water 
discharge (Q).  K is a function of the porous media and the fluid flowing through it.  Formally called 
the coefficient of permeability or simply permeability.  Contemporary use of the term permeability is 
generally reserved for the intrinsic permeability, a porous media property independent of the fluid.

 I rr igation/deep percolation schedule - 
Time and amount of water applied to irrigated land for crop requirement and leaching 

requirement.

Permeabili ty - 
see Hydraulic Conductivity

 Qd (recharge rate) - 
The steady-state rate at which water is added to the ground-water system.  See Donnan's equation.  
Since Donnan's equation is a steady-state solution, the drain outflow equals the recharge rate and Qd 
is also called the drainage coeff icient.

Root Zone - 
The uppermost portion of the soil profile in which the moisture-oxygen-salt balance is favorable for 
plant growth.

Specific yield - 
The ratio of the volume of water yielded by gravity drainage from a saturated volume of porous media 
to the initial volume of saturated porous media.

Standard deviation - 
A measure of the dispersion or spread of numerical data for the mean or average.  Standard deviation 
is the root mean square of the deviations from the mean.

Steady-state analysis - 
An analysis based on the premise that the hydraulic head is constant with respect to time for all points 
in the flow field.

Transient-state analysis - 
Analysis based on the premise that the hydraulic head varies with respect to times at any point in the 
flow field.

Uncer tainty - 
There are two classes of uncertainty in drain design problems: the natural spatial variability and 
information uncertainty.  The natural spatial variability assumes that the soil -water system is a 
stochastic system with some inherent uncertainty that cannot be reduced by sampling.  The 
information uncertainty represents the lack, in quantity or quality or both, of information concerning 
the soil properties.

Water table - 
The imaginary surface in an unconfined ground-water body at which the water pressure is 
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atmospheric.

Weighted Average Hydraulic Conductivity (equivalent hor izontal hydraulic 
conductivity) - 

A means of representing a layered system in which each layer has different hydraulic conductivity as 
a single homogeneous layer with a single (equivalent) hydraulic conductivity.  Expressed 
algebraically as:

:

where:

 Kw = the weighted average hydraulic conductivity, (L/T)

 Ki = the hydraulic conductivity for interval i, (L/T)

 di = the thickness of interval i , (L)

 n = the number of depth intervals used to represent the average saturated 

thickness (-).

Yo - 
Height of the water table at the beginning of each new drain-out period.  Yo is measured at midpoint 
between drains and is relative to the drain depth.

Kw

Kidi

i 1=

n

∑

di

i 1=

n

∑
---------------------=
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7.0   Appendix B: Data Check L ists

7.1 Transient-State Component Check List

❏  = > ? @ A B C D E F G H ? B E I D J D I > G @ K L @ M L A N D C D I > O D H P L L I Q ? A > G @ M L I L @ R Q ? A > S
❏  T U L M A V D M B M A C C G W A N C L W A I L @ I A N C L A N G J L I U L ? @ A D H A I I U L M D ? X Y G D H I G P I U L? @ A D H O D H P L L I G @ M L I L @ R S
❏  T U L ? D R I A H E L P @ G M I U L ? @ A D H I G N A @ @ D L @ O D H P L L I G @ M L I L @ R S
❏  Z Y L E D P D E > D L C ? O A ? L E D M A C H B M N L @ S
❏  T U L @ A ? D B R G P I U L ? @ A D H O D H E C B ? D H [ Y D Y L A H ? [ @ A J L C L H J L C G Y L D H P L L I G @ M L I L @ R S
❏  \ L Y I U I G I U L ? @ A D H D H P L L I G @ M L I L @ R S
❏  T U L H B M N L @ G P D @ @ D [ A I D G H A H ? Y L @ E G C A I D G H L J L H I R S
❏  T U L ? A I L G P D @ @ D [ A I D G H L J L H I R D H M G H I U R A H ? ? A > R S
❏  \ L L Y K L @ E G C A I D G H J A C B L R D H D H E U L R G @ M D C C D M L I L @ R S
❏  ] P I U L ? @ A D H D R G H I U L N A @ @ D L @ G @ D P I U L ? @ A D H D R G P P I U L N A @ @ D L @ S
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7.2 Uncer tainty Analysis Component Check L ist

❏  T > Y L G P Y D Y L O L D I U L @ Y C A R I D E O E G H E @ L I L O G @ E C A > S
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