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USING 

Music is a kind of counting performed by the 
mind without knowing that it is counting.

G.W. Leibnitz (1714)

Mathematics is music for the mind. 
Music is mathematics for the soul.

Anonymous (18th century)
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Chapter 1 Introduction to SmartScore

1.1 What SmartScore does...
1.1.1 Scan and play

With SmartScore, you are able to scan, recognize and playback sheet 
music in just minutes. To listen, just hit the space bar! Assign different 
MIDI sounds to each instrumental part and recreate a band or an 
orchestral performance. Assign different sounds to contrapuntal voices 
to create interesting and unusual textures of sound or to emphasize 
inner voices in complex arrangements. Recognition of dynamics, artic-
ulations, repeats and endings gives added nuance and realism during 
playback. Students can listen to an unfamiliar piece before learning it. 
Practice along while playing back at various tempos without altering 
pitch or key. Mute or solo one or more parts on the fly. Parts selected 
by name are automatically assigned proper MIDI instruments and 
maintain playback continuity even with optimized scores. Transposed 
instruments notated in different keys will play back in tune. Automati-
cally add drum tracks to playback... choose from many preset styles or 
create your own drum tracks from imported MIDI files. You can even 
record playback to audio-CD with the built-in CD burner.

1.1.2 Scan and work

While playback of sheet music has its uses, it is just the beginning. 
SmartScore has intelligent tools that will enable you to transform your 
scanned score into virtually any configuration. You can transpose and 
print out your music into a new key including any changes of key, time 
and clef. Transpose globally or by selected region; by key or by clef. 
Transform a viola part in C to a horn part in F. Recognized guitar frets 
and chord symbols automatically transpose along with notes and key 
symbols. Instrumental parts or contrapuntal voices can be extracted to 
new SmartScore documents using Visibility in the System Manager. 
Solo part scores can be scanned in and joined into a conductor’s score 
with drag-and-drop ease using Score Structure. Preserve proper play-
back of instruments that appear and disappear throughout the score by 
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Introduction to SmartScore
using Part Linking tool. Printed output can be reformatted by resizing 
staffline, staff and system spacing and page margins. It’s all possible 
with SmartScore. 

1.1.3 Turn MIDI files into music notation

Transform your favorite MIDI files into engraver-quality music nota-
tion. If the MIDI file contains complex voicing in a track, SmartScore 
can separate them into independent voicelines. If voices are joined into 
chords, use SmartScore’s voice-splitting tool to separate them into dis-
crete contrapuntal voices. 

1.1.4 Create scores from scratch

By selecting one of 15 templates, you can create musical scores from 
scratch. Drop in one key and time signature, press a button and the 
entire score is updated. Need more space between staves? Change one 
setting and apply to the current system, subsequent systems, page, part 
or entire score. For easy score editing, refer to the Quick Key card. 

1.1.5 Sequence and record

View and edit the MIDI data of your scanned music in the familiar 
Overview, Piano Roll and Event List format. Record your MIDI perfor-
mance either as an accompaniment to your scanned music or in layered 
tracks and transform it into musical notation. Record drum tracks from 
your computer keyboard while listening to the playback using Virtual 
Drums. 

1.2 So, what do you want to do?
• Scan and play back sheet music? 

Scan > Recognize > Playback > Karaoke
• Transpose

Edit > Transpose > Print
• Create score from scratch? 

Choose Template > Assign Instruments
• Create score from MIDI keyboard? 
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Choose real-time or step time
• Create score from imported MIDI or NIFF files?

Choose Import MIDI or NIFF
• How would you like to output your score?

Print ENF file / Create PDF file / Export to Finale® / Export 
MusicXML files to other scorewriter programs / Export MIDI 
files / Export to NIFF files / Record playback to CD

1.2.1 What Edition does what.

Not all SmartScore editions can accomplish everything listed above. 
Excluding SmartScore Pro, all other editions have limitations. The fol-
lowing chart lists the limitations of each edition.

Table 1: SmartScore Edition Limitations

Limited 
Edition 

Feature Set

Number 
of 

Staves
proces-

sed

Text &
Lyrics 

Print Guitar 
and 

Chord 
Symbol

Score 
Structure

MIDI /
Drum 

Tracks /
Virtual 
Drums

SmartScore 
Pro

32 Yes Yes Yes Yes Yes

Songbook 
Edition

3 Yes Yes Yes Yes Yes

Piano
Edition

2 No Yes No No No

Guitar 
Edition

1 No Yes Yes No No

MIDI
Edition

4 No No No No Yes
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1.3 How to use this manual
An excellent way to start using SmartScore is to turn to the Quick 
Tour on page 7. As you scan, recognize, play back and edit your files, 
turn to the corresponding chapter in this manual. Later chapters will 
help you to work with text and symbols, to change the structure of your 
score, to do detailed editing and to operate in a MIDI environment. 

This manual is fully indexed and cross-referenced. The easiest method 
of obtaining information on any topic is to look it up in the Index on 
page 254 then turn to listed page(s). Detailed descriptions of Smart-
Score menu items can be found in Reference chapter on page 221.

1.3.1 What Edition symbols mean

This manual is written for all editions of SmartScore. Features 
described that do not apply to all editions will have a symbol in the left 
margin.

• SmartScore Pro Edition

No restrictions. All features and descriptions in this manual apply to 
SmartScore Pro Edition.

• Not found in MIDI

Indicates the feature or description does not apply to MIDI Edition.

• Not found in MIDI or Guitar Editions

Indicates the feature or description does not apply to either MIDI or 
Guitar Edition.

• Not found in MIDI or Piano Editions

Indicates the feature or description does not apply to either MIDI or 
Piano Edition.

• Not found in Piano or Guitar Editions

Indicates the feature or description does not apply to either Piano or 
Guitar Edition.
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1.4 What to do when this manual does not help...
When you register your copy of SmartScore, you become eligible for 
technical support for as long as you own the product. But before you 
reach for the phone, try to solve your issues first by referring to this 
manual. E-mail is the most efficient method of communicating with 
Musitek Technical Support. It is likely that we will ask you to e-mail us 
any scanned image files and/or SmartScore files along with a brief 
description of the problems you are encountering. 

Technical Support E-mail address is: tech@musitek.com

Telephone Support number is: 805-646-5841

Musitek’s Support mailing address is:

Musitek Technical Support 
410 Bryant Circle, Suite K 
Ojai, CA 93023

If you must phone in for help, we ask that you have a few things ready 
before calling Technical Support:

• Please have your computer on with SmartScore up and running
• Please have the following information ready to give the support 

technician: 

Customer ID:_____________ Serial Number:____________________ 

• SmartScore Version Number  
(found under Help > About SmartScore)

• Windows or Macintosh operating system of your computer.
• Make and model of scanner you are using
• The type of music you are scanning (orchestral, pop song, piano 

score, etc.).
• Your e-mail address.
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Chapter 2 Installation and  
Quick Tour

2.1 Installation
SmartScore will operate correctly only when the original installer is 
used. Copying either the download or the CD installer will not work. 
You are allowed to install SmartScore up to 5 times before it will be 
necessary to contact Musitek Technical Support at 805-646-5841 or by 
e-mailing tech@musitek.com for a reset. CD installation is as follows:

a. Make sure you are connected to the Internet prior to installing 
SmartScore. If you do not have Internet access or if online verifi-
cation / confirmation fails, contact technical support at 
tech@musitek.com.

b. Insert the SmartScore CD into your computer’s CD drive.
c. (Windows) Inserting CD should launch Auto-run. If not, Push 

Start > Run and Browse to find your CD drive in the “Look In” 
pull-down. Double-click SS5INSTALL.EXE. 

d. (Macintosh) Double-click SmartScore CD icon on your desktop. 
Double-click SS5INSTALL.

e. Follow all installation steps including entering Serial Number, 
Customer ID and registering your copy of the software.

f. Installation requires online registration and verification. File sav-
ing and printing will be disabled after 30 days if registration is 
not completed. If you are unable to register online, please contact 
support at 805-646-5841 or tech@musitek.com.

g. Launch SmartScore by double-clicking its icon. 

2.2 Recognition of Sample Files
SmartScore includes several pre-scanned TIFF files. Normally, you 
will use your scanner to capture and recognize your own sheet music. 
For instructions on scanning, turn to page 27.
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For the purpose of this tutorial. we will start with sample file,  
Fandango.tif. 

a. If the SmartScore Task Window is open (Ctrl + “W” will open 
it at any time), push the “Recognize Scans” button. The Naviga-
tor and the SmartScore toolbar also have a Recognition button. 

NOTE: The Task Window opens automatically only at program start. 
It can be launched at any time with Ctrl + “W” or by select-
ing it from the Windows menu. 

The Begin Recognition window opens. This is the window you will 
use to select previously-scanned music for recognition. 

FIGURE 2 - 1: Begin Recognition window

b. Press Add Files to List. In the Open dialog box, double-click on 
the sample file, Fandango.tif, inside the SmartScore folder. This 
will add the pre-scanned file to the list. 

c. Press Begin Recognition. 

2.2.1 Unfiy Key and Time

A Unify window opens (Default = Key signatures based on the topmost 
staffline in each system). Click OK to accept. See "Unify Score (“U”)", 
Section 8.6.4, on page 144 for more details on Unify Key and Time.

2.2.2 System Report

This window will list the total number of systems found as well as the 
largest and smallest number of parts found in all systems. This informa-
tion may reveal problems with broken systems / missing parts often due 

8  USING SmartScore



Installation and Quick Tour
to incorrectly scanned pages. If the information in the report does not 
agree with the original score, check your scanned pages in the Image 
Editor or quickly scroll through the ENF file to locate problem systems. 

If part / system inconsistencies are due to mis-scanned pages, relinking 
parts is possible in the ENF editor, but we usually recommend re-scan-
ning poorly scanned pages instead. Refer to "Removing, replacing and 
re-saving scanned pages", Section 3.4.2, on page 39 for information 
about replacing individual pages in your multiple-page TIFF files. See 
Section 3.2.2 on page 35 for more details on interpreting the System 
Report. See “Re-linking parts” on page 78 for information on how to 
re-link broken or irregular systems.

• Press Open ENF to open the SmartScore ENF file.
• Press Open Image Editor to view and/or edit the scanned image 

file.
• Press Open Super System to view all parts located during recog-

nition. If more parts appear in the score than are found in the 
Super System, they can be added. See "Super System", 
Section 8.10.5, on page 158 for more details.

NOTE: You can choose to disable the system report and Unify 
notices by clicking “Do not show this window again.” Dis-
abled windows can be restored at any time by going to Edit > 
Program Preferences > User Interface.

The name Fandango.enf will appear in the Save As filename window. 
SmartScore’s filetype is listed as ENF (Extended Notation Format). 
The ENF extension will automatically be added to all filenames after 
recognition. Click on Save. 

2.3 Notes on Basic ENF Editing
2.3.1 Macintosh / Windows shortcut conventions

Most SmartScore keyboard shortcuts are identical on both Windows 
and Macintosh computers. Since most Macs do not have a right mouse 
button, the Windows right-click function is performed on the Mac ver-
sion of SmartScore by holding down the “alt” (Option) key and click-
ing the mouse.
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2.3.2 ENF Display

The original scanned image is displayed in the upper window and the 
newly recognized ENF file appears below it. Use the scroller bars,
mouse wheel, or arrow keys on your keyboard to scroll up and down 
the page. Notice the image and ENF windows are synchronized for 
comparison.

FIGURE 2 - 2: Sample TIFF / ENF view

In ENF, only one staff line is active at a time. The active staff displays 
black while inactive staff lines display as grey. To make a staff line 
active, move your cursor to within the boundary of the staff until it 
highlights black. If you want all staves to display in black, go to the 
View menu and uncheck Show Active Staff. If you do this, remember 
to move your cursor within a staff line first before doing any editing 
within a staffline.

NOTE: In this manual, Quick Keys (keyboard shortcuts) are indicated 
in bold parentheses: e.g. (C).

As accurate as SmartScore is, you should always check for errors in 
recognition. Sometimes only a few simple edits are all that is required.

TIP: To see all staff lines in black, check “Show Active Staff” in the 
View menu. Since editing is done a staff-to-staff basis, turn this 
back on if you are unsure which staff line you are editing. 
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2.4 Editing Sample Files
2.4.1 Editing Fandango

• Remove unwanted text

While the triplet in the 2nd measure was recognized properly, a large 
“3” was also recognized as text. 

a. With the Select tool active, drag a small box over the large “3” in 
the 2nd measure so it highlights yellow. Be careful not to select 
the triplet itself. Let go of the cursor button and notice the 
selected object appears in grey.

b. Hit the Delete button on your keyboard to remove the “3”.

• Changing note values using Quick-select method

a. Place your cursor over the first beamed 8th note of the triplet 
which was correctly recognized in Measure 2. Notice that it 
becomes highlighted in yellow. 

b. Hold down the Ctrl button to Quick-select the first beamed note. 
Your cursor will inherit all the attributes of an object which is 
clicked on. You will probably find Quick-select the fastest and 
easiest method for selecting objects.

c. Position your cursor over the first 16th note in the 3rd measure 
until it highlights yellow. Click on the note to change it to an 8th 
note. 

NOTE: If the target note turns light blue, a new note will be inserted. 
Only objects that highlight yellow will become changed. If a 
mistake is made, push the Undo button or Ctrl + “Z” (Cmd 
+ “C” for Macs).

d. Repeat the same Quick-Select action on the last two beamed 
notes in Measure 2 and change the remaining incorrectly recog-
nized beam notes in Measure 3. Notice the red “error” color out-
lining the measure disappears after the final correction is made.

e. Push the Space bar to begin playing the piece. To stop, hit Space.

• Correcting ties

Ties in Measure 19 to 21 were mis-read and became slurs.
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a. Push the Select tool in the SmartScore toolbar (or the “O” key).
b. Click or drag over the slur found towards the end the top staff in 

Measure 19. Hit Delete on your keyboard. 
c. Hit the “V” key on your keyboard. This activates the ties tool. 

Click on the head of the last note in the top staff of Measure 19. 
Notice the tie connects with the first note in the next system.

d. Repeat on the misread slur between Measures 21 and 22.

• Inserting accidentals

a. Quick-Select on the sharp found in the top staff of Measure 23. 
b. Click on the head of the recognized grace note in Measure 24.

• Transposing the key

a. Push the “Transpose” button in the SmartScore toolbar (or select 
Edit > Transpose).

b. In the Transpose window, click the scroller upwards to change 
the target key signature from 1 flat (Dm) to 1 sharp (Em). 

c. Push OK to effect the key transposition.

• Unifying irregular staff sizes

This piece comes from an older edition with somewhat irregular sized 
staff lines. In the last system on the page, notice the bass staff is slightly 
larger than the treble staff. Since SmartScore measures exact distances 
between staff lines and systems, the ENF display will reflect this also.

a. Select Properties tool. 
b. Move your cursor over the last system at the bottom of the page. 
c. Right-click (alt + click for Mac) and select Line/Staff Spacing 

from the System Options menu. Notice that Line Distances in 
Part 2 (bass clef) is larger than in Part 1 (treble clef). 

d. Change line distance of the bass clef to match that of the treble.
e. With All Systems selected in the Copy Setting To pull down 

menu, push the Copy button. All systems in the score will update.

• Insert beamed grace notes

A beamed grace note was missed in the top staff of Measure 1.
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a. Move your cursor to the “Notes” tool palette on the left of your 
screen. Hold the “note” button down and select a 16th note (with 
2 flags) from the expanded palette. (The number “5” key on your 
computer keyboard will also select a 16th note). 

b. Hold the ‘beam direction” button down and select the “right 
beam” icon. (Toggling he “A” key will cause the cursor to alter-
nate beam directions i.e. right / middle / left.

c. Click he “Grace note” button in the “Notes” palette. 
d. Move your cursor into Measure 1 and position the notehead of 

the grace note on D. Notice the cursor stem is in the down posi-
tion. Press the “S” key to flip the stem up. Click to insert the first 
grace note. Notice the cursor’s beam direction has gone from 
right to left. Position the cursor notehead on F and click to insert 
the second grace note.

• Prepare for printing

a. Push the “Setup” button in the Navigator or select File > Page 
Setup. Notice default Document Layout is From Recognition.

b. Change document layout to Center on Page. The print preview 
pane in the background will change to reflect actual page size. 
Push Apply.

c. Push the Print icon at the top of the Page Setup window. 
d. To compare the quality of the SmartScore output with the origi-

nal, print out the Fandango image file... Push the Open File but-
ton and in “Files of Type” window, select Image Files. Select 
Fandango.tif. In the Image Editor, select File > Print. Compare.

• Visualizing contrapuntal voices

Turning on voice color will display contrapuntal voices in different col-
ors. This allows you to view secondary voices (both notes and rests) in 
red and tertiary voices in green. Notes in 4th voice will appear in blue.

a. In Page Setup view, push “Main View” button at top of screen.
b. In the SmartScore Toolbar, push the “Voice Visibility” button.

Notice in each staff how notes and rests appear as either black or red. 
They represent two of the four possible contrapuntal voices. 
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c. Push the Console button to open the Playback Console or use 
the keyboard shortcut, Ctrl + 9 / Cmnd + 9. 

FIGURE 2 - 3: Playback Console with Voice Visibility on

• Changing Instrument sounds in Playback Console

The left and right-hand piano parts have been automatically recognized 
as piano and assigned the General MIDI patch of Grand Piano.

a. In the Instrument column of Track 3, click on Grand Piano and 
scroll down to select Harpsichord. Press the spacebar or Play
button. The secondary voice of the left hand will have a different 
sound than the other voices. 

b. Move volume slider left or right to increase or decrease volume 
on one or more parts. Close Playback Console. 

2.4.2 Editing Gluck 
NOTE: Piano users: skip to page 19. Guitar users: skip to page 22.

a. Push the Recog button in the Navigator. In the Begin Recogni-
tion window press Add Files to List. Double-click the file 
Gluck.tif inside the SmartScore folder. 

b. Press Begin Recognition button to start the recognition process. 
Press Open ENF in System Report then Save the ENF file.

c. To listen to Gluck, simply press the spacebar. 

• Shift note pitches,
• An eighth beamed note in the flute part of Measure 3 ought to be 

one pitch higher. While holding the SHIFT button down, drag 
the notehead of the first beamed note up from A to B.
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• Quickly delete objects,
• Activate the Select tool (“O” key). Click and drag to highlight 

slurs above Measures 9 and 10. Hit the Delete to remove them.

• Using Quick-select to copy and insert objects

a. Hold down the Ctrl button and Quick-select the dotted half note 
in Measure 9. 

b. Hit the “S” key to toggle the stem direction of the note. Move the 
cursor to the beginning of Measure 10 and click to insert the dot-
ted half note.

c. Hit the “V” to activate ties. Click on the dotted half notes in Mea-
sure 9 and again in Measure 10 to insert ties across measures.

d. There is a spurious dot in the eighth note beam group of the right 
hand piano part in Measure 10. Toggle the “D” key until the cur-
sor appears as a greyed-out dot and arrow. Click on the notehead 
to remove dot.

e. Hit the “D” key again and click on the half note chord in Meas. 8.
f. In Measure 18, Quick-select on the natural sign in the right-hand 

piano part. Move the cursor into the flute part and click on the 
half-note to insert the natural. 

g. Push the Select button (or hit the “O” key). Holding down the 
right mouse button (alt + click for Mac), drag over a range of 
measures until they highlight blue. Hit the Space bar to play back 
the selected range of measures.

• Using Properties tool to change playback characteristics

In Measure 20, the word “rit.” (ritard) was recognized and applied to 
gradually slow playback down for that measure. The word “poco” (a 
little bit) was also recognized, but not applied, so playback probably 
slows more than it should. Default playback characteristics can be 
changed by using the Properties tool.
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a. With Properties tool active, click on the word “rit.”. 

FIGURE 2 - 4: Ritenudo Properties window

b. Change the tempo value of the Ending of the measure by moving 
the slider to something like 70 or 80% of the current value. 

c. Push OK. The measure will slow a bit as indicated by “poco rit.”.
NOTE: With Properties tool active, try clicking on the “tr” and “f” 

signs in Measure 19 to get a sense of how this tool can work.

• Selecting a few measures for playback

You may want to hear back only Measures 19 through 20 to test the 
playback settings which you changed using the Properties tool.

To playback a small range of measures,

a. Push the Select tool in the Toolbar.
b. Hold down the right mouse button (alt + click for Mac) and drag 

inside a selected range of measures. Measures will highlight blue 
and become staged for playback using Spacebar or the Play but-
ton. 

c. Press the Spacebar again to replay the selected range from the 
beginning. 

d. Click anywhere outside of the range of measures to deselect 
range.

NOTE: Use the menu item, Playback > Set Play Range to select a 
wider range of measure or to continuously loop playback.
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• Extracting a part in System Manager

MIDI users: Skip to page 22, "Editing Guitar".

a. Hit (Ctrl + M / Cmnd + M) or select System Manager from 
Edit menu. 

Flute part
extracted
from the
original
ENF
document.

Part and voice visibility is controlled in this window.

FIGURE 2 - 5: Extracting a part in System Manager

b. Remove “Visibility checkmarks” for PianoR and PianoL parts 
in the far-left column. Check “Visibility” in the Apply region. 
Push Apply to New to create a new document which will include 
only the part(s) selected by visibility checkmarks. 

c. Play the flute part, then close this newly created document.

• Changing Parts and MIDI instruments in System Manager

You can use the System Manager to select parts and assign MIDI 
sounds. MIDI instrument assignments can be changed in the System 
Manager either by choosing one of a number of preset Part Names or 
by changing the MIDI instruments assigned to any particular voice.
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a. Return to the original Gluck score. Press Ctrl + M / Cmnd + M. 
Go to the Part Name column and click on the first Part Name, 
Flute. Scroll down the list and select Oboe. Notice Voice 1
becomes Oboe. NOTE: Default instrument names and linked 
sounds are obtained from Instrument Templates (Page 160). 

FIGURE 2 - 6: Changing MIDI instruments by selecting new Part Name

b. Even more interesting is to assign different instrument sounds to 
contrapuntal voices within a single part (staff line). Refer to the 
next figure, Changing MIDI Instrument of a voice in System 
Manager. 

c. Select Harpsichord instrument for Voice 2 of the PianoR part. 
Each voice (V1, V2, V3 or V4) can each be assigned a unique 
MIDI sound simply by clicking on its current instrument name 
and selecting one of 128 MIDI instruments. Click outside menu.

FIGURE 2 - 7: Changing MIDI instrument of a voice in System Manager

d. Press OK to apply the change and close System Manager. 
e. Now hit the spacebar to play back. Whenever the secondary 

voice in the right hand is played, you will hear a harpsichord 
sound. This technique is ideal for distinguishing “inner voices” of 
parts that are written contrapuntally.

NOTE: Changing MIDI instrument assignments of parts and voices 
can also be accomplished in the Playback Console (Ctrl + 9 / 
Playback Menu > Console).
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2.4.3 Editing Chorale

Many scores are written with multiple voices within a single staff line. 
Solo piano, guitar and choral music typically include different voices 
moving independently in and out of measures. “Voiceline threading 
technology” allows you to isolate and manipulate voices easily. 

The sample file, Chorale.tif, is a famous Lutheran hymn with four 
voices: Soprano, Alto, Tenor and Bass written in two staff lines.

NOTE: SA/TB scores usually have voices separated either by oppos-
ing stems or by multiple noteheads joined to a single stem. 

a. Push the Recog button on the Navigator. Press the Add Files to 
List button in the Begin Recognition window. Select Chorale.tif 
from the SmartScore folder

b. In the Options tab window, leave Triplets, Endings and Text Rec-
ognition unchecked. 

c. Press the Begin Recognition button. Once Recognition is com-
plete, press “Open ENF’ and save the ENF file, Chorale.enf.

d. Hit the spacebar to hear the playback.

• Correct playback of pickup and closeout measures

Pickup and closeout measures are commonly found in hymns and other 
vocal scores. Recognition of notes is correct even though the first and 
last measures are highlighted red (error). Because they are incomplete, 
playback hesitates at those measures. 

a. Push the Properties tool in the SmartScore toolbar and click on 
the barline at the beginning of the first measure. In the Barline 
Properties window, change the selection in Playback pull-down 
menu from Current time signature to As written.

b. Click again on the barline at the beginning of the last measure 
and change Playback to As written. The piece will playback and 
repeat without hesitation and error highlights will be removed.

• Apply different MIDI sounds to each part

In the upper staff, the Soprano voice is black (Voice 1) and the Alto
voice is red (Voice 2). In the lower staff, the Baritone voice is black 
and Bass is red. Up to four voices are possible within each staff.
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c. Hold down the Ctrl key and hit the “9” key. This opens the Play-
back Console. Or push the “Console” button in the toolbar.

d. Change MIDI Instrument assignments of the two voices in the 
top part, PianoR (Track 1). Change Voice 1 (black) to Choir 
Aahs and Voice 2 (red) to Voice Oohs.

e. To hear differentiated voices, push the Play button, manipulate 
the volume sliders and the solo or mute buttons. Press Close to 
close the Playback Console.

• Extracting Parts using Score Structure

a. From the Edit menu, choose Score Structure.
b. Check the Show Voices box to view voices.
c. In the Parts column, click to highlight the box titled “PianoL” 

and push the Remove button.

FIGURE 2 - 8: Eliminating a part in Score Structure

d. Now push the Apply to New button. This creates a new ENF 
document containing only the soprano and alto voices. The origi-
nal Chorale.enf document will remain unchanged.

e. Press the spacebar to hear only the women’s voices. The next 
step is to extract a single voice from this document using the Sys-
tem Manager.

• Extracting Voices in System Manager

a. With the current document visible, hold down Ctrl + “M” 
(Cmnd + M for Mac) keys to open the System Manager. Select 
the PianoR part by clicking on the black dot to the left of the part 
name. Voice Visibility check boxes become active. 
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b. Uncheck the box under Voice 1 to make the soprano part invisi-
ble. In the Apply region below, check the Visibility box since the 
change we are making will only affect visibility.

c. Press Apply to New to create a new ENF document containing 
only the alto voiceline.

d. Press the spacebar to hear just the alto line.

2.4.4 Editing Songbook

a. Select Recognition. 
b. Press the Add Files to List button in the Begin Recognition win-

dow. Select Songbook.tif and press Open. In the Options area, 
check the box to the left of Text. 

c. Press the Begin Recognition button. Once Recognition is com-
plete, accept “Open ENF” and save the ENF file, Songbook.enf. 

• Insert missing time signature

The original score is missing a time signature. Its actual meter is in 3/4.

a. In the Clefs and Signatures tool palette, locate the time signature 
button (4/4). Press and hold until all available signatures expand 
to the right. Select the 3/4 signature.

b. Move you cursor to the any part and click anywhere in the first 
measure. A 3/4 sign will insert into all the parts.

• Change system margins

Because the first system of this piece is not indented, part names over-
lap the first system. All system margins can be modified.

NOTE: Show Part Name options are found under the View menu.)
• In the horizontal ruler, drag the upper tab (margin control) to the 

right. If necessary, drag the bottom tab (part name control) too.

FIGURE 2 - 9: Controlling System Margins
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• Working with lyrics

The lyrics in the first system are not aligned to their verse numbers.

a. With Shift button down (Nudge mode), locate the small yellow 
box along the left-hand bracket to the left of the lyics.

b. Click and drag the box up or down to move lyrics vertically.

In Measure 4, an “e” was dropped from the word “remember”

c. Push the Lyric button in the Text and Controllers toolbar. 
d. Click on the “r” in the top lyric line. Once positioned in the lyric 

field, click to the right of the “r” (or use the right arrow key) and 
type “e”. Push the Lyric button again to exit Lyric mode.

2.4.5 Editing Guitar

• Editing three or more voices

Solo classical guitar and solo violin scores are unique in the world of 
published music. In most music, usually no more than two voicelines 
are present; each being distinguished by notes having opposite stem 
directions. In solo guitar notation, the four plucking fingers of the right 
hand can be represented in as many as four voices. In solo violin music, 
notes with stems in opposite directions represent the four strings of the 
instrument.

a. Push the Recognition button in the Navigator. In the Begin Rec-
ognition window, push Add FIles to List. Double click on the 
file, GUITAR.TIF in the SmartScore folder to add the file to the 
list of recognized pages. Press Begin Recognition.

b. Save the file with the default name given.
c. Notice measures have notes in three colors, including green. The 

green notes represent the third or tertiary voice. Push spacebar to 
Play. Hit spacebar again to Stop.

• Adjust default tempo

The original tempo is marked “Poco allegro”. SmartScore recognized 
the word, “Allegro” which has a default tempo of 150 bpm. It’s too fast.
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a. Select the Properties tool and click on the mark, Allegro in Mea-
sure 1. Move the slider to change the speed to something slower.

NOTE: With “Apply this tempo to all similar marks” checked, all 
existing marks of Allegro will become updated to the new 
tempo after you push OK. Subsequent Allegro marks will 
insert with the default tempo of 150 unless you permanently 
change the default tempo by checking “Apply these settings 
to all future files.” Return to Default restores 150 bpm.

• Adjusting staff (system) widths, controlling part names

You may see the part name (Nylon Guitar) overlapping the first mea-
sure. You can either adjust the width of the single staffline (system) or 
choose not to display the part name itself.

To adjust the width of the system,

• Position your cursor over the first measure then drag the upper 
margin tab inside the ruler bar to the right. Moving the lower tab 
to the left will nudge the part name horizontally.

To remove visibility of part names,

• In the View menu, select Show Part Names > Do not show.

• Working in Hidden Mode

Notice that Measure 4 is highlighted red. This indicates an rhythmic 
error. There ought to be a rest in the upper voice in the fourth beat.

To insert a hidden rest,

a. Push the “Hide/Show Symbol” button in the Text and Controllers 
toolbar. Anything entered now will not be printed or seen in “nor-
mal” view mode.

b. Locate a quarter rest from the Notes and Rests palette. In Insert 
mode, position your cursor above the second-to-last note until it 
highlights blue (see “vertical event”). Click to insert the rest.

c. In Measure 6, there should be a quarter rest in the second (red) 
voice at Beat 3. Position your cursor just below the black quarter 
note and click to insert the rest.
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NOTE: Some vertical nudging of the quarter rest and/or horizontal 
nudging of the notes in the 1st and 2nd voice may be neces-
sary. Hold the SHIFT button down to nudge symbols.

d. Repeat by inserting a quarter rest in the third beat of Measure 15.
e. Push the “Hide/Show” button again to exit Hidden Mode.

The last bit of editing required is to insert a quarter note in Measure 13 
that was dropped in recognition. 

a. With the Ctrl button down, click on a quarter note.
b. Ensure the stem of the cursor is downward. The “S” key toggles 

default stem direction of the cursor.
c. Position the notehead indicator over the “F” space and click.

• Assigning different instruments to voices
d. Open the Playback Console (Ctrl + 9 / Cmnd + 9). Click into 

Instrument selection for Voice 2. In the Instrument pull-down 
menu, change Nylon String Guitar to Tango Accordion.

e. Change Voice 3 to Acoustic Bass or some other instrument.
f. Push the spacebar and listen to how contrapuntal voices become 

more distinct when they are assigned to different instrument 
sounds. 

2.4.6 Opening MIDI View

a. In the Navigator, push the MIDI button. This will open the MIDI 
environment for the guitar score. 

b. With view Type of Overview selected, push OK. Overview dis-
plays all ENF staff lines represented as MIDI tracks. 

c. Right-click (alt + click for Mac) in the Track number (1...) col-
umn to the far left of the screen. Click on the button marked 
“Piano Roll”.

d. A new window opens to display MIDI data in a “piano roll” con-
figuration where note lengths appear as long bars in discrete 
boxes that indicate measures and beats. Velocity, Tempo and 
other controllers will be visible in the controllers bar at the bot-
tom of the screen. 
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e. Use the Zoom tool to zoom in and out of the view. Notice that 
contrapuntal voices still maintain their color.

2.4.7 Viewing all open windows using Tile

a. Click on the “Tile Windows” button in the Main Toolbar to view 
all windows that are open in SmartScore. 

NOTE: All open documents may be visible and they will tile too. To 
view just the Guitar document, close unwanted windows and 
then push “Tile Windows” button again.

TIP: When comparing ENF and MIDI views, it is helpful to change 
the ENF display to “long” horizontal view. In the ENF window, 
simply push the elongated staff in the lower right corner of the 
window, or in the View menu, select View mode > Long view. 

b. Clicking into any window activates it. You may zoom, edit and 
scroll as you would if it were the only open window.

Viewing both the ENF and MIDI windows simultaneously allows you 
to visualize both the graphical and the time-based structures of Smart-
Score. Whenever you have a playback problem that doesn’t appear to 
be resolved in ENF view, open MIDI piano roll view, tile the views and 
compare data. Often you will visualize the problem in MIDI; e.g. Incor-
rect note or rest values may cause MIDI to create more beats than what 
is written in the ENF view.

2.4.8 Two-way MIDI and ENF Editing

Both MIDI and ENF environments are tightly integrated. It is possible 
to make certain changes in a MIDI view and have that change update 
the ENF view.

• In Measure 1 of an open MIDI view window (either Piano Roll or 
Overview), position your cursor over any note until the cursor 
displays a double cross. Click and drag the note up or down while 
viewing the associated ENF display. Notice that as the MIDI 
event changes pitch, so does the corresponding ENF note.
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Chapter 3 Scanning and Recognition

3.1 Scanning Music
Be sure you have the necessary scanner drivers installed before 
attempting to scan from inside SmartScore. Most scanners come with 
software that enable programs such as SmartScore to control them. 
TWAIN and Windows (WIA) scanning drivers are normally installed 
from the CDs packaged with scanners. It may be necessary for some 
users to install TWAIN or WIA drivers separately. This is usually done 
by selecting a “Custom Install” option from the install menu of the CD 
packaged with the scanner.

3.1.1 Choosing a scanner

Some scanners work better with SmartScore than others. For an 
updated list of recommended scanners, visit:  
http://www.musitek.com/ScannerComp.html

NOTE: Scanner drivers are often updated by scanner manufacturers 
and posted on their web sites. If problems occur during scan-
ning, it is always a good idea to check the Internet for updated 
scanner drivers before calling Musitek Technical Support. 

3.1.2 Selecting your scanner and interface in SmartScore

a. Check File > Scan Music > Choose Interface = SmartScore’s.
b. Go to File > Scan Music > Select Scanner. With your mouse, 

click on the driver that corresponds to your scanner.

FIGURE 3 - 1: File > Scan Music > Select Scanner
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c. Windows HP / Visioneer Users: Select “WIA xxxx xxxx” (the 
Windows scanning utility) if it’s available and try scanning with 
that first. Do not select “PrecisionScan”®, etc. if a WIA driver is 
available. 

d. Other scanners (Epson, Canon, etc.): Whenever possible, 
always install and use a TWAIN driver. TWAIN is often more 
reliable than third-party WIA drivers.

Always reboot your computer after installing drivers. If you do not see 
your scanner listed in the Select Scanner window, the driver is proba-
bly not installed. Install or replace TWAIN or WIA drivers from your 
scanner’s CD or from Download Drivers area of the scanner manufac-
turer’s website. If your scanner still does not operate properly with 
SmartScore scanning interface, turn to "Scanning Outside of Smart-
Score", Section 3.3, on page 36.

e. Push the Scan button in the Navigator or in the Main Toolbar.

3.1.3 Using the SmartScore Scanning Interface

Your scanner will begin to operate with Scan or File > Scan Music > 
Acquire. A low-resolution pre-scan will appear in the Preview window 
along with a black bounding box surrounding the music. The bounding 
box should encompass the entire image area that you wish to scan. 
Edges of the box should be about 1/4” away from the printed image.

FIGURE 3 - 2: SmartScore scanning interface
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NOTE: If the preview image appears with white notes on black back-
ground, this means your scanner is reversing image polarity. 
In this case, you will want to check the box, Invert Image, 
below the Preview window.

f. If necessary, select a scanning region, drag your mouse to create 
a box around the music leaving at least 1/4” of white space 
between the bounding box and the music which you are scanning.

g. Push the Scan button to create a final high-resolution scan of first 
page. You will be prompted to scan additional pages or finish 
scanning. Make sure “Multiple” is checked if you have more 
than one page to scan.

h. Push Next Page and continue to preview, deskew and scan until 
you have finished scanning in your song, project, section or 
movement. Select Finish when done.

FIGURE 3 - 3: Scan Next Page / Finish window

NOTE: Selecting Next Page activates your scanner. Before selecting 
it, position your next page onto the scanner and wait until the 
scanner bar resets. If you push too soon, you may get an error 
message that “Scanner is not ready.”

NOTE: If the piece you are processing exceeds 24 pages, divide it 
into smaller, discrete sections, e.g. Intro, Part1, Part2, etc.

The following section lists image-enhancement and scanner settings 
which you can control within the SmartScore scanning interface. If you 
understand and/or accept the default settings in the Scan window, turn 
to “Recognition Sequence” on page 32 to complete scanning and to 
begin the recognition process.

3.1.4 Automatic image-enhancement functions

The SmartScore interface has 4 automatic image-enhancement func-
tions all designed to assist you in creating the best possible image for 
recognition. 
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• Auto Resolution

This feature takes the guesswork out of choosing the correct resolution 
(dpi) setting for each scan. When selected, the image is analyzed and 
sized in order to obtain an optimum image resolution, thus achieving 
the highest possible recognition accuracy. Use this whenever possible.

• Auto Cropping

The cropping region can be automatically selected by checking this 
box. The cropping region can be resized by dragging any edge with 
your mouse. The cropping rectangle should not intersect or interfere 
with any part of the music. Leave at least 1/4” of white space between 
the cropping region and your music. After the preview scan is com-
pleted on each page, check that the image in the preview window is 
straight and properly cropped.

• Auto Deskew

After an image is previewed, toggle this button on and off and choose 
the setting that gives you the straightest possible image. If you are 
unable to make the image appear straight in the Preview window, auto 
deskew failed. Reposition your music in the scanner and preview again.

3.1.5 Scanner settings

• Darkness / Brightness

The default darkness setting is -15%. For typical printed music, this 
setting should be fine. If beams smear together and whole and half 
notes appear closed or “blobbed”, then brighten the scan. If the original 
music is faded, if it is a weak copy or if it has become degraded, you 
may want to scan even darker than the default setting. SmartScore 
wants to see solid, well-defined lines that are neither razor-thin nor 
smeared together. 

NOTE: If recognition accuracy is poorer than expected, examine the 
file in the Image Editor. Zoom in close and determine the fol-
lowing:

• If stems and stafflines are thick and continuous but objects 
appear small and lack detail, re-scan with increased resolution.
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• If note stems and staff lines are broken, thin or appear to be only 
one pixel wide, re-scan with -20% to -30% increased darkness.

• Resolution 

It is recommended that you use Auto-Resolution whenever possible. If 
you choose to set resolution manually, check Auto-Resolution off. For 
most printed music, the recommended resolution is around 350 dpi. 

If the original music is printed in smaller type, you can increase resolu-
tion to 400 or 500 dpi. For miniature scores, try 600 dpi. Scanning at 
too high or too low a resolution may actually reduce recognition accu-
racy. It is not recommended to scan music below 250 dpi or higher than 
600 dpi.

• Manual or Automatic Source (Document feeder)

Normally, you will preview and scan one page at a time. Some scan-
ners have automatic document feeders. If you choose Automatic
option, you will be able to scan multiple pages at once. However, you 
will only be able to preview the first page. If you select Automatic, 
make sure when you preview the first page that the entire page is 
selected and not cropped. Remaining pages will be scanned and fed 
without preview checking.

3.1.6 Choosing an alternative scanning interface

If your scanner fails to respond properly to the Scan command in the 
SmartScore interface or your scanned image is unacceptable (partially 
scanned, distorted, color, etc.) your alternative is to scan using the soft-
ware provided with your scanner. See "Scanning Outside of Smart-
Score", Section 3.3, on page 36 for details.

3.1.7 Scanning in Macintosh®

Some Mac scanners are not fully TWAIN-compatible. In order for 
SmartScore to control a scanning device, it must be TWAIN-compati-
ble. Otherwise scanning will have to be done outside of SmartScore 
using the software provided with your scanner. See “Scanning Outside 
of SmartScore” on page 36 and “Selecting Pre-scanned Files for Pro-
cessing” below for details.
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3.2 Recognition Sequence
When scanning pages is done, choose Save As and Begin Recognition 
to initiate the recognition process or choose Open Pages in Image 
Editor to view scanned pages and to make alterations such as cropping, 
deskew, line drawing, cutting and pasting, etc. Cancel will exit.

FIGURE 3 - 4: Scan Next Page / Finish window

NOTE: Turn to “Image Editor” on page 44 to learn about editing 
scanned images (Open Pages in Image Editor). 

To save your scanned image file and begin recognition sequence, 

a. Push the Save As and Begin Recognition button.
b. Browse to a location for saving your SmartScore working files. 

You may wish to add a unique directory at this time.
c. Give the image file a name. If you are using Windows, the exten-

sion “.TIF” will be added automatically.
d. Push OK to begin the recognition process.

The image file you have just saved contains all pages you scanned. The 
default filetype is “Compressed TIFF” (CCITT Type 4), a multi-page, 
single-file TIFF compression format. This type of TIFF file is approxi-
mately 10 times smaller than an uncompressed TIFF image file. 

NOTE: If you are going to open the scanned image in Adobe Photo-
shop, you may want to save in the larger, uncompressed TIFF 
format; Photoshop does not currently support CCITT Type 4 
files.

TIP: When you Save a file, SmartScore will continue to save to that 
directory until you change it. The same is true when you Open
a file. Remember that SmartScore will look in one directory 
when opening a file and may default in a different one when 
saving a file. Once changed, the new path becomes the default.
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3.2.1 Recognition Options

FIGURE 3 - 5: Recognition - Options

The following section describes options you can choose for recogni-
tion. When satisfied with your choices, push Begin Recognition. 

NOTE: If Recognition fails, refer to “Troubleshooting Guide” on 
page 42.

• Text 

Check this box if you wish to recognize lyrics and text in the music. 

TIP: If you are scanning in single-line parts for the purpose of join-
ing them into a conductor’s score, it is recommended not to rec-
ognize text. Otherwise, text from every score-part will be 
overlaid on the pages of the conductor’s score.

• Recognize Text Symbols as Chords

Check this box if your score has chord symbols written as text instead 
of guitar fret symbols. Chord names will be linked to guitar fret library.

• Lyrics Under Last Staff of Systems

Check this box if you are recognizing a choral or orchestral score that 
has dissimilar lines of lyrics written under every staff line, including 
the last staff line of each system. Otherwise, leave unchecked. 
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• Triplets

Check this box if the score contains triplets that are indicated with the 
number “3” along with an arc or bracket.

• Implied Triplets

Check this box if the score has many repeated groups of three beamed 
notes with the first group being marked with a triplet. This is a common 
convention used to simplify reading of repeated triplet beam groupings 
without marking them. They are “implied”. The exception will be 
scores with “tripled time” signatures: 3/x, 6/x, etc. 

• Endings

Check this box if you want to automatically recognize multiple endings 
marked 1_, 2_, etc.

• Pedals

If pedal markings are written into the music, check this box.

• Bowings

If up/down bowing marks are written into the music, check this box.

• Heavy beams

Some printed music is written with especially thick note beams. If sin-
gle beams are recognized as double or triple, re-recognize the music 
again with this option selected.

• Hymnal Fonts

If you are scanning in music from a hymnal (with stubby flags and 
short stems), check this box. NOTE: “Shaped notes” do not apply.

• Join Offset Voices

Often you will see notes belonging to different voices appear horizon-
tally offset, even though they sound at the same time. It is necessary for 
the recognizer to decide which notes to join and which notes not to join 
to a “vertical event” (See “Correcting Vertical Alignment” on page 69). 
Normally, offset notes belonging to different voices have no more than 
1/4 of a notehead’s space between them. 
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• If your music has offset voices which regularly exceed this dis-
tance, choose another distance. Distance is determined by the 
white space between note heads.

• If your music has dense polyphonic texture, like that found in 
solo guitar music or tightly-spaced orchestral passages, it may be 
necessary to “tighten up” the allowable distance between offset 
voices. In these case, choose a distance less than 1/4 of a note-
head.

• Part Linking

When a score is “optimized”, parts appear (as staves in a system) only 
when played. Otherwise, parts are not visible. Optimized systems can 
be referred to as either “collapsed” or “expanded”. Sometimes parts are 
added to the top, e.g. after a piano introduction, the vocal line will 
appear above the piano part. Other scores may have parts are added to 
systems in a “bottom-up” fashion, e.g. existing staves are bumped 
upwards. If your score is structured in this way, change default to “Add 
Parts to Bottom”. Orchestral scores, being grouped by instruments, 
may have no pattern. For details on re-linking, see "Re-linking parts", 
Section 4.15, on page 78

• Fretboard Strings

The default fretboard for recognition is the six-string guitar. If your 
music has ukulele fretboards (4 strings) or some other configuration, 
change the selection to the correct number of strings.

3.2.2 Post-Recognition

FIGURE 3 - 6: Post-recognition System Report
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The scanned file will be saved prior to recognition. Following the rec-
ognition process, a System Report will be displayed indicating the 
number of systems found and on how many pages. The System Report 
reports the largest and smallest systems including the number of parts 
found in each. If any of these do not agree with the original music, 
investigate the cause before spending a lot of time editing the score... it 
could be difficult to restructure parts and systems later on.

• If you select either Open ENF or Open Super System, the first 
thing to be saved is the image file (scanned pages). Type a name 
in the Save As > Image window. 

• Following that, another Save As window will open. This is for 
the ENF file (the SmartScore file). It acquires the same name as 
was given the image file. It may be changed in the name field. 
Select a destination directory and press Save to save your new 
ENF file.

• If you select Open Super System, you will be able to scroll from 
system to system and locate any systems containing an incorrect 
number of parts. See “System Manager” on page 155 for details.

• If you select Open Image Editor, you will be taken to the image 
editor where you are able to correct certain flaws in the scanned 
image. See “Image Editor” on page 44 for more details.

You can choose to permanently view or not view System Report and 
Save As dialog following recognition. To reset these options, go to Edit 
> Program Preferences > User Interface > Recognition. When recog-
nition is complete, the screen will split between an image pane and the 
ENF pane which displays a representation of what was recognized. As 
you scroll down and page, the image and ENF panes remain synchro-
nized. An alternative to the “split screen” view is the “Zoom Window” 
view. See “Split-screen and Scan View reference views” on page 125

3.3 Scanning Outside of SmartScore
An alternative to operating your scanner when TWAIN or WIA drivers 
don’t work properly with SmartScore is to scan in another application. 
You can use your scanner’s software or a third-party imaging program 
like Photoshop® to scan and save images. Then, inside SmartScore, you 
will be able to Recognize the saved images.
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a. Check that your scanner is on and that the proper driver is 
installed (File > Scan Music > Select Scanner). If a compatible 
driver is not present, you will have to reinstall your scanner’s 
software either from the original CD or by downloading the most 
recent scanner driver from your scanner manufacturer’s web site. 
If the above is true and pushing the Scan button in the Navigator 
still causes problems, your driver is probably incompatible with 
SmartScore’s scanning interface. 

b. Switch to the scanning software that was installed with your 
scanner. To do this, go to File > Scan Music > Choose Interface
> Your Scanner’s. When you push the Scan button, you will 
then be handed off to the software that came with your scanner.

If you are using your scanner’s interface, follow the following guides:

• Place your music in the scanner as squarely as possible.
• Look for Scan type or Output option. Set scanning to Grey

(Greyscale). Do not scan in “Color” or in “Black and White” 
(Line Art, 1 bit or OCR). NOTE: This is new in Version 5.

• Set Resolution to 300-400 dpi for average printed music.
• Set Darkness to -10 or -15% for average printed music.
• Crop around but not on the music to be scanned in preview pane.
• Scan between 300-400 dpi (for average-sized printed music). 

Scan at higher resolutions for music printed in smaller-than-aver-
age print size. Do not exceed 600 dpi.

• Save as TIFF (Uncompressed) or BMP file. Each page will be 
about 1 MB per page. Use a unique filename for each page... e.g. 
Page1.tif, Page2.tif, etc.

TIP: Optimum resolution is achieved when the distance between 
staff lines is about 20 pixels. Zoom into the image. Referring to 
the mouse position readout in the status bar, measure the dis-
tance between two lines in a stave (measure white space only).
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3.4 Selecting Pre-scanned Files for Processing
Pre-scanned images must be properly prepared. For detailed informa-
tion on basic music scanning procedures, see “Scanner settings” on 
page 30.

To create an ENF file from pre-scanned images of printed music,

a. Push one of the Recognition buttons (in the toolbar or Navigator) 
or select Recognize under the File menu.

b. A file-selection window Begin Recognition will open. This is 
where you list your pre-scanned files for recognition by selecting 
them, rearranging them, removing or reordering them.

FIGURE 3 - 7: Recognition - Selected Files / Options / Preview

c. In the Begin Recognition window, push Add Files to List.
d. Browse to where your images are stored. Click on an image file 

to select. If more than one page was scanned in the SmartScore 
scanning interface, the file will appear as a multi-page list.

NOTE: SmartScore can recognize BMP or PDF files provided they 
are a minimum of 200 dpi and not RGB or CMYK color.

NOTE: You may click on and drag image icon(s) to the selected files 
list of the Begin Recognition window. Some older Windows 
operating systems may not support drag-and-drop.
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e. Preview pages prior to recognition to check that pages were 
scanned completely and that no page is severely skewed. Any of 
these issues will affect recognition results. Select the Preview tab 
and click on each page to view your pre-scanned pages. 

f. Click on the Options tab to return to the File Selection and 
Options window. Options assists the recognizer to “hone in” on 
specific symbols and helps to remove any “false positives”.

g. Refer to “Recognition Options” on page 33 for details on how 
recognition options operate.

3.4.1 Reordering the File List

If you scan more than 9 pages, you may notice “Page10” is listed 
before “Page2”. This is because most operating systems list files 
according to the first character of the filename. Click on any page and 
hit Move Up or Move Down to reposition. Hitting Remove Files from 
List will cause that page to be skipped during Recognition.

3.4.2 Removing, replacing and re-saving scanned pages

If one page of a scanned group is incorrectly scanned or is missing alto-
gether from a multi-page image file (Page group), you may reselect 
individual pages to form a new page group.

a. Select (or drag) the original multi-page file inside the selected 
files list of the Begin Recognition window.

b. Highlight a page to remove and push Remove Files from List. 
c. To add a replacement or additional page to the original page 

group, select or drag the page(s) to the selected files list. 
d. Reorder pages as necessary. 

NOTE: If pages were reordered, added to or deleted from the original 
image file, you will be able to re-save the newly listed pages.

To Save a modified list of grouped pages as a new image file,

• Select all pages so they are highlighted and push Save As.
• Select the existing name to over-write or type in a new name.
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3.5 Scanning Part Scores (Score-Parts)
SmartScore allows you to process and combine scanned pages of solo 
parts, duets, trios or quartets and play them back simultaneously. They 
may also be recombined into a conductor’s score.

TIP: If you are scanning in Score-parts for the purpose of joining 
solo parts into a conductor’s score, it is recommended not to 
recognize text. 

To scan and combine Score-parts into one ENF file,

a. Scan in all pages for each part. For easiest identification, give a 
unique name or number for pages belonging to one part, e.g. 
FluteP1, FluteP2, GuitarP1, GuitarP2, etc.

b. In the Begin Recognition window, arrange files in order of parts 
then pages: e.g. Part1/Page1, Part1/Page2, Part2/Page1, etc.

FIGURE 3 - 8: Grouping pages to Score-Parts

c. Highlight the first set of pages that make up the first Score-Part.
d. Push Group to Score-Part. In the Part Name window, give the 

selected pages belonging to a score-part a unique name.
e. When all pages are properly grouped to score-parts, push the 

Begin Recognition button.

SmartScore will internally organize score-parts following recognition. 
The ENF window will display pages for the first part followed by pages 
of the next part. Parts will play back simultaneously. For more informa-
tion on creating conductor’s scores, refer to page 121.
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TIP: Following recognition, guitar chord fret symbols may overlay 
chord names recognized as text: “Dumb” text chord names will 
not transpose. To remove “dumb” text fields, use Nudge mode 
(Shift) and drag the control handles of each text field upwards. 
Use the Select tool and “group delete” all selected text fields.

3.6 Recognition Accuracy
If recognition accuracy is not as good as what you expected, examine 
the image up close by zooming into the image pane of your ENF view. 
You may also view Image Editor (FIle > Open > Image filetype).

Determine the following by zooming close up:

• If objects lack detail, re-scan with Auto-Resolution = On or 
increase scanning resolution manually. Optimum distance 
between horizontal stafflines is 20 pixels. Use the cursor and 
readout in the Status Bar (pixel coordinates) to measure distance.

• If objects such as note stems and staff lines are broken or lack 
thickness, re-scan with increased darkness to fill in gaps.

• If the source document is poorly printed or is faded and weak, try 
locating a better print copy of the music.

NOTE: Recognition accuracy is directly related to the quality of the 
source document as well as the quality of the scanned image. 
Cheaper scanners, including Fax-Scan-Copy combos, are 
known to create poor images. Remember the old saw: “Gar-
bage in / Garbage out”. You may want to contact Musitek 
Tech Support for scanner recommendations.

If after examining the image and consulting the Troubleshooting chart, 
you are still unable to achieve good recognition results, we invite you to 
send us your TIFF file(s) for detailed analysis by our technicians. 

You can attach your image (TIFF) files to e-mail along with a short 
description of the problem you experienced to the following address: 
tech@musitek.com

We will as reply soon as possible. Most likely, we will be able to locate 
the problem and offer a solution or recommendation.
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3.6.1 Troubleshooting Scanning and Recognition

Table 2: Troubleshooting Guide

Problem Probable Cause Fix

Scanner does not operate. Scanner drivers not 
installed properly.

Install TWAIN software 
and/or scanner Plug-in.

Scanner not selected in 
SmartScore.

Ensure proper scanner 
driver is selected (File > 
Scan Music > Choose 
Scanner).

Scanner not connected or 
not turned on.

Check cabling and power. 
Use scan test program.

Automatic resolution 
returns inconsistent reso-
lution choices on the 
same page.

Music has irregular staff 
widths. Scanner may be 
distorting regions of 
page.

Re-scan in SmartScore’s 
scanning interface with 
Auto Resolution = off. 

Scanner model used does 
not support variable DPI 
(1 pixel increments)

Re-scan with Auto Reso-
lution = off. Manually set 
resolution acceptable to 
scanner (300 to 600 dpi).

“Cannot process color 
images.”

Scanner was set to scan 
in Color.

Scan in SmartScore’s 
scanning interface (File > 
Scan Music > Interface).

Re-scan in greyscale.

“Recognition failed for 
this page.”

Scanner set to screen res-
olution of 50-100 dpi.

Scan again accepting 
Auto-resolution settings 
for best results.

Manually set resolution to 
300-600 dpi. Scan again.

Page was scanned with 
too light a setting. 

Re-scan with -20% to  
-25% darkness

Scanner was forced to 
create a black & white 
image with “dithering”.

Re-scan in Your Scan-
ner’s interface: Grey-
scale / 350 dpi.
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“Recognition failed for 
this page.” (cont’d)

Music not fully scanned 
or is severely skewed.

Re-scan making sure all 
the music is selected. 
Scan music straight or use 
“Deskew” function.

Image too large for 
selected resolution.

Re-scan ensuring Auto 
Resolution = On.

Scanner hangs or 
crashes.

TWAIN driver conflict. Ensure latest scanner 
drivers are installed.

Scan outside of Smart-
Score using software that 
came with your scanner.

Poor recognition results. Missing barlines due to 
light obscuring right 
margin or to right margin 
having been cut off dur-
ing scanning.

Open image file in Image 
Editor. Use Select Tool to 
delete obscured regions 
and the Line Draw tool to 
restore barlines on right 
side of systems.

Image too small for 
selected resolution.

Scan again accepting 
Auto-resolution settings 
for best results.

Handwritten or non-stan-
dard notation. Poor print.

Scan well-printed, stan-
dard-sized sheet music.

Poorly printed music. Increase Darkness level. 
Find better original.

Image not straight 
(skewed).

Open file in Image Editor 
(File > Open > Image). 
Use Deskew tool to 
straighten each page.

Stafflines and note stems 
of canned file are broken 
or too thin.

Re-scan page(s) with 
increased darkness set-
ting.

Table 2: Troubleshooting Guide

Problem Probable Cause Fix
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3.7 Image Editor
• Begin Recognition or Open in Image Editor

Following the final scan of music pages, you may choose to “Begin 
Recognition” or “Open Image Editor”. This choice will stop the Recog-
nition process and open the scanned images in the Image Editor. 

NOTE: The image will not be saved until File > Save As is selected.

• Load an image file

To open an image file you have previously scanned, 

a. Press the Open button on the Navigator or choose Open (Ctrl + 
O) (Cmnd + O for Mac) from the File menu.

b. Change Files of Type pull-down menu to Image Files.
c. Browse and highlight an image file from the listed saved files. 

Press Open.

• Image Information

Select View > Image Information to display characteristics about the 
current scanned image including resolution, file type and page size.

• Zoom

To Zoom in and out click the Zoom Tool in the Main toolbar (Ctrl + 
Q). Click inside the image will increase the scale of your view (Zoom 
In), while right-click (alt / option + click for Mac) will decrease the 
scale of your view (Zoom Out).

• Page

To view pages of an image file, use the paging buttons in the Main 
Toolbar or select Next Page/ Previous Page from the View menu.

• Image Toolbar

Crop 
Invert RotateL 

RotateR 
Brush

Line Select 
Deskew 

Color
Thickness 

Delete
Threshold 

FIGURE 3 - 9: Image Toolbar
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3.7.1 Page Tools

• Select

Used for selecting a region for cropping, deleting, cutting or copying.

• Crop

To crop an image file (trimming unwanted portions of your image from 
outside a marked frame), 

a. Press the Select button in the Image Toolbar. 

FIGURE 3 - 10: Selecting Crop Region (Removing severe light leakage)

b. With your mouse, drag a box around the area you wish to keep. If 
you want to extend the cropping region outside of the display, 
keep dragging; the page will scroll as you drag up or down.

c. To adjust the marked bounded area, move your cursor over a 
boundary line, click and drag the boundary to a new position.

d. Select Crop from the Edit menu OR press the Crop button in the 
Image Toolbar. The resulting image will be reduced to the area 
inside the bounded frame. Remember to Save when done.

• Correcting Skew

Page through each scanned image and check for relative straightness of 
each image page. If a page appears tilted or skewed, recognition accu-
racy will be compromised. The Deskew tool rotates the image slightly 
to correct skewed pages and will optimize recognition accuracy.
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a. Press the Deskew button in the Image Toolbar or select Deskew
from the Edit menu. 

Drag deskew
tool along
topmost
staffline

FIGURE 3 - 11: Manual Skew Correction

b. Position the cursor over a staffline. Starting from the left side, 
click and drag the mouse along the length of the staffline. A red 
“skew angle” line will display as you drag the mouse. When you 
are certain the red “skew angle” line parallels the staffline, let go. 
The page will automatically straighten. Repeat for each page. 
Remember to Save when done.

NOTE: If the page becomes incorrectly rotated, undo with Ctrl + z / 
Cmnd + z for Mac (or select Edit > Undo).

• Invert

If the image you open in SmartScore is white-on-black (instead of the 
normal black-on-white), then you should reverse the image output in 
your scanning software. SmartScore defaults to 0=white polarity. 

If your scanned image appears white on black, choose Edit > Invert or 
choose the Invert button from the toolbar.

• Delete Page

If there is more than one scanned page in the image file, the Delete 
Page function is active. Use it to remove poorly scanned or duplicated 
pages. To re-scan and restore deleted pages, see “Removing, replacing 
and re-saving scanned pages” on page 39.

• Paint Brush (Free draw)

To draw free hand lines in your image file, select Brush from the Edit
menu OR press the Brush button in the Image Toolbar. Choose a line 
width then click and drag to paint.
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• Line Draw

Some printed scores have weak or missing stafflines and/or brackets 
that can create problems during recognition and may result in missing 
or incorrectly bracketed systems. Sometimes, by accident, brackets 
and/or barlines are cut off during scanning. If this is the case, you can 
manually draw in staffline and brackets or enhance their thicknesses. 

To restore cut-off or missing system brackets,

a. Select Edit > Line or choose Line Draw in the Image Toolbar. 
b. Push the Pen Color push button in the Image Toolbar, if neces-

sary, to choose Black Color. 
c. In the Width pull-down selector, choose a fairly wide thickness 

(10-20 pixels).
d. Click and drag the mouse to draw a line along the missing or bro-

ken bracket along the left margin of the music.

FIGURE 3 - 12: Using Line Draw tool to restore missing bracket

e. When finished modifying the image. Select File > Save As and 
give it a name. You may then Recognize the file with correc-
tions.

• Line / Brush Thickness

To change the width of brush or line tool, select a new size from the 
Width menu in the Image Toolbar. Select from 1 to 50 pixels.
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• Black / White Color toggle (Eraser)

Push the “Eraser” button to activate white color. Push again to deacti-
vate it for black color. Or choose Pen Color > Black or White from 
the Edit menu. 

• Rotate Left / Rotate Right

 To rotate an image file (for landscape formatted scores or upside down 
scans), go to the Edit menu and highlight Rotate OR press one of the 
Rotate buttons in the Image Toolbar.

• Rotate the image Left (90 degree rotation).
• Rotate the image Right (90 degree rotation).
• Select Edit > Rotate > Any to rotate at angles other than 90 

degrees.

FIGURE 3 - 13: Image Rotation

• Choose Clip Image mode to maintain the original page size and 
orientation of the image file. 

NOTE: Be careful that none of the music is clipped with this option. 
If so, choose Edit > Undo (Ctrl + z / Cmnd + z for Mac).

• Choose Expand Image mode to increase the page size, if neces-
sary, to include the entire image. 

• Remember to Save when done.

3.7.2 Cut / Copy and Paste functions

• Cut (Edit > Cut)

To cut an area from the scanned image, hit Delete button. Or use the 
Select tool and drag a box. Cut with Ctrl + “X”. 
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• Copy

To copy an area without removing it from the image, use the Select tool 
and drag a box with the mouse. Select Edit > Copy (Ctrl + C (Win) / 
Cmnd + C (Mac)). 

• Paste

To Paste the cut or copied region into an image file, select Edit > Paste
(Ctrl + V / Cmnd + V (Mac)). The cut or copied section will drop into 
the image. With the mouse, drag the fragment anywhere within the 
image and release the left mouse button. To fix the fragment in place, 
click outside the pasted fragment.

3.7.3 Manually converting greyscale images

• Threshold (Convert to Black and White)

This tool manually converts greyscale images to black and white for 
SmartScore recognition processing. It is helpful if the original scan was 
created in greyscale (recommended when scanning outside of Smart-
Score). See "Scanning Outside of SmartScore", Section 3.3, on page 36
for details.

If recognition is poor and examination of the image shows broken 
stems and/or broken staffline,

a. Re-scan the music and instead of choosing Begin Recognition, 
choose Open in Image Editor.

b. Push the Convert to Black and White button.

FIGURE 3 - 14: Greyscale Thresholding

c. In the Thresholding window, choose a darker level and re-exam-
ine the image for line integrity. Undo and repeat if necessary.

NOTE: After modifying pages in the Image Editor, remember to Save
the modified image file.
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Chapter 4 Playback

4.1 MIDI Setup
It is necessary to identify the MIDI device attached to your system in 
order for SmartScore to play through it. Selecting the MIDI device is 
similar on both Windows® and Macintosh®. Fortunately, computer 
operating systems now provide built-in MIDI synthesizers. This allows 
you to select and play General MIDI (GM) sounds without installing an 
outboard synthesizer or soundcard. 

To set the MIDI input and output devices,

a. Select MIDI Devices from the Playback menu. The MIDI 
Devices window will open.

FIGURE 4 - 1: Playback > MIDI Devices

b. Click on the MIDI Output device you wish to use for MIDI 
playback. The MIDI device window will display all installed 
MIDI device drivers. 

c. If you intend to record in SmartScore, select the desired MIDI 
recording device/interface in Input window.

NOTE: If the desired device is not listed in the MIDI Devices window 
make sure your MIDI device driver has been properly 
installed.

d. Press OK to set the selected MIDI devices as your MIDI sources.
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NOTE: You may need to close any open MIDI programs. Some MIDI 
programs prevent playback by blocking the MIDI Out port.

4.1.1 Audio MIDI Setup (Macintosh)

To access Audio MIDI Setup in Mac OS X, locate “Utilities” folder 
inside the “Applications” folder. Double-click on Audio MIDI Setup.

FIGURE 4 - 2: Applications > Utilities > Audio MIDI Setup (Mac)

If you have external MIDI devices installed such as an external synthe-
sizer module and MIDI interface, they should appear as icons in the 
window. Using your mouse, drag the “Out” arrow of the source device 
to the “In” arrow of the receiving device and vice-versa. Internal con-
nections should then be established. Close Audio MIDI Setup.f

FIGURE 4 - 3: Connecting MIDI Devices in Audio MIDI Setup

With SmartScore ENF file open on your Mac, go to Playback menu, 
click and select Playback at the bottom of the list. Choose CoreMIDI 
Playback to activate devices connected in Audio MIDI Setup. To acti-
vate built-in soft-synthesizer (Macintosh QuickTime Musical Instru-
ments), choose QT Internal Playback.
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No MIDI
Recording
4.2 Quick Play
To play back an open ENF file quickly, use the spacebar, 

a. Press the spacebar to start playback. Press again to pause. Press 
again to resume play. 

b. Press the comma key (“,”) to rewind to start point.

4.2.1 Mini-Console

The Mini-Console transport controls Play, Rewind and Stop. The 
Record button will launch a new MIDI recording session to record 
additional tracks (see page 196). The “spring-loaded” slider will accel-
erate or decelerate playback depending on how far the slider is dragged. 
The slider will snap back to the default tempo once it is released. 

FIGURE 4 - 4: Mini-Console

4.3 Playback Console
In the Playback Console, you can make changes to MIDI instrument 
assignments, tempo, transposition, muting, soloing, volume and pan 
settings. 

To open the Playback Console, 

• Press the Playback Console button in the SmartScore Toolbar. 
Or hold down Ctrl + 9 (Win) / Cmnd + 9 (Mac). The console is 
also accessible from the menu: Playback > Console.

FIGURE 4 - 5: Playback Console
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4.3.1 Playback Console controls

The playback transport control works exactly as does the Mini-Con-
sole. The General Volume slider controls overall volume. Tempo con-
trols default tempo (if no metronome value was assigned in ENF). 
Measure/Beat slider resets playback position to desired measure and 
beat. 

Each horizontal MIDI track is linked to a contrapuntal voiceline found 
in a staff. Tracks are grouped with light or dark grey shading represent-
ing one part / staff line. Each track has its controls arrayed in columns: 

Column 1: Track shows the MIDI track assigned to the staff. MIDI 
Tracks are assigned automatically and cannot be changed.

Column 2: Voice lists the contrapuntal voice number (1 thru 4) given to 
each voiceline. Voice colors are assigned automatically and cannot be 
changed in the Playback Console. Voices are editable only in the ENF 
view. See “Working with Contrapuntal Voices” on page 151 for 
details.

Column 3: Part Name is given to each part (staff). Names are derived 
from the System Manager and are automatically assigned and cannot 
be changed in the Playback Console. Part Names can be changed in the 
System Manager. For details, see page 155, "System Manager". 

Column 4: MIDI Channel Number A unique MIDI channel number is 
assigned to each voice within every part. If Voice Visibility is acti-
vated, MIDI channel numbers appear inside colored boxes representing 
one of 4 possible voices (black, red, green and blue). The Voice Visi-
bility button is found in the SmartScore toolbar. MIDI Channel num-
bers are automatically assigned and can be changed by clicking onto 
any Channel Number of any track.

NOTE: If a score contains more than 15 total voices, voices in each 
part will automatically be reassigned to the same MIDI chan-
nel. The result will be that each part (track) will play the same 
MIDI instrument. This avoids the problem of MIDI playback 
being limited to no more than 16 channels per port.
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Column 5: MIDI Port displays the current port to which MIDI play-
back data is being sent. If more than one MIDI device is available, the 
port assignment can be changed. The Lock radio button will prevent 
the MIDI Port from being changed by mistake.

Column 6: MIDI Instrument: A MIDI Instrument will be assigned to 
each track. The default instrument is “Grand Piano”. Some recognized 
scores, depending on their structure, may have other instruments 
assigned. The Instrument controls found in the Playback Console and 
in System Manager can be changed in either place and will be linked.

Set Instrument: See page 182.

Column 7/8: Mute / Solo buttons control whether a track should be 
muted while all other tracks play or soloed, muting all other tracks.

Column 9: Volume slider controls the default volume of each track

Column 10: Pan slider controls the Left/Right balance for each track.

Column 11: Transpose transposes the MIDI instrument in specific 
tracks up or down.

4.3.2 Playing back a selected section

The quickest way to play back a snippet of the score is to use the 
“Select” tool and drag the mouse over a region of the page while hold-
ing down the right mouse button (Alt + click for Mac). Measures 
selected for playback will highlight light blue. Hit Space bar to play.

FIGURE 4 - 6: Selecting measures for limited playback
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For playing larger sections and for looping, go to Playback menu and 
select Set Play Range.

FIGURE 4 - 7: Set Playback Range

c. In the From field, choose a starting measure. To establish a range 
for playback, select an end point in the To pull-down box. 

d. To repeat playback over the range, check the Loop box.

4.4 Dynamics and Articulations
4.4.1 Dynamics

You can use any of the tools in the “Dynamics” palette to alter play-
back velocities. 

Inserting dynamic, crescendo / decrescendo markings or hairpins will 
alter the velocity of associated notes in the active staffline only. See 
“To Insert a Dynamic marking,” on page 132 for details on inserting 
dynamics.

To apply dynamics and/or dynamic markings to more than one staff, 
enter the dynamic in each active staff that you wish to apply the effect. 
If you do not wish to have so many dynamics visible in every staffline, 
you may enter symbols in the Hidden Symbols mode. For more details, 
see “Hidden Symbols” on page 162.

4.4.2 Articulations

Numerous note articulations including slurs, trills, turns, mordents, 
staccatos, tenutos, accents, arpeggios, glissandos and tremolos can be 
applied from the “Articulations” palette. For information on modifying 
articulation playback characteristics, see “Articulations” on page 56. 
For information on editing these marks, see “Articulations and Trills” 
on page 134.
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4.5 Tempo
Default tempo for all time signatures is 120 beats per minute (120 bpm) 
except for “cut-time” and 2/2 time, which play at 60 beats per minute. 
Tempos can be modified by inserting one or more metronome marks, 
by inserting a tempo marking or with the ENF Tempo Controller.

4.5.1 Metronome mark

.The Metronome tool in the “Tempo” palette (also activated in Edit > 
Default Tempo) sets the tempo at the point the mark is inserted. 

FIGURE 4 - 8: Setting Default Tempo 

4.5.2 Tempo Markings

Tempo Markings are found in the “Tempo” palette. Clicking anywhere 
inside a staffline will insert the selected Tempo Marking above the 
staff. Tempo will be altered at that point. Note that Expressions, found 
in the “Articulations” palette, can be used but will not alter playback.

FIGURE 4 - 9: Selecting Tempo Markings from Tempo palette

4.5.3 Change of tempo

Creating a change-of-tempo is accomplished by inserting a tempo mark 
or metronome mark at the point where you want the tempo to change. 

4.5.4 Tempo controller

Another method of changing tempos is to use the Tempo Controller.

To activate the interactive Tempo Controller,

• Push the Tempo Controller button in the Text and Controllers 
toolbar. Clicking the orange line changes the default tempo 
value. For more details, see “ENF Graphical controllers” on 
page 63
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4.5.5 Tuplets and Slurs (Legatos)

While in the Insert mode, select a triplet (“T” key) from the “Notes” 
palette or select Legato from the “Articulations” palette. 

Creating a tie

Creating a slur

FIGURE 8 - 10: Creating a Tuplet or Slur (legato)

a. Click and drag down to insert the tuplet or legato above the notes 
to be selected.

b. Click and drag up to insert the tuplet or legato below the notes to 
be selected.

c. To delete a tuplet or articulation, Ctrl+click on it, press the “X” 
key then click again on the object. The Select tool (“O” key) can 
also be used to highlight and delete one or more tuplets and/or 
legatos.

NOTE: To resize or move a tuplet bracket, use Nudge mode and drag 
the control point located on either end of the tuplet.

• User-defined Tuplet (Rhythmic group button in “Note” palette)

The D:B tool button allows for custom tuplets. Divisions = The number 
of beats to be applied to the tuplet. Value = The total number of (equal) 
notes that would be in the group if no tuplet were applied.

For example: The septuplet (-5-) has a default D:B ratio of 5:4. When 
applied to a group of 5 eighth notes, its total duration value would equal 
4 “normal” eighth notes. 

• Nested tuplets (tuplet within a tuplet)

Choose the value required from the “Rhythmic Groups” palette. Click 
and drag the cursor to select a tuplet group within another tuplet. A 
bracket will drop identifying the nested tuplet.
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4.6 Playback Properties
Playback values of dynamic and articulation markings can be altered 
by use of the “Properties” tool. Changes can be applied individually to 
the marking itself or globally to all similar markings in the score. 
Finally, default values can be reset for that particular mark in all future 
files. Certain changes to barline properties will also affect playback.

To activate the Properties window of an object:

• Hit the “Esc” key or select the Properties icon from the Smart-
Score toolbar and click on one of the objects below to open and 
modify its playback properties and in some cases, its display:

4.6.1 Note Properties

Clicking on any note head will open the Note Properties window where 
a number of note duration properties can be changed. 

FIGURE 4 - 11: Note Properties

• Note duration: Change basic note value.
• Dots: Add or change dots of prolongation.
• Staccato: Change default duration when staccato is applied.
• Tenuto: Change default duration when tenuto is applied.
• Accents: Change default duration when accent is applied.
• Fermata: Change default duration when fermata is applied.

Note heads can be altered to several alternative “shaped note” configu-
rations including triangle, empty triangle, diamond, empty diamond 
and “x” shaped from the Note Head Shape pull-down menu.
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4.6.2 Property Options (All Properties windows)
• Apply (changed property) to All: 

Selecting this option will update playback properties of the same 
mark throughout the score. 

• Apply Setting(s) to All Future Files: 
Selecting this option will permanently reset the default value for 
the selected property to its new values for all future ENF files.

• Back to Default: 
This will reset values to application launch defaults.

• Reset Defaults; 
This will return values to new installation defaults.

4.6.3 Slur (Legato) Properties

FIGURE 4 - 12: Dynamic Marking Properties

• Extend duration: Duration of notes associated with the slur.
• None: No increase of note duration.
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4.6.4 Tempo Marking Properties

Tempo values can be changed by clicking any tempo marking with the 
Properties tool. Changes can be applied to all tempo marks in the docu-
ment or to all future instances of the selected tempo mark.

FIGURE 4 - 13: Tempo Marking Properties

• Tempo slider: Reset tempo value.
• Uncommon Name: Enter an alternative name for the tempo 

marking.

4.6.5 Hairpin, Cresc. and Decresc. Properties

FIGURE 4 - 14: Hairpin Properties

• Velocity sliders: Start value and Ending velocity values.
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4.6.6 Trill Properties

FIGURE 4 - 15: Trill Properties

• Permutations: The number of half-step movements.

4.6.7 Dynamic Marking Properties

FIGURE 4 - 16: Dynamic Marking Properties

• Volume slider: Resets the volume for the current part.
• Range: 10 to 127 (General Volume)

NOTE: To view the selected range of accelerando/descelerando, push 
the Hidden Objects button. Range is shown with dotted line.
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4.7 ENF Graphical controllers 
With the Velocity graphical controller you can vary note velocities of 
each note cluster quickly and smoothly. With the Tempo controller, 
you can “draw in” tempo variations smoothly over time. Controllers 
can be accessed either in the ENF Text and Controllers toolbar or 
below the Piano Roll window in MIDI view. 

FIGURE 4 - 17: Text and Controllers Toolbar

4.7.1 Velocity Controller 

In ENF score view, push the “Velocity controller” button to activate. 
Click and drag your mouse along the vertical bars which represent each 
note’s velocity. The higher the bar, the more the velocity.

FIGURE 4 - 18: ENF Velocity Controller

4.7.2 Tempo Controller

Push the “Tempo controller” button to active. The horizontal line in 
the topmost staff represents default tempo. To vary tempo, click and 
drag your mouse up or down. The last tempo point will be fixed until 
changed.

FIGURE 4 - 19: ENF Tempo Controller

4.7.3 Normalize controllers

After making changes to Tempo or Velocity controllers, you may find 
you have created greater-than-desired changes to playback. If so, you 
may globally reduce the effects of either controller by applying nor-
malizing.
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FIGURE 4 - 20: 

Normalize Tempo controller (Before)

Tempo controller after normalizing by 80%

Normalizing Tempo

To reduce effects of either Tempo or Velocity graphical controllers

a. Choose Playback > Graphical Controller
b. Select either Normalize Tempo or Normalize Velocity.
c. Choose amount of reduction desired: 20% / 40% / 60% or 80%. 

Controller display and playback will change accordingly. 
d. Choosing Reset removes all controller changes and resets the 

default settings. Tempo markings inserted into ENF will still take 
effect. The end result is an averaging of all tempo values.
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4.8 Other ENF Playback Controls
4.8.1 Barline Properties

You can correct playback of pickup and split measures, create system 
breaks (Codas) and page breaks with Barline Properties. Select Prop-
erties Tool and click on the barline that begins a measure of interest. 

FIGURE 4 - 21: Barline Properties

Pickup measures and split-measures (measures split between two sys-
tems) can be made to playback without pauses.

Pickup Measure (typical) “Split” Measure (typical)

FIGURE 4 - 22: Pickup and split measures

To correct playback of pickup and split measures,

• In the Playback pull-down menu, select “Play as written”.

To create a page break at a particular barline

• In the Page Layout pull-down menu, select “Break Page at This 
Barline”. To keep measures from separating during reformatting, 
select “Never Break System at This Barline”.
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To create a Coda (Split system)

• Codas (split systems) can be created at by clicking the appropri-
ate barline with Properties tool and checking Actions > “Split 
System”.

FIGURE 4 - 23: Creating Codas (Split Systems)

4.8.2 Pickup and split measures

Incomplete measures are sometimes written as “pickup” and “closeout” 
measures or they may be “split” between the last measure of a system 
SmartScore can correct playback for incomplete measures (pickup and 
split measures) by use of the Barline Properties tool.

For pickup measures or measures split between lines to play smoothly, 

a. Select Properties Tool and click on the barline that precedes the 
measure in question. The Barline Properties dialog box will open.

b. In the Playback combo box, choose “As written”. Playback will 
ignore current time signature. Make sure rhythm values are con-
sistent in all parts.

4.8.3 Karaoke View 

Feel like singing out loud? Hey, you only live once...

To view moving lyrics with familiar bouncing ball,

a. Press the Karaoke button in the Navigator palette.
b. The Options menu allow for changes in the Karaoke display. 

These options are also available in Edit > Program Preferences.
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c. Open the Playback Console (Ctrl + 9 / Cmnd + 9 for Mac) to 
adjust tempo and change instrument assignments for parts and 
voices. 

4.8.4 Swing

This very cool feature applies standard swing rhythm to straight 8th 
and 16th notes notated in beamed groups. SmartScore will modify 
playback and the underlying MIDI representation as follows:

To apply swing to playback,

• In the Playback menu, click on Swing.

4.8.5 Add drum tracks 

Adding an automatic drum track will add more pizazz to the mix. 

Push the Drum Pattern button in the SmartScore toolbar to select an 
appropriate pattern for your piece. For more information on adding or 
creating drum tracks, go to “Automatic Drum Patterns” on page 207.

4.9 Voices and Playback
Control of contrapuntal voices is key to proper playback of your score.

4.9.1 Voice Visibility

To view contrapuntal voices as colors, push the Voice Visibility button 
in the SmartScore toolbar. Each ENF Part (each staffline of the score) 
can contain a maximum of 4 voices (represented by 4 colors, black, red, 
green and blue). For scores to play back correctly, it is important that 
voices appear correct and be properly manipulated. See “Working with 
Contrapuntal Voices” on page 151 for additional details about editing 
voices.

4.9.2 Voice Splitting (Select + “H”)

Many hymnals and choral scores have voices grouped into chord clus-
ters as opposed to notes with stems in opposite directions. Chord clus-
ters are treated as one voice in SmartScore (usually black). Music 
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ministers and choir directors will find this tool extremely handy in 
order to split two-note clusters into 2 contrapuntal voices. Then, assign 
each voice a unique instrument or extract each voice to a separate file. 
See “Extracting Voices” on page 157 for more details.

To separate a two-note cluster to two separate voices,

a. Hit the “O” key or Select button to activate the Select tool.
b. Drag a box around any number of two-note clusters in the staff.
c. Press the “H” key to separate two-note clusters into 2 voices.

FIGURE 4 - 24: Splitting two-note chords into 2 voices

TIP: If you wish to split clusters containing three or more notes, 
select and delete the least desirable notes until you are left with 
two notes in each cluster. Only two note clusters will split.

4.9.3 Assigning instruments to voices

Assigning unique MIDI instruments adds richness and allows the user 
to distinguish contrapuntal voices during playback. There are two areas 
where you can change MIDI instrument assignments for voices: inside 
the Playback Console and inside the System Manager.

To change an instrument assignment of a voice in the Playback Con-
sole,

a. Push the Playback Console button in the SmartScore toolbar to 
open it. The console may be opened with quick-keys (Ctrl+9 / 
Cmnd+9) or from the menu by selecting Playback > Console.
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FIGURE 4 - 25: Changing MIDI instrument of a voice in Playback Console

b. In any of the Voice column, click to select a new MIDI instru-
ment.

To change an instrument assignment of a voice in the System Manager,

a. Open the System Manager (Ctrl+M / Cmnd+M) or select Sys-
tem Manager from Edit menu. All staves are displayed in hori-
zontal rows as “Parts”. Voices are arranged in columns above 
each part (1 thru 4). 

b. Find the voice number within the part you want to change. Click 
the MIDI instrument name assigned to that voice in the pull down 
menu. Select an alternative instrument. During playback, you 
will hear voices stand out from other voices provided you chose 
instruments with different timbres.

FIGURE 4 - 26: Changing MIDI instrument of a voice in System Manager

4.9.4 Correcting Vertical Alignment 

In printed music, noteheads belonging to different voices may appear 
side-by-side even though they are meant to sound simultaneously. Dur-
ing recognition, horizontal distances between offset noteheads are mea-
sured to determine whether to “glue” them to the same MIDI time 
event or not. It is possible that offset notes will not become glued due to 
excessive distance between the noteheads. It is also possible that notes 
will become incorrectly glued if they are too close. The default distance 
for joining noteheads to the same vertical event is 1/8th of a notehead. 
This can be changed prior to recognition. See page 33 for details on 
resetting this default note distance. 
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Following recognition, check that Voice Visibility is on (See Section 
4.9.1 on page 67). If two notes with opposing stems both appear black 
and are meant to play simultaneously, they can be aligned as follows:

To vertically align offset voices, 

a. Use the Select tool (“O” key) and highlight both horizontally off-
set notes or rests.

b. Press the “Y” key to group the selected, offset notes into a single 
vertical event. Selected voices may move a bit and change color.

Offset voices not “glued” 
following Recognition Using Select tool to 

highlight offset voices

“Y” key “glues” offset
voices to a single time
event. Select and “Y”
again “unglues” voices.(half note appears in black)

FIGURE 4 - 27: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes bunched together each displaying different 
colors (usually black and red and sometimes green), but which actually 
belong to only one voice, they are probably “glued” to the same vertical 
event. Joined notes can be “unglued” as follows:

To “Unglue” offset notes not intended to play simultaneously,

a. With the Select tool (“O” key), carefully select the incorrectly 
glued notes (NOTE: they will each have different colors). Be sure 
to select only the notes which are incorrectly joined.

b. Hit the “Y” key. Joined notes will separate and change color.

See “Join Offset Voices” on page 34 for changing recognition defaults. 
See also “Working with Contrapuntal Voices” on page 151.

4.9.5 More about voices and playback

Refer to “Working with Contrapuntal Voices” on page 151 for more 
information on editing voices and their affect on score playback.
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4.10 Jumps, Repeats and repeat symbols
To insert a repeat barline, repeat measure or any other repeat symbol,

• Toggle the “C” key to enter Insert mode. Select any repeat sym-
bol from “Barlines & Repeats” palette and click to place it. 

To change any current barline to a repeat barline,

• Select a repeat barline from the “Barlines” palette. Click on any 
existing barline to change it to the selected barline.

To delete any barline,

• Quick-select (Ctl+click) on a barline (or select any barline from 
the “Barlines” palette). Hit the “X” key and click on the barline to 
delete it. 

NOTE: Deleting a barline at the end of a system will cause the pro-
ceeding measure to roll to the next system. A notice warning 
of this effect will open whenever the last bar of a system is 
deleted.

To insert a “Repeat Previous Measure” mark,

a. Select the Repeat Previous Measure mark from palette.
b. In Insert mode, click into an empty measure. 

All notation present in the previous measure will automatically repeat 
itself during playback.

4.10.1 Repeated verses

Many scores have multiple verses that repeat several times even though 
they may not contain repeat barlines (e.g. hymnals). Other scores have 
sections marked only by single repeat barlines but are intended to 
repeat several times (e.g. the ending of a song with “repeat and fade”).

To set how many times a score or section of a score should be repeated,

a. Make sure the score or the section is bounded by a left and right 
repeat sign. If not, select a Left Repeat sign from the Repeats 
tool palette and click on the single barline that begins the 
repeated section. The single bar will become the repeat bar.
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NOTE: Do not delete a barline to change it; measures will reformat. 
Select a new barline and click on an existing barline to 
change. If the barline begins a system, a repeat barline will 
insert to the right and symbols will nudge to make room. This 
is normal. The two barlines will still behave as one.

a. With the Properties tool selected, click on the Left Repeat bar-
line that begins the section. The Barline Properties window will 
open.

FIGURE 4 - 28: Selecting the number of verses to be repeated

b. Select the number of desired repeats in the Repeat Section pull-
down menu. Choices are from 1 to 8 repeats.

4.10.2 Change of key/time and the double barline

Usually, changes of time and key signatures at the end of a system are 
preceded by a double barline. If for any reason playback hesitates after 
a change of key or time signature, make sure the barline preceding the 
signature is actually a double barline.

4.11 Endings 
Endings can be simple or complex. SmartScore can cope well with 
most endings, repeats and jumps, but if the logic is ambiguous or faulty 
(e.g. “bowl of spaghetti”), playback may have unexpected results.

4.11.1 Simple endings

To create a simple ending,
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a. Select Start Ending tool from the “Barlines and Repeats” palette 
and click on the appropriate barline to insert the first ending. 

b. The Repeats window will open. Choose “1” as the sequence 
number of the first ending.

c. The Close Ending tool will appear on the cursor. Click on the 
last barline that terminates the first ending. The cursor then 
switches again to the Start Ending tool. 

d. Click on barline that starts the second ending (it may be the same 
barline that closes the first ending). Choose “2” as the sequence 
number of the second ending. 

FIGURE 4 - 29: Multiple Endings

e. Finally, click the barline that “closes out” the last ending.

4.11.2 Repeated Endings

Some endings are repeated multiple times before continuing. And some 
endings may play out of strict linear sequence (e.g. 1,3 for the first end-
ing and 2,4 for the next).

To create repeat endings, 

a. Select the Start Ending button. Click on the measure that begins 
the first ending. In the Repeats window, select the number of 
repeats and/or the sequence order numbers. Sequences do not 
have to be in strict order. 

FIGURE 4 - 30: Ending Sequence
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b. Click the last barline to close out the second ending.
c. Repeat above steps as necessary for subsequent endings.

Playback will attempt to play repeated sequences in the order selected.

4.12 Jumps
4.12.1 Working with the Coda

A Coda sign marks the conclusion of a piece. A Coda is generally used 
to repeat a theme or variation outside repeated endings.

To mark the beginning of a Coda and to insert a “jump to Coda” sign,

a. Select Coda sign from the “Barlines and Repeats” palette. In 
Insert mode, click on the barline where the coda is to begin, usu-
ally at the end of a repeated section or numbered ending.

b. Select the To Coda sign and in Insert mode, find the point in the 
last passage or ending where playback is to “jump” to the Coda 
and click the barline where the jump is to occur.

NOTE: The Coda will not be played back until it is activated by the 
To Coda or d.s. al Coda sign. 

4.12.2 Working with the Segno

Segno means “sign”. It marks the beginning of a final repeat or ending. 
Segnos are usually positioned early on in the piece, after a repeat.

To mark a final repeat with Segno,

a. Select Segno from the “Barlines and Repeats” palette. 
b. Insert the Segno by clicking the barline that begins the last

repeated ending or section. 
c. To stop a final repeat or ending, return to the Segno and continue 

on to the Coda, select d.s. al Coda (meaning “from the sign to the 
Coda”).

To have a final repeat or ending return to the beginning of the piece 
and terminate at the Segno sign, 

• Select d.c. al Segno (meaning “from the beginning up to the 
sign”) and insert it by clicking on the barline in the last ending or 
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repeat where playback is to return. The repeated section will 
return to the beginning of the score and play through to the 
Segno.

NOTE: To Coda, Segno, d.s. al Coda, D.S., D.C. and d.s. al Fine 
signs are all ignored until an ending or repeat is played once.

4.12.3 Working with the da Capo (D.C.), dal Segno (D.S.), and 
Fine signs

D.C. (da capo) means “from the beginning” or “return to the begin-
ning”. 

To have playback return to the beginning of the piece and play through 
to the end,

• Select the D.C. button from the “Barlines and Repeats” palette.

D.S. (dal Segno) means “from the sign” or “return to the sign”. 

To have a final repeat or ending return to the Segno and play through 
to the end,

a. Select the D.S. button from the “Barlines and Repeats” palette.
b. Click on the desired barline to insert the D.S. sign.

Fine means ending. It is usually placed in the middle of a repeated end-
ing and terminates the song.

To have the last repeat stop, return to the Segno and continue on to the 
end of the piece,

a. Insert a Fine sign by clicking on the barline that marks the final 
end point. 

b. Select d.s. al Fine (meaning “from the sign to the end”) from the 
“Barlines and Repeats” palette.

c. Insert either the d.s. al Coda or d.s. al Fine mark by clicking the 
barline where the last repeat is to begin. 

To have the final repeat or ending return to the beginning and play 
through to the Fine,

• Place the Fine sign at the appropriate barline. Select and insert 
d.c. al Fine in a measure following the Fine sign.
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Repeat signs, ending markings (including Codas and Segnos) are found 
in the “Barlines and Repeats” palette. Using repeat signs properly will 
alter playback accordingly. 

4.13 Instrument Templates
The Instrument Templates environment makes up the “pool” from 
which instruments are assigned to stafflines in System Manager. To 
open Instrument Templates, select Edit > Instrument Templates or 
hit Ctrl + F Win (Cmnd + F Mac). Most common musical instruments 
are listed in the Names column. Abbreviations, MIDI instruments and 
transposed playback have been preassigned, but may be changed. 

FIGURE 4 - 31: Instrument Templates

Part Names in System Manager are directly linked to instrument 
Names in Instrument Templates. When a Part Name is selected in the 
System Manager, all playback parameters are derived from Instrument 
Templates. 

4.13.1 Transposed instruments

Since transposed instruments do not actually play the pitches notated in 
the score, to play them back in tune with the other non-transposed 
instruments, they must have their playback adjusted up or down by cer-
tain intervals. This “playback transposition” is already preset in Instru-
ment Templates for most transposed instruments. The number in this 
column represents the amount of pitch change (+/-) in half-step incre-
ments.
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4.13.2 Adding instruments

You can add new instruments with unique names and playback param-
eters as well as change existing names and parameters in any template. 
For more information on Instrument Templates, turn to “Instrument 
Templates” on page 160. For more information on the System Man-
ager, turn to “System Manager” on page 155.

4.14 Broken Parts
Parts (staves of the system) may loose playback continuity for several 
reasons, e.g. system braces/brackets were cut off during scanning.

4.14.1 Merging Systems

For parts to be joined to single system (and to play simultaneously), an 
adjoining bracket along the left-hand margin must be visible. If during 
scanning, brackets are cut off by mistake, one or more parts become 
separated and will appear in ENF as single-line systems themselves. In 
this case, it is possible to rejoin them; forming larger, corrected system. 

To merge two systems into one larger system,

It is important to properly re-assign part links before joining systems. 
Re-linking parts opens a window to the Super System (see page 158). 
Also, make sure systems to be merged have the same number of bars.

a. Position your cursor over the first broken system / staff line. Hit 
Ctrl+L / Cmnd+L (Mac) to open the Re-link Parts window.

FIGURE 4 - 32: Merging Systems

b. The active system highlights in grey. Using the checkboxes, reas-
sign each highlighted staff to its correct part name and position in 
what will become the final, reformed system. Apply to = System.
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c. Press the Next System button and reassign each highlighted staff 
line to its correct part name as you did above. Return to the first 
staff of the final, reformed system by selecting Previous System. 

d. Now, check the Merge checkbox. When the Next System button 
is pushed, the two systems will join into a single system. Con-
tinue using Next System again until all separated parts are cor-
rectly joined. Review Part Name checkboxes for correctness. 

4.15 Re-linking parts 
Occasionally, scores will contain collapsed or expanded systems
(sometimes referred to as “optimized systems”). Unless you re-link 
parts, these systems will not playback with the correct instrumentation.

The Re-link Parts function allows you to reassign each visible part 
with the correct Part Name found in System Manager. By re-linking 
parts of optimized scores, parts will play back correctly as they disap-
pear and reappear throughout the score. 

NOTE: Parts listed in Re-link Parts window are derived from the 
Part Name column of the System Manager (see “System 
Manager” on page 155 for more information). Checked boxes 
identify which parts are assigned to the active system. Before 
re-linking, make sure all possible parts have been created.

To re-link parts in a system, 

a. Hit Ctrl+L (Win) / Cmnd+L (Mac). Or with Properties Tool 
selected, right-click (alt / option for Mac) over any staffline in a 
system that requires re-linking and select “Part Linking”. This 
will open the Re-link Parts window.

FIGURE 4 - 33: Re-link Parts window
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b. Check the part names that are actually associated with the active 
system. Be sure to remove checks from parts that are not associ-
ated with the active system. Larger systems may require scrolling 
down the list. The program will not allow you to select more or 
less parts than actually appear in the active system. 

c. To view adjacent systems, press Next or Prev System. 
d. In the Apply To box, press Apply to apply to active system. Sys-

tem+ will apply to the active system plus all subsequent systems.
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Page #1 of Orchestral Score

Page #2 of Orchestral Score

 
 
In this example, the first 
page consists of one sys-
tem having 15 parts (15 
staves per system). With 
the cursor positioned over 
the system and Re-link 
Parts opened, 15 parts 
will be checked.

The second page contains 
3 systems each with 6 
staves. Many parts that 
appeared on the first page 
have dropped out. With 
the cursor positioned over 
one of the systems, 15 
Part Names will be listed 
but only 6 will be checked 
in the Re-link Parts win-
dow. In this case, it was 
necessary to remove all 
check marks and then 
check the top six parts to 
reestablish proper part 
linking. See Figure 33 on 
page 78. Notice that the 
re-linked parts were 
applied to all subsequent 
systems (System+) from 
the topmost active sys-
tem.

FIGURE 4 - 34: Re-linking an orchestral score
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4.15.1 Adding a staff when missed by recognition

Occasionally, a staff inside a system may not be localized during recog-
nition due to flaws in the original score (or if the scanned page is 
severely skewed. If there is a missing staff line in the ENF display, it 
can be reconstructed quite easily as follows:

a. First, you want to re-link parts in the shorted system. Position the 
cursor inside the system and hit Ctrl + L to open Re-link Parts.

b. Put a check next to the appropriate visible parts. Leave the miss-
ing part unchecked. Make sure the parts you check correspond to 
the visible staffline and the missing part is unchecked. Hit OK.

c. Select the Properties tool. Yellow arrows along the left system 
bracket will indicate all known parts, visible or invisible. 

d. In the affected system, click on the yellow arrow of any staff and 
put a check mark next to “Visibility”. Make sure “Show Staff” is 
also selected.

e. In the “Apply To:” pull-down menu, select “Current Staffline or 
System”.

f. Hit the “U” key and select Unify Key Signatures (based on First 
System). Hit OK and the key signatures of the score will become 
unified. Now you need only to fill in the missing notes. Remem-
ber you can always use Copy and Paste to clone measures of 
notes at a time whenever possible.
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Chapter 5 Basic ENF Editing

SmartScore files (or ENF files for Extended Notation Format) are fully 
editable. This section describes the most commonly-used ENF editing 
features. For information on advanced editing techniques such as part 
extraction, optimized scores, managing systems, applying or changing 
instrument templates, reformatting, respacing, page setup and part link-
ing, turn to Section Chapter 8, "Detailed ENF Editing" on page 125. 
Many editing and playback default settings are accessible in either 
Document Preferences or Program Preferences under the Edit menu. 
See Section 11.1, "Preferences" on page 213 for details.

5.1 Navigating Inside an ENF Document
5.1.1 Active staffline

Only one staff can be edited at a time. Positioning your mouse over a 
staff will cause it to highlight black. Objects associated with the staff 
(including text and lyrics) can then be edited. You can choose to high-
light just the active staff or to all staves in black. But only the staff with 
the cursor inside is active.

To display all staff lines in solid black, 

• Go to the View menu and uncheck Show Active Staff. 

5.1.2 Scan View and Long View

Following Recognition, the upper pane (in yellow) displays the 
scanned image associated with the ENF file (in white). The View > 
Split tool allows for resizing the horizontal split-pane.

FIGURE 5 - 1: Window pane control tool (View > Split)

Scores with multiple pages can be displayed in the workspace in sev-
eral different ways: Vertical, Horizontal or, if binding is required, by 
Facing Pages. A score can also display in one continuous Long View.
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To select a different page view layout,

• Click on any one of three page view buttons in Status Bar

It is possible to display your score in one, long continuous system. 

To display your ENF score in a single, long unbroken system,

• Select Long View page view button at bottom right of Status Bar. 
Otherwise, select Show Long View in the View menu. 

• To return to normal page layout, select one of page view buttons 
in the Status Bar or uncheck Show Long View in the View
menu.

NOTE: Whenever the ENF and TIFF view panes loose synchroniza-
tion, e.g. in Long View mode or after score reformatting, the 
TIFF display pane will close and a floating “Scan View” win-
dow will appear instead. The region shown in the scan win-
dow is relative to cursor position in ENF.

To change zoom level of the floating Scan view window,

• Select one of 3 zoom levels in View > Scan View window.

5.1.3 Zoom 

To Zoom in and out,

• Click the Zoom icon in the Main Toolbar or press Ctrl + Q. 
• Left click will increase the scale of your view (Zoom In), while 

right-click (Option + click for Mac) will decrease the scale of 
your view (Zoom Out). Ctrl + scroll wheel works as well.

For additional information on navigating inside an ENF document, go 
to “More ENF navigating” on page 125.

5.1.4 Paging

To page forward or backward in an ENF document, 

• The Next / Previous page control buttons are located to the far 
right of the ENF Toolbar.

To add a new page with empty systems,

• Push the Add New Page button in the Status Bar.
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5.1.5 Status Bar options

The status bar in the lower right corner of the SmartScore window con-
tains information about the current page being viewed such as Part 
Number, Page Number, Cursor Position, Page Size and Zoom View. 
Clicking inside any of these fields will open a control window: Go To 
(Part, Page, Cursor), Page Setup (Page Size) or Zoom Level (Zoom).

5.2 Editing Symbols
NOTE: It is recommended that you use the “left-hand-on-keyboard” 

technique as shown below. You will find editing fast and easy 
once you begin working with this “Quick Keys” method:

FIGURE 5 - 2: Left-Hand Position for ENF Editing

5.2.1 Pitch shift (Nudge mode)

To change the pitch of any note, 

Click into an active staff. Hold down the “Shift” key, click on control 
point in the center of the notehead. Drag the note head up or down to 
shift its vertical position in the staff.

To change the pitch of several notes at once,

a. Press “O” key to activate the Select tool in SmartScore toolbar.
b. Click and drag a box around any series of notes.
c. Hold down the “Shift” key and drag the notes up or down.
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5.2.2 Inserting Notes and Rests (F2 / R keys)

Musical symbols can be selected from one of several floating tool pal-
ettes normally positioned on the left side of the screen. Symbols with 
multiple values are grouped inside a single “master’ button identified 
with a small arrow. By holding down any button containing an arrow, 
the entire set of selectable symbols will expand to the right.

FIGURE 5 - 3: Expandable Palette Buttons (Notes and Rests)

5.2.3 Quick-select (Ctrl + Click):

You can select any symbol from the active ENF display without having 
to search inside a palette. Hold the Ctrl key down and click on any 
object in the active staff. The cursor will inherit that object’s properties. 

To insert a note, rest or other symbol
NOTE: Press the “F2” to open Notes palette or “R” key for the Rests

palette. “Shift + “R” will select an eighth rest.  
 
Quick-select (Ctrl+click) is usually the easiest way to select 
objects for editing. Hold down the Ctrl key and click on any 
nearby object. The cursor will become that object and inherit 
its attributes. Of course, objects are also found in palettes.

d. Select any note or rest from either of the expanding Notes or 
Rests buttons located “Notes” palette. 

e. Press the “C” key to activate Insert mode. 
f. The cursor will display the selected symbol along with a grey dot 

which indicates the line or space on the staff. Click to insert.

Refer to “Tool Palettes” on page 215 or to the Index on page 254 for 
details on other SmartScore tool palettes.
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5.2.4 Insert/Change mode

The “C” key on your computer keyboard activates Insert/Change mode 
as does the Insert button on the Main Toolbar. Insert/Change mode is 
automatically activated when a symbol is selected from a palette. 
Inserting a symbol and changing an existing symbol is essentially the 
same... point and click.

To change the value an existing note, rest or other symbol:
a. Select a note or rest within the same symbol class but with a dif-

ferent value.
b. Position your cursor over the note or rest to be changed until it 

highlights yellow. 
NOTE: When a note highlights light blue, a new note will be inserted 

in another voice at the same vertical event). (See“Working 
with Contrapuntal Voices” on page 151 for more information 
about vertical events.

5.2.5 Stem direction

In Insert mode, the default stem direction of a note is determined by its 
position on the staff. Stem direction automatically switches when your 
cursor crosses the middle staffline.

To override the stem direction as displayed by your cursor, insert any 
note with a right-click (option + click for Mac). This will cause the 
note to insert with the opposite stem direction as shown.

To reverse the stem direction of one or more selected notes,

• Select one or more notes with the Select Tool (“O” key). Hit the 
“S” key to change stem direction. 

To change the stem direction of an existing note,

a. In Insert mode, right-click (option + click for Mac) on any yel-
low-highlighted notehead. The stem direction will change.

5.2.6 Deleting objects

Objects must first be selected before being deleted. The 2 methods are:
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• “Click Delete” method: Quick-select (Ctrl+click) a symbol. Hit 
the “X” key. Click on any similar object to delete it. 

NOTE: You will be able to delete any object belonging to the 
selected symbol class. e.g. all notes will delete when a note of 
any duration is selected. The last selected object always 
appears when “X” key is hit.

• “Delete Group” method: Use the Select tool (“O” key) and drag 
the selector box over one or more objects highlighting them in 
yellow. Release the mouse. Selected objects will appear grey-
green. Hitting the “Delete” key will remove all selected objects.

5.2.7 Undo / Redo

To undo any single action,

• Click the Undo or Redo button to reverse the last editing action. 
Or hold the Ctrl down and hit the “Z” key (Cmnd + Z for Mac). 

To Undo or Redo one or more previous actions

• To select one or more actions to be reversed, click the small 
arrow to the right of the Undo or Redo buttons. Drag to select 
multiple actions. Push “Undo Actions” or “Redo Actions”.

FIGURE 5 - 4: Undo multiple actions

TIP: The Reset Workspace button (or F1 key) will reset all win-
dows and palettes to their default “startup” positions. It’s useful 
if your workspace gets messy. 

5.2.8 Accidentals 

FIGURE 5 - 5: Accidentals (in Notes palette)
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To insert an accidental, 

a. Select any accidental from the expanding accidental button 
located in the “Notes” palette. 

b. Toggle the “C” key to activate Insert mode.
c. Click on the notehead that is to receive the marking.

To change an accidental,

• Select an accidental from the “Notes” palette. Toggle the “C” key 
until a white arrow appears and click on a notehead to change.

To delete an accidental, 

• Quick-select (Ctrl + click) any accidental, press the “X” key and 
click on a notehead to remove its associated accidental.

A courtesy accidental is bounded by parentheses and acts as a reminder 
that a note has an accidental.

To insert a courtesy accidental, 

• Press the parentheses button when any accidental is selected 
before clicking a notehead.

5.2.9 Rhythmic errors

Measures highlighted in a reddish color indicate that one or more 
rhythmic errors has been located in a voicelines. 

FIGURE 5 - 6: Measure with rhythmic error (1 beat is missing)

For neatness, many scores intentionally truncate second and third 
voicelines. Normally, truncated voices will not cause playback prob-
lems provided notes on the same beat are vertically aligned.

FIGURE 5 - 7: Voice #2 (stem down) is truncated causing rhythmic error
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Pickup measures and measures split between systems can be made to 
play back without pauses very easily (see "Pickup and split measures", 
Section 4.8.2, on page 66). The red highlight color used to flag error 
measures can turned off by unchecking “Show Error Measures under 
the View menu. 

5.2.10 Dots of Prolongation
• Select the “D” key, dot or double dot from the “Notes” or “Rests” 

palette. Click on any notehead to attach a dot of prolongation.
• To Delete a dot of prolongation, press the “D” key again and 

click on the notehead.

5.2.11 Ties

Ties connect contiguous notes of the same pitch causing the first note 
to sound for the duration of both notes. Ties are not the same as slurs.

a. While in the Insert mode, hit the “V” key or press a Tie button in 
the “Notes” palette. 

b. Click on the notehead of the first note of a tied pair to insert the 
tie with a downward arc.

c. Right-click (option + click for Mac) to insert a tie with upward 
arc. 

d. To delete a tie, hit the “X” key with a tie showing on the cursor 
and click the first note of the pair to delete. 

5.2.12 Editing note clusters

To insert additional note heads to existing note stem: 

• In Insert mode, additional noteheads can be added to an existing 
note stem simply by clicking above or below an existing note 
provided the selected note value (displayed by the cursor) is the 
same as the existing note stem. Position the cursor on the correct 
line or space and when the note highlights yellow, click to insert.

• To add a notehead to any existing note stem (regardless of what 
is shown on your cursor), hit the “Z” key (“Cluster tool”). When 
the existing note highlights yellow, click to insert new notehead. 
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To delete a notehead from existing cluster: 

• Select Cluster tool from the Notes palette (“Z” key). Then hit the 
“X” key Clicking on any notehead in a cluster will remove a sin-
gle notehead. The Delete cluster tool also works to delete single-
headed notes.

NOTE: Always use the Cluster tool to remove single note heads. The 
single greyed note and arrow will delete entire note cluster.

5.2.13 Inserting, changing and deleting beamed notes

To edit beamed notes:

Hit the “C” key (or click on the Insert button for Insert mode) and 
select a flagged note from the “Notes” palette. Then choose a beam 
direction from the “Beams” palette or the “A” key on your computer 
keyboard. If a similar beam note is nearby, Ctrl + click on it to select it.

Notes Palette (expanded) Beams Palette (expanded)

FIGURE 5 - 8: Editing Beamed Notes

• To form a beamed group, insert the selected beamed note by 
clicking into a staff (not adjacent to another beam group). 
Repeated clicks will form successive 2-note beam groups when 
“left” or “right” beam direction is selected. One continuous beam 
group will be created when the “middle-beam” is selected. Auto-
Beam can be used, but it may also cause re-coupling of other 
beams in the measure. See “Auto-Beaming” on page 147 for 
more details.

• Inserting a “right” or “middle” beam to the left of an existing 
beam group will cause that note to attach itself to the beam on its 
right. Likewise “left” and “middle” beams will attach to the right 
of an existing beam. Clicking inside an existing beam group with 
the “middle” beam selected will insert a beam note inside the 
beamed group.

• Clicking on an yellow-highlighted beamed note will change its 
note value and/or beam direction as indicated by the cursor. 
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• To delete a beamed note, Quick-Select it, hit the “X” key and 
clicking again to remove it. Deleting an end beam will cause the 
beam to join to any adjacent beamed groups. 

5.2.14 Forming beam groups (Select + “B”)

To create a single beam group from adjacent flagged or beamed notes: 

• Use the Select tool (“O” key) and highlight any number of adja-
cent flagged notes. Hit the “B” key to join the notes into a single 
beamed group. The “B” key will also join two or more adjacent 
beam groups that are selected.

5.2.15 Barlines palette (I)

While in the Insert mode, hit the “I” key (or select any barline from the 
“Barlines & Repeats” palette). 

• Click anywhere in the active staffline to Insert a barline.

To change or delete a barline, 

a. Select a desired barline from the “Barlines” palette or Ctrl+click
on a barline nearby. 

b. Click on a yellow-highlighted barline to change it to the selected 
barline.

c. To delete a barline, Quick-select it, press the “X” key and click 
on the barline. 

NOTE: Deleting a barline at the end or beginning of a system will 
cause the proceeding measure to roll to the next system. A 
notice warning of this effect will open whenever the last bar 
of a system is deleted.

5.3 ENF Symbol Properties
The Properties tool is found in the SmartScore toolbar. Certain play-
back and display properties of most symbols can be edited by clicking 
with the Properties tool. Changes can be applied to all similar symbols 
in the score and even to all identical symbols created in future files.

Other symbol properties directly affect playback. To find out about 
editing those symbols, see “Playback Properties” on page 59.
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5.3.1 Staff Line Properties

Click the yellow staff properties marker while the Properties Tool is 
activated. Editable properties include:

• Part Name (Directly linked to Part Name in System Manager 
(Ctrl + M)). Part Names are created in Instrument Templates.

• Staff line visibility (View or hide active staff line. NOTE: Turn-
ing off visibility may remove permanently remove symbols)

• Set number of measures (Set number of measures apply glo-
bally or locally)

FIGURE 5 - 9: Staff Properties window

5.3.2 Staff Line Options (Right-click inside staff line)

Certain staff functions such as staff spacing, bracketing and part linking 
(for linking parts with expanded or collapsed systems) can be accessed 
by right-clicking (alt / option + click for Mac) in any staff line with the 
Properties tool active.

FIGURE 5 - 10: Staff Line Options (Right-click)
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For detailed description of these commands, see “Globally applying 
line, staff and system spacing” on page 119, “Bracketing” on page 112, 
“System Manager” on page 155, “Re-linking parts” on page 78.

5.3.3 Barline Properties
• With the Properties tool selected, click on the barline preceding 

the measure of interest. For details on controls, see “Barline 
Properties” on page 65.

FIGURE 5 - 11: Barline Properties

5.3.4 Note Properties
• With Properties tool selected, click on any note head. Here you 

can change note values, dots and even the appearance of the note-
head.

FIGURE 5 - 12: Note Properties
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Refer to “Playback Properties” on page 59 for details on Note Proper-
ties and other playback properties including:

• Articulations & Dynamics (trill, arpeggio, dynamic marks, etc.)
• Slur (to shorten or extend legatos)
• Tempo marking (to change default tempo speeds)

5.4 Transposition by Key and Clef 
Transposing all or part of a score can be accomplished in one of several 
ways. The most common is “transpose globally by key”, e.g. change an 
entire song from the key of E-Flat to the key of C.

Other transposition methods such as transpose-by-clef, transpose 
within a selected range and transpose-notes-only are all possible. To 
transpose the key of an entire score,

a. Push the Transpose button or hit Ctrl +T Win (Cmnd+T Mac).
b. The “source” key signature will appear in the main window with 

its signature name listed in both major and relative minor keys.

FIGURE 5 - 13: Key Transposition

c. Choose to transpose either by Key or by Clef or by Pitch.
d. Use the scroller to select a new key signature if by Key or a new 

clef sign if by Clef.
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e. With Closest selected, SmartScore will transpose to the target 
key, up or down, with the least number of intervals. Choose Up
or Down if you wish to make your own choice. Push OK.

For information on additional transposition methods turn to "Transposi-
tion", Section 8.8, on page 148.

5.5 Printing your final score
If your score was scanned, ENF pages will probably not be centered. 
Page Setup provides various tools for controlling print layout. The 
simplest way to center music on each page is to select the Fit to Page
layout option.

To center ENF frames prior to printing...

• Open Page Setup. In the Document Layout pull-down menu, 
choose Fit to Page. Click Apply.

NOTE: Other document layouts can be applied in Page Setup. For 
example, you may want to have alternating left/right margins 
for bound scores. To explore other printing layout option, see 
“Selecting and creating custom document layouts” on 
page 164.

To print your score,

• Select File > Print.

To save your score as a PDF file,

• Select File > Save As PDF (Windows requires PDF 995 from 
installer).

5.5.1 Copying an ENF region to paste into other programs

To copy an onscreen region for pasting into another application (e.g 
Microsoft™ Word®, Adobe™ Photoshop®, etc.), 

a. Press the “O” key to activate the Select tool.
b. Drag to select a region on an ENF page that you wish to copy. 
c. Select Edit > Copy (Ctrl +C / Cmnd+C) to copy selected (high-

lighted) region to the clipboard as a bitmap image. 
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d. Open application that supports bitmap graphics and select Paste.
TIP: Use this feature to take “snapshots” of musical snippets and 

Paste into word processors or other non-music programs.

5.6 Creating a New ENF Score from Scratch
SmartScore isn’t only about scanning. It is also a full-featured score-
writer as well. When creating a new score from scratch, certain defaults 
will turn on such as auto-beaming and auto-spacing.

5.6.1 New score

To create an empty ENF score using one of several basic templates,

a. Push the Score button on the Navigator or select New > New 
ENF under the File menu (Ctrl + N (Win) / Cmnd + N (Mac)). 

FIGURE 5 - 14: New score window

b. Type in a Title for the new score.
c. Add the Composer’s name for the first page score header.
d. Press the Page Setup button to change the basic page layout of 

your score. See page 222 for details.
• Page Setup opens document size and layout window.
• Tempo will insert a metronome mark for playback.
• Uncheck Insert Clef Signs automatically to create an ENF docu-

ment without clefs.
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5.6.2 Using Built-in Templates

SmartScore has 15 preset 2-page templates including solo instrument, 
piano, duet, common vocal and orchestral scores and a custom setup.

a. Select a desired template from System Type in Score window.
b. Once the score is open, you can edit normally.

To add a new page, 

a. Push the “Add New Page” button on the right of the status bar. 
b. Or, select “Add Empty Page” from the System Options menu by 

right-clicking on any system with Properties tool active.

To delete an empty page,

• With the Properties tool active, right-click (alt for Mac) into 
each system of the page you wish to delete. Select “System > 
Remove” in the System Options menu. Repeat as necessary.

5.6.3 Real Time Recording

An alternative to entering notes in by hand is to record MIDI-based 
performances using a MIDI keyboard or some other MIDI instrument. 
For more about this, see “MIDI Recording” on page 196.

5.6.4 Step Time Recording

An alternative to Real Time Recording is Step Time Recording. Step 
Time Recording is done in MIDI and can be a very fast method of 
entering in notes (when you can’t scan it in of course!). For more, turn 
to “Step Time Recording” on page 200.

5.7 Saving and Exporting ENF Files
You can save the current ENF file at any time by pushing the Save but-
ton in the Main toolbar or by hitting Ctrl + S (Cmnd + S for Mac). 

5.7.1 Converting SmartScore files to other file types

To save SmartScore files in one of several different file formats.

a. In the File > Save As (Filetype/Format) pull-down menu, 
choose one of the following formats to save the ENF score to:
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• MusicXML (.XML) MusicXML has quickly become the most 
widely used file format for the exchange of music notation files 
between scorewriters. Most well-known notation scorewriting 
programs now support importing and exporting MusicXML files 
including Sibelius®, Finale®, Notion®, Personal Composer® and 
others.

• .FIN files will import SmartScore pages into Finale® 2000 or bet-
ter with graphical information and page layout intact. Use the 
File > Import selection in Finale to open a SmartScore .FIN file.

• MIDI files (.MID) will import playback data into most other 
music software programs with no page formatting. All graphical 
information about note position, stem direction, voices, etc. are 
lost. MIDI is to music what ASCII is to text. 

• NIFF (.NIF) Notation File Format used by applications such as 
Lime.

b. Press Save. The proper extension will automatically be added.
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Chapter 6 Editing Text, Lyrics and Symbols

This section covers editing text, lyrics and chord symbols. SmartScore 
attempts to distinguish between chord symbols, lyrics and between 
“dumb” and “performance” text when music is recognized. Dynamic 
and tempo text markings become applied to playback when recognized. 
Only “dumb” text fields are editable in Text mode.

6.1 Text mode
To enter Text mode for editing or creating “dumb” text,

a. Push the “T” button in the Text and Controller toolbar. 

Text fields are associated with the nearest staffline. To ensure text is 
associated with a particular staff, move the cursor over the staff first.

b. Click anywhere and begin typing.
NOTE: It will not be possible to do other sorts of editing other than 

text or lyrics in either of these modes. It will be necessary to 
push “T” or “L” again to exit the mode first.

To edit a text field,

a. While in Text mode, click anywhere inside a text field.
b. Drag left or right to highlight one or more characters within the 

field. Typing will replace the characters. Hit the Delete key to 
remove highlighted characters. Text can also be cut, copied or 
pasted elsewhere using standard Ctrl +“X”, “C” and “V” short-
cuts (Cmnd + “X”, “C” and “V” for Mac).

To delete text fields,

a. To delete more than one text field, use the Select tool (“O” key) 
to select and highlight text in yellow. Hit the Delete (Del) key 
removes all highlighted text fields. 

b. Quick-select (Ctrl+click) any text field, hit the “X” key (cursor 
goes grey) and click again on any text field to remove it.
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6.1.1 Nudging text

To nudge text,

a. Hold the Shift button down to enter Nudge mode.
b. Each text field has a small yellow box to its left.. 
c. Click and drag the box to reposition the text field to where you 

want it. 

To move multiple text fields,

a. Use the Select Tool and drag the cursor to highlight a multiple 
text fields. Release the mouse button. Selected text fields will 
turn from yellow to green-grey. 

b. Hold the Shift button down to activate Nudge mode.
c. Dragging one control box of a highlighted text field will move all 

selected text fields together.

6.1.2 Score Header

Score headers are not considered “text”. They are unique tags.

To enter a Score Header at the top of the first page of the ENF file,

a. Select Edit > Score Header.

FIGURE 11 - 14: Score Header

a. Enter a name for the ENF document in the Title field.
b. Enter a Composer name if desired. 
c. Type a part name if it is a Score-Part. For definition, see Score-

Part on page 249.

To move a Score Header vertically,

• With Selector tool active, drag the positioning tab associated with 
the score header found in the left-hand margin up or down.
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6.2 Lyrics
A lyric “block” is a string of characters equivalent to a spoken syllable. 
Out of recognition, a lyric block becomes associated with a single note 
or rest in the staffline immediately above it. Locating the note or rest 
associated with a lyric block is as simple as searching directly above 
the center-justified lyric block. All lyric blocks within stafflines are 
horizontally linked and are separated from each other by dashes, under-
lines and/or periods. 

NOTE: Text and lyrics have different colors. Text black, lyrics blue. 
NOTE: Lyrics may be found below a system (e.g. some choral scores) 

and a special option should be selected before Recognition. 
See “Lyrics Under Last Staff of Systems” on page 33.

TIP: Move notes in Nudge mode to verify lyric-to-note associations.

To edit lyrics,

a. Push the “L” button in the Text and Controllers toolbar to enter 
Lyric mode. 

b. Click into a lyric block or on an associated note or rest. Once 
highlighted, text within the block can be edited like normal text.

c. Click and drag inside a lyric block to highlight characters for 
editing. Use the left arrow, right arrow or spacebar on your key-
board to navigate within a lyric block. Once positioned, type nor-
mally. 

d. To delete one or more characters in a lyric block, highlight one or 
more characters within the block to replace with new characters 
or . Characters can also be cut, copied or pasted elsewhere using 
standard Ctrl + “X”, “C” and “V” keyboard shortcuts (Cmnd + 
“X”, “C” and “V” for Mac).

e. To edit a lyric block below the current line of lyrics, click into the 
topmost line of lyrics and use the down arrow key. Cursor will 
enter the next block in lyric line immediately below. 

f. To create a new lyric line, hit Return anywhere in a lyric line. A 
new lyric line will be created at the first note of the system. 

g. Push “L” again (Text and Controllers toolbar) to exit Lyric Edit.
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To move lyrics up or down between staves,

a. Hold the Shift key down (Nudge mod)e, locate the yellow con-
trol handle along the left-most barline of the system.

b. Drag the control handle up or down to move entire lyric block..

FIGURE 6 - 15: Nudge mode - repositioning Lyrics

TIP: You may also change lyric font size. See “Changing styles of 
Text and Lyrics” on page 105.

6.2.1 Dashes, spaces and underscores

Dashes, spaces and underscores are special characters used to separate 
lyric blocks. Typing any of these characters will move the cursor to the 
next block. The Backspace key deletes dashes, spaces and underscores.

In the following example, the block “der-” was missed in recognition. 
The cursor was positioned at the end of the previous block. A dash was 
entered to create a new “syllabic” block and the correct text was then 
entered. 

FIGURE 6 - 16: Editing Lyrics

• Dash = Moves the cursor to next lyric block and inserts a dash. 
Normally used to connect multiple syllables within a single word.

• Space = Moves the cursor to the next lyric block. Normally used 
to separate words. Does not insert a dash or an underline.

• Underline = Normally used as a “melisma”, an underline indi-
cates that one vocal sound should be extended over two or more 
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beats. Inserting creates an underline up to the next block. Enter-
ing multiple underlines will string them together over several 
lyric blocks. 

• Backspace = Deletes characters inside a lyric block. Also deletes 
hyphens when backspacing from one lyric block to the next.

• Carriage Return = Creates a new lyric line and positions cursor 
in the first lyric block below beginning note or rest of the 
staffline.

6.2.2 Verifying vertically aligned voices

Nudging note heads horizontally is a good way to verify that a particu-
lar lyric block is indeed associated with a note stem. In a similar way, 
Nudge mode is useful in verifying that vertical events are properly 
aligned. Refer to “Checking vertical alignment of voices” on page 153
for more information.

To verify vertical alignment of two or more voices in Nudge mode,

Horizontally nudge the upper note (Voice #1) of a vertically aligned 
set of notes and/or rests. All vertically aligned (joined) notes or rests 
will move together.

6.2.3 Changing styles of Text and Lyrics

Out of recognition, all text fields and lyric blocks are matched to the 
closest font type and size available on your computer. You can change 
the font type, size and color of text and lyrics. This is useful if lyrics 
appear too large. Modifying the style of any lyric block will change 
ALL lyric blocks because lyric blocks are tightly integrated and text 
fields are not (they’re “dumb”).

To modify font styles of text fields or lyric blocks,

a. Push the “T” button to enter Text mode. Click into any text field. 
While the cursor is blinking, right-click (alt/option + click for 
Mac) to open the Style window.

b. For lyrics, push the “L” button and click on either the associated 
note or rest or directly into a lyric field. Right-click to open the 
Style window (alt / option + click for Mac). 
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The current text style will be highlighted in the Text Style window. 
Other font styles found in the current document will also be displayed. 
All installed fonts and text styles (including non-Western symbols) are 
available for selection.

c. Click on the style you wish to change and then select “Modify 
Style”. “Add Style” and “Delete Style” options are also available. 

FIGURE 6 - 17: Changing Text and Lyric styles

The Font window is where the current font name, style, size and color 
are displayed. Choose an alternative font, style, size or color. OK will 
apply the change and exit the “Font” window. OK in “Styles” will 
close that window. Selected fields will then be updated. 

NOTE: The Text Sytles window is also accessible in Document Pref-
erences (File > Document Preferences).

6.3 Editing Symbols in Document Preferences
Non-lyric and non-text symbols (e.g. dynamic and tempo markings) 
which appear as text are also editable.

To edit Text Symbols

Open Edit > Document Preferences. The Text Symbols tab appears as 
follows:
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FIGURE 6 - 18: Document Preferences > Text Symbols tab

6.4 Guitar Fret and Chord Symbols
Guitar fret diagrams are recognized automatically. Even chord symbols 
written as text can be automatically converted to fret symbols. (See 
“Recognition Options” on page 33). You can display either the chord 
symbol or the fret diagram, or both. When transposing keys, the root of 
all chord symbols will automatically update. Only chord symbols asso-
ciated with a guitar fret will be updated. Chord symbols alone, recog-
nized without frets, are only “dumb” text. See “Tip” on page 41 for an 
easy method of removing “dumb” chord names recognized as text.

6.4.1 Choosing a fret / chord symbol from the library,

If no fret symbol was recognized, it can be selected and inserted.

a. Push the fretboard button in the Text and Controllers toolbar.
b. Click above the topmost staff where the symbol will be inserted.
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c. The Guitar Chord Library and editor (GCL) will open. 

FIGURE 6 - 19: Guitar frets and chord symbols library

d. Select a Root chord name. Add a Sharp, Flat, Tonality, Exten-
sion and Augmentation as necessary. 

e. If the selected chord name matches one stored in the library, a 
corresponding fret configuration will appear in the right window. 

f. Push OK. The fret / chord symbol will appear above the staff.

6.4.2 Creating a new chord symbol / fret configuration

If the chord name you are creating does not exist in the library or if you 
want to create a new fingering configuration for the same chord name, 

a. Push the Add button in the GCL window to open the fret editor.
b. In the Label tab window, select a Root chord name. Add Sharp, 

Flat, Tonality, Extension and Augmentation as necessary. 
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c. Press the Frets tab in the upper part of the window to open the 
fingering and symbols editor. Edit options are as follows:.

FIGURE 6 - 20: Guitar Chord Library - Fret Editor

• Right-click (Option + click for Mac) on any finger marker 
inside the fretboard to remove it.

• Clear All (grid) removes all current finger markers in fretboard.
• String Marker (dot) places a finger marker on any string 

between frets on the fretboard. Clicking above the fretboard nut 
(thick line) places an open string symbol (open dot) at any string 
position.

• Barre Marker (arc) places a barre marker above the fretboard 
by dragging above the nut. When dragged across strings inside 
the fretboard, the barre marker is positioned between frets.

• Mute-string marker (x) places an X above any string position to 
indicate a muted string. When clicked above the nut, any finger 
marker of that string is deleted.

• For banjo, ukulele, bass or other non-six string fretted instrument 
or for chords that require more range than 4 frets, choose the con-
figuration you wish from Strings x Frets combo box.

• To show fingerings in other than 1st position, choose from Posi-
tion Selector. The solid line represents the fret position.

• Press Copy to copy the current fretboard to the clipboard.
• Press Paste to paste in the fretboard layout from the clipboard.
d. Press Add. 

The newly created chord and symbol will be written to the library. 
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6.4.3 Changing an existing chord symbol’s fingering

If you want to change the fingering / fret configuration of an existing 
symbol follow the steps in “Choosing a fret / chord symbol from the 
library,” on page 107. 

a. Push the Change button (not Add) in the main GCL window. 
b. Make changes in the fret editor. Push OK and OK again.

To change a recognized guitar fret / chord symbol,

a. Choose the desired chord name from the Root pull-down menu. 
b. Select sharp, flat, Tonality, Extension and Augmentation.
c. A corresponding fret configuration will appear in the window if 

the complete chord name matches one stored in the library. 
d. Click OK if the chord name / fingering configuration is accept-

able. The ENF fret diagram and chord symbol will update.
NOTE: Some chords have more than one fingering configuration. 

When Primary is checked, that configuration will appear 
before other chords having the same name. 

6.4.4 Adding newly recognized chord symbol configurations,

Following recognition, you may see some fret symbols without chord 
names. To add these new configurations to the Guitar Chord Library,

a. Position your cursor over a fretboard without a chord name and 
Quick-select (Ctrl + click) it so the cursor becomes a “grid”.

b. Click once again on the fretboard to open the GCL editor. 
c. Push the Change button to open the fret editor and make neces-

sary fingering and symbol changes. 
d. Once fingering changes have been made, push OK.
e. In the main GCL window, push Add to open the Add Chord

window. Select a Root name and any other extensions as neces-
sary. When the new chord is completed, Push the Add button.
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To delete existing chord symbol(s),

• Quick-select (Ctrl+click) on any existing chord symbol. Hit the 
“X” key. Begin clicking on any chord symbol (highlighted yel-
low) to delete them. To delete several fret symbols at once, use 
the Select tool, highlight as many fret symbols as you wish and 
hit the Delete key.

To move a chord symbol 

Hold the Shift button down and click and drag the control point of a 
chord symbol to reposition it.

To move one or more chord symbols,

a. Use the Select tool (“O” key) and highlight desired number of 
fret symbols.

b. Click and drag control point of any fret symbol.

To change an existing chord or symbol in the Guitar Chord Library,

a. Push the Change button in the Library section of chord window.
b. Proceed to edit chord symbol as described above. When finished, 

press OK in Frets window. Chord symbol is automatically 
updated.

NOTE: You can page through symbols using either the scroller or 
clicking through the “index” window in bottom right corner.

To reorder all chords based on alphabetical order,

• Press Reorder.

To scale guitar fretboard / chord symbols, 

• From the Scale window, change the size of fretboard symbol 
from +2 down to -6. All fretboard and/or chord symbols will re-
size to this scale.

To export, import, reset or clear a GCL library file, 

• Press File in the Chord Library window.
• Export Library will save guitar chord library to a file. Choose 

the target directory and/or drive to save.
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• Import Library will load a saved guitar chord library from a 
directory and/or drive. Locate the .GCL file and push OK to load.

• Reset to Default will reload original guitar chord library as ini-
tially loaded during installation.

• Clear All Chords deletes all current guitar chord library data.

6.5 Bracketing
Instrument families are grouped with the use of brackets. Grand staff 
and braces are recognized whenever possible. Use Bracketing to 
assign braces, grand staff brackets and to join selected parts into barline 
groups in an ENF document.

FIGURE 6 - 21: Bracketing window

To create braces, grand staff brackets and create barline groups,

a. Select Bracketing from Edit menu (Ctrl + B (Cmnd + B Mac).
b. Highlight two or more parts in list to select for grouping.
c. Choose Brace, Grand Staff or Barline Group set and press Set 

Sel.
d. Continue to select parts for any other type of group. Any selected 

group can overlap parts of another selected group.
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e. Click “Break Barline by Brackets” checkbox to have barlines 
break according to instrument families which are already desig-
nated by braces, groups and grand staffs.

f. Choose Clear Sel or Clear Selected Parts in selected group or 
Clear All to remove groupings.
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Chapter 7 Changing Score Structure

Once you have recognized and edited your music, you can extract and 
recombine parts and voices, create a conductor’s score from separate 
parts, resize staves and systems or reformat the entire score. This chap-
ter covers various ways of altering the ENF score structure. 

7.1 Reformatting the Score in System Manager 
7.1.1 Extracting parts using Visibility

Below is an example of a vocal / piano arrangement. Here is how to 
extract the vocal line and open it in a fresh document.

FIGURE 7 - 1: Three-part score (e.g. Gluck.ENF)

To extract a selected Part from within the System Manager,

a. Position your cursor over an ENF system that contains the part 
you wish to extract. Hit Ctrl+M (Cmnd+M for Mac). The Sys-
tem Manager will open.

FIGURE 7 - 2: System Manager (displaying active system)
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b. Check the box “Visibility” in lower left-hand corner of the win-
dow. This informs the System Manager of the kind of action we 
are taking. 

c. Now we will choose which parts to extract. To the left of the 
parts you do not wish to extract, remove the visibility check-
marks. This leaves only the part(s) you wish to extract with 
checkmarks.

d. Press Apply to New to create a new score, leaving the current file 
unaffected. Or press OK to remove parts from the open docu-
ment.

Below is the result of the extracting the part shown in FIGURE 7 - 2:

FIGURE 7 - 3: Extracted vocal Part

7.1.2 Extracting voices using Visibility

Let’s go back to the original ENF document in FIGURE 7 - 1:
(Gluck.enf / tif or any three part score). Let’s say we want to extract a 
contrapuntal voice from the right hand part.

To extract a voice from an existing part,

a. Select Edit > System Manager (Ctrl+M (Cmnd+M Mac)).
b. Remove checkmarks of all parts and voices except for the part 

and voice you wish to target.
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FIGURE 7 - 4: Selecting Voices to be extracted

c. Make sure “Visibility” in lower left-hand corner is checked.
d. Press Apply to New to create a new score, leaving the current file 

unaffected. Or press OK to isolate the part in the open document.

Here is the result of extracting Voice #1 from the right hand piano part:

FIGURE 7 - 5: Extracted Voice

7.2 Reformatting scores in ENF view
Measures, staff lines and systems can be resized, compressed or 
expanded from the ENF view while keeping proper note spacing (punc-
tuation) intact. Measures can be scrolled from one system to another 
both manually and automatically. When the time comes to print out the 
score, several page layouts can be selected, page margins can be modi-
fied and pages of the score can be previewed. 

NOTE: Reformatting any part of the ENF view may cause a loss of 
synchronization with the original scanned image. If this 
occurs, the floating Scan View reference window will open. 
To open the Scan View window manually, check Scan View 
window in the View menu.
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7.2.1 Changing staff and system spacing

Staff and system spacing can be changed by simply dragging distance 
tabs up or down. Settings can also be made numerically using a dialog 
box described on page 119, "Globally applying line, staff and system 
spacing". But that dialog is meant to apply changes to other systems.

7.2.1.a Changing staff line spacing (Right-hand tabs)

To increase/decrease the size of individual staves...

• Drag the tab aligned with the bottom staff line of any part up or 
down. The staff will resize vertically.

Resizing staff lines
(Before dragging tab)

Resizing staff lines
(After dragging tab)

FIGURE 7 - 6: Using tabs to change staff distances and system widths

7.2.1.b Changing distances between staves and system (Left-
hand tabs)

To increase/decrease the distance between staves...

• Position the cursor over a staff to make it active. Drag the lowest 
tab up or down. The distance between the home staff and the staff 
below it will change. To change the distance between the active 
staff and the staff above it, drag the “T” tab (top).

Changing staff distance
(Bottom tab)

Changing staff distance
(Upper tab)

Active
Staff

Active
Staff

FIGURE 7 - 7: Using tabs to change staff distances and system widths
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7.2.2 Globally applying line, staff and system spacing

Spacing of any system can be applied to subsequent or all other sys-
tems. For example, a piano accompaniment with smaller solo part can 
be easily created by reducing the staff height of just one system. 

To apply line, staff and system spacing to all other systems...

a. Position your cursor over the “template” system. This will 
become the baseline to change other systems. Right-click (alt + 
click for Mac).

b. Click “Line/Staff Spacing” in the System Options window.

FIGURE 7 - 8: Line/Staff spacing window

NOTE: Distance, line spacing and offset settings simply reflect the 
position of graphical spacing tabs described on page 118. 
Normally, tabs should be used to change spacing parameters.

c. In the Copy Settings To area, select either “Next Systems” or 
“All Systems”. Next Systems will change subsequent systems 
and All Systems will change all systems in the score.

d. Push Copy to apply the change. Push OK to close the window.
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7.2.3 Horizontal Reformatting

7.2.3.a Adjusting system widths

System widths can be controlled in two ways: 1) adjusting individual 
systems by dragging either end point tab in the upper ruler margin or  
2) changing document layout and/or page margins in Page Setup. See 
also "Document Page Setup" on page 163.

FIGURE 7 - 9: Using tabs to change staff distances and system widths

• Nudge Mode (Barlines)

Several interesting and useful reformatting possibilities can be applied 
when barlines are repositioned in Nudge mode:

• Resizing adjacent measures by dragging barline horizontally 
See Section 8.2, "Nudge mode (Shift button)" on page 126.

• Shuttling measures in/out of systems by dragging last barline 
See See "Nudge Mode (Barlines)",  Section •, on page 120.

7.3 Score Structure
7.3.1 Structure and hierarchy

Score Structure (Edit > Score Structure) is a powerful tool that allows 
you to create entirely new scores by removing, creating and re-linking 
parts. By simply dragging links around, you have the ability to remove 
parts, extract parts and join individual part scores into multi-part “con-
ductor” scores. See “Scanning Part Scores (Score-Parts)” on page 40
for more info.
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7.3.2 Creating a Conductor’s Score from Part Scores

An ENF file was recognized from 3 part scores (each having one Part 
per Score-Part). A “Score-Part” consists of all the pages of a single 
instrument in a part score. Some Score-Parts may contain more than 
one Part (a piano Score-Part has 2 Parts and an organ Score-Part has 3 
Parts). Let’s view the structure of a part score and then combine all 
parts into one document.

To view score hierarchy & create a conductor’s score from score parts, 

a. Select Edit > Score Structure. 

FIGURE 7 - 10: Score Structure (Typical Part Score)

b. Click on any Score-Part to highlight it and push the Insert button 
at the bottom of the window. You will see a blank Score-Part 
appear.

FIGURE 7 - 11: Inserting new Score-Part

NOTE: Inserting a new ENF Document will work just as well. In 
either case, applying the change (Apply to New) will create a 
brand new ENF document, leaving the original file 
untouched.
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Naming new Score-Part in Properties

Re-linking Parts to new Score-Part

New Conductor’s Score (Apply to New)

To the left, a new, 
empty Score-Part 
was Inserted (you 
could also re-link 
parts to an existing 
Score-Part). Here, 
the new Score-Part is 
given a name (Win: 
Right-click / Mac: 
Option + click to 
open its Properties).

To relink any struc-
tural object, click on 
the object and drag it 
to another object in 
an adjacent column.

Here, the three exist-
ing parts are relinked 
to the newly created 
Score-Part (named 
Conductor’s). 

FIGURE 7 - 12: Creating a Conductor’s Score

Highlight the unlinked Score-Parts and push Remove. Push Apply to 
New. The modified structure is transformed to a new ENF document.

NOTE: Newly-created documents will have the same name of the 
source file plus “1”, “2” etc.

7.3.3 Creating Part Scores from Ensemble Scores

Extracting instrumental parts out of a conductor’s score in Score Struc-
ture is similar to creating a conductor’s score from score-parts, just 
reversed. NOTE: All SmartScore files (ENF documents) must contain 
at least one Score-Part linked to at least one Part.

a. Open an ENF file with 2 or more staves per system. 
b. Select Edit > Score Structure.
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Inserting New Score-Parts

Naming and re-inking 
Parts to New Score-Parts

Ensemble score having 4 parts

Here is a typical 
“ensemble” score (ENF 
Document) which will 
contain one Score Part 
with several Parts 
linked to it. 

Three new Score-Parts 
Insert. To name, Right-
click (option + click 
for Mac) in Properties. 
Drag each Part (child) 
to new Score Parts 
(parent) to reconfigure 
each open ENF docu-
ment. Push Apply to 
New to spawn off a 
new document with 
included data. This will 
create a file with 4 
Score-Parts arranged in 
order. Playback 
remains synchronized 
and the original ENF 
document remains 
unchanged.

FIGURE 7 - 13: Creating Score Parts from Ensemble scores
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Chapter 8 Detailed ENF Editing

8.1 More ENF navigating
8.1.1 Split-screen and Scan View reference views

The default view is the “split screen” view immediately following rec-
ognition. An alternative view is the floating “Scan view window”. 

Default Split Screen Floating Scan View window

FIGURE 8 - 1: Scan Reference Views

To use the “Zoom Window”,

a. Go to View menu, select “Zoom Window” and “TIFF” view. 
b. To increase or decrease zoom view of the window, choose a 

zoom magnification from View > Zoom Window selection. 
Available zoom levels are Normal (1x), 2x and 3x magnification.

8.1.2 Scrolling

Use the scroll bar and up/down arrows to the right of the ENF window. 
You may also use the arrow keys located on your computer keyboard to 
scroll up, down, left, and right in an ENF document.

8.1.3 Paging

To page forward or backward in an ENF document, 

• Use the “Next page” / “Previous page” buttons located in the 
Main Toolbar or push the double paging arrows at the lower 
right-hand corner of the SmartScore window.
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8.1.4 Go To…(Ctrl +G or Cmnd+G for Mac)

While editing, you can jump to any page or measure in ENF file. 

To open the GoTo… window 

a. Choose the View menu and select Go To... (Ctrl+G or Cmnd+G 
for Mac).

FIGURE 8 - 2: Go To window

b. Select whether it is a Part, Page or Measure you wish to jump to.
c. Enter the Part, Page or Measure number.
d. Checking the Open Target in New View box will open a new

ENF at the targeted Part, Page or Measure. Push OK to jump.

8.2 Nudge mode (Shift button)
By holding the Shift button down, the display switches to a special edit 
mode. Active control points are shown as orange boxes. 

8.2.1 Changing note pitches 
• Click and drag the control point (center of notehead) up or down.

8.2.2 Moving notes and rests horizontally
• Each note contains two horizontal “pull points”; one above the 

staff and one below. Click and drag either control point to nudge 
a note or rest horizontally.

• To move multiple symbols horizontally, use the “O” key to select 
the objects. Drag the “pull point” of any object left or right.

• To compress or expand symbols within a measure or within an 
entire staff line, refer to “Repositioning measures using barlines” 
on page 127.
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8.2.3 Resizing beam angles and note stems
• Dragging the endpoint of a beam or note stem will increase or 

decrease its length.

8.2.4 Repositioning text fields linked to an active staffline.
• All text fields are linked to an active staff line. To reveal the con-

trol point for each text field, position your cursor over its associ-
ated staffline and then locate the control point of the text field.

8.2.5 Reshaping arcs and slurs

Slurs (legatos) can be reshaped in two ways: 
By moving end points of the arc and by controlling the 
shape of the curve with either Bezier control handles.

End points con-
trol the place-
ment of the slur.

Bezier handles 
control the shape 
of the slur.

FIGURE 8 - 3: Reshaping slurs

8.2.6 Repositioning measures using barlines

To horizontally reposition all symbols in adjacent measures:

• In Nudge mode, moving barlines to the left or right will reposi-
tion symbols in measures adjacent to the barline. Symbols will 
become more spaced out or more contracted depending on the 
direction. This is helpful when a particular measure becomes 
crowded. Try it! Notice that relative note spacing (punctuation) is 
retained when measures are expanded or contracted. 

To horizontally reposition all symbols in a staff line:

• Moving the barline at the end of a system will compress symbols 
in the entire system and all relative note spacing will still be kept 
intact. If a barline at the end of a system is moved far enough to 
the left, the first measure of the following system will reposition 
itself to become the last measure of the active system. 

NOTE: For more details on horizontal formatting, see page 120.
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8.2.7 Special fixes possible with Nudge mode

8.2.7a Fixing beam angles

Beam angles are a function of the length of note stems within the beam. 
By dragging note stems up or down, the angle of the beam will change. 
Control points at the end of beams can also be dragged up or down to 
adjust overall beam angle.

If a beam collides with note stems or appears at odd angles after mov-
ing or deleting notes, click & drag the control point on either beam end. 
Drag beam end until it is properly positioned. Stems of notes alternate 
as the beam angle is changed.

Beam colliding with
note stems.

Drag beam control point
to alter stem orientation

Drag beam control point
to change beam angle

FIGURE 8 - 4: Controlling cross-staff beams 

8.2.7b Fixing offset notes and rests belonging to two voices

Notes and/or rests belonging to different voices (within the same verti-
cal event) will automatically offset when positioned next each other. 
This is meant to avoid collisions between the two. Depending on the 
situation, readjusting position offset objects is possible:

Offset corrected after dragging.vertical proximity. 
Offset rests due to close

FIGURE 8 - 5: Offset due to rests too closely positioned
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FIGURE 8 - 6: 

Flagged note in secondary voice After dragging note stem control
causes offset in primary voice. point downward, offset is corrected.

Offset due to note flag inteferring with nearby chord cluster

8.3 Tool Palettes (F2-F8 keys)
All notation symbols used in SmartScore can be selected from one of 
several Tool palettes. By default, up to 3 palettes remain open at one 
time. Palettes “recycle” by default, but you may have all open at once. 

To replace an open Tool Palette with another,

a. Right-click on any open Tool Palette. (Mac: Ctrl + click). 

FIGURE 8 - 7: Tool Palette Selection

b. Click on a desired palette.

To see all palette options,

a. Right-click (Ctrl + click for Mac) onto any open tool palette.
b. At the bottom of the Palette window, you may choose one of 4 

alternative modalities for palette behavior including.

• Recycle (Default):  
This changes the secondary open palette when a Quick Key is acti-
vated. The Notes palette remains open and does not cycle.Show All 
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opens all 9 SmartScore Tool Palettes.

• Hide All: 
This removes all Tool Palettes from view.

NOTE: The F1 key (Reset Workspace icon in SmartScore toolbar) 
always resets windows and palettes to their default positions.

For detailed functions of all tool palettes, see "Tool Palettes", 
Section 11.3, on page 215.

8.3.1 Dynamics Palette (P, < and >)
• Press the “P” key to select p (piano) dynamic marking.
• Hold down “Shift” + “,” to select the crescendo hairpin.
• Hold down “Shift” + “.” to select the decrescendo hairpin.

The “Dynamics” palette will open as the secondary palette.

8.3.2 Tuplets (T)

The “T” key opens the tuplet (Rhythmic Groups) Palette. Triplet is 
selected as the default. Drag the mouse to box in the notes/rests to 
become the selected tuplet. Drag downwards to insert the tuplet above 
the selected notes/rests. Drag upwards to insert the tuplet below 
selected notes/rests.

8.3.3 Grace Notes

While in Insert mode, select a rhythmic value and press the grace note
button in the “Notes” palette. Click before any note in the active staff to 
insert a grace note. ENF playback will insert the grace note and trun-
cate the duration of either the following or the previous note.

To control how grace notes play back (including saved MIDI files) 

• Select Edit > Program Preferences > Playback

Change default playback characteristics for grace notes:

• Before the beat
• After the beat (accaciatura)

All notation objects used in SmartScore can be selected from one of 
several Tool Palettes. 
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NOTE: For full description of all SmartScore tool palettes, turn to 
"Tool Palettes", Section 11.3, on page 215.

8.3.4 Dynamics, Articulations and Tempo Markings
NOTE: Dynamic, Articulation and Tempo markings affect ENF play-

back and change the resulting MIDI file. Playback properties 
of individual markings may be adjusted singly or globally 
with the use of the Properties Tool. See “ENF Symbol Prop-
erties” on page 92.

• Dynamic markings affect the volume of a range of notes in the 
active staff (MIDI track) to which they are entered. 

• Articulation markings, such as trills, staccatos, tenutos, arpeg-
gios, glissandos and mordents are note-specific. 

• Tempo changes are global and cannot be applied to one staffline. 

8.3.5 Tempo Markings (Metronome Mark)
NOTE: Inserting a tempo marking is generally used as a “change-of-

tempo” indicator. Default tempo is normally set by going to 
the Edit > Tempo menu or to the Playback Console See 
“Tempo” on page 57 for more details.

To insert a tempo marking or change-of-tempo (metronome) mark, 

a. Select a preset tempo marking in the “Tempo” palette or select a 
custom tempo by pushing the Metronome Mark button at the 
bottom of the palette.

b. If using a metronome mark, select a new tempo and baseline note 
value. Preset tempo markings ranges from 30 bpm (Lento) to 240 
bpm (Prestissimo).

FIGURE 8 - 8: Tempo Change (Metronome Mark) window
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c. In Insert mode, click anywhere above the topmost staff of a sys-
tem to insert mark. Tempo will adjust accordingly at that point.

To edit a metronome or change-of-tempo mark in the score,

a. Select the Properties tool from the SmartScore toolbar.
b. Click on a mark in the score to edit its properties. 

FIGURE 8 - 9: Tempo Marking Properties window

c. Using the horizontal slider, select a new tempo for the mark. 
Choose whether to apply the change to just the single mark, all 
similar marks or permanently apply the change for that mark. 

8.3.6 Dynamics, Hairpins, Crescendos and Decrescendos

To Insert a Dynamic marking,

a. While in the Insert mode, select a dynamic marking from the 
“Dynamics” palette. 

b. Click anywhere above the active staff. A change in playback vol-
ume (MIDI Volume) for that particular active staff (MIDI track) 
then will apply. 

c. Changes in note volumes range as follows: 
pppp = 35 / ppp = 45 / pp = 55 / p = 65 / mp = 75

mf = 85 / f = 95 / ff = 105 / fff = 115 / ffff = 125.

NOTE: Dynamics apply only to the active staffline. To apply dynam-
ics and/or dynamic markings to more than one staff, enter the 
dynamic in each part in which you want the effect to apply. If 
you do not wish to have multiple dynamics visible, you may 
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enter dynamics in the Hidden Symbols mode. For more 
details see “Hidden Symbols” on page 162.

To insert a hairpin, 

a. Toggle the “C” key to the Insert mode.
b. Select a dynamic hairpin from the “Dynamics” palette or hit 

Shift + “,” for crescendo hairpin and Shift + “.” for decrescendo. 
c. Click and drag to select notes for which a hairpin is to be applied.
d. Dragging downward will insert the hairpin above the active staff. 

Dragging upwards will insert the hairpin below the active staff.

FIGURE 8 - 10: Hairpin crescendo (drag upwards)

To insert a crescendo or decrescendo,

a. Select Cresc. or Decresc. from the “Dynamics” tool palette.
b. In Insert mode, click and drag the mouse to highlight the range of 

notes over which you wish to apply the dynamic change.

FIGURE 8 - 11: Inserting a crescendo marking

c. Dragging downward while selecting the range of notes will insert 
the marking above the staffline. Dragging upward will insert the 
marking below the staffline. 

d. The effective range of crescendos and decrescendos can be visu-
alized in Nudge mode (Shift) and in Hidden Symbols mode.

NOTE: Playback properties of articulations and dynamics may be 
changed using the Properties tool. See “Playback Properties” 
on page 59.
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To delete a dynamic or tempo marking, 

• Quick-select, press the “X” key and click on the marking. An 
alternative is to use the Select tool (“O” key), highlight the mark 
and hit Delete.

8.3.7 Articulations and Trills

Articulations affect the playback of selected notes. These include slurs, 
turns, fermatas, mordents, trills, accents and tremolos. For a complete 
description of each articulation’s playback function, turn to "Articula-
tions palette", Section 11.3.2, on page 216.

To insert a legato (slur),

a. Push the Legato button in the “Articulations” palette.
b. Drag to select range of notes to be associated with the legato. 

Dragging downward places the legato above notes. Dragging 
upward positions legato under the notes. 

To insert expression marks,

• Many common expression marks can be inserted as text with the 
use of Expression tool. Available phrases can be found in 
English, Italian, French, German with English translation.

FIGURE 8 - 12: Expression Tool

a. Select the Expression button.
b. Choose a language and an expression from the pull down menu 

or type your own expression in the text field. Press OK.
c. Position the cursor anywhere in the active staff.

NOTE: Expressions are simple text and have no affect on playback.

To insert turns, fermatas, accents and mordents,
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Turns, fermatas, accents and mordents can be inserted above or below 
notes by clicking near the top of a notehead or near the tip of note stem.

a. Select the articulation.
b. Click on a note head to insert the articulation above the note 

head.
c. Click on a note stem to insert the articulation at the tip of the 

stem.

To delete a turn, fermata, accent or mordent,

• Quick-select the articulation. Or use “O” key to select. Press the 
“X” key and click on the notehead or stem of the associated note. 

To insert a staccato, tenuto or accent,

a. Select the articulation.
b. Click on a note head to insert the articulation above the note 

head. Click the stem tip to insert the articulation near the stem.
NOTE: Playback properties of Staccatos, Tenutos, Accents and Fer-

matas can be changed individually or globally by selecting 
the Properties tool and clicking on the associated note head.

To insert a trill,

• With tr (trill) selected, click on a note to insert a single trill. 

To create an “extended” trill, 

• Trills have a control handle to the right of the “r”. In Nudge 
mode, dragging the control handle to the right will extend the 
trill’s effect to all notes in the same staff below the extension.

FIGURE 8 - 13: Extended Trill

NOTE: Playback properties of trills can be changed individually or 
globally. Select the Properties tool and click on a trill.

To insert a tremolo,
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a. Select a tremolo from the Tremelo button of the “Articulations” 
palette. Available tremelos are single, double, triple or quadruple 
(Both single or beamed tremelos).

FIGURE 8 - 14: Tremelos (Articulations Palette)

b. Click on the head of the note to apply the tremolo value.
c. Adjacent half notes will join to become beam tremelos when the 

first half note is clicked with beam tremelo selected.
NOTE: Beam tremelos will playback only if the applied “half-beam” 

notes are positioned in measures as if they were quarter notes.

To change existing half notes to beamed tremelos,

• With a beam tremelo value selected, click on the first of two adja-
cent half notes. The notes will beam with tremelo mark inside.

To insert an arpeggio,

a. Select the Arpeggio button (squiggly line) from the palette.
b. Click and drag the mouse to select a chord cluster (can include 

more than one voice).
c. Dragging the mouse in an upward direction will cause the notes 

to arpeggiate in an upward scale.
d. Dragging the mouse in the downward direction will cause the 

notes to arpeggiate in a downward scale. A down arrow is added.

To insert a glissando,

a. Select the Glissando button (two notes connected with a line) 
from the palette.

b. Clicking on any single (non-chord cluster) note will insert a glis-
sando to the following note belonging to the same voice. During 
play back, the glissando will be heard.

To delete any articulation associated with a note,

• Quick-select the articulation. Press the “X” key, and click on the 
note associated with the articulation.
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NOTE: To delete any articulation that is not note-specific, use the 
Select tool (“O” key) to highlight it and hit the Delete key.

8.3.7a Inserting or Deleting Multiple Articulations 
Any articulation can be applied to multiple notes at one time.

To assign an articulation to many notes at once,

a. Use the Select tool (“O” key) then drag to select a range of notes.
b. Select the articulation to be applied to all highlighted notes and 

insert it to any note.

To delete all articulation marks and slurs in a selected area,

a. Use the Select tool (“O” key) to drag a box around the area from 
which you wish to remove articulations.

b. Once the area is selected, hit the “G” key to delete all articula-
tions in the selected region.

8.3.7b Note values (Number Pad)

To quickly select note duration values, 

• Use the keyboard Quick Keys number: 1 = whole note, 2 = half 
note, 3 = quarter note, etc.

TIP: See Quick Keys map on page 171 for a graphic of shortcut 
keys.

8.3.8 Signatures (Key and Time)

To change an existing key or time signature to another signature, 

Entering or changing any time signature automatically updates time 
signatures in all parts of all systems; up to the first change-of-time sig-
nature if one exists. Entering or changing key signatures must be done 
one staff at a time. 

NOTE: Once Key or Time signatures are fixed in one system, subse-
quent systems can be “cloned” by using the Unify command. 
For details see “Unify Score (“U”)” on page 144.

a. Quick-select (Ctrl+click) a desired key or time signature nearby 
or select a new signature from the tool palette.
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b. Click on a highlighted signature to be changed. 
NOTE: The key of C major (A minor) does not have a visible sign to 

indicate its presence. If no key signature is visible in the first 
measure of the ENF display, the key signature will be C 
major (A minor) by default. 

To create a custom time signature to Insert or Change,

a. Select the Custom Time button from the “Signatures” palette
b. Using numeric scrollers, select a new numerator (beats per mea-

sure) and a new denominator (note value receiving the beat).
c. Click to insert signature immediately following any barline.

To insert a new key or time signature in the body of a score, 

• With a time or key signature selected from the “Signatures” pal-
ette, Insert mode, click to the right of any barline.

NOTE: The score will be parsed from the insertion point. Error mea-
sures likely disappear after correcting the new time signature.

To insert a new key or time signature at the end of a system:

According to the conventions of music notation, a change-of-key or a 
change-of-time signature that begins on a new line should be indicated 
at the end of the previous line. 

FIGURE 8 - 15: Time Signature at the end of a system

• Simply insert a new key or time signature at the beginning of the 
following system. The last measure of the appropriate staff in 
prior system will automatically update.

To delete a signature

• Quick-Select a key or time signature. Hit the “X” key and click 
on the signature to delete it.
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8.4 System Options
System Options is useful for accessing important functions that control 
system behavior.

To activate System Options, 

• With the Properties tool active, Right-click (Alt + click for Mac) 
inside any visible system.

FIGURE 8 - 16: System Options

8.4.1 Line/Staff Spacing

Use to adjust line and staff spacing numerically (as opposed to drag-
ging spacing tabs in left-hand margin). Changes can be applied to the 
active, subsequent or all system. Refer to Section 7.2.2 on page 119.

8.4.2 Bracketing

See “Bracketing” on page 112 for information on system bracketing.

8.4.3 System Manager

See “System Manager” on page 155 for more information.

8.4.4 Part Linking

To reconnect parts of optimized systems. See Section "Re-linking 
parts", Section 4.15, on page 78.

8.4.5 Add Empty Pages

Inserts an empty page with similar structure and bracketing of the 
active system. A window opens to allow you to change numbers of sys-
tems and measures per system.
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8.4.6 System > Insert Above / Insert Below / Remove

Use to delete or insert a new system above or below the active system.

8.4.7 Staff > Insert Above / Insert Below / Remove

Use to delete or insert a new staffline above or below the active staff.

8.4.8 Ossia

Use this tool to delete or insert an ossia above or below the active staff. 
Inserted ossias are editable just as any normal staffline except that 
ossias are not played back. 

FIGURE 8 - 17: Ossia

To resize an ossia,

a. Hold the Shift key down (Nudge mode) and drag either of the 
control points at either end of the ossia. Barline, key and time sig-
nature information is inherited from its associated staffline. 

b. Re-space ossias using tabs in the left margin just as any staffline.

8.4.9 Go to..

Use this tool to jump to a new page.

8.5 Quick Keys
TIP: Refer to the Quick Keys maps on page 171 for a graphic depic-

tion of all SmartScore keyboard shortcut keys.

8.5.1 Quick-select (Ctrl + Click)

The fastest way to choose any object for inserting and changing is to 
Quick-select it. Ctrl + Click on any object inside the active staff and 
the cursor inherits all of that object’s attributes.The cursor becomes any 
object that is Quick-Selected.
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8.5.2 Inserting and changing notes and symbols (C)

To insert a note or rest anywhere in the active staffline, 

a. Toggle the “C” key to activate the Insert mode.
b. Select any note or rest from the “Notes” or “Rests” palette.
c. Click anywhere in the active staff to drop the object. 

To insert a multi-measure rest, 

• Select the “n-measures” object from the “Rests” palette. 
• Select the number of empty measures.
• Click in an empty measure of the active staffline. 

To change the rhythmic value of an existing note or rest,

a. Quick-select (Ctrl+click) a nearby note or rest having the desired 
value. Or select a new value from the “Notes” or “Rests” palette.

b. Position the cursor over the symbol to be changed until it high-
lights yellow. Click to change it to the selected value.

NOTE: When you Quick-select on any object inside the active staff, 
the palette associated with the object will open.

8.5.3 Deleting notes and symbols (X)

To delete an object in the active staff,

a. Quick-select (Ctrl + Click) a note or symbol
b. Press the “X” key and click on the note or symbol to be deleted.

To delete one or more object using the Select tool,

a. Press the Select tool icon in the toolbar.
b. Click on an object or drag a region to select one or more objects.
c. Hit the Delete key to delete object(s).

8.5.4 Select tool (“O”)

Use the Select tool to highlight one or more objects for single or mass 
editing functions such as delete, split voices, flip stem directions, join 
notes of different voices to a vertical event, and copy/paste. The “O” 
key activates this tool. Its button is found in the SmartScore toolbar.
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TIP: Use the Select tool + Delete key to remove any object other 
than lyrics and barlines. It is especially useful for removing a 
large number of spurious or unwanted text or multiple objects 
that do not delete easily with the “X” key. 

To delete one or more objects including notes, rests and symbols,

a. Push the Select tool icon in the toolbar (“O key) and click on an 
object or drag to select multiple objects to delete. 

b. Hit the Delete key. 

Occasionally, you might find an area full of incorrectly recognized ties 
and/or slurs or hairpins. Use this tool to “mass-delete” these objects.

To delete an entire system,

a. With the Properties tool active, right click anywhere in a system.
b. In the Systems option window, select System > Remove.

8.5.5 Using the Select Tool (O) to edit selected objects

A group of selected notes on the same staff can be transformed into one 
beamed group if they are flagged or they can be pitch-shifted at once.

To convert a sequence of flagged notes into one beamed group,

a. Use the Select tool (O) to select a group of adjacent flagged notes 
to be beamed together.

b. Hit the “B” key to form the flagged notes into a beamed group.

To move a selected group of notes upwards or downwards in pitch,

a. Use the Select tool (O) to select an entire region for cleanup. Edit 
> Select All (Ctrl + A) will select everything on the current page.

b. Hit the “G” key. Only articulations will be deleted. All other 
notation objects remain unaffected.

8.5.6 Dots (D)

Hit the “D” key. This toggles between Insert a dot and Delete a dot 
modes. Notice how the cursor alternates between a solid insert dot and 
grayed-out delete dot.
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Any note or rest may be selected with dots of prolongation assigned to 
it. Select a note or rest from the appropriate palette, then click on the 
single or double-dot button inside the palette. In Insert mode, the new 
note/rest will have a dot. 

8.5.7 Ties (V)

Hit the “V” key. This toggles you between the solid Insert tie and 
grayed-out Delete tie modes. To tie two contiguous notes of the same 
pitch, click on the first note. The “V” tie tool will also insert multiple 
ties from one chord cluster to the next as long as note pitches match. 

NOTE: To over-ride default arc direction, insert ties with a right-click 
(option + click for Mac). Inserted ties will have reversed arc 
directions.

To insert only one tie at a time, select the single tie button from the 
“Notes” palette.

8.5.8 Beam direction (A)

With any single flagged note chosen, hit the “A” key. This toggles 
between Left beam, Middle beam and Right beam directions.

8.5.9 Stem direction (S)

The “S” key changes the default note stem direction. When inserting a 
note, toggling the “S” key reverses the stem direction of an inserted 
note. 

Default stem direction of an inserted note is determined by its vertical 
position on the staff. Stem direction of inserted notes automatically 
changes when the cursor crosses the middle line of any staff. 

To place a note with a stem in the opposite direction of the cursor, 

• Hit the “S” key to flip the stem on the cursor. Or right-click while 
inserting a note (option + click for Mac).

To change the stem direction of an existing note,

• In Insert mode, right-click on any given notehead (option + click
for Mac). The stem direction of the note will become flipped.
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NOTE: In general, Voice #1 should have stems up and Voice #2 
should have stems down.

To change the stem direction of several notes at once,

a. Hit the “O” key to activate the Select tool.
b. Click and drag a box around any series of notes.
c. Press the “S” key to reverse the stem direction of the highlighted 

notes.

8.6 Navigator
8.6.1 Open (Ctrl+O / (Cmnd+M Mac)

Push to open any SmartScore-compatible file. Select SmartScore 
(ENF), Image (TIFF, BMP, PCX), or MIDI file from “Files of Type” 
pull-down menu. Same as File > Open.

8.6.2 Scan

Push to initiate scanning. Same as File > Scan Music > Acquire.

8.6.3 Recognition

Push to initiate recognition on any pre-scanned image. Same as File > 
Recognize.

8.6.4 Unify Score (“U”)

Unify updates key and time signatures as well as clef signs throughout 
the score based on choices made in the dialog window.

FIGURE 8 - 18: Unify Key, Time and Clefs
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TIP: Check part linking before applying Unify (Optimized scores)

If your ENF score contains collapsing and expanding systems, it is rec-
ommended to perform Part Linking before Unifying. Unifying signa-
tures and clefs will maintain part linkages as set in Logical Part 
Linking. Refer to “Re-linking parts” on page 78 for more details.

8.6.5 Unify Key Signatures
• Based on topmost staffline. (Default)

All key signatures for every part are updated based on signatures found 
in the first staffline of each system. Any change-of-key signs found in 
the topmost staffline will update subsequent stafflines within each sys-
tem. Use when systems have the same key signature in each part.

• Based on 1st system.

All key signatures in every system are updated based on signatures 
found in the first system on the first page. Any subsequent changes in 
key signatures will be removed. Use to unify scores that have trans-
posed instruments with a fixed number of parts per system. 

NOTE: Manually edit key signatures when scores contain: 
a) Transposed instruments AND change-of-key signatures 
b) Transposed instruments AND have optimized systems.

8.6.5a Unify Time Signatures

All time signatures are updated based on signatures found in the first 
system on the first page. Change-of-time signatures are removed in any 
subsequent systems. Use when no change-of-time signatures occur.

8.6.5b Unify Clefs

All clef signs are updated based on clefs found in the first measure of 
the each system. Any change-of-clef found inside systems are 
removed. Use if many false change-of-clefs were recognized or if very 
few change-of-clef signs are found in the original.

8.6.6 Parse every measure (Default)

Clefs are updated on a line-by-line basis. Change-of-clefs encountered 
updates each staffline until another change-of-clef is encountered. Use 
when many change of clefs are written into the original score.
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8.6.7 Setup

Opens Page Setup environment for page printing alignment & margins. 
For more details on Page Setup, see page 163, "Document Page Setup".

8.6.8 Print Preview

Use to check for proper page layouts. Also seen in Page Setup view.

8.6.9 Score

Push to create ENF score from scratch. Choose ENF score template 
from “System Type in Score” pull-down menu. Same as File > New > 
New ENF. See “Creating a New ENF Score from Scratch” on page 97
for details.

8.6.10 Record 

Push Record button to initiate MIDI Recording. All open ENF docu-
ments are closed when MIDI recording is launched. A MIDI Piano Roll 
view opens with Track 1 staged for MIDI recording through an external 
MIDI device. Identical to Real-time > Record in MIDI View.

8.6.11 Karaoke View

Push to enter Karaoke playback environment. 

8.6.12 MIDI View (Ctrl + I / Cmnd + I for Mac)

Push MIDI button to view score in MIDI environment. Use also to 
change from one MIDI view to another; e.g. to change from Overview 
to Piano Roll view. Choose Overview or Piano Roll or Event List for a 
selected Part. Same as View > New MIDI View. ENF view remains 
open until or unless recording is initiated. To revert back to ENF view, 
close the open MIDI view. 

8.6.13 Tiling 

Viewing several displays of your score can be extremely useful. It is 
possible to view several MIDI and ENF views simultaneously.
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• Push Tile button to display all open TIF/ENF views along with 
any open MIDI Overview, Piano Roll or Event List views. This 
is identical to selecting the Window > Tile menu.

FIGURE 8 - 19: Tiled view (typical)

8.7 Score Reformatting
SmartScore allows for flexible reformatting of the finished ENF score. 
Changes to both horizontal and vertical formats can be easily made. For 
detailed information, turn to Section 7.2, "Reformatting scores in ENF 
view" on page 117.

8.7.1 Auto-Beaming

With Auto-Beam selected, beamed notes will automatically form into 
common groups based on the active time signature and standard nota-
tion beaming rules. Auto-Beam defaults to “off” after recognition. 
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To automatically insert and edit beams into preformed groups. 

• Push Auto-Beam button in the Toolbar
• Select a note value from the Notes palette.
• With any beam tool selected, clicking from left-to-right, will cre-

ate beamed groups into pre-determined sets. 

8.7.2 Auto-Spacing

With the Auto-Space button selected, notes and rests will insert pro-
portional to their relative value within a measure. After recognition, 
Auto-Space defaults to “off.” 

8.8 Transposition 
SmartScore offers several types of transposition options depending on 
your needs. You can transpose by key, the most common type of trans-
position. Transposing by clef is useful for transforming one instrument 
to another written in another clef sign. You can also choose to transpose 
by altering note pitches only, either considering the active key signature 
or by ignoring the active key signature. Using the Limit option, you 
can choose a specified range, part or voice to transpose.

To Transpose your entire ENF document to a new key, 

a. Position your cursor inside the first staffline of the score. Press 
Ctrl + T / Cmnd + T for Mac or select the Transpose button in 
the SmartScore Toolbar or select Transpose from the Edit menu. 
The window in Transposition always displays the key signature 
or clef sign of the active staff. This is your source key. 

FIGURE 8 - 20: Transposition window
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b. Select a new target key or target clef for the score by selecting 
either the Key or Clef tab. Scroll up or down to select a target 
key signature or target clef.

c. Closest allows SmartScore to automatically choose up or down 
based on the least number of intervals. To choose the direction 
manually, select either Up or Down.

NOTE: It is recommended that you fully edit your score before trans-
posing. If your score contains incorrect change-of-key signa-
tures and/or guitar fret and chord symbols, it may be hard to 
Undo properly. Also, the scanned score won’t transpose and 
visual checking of pitches will be difficult after transposition.

8.8.1 Transposition Strategy

You can choose two “strategies” for transposing your scores: Link 
Accidentals to Key and Keep Line-space. 

• Link Accidentals to Key

This choice will consider the target key signature during transposition. 
If the target key belongs to the opposite class than that of the source 
key (e.g. transposing from a key with sharps to a target key with flats), 
then accidentals may be swapped to their harmonic equivalents. 

• Keep Line-Space

This choice will retain exact relationships between intervals after trans-
position is completed. Accidentals will generally remain fixed. No 
attempt will be made to swap harmonic equivalents of accidentals. For 
example, c and d# may transpose up to c# and d double-#.

• Transpose Symbols

To transpose guitar fret and chord symbols to match the new target key, 
check this box. This selection will also move articulations, such as 
slurs, up or down along with notes and rests. If necessary, guitar fret 
and chord symbols may move up to avoid collisions with upwardly-
transposed notes.
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• Ask For New Chord Symbol

This option allows you to accept or change each transposed guitar fret 
and chord symbol during transposition. Use this option when you know 
you won’t accept default fretboard patterns or when you know you will 
need to add new fret and chord symbols to the library.

• Adjust Stems

Stem directions will be maintained unless this box is checked. It is 
important to remember, however, that adjusting the direction of stems 
may create voicing problems. Automatic voiceline recognition relies 
heavily on stem directions. Flipping stems as they cross the mid-staff 
point can create unexpected results. Best Bet: Adjust Stems = Off. Use 
Undo (Ctrl + Z / Cmnd + Z for Mac) if necessary.

• Move Notes

Uncheck this box to leave the notes in their original positions. This will 
transpose only key signatures, leaving notes unchanged... good for 
mental games, but not much more.

• Change Pitch

This transposes notes without changing the key signature. Select the 
number of half-steps to move selected notes (harmonic pitch shift). 
Pitches are moved by a uniform interval while considering the key sig-
nature. Change Pitch can be used in conjunction with Limits tab.

TIP: To shift the pitch of a small range of notes, it is easier to use the 
Select tool (O). Hold the Shift key down, drag the selected 
notes up or down.

8.8.2 Limit Transposition

You may limit transposition to a part or voice or to a selected range 
within the ENF score.
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To limit transposition by part, voice or range,

a. Click on the Limit tab at the top of the Transposition window.

FIGURE 8 - 21: Limit Transposition

b. Choose All Parts, or select individual parts by name to trans-
pose. If you select a single part, you may also limit the scope of 
transposition to a single voiceline. In the Part Voice box, select 
the voice to transpose.

c. To limit transposition by range, choose Selected Area (range 
must already be highlighted by the Select tool) or by Measure
number.

d. Click OK to transpose with selected limits applied.

8.9 Working with Contrapuntal Voices
Each staff line has the potential of containing up to four contrapuntal 
voices. Contrapuntal voices are “measure-based”. This means that 
notes and rests are organized into “threads” (voicelines). See “Voices 
and Playback” on page 67 for more about how voices affect playback.

To view contrapuntal voices as separate colors, 

• Push the Voice Visibility button in the SmartScore toolbar. 

8.9.1 Voice color

Contrapuntal voices display as one of four possible colors (Voice 1= 
black, Voice 2 = red, Voice 3 = green and Voice 4 = blue). Normally, 
you will see black (Voice 1) and red (Voice 2). 
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8.9.2 Overriding voice color assignments

Voice color/number assignments can be changed manually.

To override default voice color of a note or rest (change voice number),

a. Select desired voice number (and color) from Voice Tool combo 
button in the SmartScore Toolbar.

b. Locate the note or rest for which you want to change voice color. 
c. Click on a note or rest to change it to the selected color and voice. 

Voice color is automatically determined based on several factors (num-
ber of voices, stem direction, number of beats, vertical alignment, etc.) 
You can override voice colors manually. Changing voice color may 
change voice colors of other notes in a given measure.

NOTE: Do not override voice colors until a measure is entirely 
edited. Unusual color combinations usually correct them-
selves automatically after a measure is corrected.

To vertically align offset voices, 

a. Use the Select tool (“O”) to highlight offset notes and/or rests.
b. Press the “Y” key to group the selected, offset notes into a single 

vertical event. Selected voices will move slightly.

Offset voices not “glued” 
following Recognition 

“Y” key “glues” offset
voices to a single event.Using Select tool to 

highlight offset voices

FIGURE 4 - 22: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes bunched together each displaying different 
colors (usually black and red and sometimes green), but which actually 
belong to only one voice, they are probably “glued” to the same vertical 
event. Joined notes can be “unglued” as follows:
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To “Unglue” offset notes not intended to play simultaneously,

a. With the Select tool (“O” key), carefully select the incorrectly 
glued notes (NOTE: they will each have different colors). Be sure 
to select only the notes which are incorrectly joined.

b. Hit the “Y” key. Joined notes will separate and change color.

8.9.3 Checking vertical alignment of voices

Measures with notes and rests that are incorrectly aligned will become 
highlighted reddish (“error”). In addition, all notes and rests that are 
glued will move together when dragged left or right in Nudge mode. 

• Hold the Shift button. Click and drag note control point to verify.

FIGURE 4 - 23: Using Nudge mode (SHIFT) to check vertical alignments

8.9.4 Swap position of note heads (Select + “L”)

Occasionally, you will want to swap the horizontal positions of a pair 
of joined offset notes. This can easily be done by selecting a vertically 
aligned pair with the Select Tool (“O”) and hitting the “L” key. The rel-
ative positions of these joined notes will be swapped without altering 
voice color or playback..

Note heads
before swap

Note heads
after swap

FIGURE 8 - 24: Note head swapping

8.9.5 Cross-staff voicing

Occasionally, notes of one voice may “visit” an adjacent staff. Techni-
cally, visiting notes belong to their “home” staff, but they obtain their 
pitch information from the visiting staff line.
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To create cross-staff voicing, 

• Make sure the note to be moved across staff lines has its stem in 
the correct orientation (Select + “S” to change stem direction). 
Hold the Shift key down and drag the notehead to the desired 
pitch of an adjacent staff. If cross-staff notes belong to a beamed 
group and the beam does not interfere with the movement of the 
notehead, simply hold the Shift button down and drag the note-
head into the adjacent staff to its desired pitch. 

FIGURE 8 - 25: Cross-staff voicing 

• Notes positioned in a “visiting” staff still belong to the “home” 
staff. To edit or move a note positioned in an adjacent “visiting” 
staff, press the Caps Lock key while the “home” staff is active. 
Press Caps Lock again to unlock the active home staff.

NOTE: Cross-staff indicator lines can be either solid or dotted. These 
attributes can be changed in Edit > Program Preferences > 
Systems > Cross-staff voicing line style.

To control cross-staff beams (beam collisions and flipped stems)

• If a beam collides with note stems or appears at odd angles after 
moving notes, hold Shift down (Nudge) then click & drag the 
control point on either beam end. Drag beam end until it is prop-
erly positioned. Stems of notes alternate as the beam angle is 
changed.

Beam colliding with
note stems.

Drag beam control point
to alter stem orientation

Drag beam control point
to change beam angle

FIGURE 8 - 26: Controlling cross-staff beams 
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8.9.6 Cross-measure beaming

To create a cross-measure beam,

a. Insert a flagged note on either side of a barline.
b. Use the Select tool to highlight both notes and hit the “B” key.

8.9.7 Overlapping or offset noteheads

Two notes in different voices can share the same pitch at the same time. 
You can choose whether note heads of different voices should overlap 
one another or become horizontally offset. 

To allow offset note heads, 

• Check off “Overlap Notes” in Edit > Document Preferences > 
Score Symbols > Overlap mode. Playback will not be affected 
whether note heads are offset or overlap.

8.10 System Manager
Use the System Manager to assign or change instrumental parts, change 
part names and extract parts and voices by controlling visibility. The 
System Manager displays information about what is found in the active 
system (the highlighted system). Changes made can be applied to the 
current system, current plus subsequent systems, to the entire score or 
limited to the current Score-Part. 

FIGURE 8 - 27: System Manager

To open the System Manager, 

a. Position the cursor over a given system in the ENF view. 
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b. Press (Ctrl+M / Cmnd+M) or select Edit > System Manager
from menu. All parameters of the active system will be displayed 
including part name, visibility and assigned MIDI instruments.

Parts of the system run vertically along the far left column. Check-
marks identify whether parts are “visible” in the active system. Voices 
run horizontally with checkmarks below which identify the status of 
their visibility. 

8.10.1 Part Names

When a Part Name is selected in the System Manager, playback 
parameters are inherited from Instrument Templates, including pitch 
shifting of transposed instrument. See “Instrument Templates” on 
page 160 for additional information. 

To select a Part Name,

a. Click into a desired instrument name in the Part Name column. 
Select one of preset instruments Notice that MIDI instruments for 
each voice become updated. 

b. If you wish to add a new part name with a unique MIDI instru-
ment assignment, select “Add New Part” from the top of the 
pull-down list. This will open Instrument Templates and allow 
you to create a new template, name it and assign any MIDI 
instrument and alter transposition pitch shifting. 

8.10.2 Assigning MIDI Instruments to Voices

Voices inherit MIDI instrument assignments from Instrument Tem-
plates initially. You can change MIDI instrument assignment for voices 
(in Voice mode) or parts (Part mode) in the System Manager or Play-
back Console.

TIP: Assigning each voice a different MIDI instrument adds richer 
sound texture and helps in hearing “inner voicings” of the 
music. Highly recommended for classes in composition.

NOTE: Playback Console and System Manager are linked. Changes 
made to MIDI instruments in one environment will update 
the other. MIDI instrument assignments in Instrument Tem-
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plates are not changed automatically. They can only be 
changed manually.

To change MIDI instruments for voices in System Manager, 

• In System Manager, click on any voice of any part and select a 
new MIDI instrument in the pull-down menu. 

8.10.3 Extracting Parts

Visibility checkboxes along the far left side of the System Manager
are used to extract parts. Parts can be extracted to new files without 
altering the original document. Checkmarks identify which parts are 
assigned (visible) in the active system. Individual parts and/or voices 
can also be “removed” from a score by selective use of Visibility. 

To extract a part from the score, 

a. Check Visibility boxes next to the parts you want to extract. 
Unchecked parts will be made invisible, but data will be retained.

b. Check Visibility in the Apply field and choose a scope from the 
“Apply To” pull-down menu. See “Applying changes to the 
score” on page 159 for details on “Apply To” options.

c. Push Apply to remove all unchecked parts from the current 
(open) document. 

d. More commonly used is to select Apply to New. This will extract 
all checked parts to a new ENF document while keeping the orig-
inal document unchanged. Both documents will display.

8.10.4 Extracting Voices

To extract a voice from the score, 

a. Highlight a visible part by clicking on the dot next to Part Name. 
b. Check or uncheck the Visibility box below the desired voice 

number depending on which voice(s) you want to extract. 
c. Select Visibility in the Apply field and choose a scope from the 

Apply To pull-down menu.
d. Apply alters the current document. Apply to New will creates a 

new ENF document.
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TIP: Part and voice extraction/removal can also be controlled in an 
entirely different way by using the Score Structure feature. 
See “Score Structure” on page 120 for more details on how to 
isolate, recombine and/or remove parts and voices from a score.

8.10.5 Super System

Sometimes in symphonic music, the total number of instruments 
exceed even the largest system in the score. For example, a system of 
20 parts containing the second string part may be followed by a system 
of 20 parts where the second string part is replaced by a violin solo line. 
This would make a total 21 instrumental parts. Since SmartScore only 
knows the total number of parts found in the largest system (in this case 
20), another instrumental part needs to be added so parts can be cor-
rectly linked and playback will sound properly.

The “official” list of all existing parts in an ENF score is stored in a 
special area called the Super System and is found in System Manager. 
Once the total number instrumental parts are established in the Super 
System, any part of any system can be reassigned to its appropriate 
instrument using the Re-link tool (see Section 4.15 on page 78). 

While it’s possible to add a new part to the Super System with the Add 
Staff Above/Below option found in the System Options tool (see Sec-
tion 8.4.7 on page 140), real control is found in the Super System itself.

To add a new part to the score,

e. Open System Manager with Ctrl + M (File > System Manager).
f. In the Controlling System pull-down menu, choose Super.

FIGURE 8 - 28: Creating a new part using Super System in System Manager
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g. Highlight where you wish to add a part above or below to by 
clicking on the black dot to the left of the existing part. Apply to: 
All should be selected to apply change globally to all systems.

h. Choose Insert Above or Insert Below. Then press Apply.
i. Switch Controlling System back to Active. Notice the newly 

added part is added, but is not checked for visibility. Added parts 
become visible in ENF only after Visibility is applied. See See 
“Part Visibility” on page 160 for details.

To re-link optimized parts for proper playback,

• To reassociate parts of a system, use Re-link (Ctrl + L). Don’t use 
Visibility to relink. See “Re-linking parts” on page 78 for details. 

To remove a part from a score (not recommended for part extraction).

a. Click the dot corresponding to the part you wish to remove.
b. Select a correct scope to Apply to: and push Remove.

8.10.6 Applying changes to the score

Changes you make to System Manager will apply to the area of interest 
you select in the “Apply To” pull-down menu:

• All
Applies the change to all systems of the score. Used when you want a 
change to be globally applied.

• System
Applies only to the currently active system.

• System+
Applies to the currently active system and all subsequent systems.

• Score/Part
Applies to the Score or Score-Part.

• Super System (Do not use except in extraordinary cases)
Changes will be applied only to the Super System..

• OK 
Applies changes to the current ENF document.
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• Apply 
Applies changes and allows further editing in System Manager.

• Apply to New
Creates and opens a new ENF document with changes applied to it. 
This action does not affect the original document which remains open 
behind the newly-created ENF document (Minimize window of top-
most document to view other open ENF files.) 

TIP: Apply to New is useful when you want to extract parts or 
voices to a new ENF document without affecting the original.

8.10.7 Part Visibility

Do not use Visibility to try and relink parts. Use the Relink tool. see 
"Re-linking parts", Section 4.15, on page 78. After re-linking, any 
“false parts” (due to possible errors in system recognition) can be 
removed in the Super System. See See “Super System” on page 158 for 
details.

To make added parts visible in one or more systems, 

a. To make an added part visible, make sure Controlling System is 
Active. Insert Visibility check mark next to Part Name and in the 
Apply region below the parts matrix. 

b. When the Apply To option = All, the part will be visible in all 
systems. When System is selected, part is visible only in active 
system. Visibility in subsequent systems = System +. Push OK.

8.11 Instrument Templates 
Characteristics of parts are inherited from Instrument Templates 
including name, abbreviation, MIDI instrument, playback pitch trans-
position. 
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To change or add a new instrument template,

a. Hit (Ctrl+F/Cmnd+F) or Edit > Instrument Templates.

FIGURE 8 - 29: Instrument Templates

b. Click in the Name field of any template and type to change the 
given name of an instrument.

c. To change an abbreviation, click then type inside the Abbr field.
d. Click and select a different MIDI instrument from the Instru-

ment list to change default MIDI instrument assignment.
e. Transpose displays the default playback transposition for 

selected instruments. The MIDI representation will reflect the 
transposed shift in pitch.

f. Various sets of MIDI instruments can be selected in Instrument 
Settings pull-down menu. Instrument sets acquire their names by 
clicking on the Instrument Settings button and selecting a set.

g. To save settings for future ENF files, check “Save for Future”.

8.11.1 Transposed Instruments

Because ensemble instruments have such wide pitch ranges, it is neces-
sary for transcribers to notate certain instruments in key signatures that 
are remote from others in the ensemble. Players of transposed instru-
ments “read” and “transpose” naturally without worrying that the part 
they are reading is actually out of tune! In order for an ENF score with 
transposed instruments to play back correctly, transposition of play-
back by specified amounts must be set. This is accomplished for preset 
instruments in the Instrument Templates but it is also possible to 
compensate for transposed instruments in the Playback Console.
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8.12 Hidden Symbols
Hidden symbols displays every possible object in the ENF display. 
Certain markings such as the range of a 8va, 8vb, ritard, accelerando
or descelerando are only visible when Hidden Symbols is active. You 
may want certain notation objects to be applied to playback, but at the 
same time, you may not want these symbols to be visible. For example, 
you may need to insert rests to “fill out” a given voiceline in a measure, 
but you do not want these “placeholder” rests to be printed. 

To insert a hidden notation object,

• Push the Hide/Show Symbol button in the Text and Controllers 
toolbar. Insert any notation object normally. Symbols entered in 
Hidden Symbols will appear as a lighter color than when entered 
normally. 

In the following example, the measure in question has only 1 beat writ-
ten into the upper part and 2 beats written in the lower part. Inserting 2 
hidden rests in the upper and one hidden rest in the lower corrects error.

Recognized measure 
(w/ cross-staff voice)

Corrected measure 
(w/ rests placed in Hidden mode)

To view ranges of dynamics and tempos,

a. Push the Hide/Show Symbol button. Dynamics or tempos which 
were applied to a range of notes will appear as follows:

FIGURE 8 - 30: Hidden range of an accelerando

Push again to exit Hidden Symbols mode. “Hidden” symbols do not 
appear in normal mode and will not print.
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8.12.1 Overriding voice color assignments in Hidden Symbols

You may find that it is necessary to change the assigned voice color 
(and number) of a hidden symbol after it is entered. If so, simply use 
the Voice Color tool found in the SmartScore toolbar. This is done 
exactly as in normal ENF editing mode. Notes and rests with changed 
voice assignments will remain invisible after you exit Hidden Symbols. 

To override voice numbers in Hidden Symbols,

a. Select a voice color and number from the Voice Color tool.
b. Click on any note or rest to change its voice number and color.

NOTE: In Hidden Symbols mode, voice colors display differently 
than in normal edit mode:  
Voice #1 = Grey, Voice #2 = Purple, Voice #3 = Yellow, 
Voice #4 = Aqua

To change the default color of Hidden Symbols, 

a. Select Edit > Program Preferences > Color >Hidden Symbols. 
b. Choose a new color and push OK.

8.13 Document Page Setup
Your finished score will probably be printed so you’ll want to control 
how it will look beforehand. 

To select or modify a document layout scheme while previewing pages,

• Push Page Setup button in the Navigator (Edit > Page Setup)

If your score was created out of recognition, the Document Layout
pull-down menu will show “From Recognition”. Each page frame rep-
resents the exact area cropped when each page was scanned. Choose 
Center on Page or one of several preset layouts as described below. 

8.13.1 Page Centering

a. Make sure your Page Type is correctly set to your paper size.
USING SmartScore 163



Detailed ENF Editing
b. In Document Layout pull down menu, select Center on Page. 

FIGURE 5 - 31: Document Page Setup (Center on Page)

c. Push Apply. Score pages in the background update with changes.
d. Each page can be fine-tuned by dragging either of the frame tabs 

in the left margin up or down. Use the bottom scroller to view 
and reposition each page up or down if necessary. Once you are 
satisfied with the layout of your document, push OK.

8.13.2 Selecting and creating custom document layouts

Custom document layouts (other than Center to Page) will change 
page margins and alter system widths to accommodate the page size 
and positioning you select. Since system reformatting is probable, you 
may see systems move from page to page. We recommend that you 
correct (edit) the full score first while the scan view is synchronized. 
See “Split-screen and Scan View reference views” on page 125 for 
details.

To select an alternative document format, select the document layout 
you want from the Page Layout pull-down menu as described below:

NOTE: The following are default settings. Defaults may be changed. 
See “To modify default margins or to create a new document 
layout:” on page 166.
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• Page Layout: Loose Leaf  
Single-sided pages with music centered in the middle of the page

Page Alignment: Centered 
Page Margins: 1/2 inch Top, Bottom, Left, Right

• Page Layout: Loose Leaf with Header Page  
Single-sided, centered pages with first page having a 2” header:

Front Page: Centered 
Page Alignment: Centered 
Page Margins: 3 inches Top (1st page). 1/2 inch Top, Bottom, 
Left, Right (remaining pages).

• Page Layout: Facing 
Left / Right pages with increased inside margins for binding

Left Page: Left 
Right Page: Right 
Page Margins: 1/2 inch Top, Bottom, Left, Right

• Page Layout: Facing with Header Page 
Left / Right pages with first page having a 2” header

Front Page: Left 
Left Page: Left 
Right Page: Right 
Page Margins: 3 inches Top (1st page). 1/2 inch Top, Bottom, 
Left, Right (remaining pages).
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To modify default margins or to create a new document layout:

a. Click to highlight the page layout you want to change in the 
Available Layout list to the right of the Page Setup window and 
push the Edit button.

FIGURE 5 - 32: Document Layout Defaults

b. Reset the numerical scrollers on Left, Right, Top and Bottom or 
simply click and drag the margin guides inside the preview win-
dow. You may also change page orientation and page type from 
the pull-down menus on the right. Push OK to reset the layout.

FIGURE 5 - 33: Default Page Margin Control

To change page layout of single pages, parts or entire scores,

a. Select File > Page Setup.
b. To set page size to correspond to a particular page format, choose 

the desired format from the “Type of Page” pull-down menu.
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c. Click and drag with your mouse or use the numeric scrollers to 
change existing margins as required. 

d. To reorient page, select Landscape or Portrait in “Orientation”.
e. To change the indent of the first system on the first page, select 

0”, 1”, 2” or 3” from the First System Indent pull-down menu.
f. In the Scope pull-down menu, select the range of pages you wish 

to apply the change to: 
The entire Score, Score-Part or only to the current Page.

g. Push OK to apply the changes.
NOTE: In the English version, Page Type size is “Letter”. In Euro-

pean versions, “A4” is the default page type. The default for 
Page Type can be reset in Edit > Program Preferences.

8.13.3 Default Page Size and Type

In the English version, the default page size and type is Letter / Por-
trait. In European versions, A4 / Portrait is the default page type. The 
default for Page Type can be reset in Edit > Program Preferences.

To permanently change your default Page Type and size,

a. Go to Edit > Program Preferences > Page Type
b. Select “Letter”, “Legal” or “A4” for your default page type / size.

8.13.4 Default Document Layouts

8.14 MIDI to ENF
SmartScore accepts any Standard MIDI file and converts it to an ENF 
file. Since printing is disabled, SmartScore MIDI Edition does not 
include MIDI to ENF.

To create an ENF document from a MIDI file,

a. Select File > Open and change the filetype pull-down menu from 
SmartScore Files to MIDI Files. All MIDI files in the given 
directory will appear in the selection window. Double-click on a 
selected MIDI file to open.
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b. The Playback Console window will appear with a MIDI Over-
view representation in the background. To hear the file playback, 
push the Play button in the console.

c. To convert the MIDI file into SmartScore notation, push the 
Close button in the Playback Console. Closing the console will 
begin the conversion process. 

FIGURE 8 - 34: MIDI to ENF window

Staff Voicing

Choose the number of contrapuntal voices you wish to see in the con-
verted ENF file. 

NOTE: It is unusual to have more than 2 voices in most music. 

Density

• Measures per System determines the number of evenly spaced 
measures per system. Automatic is recommended.

• Systems per Page determines the number of evenly spaced sys-
tems per page. Automatic is recommended.

Quantization

SmartScore can quantize the MIDI file that will be converted. Each 
note event will “snap to” the nearest beat boundary eliminating fluctua-
tions in the timing of a MIDI performance. 

MIDI files created with “free tempo” (rubato) will probably have many 
irregular note divisions and odd-looking timing as SmartScore attempts 
to “compartmentalize” notes “off-the-beat”.
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• Check None to prevent the application of quantization.
• Use Note On/ Note Off to determine the smallest rhythmic val-

ues used to when spelling note start times (Note On) and end 
times (Note Off) in the ENF document.

• Use Note On/ Note Duration to determine the smallest rhythmic 
values used to when spelling note start times (Note On) and the 
minimum length of each note (Note Duration) in the ENF docu-
ment.

• Shorten each note to the last Note Duration value.
• Lengthen each note to the next Note Duration value
• Justify each note to the nearest Note Duration value.

If the resulting ENF file has many stand-alone flagged notes, try reduc-
ing the Quantization value (e.g. to 1/8th notes).

• Divide By Beats: When ON, resulting ENF file will interpret 
measure lengths by number of beats and insert change-of-time 
signatures if beats of each measure do not correspond to the 
default time signature. Turn OFF to lock default time signature.

• Smooth Voices: When ON, contrapuntal voices will be inter-
preted as continuous lines whenever practical. When OFF, con-
trapuntal voice will be interpreted loosely.

8.15 Troubleshooting ENF Problems

Table 3: Troubleshooting ENF Problems

Problem Probable Cause Fix

Notes and symbols 
appear as large letters.

Font association lost. Reinstall Chopin10 font. 
Font is located in the 
SmartScore directory.

Measures outlined in a 
red color.

Incorrect rhythm in one 
or more voices.

Edit voicelines to agree 
with time signature.

Pickup or closeout mea-
sure highlights red & 
doesn’t play smoothly.

Voiceline durations do 
not agree with the current 
time signature

With Properties tool 
selected, click on barline 
that begins the measure. 
Select “As written”.
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Only one system high-
lights black at a time.

View active staffline is 
ON (default selection).

Check off View Active 
Staffline in View menu.

Measure remains high-
lighted but measure plays 
back smoothly.

Secondary voice may be 
truncated (not fully com-
pleted in the measure).

This is a common con-
vention in music nota-
tion. May be left as is.

Can’t delete an object 
when “X” key is pushed.

Actual object must be 
selected first.

“Ctrl + click” the object 
before deleting. Or, sim-
ply use the Select tool 
(“O” key) & drag around 
an object then hit Delete.

New note is inserted 
when trying to change an 
existing note.

Existing note was not 
highlighted yellow when 
clicked.

Yellow-highlighted notes 
will be changed to new 
value. Blue inserts new 
note at same time slice.

Measures unexpectedly 
roll from one system to 
another. 

Barlines at the end or 
beginning of measures 
may have been deleted.

Restore the number of 
measures per system by 
clicking of Staff Proper-
ties with Properties tool.

Systems unexpectedly 
roll from one page to 
another.

Line, staff or system 
spacing may have been 
changed.

Readjust spacing tabs in 
left margin until systems 
are restored to page.

Staffline missing from 
system

Staffline cut off or during 
scanning or was not 
localized during Recog-
nition.

Restore missing staff. See 
“Adding a staff when 
missed by recognition” 
on page 81

Wrong part suddenly 
plays.

Expanding / collapsing 
score; Part / instrument 
linking lost.

Reassign parts in system. 
See “Re-linking parts” on 
page 78

Display shows notes as 
brightly colored or with 
green vertical lines or 
with a solid orange hori-
zontal line along the staff 
line.

ENF display is in Hidden 
Objects, Tempo or 
Velocity controller 
mode.

Exit Hidden mode. See 

Table 3: Troubleshooting ENF Problems

Problem Probable Cause Fix
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Quick Keys Map (Windows)

FIGURE 8 - 35: Quick Keys Map (Windows)
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Chapter 9 MIDI Editing and 
Sequencing

Underlying MIDI data of an ENF score can be viewed and manipulated 
in one of three MIDI views: Overview, Piano Roll and Event List.

9.1 MIDI Views
9.1.1 Selecting MIDI views

To open MIDI environment from ENF and select a MIDI view, 

a. Press the MIDI button in the Navigator or choose View > New 
MIDI View (Ctrl +I / Cmnd+I (Mac)). 

The New MIDI View Window will open.

FIGURE 8 - 1: New MIDI View

b. In the Type window, select the type of MIDI view desired, Over-
view, Piano Roll or Event List).

• Overview

This view displays all MIDI tracks (parts) found in the open Score-Part.

• Piano Roll

This view displays all MIDI note events found in the selected track.

• Event List

This view lists all MIDI events and every detail associated with them.

The above MIDI view buttons are accessible from the MIDI toolbar.
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9.1.2 MIDI Toolbar

The MIDI toolbar (View > Toolbars > MIDI Toolbar) includes but-
tons for opening Overview, Piano Roll, Event List views. Also visible 
are the Shuttle, Record, Record to New Track and Virtual Drum tools.

FIGURE 9 - 2: MIDI Toolbar

9.1.3 Closing MIDI Views

Each MIDI view (Overview, Piano Roll and Event List) has its own 
“close” icon in the upper left-hand corner of the window. Click to close 
an active MIDI view window. Or select File > Close. Closing the last 
MIDI view will return display to its associated ENF view.

9.2 Track Overview
Overview provides a “bird’s eye view” of all existing MIDI tracks. 
Some editing functions are limited

FIGURE 9 - 3: Track Overview window

9.2.1 Selecting tracks and MIDI events

Right-clicking (option + click Mac) into a track’s Name field in Over-
view will display the track properties. Double-clicking into a track’s 
Name field will open its Piano Roll view..

FIGURE 9 - 4: MIDI Track Properties
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The Track Properties window allows for editing of the Track Name and 
its Transposition. It is also used to create new MIDI tracks. Push Piano 
Roll or Event List buttons to view selected track in one of these views. 

NOTE: The Transpose selection window will actually move all the 
note events of the selected track by half steps.

• New Track will create an empty new track.
• Selecting Duplicate Track will create an exact copy of the active 

track and insert it at the bottom of the track listing.
• Delete Track will erase the highlighted MIDI track completely.

9.3 Playback
9.3.1 Spacebar

• Press the spacebar to Play. Press again to Pause. Press again to 
resume Play. Press the comma key (“,”) to Rewind to the start.

9.3.2 Mini-Console

The Mini-Console is a dockable (tear-off) toolbar that plays, records, 
rewinds and stops playback. 

FIGURE 9 - 5: Mini-Console Transport

The “spring-loaded” tempo slider will increase or decrease tempo 
speed depending on the distance it is pulled from the center. Releasing 
the mouse will return playback tempo to the default speed.

• Play button initiates/resumes playback of the active MIDI file. 
Once playback has begun, the Play button becomes Pause. Use 
this button to retain MIDI data after returning to ENF display.

• Stop button stops playback/recording of the MIDI. Play/Record is 
re-initialized at 0 (rewinds to the beginning).

• Rewind button resets playback to the beginning of the range.
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• The Record button will be active only when a MIDI Out deveice 
is selected. Pushing the Record button will create a new MIDI 
track and will launch a new recording session. When Record is 
lit, press Play button to begin recording a new MIDI performance 
to a new track. When recording to a new MIDI track, existing 
MIDI data, instruments, channels and transpositions of the origi-
nal ENF or imported MIDI file will be maintained.

NOTE: All playback functions are also available in the Realtime 
menu (in MIDI) or Playback menu (in ENF).

TIP: To select an entire track for cutting and pasting, go to Overview 
and click (option + click for Mac) in the track’s Name field.

9.3.3 MIDI Devices

To set the MIDI input and output devices,

a. Select MIDI Devices from the Options menu. The MIDI 
Devices window will open.

FIGURE 9 - 6: Options > MIDI Devices

b. Click on the MIDI Input device / interface you will use for 
recording new MIDI data. 

c. Click on the MIDI Output device you wish to use for MIDI 
playback. The MIDI device window will display all installed 
MIDI device drivers. MIDI Mapper is the default in Windows 
and is most commonly used for sound cards although a specific 
soundcard driver may be selected from the Output list.
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d. Press OK to set the selected MIDI devices as the current Smart-
Score MIDI sources. The selected device then moves to the top of 
the list.

NOTE: If the desired device is not listed in the MIDI Devices window 
make sure the device driver has been properly installed. 
Check any software that was installed with your MIDI device 
and/or download MIDI driver from manufacturer’s website. 
When installing a new MIDI driver, reboot to initialize the 
new driver.

9.3.4 Playback Range

To specify part of the score for playback, 

a. Select Set Play Range from the Realtime menu. 

FIGURE 9 - 7: Set MIDI Play Range

b. Set the first measure and last measure of the Play Range.
c. Mark Play All to play the entire score.
d. Check Loop to continually repeat the assigned playback range.

9.4 Piano Roll
In the familiar MIDI piano roll view, it is possible to alter MIDI note 
events and fine tune other playback parameters. MIDI events are only 
editable when “Show Actual Playback” option in the View menu is 
checked off. When “Show Actual Playback” is checked, articulations 
(trills, tremelos, etc.) display but cannot be edited since articulations 
are controlled by Properties. The Piano Roll view is track-based. 

9.4.1 Selecting MIDI tracks
• To move from track to track, click the Track Paging buttons 

located in the Main Toolbar.
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To select and display a track in Piano Roll view:

a. Select the MIDI button in the Navigator. In the New MIDI View 
window, select a track or Part Name. Pushing OK will open the 
selected track in piano roll format.

FIGURE 9 - 8: Overview - Selecting a track

b. Select the MIDI track you wish to display and press OK.
c. Select the magnifying glass from the Main Toolbar. Right click 

to zoom in and left click out (option + click for Mac) of the 
Piano Roll view. Click to zoom in. Right-clickto zoom out.

FIGURE 9 - 9: MIDI Piano Roll View
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d. Another method of zooming in or out is to drag measure markers 
horizontally. Dragging to the right zooms in and dragging to the 
left zooms in.

FIGURE 9 - 10: Horizontal zoom by dragging measure markers

9.4.2 Tiling ENF and MIDI views

Using the Tile Windows feature, you can view both ENF and MIDI 
windows simultaneously. This is useful if timing problems are encoun-
tered while editing ENF notation. By switching to MIDI Piano Roll 
view and pushing the Tile Windows button, it is possible to examine 
underlying MIDI events while referring to the same region as notation 
in the associated ENF window.

To tile all open document windows,

• Push the Tile Windows button located both in the Main Toolbar 
and in the Navigator palette.

Tile Windows
Menu Button

FIGURE 9 - 11: ENF / MIDI Tile View (with floating Zoom window)
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9.4.3 Velocity and Tempo Graphical Controllers

In Piano Roll view, the bottom pane of the window displays a graphi-
cal, continuous-change MIDI controller. Click into Controller Selector 
pull-down menu and select a new MIDI controller you wish to view.

FIGURE 9 - 12: Velocity and Tempo controllers in Piano Roll view

• With the pencil mouse pointer, click and drag a curve over the 
range you wish to apply the effect.

9.4.4 Shuttle Tool

The Shuttle Tool allows you to sound MIDI events forward or back-
ward by dragging the mouse over a range of events.

To operate the Shuttle Tool,

In Piano Roll view, the “S” key toggles the Shuttle Tool off and on. To 
manually select, press the Toggle Shuttle button in the MIDI Toolbar 
or go to the Options menu and select Shuttle On. Click and hold any-
where in an Overview or Piano Roll and drag the Shuttle Tool to the 
right to play the MIDI file at your own tempo. Drag the Shuttle Tool to 
the left to rewind and hear the MIDI file simultaneously. 

To insert or change the voice assignment of selected note event(s):

a. Use the Voice Selection pull-down menu located above the piano 
keyboard to select a voice number.

b. Right-click and drag to create a note event.
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9.4.5 Inserting program changes (Assign MIDI instrument)

To insert a Program Change (MIDI patch change) for any given voice:

a. In an active track, position cursor and click wherever you wish to 
make an instrument change. Select Edit > Program Change. 

FIGURE 9 - 13: MIDI Program Change (Piano Roll)

b. Select a new Instrument from the pull-down menu. In Voice 
Color mode, select a voice number from the Voice pull-down 
menu. This will apply the new instrument sound to the selected 
voice (voices will automatically be assigned different MIDI 
channels). For more about Voice Color Mode, turn to “Working 
with Contrapuntal Voices” on page 151.

c. Press OK.
NOTE: List of instruments is determined by the selected Instrument 

set selected in Options > Instrument Settings. Instrument 
set is also able to be selected in the Playback Console (see 
page 53).

d. An inverted red triangle will indicate the point where the pro-
gram change was inserted. Clicking on any Program Change tri-
angle will open the Program Change window for additional 
changes.

NOTE: SmartScore supports multiple MIDI channels within each 
MIDI track. This allows for contrapuntal voices within ENF 
stafflines to be assigned to different instruments within each 
MIDI track. In other words, multiple voices in ENF are 
equivalent to multiple channels within a MIDI track. This is a 
sort of hybrid MIDI type (MIDI Type 1/Type 0 hybrid).
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9.4.6 MIDI Instrument settings

To change MIDI instrument parameters,

a. Select Instrument Settings under the Options menu. In Play-
back Console, push the Set Instrument button. This will open 
the Instrument Settings window.

FIGURE 9 - 14: Instrument Settings

b. Select the MIDI Port of the MIDI instrument you will be adjust-
ing with the MIDI Port pull-down menu.

c. Choose a specific Instrument Bank or all Banks from the selected 
MIDI Port if numerical banks are supported by your MIDI 
device.

d. Select the type of MIDI Instrument (GM, MT32, GS, Yamaha 
XG, Numeric or Custom) from the Instrument pull-down menu.

e. Use the radio buttons to activate or deactivate specific MIDI 
channels for selected Instrument set and Drum set. The default 
MIDI channel for drums is 10.

f. Use the Drum pull-down menu to select the type of MIDI Drum 
set your device supports (GM, No Drums, Roland GS Drums, 
Yamaha XG Drums, Numeric or Custom).

g. Push Custom to create a formatted text document for displaying 
custom instrument names for your MIDI device. Edit to change.

h. Save will save Custom patch names as a formatted text docu-
ment (.TXT). Save this file then open it in a word processing 
application and enter your patch names. Then save as a text docu-
ment.
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i. Load will allow you to load the Custom text file. Your custom 
patch names will display throughout SmartScore’s MIDI patch 
selection windows (Instrument Templates and Playback Con-
sole).

9.4.7 MIDI event selection

Under the Edit menu choosing Select opens the Select Window. 

FIGURE 9 - 15: Select Event window

Select All tracks or an individual track or voice to highlight for cut, 
paste, pitch shifting or assigning parameters. Choose Full time to dis-
play the full length of the MIDI file or designate a portion of the file to 
display by entering the measure, beat, and tick into the From and To 
fields.

NOTE: Edit > Select All is only available from a Piano Roll or Event 
List view.

Selecting MIDI events using mouse click-and-drag can be done from 
any view. Mouse functions work the same in all views.

To select a note or group of notes:

• Click on the individual note or click and drag to Group Select 
many notes.

To add note(s) to the Group:

• Hold down the Control key and click on the unselected note(s).
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To select note events within a given time frame: 

a. Click in Piano Roll to mark the beginning of the time frame.
b. Hold down the Shift key and click again to set the end of the time 

frame. The selected range will highlight in grey.

9.4.8 Changing MIDI event characteristics

To change the start time of selected note event(s):

• Click and drag the left edge of the note(s) to the position you 
want. 

FIGURE 9 - 16: Editing MIDI note on/off events

To change the duration of selected note event(s):

• Click and drag the right edge of a note to change a note’s dura-
tion.

To change the velocity (loudness/note attack) of selected note event(s):

• Drag the top and bottom edges of a note adjust the note’s veloc-
ity.

Changing note velocity Changing note pitch

FIGURE 9 - 17: Editing MIDI note velocities and pitches

To change the pitch or position of selected note event(s):

• Click and drag the center of the note to change pitch (vertical 
drag) or note placement (horizontal drag).

NOTE: The arrow keys on your computer keyboard can also be used 
to adjust the pitch and start time of the selected note. 
184  USING SmartScore



MIDI Editing and Sequencing
NOTE: To realign MIDI events to the nearest starting point (quantiza-
tion), go to Options > Snap to and select the base rhythmic 
value.

To delete selected note event(s):

• Hit the Delete key to remove any highlighted notes.

To change the velocity and/or the duration of selected note(s):

a. Select the Velocity/Duration option from the Edit menu. The 
Velocity and Duration window will open.

FIGURE 9 - 18: Velocity and Duration window

b. Use the sliders or type in numbers to increase or decrease the 
velocity or duration of the selected note(s) by a percentage. 
Example: You wish to double the duration of a group of selected 
notes. In the Velocity/Duration window move the Duration slider 
to 200%. 

c. Press OK.
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9.4.9 Note Event window

Double-clicking on any note event will open the Note Event window.

FIGURE 9 - 19: Note Event window

The Note Event window allows access to and adjustment of an individ-
ual note’s parameters.

• Raise or lower the Pitch of the Note Event
• Start Time changes when the Note Event begins
• The Duration of the Note Event can be shortened or lengthened 
• Increase or decrease the Velocity of the Note Event
• Select a different Voice for the Note Event

9.4.10 Cut/Copy and Paste

Click and drag the mouse or use Edit > Select to select a region that 
you would like to cut, copy or paste. 

• Cut removes the highlighted notes from the score and places 
them in the clipboard.

• Copy stores the selected notes to the clipboard without removing 
them from the score.

• Paste will insert the contents of the clipboard back into the score 
without deleting the existing notes. Click where you want to 
insert the music into the score. 
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• Paste Special will open the Paste Special window.

FIGURE 9 - 20: Paste Special

The Paste Special window offers several options for pasting the con-
tents of the clipboard back into the music.

• Add to existing events will add the contents of the clipboard to 
the selected area without erasing the existing notes.

• Replace existing events will replace the existing music with the 
contents of the clipboard.

• Move to make room will push the existing music backward and 
then insert the contents of the clipboard.

• Use Repetitions to determine the number of times the contents of 
the clipboard will be inserted.

• Start from time designates where the inserted music will begin 
by choosing the measure, beat, and tick.

• Select Start from track to paste to a selected track number. 
• All to track will insert the contents of the clipboard, no matter 

how many tracks were originally selected, into one track.

9.4.11 Measure Settings

The Measure Settings window allows for inserting changes of tempo, 
time signature and key signature at the start of any given measure.
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To open the Measure Settings window in Overview or Piano Roll view:

• Double-click on the measure number where you wish to insert a 
change in key, time, or tempo.

FIGURE 9 - 21: Measure Settings

To insert a change of Tempo:

• Adjust tempo with the Tempo slider.

To insert a change of Time Signature:

• Use the Time Sign pull-down menus to select the number of 
beats per measure and the base measure unit (2=Half note, 
4=Quarter note, 8=Eighth note, etc.)

To insert a change of Key Signature:

• Select the number of accidentals in the new Key Signature with 
the pull-down menu. Mark the key as major or minor with the 
radio buttons next to the pull-down menu.

Press OK to make the changes current through the end of the active 
MIDI file.
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9.4.12 Setting Repeats and Multiple Endings

While you are more likely to insert repeats and multiple endings in 
ENF view, they can also be edited in the Measure Settings window in 
Overview or Piano Roll view. Double click any measure number to 
open the Measure Settings window of that measure.

• Simple Repeats

 Check the 1st Measure of Repeat box to select a measure as the begin-
ning of the repeated section.

Use the # of Passes scroller to determine the total number of times this 
section will be played. For example: If you want the section to play 
through and repeat one time, set the # of Passes to 2 (the default).

 Check the Last Measure of Repeat box to set a measure as the final 
measure of the repeated section. During playback, once the preset num-
ber of passes has been met, playback of the remainder of the score will 
continue after this measure has finished.

 The 1st Measure of Ending box designates a measure as the beginning 
of an ending.

The Number of Passes scroller is used to number this ending, i.e, 1 = 
1st Ending, 2 = 2nd Ending. Hold down the Ctrl key to select a number 
to designate the number multiple passes this ending should have.

 Use the Last Measure of Ending check box to define the total length 
of the ending. After this measure is played, MIDI playback will jump to 
the 1st Measure of Repeat and continue on with the next pass. 

NOTE: This measure is also the Last Measure of Repeat. Check the 
Last Measure of Repeat box to continue playback with the 1st 
Measure of Repeat.

9.4.13 Segnos

A Segno is a musical notation symbol used to denote the beginning or 
the end of a repeated section.

• Starting from a Segno

Checking the Segno box will place a Segno in a measure.
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Activate the Jump check box and select d.s. or Dal Segno (from 
Segno). After this measure is played, MIDI playback will jump to the 
Segno measure and continue playback. 

• Ending at a Segno

Check the Jump box and select d.c. or Da Capo (from the beginning) 
and al segno (to the Segno). 

Checking the Segno box will place a Segno in a measure. Playback will 
stop with this measure.

• Fine

Fine means final or end. It denotes the last measure of a score when 
repeats are used. 

• d.c. al fine

Check the Jump to box and select d.c. or Da Capo (from the begin-
ning) and al fine (to the end). After this measure is played, MIDI play-
back will jump to the beginning of the score and continue playback to 
the end.

Use the Fine check box to insert a fine into a measure. MIDI playback 
will stop at the end of this measure.

• d.s. al fine

A Fine can be inserted after a Segno when the Segno is used to mark 
the beginning of the repeated section.

Checking the Segno box will place a Segno in a measure.

Activate the Jump check box and select d.s. or Dal Segno (from 
Segno) and al fine (to the end). After this measure is played, MIDI 
playback will jump to the Segno measure.

Check the Fine box to insert a fine in a measure. MIDI playback will 
play through the score, return to the Segno measure, and stop after the 
Fine measure is played.

• Jump 

Jump can be used to “send” MIDI playback to a certain measure. 
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Select to Measure in order to jump to a chosen measure during play-
back.

On Pass will send MIDI playback to the selected measure on the desig-
nated pass only.

NOTE: Check On Pass if the d.s., d.c, or the Jump measure falls 
within a repeated section and define on which pass playback 
will jump.

9.5 Event List
To view and edit detailed MIDI events, meta events, note events, con-
trollers, program changes, key and time signatures, etc. in a selected 
track, 

a. Press the MIDI button of the Navigator or in the menu, select  
View > New MIDI View or Window > Event List. 

b. Choose Event List from the Type pull-down menu
c. Select a track to view and press OK. 

The Event List displays every MIDI event of the selected track:

FIGURE 9 - 22: Event List

• Select what event types are displayed in the Event List by check-
ing or un-checking the Event Type boxes along the top of the 
Event List. 

• To scroll the Event List display during playback, check the 
“Scroll when playing” box in the Event List window.

• To page from track to track, click on Track Paging buttons in the 
Main Toolbar.
USING SmartScore 191



MIDI Editing and Sequencing
9.5.1 Changing parameters of selected notes

To change parameters of a group of selected notes:

• Click in any of the columns to change the parameters of an exist-
ing MIDI event or double click in the Type column of a Note 
Event to open the Note On window.

FIGURE 9 - 23: Note On window

The Note On window, like the Note Event window, allows for adjust-
ment of an individual note’s parameters: Channel, Time, Duration, 
Pitch, and Velocity.

9.5.2 Inserting note events

To insert new events in the Event List view, 

a. Click the Event you want the Note to follow. Select New from 
the upper left-hand corner of the Event List. The Create New 
Event window will open.

b. Scroll to Note On in the Event Type menu.
c. Press OK.
d. A Note On event will be inserted into the Event List. 
e. Enter the Voice, Time, Duration, and Pitch of the new event by 

clicking in the corresponding columns or double-click in the 
Type column to open the Note On window.
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9.5.3 Editing Key, Time and Tempo

Click in any column to make changes to any existing MIDI events. To 
insert a new tempo, key, or time signature click the event you want the 
new event to follow. Press the New button. The Create New Event win-
dow will open. 

FIGURE 9 - 24: Create New Event window

Use the scroll bar to select Meta Event. A Meta Event is a MIDI file 
instruction. Scroll through the Event Subtype window to choose 
Tempo, Time Signature, or Key Signature. Press OK. Use the Other 
column to select the new tempo, time signature, or key signature OR 
double-click in the Type column to open an event-specific window. 
You may type in a new value.

9.5.4 Inserting Non-Note Events

Any MIDI event that is not a note-on or note-off event is a non-note 
event. This includes MIDI Control Changes, Program Changes, Chan-
nel Pressure, Pitch Bend information, and Meta Events. 

To insert a non-note event in the Event List view:

a. Select the event you want the non-note event to follow.
b. Press the New button. 

The New Event window will open. 
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c. Use the Event Type menu to select the event to be added. 
NOTE: Some events, such as Control Change and Meta Event, have 

Subtype event listings. Choose one if applicable.
d. Press OK.

• Program Changes 

Program Change inserts a MIDI event that changes the instrument 
playback for a given channel / voice. 

To insert a Program Change of the voice/channel in Create New Event:

a. Program Change is the default New Event, so simply press OK.

The selected Program Change will be inserted into the Event List. 

b. Use the Voice pull-down menu to designate the voice to which 
the Program Change applies.

c. Use the Other pull-down menu to select a new instrument.

• Control Changes 

Control Changes send adjustable parameters to your selected MIDI 
device i.e., vibrato, hold, volume, pan, effects, etc. You can add spe-
cific changes to these controls from within SmartScore’s Event List. To 
find out more about what each control change will do, refer to the 
user’s manual of your MIDI device.

• Meta Events 

Meta Events are MIDI file instructions written to the MIDI file. They 
provide information such as file and track headers, SMPTE code, 
tempo, key and time signatures, etc. and can be added to any MIDI file 
using SmartScore’s Event List

9.6 Playback Console
The Playback Console is available in Overview and Piano Roll views 
and allows for detailed viewing and control of playback and provides 
real-time editing of the active MIDI file. Push MIDI in the Navigator 
and select Piano Roll or Overview. 
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Push the Playback Console button in the SmartScore Toolbar or 
choose Real-time > Playback Console (Ctrl +9 Win / Cmnd+9 Mac) 
to open the Playback Console.

NOTE: The console can act as a “window shade”. To shrink verti-
cally, drag the bottom edge of the console up or down.

9.6.1 Adjusting Playback Console Settings

General;

• Adjust global playback volume using the General Volume
slider.

• Adjust channel volumes using individual Volume sliders.
• Use Pan to adjust stereo balance for each channel.
• Default resets all MIDI tracks to their original settings.
• The Close button will close the Playback Console.
• Mute any voice while all others continue to play or Solo a single 

voice for playback.
• Change the MIDI Instrument or Channel of any voice.

To play back at a given point in the file; 

• Use the Measure / Beat slider and scroll to the desired measure 
and beat in the score.

To select the MIDI output device; 

• Use the Port pull-down selector.

To transpose playback globally; 

• Use the General Transposition pull-down selector. 

To transpose an individual track / voice;

• Use the Transposition pull-down selector in any track / voice.

9.7 Display Controls
9.7.1 Time

To choose whether the timing of MIDI note events is displayed by Mea-
sure: Beat: Tick or by Tick Number;
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• Go to the Options menu and select Time Format.
• Choose by Measure: Beat: Tick or by Tick Number.

9.7.2 Velocity

To choose whether the velocity of MIDI note events is displayed with 
absolute numbers (0-127) or as percentages;

• Go to Velocity Format under the Options menu.
• Choose by Value (0-127) or Percent.

9.8 MIDI Recording
9.8.1 Recording Options

To activate the Record mode and adjust the recording options choose 
Record from the Realtime menu.

• Synchro Start 

Recording is synchronized to start with the first MIDI note played. To 
“unsynchronize” the start of recording with the first played MIDI event 
uncheck Synchro Start from the Realtime menu OR choose the Met-
ronome Settings listed under the Options menu and uncheck Synchro 
On.

• Thru

Sends new MIDI events to the selected MIDI output device. The active 
Piano Roll determines the parameters of the MIDI Thru sound. If no 
Piano Roll is open, MIDI Channel 1 is used.

9.8.2 Metronome

The Metronome is on by default. The metronome is useful in keeping 
time while recording and as a “count-in” tool to mark the beginning of 
the recording session.

Sometimes, you may want to record “freely”... that is, you simply want 
to capture a performance in MIDI without worrying about timing or 
about trying to convert the performance into notation. For this purpose, 
you will want to turn the metronome off. To make the metronome inac-
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tive during recording, uncheck Metronome from the Realtime menu 
OR choose the Metronome Settings listed under the Options menu 
and uncheck Metronome On.

To make changes to SmartScore’s metronome;

• Choose Metronome Settings from the Options menu. The Met-
ronome Settings window will open.

FIGURE 9 - 25: Metronome Settings

NOTE: The Metronome On check box must be selected for the met-
ronome to sound during recording. To record without a met-
ronome uncheck the Metronome On box.

With Synchro On, SmartScore will synchronize the start of recording 
with the first played MIDI event.

Select which MIDI Port the metronome will play through.

Choose the metronome’s MIDI Channel. 

NOTE: The de facto drum channel, MIDI Channel 10, is the default 
channel. But you can change it if you wish.

Determine the number of Lead-in Measures that will play prior to the 
start of recording. The metronome will click at each baseline beat 
(derived from the time signature) for as many measures as you choose.

The Primary Beat (down beat) will sound when its On check box is 
selected. The Pitch pull-down menu displays all General MIDI drum 
sounds. Use the Volume scroll box to increase or decrease the volume 
of the Primary Beat. The default accents the Primary Beat. 
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The Secondary Beat will sound when it On check box is selected. The 
Pitch pull-down menu displays all General MIDI drum sounds. Use the 
Volume scroll box to increase or decrease the volume of the Secondary 
Beat.

9.8.3 Snap to

MIDI recording is very strict. Any fluctuation in timing or speed may 
result in strange or even useless notation. To prevent this, you can 
apply quantization to your performance. Select Snap to from the 
Options menu prior to recording. Choose the smallest rhythmic value 
that you think you can accurately play while recording. The resulting 
MIDI events will be justified, each event beginning at the nearest 
selected rhythmic timing mark.

You can reset start times of selected events to the nearest value set in 
Options > Snap to will also reset start times of all selected MIDI 
events and will fix the increment at which selected MIDI events can be 
moved, when using the mouse or arrow keys to move events horizon-
tally.

9.8.4 Recording New Tracks / Voices

To Record a new track to a MIDI file, 

a. Select Record from the Realtime menu OR press the Record 
button in the Playback Console. The New View window will 
open if any MIDI data already exists in an active file.

FIGURE 9 - 26: Selecting Track to Record
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b. Select an existing track to record a new voice within the same 
track.

NOTE: The new MIDI data will be added to the existing track 
without overwriting any material. 

c. Select New Track to record a brand new MIDI track.
NOTE: A Piano Roll will open for the selected track. A Piano Roll 

must be open to record in SmartScore. A new voice and MIDI 
channel will automatically be created when recording into 
any track.

d. Use the Playback Console to assign the MIDI parameters for the 
new track / voice.

e. Press the spacebar or select Play from the Realtime menu, or 
press the Play button in the Playback Console to start recording at 
measure 1, unless a Punch In point has been set (see below). 

While recording:

• Pause (spacebar) will temporarily halt recording. 
• Play button (spacebar) will resume recording the same track / 

voice
• Stop will end the current recording session. SmartScore will 

return to the standard MIDI editing environment.

9.8.5 External Timer
• To run SmartScore’s MIDI recording from an external timer, 

select External Timer from the Realtime menu.

9.8.6 Setting Punch In and Punch Out points

To set Punch In and Punch Out points for recording, double click any 
measure number in an Overview or Piano Roll. The Measure Settings 
window will open.

• Check Punch In to start recording at the beginning of this mea-
sure.

• Check Punch Out to set this measure as the last measure for 
recording.
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The Punch In and Out points are marked with red triangles in the Over-
view and Piano Roll displays.

9.9 Step Time Recording
Recording a “live” MIDI performance to a metronome may be very 
useful to an accomplished keyboardist, but many of us do not have the 
timing skills required to record a performance meaningful enough for 
conversion to notation. Even if using “Snap to” quantization will result 
in note positions that are offset with a mix of strange note values and, 
usually, many rests. A logical alternative to live recording is Step Time 
Recording. Using this method, you will be able to quickly select exact 
note durations as well as “skips” (rests) from the number pad of your 
computer keyboard. With your other hand, enter notes and chords from 
your MIDI keyboard or MIDI instrument.

To activate Step Time Recording,

a. Make sure your MIDI keyboard or MIDI instrument is properly 
connected to your computer and that it or its interface is selected 
under Input in the MIDI Devices window (See “MIDI Devices” 
on page 176 for more.)

b. From the Realtime menu, select Step Time Record.
c. Select a track. The default is set to “New Track”. If you wish to 

record onto an existing MIDI track, select that track in the New 
View window.

d. Press OK.
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e. A floating window representing the computer keyboard number 
pad and associated note durations appears. Record is now staged. 

FIGURE 9 - 27: Step Time recording (Number Keypad)

f. Click on a note value or control button in the floating key pad 
window. Or, you may select the corresponding value / control 
function using the numerical keypad on your computer keyboard. 

g. Press the Play button of the Mini Console. Recording will begin 
at Measure 1.

h. Press a note or chord on your MIDI instrument. Notes of the 
selected value will insert. The next note you enter will begin at 
the same point the last note ended. e.g. In 4/4 time with quarter 
note selected, hitting a note four times will fill up one measure.

i. To insert a rest, choose a note value and hit Enter or right arrow.

9.10 Virtual Drum Kit
In any MIDI view, you can record your own drum tracks onto existing 
tracks using nothing more than your computer keyboard. To activate 
Virtual Drums, go to the Realtime menu and select Virtual Drum Kit. 
See for more information.
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9.11 Playback Considerations after MIDI Editing
If you return to the ENF view after editing in the MIDI environment, 
playback will retain changes made in MIDI views until the ENF dis-
play is updated with “MIDI Refresh”. If notation is subsequently edited 
in ENF or if MIDI Refresh is selected, you will be given a choice of A) 
Keeping current MIDI playback B) Refreshing ENF and clearing previ-
ous changes made in MIDI or C) Saving the current playback as a 
MIDI file.

9.12 MIDI to ENF
SmartScore accepts any Standard MIDI file and converts it to an ENF 
file.Turn to “MIDI to ENF” on page 167 for details.

9.13 Saving MIDI Files
When saving a MIDI file, remember that you are not saving a music 
notation file. The more “humanized” the MIDI file sounds, the less 
likely it will appear correctly when imported into a music notation 
application, such as SmartScore. Saving SmartScore files derived from 
scanning will normally give reasonably good results because the music 
is already “quantized” into discreet start and stop times.

To save a SmartScore MIDI file,

a. Select FILE > Save As, click the “Save as Type” pull down 
menu and select either MIDI Type 0 (Single Track/Multiple 
Channels) or MIDI Type 1 (Multiple Tracks / Multiple Chan-
nels).

b. Push the Save button. A window appears saying the following:

Articulations such as slurs, staccatos and legatos will result in a 
MIDI file that will not import properly into a notation program. 
Choose whether you want your MIDI file for importing into a nota-
tion program or for playback only.

c. Choose Remove or Keep Articulations according to your need.
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Chapter 10 Working with Drums

SmartScore has some really nice drum features including MIDI support 
for the percussion clef, automatic drum patterns and a “drum kit” which 
records a drum track by tapping keys on your computer keyboard.

10.1 Percussion clef (Clefs Palette)
When the Percussion Clef is entered on a staffline, the MIDI channel 
assignment for that staff and part switches to 10; the default drum chan-
nel. Notes can be entered, deleted and pitch-shifted normally, and will 
playback as MIDI drums. The percussion clef works in den tic ally as 
all other clefs, including Unify Clefs (See 8.6.4 on page 144).

10.1.1 Playback > Drumset

Drum instruments are linked with staff lines and spaces when the drum 
clef is active. An editable drum-to-pitch map is accessed by selecting 
Playback > Drum Set. 

FIGURE 10 - 1: Drum-to-pitch links (Drum Set) 

To change the pitch assignment of a drum instrument,

a. Click on a drum instrument name and drag to a new line or space. 
If another instrument is linked to the line or space, it will unlink.
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b. Clicking and dragging a line or space to an instrument name will 
also create a new link and delete any existing link.

c. Press OK to finalize changes. Press Cancel to undo changes.
NOTE: Accidentals are ignored regardless of the key of the score. 

10.1.2 Creating a drum pattern in ENF

a. From the Navigator palette, select “Score”. In the System Type 
in Score pull-down menu, select Solo/Part. Click OK.

b. Right-click (Ctrl + click for Mac) on any open palette and select 
Clefs. Click on the rectangular “percussion clef”.

c. Position your cursor over treble clef of the first system until it 
highlights yellow. Click to change the clef. All clefs of that part 
in subsequent systems will update to drum clef.

d. Select eighth note from “Notes” palette and using beam direction 
tools, create the following pattern. Hit Spacebar to play back.

FIGURE 10 - 2: Creating a drum pattern

NOTE: Simultaneous drum sounds must be contained in the same 
voice. Therefore, you will need to use the Cluster tool to add 
additional drum “note heads” to an existing note stem. Hold-
ing down Shift and dragging a notehead up or down will 
allow you to hear each drum sound associated with each 
space and line.
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10.2 Automatic Drum Patterns
It’s more fun if it’s got a beat! Simply select a drum accompaniment or 
you can add customized patterns to the drum library yourself.

10.2.1 Play back with automatic drum pattern

To select an instant drum pattern for ENF playback,

a. With any ENF file open, click on the Drum Pattern button in the 
SmartScore toolbar.

b. Sort each column by clicking on its name in the column header.

FIGURE 10 - 3: Automatic Drum Track Window

c. Click on a pattern that matches the time signature and style of 
your ENF file. 

d. Choose a starting measure in the “from measure no.” field and 
push the Insert button.

e. To enter another drum groove at another location, repeat steps c. 
and d. above.

f. If you wish to mute drum playback for one or more measures, 
select the starting measure and push the “Insert Silents” button.

NOTE: Insert Silents are automatically inserted if the Begin and End 
points of 2 or more patterns are not sequential.

g. Press OK to accept the selection.
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h. Press the spacebar to hear your file playback with drum accom-
paniment.

To Remove a drum pattern from the library, 

• Locate the Styles folder inside the SmartScore application folder 
and delete the .ssd file you wish to remove.

10.2.2 Adding custom drum patterns from ENF

The drum pattern library is expandable. You can add new patterns that 
you have either created yourself or imported from a MIDI file which 
contains a drum track on MIDI Channel 10.

To add an ENF drum pattern to the automatic drum pattern library,

a. Open an ENF file which contains a percussion part (written with 
a percussion clef) or, 

b. Open an ENF file in which you have created your own drum pat-
tern. Refer to “Creating a drum pattern in ENF” on page 206 for 
more information on how to create drum patterns. 

c. Click the MIDI button in the Navigator to open the MIDI Over-
view. 

NOTE: See Section 9.1.1 on page 173 for more about MIDI views.
d. Select Edit > Create Automatic Drum Pattern.

FIGURE 10 - 4: Creating a drum pattern from a MIDI file

e. Locate the track in which the drum is played and select it in the 
Track field. Note that MIDI drums will sound only if they are 
assigned to MIDI Channel 10. 
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NOTE: To check the channel number of a track, right-click (alt + 
click for Mac) next to the track number in MIDI Overview 
then select Piano Roll. The channel number (and its color) 
will appear in the upper left corner of the Piano Roll View. 
Close the Piano Roll window to return to Overview window. 
Another option is to simply open the Playback Console (Ctrl 
+ 9). Next to each track number listing is a colored box con-
taining the MIDI channel number assigned.

f. Enter the name you wish to give the pattern in the Name field.
g. Select a musical style to classify the new pattern and enter it in 

the Style pull-down menu.
h. Locate the first measure where you wish the pattern to begin and 

enter it into the Beginning Measure field.
i. Decide how many measures you wish the pattern to contain and 

enter it in the Length (in Measures) field. This is a very impor-
tant decision if you want to have proper-sounding patterns. 

j. Click Generate to add the pattern to the library. It’s name will 
then appear in the Automatic Drum Pattern window.

TIP: Add “fills” to longer patterns (8 or 12 measures). Repeated fills 
in patterns having 1 or 2 measures usually sound dumb.

• Importing MIDI drum patterns

a. Push the Open button in the Navigator (File > Open) and click to 
select MIDI from the “Files of Type” pull-down menu. Browse to 
a MIDI file containing a drum track and double-click.

b. Push the Play button to hear the MIDI file play back. Push Close.
c. The imported MIDI file will appear in the MIDI Overview win-

dow. 
d. Repeat the process from Step d) above.
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10.3 Virtual Drum Kit
This option allows you to create a drum track to accompany any ENF 
playback without requiring a drum machine or any other external MIDI 
device. It maps selected MIDI drum sounds to the keys of your com-
puter keyboard. MIDI quantization to sixteenth notes is applied by 
default. For more information about quantization, see “Snap to” on 
page 198.

10.3.1 Recording a virtual drum track

To create a virtual MIDI drum track in ENF,

a. Select Options > Virtual Drum Kit.
b. In the New MIDI View window, New Track is selected. Press 

OK.
c. A MIDI Record view will open. Test drum sounds by hitting the 

center keys on the two front rows of your computer keyboard.
d. When ready, hit the Record button. You will hear a metronome 

sound for one measure. Playback and drum recording begins.
e. Hit Stop when finished. Close the MIDI window to return to 

ENF.

10.3.2 Defining Virtual Drum Kit

To change a MIDI drum and link to your computer keyboard,

a. Select Options > Virtual Drum Kit Definition

FIGURE 10 - 5: Virtual Drum Kit Definition
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b. Click on an instrument / key in Instrument list.
c. To reassign a MIDI drum instrument, push Change Instrument

and make another MIDI drum selection in the pull-down menu.
d. To reassign a keyboard key for that instrument, push Change 

Key and press any keyboard key to be linked to that instrument.
e. When finished, press OK.

To add a MIDI drum and link it to your computer keyboard,

a. Push Add.
b. Press a key to become associated with the sound. 
c. Select a new drum sound from the pull-down menu.
d. When finished, press OK.
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Chapter 11 Reference

11.1 Preferences
Default ENF display characteristics can be changed. Select Edit >  
Document Preferences or Edit > Program Preferences depending on 
whether the characteristic is document or program-dependant.

11.1.1 Document Preferences

• Text symbols

Reset default font size and type for text symbols such as triplets, 
dynamics and expression marks. For text and lyric defaults including 
part names, push the “Text Styles” button. Push Apply to change. See 
“To modify font styles of text fields or lyric blocks,” on page 105.

• Systems

Reset display characteristics for systems including part names, measure 
numbers, lyric display and printing, cross-staff pointer lines and con-
straining system scrolling when the score is reformatted.

• Score symbols

Change display options for

• Triplet bracketing (square, arc, none)
• Note overlap control (overlap voices or offset noteheads)
• Rehearsal symbol display (numbers or letters).

• Chord symbols

Change display options for chord symbols and fretboard font type, size 
and color, fretboard size scaling and how chord symbols will be dis-
played:

• Show both chord name and guitar fretboard symbols.
• Show only guitar fretboards.
• Show only chord names.
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• Show neither chord nor fretboard symbols.
• Long Minor will display “min” instead of “m” for the word 

“minor”.

• Page number

Change display options for page number display and page position.

• Playback

Change default playback characteristics for grace notes:

• Before the beat
• After the beat (accaciatura)

11.1.2 Program Preferences

• User Interface

Turn tool palette recycling off and on, turn display of active staff and 
margins off and on and show Task Window at startup. Reset disabled 
windows including post-recognition pop-up notifications.

• Page type

Reset default page size and orientation.

• Units and Zoom

Reset default ruler display units and reset zoom - screen size ratios.

• Color settings

Reset color properties of notes and other symbols.

• MIDI channel color

Reset the colors displayed for MIDI channels 1-16

• Karaoke settings

Control appearance during playback including scroll and ball behavior 
as well as background and lyric colors. These options are also available 
in Karaoke mode under the Options menu.

• Autosave

Reset default Autosave rules.
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• Every n minutes - even if no editing takes place.
• Every n actions - based on number of editing actions, e.g. 

Inserting, Changing, Deleting, etc.
• What is first - based on which is first; the number of min-

utes selected or the number of actions performed.
• Never - deactivates Auto Save of the ENF file.

• Notifications

Control whether or not to display certain warning and caution notices.

• Music XML

Change default options for saving ENF to Music XML files.

11.2 Properties Tool
Playback properties of many markings, including dynamics and articu-
lations, may be adjusted singly or globally by clicking with this 
tool.whick is located in the SmartScore toolbar. See Section 4.6, "Play-
back Properties" on page 59 and for more details.

11.3 Tool Palettes
11.3.1 Notes and Rests palette

• Notes (See Section 5.2.2 on page 86)

• Cluster tool (See Section 5.2.12 on page 90)

• Rests (See Section 5.2.2 on page 86)

• Tuplets (See Section 4.5.5 on page 58)

• Beam (See Section 5.2.13 on page 91)

• Grace notes (See Section 8.3.3 on page 130)

• Dots (See Section 5.2.10 on page 90)

• Ties (See Section 5.2.11 on page 90)

• Accidentals (See Section 5.2.8 on page 88)

• Courtesy accidental tool (See page 89)
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11.3.2 Articulations palette

Turn to “Articulations and Trills” on page 134 for editing details.

• Slur (Legato)

Note durations associated with slurs are increased about 10% giving an 
overlapping or “connected” effect when played back.

• Expressions (See page 134)

• Turn

Click on note head or note stem apply a turn. Turns play as follows:

FIGURE 11 - 1: Turn

• Fermata (bird’s eye)

Click on note head or note stem to apply a fermata. Tempo is slowed by 
50% for the duration of the note to which the fermata is attached.

• Staccato

Click on note head to apply a staccato. Duration of the associated note 
is shortened by 25%.

• Tenuto

Click on note head to apply a tenuto. Duration of the associated note is 
extended by 125%.

• Accent

Click on note head to apply an accent. Accent increases the velocity of 
its associated note by 150%.

• Soft Accent

Click on note head to apply a soft accent. Soft accent increases the 
velocity of its associated note by 125%.
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• Trill

With tr (trill) selected, click on a note to insert a single trill marking. To 
create an “extended” trill, hold the Shift button down (Nudge mode) 
and drag the yellow control handle on the trill marking to the right. See 
also “Articulations and Trills” on page 134.

Trill Extended Trill 
FIGURE 11 - 2: Trill and Extended Trill

• Sharp, Flat and Natural

With one of these modifiers selected, clicking on a trill marking will 
insert the accidental above the trill and cause playback of the trill to 
“flatten”, “sharpen” or “neutralize” target pitches while considering the 
active key signature. 

• Mordent

Click on notehead to apply a mordent. Mordents play back as follows:

FIGURE 11 - 3: Mordent

• Inverted Mordent

Inverted mordent play back as follows:

FIGURE 11 - 4: Inverted Mordent
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• Tremolo (single, double, triple, quadruple)

Tremolos repeat the note affected by dividing the associated note by 
four times the selected tremolo value. See also, “To change existing 
half notes to beamed tremelos,” on page 136.

FIGURE 11 - 5: Tremolo (Double)

• Arpeggio

Arpeggiated chords will offset the start time of all members of a cluster 
and will keep them sustained throughout the duration of the chord.

Written Played

FIGURE 11 - 6: Arpeggio

• Glissando

Glissandos divide connecting notes into equal notes of 1/4 base value

Written Played

.

FIGURE 11 - 7: Glissando)

11.3.3 Clefs and Signatures palette

In Insert mode, Quick-select (Ctrl+click) the any nearby clef of the 
desired type. Or select any clef from the “Clefs” palette. 

• Click anywhere in the active staff to insert the selected clef. 

Click on any existing clef (yellow highlighted) to change it to the 
selected clef. Notes will not reposition themselves when a clef is 
changed either by a change-of-clef sign or by Unifying Clefs.

To delete a clef, 

• Quick-select (Ctrl+click) any clef, press the “X” key and click on 
a clef to remove it.
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NOTE: Note positions do not move when a clef sign is changed. To 
change a clef while keeping original note pitches of a part or 
selected region, note positions must be shifted. Refer “Trans-
position by Key and Clef” on page 95.

• Alto / Tenor / Mezzo-soprano (“C”) clefs

The midpoint of the “C” clef indicates where C below middle C (MIDI 
C3) is to be located.

• Treble Octava / Bass Octava clefs

Playback in these clefs will be an octave higher than with a standard 
clef.

• Treble Octavo / Bass Octavo clefs

Playback in these clefs will be an octave lower than with a standard 
clef.

• Percussion clef

When the Percussion clef is inserted into a staffline, MIDI channel 
assignment of the staff switches to 10; the default drum channel. Notes 
are entered normally, but playback as MIDI drums. Note pitch-to-MIDI 
drum assignments are mapped in Drumset option under the Playback
menu. Refer to “Playback > Drum Set” on page 235 to assign drums.

• Octava / Octavo tools

These are not clefs per se. Rather than insert with a mouse click, they 
are applied to selected notes by dragging to select the notes to be modi-
fied. Playback of selected notes will be an octave higher when selecting 
with Octava tool and an octave lower when selecting with Octavo tool.

To assign Octava or Octavo to a range of selected notes

a. Select either Octava or Octavo tool. 
b. Drag the cursor to select notes in the active staff.

FIGURE 11 - 8: Octava
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Notice that the Octava or Octavo mark will appear at the beginning of 
the range of selected notes an the applied range will be indicated by a 
dashed line above the selected notes.

• Signatures (Key and Time)

See “Signatures (Key and Time)” on page 137

11.3.4 Barlines and Repeats palette

See “Barlines palette (I)” on page 92.

Also see “Jumps, Repeats and repeat symbols” on page 71.

11.3.5 Dynamics palette

See “To insert a crescendo or decrescendo,” on page 133

11.3.6 Tempo palette

See “Tempo Markings” on page 57

11.3.7 Tools palette

• Text

Selecting the Text button sets the cursor to the Text Edit mode. See 
"Text mode", Section 6.1, on page 101.

• Lyrics

Selecting the Lyric button sets the cursor to the Lyric Edit mode. See 
"Lyrics", Section 6.2, on page 103.

• Guitar Fretboard

Selecting the Guitar chord fretboard button resets the cursor to “Insert 
Guitar Chord” mode. See "Guitar Fret and Chord Symbols", 
Section 6.4, on page 107.

• Rehearsal

Ten Rehearsal Markings can be placed anywhere in the ENF view.

• Pedals

Four Pedal Markings can be placed anywhere in the ENF view.
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• Bowings

Two Bowing Markings can be placed anywhere in the ENF view.

• Breaths

A Breath Marking can be placed anywhere in the ENF view.

11.4 ENF FILE Menu
11.4.1 File > New ENF / New MID

Select between a new ENF or a new MIDI. Choosing New ENF will 
open the New SmartScore Document window. Select a Template or use 
Custom to create a unique score. Choosing New MIDI will open a 
blank MIDI Overview and Piano Roll for MIDI input.

11.4.2 File > Open (Ctrl +O Win / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file 
will be loaded into memory and will display on the screen. 

11.4.3 File > Close (Cmnd+W)

Closes active ENF document. If changes have been made, a Save As 
dialog box will open.

11.4.4 File > Save (Ctrl +S / Cmnd+S for Mac)

This will save an open SmartScore document to the same drive the file 
was opened from. The original name remains unchanged. If ENF and 
Image are displayed, only the ENF file is saved. 

11.4.5 File > Save As

You can save files in several file formats other than SmartScore’s 
native ENF format. These include MIDI (.MID), NIFF (.NIF for Lime 
and .NIF for Sibelius) and (.FIN) file. Saving in the .FIN format will 
create a file that can be opened in Finale 2000c or greater with page 
layout and formatting intact. To save open ENF document into one of 
these formats or to save open file with a new name, 

a. Go to File > Save As. 
b. In the Filetype/Format window, choose a format to save the file.
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c. Browse to another directory and change the name if necessary.
d. Press OK. The file will be saved in the last directory used to 

“save”.
NOTE: Use File > Save (Ctrl +S /Cmnd+S) to update the current 

ENF file.
NOTE: When saving ENF to MIDI files, a dialog box will open to 

explain that articulations such as slurs, staccatos and tenutos 
will create MIDI events that are not quantized. You will be 
given a choice to save the MIDI files with articulations 
removed or kept. For the purpose of playback only, it is rec-
ommended that articulations be kept. If t is recommended that 
articulations be removed if MIDI files are to be imported into 
other notation-based programs.

11.4.6 File > Save as PDF

This opens file browser and saves current active ENF file as an Adobe®

Acrobat® PDF format file. (Windows requires PDF 995 from installer)

11.4.7 File > Scan Music

• Acquire: Initiates scanning. Same as Scan in Navigator.

• Select Scanner: Opens list of available TWAIN drivers to select.

• Choose Interface:  
> SmartScore’s = selects the SmartScore scanning interface. Refer 
to “Selecting your scanner and interface in SmartScore” on page 27 
for details. 
> Your Scanner’s = selects scanning software from your scanner. 

11.4.8 File > Recognize

This initiates the recognition sequence for recognition of pre-scanned 
images. See “Recognition Sequence” on page 32 for details.

11.4.9 File > Page Setup

This opens the document layout control panel. See “Document Page 
Setup” on page 163 for details.
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11.4.10 File > Print (Ctrl+P / Cmnd+P)

11.4.11 File > Print Preview

Use to check for proper page layouts. Also seen in Page Setup view.

11.4.12 File > CD Writer

Using the CD Writer feature, you will be able to record one or more 
ENF (MIDI playback) performances as a audio CD playable in your 
car, home stereo, etc. It will be necessary to have a CD-R (CD Writ-
able) device installed and connected to your system. CD Writer will 
also record and burn MIDI files.

To record ENF or MIDI files and burn them to audio CD,

a. Push the CD Writer icon at the bottom of the Navigator.
b. Push “Add Files” and select one or more ENF or MIDI files to be 

recorded to CD.

FIGURE 11 - 9: CD Writer window

c. Each selected file must undergo a conversion to an audio format. 
(.WAV is the default). After converting, the selected file(s) will 
appear in the “Files to Burn” list as an audio.  
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Files may be reordered using the “Move Up” or “Move Down” 
buttons. They may be removed from the list separately or all 
together with “Remove” or “Remove All” buttons.

d. Insert an unused writable CD (CD-R) into your CD tray. Burn 
Method = Auto. Change to another method if you have trouble.

e. Push “Burn Last Track and Finalize CD” to record and finalize 
your ENF files to CD. All selected files will record on a single 
CD track. To record individual tracks, use “Burn New Track” as 
described below.

NOTE: “Finalizing” a CD is necessary before a can be played back. 
Once Finalize is applied, you will not be able to record any-
thing more to the CD.

f. If you wish to continue burning new selections without finalizing 
the CD, push “Burn new track”. Each set of converted files in 
the “Files to Burn” list will record to one track. Select “Burn 
Last Track and Finalize CD” to record last track and finalize 
the CD.

11.4.13 Most recently opened ENF files

The last four ENF files are listed and may be opened by clicking their 
names. 

11.4.14 Exit

Saves and closes all open ENF files and closes SmartScore.

11.5 ENF EDIT Menu
11.5.1 Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine 
layers of Undo. 

11.5.2 Redo (Ctrl +Y / Cmnd+Y)

Reapplies the last action that has most recently been Undone. 

11.5.3 Edit > Cut (Ctrl+X / Cmnd+X)

To Cut selected objects from the score and place them on the clipboard, 
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a. Hit “O” key or choose the Select tool from the Toolbar. 
b. Click and drag a box with the cursor until objects you wish to cut 

(and store to the clipboard) are highlighted orange.
c. Press the Cut button in the Main toolbar, hit Ctrl + X / Cmnd + 

X or select Edit > Cut from the menu.

11.5.4 Edit > Copy 

To Copy selected objects for pasting elsewhere in the score, 

a. Activate the Select tool then click and drag a box to select a 
region of interest.

b. Press Ctrl +C / Cmnd+C or go to Edit > Copy.
NOTE: To copy selected region of the page to the clipboard for past-

ing as a bitmap image into another program, activate the 
Select tool and drag a region with the right mouse button (Alt 
+ click for Mac).

11.5.5 Edit > Paste (Ctrl +V / Cmnd+V)

To Paste the contents of the clipboard into an ENF file, 

• Select Paste (Ctrl +V / Cmnd+V) from the Edit menu and click 
anywhere in the score. The contents of the clipboard will be 
added to the score without replacing the existing notes.

11.5.6 Edit > Paste Replace (Ctrl+R or Cmnd+R)

To Paste the copied material into an ENF file and replace existing 
notation, 

• Select Paste Replace from the Edit menu (Ctrl+R or Cmnd+R) 
and click anywhere in the score.

TIP: Use Paste Replace to quickly replace a complex passage that 
was poorly recognized with an identical passage that is correct. 

11.5.7 Edit > Delete

In this mode, clicking on objects that are moused over (and highlight 
yellow) are deleted.
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11.5.8 Edit > Select All (Ctrl+A or Cmnd+A)

To select all objects on the current page for cut, copy or paste / replace 
action, 

Choose Select All from the Edit menu (Ctrl+A or Cmnd+A).

11.5.9 Edit > Bracketing (Ctrl+B or Cmnd+B)

Refer to “Bracketing” on page 112.

11.5.10 Edit > System Manager (Ctrl+M or Cmnd+M)

Refer to “System Manager” on page 155.

11.5.11 Edit > Staff Spacing

Refer to Section 7.2.2, "Globally applying line, staff and system spac-
ing" on page 119 for details.

11.5.12 Edit > Text Styles

Refer to “To modify font styles of text fields or lyric blocks,” on 
page 105 for more details.

11.5.13 Edit > Part Linking (Ctrl+L or Cmnd+L) 
(Collapsing and expanding systems)

Many printed scores “collapse” or “optimize” systems to show only 
actively playing parts. Similarly, instruments that appear in one part 
may split into two or more parts anywhere in the score causing systems 
to “expand” in size. SmartScore automatically senses expanding sys-
tems when, for example, a piano solo introduction precedes a vocal/
piano arrangement. Expanding and collapsing parts are easily linked or 
re-linked in a simple-to-use environment called Part Linking. Part 
Linking is also used when merging staves with brackets that were cut 
off. Turn to “Re-linking parts” on page 78 for details on this feature.

11.5.14 Edit > Score Structure

This special environment is used to perform useful functions such as 
creating a conductor’s score from different parts and for isolating or 
joining parts and voices. For detailed discussion on using this powerful 
feature, turn to “Score Structure” on page 120.
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11.5.15 Edit > System > Insert Above/Insert Below/Remove

Use this feature to insert an entire empty system above or below the 
currently active system. Use to delete a system, if you need to.

a. Position the cursor over the current system to make it active. 
b. To remove a system from a score, position the cursor over the 

system you wish to delete and select Edit > System > Remove.
NOTE: When an ENF score structure is changed by adding or delet-

ing staves and/or systems from the Edit menu, synchroniza-
tion with the scanned images will be lost. We recommend 
that you complete all needed edits/corrections or save a copy 
of the ENF file before using the Edit menu to change struc-
ture of your scanned music. See “View >Associate Image 
Files” on page 232 for more about keeping synchronization.

11.5.16 Edit > Staff > Insert Above/Insert Below/Remove

Use this feature to expand or collapse a system. 

TIP: Keep in mind that when you add a part to a system, you are also 
adding a new part to the score. When adding a part to a system, 
the new part will not be visible in any system except the active 
system. For details, see “Part Visibility” on page 160.

11.5.17 Edit > Score-Part

Use this feature to append a new Score-Part to the ENF document. 
When a new Score-Part is added, it will begin playback at measure #1 
along with all other Score-Parts that have been created. For definition 
of Score-Part, see Score-Part on page 249.
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11.5.18 Edit > Add Empty Pages

Use to add new pages. Also found in Status Bar (lower right corner).

FIGURE 11 - 10: Add Empty Page window

11.5.19 Edit > Unify Signatures (U)

Refer to “Unify Score (“U”)” on page 144.

11.5.20 Format Score

This tool is used to entirely reformat the ENF score.

FIGURE 11 - 11: Format Score window

• Measures per system 
Select a fixed number of measures for every system in the score.

• Apply punctuation 
Apply auto-spacing to reformatted measures.
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• Setup indents 
Set indent for 1st system.

• Setup spacing. 
Set staff and system spacing.

11.5.21 Default Voices (Ctrl + U)

Use this feature to revert a selected set of notes within a measure to 
their default voice / color assignment. Useful if voice / color assign-
ments become confused after repeated over-riding of voices. 

11.5.22 Edit > Instrument Templates (Ctrl+S or Cmnd+S)

Refer to “Instrument Templates” on page 160.

11.5.23 Edit >Score Header

Refer to “Score Header” on page 102.

11.5.24 Edit >Default Tempo

To set the default tempo,

a. Select desired Beats per Minute from the horizontal slider.
b. Choose a base note Tempo Value (4/4 default = quarter note).
c. Check the Metronome Mark Visibility box to display the Met-

ronome Mark in the ENF document in the first measure.

Refer to “Tempo Markings” on page 57 for entering change-of-tempo 
(metronome) markings.

11.5.25 Automatic Drum Track

Opens the “assign drum pattern” window. See “Add drum tracks” on 
page 67 for details on creating automatic drum tracks.

11.5.26 Edit > Guitar Chord Library

The Guitar Chord library contains preset guitar chords and associated 
chord symbols. Add, change, delete and store any custom chords. Gui-
tar frets and chord symbols automatically transpose with key transposi-
tion. Refer to “Guitar Fret and Chord Symbols” on page 107 for details.
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11.5.27 Edit >Transpose (Ctrl +T / Cmnd+T) 

Transpose your score by key or by clef. Limit to a part, a voice or select 
a range. Refer to “Transposition” on page 148 for details.

11.5.28 Edit > Edit Mode

• Zoom 

• Select tool (Ctrl+O / Cmnd+O)

• Insert / Change - See “Insert/Change mode” on page 87.

• Delete - See “Deleting notes and symbols (X)” on page 141.

• Vertical Alignment (Y) - See “Working with Contrapuntal 
Voices” on page 151.

• Beam Notes (B) - See “To convert a sequence of flagged notes into 
one beamed group,” on page 142.

• Split Voices (H) - See “Voice Splitting (Select + “H”)” on page 67.

• Flip Stems (S) - See “Stem direction (S)” on page 143.

• Delete Selected Ties/ Articulations (G) - See “Select tool (“O”)” 
on page 141.

11.6 ENF VIEW Menu
11.6.1 View > Toolbars

• Navigator

Opens and closes the SmartScore Navigator.

• Main

Opens and closes Main Toolbar

• SmartScore

Opens and closes SmartScore Toolbar

• Image

Opens and closes Image Editing Toolbar
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• Text and Controllers

Opens and closes the toolbar containing control buttons for text and 
graphical controllers.

• Mini Console

Opens and closes the Mini playback console in ENF view.

• MIDI Toolbar

Opens the MIDI toolbar in the active ENF view.

• Print Preview Toolbar

Open and closes the Print Preview toolbar when Print Preview is active.

• Status Bar

Opens and closes Status Bar at the bottom of display. Displays current 
page, cursor position, image size, zoom, page view type and add page. 

11.6.2 View > Palettes

Refer to page 129, "Tool Palettes (F2-F8 keys)" for details.

11.6.3 View > Show Active Staff

This selection will cause the ENF display to highlight the active staff in 
black while other staves become grey. The active staffline is the staff 
that the cursor was last positioned over.

TIP: Show Active Staff is useful when notation objects do not 
respond to editing actions. Using this view option might reveal 
that they actually belong to an adjacent staffline.

TIP: If an object does not delete even if it shows itself to be in an 
active staff, use the Select tool (“O” key) to highlight it and 
then hit Delete. All selected objects will be removed with the 
Delete key, whether they are in the active staff or not.

11.6.4 View > Reset Tools and Palettes (F1)

Resets tool palettes and toolbars to their default (program launch) posi-
tions and maximizes the ENF display.
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11.6.5 View > Hidden Symbols

Refer to page 162, "Hidden Symbols" for details.

11.6.6 View > Show Part Names

To display the part name or abbreviation on the left staffline margin, 

a. Selecting Show Part Names and Abbreviations displays Part 
Names in the first system and the Part Abbreviations in subse-
quent systems. 

b. Select Show Part Names Only or Part Numbers Only to dis-
play just name or number in the 1st system and nothing more.

NOTE: For information on selecting and modifying Part Names, see 
“Instrument Templates” on page 160.

c. Selecting Do Not Show will nor display any Part Names or 
abbreviations in the ENF display. 

11.6.7 View > Lyric Show/Don’t Show

Checking this option off will remove the display and printing of lyrics.

11.6.8 View >Associate Image Files

Synchronization between the ENF and TIFF panes assumes exact ENF 
correspondence to the original score structure. Synchronization may 
become lost after systems are inserted, removed or if page margins are 
changed. Once a system rolls from one page to another, ENF-TIFF syn-
chronization will become lost for all subsequent pages. 

TIP: To keep ENF to TIFF panes synchronized for as long as possi-
ble, complete all ENF editing before inserting systems (Edit > 
System > Insert). Synchronization may be regained by resizing 
top and/or bottom margins in Page Setup after making small 
changes; e.g. after altering line spacing. Refer to “File > Page 
Setup” on page 222 for more details on controlling page mar-
gins.
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To synchronize ENF and TIFF views, 

a. Go to View > Associate Image Files...

FIGURE 11 - 12: Associate Image File Window

b. Push Add to locate the TIF file associated with the open docu-
ment. Browse your computer to find the image file. If the file 
contains several pages of images, they will appear as xxxP1, 
xxxP2, xxxP3, etc.

c. Click to highlight a page in the image-page list. A preview of the 
page will appear in the view window if Preview is checked. Then 
click on the appropriate ENF page in the list of ENF pages.

d. Push the Associate button to associate the image page with the 
appropriate ENF page. Continue as necessary.

11.6.9 View > Image Information

Provides information on the structure and type of the currently dis-
played image file.

• Next Page

Displays next page of ENF document

• Previous Page

Displays previous page of ENF document

• Go to Page (Ctrl +G / Cmnd+G)
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Presents a dialog box to select a page number to jump to. Refer to “Pag-
ing” on page 84 for details. 

• Zoom

Lists available view percentages. Changing zoom will affect both the 
image and the ENF file simultaneously. Range is from 8% to 400% 
view scale.

11.6.10 View > Scan View

Provides options for the floating zoom window including whether to 
display ENF or TIFF close-ups in the zoom window and selecting addi-
tional zoom views. Refer to page 125, "Split-screen and Scan View ref-
erence views" for details on the floating zoom window.

11.6.11 New MIDI View (Ctrl +I / Cmnd+I)

Opens New MIDI View dialog box. Select type of MIDI view.

• Overview - Displays all staves as MIDI tracks.

• Piano Roll - Displays selected stave as MIDI track.

• Event List - Displays MIDI events of selected staff line. 

11.7 ENF PLAYBACK Menu
11.7.1 Playback > Set Playback Range

Refer to “Playing back a selected section” on page 55.

11.7.2 Playback > Play / Stop / Rewind

Used to control playback functions from menu.

11.7.3 Playback > Thru

Sets MIDI device to play “live” without MIDI Record on.

11.7.4 Playback > Console

Opens Playback Console (Ctrl+9 / Cmnd+9).
234  USING SmartScore



Reference
11.7.5 Playback > Mini Console

Opens and closes Mini Console toolbar.

11.7.6 Playback > MIDI Devices

Opens MIDI device dialog box. Select MIDI input and output sources. 
Refer to “MIDI Setup” on page 51 for details.

11.7.7 Playback > Swing

Turns swing playback on or off. Refer to “Swing” on page 67.

11.7.8 Playback > Drum Set

This window allows you to map MIDI Drum instruments to staff lines 
and spaces when percussion clef is assigned to a staff. For more details, 
turn to “Percussion clef (Clefs Palette)” on page 205.

11.7.9 Playback > Lock to Time Signature

Refer to “Pickup and split measures” on page 66.

11.7.10 Playback > Graphical Controller

Refer to “ENF Graphical controllers” on page 63.

11.8 ENF WINDOW Menu
11.8.1 Task Window (Ctrl + W)

a. Opens the SmartScore task window:

FIGURE 11 - 13: Task Window
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11.8.2 Clone Document

Duplicates and opens currently open ENF file.

11.8.3 Cascade

Display, overlap and offset all open ENF files. 

11.8.4 Tile

Display all open windows of all open ENF files with no overlap.

11.8.5 Split

Activates the ENF / Scan view split control tool.

11.8.6 Scan View Window

Removes the split-screen Image pane and activates the floating scan 
view window. See Section 8.1.1, "Split-screen and Scan View refer-
ence views" on page 125 for more details.

11.8.7 Karaoke

Opens the Karaoke view window. See Section 4.8.3, "Karaoke View" 
on page 66 for more details.

11.8.8 Overview / Piano Roll / Event List

Opens MIDI view window and displays the selected MIDI environ-
ment, Overview, Piano Roll or Event List. See Section 9.1, "MIDI 
Views" on page 173 for more details.

11.9 ENF Help Menu
11.9.1 Help > SmartScore Manual (PDF)

In CD versions, this selection will open the file, SSManual.pdf. This 
file is the full Using SmartScore 5 manual in Adobe Acrobat format. It 
is located in the SmartScore directory and is opened by Adobe Acrobat.

In download versions, this selection will attempt to open an Internet 
connection and begin downloading of the file, SSManual.pdf from the 
Musitek website. If the file is moved to the SmartScore directory, the 
local file will open when the Help > SmartScore Manual (PDF) is 
selection is made again.
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11.9.2 Help > Online Help

This selection will attempt to launch your Internet browser and connect 
to a special interactive help system online at musitek.com. The Online 
Help system is fully interactive and contains index links, table of con-
tents links and text hyperlinks to related subjects.

11.9.3 Check for Updates

Opens Internet browser and attempts to locate the SmartScore online 
updates page at: http://www.musitek.com/updates.html

11.9.4 Registration

Opens Internet browser and attempts to locate the Musitek online regis-
tration page at: http://www.musitek.com/registration.html

11.9.5 About SmartScore 5

Displays version / update number. Pushing the graphic icon reveals 
author / programming information.

11.10 MIDI FILE Menu
11.10.1 File > New

Select between a new ENF or a new MIDI. Choosing New ENF will 
open the New SmartScore Document window. Select a Template or use 
Custom to create a unique score. Choosing New MIDI will open a 
blank MIDI Overview and Piano Roll for MIDI input.

11.10.2 File > Open (Ctrl +O / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file 
will be loaded into memory and will display on the screen. 

11.10.3 File > Close - (Cmnd+W Mac)

Closes all MIDI views. If any changes were made to the MIDI file, 
option to Save MIDI file. Return to main SmartScore window.

11.10.4 File > Save (Ctrl +S / Cmnd+S)

Writes currently displayed file to the hard disk. 
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11.10.5 File > Save As 

Opens Windows File Selection dialog box

Save processed or modified MIDI files to hard disk following MIDI 
Recording or Editing procedures.

Use to save selected files to directory other than the working directory

11.10.6 File > Show Task Window (Ctrl + W)

Opens SmartScore Task Window.

11.10.7 File > CD Writer

Opens CD Writer / Burn window. See “File > CD Writer” on page 223.

11.10.8 File > Recent (1,2,3, or 4)

Automatically loads one of the last four files accessed by SmartScore.

11.10.9 File > Exit/ Quit- (Cmnd+Q)

Exit SmartScore. Save current file. Go to Windows main desktop.

11.11 MIDI EDIT Menu
11.11.1 Edit > Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine 
layers of Undo. 

11.11.2 Edit > Redo (Ctrl +Y / Cmnd+Y)

Reapplies the last action that has been Undone. 

11.11.3 Edit > Select

Opens the Select window for defined note selection.

11.11.4 Edit > Select All (Ctrl +A / Cmnd+A)

Selects all MIDI events in every track. 
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11.11.5 Edit > Cut (Ctrl +X / Cmnd+X)

Removes the highlighted notes from the score and places them in the 
clipboard. 

11.11.6 Edit > Copy (Ctrl +C Win / Cmnd+C Mac)

Places selected notes on the clipboard without removing them from the 
score. 

11.11.7 Edit > Paste (Ctrl +V / Cmnd+V)

Insert the contents of the clipboard back into the score without deleting 
the existing notes. 

11.11.8 Edit > Paste Special

Opens the Paste Special window. The Paste Special window offers sev-
eral options for pasting the contents of the clipboard back into the 
music.

11.11.9 Edit > Delete (Del)

Deletes the selected section from the MIDI file. 

11.11.10 Edit > Delete Track

Deletes the currently displayed MIDI track.

11.11.11 Edit > Program Change (Piano Roll only)

Opens the Change Instrument window. Insert a change to a new MIDI 
patch.

11.11.12 Edit > Velocity/ Duration

Opens the Velocity and Duration window. Adjust the Velocity and/ or 
Duration of the selected MIDI events.

11.11.13 Edit > Create Automatic Drum Pattern

If you wish to convert a MIDI drum pattern and add it to the Smart-
Score drum pattern library, load the MIDI drum pattern file and select 
this option. For more information, see “Adding custom drum patterns 
from ENF” on page 208.
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11.11.14 Edit > Convert MIDI to ENF

Converts MIDI data in the currently open file to ENF notation.

11.12 MIDI VIEW Menu
11.12.1 View > Navigator

Opens and closes the SmartScore Navigator.

11.12.2 View > Main Toolbar

Opens and closes Main Toolbar.

11.12.3 View > SmartScore Toolbar

Opens and closes SmartScore Toolbar.

11.12.4 View > Image Toolbar

Opens and closes Image Editing Toolbar.

11.12.5 View > Text and Controllers Toolbar

Opens the Text and Controllers toolbar.

11.12.6 View > Mini Console

Opens Mini Console transport control.

11.12.7 View > MIDI Toolbar

Opens the MIDI toolbar.

11.12.8 View > Synchronize

Synchronizes measure sizes in all MIDI views to that of current MIDI 
view. All horizontal resizing is synchronized between all MIDI views.

11.12.9 View > Show Actual Playback

When selected, all MIDI events (including articulations such as trills 
and tremelos) are visible in the Piano Roll view. When selected, MIDI 
events cannot be edited (behavior of articulations is controlled with 
Properties tool in the ENF view. Turn off to edit MIDI events.
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11.13 MIDI OPTIONS Menu
11.13.1 Options > Snap to (Quantization)

Quantities selected MIDI “Note On” events to the nearest “tick” speci-
fied. Also determines default quantization value for MIDI recording 
and for horizontal nudging of selected MIDI events by mouse dragging 
or by use of the arrow keys. Quantization values range from 32nd trip-
let to whole note. 

11.13.2 Options > File Settings

Opens Sequence Settings window. Shows the MIDI header information 
including: tempo, time base, time signature, key, and MIDI instrument.

11.13.3 Options > Track (not in Overview)

Opens Track Properties dialog box. Select a different track view, 
delete, duplicate, rename, or transpose the selected track.

11.13.4 Options > MIDI Devices

Opens MIDI device dialog box. Select MIDI input and output sources.

11.13.5 Options > Instrument Settings

Opens Instrument Settings dialog box. Allows for selection of Port, 
Bank, and MIDI channel assignment for Instrument and Drum sources.

11.13.6 Options > Metronome Settings

Opens Metronome Settings dialog box. Allows for selection of Port, 
MIDI Channel, number of lead in measures, MIDI sound and volume 
for Primary and Secondary beats.

11.13.7 Options > Shuttle On

Activate/ deactivate SmartScore’s shuttle tool.

11.13.8 Options > Virtual Drums Definition

Opens the keyboard map editor for changing computer keyboard key 
assignments for the Virtual Drum feature. See “Recording a virtual 
drum track” on page 210 for more details.
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11.14 MIDI PLAYBACK Menu
11.14.1 Playback > Set Playback Range

Opens Set MIDI Play Range dialog window.

11.14.2 Playback > Play/ Pause “Spacebar”

Begins/ pauses/ resumes playback of current MIDI file. In Record 
Mode will start and pause MIDI recording.

11.14.3 Playback > Stop

Stops playback or recording of current MIDI file.

11.14.4 Playback > Rewind “,” (comma)

Rewinds to beginning of Set Playback Range. 

11.14.5 Playback > Record 

Check to activate MIDI Record mode

11.14.6 Playback > External Timer 

Set recording to begin from an external signal.

11.14.7 Playback > Synchro Start 

Active only in Record Mode, check to synchronize start of MIDI 
recording with first note played on MIDI keyboard.

11.14.8 Playback > Thru

Allows MIDI input to sound

11.14.9 Playback > Metronome

Activates/ deactivates Metronome in recording

11.14.10 Playback > Playback Console (Ctrl + 9 / Cmnd+9)

Opens the Playback Console.

11.15 MIDI WINDOW Menu
See "ENF WINDOW Menu", Section 11.8, on page 235.
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11.16 IMAGE FILE Menu Items
11.16.1 File > New

Select between a new ENF or a new MIDI. Choosing New ENF will 
open the New SmartScore Document window. Select a Template or use 
Custom to create a unique score. Choosing New MIDI will open a 
blank MIDI Overview and Piano Roll for MIDI input.

11.16.2 File > Open (Ctrl +O / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file 
will be loaded into memory and will display on the screen. 

11.16.3 File > Save (Ctrl +S / Cmnd+T)

Writes currently displayed file to the hard disk. 

11.16.4 File > Save As

Opens Windows File Selection dialog box

Save processed or modified Image files to hard disk following Scan-
ning and Editing. Use to save selected files to directory other than the 
working directory.

11.16.5 File > Save As PDF

Saves currently open TIFF image as a PDF file (Windows requires 
PDF 995 from installer). 

11.16.6 File > Scan Music

Selects scanner or initiates scanner to acquire image.

11.16.7 File > Recognition

Initiates Recognition to begin processing saved image file(s).

11.16.8 File > Print (Ctrl +P Win / Cmnd+P Mac)

Initiates Windows Print Monitor. Current Image file is output to default 
printer from selected printer port. 
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11.16.9 File > CD Writer

Opens CD Writer / Burn window. See “File > CD Writer” on page 223.

11.16.10 File > Recent (1,2,3, or 4)

Automatically loads one of the last four files accessed by SmartScore 
(Win). Select any recent files by type (Mac)

11.16.11 File > Exit/ Quit (Cmnd+Q Mac)

Exit SmartScore. Save current file. Go to Windows main desktop.

11.17 Image EDIT Menu
11.17.1 Edit > Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine 
layers of Undo. 

11.17.2 Edit > Redo (Ctrl +Y / Cmnd+Y

Reapplies the last action that has been Undone. 

11.17.3 Edit > Cut (Ctrl +X / Cmnd+X)

Removes the selected section from the image file and places it on the 
clipboard 

11.17.4 Edit > Copy (Ctrl +C / Cmnd+C)

Places selected section on the clipboard without removing it from the 
image file. 

11.17.5 Edit > Paste (Ctrl +V / Cmnd+V)

Insert the contents of the clipboard back into the image file 

11.17.6 Edit > Delete (Del)

Deletes the selected section from the image file. 

11.17.7 Select All

Selects the entire image for moving / centering.
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11.17.8 Edit > Crop

Trims the image file down to the selected region

11.17.9 Edit > Invert

Switches the colors of the image file.

11.17.10 Edit > Rotate
• Left: Rotates the image file counter-clockwise
• Right: Rotates the image file clockwise
• Any: Opens the Rotate window for rotation by defines degrees.

11.17.11 Edit > Delete Page

Deletes currently displayed page. Does not delete the entire file.

11.17.12 Edit > Selection

Activates the Area Selection tool.

11.17.13 Edit > Line

Activates the Line drawing tool.

11.17.14 Edit > Brush

Activates the Brush tool.

11.17.15 Edit > Deskew

Activates the Deskew tool for straightening “crooked” scans

11.17.16 Edit > Selection Mode
• Opaque

When a selected area is moved to the clipboard the back-
ground will be included

• Transparent

When a selected area is moved to the clipboard only the black 
portion of the selected area with be moved.
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11.17.17 Edit > Pen Color

Select the color used by the Brush and Line drawing tools.

11.18 Image VIEW Menu
11.18.1 View > Navigator

Opens and closes the SmartScore Navigator.

11.18.2 View > Main Toolbar

Opens and closes Main Toolbar

11.18.3 View > SmartScore Toolbar

Opens and closes SmartScore Toolbar

11.18.4 View > Image Toolbar

Opens and closes Image Editing Toolbar

11.18.5 View > Status Bar

Opens and closes Status Bar at the bottom of main SmartScore Win-
dow. Displays current page, cursor position, image size, and zoom per-
centage.

11.18.6 View > Palettes 

Opens and closes tool palettes for ENF document editing.

11.18.7 View > Image Information 

Provides information on the structure and type of the currently dis-
played image file.

11.18.8 View > Next Page

Displays next page of ENF document

11.18.9 View > Previous Page

Displays previous page of ENF document
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11.18.10 View > Go to Page (Ctrl +G Win / Cmnd+G Mac)

Presents a dialog box to select a page number to jump to. Use scroller 
to select desired page and click OK. 

11.18.11 View > Zoom

Lists available view percentages. Changing zoom will affect both the 
image and the ENF file simultaneously. 

11.18.12 View > Reset Tools and Palettes (F1)

Resets windows, toolbars and palettes to their default position.

11.18.13 View > Reset Warnings

Resets warning messages to their default.

11.19 Image Realtime Menu
11.19.1 Realtime > Thru

Allows MIDI input to sound while recording.

11.19.2 Realtime > MIDI Devices

Opens MIDI Device window.
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Chapter 12 Glossary

12.1 Score Formats
Score - A musical piece compiled as a document. A score usually con-
tains more than one part with all the parts to be played together. In 
SmartScore, it is a single computer file; an ENF file. A hand-written 
score is called a manuscript.

Part - A part is represented by a staff line either alone (solo part) or 
grouped into a system with other instruments (ensemble part). A part is 
usually an single instrument, but in the case of two-handed instruments 
(piano, organ, xylophone, etc.), it may represent one hand’s part.

Voice - Derived from choral music but applied to instrumental music as 
well, contrapuntal voicing (sometimes referred to as polyphonic voic-
ing) refers to a unique melodic thread distinct from other voices in a 
measure by its harmonic direction and possibly its timbre. Contrapuntal 
voices reside in the same measure of the same staff. Voices are often 
distinguished by stem direction and sometimes by offsetting the hori-
zontal position of notes. For the purposes of SmartScore, a “voice” 
written in its own staffline is referred to as a “Part”.

Score-Part - Scores that are printed in sets for each individual instru-
ment. Players read from their own unique set of pages. For example, a 
duet for guitar and flute would be printed in two separate sets: one for 
the flute player and one for the guitar. Staves of part scores flow like a 
book where each staff line appends to the one above it. 

Ensemble - Scores that have multiple staff lines connected by a verti-
cal bar or “bracket” (usually along the left-hand edge of the music). 
When joined in this way, each staff line represents a different part or 
instrument. All parts are played “ensemble”. Piano music, (with left-
hand and right-hand staves) are joined into one system, is regarded as 
“ensemble”. SmartScore assigns each stave to separate MIDI tracks.

Landscape - Some scores are wider than they are high. These “land-
scape” layouts need to be rotated prior to processing.
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Folio - Large sized and conductor scores may need to be scaled down 
during scanning or reduced on a copy machine before scanning. If the 
score must be reduced more than 50% in order to fit the imaging area of 
your scanner, you may consider scanning each full-sized page twice 
and treat each scan as one “image-page”.

12.2 Score Components
System - A grouping of multiple staves linked together by a solid line 
or bracket along the left margin is called a “system”. All staves belong-
ing to a system are played simultaneously. In ensemble scores, each 
system appends to the one before it. A single page of a symphony con-
ductor's score, containing 10 or 20 staff lines per system, may represent 
only a few seconds of music!

Staff (Stave) - The field on which notes are represented is called a 
staff. “Staves” is normally used as the plural. At the core of every staff 
are five horizontal lines. Each successive line and space are equivalent 
to a full step in note pitch. The higher the note appears on the stave, the 
higher its pitch. Every staff line anomaly begins with a clef sign and a 
key signature.

Voiceline - An individual melodic line formed by a voice within one 
measure. When a staff contains more than one voiceline in any given 
measure, note stems of each voiceline usually point in the opposite 
directions. The sum of all note and rest values of each voiceline in any 
given measure should be accounted for, but sometimes are not. Refer to 
“Working with Contrapuntal Voices” on page 151 for more on dealing 
with this rule in SmartScore.

Clef - The clef sign at the beginning of each stave identifies which 
pitch “class” that stave belongs to. The lowest instruments are written 
in the bass clef, intermediate instruments and voices often use one of 
three “C” clef classes while higher-pitched instruments, in addition to 
the right-hand part of a piano score, are scored in the treble clef. The 
clef sign always appears at the beginning of every staff line and in the 
first measure if a change of clef occurs. Change of clef signs are smaller 
than normal clefs.
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Key Signature - The key signature, along with the clef sign, appears at 
the beginning of every line; it is also found in the measure where a 
change of key occurs. The key signature defines the “tonal center” of 
the piece. The number of sharps or flats in the key signature determines 
the key tone (or tonic).

Time Signature - Time signatures usually appear only once: at the 
beginning of the stave in the first measure of the piece. They will also 
appear when a change of time signature occurs. Time signatures indi-
cate both the number of beats per measure (numerator) as well as which 
note value is given the fundamental beat (denominator). The sum of 
note duration values in a given measure must equal the value of the cur-
rent time signature.

Note - A note is the fundamental unit of tone. The duration of a note is 
determined by its note value (normally between 1 and 128 divisions). 
The note’s vertical position on a given staff (with clef) determines its 
pitch. 

Rest - Rests are equivalent to notes insofar as their durations; but repre-
sent silence. They act as “place-holders” used to keep the rhythmic 
structure of the measure intact. 

Measure - Staff lines are segmented into equal time divisions called 
measures. Measures are the building blocks that provide structure for 
music. The sum of note and rest durations within each measure must 
equal the value of the current time signature

Barline - Barlines are the vertical lines that define the beginning and 
ending of measures

Accidental - Note pitches often range outside of the tonal center 
defined by the key signature. An accidental shifts its associated note up 
(sharp) or down (flat) by 1/2 step. Accidentals may also be doubled. An 
accidental remains effective only for the remainder of the measure in 
which it appears. A natural “cancels” a note’s current accidental.

Dot of Prolongation - Notes and rests that are dotted have the value of 
their duration lengthened by 1/2. For example, a dotted quarter note is 
equal in duration to three eighth notes. Double-dotted notes increase 
the note’s duration by 3/4 of the original.
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Tuplet - Some notes belong to a special readmit class called “tuplets”. 
These include triplets, quintuplets and sextuplets. A tuplet is a group of 
notes, usually marked with a bracket, that are subdivided within a sin-
gle beat, equal in duration to the note’s next higher value. For example, 
a triplet of three eighth notes is equal in total duration to one quarter 
note

Ties - A tie links two pairs of notes of the same pitch whose durations 
are combined so that both notes are played as if one note. Ties are often 
used to sustain the sound of a note across more than one measure. 

NOTE:Ties and slurs (legatos) often look alike, but they are different. 
Ties connect two notes of the same pitch and combine their durations 
into one note event and slurs connect two or more notes over a range of 
pitches forming a legato that when performed, creates a slight overlap-
ping of the notes. 

Articulations - Performance markings that provide instructions for 
playback of the marked notes. For example, a staccato, a dot placed 
above/ below a notehead, means the note should be short, sounding for 
only a moment. 

Dynamics - Dynamic markings are used to denote the general volume 
and intensity of music. For example, “f” or forte means loud and “p” or 
piano means soft.

12.3 MIDI Terms
MIDI- Musical Instrument Digital Interface. Originally a hardware 
device that allowed a computer and a synthesizer to communicate, now 
a generally accepted term for hardware or software that operate accord-
ing to General MIDI standards.

Standard MIDI File (SMF) - The file protocol or format for music 
files saved as MIDI (.MID extension). Includes Type 1 (multiple track / 
multiple channel) and Type 0 (single track / multiple channel) formats.

Sound Device- A MIDI driven tone generator. Sound cards, synthesiz-
ers, and MIDI modules all fall under this category.
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MIDI Event - Each piece of information contained within a MIDI file 
is an event. This includes Notes (attack and release), Control Changes, 
System Exclusive, Meta Events, Program Changes, etc.

Velocity - The speed at which the note was struck, measured with a 
number from 0-127.

Channel -A MIDI device sends and receives MIDI information along 
separate and distinct Channels. Each channel contains note and non-
note event data. Most MIDI devices can support up to 16 MIDI Chan-
nels at one time.

Patch - Every MIDI channel has a MIDI patch assigned to it. A Patch 
is the instrument sound selected for a particular channel when playing 
back.

Program Change - Same as a patch. Indicates a change of patch within 
a given channel or track.

Bank - MIDI devices divide patches into groups of 128. One Bank of 
patches from a MIDI device can be accessed at a time by a MIDI com-
puter program or another MIDI device.

Port - A computer can run several MIDI devices at a time with the 
proper hardware. Each device is connected to a unique Port.

12.4 SmartScore Terms
ENF - Extended Notation Format. This is SmartScore’s proprietary file 
format. 

Navigator - The floating window containing buttons designed to “nav-
igate” through SmartScore’s main features and editing environments. 

System Manager - The System Manager is a sort of “virtual system” 
which allows for manipulating all or specific voices, parts and systems 
in the score. It contains the parts and voices that make up the active sys-
tem. The Super System, within it, contains ALL possible parts.

Voice Line Threading - SmartScore will differentiate multiple voices 
within a single staff line by displaying them in different colors (Voice 
1-black, Voice 2-red, Voice 3-green, and Voice 4-blue) while, at the 
same time, creating an independent MIDI channel for each voice. .
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Index

A
accaciatura 130, 214
accent

editing 134, 135
playback 216

accidentals 251
accidentals, editing 88
accuracy, recognition 41, 45
active staffline 10, 83, 214, 231

lock / unlock 154
active system 78
add new page 84
Apply To

System Manager 159
Apply-New 160
arpeggio 136
articulations 131, 252

deleting 136
editing 134
multiple

inserting or deleting 137
palette button 216

Associate Image Files 232
Audio MIDI Setup 52
Auto Save 214
Auto-Beaming 147
Auto-Spacing 148

B
barlines 251

bracketing 113
deleting end of staff 92
editing 92
repeat 71

repositioning measures 127
beaming flagged notes 142
beams

Auto-Beam 147
creating 91
cross-measure 155
cross-staff voicing 153
reshape 127

Begin Recognition Window 8
BMP 38
bowings 34
bracketing 112

C
CD Writer 223
centering music for printing 163
change

beamed note 91
notes and symbols 87

chord cluster 90
splitting into voices 67

chord symbols 107
changing 110
creating 108
display 213
fret editor 108
inserting 107
moving 111
preferences 213
recognizing 33, 35
scaling 111

classical guitar notation 22
clefs 250

editing 218
transposition 148
unifying 145

cluster, chord 90
Coda 74
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coda 66
collapsed systems 78
color

MIDI channels 214
overriding automatic color 152
preferences 214

conductor score from parts 33, 40, 
121
contrapuntal voices (see also 
"voicelines") 13, 151
Copy 225

ENF region to clipboard 96
courtesy accidentals 89
crescendos and decrescendos

hiding 162
inserting 133
properties 61

Crop 45
cross-measure beaming 155
cross-staff voicing 153

locking the active staff 154
preferences 213

D
da Capo 75
dal Segno 75
darkness, scanning 30
defaults, restoring 9, 214
delete 87, 141, 142

beamed note 91
entire system 142
selected group of objects 142
when all else fails (Tip) 142, 

231
display, page view 84
document layout 163

custom 164
document preferences 213

dot of prolongation 90, 251
delete 15

drums
automatic drum patterns 207
virtual 210
working with 205

dynamics 56, 130, 131, 252
inserting 132
properties 62
range 162

E
EDIT menu 224
endings 34, 72
ENF 83, 253

add new page 84, 228
adding or removing parts 160
associate view with image 232
bracketing 112
cascade windows 236
clone document 236
copy region to other programs 

96
creating from scratch 97
Cut, Copy and Paste 224
editing files 9
editing scanned files 31
Graphical Controllers 63
paging 125
playback 53
Preferences 213
reformat 228
respacing 118
saving and exporting 98
score header 102
score templates 98
scrolling 125
status bar 85
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System Manager 155
tempo marking 229
tile windows 236
to CD 223
warning preferences 215
Zoom 84, 178, 180

ENF - MIDI
remove articulations 222

ENF playback 51
real-time settings 54

ensemble 249
creating part scores from 122

errors, rhythmic 89
expanded systems 78
exporting ENF files 98
expressions 57, 134
Extended Notation Format 9
extract parts and voices 157
extracting parts and voices 20

Apply-New 160

F
fermata

editing 134
playback 216

file formats 98, 221
FILE menu 221
Finale

exporting to 99
Fine 75
flagged notes

beaming 142
folio 250
fonts

changing style 105
setting default style 213

format / reformat score 117, 228

G
glissando 136
Go to… 126
grace notes 130, 214
Graphical Controllers

ENF 63
MIDI 180

greyscale thresholding 49
guitar fret symbols

see chord symbols 213
guitar, tutorial 22

H
hairpin

inserting 133
properties 61

Help 236
Hidden Symbols 162
hymnals 71

I
Image Editor 44

Cut/ Copy and Paste 48
grey thresholding 49
image info 44

indent, first system 167
insert 141

beamed note 91
inserting new systems 227
Installation 7
Instrument Templates 76, 160
instruments

selecting for playback 14, 68
Invert Image 29

J
Jumps 71
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K
Karaoke view 66

preferences 214
key signature 137, 251

change 137
unifying 145

key transposition 95, 148

L
landscape 249
Long view (horizontal display) 84
lyrics 103

default font preferences 213
font size and style 105
recognizing 33
show/don’t show 213, 232
when found under last staff 33

M
Macintosh / Windows shortcut 
conventions 9
map, Quick Keys 171
measure number

display 213
measures 251

error 89
pickup 66
resizing 127
shuttle between systems 127
split 66

merging
systems 77

metronome markings 131
MIDI

bank 253
channel 253
closing MIDI views 174
Cut/Copy and Paste 186

display controls 195
Event List 191
event selection 183
Graphical Controllers 180
importing files 167
inserting note events 192
Instrument settings 182
measure settings 187
metronome 196
note characteristics 184
Note Event 186
patch 181, 253
playback 175
playback range 177
port 253
program change 181, 253
recording 196

new tracks 198
repeats and endings 189
select by time frame 184
selecting view 173
Setup 51
Show Actual Playback 177, 

240
shuttle tool 180
snap to 198, 241
Step Time Recording 200
switching tracks 177
synchronize views 240
Track Overview 174
velocity 253
velocity and duration 185
virtual drums 241

MIDI Devices 176
MIDI Event 253
MIDI Files

burn to CD 223
opening from ENF document 
USING SmartScore 257
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234
MIDI instruments

assigning 156
MIDI Menu Items 237
MIDI Setup

Mac 52
MIDI to ENF 167
miniatures, scanning 31
Mini-Console 53
modes

Hidden symbols 162
Insert/Change 87
Lyric 103
Nudge 126
Text 101

mordent
editing 134
playback 217

Music XML 215
MusicXML 99

N
navigating around ENF 83, 125
Navigator 144, 253
NIFF 222
normalize graphical controllers 
63
notes 141, 251

adding to existing 90
adjusting stems 127
associated with lyric block 103
Auto-spacing 148
change 87
changing pitch 85, 126
changing values 141
color 151
color properties 214
deleting 87

dotted 90
editing beamed 91
editing clusters 90
grace notes 130
insert, change & delete 141
inserting 86
inserting and changing 87
moving horizontal 126
overlap default 213
overlap or offset 155
properties 59
punctuation 127
splitting 68
stem direction 87, 143
swap position of 153

Nudge mode 126
barlines 120, 127
moving multiple symbols 126
repositioning measures 127
reshaping angles 127
special functions 128
text 102

O
online help 237
optimized scores 78
optimized systems 226
Ossia 140
overlap/offset notes 155

P
page margins display 214
page number display 214
Page Setup 163

Center on Page 163
simple centering 96

page type 167
preferences 214
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page view button 84
Paint brush (free draw) 46
part linking 78, 93
parts 249

adding to score 158, 160
extracting 115, 157
insert or remove from system 

140, 227, 254
merging separated systems 77
naming in System Manager 156
re-linking / optimized 78, 159
removing from score 159
show names in ENF 232

Paste 225
Paste / Replace 225
PDF

recognition of 38
Save as 96

pedals 34
Percussion clef 205, 219
Piano Roll 177
pickup measures 65, 66
pitch shift (see Nudge) 126

select range 254
selected notes 142

Playback
re-linking parts 77
selecting a range 16, 55
tempo 53
transposing 53

Playback Console 194
polyphonic voices 13
Preferences

Document 213
Program 214

Print Preview 96, 163, 223
printing 96

centering pages 163

Program Change
Event List 194
Piano Roll 181

Program change 253
Program preferences 214
Properties

Barline 65
Note 59
playback 59
Staff line 93

Properties tool, playback 15
punctuation 127

Q
quantization 241
Quick Keys 85, 140

Barlines 92
Beam Direction 143
Dots 142
Dynamics 130
Note Values 137
QuickSelect 140
Rests 86
Select Tool 141
Stem Direction 143
Ties 143
Tuplets 130
Vertical Alignment 70, 152

Quick Tour 7
Quick-Select 86

R
recognition

adding a staff missed by 81
bowings 34
endings 34
fretboard 35
heavy beam 34
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hymnal fonts 34
join offset voices 34
lyrics and text 33
lyrics under every staff 33
optimized scores 35
options and preview tabs 33
pedals 34
poor 30, 41
pre-scanned music 38
sample files 7
System Report 8, 214
triplets 34

record a CD 223
record new MIDI track 198
reformat score layout 213, 228
registration, product 237
rehearsal symbols 213
Re-link parts 78

after Unify 145
before inserting staff 81

repeat endings 73
Repeat previous measure mark 71
repeated verses and sections 71
reset windows and palettes 88
Resolution, scanning 31
rests 141, 251

associated with lyric block 103
moving horizontal 126
multi-measure 141

Rotate scanned image 48
ruler preferences 214

S
Save ENF 98
scan view window 83, 125

display 234
floating 236
split control 236

split-screen 125
scanning music 27

choose interface 28
converting grey images 49
Macintosh 31
manual/automatic 31
outside of SmartScore 36

score
create from scratch 98
display 84
formats 249
header 102
reformatting 117

Score Structure 120
Score-Part 121, 227, 249

scanning in 40
screen grab 96
Segno 74

Piano Roll 189
Select tool 11, 12, 141
shift pitch 14
shortcut conventions 9
Sibelius

exporting to 99
signatures 137

unifying 145
Slur 216
slurs

editing 134
playback 216
properties 60
reshaping 127

soft accent
playback 216

solo violin tutorial 22
spacing

single staff or system 117
staff and system 118
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unify 119
split measures 66
split pane tool 83
staccato

editing 135
playback 216

staff 250
active 231
adding a part 158
resizing 118
when not recognized 81

stem direction
changing 87, 143

Step Time Recording 200
Super System 158
symbol preferences 213
symbol select 86
symphonic music

adding missing parts 158
system 250

apply changes to 159
changing widths 120
display preferences 213
indent first 167
insert above/below/remove 227
merging 77
re-linking parts in 78
resize staff sizes 12
respacing 118
split 66

System Manager 155, 253
part extraction 115
Part Names 156
reformatting 115
Visibility 157
voice extraction 116

System Options 98, 139
System Report 36

System+, apply changes to 159

T
Task Window 8, 214, 235
tempo

change mark (metronome) 131
change of 57
markings 57
properties 61, 132
setting default 57, 229
slider 188

Tempo Controller
ENF 63
MIDI 180

tenuto
editing 135
playback 216

Text
deleting 101
Document preferences 213
editing 101
font size and style 105
nudging 102
repositioning 127

ties 15, 90, 252
tiling views 146
time signature 137, 251

change 137
at end of line 138

unifying 145
Tool palettes 129, 215

resetting 88
Toolbars 230
transposed instruments 76, 161
Transposition 95, 148
tremelo 135

beamed 136
playback 218
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trill
editing 135
playback 217
properties 62

trills and mordents 134
triplets 34, 58

change bracket type 213
implied 34
nested 58

tuplets 252
user-defined 58

turn
editing 134
playback 216

U
Undo 88
Unify key, time and clefs 144
updates, online 237
user interface preferences 214

V
Velocity Controller

ENF 63
MIDI 180

velocity, note 253
verses, repeated 71
vertical alignment 34

correcting 69
verifying 105, 153

View > Scan View Window 84
View > Show Long View 83
views, tiling 146
violin, solo 22
Visibility 115

Extracting parts with 115
extracting voices with 116

voice color 11

voice visibility 67
voiceline 89, 151, 250

threading 19, 253
visibility 157
visiting another staff 153

voices 249
affecting playback 67
assigning instruments to 68, 

156, 181
color 151
extracting 116, 157
gluing and ungluing 70, 152
offset 34

swap position 153
polyphonic 19
splitting 67
using hidden rests 162
vertically aligning 70, 152

W
window synchronization 84

Z
Zoom

ENF 84
preferences 214
Scan Window 84
screen size 214
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