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Chapter 1  
Using This Guide 

Introduction 
The M-Explorer User’s Guide provides information about how to use 
the M-Explorer software application. This chapter outlines the guide’s 
organization and content. 

© January, 2001 Johnson Controls, Inc.  www.johnsoncontrols.com
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Key Concepts 
Chapter Organization 

Each chapter of this M-Explorer User’s Guide contains five sections as 
described in Table 1-1. 

Table 1-1: Chapter Organization 
Section Description 
Introduction Briefly outlines the contents of the chapter. 
Key Concepts Describes background information necessary to 

perform or understand specific tasks. 
Procedure Overview Describes general steps for performing the 

tasks described in the Detailed Procedures 
section. This section is geared toward users 
already experienced in using M-Explorer. This 
section may be used as a quick reference 
guide. 

Detailed Procedures Describes in detail the steps needed to 
complete specific tasks described within the 
chapter. This section is geared toward users 
who are new to M-Explorer. 

Troubleshooting Provides information on potential problems, as 
well as methods for solving them. 

 
A section is omitted if it is not necessary for a particular chapter. For 
example, this chapter, Using This Guide, does not contain a Procedure 
Overview section. 

Online Help 
The M-Explorer application includes online help. To access the Help 
screens, select Help from the menu bar, or press the F1 key, or press 
Alt + H. Help describes the basic procedure for performing functions 
within the M-Explorer software. The online help system for 
M-Explorer is a cross platform help system that follows the basic 
conventions of Windows® 98 and Windows NT® help systems, but 
also incorporates some of the features of the HyperText Markup 
Language (HTML) help used in Windows 98 programs. 

Manual Conventions 
As in most Windows-based programs, sometimes there are multiple 
ways to perform the same tasks. This manual does not describe how to 
use both the mouse and the keyboard to perform the same step. In 
general, use Microsoft® conventions to describe software features. 



M-Explorer User’s Guide     2-1 

Chapter 2  
Introduction to M-Explorer 

Introduction 
M-Explorer is a software application for browsing a hierarchy of 
online objects in controller subsystems. This chapter describes: 

• system component interaction 

• Object Linking and Embedding (OLE) for Process Controls (OPC) 
Data Access Servers 

• M-Inspector 

• M-Password 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153410 
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Key Concepts 
System Component Interaction 

M-Explorer interacts with various system components to provide a 
comprehensive user interface for working with objects. These 
components include: 

• OLE for Process Controls (OPC) Data Access Server provides 
dynamic data values from the controllers for the M-Explorer 
display. 

• M-Inspector allows detailed object viewing and data manipulation. 

• M-Password determines what data M-Explorer can access and 
what actions may be performed based on the currently logged in 
user. 

OPC Data Access Servers 
An OPC Data Access Server is a communications server providing 
access to data in a generic way so that the client does not require 
knowledge of the underlying subsystem. The OPC Data Access Server 
provides an interface for browsing the subsystem to view object values 
and status, as well as for reading and writing data values. 
The existence of OPC Data Access Servers allows M-Explorer to 
access data from controller subsystems. Subsystems are sets of objects 
having similar physical or logical separation in terms of connection, 
protocol, or vendor. Examples of subsystems include BACnet® 
networks, Companion™/Facilitator™ Panel units, or N1 networks. 
Each existing controller subsystem with a separate OPC Data 
Access Server displays in the M-Explorer workspace as branch items 
in the Tree view. Examples: JC.BNOPC, JC.CFOPC, or 
JC.N1OPC. M-Explorer automatically recognizes registered 
OPC Data Access Servers upon startup. 

M-Inspector 
M-Inspector is a tabbed dialog application presenting detailed 
information about a selected object. 
Launch the M-Inspector application from M-Explorer via the Actions 
menu of M-Explorer, from a pop-up menu in the Tree or Focus view, 
or from an M-Graphic display. 
Refer to the Using M-Inspector chapter of this document for details. 
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M-Password 
M-Explorer supports the restriction of certain user activity as 
established by the M-Password component. According to M-Password 
configuration, M-Explorer: 

• filters out any object names for which the current user does not 
have access and does not display the object names. 

• restricts access to menu items. For example, a restricted Print 
option appears grayed out on the File menu. 

Note: Individual Action menu options (such as Inspect, Connect, or 
Disconnect) cannot be disabled, although the main Action 
menu can be completely disabled. 

In addition, while launching M-Inspector outside of the M-Explorer 
application, the M-Inspector launch fails if inspecting an object with 
restricted access. 
Refer to the M-Password Technical Bulletin (LIT-1153150) in the 
M-Series Workstation Manual (FAN 1153.2) for more information. 
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Chapter 3  
Getting Started 

Introduction 
M-Explorer displays online objects similarly to Microsoft Windows 
Explorer. 
This chapter describes how to: 

• start M-Explorer as a standalone application 

• start M-Explorer as a workspace in the M3 Workstation 

• start M-Explorer from an icon on the M5 Screen Manager Bar 

• change object status color coding 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153415 
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Key Concepts 
M-Explorer User Interface 

Figure 3-1 shows the standalone M-Explorer application labeled with 
callouts. Table 3-1 describes the various parts, views, and items of the 
application labeled by the callouts. 
 

 

Figure 3-1: M-Explorer User Interface 
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Table 3-1: M-Explorer Main Window Callouts 
Callout View/Item Description 
1 Title Bar Displays the name of the currently opened M-Explorer document. 
2 Menu Bar Provides access to top level M-Explorer menus. 
3 Tool Bar Provides one button access to commonly used tools. 
4 Full Reference 

Line 
Displays the complete hierarchical path or full reference for the currently 
selected item in the Tree or Focus view. 

5 Tree View Occupies the left window within M-Explorer and allows the user to open and 
close branch items in the system hierarchy. 

6 Focus View Occupies the right window within M-Explorer and displays the contents of the 
branch selected in the Tree view. A scroll bar appears if the information 
shown does not fit in the current dimensions of the window. The Focus view 
displays items in either Details view or Large Icon view. Choose the view 
options from the View menu, toolbar, or pop-up menu. 
Details View – Objects display as a list with columns for Label, Status 
(current), Value (current), Name, and Description. The appearance of the 
status text follows the status color coding scheme. By default, objects appear 
in the order returned by the OPC Data Access Server. 
Icons View – Objects display from left to right and top to bottom in the same 
order as the Detailed view. The label, current value, and current status of the 
item appear underneath the icon. The appearance of the status text follows 
the status color coding scheme. 

7 Branch Item Appears in M-Explorer, in both Tree view and Focus view, as an item 
containing other items (analogous to a directory in Windows Explorer). 

8 Leaf Item Appears in M-Explorer as an item not containing other items (analogous to a 
file in Windows Explorer). Leaf items represent data values. 

9 Status Bar Describes how to access Help and displays the number of objects currently 
appearing in the Tree view or contained within the selected Branch item. 
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M-Explorer Menus 
Table 3-2 describes the menus and commands available from the 
M-Explorer application. 

Table 3-2: M-Explorer Workspace Menu Options 
Menu Command Description 
File New Creates a new M-Explorer document. 
 Open . . . Opens an existing M-Explorer document. 
 Save Saves the current state of M-Explorer as a document using the current file 

name. 
 Save As . . . Saves the current state of M-Explorer as a document to a selected 

directory with the .mxp extension. 
 Print . . . Prints the information appearing in the Focus view. 
 Print Preview Shows how a document prints if the user selects the print command. 
 Print Setup . . . Opens the Print Setup dialog box for the current printer. 
 Recent File Reopens a previously accessed document. 
 Exit Closes the M-Explorer application. 
View Toolbar If checked, the toolbar is visible; otherwise the toolbar is hidden. 
 Status Bar If checked, the status bar is visible; otherwise the status bar is hidden. 
 Icons View Changes the object representation to icons in the Focus view. 
 Details View Changes the object representation to a list with columns in the Focus 

view. 
 Refresh Rereads the items in the currently selected branch to show objects added 

or removed from a branch since the branch was first opened. 
 StatusColors Opens the M-Explorer Properties dialog box. 
 AutoRefresh Automatically updates M-Explorer View. 
Actions  Provides a set of actions to perform on the currently selected item. 

Note: When selecting Companion points, the Actions menu is not 
available. 

 Inspect Provides access to the M-Inspector window when selecting an item with 
inspecting capabilities in M-Explorer’s Tree or Focus view. 

Connect  
Disconnect 

Connects or disconnects communication to a site when selecting a site in 
either the Tree or Focus view. 

Help Help Topics Opens the online help file for M-Explorer. 
 About M-Explorer . . . Displays M-Explorer’s copyright and version information. 
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M-Explorer Toolbar 
Table 3-3 describes the use of the toolbar buttons available from the 
M-Explorer workspace. 

Table 3-3: M-Explorer Workspace Toolbar Buttons 
Button Name Description 

 

Up One Level Closes the current item and returns to the previous item in the hierarchy. 

 

Icons Displays items as icons in the Focus view. 

 

Details Displays items in a list with columns in the Focus view. 

 

View Refresh Rereads the items in the currently selected branch to show objects added 
or removed from a branch since the branch was first opened. 

 

Print Prints the information in the current M-Explorer Focus view. 

 

About Shows software version number and copyright information. 

 

Inspect Opens the M-Inspector window. This button only appears on the toolbar 
when selecting an item with inspecting capabilities in M-Explorer’s Tree or 
Focus view. 

 
Connect 
Disconnect 

Connects or disconnects communication for a selected item such as a 
site. These two buttons only appear on the toolbar when selecting an item 
with connecting or disconnecting capabilities in M-Explorer’s Tree or 
Focus view. 
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Details View Columns 
In Details view, the Focus window shows object/point data organized 
into five columns. Adjust columns by moving the column header 
boundaries with the mouse. Sort objects based on the values shown in 
a column by clicking the column header. Change the column order by 
dragging and dropping the column header left or right. Table 3-4 
describes the Details view column headings. 

Table 3-4: Details View Column Headings 
Column Description 
Label Lists the names of the items contained within the selected 

branch item. 
Status Status information depends on the OPC Data Access Server 

supplying the data. Refer to Appendix A: BACnet OPC Data 
Access Server, Appendix B: Companion/Facilitator OPC 
Data Access Server, and Appendix C: N1 OPC Data Access 
Server in this document for details. 

Value Lists the present value of the object, attribute, or point. 
Name Lists the full reference of each item (container, objects, 

attributes, points). Use the string for Leaf items to bind in the 
M-Graphics application. 

Description Lists the same information appearing in an object’s optional 
Description attribute or any additional description for a point. 

 

Label Icons/Symbols 
In addition to the name listed in the Label column, M-Explorer also 
represents each object/point with an icon based on its object/point 
type. Different icons appear for the different OPC Data Access Servers 
available. Refer to the appendices in this guide for details. 
A colored symbol based on the data type represents each object/point 
attribute: 

• String = Cyan (light blue) 

• Integer = Light green 

• Boolean = Black 

• Float = Red 

• Complex = Blue 
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Pop-Up Menus 
A right-click of the mouse on an item in either the Focus view or the 
Tree view brings up a pop-up menu. The available options depend on 
what type of OPC Data Access Server provides the data. Refer to the 
appendices in this guide for details. 

Browsing Guidelines 
Since M-Explorer behaves similarly to Microsoft Windows Explorer, 
browsing occurs in much the same way as well. Here are guidelines 
for browsing in M-Explorer: 

• When branch items in the Tree View contain other items, a + 
appears to the left of the branch. 

• To view the items contained in a branch item, either click the + to 
the left of the branch or double-click the branch. 

• To close an open branch item, click the – that appears to the left of 
the branch or double-click the branch. 

• Branch items without sub-branches do not have a + to the left of 
the branch or the + may appear at first, but disappears when the 
branch item is clicked. 

AutoRefresh 
The AutoRefresh feature automatically updates the current values from 
the controller. Refresh manually is the Default. On the View menu, 
select AutoRefresh to activate the AutoRefresh feature. When viewing 
third-party controllers with a large number of objects (appearing in a 
flat list), we recommend turning off the AutoRefresh feature to 
improve performance. 

Status Color Coding 
M-Explorer uses color coding to indicate five levels of object status, 
meaning the color of the text and background of the object name 
indicates the current condition of the object. Status color coding 
appears for objects in both the Details view and the Icons view. These 
settings are applied globally to the entire M-Explorer application. See 
the procedure to change status color coding in this document. 
Table 3-5 describes the default color coding scheme. 
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Table 3-5: Status Color Coding Scheme 
Status Category Text Display Properties 
Communication Problem White letters on black background 
Overridden/Unknown Black letters on gray background 
Alarm Condition Yellow letters on red background 
Warning Condition Blue letters on yellow background 
Normal Condition Black letters on white background 

 

Dynamic Data Display 
M-Explorer updates dynamic values as soon as the OPC Data Access 
Server reports the value change. Users see these values change as they 
browse object data in the M-Explorer user interface. Refresh the 
display only if there are changes to the object hierarchy structure 
within the OPC Data Access Servers. 
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Procedure Overview 
Table 3-6: Getting Started 
To Do This Follow These Steps: 
Start M-Explorer as a 
Standalone Application 

On the Windows Start menu, select 
Programs > Johnson Controls > M-Explorer. 

Start M-Explorer as a 
Workspace in the 
M3 Workstation 

With the M3 Workstation application open, 
select Add Workspace from the M3 Options 
menu. Select Johnson Controls M-Explorer 
Display from the list. Click OK. 

Start M-Explorer from an Icon 
on the M5 Screen Manager Bar 

From the M5 Screen Manager Bar, click the 
icon for M-Explorer. 

Change Object Status Color 
Coding 

From the View menu, select StatusColors. In 
the Property Name field, click the drop-down 
arrow to view the available options. Select the 
desired Property Name option from the list. 
Select the desired color from the pallet, or click 
the drop-down arrow in the System Color field 
and select a system color. Click Apply. Click 
OK. 

 



 M-Explorer 3-10 

Detailed Procedures 
Starting M-Explorer as a Standalone Application 

To start a standalone M-Explorer application: 
On the Windows Start menu, select Programs > Johnson Controls > 
M-Explorer. 

Starting M-Explorer as a Workspace in the M3 Workstation 
To start M-Explorer from M3 Workstation: 
1. Open the M3 Workstation application. 
2. Select Add Workspace from the M3 Options menu. The Add 

Workspace window appears (Figure 3-2). 

 

Figure 3-2: Add Workspace Window 
3. Select Johnson Controls M-Explorer Display from the list. 
Note: To locate a specific file to appear in the workspace when 

adding the file, click Browse to make the Open dialog box 
appear. Locate and select the file, then click Open to return 
to the Add Workspace dialog box. 

4. Click OK. The M-Explorer workspace appears within the 
M3 Workstation display (Figure 3-3). 
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Figure 3-3: M-Explorer in M3 Workstation Display 
Note: Adding multiple M-Explorer workspaces on large databases 

may cause the system to freeze. This problem has occurred 
when browsing the JC.CFOPC server with Companion 
databases larger than 600 points. 
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Starting M-Explorer from an Icon on the M5 Screen Manager Bar 
To start M-Explorer from the M5 Screen Manager Bar (Figure 3-4): 
Click the icon for the M-Explorer application. 

 

Figure 3-4: M-Explorer on the M5 Screen Manager Bar 

Changing Object Status Color Coding 
To change object status color coding: 
1. From the View menu, select StatusColors. The M-Explorer 

Properties window appears (Figure 3-5). 

 

Figure 3-5: M-Explorer Properties Window 
2. In the Property Name field, select an option from the drop-down 

list. 
Table 3-7 describes the Property Name options. 
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Table 3-7: Property Names for Status Color Coding 
Property Name Description 
Alarm – BackColor Alarm Background Color 
Alarm – TextColor Alarm Text Color 
CommProblem – BackColor Communication Problem Background Color 
CommProblem – TextColor Communication Problem Text Color 
Normal – BackColor Normal Background Color 
Normal – TextColor Normal Text Color 
Override – BackColor Override Background Color 
Override – TextColor Override Text Color 
Warning – BackColor Warning Background Color 
Warning – TextColor Warning Text Color 

 
3. Select the desired color from the pallet or the drop-down list in the 

System Color field. 
Note: By selecting a system color, the M-Explorer color properties 

automatically follow these settings as configured in the 
Windows Control Panel. 

4. Click Apply. 
5. Click OK. 
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Troubleshooting 
In the M-Series Workstation, OLE for Process Control (OPC) servers 
such as the BACnet OPC server, Companion/Facilitator OPC server, 
and the N1 OPC server may not appear as points within the root level 
of the M-Explorer tree. This occurs when M-Password is configured 
incorrectly. Configure M-Password to grant access to OPC servers 
(points). 
To configure points in M-Password: 
1. Log in as Administrator to the M-Password Configuration 

software. Refer to the M-Password Technical Bulletin 
(LIT-1153150). 

2. Select Edit > Default Group. The Default Group Properties Page 
appears (Figure 3-6). 

Note: To edit individual group properties, select the group and 
select Edit > Edit. The Group Properties Page appears. To 
edit individual user properties, select the user and select 
Edit > Edit. The User Properties Page appears. 

 

Figure 3-6: Default Group Properties Page 
3. Select the Points tab (Figure 3-7). 
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Figure 3-7: Default Group Properties Page – Points Tab 
4. In the Include edit box of the Points tab, perform one of the 

following options: 

• enter * to grant access to all OPC servers (Figure 3-7). Use this 
option when users or groups need access to browse all OPC 
servers and restricting access is not needed for security. 

• enter or browse to the desired OPC server point name 
(i.e., JC.BNOPC) to grant access to only certain OPC servers 
(Figure 3-8). Use this option when OPC server access for users 
or groups must be restricted for security. The user or group can 
browse only the OPC servers to which they were granted 
access. 

Note: When granting access to individual users or groups, access is 
least restrictive. 
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Figure 3-8: Default Group Properties Page – Points Tab 
5. Click Add. 
6. Enter other OPC server point names as desired and click Add. 
7. Click Apply. 
8. Click OK. 
9. Select File > Exit to close M-Password. 
After granting access to the OPC servers in M-Password, open the 
M-Explorer software to browse them. Figure 3-3 is an example of an 
M-Explorer tree granting access to browse the BACnet OPC server 
and the Companion/Facilitator OPC server. 
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Chapter 4  
Working with M-Explorer 
Documents 

Introduction 
M-Explorer allows its current browser state to be saved at any point. 
The saved browser state is an M-Explorer document and has an 
.mxp extension. 
This chapter describes how to: 

• save the current browser state of M-Explorer as a document 

• launch an M-Explorer document 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153420 
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Key Concepts 
Save Options 

By saving the current browser state of M-Explorer, a user can quickly 
access data that may need frequent monitoring and can easily 
customize the browser for specific data. For example, a user can: 

• Check an object with a detection alarm every day. 

• View data efficiently with a Detailed view sorted by Status and 
with the Focus view splitter window moved over to the left. 

• Save the browser state as a document at this exact point with these 
exact settings. 

The information saved in an M-Explorer document includes: 

• open branches in the Tree view 

• currently selected branch item shown in the Focus view 

• Focus view selections (details vs. large icon) 

• location of splitter window boundaries 

• location of columns and column boundaries within the Details 
view 

Notes: M-Explorer documents do not save changes to object status 
color coding settings. These settings are globally applied to 
the workstation. 
 
Make sure M-Explorer Documents (*.mxp) appears 
in the Save as type field to save the current browser state of 
M-Explorer as a document. 

Launch Options 
The flexibility of the M-Explorer application allows access to 
M-Explorer documents in a variety of ways. 
Launch an M-Explorer document by: 

• double-clicking the document name from a file browser such as 
Windows Explorer 

• selecting the Open option on the File menu from the M-Explorer 
application or from an M-Explorer workspace (described later in 
this document) 

• double-clicking a shortcut icon to the M-Explorer application on 
the Windows Desktop 
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Procedure Overview 
Table 4-1: Working with M-Explorer Documents 
To Do This Follow These Steps: 
Save the Current Browser 
State of M-Explorer as a 
Document 

From the File menu, select Save As. The Save 
As dialog box appears. If necessary, browse to 
a different location to save the document using 
the drop-down arrow in the Save in field, the 
Up One Level button, or the Create new folder 
button. In the File name field, type a name for 
the document, keeping the .mxp extension. 
Make sure M-Explorer Documents 
(*.mxp) appears in the Save As type field. 
Click Save. 

Launch an M-Explorer 
Document 

From the File menu, click Open. Make sure 
M-Explorer Documents (*.mxp) appears 
in the Files of type field. Select the desired 
document via one of these three possible 
options: 
• In the File name field, type the name of 

the desired document with the .mxp 
extension. 

• Browse using the Look in field or the Up 
One Level button until the desired 
document appears in the list and select it. 

• Select the desired document that may 
already appear in the list. 

Click Open. 
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Detailed Procedures 
Saving the Current Browser State of M-Explorer as a Document 

Note: This procedure applies to a standalone version of 
M-Explorer. 

To save the current browser state of M-Explorer as a document: 
1. From the File menu, select Save As. The Save As dialog box 

appears (Figure 4-1). 

 

Figure 4-1: Save As Dialog Box 
Note: Selecting Save also brings up the Save As dialog box for the 

current browser state’s first save. 

2. If necessary, browse to a different location to save the document 
using the drop-down arrow in the Save in field, the Up One Level 
button, or the Create New Folder button. 

Note: The default save location is: 
Program Files/Johnson Controls/M-Explorer, unless 
installing M-Explorer into a different directory. 

3. In the File name field, type a name for the document, keeping the 
.mxp extension. 

4. Make sure M-Explorer Documents (*.mxp) appears in 
the Save As type field. 

5. Click Save. The new document name appears in the title bar of the 
M-Explorer application. 
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Note: Click the List or Details button for different views of the 
existing documents. 



 M-Explorer 4-6 

Launching an M-Explorer Document 
Note: This procedure applies to a standalone version of 

M-Explorer. 

To launch an M-Explorer document: 
1. From the File menu, click Open. The Open dialog box appears 

(Figure 4-2). 

 

Figure 4-2: Open Dialog Box 
Note: Recently opened documents appear near the bottom of the 

drop-down File menu. Immediately open a document by 
clicking on the desired document name. 

2. Make sure M-Explorer Documents (*.mxp) appears in 
the Files of type field. 

Note: Click the List or Detail button for different views of the 
existing documents. 

3. Select a document via one of these three possible options: 

• In the File name field, type the name of the desired document 
with the .mxp extension. 

• Browse using the Look in field or the Up One Level button 
until the desired document appears in the list and select it. 

• Select the desired document that may already appear in the list. 
4. Click Open. M-Explorer appears at the desired browser state. 
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Chapter 5  
Using M-Inspector 

Introduction 
The M-Explorer application provides capabilities beyond its browser 
features. Through M-Inspector, M-Explorer provides access to object 
data for viewing and modification. This chapter describes how to: 

• start M-Inspector from M-Explorer using the Actions menu 

• start M-Inspector from M-Explorer using a pop-up menu 

• use M-Inspector in M-Graphics 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153425 
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Key Concepts 
M-Inspector Window 

The M-Inspector window consists of a tabbed presentation style. The 
tabs that appear depend on the type of object selected. Users move 
between tabs by clicking the tab name near the top of the window. 
Buttons, drop-down lists, and text fields appearing on each tab allow 
users to perform the various available functions. 

Each tab is an ActiveX® control meaning that it can be inserted into 
other applications. Refer to the Embedding M-Explorer ActiveX 
Controls into M-Graphics chapter in this guide for more information. 
For information about available tabs and commanding, viewing, and 
editing objects, refer to Appendix A: BACnet OPC Data Access Server. 
Figure 5-1 shows an example of the M-Inspector window. 

 

Figure 5-1: Example of the M-Inspector Window 
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Procedure Overview 
Table 5-1: Using M-Inspector 
To Do This Follow These Steps: 
Start M-Inspector from 
M-Explorer Using the Actions 
Menu 

Open the M-Explorer application. Select an 
object in either the Tree view or Focus view. 
From the Actions menu, select Inspect. 

Start M-Inspector from 
M-Explorer Using a Pop-up 
Menu 

Open the M-Explorer application. Select an 
object in either the Tree view or Focus view. 
Right-click the mouse. Select Inspect. 

Use M-Inspector in M-Graphics Open the M-Graphics application. Draw an 
object for the M-Inspector pick. From the 
Dynamics menu, point to Actions, select Pick. 
In the Action field, select Launch Application 
from the drop-down menu. In the Filename 
field, type in the name of the M-Inspector 
executable file or click the Browse button to 
locate the file on the system. After the 
executable name in the Filename field, insert a 
space and type in the complete hierarchical 
path of an object. Click OK. Click Runtime on 
the menu bar. Click the M-Inspector pick. 
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Detailed Procedures 
Starting M-Inspector from M-Explorer Using the Actions Menu 

To start M-Inspector from M-Explorer using the Actions menu: 
1. Open the M-Explorer application. 
2. Select an object in either the Tree view or Focus view. The Actions 

menu becomes available. 
3. From the Actions menu, select Inspect. The M-Inspector window 

appears. 

Starting M-Inspector from M-Explorer Using a Pop-Up Menu 
To start M-Inspector from M-Explorer using a pop-up menu: 
1. Open the M-Explorer application. 
2. Select an object in either the Tree view or Focus view. 
3. Right-click the mouse. A pop-up menu appears. 
4. Select Inspect. The M-Inspector window appears. 

Using M-Inspector in M-Graphics 
To use M-Inspector in M-Graphics: 
1. Open the M-Graphics application. 
2. Draw an object for the M-Inspector pick. 
3. From the Dynamics menu, point to Actions, select Pick. The 

Property Inspector dialog box appears. 
4. In the Action field, select Launch Application from the drop-down 

menu. 
5. In the Filename field, type in the full path name of the M-Inspector 

executable file or click the Browse button to locate the file on the 
system. 

Example: 
C:\Program Files\Johnson Controls\M-Explorer\Inspector.exe 
6. After the executable name in the Filename field, insert a space and 

type in the complete hierarchical path of an object (Figure 5-2). 
Example: 
JC.BNOPC\@BRENGEL:FL06:FL06-UNT-10-ADF-64. 
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Figure 5-2: Completed Property Inspector Dialog Box 
Note: For a quick and accurate way to enter the complete 

hierarchical path of an object, go to the M-Explorer 
application, select an object, and copy the Full Reference 
Line; then, return to M-Graphics and paste the Full 
Reference Line into the Object Name field after the 
executable name. 

7. Click OK. 
8. Save the M-Graphics display. 
9. Click Runtime on the Menu bar. 
10. Click the M-Inspector pick. The M-Inspector window opens. 
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Chapter 6  
Embedding M-Explorer ActiveX 
Controls into M-Graphics 

Introduction 
Each tab of the M-Inspector and the M-Explorer itself are ActiveX 
controls capable of being embedded into a container application such 
as M-Graphics. This chapter describes how to: 

• embed M-Explorer ActiveX control into M-Graphics 

• embed M-Command ActiveX control into M-Graphics 

• embed M-View ActiveX control into M-Graphics 

• embed M-Schedule ActiveX control into M-Graphics 

• embed M-Calendar ActiveX control into M-Graphics 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
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Key Concepts 
ActiveX 

ActiveX is a set of integration technologies that enables software 
components to interoperate in a networked environment using different 
programming languages. The foundation for ActiveX is Microsoft 
Object Linking and Embedding (OLE) and the Component Object 
Model (COM). 

ActiveX Control 
ActiveX is a type of software module and an extension of the 
Microsoft Visual Basic® programming language toolbox. When 
adding an ActiveX control to a program, the ActiveX becomes part of 
the development and runtime environment and provides new 
functionality for your application. 

Container Application 
A container application is a software application, such as M-Inspector 
or M-Graphics, that can hold an Active X control such as M-View or 
M-Explorer. 

M-Graphics 
M-Graphics allows monitoring, control, and analysis of facilities using 
dynamic color graphic displays. M-Graphics also provides graphical 
navigation of a facility and launching of other applications. For 
information about M-Graphics, refer to the M-Graphics User’s 
Manual (FAN 644.0). 

M-Inspector 
The M-Inspector window consists of a tabbed presentation style. The 
tabs that appear depend on the type of object selected. Users move 
between tabs by clicking the tab name near the top of the window. 
Buttons, drop-down lists, and text fields appearing on each tab allow 
users to perform the various available functions. 
Each tab is an ActiveX control, meaning that it can be inserted into 
other applications. For example, the M-Command tab of M-Inspector 
is equivalent to embedding M-Command into M-Graphics. 
Figure 6-1 shows an example of the M-Inspector window. 
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Figure 6-1: Example of the M-Inspector Window 
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Procedure Overview 
Table 6-1: Embedding ActiveX Controls into M-Graphics 
To Do This Follow These Steps: 
Embed M-Explorer ActiveX 
Control into M-Graphics 

Open the M-Graphics application. From the Edit menu, select Insert New 
Object. Be sure to select the default, Create Control. Use the vertical 
scroll bar to locate and select Johnson Controls M-Explorer Control from 
the Object Type list. Click OK. Save the M-Graphics display, so you can 
return to it from other M-Graphics displays. Click Runtime on the Menu 
bar to access M-Explorer. 

Embed M-Command ActiveX 
Control into M-Graphics 

Open the M-Graphics application. From the Edit menu, select Insert New 
Object. Be sure to select the default, Create Control. Use the vertical 
scroll bar to locate and select Johnson Controls M-Command Control 
from the Object Type list. Click OK. From the Edit menu, point to Johnson 
Controls M-Command Control Object, and select Properties. In the Object 
Name field, type in the complete hierarchical path of an object. Click OK. 
Save the M-Graphics display, so you can return to it from other 
M-Graphics displays. Click Runtime on the Menu bar to command the 
object. 

Embed M-View ActiveX 
Control into M-Graphics 

Open the M-Graphics application. From the Edit menu, select Insert New 
Object. Be sure to select the default, Create Control. Use the vertical 
scroll bar to locate and select Johnson Controls M-View Control from the 
Object Type list. Click OK. From the Edit menu, point to Johnson Controls 
M-View Control Object and select Properties. In the Object Name field, 
type in the complete hierarchical path of an object. Click OK. Save the 
M-Graphics display, so you can return to it from other M-Graphics 
displays. Click Runtime on the Menu bar to proceed viewing the object. 

Embed M-Schedule ActiveX 
Control into M-Graphics 

Open the M-Graphics application. From the Edit menu, select Insert New 
Object. Be sure to select the default, Create Control. Use the vertical 
scroll bar to locate and select Johnson Controls M-Schedule Control. 
Click OK. From the Edit menu, point to Johnson Controls M-Schedule 
Control Object, and select Properties. In the Schedule Object Name field, 
type in the complete hierarchical path of a Schedule object. Click OK. 
Save the M-Graphics display, so you can return to it from other 
M-Graphics displays. Click Runtime on the Menu bar to proceed working 
with the Schedule object. 

Embed M-Calendar ActiveX 
Control into M-Graphics 

Open the M-Graphics application. From the Edit menu, select Insert New 
Object. Be sure to select the default, Create Control. Use the vertical 
scroll bar to locate and select Johnson Controls M-Calendar Control from 
the Object Type list. Click OK. From the Edit menu, point to Johnson 
Controls M-Calendar Control Object, and select Properties. In the 
Calendar Object Name field, type in the complete hierarchical path of a 
Schedule object. Click OK. Save the M-Graphics display. Click Runtime 
on the Menu bar to proceed working with the Calendar object. 
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Detailed Procedures 
Embedding M-Explorer ActiveX Control into M-Graphics 

Note: Techniques for inserting an ActiveX control may vary 
slightly among different control containers; however, the 
basics are the same. 

To embed M-Explorer ActiveX control into M-Graphics: 
1. Open the M-Graphics application. 
2. From the Edit menu, select Insert New Object. The Insert Object 

dialog box appears (Figure 6-2). 

 

Figure 6-2: Insert Object Dialog Box 
3. Be sure to select the default, Create Control. 
4. Use the vertical scroll bar to locate and select Johnson Controls 

M-Explorer Control from the Object Type list. 
5. Click OK. The ActiveX control appears in the display. 
6. Save the M-Graphics display. By saving the M-Graphics display, 

you can return to the display from other M-Graphics displays. 
7. Click Runtime on the Menu bar to access M-Explorer. 

Embedding M-Command ActiveX Control into M-Graphics 
To embed M-Command ActiveX control into M-Graphics: 
1. Open the M-Graphics application. 



 M-Explorer 6-6 

2. From the Edit menu, select Insert New Object. The Insert Object 
dialog box appears (Figure 6-2). 

3. Be sure to select the default, Create Control. 
4. Use the vertical scroll bar to locate and select Johnson Controls 

M-Command Control from the Object Type list. 
5. Click OK. The ActiveX control appears in the display. 
6. From the Edit menu, point to Johnson Controls M-Command 

Control Object, and select Properties. The Properties dialog box 
appears. 

7. In the Object Name field, type in the complete hierarchical path of 
an object (Figure 6-3). 

 

Figure 6-3: Completed Properties Dialog Box 
Note: For a quick and accurate way to complete the Object Name 

field, go to the M-Explorer application, select an object and 
copy the Full Reference Line; then, return to M-Graphics 
and paste the Full Reference Line into the Object Name 
field. Do not include the attribute name when copying and 
pasting. 

8. Click OK. 
9. Save the M-Graphics display. By saving the M-Graphics display, 

you can return to the display from other M-Graphics displays. 
10. Click Runtime on the Menu bar to proceed commanding the 

object. 

Embedding M-View ActiveX Control into M-Graphics 
To embed M-View ActiveX control into M-Graphics: 
1. Open the M-Graphics application. 
2. From the Edit menu, select Insert New Object. The Insert Object 

dialog box appears (Figure 6-2). 
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3. Be sure to select the default, Create Control. Use the vertical scroll 
bar to locate and select Johnson Controls M-View Control from the 
Object Type list. 

4. Click OK. The ActiveX control appears in the display. 
5. From the Edit menu, point to Johnson Controls M-View Control 

Object, and select Properties. The Properties dialog box appears. 
6. In the Object Name field, type in the complete hierarchical path of 

an object (Figure 6-3). 
Note: For a quick and accurate way to complete the Object Name 

field, go to the M-Explorer application, select an object, and 
copy the Full Reference Line; then, return to M-Graphics 
and paste the Full Reference Line into the Object Name 
field. Do not include the attribute name when copying and 
pasting. 

7. Click OK. 
8. Save the M-Graphics display, so you can return to the display from 

other M-Graphics displays. 
9. Click Runtime on the Menu bar to view the object. 

Embedding M-Schedule ActiveX Control into M-Graphics 
To embed M-Schedule ActiveX control into M-Graphics: 
1. Open the M-Graphics application. 
2. From the Edit menu, select Insert New Object. The Insert Object 

dialog box appears (Figure 6-2). 
3. Make sure to select the default, Create Control. 
4. Use the vertical scroll bar to locate and select Johnson Controls 

M-Schedule Control from the Object Type list. 
5. Click OK. The ActiveX control appears in the display. 
6. From the Edit menu, point to Johnson Controls M-Schedule 

Control Object and select Properties. The Input Object Name 
dialog box appears. 

7. In the Schedule Object Name field, type in the complete 
hierarchical path of a Schedule object (Figure 6-4). 
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Figure 6-4: Completed Input Object Name Dialog Box 
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Note: For a quick and accurate way to complete the Object Name 
field, go to the M-Explorer application, select an object, and 
copy the Full Reference Line; then, return to M-Graphics 
and paste Full Reference Line into the Object Name field. 
Do not include the attribute name when copying and pasting. 

8. Click OK. 
9. Save the M-Graphics display so you can return to the display from 

other M-Graphics displays. 
10. Click Runtime on the Menu bar to work with the Schedule object. 

Embedding M-Calendar ActiveX Control into M-Graphics 
To embed M-Calendar ActiveX control into M-Graphics: 
1. Open the M-Graphics application. 
2. From the Edit menu, select Insert New Object. The Insert Object 

dialog box appears (Figure 6-2). 
3. Make sure to select the default, Create Control. 
4. Use the vertical scroll bar to locate and select Johnson Controls 

M-Calendar Control from the Object Type list. 
5. Click OK. The ActiveX control appears in the display. 
6. From the Edit menu, point to Johnson Controls M-Calendar 

Control Object, and select Properties. The Input Object Name 
dialog box appears. 

7. In the Calendar Object Name field, type in the complete 
hierarchical path of a Schedule object (Figure 6-5). 

 

 

Figure 6-5: Completed Input Object Name Dialog Box 
Note: For a quick and accurate way to complete the Object Name 

field, go to the M-Explorer application, select an object, and 
copy the Full Reference Line; then, return to M-Graphics 
and paste the Full Reference Line into the Object Name 
field. Do not include the attribute name when copying and 
pasting. 

8. Click OK. 
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9. Save the M-Graphics display. By saving the M-Graphics display, 
you can switch back to it from other M-Graphics displays. 

10. Click Runtime on the Menu bar to work with the Calendar object. 
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Chapter 7  
Dragging and Dropping 

Introduction 
M-Explorer allows leaf items, such as attributes of N30 objects or 
Companion/Facilitator points, to be moved into the TWXView32 
ActiveX Control for realtime viewing of trend data. This works with 
both controls embedded into M-Graphics or with M-Explorer running 
next to an M-Graphics display with only the TWXView32 control 
embedded. This chapter describes how to drag and drop an item from 
M-Explorer to TWXView32. 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153435 



 M-Explorer 7-2 

Key Concepts 
TWXView32 ActiveX Control 

The TWXView32 ActiveX Control displays realtime trend data from 
connected OPC data access servers from within the M-Graphics 
application. Refer to M-Graphics User’s Manual (FAN 644.0) for 
more information. 
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Procedure Overview 
Table 7-1: Dragging and Dropping 
To Do This Follow These Steps: 
Drag and Drop an Item from 
M-Explorer into TWXView32 

Embed the TWXView32 ActiveX Control into 
M-Graphics. Embed the M-Explorer ActiveX 
Control into the same M-Graphics display as 
the TWXView32 ActiveX Control. In 
M-Explorer, select a Leaf item with the mouse, 
then drag and drop the Leaf item into 
TWXView32. 
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Detailed Procedures 
Dragging and Dropping an Item from M-Explorer into TWXView32 

Note: These procedures describe dragging and dropping with both 
controls embedded into M-Graphics. 

To drag and drop an item from M-Explorer into TWXView32: 
1. Embed the TWXView32 ActiveX Control into M-Graphics. Refer 

to M-Graphics User’s Manual (FAN 644.0). 
2. Embed the M-Explorer ActiveX Control into the same M-Graphics 

display as the TWXView32 ActiveX Control (Figure 7-1). Refer to 
the Embedding M-Explorer ActiveX Controls into M-Graphics 
chapter. 

 

Figure 7-1: M-Explorer and TWXView32 in M-Graphics Configure Mode 
3. Be sure the M-Graphics display is in Runtime mode to perform the 

drag and drop. 
4. In M-Explorer, click and hold the left mouse button on a leaf item 

to select it, move the mouse to drag the item to TWXView32, then 
release the mouse button (Figure 7-2). 
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5. The TWXView32 ActiveX control will start showing the real-time 
data of the selected point in a dynamic trend display format. 

 

Figure 7-2: Item from M-Explorer in TWXView32 in Runtime Mode 
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Appendix A  
BACnet OPC Data Access Server 

Introduction 
The BACnet OPC Data Server provides M-Explorer with dynamic 
data values from N30 series supervisory controller objects, third-party 
BACnet objects, and Cardkey® PEGASYS® objects for display. 
M-Inspector views and commands specific N30, BACnet, and Cardkey 
PEGASYS objects. In addition to describing how M-Explorer and 
M-Inspector provide unique access to the data provided by the BACnet 
OPC Data Access Server, this appendix describes how to: 

• command an object 

• view an object 

• edit an object 

© January, 2001 Johnson Controls, Inc.  www.johnsoncontrols.com
      Code No. LIT-1153440 
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Key Concepts 
M-Explorer JC.BNOPC Hierarchy 

M-Explorer presents data from a BACnet OPC Data Access Server in 
a hierarchical structure as illustrated in Figure A-1. Table A-1 
describes the numbered callouts in Figure A-1. 
This hierarchy matches the M-Tool Project Builder application and the 
VT100 interface embedded in the N30 supervisory controller. 
However, this hierarchy is different from the OPC Tag Browser which 
shows a flat list of named objects within each N30 device and does not 
show additional containers within the N30 device. Third-party BACnet 
devices and Cardkey devices are shown in a flat list similar to the 
Tag Browser. Refer to Project Builder User’s Guide (LIT-693200) in 
the M-Tool Manual (FAN 693), the N30 Supervisory Controller User’s 
Manual (FAN 689.2), and M-Graphics User’s Manual (FAN 644.0) for 
more information. 

 

Figure A-1: M-Explorer JC.BNOPC Hierarchy 
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Table A-1: M-Explorer JC.BNOPC Hierarchy Callouts 
Callout View/Item Description 
1 M-Explorer Top of the M-Explorer hierarchy 
2 JC.BNOPC BACnet OPC Data Access server 
3 Phoenix Devices Site (name) 
4 GEX, HDMAV, etc. Devices 
5 NotificationClass_1, etc. Objects 
6 Cardkey Devices Site (name) 
7 CardReader_1 Device 
8 Label, etc. Attributes of the selected item 

(NotificationClass_1) 

 

Site 
A logical or physical grouping of devices that exist in connected or 
disconnected state relative to the M-Series Workstation. Each site has 
its own communication characteristics that can be described by 
protocol or physical connection. Examples of sites within the 
Johnson Controls product family include Companion panels, 
N1 networks, or N30 networks. 

Site Book 
The Site Book is a software program used to define and edit a 
physical or logical grouping of N30, third-party BACnet, and Cardkey 
objects that can be connected to an M-Series Workstation. Each site 
within the database has parameters that are needed to establish the 
connection. For more information, refer to the Site Book User’s Guide 
(LIT-6893100) in the N30 Supervisory Controller System 
Communications Manual (FAN 689.3). 

Status 
With M-Explorer in Details view, the Status column displays data for 
N30, BACnet, and Cardkey PEGASYS objects as follows: 

• The status of Leaf items lists the OPC Data Access Server quality, 
such as Good, Unsure, and Bad, for the value of attributes. 

• The status of Branch items represents the object status. Refer to the 
Object Dictionary (FAN 694) for more information. 

Note: Objects in Overridden status appear in Normal status color, 
as long as the objects are within alarm/warning limits. Refer 
to the Getting Started chapter in this manual for more 
information about status colors. 



 M-Explorer A-4 

Label Icons/Symbols 
In addition to the name listed in the Label column, M-Explorer also 
represents each object from a BACnet OPC Data Access Server with 
an icon based on object type. Table A-2 shows each type of icon and 
what object type the icon represents. 
 

Table A-2: Label Icons for Objects 
Icon Object Type 

 Analog Alarm 

 Analog Totalization 

 Analog Value 

 BACnet Averaging 

 BACnet Event Enrollment 

 BACnet File 

 BACnet Life Safety Point 

 BACnet Life Safety Zone 

 BACnet Loop 

 BACnet Protocol Engine 

 Binary Value 

 Broadcast Management 

 Calendar 

 Connection (Not available in North America as of this release) 

 Container 

 Controller 

 Data Broadcast 

 Demand Load Rolling 

 Device Diagnostic 

 Ethernet IP Datalink 

 Event Totalization 

 Global Data Sharing 

 Group 

 Heavy Equipment Controller 

 Interlock 

 Latch 

 Load 

 Message Router 

 Modem Configuration 

 Multiple Command 

 Multistate Alarm 

Continued on next page . . . 
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Icon (Cont.) Object Type 
 N2 Analog Input 

 N2 Analog Output 

 N2 Binary Input 

 N2 Binary Output 

 N2 Master Data Link 

 N2 Multistate Input 

 N2 Multistate Output 

 N2 Pulse Counter 

 N30 Device 

 Name List 

 Notification Class 

 Operator 

 Optimal Start 

 Printer 

 Pulse Meter 

 Reference (Not available in North America as of this release) 

 Remote Destination 

 Report Server 

 Runtime Totalization 

 Schedule 

 Serial Datalink 

 Signal Select 

 Site 

 Site Data 

 Summary 

 Temporary Occupancy 

 Trend Log 

 Utility Profile 

 VT100 
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M-Inspector Window 
When accessing N30, third-party BACnet, or Cardkey objects from the 
BACnet OPC Data Access Server, M-Inspector displays object data in 
a tabbed presentation style. Users select a tab to command objects, 
view and edit attributes, or to modify Schedule and Calendar objects. 
For information about the commands supported by each object and the 
attributes for each object, refer to the Object Dictionary (FAN 694). 

M-Command 
The M-Command ActiveX control appears as the M-Command tab in 
the M-Inspector window and displays values for key attributes 
associated with an N30, third-party BACnet, or Cardkey object being 
inspected, including Object Name, Present Value, Description, Status, 
and Object Type. The values of these attributes refresh every 
sixty seconds. The M-Command tab allows a user to send commands 
to objects that support commands. (If an object does not support 
commands, then the Command Selection drop-down list is empty.) 
The pop-up menu that appears when right-clicking on the 
M-Command tab with the mouse lists the About M-Command menu 
item. Selecting this menu item displays information about the 
copyright of the M-Command ActiveX control. 
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M-View 
The M-View ActiveX control appears as the M-View tab in the 
M-Inspector window and allows users to view and edit the attributes of 
an individual object defined in the system. From the M-View tab, 
users view data while in the View mode. By clicking the Edit button, 
users can change the M-View tab to the Edit mode to modify attribute 
values. Users can choose multiple views of data from a pop-up menu 
that appears by right-clicking the M-View tab (Figure A-2). 

 

Figure A-2: View Tab Pop-Up Menu 
The default views available to users from the pop-up menu include: 

• Focus – Contains the most important attributes of the object, 
providing the most useful data to a user and may or may not 
include configurable/writeable attributes. 

• Configuration – Contains only configurable/writeable attributes of 
an object. Use this view to edit an object’s attributes. 

Note: Third-Party BACnet objects do not support the Focus and 
Configuration views. Third-Party BACnet objects display in 
Snapshot view. 

The Edit, Save, and Refresh menu items in Figure A-2 correspond to 
the buttons described in Table A-5. Selecting the About M-View menu 
item displays information about the copyright of the M-View ActiveX 
control. 

M-Schedule 
An M-Schedule ActiveX Control appears as the M-Schedule tab in the 
M-Inspector window and allows users to view and modify a Schedule 
object. A Schedule object runs events within a facility management 
system at specified times. 
Note: M-Schedule refers to both an N30 Schedule and a BACnet 

Schedule. 

For details, refer to the M-Schedule/M-Calendar User’s Guide 
(LIT-1153600) in the M-Series Workstation Manual (FAN 1153.2). 
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M-Calendar 
The M-Calendar ActiveX Control appears as the M-Calendar tab in the 
M-Inspector window and allows users to view and modify a Calendar 
object. A Calendar object is a reusable exception to weekly schedules 
within a facility management system. 
Note: M-Calendar refers to both an N30 Calendar and a BACnet 

Calendar. 

For details, see the M-Schedule/M-Calendar User’s Guide 
(LIT-1153600) in the M-Series Workstation Manual (FAN 1153.2). 

BACnet 
The American Society of Heating, Refrigerating, and Air Conditioning 
Engineers (ASHRAE) developed the Building Automation Controls 
Network (BACnet) as a data communications protocol designed to 
promote connectivity among multiple vendors of control equipment. 
BACnet is the protocol used for communication between the M-Series 
Workstation and N30 Controller network. M3 Workstation Release 3.0 
and M5 Workstation Release 2.0 communicate with: 

• N30 Supervisory Controllers 

• devices through BACnet OPC Alarm and Events (AE) and Data 
Server 

• third-party BACnet devices 

Pop-Up Menus 
Pop-up menus provide another means to access menu options. A 
pop-up menu displays various options for different views, as described 
in Table A-3, when selecting specific items from a BACnet Data 
Access Server in M-Explorer. 

Table A-3: Pop-Up Menu Options 
Item Selected Tree View Pop-Up Menu Options Focus View Pop-Up Menu Options 
Site Connect, Disconnect, AutoRefresh Connect, Disconnect, Icons View, Details View, 

Refresh, Up One Level, AutoRefresh 
Device Inspect, AutoRefresh Inspect, Icons View, Details View, Refresh, 

Up One Level, AutoRefresh 
Object Inspect, AutoRefresh Inspect, Icons View, Details View, Refresh, 

Up One Level, AutoRefresh 
Attribute Not listed in Tree view Icons View, Details View, Refresh, Up One 

Level, AutoRefresh 
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Connect/Disconnect 
When selecting sites, the connect/disconnect options appear on the 
Actions or pop-up menu. Connect or disconnect a user-connected site 
from the M-Explorer application by selecting one of these options. 
These options are applicable only to user connected sites as defined in 
the Site Book application. 
System-connected sites automatically connect upon startup of the 
M-Series Workstation. System-connected sites cannot be connected or 
disconnected, even though these options are presented by M-Explorer. 
Only two sites may be connected simultaneously. Attempting a third 
site connection fails by leaving the site disconnected. 
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Procedure Overview 
Table A-4: BACnet OPC Data Access Server 
To Do This Follow These Steps: 
Command an Object On the M-Explorer workspace, select the 

object to be inspected. From the Actions 
menu, select Inspect. In the Command field, 
click the drop-down arrow to view a list of 
supported commands. Select a command from 
the list. Fill in any additional command 
parameters that may appear for the selected 
command. Click Execute. Click Close. 

View an Object On the M-Explorer workspace, select the 
object to be inspected. From the Actions 
menu, select Inspect. Click on the View tab. 
View the object attributes. Select a button from 
the bottom of the window. 

Edit an Object On the M-Explorer workspace, select the 
object to be inspected. From the Actions 
menu, select Inspect. Click on the View tab. 
Click Edit. Edit the fields as desired. Click 
Save to save the changes. Click Refresh to 
update the information in the display. Click 
Close. 
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Detailed Procedures 
Commanding an Object 

To command an object: 
1. On the M-Explorer application, select an object. 
2. From the Actions menu, select Inspect. The M-Inspector window 

appears with the M-Command tab selected and the complete 
hierarchical path of the object appearing in the Title bar  
(Figure A-3). 

Note: Right-clicking on a selected item in either the Tree view or 
Focus view brings up the Inspect option on a pop-up menu. 

 

Figure A-3: M-Inspector Window with M-Command Tab Visible 
3. In the Command field, click the drop-down arrow to view a list of 

supported commands (Figure A-4). 
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Figure A-4: Command Drop-Down List 
4. Select a command from the list. If the command selected has 

additional command parameters, the Command Parameter section 
appears below the Command Selection section in the M-Inspector 
window (Figure A-5). For more information about the object’s 
supported commands, refer to the Object Dictionary (FAN 694). 
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Figure A-5: Command Parameters 
5. In the Value field, click the drop-down arrow to view and select 

from a list of command parameter values. For more information 
about the object’s command parameters, refer to the 
Object Dictionary (FAN 694). 

6. Click Execute. 
7. Click Close. 
Note: The Help button brings up information specifically about the 

inspected object. 
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Viewing an Object 
To view an object: 
1. On the M-Explorer application, select an object. 
2. From the Actions menu, select Inspect. The M-Inspector window 

appears with the M-Command tab selected and the complete 
hierarchical path of the object in the Title bar (Figure A-3). 

Note: Right-clicking on a selected item in either the Tree view or 
Focus view brings up the Inspect option on a pop-up menu. 

3. Click on the M-View tab. The M-View tab appears in the 
M-Inspector window (Figure A-6). 

 

Figure A-6: M-Inspector Window with M-View Tab Visible 
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4. View the object attributes using the horizontal and vertical scroll 
bars or resizing the M-Inspector window to make other attributes 
visible. For more information about object attributes, refer to the 
Object Dictionary (FAN 694). 

Notes: The values on the View tab may automatically refresh. 
Refresh manually is the Default. Right click the M-View tab 
and select AutoRefresh to automatically update the current 
values from the Controller. 
 
When viewing third-party controllers with a large number of 
objects (appear in a flat list), we recommend turning off the 
AutoRefresh feature to improve performance. 

5. Select a button from the bottom of the window, or right-click the 
M-View tab and select an option from the pop-up menu. Table A-5 
describes the button and menu options. 

Table A-5: View Tab Button Options 
Button Description 
Close Closes the M-Inspector window. 
Help Brings up information specifically about the inspected object. 
Edit/View The Edit button allows the visible attributes to be edited. Edit the object when the 

Edit button is clicked, even though the button name changes to View. The View 
button switches to view-only mode for the attributes. View the object when the 
View button is clicked, even though the button name changes to Edit. This button 
toggles between the Edit and View modes. 

Save Saves any changes to the attributes after editing. 
Refresh Updates any changes to attributes on the M-View display since M-Inspector 

opened (M-View does not automatically refresh values). 

 

Editing an Object 
To edit an object: 
1. On the M-Explorer application, select an object. 
2. From the Actions menu, select Inspect. The M-Inspector window 

appears with the M-Command tab selected and the complete 
hierarchical path or functional name of the object appearing in the 
Title bar (Figure A-3). 

Note: Right-clicking on a selected item in either the Tree view or 
Focus view also brings up the Inspect option on a pop-up 
menu. 

3. Click on the M-View tab. The entire M-View tab appears in the 
M-Inspector window (Figure A-6). 
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4. Click Edit, or right-click the M-View tab and select Edit from the 
pop-up menu. The attributes become available for editing. 

Note: After clicking the Edit button, the View button appears in its 
place to return to the view-only mode for the attributes. 

5. Edit the fields as desired. For more information about the object’s 
attributes, refer to the Object Dictionary (FAN 694), or select the 
M-Inspector Help button. 

6. Click Save to save the changes. Any error messages regarding 
invalid parameters appear at this time. 

7. Click Close. 
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Appendix B  
Companion/Facilitator OPC Data 
Access Server 

Introduction 
The Companion/Facilitator OPC Data Server provides dynamic data 
values for points to M-Explorer for display. Companion/Facilitator 
points are not accessible through M-Inspector, but M-Explorer still 
provides access to the data provided by the Companion/Facilitator 
OPC Data Access Server as described in this appendix. 

© January, 2001 Johnson Controls, Inc. www.johnsoncontrols.com
      Code No. LIT-1153445 
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Key Concepts 
M-Explorer JC.CFOPC Hierarchy Server 

M-Explorer presents data from a Companion/Facilitator OPC Data 
Access Server in a hierarchical structure as illustrated in Figure B-1. 
Table 2-1 describes the numbered callouts in Figure B-1. 

 

Figure B-1: M-Explorer JC.CFOPC Hierarchy 
 

Table B-1: M-Explorer JC.CFOPC Hierarchy Callouts 
Callout View/Item Description 
1 M-Explorer Top of the M-Explorer hierarchy 
2 JC.CFOPC Companion/Facilitator OPC Data Access Server 
3 507 East Michigan St. Site (name) 
4 1.ACM B17 AHU255, etc. Companion/Facilitator points 
5 Description, etc. Attributes of the selected item (2.AHU9 ACM BI----8) 
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Site 
A site is a logical or physical grouping of devices that exist in 
connected or disconnected state relative to the M3 Workstation. Each 
site has its own communication characteristics that can be described by 
protocol or physical connection. Examples of sites within the 
Johnson Controls product family include Companion Panels, 
N1 networks, or BACnet networks. 

Phone Book 
The Phone Book includes a list of defined sites and allows operators to 
select and open a connection to a site, add a site, modify a site, or 
delete a site. All sites, dial-up and direct-connect, must be defined in 
the Phone Book. 

Status 
With M-Explorer in Details view, the Status column displays a status 
for each OPC attribute. For more information about status, refer to the 
Companion/Facilitator OPC Server User’s Guide (LIT-11531100) in 
the M-Series Workstation with Companion/Facilitator Manual 
(FAN 1153.1). 

Label Icons/Symbols 
In addition to the name listed in the Label column, M-Explorer also 
represents points from a Companion/Facilitator OPC Data Access 
Server with an icon based on its object type. Table B-2 shows each 
type of icon and what object type it represents. 
 

Table B-2: Label Icons for Points 
Icon Point Type 

 Accumulator 

 Analog Input 

 Analog Output 

 Binary Input 

 Binary Output 
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Pop-Up Menus 
Pop-up menus provide another means to access menu options. A 
pop-up menu displays various options for different views, as described 
in Table B-3, when selecting specific items from a 
Companion/Facilitator Data Access Server in M-Explorer. 

Table B-3: Pop Up Menu Options 
Item Selected Tree View Pop-Up Menu Options Focus View Pop-Up Menu Options 
Site Connect, Disconnect, AutoRefresh Connect, Disconnect, AutoRefresh 
Companion 
Point 

None. No pop-up menu appears. Icons View, Details View, Refresh, Up One Level, 
AutoRefresh 

Attribute Not listed in Tree view Icons View, Details View, Refresh, Up One Level, 
AutoRefresh 

 

Connect/Disconnect 
When selecting a Companion/Facilitator site, the connect/disconnect 
options appear on the Actions or pop-up menu. Connect or disconnect 
Companion/Facilitator sites from the workstation. Connect only 
one Companion/Facilitator site at one time. 
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Appendix C  
N1 OPC Data Access Server 

Introduction 
The N1 OPC Data Access Server provides dynamic access to point 
data values residing on a Metasys® N1 network. M-Explorer provides 
read access capabilities to the data provided by the N1 OPC Data 
Access Server as described in this appendix. 

© May 15, 2002 Johnson Controls, Inc. www.johnsoncontrols.com 
 LIT-1153450 
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Key Concepts 
M-Explorer JC.N1OPC Hierarchy Server 

M-Explorer presents data from an N1 OPC Data Access Server in a 
hierarchical structure as illustrated in Figure C-1. Table C-1 describes 
the numbered callouts in Figure C-1. 

 

Figure C-1: M-Explorer JC.N1OPC Hierarchy 
 

Table C-1: M-Explorer JC.N1OPC Hierarchy Callouts 
Callout View/Item Description 
1 M-Explorer Top of the M-Explorer hierarchy 
2 JC.N1OPC N1 OPC Data Access Server 
3 JCHDQTRS Site (name) 
4 10, 100-105, for 

example N1 OPC Data Access Server points 

5 Label, Status, for 
example Attributes of the selected item (BO-4-1) 
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Site 
A site is a logical or physical grouping of devices that exist in a 
connected or disconnected state relative to the M-Series Workstation. 
Each site has its own communication characteristics that can be 
described by protocol or physical connection. Examples of sites within 
the Johnson Controls product family include Companion Panels, 
N1 networks, or BACnet™ networks. 

Label Icons/Symbols 
In addition to the name listed in the Label column, M-Explorer also 
displays points from an N1 OPC Data Access Server with an icon 
based on its object type. Table C-2 shows each type of icon and what 
object type it represents. 
 

Table C-2: Label Icons for Points 
Icon Point Type 

 Accumulator 

 Analog Input 

 Analog Output 

 Analog Value 

 Binary Input 

 Binary Output 

 Binary Value 

 Lighting 

 Proportional Integral Derivative (PID) Loop 
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Pop-Up Menus 
Pop-up menus provide another means to access menu options. A 
pop-up menu displays various options for different views, as described 
in Table C-3, when selecting specific items from an N1 OPC Data 
Access Server in M-Explorer. 

Table C-3: Pop Up Menu Options 
Item Selected Tree View Pop-Up Menu Options Focus View Pop-Up Menu Options 
Site Connect, Disconnect, AutoRefresh Connect, Disconnect, AutoRefresh 
Companion 
Point 

None. No pop-up menu appears. Icons View, Details View, Refresh, Up One Level, 
AutoRefresh 

Attribute Not listed in Tree view Icons View, Details View, Refresh, Up One Level, 
AutoRefresh 

 

Connect/Disconnect 
When selecting an N1 OPC site, the connect/disconnect options appear 
on the Actions or pop-up menu. Connect or disconnect N1 OPC sites 
from the workstation. Connect only one N1 OPC site at one time. 
 

 
 
Controls Group 
507 E. Michigan Street 
P.O. Box 423 www.johnsoncontrols.com
Milwaukee, WI  53201 Printed in U.S.A.
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Appendix D  
LN OPC Data Access Server 

Introduction 
The LONWORKS® Network (LN) OLE for Process Controls (OPC) 
Data Access Server provides M-Explorer with dynamic data values 
from Johnson Controls LONWORKS controllers, and qualified 
third-party LONWORKS devices for display. M-Inspector views and 
commands specific LN data values (OPC tags). The LN Scheduling 
OPC Server provides access to the database of LN Schedule objects 
that are used to implement workstation (computer) based scheduling 
for the LONWORKS network. Both of these server components are 
supplied with the Metasys® system Connectivity to LONWORKS 
network (MCL) software package that is designed to allow the 
M3 Workstation to communicate with the LONWORKS network. 
In addition to describing how M-Explorer and M-Inspector provide 
unique access to the data provided by the LN OPC Data Access Server 
and LN Scheduling OPC Server, this appendix describes how to: 

• command an LN OPC tag or LN Schedule object 

• view an LN OPC tag 

© June 30, 2004 Johnson Controls, Inc.  www.johnsoncontrols.com 
 Code No. LIT-1201121 
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Key Concepts 
LONWORKS 

LONWORKS network technology was developed by the Echelon® 
Corporation to provide an industry-standard Local Operating Network 
(LON®). The network is built around the Neuron® chip, a 
microprocessor that combines three Central Processing Units (CPUs) 
into one chip. The Neuron chip is an integral component of any 
LONWORKS device. LONWORKS is the generic term for Neuron chip 
technology and networking applications.  
LONMARK® standards are a set of guidelines issued by the LONMARK 
Interoperability Association. These guidelines ensure that devices from 
different vendors can coexist and cooperate on a single LONWORKS 
network. The organization also certifies specific devices as LONMARK 
compliant. 

M-Explorer JC.LNOPCVNI Hierarchy 
M-Explorer presents data from the LN OPC Data Access Server 
(named JC.LNOPCVNI in the Tree view) in a hierarchical structure as 
illustrated in Figure D-1. The JC.LNOPCVNI hierarchy is defined 
during MCL setup either to match the physical subsystem/device 
hierarchy of the LONWORKS network, or is freely definable to reflect, 
for example, an application-oriented view of the LONWORKS network.  
Note: In M-Explorer and the OPC Universal Tag Browser, this 

hierarchy may be shown as a flat list of named objects, with 
or without dots (or periods [.]) as separator characters 
between the branch item names. The display format 
(hierarchical, flat with separators, or flat without separators) 
is defined during MCL setup. For more information, refer to 
the MCL Installation and Commissioning Technical Bulletin 
(LIT-1201120). 
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Figure D-1: M-Explorer JC.LNOPCVNI Hierarchy 
Table D-1 describes the numbered callouts in Figure D-1. 

Table D-1: M-Explorer JC.LNOPCVNI Hierarchy Callouts 
Callout View/Item Description 
1 M-Explorer Top of the M-Explorer hierarchy 
2 JC.BNOPC N30/BACnet OPC Data Access server 
3 JC.LNOPCVNI LN OPC Data Access server 
4 ESSEN, JCI, etc. Branch names derived from LONWORKS 

subsystem/device (physical) hierarchy, or 
user-defined, application-oriented (logical) 
hierarchy. MCL setup allows you to choose 
how the display hierarchy is organized; the 
Tree view pane of Figure D-1 shows an 
application-oriented hierarchy. 

5 JC.LNSchedOPC LN Scheduling OPC server 
6 Holidays, etc. LN schedule object hierarchy 
7 ESSEN.JCI.TOWER… OPC tags of the selected branch item 

(TOWER). Using the tree analogy, these are 
the leaf (lowest level) items in the hierarchy, 
which do not contain any other items.  
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OPC Tag 
An OPC tag is a named object in an OPC server database that can be 
accessed from an OPC client, such as M-Explorer. An LN OPC tag 
represents an entire LONWORKS Network Variable (NV) if the variable 
has a single value, or the tag can represent an individual field of a 
structured network variable. For simplicity, the rest of this chapter uses 
the term network variable to mean both single-valued network 
variables and the fields of structured network variables. 
Note: An LN OPC tag can also represent an entire structured 

network variable. In this case, the Value displayed in 
M-Explorer and M-Inspector is a byte string showing the 
individual bytes of all fields of the variable (in decimal) 
separated by commas, e.g., 16, 255, 123, 74. Due to 
their ambiguous nature, these OPC tags cannot be 
commanded in M-Inspector. 

Status 
With M-Explorer in Details view, the Status column displays data for 
LN OPC tags as follows: 

• The status of Leaf items lists the OPC Data Access Server quality, 
such as Good, Unsure, or Bad, for the values of the displayed LN 
OPC tags. 

• The status of Branch items under JC.LNOPCVNI is always 
displayed as dashes (--), because the branch items only help to 
organize the hierarchical display and are not objects with viewable 
or commandable properties (see Figure D-2 for an example). The 
branch items can be compared with the folders shown in Windows 
Explorer. 
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Figure D-2: Details View of JC.LNOPCVNI Branch Items 

M-Explorer JC.LNSchedOPC Hierarchy 
In addition to the OPC server for accessing data on the LONWORKS 
network, MCL provides an OPC server (JC.LNSchedOPC) for 
accessing LN Schedule objects. These objects help to implement 
workstation (PC) based scheduling for the LONWORKS network. Note 
that workstation-based scheduling is not the same as controller- or 
device-based scheduling provided by special LONWORKS timer 
devices. Schedules can be configured from M-Explorer by selecting a 
Schedule object, and then selecting the Inspect option. For details, 
refer to the Working with LN Schedule Objects (LIT-1201123) chapter 
of the M-Schedule/M-Calendar User’s Guide (LIT-1153605). 
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Figure D-3: M-Explorer JC.LNSchedOPC Hierarchy 

Label Icons/Symbols 
In addition to the name listed in the Label column, M-Explorer also 
displays an icon for each OPC tag and Schedule object from the 
LN OPC Data Access server and LN Scheduling OPC server. The icon 
shown for an LN OPC tag is based on the type of network variable the 
tag represents, as listed in Table D-2. 
 

Table D-2: Label Icons for LN OPC Tags 
Icon Object Type 

 OPC tag representing a LONWORKS network variable input (NVI). If 
the OPC tag represents a single-valued NVI or a single field of a 
structured NVI, then it can be commanded in M-Inspector. 

 OPC tag representing a LONWORKS network variable output (NVO). 
NVOs are read-only, and can only be viewed in M-Inspector. 

 LN Schedule object, which can be commanded and configured in 
M-Inspector. 

 

M-Inspector Window 
When accessing LN OPC tags from the LN OPC Data Access Server 
(JC.LNOPCVNI), or Schedule objects from the LN Scheduling OPC 
Server (JC.LNSchedOPC), M-Inspector displays object data in a 
tabbed presentation style. Users select a tab to command and view 
OPC tags, or to command and configure Schedule objects. 



 Appendix D: LN OPC Data Access Server D-7

Command Tab 
The LN Command ActiveX control appears as the Command tab in 
the M-Inspector window and displays values for key attributes 
associated with the LN OPC tag or Schedule object being inspected, 
including Object Name, Present Value, Communication Status, Value 
Range, and Description. The displayed values are event-driven, 
meaning that if the tag’s value changes, it is automatically refreshed on 
the screen. The Command tab allows a user to send commands to tags 
and objects that support commands. If a tag or object does not support 
commands, or the user does not have the proper access rights, or the 
OPC tag represents a structured NV (not a single-valued NV and not a 
single field of a structured NV), then the Command tab does not 
appear in the M-Inspector window for that object. 

View Tab 
The LN View ActiveX control appears as the View tab in the 
M-Inspector window and allows users to view the attributes of an 
individual LN OPC tag defined in the system. 
Note: In contrast to objects from other OPC Data Access servers, 

such as the BACnet OPC Data Access server, LN OPC tags 
do not have editable attributes, so an Edit mode is not 
available on the View tab. 

Schedule Tab 
The LN Schedule ActiveX control appears as the Schedule tab in the 
M-Inspector window when the user inspects an LN Schedule object 
from the JC.LNSchedOPC server. The Schedule tab allows users to 
configure the Schedule object. A Schedule object runs events within a 
building automation system at specified times. For details, refer to the 
Working with LN Schedule Objects (LIT-1201123) chapter of the 
M-Schedule/M-Calendar User’s Guide (LIT-1153605). 

Pop-Up Menus 
Pop-up menus provide another means to access menu options. A 
pop-up menu displays various options for different views, as described 
in Table D-3, when selecting specific items from the LN OPC Data 
Access Server and the LN Scheduling OPC Server in M-Explorer. 



 M-Explorer User’s Guide D-8 

Table D-3: Pop-Up Menu Options 
Item Selected Tree View Pop-Up Menu Options Focus View Pop-Up Menu Options 
OPC Server AutoRefresh Icons View, Details View, Refresh, Up One 

Level, AutoRefresh 
Branch Item AutoRefresh Icons View, Details View, Refresh, Up One 

Level, AutoRefresh 
LN OPC Tag Not listed in Tree view Inspect, Icons View, Details View, Refresh, 

Up One Level, AutoRefresh 
LN Schedule 
Object 

Not listed in Tree view Inspect, Icons View, Details View, Refresh, 
Up One Level, AutoRefresh 
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Procedure Overview 
Table D-4: LN OPC Data Access Server 
To Do This Follow These Steps: 
Command an LN OPC 
Tag or Schedule 
Object 

On the M-Explorer workspace, select the tag or object 
to be inspected. From the Actions menu, select Inspect. 
In the Command Value To field, click the drop-down 
arrow to select a value from the list of supported 
command values for tags that have enumerated, named 
values, or type the numeric value for analog (floating 
point) or digital (integer) tags. Schedule objects support 
the Enable and Disable commands. Click Execute. 
Click Close. 

View an LN OPC Tag On the M-Explorer workspace, select the LN OPC tag 
to be inspected. From the Actions menu, select Inspect. 
Click on the View tab. View the tag’s attributes. Click 
Close. 

Detailed Procedures 
Commanding an LN OPC Tag or LN Schedule Object 

To command an LN OPC tag or Schedule object: 
1. In the M-Explorer application, select the LN OPC tag or Schedule 

object in the Focus view pane. 
2. From the Actions menu, select Inspect, or click the Inspect toolbar 

button ( ), or right-click on the tag or object and select Inspect 
from the pop-up menu. The M-Inspector window appears with the 
complete hierarchical path of the tag or object displayed in its Title 
bar (Figure D-4). If the tag or object can be commanded and the 
user has the proper access rights, the Command tab is selected. 
Otherwise, only the View tab appears in the M-Inspector window 
(see Viewing an LN OPC Tag). 
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Figure D-4: M-Inspector Window with Command Tab Visible 
Note: Resize the window to display all available button options. 

You can click the window’s Maximize button ( ) in the 
upper right corner, which automatically resizes the window 
to the optimal size for the Command tab. 

3. In the Command Value To field, click the drop-down arrow to 
select a value from the list of supported command values for tags 
that have enumerated, named values (Figure D-5), or type the 
numeric value for analog (floating point) or digital (integer) tags. 
The range of values is shown in the Commandable Value Range 
field. Schedule objects support the Enable and Disable commands. 
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Figure D-5: Command Value To Drop-Down List 
4. Click Execute. 
5. Click Close. 

Viewing an LN OPC Tag 
To view an LN OPC tag: 
1. In the M-Explorer application, select an LN OPC tag in the Focus 

view pane. 
2. From the Actions menu, select Inspect, or click the Inspect toolbar 

button ( ), or right-click on the tag and select Inspect from the 
pop-up menu. The M-Inspector window appears with the complete 
hierarchical path of the tag displayed in its Title bar (Figure D-6). 
If the tag can be commanded and the user has the proper access 
rights, the Command tab is selected. Otherwise, there is no 
Command tab and the View tab is selected.  

3. Click on the View tab. The View tab appears in the M-Inspector 
window (Figure D-6). 
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Figure D-6: M-Inspector Window with View Tab Visible 
Note: Resize the window to display all available button options. 

You can click the window’s Maximize button ( ) in the 
upper right corner, which automatically resizes the window 
to the optimal size for the View tab. 

4. View the tag’s attributes. 
5. Click Close. 
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