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Warranty

Bio-Rad Laboratories warrants that the Melanie II software shall substantially
conform, in all operational features, to Bio-Rad’s current specifications as pub-
lished in Bio-Rad’s user and installation guides and that, when properly
installed, it will be free of material defects which affect system performance.The
Purchaser must notify Bio-Rad in writing, within 30 days of delivery of the soft-
ware (not including delivery of any subsequent modifications to the software),
of any defect. If the software is found to be defective by Bio-Rad, Bio-Rad’s sole
obligation under this warranty is to remedy the defect in a manner consistent
with Bio-Rad’s regular business practices. For a defect which adversely affects
the performance of the software, Bio-Rad shall use its best efforts to cure such
defect as soon as reasonably practicable after receipt of Purchaser’s notice.
For minor defects, Bio-Rad shall use its best efforts to correct such minor
defects in the next release of its software. If, however, Bio-Rad is unable to cure
a major defect within 90 days of receipt of Purchaser’s notice, Purchaser shall
have the option to cancel this agreement, whereupon Bio-Rad shall refund only
the software fees paid.The warranties set forth in this agreement are in lieu of
all other representations and warranties, expressed or implied, including war-
ranties of merchantability and fitness for a particular purpose and any other
statutory or common-law warranty. Bio-Rad on its own behalf expressly dis-
claims and excludes any and all such other representations and warranties.
Liability of Bio-Rad to Purchaser, if any, for breach of warranty, or any other
claim relating to this agreement, shall be limited to the total amount of software
fees paid by purchaser to Bio-Rad. In no event shall Bio-Rad be liable for inci-
dental or consequential damages, loss of business or profits, special or indirect
damages of any nature whatsoever. No amendment, waiver, or other alteration
of the warranties in this agreement may be made except by mutual agreement
in writing.

Purchaser agrees that Bio-Rad’s liability arising out of contract, negligence,
strict liability in tort or warranty shall not exceed the amount of software license
fees paid by Purchaser. Under the copyright laws, this manual and the software
program contained herein may not be copied, in whole or in part, without the
prior written consent of Bio-Rad, except in the normal use of the software or to
make a backup copy. This exception does not allow copies to be made for oth-
ers, whether or not sold, but all of the materials purchased (with all backup cop-
ies) may be sold, given or loaned to another person. Under the law, copying
includes translating into another language or format. A multi-use license may
be purchased to allow the software to be used on more than one computer
owned by the purchaser, including a shared disk system.



Copyright

Copyright  1985 - 1997 The Melanie Group, Geneva, Switzerland. All
rights reserved.

Copyright  1991 Free Software Foundation Inc. for the GNU C++ library.
Copyright  1990-1993 Groupe BULL for the XPM library. Copyright 
1994, 1995 Quest Protein Database Center, Cold Spring Harbor Labs, for
the gd library. Copyright  1988-1996 Sam Leffler and 1991-1996 Silicon
Graphics, Inc. for the TIFF library.

Trademarks

TIFF is a trademark of Aldus Corporation. Windows 95 and Windows NT
are trademarks of Microsoft Corporation. Sun Microsystems, SPARCSta-
tion, OpenWindows and SunOs are trademarks or registered trademarks
of Sun Microsystems, Inc. Apple, Macintosh and Power Macintosh are
trademarks of Apple Computer, Inc. UNIX is a trademark of Novell, Inc.
PostScript is a trademark of Adobe Systems, Inc. Netscape Communica-
tions, Netscape and Netscape Navigator are trademarks of Netscape
Communications Corporation. FrameMaker is a registered trademark of
Frame Technology Corporation.

Rather than put a trademark symbol in every occurrence of other trade-
marked names, we state that we are using the names only in an editorial
fashion, and to the benefit of the trademark owner, with no intention of
infringement of the trademark.

Production notes

This document was created electronically using FrameMaker® 5.
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1 OVERVIEW

Using this manual
Welcome to Melanie II 2-D PAGE analysis software . Melanie II 2-D PAGE is a
complete state-of-the-art software to view, process and analyze images of two-
dimensional electrophoresis (2-DE).

This manual is divided into six parts. The first three parts are devoted to Mel-
View, Melanie’s main program. Part I gives an overview of the Melanie II
2-D PAGE software, as well as the basic procedures for analyzing 2-DE
images. Part II details the necessary steps for comparing images. Part III pre-
sents advanced features, such as editing, image creation and working with
remote databases, as well as analyzing resulting data. Part IV is dedicated to
MelBatch , a companion program that provides 2-DE analysis in batch (non-
interactive) mode. The two tutorials in part V describe typical sessions with the
MelView software, using 2-DE gels provided on the distribution CD-ROM. We
strongly suggest you read through this section before working with Melanie II
2-D PAGE. Part VI provides technical support information. Finally, an index is
supplied at the end of the manual.

Appendix A details the algorithms and methods used in Melanie II 2-D PAGE.

Important points in the manual, as well as useful hints are marked by a small
hand in the margin in order to draw your attention.

The manual is also available on-line in the MelView program (See On-line help
on page 3-1).
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Important note

This manual describes the Melanie II 2-D PAGE software release 2.2 for PC,
Macintosh and Unix. The functionality and usage are similar on the three ver-
sions. Where necessary, we highlight the differences. Also, files are placed in
directories, that are called folders on the Macintosh. For sake of clarity, we
always refer to directories. Macintosh users will rectify easily.

Hardware and software requirements

Environment

Melanie II 2-D PAGE release 2.2 for PC compatible requires the following mini-
mal hardware environment:

Windows 95 or MS-Windows NT 4.0 (or later)® and 32 MB of memory. We rec-
ommend 64 or even 128 MB of memory to process many gels simultaneously.

Melanie II 2-D PAGE release 2.2 for Unix  requires the following minimal hard-
ware and software environment:

Sun Microsystems® workstations (SPARCstation® series), 32 MB of memory,
SunOS® 4.1.x (Solaris 1) or Solaris 2, and either X-Windows X11R4, X11R5 or
OpenWindows3®. We recommend at least 100 MB of swap space to process
several gels simultaneously.

Melanie II 2-D PAGE release 2.2 for Macintosh  requires the following minimal
hardware environment:

Apple Power Macintosh® and 32 MB of memory. We recommend 64 or even
128 MB of memory to process many gels simultaneously. Alternatively, you may
use a Power Macintosh® with less memory, and define virtual memory, though
performances will not be as good.

Programs and files distributed with the Melanie II
2-D PAGE package

Melanie II 2-D PAGE programs
• MelView  - Melanie II main program

• MelBatch  - program to perform actions in batch mode

PC

Unix

Macintosh
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• MelLicense  - license manager (Unix only)

• MelProgress  - progress report program (Unix only)

• elmadmin  - Melanie II license administrator (Unix only)

• elmd  - Melanie II license demon (Unix only)

Public domain programs
• Melxwd (Unix only)

• Melgiftopnm (Unix only)

• Melpgmtolpr (Unix only)

• Melpgmtops (Unix only)

• Melpnmscale (Unix only)

• Melppmtogif (Unix only)

• Melppmtopgm (Unix only)

• Melxwdtoppm (Unix only)

Master protein maps
• CSF.mel  - Human cerebrospinal fluid

• ECOLI.mel  - Escherichia coli

• ELC.mel  - Human erythroleukemia cell

• HEPG2.mel  - HepG2

• HEPG2SP.mel - HepG2 secreted proteins

• LIVER.mel  - Human liver

• LYMPHOMA.mel - Human lymphoma

• PLASMA.mel - Human plasma

• PLATELET.mel  - Human platelet

• RBC.mel  - Human red blood cell

• U937.mel  - Macrophage like cell line

• YEAST.mel  - Yeast (Saccharomyces cerevisiae)

Example images
• Three images in directory Gels

• Same images after complete analysis in directory Gels-analyzed

• Six Plasma gels after complete analysis in directory Gels-analyzed

Other files
• Manual and tutorial files in directory man (Unix) or Help (PC or Macintosh).

Licence hardware protection key (for PC version)

To run MelView you need to install the provided hardware protection key on the
parallel port (see the Release Notes).
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Licence hardware protection key (for the Macintosh
version)

To run MelView you need to install the provided hardware protection key
between the computer and the keyboard (see the Release Notes).

Netscape Navigator ®

In order to use the on-line manual, as well as to access remote databases over
Internet, you must install the Netscape Navigator® World-Wide Web browser
from Netscape Communications Corp., Mountain View, California, USA. You
can purchase this product from Netscape Communications Corp., or download
a free copy for non-commercial use by anonymous FTP from the following FTP
sites that are available at Netscape Communications Corp.:

FTP sites:
• ftp.netscape.com

• ftp1.netscape.com

• ftp2.netscape.com

• ftp3.netscape.com

• ftp4.netscape.com

• ftp5.netscape.com

• ftp6.netscape.com

• ftp7.netscape.com

Directory

/pub/navigator/Right_version/windows/ (for the PC version)

/pub/navigator/Right_version/unix/ (for the Unix version)

/pub/navigator/Right_version/mac/ (for the Macintosh version)

where Right-Version  is the version you want to download. Mirror sites exist
in other geographical areas and you may download Netscape from them. To
obtain an updated list of FTP sites, get the following document from Netscape
Communications Corp.’s Web site:

http://home.netscape.com/comprod/netscape_products.html

or Netscape Communications Corp.’s main Web page:

http://home.netscape.com/

To download the PC version of this software, type the following command:

> ftp FTP-site
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where FTP-site  is one of the FTP sites above. Enter anonymous  as user
name and give your full electronic mail address as password. Then enter the
following sequence of commands:

> cd /pub/navigator/Right-Version/windows/

> bin

> dir

Find the correct version corresponding to your computer and operating system
(16 or 32 bits), then type:

> get Right-Version

> quit

where Right-Version  is the version you want to download. Double-click on
the downloaded file and follow the installation instructions.

To download the Unix  version of this software, type the following command:

> ftp FTP-site

where FTP-site  is one of the FTP sites above. Enter anonymous  as user
name and give your full electronic mail address as password. Then enter the
following sequence of commands:

> cd /pub/navigator/Right-Version/unix/

> bin

> dir

Find the correct version corresponding to your computer and operating system
(SunOs or Solaris), then type:

> get Right-Version

> quit

where Right-Version  is the version you want to download. Uncompress the
downloaded file and follow the installation instructions.

To download the Macintosh  version of this software, use Fetch (a freeware
program), or any other FTP program. Double-click on the fetch icon. Enter the
following information:

Host: FTP-site

where FTP-site is one of the FTP sites above,

User ID: anonymous
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Password: your full electronic mail address

Directory: /pub/navigator/Right_version/mac/

Click OK. Then select the latest version of Netscape and click on Get Files.
Provide a file name to save the program and click OK. Once the program is
downloaded, double-click on its icon.

Overview of Melanie II 2-D PAGE
Melanie II 2-D PAGE is a complete state-of-the-art software application
designed to analyze images of two-dimensional electrophoresis (2-DE). You
may perform qualitative and quantitative image analysis of 2-DE gels. MelView
is the main program and provides interactive as well as automatic gel analysis.

Manipulating images

2-DE images may be manipulated in various ways. Images may be displayed in
tile mode (one gel next to the other) or in stack mode (two gels on top of each
other). They may be zoomed. Various color modes are provided in order to best
visualize spots. Selected 2-DE images or the whole MelView screen may be
printed. Images may be imported from or exported to various file formats such
as TIFF, GIF and PPM.

Detecting and quantifying features

Melanie II automatically detects features  (spots) on several gels at once. Vari-
ous reports on feature values such as optical density (or instrument counts for
non-optical images), area and volume are computed and may be displayed,
printed or saved to files.

Landmarks and labels

You may add landmarks  to gels in order to mark specific points on the image.
Landmarks may just hold a name, or they can be associated to pI and Mw val-
ues. They may also be used as starting points for the gel matching program.

Labels  may be defined and associated to detected features. They are most
often used to mark identified proteins. They hold the accession numbers (iden-
tification numbers) and names of the proteins.

Aligning and matching gels

Gels may be aligned , that is distorted gels will be stretched pixel wise, in order
to make a set of images completely superimposable. Aligned or non-aligned
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gels may be automatically matched , i.e. corresponding features will be paired
across gels.

Grouping features

A set of gels may be matched to one reference gel. All features paired with the
same spot in the reference gel may then be clustered to form groups . A group
represents the same spot over a set of gels. Reports on groups, as well as his-
tograms may be displayed, printed or saved. Groups may also be exported to
ASCII tables in order to be used with external programs such as Excel or other
data analysis packages.

Analyzing sets of gels

Statistical data analysis may be performed on groups of features in sets of gels.
Variations, differences and similarities are computed. Classes of gels may be
created to represent different populations. Reports on the analysis results, as
well as graphics may be displayed, printed or saved.

Creating new images

Gel images may be duplicated, flipped, scaled or cropped. Filters are provided
to improve image quality, such as contrast enhancement, smoothing and back-
ground subtraction. Synthetic gels  may be produced by merging spot informa-
tion from several gels. Gaussian modeling of features is also supplied.

Querying databases

Master gels  may be defined, or those provided on the distribution CD-ROM
may be used. A master gel contains labels for each identified protein. These
proteins may then be automatically linked to remote databases such as
SWISS-2DPAGE or SWISS-PROT through the use of Netscape Navigator®.

MelBatch

In the MelView program, actions may be carried out on open gels only. The
MelBatch  program is supplied to perform certain actions on gels without the
need of displaying them. In this way, feature detection and quantification fol-
lowed by gel matching may be performed on a set of gels as a background pro-
cess.
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The Melanie II 2-D PAGE file format
The Melanie II programs work with Melanie II release 2 file formats, as well as
with TIFF files. Analyzed gels are always saved into the Melanie II release 2 file
format, unless otherwise specified by the user.

Gel images may be imported from or exported to other formats such as TIFF,
GIF and PPM.

Running MelView

To run the MelView program, PC release , double-click on the MelView  icon.
You may also run the MelView program by double-clicking on the icon of a gel
image file. In this way the given gel will automatically be opened upon running
the program.

To run the MelView program, Unix release , type the following command:

> MelView &

The & sign indicates that the MelView program has to run in background. You
have to make sure that the directory in which the MelView program resides is
part of your path. Type

> echo $path

to verify this. If it is not in the path, please refer to the Unix manual to include it.

You may also run the MelView program and automatically open gel images.
Type the MelView command followed by the gel names. For example, to open
gels GelA and GelB, type:

> MelView GelA GelB &

To run the MelView program, Macintosh release , double-click on the MelView
icon.

You may also run the MelView program by double-clicking on the icon of a gel
image file. In this way the given gel will automatically be opened upon running
the program. Alternatively, you may select several gel image files and choose
File → Open in the Macintosh menu, or even drag and drop gel icons onto the
MelView icon. Note that if you have transferred images to the Macintosh using a
program such as Fetch, this option is only available if you specified MELA as
the creator and TIFF as the type during file transfer.

PC

Unix

Macintosh
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Upon loading the program the Melanie II 2-D PAGE logo appears. Click on the
logo to get rid of it.
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2 THE MELVIEW

COMPONENTS

The MelView window is divided into three parts: the horizontal menu bar  on the
top, the vertical tool bar  on the left side of the window and the rectangular dis-
play area . Figs. 2-1, 2-2 and 2-3 show the starting MelView display on PC,
Macintosh  and Unix , respectively. In the remaining part of this manual, figures
illustrate screens from the PC version only. The display is similar on Unix and
Macintosh. When necessary, screen displays from specific platforms will be
shown. . .

Figure 2-1. The MelView display on the PC.
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You may use the tools to select objects in the display area, then apply actions
from the various menu options to the selected objects. Objects are gel images,
landmarks associated to specific points on the image, features (detected
spots), labels associated to features, feature pairs between two gels, groups of
features across several gels, or comments on gels.

This chapter describes the functionality of the various MelView components.
Their practical use will be discussed in detail in the following chapters.

Figure 2-2. The MelView display on the Macintosh.

Figure 2-3. The MelView display on Unix.
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Objects
A Melanie II object is an entity that may be displayed and manipulated. The
objects are gels, as well as gel components such as regions, landmarks, fea-
tures, labels, pairs, groups or comments.

Gels

A gel  is a 2-DE image that has been digitized and stored on disk in the
Melanie II 2-D PAGE release 2 format. Images in other formats (TIFF, GIF,
PPM) may also be opened as gels, but they have to be saved into the Melanie II
format in order to keep objects such as detected feature shapes, feature val-
ues, pairs, etc. Other file formats may only contain plain unstructured images. If
a gel is saved with its objects into a foreign format, then the objects will simply
be part of the saved image and will have lost any structure or value.

The gel image is the raw input data to the MelView program, from which fea-
tures may be detected and quantified. Gels may also be duplicated, erased,
cropped, filtered, flipped or scaled. Synthetic gels may be created by merging
spots from other gels.

Regions

A region  is a rectangular subpart of a gel that can be defined using the Region
tool. When a region is defined, certain actions may be limited to it (Fig. 2-4).

Landmarks

Individual points (pixels) in a gel may be marked by landmarks , using the
Landmark tool. A landmark is defined by its position (row and column number)
and its name. It may be assigned pI and MW values. pI and MW values of land-
marks are used to compute an approximated pI and Mw value for any point in a

Figure 2-4. Feature shapes, a landmark and a label in a region

Region

Landmark Label

Features
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gel. Landmarks may also be used as reference points for operations such as
gel alignment and gel matching (Fig. 2-4).

Features

The elementary component of a gel is the feature . Features are spot shapes
automatically detected by Melanie II’s feature detection algorithm, or manually
adjusted by the user (Fig. 2-4). Gels may be displayed with or without their fea-
ture shapes. Each feature in a gel has an associated feature ID  (a unique
sequential number) automatically given when it is created. Features may be
quantified, i.e. their optical density (or instrument count for non-optical images),
area and volume are computed. Alternatively, features may be modeled by Mel-
anie’s Gaussian modeling algorithm. In this case their quantification values will
be the bi-Gaussians peak values and volume, as well as the area of the Gauss-
ian’s half-height section.

Features represent the proteins from the original image. Features may auto-
matically be paired between two gels, or groups of features may be formed
across a series of gels. Quantification values of spot groups may then be dis-
played or printed as histograms, or exported as tables for use with external data
analysis programs.

Labels

The label  is a small tag associated to a feature and identifying the correspond-
ing protein. The label holds the protein’s accession number (AC) and name
taken from a user-selected database, or it may just contain any textual data.
The label is the link to MelView’s remote database query engine (Fig. 2-4).

Pairs and groups

Gels may be compared using Melanie’s powerful automatic gel matching pro-
gram. When two gels are matched the corresponding features are paired .
Selected feature pairs may be displayed when gels are in tile mode. Alterna-
tively, all pairs may be shown as small vectors when two gels are displayed in
stack mode. Gels can be matched pair wise, or a set of gel images can be
matched to a user-chosen reference gel. A reference gel may be any 2-DE gel
image, a master gel image or even a synthetic gel image. The pair is the link
between corresponding features, i.e. the same protein in several gels.

When several gels have been matched to a given reference gel, the latter pro-
vides a unique feature numbering scheme across all gels. Each paired feature
in a gel image may then be associated to the corresponding feature ID in the
reference gel. The features in a set of gels that are paired to one given feature
in the reference gel form a feature group . The group is the basic element for
exporting data as tables, and for producing histograms of feature values across
a series of gel images.
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Comments

Textual data may be associated to individual gels in the form of comments.
Comments may be displayed, printed or saved to files.

Selecting and showing objects
Objects may be either shown , hidden  or selected . When an object is shown, it
is visible on the screen. Objects may also be selected using one of the tools
from the left hand side vertical tool bar or using certain menu options (for exam-
ple Select → Features → All Features). Once selected, an object is marked in
green. The green color is always used to highlight selected objects. If an object
is shown, i.e. if it is visible, this does not mean it has been selected. As a gen-
eral rule, actions from the menus may only be performed on selected objects.
Objects may also be hidden, so that they are not visible on screen.

Mouse buttons
The mouse may be used in various manners, each having a specific behavior
depending on the active tool (See Tools on page 2-6).

Mouse click

In Melanie II for PC, the most common way to use the mouse is to move it so as
to position the cursor over a given object, then press the left mouse button, then
quickly release it. In given situations, you may also click the middle or the right
mouse button. Generally, the right mouse button is used to manipulate corre-
sponding objects on several visible gels. With a 2-button-mouse, the middle
button is replaced by pressing the Control key and the right button simulta-
neously.

Important  The left mouse button being the most frequently used, we shall
sometimes in this manual refer to it by just saying the mouse button or click on
the mouse.

In Melanie II for Unix , the most common way to use the mouse is to move it so
as to position the cursor over a given object, then press the left mouse button,
then quickly release it. In given situations, you may also click the middle or the
right mouse button. Generally, the right mouse button is used to manipulate
corresponding objects on several visiblegels.

PC

Unix
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Important  The left mouse button being the most frequently used, we shall
sometimes in this manual refer to it by just saying the mouse button or click on
the mouse.

In Melanie II for the Macintosh , the most common way to use the mouse is to
move it so as to position the cursor over a given object, then press the mouse
button, then quickly release it. In given situations, you may also hold down the
Option key ( ) and click the mouse button at the same time, or hold down the
Command key ( ) and click the mouse button. Generally, the Command key /
mouse button combination is used to manipulate corresponding objects on sev-
eral visible gels.

Dragging

In Melanie II for PC or Unix , you may also push down the left mouse button,
and then, without releasing it, move the mouse in order to drag objects from
one place to the other. In given situations, this is also possible using the middle
or the right mouse buttons.

In Melanie II for the Macintosh , you may also push down the mouse button,
and then, without releasing it, move the mouse in order to drag objects from
one place to the other. In given situations, this is also possible using the Com-
mand key ( ) / mouse button or Option key ( ) / mouse button combina-
tions.

Note that when you want to move the MelView window while a dialog window is
displayed, you have to hold down the Option key ( ) and drag the window
with the mouse.

Tools

Objects on screen may be displayed, manipulated or processed using the vari-
ous options from the MelView menus. Prior to choosing an option from the

Macintosh

PC / Unix

Macintosh
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menu bar, individual objects have to be selected using the tools  provided in the
left hand side tool bar (Fig. 2-5).

The Select tool

The Select tool is used to select individual gels. To select one gel, pick the
Select tool in the tool bar. The Select tool will be surrounded by a small black
rectangle showing that it is active. Put the cursor in a gel and click on the
mouse button. The gel will be surrounded by a green line indicating that it has
been selected. To select more than one gel, select the first one as described
above, then hold the shift key on the keyboard and select additional gels by
clicking on them.

This rule holds for any kind of objects in MelView: to select several objects of
the same kind, pick the corresponding tool from the tool bar, select the first
object by clicking on it with the mouse button, then hold the shift key on the key-
board and select additional objects by clicking on them.

The Hand tool

The MelView window is often not large enough to display the whole gel images,
and only a small part of the gels will be visible at one given time. The Hand tool
moves gels in order to show other parts. Pick the Hand tool in the tool bar, put
the cursor in a gel, hold down the mouse button and drag the mouse. The gel
image will follow your movement.

If instead you hold down the middle mouse button1, then all selected gels will
move together.

1. On the PC mouse with 2 buttons, hold down the Control key and the right mouse but-
ton. On the Macintosh, hold down the Option key ( ) and the mouse button.

Figure 2-5. The MelView tool bar

Select tool

Hand tool

Region tool

Landmark tool

Feature tool

Label tool

Magnify tool
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By holding down the right mouse button1, you will position all gels according to
the absolute cursor position in the pointed gel. That is, the top left corner of
each visible gel area will correspond to the same pixel (in absolute row and col-
umn positions).

The Region tool

The Region tool is useful to select a rectangular subregion of a gel. Position the
cursor at the top left position of the desired region, hold down the mouse but-
ton, then drag the cursor to the bottom right position. A rectangle will be drawn
around the region while selecting it. Release the mouse button at the desired
point. You may move the region by dragging the rectangle’s top left corner. You
may also change its size by dragging its bottom right corner.

If gels have been aligned (see Aligning gels on page 7-1) then you may use the
right mouse button1 to select the same region in all aligned gels simultaneously.

The Landmark tool

The Landmark tool is used to create or select landmarks at specific points on
the gel image. To create a landmark, pick the Landmark tool, then double-click
the mouse button at the position you want the landmark to be. To select an
existing landmark, just click on it. To select more than one landmark, select the
first one by clicking on it with the mouse button, then hold the shift key on the
keyboard and select additional landmarks by clicking on them. To select all
landmarks in a given region, position the cursor at the top left position of the
desired region, hold down the mouse button, then drag the cursor to the bottom
right position. All landmarks in the selected region will be selected and high-
lighted in green.

If gels have been aligned (see Aligning gels on page 7-1), you may use the right
mouse button1 to select landmarks in all aligned gels simultaneously. See
detailed discussion on landmarks in Landmarks on page 4-1.

The Feature Tool

The Feature tool lets you select individual features. To select a feature, pick the
Feature tool and click on the chosen feature. To select more than one feature,
select the first one by clicking on it with the mouse button, then hold the shift
key on the keyboard and select additional features by clicking on them. To
select all features in a given region, position the cursor at the top left position of
the desired region, hold down the mouse button, then drag the cursor to the
bottom right position. All features in the selected region will be selected and
highlighted in green. The selected region delimits an area of the gel which
given actions will be limited to.

1. On the Macintosh, hold down the Command key( ) and the mouse button.
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If gels have been aligned (see Aligning gels on page 7-1), you may use the right
mouse button1 to select features in all aligned gels simultaneously. See
detailed discussion on features in Features (spots) on page 5-1.

The Label tool

With the Label tool you may select labels. To select a label, pick the Label tool
and click on the chosen label. To select more than one label, select the first one
by clicking on it with the mouse button, then hold the shift key on the keyboard
and select additional labels by clicking on them. To select all labels in a given
region, position the cursor at the top left position of the desired region, hold
down the mouse button, then drag the cursor to the bottom right position. All
labels in the selected region will be selected and highlighted in green.

If gels have been aligned (see Aligning gels on page 7-1) then you may use the
right mouse button1 to select labels in all aligned gels simultaneously. See
detailed discussion on labels in Labels on page 6-1.

The Magnify tool

The Magnify tool lets you zoom in on the region of a gel around the cursor posi-
tion. Just pick the Magnify tool, then hold down the mouse button. Similar to a
magnifying glass, you may then move the mouse to change the zoomed region.

If gels have been aligned (see Aligning gels on page 7-1), you may use the right
mouse button1 to magnify the same region in all aligned gels simultaneously.

Menus
Once objects have been selected, you may choose actions from the menus to
be performed on them. Move the cursor to the desired menu on the menu bar
located at the top of the MelView window, hold down the mouse button, then

1. On the Macintosh, hold down the Command key( ) and the mouse button.
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choose a menu option. Certain menu options have sub-options you may
choose from by dragging the cursor over the small arrow on the right hand side
of the option (see Fig. 2-6).

The following menus are provided in the MelView program (from left to right in
the menu bar):

1 File  - to handle whole gels and data on disk (open and close gel images, save
data, print images, export data).

2 Edit  - to edit (add, modify, delete) selected objects.

3 Select  - to select specific objects.

4 Show  - to show or hide specific objects, as well as to display reports.

5 Stack  - to handle stacked gels (two gels on top of each other).

6 Image  - to create new gel images from selected ones (duplicate, crop, filter
gels, create synthetic or Gaussian gels, flip and scale gels, as well as erase
gels).

7 Process  - to detect and quantify features, and to align and match gels.

8 Analyze  - to compute differences and similarities among gels (statistical data
analysis).

9 Database  - to handle master gels and to access remote 2-DE databases.

10Help  - to obtain on-line help.

At given points in time, depending of the status of the MelView window, certain
menu options will not be available. In this case, they will appear faded in the
menus.

Shortcuts

Several menu options may be activated by keyboard shortcuts. These are indi-
cated at the right hand side of the corresponding menu option.

In Melanie II for PC or Unix , for example, you may activate the Open Gels
action by holding down the Control key and the O key simultaneously (lower or
upper case). This is indicated next to the Open menu option by the ^O sign.
Similarly, you may exit MelView by hitting ^Q.

Figure 2-6. Choosing a sub-option from the menu

PC / Unix
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In the same way, in Melanie II for the Macintosh , for example, you may activate
the Open Gels action by holding down the Command key ( ) and the O key
simultaneously (lower or upper case). This is indicated next to the Open menu
option by the O sign. Similarly, you may exit MelView by hitting Q.

Macintosh
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3 BASIC PROCEDURES

This chapter presents basic MelView procedures such as opening, saving and
closing gels, manipulating gel images (such as changing colors and zoom
modes) and printing them.

On-line help

The manual is also available on-line in the MelView program. To consult it on-
line:

- in Melanie II for Unix , choose Preferences in the File menu. Set the Melanie
Home directory to the directory in which the man directory resides, usually the
same as the Melanie II programs.

- in Melanie II for the PC or Macintosh  make sure that the Help folder is located
in the same folder as the MelView application.

Then, in the Help menu, choose Tutorial. On-line user manual and index are
available too. To access the on-line tutorial and user manual, you must have the
Netscape Navigator® World-Wide Web browser installed.

You may choose the table of content document from which you can read any of
the on-line manual chapters, or you can request the on-line index, then click on
the desired concept to obtain the related on-line chapter. You may also directly
refer to the on-line tutorial. Go to the Help menu and choose one of the avail-
able options.

Unix

PC / Macintosh
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If Netscape was running before MelView, and if the colors in Netscape do not
look correct, quit Netscape and choose the Help option again.

Setting preferences
A few preferences may be set and preserved between MelView sessions. In
menu File, choose Preferences. You may set the following preferences:

In Melanie II for Unix  -

1 The Netscape Navigator® full pathname. To use the on-line manual as well as
the database options (see Databases on page 14-1) you must give the exact
location of the Netscape program (for example: /usr/local/bin/netscape).

2 The database server. To use the database options (see Databases on page 14-
1) you must specify the hostname of the World-Wide Web server on which the
database resides (for example: www.expasy.ch).

3 The database name. To use the database options (see Databases on page 14-
1) you must specify the remote database (for example: SWISS-2DPAGE).

4 The printer. You have to give the printer name (for example: lp).

5 The Melanie Home directory. This is the directory in which the on-line manual
files resides, the man directory, usually the same as the Melanie II programs.

In Melanie II for PC or Macintosh  -

1 The database server. To use the database options (see Databases on page 14-
1) you must specify the hostname of the World-Wide Web server on which the
database resides (for example www.expasy.ch).

2 The database name. To use the database options (see Databases on page 14-
1) you must specify the remote database (for example: SWISS-2DPAGE).

In the Preferences window, click on the OK button. If preferences were already
found on disk, MelView will ask you to confirm the new preferences.

Opening gels

Opening Melanie 2-DE images

In Melanie II for PC:

Unix

PC / Macintosh

PC
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Click in the File menu and select the Open option. The Open window will be
displayed (Fig. 3-1). Hold down the Shift key and, in the Files column, click on

each of the gel file names you want to open. To choose discontinuous file
names, hold down the Control Key and click on the file names. Click on the OK
button. The gels will be opened.

In Melanie II for Unix :

Click on the File menu and select the Open option. The Open window will be
displayed (Fig. 3-2). Hold down the Control key and, in the Files column, click

Figure 3-1. The Open window allows the selection of the gels that will be
opened and loaded into MelView, PC release

Figure 3-2. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Unix release

Unix
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on each of the gel file names you want to open. To choose discontinuous file
names, hold down the Shift Key and click on the file names. Click on the OK
button. The gels will be opened.

The Open menu option allows you to open gel images stored on disk in the
Melanie II release 2 or Melanie 1 format. Melanie 1 images will be converted to
Melanie II release 2 file format. MelView will ask you for confirmation. You can-
not open Melanie 1 images without converting them to the new format. If you
want to keep the image in the old Melanie 1 format, use the Open As menu
option (see next section).

In Melanie II for the Macintosh :

Click on the File menu and select the Open option. The Open window will be
displayed (Fig. 3-3). Click on each of the desired gel names and each time click

on the Add button, or just double-click on each gel name. This adds the
requested gels to the Open gel box. Click on the Done button. The gels will be
opened.

Opening foreign image formats

MelView allows you to import images stored in foreign image file formats, such
as TIFF (8 or 16 bits), GIF or PPM. In the Unix  release, MelView also lets you
import the Elsie and Melanie 1 formats, Choose File → Open As. In the Open
As window that pops up, choose one of the available formats. Click OK. In the
next pop-up window, select the images you want to open, following the above
described procedure. Click on the OK button (on the Done button on the Macin-
tosh). Opening a Melanie II image in this way lets you open a copy of the gel
image.

Figure 3-3. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Macintosh release

Macintosh
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Selecting gels
To perform the actions described in the remaining part of this chapter, you must
first select one or more gels. This may be achieved using either the Select tool
or one of the Gels options in menu Select.

To select one gel, pick the Select tool in the tool bar. The Select tool will be sur-
rounded by a small black rectangle showing that it is active. Put the cursor in a
gel and click on the mouse button. The gel will be surrounded by a green line
indicating that is has been selected. To select more than one gel, select the first
one as described above, then hold the shift key on the keyboard and select
additional gels by clicking on them.

Alternatively you may select all visible gels in the MelView window by choosing
Select → Gels → Visible Gels, or only the aligned gels by taking Select →
Gels → Aligned Gels (See Aligning gels on page 7-1) or just the stacked gels
by taking Select → Gels → Stacked Gels (See Stacking gels on page 3-13).

Showing gels / reporting on gels
Once you have opened a given number of gel images, you can decide which
ones you want to display and which ones you prefer to hide at a given point in
time. The Gels option in menu Show provides the following choices to this pur-
pose:

• Selected Gels - displays all selected gels and hides the other ones.

• Aligned Gels - displays all aligned gels (See Aligning gels on page 7-1) and
hides the other ones.

• Stacked Gels - displays all stacked gels (See Stacking gels on page 3-13) and
hides the other ones.

• All Gels - displays all opened gels, including the currently hidden ones.

• Show Comments - displays the comments for the selected gel (See Editing /
showing comments on page 11-5).
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• Report On Gels - Displays a report summarizing information about the selected
gels, such as image size in pixels, minimum and maximum grey levels, number
of detected features (Fig. 3-4).

• Report On Matches - Displays information on matching between the selected
gels and all open gels, that is the number of paired features between each pair
of gels (See Matching gels on page 8-1).

• Report All Matches - Displays information on matching between all gels in a
given directory (See Matching gels on page 8-1). A pop-up window requests
the directory name (default: current directory).

Moving gels
The size of the MelView window usually does not allow to display whole gels. At
any point in time you may determine to move gel images in order to show other
image parts. You may also change the way in which gels are arranged on the
screen.

Showing corners

The Show Corner option lets you choose to display the top left, top right, bot-
tom left or bottom right part of the selected gels. Just take Show → Show Cor-
ner, then choose the corresponding sub-option.

Using the Hand tool

The Hand tool allows you to interactively move one or several gels. Pick the
Hand tool in the tool bar, put the cursor in a gel, hold down the mouse button
and move the mouse. The gel image will follow your movement.

Figure 3-4. Report on gels
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If instead you hold down the middle mouse button1, then all selected gels will
move together.

By pressing the right mouse button2, you will position all gels according to the
absolute cursor position in the pointed gel. That is, the top left corner of each
visible gel area will correspond to the same pixel (in absolute raw and column
position).

If you cannot select a gel, because it was moved outside the visible parts of the
screen while using the hand tool, then select all gels with Select → Gels →
Visible Gels and Show → Show Corner.

Using the Select tool

You may change the order in which gel images are arranged on the screen.
Pick the Select tool, put the cursor in the gel you want to shift, then hold down
the mouse button and move the cursor over another gel. Release the mouse
button. The two gels will be swapped.

Zooming
Another method to decide what part of a gel should be displayed is to change
the zoom mode. You may zoom in to enlarge the image (you will see less of the
image at once) or zoom out to see more of the gel image.

Selecting zoom mode

Select the gels you want to zoom, then take Select → Select Zoom and choose
the zoom mode: 1 is the default mode and displays images in real size; 2
zooms in by a factor of 2; 1/2 and 1/4 zoom out by a factor of respectively 2 and
4.

1. On the PC mouse with 2 buttons, hold down the Control key and the right mouse but-
ton. On the Macintosh, hold down the Option key ( ) and the mouse button.

2. On the Macintosh, hold down the Command key( ) and the mouse button.
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Using the magnifying glass

An alternative way to enlarge parts of gels is to use the magnifying glass. Pick
the Magnify tool, then hold down the mouse button. Similar to a magnifying
glass, you may then move the mouse to change the zoomed region (Fig. 3-5).

If gels have been aligned (see Aligning gels on page 7-1) then you may use the
right mouse button1 to magnify the same region in all aligned gels simulta-
neously.

Changing colors
A 2-DE gel image is traditionally displayed as a grey level image, where grey
levels represent the gel’s optical density (respectively instrument counts for
non-optical images). You may opt to display images using pseudo colors. You
may also change the way grey levels are displayed.

Adjusting colors

Modern scanners are usually able to scan 2-DE images with 12 or even 16 bits
per pixel, that is with 4096 or 65536 grey levels, respectively. Because common
screens are only able to display 256 colors or grey levels, mapping has to be
undertaken between the 4096 or 65536 grey levels, respectively and the 256
screen grey levels. By default, MelView uses a linear mapping function, where
the lightest point in the image is mapped to 0 (white) and the darkest point is

1. On the Macintosh, hold down the Command key( ) and the mouse button.

Figure 3-5. The magnifying glass
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mapped to 255 (black) (Fig. 3-6). However, you may choose other mapping

functions, e.g. in order to highlight small light spots.

MelView lets you change the grey level mapping in two different manners. You
can define the minimum (0) and maximum grey levels (255), i.e. you may look
at only the light or the dark regions of the images (Fig. 3-7). Or you can change

Figure 3-6. default linear mapping: minimum image grey level is mapped
to white and maximum grey level is mapped to black.
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the default linear mapping function to an exponential or logarithmic one
(Fig. 3-8 and 3-9).

Figure 3-7. Mapping the light image pixels; grey levels 1016 to 3844 in the
original image will appear black.

Figure 3-8. Using a logarithmic mapping function, light spots appear
darker.
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To change the mapping function, select some gels, then choose Select →
Select Mode → Adjust Colors. Then, in the Adjust Colors window, change the
minimum and maximum grey levels, as well as the mapping function. You may
increase or decrease the curvature of the exponential or logarithmic function by
adjusting the respective sliders (Fig. 3-10).

Hold down the left mouse button and move the slider1.

Click OK. Colors will be adjusted in all selected gels.

If you save gels after having performed color adjustments, the latter will be
saved with the gel images (see Saving gels on page 3-15).

Adjusting colors in real-time

Each change of the mapping function in the Adjust Colors window may immedi-
ately be reflected in a given region, if such a region has been defined prior to
adjusting colors. Select the Region tool and draw a small rectangle in one of the
selected gels by putting the cursor at the top left point of the region, holding
down the mouse button and dragging the cursor to the bottom right point.
Release the mouse button. The selected region will be delimited by a rectangle.
In the Select menu, choose Select Mode → Adjust Colors. Each time you

1. On Unix, you can also click once on the slider and adjust it using the arrow keys. On
the Macintosh, you can also adjust the slider using the arrows.

Figure 3-9. Region of a gel showing the color adjustment from Figure 3-8:
the left image shows the original image; the right image shows the same
gel area after mapping with a logarithmic function.
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change one of the mapping parameters (the function or a slider), the change
will immediately be reflected in the selected region (Fig. 3-10).

Note that if the small rectangle temporarily disappears from the display, when
the Adjust Colors window pops up, slightly change one of the parameters.

Click on the OK button. The grey levels (or colors if you have set pseudo colors
- see next section) will be adjusted in all selected gels.

In Melanie II for the Macintosh , note that if you want to move the MelView win-
dow while the Adjust Colors window is displayed, you have to hold down the
Command key ( ) and drag the window with the mouse.

Selecting pseudo colors

Choose Select → Select Mode → Pseudo Colors. Choose one of the color
lookup tables, for example FiveRamps. Click OK. The lookup table will be

Figure 3-10. The Adjust Colors  option. The modifications are directly
reflected in the selected region.

Macintosh



BASIC PROCEDURES

The Melanie II User Manual 3-13

changed accordingly (Fig. 3-11). To go back to grey levels, choose Select →
Select Mode → Grey Levels.

Selecting grey levels

This is the default mode. To select this mode, choose Select → Select Mode
→ Grey Levels.

Stacking gels

In given situations it is helpful to stack two gels, i.e. to display one gel on top of
the other. By switching from one gel to the other you may then better compare
given gel areas. Select two gels, then Stack → Stack Selected Gels. The two
gels will be displayed on top of each other. To switch from one gel to the other,
choose Stack → Front To Back, or just Control1-F. By pressing Control1-F
quickly several times, the differences between the two gels can be observed
visually. To unstack the gels, choose Stack → Unstack Selected Gels.

1. On the Macintosh, use  instead.

Figure 3-11. Gels displayed using the FiveRamps color lookup table.
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Moving stacked gels

MelView provides a means to superimpose corresponding features of stacked
gels in a simple way. Select the Hand tool. When two gels are stacked and
selected, you may use the mouse button to move the front gel.

By holding down the middle mouse button1, both gels will be moved at the
same time.

To superimpose two features, put the cursor on the given feature in the front
gel, then hold down the mouse button. Press Control2-F to display the other
gel. Move the cursor to the corresponding feature and release the mouse but-
ton. The two features will be superimposed. Verify this by pressing Control2-F.

Printing gels
Two print modes are provided in MelView. You may print selected gels, one gel
image per page, or print the whole MelView window.

In Melanie II for Unix , you first have to set the printer. Select Files → Prefer-
ences. Make sure to define an existing printer (example: lp). You may also set
the printer from the File → Print → Printer Setup option.

In Melanie II for the PC or Macintosh , select File → Page setup and verify the
settings.

Printing the MelView window

Select File → Print → Print MelView Window. The image of the whole MelView
window is sent to the printer, it means to the Postscript® printer when using the
Unix  release.

Printing selected gels

Select some gels, using the Select tool. Then choose Files → Print → Print
Selected Gels. A pop-up window lets you choose the gel objects to be printed
with the image such as Features, Landmarks, Labels, Vectors, Color Adjust-
ment, Alignment & Zoom. The selected gels will be printed in full size.

1. In the PC mouse with 2 buttons, hold down the Control key and the right mouse but-
ton. In the Macintosh, hold down the Option key ( ) and the mouse button.

2. On the Macintosh, use  instead.



BASIC PROCEDURES

The Melanie II User Manual 3-15

Saving gels
Any changes carried out on gels have to be saved in order to be stored in the
gel file. Otherwise the changes will be lost when exiting the MelView program or
when closing the gels. Choose File → Save → Save Changes to save all
changes performed on the selected gels, or any of the individual saving
options. For example, File → Save → Save Features will only save the
detected feature shapes, but not other changes.

If you save gels after having performed color adjustments, the latter will be
saved with the gel images.

After performing changes on gels, you may revert to the saved status on disk by
choosing one of the Revert options in menu File. Current changes will be lost. If
objects have never been saved to disk for the selected gels, then the Revert
option is not active.

Alternatively, you may save any gel images in one of the supported foreign file
formats. In this case, you can choose to save the gel image alone, or the gel
image with any of its associated components such as features, labels or land-
marks. But the saved file will contain a flat image, without any structure. For
example, when saving a gel with its features to a TIFF file, this file will contain a
flat image of the gel and its features. Choose File → Save As, then select the
objects you want to add to the image and click OK. The File Extension window
will pop-up. You can then enter the names of the new files manually, or use the
Replace Extension or the Add Extension options. Add Extension lets you spec-
ify an extension to add to each new file name, while Replace Extension lets you
replace the file name extensions of the selected gels with any other extension.

Closing gels and exiting MelView
Use File → Close to close all selected gels. If any of the gels have not been
saved since changes were performed, MelView lets you choose to save them
before closing them.

To exit MelView, do File → Quit. MelView lets you choose to save any unsaved
gel images before exiting.
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4 LANDMARKS

Individual points (pixels) in a gel image may be marked by a landmark . A land-
mark is defined by its position (row and column number) and its name. It may
be assigned pI and Mw values. pI and Mw values of landmarks are used to
compute approximated pI and Mw value for any point in a gel. Landmarks may
also be used as reference points for operations such as gel alignment and gel
matching (see Aligning gels on page 7-1 and Matching gels on page 8-1).

Creating landmarks

To create a landmark, pick the Landmark tool and double-click at the position in
a gel where you want the landmark to be located. The Landmark window pops
up. Enter a name. You may also enter the pI and/or Mw of the gel at the given
position. A value of -1  means that no value is set. The pop-up windows also
indicates the selected landmark position in row and column numbers. You can
adjust these by clicking on one of the row or column sliders and moving them
(hold down the mouse button and drag the cursor). To assure fine position
adjustment, click on one of the sliders, then adjust the position using the arrow
keys. Click on OK. The landmark is created, and its name and position are dis-
played on the gel.
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If the landmark contains a pI or Mw value, then its tag will contain an asterisk
(‘*’) (Fig. 4-1).

Alternatively, landmarks may be created with the Edit → Landmarks → Add
Landmarks option. In this case, the Landmark window pops up without prior
landmark position. You then have to specify the landmark position using the
sliders or the arrow keys1.

For aligned gels (see Aligning gels on page 7-1) double-click using the right
mouse button2, in order to create the same landmark at the same position in all
selected aligned gels.

Selecting landmarks
Landmarks may be selected wit the Landmark tool. Click on any landmark to
select it. The selected landmark will be highlighted in green. To select more
than one landmark, select the first one by clicking on it with the mouse button,
then hold the shift key on the keyboard and select additional landmarks by
clicking on them. To select all landmarks in a given region, position the cursor at
the top left position of the desired region, hold down the mouse button, then
drag the cursor to the bottom right position. All landmarks in the selected region
will be selected and highlighted in green.

Landmarks may also be selected from the Select → Landmarks sub-menu.
Choose Select → Landmarks → By Name and enter a landmark name to
select the corresponding landmark. You may use wildcards (‘*’) to select a
group of landmarks. For example, “L*” designates all landmarks whose names
start with the letter ‘L’.

Select a region on a gel using the Region tool, then Select → Landmarks → In
Region to select all landmarks in the selected region, or Select → Landmarks
→ All Landmarks to select all landmarks in all selected gels.

Finally, if some landmarks have already been selected, you have the possibility
to do Select → Landmarks → Inverse Selection. This will unselect the selected
landmarks and select all unselected ones.

1. On the PC or Macintosh, you can use the sliders or the arrows.

2. On the Macintosh, hold down the Command key( ) and the mouse button.

Figure 4-1. A landmark with pI/Mw (shown by the asterisk)
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Showing landmarks
Landmarks may be displayed with the Show → Landmarks → Show Land-
marks menu option, and hidden with the Show → Landmarks → Hide Land-
marks option. You may show only selected landmarks with Show →
Landmarks → Selected Landmarks.

Modifying and deleting landmarks
In the Edit → Landmarks sub-menu, two options allow you to modify and delete
existing landmarks. Edit → Landmarks → Modify Landmarks is available when
one landmark is selected. This pops up the landmark window. You may then
change the various parameters for the selected landmarks. Edit → Landmarks
→ Delete Landmarks deletes all selected landmarks.

You can also manually change a landmark position. Select a landmark with the
Landmark tool. Then move the cursor to the cross representing the landmark
position. Hold down the mouse button and drag the landmark. Release the
mouse button.

To interactively change a landmark’s tag position, select a landmark with the
Landmark tool. Then move the cursor onto the landmark’s tag. Hold down the
mouse button and drag the tag. Release the mouse button (Fig. 4-2).

Figure 4-2. Default landmark tag position (left) and modified tag position
(right).
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Reports on landmarks
Select landmarks using the Landmark tool or the Select → Landmarks options.
Choose Show → Landmarks → Report On Landmarks. A report will be dis-
played giving specific information on the selected landmarks, such as landmark
names, positions and pI/Mw values. The report may be saved or printed
(Fig. 4-3).

A dialog box lets you choose the directory and the file name to save the report
to.

Showing pI and Mw
If you have defined a few landmarks in a gel and given pI and Mw values, you
can display the interpolated pI and Mw values at any point in the gel. Take
Show → ID & pI/Mw. This will display a small window holding the pI and Mw at
cursor position. Moving the cursor will change the window content accordingly
(Fig. 4-4).

Additionally, this option also displays the feature ID, when the cursor is posi-
tioned over a detected feature (see Features (spots) on page 5-1).

Figure 4-3. Report on landmarks

Figure 4-4. The ID & pI/Mw window
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5 FEATURES (SPOTS)

The elementary component of a gel is the feature . Features are spot shapes
automatically detected by Melanie II’s feature detection algorithm, or manually
adjusted by the user. Each feature in a gel has an associated feature ID  (a
unique sequential number) automatically assigned to when it is created. Fea-
tures may be quantified, i.e. their optical density (or instrument count for non-
optical images), area and volume are computed. Alternatively features may be
modeled by Melanie’s Gaussian modeling algorithm. In this case, their quantifi-
cation values will be the bi-Gaussians peak values and volume, as well the area
of the Gaussian’s half-height section (see Creating Gaussian gels on page 12-
5).

Detecting features
Select gels to detect features on, then take Process → Detect Features. The
Detect Features window pops up. Various detection parameters are available
and may be adjusted. The default parameters have been optimized for silver
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stained 2-D PAGE images run according to the SWISS-2DPAGE protocol [see
reference 9]. You may tune the parameters to adapt the detection program to
your images. The following parameters may be set (Fig. 5-1):

• Number of smooths on the images  - Before detecting features, MelView will
smooth the image using a “smooth-by-diffusion” algorithm, in order to eliminate
parasite noise. Select the number of times the smoothing operation should
occur. Note that other smoothing algorithms are available in the Image menu
(see Filtering gels on page 12-2). To avoid smoothing, set the parameter to
zero.

• Threshold for Laplacian  - The detection algorithm looks for spot peaks by cal-
culating the Laplacian for each pixel in the image. To detect as many features
as possible, set a small value for this parameter. If you set high values, only
very curved features will be detected and flat spots will be ignored.

• Threshold for Partial derivatives  - Melanie also checks the spot curvature in
both the X and Y axes, in order to separate features with flat sections, or to
eliminate streaks. Augmenting this value increases the separation power of the
detection algorithm.

• OD (resp. counts) above which image is saturated (in percentage)  - Some
very dark spots may be saturated (especially when digitized with older scan-
ners) and may therefore be flat on the top. To insure that these features be
detected, Melanie II artificially increases the peakedness (curvature) of all pix-
els whose OD (respectively counts) are above a given threshold. The threshold
is expressed as a percentage of the maximum grey level in the image. A value
of 90% is usually considered correct.

• Increase in peakedness for saturated pixels - This is an internal value
expressing how much Melanie increases the curvature of saturated pixels. 100
is the default value and should only be changed with care.

Figure 5-1. The feature detection parameters
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• Minimum feature perimeter  - With this parameter you may decide to ignore
features that are too small. Melanie II will ignore all features whose perimeters
(in pixels) are smaller than the given threshold.

An additional criterion affects the way features are represented. You may
choose between the following three options:

1 Detect using default algorithm  - This is the default. Features are detected
using the Laplacian, and feature shapes are represented that match the original
spot shapes.

2 Detect, then fit with Gaussians  - Features are detected with the Laplacian,
then Gaussian modeling is performed on all detected features. Features are
represented by bi-Gaussian functions.

3 Fit existing features with Gaussians  - Features have to be already detected
using option 1, and modeling is performed on the detected features. Note that
the parameters are of no utility here.

Click OK. Features (spots) will be detected according to the parameter values
you have set. After detection the feature shapes will be displayed over the gels
(Fig. 5-2 and 5-3). Try first to detect features using the default parameter val-
ues, then tune the parameters for your data.

When using 16-bit-images, a pop-up window lets you choose, before deciding
the detection parameters, wheter you want to change or not the grey levels to
correspond to 12 bit images.

Figure 5-2. Detected feature shapes

Figure 5-3. Features modeled as Gaussians
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Adjusting detection parameters in real-
time

Each change of a parameter value may immediately be reflected in a given
region, if such a region has been defined. Select the Region tool and draw a
small rectangle in one of the selected gels, using the button mouse. In the Pro-
cess menu, choose Detect Features. Each time you change one of the parame-
ters, the change will immediately be reflected in the selected region (Fig. 5-4).

Note that if the small rectangle temporarily disappears from the display, when
the Detect Features window pops up, change slightly one of the detection
parameters.

Click on the OK button. The features will be detected in all selected gels using
the parameter values you have set.

Quantifying features

Choose Process → Quantify Features to compute the feature values. Depend-
ing on the scanner used to digitize the images, the following quantification val-
ues are calculated for each detected feature:

Figure 5-4. Adjusting detection parameters in real time.



FEATURES (SPOTS)

The Melanie II User Manual 5-5

Images digitized by transparence

The pixel value is the optical density:

• OD - the highest optical density in the feature.

• AREA  - the feature’s area.

• VOL - the feature’s volume, i.e. the integration of OD over the feature’s area.

• %OD - the relative OD, i.e. the feature OD divided by the total OD over the
whole image.

• %VOL - the relative VOL, i.e. the feature VOL divided by the total VOL over the
whole image.

Images digitized by transmittance

The pixel value is transmittance. A conversion table is used during quantifica-
tion in order to convert transmittance values to optical density:

• OD - the highest optical density in the feature.

• AREA  - the feature’s area.

• VOL - the feature’s volume, i.e. the integration of OD over the feature’s area.

• %OD - the relative OD, i.e. the feature OD divided by the total OD over the
whole image.

• %VOL - the relative VOL, i.e. the feature VOL divided by the total VOL over the
whole image.

Non-optical images

The pixel value is instrument counts:

• Count  - the highest instrument count in the feature.

• AREA  - the feature’s area.

• VOL - the feature’s volume, i.e. the integration of Count over the feature’s area.

• %Count  - the relative Count, i.e. the feature Count divided by the total Count
over the whole image.

• %VOL - the relative VOL, i.e. the feature VOL divided by the total VOL over the
whole image.

Gaussian features
If features have been modeled as Gaussians, the following quantification values
are computed:

• OD/Count  - the optical density (respectively count) of the Gaussian’s peak.

• AREA  - the area of a section of the Gaussian, taken at the peak’s half height.

• VOL - the Gaussian’s volume.

• %OD - the relative OD, i.e. the OD divided by the total OD over the whole
image.
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• %VOL - the relative VOL, i.e. the VOL divided by the total VOL over the whole
image.

Selecting features
Features may be selected with the Features tool. Click on any feature to select
it. The selected feature will be highlighted in green. To select more than one
feature, select the first one by clicking on it with the mouse button, then hold the
shift key on the keyboard and select additional features by clicking on them. To
select all features in a given region, position the cursor at the top left position of
the desired region, hold down the mouse button, then drag the cursor to the
bottom right position. All features in the selected region will be selected and
highlighted in green.

Features may also be selected from the Select → Features sub-menu. Choose
Select → Features → By ID and enter a feature ID to select the corresponding
feature. Choose Select → Features → By Master ID and enter a feature ID
from the master gel to select the corresponding features (see Master gels on
page 14-2). Choose Select → Features → By Group ID and enter a group ID
to select the corresponding features (see Groups on page 9-1). Choose Select
→ Features → Only Gaussians to only select features that have been modeled
by a Gaussian function.

Select a region on a gel using the Region tool, then Select → Features → In
Region to select all features in the selected region, or Select → Features → All
Features to select all features in all selected gels. If certain labels are selected
you may also choose Select → Features → For Labels. This will select all fea-
tures associated to currently selected labels (see Labels on page 6-1).

If you have already saved a Report on Features, you may reselect all the fea-
tures by choosing Select → Features → From File. A pop-up window lets you
choose the name of the file which contains the report.

Finally, if some features have already been selected, you have the possibility to
do Select → Features → Inverse Selection. This will unselect the selected fea-
tures and select all unselected ones.

Showing features
Features may be displayed with the Show → Features → Show Features
Shapes menu option, and hidden with the Show → Features → Hide Features
Shapes option. You may show only selected features with Show → Features
→ Selected Features.
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You may also show (respectively hide) the IDs of selected features. Select
some features, then Show → Features → Show Features ID (respectively
Show → Features → Hide Features ID).

Hiding features also has the side effect of displaying images faster.

Reports on features
Select features using the Feature tool or the Select → Features options.
Choose Show → Features → Report On Features. A report will be displayed
giving specific information on the selected features, such as features ID, quanti-
fication values, pI and Mw, as well as the following data from the master gel,
provided the selected gels have been matched to a master gel (see Matching
gels on page 8-1 and Master gels on page 14-2): serial number, pI, Mw and
accession number (M:S/N, M:pI, M:Mw and M:AC, respectively). The report
may be saved or printed (Fig. 5-5).

To have master gel information (M:S/N and M:AC) on the report, it must be a
SWISS-2DPAGE gel and it must be selected as the master gel (see Master
gels on page 14-2).

Selecting / unselecting all
The Select → Select All menu option lets you select all defined objects from
selected gels (including landmarks, features and labels). The Select → Unse-
lect All option lets you unselect all objects from selected gels.

Figure 5-5. Report on features
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Showing / hiding all
The Show → Show All menu option lets you display all defined objects from
selected gels (including landmarks, features and labels). The Show → Hide All
option lets you hide all objects from selected gels. Hiding objects also has the
side effect of displaying images faster.
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6 LABELS

The label  is a small tag associated to a feature and identifying the correspond-
ing protein. The label holds the protein’s accession number (AC) and name
taken from a user-selected database, or it may just contain any textual data.
The label is the link to MelView’s remote database query engine.

Note that the AC is the label’s identification. Two features labelled with the
same AC are considered identical, while the label names may differ.

Also, as labels are associated to features, you may define labels only after hav-
ing detected features (see Features (spots) on page 5-1).

Creating labels

To create a label, pick the Label tool and double-click on a feature you wish to
associate a label to. The Label window pops up. Fill in the AC (accession num-
ber) and name fields. Click on OK. The label is created and its AC or name is
displayed on the gel, depending on the Show → Labels options previously cho-
sen.

Alternatively, labels may be created with the Edit → Labels → Add Labels
option. Select one or more features using the Feature tool, then choose Edit →
Labels → Add Labels. The label will be added to all selected features.
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Selecting labels
Labels may be selected with the Label tool. Click on any label to select it. The
selected label will be highlighted in green. To select more than one label, select
the first one by clicking on it with the mouse button, then hold the shift key on
the keyboard and select additional labels by clicking on them. To select all
labels in a given region, position the cursor at the top left position of the desired
region, hold down the mouse button, then drag the cursor to the bottom right
position. All labels in the selected region will be selected and highlighted in
green.

Labels may also be selected from the Select → Labels sub-menu. Choose
Select → Labels → By AC and enter a label accession number to select the
corresponding labels. You may use wildcards (‘*’) to select a group of labels.
For example, “P12*” designates all labels whose ACs start with the letters
“P12”.

Choose Select → Labels → By Name and enter a label name to select the cor-
responding labels. You may also use wildcards to select a group of labels.

Select a region on a gel using the Region tool, then Select → Labels → In
Region to select all labels in the selected region, or Select → Labels → All
Labels to select all labels in all selected gels.

If you have selected features before selecting labels, you may take Select →
Labels → For Features and all the labels associated to the selected features
will be selected.

Finally, if some labels have already been selected, you have the possibility to
do Select → Labels → Inverse Selection. This will unselect the selected labels
and select all unselected ones.

Showing labels
Labels may be displayed with the Show → Labels → Show Labels menu
option, and hidden with the Show → Labels → Hide Labels option. If several
features hold the same label AC (accession number), then, by default, each
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feature will be displayed with its own label. You may display only one label tag
for all identical labels by choosing Show → Labels → Pack Labels. Show →
Labels → Unpack Labels separates the label tags again (Fig. 6-1). .

You can either display the label names or the label ACs. The option Show →
Labels → Show AC and Show → Labels → Show Name may be used to tog-
gle the AC/name display.

You may show only selected labels with Show → Labels → Selected Labels.

Modifying and deleting labels
In the Edit → Labels sub-menu, two options allow you to modify and delete
existing labels. Edit → Labels → Modify Labels is available when one label is
selected. This pops up the label window. You may then change the AC or name.
Edit → Labels → Delete Labels deletes all selected labels.

You can manually change a label’s tag position. Select a label with the Label
tool. Then move the cursor onto the label’s tag. Hold down the mouse button
and drag the tag. Release the mouse button.

Figure 6-1. A label for Human albumin
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Reports on labels
Select labels using the Label tool or the Select → Labels options. Choose
Show → Labels → Report On Labels. A report will be displayed giving specific
information on the selected labels, such as label AC and name, as well as fea-
ture ID and position. The report may be saved or printed (Fig. 6-2).

Figure 6-2. Report on labels


