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1 Features 
 

 Up to 1000Hz sampling rate 

 Data presentations and log to file capability 

 Full device configuration capability (Service Mode access) 

 Demonstrator view (showing angular rate and integrated angle)  
 

 
2 General descriptions and system contents 
 
The STIM202 evaluation kit provides rapid measurement and configuration access to the STIM202 multi-axis gyro 
module from Sensonor Technologies. Full device configuration, graphical result presentation, demonstration and save 
data to file are supported for 1, 2- or 3-axis units. The required single supply voltage (5VDC) for the module is 
provided from a PC or laptop USB port. 
 
System contents: 
 

 Quick start manual (aprinted version of this document) 

 STIM202 evaluation kit PC software for Windows operating systems 

 NI USB interface cable for RS485/RS422 (for quick evaluation/device configuration, supporting RS422 bit 
rates up to 460800 baud) 

 STIM202 communication cable 

 Included CD-ROM (or memory stick) with kit installation files and documentation 
 

 
NOTE 1:  STIM202 modules are ordered separately to the kit 
 
NOTE 2: PCI cards are available as add-ons to the kit, fully compatible with the STIM202 communication cable, supporting bit rates 
 up to 3 Mbaud 
 
 EXPRESS card are available as add-ons to the kit, fully compatible with the STIM202 communication cable, supporting bit rates up to 
 460800 baud 

 
 

 

 
Figure 1: STIM202 evaluation kit setup schematics 

 
 
3 System requirements 
 
Minimum 2 free USB ports required; One for STIM202 communication and one for STIM202 power supply. 
 
The STIM202 evaluation kit is verified on the following operating systems: 
 

 Windows Xp 

 Windows Vista 

 Windows 7 
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4 Getting started 
 
4.1 Installation of NI-Serial cable assembly driver 
 
Without connecting anything yet, install the NI-serial driver. Refer to „Serial Installation Guide‟ and included driver CD-
ROM for instructions. During installation the following windows appear (exact figures listed refers to Vista installation): 
 

 
Figure 2: NI-Serial installation  
(1 of 12) 

 

 
Figure 3: NI-Serial installation  
(2 of 12) 

 
Figure 4: NI-Serial installation  
(3 of 12). Selections can be left 
as default 

 
Figure 5: NI-Serial installation  
(4 of 12) 

 
Figure 6: NI-Serial installation  
(5 of 12) 

 

 
Figure 7: NI-Serial installation  
(6 of 12) 

 
Figure 8: NI-Serial installation  
(7 of 12) 

 
Figure 9: NI-Serial installation  
(8 of 12) 

 
Figure 10: NI-Serial installation  
(9 of 12) 

 

 
Figure 11: NI-Serial installation  
(10 of 12) 

 
Figure 12: NI-Serial installation  
(11 of 12) 

 
Figure 13: NI-Serial installation. 
Installation complete 
(12 of 12) 
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4.2 Installation of STIM202 evaluation PC software 
 

 Locate the software zip file on the included CD-ROM, unzip it to a local drive, and run the installation file 
(setup.exe.) (Notice also that the latest available PC software is found at the Sensonor web site) 

 Follow the on-screen instructions to complete the installation 
 

 
During installation the following windows will appear (refered to Vista installation): 
 

 
Figure 14: PC software 
installation (1 of 6) 

 

 
Figure 15: PC software 
installation (2 of 6) 

 
Figure 16: PC software 
installation (3 of 6) 

 
Figure 17: PC software 
installation (4 of 6) 

 
Figure 18: PC software 
installation (5 of 6) 

 
Figure 19: PC software 
installation. Installation 
complete (6 of 6) 

  

 
4.3 First hardware connection 
 
Notice: NI-Serial driver and PC software should already be installed at this point 
 
Connect system hardware as follows: 
 

 Connect a STIM202 module to the Nicomatic connector of the STIM202 communication cable. A small 
screw/torx driver is needed for tightening the fixing screws of the Nicomatic connector to the male connector of 
STIM202 

 Connect the 9 pin D-SUB connector of the STIM202 communication cable to the NI interface cable 
Alternatively, if any of the add-on solutions are used (the PCI card or the Express card) instead of the default 
USB interface cable included in the kit; skip this point 

 Insert the USB connector of the NI interface cable into a free USB port of the stationary PC/ laptop 
Alternatively, if any of the add-on solutions are used (as mentioned above); connect the STIM202 
communication cable to the PCI card or Express card hardware 

 Verify that the device driver installation is completed successfully. The NI-Serial device should become visible 
in device manager (an example for STIM202 evaluation kit USB interface device recognition is shown in 
Figure 20). NOTICE: At this point; Remember or write down the COM-port number as this is needed for 
editing the software parameter file later 
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Figure 20: Verification that NI USB-485 device is visible in device manger after first hardware connection (example from Vista) 

 
 

 NOTE: Leave the second USB connector of STIM202 communication cable (the one for powering STIM202) 
unconnected at this point 

 
4.4 First PC software start-up 
 
Notice: All hardware should now already be connected 
 
Proceed to first time start-up of PC software: 
 

 Navigate to the „STIM Evaluation‟ folder in the Windows start menu. The shortcut to start the STIM202 
Evaluation Kit PC software should be found within this folder 
 

 Directly after start-up of program a pop-up box will appear and ask for a parameter file (an .INI-file). Select the 
INI-file available in the installation folder (C:\Program Files\STIM Evaluation by default). The file name is 
„STIM202 evaluation kit.INI‟ or similar 
 

 The software GUI (graphical user interface) and Normal Mode panel loads and shows (by default) next, after 
the INI-file was selected 
 

 In the parameters file (INI-file), accessible from software, ensure the correct COM port number for the active 
device is defined. Notice also the Device-to-COM port correlation listed in the parameters view. The 
parameters view (INI-file editing) can be done directly by clicking on the „Parameters‟ tab in software. The 
password to enable edit of parameters is „stim‟.  
 

 Notice also that the device selection of the Normal Mode panel (go back to normal mode panel if needed to 
check) must correspond to the correct Device and COM port of the parameters view (INI-file) in order to 
successfully establish the STIM202 connection (next step).  
 

 (Notice: The parameters view (INI-file) only accept already assigned port numbers listed (OR alternatively 0‟s 
for devices not in use), or else the connection later will fail (next step))  
 

 After completing the correct COM port configuration in the parameters view, press „OK‟ button in upper right 
corner to confirm parameters setting and return back to the Normal Mode by clicking directly on the Normal 
Mode tab 
 

 Establish now first hardware connection to STIM202 by clicking the „Connect to HW‟ button. Verify that a 
green light appears, and that the message „Hardware connected OK‟ is shown in the lower right corner of the 
panel. See Figure 21 for an example of how the Normal Mode panel looks like directly after a first successful 
hardware connection 
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Figure 21: ‘Normal Mode’ panel. PC software confirming hardware connection is OK 

 

 Change the ‟Apply voltage‟ control switch position to ‟ON‟ and read the pop-up message telling to turn on 
power. Turn now, as instructed, the power (5V) on to STIM202. This is done by inserting the free USB 
connector into a free USB port. Confirm also the supply voltage applied by clicking „OK‟ button on the following 
pop-up panel. (Notice that this manual process controls some operations of the program) 
 

 
Figure 22: Pop-up panel showing it’s time to turn on STIM202 power 

 
 

 (The kit is now ready for use) 
 

 Now, verify connection and module communication by e.g. pressing the „Request config DG‟ button. An 
example of such result is shown below (in blue text in Figure 23) 
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Figure 23: Result of sending ’Request config DG’ to STIM202 

 
 

5 Introduction to different parts and features of PC software 
 
5.1 Panels overview 
In addition to the panel already shown („Normal Mode‟ panel), some other panels are available in the PC software. 
Here they are listed as an introduction: 
 

 
Figure 24: ‘Service Mode’ panel 

 

 
Figure 25: ‘Measure’ panel 
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Figure 26: ‘Demo’ panel 

 
 

 
Figure 27: ‘Parameters’ panel 

Main panel menus: 
 

 ‘File’ → ‘Open’ : For taking a specific INI-file into 
use (e.g. the default “STIM202 evaluation.INI”) 

 ‘File’ → ‘New’ : For generating a new INI-file. 
Notice that this new INI-file should be edited 
before taken into use, and that it is not a copy of 
any existing INI-file 

 ‘File’ → ‘Save as’ : For saving the current 
„Parameters‟ content into a INI-file 

 ‘File’ → ‘Print’ : For printing the current 
„Parameters‟ content at the default printer 

 ‘File’ → ‘Exit’ : To exit program 

 ‘Edit’ → ‘Parameters’ : To edit the „Parameters‟ 
content 

 ‘Help’ → ‘About’ : About the program (software 
revision number etc.) 

 
 

 

5.2 Normal Mode panel description 
 
Table 1: Normal Mode panel descriptions 

Panel unit Functionality and description 

Connect to HW To connect to interface hardware. Opens PC COM port according to selections in the 
parameter file 

LED Indicator for hardware connection. Lit GREEN when successfully connected 

Disconnect from HW To Disconnect from interface hardware. Closes PC COM port 

Apply voltage switch (On/Off) To be switched manually  (ON or OFF) by user when asked to. Controls certain 
functions of the PC software  

Device box Should hold the correct device number for the correct COM port number according to 
parameter file 

Reset device button Resets the device (the STIM202). Sends reset command („R‟) 

Request config DG button Sends command („C‟) to receive one configuration datagram 

Request identity DG button Sends command („N‟) to receive one part number datagram 

Request serial# DG button Sends command („I‟) to receive one serial number datagram 

Enter serv. mode button To enter Service Mode 

Response window List the response to commands from the device (from STIM202) 
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Figure 28: Result txt-file with time tags, measurement data, status byte, Rx CRC, Calc CRC and DG ID 

 
 
Table 2: Result file descriptions 

Column label Description 

T [s] This column holds time tag data for each row of measurement data listed 

AR_X [/s] X-axis rotation angular rate data, in [°/s] 

AR_Y [/s] Y-axis rotation angular rate data, in [°/s] 

AR_Z [/s] Z-axis rotation angular rate data, in [°/s] 

STS Status byte. Normally 0. See ref[1] for details 

RxCRC Re-calculated CRC on receiver side (in PC software) 

CalcCRC  Calculated CRC on transmitter side (in STIM202 micro controller) 

DG_ID Datagram ID. See ref[1] for details 

 
 
5.3 Service Mode panel description 
Service Mode is used for device configuration. 
 
Service Mode is entered by pressing „Enter serv. mode‟ button in Normal Mode. Panel units, functionality and 
descriptions are listed in Table 3. Exit from Service Mode is done by pressing either „Exit to Normal Mode‟ or „Exit to 
init mode‟ button.  
 
Note: Changes applied by sending commands in Service Mode is stored to flash memory of STIM202 by sending the 
save command („s‟). 
 
Table 3: Service Mode panel descriptions 

Panel unit Functionality and description 

Available commands window Shows a list of available commands. See also ref[1] for details 

Complete command window Contains the complete command to send. It is auto-completed by usage of the 
listings in the available commands window. Left click in the complete command 
window shows a list of earlier sent commands. Right click enables manual command 
entry 

Send command button Sends command to device (STIM202) 

Command response window Shows the response to commands (the response from STIM202). See also ref[1] for 
details 

Erase button Erases the content of the command response window 

Save button Saves the content of the command response window to a text file with a detailed 
date and time tag 
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5.4 Measure panel description 
 
Table 4: Measure panel descriptions 

Panel unit Functionality and description 

Measure button Starts a measurement series 

Samples box Defines the number of samples to be collected (max 50 millions) 

Save to file button Saves data from a completed measurement series to a result file 

X-, Y- and Z-axis check boxes Selects which axis data to present in the graph area (up to 3 axes can be plotted) 

CRC and DG-ID LEDS Confirms CRC and DG-ID as expected. LEDs turns red if checks fail 

DG type box Informs which datagram type is being received 

Data box Reserved for future use 

Save to disk icon Saves a picture of the plotted data to file 

Print icon Prints a picture of the plotted data to the default printer 

1:1 icon Resets zoom level to 1:1 

Zoom icon Enables a custom zoom of the presented results in the strip chart (graph area) 
according to placement of available cursors 

Progress bar A blue continuous line shows the measurement series progress 

Lower bar on panel Shows the INI-file in use and the active mode (NORMAL MODE) 

 
 
Save data to file feature: 
 
Measurement data can be logged to file from „Measure‟ panel‟ by clicking “Save to file”. This result file contains eight 
columns of tab separated data. An example of result file is shown in Figure 28. A detailed description of each column 
of data is found in Table 2. 
 
 
5.5 Demonstrator panel description 
A demonstrator part of the software is found in the „demo‟ panel. Various reset times and axis scales can be selected. 
The STIM202 axes rate signals are handled and plotted axis by axis real-time in these windows. Curves shown are 
angular rate [°/s] in red, and increment angle [°] in blue. 
 
Table 5: Demonstrator panel descriptions 

Panel unit Functionality and description 

Measurements switch (On/Off) Switches continuous measurements On/Off 

Reset button Does a bias cancellation on the reported STIM202 angular rate data  

Reset time[s] box To insert the chosen data evaluation time for bias cancellation 

Scale box Sets the max and min y-axis scale values for the three strip charts below 

Strip charts (X, Y and Z) Shows angular rate and integrated angle results 

The 3 square plot areas on the 
right side 

Shows the integrated angle of each reporting STIm202 axis  
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5.6 Parameters panel description 
 
Table 6: Parameters panel descriptions 

Panel unit Functionality and description 

===== General Parameters =====  

Password Current valid password to be able to edit the parameters list. The 
password is “stim” by default. Can be changed 

Default Folder for Result file Storage This is \ (root on drive), however can be changed upon saving files 

User Interface Tab to activate After Startup Is Normal Mode panel by default, however can be changed 

What Format to Use For Result Files ASCII by default, however can be changed to 8byte binary 

===== STIM communication =====  

RS422 Port # to Device # list Defining which device to be assigned to which COM port number 

RS422 Bitrate Manual RS422 bit rate selection. NOTE: The USB serial interface cable 
that comes with the kit supports only the 460800 baud option for 
STIM202, while e.g. the add-on PCI card supports also the 374400 and 
921600 baud option 

RS422 Stopbit 1 or 2 

RS422 Parity None, odd or even 

RS422 Input Buffer Size Recommended 1000000 (as default) 

RS422 Output Buffer Size Recommended 1000 (as default) 

===== External Hardware =====  

The GPIB Card # to USE Normally 0 (when no GPIB card in user). If card(s) are in use; the first 
card will be assigned to #1, second to #2, etc. 

Type of Power supply used Normally None (when not in use). Agilent E3631A, E3633A and E3644A 
supported 

Interface that the Power is Connected With Normally None (when not in use). RS232 (for Agilent E3631A only) and 
GPIB supported 

Port Address to Power Selectable up to 31. Default value is 5. Parameter should be neglected if 
not in use 

Voltage on Output Power [V] Default value is 5V. Can be neglected if not in use. Should be within 
supply voltage range of the device, and never exceed absolute 
maximum ratings value! (7.0V) 

Current Limit on Output of Power [A] Normally 0.5 if in use 

 
 
 
6 Summary table for available STIM202 evaluation tools 
 
Table 7: STIM202 Evaluation kit and available add-ons 

Description 

STIM202 EVALUATION KIT 

STIM202 NI PCI CARD RS485/RS422 2-PORT SERIAL INTERFACE 
STIM202 NI EXPRESS CARD RS485/RS422 2-PORT SERIAL INTERFACE 

 
NOTICE: 
 

- The default STIM202 evaluation kit (hardware and software) with included NI USB interface cable for 
RS485/RS422 supports STIM202 communication and full  device configuration at 460800 baud 

- The PCI and express cards are considered as add-ons to the kit. They are both compatible with the STIM202 
communication cable already included in the kit. The PCI card is the choice for longer measurements 
(characterizations) on stationary PC setups, while the express card is the choice for longer measurements 
(characterizations) on laptop setups. The PCI card supports RS422 bit rates up to 3Mbaud, and the express 
card supports RS422 bit rates up to 4608000 baud 

 
 
7 Referred documents 
 
Table 8: Referred documents 

Ref Doc Description 

[1] TS1439 Datasheet STIM202  

 


