Chapter 3
Basic Simulation

Introduction

In this lesson you will go step-by-step through the basic simulation flow:

Create the Working Design Library
Compile the Design Units
Optimize the Design

Load the Design

o W D E

Run the Simulation

Design Files for this Lesson

The sample design for this lesson is asimple 8-bit, binary up-counter with an associated test
bench. The pathnames are as follows:

Verilog — <install_dir>/examples/tutorial s/'verilog/basicS mulation/counter.v and tcounter.v
VHDL —<install_dir>/examples/tutorials/vhdl/basicS mulation/counter.vhd and tcounter.vhd
This lesson uses the Verilog files counter.v and tcounter.v. If you have aVHDL license, use

counter.vhd and tcounter.vhd instead. Or, if you have amixed license, feel freeto use the
Verilog test bench with the VHDL counter or vice versa.

Related Reading

User’'s Manual Chapters. Design Libraries, Verilog and SystemVerilog Simulation, and VHDL
Simulation.

Reference Manual commands: vlib, vmap, vlog, vcom, vopt, view, and run.

Create the Working Design Library

Before you can simulate a design, you must first create alibrary and compile the source code
into that library.

1. Create anew directory and copy the design files for thislesson into it.

Questa SIM Tutorial, v10.3 25



Basic Simulation
Create the Working Design Library

Start by creating a new directory for this exercise (in case other users will be working
with these lessons).

Verilog: Copy counter.v and tcounter.v files from
/<install_dir>/examples/tutorial s/verilog/basicS mulation to the new directory.

VHDL: Copy counter.vhd and tcounter.vhd files from
[<ingtall_dir>/examples/tutorial ’'vhdl/basicSmulation to the new directory.

. Start Questa SIM if necessary.

a. Typevsim at aUNIX shell prompt or use the Questa SIM icon in Windows.

Upon opening Questa SIM for the first time, you will see the Welcome to Questa
SIM diaog. Click Close.

b. Select File> Change Directory and change to the directory you created in step 1.

. Create the working library.

a Select File> New > Library.

This opens a dialog where you specify physical and logical names for the library
(Figure 3-1). You can create anew library or map to an existing library. We'll be
doing the former.

Figure 3-1. The Create a New Library Dialog
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b. Typework inthe Library Namefield (if it isn’'t already entered automatically).
c. Click OK.

Questa SIM creates adirectory called work and writes a specially-formatted file
named _info into that directory. The _info file must remain in the directory to
distinguish it as a Questa SIM library. Do not edit the folder contents from your
operating system; all changes should be made from within Questa SIM.
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Questa SIM aso adds the library to the Library window (Figure 3-2) and records the
library mapping for future reference in the Questa SIM initialization file
(modelsim.ini).

Figure 3-2. work Library Added to the Library Window
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When you pressed OK in step 3c above, the following was printed to the Transcript window:

vlib work
vmap work work

These two lines are the command-line equivalents of the menu selections you made. Many
command-line equivalents will echo their menu-driven functions in this fashion.

Compile the Design Units

With the working library created, you are ready to compile your source files.

Y ou can compile by using the menus and dialogs of the graphic interface, asin the Verilog
example below, or by entering acommand at the Questa SIM> prompt.

1. Compile counter.v and tcounter.v.

a. Select Compile > Compile. This opens the Compile Source Files dialog
(Figure 3-3).

If the Compile menu option is not available, you probably have a project open. If so,
close the project by making the Library window active and selecting File > Close
from the menus.

b. Select both counter.v and tcounter.v modules from the Compile Source Files dialog
and click Compile. The files are compiled into the work library.

c. When compileisfinished, click Done.
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Figure 3-3. Compile Source Files Dialog
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2. View the compiled design units.

a. IntheLibrary window, click the’+" icon next to the work library and you will see
two design units (Figure 3-4). You can also see their types (Modules, Entities, etc.)
and the path to the underlying sourcefiles.
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Figure 3-4. Verilog Modules Compiled into work Library
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Optimize the Design

1. Usethevopt command to optimize the design with full visibility into all design units.
a. Enter the following command at the Questa SIM> prompt in the Transcript window:

vopt +acc test_counter -o testcounter_opt

The +acc switch provides visibility into the design for debugging purposes.

The -0 switch allows you designate the name of the optimized design file
(testcounter_opt).

Note
Y ou must provide a name for the optimized design file when you use the vopt command.

Load the Design

1. Loadthetest _counter module into the simulator.
a. Usethe optimized design name to load the design with the vsim command:

vsim testcounter_opt

When the design is loaded, a Structure window opens (labeled sim). This window
displays the hierarchical structure of the design as shown in Figure 3-5. Y ou can
navigate within the design hierarchy in the Structure (sm) window by clicking on
any linewitha’+ (expand) or -’ (contract) icon.
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Figure 3-5. The Design Hierarchy
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2. Open the Objects and Processes windows.
a. Select View > Objects from the menu bar.
b. Select View > Process.

The Objects window shows the names and current values of data objectsin the
current region selected in the Structure (ssim) window (Figure 3-6). Data objects
include signals, nets, registers, constants and variables not declared in a process,
generics, parameters, and member data variables of a SystemC module.

The Processes window displaysalist of HDL and SystemC processes in one of four
viewing modes: Active, In Region, Design, and Hierarchical. The Design view mode
isintended for primary navigation of ESL (Electronic System Level) designs where
processes are a foremost consideration. By default, this window displays the active
processes in your simulation (Active view mode).
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Figure 3-6. The Object Window and Processes Window
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Run the Simulation

We'reready to run the simulation. But before we do, we'll open the Wave window and add
signalstoit.

1. Open the Wave window.
a. Enter view wave at the command line.

The Wave window opens in the right side of the Main window. Resize it, if
necessary, soitisvisble.

Y ou can aso use the View > Wave menu selection to open a Wave window. The
Wave window isjust one of several debugging windows available on the View
menu.

2. Add signalsto the Wave window.

a. Inthe Structure (sim) window, right-click test_counter to open a popup context
menul.

b. Select Add Wave (Figure 3-7).
All signalsin the design are added to the Wave window.
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Figure 3-7. Using the Popup Menu to Add Signals to Wave Window
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3. Runthe simulation.

a. Click the Runicon.

The simulation runs for 100 ns (the default simulation length) and waves are
drawn in the Wave window.

b. Enter run 500 at the VSIM> prompt in the Transcript window.
The simulation advances another 500 ns for atotal of 600 ns (Figure 3-8).

Figure 3-8. Waves Drawn in Wave Window

o

c. Click the Run -All icon on the Main or Wave window toolbar.

The simulation continues running until you execute a break command or it
hits a statement in your code (ie., a Verilog $stop statement) that halts the
simulation.

d. Click the Break icon | |54 | to stop the simulation.
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Set Breakpoints and Step through the Source

Next you will take a brief look at one interactive debugging feature of the Questa SIM
environment. Y ou will set abreakpoint in the Source window, run the simulation, and then step
through the design under test. Breakpoints can be set only on executable lines, which are
indicated with red line numbers.

1. Open counter.v in the Source window.
a. Select View > Files to open the Files window.
b. Click the + sign next to the sim filename to see the contents of vsim.wif dataset.

c. Double-click counter.v (or counter.vhd if you are ssmulating the VHDL files) to
open the file in the Source window.

2. Set abreakpoint on line 36 of counter.v (or, line 39 of counter.vhd for VHDL).
a. Scroll to line 36 and click in the Ln# (line number) column next to the line number.

A red dot appears in the line number column at line number 36 (Figure 3-9),
indicating that a breakpoint has been set.

Figure 3-9. Setting Breakpoint in Source Window

. [Tutorial fexamples tutorialsfverilog basicSimulation foounter. v {ftest_counter fdut) - Default
tng | T+ B How 4]
3s -
38 Ial'u'.i}rs @ (posedge clk or posedge reset)
37 if ({reaet)
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3. Disable, enable, and delete the breakpoint.
a. Click the red dot to disable the breakpoint. It will become a gray dot.
b. Click the gray dot again to re-enable the breakpoint. It will become ared dot.
c. Click thered dot with your right mouse button and select Remove Breakpoint 36.

d. Click intheline number column next to line number 36 again to re-create the
breakpoint.

4. Restart the simulation.
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a. Click the Restart icon to reload the design elements and reset the simulation

time to zero.

The Restart dialog that appears gives you options on what to retain during
the restart (Figure 3-10).

Figure 3-10. Setting Restart Functions
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b. Click the OK button in the Restart dialog.

c. Click the Run -All icon.

The simulation runs until the breakpoint is hit. When the simulation hits the
breakpoint, it stops running, highlights the line with a blue arrow in the
Source view (Figure 3-11), and issues a Break message in the Transcript window.

Figure 3-11. Blue Arrow Indicates Where Simulation Stopped.
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When a breakpoint is reached, typically you want to know one or more signal
values. Y ou have severa options for checking values.

® Look at the values shown in the Objects window (Figure 3-12).

34 Questa SIM Tutorial, v10.3



Basic Simulation
Set Breakpoints and Step through the Source

Figure 3-12. Values Shown in Objects Window
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® Set your mouse pointer over avariable in the Source window and a yellow box
will appear with the variable name and the value of that variable at the time of
the selected cursor in the Wave window (Figure 3-13).

Figure 3-13. Hover Mouse Over Variable to Show Value
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® Highlight asignal, parameter, or variable in the Source window, right-click it,
and select Examine from the pop-up menu to display the variable and its current
value in a Source Examine window (Figure 3-14).

Figure 3-14. Parameter Name and Value in Source Examine Window
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® usethe examine command at the VSIM> prompt to output a variable value to
the Transcript window (i.e., examine count)

5. Try out the step commands.
a. Click the Step Into icon on the Step toolbar. *
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This single-steps the debugger.
Experiment on your own. Set and clear breakpoints and use the Step, Step Over, and
Continue Run commands until you feel comfortable with their operation.

Lesson Wrap-Up

This concludes this lesson. Before continuing we need to end the current simulation.

1. Select Simulate > End Simulation.
2. Click Yeswhen prompted to confirm that you wish to quit simulating.
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