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Overview and Method 

his User Guide and tutorial has been designed to enable you get the 
most out of your investment in Schedule24 Resource Manager. 

It enables a “hands on” approach from the outset, with a series of 
exercises to reinforce your learning and skills in workplace resource management. 
You will find it offers much more than just shift scheduling. In today’s climate 
where driving out costs from the workplace is seen as paramount, Team Leaders 
and Line Supervisors have an even more important role than ever in maintaining 
the high performance workplace. This has been largely brought about by a growing 
realization by corporate managers that Team Leaders and Line Supervisors know 
more about what is going on in the workplace, are able to respond more 
appropriately and faster than anyone else. 

Schedule24 Resource Manager offers the same principled workflow and 
features found in much larger expensive systems but with the capability of 
being deployed wherever a Team Leader or Line Supervisor are to be found 
struggling with paper and pencil.  

You can anticipate being a competent user within 4 to 6 hours 
practice; and achieving expert user status after around 20 to 30 
hours of delivering Schedule24 principles of control, coordination 
and communication in the workplace. 

Take a moment to familiarize yourself with the icon keys which 
indicate the purpose of the text you are reading. These are used 
throughout this tutorial and guide and will appear at the side of 
the text or paragraph of information. 

 

 

T 

I C O N  K E Y  

  General information 

Tip on technique 

  Keyboard exercise 

 Course Note 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

6 

How this Course is structured 

This has been designed to help those that are totally new to the challenges of 
managing staff in the workplace which for many organizations is the most 
expensive assets. Poorly deployed staff in the workplace can consume up to 60% of 
wasted costs before anyone realises something is badly wrong. 
 
The course has been developed to follow the Schedule24™ workflow and enable 
the Team Leader and Line Supervisor to acquire new skills to control, coordinate 
and communicate good governance in the workplace. 
 

Section Title Summary 

1 Schedule24 Workflow 
Provides an overview of Schedule24 features 
and workflow. 

2 Getting Started 

Rapid start tutorial that enables you to 
understand how the main features work 
together so you can be productive from day 
one. 

3 Working with Schedules 
Adding more detail to your staff schedule 
means improved coordination and greater 
control of your workforce.  

4 
Working with Shift 
Patterns. 

However demanding the workplace you can 
scale up and automate your staff schedules 
with any combination of shift patterns. 

5 Shift Pattern Design. 
Matching staff deployment to a business 
requirement is crucial to deliver both an 
efficient and cost effective workplace. 

6 Monitoring and Analysis 

A wide range of options allied to powerful 
analytics combine to provide instant 
feedback about scheduling conflicts, 
breaches of working hours, rest period 
thresholds and staff costs. 

7 Printing and Publishing 

Swift communication of staff schedules is as 
important as doing the scheduling in the first 
place; and is the hallmark of an effective 
workplace manager. 

8 
Security, Importing, 
Exporting & Archiving. 

Customised options to exchange data with 
other applications and protect your work 
files. 

 
 Remember while using Schedule24™ Resource Manager   comprehensive and 

context sensitive help is available by clicking Help > Schedule24 Help  or 
pressing the F1 key.



 

 

Section 1 - Schedule24 Workflow 
Schedule24 Resource Manager supports a disciplined workflow 
for the production of workforce deployment schedules. 
Schedule24 supports both structured and unstructured 
scheduling styles. 

After completing this Section you will be able to: 

1. Understand the main features of Schedule24™. 

2. How the features work together. 

3. Understand the difference between structured and unstructured 
scheduling. 

4. Know when to use the features depending on your approach to scheduling. 

Workflow 

You will use a combination of tools to create staff schedules; these include 
Schedule & Shift Pattern Wizards, the Shift Pattern Design environment and 
the Team Manager. 

 

Section 

1 
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The most common features can be accessed and used from the Navigation or 
Shortcut Bar in addition to the Menu or toolbars. 

 

Start your Schedule 

Schedule 

Wizard 

The Wizard is a quick way to start scheduling especially if you 
are not too sure what kind of schedule you want. You do not 
have to think about the complexity of rotating or day off 
patterns in your schedule. The Wizard takes care of all that you 
just provide the inputs. For more advanced shift patterns you 
use the Shift Pattern Designer. 

New 

Schedule  

You can create a new schedule from scratch by selecting File > 
New.  Schedule Assistants will prompt you at each stage to 
assist you. 

Schedule 

Template 

Schedule templates contain all the information about shift 
patterns and also staff details like job descriptions so you can 
create new staff schedules based on proven industry schedules. 
You can also create and share your own schedule templates for 
consistent working arrangements. 

 

Add and Remove Staff 

Staff 

Manager 

 

You manage all your staff records and information in the Staff 
Manager. Contact information, training and service records are 
all maintained at your finger tips in the Staff Manager. 

Importing 

staff  

Import staff details from other applications e.g. HR or Contact 
Management database or from another Schedule24 schedule 
using the Import Wizard. 
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Add More Detail to a Schedule 

Shift Editor 

You can view and work on multiple schedules at the same 
time. The Shift Editor is a docking feature that can be moved 
around your work area and used to create and maintain 
schedules. It supports all shift types and displays 12 hr or 24 hr 
formats. 

Assignments 

Individual or multiple assignments, or details about jobs or 
tasks, can be scheduled to staff shifts. These are 
automatically tracked and cross-referenced on published 
schedules when they are edited and modified. 

Breaks 

Single or multiple breaks can be scheduled during the course 
of a shift. 

Unavailability 

Staff unavailability can be recorded and warnings are 
displayed where this conflicts with staff shifts or assignments.  

Memo 

Other information can be attached to a staff shift or calendar 
date using the Memo feature. 

 

Create Shift Patterns 

Shift Pattern 

Designer 

The Shift Pattern Design environment supports over 30 
business and scheduling rules. Multiple shift pattern 
designs can be combined to manage complex working 
arrangements. 

 

Manage Shift Patterns 

Team 

Manager 

The Team Manager is where you manage shift patterns and staff 
to deliver higher levels of automation and scaling up of your 
staff schedules.  
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Monitoring and Analysis 

Staff Count 

A dashboard display of staff frequency counts including head 
count by category, working hours and staff costs. The display 
list can be customized for instant feedback. 

Distribution 

Profile 

Getting the numbers right isn’t enough. Staff distribution over 
a zooming timeline displays when staff are working those 
hours and in the context of other sub-group categories. 

Staff Work 

Time Profile 

Details about staff working hours can be profiled to include 
working hours on days of the week including rest periods. 

Staff 

Availability 

Staff availability including split times can be recorded and 
monitored throughout the working week. Scheduling conflicts 
with availability are immediately flagged. 

Staff Costs 

Comprehensive staff cost analysis can be performed on a wide 
range of factors making benefit analysis the fastest available 
when planning staff deployment. 

ACM Control 

Active Conflict Monitoring checks the scheduling logic for 
breaches of thresholds for working hours or weekly and daily 
rest periods between shifts. Standards and quality of published 
schedules is high. 

 
 

Publishing 

Email Wizard 

Schedules can be swiftly emailed direct to staff to inform and 
coordinate team work. Options are available to customize email 
content including iCal formats for Outlook and Google personal 
calendars.  

Web Wizard 

Use the Web Wizard to publish schedules to the Web, to enable 
convenient access to schedule information from anywhere in 
the organization. 

Managemen

t Reports 

You can create over 35 reports for breakdown information 
about working hours and staff costs. All reports can be exported 
as PDF, Word or Excel. 

Statistics 

Comprehensive statistical reporting of scheduling activity 
includes individual, team and job title groupings to provide 
totals and frequency counts of assignments and unavailability 
status over any time period. 

Exporting 

All Schedule24 information can be exported as CSV files or as an 
Access database using the Export Wizard. 
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Section 2 – Getting Started 
This lesson will walk you through the main features of 
Schedule24 Resource Manager. This schedule is based on a 
requirement to deploy a staff supply over 24 hours in a 
business facility. 

After completing this section you will be able to: 

1. Create a structured schedule with the Schedule Wizard 

2. Add and remove people from a schedule 

3. Understand schedule templates 

4. Open, Save and close a schedule 

 

Section 2 Exercises: Starting your scheduling 

 Exercise 2.1 
Launch Schedule24 Resource Manager. 

At the start of this exercise it is assumed you have not launched Schedule24 
Resource Manager. 

1. Click Start > All Programs > Schedule24 Resource Manager and select 
Schedule24 Resource Manager to launch the application. 

2. Close the Welcome to Schedule24 Resource Manager screen by clicking 
the Close button in the bottom right hand corner of the dialog.  

3. If the Navigation Pane is not displayed select View > Navigation Pane 
from the Menu to display. 

4. Similarly if the Issues Pane is not displayed select View > Issues Pane from 
the Menu to display. 

Section 

2 
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 This is the staff scheduling environment that enables you to access the main features from the 
Navigation Pane; and conflicts and warnings that arise as you schedule are displayed in the 
Issues Pane and will be dealt with in a later section. 

 

  

 The staff scheduling environment, notice many of the menu items are disabled. When you 
open a schedule or create a new schedule more features become enabled as you progress 
through the workflow.  

 

 Exercise 2.2 
Using the Scheduling Wizard. 

 

This exercise uses the convenience of the Schedule Wizard to take you step 
by step through creating a staff schedule from beginning to end. It is used 
here as an introduction to many of the basic concepts considered the 
hallmark of good scheduling. In the wider context of solving scheduling 
problems it does have limitations, and for total control over our staff 
schedules we will be revisiting many of these features in greater detail 
later. For now it is a convenient way to quickly demonstrate the main 
components of the Schedule24 Resource Manager workflow. 

 
1. Launch Schedule24 Resource Manager and close the Welcome Screen if you 

haven’t already done so. 
 

2. From the Start Your Schedule section of the Navigation Pane select 
ScheduleWizard... This will display the ScheduleWizard welcome screen. 
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The Schedule Wizard welcome screen on start up. 

 
3. Click Next to the Add Staff section. 

 

 
If you leave this blank the Wizard will work out the staff you need and you can add the detail later. 

 

 Using the small sample staff list below enter the staff details into the Add Staff dialog form. 
Information entered here will automatically be entered into the Staff manager when you 
complete the Wizard. 

 

First Name Last Name Job Title 

Peter Agar FT Agent 

Victoria Ainsworth FT Agent 

Javid Ali FT Agent 

Richard Allen FT Agent 

Jasmine Fields FT Agent 
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 You add each entry to the display list in turn using the Add button. Entries can be removed 
from the display list using the Delete button. If you hit the Enter key to add a staff record it will move 
to the next step in the Wizard, to return to entering staff information simply click the Back button. 

 

  
You can also enter Job Title on its own if scheduling roles and add the names later. 

 
4. Click Next and move to the next step Add shifts to your schedule. 
 

 
You can enter any number of shifts and descriptions. 

 
5. In the Shift box enter “7a3p” (to denote 7:00a-3:00p) and in the 

Description box enter “Early”. Select a color code for the shift by clicking 
the color listing. Click the Add button to add this shift to the display list. 
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 If your preference is for 24 hour working select the 24 hour option. To save time formatting 24 
hour time can be entered as a continuous entry e.g. 07001500 and the 07:00-15:00 formatting 
will be applied automatically. 

6. Follow the step above to enter the following time and descriptions each 
with a color code: 

 

7a-3p Early 

10a-6p Day 

3p-11p Late 

5p-1a Evening 

11p-7a Night 

 
7. When you have completed entering this list your display should look 

something like this: 
 

 
Having completed entering the shift list a final check of hours. 

 

 If you make a mistake on entering information simply delete the entry and re-enter. The entry 
order for shifts in this section becomes a choice option later. 

8.  Click Next and move to the Select Start Day section. Accept the default 
start day Monday. 

 

 Click the More button to display the information feedback dashboard as you work through the 
options each step of the way. Your display should now look similar to this: 
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The zoom in view display more details about how teams are made up of staff 

 
9. Move the mouse pointer over the grid area and when the pointer changes 

to a magnifying-glass icon double-click to zoom out and view more detail. 
 

 
The zoom out displays the bigger picture, it’s all in the pattern! 

 
10. Click Next and move to the Fixed or Rotating section and select the 

Rotating option. 
 

 You will notice the shift pattern adjust to the rotation of the shifts based on the options chosen 
so far. This is a good example of a structured schedule displaying its characteristic pattern. 
Using the scroll controls you will be able to see how the information you entered earlier is 
beginning to be structured. 
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Scrolling to display the staff count for each shift. 

 
11. Click Next and move to Add Days Off section and select the Customize 

option to display the controls for the days-off days-on work ratio. Accept 
the 2 days-off default and increase the days-on to 6. Finally select the 
Forward stagger option. 

 

 
Evaluating the dashboard feedback to improve the shift pattern 

 

 This configures the days-off pattern on a rotating basis. So not all the staff would be off on the 
same day. Ideal for 24 hour 7 day working. Monitoring the feedback panel which is dynamically 
updated depending on which options are selected. For example here the rest periods between 
shifts is displaying ‘0’ which indicates that somewhere in the pattern two shifts are adjoining 
with no rest period in between. In this case selecting the Backward stagger option for days-off 
re-adjusts the pattern to maintain sufficient rest periods between shifts. 
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 You will also notice feedback on percentages. The notable one is the 4% of unallocated shifts. 
This is telling us not all staff has been allocated a shift on every day given the options chosen 
so far. This can be improved in the next step.  

 
12. Click Next and move to the Staff Distribution section and select the 

Customize, enter the desired number of staff in the staff column option. 
This will display the staff distribution control. For the purposes of this 
tutorial click the mouse pointer in the staff column next to the 10:00a-
6:00p Day shift and enter 2. Your schedule design should now  look 
something like this: 
 

 
The feedback dashboard instantly updates the moment you make a change 

 

 Adding an additional staff member to the day shift re-adjusts the schedule pattern of working 
so they are no unallocated shift periods. Scrolling to the right of the pattern and the distribution 
balance is perfectly balanced given the options selected so far. This is a matter of judgement, 
and we will see later how more control can be achieved when looking at the Shift Pattern 
Designer. For now we are simply working through the basic concepts underlying staff 
scheduling. 

 
13. Click Next and move to the Direction of Rotation section and accept the 

Forward default option. 
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The direction of rotation can be seen in an instant saving hours of guesswork. 

 

 The Direction of Rotation of DOR is important and directly impacts our ‘body clock’ and 
sometimes referred to as circadian rhythms. It has been long established that a forward 
rotating schedule is to be preferred. 

14. Click Next and move to the Speed of Rotation section and select the 
option Customize speed and reduce the days to ‘2’. The schedule pattern 
will dynamically update. 
 

 
A well balanced shift pattern is not easy but if it is possible it can be achieved in a few moments. 

 

 You will notice in the feedback panel things have changed – even though there are no 
unallocated shifts as before. Rest period between shifts has been reduced to ‘zero’; and the 
balance of shifts and days off has become less efficient with a 15% drop down to 85%. 
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 Selecting a faster rotation in the Speed of Rotation step, known as a schedules SOR, is also a 
preferred option but it can upset a carefully crafted schedule pattern, as in this case. Often the 
solution can be as simple as changing a previous option. In this case changing the day off 
stagger in the earlier Days Off step back to ‘Forward stagger’ from ‘Backward stagger’ 
resolves this problem. 

 

 
Now we have a balanced shift pattern. 

 
 
15. Click Add Days Off in the Menu list on the right to return to the previous 

step and change the option back to ‘Forward stagger days off’ 
 

 Do not be too concerned if there are things you have not followed or do not understand. For 
now you just need to understand the relationship between the working hours and days-off, 
characteristics of shift patterns. You need to be aware the direction and speed of rotation can 
have significant impact on a staff schedule. In the feedback panel you will notice that 8 staff are 
needed to make this schedule work, however only 5 staff were entered at the beginning. The 
Schedule Wizard calculates the additional staff needed and enters default staff when the 
schedule is created. 

16.  Click Save Schedule in the Menu list and move to the Save your Schedule 
section. Enter the filename ‘Myschedule’ and click Next to Finish and 
generate your schedule. 
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The Schedule Wizard completed when all the checks are displayed. 

 

 Schedule24 is doing several things “behind the scenes” when you click the Finish button of the 
Schedule Wizard. It updates the Staff Manager with staff details you entered. If you have not 
entered enough staff for the schedule pattern to work, in this example only 5 staff were entered 
and the schedule requires 8 people, it will create default staff and add them into the Staff 
Manager. In addition a shift pattern is created and saved to the Shift Pattern folder for future 
use, and the Team Manager is populated with staff allocations to their respective shift rotations 
are distributed in the Team Manager. We will see how each of these features work in greater 
detail later but for now this has all been done automatically. 

 

 
The staff schedule displayed in the Schedule View area 
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17. From the Menu toolbar click the Staff Manager button to display the Staff 

Manager. Select the Service tab to display the staff information generated 
from the ScheduleWizard. 

 

 
The Staff Manager is automatically populated with staff details. 

 
18. Close the Staff Manager and from the Menu toolbar click the Team 

Manager button to display the Team manager. Click the View button to 
display the shift pattern staff have been allocated to. 

 

 
Working with the multiple displays of the Team manager makes things easier to check out. 

 
19. Close the Shift Pattern View window; and close the Team Manager to 

return to the Schedule view area. 
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20. Using the mouse pointer select File > Close from the toolbar menu and 
when prompted to save give it a filename. For the purpose of this tutorial 
save it as “My Schedule”. The Schedule will then be saved to the Schedule 
folder of your installation directory. 

 

 The completed exercise has demonstrated the characteristics of structured scheduling using 
the Schedule Wizard. You will see later this is not the only way to approach structured 
schedules and greater control can be obtained using the Shift Pattern Designer and Shift 
pattern Wizard. You have seen four major components of Schedule24 Resource Manager 
Workflow: 
 

The Scheduling environment; 
The Staff Manager; 
 The Shift Pattern; and 
The Team Manager 

 
We will be revisiting each of these again in greater detail 

 

 Exercise 2.3 
Create a New Staff Schedule. 

This exercise will look at a different way of creating and saving a new staff 
schedule, while at the same time taking a closer look at the Staff Manager. 
We will carry out a simple staff import from an existing schedule. You 
cannot start scheduling until you have entered some information about 
staff into the Staff Manager, and it is the only place where you manage 
staff changes. 
 
At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and displaying the Navigation and Issues 
Pane with no staff schedule displayed in the schedule viewing area. 

1. Using the mouse pointer click 1. Start your schedule bar if it is not already 
displayed. Select the item New schedule from the list. This will display a 
blank schedule. Alternatively from the Menu select File > New and select 
New to display the New Dialog and click Blank Schedule. 

2. A blank schedule with calendar information will be displayed, together 
with a Schedule Assistant prompting for information about staff. 

3. Select Import Staff from an existing schedule option and click OK to 
display the Insert Staff from another schedule dialog. 

4. From the list displayed select the schedule you saved in the previous 
exercise with the default file name My Schedule. Click OK to populate your 
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blank schedule with the staff details from that schedule into your new staff 
schedule and to close the dialog. 

5.  The Schedule Assistant will be displayed prompting you about options for 
entering shifts. Select the ‘No thanks...’ option and click OK to close the 
dialog. 

6. Save the schedule with the filename Small Team Schedule and select File 
> Close to close the schedule and return you to an empty schedule view 
area.  

 

 Exercise 2.4 
Adding and Removing Staff. 

This exercise follows on from the previous exercise and will look at the 
way we add and modify staff records in a staff schedule. 
 
At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and displaying the Navigation and Issues 
Pane with no staff schedule displayed in the schedule viewing area. 

1. From the menu toolbar select File > Open to display the Open dialog box. 

2. From the file list select ‘MySchedule’ and click OK to open the staff 
schedule in the schedule view area.  

3. From the Toolbar menu select the Staff Manager to display the Staff 
Manager. 

 
The Staff Manager 
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 Using the staff list below enter the staff details into the Staff Manager . 

Title First Name Last Name Department Job Title 

Mr Peter Agar A FT Agent 

Miss Victoria Ainsworth A FT Agent 

Mr Javid Ali A FT Agent 

Mr Richard Allen A FT Agent 

Mrs Jasmine Fields B FT Agent 

Mr Timothy Chiswick B FT Agent 

Mrs Jane Green C FT Agent 

- - Temp 001 Temp Staff FT Agent 

 The greyed section is information already imported from the previous exercise. The content in 
plain cells needs to be added by modifying these records. In this example that means adding 
Department information to the greyed names; and default staff records to named staff and a 
“Temp 001” record. 

4. Using the mouse pointer select ‘Person 6’ record and select the Service 
tab 
 

5. Using the mouse pointer, or tab key enter ‘Timothy’ into the First text box; 
and replace “Person 6” default with the name ‘Chiswick’ in the Last text 
box. 
 

6. For the same record, enter the Department information “B” into the 
Department field; and enter “FT Agent” into the Job title field. 
 

7. Using the mouse pointer on the Staff list select the record “Person 7”. This 
will update the changes you have just made for Timothy Chiswick record, 
and display the record you have just selected to be modified. 
 

8. Repeat the procedure for ‘Person 7’ record using the above table for your 
reference to information to be entered. 
 

9. Similarly, repeat the procedure for ‘Person 8’ entering “Temp 001” 
information. 

 You will note that you can use any description in the fields to record temporary staff. This is 
also useful if you also want to schedule staff but do not have their full details until perhaps later. 

10. To update the remaining records with Department information select each 
record in turn and enter the Department if it isn’t already displayed for 
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selection in the drop down list and click the Add Record button. 
 

 The Add Record button has the same action as update record and it populates the drop down 
lists as you move through the staff lists. 

 You can sort your staff lists in ascending and descending order by clicking on the column 
header of the information type you want to sort while in the Staff Manager. 
 

11. Similarly using the mouse pointer select each record in the staff list 
displayed on the left hand side of the Staff Manager and enter their 
respective salutation in the Title text box and click Add Record button to 
update the staff record. 
 

 When you have completed this list your Staff Manager  entries should look like this: 

 

 
The Staff Manager presents an intuitive interface to access a wide range of data. 

 

6. Click Save and Close button which will close the Staff Manager and update 
your schedule with the staff names you have entered. 
 

7. From the Toolbar Menu select the Staff Manager. This will display the Staff 
Manager again. 
 

8. Using the mouse pointer select the record for Temp 001 in the Personnel list. 
This will select the record and display a black triangle to the left of the name 
showing it is selected. 
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9. Click the Delete Person button to delete the staff record Temp 001 from the 
Staff Manager. Click Save and Close to close the Staff Manager and update the 
staff schedule. 

 Tip: If you make a deletion by mistake, closing the Staff manager using the x closing button will 
close the Staff Manager without making changes. 

10. From the Menu select View > Department to display the department 
information for each member of staff. The display should look something like 
this: 
 

 
 
 If you have a break in going through this user guide and tutorial the department and job title 

information may not be displayed. This is because you are working in a real time environment 
and records are time stamped by the current date and time when you modified the record. If 
you scroll the schedule to the date the modification was made the information will be displayed. 
Alternatively you can enter a date into the Start date field when you want the information to be 
displayed as follows: 

 
 

11. From the Menu toolbar select File > Close to close the staff schedule if 
prompted Save with the file name ‘My Schedule’. 
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 Exercise 2.5 
Working with Schedule Templates. 

This is a short introduction to using Schedule Templates. A range of templates are 
shipped with Schedule24 Resource Manager. Templates are a good way of sharing 
working arrangements and avoids “re-inventing the wheel” when there exist 
standard patterns of working in the organization. Templates can be created from 
operational schedules including shift and days-off patterns and staff information. 

At the start of this exercise it is assumed you have already launched Schedule24 
Resource Manager and displaying the Navigation and Issues Pane with no staff 
schedule displayed in the Schedule View area. 

 
You can check the Don’t show me again checkbox to suppress the Welcome screen 
display on launching Schedule24. It can be re-activated for display using the Tools > Options 
dialog.  

1. From the Start your Schedule section of the Navigation Pane select Schedule 
Templates… to display the Templates dialog display.  

 
The Schedule Template choices in the New schedule dialog. 

2. Select the template Three Shift System and click OK to display the schedule 
in the Schedule View Area. 

 This template has default entries for the personnel information. This information can be updated 
with staff details using the Staff Manager as in the previous exercises. 

3. Close the schedule without saving at the prompt. 
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Section 3 – Working with Schedules 
Once a schedule has been created more detailed information 
can be entered. Schedule24 manages different kinds of 
information in layers so you always have ready access to 
information depending on the views you have selected. This 
enables you to work in a context rich environment and 
improves your team management skills.  

After completing this lesson you will be able to: 

1. Navigate around the Schedule Work Area 

2. Enter, modify and schedule shifts. 

3. Add details about assignments, unavailability and breaks. 

4. Apply options to change what you see. 

 

Section 3 Exercises: Adding more detail to schedules 

 

 Exercise 3.1 
Displaying staff information in the Schedule View Area 

This exercise will help you start navigating around the Schedule View area and 
will introduce the Options dialog where you can change options about 
information displayed in the staff schedule. 
 
At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and displaying the Navigation and Issues Pane 
with no staff schedule displayed in the schedule viewing area. 

 

Section 

3 
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1. From the Menu toolbar select File > New to display the New dialog. Select 
the schedule ‘Blank Schedule’ and click OK to display a new staff schedule 
in the Schedule View area. 

2. The Schedule Assistant will be displayed. Select the “Import staff from an 
existing schedule?” option to display the “Insert staff from another 
Schedule” dialog. Select the “My schedule” item and click OK. This will 
import the staff into your new schedule. 

 

3. From the Menu toolbar select Tools > Options to display the Options dialog 
and then select the View tab. 

 
When you want to change what you see the Options is where you do it. 
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4. Make sure the checkboxes for Job title and First name and Last name are 
checked to display this information in the schedule view; and the Time 
settings are set to 12 hour AM/PM option. Click OK to close the Options 
dialog and update the schedule display. 

 Tip: If you are familiar with and prefer to work in 24 hour ‘military’ time then select that option. 
The section exercises use 12 hour time format. 

 If the checkboxes are unchecked then this information will not be displayed in the staff 
schedule view. In fact the information will not be displayed anywhere in the workflow including 
publishing schedules to the web and email. Depending on preferences just first names may be 
sufficient; on the other hand you may want to communicate a more formal approach and use 
job titles and last names. If you are focused on more advanced staff shift patterns you may just 
want to reference job titles before staff names. 

5. Repeat the above procedure to display the Options dialog again and select 
the Color tab. 

 
A range of color mapping options can be configured here. 

 

6. Using the mouse pointer select and highlight ‘Weekends’ in the Holiday 
Section. Launch the color picker and select a color for weekend days and 
check the checkbox to display the color in the schedule view area. Click 
OK to close the Options dialog. 

7. In the Schedule View area select 50% zoom setting in the toolbar menu to 
view weekend color mapping. This is a useful technique for navigating 
week based staff schedules. Return the zoom setting to 100%. 
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An example of sensible color mapping instantly gives a breakdown of the weeks. 

 

8. Using the horizontal scroll bar adjust the staff schedule forward so the first 
column is Monday. This helps navigate the following lessons using days of 
the week.  

 You can scroll the schedule backwards to a Monday, but you may take the schedule to a date 
before the staff details e.g. Job title was created. Job title information is timestamp sensitive 
and will not be displayed if the schedule view navigates to a date before the Job title start date 
in the Staff Manager. 

 Schedule24 functions with a perpetual calendar. This means it never runs out whether you go 
backwards or forwards. You control schedule date ranges using date range options when 
printing or publishing. There are more advanced techniques using the Team Manager which 
will be dealt with later. 

 Exercise 3.2 
Working with the Shift Editor 

This exercise introduces the Shift Editor. It is the only means for entering 
information about shifts, shift descriptions, days off and other shift pattern 
information. It will show you how to use 12 hour and 24 hour formats and tips 
to speed up entering shifts. 
 
At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and the ‘Small Team Schedule’ is open and 
displayed in the schedule viewing area. 
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1. Using the mouse pointer select the first day cell for “FT Agent Peter Agar” 
in the first column of the schedule. This should be a Monday. 

2. From the Toolbar menu click Shift Editor. This will display the shift data 
box in the Toolbar. 

 

The Shift Editor controls displayed in the docked position. 

3. Use the mouse pointer and click in the text box displayed in the toolbar of 
the Shift Editor. This will display a flashing cursor indicating you can edit 

the box entry. Enter the text 7a3p and click the  button. This will 
commit the change to the highlighted day cell. 

 Note that the time format characters : and – are added automatically. If you prefer to work in 24 
hour format then make sure the option is selected in the Options dialog and the above entry 
will be displayed in 24 hour format even though a 12 hour format was entered. The equivalent 
24 hour format would be 07001500 and the formatting characters are added automatically.  

4. Click the Shift Descriptions button next to the Shift Editor text field to 
display the Shift Descriptions dialog. 

 

 
The Shift Descriptions dialog 
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5. Double click the mouse pointer in the descriptions column of the 7:00a-
3:00p shift and enter a description for this shift e.g. “Early”. Click OK to 
close the dialog. 

6. In the Schedule View area using the mouse pointer, select and highlight the 
Tuesday day cell for “FT Agent Peter Agar”. 

7. Use the mouse pointer to select the drop down list in the text box 
displayed in the toolbar of the Shift Editor. Select the ‘07:00a-3:00p Early’ 

shift in the drop down list and click the  button. This will commit the 
change to the highlighted day cell. 

8. Use the mouse pointer and click in the text box displayed in the toolbar of 
the Shift Editor. This will display a flashing cursor indicating you can edit 

the box entry. Enter the text 7a3p and click the  button. This will 
commit the change to the highlighted day cell. 

9. From the Menu toolbar select View > Shift Description this will change the 
Tuesday shift time format to a shift description. 

 Notice the Monday 7:00a-3:00p shift remains as a time format, while the Tuesday 7:00a-3:00p 
shift entry toggles between a time format and the description entered in the Shift Descriptions 
dialog box depending which View option is selected. If you want a shift description and a shift 
time then you need to assign a shift its description before you start scheduling. Put another 
way, a shift time without a description will not pick up a later description added after it has 
already been entered into a staff schedule. 

 Depending on the View option selected the shift time or shift description will be displayed in the 
Tools > Options dialog Color tab. This enables you to assign a different color to both a time 
format and a shift description. 

 
Shift times and shift descriptions can be allocated color independently 
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Shift times maintain consistent color mapping 

 

10. Close the schedule and when prompted save with the filename “Small 
Team Schedule”. 

 
 

 Exercise 3.3 
Working with more shift options 

This exercise introduces more shift controls when the Shift Editor is undocked 
from the toolbar Menu. 
 
At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and the ‘Small Team Schedule’ is open and 
displayed in the schedule viewing area. 

 

1. Using the mouse pointer click the Shift Editor bar control and drag down 
onto the schedule view area and release when the outline changes to 
undock the Shift Editor and display more controls.  

 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

36 

 
 

 If the Shift Editor bar control is not displayed then using the mouse pointer, click the Toolbar 
menu Shift Editor Button. When the Shift Editor is undocked it should look something like this: 

 

 

 

2. From the main Menu toolbar select View > Shift descriptions to change the 
time format to shift descriptions. 

 Use the mouse pointer to highlight the shift description “Early”. Notice the Shift Editor will 
change its content to reflect shift descriptions. 

3. Similarly select View > Shift times to change the shift descriptions display 
back to the time format. 

 Now the Shift Editor will display the time format. If there is no shift description it will display the 
time format by default. 

4. Using the mouse pointer double click the Shift Editor bar to automatically 
dock the control panel. 
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 Exercise 3.4 
Working with split shifts 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and the ‘Small Team Schedule’ is open and 
displayed in the schedule viewing area. The Shift Editor is docked. 
 

 
1. Using the mouse pointer click and drag the Shift Editor down onto the 

Schedule View Area. 
 

 
The Shift Editor displayed undocked. 

 

 The Shift Editor in its undocked state displays more shift editing tools. Double clicking the top 
bar will re-dock the Shift Editor automatically. 

2. Highlight the Monday cell for “FT Agent Ainsworth” 
 

3. Enter the following split shift 10:00a-2:00p, 6:00p-10:00p. The comma 
denotes the split between the two tours of duty. 
 

 Using this example of a split shift a quicker shortcut is to enter 10a2p, 6p10p.  The time 
formatting is automatically added when entered. Similarly if using 24 hour format i.e. 
10001400,18002200 
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4. Click the Check or Tick icon button to update the information in the day 

cells. A split shift is denoted by ‘x’ between the start and end time display 
in the schedule view. 
 

 If you want to delete one of the periods of a split shift while editing click the period you want to 
delete with the mouse pointer and enter “1” in the Splits box using the spin button. This will 
return the shift to a continuous shift period. 

5. Close the schedule and save with the same filename “Small Team 
Schedule” if prompted. 

 
 
 
 

 Exercise 3.5 
Entering information about Breaks. 

 

This exercise will use the “My Schedule” to schedule breaks. At the start of 
this exercise it is assumed you have already launched Schedule24 Resource 
Manager and no schedule is being displayed in the schedule view area. 

 
1. Click File > Open and select the item “My Schedule” to display the 

schedule in the Schedule View Area. 
 

2. Highlight the Monday column or the first cell and from the Toolbar Menu 
select Data > Sort and click “by Start time” item to sort shifts on this day 
by start time. 
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My Schedule in the Schedule View Area sorted by start time and the Monday column highlighted ready to 

schedule breaks 
 

3. Using the mouse pointer highlight Monday column for all Agents and click 
the right mouse button to display the pop-up menu and select Breaks …. 
This will display the Breaks dialog listing all the shifts on that day. 
Alternatively from the Menu you can select Schedule > Breaks….  
 

 
The Breaks dialog displaying a range of shift. 

4. Select the first shift 7:00a-3:00p in the list.  
 

5. Place the mouse pointer and double-click in the Add new break box. This 
will display the editing cursor to enter break details. 
 

6. Enter 11:00a (alternatively 11a or 1100) in the Start of Break column. 
 

7. Next enter 11:45a (alternatively 1145a or 1145) in the End of Break 
column. 
 

8. Click the mouse pointer below the record. This will update the Total Time 
column and display the box for your next break for this shift if required.  
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The Breaks dialog 

 You can enter times in any two fields to calculate the third field e.g. Start of Break and Total 
Time will calculate the End of Break, or Total Time and End of Break will calculate Start of 
Break. 

9. Repeat the above steps and enter breaks for the following shifts 
 

Shift 
Start of 
Break 

End of 
Break 

Total Time 

7:00a-3:00p 
11:00a 
2:15p 

11:45a 
2:45p 

00:45 
00:30 

10:00a-6:00p 11:45a 12:15p 00:30 

3:00p-11:00p 6:00p 7:00p 1:00 

5:00p-1:00a 9:00p 10:00p 1:00 

11:00p-7:00p 2:00a 3:00a 1:00 

 

10. After you have entered the above breaks for each shift in turn click OK. 
This will close the Breaks dialog and update the highlighted day cells in the 
first column with their respective break periods. 
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Underlying information can be displayed using the mouse “roll-over”. 

 

 You can view more detailed information using the mouse pointer to display the Info tip pop-up. 
This option can be turned on or off in Tools > Options > View tab using the Show Info tips 
checkbox. Note the weekend color coding displayed in the column headers when shift colors 
have priority. Also the ledger view here is created when Grouping is activated in the Options 
dialog based on start times in this example. 

 Breaks can be scheduled for the same shift over a range of days ore weeks so you only enter 
breaks information once. Use the Go To date with the Shft key and mouse control to select any 
range to display the shifts and then add breaks once for all the shift types to be allocated breaks. 

 Exercise 3.6 
Adding Assignments to a schedule 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time. 

 

1. Using the mouse pointer highlight the Monday and Tuesday day cells for FT 
Agent Chiswick and FT Agent Green. 

 
Highlighting the range of shifts to assign tasks. 
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2. From the Menu select Scheduling > Assignments …. Alternatively you can 
point the mouse pointer in the highlighted area and click the right mouse 
button to display the pop-up menu and select Assignments…. This will 
display the Assignments dialog. 

 

3. Enter “Training” in the Type box. 

4. Enter “Induction course” in the Description box. 

5. Enter “Contact department supervisor at the training facility at 10am” in 
the Details box. 

6. Click Add and this will transfer the assignment to the Assignments list. 
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 Entries in the Type box are listed so they can be used again. Choose general categories that 
you are most likely to use again for this box.  

7. Click OK to close the dialog and update both staff on these dates in the 
schedule with this assignment. 

 

You can schedule multiple assignments to a staff shift. Assignment information is also a publishing 
option for schedules. You can view underlying information in your schedule using Infotip display. 

8. Using the mouse pointer highlight the Tuesday day cells for FT Agent 
Chiswick and click the right mouse button to display the pop-up menu.  
 

  
 

9. Select “Assignments” to display the Assignments dialog. 

 You can create a list of categories using the Edit Facility and assign a ranking order whenever 
this information is published in a report as follows. 

10. Click the “Edit” button to display the Assignment category list. 
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11. Enter each the following categories in turn into the “Enter new Assignment 
type:” text box and click the Add button to add it to the list: 

Office Duties 
Front Desk 
Driver 
Stock Taking 
Meeting 
Appraisal 

 

 
The Assignment Editing dialog to add remove or modify Assignment categories 
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12. Using the sort “arrow” buttons re-arrange the order of the list as follows: 
 

 

13. Click the OK button to close the dialog and update the list, and then click 
the OK button to close the Assignment dialog and return you to the 
Schedule View Area. 

 It is recommended you create a category list at the outset. This will help standardise your 
assignments and ensure communication to staff is more consistent. It also makes searching and 
retrieval of information easier. 

 Assignment information is also a publishing option for printed, and email or web schedules. 
There are also a number of standard reports that are based on assignment information. 

 
An example of a report using assignment activity. 
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 Exercise 3.7 
Recording Staff Unavailability. 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time. 

 

1. Using the mouse pointer highlight the Wednesday day cell for “Jasmine 
Fields”. 

 

2. From the Menu select Scheduling > Unavailability …. Alternatively you can 
point the mouse pointer in the highlighted area and click the right mouse 
button to display the pop-up menu and select Unavailability…. This will 
display the Unavailability dialog. 

 

3. Enter “Sick” in the Type box. 
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4. Enter “Heavy Head Cold” in the Description box. 

5. Enter “Will try and do some work from home tomorrow.” in the Details 
box. 

  

 Similar to Assignments entries in the Type box are listed so they can be used again. You can 
also create and modify the category list using the “Edit” button and sort a ranking order using 
the sort arrow buttons. 

6. Click OK to close the dialog and update the schedule with this 
unavailability. A warning dialog will be displayed: 
 

 
 

 Unavailability and Assignments cannot be scheduled together and will generate a conflict 
warning when this occurs. 

7. Click the “Yes” button to accept the change and update the schedule. 
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 Exercise 3.8 
Recording staff vacation. 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time. 

 

1. Using the mouse pointer highlight the day cells Wednesday to the following 
Monday for “Richard Allen”. 

 

2. From the Menu select Scheduling > Unavailability …. Alternatively you can 
point the mouse pointer in the highlighted area and click the right mouse 
button to display the pop-up menu and select Unavailability…. This will 
display the Unavailability dialog. 
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3. Using the drop down list for the Type box select Full Day Holiday. 

4. Enter “Main Leave” in the Description box. 

5. Enter “Approved and confirmed” in the Details box. 

  

6. Click OK to close the dialog. A warning dialog will be displayed: 
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7. Click “Yes to All” button to accept the update and close the dialog and 
update the schedule. 

 If you simply click the “Yes” button on a multiple selection of days, the dialog will update each 
cell at a time and prompt you with a warning before making any changes. “Yes to All” option 
updates all the cells in one go and you only get a warning prompt once. 

 
Entering Vacation into the schedule plan. 

 You check a staff vacation status by running a staff report. Depending on the dates you select 
to run the staff report the vacation status checks against the staff leave entitlement. The default 
staff leave entitlement is 20 days and is set in the Tools > Options > Vacation tab. This can be 
modified. If you went to set individual staff vacation entitlement this is set in the Staff Manager 
> Service tab “Leave Entitlement” text box. 

 Exercise 3.9 
Checking staff vacation status. 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time and you have 
completed the previous exercise. 

 

1. From the Toolbar menu select the “Staff Report” button to open the Print 
Preview Window. 

2. Click the “Setup” button in the Print Preview toolbar to display the Page 
Setup dialog. If not already displayed click the Staff tab. 
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3. Uncheck the checkboxes except the Vacation checkbox in the “Include in 
staff” section. Then click the “Print Range” tab. 

 

4. Select “Richard Allen” in the Staff range section; and select the date in the 
middle of the vacation leave period you have scheduled. 

 This is for the purpose of this exercise and the dates will be different for you. Selecting the 
same ”From” and “To” date  runs the report  and will calculate the vacation status on that date. 
In this example 6 days have been scheduled. Three will have been taken, and three more are 
scheduled to be taken leaving 14 days outstanding from the entitlement. 

5. Click OK to display a preview of the report and the calculated vacation status. 
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 This is the standard staff report. There are other reporting formats calculating leave in various 
Management Reports available as downloads from the Intellicate web site. 

 

 

 Exercise 3.10 
Enter a Memo into your schedule. 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time and you have 
completed the previous exercise. 

 

1. Using the mouse pointer highlight the Monday day cell Monday for Jasmine 
Fields. 

2. From the Toolbar menu click Shift Editor Button to display the Shift Editor 
bar. 

 
Schedule View Area with the Shift Editor bar displayed. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

53 

 
3. Using the mouse pointer click in the Shift Editor text box to display the 

editing tool and change 3 to 5 to display 7:00a-5:00p and click the  
button to update the shift in the schedule. 

 
Highlight a day cell to attach some Memo information. 

1. From the Menu select Scheduling > Memo …. Alternatively you can point 
the mouse pointer in the highlighted area and click the right mouse button 
to display the pop-up menu and select Memo…. This will display the Memo 
dialog. Enter “2 hours overtime incurred extending the shift to 5pm”. 

 
Memo dialog enables you to add information to the staff shift. 

 

 You can enter quite a large amount of information in a Memo. Text will automatically wrap. 
Where you want to enter a break in the text to create a paragraph use Ctrl Break to enter the 
next line. If you enter too much information it may affect layout when publishing schedules and 
reports.  
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2. Click OK to close the dialog and update the schedule with the Memo 
information. 

 

 A red triangle displays a visual cue when a staff shift has a Memo attached to it. A Memo is a 
publishing option for schedules. You can attach a memo to any cell whether or not scheduling 
information is present and is useful for scheduling notes. 

 If you move the selection off the day cell you will notice that Jasmine Field 7:00a-5:00p shift 
has no color, similar with other entries. Color mapping will be covered in the next exercise. 

 

 Exercise 3.11 
Color mapping Days-off, Weekends and other Holidays. 

 
 

At the start of this exercise it is assumed you have already launched 
Schedule24 Resource Manager and ‘My Schedule’ is displayed in the Schedule 
View Area. The first day column is sorted by Start time and you have 
completed the previous exercise. 

 

 Color mapping is dependent on option settings which will differ from the example illustrations 
used here. The purpose here is to know the features that apply color and turn them on and off. 
The color is not important and will always be a matter of preference. 

1. From the Menu select Tools > Options … > Color tab to display the Options 
dialog. 

2. Check “Show” in the Shifts section and select “Shift color” option. 

3. Check “Show” checkbox in the Unavailability section and select the 
“Individual” option; and check “Show” in the “Holiday” section. 

4. Finally, check “Show Assignment color”.  
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This is where you control all your color mapping in the Schedule View 

 

 Ignore the “Cover count” or Staff count section this will be dealt with in a later section. The 
individual option for “Unavailability” enables you to map colors to individual categories of 
unavailability. This can be contrasted with “Assignments” that are mapped to a single color 
choice as multiple assignments can be scheduled to one shift and has a display constraint.  

5. Check  and highlight the “7:00a-5:00p” shift displayed in the shift list, and 

Click the color palette icon  to display the color palette 

 

6. Pick your color preference and click OK to assign the color to the shift. 

7. Repeat the above steps and assign your color preferences to other shifts. 
Click OK to close the Color palette window. 
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 If you don’t check the shift checkbox that particular shift color will not be displayed in the 
Schedule. 

8. Repeat the procedure for “Unavailability” and options for “Show 
Assignment color” and in the “Holiday” section. 

 When you close the Options dialog the color mapping will be updated. If it doesn’t behave how 
you expected, go back and check you have options selected to display even though you have 
mapped a color. 

9. Close the Options dialog to update the schedule view. 

 The following procedure deals with options in the Holiday section. For the purpose of this 
exercise make a note of the Monday date in the first column displayed in the Schedule View. If 
you haven’t already done so select a color for the Public Holiday and Weekends option and 
check to display in the Schedule View  Area. 

 You might want to deselect the other color mapping options to see the changes more easily. 

 
These settings will only display the color mapping of weekends and public holidays 

10. Open the Options dialog and select the Vacation tab. 
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11. Select the date displayed in the first column of your Schedule in the Public 
Holiday date box using the drop down calendar. 

 You can extend the drop down calendar to enlarge your selection area. This is useful if you 
want to select all your public holidays for the year in one go. 

12. Add the date to the Public Holiday list using the < button. Click OK to 
close the dialog and update the color display in the Schedule. 

 
The Schedule View displaying holiday options using color mapping 

13. Open the Options dialog and select the color tab again. Check the Shift 
color: checkbox. Click OK to close the dialog and to display the shift colors 
in the Schedule. 
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The Schedule View displaying shift and holiday options using color mapping 

 Shift colors have priority over holiday colors. However the date header for each column 
always displays the color mapping for holiday colors. Care needs to be taken when using 
color, too much and it can be confusing. Also bear in mind printers set on economy will 
often only print greyscale. 

 

 Exercise 3.12 
More about entering shift time and shift descriptions. 

At the start of this exercise it is assumed you have launched Schedule24 
Resource Manager and have completed the ‘Small Team Schedule” in the 
exercise 3.4.  

My Schedule we have been working with was originally created using the 
“Scheduling Wizard” and was based on an underlying shift pattern. You may 
not have realised this and it is not important at the moment as we will be 
dealing with Shift Patterns and how they work with schedules in the next 
section. The Small Team Schedule has been created manually from scratch 
using the standard editing tools, and we are returning to this schedule to help 
show step by step how things work in this exercise.  

1. Using the mouse pointer select File > Open from the Toolbar menu to 
display the open dialog. 
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2. From the file list select Small Team Schedule 

 

The “Small Team Schedule” displayed in the Schedule View Area for the section exercises. 

 What you see may be different to the screenshot being displayed here. The color, ordering of 
staff and even display may look different. The following steps are to adjust the settings so your 
screen looks the same. 

3. From the toolbar menu select Tools > Options and select the View tab and 
adjust the settings to those displayed here: 
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Viewing options if you have ledger lines displayed uncheck Grouping. 

 

4. Keep the Options dialog open and select the Color tab and adjust the 
settings to those displayed here: 

 
Color options. Only content specific to your schedule is displayed. 

5. Close the Options dialog to update the Schedule View Area. 

6. From the toolbar menu select Data > Sort by > Last name. This will display 
staff last names in alphabetical order. 

7. From the toolbar menu select View > Departments to display this 
information against each staff record in the schedule View. 
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 The rest of this exercise will involve manually adding more information to the schedule, and 
take a closer look at ways of representing information using descriptions and color mapping. It 
will not involve a great deal of information, but sufficient to reinforce and expand on what we 
have done so far. The procedures are the same whether we are dealing with a handful of staff 
to several hundred.  

8. From the Shift Editor bar click the Shift Description button to display the 
Shift Descriptions dialog. 

 

 
Shift Descriptions dialog is where you add meaning to shift times 

 

 A shift description can be anything and is a useful technique to add additional information to 
your staff schedule. You can use descriptions like “Early”, “Late” and “Night” to describe 
different shifts. You can also use descriptions which describe an activity, role or location, for 
example “Reception”, “Senior Lead”, “Available” and “Unavailable”. You can also use a 
description for non shift events, one good example is “Day Off”. A non shift event is anything 
that does not have a period of work hours and is associated with the whole day. There are 
three special or reserved descriptions Schedule24 Resource Manager recognises when 
making calculations: 

Reserved 
Description 

What it 
represents 

When to use it 
Why should I 
use it 

Day Off 

It represents a rest 
period taken as part 
of agreed working 
arrangements. 

Normally for full time 
working e.g. over 30 
hours a week. 

To automatically 
check for working 
hour s and rest 
periods conflicts. 

Unallocated Staff have not been Normally for part time Calculating working 
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assigned a shift but 
it is not a day off. 

working e.g. under 30 
hours a week. 

hours. 

Time Off 

It represents time off 
in place of a 
previously 
scheduled shift. 

When staff has extra 
hours in hand and 
takes a whole shift off 
in lieu. 

To track overtime and 
time off in lieu in 
management reports. 

 

9. Using the mouse pointer and double-click the Descriptions column in the row 
displaying “Add new ones here...” this will display the text tool, and enter 
“Day Off” (without the quotes). 

10. Using the mouse pointer highlight the text “Add new ones here...” and press 
the Delete key on the keyboard; or alternatively right click the mouse button 
and select “Delete” from the pop-up menu. 

11. Move the mouse pointer off the record and click to display the “Add new ones 
here...” prompt for the next record and to update the record. 

12. Click OK to close the dialog. 

 

 
Entering the Day Off in the Shift Descriptions dialog. 

 If you do not delete the “Add new ones here...” prompt when you update the record the default 
time 12:00a-12:00a will be entered. Simply go back and highlight “12:00a-12:00a” and delete. 
The Shift entry column for reserved descriptions is always blank for the logic to be applied in 
calculations.  

13. Using the mouse pointer click on the Shift Editor bar and holding the mouse 
key down drag into the Schedule View Area to display the undocked Shift 
Editor controls. 
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The Shift Editor controls displayed when undocked in the Schedule View area. 

14. Highlight the Monday day cell for “Victoria Ainsworth” and click the 
“Unallocated” button in the Shift Editor and then the tick or check button 
to enter the information into the schedule. 

 

Entering “Unallocated” a reserved description into the schedule. 

15. Click the drop down list in the Shift Editor text box to display the previous 
entries. 

 

Displaying the list of entries used in a schedule. 
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 Note “Unallocated” has been entered into the list without typing the entry. That was to 
demonstrate another way of using a feature.  The two reserved descriptions “Day Off” and 
“Unallocated” are entered into the list when using their respective button controls in the Shift 
Editor. We will now enter more information using the Shift Descriptions dialog. 

16. From the Shift Editor bar click the Shift Description button to display the 
Shift Descriptions dialog. 

17. Following the procedure described earlier enter the information as below: 

 

 

Adding more shift entries into the Shift Editor list 

 You are not adding this information into the schedule, but preparing a defined list of shifts and 
descriptions. It is worthwhile taking the time to plan this to maintain a consistent plan. You can 
change this information and add to it at any time. 

18. Click OK to close the dialog and click the drop down list in the Shift Editor 
text box to display the entries. 
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A more comprehensive list of scheduling information. 

19. Using the mouse pointer highlight the range of day cells for “Javid Ali from 
Monday to Friday and from the drop down list in the Shift Editor select 
“7:00a-3:00p Early” and click the tick or check button to enter the 
information into the Schedule View. 

20. Following this procedure enter the information into your schedule as 
presented below:  

 

Adding shift information to the Schedule View area 

21. Using the mouse pointer click View > Shift Description to display the 
description view. 

 The color settings in the Options dialog have been turned off in this screenshot. You can 
experiment with color and remember shift times and shift descriptions can be mapped to colors 
independently. 
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You can toggle between shift times and shift description to display information in alternative ways. You 
can also view both shift time and description by hovering the mouse pointer to display the info tip. 

 Have a go and enter information to present the following view: 

 

 Tip: The descriptions “Available” and “Not Available” do not have shift times associated with 
them. It is another example how to plan and work with information. The Shift Editor list would 
look like this: 

 

Displaying the descriptions “Availability” and “Unavailability”. Note the sort control. 
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22. Using the mouse pointer highlight the Wednesday day cell for “Jasmine Fields” 
and enter 7a3p (this is the shortcut entry and the time format will be applied) 
in the Shift Editor text field. 

23. Click the enter button and this will display the “Duty Selection” dialog. 

 

The Duty Selection dialog enables you to reduce and remove ambiguity.  

 

 When you type a shift or shift description as an alternative to selecting from the list and the 
information you have entered can have more than one match, the dialog enables you to 
choose the one you want. In this example there are two instances of 7:00a-3:00p shifts having 
different shift descriptions. If you do not want to use shift descriptions displayed you can select 
the default blank value and the shift time only will be updated in the Schedule View. 

24. Select “Early” and click to close the dialog and update the Schedule View 
area. 

 
The updated schedule after completing this series of exercises. Color mapping is displayed for shift 

descriptions. 
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25. Close the schedule and at the Save prompt save the schedule with the 
filename Small Team Schedule and exit Schedule24 Resource Manager. 

 

 Exercise 3.13 
Color mapping Assignments and Unavailability. 

At the start of this exercise launch Schedule24 Resource Manager and have ‘My 
Schedule” displayed in the Schedule View area.  

1. From the Menu select View > Shift Times to return the display from a shift 
description to a time format if not already displayed. 

2. Open the Options dialog and select the Color tab. You will see the shift 
description is now replaced with shift time format. 

3. Uncheck the Shift colors: checkbox to disable the shift color display 

4. Select the Unavailability color: checkbox to enable the color display for 
unavailability and select the “Individual” option. Select a preferred color for 
category “Full Day Holiday” and “Sick” using the screenshot below as a guide. 

5. Check Assignment color and select a preferred color. 

6. Follow the procedure to remove the color for “Cover” or staff count. We will 
return to this feature in a later section. 

 Color is always a matter of preference and it is not important for this exercise to follow these 
examples accurately. 

 
The Options display after selecting the exercise options. 
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7. Click OK to close the Options dialog and update the Schedule with the 
modified colors for shift descriptions. 

 

8. Close the schedule.  
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Section 4 - Working with Shift Patterns 
You can schedule directly into a Schedule using the scheduling 
editing tools to quickly create and build your schedules. A 
powerful alternative is using shift patterns to automate and 
scale up your scheduling. 

After completing this lesson you will be able to: 

1. Use the Shift Pattern Design Wizard. 

2. Learn about the Shift Pattern design environment. 

3. Design a shift pattern to automate schedule production. 

4. Work with the Team Manager to assign staff to shift patterns. 

Section 4 Exercises: Working Faster with Shift Pattern Designs 

 Exercise 4.1 
Using the Shift Pattern Wizard. 

 

At the start of this exercise it is assumed you have launched Schedule24 
Resource Manager and you have no schedule displayed in the Schedule View 
area. Notice that all the toolbar menu items and controls in the Navigation 
pane are greyed out and disabled because you do not have a schedule 
displayed, however the “Shift Pattern Designer” button is enabled. 

The Shift Pattern Designer is an embedded application with its own toolbar 
menu and controls independent of the Schedule View area. You are already 
familiar with the Shift Editor controls used for scheduling. 

The Shift Pattern Wizard is very similar to the Schedule Wizard except it does 
not have a staff section; it is totally focused on creating a shift pattern. 

Section 

4 
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 Designing shift patterns is a management skill outside the scope of these exercises designed 
to familiarise you with the controls of the design environment and how they work. We will use 
practical examples and some of the techniques of shift pattern design but the subject matter is 
too wide to cover everything here. A shift pattern is not a schedule, but is used to create 
schedules. When managing complex workplace environments, often with multiple working 
arrangements, the best approach is to combine several simple shift patterns into one schedule 
rather than try and create one overall shift pattern that attempts to deal with everything. Finally, 
the Shift Pattern Designer is closely allied to the Team Manager which is used to allocate staff 
you have entered in the Staff Manager to the shift patterns you are using to automate your 
scheduling. 

1. Launch Schedule24 Resource Manager and close the Welcome Screen if you 
haven’t already done so. 

2. From the Toolbar Menu select Schedule Designer. This will display the 
schedule design environment. 

 

The shift pattern design controls 

 
The Shift Pattern Design environment default week based view. 

 

 The Shift Pattern Designer supports over 30 business and scheduling rules governing shift 
type, duration, juxtaposition (in relation to each other and days off) and constraints about 
working hours. There are two kinds of shift pattern designs: weekly; and sequence based 
patterns. Weekly based patterns use the standard 7 day week, and sequence based patterns 
use a number of days without reference to days of the week. For example, 4 days on followed 
by 4 days off generates an “8 day week” which of course does not exist but is often referred to 
as such. 
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3. Using the mouse pointer select File > Shift Pattern Wizard to launch and 
display the Wizard welcome screen. 

 
The Shift Pattern Design Welcome screen 

4. Click Next to the Add Shifts section.  
 

 
The Shift Pattern Design “Add Shifts” screen. 

5. In the Shift box enter “7a3p” (to denote 7:00a-3:00p) and in the 
Description box enter “Early”. Select a color code for the shift by clicking 
the color listing. Click the Add button to add this shift to the display list. 

 Tip: If your preference is for 24 hour working select the 24 hour option. To save time 
formatting 24 hour time can be entered as a continuous entry e.g. 07001500 and the 
07:00-15:00 formatting will be applied automatically. 
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  
 

6. Follow the step above to enter the following (shortcut) time and 
descriptions each with a color code: 

 

7a3p Early 

10a6p Day 

3p11p Late 

5p1a Evening 

11p7a Night 

 
 

7. When you have completed entering this list your display should look 
something like this (your color choice is not important for this exercise): 

 

 
The Shift Pattern Design after shifts and descriptions have been added. 

 If you make a mistake on entering information simply delete the entry and re-enter. The entry 
order for shifts in this section becomes a choice option later. 

8.  Click Next to move to the Select Start Day section. Accept the default 
start day Monday. Click the More button to display the dashboard 
feedback during design. Your display should look similar to this: 
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The Shift Pattern Design is created with default teams and staff. 

9. Move the mouse pointer over the grid area and when the pointer changes 
to a magnifying-glass icon double-click to zoom out and view more detail. 

 Repeating this procedure will toggle the display and zoom back in. 

 

The Shift Pattern Design in ‘zoom’ out view. 

 You can navigate the Wizard forwards and backwards using the ‘Back’ and ‘Next’ buttons. 
Changing options will automatically update the shift pattern including the shift count for each 
day and team. 

10. Using the mouse pointer Click the More > button to display the feedback 
panel. Repeat the procedure and Click the Less < button to hide it. 
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The Shift Pattern Design feedback panel displayed. 

 The feedback panel dynamically updates as you navigate through the wizard selecting and 
changing options. Before continuing with the keyboard exercise the following table explains the 
meaning and importance of this information. 

Description What does it tell me Why do I need to know this 

Percentage of allocated shifts The number of shifts used in the 
overall shift pattern expressed as a 
percentage. 

8 hour shift will be around 75% and 
12 hour shifts around 50%. This 
gives you feedback about the 
effectiveness of your staff supply. 

Percentage of unallocated shifts The number of day cells that do not 
have a shift or day off. When the 
number of shift options are satisfied 
no more will be added even when 
there are empty days cells 

This gives you feedback about the 
efficiency of your staff supply, if you 
have a set number of staff you need 
to know where the redundancy is to 
consider other options. 

Percentage of days-off The number of days off used in the 
overall shift pattern expressed as a 
percentage  

Indicates the flexibility of the staff 
supply. 50% Days Off is less flexible 
than 25% Days Off. 

People working each day The number of people actually 
working each day. Not to be 
confused with the number of people 
needed. 

Can be any number depending on 
the shift pattern. The number can 
be controlled using a customised 
Staff Distribution. 

Distribution balance (Efficiency) How close the shifts are distributed 
equally among the number of staff 
indicates the efficiency of the shift 
pattern. 

100% balance means shifts are 
distributed equally among all the 
staff. Less than 100% will mean 
there may be some inequality.  

People required This is the number of the people Sometimes confused with ‘People 
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Description What does it tell me Why do I need to know this 

needed to make the shift pattern 
work. 

working each day’ which is always 
less than ‘People required’ because 
some are on days off. 

People entered The number of people entered by 
the user. 

Only applicable for the schedule 
wizard and not when used as with 
the shift pattern wizard in the 
environment. 

People per team The number of people that can be 
grouped into teams. 

If standard shifts are used with 
equal staff allocations grouping will 
occur; otherwise there may be 
several teams with just one person. 

Teams required The number of teams needed to 
make the shift pattern work. 

If working together in teams is 
important it will let you know which 
shift combinations achieve this. 

Length of schedule The number of days a shift pattern 
needs before it starts repeating. 

If you have a number that can be 
divided by 7 you have a week 
based pattern; otherwise it will be a 
sequence based pattern. 

Maximum daily hours The maximum hours worked in one 
24 hour day. 

Too many hours can lead to fatigue 
and increase risk. 

Average daily hours The average daily hours worked 
over the length or cycle of the shift 
pattern. 

Too high or too low need to be 
avoided. Used with maximum daily 
hours. 

Maximum hours per rolling week The maximum hours worked in any 
given 7 day period. 

Useful whenever 24/7or any rotating 
shift patterns are used.  

Average hours per rolling week The average hours worked in any 
given 7 day period. 

Useful whenever 24/7or any rotating 
shift patterns are used. 

Minimum rest period between 
shifts 

The time between two shifts not 
including days off. 

The most important piece of 
feedback in this panel. Less than 11 
hours between shifts is considered 
undesirable and should be avoided. 

Average rest period between 
shifts 

The average time between two 
shifts not including days off. 

Increasing the average rest period 
over the shift pattern cycle wherever 
possible is to be preferred, even 
though the minimum period is 
satisfied. 

 

 There are countless permutations when using the shift pattern wizard. Even so it has 
limitations, for example, it will not allow single or ‘orphan’ days off to occur in any pattern. For 
total control the shift pattern design environment is used although the wizard is one way to get 
you started with the basics. 

 Whatever options you choose the shift pattern wizard will always guarantee a shift pattern. For 
those of you who are familiar with endless streams of ‘no solution found’ after battling configuration 
tables will appreciate. 

11. Click Next to move to the Fixed or Rotating section and select the 
Rotating option. 
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 A “Fixed” shift option means staff generally always work the same shift and have the same days off 
each week. A “Rotating” shift option generally means staff work different shifts and have different 
days off each week. 

 
The Shift Pattern Design with a perfectly balanced distribution of shifts. 

 In practice shift patterns may not always be so conveniently balanced but should always be a 
goal of shift pattern design. 

12. Click Next to move to Add Days Off section and select the Customize 
option to display the controls for the days-off days-on work ratio. Accept 
the 2 days-off default and increase the days-on to 6. Finally select the 
Forward stagger option. 

 Monitoring the feedback panel the rest periods between shifts is displaying ‘1’ which indicates 
that somewhere in the design two shifts are adjoining each other, and clearly 1 hour is 
insufficient rest between shifts.  

13. To resolve this select the “Backward stagger” option for days-off which 
re-adjusts the pattern to maintain sufficient rest periods between shifts. 

 This approach is known as heuristic problem solving i.e. you do not have to know the details of 
the problem completely to find an acceptable solution faster. When presented with an 
alternative to continue searching longer for another solution you need to take account that one 
may not exist or if it does, the benefits delivered do not outweigh the costs finding it. 
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The Shift Pattern Design with a less than perfectly balanced distribution of shifts. 

 As modifications are made to the shift pattern the dashboard feedback will automatically 
update its display. The interactions are complex which would take many hours to work out, in 
some cases several days’ even weeks. With practice, keeping an eye on the feedback will 
guide you toward which options improve your design and avoid those that don’t in a few 
minutes.  The following procedures will demonstrate this time saving approach. 

14. Click Next to move to the Staff Distribution section and select the 
Customize, enter the desired number of staff in the staff column option. 
This will display the staff distribution control. For the purposes of this 
exercise click the mouse pointer in the staff column and enter the staff 
number 3 next to 10:00a-6:00p displayed in this screenshot. 

 
Changing options like changing the distribution 

of staff can improve the shift pattern. 
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 Tip: You can treat the staff numbers as actual numbers of staff, or as proportions of staff. For 
example you can take the view there are three times the number of staff on the 10:00a-6:00p day 
shift than on the early, late and night shifts. 

15. Click Next to move to the Direction of Rotation section and accept the 
Forward default option. 

16. Click Next to move to the Speed of Rotation section and accept the 
Change Shift after Days Off default option. 

 

Sometimes improving one area can mean making another worse. 
 

 As we move through the Wizard choosing options to improve the pattern can impact other 
areas. In short it can be a question of trade-offs. Here for example we have reduced the length 
of time staff work a particular shift (they work three times the number of day shifts). While we 
have solved that problem it is at the cost of the distribution balance; and worse almost non-
existent rest period between shifts at some point in the pattern. 

17. Click “Add Days Off” in the left hand side menu list to go back to the 
“Setup your Days Off” section of the Wizard. Select the option “Forward 
stagger days off”. Your shift pattern should look something like this. 
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Revisiting a simple option choice can make all the difference. 

 

 Revisiting a previous option can make all the difference and in this case the shift pattern is as 
good as it is likely to get. What may have worked well at the beginning of a design may not 
work as well as you make changes downstream. Monitoring the Dashboard feedback is key to 
making better choices.  

18. Click Finish in the menu list to move to the Finish section and click Finish. 
This will display the completed shift pattern in the shift pattern design 
environment. 

 
The completed shift pattern created in the Wizard displayed in the Shift Pattern Design environment. 

 To view the average weekly hours for the shift pattern using the mouse pointer select View > 
Hours Summary from the Shift Pattern Designer menu. Then select Tools > Options > 
Calculations tab to display the settings for hour’s calculations. In the Calculate over box enter 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

81 

24 days (the rotation cycle of the shift pattern in days before repeating) and in the display 
calculation for box enter 7 days. Click OK to close the Options dialog and update the hour’s 
summary display in the Shift Pattern Designer. 

 A bit of theory: Remember there are only two kinds of shift pattern design: weekly based; and 
sequence based patterns. This pattern example has a 24 day rotation cycle. It is not divisible 
by 7 – the number of days in a week – therefore it is not a weekly based pattern but a 
sequence based pattern based on a period of 24 days. (Sequence are notoriously difficult to 
generate in a standard spreadsheet because we are so ‘tuned’ to the 7 day week.) The main 
point to remember with sequence based patterns the shifts are ‘anchored’ to their respective 
positions in the pattern and not the days of the week. For example, the first shift for Team 1 is 
7:00a-3:00p, it also appears to be on a Mon of the week which is correct as far as this was the 
day of week we want this shift pattern to start. What it doesn’t mean is that 7:00a-3:00p will 
always fall on a Monday, or put another way Monday will always be a 7:00a-3:00p shift. 
Because of the 24 day pattern cycle it will be sometime before 7:00a-3:00p does fall on a 
Monday (a further 72 days in fact). 

 Tip: Most of the time you need not worry about these subtleties. Once you have a completed 
shift pattern whether weekly or sequence based its management in a schedule is automatic and will 
always do the right thing. For more serious shift pattern analysis these are your reference points 
when analysing the two types of shift patterns. 

 

Referencing week based and sequence based shift pattern. 

 
19. From the Designer Menu select File > Save with the filename My Shift 

Pattern. 
 

20. From the Shift Pattern Designer Menu select File > Exit to exit the Shift 
Pattern Designer. Alternatively you can use the Close X button on the 
form.  
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 Exercise 4.2 
Automating a staff schedule with a shift pattern design 

The first part of this exercise provides the opportunity to demonstrate how to 
import staff from another schedule and setup the schedule view area for the rest 
of the exercise without re-keying staff information. It is assumed you have 
launched Schedule24 Resource Manager, the Navigation Pane is displayed and the 
Schedule View Area is empty.  

1. Using the mouse pointer select New Schedule from the Start your Schedule 
section of the Navigation Pane to display a new schedule in the schedule 
View Area and the Schedule Assistant dialog prompts. 

 

Creating a new schedule with the Schedule Assistant prompt dialog displayed. 

2. Select the option “Import staff from an existing schedule” to display the 
list of available schedules dialog. 
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Selecting a schedule from a list of available schedules. 

3. From the list of example schedules select “IT Support” and click OK to 
import the staff from that schedule into the new schedule in the Schedule 
View area, and display the Schedule Assistant. 

 

Importing staff into a new schedule with the Schedule Assistant displayed prompting the next steps. 

4. Select the option “Insert shift patterns to automate my schedule” and click 
OK to display the “Insert Shift Pattern” dialog. Making sure the start date 
matches the first day of the shift pattern design in this case “Monday”. 

 

Displaying the Insert Shift dialog with the list of shift patterns available. 
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 For week based patterns it is very important when inserting a shift pattern into a schedule that 
it starts on the same day of the week as the first day used in the shift pattern design. If the days 
of the week are not matched correctly the weekly based shift pattern will not synchronise 
correctly with the calendar dates in the schedule.  It is less important for sequence based 
patterns but it is good practice to apply this principle to all shift patterns being entered into a 
schedule. 

5. Select “My Shift Pattern” in the list and using the mouse pointer click 
“Start Date” drop down calendar and select the next date falling on a 
“Monday” and click Insert button to enter the shift pattern. The Schedule 
assistant will again be displayed. 

1. You will have realised by now that Schedules are dynamically associated with your 
computer clock. You need to make sure this is setup correctly. 

 

 

The Schedule Assistant prompting the nest steps after entering a shift pattern 

6. In the Schedule Assistant accept the recommended default prompt 
“Allocate staff to teams using the Team Manager” and click OK to display 
the Team Manager. 

 The Team Manager organises all the information about staff and shift patterns. It is where you 
allocate the staff entered in the Staff Manager to any of the shift patterns you have designed 
and entered (or associated) with a schedule. It is in effect the ‘bridge’ that coordinates staff with 
shift pattern designs. If you do not have a shift pattern associated with a schedule the Team 
Manager will be disabled. 
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THE TEAM MANAGER C ONTROLS  

 

The Team Manager is the ‘Bridge’ for coordinating staff and shift patterns. 

 We will be revisiting the Team Manager in more detail later for now this serves as an 
introduction to its main features, and we use the controls for convenience of this exercise. 

7. Click the “Auto-Distribute Staff to Teams” to automatically allocate the 
available staff equally across the shift pattern teams. 

 

Distribution of staff displayed after auto-distribute. 
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8. Using the mouse pointer select and highlight “Wendy Harrow” and holding 
down the left button of the mouse ‘drag and drop’ into the “Available 
staff” pane (or window). 

 

Adjusting the lists in the Team Manager using drag and drop. 

 When staff numbers cannot be equally divided amongst the number of team places available, 
you will have one or more teams with less staff than other teams. In this example the 
distribution is two staff to each team but one has three. It can also be used to move staff from 
one team to another. The effect of moving “Wendy...” to the “Available staff” status will mean 
she has no shifts allocated in the schedule view area. 

9. Click the OK button to close the Team Manager and update the Schedule 
View Area. 

 
The updates schedule generates the pattern of shifts against allocated staff. 
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10. Using the mouse pointer select the “Automate with Shift Patterns” section 
of the Navigation Pane to display easier access to the shift pattern and 
Team Manager features. 

11. Finally, using the mouse pointer click the date header column to highlight 
the “Monday” day and from the toolbar menu select Data > Sort by > Start 
time. This will arrange the schedule in a familiar shift block display. 

 

After sorting by start time the characteristic shift blocks emerge in the display.  

 If you scroll the schedule about half way down “Wendy...” will be displayed with no shift 
patterns because she was not allocated a shift pattern in the Team Manager. This doesn’t 
prevent shifts being added manually using the Shift Editor. Also remember you can change the 
color mapping by going to the Color tab in Options to change these settings. The schedule will 
be generated however far you scroll or ‘jump’ to in the future. 

 When the time comes to navigate sometime in the future you can use the “Go to Date” pop up 
calendar by using the right mouse click on the column header. If you ‘jump’ several months or even 
longer it will take a minute to build the schedule over the period of time ‘jumped’. Afterwards 
navigation to any date in that period will be instantaneous for that session. 

12. Using the mouse pointer select File > Save and when prompted save with 
the filename “My Auto Schedule”. 

13. Exit Schedule24 Resource Manager. 
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 Exercise 4.3 
Automating more complex staff schedules with multiple shift patterns. 

At the start of this exercise it is assumed you have launched Schedule24 Resource 
Manager, no schedule is open in the Schedule View area; and the Navigation Pane 
is displayed. 

 This exercise is designed to reinforce what you have done so far, and provide additional practice 
with the Team Manager and shift pattern designs to automate a more complex staff schedule. It 
involves several staff groups and roles with different working arrangements. You will be using 
previously prepared example material to reduce and avoid keyboard entry to enable you to focus 
on technique. 

 You will be using several shift patterns but for this exercise do not need to understand how they 
were designed. This will be covered in the next section. 

1. Using the mouse pointer select New Schedule in the “Start your Schedule” 
section of the Navigation Pane to display a new schedule in the Schedule 
View area and the Schedule Assistant. 

2. Select the option “Import staff from another schedule” to display the list 
of schedules in the Insert staff dialog. 

3. Select the schedule “Business Center” and click OK to populate the 
schedule with staff and the Schedule Assistant will be displayed.  

4. On this occasion select the option “No thanks, I’ll add shifts or shift 
patterns later” and click OK. This will display the Shift Editor Toolbar in its 
docked position. 

 

Declining to add shifts or shift patterns in the Schedule Assistant. 

5. Using the mouse pointer select the “Automate with Shift Patterns” section 
in the Navigation Pane to display access to the Shift Pattern and Team 
Manager controls if not already displayed. 
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6. Using the horizontal scroll bar, adjust the schedule display forwards so the 
first day column is a Monday. 

 

The Schedule View area with the “Automate with shift Patterns” section control displayed 

 At this point color mapping of shifts has been disabled in Options > Color tab by unchecking 
the “Show” checkbox in the shifts section. This is to reduce any confusion between any color 
mapping on different computer settings that may have taken place. It will be enabled later in 
this lesson. 

 Tip: Note that the Team manager button in the menu toolbar is disabled because this schedule 
has no shift patterns associated with it. 

7. Select “Insert shift pattern into schedule” from the “Add shift pattern” 
section to display the “Insert Shift Patterns” dialog. Double click the 
“Business Centre” folder to open the shift pattern list. 

 This folder contains the shift pattern designs to be used for this schedule.  

 

The Insert Shift Pattern dialog displaying the example shift patterns in preview mode. 
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8. From the list select the “Management Team” shift pattern and in the Start 
Date calendar field select the Monday date displayed in the first column of 
the Schedule View area. 

 Tip: The start date week day has to be the same day as the start day of the shift pattern 
design. It can be any date provided it is a Monday. If the shift pattern design started on Sunday 
then it can be any date provided it was a Sunday (or whatever day of the week the shift pattern 
design starts). 

 If you scroll the preview to the end of the shift pattern you will see it has a 7 day cycle before it 
repeats (it is a simple traditional working week). The number of days can clearly be divided by 
seven making it a week based shift pattern. If the shift pattern is started on a day other than 
“Monday” it will not be synchronised with the calendar dates and days of the week. The most 
obvious effect will be the days off will fall on other days of the week rather than at weekends.  

9. Click the Insert button to close the dialog and display the Schedule 
Assistant prompting for the Team Manager and accept the default option to 
display the Team Manager. 

 You will be staying with the Team Manager to insert the other shift patterns we will be using. 
You do not have to exit the Team manager to insert (or associate) another shift pattern to the 
schedule. Also note that this shift pattern has only one Team  slot due to its simplicity of design 
i.e. one shift, office hours if you like that repeats every week with always the same days off at 
weekends. 

 

The Team Manager displaying the first selected shift pattern 

10. Click the “Insert Shift Pattern...” button to display the “Insert Shift 
Pattern” dialog. 
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The Insert Shift Pattern dialog ready to select and insert the next shift pattern 

11. Select and highlight the “Meet and Greet” shift pattern and note the 
preview display changes. 

 Scroll the preview to the end of the shift pattern and note the 14 day rotation cycle, or duration, 
before repeating. It can be divided by seven making it a weekly based shift pattern. 

12. Making sure the “Meet and Greet” shift pattern is still highlighted, in the 
Start Date calendar field select the start date that is on a Monday week 
day. 

 This can be the date of the first day Monday displayed in the schedule. 

13. Click the “Insert” button to update the Team manager with the shift 
pattern and close the dialog. 

 

The Meet and Greet Team Example shift pattern is added to the list 
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 Note the Teams display has changed from one group to two groups because of the different 
characteristics of this shift pattern having two teams. If you select the other shift pattern and 
toggle the view you will see the display change depending on the selection. 

14. Using the mouse pointer Click on the “Modify List” button to display the 
“Modify Shift Pattern List” dialog. 

 

Managing the display and order of shift pattern 

 You may only have one shift pattern associated with a schedule; on the other hand you may 
have many. Over time you may find a shift pattern is no longer needed, and add new ones. 
You can manage the display of shift patterns this way so the lists do not get too long to 
manage, and if you decide to use a shift pattern again you simply enable its display in the drop 
down select list. You can also maintain an accurate historical record of schedules using shift 
patterns no longer in use. 

15. Click OK or Cancel button to close the dialog and return to the Team 
Manager. 

 At this point and before we add the remaining shift patterns we will allocate staff to these two 
shift patterns. 

16. Using the mouse pointer make sure you have selected “Management Team 
activated from <date> starting week 1” if you have not already done so to 
display the team groupings for that shift pattern in the Team Manager 
Team list. 

17. Using the mouse pointer click on the “Name bar” of the “Available Staff” 
section to sort the staff in descending alphabetical order, or until the small 
back arrow is pointing downwards. 
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18. Click the “View” button to display a view of the selected shift pattern, and 
then close the dialog using the windows close button. 

 

Checking the view of the shift pattern before allocating staff. 

 If you are working with multiple shift patterns it is good practice to check the view of the shift 
pattern before allocating staff to make sure you have selected the right pattern. 

19. Using the mouse pointer and the Ctrl key select the following staff in the 
“Available staff” list. 

 Res. Planner Mrs Hilary Gough 

 Mgmt Coach Dr Trevor Casey 

 Manager Ms Cynthia Cross 
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Selecting staff from the Availability staff list. 

20. While holding down the mouse button and Ctrl key drag the selection into 
the “Management Team” displayed in the “Teams” section. 

 

Using drag and drop to allocate the selected staff a shift pattern 

 Having allocated staff to their respective teams (though in this example there is only one team 
due to the simplicity of traditional office hours) it might be important to allocate a sort or ranking 
order of those staff in the team. It may be based on role, seniority or any ordering that the 
default ascending or descending alphabetical sort does not give you. Where there are several 
teams (boxes) each one can be configured independently as we will see shortly. 

 Ascending/descending alphabetical sort is the default setting. You toggle between the two by 
clicking the mouse pointer on the team box header. The black arrow indicates the current sort 
display.  
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21. Select the “Order” option at the bottom of the “Teams” section to display 
the ranking arrows at the side of the team box. 

 
Ranking team members using the “Order” and up and down buttons. 

22. Select “Res. Planner Mrs Hilary Gough” to enable the “Up” button and click 
the “Up” button to move her to the second position in the team. 

 The “Up & Down” buttons are enabled and disabled depending on the position the selection 
occupies in the team e.g. if at the bottom of the list the “Down” button will be disabled. 

23. Using the mouse pointer make sure you have selected “Meet and Greet 
Team Example activated from <date> starting week 1” to display the team 
groupings for that shift pattern. 

24. Using the mouse pointer click on the “Name bar” of the “Available Staff” 
section to sort the staff in descending alphabetical order, or until the small 
back arrow is pointing upwards. 

25. Click the “View” button to display a view of the selected shift pattern, and 
then close the dialog using the windows close button. 

 The Meet and Greet shift pattern has two alternating shifts and requires two teams. Each team 
member works the two shifts alternately each week. The CRM staff are distributed across the 
two teams. 
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Viewing the selected shift pattern before allocating staff. 

26. Using the mouse pointer and the Ctrl key select the following staff in the 
“Available staff” list. 

 CRM Miss Helen Vizara 

 CRM Mr Graham Waters 
 

 
Selecting staff from the Availability staff list. 

27. While holding down the mouse button and Ctrl key drag the selection into 
the “Meet and Greet A Team” displayed in the “Teams” section. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

97 

 
Using drag and drop to allocate the selected staff a shift pattern 

28. Repeat the above procedure for the following staff: 

 CRM Mrs Carol Van Allen 

 CRM Mrs Wendy Harrow 
 

29. Select the “Sort” option at the bottom of the “Teams” section. 

 
Ready to close the Team Manager and update the Schedule View area. 

30. Click OK to close the Team Manager and update the Schedule View area. 
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The updated schedule displaying staff allocated to their respective shift patterns. 

31. Highlight the first Monday day column in the Schedule View area and from 
the menu toolbar select Data > Sort by > Start time. 

 Alternatively you can simply click on any staff day cell in a column to sort content for the day. 

 
The Schedule View area sorted by start time collates all the times at the top of the Schedule View area. 

32. Close the Schedule View area and when prompted save with the filename 
“My Business Center”. 
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Displaying Shift Pattern allocations 

 Exercise 4.4 
Displaying and sorting information in the Schedule View area. 

This exercise continues from the previous exercise and shows how to change views 
of underlying information when working with shift patterns in the Schedule View 
area. It is assumed Schedule24 Resource Manager has been launched and you have 
“My Business Center” schedule displayed in the schedule View area. 

 

1. From the toolbar menu select View > Shift Pattern Name to display the 
allocated shift patterns. 

 
The Schedule View area displaying information about staff allocations to their respective shift patterns. 

 This view is useful when moving staff from one shift pattern to another, or to another team 
within the same shift pattern. You wouldn’t normally change staff allocations for a few days or 
shift swaps and manage direct updates with the Shift Editor. Where changes are for longer or a 
more permanent nature then the Team Manager may be appropriate to make those kinds of 
changes. 

Sorting Shift Patterns and Teams 

2. From the toolbar menu select Data > Advanced Sort... to display the 
advanced sort dialog. 
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The Advanced sorting dialog enables hierarchical sorting options 

3. Sort by “Start time” with “Ascending” option selected; and Then by “Shift 
Pattern” with “Ascending” option and Click OK to close the dialog and 
update the Schedule View area with the sort selection. 

 Having the “Shift Pattern Name” view displayed is not that helpful for sorting the Schedule View 
area. You can change the view to shift times and still monitor shift pattern and team allocation as 
follows. 

4. From the toolbar menu select View > Shift Pattern Name to toggle the 
display off and return to the shift time format. 

5. From the toolbar menu select View > Teams to display team information 
column. Displaying shift times or shift descriptions 

 
The Schedule View area displaying shift time information and staff team allocation. 

6. From the toolbar menu select View > Shift Description to display shift 
descriptions. 
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The Schedule View area displaying shift descriptions and staff team allocation. 

7. Close the Schedule View area and save with the same file name when 
prompted. 

 Exercise 4.5 
Adding more shift patterns to complete the staff schedule 

This exercise completes the allocation of staff to shift patterns and explores the 
Advanced Sorting feature further. It is assumed you have launched Schedule24 
Resource Manager and have “My Business Center” schedule open in the Schedule 
View area and the shift time view displayed. 

1. From the “Automate with Shift Patterns” section of the Navigation Pane 
select “Distribute Staff to Teams” to display the Team Manager. 

2. Click the “Insert Shift Pattern...” button from the Team Manager to display 
the Insert Shift Pattern dialog 

 
Inserting a shift pattern from within the Team Manager 
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3. From the list select the “Part Time Agents” shift pattern and in the Start 
Date calendar field select the Monday date displayed in the first column of 
the Schedule View area 

 This shift pattern has been designed for “Job Sharing” roles. In this case staff work part time 
either in the morning or late evening. There is no rotation and have the same days off at the 
week end. It is a week based shift pattern.  

4. Click the “Insert” button to close the dialog and associate the shift pattern 
“Part Time Agents” with the schedule. 

 
Selecting the final and most complex shift pattern. 

5. Repeat the procedure to display the “Insert Shift Pattern” dialog and 
highlight the “Full Time Agents” shift pattern; and select the Monday date 
as previously. 

 This is a complex shift pattern involving several shifts and rotating shifts and days off to provide 
a 24/7 staff supply. It has a 63 day rotation cycle which makes it a week based shift pattern 

6. Click “Insert” button to close the dialog and associate the shift pattern 
“Full Time agents” with the schedule. 

 
The four shift patterns associated with this schedule. 
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7. Within the Team Manager select the “Part Time Agents...” shift pattern 
from the drop down list to display the two Team groups for this schedule. 

8. Using the mouse pointer click the “Name” header of available staff to sort 
and group the PT Agents together. 

9. Using the Shft key and mouse button select and highlight the following PT 
staff; and drag and drop into the “Day Team” group. 

 PT Agent Mrs Marlene Phillips 

 PT Agent Mrs Jackie Long 

 PT Agent Mr Stephen Owen 
 

10. Repeat the procedure for the three remaining PT staff and drag and drop 
into the “Evening Team” group. 

 Make sure the Sort option is selected in the “Teams” section of the Team Manager. 

11. Using the mouse pointer select the “FT Agents” shift pattern in the drop 
down list to display the team groups in the Team section. 

 Note that staff already allocated to shift patterns are added to the “Staff scheduled to other 
teams” list pane (or window section). 

 

As staff are allocated to shift patterns the number of staff available reduces. 

 Because the last group simply need to be distributed equally as far as we possibly can we use 
the “Auto-Distribute Staff to Teams” button. 

12. Click the “Auto-Distribute...” button. 
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The completed staff distribution across 4 different shift patterns. 

13. Click OK to close the Team manager and update the Schedule View area. 

 
The updated Schedule View area displaying the “Shift Pattern Name” view. 

14. Save the schedule with the same filename and close. 
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 Exercise 4.6 
More advanced sorting and ranking of Schedule View information 

This exercise looks at more advanced techniques for sorting and ordering 
information in the schedule. It is assumed you have launched Schedule24 
Resource Manager, and you have “My Business Center” schedule open in the 
Schedule View area. 

1. From the toolbar menu select View > Shift Pattern Name to toggle the 
shift time display view. 

2. From the toolbar menu select Tools > Options > Color tab and check the 
“Show” checkbox to enable shift color mapping. 

 Tip: Displaying shift color will make it easier to visually group the same shifts while changing 
views in the Schedule View area. 

 
Schedule displayed with color mapping on, and first day sorted by start time. 

Sorting by Shift Pattern Order 

3. Using the mouse pointer select a staff day cell in the first Monday day 
column. 

 Before opening the Team Manager it is good practice to highlight a staff day cell on the date 
you have an interest, this ensures when the Team Manager opens it is displaying the staff 
distribution on the selected date. 
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4. From the toolbar menu Click the Team Manager button to display the Team 
Manager. 

5. From within Team Manager click the “Modify list...” to display the “Modify 
Shift Pattern List” dialog. 

6. Highlight the shift patterns in turn and using the “Up & Down” arrows 
order the shift patterns displayed in the following screenshot. 

 
Ordering the shift patterns in the Team Manager. 

7. Click OK to close the dialog and OK again to close the Team Manager. 

8. From the toolbar menu select Data > Advanced Sort... to display the 
Advanced sort dialog. 

 
The Advanced Sort dialog displaying the order options 

9. Selecting from the drop down lists Sort by “Shift Patterns” with 
“Ascending” option and the “Order” option checked. 
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10. Click OK to close the dialog and update the Schedule View area. 

 The Shift Pattern will be sorted and ranked in the order saved in the Team Manager. If the 
“Order” option is not checked in the advanced sort settings then the display will be sorted 
alphabetically and the order will be ignored. Similarly if the descending and order options are 
selected the order would be maintained but in reverse order. Without the order constraint the 
descending option would sort alphabetically in reverse. 

Ranking Staff in Their Respective Teams 

11. Repeat the above procedure to open and display the Team Manager and 
select the “Meet & Greet” shift pattern from the “Shift Patterns used in 
this schedule” drop down list. 

12. Select the “Order” option to display the ranking arrows at the side of team 
group list boxes, and using the controls arrange the staff in the ranked 
order displayed in the following screenshot. 

 
Ordering staff in their respective teams using the ranking arrows 

13. Click OK to save the changes and close the Team Manager to return to the 
Schedule View area. 

14. From the toolbar menu Data > Advanced Sort... to display the Advanced 
sort dialog and select the options displayed in the following screenshot. 
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Options to display staff according to their team ranking 

15. Click OK to close the dialog and update the schedule. 

 
Staff ordered in the schedule view according to their Team Manager rankings. 

 If the “Order” option is unchecked for Teams then the alphabetical sorting of the team name 
has precedence. In this example “Day Team” comes before “Evening Team” and the staff 
ordering with no further sort constraint appears random. Add a “Sort by” Last name constraint 
and this group will be ordered by last name. 

Sort Staff by Department 

 Using the advantage of imported data we can explore further examples of sorting and ordering. 

16. From the toolbar menu select View > Department to display department 
information. 

17. From the toolbar menu select Data > Advanced Sort...to display the 
advanced sort dialog and select the options displayed in the following 
screenshot. 

 
Options for sorting by Department alphabetically 

18. Click OK to close the dialog and update the schedule display. 

 The departments will be sorted in ascending alphabetical order. 
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Ranking Department Order 

 While alphabetical sorting is useful sometimes Departments need to be ranked in non 
alphabetical order to reflect importance or most common reference. 

19. From the toolbar menu select Staff Manager to display the Staff Manager 
dialog and select the Service tab. 

20. Click the “Order” button next to the Department text box to display the 
“order by Department” dialog. Highlight one of the departments in the list 
and using the “Up & Down” arrows order the departments as displayed in 
the following screenshot. 

 
Ranking Departments 

21. Click OK to close the dialog, and Save and Close the Staff Manager to 
return to the Schedule View area. 

22. Open the “Advanced Sort...” dialog and select the options as displayed in 
the following screenshot. 

 
Checking the “Order” option to apply Department ranking 

23. Click OK to close the dialog and update the Schedule View area 
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Department sorted according to ranking order in the Service tab of the Staff Manager. 

 Departments are now sorted in a ranked order independent from alphabetical sorting.  

 Tip: When using sort functions it is useful to enable the “Group” view in Tools > Options > View 
tab. This displays the main sort selection in a ledger style so you can see where a group starts and 
finishes. 

 
The ledger style view makes it easier to see where groups start and finish 

Ranking Job Title 

 Similarly Job title can be ranked in non alphabetical order to reflect importance or most 
common reference. 
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24. From the toolbar menu select Staff Manager to display the Staff Manager 
dialog and select the Service tab. 

 Click the “Order” button next to the “Job title” text box to display the “order by Job Title” dialog. 
Highlight one of the job titles in the list and using the “Up & Down” arrows order the 
departments as displayed in the following screenshot. Make sure the “Enable order by Job 
Title” checkbox is checked to enable the order controls. 

 
Ranking Job Title using “Up & Down” buttons 

25. Click OK to close the dialog, and Click Save and Close to close the Staff 
Manager and return to the Schedule View area. 

26. Open the Advanced sort... dialog and select the options displayed in the 
following screenshot. 

 
Option settings to rank Job title in the Schedule View 

27. Click OK to close the dialog to update the schedule and return to the 
Schedule View area. 
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Job Title sorted according to ranking order in the Service tab of the Staff Manager. 

 

Multiple or hierarchical sorting and ranking 

 There are around 352 combinations of sorting and ranking schedule content using the 
Advanced Sort... feature. In practice you will probably have two or three you will use regularly 
but these may involve more than one category in your sort of choice options.   

28. Open the Advanced sort... dialog and select the options displayed in the 
following screenshot. 

 
Option settings to sort and rank more than one category. 

29. Click OK to close the dialog to update the schedule and return to the 

Schedule View area. 
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Content sorted by Job Title ranking and Team rankings 

 With the additional sorting option on Team order, the Job Title ranking remain the same, and 
the staff with the same Job Title are displayed according to their order position in the Team 
Manager. 

Using ‘Quicksort’ Sort by... 

30. Using the mouse pointer highlight the first day “Monday” column of the 
schedule. 

 Tip: You can also just select any staff day cell in the day column to apply the sort selection. 

31. From the toolbar menu select Data > Sort by > Start time to sort shift 
times on this day by their start times. 

 
Using ‘Quicksort’ to arrange content by start of shift times. 
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 Note the group view changes to start shift time groupings, and the shift times are sorted by 
start time. Theoretically the shift start times are only ordered on the day selected – in this 
example the first day ‘Monday’. The appearance the sort is applied to the other days is illusory 
and the effect of the underlying shift pattern. For example ‘Richard Allen’ shift is not in shift start 
time order on ‘Wednesday’.  If you repeat the above procedure for Wednesday the sort would 
then be applied for ‘Wednesday’ and the change would be significant. 

32.  Close the schedule and if prompted save with the same filename “My Business Centre” 

 
Schedule24 Resource Manager Schedule View area after closing a schedule. 
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Section 5 – Shift Pattern Design 
Understanding and identifying the business requirement is 
crucial for defining an appropriate shift pattern which will be 
the basis of any successful staff deployment strategy. If the 
business requirement is clearly understood then it is likely a 
good shift pattern will follow. 

After completing this section you will be able to do the following: 

1. Understand and work with the Shift Pattern Designer. 

2. Create rotating and fixed shift patterns. 

3. Work with combinations of shift patterns to automate a complex schedule. 

4. Understand and work with the Team Manager 

 Examples of shift patterns used in this section are designed to help you understand the 
product features used in shift pattern design and creating staff schedules. It is not intended to 
provide in-depth instruction about shift pattern theory and recommendation for a particular 
business. For further details about shift patterns and adoption of specific shift pattern solutions 
please contact www.intellicate.com.  

Defining a scheduling strategy 
Schedule24 Resource Manager support both structured and unstructured 
scheduling styles. 

Structured Scheduling  

A good example of structured scheduling would involve well-defined shifts 
and day-off pattern, worked in a particular order. It would enable staff to 
know, months or a year or more in advance, what shift they will be working 
on which day and when they will have a day off. 

Unstructured Scheduling 

Unstructured scheduling is the opposite of structured scheduling. An example 
of unstructured scheduling would involve ill-defined shifts, worked in no 
particular order. Unstructured scheduling may be the only approach if the 

Section 

5 

http://www.intellicate.com/
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manager has no control over staff and effectively schedules the business 
requirement to fit around staff availability.  

 Structured scheduling will involve the Shift Pattern Designer and Team Manager, whereas 
unstructured scheduling styles do not. 

 You have already been introduced to the shift patterns examples used in this section when you 
added and allocated staff, using the Team Manager, to create a schedule in Section 4. The 
Team Manager is used to manage the various shift patterns and staff allocations. This section 
will take you through step by step how each shift pattern was designed using the Shift Pattern 
Designer. 

 



 

 



 

 

Defining a Business Requirement 
It is important to have a clear understanding or goal about the business 
requirement before designing a shift pattern. Some useful questions include: 

 Does the daily business requirement or service delivery require staff to 
work extended hours or 24 hour working? 

 Do staff need to work fixed or rotating shifts, or even a combination of 
both? 

 Do staff have the same day-off e.g. at weekends, or are days-off 
staggered on different days of the week? 

 Do staff work full-time or part-time or a combination of both? 

 What is the maximum working hour’s staff work in a day or week? 

 What are the average working hours staff work a day or a week? 

 Do staff have different working arrangements involving different kinds 
of schedules. 

 Is the current scheduling well-defined and structured, or ill-defined and 
changes regularly depending on staff availability? 

 In straightforward terms when a business is running beyond a “normal day” e.g. traditional 
office hour, requiring a staff supply over extended or 24 hour working hours, a rotating shift 
pattern is required. 

The exercises in this section use an example of a business operation that is 
required to deploy 25 full-time staff over 24 hours 7 day week. In addition the 
business wants fewer staff on weekday evenings and at weekends. 
 
There are four groups each having their own working arrangements: 

 The Management Team work traditional office hours. 

 The Meet and Greet Teams work an alternating two shift system. 

 The FT Agents work a 24/7 shift system. 

 The Part-time agents work an Early-Late to facilitate job share. 

A fixed shift pattern 

The working schedule for the Management Team is not complicated. In fact it 
is based on traditional office hours and about as simple as it can get. The 
characteristics of the working arrangements (or rules) are as follows: 
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 The daily hours of work are 8.30am to 5:30pm 

 They work Monday to Friday; and  

 Have every weekend off. 

 A fixed shift pattern is when staff works the same shift, and have the same days off on the 
same days of the week. There is no variation from week to week. 

 Exercise 5.1 
Designing a simple fixed shift pattern. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
Navigation Pane is displayed and you do not have any schedules displayed in the 
Schedule View area. 

1. From the Menu Toolbar click the Shift Pattern Designer icon. This will 
display the Shift Pattern Designer in the Schedule View area. 

  
The Shift Pattern Designer 

 The Schedule Designer displays a default week starting on Monday and four rows or teams. 
This default can be modified depending on the kind of schedule you want to design. 

2. Using the mouse pointer click on the Team 2 row and drag the mouse 
down to highlight Team 3 and Team 4. 
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Highlighting the Team rows in the Shift Pattern Designer 

3. From the Menu select Edit > Remove > Teams. Alternatively click the 
“Remove Teams” button in the Shift Pattern Designer toolbar menu. 

 

 
Removing team rows to modify the layout of the design. 

 Note that the shift editing controls are disabled when an active row does not have focus. 

4. From the Menu Toolbar select the Teams  button. This will display the 
Schedule Teams dialog. 
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Displaying the Schedule Teams dialog to edit the Team description 

5. Using the mouse pointer click in the “Team name” text box to enable the 
edit cursor and enter “Week 1” without the quote marks. 

6. Click the “Add” button to add this to the team list. 

7. Highlight the description “Team 1” and click the “Remove” button to 
remove it from the team list. 

 Alternatively using the mouse pointer select and highlight “Team 1” in the display list. Click a 
second time to enable the edit cursor and enter “Week 1”. 

8. Click OK to close the dialog and update the Schedule. 

 
Changing the row name to “Week 1” 
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 It is easier to think about this simple design for one week because this working 
arrangement is the same and repeats for each week.  

 

 
Highlighting days cells in the Shift Pattern Designer 

9. Using the mouse pointer highlight the Sat and Sun and select the Day-off 

button. Click the Check or Enter   button to enter days-off at 
weekends. 

 
Entering “Day Off” into the shift patter design. 

10. Using the mouse pointer select and highlight the days Monday to Friday for 
this week. 

11. Enter “8:30a5:30p” in the Shifts box. Click the Check or Enter   
button to enter this shift into the highlighted days for this week. 
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Adding shifts to the shift pattern design 

12. Click the Add Shift Descriptions  button. This will display the Shift 
Descriptions dialog. 

  
Adding a shift description 

13. Using the mouse pointer double-click the Description cell next to the Shift 
time. This will display the text editing tool. Enter “Office” and click off the 
record to commit the changes to the database. Click OK. To close the 
dialog and return to the shift pattern design. 
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Displaying the shift description view 

 You can now toggle views between time format and times descriptions using View > Shift 
Description. Shift pattern descriptions are inherited by any schedule using this shift pattern. 
Color settings are defined in Tools > Options … and depending on those settings may differ 
to those illustrated here. 

14. Adjust the Standard hours in the Daily Hours section to 09:00 hours. This is 
the duration of the daily standard hours entered into the design. 

 This is an aid when designing shift patterns to see when a shift being entered conforms to the 
standard daily hours of the shift pattern. If the hours are different it will indicate “overtime” or 
“time off” depending whether the hours being entered are over or under the standard hours. 

15. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. Edit the entry “Week 1” to “Management Team”. 

 The Team labelling in a schedule design is displayed throughout the application e.g. Team 
Manager and schedule views. When the design is complete they can be modified to display 
more meaningful descriptions making it easier to identify changes and navigate between 
different shift patterns. 

 Tip: Think about your team descriptions and keep them short and to the point. Descriptions 
that are too long may effect layouts when printing and publishing. 

16. From the Menu select Tools > Options …. This will display the Options 
dialog. Select the Calculation tab. 
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Setting the calculation to display the shift pattern working hours 

17. In the Calculate over box enter “7” days, and in display calculation for 
box enter “7” days and click OK. This will close the Options dialog and 
update the working hours display in the Schedule Designer. 

 This will show the design hours worked each week which in this example is 45 hours. 

 
The completed shift pattern displaying shift time format 

18. From the Menu select File > Save to display the Save dialog. Enter a 
filename and for the purpose of this tutorial enter “Management Team”. 
Click OK to Save and close the Schedule Designer. 

 If you save with the shift description displayed that will be the display used in any previews. 
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Alternating double day shift pattern 

The characteristics of the schedule design are a little more complicated than 
for the Management Team. The characteristics of the working arrangements 
(or rules) are as follows: 

 Two shifts: 8am:-4:00pm and 2:00pm-10:00pm 

 Alternating each week 

 Staff work Monday to Friday; and  

 Have every weekend off. 

 A double day shift delivers a staff supply over 16 hours of the day. It is sometimes referred to 
as a rotating shift pattern but technically two shifts alternate each week. 

 Exercise 5.2 
Designing an alternating double day shift pattern. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
Navigation Pane is displayed and you do not have any schedules displayed in the 
Schedule View area. 

 When you saved the last exercise you may have been prompted by the properties dialog. If 
you do not want this prompt it can be turned off in Tools > Options > General tab and in the 
“Settings” section uncheck “Prompt for shift pattern properties”. 

1. From the Menu Toolbar click the Shift Pattern Designer icon. This will 
display the Shift Pattern Designer. 

2. Using the mouse pointer click on the Team 3 row and drag the mouse down 
to highlight Team 4.  
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Highlighting to remove teams and start this design for alternating shifts. 

3. From the Menu select Edit > Remove > Teams or alternatively click 
“Remove Teams” button in the menu toolbar. 

 
The shift pattern with two rows removed ready for the next step for setting up this design. 

4. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. 

 
Changing the row descriptions to aid shift pattern design. 

5. Using the mouse pointer click in the “Team name” text box to enable the 
edit cursor and enter “Week 1” and “Week 2” without the quote marks in 
turn and click the “Add” button to add them to the list. 

6. Select the two team items in turn and click the “Remove” button to 
remove them from the list. 
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 Alternatively you can click the team items in the list in turn and edit the field when the text 
cursor appears. 

7. Click OK to close the dialog and return to the shift pattern design 
environment. 

 
The modified row description for a two weekly alternating shift pattern. 

 
Adding days off to the design 

8. Using the mouse pointer highlight the Sat and Sun and select the Day-off 

button. Click the Check or Enter   button to enter days-off at 
weekends. 

9. Using the mouse pointer select and highlight the days Monday to Friday for 
Week 1. 

Schedule24 Professional – Creating scheduling designs 
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Highlighting day fields in the design to enter shifts 

10. Enter “8:00a4:00p” in the Shifts text box. Click the Check or Enter   
button to enter this shift into the highlighted days for this week. 

 Tip: You can use 8a4p as a shortcut to shift entry, the formatting will be added when you click 
enter. 

11. Repeat the above steps to enter “2:00p-10:00p” for Week 2. 

 
The two alternating shifts entered into the shift pattern design. Shift color is turned on in this example. 

12. Click the Add Shift Descriptions  button. This will display the Shift 
Descriptions dialog. 

 If this button is disabled click on a day cell in the shift pattern to enable it. 
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Adding shift descriptions to the shift times. 

13. Using the mouse pointer double-click the Description cell next to the Shift 
time. This will display the text editing tool. Enter “Day” and “Evening” 
respectively click off the record to commit the changes to the database. 
Click OK to close the dialog and return to the shift pattern design view. 

 

 
Updating the shift pattern design with shift description color turned on. 

 You can now toggle views between time format and times descriptions using View > Shift 
Description. Shift pattern descriptions are inherited by any schedule using this shift pattern. 
Color settings are defined in Tools > Options > Color tab and depending on those settings 
may differ to those illustrated here. 

14. Click the Rotate Teams   button to complete the rotation for this 
design. 
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The shift pattern is rotated to complete the design and ready to be used. 

 This is also referred to as the “Managers View”. It is the complete shift pattern. This can be 
contrasted with the “Individual View” before using the rotation feature. A person views their shift 
pattern in following weeks. It now requires the team labelling to be changed to something more 
meaningful as follows. 

15. Save the Shift Pattern with the filename “Meet and Greet” and do not 
close. 

16. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. Edit the entry “Week 1” to “A Team” and the entry “Week 
2” to “B Team”. 

 You must edit the “Week” descriptions by clicking directly on each entry. Do not enter the team 
descriptions using the Team name text field and adding to the list. If you do, and then remove 
“Week 1” and “Week 2” it will also remove the shift pattern shifts which are now associated with 
those rows.  

  
Renaming the team descriptions 

17. Click OK to close the dialog and update the schedule design. 
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The completed shift pattern design in “Management View” ready for use in a schedule. 

 Remember you can use the filename of the shift pattern design and the teams’ description to 
represent an additional ‘level’ in your business organization if needed. 

18. From the Menu select Tools > Options …. This will display the Options 
dialog. Select the Calculation tab. 

  
Adjusting the hour’s calculation to display the average weekly hours of a 14 day shift cycle or rotation. 

19. In the Calculate over box enter “14” days, and in display calculation for 
box enter “7” days and click OK. This will close the Options dialog and 
update the working hours display in the Shift Pattern Designer. 

20. From the Menu select File > Save. Alternatively click the Toolbar menu 
Save icon. Close the Shift Pattern Designer. 
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24/7 Rotating Shift Pattern 

The characteristics of this shift pattern are more complicated due to the 
working arrangements (or rules) as follows: 

 Seven rotating shifts: 7:00a-3:30p; 8:00a-4:00p; 9:00a-5:00p; 12:00p-
8:00p; 12:30p-8:30p; 8:00p-7:30a; and 8:00p-8:00a. 

 Rotating days off; 

 Variable staff supply increasing toward the middle of the day and 
reducing toward the evening and during the night; 

 Reduced staff supply at weekends. 

 Rotating teams are more complex due to the requirement for days-off to be rotating in addition 
to shifts deploying staff 24/7. While not a requirement good shift pattern design would try to 
ensure best practice for a forward (DOR) pattern and sufficient daily rest periods between shifts 
and adequate weekly rest periods. 

 Exercise 5.3 
Designing a 24/7 shift pattern delivering a variable staff supply. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
Navigation Pane is displayed and you do not have any schedules displayed in the 
Schedule View area. 

1. From the Menu Toolbar click the Schedule Design icon. This will display 
the Schedule Designer. 

 
The Shift Pattern Design environment default display 

 The Shift Pattern Designer default display requires modifying for this design. 
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2. Using the mouse pointer click on the Team 1 row and drag the mouse 
down to highlight Team 4. 

 
Highlighting the team rows using the mouse pointer. 

3. From the Menu select click the Remove Teams button. This will clear the 
design environment of all the Teams. 

 
The team rows removed. 

4. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. Enter the following into the Team name and add to the 
display list. 
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Entering teams into the Team list dialog 

 Tip: Copy the description and paste into the Team name text box to modify the letter and hit 
the “Enter” key to add to the list for a faster data entry. 

5. Click OK to close the dialog and update the Schedule Design. 

 Keep the View > Hours Summary column displayed to see the weekly working hours total as 
a guide during design.  

 
The team descriptions updated and displayed in the Shift Pattern Design environment. 

 This design requires seven shifts to be worked each day except at weekends. Rotating days-
off throughout the week is also a requirement. This means at least 9 rows will be required to 
structure a shift pattern to meet those requirements. 

6. Using the Shift editing tools enter the working pattern of shifts and days-
off displayed below into the schedule design. 
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Entering shifts into the shift pattern design. 

7. Use your color preference settings in Tools > Options … > Color tab to display color. You 
can use Copy Cut & Paste to enter information between row and column cells as an 
alternative to entering information into the Shift Editor text box.Click the Add Shift 

Descriptions   button. This will display the Shift Descriptions dialog. 
Enter the shift description as below: 

 
The Shift Description dialog box displaying the description list. 

8. Click OK to close the dialog. 
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Toggling the shift time and descriptions view. 

 You can toggle views between time format and times descriptions using View > Shift 
Description in the Shift Pattern Designer toolbar menu. 

 
The basic shift pattern rules are implicit in the pattern created. 

 This is the basic pattern or “rules” for the daily working arrangements of FT Agents each week. 
At this stage if you were to save this shift pattern it would in effect be a fixed schedule i.e. each 
team would have the same days-off and shifts on the same day each repeating week. The 
rotation feature completes the shift pattern and ensures the ‘pros and cons’ of the shift pattern 
is shared equally amongst everyone. 

9. From the Toolbar menu click the Rotate Teams  button to complete 
the shift pattern. 

 You only click the Rotate Teams feature once to complete the rotations cycle. 
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The rotation feature completes the shift pattern design. 

 For illustration purposes the schedule design has been scrolled to the end of the rotation cycle. 
Remember a schedule design is independent of calendar dates until it is inserted into a 
Schedule. This design has a rotation cycle of [9] weeks (the number in square brackets) or 63 
days (the number next to the day of the week e.g. [9] 59, Wed means the 9th Wednesday or 
59th day in the completed shift pattern design. 

10. From the Shift pattern Designer Menu select Tools > Options …. This will 
display the Options dialog. Select the Calculation tab. 

 
Setting the hours calculation for the Shift Pattern designer. 

11. In the Calculate over box enter “63” days, and in display calculation for 
box enter “7” days and click OK. This will close the Options dialog and 
update the working hours display in the Schedule Designer. 
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Displaying the average weekly hours over the shift pattern cycle. 

 This will show the design hours as a weekly average for the rotation cycle which in this 
example is 35 hours a week.  Including or excluding break times for working hour’s calculations 
is an option available in the Schedule View area where breaks are scheduled. Breaks are not 
scheduled in the Shift Pattern Designer. 

12. Save the shift pattern with a suitable filename and for the purposes of this 
tutorial enter “Full Time Agents” in the save dialog. Click OK to close the 
save dialog. 

13. Exit the Schedule Designer. 

Early and Late Part-time Shift Pattern 

Job share is where two part-time staff working less than a 30 hour week share 
a full time job role. The characteristics of the working arrangements (or rules) 
are as follows: 

 Two shifts: 09:30am-2:30p; and 6:00p-10:00p 

 Hours fixed each week 

 Staff work either Monday to Thursday or a Friday; and  

 Have every weekend off. 

 This arrangement delivers a 40 hour week by two staff members working 20 hours a week 
each. 
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 Exercise 5.4 
Designing a Part-time shift pattern. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
Navigation Pane is displayed and you do not have any schedules displayed in the 
Schedule View area. 

1. From the Menu Toolbar click the Schedule Design icon. This will display 
the Schedule Designer. 

 
The Shift Pattern Design environment default display 

 The Shift Pattern Designer default display requires modifying for this design. 

2. Using the mouse pointer click on the Team 1 row and drag the mouse 
down to highlight Team 4. 

 
Highlighting the team rows using the mouse pointer. 
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3. From the Menu select click the Remove Teams button. This will clear the 
design environment of all the Teams. 

 
The team rows removed. 

4. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. Enter the following into the Team name and add to the 
display list. 

 
Changing the team descriptions in the Teams dialog. 

5. Click OK to close the dialog and update the Schedule Design. 

 Keep the View > Hours Summary column displayed to see the weekly working hours total as 
a guide during design.  
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The team descriptions updated and displayed in the Shift Pattern Design environment. 

6. Using the Shift editing tools enter the working pattern of shifts and days-
off displayed below into the schedule design. 

 
Entering two part time shifts into the shift pattern design. 

 Use your color preference settings in Tools > Options … > Color tab to display color. You can 
use Copy Cut & Paste to enter information between row and column cells as an alternative to 

entering information into the Shift Editor text box.Click the Add Shift Descriptions   
button. This will display the Shift Descriptions dialog. Enter the shift description as below: 
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The Shift Description dialog box displaying the description list. 

7. Click OK to close the dialog. 

 
Toggling the shift time and descriptions view. 

 You can toggle views between time format and times descriptions using View > Shift 
Description in the Shift Pattern Designer toolbar menu. 

 We do not use the Rotation feature for this pattern, do you know why? 

 We do not use the Rotation feature because the shift pattern is fixed and staff do not rotate 
onto the other shift. They work the same shift on the same days each week. The shift pattern 
cycle is one week and then repeats. 

8. From the Shift pattern Designer Menu select Tools > Options …. This will 
display the Options dialog. Select the Calculation tab. 
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Setting the hours calculation for the Shift Pattern designer. 

9. In the Calculate over box enter “7” days, and in display calculation for 
box enter “7” days and click OK. This will close the Options dialog and 
update the working hours display in the Schedule Designer. 

 
Displaying the total weekly hours 

 This will show the design hours as a weekly average for the rotation cycle which in this 
example is 20 hours a week.  Including or excluding break times for working hour’s calculations 
is an option available in the Schedule View area where breaks are scheduled. Breaks are not 
scheduled in the Shift Pattern Designer. 

10. Save the shift pattern with a suitable filename and for the purposes of this 
tutorial enter “Part Time Agents” in the save dialog. Click OK to close the 
save dialog. 

11. Exit the Schedule Designer. 
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 You have already inserted these shift pattern designs into a schedule and allocated staff to 
them. The exercises you have completed serve as an introduction to shift pattern design which 
is a study in its own right and a subject that cannot be exhaustively covered here. Check out 
the Knowledge Base for more resources about shift pattern designs. 

 Exercise 5.5 
Split shift working. 

This exercise has been included to provide an introduction to split shift working. It 
is not as common as it once was, but is gaining popularity where it advances 
flexible working and enables staff to break full time hours across the working day 
e.g. morning and evening. 
 
This exercise assumes you have launched Schedule24 Resource Manager, the 
Navigation Pane is displayed and you do not have any schedules displayed in the 
Schedule View area. 

 The schedule design is similar to the “Part time Agents” earlier. The characteristics of these 
working arrangements (or rules) are as follows: 

 One split shift: 1st tour is 9:30a:-2:30pm; and 2nd tour is 6:00pm-
9:00pm. 

 The schedule repeats each week. 

 Work days are Monday to Friday. 

 Weekends off. 

1. From the Menu Toolbar click the Schedule Design icon. This will display 
the Schedule Designer. 

 
The default display of the Shift Pattern Designer. 
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 The Schedule Designer default display requires modifying for this design. 

2. Using the mouse pointer click on the Team 2 row and drag the mouse 
down to highlight Team 4.  

 
Highlighting the teams rows to delete. 

1. From the Menu select Remove Teams button, alternatively Edit > Delete > 
Teams. 

 
The unwanted team rows deleted. 

2. From the Menu Toolbar select the Teams  button. This will display the 
Teams dialog. 
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Modifying the team description to “Split shifts” 

3. Using the mouse pointer select and highlight “Team 1” in the display list. 
Click a second time and enter “”Split shifts””. Click OK to close the dialog 
and update the Shift Pattern design. 

 

 
The shift pattern updated with the “Split shifts” description 

4. Using the mouse pointer select and highlight the days Monday to Friday . 

5. Enter “9:30a-2:30p, 6:00p-9:00p” in the Shifts text box. Click the Check or 

Enter   button to enter this shift into the highlighted days. 

 The comma creates the “split” between the two halves of the shift. Alternatively you can use 
the Splits by entering “2” and then adjust the time bar or editing the text in the Shifts text box. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

148 

 
Displaying the split shift format in the Shift Pattern 

6. Click the Add Shift Descriptions   button. This will display the Shift 
Descriptions dialog. 

 
Entering the description for a split shift 

7. Using the mouse pointer double-click the Description cell next to the Shift 
time. This will display the text editing tool. Enter “Day Split”. Click off the 
record to commit the changes to the database. Click OK. To close the 
dialog. 
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Toggling the shift description view. 

 Remember you can toggle views between time format and times descriptions using View > 
Shift Description. 

 This is a fixed schedule with no rotation and the Rotate Teams   button is not used for 
this kind of design. 

8. Save the Schedule Design with a suitable filename or alternatively for the 
purposes of this tutorial enter “Split shifts” in the save dialog. Click OK to 
close the dialog. 

 
Saving the completed shift pattern 

9. Using the mouse pointer click on the “Split shifts” to highlight the row for 
this week. 
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Highlighting the row range of days to display the shift pattern design profile graph 

10. From the Toolbar menu click the Design Profile  button to display the 
Design Profile graph. 

 
Displaying characteristics of the “split shifts” shift pattern. 

 Comparing the shift pattern profiles of part-time staff ‘job sharing’ (earlier lesson) and the full-
time staff working ‘splits’ display similar characteristics in the design profile. The above 
identifies the same person working two work periods; and the one below identifies two people 
working one work period. 

 
Displaying characteristics of the” part time” shift pattern. 

11. Save the design and Exit the Schedule Designer. 
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Section 6 - Monitoring and Analysis 
Powerful tools enable analysis of scheduling activity. In 
addition to the Staff Count and the staff Distribution Profile, 
there is a comprehensive and automated conflict monitoring 
tool to check out your scheduling logic surrounding staff 
availability, working hours and rest periods. 

After completing this lesson you will be able to: 

1. Work with Staff Counts and Staff Distribution profiles to monitor and 
improve staff deployment patterns. 

2. Avoid breaches of working hours and rest period thresholds; 

3. Monitor working hours and evaluate staff costs, for successful business 
planning. 

Working With Staff Count Dashboard 

 During scheduling many changes may take place, which means you need to monitor how 
these changes impact on providing an adequate staff supply. Too many staff can be as bad as 
having too few.  Staff Count is a simple but effective dashboard display about headcount, staff 
hours and costs dynamically updated as you schedule your staff. 

 

 Exercise 6.1 
Re-visiting schedule options and settings. 

The first exercise steps will make sure your settings are configured correctly with 
the correct schedule for this series of exercises, and assumes you have Schedule24 
Resource open, with the navigation pane displayed and no schedule displayed in 
the Schedule View area. 

1. Open the Healthcare schedule example. 
 

 The Cover Count is displayed at the bottom of the schedule. It displays the total number of staff 
in the schedule. In this schedule there are a total of 25 staff. 

Section 

6 
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The Healthcare schedule example correctly configured 

 
2. Click Tools > Options > Tab to display the option settings, and adjust the 

options to be the same as this display: 
 

 
View options settings for Staff Count exercises. 

3. Without closing the Options dialog select the Color tab to display the color 
controls, and adjust the options to be the same as this display: 
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View Color settings for Staff Count. 

 The color preferences are not significant but the display options will reduce “clutter” at this point 
of the exercise. Note The “Cover count” non-color options have been selected to remove color 
display in the Staff Count. “Staff Count” and “Cover Count” mean the same thing. 

4. Close the Options dialog. 
 

5. Select Data > Advanced sort... to display the Advanced sort dialog and 
adjust the options to be the same as this display: 
 

 
Adjusting the options of the advanced sort feature. 

6. Click OK to close the dialog and update the Schedule View area. 
 
 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

154 

 Exercise 6.2 
Introducing and working with the Staff Cover Count. 

This exercise introduces the Staff Count and assumes you have Schedule24 
Resource open with no schedule displayed in the Schedule View area and the 
navigation pane displayed. 

1. Place the mouse pointer on the separation bar of the Cover Count display 
until the pointer turns into a double-headed arrow cursor. Click and 
holding the mouse button drag the bar down until the display is hidden 
from view and release. This will hide the Cover Count display. 
 

 
Selecting the Staff Count display herewith the mouse pointer to hide and unhide the display. 

 

2. To display the Cover Count place the mouse just beneath the vertical 
scroll bar. The mouse pointer will change to double-headed arrow. Click 
and holding the mouse button drag the bar up until the Cover Count is 
displayed and release. 
 

 The Cover Count bar can be moved upwards or downwards to adjust the amount of 
information you want to see displayed. 

3. Using the mouse pointer to point on the Staff Count area and right 
mouse click and select the “Customize” popup menu item to display 
the Staff Count dialog. 
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The Staff Count dialog with list highlighted to remove. 

4. Using the mouse pointer and the Shft key highlight the records in the 
Current View list. 

5. Click the >> button to remove the items in the list. 

 
Items removed from the Staff Count list. 

6. Click OK to close the dialog and update the Staff Count dashboard. 

 This action removes all data from the Staff Count display including the default staff count 
setting that is displayed when a schedule is opened. 

7. Repeating the above procedure open the Staff Count dialog, and select the 
options and choices displayed here: 

 
Selecting the list of items for display in the staff Count dashboard. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

156 

 You make your selection from the drop down list boxes in the Select Combinations” section 
and clicking the << button to move the selection to the “Current View” list. You repeat this for 
each entry. If you make a mistake highlight the item in the list and click the >> button to remove 
it from the list. The list is sorted descending on the “Shift” column. 

8. Click OK to close the Staff Count dialog and update the dashboard. 

9. From the toolbar menu select View > Shift Description to display shift 
descriptions. 

10. Repeat the procedure to open the Staff Count dialog and select the 
options in this display: 

 
Setting options while shift descriptions view displayed. 

 The drop down selection in the Staff Count List boxes is dependent on the current display 
option selected. You can mix selections for the dashboard display. One advantage of shift 
descriptions is they can group shift times that are similar and not significantly different e.g. 
“Late” and “Early”. The above display is sorted “descending” before clicking OK and updating 
the Staff Count Dashboard. 

11. Click the Shift column header until the sort indicator cue is pointing 
down and click OK to close the dialog and return to the Schedule View 
area. 
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Customizing the Staff Count Dashboard. 

 

 Exercise 6.3 
Working with Staff Count Combinations. 

The Staff Count can also be used to monitor working hour totals and staff costs on 
a daily basis; and any combinations of these groups. This exercise assumes you 
have Schedule24 Resource Manager and the schedule from the previous exercise 
open. 

 The interaction between staff headcounts, working hours and staff costs is complex. Especially 
when job title (skill sets) and variable cost rates are added to the “mix”. Staff Count enables 
simplistic “headcount” approaches to be avoided and presents the opportunity to manage more 
complex dependencies effectively. 

The following combinations for the Staff Count dashboard can be presented in 
the following table. 

 Description Count Hours Cost 

All Job titles    

All 
   

Working 
   

Non-working 
   

Shifts/Day-off 
   
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 Description Count Hours Cost 

Defined Job Titles    

All 
   

Working 
   

Non-working 
   

Shifts/Day-off 
   

All Teams    

All 
   

Working 
   

Non-working 
   

Shifts/Day-off 
   

Defined Teams    

All 
   

Working 
   

Non-working 
   

Shifts/Day-off 
   

 

1. Place the mouse pointer in the Staff Count area and click the right mouse 
button to display the pop-up menu and select Customize view to display the 
Staff Count dialog.  

2. Using the mouse pointer, Shft & Ctrl keys select all the records as displayed: 

 
Selecting records to be removed from the display list 

 Click the >> button to remove the selected records from the Staff Count display. 
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The selected records removed from the list 

 From the drop down lists add the following combinations: 

 
Selecting Staff Count combinations. 

 

 

Combinations displayed in the Staff Count dashboard 
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 In addition to the daily totals of the respective combinations, the summary total for each 
combination displayed is dependent on the calculations settings in Tools > Options > 
Calculations. In this example it is set to sum the totals over a period of a week, or seven 
rolling days when scrolling the schedule date ranges. You can also calculate average and 
projected totals for these combinations as described in the calculations tab of Options. 

 Currency symbols are dependent on the Regional settings in Control Panel. 

 

 Exercise 6.4 
Setting Staff Count thresholds. 

The Staff Count can also be used to monitor when thresholds are breached. This 
includes headcount, working hours or staff costs. This exercise assumes you have 
Schedule24 Resource Manager and the “Healthcare” schedule from the previous 
exercise open. 

 
1. From the Navigation bar Check how you’re doing section, select 

Customize colors to display the Options > Color tab dialog. Alternatively 
from the Menu you select Tools > Options > Color tab. 
 

  
Displaying the Options > Color tab to map color Staff Count thresholds. 

2. Click the color palette or picker next to the Over staffing: indicator and 
select a suitable color. 

3. Repeat the above step for Acceptable staffing: and Under staffing: 
indicators. 

4. Click OK to close the dialog and update the color display in the Cover 
Count display. 
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 The color cue displayed is not that meaningful given we have not set the thresholds in the Staff 
Count dialog. At the moment the color display is generated by the default settings. 

5. From the Navigation pane “Cover Count” section select “Categories and 
Ranges” to display the Staff Count dialog. 

6. Using the mouse pointer select each record displayed in the “Current 
View” list of the Staff Count dialog, and set the minimum and maximum 
thresholds for each entry and click the << button to update the threshold 
count. Do this for each in turn. 

 
Setting the thresholds for each of the combinations listed. 

 If you do not select the combination category when changing thresholds it will add the 
combination category and threshold as a new list item to be displayed. If you do this in error 
then just click the >> button to remove it from the list and repeat the procedure to change an 
existing items threshold. 

7. Click OK to close the Staff Count dialog and update the Staff Count 
dashboard. 

 
The Staff Count dashboard displays information about breaches in operational thresholds 
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Working with Staff Distribution Profiles. 

 The Staff Count is only one of the analytical tools available and is closely associated with the 
Staff Distribution Profile. Having the right numbers of staff delivered at the wrong time is a 
common failing often overlooked leading to a reactive response by increasing overtime or 
agency costs. 

 Exercise 6.5 
Working with Staff Distribution Profile. 

The Staff Distribution Profile displays a graph about how staff are distributed by 
sub-groups including department, job title and shift categories. This exercise 
assumes you have Schedule24 Resource Manager and the schedule from the 
previous exercise open. 

1. Open the Healthcare example schedule if it is not already open. 

2. From the toolbar menu select Data > Sort by > Job title to sort the 
Schedule View area. 

 A key feature of the Staff Distribution Profile is the ability to analyze how different sub-groups 
make up the total distribution of available staff. The current primary Sort by category is also 
the sub-group category displayed in the Staff Distribution Profile.  

2. Using the mouse pointer highlight a range of days from Monday to Sunday. 

 This range will be displayed in the Staff Distribution Profile. Selecting greater ranges over 
several weeks or months can be analysed in the Staff Distribution Profile using the scrolling 
controls and the Go To Date feature with Shft key and mouse control. 

  
Highlighting a range of dates for display in the staff Distribution Profile 
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3. From the Menu toolbar click the Staff Distribution Graph button, 
alternatively select Data > Distribution Graph or select Show Distribution 
Graph by Job Title from the Distribution Profile section of the Navigation 
Bar. This will display the Distribution Profile window. 

4. From the Timescale: dropdown list select 12 hour zoom and adjust the 
window size to display Monday to Sunday week days. 

 
Displaying the bar chart graph by Job title category  

 The Chart area displays several key pieces of information including a timeline, a red line graph 
of headcount, a stacked bar chart that displays how the different sub-groups (in this example 
Job title) make up the overall distribution. 

5. Uncheck the “Stacked bar chart” checkbox to reduce the bar chart and 
reveal the red line graph. Check the control to display the bar chart of sub-
group information. 

 
Displaying the red line graph of staff distribution over a week range. 

6. In the Sub group distribution pane, uncheck and check category 
checkboxes to reduce or increase information in the Profile view area. 
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 The view scale can be zoomed in to display 15 minute time intervals using the Timescale 
options. 

7. Close the Distribution Profile window. 

8. Using the mouse pointer highlight the week range as before if not already 
highlighted. 

9. Select Show Distribution Graph by Department from the Distribution 
Profile section of the Navigation Bar. This will display the Distribution 
Profile window. 

 Remember the category display is based on the primary “sort by” category; in this case we 
now want to see how staff are distributed by the respective departments. 

 
Displaying the bar chart graph by Department category. 

 Note that the staff distribution by headcount is identical to the previous graph displaying 
distribution by Job title. The only thing that changes is the sub category, and the bar chart is 
significantly different because it is measuring a different sub-group. The staff headcount 
distribution however is common to both (in fact all sub-groups do until the headcount changes). 
These are some of options for analysing distribution profiles: 

 Contribution of sub-group resources in the context of the overall 
distribution; 

 Compare sub-group resources in context of other sub-groups; 

 Identify which sub-group is involved in unsocial hours working; 

 Increasing or decreasing sub-group availability at specified times; 

 Identifying “too many”, “too few” or acceptable levels of staffing 
by sub-group. 

 
10.  Close the schedule and save if prompted. 
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Monitoring Staff Working Hours 

 Staff work hours is the universal measure for compensation; and the capacity to deliver goods 
or services. It underpins the basis of all business strategy given staff costs typically represent 
around 80% of business costs. They are also the only costs the business can control. However 
despite these factors, the latest research highlights around 50% of senior business managers 
and executives have little or no knowledge about the impact of staff costs on their business.  

 

 Exercise 6.6 
Working with staff working hours. 

Staff working hours are automatically calculated and displayed in a variety of 
ways including hours total for health & safety, pay role, or just to keep costs in 
check especially where unproductive overtime is concerned. This exercise 
assumes you have launched Schedule24 Resource Manager, the navigation pane 
displayed and no schedule is open in the Schedule View area. You will be using 
the “MySchedule” created in the “Getting Started” Section 2. 

1. Open the MySchedule. 

 
Displaying “Myschedule” in the schedule View area. 

2. Open Tools > Options > View tab and set the options as follows: 
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Displaying the View options for Myschedule. 

 

3. Click the Color tab and set the options as follows, although it does not have 
to be color specific. 

 
Displaying the Color options for Myschedule 

4. From the Menu toolbar select View > Hours to display the hour’s column in 
the Schedule. To hide the hours column repeat this procedure and uncheck 
the menu item. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

167 

 
Displaying the staff working hours in the schedule View area. 

 The hours calculation is set in the Tools > Options > Calculations tab. In this example we are 
calculating the hours worked over 7 days. All hours’ calculations start from the first day column 
displayed. If you have any other column displayed e.g. Department, uncheck View > 
Department. 

 

 Exercise 6.7 
Calculating exact work hours. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
navigation pane displayed and “MySchedule” is open in the Schedule View area. 

1. From the Menu select Tools > Options > Calculation to display the 
calculation settings for budget and working hours. Alternatively select 
Customize calculation from the View hours and budget section of the 
Navigation Bar. 

 
Setting the calculation to display exact totals 

2. In the Calculate over text box enter “7” days, and 

3. In the display calculation for text box enter “7” days 
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4. Uncheck the Include breaks in calculation checkbox 

 If you want to include break time in the working hour’s calculation check this checkbox. 

5. Click OK to close the dialog and update the working hour view in the 
schedule to display the exact hours worked by staff each week. 

 

 Exercise 6.8 
Calculate average staff working hours. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
navigation pane displayed and “MySchedule” is open in the Schedule View area. 

1. Select Customize calculation from the View hours and budget section of 
the Navigation Bar. This will display the Calculation options. 

 
Setting the calculation to display average totals 

2. In the Calculate over text box enter “28” days, and 

3. In the display calculation for text box enter “7” days 

4. Check the Include breaks in calculation checkbox 

5. Click OK to close the dialog and update the working hour view in the 
schedule to display the average hours worked by staff each week. Over a 
period of 28 days. 
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Displaying average hours over 28 days. 

 Exercise 6.9 
Calculate projected staff working hours. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
navigation pane displayed and “MySchedule” is open in the Schedule View area. 

1. Select Customize calculation from the View hours and budget section of 
the Navigation Bar. This will display the Calculation options. 

2. In the Calculate over text box enter “7” days, and 

3. In the display calculation for text box enter “28” days 

4. Check the Include breaks in calculation checkbox 

 
Setting the calculation to display projected totals. 
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5. Click OK to close the dialog and update the working hour view in the 
schedule to display the projected hours worked by staff over a period of 28 
days based on the hours worked in one week. 

 
Displaying projected hours over 28 days based on 7 days. 

 Note the Total Hours header change to indicate calculation period being applied.Monitoring 
Staff Availability 

 When staff are available to work is clearly important to longer term planning. With the increase 
in “flexible working”, and in some countries this entitlement is legislated e.g. EEC Member 
States, it is important to record staff working arrangements or “working time profile”. It might 
sometimes be referred to as “staff preferences”, but in most cases it is based on an agreement 
between the employer and employee and will often form part of a contract. For all other 
reasons it simply makes sense to include individual staff arrangements in schedule planning.  

 

 Exercise 6.10 
Working with Staff Availability settings. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
navigation pane displayed and “MySchedule” is open in the Schedule View area. 

1. From the toolbar menu click the Staff Manager button to display the Staff 
Manager, alternatively from the Add and Remove Staff section of the 
Navigation Pane select “Add and Remove Staff”. 

2. Select the Availability tab and select the options displayed here: 
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Entering information about a staff working time profile. 

 This information is automatically checked during the course of scheduling and if any conflicts 
arise a warning is displayed to take avoiding action. 

3. Click Save and Close to update the staff record. 

4. From the toolbar menu click the Management Reports button 
to display the Reports dialog. 

 
Displaying the Reports dialog 

5. Select HR > Staff Work Preference report and click Open to display the 
report 
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An example of a Staff working time profile report 

 Tip: A definitive document about working hours can save time and misunderstanding at the 
beginning of any agreed working arrangements. 

6. Close the Report View using the Close button on the toolbar to return 
you to the Schedule View area. 

7. From the toolbar menu select View > Issues Pane to display 
the Issues Pane at the bottom of your screen. 

 
The issues pane displayed with a list of issues, warnings about scheduling conflicts. 
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 At this point a list of warnings will have been generated for “Peter Agar” because his availability 
will conflict with the current schedule. The Issues Pane can be docked and undocked and 
adjusted to requirements in the Schedule view area. 

 
Displaying the warnings in the Issues Pane and compared with staff working time profile. 

 

 In the main these should be self-explanatory, but one or two may require further clarification. 
What can catch people out is a night shift on the preceding day impacting a constraint on the 
following day which flags a warning. One warning listed here deserves more explanation: 
“Saturday June 02, 2012 5:00p-1:00a Availability Shift: 5:00p-1:00a does not match this day’s 
staff availability: 12:00a-12:00a”. This is caused by the 5:00p-1:00a Saturday evening shift 
running into the following Sunday which has an availability constraint starting at 13:00 or 1pm 
in the afternoon. Put another way they are unavailable before then, including the 1am hour in 
the small hours of Sunday morning, albeit it is considered a Saturday shift. Finally, 12:00a-
12:00a represents a full 24 hour period or day running from midnight to midnight and this is 
displayed as part of the warning message. If there was no constraint on the early hours of 
Sunday morning there would be no warning. 

8. Close “Myschedule” and clear the Schedule View area. 

Work Hour Thresholds 

 In addition to Staff availability we need to manage information about Work Hour Thresholds. 
This is about monitoring when staff are working too many or too few working hours. This is 
more sophisticated than just monitoring staff hour totals we saw earlier in the Schedule View 
area. For example the weekly hours may add up correctly but may involve working longer 
hours over fewer days and for some occupations e.g. driving and operating machinery and not 
satisfactory.   
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 Exercise 6.11 
Working with Work Hour Thresholds. 

This exercise assumes you have launched Schedule24 Resource Manager, both the 
navigation and issues panes are displayed and no schedule is displayed in the 
Schedule View area. 

1. Open the “Myschedule” schedule in the Schedule View area. Warning 
messages will appear in the Issues Pane. 

2. Click the Monitor Conflicts button in the toolbar menu to display the Active 
Conflict Monitoring (ACM) dialog. 

 
The Active Conflict Monitoring (ACM) control dialog deactivated 

3. Using the mouse pointer uncheck the “Active conflict checking” 
checkbox and click Close to return to the Schedule View area. 

4. Save the “Myschedule” schedule and close to clear the 
schedule View area. 

5. Open the “Myschedule” schedule to display it in the schedule 
View area. 

 On opening “Myschedule” on this occasion you will notice the Issue Pane is not populated with 
warnings. This is because the background processing has been turned off and checks are not 
carried out when opening a schedule. 

6. Using the mouse pointer select the Monitor Conflict button in 
the toolbar menu to display the ACM control dialog. 
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The Active Conflict Monitoring (ACM) control dialog settings activated 

7. Using the mouse pointer check the “Active conflict checking” checkbox 
and click Search this will search and display conflict warnings in the 
Issues Pane. 

 It is recommended for large schedules to only activate the ACM control when you need to 
check conflicts e.g. before publishing etc. Otherwise there may be a delay of 2 or 3 minutes as 
the ACM will carry out all the checks as it is opening a schedule. 

8. Close the ACM control dialog to return to the Schedule View 
area. 

Rest Period Thresholds 

 Associated with work hour thresholds are thresholds for rest periods. The most obvious is the 
time between shifts, but it also includes weekly rest periods. Lack of either can have a 
cumulative effect and lead to sleep deprivation over a period of time increasing fatigue and risk. 

 Exercise 6.12 
Working with Rest Period Thresholds. 

This exercise assumes you have launched Schedule24 Resource Manager, both the 
navigation and issues panes are displayed and “Myschedule is displayed in the 
Schedule View area. 

1. Using the mouse pointer right mouse click on Peter Agar in the schedule 
View area and select the Staff manager in the pop-up menu and when 
displayed click on the Working Hours tab. 

2. Enter the values displayed here: 
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Displaying the Staff Manager Working Hours controls and configuring values. 

3. Click Save and Close to return to the Schedule View Area 

 You can set global Working Hours values in Tools > Options that are applied to all staff in the 
schedule; and individual Working Hours values for each member of staff. Values are calculated 
depending on option selected i.e. global or individual. 

 Enter global first and then deal with exceptions individually. 

4. Open the ACM control dialog and accept the default dates click Search 

 There should be no change to the warnings listed in the Issues Pane. The values entered for 
“Peter Agar” do not as yet breach any thresholds you have set. 

5. Close the ACM control dialog to return to the Schedule View area. 

 Tip: use the mouse pointer to grab the top of the Issues Pane and extend upwards to display 
more visible area. 

6. If not already done so, adjust the Schedule View area to display the 
schedule content as follows. 
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Adjusting the schedule view area to display this schedule content 

 It may be difficult to get the exact schedule colors and dates will be different depending when 
you do the tutorial, however the scheduling content should be accurate if you have followed the 
previous exercises and that is all we are concerned with here. We will be modifying the 
schedule content to breach thresholds and display warnings in the Issues Pane. 

7. Select “Peter Agar” Sunday 10:00a-6:00p shift and change to 
10:00-10:00p shift effectively extending it to a 12 hour shift. 

 Tip: Place the mouse pointer on the shift cell and right mouse click and select Shift Editor to 
display the Shift Editor controls in the menu toolbar at the top of the Schedule View area. 

8. Click the ACM control button to display the ACM control 
dialog and accepting the default search range click Search to 
display any additional warnings. 

 
Additional and new warnings are added to the list of warnings. 
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 Two new warnings are added: the daily 12 work hours exceed the daily 8 hours threshold; and 
the daily overtime total of 4 hours exceeds the daily 2 hour overtime threshold. There is 
actually a third which is a modified warning in light of the 1pm work constraint on this Sunday 
which simply notifies the change of shift hours but the existing warning remains the same. 

9. Using the mouse pointer click on the Undo button in the 
toolbar menu, alternatively select Edit > Undo to return the 
shift change back to 10:00a-6:00p. 

10. Use the mouse pointer to highlight “Peter Agar” Mon, Tue & 
Wed shift cells and select 10:00a-6:00p from the drop down 
shift list and click the check or ‘tick’ button. 

 This action effectively removes “Peter Agar’s” scheduled Days off from the schedule. 

11. Open the ACM control dialog and accept the default dates click Search 

 The previous warnings about exceeding daily hours and overtime are removed from the 
warning list and replaced by two more warnings: the weekly 56 hours exceed the weekly 40 
hour threshold; and the minimum 24 hour weekly rest period is breached with the longest 
period 22 hours falling short. This is a good example how changes can impact the schedule 
and the working hours in different ways depending on the threshold values entered. 

12. Use the mouse pointer to highlight “Peter Agar” Tue & Wed 
following Days Off, and enter 11:00p-07:00a night shifts on 
these two days using either the Shift Editor or Copy & Paste 
edit tools. 

 Tip: Click on the ‘Pin’ icon of the Navigation Bar. This will enable the Navigation Bar to auto 
hide and increases the screen view to see more of the Schedule View area. 

 This will now mean “Peter Agar” works more than 2 weeks without a 24 or 48 hour consecutive 
rest period in this period. Clear breaches of working hour’s compliance. 

13. Open the ACM control dialog and accept the default dates click Search 

 The previous warnings are still current and more warnings are added: there are more breaches 
of the 24 hour weekly rest period (a Day Off); and a new warning about the 2 weekly range rest 
period of 48 hours (two consecutive days off) being breached.  
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Working hours’ breaches may impact several compliance factors. Warnings 

have been sorted by issue category in descending order 

 Using the mouse pointer click on the Undo button in the toolbar menu twice, alternatively select 
Edit > Undo to return to the original shift settings and remove the warnings from the Issues 
Pane. The only warnings listed should now be the ‘Availability’ category. 

14.  Use the mouse pointer to highlight “Peter Agar” Monday 
following night shift, and enter 10:00a-6:00p using either the 
Shift Editor or Copy & Paste edit tools. 

15. Open the ACM control dialog and accept the default dates click Search 

 This will generate a new warning about the “Min Daily Rest Period” of 11 hours being breached 
by a 3 hour period between finishing night shift and starting a later day shift. This is a common 
error and even though most people recognise it as an error it continues to prove expensive 
when published and exploited as a call out or overtime. 

16. Use the mouse pointer and click on the Undo action to remove the 
conflict, and Close “Myschedule” schedule and save when prompted. 

17. Exit the Schedule24 Resource Manager application. 

 You have covered the basic features of the ACM control. For the purpose of the exercise we 
have only been focusing on one person in one schedule. Where multiple staff, or even multiple 
schedules displayed in the Schedule View area warnings are identified to their point of origin 
i.e. schedule name; person; date and time; category of issue; and sufficient detail to resolve the 
issue. 
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Working With Staff Costs. 

 Any business manager needs to be aware of staff costs and how they impact business. The 
relationship between costs and staff deployment strategies is not a straight forward one. Cost 
management with Schedule24 Resource Manager provides instant feedback about how much 
a particular scheduling strategy is costing the business, enabling swift comparison to be made 
and enable expensive options to be avoided. In fact it becomes a matter of daily routine rather 
than annual review. It is not uncommon for organizations to change staff deployment strategies 
which incur significant cost hikes while failing to add one hour to the production schedule. 

 Exercise 6.13 
Introduction to measuring staff costs. 

Costs are almost exclusively influenced by the number of staff hours, when and 
how they are worked. The exercise assumes you have launched Schedule24 
Resource Manager and “MySchedule” schedule is displayed in the schedule View 
area. It is also assumed regional settings are configured to US English and the $ 
currency symbol is displayed throughout. 

 The currency symbol does not affect calculations and no calculation is used that applies 
currency exchange rates. For example, the figure 10.00 is the same whatever the currency 
symbol. 

1. From the toolbar menu select Tools > Options … Costs tab. 

 
Cost Options for calculating Staff costs 

2. In the Default cost type box select “Hourly Rate…” 

3. In the Default cost rate box enter the value “7.50”. 
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4. Modify the remaining default values as displayed in the above illustration. Click 
OK to close the dialog and set the default calculations for all the staff in the 
schedule. 

5. Using the mouse pointer ‘Unpin’ the Issues Pane so it auto hides from the 
Schedule View area. 

6. From the toolbar menu select View > Costs to display the staff cost column; 
and for the purpose of this exercise hide the staff hour’s column. 

7. Using the mouse pointer right mouse click in the Staff Count dashboard area 
and select customize to display the dialog for selecting Category Combinations 

8. Add “All working” and “Cost” category and add to the display list using the << 
button. Click OK and close the dialog. Adjust the dashboard so the cost 
information is visible if it isn’t already. 

 
Displaying cost information in the Schedule View area 

9. Using the mouse pointer highlight the column date headers across the week 
range Monday thru to Sunday, and right mouse click and select “Breaks...” to 
display the Breaks dialog. 

 

Scheduling Breaks for a multiple selection of shifts over a date range. 
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10. Using the table below enter the following Breaks information into the Breaks 
dialog box: 

Select Shift Start of Break End of Break Total Time 

10:00a-6:00p 1:00p 1:45p 00:45 

3:00p-11:00p 7:15p 8:00p 00:45 

5:00p-1:00a 9:30p 10:15p 00:45 

11:00p-7:00a 3:00a 3:45a 00:45 

7:00a-3:00p 11:00a 12:00p 01:00 

 

 Tip: Enter Start of Break and then enter (Copy & Paste) Total time to calculate End of Break 
time – it’s a little quicker. 

11. Click OK to close the Break dialog and update the Schedule View area with 
Breaks information. 

 
Updating the Schedule View area with Breaks information 

12. Select View > Hours to display the Staff working hours column 

 Both the work hours and staff cost totals are based on the calculation settings in Options > 
Calculation tab. In this example it is calculation over a 7 day period. The Breaks calculation is 
not included in shift times which total both hours and costs lower in this displayed example. 

Select Tools > Options > Calculate to display the Calculation controls in the 
Options dialog and check the “Include breaks in calculation” checkbox. 
Click Close to close the dialog and update the Schedule View area with the 
new calculations. 

 Tip: “Peter Agar’s” hours total should be 40 hours; and staff costs $375.00. 

13. Select from File > Print Range to display the print range 
dialog. 
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The Print Range dialog for adjusting print range settings. 

14. Accept the default selection of all staff and enter the 
appropriate dates containing you breaks information in 
“MySchedule”. 

15. Click OK to close the dialog, and click the Management 
Reports button in the menu toolbar to display the reports list 
dialog. 

16. In Managements Reports folder click Operations and select 
the Staff Timesheet report. 

 
The Management Reports list 

17. Click Open to display the Timesheet management report in 
Print Preview. 
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Displaying the Timesheet Management Report in Print Preview 

18. Click the Close button of the Print Preview manager to return to the Schedule 
View area. 

 

 Exercise 6.14 
Working staff cost breakdown. 

A detailed breakdown of staff costs is also available from within the Schedule 
View area for instant feedback.  This exercise assumes you have launched 
Schedule24 Resource Manager and “MySchedule” schedule is displayed in the 
schedule View area.  

1. Open “MySchedule” if not already open in the schedule View area. 

2.  From the toolbar menu select View > Daily Costs to display a cost amount in 
each individual staff day cell. 

3. Using the mouse pointer hover over “Peter Agar” Friday day cell and 5:00p-
1:00a shift to display the breakdown of staff costs for that shift. 
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Displaying the breakdown of staff costs. 

 The 5:00p-1:00a evening shift includes the following rates: a 1 hour basic rate from 5p-6p. At 
6p this starts the Premium rate until 9p; and from 9p until 1am the end of the shift the weekend 
rate is applied. Where more than one rate is involved in a shift duration all rates are quoted in 
the breakdown, but only one can be applied and the rate applied is displayed in upper case. 
For example, basic PREMIUM weekend during the times of the premium rate; and basic 
premium WEEKEND during the times of the weekend rate.  

 Tip: The cost breakdown displayed in the pop-up can be printed in the Staff Week 
management report. 

4. Click OK to close the dialog, and click the Management Reports 
button in the menu toolbar to display the reports list dialog. 

5. In Managements Reports folder click Costs and select the Staff 
Week report. 

6. Click Open to display the Staff Week report in Print Preview. 

 
The Staff Week management report showing the cost breakdown viewed in the Schedule View area. 

 

7. Close the Print Preview and return to the Schedule View area. 

 Changes to global cost rates and type are made in Tools > Options > Costs. These include 
salaried, daily and hourly cost type; and cost rates as a $ amount. These rates can also be 
changed for individual staff where they are an exception to the rule. 

 Exercise 6.15 
Setting individual staff cost rates. 

Staff cost calculations can be made on an individual basis which override global 
settings. This exercise assumes you have launched Schedule24 Resource Manager 
and “MySchedule” schedule is displayed in the schedule View area.  
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1. Open the Staff Manager and select the Cost tab and select “Peter Agar” in 
the staff list. 

2. Enter the options and values displayed in the following: 

 
Displaying the individual cost controls in the Staff Manager 

 Make sure the “Custom individual cost type” option is selected so the individual values are 
applied to calculations. 

3. Click Save and Close to return to the Schedule View area. 

4. Using the mouse pointer hover over “Peter Agar” Friday day cell and 5:00p-
1:00a shift to display the breakdown of staff costs for that shift. 

 
Displaying the daily rate breakdown of staff costs. 

 Following the rate change to a daily rate the 5:00p-1:00a evening shift displays a simpler 
calculation of the following rate: a basic daily rate from 5p-1a at 1 day $450. No more than one 
rate is involved.  A multiplier is calculated for weekend and public holidays where they occur for 
daily rates. 
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5. Click OK to close the dialog, and click the Management 
Reports button in the menu toolbar to display the reports list 
dialog. 

6. In Managements Reports folder click Costs and select the 
Staff Week report. 

7. Click Open to display the Staff Week report in Print Preview. 

 
The Staff Week management report showing the daily rate cost breakdown viewed in the Schedule View area. 

 The day rate is now reflected in the Staff week management report. The idea of the breakdown 
pop-up is instant feedback when making scheduling decisions. Evidence suggests when 
feedback is swiftly available better decisions result. Even a short delay at the point of decision 
impacts that benefit. 

8. Close the Print Preview and return to the Schedule View area. 

9. Repeat the above procedure for changing “Peter Agar’s” individual rate to 
a salaried rate using the options and values displayed in the following: 

 
Displaying the individual cost controls for salaried rate in the Staff Manager 
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10. Click Save and Close to return to the Schedule View area. 

11. Using the mouse pointer hover over “Peter Agar” Friday day cell and 5:00p-
1:00a shift to display the breakdown of staff costs for that shift. 

12. Click Save and Close to return to the Schedule View area. 

13. Using the mouse pointer hover over “Peter Agar” Friday day cell and 5:00p-
1:00a shift to display the breakdown of staff costs for that shift. 

 
Displaying the salaried rate breakdown of staff costs. 

 Following the rate change to a salaried rate the 5:00p-1:00a evening shift displays a calculation 
amortized over the year: a basic daily rate from 5p-1a at 1 at $112.33 a day. No more than one 
rate is involved.  No multiplier is calculated for salaried rates at weekend and public holidays. 
Note that the salaried rate is also applied to Days off unlike hourly and day rates. 

14. Click the Management Reports button in the menu toolbar to 
display the reports list dialog. 

15. In Managements Reports folder click Costs and select the 
Staff Week report. 

16. Click Open to display the Staff Week report in Print Preview. 

 
The Staff Week management report showing the salaried cost breakdown viewed in the Schedule View area. 

 The salaried rate is now reflected in the Staff week management report.  
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17. Close the Print Preview and return to the Schedule View area. 

 Tip: When you highlight any area of the Schedule View area a hours and cost calculation is 
also displayed in the left hand side of the status bar. For example highlighting a two column 
Sat & Sun weekend column gives an instant feedback on the costs of weekend working. 

 The calculation priority of multipliers in the context of rates can be presented as follows: 

Multiplier Rates 

In order of 

precedence Hourly Day Salaried 

Public Holiday Yes Yes No 

Overtime Yes No No 

Premium Yes No No 

Weekend Yes Yes No 

Basic Yes Yes Yes 

 

 Useful considerations when working with Staff costs include: 

 Comparing deployment costs in context of production (staff) hours 
e.g. know when change in staff deployment patterns threatens 
increase costs without benefit in more production hours. 

 Calculating service costs for business tariffs knowing your 
deployment costs means a more competitive tariff that wins 
business e.g. out manoeuvring the competition that make it up as 
they ‘go along’. 

 Understand your options in the Staff/Cost grid e.g. better 
coordination can avoid short notice agency staffing due to lack of 
planning. 

  Staff 

  More Fewer 

Cost 
Higher Effective not Efficient Not efficient or effective 

Lower Efficient and Effective Efficient not Effective 
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Section 7 - Printing and Publishing 
How you communicate action is as important as doing it in the 
first place.  Ambiguity, uncertainty and delay are the 
hallmarks of an inefficient and ineffective work place. 

After completing this lesson you will be able to: 

1. Communicate an effective staff deployment strategy. 

2. Publish web schedules for universal access. 

3. Email schedules for faster communication. 

4. Provide workplace intelligence. 

5. Create management reports for improved decision making. 

Printing and Publishing Options 

 Schedule24 Resource Manager works with a perpetual calendar which means scheduling is a 
continuous process. You control the start and end of schedules you print and publish by 
selecting a Print Range and selecting formatting options in Page Setup depending the style of 
information you want to print or publish. You also have additional options when working with 
the Web and Email Wizards. All this gives you a wide range of choices when it comes to 
communicating your information. 

 

 Exercise 7.1 
Working with Page Setup for Day Schedules. 

For these exercise we will be using the example schedule “Business Center” which 
is sufficiently populated with scheduling information for creating reports. This 
exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed with no schedule open in the Schedule View area. 

Section 

7 
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 The “Day Schedule” format has comprehensive detail about staff shifts, assignments and is the 
preferred format for a daily manifest or action sheet used by supervisors and staff alike in the 
workplace. 

1. Open the example schedule “Business Center” 

2. Highlight a day cell in the first column and select Data > Sort by > Start 
time to arrange the shifts in chronological order at the start of the 
schedule. 

 This will help navigate through the steps outlined in the following exercises. 

3. From the toolbar menu select File > Page Setup > Day Schedules to 
display the Page Setup dialog 

 
The Page Setup for Day Schedule options displayed. 

4. Accept the default values and select “Page” tab to display the page 
formatting controls 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

192 

 
The Page Setup for Day Schedule options displayed. 

5. Accept the default values and select “Margins” tab to display more 
page formatting controls. 

 
The Page Setup for Day Schedule margin options displayed. 

6. Accept the default values and select “Print Range” tab to display 
options to select the range of data to be published. 
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The Page Setup for Day Schedule print range displayed. 

 The print range window is sorted by Job Title in ascending order. Each column can be sorted 
by clicking on the column header of each category. 

7. On this example select the “Finish” date to complete one 
week of data to finish on a Sunday; and then select the 
Header/Footer tab. 

 
The Page Setup for Day Schedule print range displayed. 

 You can add additional information to your printed schedule e.g. date and time when printed 
and contact details. 

8. Click the “Print Preview” button to display the Day 
Schedule in the Print Preview window. 
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The Day Schedule displayed in print preview. 

 

9. Click Close to return to the Schedule View area. 

 

 

 Exercise 7.2 
Working with Page Setup for Weekly Schedules. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and the “Business Center” schedule displayed in the 
Schedule View area. 

 The weekly format schedule displays a traditional layout of staff shifts for each day of the week. 
It contains some detail but will truncate long text strings to maintain the format. This format 
provides notice of shifts and Day off in advance and does not carry the detail of the Day Plan 
format. 

1. From the toolbar menu select File > Page Setup > Week Schedules to 
display the Page Setup dialog 
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The Page Setup for Weekly style options displayed. 

 

2. Accept the default settings and click Print Preview button to display 
the schedule in the print preview window. 

3. Click the Setup button in the Print Preview toolbar to display the 
Page setup controls and click the Page tab. 

4. Select the Landscape option and check fit to page. 

 Depending on your printer and page selection you may need to adjust the margins to display 
the full week on the page layout. 

5. Click Print Preview button to display the schedule in the 
print preview area. 
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The Weekly Schedule displayed in print preview. 

 Tip: You can reduce the hour columns and staff content to maximize the schedule content.  

 

6. Click the Setup button to return to the Page Setup dialog 
and select the weekly tab if not already displayed. 

7. Select the “Full page optimization” option and accept the 
defaults this enables and click the Print Preview button. 

 
The Weekly Schedule displayed in optimized format with following weekly blocks. 
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8. Close the Print Preview and return to the schedule View area and 
Exit the application and return to your desktop. 

 Exercise 7.3 
Working with Page Setup for Staff Reports. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and there is no schedule displayed in the Schedule 
View area. 

 

 The Staff Report contains all the personal and contact information you have entered about staff 
in the Staff Manager. The options are configurable so you only produce the staff reports with 
the content you need. 

1. Open the Business Center schedule. 

2. From the toolbar menu select File > Page Setup > Staff Report to 
display the Page Setup dialog 

 
The Page Setup for Staff Report style options displayed. 

 The options are straight forward. If you want the information to be displayed check the 
appropriate checkbox, and uncheck if you do not want the information displayed. Note the tab 
format is the same except for the style tab. This is the only tab that changes in Page Setup 
depending on the style selected, the other controls remain the same. 

3. Accept the default settings and click the Print preview 
button to display the Staff Report in the print preview 
window. 
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The Staff Report will all options for content displayed in print preview. 

 

4. Click the close button to return to the Schedule View 
area. 

 

 Exercise 7.4 
Working with Page Setup for Statistics Reports. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and the “Business Center” schedule is displayed in 
the Schedule View area. 

 

 The Statistic Report provides detailed information about scheduling content and provides configurable 
options to obtain frequency counts about scheduling activity. This is a standard report feature and in 
addition to any Management Reports that may be available. 

1. From the toolbar menu select File > Page Setup > Statistic Report to 
display the Page Setup dialog 
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The Page Setup for Staff Report style options displayed. 

 Again the selection options for the Statistics Report are straight forward. The Checkboxes on 
the right include more detail when checked. The Checkboxes on the left will exclude the 
category data if unchecked. 

2. Accept the default settings and click the Print preview button 
to display the Statistic Report in the print preview window. 

 
The Statistics Report displayed in print preview. 

 

3. Click the close button to return to the Schedule View area. 
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 Exercise 7.5 
Working with Page Setup for Management Reports. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and the “Business Center” schedule is displayed in 
the Schedule View area. 

 

 The Management Reports are a suite of business reports shipped with the product. Additional 
Management Reports are also available for download. They are dealt with in more detail in a 
later section. The Page Setup control has the standard four tab page layout controls as the 
other styles, but there is not a specific tab control for management reports. 

 

1. From the toolbar menu select File > Page Setup > Management Report 
to display the Page Setup dialog 

 
The Page Setup for Management Report style displayed. 

 

2. Accept the default options and click the “Print Preview” button to display 
the Management Report dialog. 
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The Management Reports dialog listing report categories 

 

 You access Management Reports in their own folder location on your computer or network. 

3. Select the “Charts and Graphs” folder and select the “Department Costs 
Chart” and click Open to display the report. 

 
The Management Reports displaying Department Month Graph in print preview window. 

 This chart has been navigated to Department “E” using the forward and backward navigation 
arrows in the print preview toolbar. 

4. Click the Setup button in the print preview toolbar to display the Page 
Setup controls and click the Print Range tab. 

5. Select the End date drop down calendar and enter the last day of the 
month (in this example 28 Feb-09). 
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6. Click Print Preview to display this management report in the print preview. 
Use the navigation arrows to move forward and backwards across multiple 
pages. 

 Management Report information can be exported in a number of formats including Microsoft® 
Excel. 

7. Using the mouse pointer click the Export button in the print preview 
toolbar to display the Export dialog. 

 
The export function for Management Reports 

 

 
The export dialog for Management Reports 

 

8. Select the settings to export to Microsoft Excel and accept 
the default setting through the procedure and click OK to 
display the Excel spreadsheet. 
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The exported data displayed in Excel ready for more in-depth analysis. 

 

 The data will be exported to Excel and the default values should enable all Excel functions to 
be applied e.g. sum, average and counts depending on your version of Excel. You do need 
Excel installed on your computer. All management reports have this export function. 

9. Close the Print Preview window and return to the Schedule 
View area. 

 

 Exercise 7.6 
Working with Print Ranges. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and the “Business Center” schedule is displayed in 
the Schedule View area. 

 

 Schedule24 Resource Manager only understands the concept of scheduling on a continuum; 
schedules do not have a start or an end they are part of a never ending timeline. You can 
however create discrete schedules with a start and end and you do this using the Print Range 
control. 

 

1. From the toolbar menu select File > Print Range to display the Print 
Range dialog controls. 
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The Print Range controls for publishing schedules with a start and end date. 

 

2. With the mouse pointer click on the Name column header to 
sort contents in ascending order. 

 Tip: The little black arrow indicates the sort order, up for ascending; and down for descending. 

3. Using the mouse pointer and the Shft & Ctrl keys select the 
records to be included in your published content. 

 Tip: Sort by Department to select records for a department schedule; and similarly for teams or 
Job Title. 

4. You can select any date range for your published content 
using the drop down calendar controls. 

 Tip: You can extend the calendar control to view a large selection area on your time line. 

5. With the mouse pointer pull the lower right ‘grab’ handle of 
the calendar control and extend across and down to reveal 
more dates. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

205 

 
The date ranges displayed by extending the calendar in Print Range control. 

 

 You will come across the print range calendar control in the email and web publishing wizards. 
These operate independently from the Print Range control used for publishing printed 
schedules. The reason is web and email publishing typically have longer date ranges than 
printed schedules and this reduces the need to keep going back and changing the start and 
end date settings when swapping between different publishing channels. 

6. Click the Cancel button in the Print Range control so you 
don’t save changes and return to the Schedule View area. 

 

 Exercise 7.7 
Working with Print Preview. 

This exercise assumes you have launched Schedule24 Resource Manager and the 
Navigation Pane is displayed and the “Business Center” schedule is displayed in 
the Schedule View area. 

 

 You have already familiarised yourself working with the Print Preview window. Here you are 
made aware of accessing Print Preview quicker. 

1. From the toolbar menu select File > Print Preview to display the Print 
Preview style options. 
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The Print Preview style options from the main menu. 

 

 You can access any style of schedule or  report for print preview without going through Page 
Setup and your previous settings and header and footer information used in the session will be 
‘remembered’. Similarly with File > Print the same options are presented for direct access 
without going through Page Setup options. 

 
2. Close the Business Center schedule and exit the application to your 

desktop. 
 

Web Schedules 

 

 Exercise 7.8 
Working with Web schedules. 

This exercise assumes you have launched Schedule24 Resource Manager and 
“Business Center” schedule is displayed in the schedule View area.  

 Publishing schedules to the web enables anyone in the organization to access and see their 
scheduling information from any browser. 

1. From the toolbar menu click the “Publishing to the Web...” button to 
launch the Web Wizard. 
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The welcome screen of the Web Wizard 

2. Click the Next button to move to the next step. 

 
The content screen of the Web Wizard 

3. Click the Next button to move to the next step. 

 
The staff screen of the Web Wizard 

4. Click the Next button to move to the next step. 
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The format screen of the Web Wizard 

 This information is formatting content for the home pages and is used to brand the ownership 
along with contact information. 

5. Click the Next button to move to the next step 

 
The preview screen of the Web Wizard 

 You can choose any location on the network to save web schedules. To save web schedules 
to an external hosting location you need access to a file transfer protocol solution. 

 There are a number of suitable open source FTP solutions e.g. “Coffee Cup” and “FileZilla” 

6. Click the Preview in Browser button to display the web schedule in your 
local browser. 
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Displaying the web schedule home page in a browser. All sections are fully hyperlinked. 

 Tip: Once you have setup your web schedule location on your network you can select the 
option to update the web schedule every time you save your schedule. 

 
Tools > Option > General tab displays option to update web schedule when saving file. 

 

 The time taken to save to a network location is dependent on available bandwidth and network 
traffic at the time of day. Care needs to be exercise when loading content onto network 
locations e.g. personal contact information. Contact your local IT administrator about your 
security protocols.  

 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

210 

Email Schedules 

 Exercise 7.9 
Working with Email schedules. 

This exercise assumes you have launched Schedule24 Resource Manager and 
“Business Center” schedule is displayed in the schedule View area.  

 Publishing staff schedules via email enables anyone in the organization to be quickly kept up to 
date about schedule changes. 

1. From the toolbar menu click the “E-mail Staff Schedules...” button to 
launch the Email Wizard. 

 
The welcome screen of the Email Wizard 

2. Click the Next button to move to the next step. 

 
The Staff screen of the Email Wizard 
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3. Click the Next button to move to the next step. 

 
 

 
Option of the Email Wizard displaying format of schedule content. 

 The configurable content is a visual cue of representative data. You can decide how much or 
how little scheduling content is forwarded to staff email boxes. 

 
4. Click the Next button to move to the next step. 
 

 
The iCal format and attachment screen of the Email Wizard 

 

 The iCal format enables email recipients to import their schedules and assignment information 
direct into their personal Outlook and Google calendars and access mobility of scheduling data 
via mobile devices. The attachment feature will send any attachment to all email recipients. 

 You will not be able to complete this exercise without genuine email addresses and 
connection to a mail server. 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

212 

5. Click Cancel to close the Email Wizard and return to the schedule View 
area. 

Management Reports 

 Management Reports are a series of reports in addition to the standard schedule formats, 
statistics, and staff reporting. They are flexible additions and from time to time additional 
reports are made available for download. Where a customer has specific requirements they 
can be delivered against a specification. 

 

 Exercise 7.10 
Working with Management Reports. 

This exercise assumes you have launched Schedule24 Resource Manager and 
“Business Center” schedule is displayed in the schedule View area.  

 Management Reports have their own file location and by default are stored in the root directory 
at the time of installation. You can change the file location using Tools > Options > General tab. 
All Management Reports can be exported to a range of different applications including Excel, 
Word and PDF formats. 

1. From the toolbar menu select Tools > Options > General tab to display 
the control settings for changing location pathnames. 

 
The Option controls for changing the pathname location for all file types including Management Reports. 

2. Cancel the dialog and return to the Schedule View area. 

3. From the toolbar menu click the “Management Report” button to 
display the Management Reports dialog from where you can select your 
report from one of the six categories of Management Report. 

Schedule24 Professional – Printing and 
Publishing 
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The Management Report categories containing a range of business reports. 

4.  Click Cancel and return to the Schedule View area. 

 The procedure for opening, displaying a chart in the Print Preview window, and publishing 
using the Print Range options is common to all the categories of Management Reports. A full 
description of each report can be found in the Help files, and more information about available 
charts can be found by logging onto the Intellicate Knowledgebase online. There are however 
a class of Management Report worthy further attention, the Dynamic Report. 

 

Dynamic Reports 

 All management reports can be configured by using Print Range options, and the ranking and 
sorting criteria selected in the application. Dynamic reports have additional controls to filter and 
select reports content. 

 
 

 Exercise 7.11 
Dynamic Management Report: Activity Detail 

 This report enables the user to select parameters based on assignment and unavailability 
information entered into a schedule. Information includes frequency counts of the selected 
records by date and by officer. In common with all other reports personnel and date ranges can 
be selected using the Print Area dialog. 

1. From the toolbar menu click the “Management Report” button to display the 
Management Reports dialog. 

2. Open the Research folder and select the “Activity Detail” Report and click 
Open to display the report in the Print Preview window 
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A dynamic report with addition controls to filter and search on combinations 

3. Using the mouse pointer select the items in the display and move them to 
the “Selected Values” pane. 

 The menu items automatically filter content dependent on the previous selection. 

4. Click OK to display the report content in the Print Preview window. 

 
A dynamic report with selected content looking at page 4 of 6. 

 It pays dividends to think about the kind of activity you want to record in your schedule as it can 
provide invaluable information about workplace activity especially over time. 

5. Click Close to return to the Schedule View area. 
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6. Repeat the above procedure to open the Management Report 
dialog and from the “Research” folder select the “Skills 
availability” report and click open to display in the Print 
Preview window. 

 
A dynamic report with selected options for specific skill set availability at 9:00am. 

7. Select the options to search for a specific skill set at a 
particular time over the current print range dates and click 
OK to display the content in the Print preview window. 

 
A dynamic report with selected content about skill set looking at page 1 of 7. 

 

8. Click Close to return to the Schedule View area. 

 The available skills are searched across the training records entered into the Staff Manager 
and matched in the context of scheduled staff availability. 
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A combination of skills associated with the availability across the date range. 

 

9. Close the “Business Center” schedule and Exit the application to desktop. 
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Section 8 – Exchanging Data 
Importing, Exporting & Archiving Database information enable 
you to maximize your investment and maintain the integrity 
of staff work place records. 

After completing this lesson you will be able to: 

1. Import staff information into Schedule24. 

2. Export Schedule24 database information. 

3. Share information with third party applications. 

4. Know how to create import and export scripts to automate data exchange. 

5. Archive large or very large Schedule24 databases. 

6. Password protect your schedules and shift pattern designs. 

Importing and Exporting 

Wizards enable you to configure your importing of staff details; and exporting 
of all your scheduling content to other applications. 

 

 Exercise 8.1 
Import staff from another Schedule 

This exercise assumes you have launched Schedule24 Resource Manager and there 
is no schedule  displayed in the schedule View area. 

 Once you have entered staff into a schedule and you want to start a new schedule with the 
same staff it is easy to import staff from an existing schedule using the Import Wizard. This 
includes all their data including training and service records and working profiles. 

 

Section 

8 
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1. From the toolbar menu File > New > New to display the New 
dialog and select Blank schedule icon and click OK to display 
a new schedule in the Schedule View area. 

2. The schedule Assistant will be displayed, select the” Import 
staff from an existing schedule?” prompt and click OK to 
display the “Insert staff from another Schedule” dialog listing 
all the available schedules. 

3.  Select the schedule “My Business Center” and click OK to 
close the dialog and populate the new schedule with the staff 
records from the existing schedule. 

4. Close the Schedule Assistant prompt using the window close 
button. 

 If you repeat the procedure to import staff from another schedule they will be added to the 
existing staff. This procedure is constrained by your licensing terms and conditions. You will be 
unable to import staff which exceeds the number of staff licensed per schedule. 

 

 Exercise 8.2 
Import staff from another Application 

This exercise assumes you have launched Schedule24 Resource Manager and 
there is no schedule  displayed in the schedule View area. 

1. Repeat the above procedure to open a new blank schedule in the Schedule 
View area. 

2. The Schedule Assistant dialog will be displayed prompting your option. 
Select the “Import staff from another source?” option and click OK to 
display the “Import Wizard” dialog. 

 

 
The import wizard prompting for file format to import. 
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3. Select the option displayed and click Next to display the file prompt. 

 
The import wizard prompting for file to import. 

 You need to select an example file located as above in the default installation path. This is a 
common separator value format of a Schedule24 database. 

4. Click Finish and the file will be imported into the Staff Manager. 

5. Close the Schedule assistant prompt dialog that will appear and the 
schedule without saving to clear the schedule View area. 

6. Repeat the procedure to open a new blank schedule in the schedule View 
area. 

7. The Schedule Assistant dialog will be displayed prompting your option. 
Select the “Import staff from another source?” option and click OK to 
display the “Import Wizard” dialog. 

 

8. Select the “Other” option displayed and click Next to display the file 
prompt. 

 

 
The import wizard displaying available options. 
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9. Select the option from the drop down menu list displayed below to save to 
a location. 

 
The import wizard prompting for the file name to import. 

 You need to select this example import file located as above in the default installation path. 
This is a standard import format for QuickBooks. 

10. Click Finish and the file will be imported into the Staff Manager. 

11. Close the Schedule assistant prompt dialog that will appear and the 
schedule without saving to clear the schedule View area. 

 The menu items are defined importing scripts saved with the file extension .IMP and located in 
the Import folder of the installation path. 

 
The import files used to create items in the drop down list. 
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Example of a script of an .IMP file for QuickBooks format. 

12. Close the Schedule assistant prompt dialog that will appear and the 
schedule without saving to clear the schedule View area. 

 

 Exercise 8.3 
Export Schedule24 as an Access database 

 

This exercise assumes you have launched Schedule24 Resource Manager and the 
“Business Center” schedule is open and displayed in the Schedule View area. 

 You can export a Schedule24 database in several formats, as a Microsoft® Access database, 
to another application using a script file, or as a CSV file format. 

1. From the toolbar menu select File > Export to display the Export 
Wizard. Alternatively you can select “Export to Microsoft Access” from 
the Export Section of the Publish your Schedule bar of the Navigation 
Pane. 

 
The Export Wizard with the Access option selected 
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2. Select the Access option and click Next to move to the next step. 

 
The Export Wizard with the content options selected 

3. Accept the default options and click Next to move to the next step. 

 
The Export Wizard with the range options selected 

4. Accept the default options and click Next to move to the next 
step. 
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The Export Wizard with the target file and location selected 

 

 Enter a file name and target location to save the Access database. For the purpose of the 
exercise save the file as “MyExport.mdb” and save to your desktop. 

5. Click Finish to start the export which may take a few 
minutes. 

 Tip: You can see the progress of your export in the flood bar of the Status Bar and the process 
display “Exporting...” If you have other background process operating the flood bar may ‘freeze’ but 
the export will complete. 

 
The exported database tables and displaying the records of the Activity table. 

 

 Exercise 8.4 
Export CSV file format 

 

This exercise assumes you have launched Schedule24 Resource Manager and the 
“Business Center” schedule is open and displayed in the Schedule View area. 

 This procedure is very similar to exporting an Access database in the steps and choice of 
options to select range and format of data. 
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1. From the toolbar menu select File > Export to display the Export 
Wizard. Alternatively you can select “Export to file” from the Export 
Section of the Publish your Schedule bar of the Navigation Pane. 

 
The Export Wizard with the CSV option selected 

2. Select the CSV option if not already selected and click Next to move to 
the next step. 

 
The Export Wizard with the content and formatting options selected 

3. Accept the default options and click Next to move to the next 
step. 
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The Export Wizard with the range options selected 

 

4. Accept the default options and click Next to move to the next 
step. 

 
The Export Wizard with the target file and location selected 

 Enter a file name and target location to save the Access database. For the purpose of the 
exercise save the file as “MyExport.csv” and save to your desktop. 

6. Click Finish to start the export which may take a few 
minutes. 

 You will be returned to the schedule View area for the next exercise. 

 

 

 



S C H E D U L E 2 4  U S E R  G U I D E  A N D  T U T O R I A L  

 

 

226 

 Exercise 8.5 
Export to another application 

 

This exercise assumes you have launched Schedule24 Resource Manager and the 
“Business Center” schedule is open and displayed in the Schedule View area. 

 This procedure uses scripts to map data fields to other applications. It is similar to the import 
script files, but of course in this case they are export script files with the file extension .EXP and 
appear in the drop down menu as items. 

1. From the toolbar menu select File > Export to display the Export 
Wizard. Alternatively you can select “Export to file” from the Export 
Section of the Publish your Schedule bar of the Navigation Pane. 

 
The Export Wizard with the Other option selected 

2. Select the QuickBooks employee item from the drop down list and click 
Next to move to the next step. 

 
The Export Wizard with the range options selected 
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3. Accept the default options and click Next to move to the next 
step. 

 
The Export Wizard with the target file and location selected 

 

 Enter a file name and target location to save the Access database. For the purpose of the 
exercise save the file as “MyExport003.csv” and save to your desktop. 

4. Click Finish to start the export. 

 
The exported data mapped to QuickBooks staff records. 

 

 The menu items are defined importing scripts saved with the file extension .EXP and located in 
the Import folder of the installation path. 
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The export files used to create items in the drop down list. 

 
Example of a script of an .EXP file for QuickBooks format. 

 You can have as many scripted import and export files as you like. Each file will appear as a 
menu item in the respective drop down list for either imports or exports. It is ideal for mapping 
Schedule24 data to other applications you want to share data with regularly. 

 How to script these files is outside the scope of this user guide and tutorial. More detailed 
information can be found in the application Help files. 

5. Close the schedule and clear down the schedule View area. 
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Archiving Schedule24 Database 

 Although you can work on as many schedules in the Schedule View area as you like it is not 
uncommon to keep all your scheduling data in one schedule and over very long time ranges. 
Over time the schedules can become large and archiving is one way to keep files to a 
manageable size and still keep your historic data. 

 Exercise 8.6 
Working with the Archiving Wizard. 

This exercise assumes you have launched Schedule24 Resource Manager, the 
navigation pane is displayed and there is no schedule displayed in the Schedule 
View area. 

1. From the toolbar menu select File > Archive… to display the Archive 
Wizard. 

2. From the drop down file box select “Business Center” 
schedule to populate data into the other fields about the 
content. 

 
The archive wizard displaying the dates of the schedule range and selected archive date 

3. Select a “Archive data older than” date between the two dates 
displayed holding scheduling data. 

4. Using the … button select a target location and suitable file name of 
the archive file e.g. MyArchive001 and click OK to archive that data. 

 Archiving reduces file size. If you want to recover archived files simply open the archive file as 
you would a normal schedule and it will open in the Schedule View area. 
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Password Security 

 You want to secure your schedules or shift pattern designs to prevent 
unauthorized modifications. Always keep your password in a safe place and 
do not lose it otherwise you will not be able to access your files.  

 Exercise 8.7 
Protecting schedules and shift patterns 

This exercise assumes you have launched Schedule24 Resource Manager and 
“MySchedule” schedule is displayed in the schedule View area.  

 THERE IS NO WAY YOU CAN RECOVER A PASSWORD PROTECTED FILE WITHOUT 
THE PASSWORD. 

1. From the toolbar menu select Tools > Protection > Protect Schedule to 
display the password dialog control. 

 
Accessing the password controls to protect your work. 

 
The Set Password dialog with password entry entered 

2. Click OK and Save before closing the schedule and re-open in the 
Schedule View area. 
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The screen display when opening a protected schedule. 

 The procedure is identical when working in the Shift Pattern Designer environment and you 
want to protect your shift pattern design files. 

3. Cancel or close the Set Password dialog control and exit the 
application to desktop. 

Schedule24 File Types 

 For convenience the different file types you will be working with are produced in this table. You 
can also find information about Schedule24 files in the application Help files. 

 

Icon Extension What is it Folder Actions 

 

WPN Staff Schedule Schedules 
Delete if 

sure 

 
RPN 

Shift Pattern 
Design 

Shift patterns 
Delete if 

sure 

 

WPT 
Schedule 
Template 

Templates 
Delete if 

sure 

 
RPT 

Crystal or 
Business Objects 

Report 

Management 
Reports 

Don’t 
delete 

 
BAK 

System backup of 
your files to aid 

recovery 
With original 

Don’t 
delete 

 
COP 

Created when 
accessed by more 

than one user. 
With original 

Can 
Delete 
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