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1 Introduction 

Kindle Textbook Creator is a free tool designed to help authors and educators create, preview, and 
publish Kindle textbooks and supplemental educational materials without having to know any HTML or 
CSS.  

1.1 Import Format  
You can add pages to your book from any PDF file. Kindle Textbook Creator accepts single-page or multi-
page source files in .pdf. 

You can add audio, video, and image pop-ups  to your textbook as icons or as hyperlinks (see Section 2.7 
Adding Plug-ins). Kindle Textbook Creator accepts the following file types: 

• Video: .mp4 
• Audio: .mp3 
• Images: .jpg, .jpeg or .png 

1.2 Export Format  
Kindle Textbook Creator exports the finished book to a Kindle Package Format (.kpf) file that you can 
upload to Kindle Direct Publishing (KDP) to make it available to customers. 

NOTE: Books created with Kindle Textbook Creator can only be uploaded to KDP; they cannot be 
uploaded to Amazon Vendor Central at this time.  

If you want to update a Kindle book that was created with Kindle Textbook Creator on KDP, you can use 
Upload Your Book File to update that book on your KDP bookshelf. However, if you want to update a 
Kindle book that was not created with Kindle Textbook Creator, you must use Create new title to create 
and submit a new book on your KDP bookshelf instead. 

1.3 Selecting Your Language 
To display your preferred language in Kindle Textbook Creator, select File > Set UI Language and then 
choose your language from the list (see Figure 1). 

https://kdp.amazon.com/
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Figure 1: Selecting Your Language 

1.4 Kindle Textbook Creator Workspace  
The following sections describe the features of the Kindle Textbook Creator workspace (see Figure 2). 

 

Figure 2: Kindle Textbook Creator workspace 
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1.4.1 Pages Panel  

The Pages Panel displays thumbnails of every page in your textbook (see Figure 3). You can use the 
Pages Panel to add, delete, or move pages.  

 

Figure 3: Pages Panel 

To hide or display the Pages Panel, click the View button (see Figure 3) or select View > Show/Hide 
Pages Panel. 

1.4.2 Document Window  

The Document Window (see Figure 4) provides a detailed view of the page selected in the Pages Panel.  
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Figure 4: Document Window 

To adjust the zoom of the Document Window, select the Zoom menu (see Figure 5) or select View > 
Zoom In or View > Zoom Out. 

  

Figure 5: Zoom menu 
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1.4.2.1 Rulers and Guide Lines 

Rulers and guide lines make it easier for you to position elements consistently throughout your book.  

To hide or display rulers in the Document Window, select View > Show/Hide Rulers.  

You can create vertical or horizontal guide lines by moving the cursor over the ruler, holding down the 
left mouse button, and dragging the cursor onto the page. The guide lines appear as yellow lines in the 
document window (see Figure 6).  

 

Figure 6: Rulers and ruler guides 

1.4.3 Properties Panel 

The Properties Panel displays the options for the selected element: 

• When you select a page thumbnail in the Pages Panel, the Properties Panel displays options for 
including that page in the table of contents (see Figure 7). 
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Figure 7: Properties Panel—Page selected 

• When you select a plug-in icon or hyperlink in the Document Window, the Properties Panel 
displays options for that plug-in (see Figure 8). 

 

Figure 8: Properties Panel—Plug-in selected 
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1.5 Keyboard Shortcuts  
You can use the following keyboard shortcuts in Kindle Textbook Creator. 

Action Windows Shortcut Mac Shortcut 
Create New Book CTRL + N CMD + N 
Open Book  CTRL + O CMD + O 
Close Book CTRL + W CMD + W 
Save Book CTRL + S CMD + S 
Save Book As CTRL + SHIFT + S CMD + SHIFT + S 
Package for Publishing CTRL + SHIFT + P CMD + SHIFT + P 
Undo Change CTRL + Z CMD + Z 
Redo Change CTRL + SHIFT + Z CMD + SHIFT + Z 
Delete Plug-in DELETE DELETE 
Zoom In CTRL + = CMD + = 
Zoom Out CTRL + - CMD + - 
Fit to Window CTRL + 0 CMD + 0 
Fit Page Width CTRL + 2 CMD + 2 

1.6 Automatic Updates 
When Amazon releases a new version of Kindle Textbook Creator, the application automatically 
downloads it for you. When Kindle Textbook Creator prompts you to install an update, Amazon 
recommends that you install the newest version to get all of the latest features. 

 



Kindle Textbook Creator User Guide 
 

 Page 11 
 

2 Creating and Editing Your Textbook  

2.1 Preparing Your PDF 
Before you import your PDF, make sure that it includes bookmarks for each entry on the table of 
contents. After you upload your finished book to KDP, Amazon converts these bookmarks into an 
electronic table of contents that customers can use to navigate through your book.  

2.2 Creating Your Textbook  
To create a new Kindle textbook: 

1. On the opening screen of Kindle Textbook Creator (see Figure 9), click Create New Textbook 
from File. The Import from a PDF File dialog box appears (see Figure 10). 

 

Figure 9: Opening screen 

 

Figure 10: Import from a PDF File dialog box 
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2. Navigate to the PDF on your local hard drive, select the file, and click Open. Your PDF is 
imported and displayed in Kindle Textbook Creator (see Figure 11).  

 

Figure 11: Imported PDF 

3. Select File > Save Book to save your imported book. The Save dialog box opens (see Figure 12). 
Navigate to the location on your computer where you want to save the file. Enter the File name. 
Click Save. 

 

Figure 12: Save dialog box 
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2.3 Building Your Table of Contents 
To build the table of contents for your textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed and ready to edit. 

2. For each page that you want listed in the table of contents, select the page in the Pages Panel, 
check the box next to Include Page in Table of Contents, and type the table of contents entry in 
the Page Title box (see Figure 13). In the Pages Panel, each page that will be included in the 
table of contents is marked with a blue triangle in the upper left corner (see Figure 14). 

 

Figure 13: Table of contents example 

 

Figure 14: Page marked for table of contents 

3. To save your work, click File > Save Book. 
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2.4 Adding Pages  
To add pages to your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears 
(see Figure 15). Navigate to the folder where your book is saved, select the .kcb file, and then 
click Open. The book is displayed and ready to edit. 

 

Figure 15: Open a Kindle Textbook dialog box 

2. In the Pages Panel, right-click a thumbnail and select Insert Page(s) from the pop-up menu (see 
Figure 16). The Import from a PDF File dialog box appears. 

 

Figure 16: Insert Pages menu 
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3. Navigate to the PDF on your local hard drive, select the file that contains the pages you want to 
add, and click Open. The contents of the PDF are added to your book. 

4. To save your work, click File > Save Book. 

2.5 Moving Pages  
To move pages in your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. In the Pages Panel, drag and drop the pages in the order you prefer. To select multiple pages, 
use SHIFT + click or CTRL + click. 

3. To save your work, click File > Save Book. 

2.6 Deleting Pages  
To delete pages from your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed and ready to edit. 

2. In the Pages Panel, select the thumbnail of the page you want to delete. Right-click the 
thumbnail and select Delete Selected Page from the pop-up menu (see Figure 17). The page is 
deleted. 

 

Figure 17: Delete Selected Page menu 

3. To save your work, click File > Save Book. 
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2.7 Adding Plug-ins 
With Kindle Textbook Creator, you can add audio, video, and image plug-ins to your textbook as icons 
(see Figure 18) or hyperlinks (see Figure 19). 

 

Figure 18: Video plug-in icon 

 

Figure 19: Video plug-in hyperlink 

2.7.1 Adding Plug-ins as Icons 

You can add audio, video, and image plug-ins to your textbook as icons. Kindle Textbook Creator accepts 
the following file types: 

• Video: .mp4 
• Audio: .mp3 
• Images: .jpg, .jpeg or .png 

To add plug-in icons to your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Select Edit > Insert Plugin or click the Insert button (see Figure 20) and then select the type of 
plug-in that you would like to add (image, audio, or video). 
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Figure 20: Insert button 

3. A dialog box appears asking you to select the file that you want to add (see Figure 21). Navigate 
to the folder where your file is saved and click Open. The cursor changes to show the plug-in 
icon attached to it. Click the location where you want to place the plug-in and the icon appears 
on the page (see Figure 22).  

 

Figure 21: Select a Video File dialog box 

 

Figure 22: Video plug-in icon 
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4. To save your work, click File > Save Book. 

2.7.2 Adding Plug-ins as Hyperlinks 

You can add audio, video, and image plug-ins to your textbook as hyperlinks. Kindle Textbook Creator 
accepts the following file types: 

• Video: .mp4 
• Audio: .mp3 
• Images: .jpg, .jpeg or .png 

To add plug-in hyperlinks to your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Click the Select button (see Figure 23) and select the text that you want to link to the plug-in. 

 

Figure 23: Select button 

3. Click the Insert button (see Figure 24), select Link from Selection, and then select the type of 
plug-in that you would like to link to (image, audio, or video). 

 

Figure 24: Insert button 

4. A dialog box appears asking you to select the file that you want to add (see Figure 25). Navigate 
to the folder where your file is saved and click Open. The text that you selected is now 
hyperlinked to that file (see Figure 26).  
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Figure 25: Select a Video File dialog box 

 

Figure 26: Video plug-in hyperlink 

5. To save your work, click File > Save Book. 

2.8 Moving Plug-in Icons 
To move plug-in icons in your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Click the plug-in’s icon to select it. A blue border appears to let you know that it is selected (see 
Figure 27). 

 

Figure 27: Video plug-in icon (when selected) 

3. Once the plug-in is selected, drag and drop it to your desired location.  
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4. To save your work, click File > Save Book. 

2.9 Editing a Plug-in's Title Text, Descriptions, and Alternative Text 
To change a plug-in’s title text, description, or alternative text: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Click the plug-in’s icon or hyperlink to select it. If you have selected an icon, a blue border 
appears. If you have selected a hyperlink, an orange border appears. 

3. Once the plug-in is selected, the Properties Panel displays the plug-in’s Title, Description, and 
Alternative Text (see Figure 28). Edit these fields as needed. 

 

Figure 28: Editing options in the Video panel 
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4. To save your work, click File > Save Book. 

2.10 Replacing a Plug-in’s Media File 
To replace a plug-in’s media file: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Click the plug-in’s icon or hyperlink to select it. If you have selected an icon, a blue border 
appears. If you have selected a hyperlink, an orange border appears. 

3. Once the plug-in is selected, the Properties Panel on the right side of the screen displays the 
plug-in's properties (see Figure 28). Click the Replace button.  

4. A dialog box appears asking you to select the file that you want to add. Navigate to the folder 
where your file is saved and click Open. The plug-in icon appears on the page.  

5. To save your work, click File > Save Book. 

2.11 Deleting Plug-ins  
To delete plug-ins from your Kindle textbook: 

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. 
Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The 
book is displayed. 

2. Click the plug-in’s icon or hyperlink to select it. (To select multiple plug-ins, SHIFT + click on each 
plug-in.) If you have selected an icon, a blue border appears. If you have selected a hyperlink, an 
orange border appears. 

3. To remove the plug-in(s), select Edit > Delete or right-click the icon and select Delete Plugin. 
4. To save your work, click File > Save Book. 
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3 Publishing Your Textbook  

3.1 Previewing Your Book  
When you have finished making changes to your book, Amazon recommends that you preview it to see 
how it will look on Kindle devices.  

To preview your book:  

1. Select the Preview button at the top-right of the screen. The Previewer and Inspector windows 
are displayed (see Figure 29). 

 

Figure 29: Previewer and Inspector windows 
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2. Page through your book and review it. In the Inspector window, you can:  
• Use the Device tab to change the orientation, zoom level, and/or device. You can also 

navigate through the pages of your book. 
• Use the TOC tab to view and/or navigate your textbook’s table of contents file.  

3. When you have finished previewing your book, click the Close button in the upper-right corner 
of the Previewer window.  

3.2 Exporting Your Book  
After you have previewed your book (see Section 3.1) and confirmed that you are satisfied with the 
quality, the next step is to export it. 

To export your book:  

1. Click File > Package for Publishing. The Package Book dialog box appears (see Figure 30). 

 

Figure 30: Package Book dialog box 

2. Navigate to the location on your hard drive where you want to save your book and then click 
Save. A confirmation message is displayed. Click OK.  Your book is saved as a .kpf file that you 
can upload to KDP. 

3.3 Uploading Your Book to KDP 
After your book is previewed (see Section 3.1) and exported (see Section 3.2), you are ready to upload it 
to KDP and make it available to Kindle customers. 

NOTE: Books created with Kindle Textbook Creator can only be uploaded to KDP; they cannot be 
uploaded to Amazon Vendor Central at this time. 

If you want to update a Kindle book that was created with Kindle Textbook Creator on KDP, you can use 
Upload Your Book File to update that book on your KDP bookshelf. However, if you want to update a 
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Kindle book that was not created with Kindle Textbook Creator, you must use Add new title to create 
and submit a new book on your KDP bookshelf instead. 

To upload your book: 

1. Visit the KDP website at https://kdp.amazon.com/ or select Help > Visit the Kindle Direct 
Publishing Website. The KDP website opens in a browser window (see Figure 31). 

 

Figure 31: KDP website 

2. To sign in to the KDP website: 
• If you have an Amazon account, click the Sign in button to go to the Sign in page. Enter 

your email address and password, and then click the Sign in using our secure server 
button. 

• If you do not have an Amazon account, click the Sign up button to go to the Sign in 
page.  Enter your email address, select the I am a new customer button, and then click 
the Sign in using our secure server button. On the Registration page, enter your name, 
email address, and password, and then click the Create account button. 

3. The KDP Bookshelf page is displayed in your browser. Click the Create new title button. The 
Your book page is displayed.  

4. Enter the information about your book in the fields on this page. All fields are required unless 
they are marked (optional). 

https://kdp.amazon.com/
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5. Under Upload Your Book File, click the Browse button (see Figure 32).  The Open dialog box is 
displayed.  

 

Figure 32: Browse button 

 

6. Navigate to the location where you saved your .kpf file, select the file, and then click Open. You 
will get a message that the book is processing. 

7. When your book is successfully uploaded to KDP, the Preview book button is displayed (see 
Figure 33). Click the Preview book button and page through the book to confirm that you are 
satisfied with the conversion.  

 

Figure 33: Preview book button 

8. When you have finished previewing your book, click the Book Details button in the upper-left 
corner (see Figure 34) to return to the previous page. 
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Figure 34: Book Details button 

9. When you have completed all of the fields on the Your book page, click the Save and Continue 
button. The Rights & Pricing page is displayed. 

10. Answer the questions on the Rights & Pricing page. At the bottom of the page, read the terms 
and conditions, click the box to acknowledge, and then click the Save and Publish button. If you 
need to complete any further steps to publish your book, such as providing account information, 
the KDP website will prompt you. Otherwise, a success message is displayed. 
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