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Notice 
1. All information included in this document is current as of the date this document is issued. Such information, however, is 

subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please 
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to 
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website. 

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights 
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.  
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights 
of Renesas Electronics or others. 

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part. 
4. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of 

semiconductor products and application examples.  You are fully responsible for the incorporation of these circuits, software, 
and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by 
you or third parties arising from the use of these circuits, software, or information. 

5. When exporting the products or technology described in this document, you should comply with the applicable export control 
laws and regulations and follow the procedures required by such laws and regulations.  You should not use Renesas 
Electronics products or the technology described in this document for any purpose relating to military applications or use by 
the military, including but not limited to the development of weapons of mass destruction.  Renesas Electronics products and 
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited 
under any applicable domestic or foreign laws or regulations. 

6. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics 
does not warrant that such information is error free.  Renesas Electronics assumes no liability whatsoever for any damages 
incurred by you resulting from errors in or omissions from the information included herein. 

7. Renesas Electronics products are classified according to the following three quality grades:  “Standard”, “High Quality”, and 
“Specific”.  The recommended applications for each Renesas Electronics product depends on the product’s quality grade, as 
indicated below.  You must check the quality grade of each Renesas Electronics product before using it in a particular 
application.  You may not use any Renesas Electronics product for any application categorized as “Specific” without the prior 
written consent of Renesas Electronics.  Further, you may not use any Renesas Electronics product for any application for 
which it is not intended without the prior written consent of Renesas Electronics.  Renesas Electronics shall not be in any way 
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an 
application categorized as “Specific” or for which the product is not intended where you have failed to obtain the prior written 
consent of Renesas Electronics.  The quality grade of each Renesas Electronics product is “Standard” unless otherwise 
expressly specified in a Renesas Electronics data sheets or data books, etc. 

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual 
equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots. 

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support. 

“Specific”:  Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or 
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or healthcare 
intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life. 

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, 
especially with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation 
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or 
damages arising out of the use of Renesas Electronics products beyond such specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have 
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further, 
Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to 
guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a 
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire 
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because 
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system 
manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental 
compatibility of each Renesas Electronics product.  Please use Renesas Electronics products in compliance with all applicable 
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS 
Directive.  Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with 
applicable laws and regulations. 

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas 
Electronics. 

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this 
document or Renesas Electronics products, or if you have any other inquiries. 

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-
owned subsidiaries. 

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 
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Compiler Package 
Call Walker 

This document explains usage and notes of the "Call Walker".  The Call Walker is a 
stack information analysis tool bundled to Renesas Compiler Package (for SuperH, 
H8, M16C, R8C, and RX families). 
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Call Walker reads the stack information files (*.sni) that are output by the linkage editor or the profile information files 
(*.pro) that are output by the simulator debugger (for the SuperH, H8, or RX family only). Call Walker also displays 
the sizes of the stacks that are used statically. 

Although the sizes of the stacks used by assembly language programs cannot be output to stack information files, you 
can add the information by using the editing feature and obtain the sizes of the stacks used in the entire system. 

Once you edit information about the sizes of the used stacks, you can save the modified information in a call 
information file (*.cal) or read the modified information from the file. 

You can also merge multiple call information files. 

 

1. Creating a Stack Information File 
 

1.1 When the SuperH, H8, or RX Family Compiler is in Use 
Follow the procedure below to create a stack information file or a profile information file. 

 
• How to create a stack information file (*.sni) 
To create a stack information file, select the following option in the Link/Library page. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this dialog box: Choose the Link/Library tab.  
Then select Other in the Category list and select  
Stack information output in the Miscellaneous options list. 
Command line: STACk 
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• How to create a profile information file (*.pro) 
Use the profile feature to execute a desired user program. 

When you complete executing the user program, right-click on the Profile window to save the profile information and 
create a profile information file (*.pro). 

For details about how to create profile information, see section, Viewing the Profile Information, in the 
Simulator/Debugger User's Manual. 

 
Profile window: 

[View] -> [Performance] -> [Profile] 
 

 

 

 

 

 

 

 

 

 

 

 

 

1.2 When the M16C or R8C Family Compiler is in Use 
If you build and link by High-performance Embedded Workshop, the stack information file (*.sni) is always created 
without any setting. However, when compiling, you should specify -finfo option. If -finfo option is not specified, the 
stack information file cannot have necessary information. 

If you build and link without High-performance Embedded Workshop, you should use gensni which is the tool 
generating a stack information file. You can execute gensni by command prompt in Windows. gensni inputs the 
absolute module file (*.x30), and outputs the stack information file. 

 
Example: Creating stack information file (test.sni) from absolute module file (test.x30) 

>gensni test.x30 
 

Notes: 1. When the M16C or R8C family compiler is in use, you can not use a profile information file. 
 2. The version of each products that can use Call Walker is as follows. 

・ C Compiler Package for M16C Series and R8C Family [M3T-NC30WA]:    V.5.42 Release 00 or later 
・ C Compiler Package for M32C Series [M3T-NC308WA]:    V.5.41 Release 00 or later 
・ C Compiler Package for R32C Series:    Any version can be used. 
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2. Starting Call Walker 
You can start Call Walker in two ways. 

• From the [Start] menu 
Choose Programs -> [Renesas High-performance Embedded Workshop] -> [Call Walker]. 

• From High-performance Embedded Workshop 
Choose [Tools] -> [Renesas Call Walker]. 

 
Note: When the M16C or R8C family compiler is in use, the path to Call Walker in the start menu is as follows. 

Programs -> [Renesas] -> Package name -> [Call Walker] 
 

3. Call Walker Window and Opening a File 
When you start Call Walker, you open a desired stack information file (*.sni) or profile information file (*.pro) by 
choosing [File] -> [Import Stack File...]. 

You choose [File] -> [Open...] to open an existing edited file (*.cal). 

When you open a file, the following window appears. 

 

Note: When the SuperH or H8 family compiler is in use, the stack size for assembler functions other than those in the 
standard library is shown as 0. See section 4, Editing Stack Information and set the appropriate stack size. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Menu bar Title bar Tool bar

Symbol details 
View 

Statesbar 
Left comer  :  The explanation indication of each function
Center frame  :  CPU information in dication 
Right corner  :  Symbol reference information 

Call information 
View 
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• Call information view 

This view shows the link hierarchy of the symbols. 
The number on the right of each symbol name indicates the required stack size.  

 

(1)  Details about the symbols 
The icon on the left of each symbol name indicates the type of the symbol.  
The following types are available: 

 

          File being edited 

 

          Assembler 

 

          C/C++ function 

 

          Direct or indirect recursive functions 

     (a)  Direct recursive function 
      This icon indicates that the indicated function directly calls itself. 

      [Example] 

 

 

 

 

 

 

  (b)  Indirect recursive function 
      This icon also indicates that the indicated function indirectly calls itself. 

      [Example] 

 

 

 

 

 

 

           RTOS function (symbol for an RTOS such as ITRON) 
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           Unknown reference source function 

      In the following example, the func1() function calls the Undef() function. However,  
      if the Undef() function really does not exist, this icon is displayed for the Undef() function. 
      Calling a non-existing function results in a linkage error. However, by using the change_ 
      message link option, you can change error messages to warning messages.  
      You can create load modules even if warning messages exist. Therefore, you can create  
      stack information files as well. 

      [Example] 

 

 

 

           Function with unresolved reference address 

      This icon is displayed when the indicated function is called from a table as shown below. 

      [Example] 

 

 

 
 
 
           Abbreviation icon 

     This tool displays all the link levels. If the user application is large, the number of  
     link levels to be displayed is enormous.  
     Therefore, only the first symbols are displayed and other same symbols are abbreviated  
     using the abbreviation icon. 
     To show all the symbols, choose [View] -> [Show All Symbols]. 
     To show part of the symbols, choose [View] -> [Show Simple Symbols]. 

      [Example] 

 

 

 

 

 

           RTOS handler 

 

           RTOS task function 

 

           Variadic function 

Show All Symbols Show Simple Symbols 
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• Detailed symbol view 

 

 

 

 

 

 

 

 

 

This view shows the address, attributes, stack size, and other details about each symbol.  
Click a symbol and then right-click to execute editing commands. 

 

• Status bar 

 

 

The status bar shows the CPU type and other information about the stack information file (at the time of creation) that 
is currently open. 

 

• Maximum stack size 

 

 

"Max" indicates the maximum size of the statically-used stack in the currently open stack information file. 

 

• Standard library version selection (for the SuperH or H8 family compiler) 

 

 

Select the standard library version that is used when you create the currently open stack information file. 

The stack size used by the assembler functions in the standard library is determined by the version of the standard 
library. 

 

Note: You do not need to select any version when the M16C, R8C, or RX family compiler is in use. Any selection 
doesn't influence. 
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4. Editing Stack Information 
While a file is open, you can select a desired symbol name from the detailed symbol view on the right to add, change, 
or delete the symbol using the Add..., Modify..., or Delete... command in the Edit menu. 

You can also perform the same operations by right-clicking in the detailed symbol view. 

Although this tool calculates the maximum size of the statically-used stack, the user needs to edit the information file to 
determine the maximum size of the dynamically-used stack due to multiple interrupts and other reasons. 

You can change the positions of symbols by dragging and dropping the desired symbol in the call information view on 
the left. 

When you move or edit a symbol, a check mark appears next to the corresponding symbol in the call information view 
in the left.  

 

 

 

 

 

 

 

 

The following sections describe the available commands. 
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• Add... command 

(1)  Adding an existing symbol 
When you click the Add... command, the following dialog box appears. The list on the right shows the symbols in the 
current file. To add an existing symbol, select a desired symbol from the list and click the OK button. 

 

 

 

 

 

 

 

 

 

 

 

 

(2)  Adding a new symbol 
When you select the New symbol check box on the left, you can create a new symbol. 
At the same time, you can define the symbol name, symbol category, attributes, address, stack size, and other details. 

 

 

 

 

 

 

 

 

 

 

 

Available 
symbol list 
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• Modify... command 

Select the symbol whose information you want to change and click the Modify... command. The following dialog box 
appears. You can modify several information items. 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

• Delete... command 

To delete the symbols that are unnecessary for determining the stack size, select such a symbol (in the left or right 
view) and click the Delete... command. 

Symbol 
name 

Symbol 
categor

Address 

Functio
n size 

Stack 
size 

Symbol 
attributes 

Object 
file name 
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5. Stack Area Size of Assembly Program 
The content of this chapter is for SuperH, H8, and RX family compilers. This content cannot be applied for the M16C 
or R8C family compiler. 

Unlike by C/C++ program, the stack area size used by assembly program cannot be calculated automatically in 
assembling. Therefore the stack area size used by assembly functions should be edited by using Call Walker. 
But the stack area size is specified in the assembly function by using .STACK directive. Call Walker displays the value 
specified by .STACK directive. 

 
• Description of .STACK directive 

Defines the stack amount for a specified symbol referenced by using Call Walker. 

The stack value for a symbol can be defined only one time; the second and later specifications for the same symbol are 
ignored. A multiple of 2 in the range from H'00000000 to H'FFFFFFFE can be specified for the stack value, and any 
other value is invalid. 

The stack value must be specified as follows: 
・ A constant value must be specified. 
・ Forward reference symbol, external reference symbol and relative address symbol must not be used. 

 
• Specification Method of .STACK assembler directive 

  .STACK <symbol> = <stack value> 
 
• Example of assembly program 

 

 

 

 

 

 

 

Displayed Example by Call Walker 
As the following example, the stack area size used by _asm_symbol function is displayed 88 in Call Walker. 

 

 

 

 

 

• Notes 

(1) .STACK assembler directive can only make Call Walker display stack size, and does NOT affect the behavior of 
program. 

(2) This assembler directive is supported by SuperH RISC engine Assembler Ver.7.00, H8S, H8/300 Series Assembler 
Ver.6.01, RX Family Assembler V.1.00 Release 00, and later versions. 

    .EXPORT     _asm_symbol 
    .SECTION    P,CODE,ALIGN=4 
_asm_symbol: 
    .STACK      _asm_symbol=88 
      : 
    RTS 
    NOP 
    .END 

( Stack Size of the _asm_symbol function is 88
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6. Merging Stack Information 
You can merge a stack information file that is saved or being edited with another stack information file. 

By doing so, the edited stack information is not overwritten by the post-build stack information. 

 

• Merge example 

(1)  Contents of test.c 
 

 

 

(2)  Open a stack information file from Call Walker. 
 

 

 

 

(3)  Change the contents of the file (change the stack size of func1 to 100). 
 

 

 

 

(4)  Change the contents of test.c and perform build (add a call for func2). 
 

 

 

 

(5)  Open test.sni while test.cal is open in Call Walker. 
Select here and choose the Open button. 
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(6)  The information of func2 is added while keeping the stack size of func1 changed in step (3). This is merging of 
stack information. 

 

 

 

 

If you do not select the Merge specified file check box in step (5), the stack size of func1 changed in step (3) returns to 
the previous value. 

 

 

 

 

• Detailed merge options 

You can change the method of merging. Five methods are available. 
For details about merge methods, read Description in the following dialog box. 

 

To select this feature: 
[Tools] -> [Merge Option...] 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Note 

The merge feature is available in Call Walker version 1.3 or later. 
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7. Other Features 
• Output of a list 
Stack information can be output to a text file. 

 
To select this feature: 

[Edit] -> [Output List...] 
 

• Search feature 
You can find the following two items from the call information view by specifying the desired target in the following 
dialog box. 

 

 

 

 

 

 

(1)  Pass with the maximum stack size 
(2)  Symbol name 
 
To select this feature: 

[Edit] -> [Find...] 
[Edit] -> [Find Next...] (find the next item) 
[Edit] -> [Find Previous...] (find the previous item) 

 

• Setting the display format for the call information view 
You can use the following two commands to select the format for displaying stack sizes: 

(1)  Show Required Stack 
The largest stack size is shown at the top and the smallest stack size is shown at the bottom. 

(2)  Show Used Stack 
The smallest stack size is shown at the top and the largest stack size is shown at the bottom. 

 
To select this feature: 

[View] -> [Show Required Stack] or [Show Used Stack] 
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• Specifying the expansion level of symbols in the call information view 
You can select either of the following two options to determine the expansion level for the child symbols of the selected 
symbol. 

 

 

 

 

 

(1)  Expansion Level 
The child symbols will be expanded up to the specified level. 

(2)  Expand All 
All child symbols of the selected symbol will be expanded. 

 
To select this feature: 

[View] -> [Expand…] 
 
Note: Specifying the expansion level of symbols in the call information view is available with Call Walker Ver.2.00 

or later. 
 

• Specifying the amount of stack usage by the user library 
This feature replaces the current stack sizes of symbols with those in the specified stack-information file being loaded 
and updates the display. The following dialog box allows you to specify a user-library stack-information file and the 
amount of stack usage. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To select this feature: 
[Tool] -> [User Library Options…] 

 
Note: Specifying the amount of stack usage by the user library is available with Call Walker Ver.2.00 or later. 
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Website and Support 
Renesas Technology Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/inquiry 
csc@renesas.com 
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Rev. 
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New features of Call Walker Ver.2.00 added 
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1. This document is provided for reference purposes only so that Renesas customers may select the appropriate 
Renesas products for their use. Renesas neither makes warranties or representations with respect to the 
accuracy or completeness of the information contained in this document nor grants any license to any  intellectual 
property rights or any other rights of Renesas or any third party with respect to the information in  this document. 

2. Renesas shall have no liability  for damages or infringement of any intellectual property or other rights arising  out 
of the use of any information in this document, including, but not limited to, product data, diagrams, charts,  
programs, algorithms, and application circuit examples.

3. You should not use the products or the technology described in this document for the purpose of military 
applications such as the development of weapons of mass destruction or for the purpose of any other military  
use. When exporting the products or technology described herein, you should follow the applicable export  
control laws and regulations, and procedures required by such laws and regulations.

4. All information included in this document such as product data, diagrams, charts, programs, algorithms, and  
application circuit examples, is current as of the date this document is issued. Such information, however,  is  
subject to change without any prior notice. Before purchasing or using any Renesas products listed in this  
document, please confirm the latest product information  with a Renesas sales office. Also, please pay regular  
and careful attention to additional and different information to be disclosed by Renesas such as that disclosed  
through our website. (http://www.renesas.com)

5. Renesas has used reasonable care in compiling the information included in this document, but Renesas  
assumes no liability whatsoever for any damages incurred as a result of errors or omissions in the information  
included in this document.

6. When using or otherwise relying on the information in this document, you should evaluate the information in  light 
of the total system before deciding about the applicability of such information to the intended application. 
Renesas makes no representations, warranties or guaranties regarding the suitability of its products for any  
particular application and specifically disclaims any liability arising out of the application and use of the  
information in this document or Renesas products.

7. With the exception of products specified by Renesas as suitable for automobile applications, Renesas  products 
are not designed, manufactured or tested for applications or otherwise in systems the failure or  malfunction of 
which may cause a direct threat to human life or create a risk of human injury or which require  especially high 
quality and reliability such as safety systems, or equipment or systems for transportation and  traffic, healthcare, 
combustion control, aerospace and aeronautics, nuclear power, or undersea communication  transmission. If you 
are considering the use of our products for such purposes, please contact a Renesas  sales office beforehand. 
Renesas shall have no liability for damages arising out of the uses set forth above.

8. Notwithstanding the preceding paragraph, you should not use Renesas products for the purposes listed below:
  (1) artificial life support devices or systems
  (2) surgical implantations
  (3) healthcare intervention (e.g., excision, administration of medication, etc.)
  (4) any other purposes that pose a direct threat to human life
 Renesas shall have no liability for damages arising out of the uses set forth in the above and purchasers who 

elect to use Renesas products in any of the foregoing applications shall indemnify and hold harmless Renesas  
Technology Corp., its affiliated companies and their officers, directors, and employees against any and all  
damages arising out of such applications.

9. You should use the products described herein within the range specified by Renesas, especially with respect  to 
the maximum rating, operating supply voltage range, movement power voltage range, heat radiation  
characteristics, installation and other product characteristics. Renesas shall have no liability for malfunctions or  
damages arising out of the use of Renesas products beyond such specified ranges.

10. Although Renesas endeavors to improve the quality and reliability of its products, IC products have specific  
characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use  conditions. 
Please be sure to implement safety measures to guard against the possibility of physical injury, and  injury or 
damage caused by fire in the event of the failure of a Renesas product, such as safety design for  hardware and 
software including but not limited to redundancy, fire control and malfunction prevention,  appropriate treatment 
for aging degradation or any other applicable measures.  Among others, since the  evaluation of microcomputer 
software alone is very difficult, please evaluate the safety of the final products or system manufactured by you.

11. In case Renesas products listed in this document are detached from the products to which the Renesas  products 
are attached or affixed, the risk of accident such as swallowing by infants and small children is very  high. You 
should implement safety measures so that Renesas products may not be easily detached from your  products. 
Renesas shall have no liability for damages arising out of such detachment.

12. This document may not be reproduced or duplicated, in any form, in  whole or in part, without prior written  
approval from Renesas.

13. Please contact a Renesas sales office if you have any questions regarding the information contained in this 
document, Renesas semiconductor products, or if you have any other inquiries.

Notes regarding these materials
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