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USER MANUAL 

MODEL 429 

DIAGNOSTIC AND MAINTENANCE  

INFORMATION TRANSFER SYSTEM 

(DMITS) 

 
 
 
1.0 INTRODUCTION 
 

This document is the User Manual for the Model 429 Diagnostic and 
Maintenance Information Transfer System (DMITS) maintenance software for 
the versions identified below: 
 
• Setup P/N 429-770-014-103, version 1.0 
• Executable P/N 429-770-014-109, version 1.0 

 
1.1 DOCUMENT CONVENTIONS 

 
The following formatting conventions are used in this document to facilitate 
readability and to help associate software screen features to the descriptive 
text contained herein. 
 
 
TYPE FORMAT 
Software screen options, messages, 
buttons, field names, etc 

bold lettering 

Document Caution callout and text CENTERED BOLD ALL CAPS LETTERING 
Document Note callout Centered underlined lettering
Document Note text Centered lettering 
Document cross reference links blue underlined lettering
Software folder and subfolder listings blue lettering 
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2.0 SYSTEM OVERVIEW 
 

The DMITS software provides a GUI for calibrating, uploading and 
downloading maintenance information from the Integrated Avionics System 
(IAS). The DMITS provides interfaces to the following systems of the IAS: 
Display Unit (DU), Aircraft Data Interface Unit (ADIU), Flight Control 
Computer (FCC) and the Lighting Power Supply (LPS). 
 
The DMITS software will be installed on a laptop computer running under XP 
or Vista. The laptop connects to the aircraft’s Ground Service Equipment 
(GSE) ports via a GSE switch box, using either the RS-232 or the USB port. 

 
2.1 INSTALLING THE MAINTENANCE PACKAGE 

 
The 429 maintenance package consists of the following parts: 
 

• GSE Switch Box (P/N DK-504-001-1) 

• GSE Harnesses (P/N 429-079-554-101/-103) 

• USB A/A Extension (P/N USB2-AA-6) 

• DMITS CD-ROM (P/N 429-770-014-101); contains: 

• DMITS429 Setup (P/N 429-770-014-103, v1.0) 

• DMITS429 User Manual (P/N 429-770-014-105) 
 

2.1.1 DMITS SOFTWARE 
 
The DMITS application is installed by a self installer software tool by 
executing the DMITS429 setup file. The DMITS software package consists of 
the following: 
 

• DMITS429 Executable (P/N 429-770-014-109, v1.0) 

• DMITS429 User Manual (P/N 429-770-014-105) 

• Electronic Data Recorder (EDR) data masks examples 

• Software Drivers and Installation Manual for the EDGEPORT/1, RS-
232/USB converter 
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To launch the setup, on the installation CD double click on the setup file (for 
Windows XP) or right click on the setup file and select Run as administrator 
(for Windows Vista): 
 

 
 
then follow the steps as explained in the following figures: 
 

Step #1 

 
This is the introduction screen. Press the  

Next > button to continue to the next step. 

Step #2 

This is the license agreement screen. 
Review the licensing agreement; check the 
I accept the agreement button to accept 
the license terms, then press the Next > 

button to continue to the next step. 
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Step #3 

 
This is the installation location screen. To 

modify default path, type the desired path or use 
the Browse button to choose an existing path. 

Once the desired path is entered, click the Next 
> button to continue to the next step or the < 

Back button to return to the last step. 

Step #3.1 

This message box will appear only if the 
installation path the user selected already 

exists. If the user is reinstalling a new 
release of the application over an old 

release, the user should select Yes, if not; 
he should make sure the folder is the 

desired installation path. Selecting No will 
return the user to Step #3. 

Step #4 

 
This is the Start Menu Folder screen. To modify 
the default program group folder, type the folder 
name or use the Browse button to choose an 
existing group folder. Once the desired folder 

group is entered, click the  
Next > button to continue to the next step or the 

< Back button to return to the last step. 

Step #5 

This is the Desktop Shortcut screen. To 
create a desktop shortcut, check the 

Create a Desktop Shortcut checkbox and 
select one of the shortcut creation options. 

Un-checking the shortcut box will forgo 
shortcut creation. Once the desired shortcut 

options are set, click the Next > button to 
continue to the next step or the < Back 

button to return to the last step. 
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 Step #6 

 
This is the Installation Confirmation screen. An 

overview of the selected user options is 
displayed for confirmation. If the options are 

satisfactory, proceed with installation by 
selecting the Install button. If changes need to 
be made, use the < Back button to return to the 

previous screen. 

Step #6.1 

This is the installation progress screen. The 
blue progress tracks installation progress. 
The Confirm message box will appear if 

the installer detects a file of different 
version in the installation folder; a file of the 
same version will be overwritten. User will 
click Yes to overwrite the file or No to keep 

the existing file. 

Step #7 

 
This is the installation complete screen. Press 

Finish to exit the installer. If the View 
DMITS429 User Manual (429-770-014-105).pdf 
checkbox is checked, the installer will open the 
User Manual file. If the Run DMITS429 (429-

770-014-109,1.0).exe checkbox is checked, the 
installer will launch the application prior to 

terminating. 

 

 

 

 

 

 

 

 

Note: 

The {root} directory specified herein 
refers to the installation directory 

selected in Step #3 of this section. 
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Installation can be aborted at any time by selecting the Cancel button; the 
following screen will be displayed: 
 

 
 
Choosing Yes will exit the installer. Selecting the No button will return the 
user to the previous screen. 
 
In addition to installing the DMITS package in the user selected directory, the 
installer also performs the following tasks: 
 

• Verifies if the operating system is XP or later; if not, installation is aborted. 

• Creates an uninstall script  file and places it in the application directory 

• Creates a Start menu group with containing a shortcut to the application 
executable and one to the uninstall script file. 

• Creates a desktop shortcut to the application executable (if selected in 
installation options) 

• Creates the DMITS folder structure 

• Creates an application registry key containing the installation path. 

• Creates the registry framework to allow launching of the DMITS software 
from the RUN command box (located in the Windows Start menu). 

• Installs the software drivers and installation manual for the EDGEPORT/1  
RS-232/USB converter. 
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CAUTION 

ONCE THE APPLICATION IS INSTALLED 
THROUGH THE INSTALLER, USER MUST NOT 
MANUALLY MODIFY THE PATH TO THE 
INSTALLATION DIRECTORY OR MODIFY THE 
SOFTWARE PACKAGE FILENAMES. IT IS 
SUGGESTED TO FIRST UNINSTALL THE 
APPLICATION PER SECTION 2.2.1 AND THEN 
RUN THE INSTALLER AGAIN AND SELECT THE 
DESIRED PATH THROUGH THE INSTALLER. 
FILES NOT PART OF THE INSTALLATION 
PROCESS WILL BE RETAINED IN THE OLD 
INSTALLATION DIRECTORY, THEY SHOULD BE 
MANUALLY MOVED TO THE NEW INSTALLATION 
DIRECTORY OR DELETED IF NOT NEEDED. 
ADVANCED USERS MAY AVOID REINSTALLING 
THE APPLICATION BUT WILL HAVE TO 
MANUALLY EDIT THE CREATED SHORCUT 
TARGETS AND MODIFY THE FOLLOWING 
REGISTRY KEYS TO REFLECT THE CHANGES: 

 
HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOF

T\WINDOWS\CURRENTVERSION\APP 
PATHS\DMITS429.EXE\(DEFAULT) 

 
HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOF

T\WINDOWS\CURRENTVERSION\APP 
PATHS\DMITS429.EXE\PATH 

 
HKEY_LOCAL_MACHINE\SOFTWARE\DMITS429\ 

INSTALL_DIR 
 

HKEY_CLASSES_ROOT\DMITS429.FILES\DEFAUL
TICON 
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2.1.2 USB/RS-232 Converter 

 
The USB/RS-232 converter lets the user use the laptop’s USB ports for 
connecting to GSE switch box rather than using the serial ports. To install the 
USB/RS-232 converter, follow the steps as explained in the following figures: 
 

Step #1 
Connect one end of the USB extension cable 

in an available USB port on the laptop, and the 
other end to the USB wall mount connector of 

the GSE switch box. 

 

 
In the Windows notification area, Found New 
Hardware is displayed and the New Hardware 

Wizard is displayed. 

Step #2 

 
On the New Hardware Wizard, check the 

No, not this time radio button and click the 
Next > button. 
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Step #3 

 
On the Install mode selection screen, check 
the Install from a list or specific location 

(Advanced) radio button and click the Next > 
button. 

Step #4 

 
On the Install Options selection screen, check 

the Search for the best driver in these 
locations radio button, uncheck the Search 

removable media (floppy, CD-ROM…) 
checkbox and check the Include this location 

in the search: checkbox. Use the Browse 
button and locate the {root}\EDGEPORT 

Drivers\Win2k\ folder. Press Next > when ready.

Step #5 

 
The installer will search for the appropriate 

hardware installation files. Edgeport/1 should 
be displayed in the window. 

Step #5.1 

 
Once located, the installer will automatically 

proceed to the installation. Installation progress 
is displayed in the window. 
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Step #6 

 
When installation is completed, the status 

screen will be displayed. Ensure installation is 
successful, then click the Finish button. 

Step #7 

 
Depending on past installations, in the Windows 

notification area, a Found New Hardware 
message may be displayed and the New 

Hardware dialog box may be displayed. If such 
a message is displayed, continue with the 

following steps, if not, the installation is 
complete. 

 

Step #8 

 
Repeat steps #2, #3, and #4. 

Step #9 

 
The installer will search for the appropriate 

hardware installation files.  
Edgeport Serial Port_1 [actual serial #] 

should be displayed in the window. 
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Step #9.1 

 
Once located, the installer will automatically 

proceed to the installation. 

Step #10 

 
When installation is completed, the status 

screen will be displayed. Ensure installation is 
successful, then click the Finish button. 

 
2.2 UNINSTALLING THE SOFTWARE 
 
2.2.1 DMITS Software 

 
When the software package is installed through the installer, an uninstall 
script file (unins000.exe) is created. The script is placed in the {root}\uninst\ 
folder. A shortcut to the uninstall (Uninstall DMITS429) script file is also 
created in the start menu group. To uninstall the DMITS application, double 
click the uninstall script file (for Windows XP) or right click on the uninstall 
script file and select Run as administrator (for Windows Vista): 

 
 
or click the uninstall script shortcut (for Windows XP) or right click on the 
uninstall script shortcut and select Run as administrator (for Windows Vista) 
in the appropriate start menu group: 
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or use the Add or Remove Programs (for Windows XP) or Program and 
Features (for Windows Vista) application from the Windows Control Panel: 

 

 
 
All files installed by the installer will be deleted at uninstall. If no other files 
were created in the application directory, the folder will also be deleted. Files 
not part of the initial DMITS software package installation will not be deleted 
and will remain in the application folder after uninstall. 
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2.2.2 USB/RS-232 Converter 
 

To uninstall the USB/RS-232 converter, follow the steps as explained in the 
following figures: 

 

Step #1 

 

From the Run line command utility 
(located in the Windows Start Menu), 

type edgeport and press the OK 
button. 

Step #2 

 
 

From the Edgeport Properties application, 
select the Advanced tab. Check the  

Based on converter serial number. (Default) 
radio button and press the Uninstall button. 
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Step #3 

 

A confirmation message box appears; press 
the Yes button to continue with the uninstall 

process. 

 

Step #4 

 
 

The uninstall screen is displayed with green 
status arrows representing successful un-

installation tasks. Ensure all tasks are 
successful, then press Yes to reboot the laptop. 
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2.3 MICROSOFT WINDOWS AND LAPTOP SETTINGS 

 
The following Microsoft Windows and laptop PC settings are recommended 
for proper operation of the maintenance application: 
 

• Users should be logged in as administrator on the laptop 

• For Windows Vista users, always run the application as the administrator 
(right click and select Run as administrator) when User Account Control 
(UAC) is enabled  

• Alternatively, Windows Vista users may elect to turn off UAC to avoid the 
need to right click to run the application. To turn off UAC: from the Control 
Panel, select Classic View, open the User Accounts screen, select the 
Turn User Account Control on or off option, uncheck the Use User 
Account Control (UAC) to help protect your computer box then press 
the OK button 

• Laptop screen savers should be set to more than five minutes 

• Any laptop PC power or battery saving features should be disabled 

• Select a screen resolution of a least 1024 by 768 pixels using one of the 
laptop’s native screen sizes 

• The printer used should be of the post-script type 
Refer to the Microsoft Windows User’s Guide and laptop PC user 
documentation. 
 

2.4 GENERAL GUIDELINES 
 
The various screens (windows) that are shown for this tool are designed to 
keep the standard philosophy of all programs developed in the Windows 
environment, and to ensure a maximum of security in the user’s actions. 
 

2.4.1 Running The DMITS Application 
 
There is four ways to launch the application. The first one is to open the 
installation folder and double click on the application icon (for Windows XP) or 
right click on the application icon and select Run as administrator (for 
Windows Vista): 

 



 
 
 
 
 
 
 
 
12,800 RUE DE L'AVENIR, MIRABEL, QUÉBEC J7J 1R4  

429-770-014-105
DMITS429 User Manual

 

16 

 
The second way is to double click the desktop shortcut (for Windows XP) or 
right click on the desktop shortcut and select Run as administrator (for 
Windows Vista). This will only be available if the desktop shortcut was created 
at installation time. 
 

 
 
The third way to start the application is by clicking the shortcut created in the 
start menu group (for Windows XP) or right click on the shortcut created in the 
start menu group and select Run as administrator (for Windows Vista): 
 

 

 
The fourth way is to use the Run line command utility located in the Windows 
Start Menu, using either of the following (case insensitive). For Windows 
Vista, ensure the This task will be created with administrative privileges 
message is displayed (UAC turned off, see section 2.3 for details); if not, 
select one of the other three launching methods. 
 

Windows XP Windows Vista 
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When the application is launched, it will appear without any configuration. 
 

 
 
Before maintenance operations may be carried out, the user will have to 
select a system and a communication port from the appropriate drop-down 
menus. Refer to section 3.0 for details on DMITS software operation. 
 

2.4.2 Dynamic Menus 
 
Menus within DMITS are dynamically configured to match the state of 
execution of the application. Menus and menu items are contextual and may 
be added/removed; this scheme informs the user of the selected system’s 
available maintenance functions. Menus and menu items may also be 
enabled/disabled; this scheme informs the user of possible/impossible options 
for the current execution state. 
 
System specific menu configuration occurs in the following menus: 
 

• The View horizontal drop down menu, located under the File drop down 
menu. 

• The Communication drop down menu. 

• The Upload File Editor horizontal drop down menu, located under the Tools 
drop down menu. 
 
The Select Port drop down menu is also dynamically populated to show the 
laptop’s available serial communication ports. 
 
More details on menus may be found in section 3.1. 
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2.4.3 Maintenance Files 
 
Maintenance files are stored in the application directory in a predefined folder 
structure. File extensions associated to maintenance functions are assigned 
at installation time. The following table lists the folder and file extension for 
each maintenance function. 
 

Functions 
View Upload Download Edit 

Storage Folder File 
Type 

√ √  √ {root}\DU\EDR Data Mask\ *.udm 

√ √  √ {root}\DU\Normal Checklist\ *.unc 

√ √  √ {root}\DU\Emergency 
Checklist\ 

*.uec 

√ √  √ {root}\DU\Programmable 
CAS\ 

*.upc 

√  √  {root}\DU\DU Faults\ *.ddf 

√  √  {root}\DU\EDR Data\ *.csv 

√ √ √ √ {root}\ADIU\Aircraft Data\ *.adf 

√  √  {root}\ADIU\ADIU Faults\ *.daf 

√  √  {root}\ADIU\Exceedances\ *.dex 

√  √  {root}\ADIU\Chip History\ *.dch 

√  √  {root}\ADIU\Aircraft Flight 
Log\ 

*.dal 

√  √  {root}\ADIU\Timers Counters\ *.dtc 

√  √  {root}\ADIU\Power 
Assurance\ 

*.dpa 

√ √ √ √ {root}\LPS\Dimming Table\ *.csv 

√  √  {root}\LPS\Fault Log\ *.dfl 

√  √  {root}\LPS\Status Data\ *.dsd 

√  √  {root}\LPS\Version Data\ *.dvd 

√  √  {root}\LPS\Table CRC\ *.dcr 

√  √  {root}\FCC\Faults & Events\ *.dfe 

√  √  {root}\FCC\Rigging Data\ *.drd 
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2.4.4 File Saving/Opening 

 
When running a maintenance function, the OPEN FILE and SAVE FILE dialog 
boxes will default to the maintenance functions predefined folder path. It is 
highly recommended that files be saved in their predefined folders as the 
OPEN FILE and SAVE FILE dialog boxes apply selective masking on file 
extensions; therefore, a misplaced file will not appear in the default folder of 
the OPEN/SAVE FILE dialog boxes. 
 

 
 
The example above depicts the SAVE FILE dialog box following a download 
of the ADIU Faults maintenance function. The dialog box defaults to the 
{root}\ADIU\ADIU Faults\ folder. The dialog box will masks all files that do not 
have the *.daf file extension. 
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The example above depicts the OPEN FILE dialog box following the selection 
of the View ADIU Faults function. The dialog box defaults to the 
{root}\ADIU\ADIU Faults\ folder. The dialog box will masks all files that do not 
have the *.daf file extension. 
 

2.4.5 Password Protection 
 
Sensitive maintenance functions are password protected. Password protected 
functions include: accessing the Normal/Emergency Checklist File Editor, 
accessing the Programmable CAS File Editor, uploading Programmable CAS 
files and clearing Programmable CAS non volatile memory. When one of 
these functions is selected, the password caption dialog box is displayed. 
User must enter the application’s password to access the function. Default 
password after installation is “admin” (without the brackets). 
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Password may be modified at any time by selecting the Tools -> Change 
Password menu item; the password change dialog box is displayed: 
 

 
 

To change the password, user must enter the old password in the Old 
Password: field then enter the desired password in both the New Password: 
and the Confirm New Password: fields. The password must contain 
between 4 and 15 characters. After successfully changing the password, a 
confirmation message box is displayed: 
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3.0 DMITS INTERFACE 
 
3.1 MENUS 

 
DMITS software relies on the main menu to let the user navigate the different 
available options. The basic main menu architecture includes 6 drop down 
menu selections: File, Select System, Select Port, Communication, Tools 
and Help: 
 

 

File: The File drop down menu regroups menu items related to 
file operations. This menu option is disabled if an I/O 
communication task is in progress. 

Select System: The Select System drop down menu regroups menu items 
related to system selection. This menu option is disabled if 
an I/O communication task is in progress. 

Select Port: The Select Port drop down menu regroups menu items 
related to communication setup. This menu option is 
disabled if an I/O communication task is in progress. 

Communication: The Communication drop down menu regroups 
communication functions. This menu option is disabled if 
an I/O communication task is in progress or if no 
communication port is selected. 

Tools: The Tools drop down menu regroups DMITS support 
tools. This menu option is always enabled. 

Help: The Help drop down menu regroups menu items related to 
user support. This menu option is always enabled. 

3.1.1 File Menu 
 
The File drop down menu regroups menu items related to file operations. 
Options within this drop down menu are dynamically configured to match the 
selected system’s maintenance functions (DU used in example). The File 
drop down menu contains 4 menu items, Save, Close, Print and Exit and 
may contain the optional View horizontal drop down menu depending on the 
selected system. 
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Save: Clicking this menu item will open the Save Dialog Box, which 
lets the user specify the drive, directory, and name of the file 
to save. This menu option is enabled if data was downloaded 
from a system download function and is presented in the 
viewing window (see section 3.3 for viewing window details). 

Close: Clicking this menu item will close the viewing window. This 
menu item is enabled if a data file was opened with the View 
horizontal drop down menu and is presented in the viewing 
window. 

Print: Clicking this menu item will open the Print Dialog Box, which 
lets the user specify the printer in order to print the data 
contained in the viewing window. This menu item is enabled if 
data is presented on the viewing window. 

Exit: Clicking this menu item will close the DMITS application. This 
menu item is always enabled. 

View: This optional horizontal drop down menu regroups menu items 
for opening and viewing maintenance function files. Options 
within this horizontal drop down menu are dynamically 
configured to match the selected system’s maintenance 
functions. Depending on the selected system, the View 
horizontal drop down menu may contains two horizontal drop 
down menus, Downloaded Files and Uploaded Files, which 
regroup the system’s maintenance functions menu items.  

Downloaded Files: This horizontal drop down menu regroups menu items 
related to opening and viewing downloaded maintenance 
functions files. Menu items within this horizontal drop 
down menu are dynamically configured to match the 
selected system’s download maintenance functions. 
Clicking one of these menu items lets the user specify 
the drive, directory, and name of the file to open and 
display on the viewing window. 
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Uploaded Files: This horizontal drop down menu regroups menu items 
related to opening and viewing uploaded maintenance 
functions files. Menu items within this horizontal drop 
down menu are dynamically configured to match the 
selected system’s upload functions. Clicking one of these 
menu items lets the user specify the drive, directory, and 
name of the file to open and display on the viewing 
window. 

 
3.1.2 Select System Menu 

 
The Select System drop down menu regroups menu items related to system 
selection. The Select System drop down menu contains 4 menu items: 
ADIU, DU, FCC and LPS. 
 

 
ADIU: Clicking this menu item will set ADIU as the selected system. The 

View horizontal drop down and the Communication drop down 
menus will be filled with menu items corresponding to ADIU 
functions. 

DU: Clicking this menu item will set DU as the selected system. The View 
horizontal drop down and the Communication drop down menus will 
be filled with menu items corresponding to DU functions. 

FCC: Clicking this menu item will set FCC as the selected system. The 
View horizontal drop down and the Communication drop down 
menus will be filled with menu items corresponding to FCC functions. 

LPS: Clicking this menu item will set LPS as the selected system. The 
View horizontal drop down and the Communication drop down 
menus will be filled with menu items corresponding to LPS functions. 

The selected system, if any, is indicated by a check mark next to the 
corresponding menu item and is also identified in the first status pane. 
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3.1.3 Select Port Menu 

 
The Select Port drop down menu regroups menu items related to 
communication setup. The Select Port drop down menu contains at least 2 
menu items: Close Port and Update Ports. The actual communication ports 
on the laptop are determined at runtime and dynamically added to the menu 
with the COMX notation; where X represents the OS defined port number. All 
communication ports are added to the menu, grayed options represents ports 
that are already in use by another application, they may not be selected. 
 

 
 

COMX: Clicking one of these menu items will open and configure the 
communication port for data transmission. These menu 
items are enabled if the communication port is not already in 
use when the port scan occurred. When the computer is 
connected to the GSE switch box through a USB cable, the 
USB communication port appears with the COMX - USB 
notation. 

Close Port: Clicking this menu items will close the communication port. 
This menu item is enabled if a communication port is opened 
by the application. 

Update Ports: Clicking this menu items does a port scan and refreshes the 
Select Port menu items and their state. This menu item is 
always enabled. 

 
The selected communication port, if any, is indicated by a check mark next to 
the corresponding menu item and is also identified in the second status pane. 
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3.1.4 Communication Menu 

 
The Communication drop down menu regroups communication functions. 
Options within this drop down menu are dynamically configured to match the 
selected system’s maintenance functions (DU used in example). The 
Communication drop down menu may contain the Fuel XFER Override 
menu item and may contain up to three optional horizontal drop down menus, 
Download Data, Upload Data and Clear NVM and may contain the Fuel 
XFER Override menu item. 
 

 

 
 
Download Data: This optional horizontal drop down menu regroups menu 

items related to download maintenance functions. Menu 
items within this horizontal drop down menu are 
dynamically configured to match the selected system’s 
download maintenance functions. Clicking one of these 
menu items enables the communication download 
interface. 

Upload Data: This optional horizontal drop down menu regroups menu 
items related to upload maintenance functions. Menu 
items within this horizontal drop down menu are 
dynamically configured to match the selected system’s 
upload maintenance functions. Clicking one of these 
menu items enables the communication upload interface. 

Clear NVM: This optional horizontal drop down menu regroups menu 
items related to memory clear functions. Menu items 
within this horizontal drop down menu are dynamically 
configured to match the selected system’s memory clear 
maintenance functions. Clicking one of these menu items 
lets the user send memory clear commands to the 
selected system. 
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Fuel XFER Override: This optional menu item is only part of the ADIU 

maintenance functions. Clicking this menu items will 
open the Fuel XFER Override Interface and let the user 
send override commands to the aft/fore transfer pump. 

 
3.1.5 Tools Menu 

 
The Tools drop down menu regroups DMITS support tools. Options within 
this drop down menu are dynamically configured to match the selected 
system’s maintenance functions (DU used in example). The Tools drop down 
contains 1 menu items, Change Password and may contain the optional 
Upload File Editor horizontal drop down menu depending on the selected 
system. 
 

 
Change Password: Clicking this menu items will open the change password 

dialog Box. This menu item is always enabled. 

Upload File Editor: This optional horizontal drop down menu regroups menu 
items related to upload functions file creation. Menu 
items within this horizontal drop down menu are 
dynamically configured to match the selected system’s 
upload maintenance functions. Clicking one of these 
menu items opens an editor dialog box that lets the user 
create uploadable files in the correct format. 

3.1.6 Help Menu 
 
The Help drop down menu regroups menu items related to user support. The 
Help drop down menu contains 3 menu items: DMITS User Manual, Contact 
Info and About... 
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DMITS User Manual: Clicking this menu items will open the DMITS User 
Manual. This menu item is always enabled. 

Contact Info: Clicking this menu items will open the Contact 
Information dialog box containing support point of 
contact. This menu item is always enabled. 

About...: Clicking this menu items will open the About dialog 
box containing software version information and P/N. 
This menu item is always enabled. 
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3.2 MAIN WINDOW CAPTION 

 
The selected system’s maintenance function (ADIU Download Chip History in 
this example) is displayed in the main windows caption area when a 
maintenance function is selected. Additional information is displayed in the 
status bar located in the bottom portion of the main window; see section 3.4 
for status bar details. 
 

 
 
The main windows caption area will display the default caption when no 
maintenance function is selected. 
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3.3 VIEWING WINDOW 

 
The viewing window is a multipurpose display window. It is displayed in the 
center of the application window when required. 
 

 
 

The viewing window is displayed in the following cases: 
 

• File data opened from one of the View menu items (except for *.cvs files) 
is displayed. 

• File data prior to using a system’s upload function is displayed. 

• Downloaded data from a system’s download function is displayed. 
 
When displayed, the viewing window will be closed by the following actions: 
 

• The File->Close menu item is selected while viewing a maintenance data 
file. 

• The toolbar’s Exit button is pressed while in a communication 
maintenance function. 

• The selected system is changed through the Select System drop down 
menu 

• The communication port is close through the Select Port drop down menu 
while in a communication maintenance function. 
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The viewing window has both horizontal and vertical scroll bars. The scroll 
bars will appear only if the text extends past the window’s current size. In the 
example above, the vertical scrollbar is displayed and may be used to scroll 
down the text displayed in the viewing window. 
 
Text may not be typed in the viewing window, but text may be copied from it 
using typical copy techniques. 
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3.4 STATUS BAR 

 
The status bar window occupies the bottom portion of the screen; it contains 
status information relevant to the application. 
 

 
 
The status bar window is separated into 5 panes. 
 
PANE 1: This pane is used to display the selected system. Right-clicking 

on this pane brings up a track menu that allows the user to 
change the selected system. 

PANE 2: This pane is used to display the configured communication port. 

PANE 3: This pane is used to display the state of the configured 
communication port. This pane is also used following a 
communication function to display the status messages received 
from the system under maintenance. 

PANE 4: This pane is used to display header information for the fifth pane. 

PANE 5: This pane is used to display the filename, if any, of the file 
displayed in the viewing window. This pane is also used to show a 
progress bar for lengthy maintenance communication functions. 
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The progress bar is displayed for the following maintenance functions: DU 
Download EDR Data, DU Upload Normal Checklist, DU Upload Emergency 
Checklist, ADIU Upload Aircraft Data, LPS Download Dimming Table and 
LPS Download All Dimming Tables. 
 
The following examples illustrate the pane usage for the DU Upload Normal 
Checklist function. Example #1 illustrates the pane usage prior to upload, 
Example #2 illustrates the pane usage during the upload and Example #3 
illustrates the pane usage after the upload. 
 

Example #1 - Prior to Upload 
 

 
 

PANE 1: Displays the current sub-system (DU). 

PANE 2: Displays the configured communication port (COM1). 

PANE 3: Displays the state of the communication port (Ready to Upload ->). 

PANE 4: Displays header information for PANE 5 (File ->). 

PANE 5: Displays the normal checklist filename to upload (C:\Program 
Files\DMITS429\DU\Normal Checklist\429 normal.unc). 
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Example #2 - During Upload 

 

 
 

PANE 1: Information is unchanged. 

PANE 2: Information is unchanged. 

PANE 3: Displays the state of the communication port (Uploading ->). 

PANE 4: Displays header information for Pane 5 (Progress ->). 

PANE 5: Displays a progress bar for the upload. 
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Example #3- After Upload 

 

 
 

PANE 1: Information is unchanged. 

PANE 2: Information is unchanged. 

PANE 3: Displays the status messages1 received from the system under 
maintenance. 

PANE 4: Displays header information for Pane 5 (File ->). 

PANE 5: Displays the uploaded normal checklist filename (C:\Program 
Files\DMITS429\DU\Normal Checklist\429 normal.unc). 

 
The status bar window contains a size grip icon to the right of the fifth pane. 
The size grip is used to resize the application’s window. 

                                            
1 In the case of a DU, status messages are displayed in the gray bordered box on the DU Maintenance 
page. 
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3.5 TOOLBAR 
 
3.5.1 Download 

 
The download toolbar window is displayed when a download maintenance 
function is selected. The toolbar window is dynamically updated to show only 
appropriate buttons for the given situation and may contain up to 3 buttons: 
 

Example #1 - Prior to Download 
 

 
 

Download: The Download button is displayed when communication is in 
idle or ready state. Clicking the button will launch the download 
process. 

Exit: The Exit button is displayed when communication is in idle or 
ready state. Pressing the button will exit the download 
maintenance function. 
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Example #2 – Downloading 
 

 
 
Abort: The Abort button is displayed when a download process is 

underway. Clicking this button will terminate the software 
download process. 

 
Example #3 – Download Complete 

 

 
Save: The Save button is displayed after a successful download 

operation, when communication returns to the idle or ready state. 
Clicking this button will open the Save Dialog Box, which lets the 
user specify the drive, directory, and name of the file to save.  
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3.5.2 Upload 

 
The upload toolbar window is displayed when an upload maintenance 
function is selected. The toolbar window is dynamically updated to show only 
appropriate buttons for the given situation and may contain up to 3 buttons: 
 

Example #1 – Prior to Upload 
 

 
Upload: The Upload button is displayed when communication is in idle or 

ready state. Clicking the button will launch the appropriate upload 
process. 

Open: The Open button is displayed when an upload maintenance 
function is selected. Clicking this button will open the Open Dialog 
Box, which lets the user specify the drive, directory, and name of 
the file to upload. 

Exit: The Exit button is displayed when communication is in idle or 
ready state. Pressing the button will exit the upload maintenance 
function. 
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Example #2 – Uploading 

 

 
 

Abort: The Abort button is displayed when an upload process is 
underway. Clicking this button will terminate the upload process. 
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Example #3 – Upload Complete 
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3.6 EDITORS 

 
The DMITS file editors are dialog boxes used to create valid and formatted 
uploadable data files. File editors are available for the following maintenance 
functions: DU EDR Data Mask, DU Normal Checklist, DU Emergency 
Checklist, DU Programmable CAS, ADIU Aircraft Data and LPS Dimming 
Table. 
 
File editors share a common toolbar structure: 
 

 

New: The New button is used to reset the editable fields to a blank 
state. 

Open: The Open button is used to open a file and fill the forms editable 
fields. 

Save: The Save button is used to save an already existing file. 

Save As: The Save As button is used to save under a new filename. 

Exit: The Exit button is used to close the editor dialog box. 

Tooltip: The Tooltip button is used to toggle ON or OFF the display of the 
tooltips. 

Tooltips are displayed when the mouse is hovered over the editor’s controls: 
toolbar buttons, status bar panes and editable fields. Tooltips will display 
useful information related to the each control. Tooltips are displayed as yellow 
bulleted text per the example above (mouse hovered over the Exit button). 
To ensure the files are properly formatted to upload, before saving the file the 
editors will typically ensure that: 

• Characters used are part of the valid character set 

• Maximum length of each editable field is respected 

• All required editable fields are completed 
 
When one of these criteria is not met, a message box will display the nature 
of the problem and suggest possible solutions. 
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Note: 
 

Use of the editors is mandatory for creating 
uploadable files. Files created outside the editors will 
not be recognized as valid by the various upload 
functions. 

 
3.6.1 DU EDR Data Mask 

 
The EDR Data Mask editor dialog box may be opened by setting the current 
system to DU (Select System->DU) and selecting the Tools->Upload File 
Editor->EDR Data Mask menu item. The following figure illustrates the editor 
with the EDR mask 1 of 2.udm file opened. 
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To create an EDR Data Mask file, check the desired parameters checkboxes, 
then save to file.  
 
The EDR Data Mask is uploaded to the DU to indicate what parameters are 
required to be downloaded as part of a subsequent call to the EDR Data 
download function. If an all-zero parameter mask is uploaded, the DU shall 
default to a parameter mask with only parameters 1 and 2 selected (lat/long). 
The downloaded binary data is translated to text to represent the parameters 
value and saved in a comma separated value (CSV) file. The first status pane 
of the editor is used to display the number of rows required in this EDR Data 
downloaded file using the editor’s current mask. 
 

Note: 
 

CSV Files are opened with the microsoft excel 
application. excel versions prior to version 12 have an 
intrinsic 256 row limit; any data beyond row 256 is 
clipped. for users of excel prior to version 12, it is 
recommended to create an EDR data mask that will 
require 256 rows or less. two EDR data mask files are 
installed with the application respecting this limitation: 
EDR mask 1 of 2.UDM (all parameters except the 
CAS words) and EDR mask 2 of 2 (cas).UDM (all the 
cas words). 

 
The third status pane is used to display the current EDR Data Mask filename. 
An [*] before the filename indicates file has been changed since last saved. 

 
3.6.2 DU Normal Checklist 

 
The Normal Checklist editor dialog box may be opened by setting the current 
system to DU (Select System->DU), selecting the Tools->Upload File 
Editor->Normal Checklist menu item and then entering the DMITS 
password in the password caption dialog box. The following figure illustrates 
the editor with the 429 normal.unc file opened. 
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Creation of a Normal Checklist file is done via the Edit Normal Checklist 
Fields window and the various control buttons. The following table explains 
the use of each control: 
 

Control Details 

Edit Normal Checklist 
Fields 

This field is used to type the text that will be assigned to 
other fields on the form (named Edit herein). 

Button used to transfer the text contained in the Edit 
field to the Normal Checklist Version Identifier field. 
Button is enabled if the Edit field is not blank. 

Set Identifier 

Button used to transfer the text contained in the Normal 
Checklist Version Identifier to the Edit field. Button is 
enabled if the Normal Checklist Version Identifier 
field is not blank. 

Edit Identifier 

Normal Checklist Version 
Identifier 

This field holds the normal checklist version identifier 
saved to file. Double clicking this field as the same 
effect as using the Edit Identifier button. The version 
identifier is limited to 10 characters. 
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Set Name 
Button used to transfer the text contained in the Edit 
field to the Normal Checklist Name field. Button is 
enabled if the Edit field is not blank. 

Edit Name 
Button used to transfer the text contained in the Normal 
Checklist Name to the Edit field. Button is enabled if 
the Normal Checklist Name field is not blank. 

Normal Checklist Name 

This field holds the normal checklist name saved to file 
for the current checklist. Double clicking this field as the 
same effect as using the Edit Name button. Checklist 
names are limited to 10 characters. 

Add Item 
Button used to transfer the text contained in the Edit 
field to the end of the Normal Checklist Items field. 
Button is enabled if the Edit field is not blank. 

Insert Item 

Button used to transfer the text contained in the Edit 
field to the highlighted position of the Normal Checklist 
Items field. Button is enabled if the Edit field is not 
blank. 

Edit Item 

Button used to transfer the text contained in the 
highlighted position of the Normal Checklist Items 
field to the Edit field. Button is enabled if the Normal 
Checklist Items field is not empty. 

Delete Item 

Button used to delete the text contained in the 
highlighted position of the Normal Checklist Items 
field. Button is enabled if the Normal Checklist Items 
field is not empty. 

>> Move Item >> 

Button used to transfer the text contained in the 
highlighted position of the Normal Checklist Items 
field to the highlighted position of the Temporary 
Checklist Items field. Button is enabled if the Normal 
Checklist Items field is not empty. 

<< Move Item << 

Button used to transfer the text contained in the 
highlighted position of the Temporary Checklist Items 
field to the highlighted position of the Normal Checklist 
Items field. Button is enabled if the Temporary 
Checklist Items field is not empty. 

<< Delete All Items 
Button used to delete all the text contained in the in the 
Normal Checklist Items field. Button is enabled if the 
Normal Checklist Items field is not empty. 
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This field holds the normal checklist items saved to file 
for the current checklist. Double clicking an item in this 
field as the same effect as using the Edit Item button 
when the item is highlighted. Checklist items are limited 
to 46 characters. 

Normal Checklist Items 

Temporary Checklist 
Items 

This field holds temporary normal checklist item, they 
are not saved to file. 

Button used to move and display information of the 
previous checklist (name & items). Button is enabled if 
currently displayed checklist is 2 or above. 

<< Previous Checklist 

Button used to move and display information of the next 
checklist (name & items). Button is enabled if the 
Normal Checklist Name field is not empty 

Next Checklist >> 

 
The valid character set for checklist identifier, checklist names and checklist 
items is as follow: "-"(minus or dash), “+”(plus), "."( period), “,”(comma), 
“/”(slash), “%”(percent), “(“(open bracket), “)”(close bracket), “ “(space), 
“>”(greater than), “<”(less than), “=”(equal),  "0 thru 9" or "A thru Z". A beep 
sound will be heard when the user tries to enter an invalid character. 
 
The status bar panes usage is as follow: 
 

 
 
The second status pane is used to display the current normal checklist file 
name. An [*] before the file name indicates file has been changed since last 
saved. 
 
The third status pane indicates the current checklist displayed on the form. A 
normal checklist file may contain up to 20 checklists. 
 
The forth status pane indicates the current checklist’s item count. A checklist 
may contain up to 50 checklist items. 
 
The fifth pane indicates the item count contained in all checklists. .A normal 
checklist file may contain up to a combined total of 500 checklist items for all 
the checklists. 
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3.6.3 DU Emergency Checklist 

 
The Emergency Checklist editor dialog box may be opened by setting the 
current system to DU (Select System->DU), selecting the Tools->Upload 
File Editor->Emergency Checklist menu item and then entering the DMITS 
password in the password caption dialog box. 
 
Functionality of the Emergency Checklist editor is identical to that of the 
Normal Checklist editor defined in section 3.6.2. 
 

3.6.4 DU Programmable CAS 
 
The Programmable CAS editor dialog box may be opened by setting the 
current system to DU (Select System->DU), selecting the Tools->Upload 
File Editor->Programmable CAS menu item and then entering the DMITS 
password in the password caption dialog box. The following figure illustrates 
the editor (without any opened file). 
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To create a Programmable CAS file, type the desired CAS messages in the 
appropriate fields, then save to file. If some fields are left blank when saving 
the file, the following message will appear.  
 

 
 
Default CAS messages are defined as follow: PGM CAS Gx (where x is the 
ground/open CAS message number) and PGM CAS 28Vx (where x is the 
28V/open CAS message number). 
 
Programmable CAS messages are limited to 15 characters and the valid 
character set is as follow: "-"(minus or dash), “+”(plus), "."( period), 
“,”(comma), “/”(slash), “%”(percent), “(“(open bracket), “)”(close bracket), “ 
“(space), “>”(greater than), “<”(less than), “=”(equal),  "0 thru 9" or "A thru Z". 
A beep sound will be heard when the user tries to enter an invalid character. 
 

CAUTION: 

Care should be taken when creating and uploading a 
programmable CAS data file. Ensure any previous 
programmable CAS messages (previously uploaded to the 
display units) are repeated in the appropriate fields while 
adding a CAS messages to a data file. Failure to do so will 
result in overwriting previous programmable CAS messages 
with the default values when the file is uploaded to the display 
units. 
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3.6.5 ADIU Aircraft Data 

 
The Aircraft Data editor dialog box may be opened by setting the current 
system to ADIU (Select System->ADIU) and selecting the Tools->Upload 
File Editor->Aircraft Data menu item. The following figure illustrates the 
editor’s different tab pages (without any opened file). 
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Clicking on the appropriate tab page header will navigate the different tab 
pages. To create Aircraft Data file, type all the required information in the 
appropriate fields, then save to file.  
 
The table blow indicates valid ranges for the different parameters. 
 
Parameter Parameter Validity Range 
Aircraft S/N 9 characters max 
Engine #1 S/N 6 characters max 
Engine #2 S/N 6 characters max 
FWD Main Tank - Offset -50 to 50 
FWD Main Tank - Scale Factor 0.008 to 1.200 
MID1 Feed Tank - Offset -50 to 50 
MID1 Feed Tank - Scale Factor 0.008 to 1.200 
MID2 Feed Tank - Offset -50 to 50 
MID2 Feed Tank - Scale Factor 0.008 to 1.200 
AFT Main Tank - Offset -50 to 50 
AFT Main Tank - Scale Factor 0.008 to 1.200 
AUX Tank - Offset -50 to 50 
AUX Tank - Scale Factor 0.008 to 1.200 
Aircraft Empty Weight 4000 to 5000 
Aircraft Empty Balance Station -150.0 to 350.0 
Balance Station 1 -150.0 to 350.0 
Balance Station 2 -150.0 to 350.0 
Balance Station 3 -150.0 to 350.0 
Balance Station 4 -150.0 to 350.0 
Total Operating Time 0.00 to 9999.99 
Total Air Time 0.00 to 9999.99 
Density Altitude Zone 1 0.00 to 9999.99 
Density Altitude Zone 2 0.00 to 9999.99 
Density Altitude Zone 3 0.00 to 9999.99 
Density Altitude Zone 4 0.00 to 9999.99 
Takeoffs / Landings 0 to 9999 
Engine #1 Starts 0 to 9999 
Engine #2 Starts 0 to 9999 
 
Serial numbers valid character set is as follow: "-"(minus or dash), “+”(plus), 
"."( period), “,”(comma), “/”(slash), “%”(percent), “(“(open bracket), “)”(close 
bracket), “ “(space), “>”(greater than), “<”(less than), “=”(equal),  "0 thru 9" or 
"A thru Z". A beep sound will be heard when the user tries to enter an invalid 
character.



 
 
 
 
 
 
 
 
12,800 RUE DE L'AVENIR, MIRABEL, QUÉBEC J7J 1R4  

429-770-014-105
DMITS429 User Manual

 

52 

 
3.6.6 LPS Dimming Table 

 
The LPS Dimming Table editor dialog box may be opened by setting the 
current system to LPS (Select System->LPS) and selecting the Tools-
>Upload File Editor->Dimming Table menu item. The following figure 
illustrates the editor with the FTG LAMP-5V-TREND.csv file opened. 
 

 
 
Four tab pages are used to display all (254) possible dimming potentiometer 
positions (indicated by the -#- symbols). Clicking on the appropriate tab page 
header will navigate the different tab pages. An output voltage is assigned to 
each potentiometer position; omission of one value will be equivalent to 
entering a value of 0.0. 
 
The NVG field is used to enter the output voltage for NVIS operation. 
 
The LOAD field is used to program the load ratio lookup table for the output. 
This value is set by selecting the appropriate value in the LOAD combo box. 
The load ratio can be computed for each output by dividing the expected 
operational load of the output by the maximum load for the output (28 V = 0.5 
mA max; 5V = 0.2mA max) and selecting the closest available load ratio from 
the combo box. Sixteen load ratios are available, spanning from 6.25% to 
100.00 % in 6.25% increment. 
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The TABLE # field is used to enter the dimming table number, from 1 to 40. 
Dimming tables from 1 to 15 correspond to the 5 Volts outputs whereas 
dimming tables from 16 to 40 correspond to the 28 Volts outputs. 
 
The Scaling Options combo box contain the Rescale to 28/5 and Rescale 
to 5/28 options and are used to multiply each output voltage fields by the 
corresponding scaling factor. 
 
The Data Sets radio buttons determine how many data points must be 
entered by the user to complete the dimming table. When the All Data Points 
radio button is checked, all data points are available for editing. When one of 
the other radio buttons is checked, only that amount of data points are 
available for editing. When selected, these options will only enable the 
necessary data point fields; intermediate data points are disabled and their 
data point values linearly extrapolated. 
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The Graph toolbar button is used to plot the data points. When in the pushed 
position, the plot is displayed1, when in the popped position, the plot is not 
displayed. The abscissa axis represents dimming potentiometer’s position 
while the ordinate axis represents corresponding output voltage. 
 

 
 
Left clicking in the plot window will display a red marker and the point’s 
coordinate will be displayed in the upper portion of the window. 
 

 
 
When the plot window is displayed, the Refresh button is added to the editor’s 
toolbar. 
 

 

                                            
1 When displayed or refreshed, the plot window is moved to the upper right position of the screen. 
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The plot is not modified in real time while data points are modified. To reflect 
changes made to the data points, the Refresh toolbar button must be 
pressed. 

 
Note: 

 
Output voltage values displayed when a dimming 
table file is opened may not exactly match the values 
displayed prior to saving the file. Precision is lost 
when file is saved as double precision variables are 
cast into byte variables. 
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3.7 MAINTENANCE FUNCTION FLOWCHART 

 
The following process flowcharts apply when using the maintenance function 
described in section 4.0. 
 

3.7.1 Download Functions 
 
Except for the exception described in section 3.7.2, the following represents 
the flowchart for all the download functions. 
 

OPEN THE 
DMITS429 S/W 

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

USE THE DOWNLOAD 
FUNCTION 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

LEGEND 

 
3.7.2 Download Functions - Exceptions 

 
The following represents the flowchart for the Download EDR Data (section 
4.2.1) function. 
 

OPEN THE 
DMITS429 S/W 

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

USE EDITOR TO CREATE 
AN EDR DATA MASK FILE 

UPLOAD THE EDR 
DATA MASK FILE 

USE THE EDR DATA 
DOWNLOAD FUNCTION 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

OPTIONAL STEP 

LEGEND 
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3.7.3 Upload Functions 

 
Except for the exceptions described in section 3.7.4, the following represents 
the flowchart for all the upload functions. 
 

 

OPEN THE 
DMITS429 S/W 

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

USE EDITOR TO CREATE 
OR EDIT A DATA FILE 

USE THE UPLOAD 
FUNCTION 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

OPTIONAL STEP 

LEGEND 

3.7.4 Upload Functions - Exceptions 
 
The following represents the flowchart for the Upload Aircraft Data (section 
4.1.8) and the Upload Dimming Table (4.4.7) functions. 
 

 

OPEN THE 
DMITS429 S/W  

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

USE EDITOR TO CREATE 
OR EDIT A DATA FILE 

USE THE UPLOAD 
FUNCTION 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

OPTIONAL STEP 

LEGEND USE THE MATCHING 
DOWNLOAD FUNCTION 
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3.7.5 NVM Clear Functions - Inhibited 

 
The following represents the flowchart for all the “inhibited” NVM clear 
functions. 
 
. 

OPEN THE 
DMITS429 S/W 

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

USE THE MATCHING 
DOWNLOAD FUNCTION 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

OPTIONAL STEP 

LEGEND 

USE THE NVM CLEAR 
FUNCTION 

 
 

Note: 
 

Failure to use the matching download function prior to 
using a NVM clear function will result in a clear not 
allowed response from the target system. 

 
3.7.6 NVM Clear Functions - Non-Inhibited 

 
The following represents the flowchart for all the “non-inhibited” NVM clear 
functions. 
 

OPEN THE 
DMITS429 S/W 

SELECT THE 
SYSTEM 

SELECT THE 
COM PORT 

Sequential Steps 

Interchangeable Steps 

MANDATORY STEP 

LEGEND USE THE NVM CLEAR 
FUNCTION 
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4.0 MAINTENANCE FUNCTIONS 
 
4.1 ADIU MAINTENANCE FUNCTIONS 

 
There are two ADIU channels installed on the model 429 helicopter. Channel 
selection is done via the GSE switch box. ADIU maintenance functions 
include: 
 
Download Functions 
 
• ADIU Faults (section 4.1.1) 
• Exceedances (section 4.1.2) 
• Chip History (section 4.1.3) 
• Aircraft Flight Log (section 4.1.4) 
• Timers/Counters (section 4.1.5) 
• Power Assurance (section 4.1.6) 
• Aircraft Data (section 4.1.7) 
 
Upload Functions 
 
• Aircraft Data (section 4.1.8) 
 
NVM Clear Functions 
 
• ADIU Faults (section 4.1.9) 
• Exceedance Flags (section 4.1.10) 
• Exceedance History (section 4.1.11) 
• Chip History (section 4.1.12) 
• Flight Log History (section 4.1.13) 
• Timers/Counters (section 4.1.14)  
• Initialize ADMM (section 4.1.15) 
 
Discrete Override  
 
• Fuel XFER Override (section 4.1.16) 
 
When the ADIU is selected as the desired system (Select System->ADIU) 
and the communication port is configured (Select Port->COMX), the ADIU’s 
communication checklist message box is displayed. The message box details 
the required setup to interface with the ADIU’s maintenance functions. 
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After the setup is completed and the message box is closed, the ADIU’s 
maintenance functions may be accessed through the Communication drop 
down menu. 
 
After performing a maintenance function, the third status pane will report one 
of the following status messages: 
 

STATUS MESSAGE DESCRIPTION SOURCE 
STATUS: READY Receipt of CR with no command ADIU 

STATUS: CLEAR COMPLETE Successful completion of clear command ADIU 

STATUS: CLR NOT ALLOWED Receipt of inhibited clear command ADIU 

STATUS: CRC ERROR Receipt of data with CRC error ADIU 

STATUS: INVALID CMD Receipt of invalid command sequence ADIU 

STATUS: UPLOAD ERROR Parity or format error in uploaded data ADIU 

STATUS: ADMM FAILED ADMM failed, unable to perform action ADIU 

STATUS: UPLD COMPLETE Successful completion of upload command ADIU 

STATUS: VERIFY ON DU Successful completion of the command 
should be verified on the DU DMITS429 

STATUS: ERROR - NO 
FEEDBACK 

No feedback from ADIU after using an 
upload or a clear command DMITS429 

STATUS: UPLD ABORTED Upload function was aborted using the 
Abort Toolbar button DMITS429 

STATUS: DNLD COMPLETE Download function has completed DMITS429 

STATUS: ERROR - NO DATA Download function has failed, no data was 
received from the ADIU DMITS429 

STATUS: DNLD ABORTED Download function was aborted using the 
Abort Toolbar button DMITS429 

STATUS: NVM CLEAR 
CANCELLED 

Memory clear was cancelled by selecting 
No on the confirmation message box DMITS429 
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4.1.1 Download ADIU Faults 

 
The ADIU Fault download function downloads the fault messages from the 
ADIU. The number of records to be downloaded will depend on the data 
recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->ADIU Faults menu item. 
 

 
 

The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
 

 
 

When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
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The fault messages are displayed in text format along with the time and date 
at which they were logged. The following table contains the complete listing of 
faults reported by ADIU; refer to the maintenance manual for more details on 
each fault. 

 
Fault Messages 

ADMM synchronization Failure Channel Interconnect Failure 
Chip System Test Failure Analog Inputs Miscompare 
Not Receiving L-DU Arinc Data Discrete Inputs Miscompare 
Not Receiving C-DU Arinc Data Serial I/O Failure 
Not Receiving spare Arinc Data I/O Processor Failure 
Not Receiving R-DU Arinc Data Power Supply Failure 
Not Receiving Left ECU Data CPU Failure 
Not Receiving Right ECU Data Real Time Clock Failure 
Channel Interconnect Failure ADMM Read/Write Failure 
Analog Inputs Miscompare ADIU Internal Failure 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
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The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.daf) and will default to the 
{root}\ADIU\ADIU Faults\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Faults download function will display the unsaved data error 
message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Faults download function. Selecting No will exit the ADIU Faults 
download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Faults download function and 
close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.2 Download Exceedances 

 
The Exceedance download function downloads the exceedance history data 
from the ADIU, preceded by the aircraft tail number and engine serial 
numbers. The number of records to be downloaded will depend on the data 
recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->Exceedances menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
 

 
 
When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
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“A” indicates an alpha-numeric character and “X” indicates a numeric 
character “0” thru “9”. The aircraft and/or engine serial numbers may appear 
as blank if values have not been uploaded to the ADIU. The “D” characters 
under EVENT are decoded according to the following table: 
 

System 
Text 

(1 char) 
 Parameter Text 

(3 char)  Event Text  
(7 char) 

Xmsn X  NP/NR NP or NR  30S Excursion/Exceed 30-SEC 

Eng1 1  TRQ TRQ  2.5M Excursion/Exceed 2.5-MIN 

Eng2 2  MGT MGT  2.M Excursion/Exceed 2-MIN 

Rotor R  NG NG_  30M Exceed  30-MIN 

      Limit Exceed LIMIT 

      Start Exceeded STRT 

      5 M T/O Exceed E-TO 

      AEO Limit Exceed E-AEO 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
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The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dex) and will default to the 
{root}\ADIU\Exceedances\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Exceedance download function will display the unsaved data 
error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Exceedance download function. Selecting No will exit the ADIU 
Exceedance download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Exceedance download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.3 Download Chip History 

 
The Chip History download function downloads the chip history data from the 
ADIU, preceded by the aircraft tail number and engine serial numbers. The 
number of records to be downloaded will depend on the data recorded in 
memory. The function may be accessed by selecting the Communication-
>Download Data->Chip History menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and the 
Communication drop down menus are deactivated. The toolbar buttons are 
modified and the Abort button is displayed; pressing this button will terminate 
the download process. 
 

 
 
When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
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“A” indicates an alpha-numeric character. The “D” under CHP/FUZ is an 
ASCII “C” character if a chip was recorded or an “F” character if fuzz was 
recorded. The aircraft and/or engine serial numbers may appear as blank if 
values have not been uploaded to the ADIU. The “D” characters under TYPE 
are decoded according to the following table: 
 

Chip Type Text (8 Char) 
Left Transmission Input LFT XMSN  

Right Transmission Input RGT XMSN 

Mast MAST 

Tail Rotor Gearbox TR GB 

Engine 1 ENG 1 

Engine 2 ENG 2 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
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The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dch) and will default to the 
{root}\ADIU\Chip History\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Chip History download function will display the unsaved data 
error message box: 
 

 
 

Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Chip History download function. Selecting No will exit the ADIU Chip 
History download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Chip History download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.4 Download Aircraft Flight Log 

 
The Aircraft Flight Log download function downloads the Aircraft Flight Log 
data from the ADIU, preceded by the aircraft tail number and engine serial 
numbers. The number of records to be downloaded will depend on the data 
recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->Aircraft Flight Log menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 

 

 
 
“A” indicates an alpha-numeric character and “X” indicates a numeric 
character “0” thru “9”. The aircraft and/or engine serial numbers may appear 
as blank if values have not been uploaded to the ADIU. For the “TO/LDGS” 
field, the one hundreds digit will be displayed as a “P” to indicate a power 
interruption. 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
 

 
 

The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dal) and will default to the 
{root}\ADIU\Aircraft Flight Log\ folder. When saved, the filename will be 
displayed in the fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Aircraft Flight Log download function will display the unsaved 
data error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Aircraft Flight Log download function. Selecting No will exit the ADIU 
Aircraft Flight Log download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Aircraft Flight Log download 
function and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.5 Download Timers/Counters 

 
The Timer/Counters download function downloads log timer and counter data 
from the ADIU. The number of records to be downloaded will depend on the 
data recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->Timers/Counters menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
 

 
 
When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
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“A” indicates an alpha-numeric character and “X” indicates a numeric 
character “0” thru “9”. Three dashes “- - -” indicates a parameter is invalid or 
has not been initialized in NVM. 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
 

 
 

The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dtc) and will default to the 
{root}\ADIU\Timers Counters\ folder. When saved, the filename will be 
displayed in the fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Timer/Counters download function will display the unsaved data 
error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Timer/Counters download function. Selecting No will exit the ADIU 
Timer/Counters download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Timer/Counters download 
function and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.6 Download Power Assurance 

 
The Power Assurance download function downloads the power assurance 
history data from the ADIU, preceded by the aircraft tail number and engine 
serial numbers. The number of records to be downloaded will depend on the 
data recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->Power Assurance menu item. 
 

Note: 
 
The ADIU power assurance download function is 
disabled for S/W 429-770-014-109, Version 1.0. 
 

 
 

The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
 

 
 
“X” indicates a numeric character “0” thru “9”. The aircraft and/or engine serial 
numbers may appear as blank if values have not been uploaded to the ADIU. 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
 

 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dpa) and will default to the 
{root}\ADIU\Power Assurance\ folder. When saved, the filename will be 
displayed in the fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Power Assurance download function will display the unsaved 
data error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Power Assurance download function. Selecting No will exit the ADIU 
Power Assurance download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Power Assurance download 
function and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.7 Download Aircraft Data 

 
The Aircraft Data download function downloads the S/Ns, the fuel calibration 
settings, the weight & balance data and selected flight counters from the 
ADIU. The function may be accessed by selecting the Communication-
>Download Data->Aircraft Data menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.1. 
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The aircraft and/or engine serial numbers may appear as blank if values have 
not been uploaded to the ADIU. 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
 

 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.adf) and will default to the 
{root}\ADIU\Aircraft Data\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the ADIU Aircraft Data download function will display the unsaved data 
error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
ADIU Aircraft Data download function. Selecting No will exit the ADIU Aircraft 
Data download function without saving the downloaded data. 
 
Doing one of the following will exit the ADIU Aircraft Data download function 
and close (or reset) the viewing window:  
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• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.1.8 Upload Aircraft Data 
 

The Aircraft Data upload function stores S/Ns, the fuel calibration settings, the 
weight & balance data and selected flight counters into NVM. The function 
may be accessed by selecting the Communication->Upload Data->Aircraft 
Data menu item. 
 

CAUTION: 

Uploading an aircraft data file overwrites the 
existing aircraft data in the admm. When only 
selected parameters require changes, the user 
should first download and save the data per 
section 4.1.7. The parameters requiring change 
should be edited from the downloaded file and 
saved per section 3.6.5. The edited file can then 
be uploaded and the resulting upload will only 
change those edited parameters. 

 
When selected, the Open File Dialog Box is displayed, which lets the user 
specify the drive, directory, and name of the file to open. The Open File 
Dialog Box will apply the function’s file extension mask (*.uad) and will default 
to the {root}\ADIU\Aircraft Data\ folder.  
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When opened, the file is displayed in the viewing window and the filename is 
displayed in the fifth status pane. 
 

 
 
Pressing the Open button will display the Open File Dialog Box, at which 
point a different file may be selected for upload.  
 
The Upload button will launch the upload process. While data is being 
uploaded, the File, Select System, Select Port and the Communication 
drop down menus are deactivated. The fifth status pane is used to display an 
upload progress bar. The toolbar buttons are modified and the Abort button is 
displayed; pressing this button will terminate the upload process. 
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When data is uploaded, the toolbar regains its original buttons and the third 
status pane will display one of the status messages as defined in section 4.1. 
 

 
 
If the ADIU reports a STATUS: UPLD COMPLETE status message, a 
message box is displayed to indicate the required step to complete the upload 
process. 
 

 
 
Doing one of the following will exit the ADIU Aircraft Data upload function and 
close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Open button and closing the Open File Dialog Box 

without selecting another file for upload 
• Pressing the toolbar’s Close button 
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4.1.9 NVM Clear ADIU Faults 

 
The ADIU Fault NVM clear function marks the NVM records as erased from 
memory. The function may be accessed by selecting the Communication-
>Clear NVM->ADIU Faults menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the NVM 
clear command. The No button will cancel the clear operation. 
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 
 

The NVM clear function will be inhibited by the adiu 
unless the ADIU Faults were previously downloaded 
per section 4.1.1
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4.1.10 NVM Clear Exceedance Flags 

 
The Exceedance Flags NVM clear function erases the records from memory. 
The function may be accessed by selecting the Communication->Clear 
NVM->Exceedance Flags menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
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4.1.11 NVM Clear Exceedance History 

 
The Exceedance History NVM clear function marks the NVM records as 
erased from memory. The function may be accessed by selecting the 
Communication->Clear NVM->Exceedance History menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation. 
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 
 

The NVM clear function will be inhibited by the adiu 
unless the Exceedance History was previously 
downloaded per section 4.1.2. 
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4.1.12 NVM Clear Chip History 

 
The Chip History NVM clear function marks the NVM records as erased from 
memory. The function may be accessed by selecting the Communication-
>Clear NVM->Chip History menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 

The NVM clear function will be inhibited by the adiu 
unless the Chip History was previously downloaded 
per section 4.1.3.  
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4.1.13 NVM Clear Flight Log History 

 
The Flight Log History NVM clear function marks the NVM records as erased 
from memory. The function may be accessed by selecting the 
Communication->Clear NVM->Flight Log History menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 
 
The NVM clear function will be inhibited by the adiu 
unless the Flight Log History was previously 
downloaded per section 4.1.4.  
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4.1.14 NVM Clear Timers/Counters 

 
The Aircraft Logs/Timers NVM clear function marks the NVM records as 
erased from memory. The function may be accessed by selecting the 
Communication->Clear NVM->Timers/Counters menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 
 
The Timers/Counters can be reprogrammed by 
means of an Aircraft Data Upload per section 4.1.8.  
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4.1.15 NVM Initialize ADMM 

 
The ADMM NVM initialize function is used to zeroize the ADMM memory. The 
function may be accessed by selecting the Communication->Clear NVM-
>Initialize ADMM menu item. 
 
When the option is selected, the initialize ADMM checklist message box is 
displayed. The message box details the required steps while using the 
initialize ADMM functions. 
 

 
 
The Yes button will send the NVM initialize command. The No button will 
cancel the initialize operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.1. 
 

 
 

Note: 
 

Following ADMM initialization, a POWER CYCLE is 
required. an Aircraft Data upload Per section 4.1.8 is 
ALSO required to ensure proper ADIU operation after 
maintenance interlock has been released. 
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4.1.16 Fuel XFER Override 

 
The Fuel XFER Override interface is used to provide force control of the fuel 
transfer pump and valve. The interface may be accessed by selecting the 
Communication->Fuel XFER Override menu item. 
 
When the option is selected, the override checklist message box is displayed. 
The message box details the required setup to use the override functions. 
 

 
 
The override interface is composed of a schematic of the fuel tanks, fuel lines 
and fuel pump/valve state icon and description. The lower portion contains 
the available command buttons. The default interface is presented below. 
 

 
 

 AUTO: clicking this button will return the ADIU in automatic fuel XFER 
mode, i.e., cancel any override modes. The automatic mode is 
indicated by the default schematic. 
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OVERRIDE PUMP FORWARD: clicking this button will force the 
pump/valve to transfer fuel towards the forward tank. The pump 
forward override is indicated by the pump forward icon and description 
and animated flow bubbles moving from the aft to the forward tank. 
 

 
 

OVERRIDE PUMP OFF: clicking this button will force the pump/valve 
to close. The pump off override is indicated by the off icon and 
description and absence of flowing bubbles. 
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OVERRIDE PUMP AFT: clicking this button will force the pump/valve 
to transfer fuel towards the aft tank. The pump aft override is indicated 
by the pump aft icon and description and animated flow bubbles 
moving from the forward to the aft tank. 
 

 
 
The EXIT button is used to leave the fuel XFER override interface. Prior to 
exiting, a Pump AUTO command is sent to return the ADIU to automatic 
operating mode. 
 
In the event the ADIU does not confirm engagement of an override command, 
the Fuel XFER Override Interface screen remains unchanged and a message 
box is displayed to indicate the error (Pump Aft in the example below). 
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4.2 DU Maintenance Functions 

 
There are up to three DUs installed on the model 429 helicopter. DU selection 
is done via the GSE switch box. DU maintenance functions include: 
 
Download Functions 
 
• Download EDR Data (section 4.2.1) 
• Download DU Faults (section 4.2.2) 
 
Upload Functions 
 
• Upload EDR Data Mask (section 4.2.3) 
• Upload Normal Checklist (section 4.2.4) 
• Upload Emergency Checklist (section 4.2.5) 
• Upload Programmable CAS (section 4.2.6) 
 
NVM Clear Functions 
 
• NVM Clear DU Faults (section 4.2.7) 
• NVM Clear Normal Checklist (section 4.2.8) 
• NVM Clear Emergency Checklist (section 4.2.9) 
• NVM Clear Programmable CAS (section 4.2.10) 
 
When the DU is selected as the desired system (Select System->DU) and 
the communication port is configured (Select Port->COMX), the DU’s 
communication checklist message box is displayed. The message box details 
the required setup to interface with the DU’s maintenance functions. 
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After the setup is completed and the message box is closed, the DU’s 
maintenance functions may be accessed through the Communication drop 
down menu. 
 
After performing a maintenance function, the third status pane will report one 
of the following status messages: 
 

STATUS MESSAGE DESCRIPTION SOURCE 

STATUS: VERIFY ON DU Status messages should be verified on the 
DU’s Maintenance page (see next table) DMITS429

STATUS: UPLD ABORTED Upload function was aborted using the 
Abort Toolbar button DMITS429

STATUS: DNLD ABORTED Download function was aborted using the 
Abort Toolbar button DMITS429

STATUS: NVM CLEAR 
CANCELLED 

Memory clear was cancelled by selecting 
No on the confirmation message box DMITS429

 
Status message displayed on the DU’s Maintenance page may be one of the 
following: 
 

STATUS MESSAGE DESCRIPTION COLOR 

READY Ready to accept maintenance bus 
commands Green 

UPLOADING Upload in progress White 

DNLOADING Download in progress White 

CLEARING NVM clearing in progress White 

UPLD COMPLETE Upload complete Green 

DNLD COMPLETE Download complete Green 

CLEAR COMPLETE NVM clear complete Green 

CRC ERROR CRC mismatch error Yellow 

INVALID CMD Command sequence not recognized Yellow 

CLR NOT ALLOWED Receipt of inhibited clear command Yellow 

UPLOAD ERROR Parity or format error in uploaded data Yellow 
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4.2.1 Download EDR Data 

 
An EDR Data Mask must be uploaded prior to downloading EDR Data (see 
section 4.2.3 for details). If no EDR Data Mask has been uploaded, a 
message box is displayed when the EDR Data download function is selected. 
Selecting Yes will open the EDR Data Mask upload function interface. 
 

 
 
The EDR Data download function downloads the binary data recorded in EDR 
memory. The number of the records to be downloaded will depend on the 
uploaded EDR Data Mask, the selected download rate and the selected 
download time period. The function may be accessed by selecting the 
Communication->Download Data->EDR Data menu item. 
 

 
 
The Download button will open the download rate and the download time 
period selection dialog box. Default options are set to Fast Data (30 rec/min) 
and Data 1 hour back. The user may change selection by clicking on the 
radio buttons. The EDR Download Information section shows approximate 
download time based on user parameter selection and uploaded EDR data 
mask. 
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Once the download parameters are selected, pressing the OK button will 
launch the download process. While data is being downloaded, the File, 
Select System, Select Port and the Communication drop down menus are 
deactivated. The toolbar buttons are modified and the Abort button is 
displayed; pressing this button will terminate the download process. A 
progress bar is displayed in the fifth status pane to indicate download 
progress. 
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When download is completed, the binary data is translated and formatted. A 
progress bar is displayed in the fifth status pane to indicate formatting 
progress. 
 

 
 
Once the formatting process concludes, a message is displayed in the 
viewing window and the Save button is added to the toolbar. Formatted 
downloaded EDR data is too large to be effectively viewed in the viewing 
window; it is best viewed in Microsoft Excel. 
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The Save toolbar button is used to save the formatted downloaded data. The 
Save toolbar button will open the Save File Dialog Box, which lets the user 
specify the drive, directory, and name of the file to save. The Save File Dialog 
Box will apply the function’s file extension mask (*.csv) and will default to the 
{root}\DU\EDR Data\ folder. When saved, the filename will be displayed in the 
fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the DU EDR Data download function will display the unsaved data error 
message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
DU EDR Data download function. Selecting No will exit the DU EDR Data 
download function without saving the downloaded data. 
 
Doing one of the following will exit the DU EDR Data download function and 
close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.2.2 Download DU Faults 

 
The DU Fault download function downloads the fault flag from the DU. The 
number of the records to be downloaded will depend on the data recorded in 
memory. The function may be accessed by selecting the Communication-
>Download Data->DU Faults menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
 

 
 
When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.2. 
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“C” indicates an ASCII character and “X” indicates a numeric character “0” 
thru “9”. 
 
When a CRC error is detected, the data is displayed in the viewing window, 
the Save button is added to the toolbar and the CRC error message box is 
displayed. 
 

 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.ddf) and will default to the 
{root}\DU\DU Faults\ folder. When saved, the filename will be displayed in the 
fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the DU Faults download function will display the unsaved data error 
message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
DU Faults download function. Selecting No will exit the DU Faults download 
function without saving the downloaded data. 
 
Doing one of the following will exit the DU Faults download function and close 
(or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.2.3 Upload EDR Data Mask 
 
The EDR Data Mask upload function stores a bit mask in DU RAM that is 
used to select which parameters to include in the EDR Data download 
(section 4.2.1). The function may be accessed by selecting the 
Communication->Upload Data->EDR Data Mask menu item. 
 
When selected, the Open File Dialog Box is displayed, which lets the user 
specify the drive, directory, and name of the file to open. The Open File 
Dialog Box will apply the function’s file extension mask (*.udm) and will 
default to the {root}\DU\EDR Data Mask\ folder.  
 

 
 
When opened, the file is displayed in the viewing window and the filename is 
displayed in the fifth status pane. 
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Pressing the Open button will display the Open File Dialog Box, at which 
point a different file may be selected for upload.  
 
The Upload button will launch the upload process. While data is being 
uploaded, the File, Select System, Select Port and the Communication 
drop down menus are deactivated. The toolbar buttons are modified and the 
Abort button is displayed; pressing this button will terminate the upload 
process. 
 

 
 
When data is uploaded, the toolbar regains its original buttons and the third 
status pane will display one of the status messages as defined in section 4.2. 
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Doing one of the following will exit the DU EDR Data Mask upload function 
and close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Open button and closing the Open File Dialog Box 

without selecting another file for upload 
• Pressing the toolbar’s Close button 
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4.2.4 Upload Normal Checklist 
 
The Normal Checklist upload function stores Normal Checklist data in NVM. 
The function may be accessed by selecting the Communication->Upload 
Data->Normal Checklist menu item. 
 
When selected, the Open File Dialog Box is displayed, which lets the user 
specify the drive, directory, and name of the file to open. The Open File 
Dialog Box will apply the function’s file extension mask (*.unc) and will default 
to the {root}\DU\Normal Checklist\ folder.  
 

 
 
When opened, the file is displayed in the viewing window and the filename is 
displayed in the fifth status pane. 
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Pressing the Open button will display the Open File Dialog Box, at which point 
a different file may be selected for upload.  
 
The Upload button will launch the upload process. While data is being 
uploaded, the File, Select System, Select Port and the Communication drop 
down menus are deactivated. The fifth status pane is used to display an 
upload progress bar. The toolbar buttons are modified and the Abort button is 
displayed; pressing this button will terminate the upload process. 
 

 
 
When data is uploaded, the toolbar regains its original buttons and the third 
status pane will display one of the status messages as defined in section 4.2. 
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Doing one of the following will exit the DU Normal Checklist upload function 
and close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Open button and closing the Open File Dialog Box 

without selecting another file for upload 
• Pressing the toolbar’s Close button 
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4.2.5 Upload Emergency Checklist 
 
The Emergency Checklist upload function stores Emergency Checklist data in 
NVM. The function may be accessed by selecting the Communication-
>Upload Data->Emergency Checklist menu item. 
 
When selected, the Open File Dialog Box is displayed, which lets the user 
specify the drive, directory, and name of the file to open. The Open File 
Dialog Box will apply the function’s file extension mask (*.uec) and will default 
to the {root}\DU\Emergency Checklist\ folder.  
 

 
 
When opened, the file is displayed in the viewing window and the filename is 
displayed in the fifth status pane. 
 

 



 
 
 
 
 
 
 
 
12,800 RUE DE L'AVENIR, MIRABEL, QUÉBEC J7J 1R4  

429-770-014-105
DMITS429 User Manual

 

112 

 
Pressing the Open button will display the Open File Dialog Box, at which 
point a different file may be selected for upload.  
 
The Upload button will launch the upload process. While data is being 
uploaded, the File, Select System, Select Port and the Communication 
drop down menus are deactivated. The fifth status pane is used to display an 
upload progress bar. The toolbar buttons are modified and the Abort button is 
displayed; pressing this button will terminate the upload process. 
 

 
 
When data is uploaded, the toolbar regains its original buttons and the third 
status pane will display one of the status messages as defined in section 4.2. 
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Doing one of the following will exit the DU Emergency Checklist upload 
function and close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Open button and closing the Open File Dialog Box 

without selecting another file for upload 
• Pressing the toolbar’s Close button 
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4.2.6 Upload Programmable CAS 
 
The Programmable CAS upload function stores a listing of CAS data in NVM. 
The function may be accessed by selecting the Communication->Upload 
Data-> Programmable CAS menu item and then entering the DMITS 
password in the password caption dialog box. 
 
After the DMITS password is validated, the Open File Dialog Box is displayed 
which lets the user specify the drive, directory, and name of the file to open. 
The Open File Dialog Box will apply the function’s file extension mask (*.upc) 
and will default to the {root}\DU\Programmable CAS\ folder.  
 

 
 
When opened, the file is displayed in the viewing window and the filename is 
displayed in the fifth status pane. 
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Pressing the Open button will display the Open File Dialog Box, at which 
point a different file may be selected for upload.  
 
The Upload button will launch the upload process. While data is being 
uploaded, the File, Select System, Select Port and the Communication 
drop down menus are deactivated. The toolbar buttons are modified and the 
Abort button is displayed; pressing this button will terminate the upload 
process. 
 

 
 
When data is uploaded, the toolbar regains its original buttons and the third 
status pane will display one of the status messages as defined in section 4.2. 
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Doing one of the following will exit the DU Programmable CAS upload 
function and close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Open button and closing the Open File Dialog Box 

without selecting another file for upload 
• Pressing the toolbar’s Close button 
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4.2.7 NVM Clear DU Faults 

 
The DU Fault NVM clear function erases the fault flag records from memory. 
The function may be accessed by selecting the Communication->Clear 
NVM->DU Faults menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation. 
 
The third status pane will display one of the status messages as defined in 
section 4.2. 
 

 
 

Note: 
 

The NVM clear function will be inhibited by the du 
unless the DU Faults were previously downloaded per 
section 4.2.2. 
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4.2.8 NVM Clear Normal Checklist 

 
The Normal Checklist NVM clear function erases the checklist records from 
memory. The function may be accessed by selecting the Communication-
>Clear NVM->Normal Checklist menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.2. 
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4.2.9 NVM Clear Emergency Checklist 

 
The Emergency Checklist NVM clear function erases the checklist records 
from memory. The function may be accessed by selecting the 
Communication->Clear NVM->Emergency Checklist menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.2. 
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4.2.10 NVM Clear Progrmmable CAS 

 
The Programmable CAS NVM clear function erases the CAS messages from 
memory. The function may be accessed by selecting the Communication-
>Clear NVM-> Programmable CAS menu item and then entering the DMITS 
password in the password caption dialog box.  
 

 
 
The confirmation message box is displayed after the DMITS password is 
validated. The Yes button will send the NVM clear command. The No button 
will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.2. 
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4.3 FCC Maintenance Functions 
 
There are two FCC installed on the model 429 helicopter. FCC selection is 
done via the GSE switch box. FCC maintenance functions include: 
 
Download Functions 
 
• Download FCC Faults/Events (section 4.3.1) 
• Download Rigging Data (section 4.3.2) 
 
NVM Clear Functions 
 
• NVM Clear FCC Faults/Events (section 4.3.3) 
• NVM Clear Rigging Data (section 4.3.4) 
 
When the FCC is selected as the desired system (Select System->FCC) and 
the communication port is configured (Select Port->COMX), the FCC’s 
communication checklist message box is displayed. The message box details 
the required setup to interface with the FCC’s maintenance functions. 
 

 
 
After the setup is completed and the checklist message box is closed, the 
communication interface with the FCC is initialized and the third status pane 
displays Initializing FCC interface…. If the initialization fails, a message box 
is displayed and the FCC is removed as the currently selected system. 
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Once the communication protocol is initialized, the FCC’s maintenance 
functions may be accessed through the Communication drop down menu. 
 

 
 
FCC maintenance functions may be processed by either one of the two FCC 
processors. The processor to use during the maintenance functions is set in 
the Communication drop down menu and indicated by a check mark. 
 
After performing a maintenance function, the third status pane will report one 
of the following status messages: 
 

STATUS MESSAGE DESCRIPTION SOURCE 
STATUS: READY Receipt of CR with no command FCC 

STATUS: CLEAR COMPLETE Successful completion of Clear 
command FCC 

STATUS: CLR NOT ALLOWED Receipt of inhibited clear command FCC 

STATUS: INVALID CMD Receipt of invalid command sequence FCC 

STATUS: ERROR - NO FEEDBACK No feedback from FCC after using a 
clear command DMITS429 

STATUS: DNLD COMPLETE Download function has completed DMITS429 

STATUS: ERROR - NO DATA Download function has failed, no data 
was received from the FCC DMITS429 

STATUS: DNLD ABORTED Download function was aborted using 
the Abort Toolbar button DMITS429 

STATUS: NVM CLEAR CANCELLED
Memory clear was cancelled by 
selecting No on the confirmation 
message box 

DMITS429 
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4.3.1 Download FCC Faults/Events 

 
The FCC Faults/Events download function downloads the faults and events 
from the FCC. The number of the records to be downloaded will depend on 
the data recorded in memory. The function may be accessed by selecting the 
Communication->Download Data->FCC Faults/Events menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process but will require reinitializing the FCC 
maintenance interface (per section 4.3). 
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Note: 

 
This function might require a long time to complete. if 
the third status pane still indicates downloading -> 
after 5 seconds, the download is underway and the 
function should be allowed to complete (to avoid 
reinitializing the FCC maintenance interface). 

 
While the data is downloading, the viewing window will be refreshed every 
time a new fault/event is received. When the data is successful downloaded, 
the complete data is displayed in the viewing window and the Save button is 
added to the toolbar. The third status pane will display one of the status 
messages as defined in section 4.3. 
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For each fault/event record, the lines starting “P0”, “P1”, “P2” and “P3” are 
optional depending on the event record. The “Z” are ASCII character string to 
describe the fault or recorded parameter (this can be either a description or 
description with data.) The “(ZXX)” following P0 thru P4 are either two or 
three characters to describe data type (e.g. (U8) for unsigned 8 bit (S32) for 
signed 32 bit, etc.) The title lines (first 8 lines of the table) are be transmitted 
prior to sending the first record (the most recent record) in the list. The last 
line of the table is transmitted after the last record (the oldest record) in the 
event list. Refer to the maintenance manual for more details on each fault. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dfe) and will default to the 
{root}\FCC\Faults & Events\ folder. When saved, the filename will be 
displayed in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the FCC Faults/Events download function will display the unsaved data 
error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
FCC Faults/Events download function. Selecting No will exit the FCC 
Faults/Events download function without saving the downloaded data. 
 
Doing one of the following will exit the FCC Faults/Events download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.3.2 Download Rigging Data 

 
The Rigging Data download function downloads the stored CMT offset rigging 
data from the FCC. The function may be accessed by selecting the 
Communication->Download Data->Rigging Data menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.3. 
 

 
 
“X” indicates a numeric character “0” thru “9”. Three dashes “- - -” indicates a 
parameter is invalid or has not been initialized in NVM for that axis. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.drd) and will default to the 
{root}\FCC\Rigging Data\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the FCC Rigging Data download function will display the unsaved data 
error message box: 
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Selecting Yes will let the user save the downloaded data before exiting the 
FCC Rigging Data download function. Selecting No will exit the FCC Rigging 
Data download function without saving the downloaded data. 
 
Doing one of the following will exit the FCC Rigging Data download function 
and close (or reset) the viewing window:  
 

• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop down 

menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.3.3 NVM Clear FCC Faults/Events 

 
The FCC Faults/Events NVM clear function erases the records from memory. 
The function may be accessed by selecting the Communication->Clear 
NVM->FCC Faults/Events menu item. 
 

Note: 
 
The FCC faults/events clear function is disabled for 
S/W 429-770-014-109, Version 1.0. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation. 
 
The third status pane will display one of the status messages as defined in 
section 4.3. 
 

 
 

Note: 
 

The NVM clear function will be inhibited by the fcc 
unless the FCC Faults/Events were previously 
downloaded per section 4.3.1. 
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4.3.4 NVM Clear Rigging Data 

 
The Rigging Data NVM clear function clears all the rigging correction values 
from memory. The function may be accessed by selecting the 
Communication->Clear NVM->Rigging Data menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.3. 
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4.4 LPS Maintenance Functions 
 
There is one LPS installed on the model 429 helicopter. Selection is done via 
the GSE switch box. LPS maintenance functions include. 
 
Download Functions 
 
• Download Dimming Table (section 4.4.1) 
• Download All Dimming Tables (section 4.4.2) 
• Download LPS Fault Log (section 4.4.3) 
• Download Status Data (section 4.4.4) 
• Download Table CRC (section 4.4.5) 
• Download Version Data (section 4.4.6) 
 
Upload Functions 
 
• Upload Dimming Table (section 4.4.7) 
 
NVM Clear Functions 
 
• NVM Clear Fault Log (section 4.4.8) 
 
When the LPS is selected as the desired system (Select System->LPS) and 
the communication port is configured (Select Port->COMX), the LPS’s 
communication checklist message box is displayed. The message box details 
the required setup to interface with the LPS’s maintenance functions. 
 

 
 
After the setup is completed and the message box is closed, the LPS’s 
maintenance functions may be accessed through the Communication drop down 
menu. 
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After performing a maintenance function, the third status pane will report one 
of the following status messages: 
 

STATUS MESSAGE DESCRIPTION SOURCE 

STATUS: UPLD COMPLETE Successful completion of upload 
command LPS 

STATUS: UPLD ERROR Parity or format error in uploaded data LPS 

STATUS: CLEAR COMPLETE Successful completion of clear 
command LPS 

STATUS: CLR NOT ALLOWED Receipt of inhibited clear command LPS 

STATUS: ERROR - NO FEEDBACK No feedback from LPS after using an 
upload or a clear command DMITS429 

STATUS: UPLD ABORTED Upload function was aborted using the 
Abort Toolbar button DMITS429 

STATUS: DNLD COMPLETE Download function has completed DMITS429 

STATUS: ERROR - NO DATA Download function has failed, no data 
was received from the LPS DMITS429 

STATUS: DNLD INCOMPLETE Download function has not received 
the expected data DMITS429 

STATUS: DNLD ABORTED Download function was aborted using 
the Abort Toolbar button DMITS429 

STATUS: NVM CLEAR CANCELLED
Memory clear was cancelled by 
selecting No on the confirmation 
message box 

DMITS429 
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The following correlates LPS table numbers (used by the maintenance 
interface) to the LPS output number and associated systems. 
 

Table 

No. 

LPS Output 

No. 
System 

Table 

No. 

LPS Output

No. 
System 

1 5 VDC #1 Standby Attitude Indicator 21 28 VDC #6 Spare 

2 5 VDC #2 GPS/NAV/COM #1 22 28 VDC #7 Lighting & ECS Control 
Panel Edgelit 

3 5 VDC #3 GPS/NAV/COM #2 23 28 VDC #8 Air Conditioning Control 
Panel Edgelit 

4 5 VDC #4 Standby Altimeter 24 28 VDC #9 CHFD Panel Edgelit 

5 5 VDC #5 Standby Airspeed Indicator 25 28 VDC #10 Audio Panel 

6 5 VDC #6 Spare 26 28 VDC #11 Transponder 

7 5 VDC #7 Spare 27 28 VDC #12 ADF 

8 5 VDC #8 Spare 28 28 VDC #13 Standby Compass 

9 5 VDC #9 Spare 29 28 VDC #14 Right Display Unit Besel 

10 5 VDC #10 Spare 30 28 VDC #15 Center Display Unit 
Besel 

11 5 VDC #11 Spare 31 28 VDC #16 Left Display Unit Besel 

12 5 VDC #12 Spare 32 28 VDC #17 Pilot Map Light 

13 5 VDC #13 Spare 33 28 VDC #18 Copilot Map Light 

14 5 VDC #14 Spare 34 28 VDC #19 Pilot Collective Edgelit 

15 5 VDC #15 Spare 35 28 VDC #20 Copilot Collective 
Edgelit 

16 28 VDC #1 Miscellaneous Control 
Panel Edgelit 36 28 VDC #21 Weather Radar Control 

Panel Annunciators 

17 28 VDC #2 Weather Radar Control 
Panel Edgelit 37 28 VDC #22 Spare 

18 28 VDC #3 Wheel Gear Control Panel 
Edgelit 38 28 VDC #23 Spare 

19 28 VDC #4 Electrical Control Panel 
Edgelit 39 28 VDC #24 Spare 

20 28 VDC #5 Engine & Fire Control 
Panel Edgelit 40 28 VDC #25 Spare 
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4.4.1 Download Dimming Table 
 
The Dimming Table download function downloads the dimming table data of a 
particular table stored in the LPS. The function may be accessed by selecting 
the Communication->Download Data->Dimming Table menu item. 
 

 
 
The Download button will open the Dimming Table Download selection 
dialog box. 
 

 
 
Entering a valid dimming table number (1 to 40) and pressing the OK button 
will launch the download process. While data is being downloaded, the File, 
Select System, Select Port and the Communication drop down menus are 
deactivated. The toolbar buttons are modified and the Abort button is 
displayed; pressing this button will terminate the download process. 
 

 



 
 
 
 
 
 
 
 
12,800 RUE DE L'AVENIR, MIRABEL, QUÉBEC J7J 1R4  

429-770-014-105
DMITS429 User Manual

 

135 

 
When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
“XX” indicates a numeric character “01” thru “40” and represents the dimming 
table number. “HH” indicates the hexadecimal values of the output voltages 
associated to different potentiometer position. Voltages are linearly scaled on 
the 256 possible values. “00” corresponds to 0 volts while “FF” corresponds to 
5 volts for tables 1 thru 15 and 28 volts for tables 16 thru 40. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.csv) and will default to the 
{root}\LPS\Dimming Table\ folder. When saved, the filename will be displayed 
in the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the LPS Dimming Table download function will display the unsaved data 
error message box: 
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Selecting Yes will let the user save the downloaded data before exiting the 
LPS Dimming Table download function. Selecting No will exit the LPS 
Dimming Table download function without saving the downloaded data. 
 
Doing one of the following will exit the LPS Dimming Table download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.2 Download All Dimming Tables 

 
The All Dimming Tables download function downloads the dimming table data 
of every table stored in the LPS. The function may be accessed by selecting 
the Communication->Download Data->All Dimming Table menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. A progress bar is displayed in the fifth status 
pane to indicate download progress. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
“XX” indicates a numeric character “01” thru “40” and represent the dimming 
table’s number. “HH” indicates the hexadecimal values of the output voltages 
associated to different potentiometer position. Voltages are linearly scaled on 
the 256 possible values. “00” corresponds to 0 volts while “FF” corresponds to 
5 volts for tables 1 thru 15 and 28 volts for tables 16 thru 40. 
 
The downloaded information may not be saved. To save dimming table data, 
download individual dimming table per section 4.4.1. 
 
Doing one of the following will exit the All Dimming Table download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.3 Download LPS Fault Log 

 
The LPS Fault Log download function downloads the fault code data stored in 
the LPS. The function may be accessed by selecting the Communication-
>Download Data->Fault Log menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
The fault codes transmitted by the LPS have the “XX,YY” format. They are 
translated by the application according to the following table. 
 

Fault 
Code 

Displayed Fault Message 

VOLTAGE OUTPUT FAULT #XX1 (System Name) XX,VE 
00,TE OVER TEMPERATURE FAULT 
00,PM PROGRAM MEMORY CHECK SUM FAULT 
XX,TM TABLE MEMORY CHECK SUM FAULT #XX (System 

Name) 
 
When a code does not match any of the above codes, the “UNRECOGNIZED 
FAULT (XX,YY)” message is displayed, where “XX,YY” is the fault code 
transmitted by the LPS. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dfl) and will default to the 
{root}\LPS\Fault Log\ folder. When saved, the filename will be displayed in the 
fifth status pane. 
 

 

                                            
1 XX indicates the output table number; 01 thru 40. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the LPS Fault Log download function will display the unsaved data error 
message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
LPS Fault Log download function. Selecting No will exit the LPS Fault Log 
download function without saving the downloaded data. 
 
Doing one of the following will exit the LPS Fault Log download function and 
close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.4 Download Status Data 

 
The Status Data download function downloads the current temperature 
sensor values, input switch status and output voltage levels from the LPS. 
The function may be accessed by selecting the Communication->Download 
Data->Status Data menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
The VOUT FEEDBACK “HH” indicates the hexadecimal values of the output 
voltages associated to current potentiometer position. The 
POTENTIOMETER “HH” indicates the hexadecimal value of the current 
potentiometer position. The TST, MNT, DIM, NVIS “B” indicates binary values 
“0” or “1” to represent the status of the switches. The TEMPERATURE DEG. 
C. “XX” indicates a numeric character “0” thru “9” to represent values of the 
temperature sensors. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dsd) and will default to the 
{root}\LPS\Status Data\ folder. When saved, the filename will be displayed in 
the fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the LPS Status Data download function will display the unsaved data 
error message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
LPS Status Data download function. Selecting No will exit the LPS Status 
Data download function without saving the downloaded data. 
 
Doing one of the following will exit the LPS Status Data download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.5 Download Table CRC 

 
The Table CRC download function downloads the dimming tables CRC 
values from the LPS. The function may be accessed by selecting the 
Communication->Download Data->Table CRC menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
“HHHH” indicates the hexadecimal value of the dimming table CRC. The first 
two “HH” represent the HI byte and the last two “HH” represent the LO byte. 
The first CRC value is associated to dimming table 1, the remaining are 
presented sequentially up to dimming table 40. 
 
The Save toolbar button is used to save the downloaded data. The Save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dcr) and will default to the 
{root}\LPS\Table CRC\ folder. When saved, the filename will be displayed in 
the fifth status pane. 
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If data was successful downloaded but not subsequently saved, attempting to 
exit the LPS Table CRC download function will display the unsaved data error 
message box: 
 

 
 
Selecting Yes will let the user save the downloaded data before exiting the 
LPS Table CRC download function. Selecting No will exit the LPS Table CRC 
download function without saving the downloaded data. 
 
Doing one of the following will exit the LPS Table CRC download function and 
close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.6 Download Version Data 

 
The Version Data download function downloads the product name, company 
name and the loaded software version from the LPS. The function may be 
accessed by selecting the Communication->Download Data->Version Data 
menu item. 
 

 
 
The Download button will launch the download process. 
 
While data is being downloaded, the File, Select System, Select Port and 
the Communication drop down menus are deactivated. The toolbar buttons 
are modified and the Abort button is displayed; pressing this button will 
terminate the download process. 
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When the data is successful downloaded, the data is displayed in the viewing 
window and the Save button is added to the toolbar. The third status pane will 
display one of the status messages as defined in section 4.4. 
 

 
 
The “X.X” indicates the revision. The “HHHH” indicates the two byte of the 
calculated CRC in hexadecimal. 
 
The Save toolbar button is used to save the downloaded data. The save 
toolbar button will open the Save File Dialog Box, which lets the user specify 
the drive, directory, and name of the file to save. The Save File Dialog Box 
will apply the function’s file extension mask (*.dvd) and will default to the 
{root}\LPS\Version Data\ folder. When saved, the filename will be displayed in 
the fifth status pane. 
 

 
 
If data was successful downloaded but not subsequently saved, attempting to 
exit the LPS Version Data download function will display the unsaved data 
error message box: 
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Selecting Yes will let the user save the downloaded data before exiting the 
LPS Version Data download function. Selecting No will exit the LPS Version 
Data download function without saving the downloaded data. 
 
Doing one of the following will exit the LPS Version Data download function 
and close (or reset) the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.7 Upload Dimming Table 
 
The Dimming Table upload function stores the dimming table data of a 
particular output in the LPS. The function may be accessed by selecting the 
Communication->Upload Data->Dimming Table menu item. 
 

 
 
The Upload button will open the Open File Dialog Box, which lets the user 
specify the drive, directory, and name of the file to open. The Open File 
Dialog Box will apply the function’s file extension mask (*.csv) and will default 
to the {root}\LPS\Dimming Table\ folder. Multiple files4 may be selected at 
once. In the example below, five tables will be uploaded by the upload 
process. 
 

 
                                            
4 There is no limit on the number of dimming table to select; user may upload 1 or all 40 tables. 
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When all desired files are selected and the Open button pressed, the upload 
process is launched. The current table data is displayed in the viewing 
window (on the lower row) as it is uploaded and its filename is displayed in 
the fifth status pane. 
 

 
 
When a table is uploaded, the application listens for a status message form 
the LPS. These messages, as defined in section 4.4, are displayed in the 
third status pane. When multiple files are selected for upload, the status 
messages are displayed for one second in the third status pane and are 
added following the table data before the upload process continues with the 
next file in the sequence.  
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While data is being uploaded, the File, Select System, Select Port and the 
Communication drop down menus are deactivated. The toolbar buttons are 
modified and the Abort button is displayed; pressing this button will complete 
the current file upload and then terminate the upload process. 
 
When all files are uploaded, the toolbar regains its original buttons. 
 

 
 
Doing one of the following will exit the LPS Dimming Table upload function 
and close the viewing window:  
 
• Selecting a menu item in the File->View horizontal drop down menu 
• Selecting a different maintenance system in the Select System drop 

down menu 
• Selecting the Select Port->Close Port menu item 
• Selecting a menu item in the Communication drop down menu 
• Pressing the toolbar’s Close button 
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4.4.8 NVM Clear Fault Log 

 
The Fault Log NVM clear function clears all the fault log data from memory. 
The function may be accessed by selecting the Communication->Clear 
NVM->Fault Log menu item. 
 

 
 
The confirmation message box is displayed. The Yes button will send the 
NVM clear command. The No button will cancel the clear operation.  
 
The third status pane will display one of the status messages as defined in 
section 4.4. 
 

 
 

Note: 
 
The NVM clear function will be inhibited by the lps 
unless the LPS FAULT LOG wAS previously 
downloaded per section 4.4.3. 
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5.0 ACRONYMNS 

 
 
ADF···················Automatic Direction Finder 
ADMM ···············Aircraft Data Memory Module 
ADIU ·················Aircraft Data Interface Unit 
ARINC···············Aeronautical Radio Incorporated 
ASCII·················American Standard Code for Information Interchange 
CAS···················Crew Alerting System 
CHFD ················Course / Heading / Flight Director Panel 
COM··················Communication 
CRC ··················Cyclic Redundancy Check 
DMITS···············Diagnostic and Maintenance Information Transfer System 
DU·····················Display Unit 
EDR ··················Electronic Data Recorder 
FCC···················Flight Control Computer 
GPS ··················Global Positioning System 
GSE ··················Ground Service Equipment 
IAS ····················Integrated Avionics System 
LPS ···················Lighting Power Supply 
NAV···················Navigation 
NVM ··················Non Volatile Memory 
PC ·····················Personnal computer 
P/N ····················Part Number 
UAC ··················User Account Control 
USB···················Universal Serial Bus 
XFER·················Transfer 
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