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Introduction 
 
Procoder for Digital Video was developed at the John F. Kennedy Center at Vanderbilt 
University to facilitate the collection of different forms of observational data from digital 
media files.  Media files can be any files that contain events of interest on digital video or 
audio files.   Data files can be of two general types: event files or transcription files.  Files 
can be exported into MOOSES (Tapp & Wehby, 1995) format or SALT (Miller & 
Chapman, 1993) format or can be read directly by many popular statistical or spreadsheet 
programs. A code file can be used in conjunction with ProcoderDV to guide the coder in 
marking events for later quantification and analysis. 
 
Files connected with ProcoderDV are of three general types: 1) data files that store the 
data being collected, 2) video movie or sound files that are in one of the standard 
supported formats, and 3) code files that hold the code set you are working with.  Data 
files can be either in transcript-type format or events-type format.  The event files can be 
arranged in groups of codes that are related on some dimension if desired.  Transcript 
files consist of times, codes, and a transcription for each record.  For analysis, data can be 
easily exported to SALT format (for transcriptions) or MOOSES format (for events).  
The data files are in comma-separated text format and can be opened with most 
spreadsheet, word processor, or statistical programs.  The MOOSES and SALT export 
options are not needed to use the data you collect.  Data can be sorted by columns and 
filtered to display instances of events that are coded alike or have the same string in them.  
Fixed-interval coding can be done by simply turning it on in the options dialog box and 
entering your interval.  You then get the next interval time calculated when you add rows. 

Requirements 
 
Some way of making your digital media is required (see Capture Recommendations 
section of this manual).  ProcoderDV does not do video or audio capture in this version.  
There are several good commercially available capture programs.  ProcoderDV requires a 
computer running Windows 98 or later with Windows XP being the preferred operating 
system for ProcoderDV. The minimum processor speed of the machine should be 
300MHZ or higher and the minimum RAM should be 128Megabytes.   The type of media 
files used will determine the computer power you need.  In general, if the media can be 
played smoothly with Windows Media Player on the machine it should work fine with 
ProcoderDV.  A registered email address and an Internet connection to the computer is 
required to activate the program but is not required while operating the program.  This 
manual assumes that you have experience with Microsoft Windows and can navigate 
standard pull-down menus and controls found in all windows programs. 
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Getting Started 
 
The free demo version of ProcoderDV can be downloaded and shared freely.  It is limited 
to only 10 rows of data, and some features are disabled.  Once you download the 
program, run it and follow the onscreen directions to install it.   The installer will put a 
shortcut to the program on the Start menu of your computer.  Pick ProcoderDV from the 
Start menu to run the program.  If you have purchased a license, you will be able to 
activate your copy using your registered email and customer ID by picking Activate this 
Copy on the Help menu.   The Getting Started section is a quick overview of the 
operation of the program.  More detailed explanations are found in subsequent sections of 
the manual. 
 
A small main window opens with a few menu choices when the program is first run.  To 
get started click on File then New then select the type of file you'd like to create, (e.g., 
data file or code file).  Once you create a new file you can enter relevant information 
about it in the provided fields and then enter data in the grid on the Data tab. The data file 
has fields that attach code files and video/media files to the data file.  To do that, open a 
code file or video file using the small main window’s menus and click on the Use Current 
button to attach the code or media file to the data file.  Once a data file is saved in this 
way, the code and media files are opened automatically when a data file is opened.  The 
code file is not shown by default unless you choose Show Loaded Code File from the 
data form's menu.   The data grid adjusts automatically to your code set when the data file 
is opened or can be adjusted manually by selecting Adjust Data Grid for Current Codes 
Set in the Data menu on the Data window.  The codes can be entered by editing directly 
in the cell or by pulldown lists.  This is set in the Options.  If you change that option it is 
necessary to do a manual adjustment to the new code settings.  Once you arrange the 
windows on the screen and save your data, the windows will appear in the same place the 
next time you use the program. 
 
You can associate a media file with your data file by opening the media file and a data 
file, then attach the media file to the data file using the Use Current button in the data 
window.  Once you save the data file, the media file will be opened automatically the 
next time the data file is opened (if the media file is still in the same location on your 
computer).  If you hover the mouse over them briefly, the toolbars on the windows have 
tool tips that tell you what each button does. Most of the menus should be self-
explanatory.  The options you can set are in the Options box under Edit on the main 
window.  
 
These are a few tips about things that are not on menus:  The time can be marked in the 
frame column by holding down Alt and clicking on the frame column in the row you 
want to mark.  If you hold down Ctrl and click on a row the video will seek that location.  
The grid can be sized by dragging columns wider or smaller or auto sized when a change 
is made or when you double click on a column boundary.  The menu controls have some 
Ctrl keys attached to make playing, marking and other functions easier while keeping 
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your hands on the keyboard.  The quick keys method is way cool option.  If enabled, 
Quick Keys allow you to mark an event and add a data row with one keystroke.  It uses 
the first letter of the code to determine the key/code that will be inserted.  A video must 
be opened to use quick keys or it will not work because it cannot get the video time.  
 
When you first begin to use ProcoderDV you must decide what time format you want to 
use: frames or seconds.  It is probably best to use seconds with ProcoderDV.  It will give 
you time down to 2 decimal places on a second.  You can use frames with media formats 
that support them.  Playing your media file will display an error message if you attempt 
to use frames in a format that does not support them.  Frame-based formats are either of 
fairly low quality (i.e., MPEG-1) or are large in file size (i.e., DV format or MPEG-2).  
Modern compression schemes use a previous frame (a key frame) to keep picture 
information that does not change in order to save space in the file, so frame-based 
formats are becoming less popular.  Changing time formats will have undesirable effects 
in the program when older files are loaded that are not in the currently set time format. 
Choose you time format and stick with it. 
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ProcoderDV Operation 
 
This section describes the operation of ProcoderDV in terms of the four windows that are 
part of the program: the main window, the media window, the data window, and the 
codes window.  The program was designed in separate windows to allow for placement 
of the media window on another screen if desired.   The placement of the windows on the 
screen is saved with the system setting each time the program is exited.  When you 
resume working the window positions will remain how you have arranged them.  The 
program is designed to be very simple to use and yet powerful and versatile in the ways it 
can collect data from media files. 

The Main Window 

 
 
The main window functions as a starting place to allow creation of new files and opening 
existing files.  The main window has three drop down menus: the File menu, the Fdit 
menu, and the Help menu.  When you run the program from the Start menu in Windows, 
the main window is the one that opens first. 
 
The File menu has two submenus: New and Open.  The New submenu lets you create a 
new event file, code file, or transcription file.  Once you select an option, a standard 
windows dialog box opens to let you name the file and pick the location of the file on 
your hard drive.  The Open menu lets you open existing data files, code files, or media 
files.  You can also import existing SALT transcripts into a ProcoderDV transcription file 
using the Open menu.  
 
The four most recently opened files are also placed on the File menu for your 
convenience so that you can easily return to your work on files you have already started.  
Additionally, the File menu has the Exit selection that closes the program and saves all 
currently loaded data and settings. 
 
The Edit menu allows you to open the Options dialog box (see the Optional Settings 
section) and set all the options to their defaults if you wish. 
 
The Help menu on the main window has the Activate command that lets you activate 
your copy of the program.  The About box in the Help menu tells you the version of the 
software you have. 
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The Media Window 

 
 
The Media window allows control of the media file.  Media files can be either videos or 
sound files.  The window can be sized and the video size within the window can be 
adjusted using the Control menu on the menu bar.  The File menu allows you to close the 
current file and open another file if desired.  The Control menu has Play, Stop, and Mute 
as well as Speed control and Size control. 
 
Under the video window there is a slider that lets you set the position of your media file 
in time.  The slider also moves as the media plays to indicate the position.    
There are standard controls on a toolbar at the bottom of the window.  The buttons, in the 
order that they appear, are used for play, pause, go to start, frame advance back, frame 
advance forward, and go to end.  On the bottom right there is a volume control slider. The 
current time in the selected format is displayed on the bottom left of the media window 
(see Optional Settings in the manual for time formats). 
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The Data Window 
 
The Data file window has two tabs in the main window (File Info and Data), a toolbar, 
and pull down menus.   
 

 
Data window showing the File Info tab 

File Info Tab 
 
The File Info tab can be used to include some information about the session you are 
coding.  This information is stored in the file for your labeling purposes.  Filling in the 
items in the file info tab is optional according to your needs.   In the File Info tab you can 
hold Ctrl and click in the frame text boxes to insert the current time of the media file 
automatically.  Holding Ctrl and clicking in the date text boxes also inserts the current 
computer date automatically.  The start and end times can be used to calculate the 
duration of the session by clicking on the Calc Length text label. 
 
The media file text box tells the program which media file is linked to the current data 
file.  The file in this textbox, if found on the disk, is loaded when the data file is opened.  
The file name must contain the full path to the file.  Similarly, the code file text box tells 
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the program which code file is linked to the current session.  If the code file is found,  it is 
loaded into memory and the data grid is adjusted to that code file when it is loaded.  The 
code file window is not displayed automatically but is available using the Show Loaded 
Code File command on the data pull down menu. 
 

 
Data window showing the Data tab. 

Data Tab 
 
The Data tab is where you enter data about your media.  Data rows are linked to a 
particular time on the media file using the Mark button or command.  You can set a few 
different ways of entering data into the data grid.  These options are described in the Data 
Options section of this manual.  Once data are entered, the toolbar and menu commands 
can be used to find the marked events on the media file instantly by using the Seek button 
or Seek menu selection. 

Working with the Data Grid 
 
Columns can be sized to the widest entry automatically by hovering the mouse over a 
column boundary and double clicking.  You can also size columns by dragging the 
column boundaries with the mouse. Depending on the selection mode (see Data Menu 
Commands section below), you can select rows, columns, or areas.  Holding Shift allows 
you to select ranges of cells that are next to each other, and holding Ctrl lets you select 
cells that are not next to each other.  Standard keys for cut (Ctrl + x), copy (Ctrl + c) and 
paste (Ctrl + v) are supported and allow you to copy and paste data into other programs.   
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File Menu Commands in the Data Window 
 
The File menu in the data window has commands for dealing with the data files.  
Standard commands include Save, Save As, Save and Close, Revert (to the saved file on 
this disk), Print, Export and Exit Without Saving.  Data is saved automatically if the data 
window is closed unless you pick Exit Without Saving from the File menu.  Currently, 
the only way to undo any changes made in the data is by reverting to the saved file on the 
disk. 

Media Control Menu Commands in the Data Window 
 
The Media Control menu has all the commands needed to control the media file in the 
media window.  You can play, seek, replay, and do other functions using these menus.   
Shortcut keys are assigned to commands as shown in the menus and enable media 
control.  Using these keys lets you control the media without the need to leave the data 
window.  The best way to use ProcoderDV is to keep the data window active and use the 
commands in the data window to control the media as you code.  Keep in mind that the 
data window menu commands are only available when the data window is the active 
window on the screen.  Using the media controls in the media window makes the media 
window the active window.  Similarly if you are using the Quick-keys option to code, the 
data grid must be the active control in the data window to register the keystrokes (see the 
Optional Settings section of this manual).   
 
The Frame Ahead and Frame Back commands move the smallest time increment possible 
for the loaded media.  The Mark command marks the current media time on the currently 
selected row in the data grid.  The way replay works can be set in the options dialog box.  
You can play for a short time before and after the current row, play from the previous 
row time to the current row time, or play from the current row time to the next row time. 
The Preroll and Play command lets you quickly rewind from the current media position 
back to the designated pre-roll length before and then start playing from there.  A table of 
the commands and keystrokes for them is provided below. 
 

Media Function Key to press 
Play Ctrl + d 
Stop/Pause Ctrl + f 
Go to Start Ctrl + g 
Frame Back F7 
Frame Ahead F8 
Mark Ctrl + e 
Seek/Find Ctrl + r 
Replay Ctrl + a 
Preroll and Play Ctrl + b 
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Data Menu Commands in the Data Window 
 
The Data menu allows you to control how the data are displayed in the data grid.  You 
can easily filter rows to replay events of interest with similar coding and hide other rows. 
This allows you to find and play sections quickly that are coded the same.  You can sort 
the data by any column.  Data are automatically sorted when exported to other file 
formats.  The ability to sort back easily by time allows you to code any time on the media 
in any order. You do not have to code the beginning before you code the end for 
example.    
 
The Show Loaded Code File selection displays the currently loaded code file.  The code 
file is loaded when the data file is loaded if there is one referenced in the data file’s 
header.  However, to save screen space, the code file is not displayed automatically.  The 
Adjust Grid to Current Code File command sets the row titles using the group 
descriptions setting in the code file.  Columns for code groups that are not defined are 
hidden automatically.  The cells in the grid are adjusted to the current entry method as set 
in the data options.  When the code file is loaded while loading the data file, the data grid 
is adjusted to the current settings automatically as well. 
 
The Fill in Initial Codes command inserts the first code found for each code group in the 
first row of the data grid.  This allows you to set the initial state of your coding for all 
groups quickly to default values.  The Add Rows command allows you to add more than 
one row to the data grid at one time.  If interval coding is enabled in the options, the 
times of the fixed intervals are added automatically. 
 
The grid selection mode can be set to select ranges, rows, or columns.   You can select 
columns and hide them or select multiple rows for deletion.  When Row Selection is 
enabled you can select rows that are contiguous by holding Shift and clicking on the first 
then the last row in the range you want to select.  You can also select rows that are not 
contiguous by holding Ctrl and selecting rows by clicking them.  Standard keys for cut 
(Ctrl + x), copy (Ctrl + c) and paste (Ctrl + v) are supported and allow you to copy and 
paste data into other programs. 

Data Window Toolbar 
 
The toolbar in the data window lets you quickly access some of the most often used 
commands on the drop down menus using the mouse.  The Media button displays or 
loads the media file that is currently loaded or referenced in the data File Info tab.  Other 
toolbar functions are described in the Menu Commands sections above. 
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The Codes Window 

 
 
The Codes window lets you edit your code file that controls the appearance of the data 
grid and the code you have to choose from while coding your media file. The effects of 
codes on the data grid are described in detail in the Code Files section of this manual.  A 
code file is not required but it helps guide the coder in what types of codes should be 
entered into the data grid.  The code file is loaded and the data grid is adjusted 
automatically if a code file is referenced in the file info part of the data file. 
 
The toolbar and command menus in the code file menu let you control the code file grid.   
The File menu has standard file commands for the code file.  You can open a new code 
file, save the code file, save the code file with a different name, and so on.  Hovering the 
mouse over a toolbar item pops up a short description of the toolbar button’s function.  
The toolbar commands in order are:  Open, Save, Save As, Delete (the current code row), 
Move Code Up, Move Code Down, Add a New Code, Insert a Code, Revert to the Saved 
Code File, Erase All Codes, and Help. 
 
A code definition consists of the code, a description of the code and the group.  The 
group in ProcoderDV equates to a column in the data grid window.  The group 
descriptions allow you to label columns in the data grid for coding.  If the data grid is 
adjusted to the current code file, the columns that are not used are hidden automatically.  
Codes can be entered manually in the data grid or the code file can be used to display 
pick lists of either codes or descriptions. This is described in the Optional Settings section 
of this manual.  
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Code Files 
 
A code file in ProcoderDV allows you to customize the coding scheme and data grid for 
your particular task.   Designing a code file depends on what type of coding you want to 
do with the program.   Five general methods of coding are supported:  
 

• Event coding 
• Event coding with qualifier codes 
• Fixed-interval coding  
• Fixed-interval coding with qualifiers 
• Transcription 

 
Each of these methods is described here in detail so that you can decide which type of 
coding you need to do to address your research question.  Read this section carefully to 
determine which type of coding method(s) best answers your research questions. 
 

Event Coding 
 
For coding events, it is best to set up a coding scheme with codes that are mutually 
exclusive and exhaustive within a code group.   You can have up to 49 code groups.  For 
a simple example, consider the situation in which you want to measure the duration in 
time that a target subject is talking.  You would need 2 codes in one group:  one code for 
talking (T) and one for not talking (N).  This way the 2 codes are mutually exclusive 
(they do not mean the same thing) and exhaustive (they cover the entire time you are 
observing).    When the media starts, mark a code in a data row that indicates talking or 
not talking (T or N).  Then when talking occurs, mark a new row with the talking code 
(T).  When talking stops, add a row with the not talking code (N) and so on until the 
observation period is over.   To be more realistic about this coding scheme, you may want 
to add a third code that means “I can’t see if the subject is talking or not” and put it in the 
same group.  Codes in the same group “start” and “stop” each other. 
 
To expand on this example, let us assume you want to know the duration of talking from 
the subject when a certain person is present or not (e.g., whether or not the teacher is in 
the room).  To get these data, you would create another code group that indicates whether 
the teacher is present (P) or not (A).  In ProcoderDV, codes in different groups go into 
different columns in the data file grid.  Let us also add a desire to know how often the 
subject blinks and let us say that in this case you do not care how long a blink lasts.  You 
can use B for the blink code and put blinks in level 0.  In MOOSES, level 0 indicates that 
the code is a “frequency only” code.  Procoder does not care what level codes are in, so 
we just use level 0 for frequency-only codes to comply with MOOSES.   If you make the 
talking codes in group 1, and the teacher codes in group 2, a sample data file could look 
like the one shown below.   The code file for that grid arrangement is shown below the 
data file.. 
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Event codes from three groups 
 

 
A simple code file 
 
Codes are added to the code grid in the data file by using the Add Rows button on the 
toolbar.  You can then click in the cells and fill in the codes as needed.   
 
The menus in the Code File Editor are standard and self-explanatory.  All toolbars have 
tool tips that show you what each tool does when you hover the mouse over the tool.  The 
Group Descriptions tab in the Code File Editor allows you to put a label on the data file 
column for each group. 
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Event Coding with Qualifiers 
 
Sometimes you want to qualify a coded event with some type of measure.  Suppose you 
are still interested in talking but the sound level of talking is important to you.  In this 
case, you would set up an additional code group containing codes that indicate the sound 
level of talking.  For simplicity, we will use three codes to quantify this -- Soft (S), 
Medium (M), and Loud (L) -- but you can use as many codes as you wish.  The code file 
and data file with the sound level qualifier added are shown below 
 

 
Code file with modifiers for talking sound level 
 

 
Event data file with talking sound level entered 
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The graphic below shows how to set the options to export the sound level codes (group 3) 
together with the talking codes (group 1) to make a single qualified code for MOOSES to 
use. Exporting and options are described in more detail elsewhere in this manual.  
 

 
Options dialog box for using code qualifiers 

Fixed-Interval Coding 
 
Fixed-interval coding is much like event coding except that with fixed intervals, you want 
to play a section of the media file that is of fixed length (e.g., 10 seconds). Then make 
some type of judgment and code the judgment on a data row.  For example, say that you 
are concerned with a target child’s engagement level.  You could set up two codes in a 
level indicating engaged or not engaged.   
 
Then you would turn interval coding on in the Options dialog box and indicate the 
duration of your interval (see the first graphic below).  When interval coding is turned on, 
the time mark is automatically incremented by the interval duration from the previous 
row and you can play from the previous interval end time to the current interval time. Do 
this by setting the Replay option to Play from the Previous Event Time (see second 
graphic below).  Click the Replay button in the data window to play the selected interval 
of time and make a judgment.  The media will stop at the end of the interval so that no 
time of the session is missed, as it would have been if you were coding in a real time 
situation. 
 



 15
 

 
Turning on interval coding fills the times in the data grid 
 

 
Replay option for interval coding  
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Fixed-Interval Coding with Qualifiers 
Just as with events, you can add qualifier codes to the rows of codes for any given time 
interval.  For example, if you are interested in investigating how levels of engagement 
relate to a particular teaching method being used by the parent or teacher, you can set up 
another code group that has codes that indicate the type of teaching method being used in 
each interval.  Then you can enter that code in another column on the row for the time 
interval.  This way, you can have up to 49 codes per interval. 
 
Note: Analysis of fixed-interval coding is not currently supported by MOOSES.  Data 
files can be read directly by any standard spreadsheet or statistical program for analysis.  
A program called INTMAN (for interval manager) that will handle these analyses is 
currently available from the author. 

Transcription Coding 
ProcoderDV can be used to transcribe from media files as well.  Selecting New 
Transcription File opens the data editor in transcription mode.  In transcription mode, the 
data consist of three columns in which a row represents an utterance.  The first column in 
the row holds the time mark for that utterance.  The second column holds any coding for 
that utterance and the third column holds the utterance text itself.  Transcriptions are 
generally designed to export to the SALT format but they can also be read directly by any 
word processing or spreadsheet program.  Transcriptions of any type of data from 
parent/child interactions to medical or court transcriptions can be entered this way. The 
ability to code utterances makes ProcoderDV a good program for the collection of 
qualitative data, because utterances can be coded and sorted to find records that are alike.  
 
Codes for transcription are generally applied to a row of data and therefore do not really 
need to be arranged in groups.  In transcription mode, hitting a return on a transcription 
automatically starts a new row and enters the media time for that row.  When the data 
grid is adjusted to the current code set in transcription mode, the codes and descriptions 
show up in a pick list to the right of the data.  You can then pick codes for the utterance 
from the list to apply to that row by using the Add Code button when the row you want to 
code is selected (see graphic below).  Multiple codes can be added to a row if desired.  
 

 
Transcription coding in the data window 
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Optional Settings 
 
This section gives details on the options that can be set in ProcoderDV and describes 
their function in the program.  The options setting dialog box is accessed from the Edit 
menu in the ProcoderDV main window.  Options are grouped into three general areas; 
Media Control Options, Data Options, and Export Options. 
 

Media Options 

 
Media Control Options dialog box  
 
The Time Display setting lets you choose how times will be displayed.  This effects how 
the time is displayed in your data files and in the time counter at the bottom of the media 
window.  It is best to decide which format you want to use and leave it set that way for a 
given data file.  It is currently not possible to easily convert times that are already entered 
into data files.  Conversion has to be done manually if needed.   
 
Many types of media cannot work in frames.  Compression schemes use “key frame” 
methods to save data space in files by building successive frames from the previous 
“key” frame.  All formats can support times in seconds so it is probably best to stay in the 
default setting of HH:MM:SS.ss for readability and for the most compatible time format 
if you are starting fresh with the program.  Frame address ability is provided for those 
who wish to work in frames and have media formats that support frame addressing.  If 
you set the program to work in frames and the media does not support it, then playing a 
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media file in the media window will display an error message and the format will be set 
back to seconds. If you are working in frames you can set the frames per second rate 
manually or calculate it from a currently loaded media file with the button provided. 
 
Replay Controls let you set the behavior of the replay function in the data windows.  The 
replay function acts using the time on the selected data row.  You can select from the 
three given options for how the replay will behave.  If you select the Pre-roll/Post-roll 
option the pre-roll and post-roll durations are used as set in the supplied text boxes.  The 
time of the pre and post roll is assumed to be in the same time base (in seconds or frames) 
as set in the time display option.  If you are in seconds, then decimal numbers are 
acceptable (e.g., .5 seconds) as pre-roll and post-roll values.  If you are in frames, only a 
whole number (in frames) is accepted. 

Data Options 

 
Data Options dialog box 
 
Data options control how the data grid operates in the data window.  Changes made here 
do not affect currently entered data and are only applied when the data file is loaded or 
when Adjust Grid to Current Code Set is selected from the menu in the data window. 
 
To the right of the time, in the data grid cells, you have three options for entering data.  
Edit In Cell lets you type directly in the data cells on the data grid by either double 
clicking the cell or starting to type with a cell selected.  Another option for entering data 
is by using pick lists. The pick lists are made up of either the codes or the code 
descriptions.  If a pick list is used, a small pull down list to pick from is supplied in the 
selected data cell. 
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Quick keys allow for coding of the media using single keystroke coding when something 
changes or an event needs to be marked.  If quick keys are enabled, you can select the 
group you wish to use the keys/codes from or you can have the program look at all the 
groups for a key match.   This option works by searching the first letters of the codes in 
the code file list to select which code to put in the data grid.  When the data grid is 
selected and a key is hit that matches one of the first letters, a row is added to the data, 
the time is marked, and the code is entered on the proper column.  Using quick keys 
automates the process of coding so that coding can be done quickly and efficiently as the 
media is being played.  You can do multiple groups in different passes of the media and 
sort the data into temporal order later.   If the Pause box is checked, the media will pause 
once a quick key code is added to the data. 
 
Turning on, and setting a value for, fixed-interval coding causes the time of a given row 
to be entered automatically when new rows are added.  Adding value given in the Interval 
to Use box to the time from the previous row computes the time of the new row.  This 
mode of operation is described in greater detail under interval coding in the Code File 
section of this manual. 

Export Options 

 
Export Options dialog box 
 
Export options allow you to set how the data will be exported into MOOSES (event files) 
or SALT (transcription files) file formats.  All formats that Procoder, MOOSES, or SALT 
use are standard ASCII text files and are readable by any word processor program or by 
the notepad program in Windows. 
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Event files are exported to MOOSES format when the Export button is selected in the 
data window or when Export is selected from the menu in the data window.  MOOSES 
files consist of a line that says “Events” then a line with header information, then a 
stream of lines that consist of an event code, a comma, and a time.  You have the option 
of converting the times to seconds for MOOSES.  This box makes the export convert the 
time to the nearest second.  If it is not checked, then the time is left in frames or 
hundredths of seconds.   
 
The End Time in the data header (if present) or the Last Time in the loaded media (if 
loaded) can be used for the end of session time in MOOSES.  If this option is not checked 
then the session end time must be entered in the text box supplied.  The MOOSES export 
zero justifies the data to the first time in the file, that is, the first time is zero and the rest 
of the times are adjusted by subtracting the first time from them. MOOSES can handle 
any data time base; however, the analyses in the program will take longer with finer time 
bases (frames or hundreds of seconds take longer to analyze than seconds). 
 
The Combine Groups option allows for combining of codes into a single code for 
MOOSES analysis.  This allows for codes with qualifiers.  This coding scheme is 
described more fully in the Code Files section of this manual. 
 
The SALT Export options control how data is exported into SALT format.  A SALT 
utterance line consists of an actor code, a space, then the transcription of the utterance, 
then the coding of the utterance, then an end punctuation mark.  The option lets you set 
whether the actor code is the first character in the codes column or the first character in 
the transcriptions column.  The codes are put before the ending punctuation and the times 
are put after the actor in braces {}.  SALT ignores things in these braces.  The data 
header information is passed to the SALT file on lines that begin with ‘+’.  The ‘+’ is 
used to identify comment lines in SALT.  The first line in a SALT file is a special line 
that SALT uses to identify the actors.  A default first line is given, but that line can be 
customized for your needs in the supplied text box. 
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Exporting Data 
 
Two general formats for exporting data are provided with ProcoderDV.  MOOSES file 
format is used for event data so that data can be analyzed using the MOOSES system 
(Tapp & Wehby, 1995).  Transcription data can be exported into SALT Format (Miller & 
Chapman ,1993).  All file formats (with the exception of the media files) are simple 
ASCII text file formats that can be opened with Windows Notepad or any standard word 
processor or spreadsheet program.  The ProcoderDV data file is in comma-separated 
format and can be read directly with standard statistical or spreadsheet programs.  The 
MOOSES or SALT programs are not required in order to use the data (but they are good 
programs to have). 

Event File Data 
 
Event file data can be exported into MOOSES format.  The set-able options let you set 
how the export is done.  The MOOSES file format is as follows: The first line is the word 
“Events”, then there is a header line for data labeling, then a series of lines with “Event, 
Time” on each line, then a –500 code to signify the end time.  The last time in the file can 
be set in the options or can be pulled from the last time in the File Info section of the data 
file or from loaded media.  Data is sorted by time before the output file is written.  A 
standard dialog box that lets you name the MOOSES file and sets the folder is displayed 
when the Export toolbar button is pressed or Export is picked from the File menu in the 
data window. 

Transcription File Data 
 
Transcription files can be exported into SALT format.  This format consists of a first line 
(which is set-able in the ProcoderDV options), then a series of lines beginning with + to 
signify comment lines and hold the File Info data from ProcoderDV.  The rest of the lines 
in a SALT file consist of an actor code (the first character), a space, then the transcription 
followed by the codes in square brackets [] and an ending punctuation mark.  The set-able 
options let you pick how the actor code is entered in your data.  ProcoderDV saves the 
frame data after the actor code in braces {}.  SALT ignores text in the braces.  

Reading Data Files with Other Programs 
 
On computers that have Excel, you can simply rename the ProcoderDV file and change 
the extension to “.csv” to have the file opened directly by Excel.  You can also name the 
file with a “.txt” extension to have the file opened by your default text editor.  The file 
associations stored in the Windows registry control what program in Windows opens 
what extension. The file associations are set-able in the folder options area in the Tools 
menu of any directory window in Windows (e.g., the My Computer window). 
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Capture Recommendations 
 
ProcoderDV can support any digital media file supported by Windows Media Player.  It 
uses the same technology that is built into Windows.  MPEG-1 format offers a small file 
size that is frame addressable, but the resolution of MPEG-1 format is limited.  MPEG-2 
offers a much better range of resolutions at the cost of larger file sizes.  MPEG-2 is also 
frame addressable in ProcoderDV.  Windows Media format (.wmv) files offer very high 
resolutions with much smaller file sizes,  but they are addressable in ProcoderDV only by 
second and not by frame.  The smallest increment of motion in seconds is not hundredths 
of seconds but is really in frames (about 1/30th of a second).  DV format is the standard 
format that is stored on the hard drive using many  “firewire” devices. DV file sizes are 
very large, however, and storing many sessions in DV format for use with ProcoderDV is 
probably still too costly. Some compression to either MPEG or Windows Media formats 
will probably need to be done to have enough space to store your media files on CDs or 
DVDs. 
 
Many commercial devices are available that can capture directly into MPEG format.  
This saves the costly time of compressing DV formats into smaller MPEG files.  Dazzle 
(www.dazzle.com) has several choices for this equipment at reasonable prices.  More and 
more devices for capturing digital video are becoming available every day and the prices 
are dropping.   Contact us through the ProcoderDV website (www.procoderdv.com) for 
our latest information on capture gear that works with ProcoderDV.  Be sure to find 
something that can capture into MPEG format directly to save the costly compression 
times that DV format will require.   
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