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1.1 Software Overview

Psychology Software Tools’ SimFx software creates an auditory simulation of an authentic 
MRI environment.  SimFx not only replicates the active scanner noises, and generates ambient 
sounds; it has the ability to play back up to four different sound files simultaneously.  It also is 
capable of accepting serial input.  Coupled with a simulator, SimFx allows you to recreate an 
effective, simulated MRI environment.

The following pages will guide you through the use and installation of SimFx.  

	 NOTE: This program is compatible with 32-bit and 64-bit Window XP, VISTA and Windows 7.
	 Please note that the file paths will vary accordingly.

Chapter 1: Introduction
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1.2 Software Installation

Before continuing, be sure that you have administrative rights to install this software on the 
computer.  If you do not have administrative rights, you will be unable to install SimFx.  If you
are unsure of your administrative privileges, contact your System Administrator. 

NOTE: The version number on the following screen grabs may not correspond to the version 
number on your software.

1)	 Insert the SimFx installation
	 CD into your CD-ROM drive. 
	 If the CD does not automatically
	 start, navigate to your CD-
	 ROM drive in Windows Explorer
	 and open Setup.exe to launch
	 the installation.

2)	 Click “Next” when you see the
	 window. 

3)	 Please read the License
	 Agreement and make sure that
	 you agree completely with the
	 terms and conditions described
	 in the agreement before
	 proceeding. Once you have
	 read the agreement, click
	 “Next” to proceed with the
	 installation.

4)	 Enter the Customer Information
	 in the window shown. 
	 Specify a User Name and
	 Organization or check with
	 your system administrator for
	 appropriate information.

5)	 Click “Next” to begin
	 transferring files to your
	 computer.
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6)  Click “Next” to install to the
	 Destination folder.

7)  Click “Install” to begin the
	 installation.

8)  Wait for the installation to finish.

9)  If SimFx was installed properly,
     you will see the following
     window. Click “Finish” to
     complete the installation.
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2.1 Opening the Application

Once you have successfully installed the SimFx software you can open the application through 
the Windows Start Menu.

1)	 Click on the Windows Start
	 menu, select All Programs, and
	 then select SimFx. 

2)	 Click on SimFx to launch the
	 application.

3)	 Wait for the application to load.
  

 1

 

2

 3

Chapter 2: Getting Started Guide
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3.1 Sound Playback

The SimFx software was designed to be user friendly.  It includes pre-recorded ambient noises, 
anatomical and functional scanner sounds, and it supports a number of file formats if you would 
like to add sound files to the library.

.wav, .mpa, .mp2, .mp3, .au, .aif, .snd, and .wma.

3.1.1 Supported file formats

Background Sounds
File Name Scan Type/Description Length Sound Type

AmbientNoise.wav White noise, static 10 seconds monophonic
CryogenicPump.wav Noise from cryogenic pumps in scanner room 7.47 seconds monophonic
AmbientCryogenic.wav Ambient.wav and CryogenicPump.wav in one .wav file 7 Seconds monophonic

Scanner Sounds
File Name Scan Type/Description Length Sound Type

GE_DTI.wav Diffusion Tensor Imaging sequence 14.29 seconds monophonic
GE_SE.wav Spin Echo sequence 9.89 seconds monophonic
GE_EPI.wav Echo Planer Image sequence 4.89 seconds monophonic

GE_GRE.wav Gradient Echo sequence, 2D low resolution structural 
(InPlane) 4.77 seconds monophonic

GE_SPGR.wav Incoherent Gradient Echo (RF Spoiled), Spoiled GRASS 
sequence, 3-D high resolution structural sequence 7 minutes monophonic

Siemens_DTI.wav Diffusion Tensor Imaging sequence 16.80 seconds monophonic
Siemens_Echo.wav Fast Spin Echo sequence 10.35 seconds monophonic
Siemens_EPI.wav Echo Planer Image sequence 59.60 seconds monophonic
Siemens_Localizer.wav Low resolution structural image sequence 14.29 seconds monophonic

Siemens_MPRAGE.wav Gradient Echo 3D high resolution structural sequence 6 minutes 53 
seconds monophonic

Siemens_PD-T2.wav Proton density T2 weighted Image sequence, low 
resolution structurals (InPlane) 57.35 seconds monophonic

NOTE: You need Administrative rights to add/change/remove any sound file.

3.1.2 Sound library
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3.2 Load Sound

In order to load a sound file, click the browse buttons located on the right side of the application, 
navigate to the appropriate directory and select the desired sound file to be played. The browse file 
window will automatically open at the designated location of the installed sound files. 

 2

 3

 

1

1)	 Click on the Browse button to
	 select a file.  
	
	 NOTE: You will be directed
	 to the default Sound Folder
	 location which is: C:\Program 
	 Files(x86)\PST\SimFx\Sounds.
	 XP users will be directed to
	 C:\Program Files\PST\SimFx\
	 Sounds unless you designated
	 a different location at the
	 installation.

2)	 Select a file.

3)   Click Open.
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3.3 Play Sound File

The play and stop buttons will be disabled until a sound file is loaded in one of the text boxes. The 
checkbox that corresponds with the loaded sound file must be checked for SimFx to play the file.  
The sound file playback is controlled by the start and stop buttons located at the bottom of the 
application.

4)	 Confirm the checkbox is
	 checked. The text will appear
	 in the digital display.

5)	 Click Play to begin playback.

6)	 Click Stop to terminate
	 playback.

	 NOTE: Once playback has
	 begun, the loaded sound file
	 cannot be changed before
	 playback is terminated.

7)	 Check the equalizer.
 
	 NOTE: If the equalizer is
	 animated, but you cannot hear
	 the sound, check that the system
	 volume is not muted or turned
	 down and check the speaker
	 connections.

 7

 6 5

 4
 4
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3.4 Volume Control

The volume control for each sound file is located beneath the digital display. The slider is used to 
control the volume of the associated sound file. To decrease the volume, drag the slider to the left, 
and increase the volume by dragging the slider to the right.

 1

 

2

1)	 Click and drag the slider left
	 and right to increase or
	 decrease the volume. 

2)	 The text below the slider
	 indicates the volume level (%). 

	 NOTE: The volume control for
 	 each sound file is located
	 beneath the digital display.   
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4.1 Basic Features

The File Menu consists of two options, File and Help.  The File option of the File Menu contains 
general application functionality such as the save, open, exit operations. The Help Menu contains a 
link to the documentation and information about the SimFx installation.

1)	 New: This menu option clears
	 all user defined configurations,
	 and returns the application state
	 to default.

2)	 Open: Allows a previously saved
	 configuration to be loaded.

3)	 Save: Saves current user
	 configuration into a file. If the
	 configuration does not initially
	 have a name, you will be
	 prompted to name the file.

4)	 Save As: Saves current open
	 user configuration into a file.
	 The name of the file is specified
	 by user.

 1

 4

 3

 2

Chapter 4: File Menu
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4.1 Basic Features

SimFx installs several sample sound files in a default location on the installation system.  This 
location can be accessed via the File Menu for convenience. The default sound folder can also be 
changed to any folder located on the system. Please note, you must have administrative privileges 
to write to the default sound folder location.

1)	 Go to File Menu, Select Sound
	 Folders.

2)	 Click User Defined Folder.

3)	 Browse to desired location you
	 wish to save your sound files.

	 NOTE: The sound folder must
	 be located in My Documents.

4)	 Click OK.	

5)	 Confirm the Default Folder
	 is set to the location of the sound
	 files to be played.

6)	 Click OK.

	 NOTE: The location of the sound
	 files can be reset at anytime by
	 selecting the Default Folder
	 option via the File Menu.

 2
 1

 6

 5

 3

 4
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4.2 Configuration

SimFx is able to communicate with other entities via serial connection.  The Configuration option in 
the File Menu opens the Serial Communications options. You will need to determine which COM 
port is assigned to your serial port. The state of Serial Communications is displayed in the right 
corner of the application opposite the File Menu.  Basic information regarding serial ports settings 
can be found in Appendix A: COM Port Settings (Page 20). If you have questions about your 
serial port configurations, please contact your network administrator or other computer support 
personnel.

 

4

 3

 1

 2

1)	 Open the File Menu, Select
	 Configuration. 

2)	 Click the COM port drop down
	 menu to set the appropriate
	 COM port.

	 NOTE: A warning dialog will
      appear if a port is unavailable
      on your machine. 

	 NOTE: If you have not
	 determined what COM Port
	 number is assigned to your
	 serial port please contact your
	 network administrator or other
	 computer	support personnel.
	 See Appendix A (Page 20).

3)	 Click OK to close the Serial
	 Communications dialog. 

4)	 Verify Serial Communication
	  is enabled via the checkbox in the
       upper right corner of the user
       interface. 

	 NOTE: If Serial Communications
	 cannot be enabled by checking the
	 check box at the top of the user
	 interface, please check that the
	 device settings are correct. 
	 See Appendix A (Page 20).
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4.3 Open Log File Location

SimFx includes a log file that can be used to double check the application's functioning.  The log 
file is opened via the File Menu.  This file contains information and operations performed by the 
SimFx application.

1)	 Open the File Menu, Select
	 Open Log File Location.

2)	 The SimFxLogFiles dialog
	 lists the location and file
	 names of the available SimFx
	 Log Files.

 1

 

 

2
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4.3 Open Log File Location

This is an example of the SimFx log file.  It is a tab delimited file and can be opened in notepad. 
This file tells you the current Serial Communications settings, current sound folder location, and a 
list of the operations performed by the SimFx application

1)	 Current Sound Folder Location  (sound file)

2)	 Serial communication settings (Initializing Serial Port ComPort = COM1)

3)	 List of Actions performed by application

4)	 What sound file is played (Audio File Location = EPISound4.wav)

 

4

 1

 

2

 

 

 

3
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Appendix A: COM Port Settings

COM Port:	 This option designates which port you want the program to use to communicate.
			   Predefined values: COM1, COM2
			   Default value: The User’s Default Communication Port (which will be found by SimFx)

Baud Rate:	 This option controls the number of data bits per second that are transferred via the
			   selected port.
			   Predefined values: 9600,14400,19200,28800,38400,56000,128000,256000 
			   Default value: 9600

Data Bit:	 This option will change the number of data bits you want to use for each character
			   that is transmitted and received.
			   Predefined values: 5,6,7,8
			   Default value: 8

Parity:	 This controls the type of error checking the device performs.  Please be advised that
			   the computer or device you are communicating with must have the same setting as
			   what you chose here.
			   Predefined values: None, Odd, Even, Mark, Space
			   Default value: None

Stop Bit:	 Changes the time between each character being transmitted.
			   Predefined values: None
			   Default value: None

	 NOTE:	 For more information about configuration settings consult the help provided by your
			   OS, or contact your computer support personnel.
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Appendix B: Contact Information

For additional information or support 

Contact us at
Psychology Software Tools, Inc

311 23rd Street Extension, Suite 200
Sharpsburg, PA 15215-2821

Phone: 412-449-0078
Fax: 412-449-0079
www.pstnet.com

For product support and technical issues
Please e-mail us at
info@pstnet.com

To report a medical emergency that is suspected to be caused by a 
SimFx Software failure call 412-449-0078 ext. 1441.  
 
For failure outside of normal business hours, please call 888-540-9664.




