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2 Biopac Student Lab 
 

Welcome to the Biopac Student Lab PRO! 

To learn how the Biopac Student Lab PRO works, complete this interactive Tutorial and read the Overview Chapter of 
the BSL PRO Manual. For an in-depth discussion of BSL PRO features and how they can make your work easier, read 
further chapters of the BSL PRO Manual. 

The BSL PRO Manual (PDF format) is under the Help menu of the BSL PRO application.  

The particulars of setup and recording are application specific and are discussed only generally in this Tutorial. For 
detailed instructions about setup and recording, consult the BSL PRO Manual and the BSL PRO Hardware Guide—and 
follow your particular lesson plans and application notes. 

This tutorial demonstrates the use of BSL PRO 3.7.5 software with the BIOPAC MP45 data acquisition unit. 

All life science applications for the BSL PRO system involve setting up the hardware for acquiring signals (such as 
electrodes, leads, and the BIOPAC MP data acquisition unit), setting up BSL PRO software, acquiring data (recording), 
and analyzing the data. The purpose of this Tutorial is to familiarize you with the BSL PRO software tools that assist in 
acquiring and analyzing your data. 

LAUNCH BSL PRO  

1. Click the program icon on the 
desktop. 

 Or, from the Windows Start 
menu, choose Start > 
Programs > Biopac Student 
Lab 3.7.5 Lessons & PRO. 

2. BSL PRO will a launch dialog 
to determine how you want to 
use the program: 

 Record a Lesson – choose a 
BSL Lesson or BSL PRO 
template form the tabbed 
window in the dialog. 

 Create and/or Record a new 
experiment – launch the BSL 
PRO. 

 Analyze a saved data file - 
click the appropriate tab and 
select or browse to the 
desired file. 

3. Select Analyze a saved data 
file and choose to 
4Channel.acq. 

4. Click OK. 

 

This tutorial illustrates some of the basic features of the Biopac Student Lab 
PRO software, and assumes you have already installed BSL PRO to your hard 
drive. (If not, insert the CD and follow the Install Wizard). 

You do not need to record data, nor be connected to the MP recording 
hardware, to conduct this tutorial. 

You do not need to be connected to MP recording hardware to analyze any 
data that you yourself may record and save to disk. This allows you to review 
a previously saved file and analyze it with the powerful BSL PRO software on 
any computer, at home or in the lab, even when that computer is not connected 
to the MP data acquisition unit. 
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OPENING A DATA FILE AFTER BSL 

IS LAUNCHED 

5. If BSL 3.7.5 is already running, 
you can use File > Open to 
open the sample file for this 
tutorial. 

6. Navigate to the PRO samples 
folder. 

 

With default installation, sample data files are located: 

Main Drive:\Program Files\BIOPAC Systems, Inc\Biopac Student Lab 3.7.5 
Lessons & PRO\Sample Data\PRO 

7. Open the sample file 
4Channel.acq. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The sample data file 4Channel.acq is used in this tutorial. This data file shows 
simultaneous recordings of ECG Lead II, Pulse Pressure (PPG), Heart Sounds 
(Stethoscope), and Respiration. This setup provides quantitative data on how 
the cardiac and respiratory cycles change as metabolic demands on the body 
change. You may also review other sample files to familiarize yourself with 
BSL PRO applications and tools. 
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8. Observe the BSL PRO display 
and, if needed, adjust the 
window so your display 
resembles the figure at the 
right. 

The BSL PRO display consists of a graph window and a Journal. Adjust the 
size of the Journal by dragging the bar that separates it from the graph window. 
You may resize the entire BSL PRO window to best fit your computer screen 
by dragging its corner (or elsewhere on its perimeter).  

SAVING A DATA FILE 

9. Save a copy of the sample file, 
if desired.  

To save a copy, choose File > 
Save As and rename the file, 
i.e., “4Channel_Test.acq.” 

As you practice using BSL PRO tools and commands, you may substantially 
alter your sample file. If so, you may choose to close it without saving and then 
reopen a fresh working copy to continue the Tutorial. 

You may want to practice on a copy of the 4Channel.acq sample file. That 
way you can experiment with BSL PRO without worrying about changes you 
may make and save to the sample file provided with the software installation. 

By default, BSL PRO data files are saved in the BSL PRO format with the 
“.acq” filename extension. Saving a file in the BSL PRO format saves the 
graph data and the journal notes, the setup parameters (established under the 
MP45 menu), and window positions. Except in exceptional cases, you will 
save data files in the default BSL PRO format (*.ACQ).  

 

IMPORTANT! Saving as a Graph Template does not save any data—only 
the setup parameters. 
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Part 1: Acquisition 
Parameters 

Each BSL PRO lesson—including experiments that you may design—will 
have unique procedures for attaching electrodes, transducers, and other signal 
monitoring equipment. Signal monitoring equipment is connected to the MP 
data acquisition unit, and the MP unit in turn is connected to your computer. 
Follow the instructions for your particular experiment to set up the hardware. 

Before recording, however, you must set data acquisition parameters in the 
BSL PRO software. 

SET UP CHANNELS 

10. Choose the menu command 
MP45>Set up Channels to 
generate the Set up Channels 
dialog. 

The Set up Channels dialog displays options that determine which channels 
receive data, what type of data the channels receive, and how data is displayed 
and interpreted on your computer. 

   

Data Input Channels 

Analog Input Channels 

Calculation Channels 

 

11. Read about data input 
channels at right. 

Analog Input Channels are the most common type of channel and are used to 
acquire any data with “continuous” values. Examples of this include nearly all 
physiological applications where input devices (transducers and electrodes) 
produce a continuous stream of varying data. 

 BSL PRO records and displays up to two analog signals from devices 
connected to analog input ports on the front of the MP45 acquisition unit. 

Calculation channels transform data in some way (rather than collect external 
data as input channels do). Calculation channels acquire data from other 
channels. The original source data is not altered—it is mathematically 
transformed and stored in a modified form in the new calculation channel. 

 For example, if you wanted to know the difference between CH1 and CH2 
data for every point of data collection, you could set up a calculation 
channel to acquire the data from those two analog channels and plot a 
waveform of the difference. 

 Up to 12 calculation channels can be configured. This allows for complex 
calculations to be performed that involve two or more calculation 
channels, such as filtering ECG data and then computing BPM. 
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Channel Specification Options 

12. Note the three checkbox 
settings for each channel that 
determine whether a channel 
acquires data, whether the data 
is plotted as a waveform on the 
screen, and how the data values 
themselves may be optionally 
displayed. 

 

 

Acquire Data 

 

Plot on Screen 

 

 

 

 

 

Enable Value Display 

 

 

 

 

 

Acquire Data records data into memory via the selected channel, but the data 
will not be displayed unless you also select “Plot on Screen.” 

Plot on Screen displays the recorded data on screen so you can view the 
waveforms. 

 In some cases you may not want to plot data on the screen. For example, 
you may want to acquire data on an input channel and run a calculation 
function before displaying it on screen. In that case, you would select 
“Acquire Data,” but not “Plot on Screen” for the Input Channel, and 
“Acquire Data” and “Plot on Screen” for the Calculation Channel. 

Enable Value Display allows incoming data values to be displayed 
numerically and/or in “bar chart” format in a separate window during 
acquisition. Checking this option enables you to open (under the MP45 menu) 
a Show Input Values window in which the values are displayed.  

 Enable Value Display is useful for tracking slowly changing values such 
as heart rate, respiration rate, or the concentration of chemicals in a 
substance. 

Channel Presets  

13.  Click the Presets icon 
(down arrow) to the right of any 
analog channel label to view a 
menu of parameter presets. 

14. Press ESC (Escape key) to 
close the menu without 
selecting a new preset option. 

Note the many presets available for data types you may wish to acquire. 

 

 

 

 

 

 



PRO Tutorial 7 

© BIOPAC Systems, Inc. www.biopac.com 

View/Change Parameters 

15.  Click the View/Change 
Parameters icon (wrench) for 
Analog Input Channel CH2, 
PPG (.5 – 35 Hz). 

Note CH3 and CH4 data is 
displayed in the sample file 
but the set up options are 
not selectable (greyed out) 
because the MP45 supports 
only two channels. 

 

Clicking View/Change Parameters  generates the Input Channel 
Parameters dialog for each channel, which allows specification of settings for 
gain, offset, and other recording parameters. 

16. View the Input Channel 
Parameters dialog for CH2. 

 

17. Read about input channel 
parameters at right. 

The Channel Preset for CH2 is “PPG (.5 – 35 Hz).” The Channel Label is 
not always the same as the name of its preset parameters—you will often label 
a channel differently to better describe its data. 

Gain 

 

 

 

 

 

 

 

Gain specifies the extent to which an incoming signal is amplified. Preset gain 
settings are educated guesses for the data type selected and should be used as 
initial starting values; you may need to adjust the gain depending on how the 
amplified signal appears once data is collected. 

Some types of signals (such as EEG) typically need greater amplification 
than other types of signals (such as ECG or EMG), although ideal gain 
settings are best determined on a case-by-case basis.  

To set the gain for a given channel, choose a value from the pull-down menu. 
Higher gain results in greater amplification. Setting the gain too high results in 
data that is “clipped.” Setting the gain too small results in data that appears 
“flatlined.” For the best resolution, establish gain such that the maximum peaks 
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Offset 

 

 

Input Coupling 

of the signal are close to the maximum range. Consult the BSL PRO Manual 
for a complete discussion of gain. 

Offset enables you to correct the offset of an incoming analog signal by adding 
or subtracting a constant prior to amplification. The correction is generally 
zero, but may be set if a transducer or electrode has inherent offset, a condition 
especially true of signals collected in DC mode. 

Input coupling is set for the type of signal you are recording. For example, 
AC coupling is generally used for biopotential signals such as ECG and EEG, 
while DC coupling is best for transducer signals measuring absolute values 
such as force, pressure, and temperature. In AC-coupled mode, you may adjust 
the upper limit of the bandwidth of the signal being recorded by choosing one 
of three high pass (HP) filter options. 

Scaling 

18. Click the Scaling button to 
generate the Change Scaling 
Parameters dialog. 

The Scaling button at the bottom of the Input Channel Parameters dialog 
generates the Change Scaling Parameters dialog, which allows conversion of 
incoming signals into other units (such as ft/lbs, millimeters, liters, etc.). 

 

19. Note the scaling parameter 
options and read about scaling 
and calibration  
at right. 

Scaling allows you to easily translate the voltage read by the MP45 into the 
units being measured. Note that, for CH2, PPG, the Units label is mV.  To 
change the label, enter text and click OK; for instance, type “millivolts.” 

Calibration is performed prior to acquisition, never while recording.  

Input values (Cal1 and Cal2) from a transducer may be calibrated to known 
low and high values (i.e., temperature). When an acquisition is performed, data 
samples from the selected channel are scaled accordingly and the vertical 
(amplitude) scale reflects the rescaled units. 

20. Click Cancel to exit the 
dialog without changing 
scaling parameters and return 
to the Input Channel 
Parameters dialog. 

Calibration is unique to each application and not demonstrated in this Tutorial. 
To calibrate, follow the guidelines of the specific lab lesson or application 
note. To read more about calibration, consult the BSL PRO Manual. 
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Digital Filtering 

21. Note the Digital Filters 
options of the Input Channel 
Parameters dialog and read 
about them at right. 

 

The MP45 hardware-based Digital Filters are three cascading, second-order 
filters that can be set independently using the pull-down boxes. They are 
designed primarily for basic signal conditioning (e.g., removing 60 Hz noise), 
rather than for filtering data to retain physiological signals of interest (such as 
retaining alpha activity from an EEG signal). Specify a filter type (low pass, 
high pass, band pass, or band stop), frequency, and Q setting. 

Saving Input Parameters 

22. Read about saving input 
parameters at right. 

23. Click Cancel to exit the dialog 
without changing parameters 
and return to the Set up 
Channels dialog. 

Click Cancel to exit the dialog without changing parameters. Choosing OK 
sets the input channel parameters, including any changes you may have made.  

When you save a data file, all acquisition parameters for every channel are 
saved along with the recording. This enables you to open a saved data file and 
collect new data without having to reset any parameters.  

This feature also enables you to save parameters only—without data—in the 
Graph Template file format (.gtl).  

A Graph Template contains no recording data, but contains the parameters that 
you have set up and saved with the file. When you open the template file, it is 
ready to record. This is useful for creating your own lessons. Consult the BSL 
PRO Manual to learn more about Graph Template files. 

Calculation Channel Parameters Calculation channels acquire data from analog input channels or other 
calculation channels and perform a calculation on that data. The original 
source data is not altered—it is mathematically transformed and stored in a 
modified form in the new calculation channel. 

An important concept to understand is that calculation channels are not input 
channels. They must ultimately acquire their data from an input channel that 
collects signals from an external source. When the source of a calculation 
channel is another calculation channel, that calculation channel in turn must 
acquire its data from an input channel (usually an analog input channel, though 
possibly a digital input channel). 
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24.  Click the Presets icon 
(down arrow) for Calculation 
Channel C1 and choose the 
preset option ECG R-R 
Interval. 

 

 

 

 

 

 

For example, you can set up a calculation channel C1 to compute the average 
R-R Interval of the ECG data on analog input channel CH1. 

To do this, click the Presets icon (down arrow) to the right of Calculation 
Channel C1 to generate a menu of calculation channel presets. Choose the 
preset option “ECG R-R Interval.” 

25.  Click the View/Change 
Parameters icon (wrench) to 
the right of Calculation 
Channel C1 to generate the 
Rate Parameters dialog. 

26. Note the Rate Parameters for 
the ECG R-R Interval 
calculation, and read about 
them at right. 

27. Click Cancel to exit the dialog 
without changing rate 
parameters and return to the Set 
up Channels dialog.  

Note the Rate Parameters dialog for the “ECG R-R Interval” preset you 
have chosen. The Source data for the calculation is acquired from “CH1, ECG 
lead 2” and the Function is to compute the interval in seconds. 

Were you to record with these rate parameters, Analog Input Channel CH1 
would acquire the ECG data from the subject, and Calculation Channel C1 
would in turn compute the R-R Interval of the data collected on CH1. 

28.  Click the Presets icon 
of Calculation Channel C1 and 
choose Off. 

29. Click the close box to exit the 
Set up Channels dialog and 
return to the graph window. 

Choosing the “Off” preset option turns off the calculation channel. It will no 
longer acquire, plot, nor display data. 

SET UP ACQUISITION  

30. Choose the menu command 
MP45 > Set up Acquisition. 

31. Note the acquisition parameter 
options of the Set up 
Acquisition dialog and read 
about them at right. 

Once you have set up the channels to be acquired, the next step is to set up the 
acquisition parameters. The Set up Acquisition dialog displays options that 
control, among other things, how and where data will be stored, the sample 
rate for data collection, and the duration (length) of each acquisition. 

Default acquisition parameters are to Record and Append using PC Memory 
at a sample rate of 200 samples per second for 30 seconds. 
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Data Storage Options 

 

The three pull-down menus at the top of the Setup Acquisition dialog allow 
control over how and where the acquisition data will be saved. 

Default parameters are set to Record and Append using PC Memory, which 
tells BSL PRO to append acquisitions until the file is saved and to store the data 
in computer memory (RAM) during the acquisition. Options can be set to save 
data once each segment is acquired, to “autosave,” and to utilize the computer’s 
hard disk for storage. 

Sample Rate Sample Rate determines how many samples the MP45 will acquire per second, 
and is analogous to the mm/sec setting on a chart recorder. Choose the desired 
value in the pull-down menu; you may need to scroll up to see higher values. 
The default sample rate is 200 samples per second, but the best sample rate will 
vary depending upon the nature of the data being acquired. 

Acquisition Length Acquisition Length is set using the scroll bar or entering the length directly 
into the value box. Units are set in the pull-down menu to the right. Length of 
acquisition will vary depending upon the experimental design. 

The MP45 will stop acquiring data when the specified length is reached. You 
may also stop acquisition at any time by clicking on the “Stop” button that is 
enabled during recording in the lower right corner of the graph window. 

 

Repeat The Repeat option allows you to acquire data from repeated trials using the 
same parameters for each trial. 

32. Click the close box to exit the 
Set up Acquisition dialog and 
return to the graph window. 

Consult the BSL PRO manual for more information about acquisition 
parameters. 

OUTPUT CONTROL AND OTHER 

MP45 MENU OPTIONS 

33. Click on the MP45 menu and 
view other available 
commands. 

 

 

Note the options on the MP45 menu and read about some of them below.  

Show Input Values opens a window that displays input data in numerical 
format as it is being acquired. (This function is enabled only when the “Show 
Input Values” option for a channel is enabled in the Set up Channels dialog). 

Output Control generates a submenu of Output Controls. The MP45 outputs 
signals via ports on its back panel. To output analog signals, use the “Analog 
Out” port; to output digital signals, use the “I/O” port. 
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 The MP45 output function is CH1 to Output. For additional output 
functions, including Digital Outputs, Pulses, Voltage, Stimulator-
BSLSTM, and Stimulator-SS58L, use a BSL MP3X unit. 

Part 2: Recording 
34. Read about recording a data file 

at right. 

 

If the MP45 unit is not 
connected, read about 
recording at right and proceed 
to the following section. 

Once you have set up the input channels and set up the acquisition parameters, 
you are ready to record. To acquire data, the MP45 unit must be connected to 
your computer. (If the MP45 is not properly connected and communicating 
with your computer, you will be unable to record and receive an error prompt.) 

Recording a file is beyond the scope of this tutorial, other than to practice 
acquiring a few segments of “flatline” practice data. 

 To acquire useful data, electrodes, transducers and other devices must be 
in place to collect signals from your subject. If no input devices (e.g. 
electrodes or transducers) are connected to the MP45 acquisition unit, but 
the MP45 is connected to the computer, the unit will collect—and BSL 
PRO will display—a small, “flatline” value of random signal “noise” with 
a mean of about 0.0 Volts. 

35. If the MP45 data acquisition 
unit is connected, practice 
recording a new data file. 

 Choose File>New to open an 
“Untitled” graph window and 
practice recording. 

 

 Use the Start/Stop button in 
the graph window to acquire 
multiple, short segments of 
“flatline” practice data. 

 Use the Rewind button in the 
Toolbar to delete a data 
segment. 

 Choose File>Close to close 
the practice graph without 
saving. 

 

 

 

 

 

 

 

 

 

 

 

If the MP45 unit is connected, choose File > New to open an “Untitled” graph 
window and practice recording data. If no MP unit is connected, read about 
recording below and proceed to the following section of this tutorial. 

 Start acquisition by clicking the Start button in the lower right 
corner of the graph window, or by pressing “Alt + Spacebar.” The circle next 
to the Start/Stop button, when green and solid, indicates that the MP45 
hardware is communicating with the computer, ready to record. 

Once an acquisition has started, the Start/Stop button in the graph window 
changes to Stop. The two opposing arrows to the right of the button indicate 
that data is being collected. The “Busy” status light on the front of the MP45 
also indicates that data is being collected. 

 Stop an acquisition at any time by clicking the Stop button, or 
by pressing “Alt + Spacebar.” An acquisition automatically stops when it 
reaches the Acquisition Length parameter in the Set up Acquisition dialog. 

In the default Append mode, BSL PRO can record multiple segments in a 
single file. Simply “Start” again to append another recording segment. An 
append marker indicates the beginning of each new recording segment. 

 The Rewind button on the Toolbar deletes the last recorded segment. 

You cannot change acquisition parameters while recording. If you change 
acquisition parameters during a pause between recording segments, when you 
attempt to start recording again, BSL will warn that your previous data will be 
overwritten (unless the “Warn on Overwrite” option in the MP45 menu is 
disabled). Similarly, deleting a recorded segment with the Rewind command 
will generate a warning. 

After recording multiple short segments, choose File>Close to close the 
practice data window without saving. 

Recording is unique to each application. Follow the recording guidelines for 
your specific lab lesson, experiment, or application note. To read more about 
recording, consult the BSL PRO Manual. 
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Part 3: Display The BSL PRO graph window is designed to provide you with a powerful yet 
easy-to-use interface for viewing and manipulating data. 

36. Note the features of the BSL 
PRO display in the labeled 
figure at right. 

The Biopac Student Lab PRO Display 

CHANNELS 

Selecting Channels 

37. Note the four channels of data 
in the display of sample file 
4Channel.acq. 

38. Click the CH2 channel 
number box (or its “PPG” 
label to the left of the 
waveform) to make it active. 

 

 

The 4Channel.acq sample file contains four different types of data, each in its 
own channel with a border between each waveform display. To the left of each 
waveform is a channel label, color-coded to help identify each waveform: ECG 
Lead 2, PPG (Pulse Pressure), Stethoscope (Heart Sounds), Respiration. 

 

In the upper left of the graph window, a row of small, numbered boxes 
indicate the acquired channels. The color for each channel’s waveform, 
label, and indicator box correspond and can be changed. The box on the 
left corresponds to the waveform at the top of the screen. 

The box that appears depressed is the selected, or “active,” channel. The 
label of the active channel is displayed to the right of the channel number 
boxes and is highlighted in the graph window to the left of the 
waveforms. 

To make a channel active, select its channel number box or its label with 
the arrow tool. Only one channel can be active at a time. In the example 
shown here, Channel 2 (PPG) is active. 

Transformations and editing operations generally apply to the active 
channel, though in some cases, to multiple channels. Measurements can 
be taken from any channel, whether active or not. 

Hiding channels 

39. Hold down the Ctrl key  
and click on the CH2 PPG 
channel number box to hide the 
channel. 

To focus on one channel, it is sometimes helpful to temporarily “hide” another. 
To hide a channel, click on that channel’s number box while holding down 
the Ctrl (Control) key. The channel’s number box is crossed-over and the 
display redrawn without this channel. Pressing Ctrl and clicking the channel’s 
number box again causes the waveform to reappear. 
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40. Hold down Ctrl and click again 
to make it reappear. 

  

You can hide multiple channels. Hiding an active channel makes the following 
visible channel become active. Note, though, that a hidden channel can be 
made active (even while hidden) by clicking its channel number box. 

SCALE 

Adjust Vertical Scale 

41. Adjust the Vertical Scale of 
CH1. 

 Click in the vertical scale 
region of the channel to 
generate the Vertical Scale 
dialog. 

 Change the scale range to 
one-half of its current value. 

 Click OK to set the new scale 
and close the dialog. 

 Observe the rescaled 
waveform in the graph 
window. 

 

 

42. Repeat the previous step to 
adjust the vertical scale of 
CH2, CH3, and CH4. 

  

The vertical scale at the right edge of the graph window displays the 
amplitude units and range for each channel. 

You can independently adjust the vertical scale of each waveform. Click 
the mouse in the vertical scale region corresponding to that waveform’s 
channel to generate a vertical scale dialog. Type in scale values that result in a 
scale range about half the current value and click OK. The waveform's screen 
amplitude should now be about twice as large as it was before. 

 Note: When grids are locked, the scale dialog includes grid settings. When 
grids are not locked, the dialog includes scale settings only. Refer to the 
discussion of Grid Options later in this tutorial. 

43. Select each channel’s 
waveform and use the vertical 
scroll bar to adjust the 
midpoint of each. 

After changing the vertical scale, use the vertical scroll bar to adjust the 
midpoint of each channel. The scroll bar acts independently upon each 
channel; you must select the channel first. 

Adjust Horizontal Scale 

44. Adjust the Horizontal (Time) 
Scale of all waveforms. 

 Click in the horizontal scale 
region to generate the 
Horizontal Scale dialog. 

 Change the scale range to one 
half of its current value. 

 Click OK to set the new scale 
and close the dialog. 

 Observe the rescaled 
waveform in the graph 
window 
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The horizontal scale affects all 
channels. 

You can adjust the horizontal scale to any range to compress or expand the 
displayed waveforms along the horizontal (time) axis. The horizontal scale 
affects all channels. 

Click in the horizontal scale region to generate the horizontal scale dialog. 
Type in an upper range value that is about half the current value and click OK. 
The horizontal scale of all waveforms should now be about twice as large as it 
was before. 

 Note: When grids are locked, the scale dialog includes grid settings. When 
grids are not locked, the dialog includes scale setting only. Refer to the 
discussion of Grid Options later in this tutorial. 

45. Use the horizontal scroll bar 
to scroll to the beginning and 
end of the recording. 

Adjusting horizontal scale allows you to magnify the screen display to better 
examine a waveform, but note that the waveforms may no longer fit in the data 
window. The file, however, contains the complete record even if all data is not 
displayed on the screen. 

To view the beginning of the recording (time zero), scroll left with the 
horizontal scroll bar. To view the end, scroll right. The horizontal (time) 
scale along the bottom of the graph window denotes when the data was 
recorded relative to the beginning of the acquisition. 

AUTOSCALE Autoscale commands determine the optimal scale for waveforms and center 
their display. 

Note: Once waveforms are optimally scaled, repeating an autoscale 
command has no apparent effect. As needed to practice autoscale 
commands, individually adjust the scale of each channel as you have done 
in prior steps and scroll midpoints away from center. 

Autoscale Waveforms (Vertical) 

46. Select a channel. 

47.  Click the Vertical 
Autoscale icon in the Toolbar 
at the top of the graph window 
to optimize the vertical scale of 
the selected waveform. 

48. Right-click in another channel 
to select it, and choose 
Autoscale from the pop-up 
menu to optimize the vertical 
scale of that selected 
waveform. 

 

Note the graph display of the waveform before and after autoscaling. 

 

 To optimize the vertical scale of an individual channel, select the channel 
and click the Vertical Autoscale icon in the Toolbar at the top of the graph. 

 Shortcut: right-click to select a waveform and choose Autoscale from the 
pop-up menu. 

49. Choose Display>Autoscale 
Waveforms to optimize the 
vertical scale of all waveforms. 

To optimize the vertical scale for all channels and center the waveforms 
vertically, choose the menu command Display>Autoscale Waveforms. 
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Autoscale Horizontal 

50. Choose Display>Autoscale 
Horizontal to optimize the 
horizontal (time) scale of all 
waveforms. 

51. Choose Display>Autoscale 
Waveforms (Vertical) again. 

 

Note that the entire recording is 
displayed. 

Choosing Autoscale 
Horizontal and then Autoscale 
Waveforms from the Display 
menu is the standard way to 
quickly and easily display the 
entire recording. 

 

Note the graph display of all waveforms before and after autoscaling. 

 

To optimize the horizontal scale for all waveforms and make all the data 
visible in the graph, choose the menu command Display>Autoscale 
Horizontal. This sets the horizontal (time) scale range to start at 0 (beginning 
of acquisition) and end at the end of the recording. The entire recording is 
displayed. 

 Shortcut: click on the Horizontal Autoscale  icon in the Toolbar at 
the top of the graph window. 

GRIDS AND GRID OPTIONS  

52.  Toggle the Grid icon in 
the Toolbar to “show” grid 
lines. 

53. Right-click in the waveform 
region and choose Grid 
Options from the pop-up menu 
to generate the Grid Options 
dialog. 

54. Note the available grid options. 
Toggle the option Show minor 
division and click OK to view 
changes in the display. 
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Note that the option to “Lock 
grid lines” affects grid display. 

55. Right-click in the waveform 
region to generate a pop-up 
menu, and deselect Grid to 
“hide” the grid lines. 

 

 The Grids icon on the Toolbar “shows” or “hides” grids. Alternately, 
choose the Display>Show>Grid, or right-click in the waveform region and 
select or deselect Grid. 

Display>Show>Grid Options generates the Grid Options dialog, with 
settings that control the display and locking of grid lines. Alternately, right-
click in the waveform region and choose Grid Options. 

Note that the “Lock grid lines” option can affect the grid display. In general, 
“Unlocked” grids can help you view the data display on the monitor, while 
“Locked” grids can help with printing. See the BSL PRO Manual for more 
information about grids and grid options. 

When grids are “locked,” the scale dialog options include grid settings. When 
grids are “unlocked,” scale dialogs include scale options only,  
as shown in these two screen shots 
of the vertical scale dialog. Refer to 
the discussion of Scale earlier in this 
Tutorial. 

 

MARKERS  

56. Read about markers at right. 

 

 

 

 

 

 

 

Append Markers 

 

 

Event Markers 

 

Markers are used to identify important data points in a recording so they can 
be referenced later. For instance, you may want to note when an experimental 
condition began or when an external event occurred so you can examine any 
possible reaction. Marker labels help reference these data locations. 

The marker that is active (selected) is colored and its label displayed. 

 Append markers are displayed in the marker region above the marker label 
box. They are automatically inserted by BSL PRO 3.7 to mark the beginning of 
recording segments. 

 Event markers are displayed below the marker label box. They are 
manually inserted during or after recording. 
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Marker Tools 

Marker Preferences 

 To insert an event marker during recording, press the F9 (Win) or Esc 
(Mac) key and enter a label in the marker label text box. This enters a 
marker at exactly the time the key is pressed. 

 To insert an event marker after recording, click with the Arrow tool in 
the event marker region above the data point to be marked and enter a label 
in the marker label text box. 

  Marker Tools are located at the right of the marker region. Use the 
tools to jump through the markers or generate a menu that allows you to search 
for specific markers, to manage markers, to paste a summary of markers to the 
Journal, and to generate a dialog to set Marker Preferences. 

 

57.  Toggle the Markers icon 
on the Toolbar to hide and 
show the marker region of the 
graph window. 

 The Markers icon on the Toolbar activates the marker display region 
near the top of the graph window. Alternately, you may choose the menu 
command Display > Show > Markers. 

Note: Not all sample files included with BSL PRO include append markers, 
but all files you create with the software will include automatic append 
markers at the beginning of each recorded segment. Consult the BSL PRO 
Manual for more information about markers. 

58. Add and label a new event 
marker in the event marker 
region. 

To add a new event marker, click with the Arrow tool above the data point 
you wish to mark, in the space between the bottom of the marker label box and 
the top of the graph. 

Enter a new marker’s label by typing in its activated label 
text box. 

You may change an active marker’s label by entering new text in its label box. 
(Clicking on an existing marker with the Arrow tool selects that marker and 
makes it active.) 

59.  Use the Marker 
Tools to move through the 
markers and activate the event 
marker that you added in the 
previous step. 

Use the Marker Tools right and left arrows to move through the markers. 
Move to the marker you added in the previous step. When active (selected), it 
will be colored and its label displayed. 

The marker that you added is a yellow-colored inverted triangle, as it is an 
event marker that you added to the recorded file. 

60.  Click the Marker 
Tools down arrow to generate 
a pull-down menu. Choose 
Clear > Active Event Marker 
to delete the marker that you 
activated  
in the previous step. 

 

 

 

 

 

The Marker Tools down arrow generates a menu and submenus of marker 
commands. Use the Clear>Active Event Marker command to clear the event 
marker that you added and activated in previous steps. Take care that you have 
activated the marker you wish to clear, as you may not undo this command.  
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61.  Click the Marker 
Tools down arrow and choose 
Preferences to generate the 
Marker Preferences dialog. 

 

Click the Marker Tools 
down arrow and choose 
Preferences to generate 
a Marker Preferences 
dialog. Alternately, 
choose File> 
Preferences>Markers. 

Marker Preferences has 
three tabs of options to 
auto-label markers, and one to format marker data summarized to the Journal. 

62. Click through the tabs of the 
Marker Preferences dialog to 
note the options available for 
configuring custom marker 
labels, and for pasting a marker 
summary to the Journal. 

Marker Preferences has tabs that allow you to pre-establish custom labels 
before recording that are entered when a marker is inserted during recording. 

Custom labels (rather than the default labels “Segment 1,” “Segment 2,” etc.) 
can be pre-established for the append markers that are automatically inserted 
at the beginning of each new recording segment. 

Custom labels, either fixed or sequential, can be pre-established for event 
markers that are inserted with the press of a function key while recording. 
This can help you enter markers with descriptive labels during recording at 
exactly the moment an event occurs, when you otherwise might not have time 
to label your markers. 

Note also the Preferences tab that sets format and sort options for marker 
summaries that you may paste to the Journal. 

SELECTION TOOLS 

 

When working with data, you will use one of three selection tools: Arrow, I-
Beam, and Zoom. 

Selection Tool icons are located in the lower right corner of the display 
window. Click on an icon to activate the tool indicated for the editing or 
analysis function to be performed. Selection tools may also be activated by 
choosing the menu command Display>Cursor Style. 

You will often use the Zoom tool and I-Beam tool to select a portion of a 
waveform to edit or analyze. Once you have selected (highlighted) an area, 
you can perform a variety of operations—such as editing, measuring, or 
transforming data. 

Arrow Tool 

63. Select the Arrow tool in the 
lower right corner of the graph 
window. 

 

 The Arrow tool is a general-purpose cursor that is used to select a 
waveform or channel, scroll through data, adjust chart boundaries between 
waveforms, select options from pull-down menus, etc. All other cursors 
default to the arrow style when moved outside of the waveform region. 
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64. Use the Arrow tool to resize the 
chart boundaries between 
waveforms. 

65. Choose Display > Reset Chart 
Display to return the display to 
equal sized waveform “tracks.” 

You may use the Arrow tool to adjust chart boundaries 
and better view a waveform’s “track.” Position the 
Arrow tool over a boundary line between waveforms. 
When the cursor changes style, drag to resize the track 
of that waveform. (The I-Beam tool similarly changes 
style and can be used to adjust chart boundaries.) 

Choose Display>Reset Chart Display to evenly 
display the waveform “tracks” in the graph window. 

I-Beam Tool 

66. Select the I-Beam tool in the 
lower right corner of the graph 
window.  

67. Click and drag the I-Beam tool 
across the waveforms to select 
an area of data. 

68. Click the I-Beam tool in the 
waveforms—without 
dragging—to select a single 
data point. 

The I-Beam tool is used to select an area of a waveform (or multiple 
waveforms) to be edited, measured, or transformed. 

Clicking and dragging the I-Beam tool across waveforms selects and 
highlights an area of data. You can perform a variety of operations—editing, 
measuring, transforming, copying, pasting measurements to the Journal—on 
the selected data. 

As you scroll though waveforms with the I-Beam tool and highlight areas of 
data to be measured, note that the values in the channel measurement boxes 
above the graph window adjust themselves continuously. 

It is important to note, even without dragging, that the I-Beam tool always 
selects at least one sample point. If a single point is selected, the cursor will 
“blink.” If multiple points are selected, the area will be highlighted. 

Zoom Tool 

69. Select the Zoom Tool in the 
lower right corner of the graph 
window. 

70. Click, drag, and release the 
Zoom tool in a waveform to 
select and magnify a section of 
data. 

71. Zoom again. 

72. Choose Display>Zoom Back, 
or press “Ctrl –” (Control + 
Minus keys), to undo the 
previous Zoom command. 

  

The Zoom tool magnifies a portion of any wave for examination. 

Click on the waveform with the Zoom tool in the area you wish to examine, or 
hold the left mouse button and drag the Zoom tool so it forms a box over the 
desired area. Then release the mouse button to display the enlarged area. 

The Zoom tool magnifies all waveforms. You may want hide other channels to 
focus on the channel you wish to zoom in on. 

You may “undo” previous zooms (up to 5) by choosing Display>Zoom Back, 
or by pressing “Ctrl –” (Control + Minus keys). 

73. Choose Display>Autoscale 
Horizontal and Display> 
Autoscale Waveforms to 
center all waveforms and 
display the entire recording. 

Choosing Autoscale Horizontal and then Autoscale Waveforms (Vertical) 
from the Display menu is the standard way to quickly and easily return to 
a display of the entire recording. 
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MEASUREMENTS Using the BSL PRO measurement tools, you can easily use absolute 
functions—such as value, X-axis (time) and samples—that measure a single 
point, and use functions—such as min, max, mean, and ∆ Time—that operate 
over a selected, highlighted area of data. 

Measurement features can be automated so that measurements are taken and 
pasted into the Journal file when a specific event occurs, or at pre-specified, 
user-defined time intervals. Functions under the Transform menu (such as Find 
Peak) identify specific events based on a variety of threshold and window 
discriminators. 

Measurement Boxes 

74. Read about measurement 
boxes at the right. 

 

The measurement region is located near the top of the graph window. For 
each measurement, there are pull-down boxes that specify the channel to be 
measured and type of measurement, and a value box that displays the results. 

To specify the channel to be measured, click on the channel selection box 
and choose from the pull-down menu. When the designation “SC” is chosen 
(default), measurements are taken from the channel that is active, or 
“selected,” in the graph window. 

To specify a measurement type, click on the measurement box and choose 
from the pull-down menu. 

Measurement results are displayed in the box to the right of the 
measurement type. Results reflect the waveform data selected in the graph 
window with the I-Beam tool. 

Taking Measurements 

75. Note the measurement boxes 
in the 4channel.acq sample 
file. 

As you drag the I-Beam tool 
across waveforms, note the 
change in values in the channel 
measurement boxes. 

The sample file 4Channel.acq displays five measurement boxes in the region 
below the Toolbar. The first is configured to measure CH1 delta, the second 
to measure CH1 BPM, the third CH3 Peak-to-Peak, the fourth CH4 ∆ Time, 
the fifth CH4 Peak-to-Peak. 

If all five measurement boxes are not displayed, drag the window wider. 

The measurements adjust themselves continuously as you scroll through the 
waveforms with the I-Beam tool, reflecting the area of data highlighted in the 
graph window. 

It is important to note that the I-Beam always selects either a single point or 
an area spanning multiple sample points. When a single point is selected, 
the cursor will “blink.” When multiple points are selected, the area will be 
highlighted. If an area is defined and a single point measurement is selected, 
such as X-axis T (Time), the measurement will reflect the last selected point. 
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76. Hide CH1 and CH2. To hide channels, hold the Ctrl key and click their channel number boxes. 

 Hiding a channel removes its waveform from the graph display. 

 A hidden channel can remain the active channel. 

In the following exercise we will observe the results in the three measurement 
boxes that are configured for CH3 p-p, CH4 delta T, and CH4 p-p. If all the 
measurement boxes are not displayed, drag the window wider. 

77. Compare the p-p measurements 
for CH3, Stethoscope and  
CH4, Respiration during the 
“Deep Breathing” and “After 
Exercise” segments of the 
recording. 

 Using the I-Beam tool, select 
8 seconds of data in the 
“Deep Breath” segment. 

 Note the p-p measurement 
results in the measurement 
boxes for CH3 and CH4. 

 Choose Edit>Journal> 
Paste Measurement. 

 Read the measurement results 
that have been pasted into the 
Journal. 

 Select 8 seconds of data in 
the “After Exercise” segment. 

 Note the p-p measurement 
results in the measurement 
boxes for CH3 and CH4. 

 Choose Edit>Journal> 
Paste Measurement. 

 Read the measurement results 
that have been pasted into the 
Journal. 

 

 

In the Analysis and Journal 
sections of this Tutorial, you 
will learn more about taking 
measurements and pasting 
measurement data to the 
Journal. 

 

 

To practice taking measurements, select and compare eight seconds of “Deep 
Breathing” data with eight seconds of “After Exercise” data. 

Labeled markers identify the data segments for each condition. When 
selecting an area of each segment with the I-Beam tool, note the CH4 
delta T measurement to determine 8 seconds of data. 

Compare the Peak-to-Peak measurement results for CH3, Stethoscope 
(Heart Sounds) and for CH4, Respiration under each condition. 

The menu command Edit>Journal>Paste Measurement pastes each 
measurement to the Journal. Review the Journal entries shown below. 

 If the Journal is not displayed, toggle the Journal icon in the Toolbar. 
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Part 4: Analysis  

ANALYSIS OVERVIEW One advantage of saving data files to disk is that you can quickly and easily 
perform post-hoc analyses of your recorded data. BSL PRO software is a 
powerful and flexible analytical tool designed to provide you with immediate 
feedback from each operation. Using BSL PRO, you are able to...  

 Use digital filtering and smoothing. 
 Find patterns within data sets. 
 Automatically find peaks and calculate rate data. 
 Perform mathematical and statistical operations. 
 Log results and observations to a journal. 
 Mark events during acquisition or analysis. 
 Transform data after it has been acquired. 

 To get an idea of how BSL PRO provides immediate feedback, run a Find 
Peak function on the 4Channel.acq sample file. 

78. Adjust the display of the sample 
file 4Channel.acq to view ten 
seconds of ECG data. 

 Select CH1, ECG. 

 Hide other channels 

 Zoom in on about ten 
seconds of data 

 Autoscale the waveform as 
needed.  

79. Use the I-Beam tool to select 
one ECG cycle, as shown in the 
screen shot at right. 

Select CH1 and hide the other channels by pressing Ctrl and clicking their 
channel number boxes. 

Use the Zoom tool to examine a 10-second portion of the waveform. To center 
your display after zooming, use the Autoscale Waveforms (Vertical) 
command from the Toolbar or from the Display menu. 
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80. Choose Transform>Find Peak 
to generate the Find Peak 
dialog. 

81. Choose the Off-line Averaging 
option (in the bottom third of 
dialog). 

82. Set the first cursor to “Peak + 
(-.45) sec” and the second 
cursor to “Peak + (+.45) sec.” 

 

 

 

 

   

Note the settings in the Find Peak dialog. BSL PRO automatically calculates 
a threshold level based upon a percentage of the peak in the selection of data 
that you highlighted. 

Choose Off-line Averaging, and set  
the first and second cursors relative to the peak. 

83. Click the “Ave Start” button. 

84. Close the Averaging result 
window without saving and 
return to the graph display 
window. 

BSL PRO runs through the data and 
generates a new window showing the 
average ECG for the entire recording. 

You may also set Find Peak to average a 
selected portion of the recording. This 
feature is useful when comparing the ECG 
complex during different sections of an 
experiment. 

THE TRANSFORM MENU 

85. Scroll through the options 
under the Transform menu 
command and note the 
available functions. 

 

The Transform menu contains a number of 
functions that modify waveform data. 

The Digital Filter sub-menu has both FIR and 
IIR types of filter operations. For most datasets, 
the default filter parameters may be used and will 
produce relatively robust results. 

The Math Functions sub-menu lists several 
available mathematical transformations. Some 
transformations produce a dialog with parameters 
that can be changed. 

The Template Functions sub-menu provides a 
host of options to examine the relationship 
between two different waveforms. 

The Integral transformation results in a running 
total of all selected waveform values (using a 

 trapezoidal rule integration). 



PRO Tutorial 

© BIOPAC Systems, Inc. www.biopac.com 

25 

The Derivative transformation approximates an ideal differentiator. It allows 
you to specify a low pass frequency to filter the data prior to performing the 
derivative. The Difference transformation is a running subtraction over the 
number of points specified. 

The Expression option has an “Equation Generator” that lets you perform a 
range of mathematical operations, from addition and subtraction to arcsine and 
log transformations. You can perform complex operations in a single step. For 
example, you can compute the mean of several channels, and then use the 
arcsine function to transform the result and save the output to a new channel. 
You can transform entire waveforms or sections of waveforms. 

TRANSFORM>FIND RATE In addition to performing mathematical functions, the BSL PRO software can 
search for peaks and calculate rate. The Find Rate function will calculate rate 
information for a variety of cyclical data, including BPM, Hz, peak max, peak 
min, P-P, area, and mean. 

 For example, suppose you want to calculate BPM for the entire ECG 
waveform once it has been collected. 

86. Select CH1, ECG. 

87. Choose Transform>Find 
Rate. 

88. Select the function Rate 
(BPM). 

89. Check to enable “Find rate of 
entire wave.” 

To do this, select CH1 and choose the menu 
command Transform>Find Rate to 
generate the Rate Detector dialog. View 
the functions available on the pull-down 
menu and choose Rate (BPM). 

Note the other options allowing you to 
customize the Rate calculation. The Rate 
Detector can operate as a simple threshold 
detector or can include more sophisticated 
parameters such as noise rejection and 
windowing. 

90. Click OK. 

 BSL PRO calculates the rate 
and displays its graph. 

91. Note the new CH5 Rate 
channel that has been added to 
the graph window. 

BSL PRO calculates the 
threshold values and computes 
the rate for the entire 
waveform. The rate is charted 
and added to the current graph 
window. Options enable you to 
limit the transformation to a 
selected area, and to display the 
rate graph in a new window. 

92. Remove the new channel 
selecting CH5 and choosing 
Edit > Remove Waveform. 

To remove a channel from a file, select it and choose Edit>Remove 
Waveform. Take care to select the channel you wish to remove, as you may 
not undo this command. 

Transform > Histogram A related type of transformation is the histogram, which allows you to display 
data in summary format and examine the central tendency characteristics and 
variability within a waveform. 
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93. Select CH1, ECG. 

94. Choose Transform > 
Histogram. 

95. Set the bins value to “50.” 

Choosing Transform > Histogram 
generates the Histogram Options 
dialog. The dialog prompts you to enter 
the number of “bins” to sort the values 
into, and (if you do not accept the 
default “autorange”) to enter the upper 
and lower bounds of the data to be 
sorted. Type “50” in the bins entry and 
click OK. 

96. Click OK. 

97. Close the Histogram graph 
window without saving. 

 

 

 

The resulting waveform is generated in 
a new graph window and should 
resemble the histogram plot shown 
here. 

98. Show all four channels of the 
4channel.acq graph. 

Return to the 4Channel.acq graph window. “Show” channels that are hidden 
by holding the Ctrl key and clicking their channel number boxes. 

DISPLAY MODES 

 

BSL PRO offers a number of display options, including Scope, Chart, X/Y 
Plot, and Overlap Segments. Chart is the default display mode. 

You can switch from one display mode to another using the Toolbar icons in 
the upper left hand corner of the window. By clicking on these icons, you can 
alternately have your display emulate a chart recorder (Chart mode), 
oscilloscope (Scope mode), or plot data from one channel against data from 
another channel. (X/Y Plot Mode). 

Overlap Segments display is useful for comparing the waveforms of appended 
segments. The icon for this mode is enabled only in data files with multiple, 
appended recording segments. (Overlap Segments mode is not enabled in the 
sample files included with BSL 3.7.) Consult the BSL PRO manual for more 
information about display modes. 

99.  Click on the Scope display 
mode icon. 

The Scope display mode emulates an oscilloscope. All waveforms are in a 
single window with no borders between channels. Waveforms can overlap. 

 Choose Display>Tile 
Waveforms 

 Choose Display> 
Overlap Waveforms 

 Choose Display> 
Autoscale Waveforms 

 Hide CH1 and CH2. 

 Analyze the CH3 and CH4 
waveforms. 

Display menu options determine the display of waveform data. 

 

 

 

 

Analyze the relationship between CH3, Stethoscope (Heart Sounds) and 
CH4, Respiration. Note the differences between the “Deep Breath” and 
“After Exercise” data segments. 

100.  Click on the X/Y Plot 
display mode icon. 

 Set the X-axis to 
“Respiration.” 

X/Y Plots are useful for respiration studies, vectorcardiograms, and 
investigations into non-linear dynamics. 

In X/Y display mode, the X-axis and Y-axis labels correspond with the 
channels that are being plotted. To set the axes, click on the labels and choose 
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 Set the Y-axis to 
“Stethoscope.” 

the channel to plot from the pull-down menu. 

In X/Y display mode, the I-Beam tool becomes a cross hair. When scrolled 
across the graph window, the X-axis and Y-axis values are displayed in the 
measurement region above the graph window. 

In X/Y display mode, the icon for the Plot Standard Curve  function is 
enabled in the Toolbar; it generates a dialog that enables you to enter values 
for colorimetric studies. 

101.  Return to the Chart 
display mode, show all 
channels, and autoscale 
waveforms. 

 

 

Click on the Chart display icon to return to Chart mode. Show any hidden 
channels by holding the Ctrl key and pressing their channel number boxes. 

Choose Autoscale Horizontal, then Autoscale Waveforms to optimally scale 
and center all waveforms. 

Part 5: Journal  

102.  Toggle the Journal icon 
on the Toolbar to hide and 
show the Journal region of the 
display. 

103. Adjust the size of the Journal 
region by dragging the 
boundary that separates the 
Journal from the graph window. 

 

The Journal is a text editor built into the BSL software that allows you to 
record notes and data at the same time you are acquiring and analyzing data. 
Journal entries are saved with the BSL PRO data file. You can copy 
measurements and wave data (in numeric format) from the graph to the 
Journal, and export Journal data to other programs for further analysis.  

 Toggle the Journal icon on the Toolbar to display the Journal region. 
Alternately, choose the menu command Display>Show>Journal. 

You may adjust the size of the Journal display with the mouse by dragging the 
boundary bar that separates the Journal from the Graph window. 
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JOURNAL TEXT ENTRY 

104. Place the cursor at the 
beginning of the Journal 
and type your notes. 

Type any notes you want directly in the Journal. Your keystrokes are entered 
where the cursor is placed. The Journal accepts standard keyboard text entries 
(except certain keystroke combinations reserved for BSL PRO functions.)  

JOURNAL TIME AND DATE TOOLS 

 Time, Date, AutoTime 

 

Time, Date, and AutoTime tools are in the top left corner of the Journal 
window. They record the time and/or date directly into the Journal. 

 Time and date are entered according to your computer’s system clock and 
calendar. If incorrect, check your system settings. 

105. Enter a time stamp. 

 Place the cursor at the end of 
existing journal entries. 

  Click the Time tool 
(clock icon) to enter a time 
stamp. 

 Review the Journal. 

 Once the cursor is placed in the Journal, click the Time tool (clock icon.) 
The current time is entered at the cursor point.  

106. Enter a date stamp. 

 Place the cursor at the end of 
existing journal entries. 

  Click the Date tool 
(calendar icon) to enter a 
date stamp. 

 Review the Journal. 

 Once the cursor is placed in the Journal, click the Date tool (calendar 
icon.) The current date is entered at the cursor point. 

107. Activate the AutoTime tool 
and enter time stamps. 

  Click the icon to 
activate AutoTime. 

 Place the cursor where you 
want the time stamp to be 
inserted. 

 Press the Enter key. 

 Press the Enter key again. 

 Review the Journal. 

  Click the icon again to 
deactivate AutoTime. 

 Click the AutoTime tool (clock icon with arrow – upon activating, the 
icon will appear depressed). Then, place the cursor in the Journal and press the 
Enter (Return) key. 

If the AutoTime tool is activated—and if the cursor is positioned in the Journal 
text region—the current time is entered each time you press the Enter key. 

 To reset the Enter key to its normal “Return” function in the text editor, 
toggle the AutoTime icon again. 

The AutoTime function records the time at the instant the Enter (Return) key 
is pressed. This is very useful for entering time stamps during recording while 
data is being collected. 

PASTE MEASUREMENTS TO THE 

JOURNAL 
 

Set Journal Preferences 

108. Choose the menu command 
File>Preferences>Journal to 
generate the Journal 
Preferences dialog.  
 

Journal Preferences options control how measurements and wave data are 
formatted, when pasted directly from the graph window to the Journal using 
the Edit>Journal submenu commands 

You can also set general text options for the Journal in Preferences. To set the 
text word wrap option, right-click anywhere in the journal text entry region. 
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109. Review the options that 
determine how measurements 
and wave data are pasted into 
the Journal. 

110. Check that all Measurement 
Paste Options are selected, as 
well as the “Include time 
values” option of the Wave 
Data Paste Options. 

111. Click OK to accept any 
preference option changes. 

For this tutorial, select all 
of the measurement and 
wave data paste options so 
when you paste data to the 
Journal you can easily 
identify them. 

When you plan to export 
measurements and data to 
other programs (such as  
an external spreadsheet 
program), it is sometimes 
best not to select all of the 
options, as some may 
affect formatting. 

Set Measurements  

112. Set a measurement box for 
CH1 BPM. 

 Choose CH1 as the selected 
channel. 

 Choose “bpm” as the 
measurement. 

 From the pull-down menus in the measurement box, choose 
CH1 as the selected channel, and BPM as the measurement. 

 TIP: If the channel you wish to measure is the active channel, you can 
set SC (selected channel) as the channel to be measured. 

113. Set a second measurement box 
for CH1 delta T (Time). 

 Choose CH1 as the 
selected channel. 

 Choose “delta T” as the 
measurement. 

 From the pull-down menus in another measurement box, 
choose CH1 as the selected channel, and delta T (Time) as the measurement. 

114. Use the I-beam tool to select 
an area of data from the peak 
of one R-wave to the peak of 
the next R-wave. 

 

 

 

 

 

 

 

 

 

 

Zoom in on the CH1 ECG data. Identify and select a region from the peak of 
one R-wave to the peak of the next R-wave. 
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Paste Measurement Data  

115. Click the cursor in the Journal 
where you want to paste the 
measurement. 

116. Choose the menu command 
Edit>Journal>Paste 
Measurement. 

117. Review the Journal entry. 

 

 

 

When you use the Paste 
Measurement function, 
all the measurements 
showing a value will be 
written to the Journal.  

If you do not want a 
particular measurement 
pasted to the Journal, go 
to the pull-down menu 
for that measurement and 
select the option “none.” 

PASTE WAVE DATA TO THE 

JOURNAL 
The Paste Wave Data function writes to the Journal all the data points of the 
selected area in the graph window. 

118. Use the I-Beam tool to select 
the portion of the waveform 
you are interested in. 

It is very easy to put a lot of data into the Journal using this command.  

You are not pasting simply a measurement—you are pasting all the data points 
of the selected area of the waveform in all channels. If you select one second 
of a wave that was sampled at 200 Hz, 200 numbers will be pasted into the 
Journal. The values will be formatted in columns headed by the respective 
channel names. 

119. Click the cursor in the Journal 
where you want to paste the 
wave data and choose 
Edit>Journal>Paste Wave 
Data 

120. Review the Journal entry. 

 

 

 

 

 

 

 

 

 

 

 

Journal data may be exported to a file of type “.txt” for subsequent 
import into other programs such as spreadsheets. 

If you wish to copy graph window data not to the Journal, but directly into 
external programs, use the Edit>Clipboard submenu commands. Copy 
measurements, wave data, and graphs for pasting directly into word 
processors, spreadsheets, and graphic programs. 
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JOURNAL TEXT TOOLS 

 

The Journal is saved with the data file. If the data file is closed and 
reopened, the Journal notes and window position will be as when the file was 
last saved. 

121. Review and practice using the 
text tools for working with 
Journal notes. 

New Journal 

 

Load Text  

 

Save Text 

 

 

Print Journal 

Journal Text Tools are activated by icons in the Journal Toolbar at the top 
of the Journal and below the graph window.  

 New Journal deletes all text currently in the Journal. 

 Load Text enables the import of data from other files into the Journal. It 
generates a window to import files, which are limited to files of type “.txt.”  

 Save Text allows you to export your Journal notes to a separate file of 
type “.txt.” This is useful for exporting data to other programs, such as 
spreadsheets, for further manipulation and analysis. 

 Print Journal prints the contents of your Journal. 

Part 6: Printing Graphs 
122. Read about the Print functions 

to the right. 

The File>Print command will print what is displayed in the graph window. 
You control how data will be printed by controlling how the data is displayed 
on the screen. 

For instance, if you’ve zoomed, changed scale, or hidden a channel, only the 
portion of data displayed in the graph window will be printed. This can be 
useful if you want to print only a portion of the graph.  

123. Adjust the graph window  
to show the portion of the 
graphs you wish to print. 

Show or hide the waveform channels you wish to print. 

To print a portion of the data file, use the zoom tool, scale tools, and scroll bars 
to display the portion of the recording you wish to print. 

To print the complete data file, choose Display>Autoscale Horizontal and 
Display>Autoscale Waveforms to center waveforms and display the entire 
recording. 

124. Choose File > Print to generate 
the Print Graph dialog. 

125. Choose OK to print the graph 
window. 

126. Review the printed result. 

 

Choosing File>Print Graph generates a dialog with options that will depend 
on the printer (and operating system) you are using. Set print options as 
desired, and use the Print Setup command to set paper size, orientation, etc. 
Consult the BSL PRO Manual for more information about printing. Refer to  
the user manual for your computer and/or printer for details about your 
particular printer. 
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127. Close the 4channel.acq sample 
data file. 

This completes the BSL PRO 3.7 Tutorial. Following is a brief description of 
other sample files that you may wish to review. 

Sample Data Files To further familiarize yourself with features of BSL PRO and see how it can 
make your work easier, open and examine other data sample files included 
with the BSL PRO installation. Sample files include the following. 

SAMPLE FILE NAME DESCRIPTION OF DATA 

4Channel.acq Provides quantitative data on how the cardiac and respiratory cycles change 
as metabolic demands on the body change. (Demonstrated in this Tutorial) 

BloodPressure.acq Shows simultaneous recordings of Blood Pressure and Korotkoff Sounds. 

Earthworm data.acq Shows the nerve response from an isolated earthworm nerve.  

Earthworm smooth muscle.acq Shows spontaneous contractions from isolated earthworm gut smooth muscle 
and the peak to peak response of each contraction. 

EEG.acq Shows how EEG activity changed when the Subject opened and closed her 
eyes (markers indicate change). 

EMGwForce.acq Shows simultaneous recordings of Clench Force and EMG, correlating motor 
unit recruitment to increased power of skeletal muscle contraction and 
measuring changes in EMG and Force when the muscles become fatigued. 

FingerTwitch1.acq Shows simultaneous recordings of Force, Displacement, and Stimulator 
output. The Stimulator pulse induced skeletal muscle twitch causing the 
Subject's finger to lift a small weight. 

FingerTwitch2.acq Channel 1 displays the force generated from the twitch of a finger after a 
stimulus was delivered to the forearm of a human subject. Channel 2 shows 
the stimulus. The event markers above the graph window mark the points in 
the recording when the stimulus frequency was increased. 

NerveConduction.acq Channel 1 displays the stimulus voltage and Channel 2 the motor (EMG) 
response of a muscle. The display is in the Overlap Segment mode, which is 
an easy way to view the EMG response to different levels of stimulus. 

StandardCurveData.acq Shows a typical Standard Curve, used in colorimetric studies to find the 
concentrations of unknown solutions. 

ValidateMeasurements.acq Demonstrates multiple measurements on a selected area of data. 
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Copyright 

Information in this document is subject to change without notice and does not represent a commitment on the part of 
BIOPAC Systems, Inc. This tutorial and the software it describes are copyrighted with all rights reserved. Under 
copyright laws, this tutorial or the software may not be copied, in whole or part, without the written consent of BIOPAC 
Systems, Inc., except in the normal use of the software or to make a backup copy. 

The same proprietary and copyright notices must be affixed to any permitted copies as were affixed to the original. This 
exception does not allow copies to be made for others, whether or not sold, but all of the material purchased (with all 
backup copies) may be sold, given, or loaned to another person. Under the law, copying includes translating into another 
language or format. 

Biopac Student Lab Tutorial, including all text and graphics, are ©1998-2009 BIOPAC Systems, Inc., with all rights 
reserved. 

Warranty 

BIOPAC Systems, Inc. warrants its hardware products against defects in materials and workmanship for a period of 12 
months from the date of purchase. If BIOPAC Systems, Inc. receives notice of such defects during the warranty period, 
it will, at its option, repair or replace the hardware products that prove to be defective. 

This warranty applies only if your BIOPAC Systems, Inc. product fails to function properly under normal use and within 
the manufacturer’s specifications. This warranty does not apply if, in the sole opinion of BIOPAC Systems, Inc., your 
BIOPAC Systems, Inc. product has been damaged by accident, misuse, neglect, improper packing, shipping, 
modification, or servicing by other than BIOPAC Systems, Inc. 

Any returns should be supported by a Return Mail Authorization (RMA) number issued by BIOPAC Systems, Inc. 
BIOPAC Systems, Inc. reserves the right to refuse delivery of any shipment containing any shipping carton without the 
RMA number(s) displayed on the outside. The Buyer shall prepay transportation charges to the site designated by 
BIOPAC Systems, Inc. 

BIOPAC Systems, Inc. makes no warranty or representation, either expressed or implied, with respect to this software, 
its quality, performance, merchantability, or fitness for a particular purpose. As a result, this software is sold “as is” and 
you, the Buyer, are assuming the entire risk as to its quality and performance. 

In no event will BIOPAC Systems, Inc. be liable for direct, indirect, special, incidental, or consequential damages 
resulting from any defect in the software or its documentation, even if advised of the possibility of such damages, or for 
damage of any equipment connected to a BIOPAC Systems, Inc. product. 

 

Trademarks 

Biopac Student Lab is a trademark of BIOPAC Systems, Inc. 

Windows is a trademark of Microsoft Corporation; Mac OS X is a trademark of Apple Computer, Inc. 

This document was created with Microsoft Word for Windows, Adobe Photoshop, Adobe Distiller, Corel Draw 7.0, 
Mainstay Capture, and JASC, Inc. JasCapture. 
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