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About Creative Workflow
Kodak® InSite™ Creative Workflow system provides a collaborative workspace 
where you and your team can manage and share elements—the individual images, 
pieces of artwork, and other files that make up a publication. (You may already know 
elements as “digital assets.”) In Creative Workflow, you organize elements into 
projects.

Multiple users can access the system at the same time, either through a Web 
browser or through the Kodak InSite Desktop software, which you install on your 
local workstation and use to access the Creative Workflow server.

When compared to a Web browser, Desktop provides additional features that are 
intended for advanced users. For details, see Desktop Feature Summary on page 15.

About Projects
A project is a collaborative workspace where you can upload and download elements 
to share with other users. You can also use projects to manage the review and 
approval of elements by associating tasks with specific elements and assigning 
those tasks to other users. (For more information, see About Tasks on page 1.)

Projects are typically temporary—they are used over short periods of time and 
deleted when the work is complete.

What you can do with projects depends on the user rights you are assigned, but a 
common scenario is for anyone to be able to create and delete projects, organize the 
elements within a project, and upload and download elements in projects. (For more 
information about user rights and for instructions on finding out which rights are 
assigned to you, see the Creative Workflow Help.)

About Tasks
A task is an action associated with one or more elements in a project and assigned 
to one or more users. You can use tasks to better manage the review and approval of 
the elements in your projects.

Depending on your project user rights, you can create tasks, assign them to various 
members of your project team, and then monitor the status and completion of each 
task. Depending on their project user rights, users assigned to tasks can review, 
approve, request changes for, and reject elements associated with tasks.

If event notification is set up for your system, and your user account specifies your 
e-mail address, you can automatically receive an e-mail message whenever you are 
assigned a task or when another user sets the status for a task that you created. This 
is useful because you can be notified of new tasks and task status changes without 
having to log on to the system. Each e-mail message also includes links to open 
either a Web browser or Desktop to the target task. (For more information about 
event notification and for instructions on viewing your event notification settings, 
see the Creative Workflow Help.)

www.glintegrated.com
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Users assigned a task can set their task status in either the Elements or Tasks view 
of a project or in Smart Review. (See About Smart Review on page 2.)

For instructions on creating tasks and setting task status, see Working With Tasks on 
page 11.

About Smart Review
Smart Review is a tool available through Creative Workflow that enables you to open 
a detailed, full-resolution preview of an element.

Using Smart Review, you can view an element in different ways (for example, by 
zooming in or out on an image, panning to a different area of the image, or rotating 
the image), take measurements, display and hide separations, check color density, 
add annotations, and (depending on your user rights) set the status for individual 
annotations.

You can also use Smart Review to approve and reject elements that are associated 
with tasks. If the system is licensed for color-accurate monitor proofing, you must 
use Smart Review to review and approve elements for color accuracy.

Note:  To color approve an element in Smart Review, you must view the element on a 
Apple® Macintosh® workstation that is running the Kodak Matchprint® Virtual 
technology, and you must use a qualified color monitor. For more information, see the 
Creative Workflow Help. 

If multiple users are assigned the same task, they can also use Smart Review to view 
the associated element at the same time and collaborate in a group review session. In 
a group review session, all users can see annotations made by another user for the 
same task, and all users can use the chat tool to discuss the element.

Logging On
How you log on to the system varies, depending on whether you are using a Web 
browser or Desktop.

You can log on through a Web browser on a computer running either the Apple Mac 
OS® X or Microsoft® Windows® operating system. In a Mac OS X operating system, 
the supported browser is Safari®. In a Windows operating system, the supported 
Web browser is Internet Explorer® 5.0 or later.

Desktop runs on a Mac OS 10.3.9 or 10.4 client or on a Windows XP, 2000, or 2003 
client. To install Desktop, you must first log on through a Web browser. At the 
bottom of the Web browser window, click Download InSite Desktop, and follow the 
on-screen instructions to complete the installation. Once Desktop is installed, you 
can log on to it directly.

GLI InSite Creative Workflow Customer Quick Start Guide2
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In a Web Browser
To log on using a Web browser, you must have a high-speed Internet connection—
64 kilobits per second (Kbps) or higher. As well, you must have previously been 
assigned a logon user name and password.

1. In the browser’s Address box, type the printer’s home page address—for 
example, http://server.printer.com.

2. Before the first time you log on, check your computer’s configuration to ensure 
that it is running the required software.

a. On the logon page, click System Diagnostics.

b. The System Diagnostics dialog box appears, displaying your computer’s 
configuration, including the operating system, Web browser, JavaScript and 
cookie settings, and Sun® Java® software version. The Java software must 
be installed and enabled for your browser to correctly display the site’s 
contents.

c. If the Java software is not installed or is not enabled, or your current Java 
version is not supported, click Follow these instructions... to install and 
enable a supported Java version.

d. Return to the logon page.

The next time you log on to the system from the same computer, you do not 
need to check the system diagnostics. (If desired, you can check the system 
diagnostics at any time after logging on by clicking System Diagnostics at 
the bottom of the window.)

3. Type your Username and Password, and click Login.

Note:  If you log on using your e-mail address as your user name and a default password 
that was assigned to you, the first time that you log on, you may be prompted to change 
your password and contact information.

To log off:

In the upper-right corner of the Web browser window, click Logout .

www.glintegrated.com
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In Desktop
To log on using Desktop, you must have previously been assigned a logon user name 
and password.

1. Start Desktop.

If this is your first time logging on to Desktop, you are prompted to enter your 
user name and password.

Figure 1: New Account dialog box

2. In the Server URL box, type the printer’s home page address, as you would 
when logging on using a Web browser.

3. If you are connecting to a server in an SSL (Secure Sockets Layer) environment, 
select Use secure connection (SSL). When in an SSL environment, selecting 
this option automatically adds the prefix https:// to the connection URL.

4. Type your User Name and Password.

5. Select Remember password to have a Desktop window open automatically the 
next time that you start Desktop, without prompting you for your user name or 
password.

6. Auto Refresh specifies the frequency at which Desktop is automatically 
refreshed with updated information from the server. Changes made by other 
users since the last refresh appear only after Desktop is refreshed. However, 
refreshing Desktop requires significant bandwidth. If you have a high-speed 
connection, you can leave the Auto Refresh option set to the default 1 minute.
If you have a low-speed connection or if it is not important for you to see recent 
changes made by other users, you may want to decrease the frequency at 
which Desktop is automatically refreshed.

7. Click Connect. A new Desktop window opens.

To log off:

In Desktop for Mac: From the Kodak InSite Desktop menu, select Quit Kodak 
InSite Desktop.

In Desktop for Windows: From the File menu, select Exit.

GLI InSite Creative Workflow Customer Quick Start Guide4
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Getting Around
How you navigate and manage projects depends on whether you are accessing 
them through a Web browser or though Desktop.

In a Web Browser
When you log on through a Web browser, the main portal page lists any projects to 
which you have access. Click a project name to open it.

The Elements view displays the elements in the project, organized into folders. In 
this view, you can upload, organize (rename, move, and copy), and download 
elements. You can also assign source profiles to elements, select elements and 
create tasks for them, and set the status of tasks assigned to you. An icon appears 
in the upper-right corner of any element that has an associated task assigned to you.

Figure 2: A project open in a Web browser—Elements view

For information about source profiles, managing user accounts, and about managing 
project access, see the Creative Workflow Help.
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The buttons on the Operations palette enable you to view element attributes, 
organize elements in the project, create tasks and set task status, and download 
elements. You must select an element’s check box before you can take action on the 
element using the Operations palette.

Figure 3: Operations palette

The project Tasks view lists all tasks associated with elements that reside in the 
current project, the elements associated with each task, and your task status for any 
tasks assigned to you. In this view, you can set the status of tasks assigned to you, 
view the attributes of selected elements, and download elements. You can also view 
a report summarizing all annotations added to an element in Smart Review for a 
particular task.

Figure 4: A project open in a Web browser—Tasks view
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In Desktop
The left pane of the Desktop window lists all projects to which you have access. 
Click a project name to open it.

As in a Web browser, the project Elements view in Desktop displays the elements in 
the project, organized into folders. You can upload, organize, and download 
elements, and view element attributes. In addition, you can filter the elements to 
display either all elements in the current folder or only elements with associated 
tasks that are assigned to you. You can also type a file name or extension in the filter 
box to display only the elements in the current folder whose names match the 
specified file name or extension.

Using Desktop’s menu items (not shown), you can also assign source profiles to 
elements, select elements and create tasks for them, and set the status of tasks 
assigned to you. An icon appears in the upper-right corner of any element that has 
an associated task assigned to you.

Figure 5: A project open in Desktop—Elements view
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Figure 6: Elements view toolbar

The project Tasks view lists all tasks associated with elements that reside in the 
current project, the elements associated with each task, and your task status for any 
tasks assigned to you. In this view, you can set the status of elements in tasks 
assigned to you and view a report summarizing all annotations added to an element 
in Smart Review for a particular task. You can also use the Filter list to filter the tasks 
that are displayed (either all active tasks in the project, only active tasks assigned to 
you, or only tasks whose associated elements require changes).

Figure 7: A project open in Desktop—Tasks view
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Smart Review
When you open an element in Smart Review, the Smart Review window looks the 
same, regardless of whether you are using a Web browser or Desktop.

Figure 8: Element in a Smart Review session

For more information about using Smart Review, see the Creative Workflow Help.
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Frequent Procedures
The following table describes how to perform common procedures in either a Web 
browser or Desktop. For detailed instructions and for additional procedures, see the 
Creative Workflow Help.

Procedure In a Web Browser In Desktop

Create a project In the Projects view, click New Project,
type a name for the project, and click 
Create Project.

Select File > New Project, type a 
name for the project, and click 
Create Project.

Upload an element to a 
project

Click New Upload. In the Upload Files 
dialog box, type a name for the upload. 
Click the Add Files button to locate 
and select the elements that you want 
to upload. (Alternatively, you can drag 
elements from your desktop directly to 
the dialog box.) Click Upload.

Click Upload Files. In the New 
Upload dialog box, type a name for 
the upload. Click Add Elements to 
locate and select the elements that 
you want to upload. (Alternatively, 
you can drag elements from your 
desktop directly to the Elements to 
upload area.) Click Upload.

Tip:  In Desktop for Mac, you can drag 
elements from your desktop directly 
into a project. This automatically 
opens the New Upload dialog box, 
with the dragged elements already 
listed.

Open an element in Smart 
Review

Click the element. Double-click the element.

Copy an element between 
folders within a project, or 
between projects 

Select the element, and on the 
Operations palette, click Copy. Select 
the destination location, and click 
Copy.

Select the element and select Edit > 
Copy. Open the destination location 
and select Edit > Paste.

Move an element between 
folders within a project

Select the element, and on the 
Operations palette, click Move. Select 
the destination folder, and click Move.

Drag the element to the destination 
folder.

Move an element between 
projects 

In a Web browser, you can move 
elements between folders within a 
project only. To move elements 
between projects, you must first copy 
the element to the destination project 
and then delete it from its original 
location. 

Drag the element onto the name of 
the destination project in the left 
pane.

Note:  You can move elements 
between projects in Desktop for Mac 
only. In Desktop for Windows, you 
must first copy the element to the 
destination project and then delete it 
from its original location. 

Download a high-resolution 
version of an element in its 
original format

Select the element that you want to 
download, and, on the Operations 
palette, click Download Original.

Select the element that you want to 
download, and click the Download 
Files button. In the Download type 
list, select Original.

GLI InSite Creative Workflow Customer Quick Start Guide10
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Working With Tasks
Note:  The following table describes how to perform common procedures that are 
specific to tasks. For detailed instructions and for additional task-related 
procedures, see the Creative Workflow Help.You can perform task-related procedures 
only if you are assigned a project role that includes task user rights. For information 
about user rights, see the Creative Workflow Help. 

Download a low-resolution 
JPEG version of an element

Select the element that you want to 
download, and on the Operations 
palette, click Download JPEG. Select 
the desired resolution.

Select the element that you want to 
download, and click the Download 
Files button. In the Download type 
list, select Low resolution JPEG. In 
the Resolution list, select the 
desired resolution.

Delete an element Select the element. On the Operations 
palette, click Delete.

Select the element, and select Edit > 
Delete.

Procedure In a Web Browser In Desktop

Procedure In a Web Browser In Desktop

Create a task In the Elements view, select the 
elements for which you want to create 
a task. On the Operations palette, click 
Create Task.

In the Elements view, select the 
elements for which you want to 
create a task. From the Actions 
menu, select Create Task.

Set the status of a task 
assigned to you

In the Elements or Tasks view, select 
the elements whose task status you 
want to set. (You can set the status 
only for tasks assigned to you.) On the 
Operations palette, click Set Status.
Click the name of the task whose 
status you want to set.

Tip:  You can also set task status in 
Smart Review. If you have been assigned 
a color approval task, you must set its 
status in Smart Review. For details, see 
the Creative Workflow Help. 

In the Elements or Tasks view, select 
the elements whose task status you 
want to set. (You can set the status 
only for tasks assigned to you.) From 
the Actions menu, select Set Task 
Status. Select the task whose status 
you want to set.

Tip:  You can also set task status in 
Smart Review. If you have been 
assigned a color approval task, you 
must set its status in Smart Review. For 
details, see the Creative Workflow 
Help. 

Add elements to an existing 
task

This feature is not available in a Web 
browser.

In the Elements view, select the 
elements that you want to add to the 
task. Drag the elements to the Tasks 
tab at the top of the Desktop 
window. When the window switches 
to the Tasks view, drag the elements 
to the name of the task to which you 
want to add the elements.

www.glintegrated.com
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Remove elements from a 
task

This feature is not available in a Web 
browser.

In the Tasks view, expand the task 
whose elements you want to 
remove. Select the elements that 
you want to remove. From the Edit 
menu, select Delete.

Edit a task to modify its task 
name, due date, or 
description, or to turn 
password authentication on 
or off

This feature is not available in a Web 
browser.

In the Tasks view, select the task that 
you want to edit. From the Actions 
menu, select Edit Task.

Add users to a task or 
remove users from a task

This feature is not available in a Web 
browser.

In the Tasks view, select the task for 
which you want to add or remove 
users. From the Actions menu, 
select Edit Task. In the Users area, 
select the check box for each user 
that you want to add to the task, and 
clear the check box for each user 
that you want to remove from the 
task. Click Apply.

Send a reminder e-mail 
message to any users 
assigned a task who have 
not yet set their task status

This feature is not available in a Web 
browser.

In the Tasks view, select the task for 
which you want to send a reminder. 
From the Actions menu, select Send 
Task Reminder. Modify the message 
as desired, and click Send Reminder.

Reset a user’s task status This feature is not available in a Web 
browser.

In the Tasks view, expand the task 
for which you want to reset the 
user's status until you see all of the 
users assigned the task. Select the 
user whose task status you want to 
reset. From the Actions menu, select 
Reset User's Task Status.

View a report summarizing 
all of an element’s 
annotations that are 
associated with a particular 
task

In the Tasks view, select the task 
associated with the element for which 
you want to view a report. (You can 
view a report for only one element at a 
time.) Click Proof Report next to the 
element.

In the Tasks view, select the element 
for which you want to view a report. 
(You can view a report for only one 
element at a time.) From the Actions 
menu, select View Proof Report.

Procedure In a Web Browser In Desktop

GLI InSite Creative Workflow Customer Quick Start Guide12
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Using Auto Tasks
When you create an auto task in a project, any elements uploaded to the project 
after the task is created are automatically added to the task. This is useful if you have 
several elements to upload to the project at different times, but you want all of the 
elements to be reviewed by the same users.

When you upload an element to a project that has an auto task, the element is 
automatically added to the task. (Elements are added to color approval tasks only if 
their file types are supported by the Matchprint Virtual technology. For information 
about the file types supported by Matchprint Virtual, see the Creative Workflow 
Help.)

Like regular tasks, auto tasks appear in the Tasks view of a project. When an element 
is added to an auto task, a task icon automatically appears on the element 
thumbnail in the Elements view. If event notification is set up for your system, when 
an element is added to an auto task, all users who are assigned the task receive an 
e-mail message.

To create an auto task:

In a Web browser: Open the project in which you want to create an auto task, 
and click Administration > Create Auto Task.

In Desktop: Open the project in which you want to create an auto task, and 
select Actions > Create AutoTask.

About Element Revisions
You can upload multiple revisions of an element, and each revision is stored and 
displayed without overwriting previous revisions.

An element with multiple revisions appears differently in a Web browser than in 
Desktop. In a Web browser, the number of revisions for the element appears as a 
<number> Revisions link below the thumbnail. In Desktop, the thumbnail appears 
as a stack of images (in Gallery Display mode). In either case, the thumbnail in the 
Elements view is for the latest revision of the element.

F

In a Web browser In Desktop
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To view all of an element’s revisions:

In a Web browser: Click the <number> Revisions link below the element 
thumbnail.

In Desktop: Select the element, and select Actions > View Revisions.

You can then perform actions on a specific revision—for example, copy it to another 
location, download it, or open it in Smart Review.

For more information about working with element revisions, see the Creative 
Workflow Help.

Working With Element Attributes
An attribute is information associated with an element that provides details about 
that element, such as its file size or type. You might want to view an element's 
attributes to learn more about the element. For example, the attributes that are 
displayed when you select a PDF file indicate whether the file can be separated and, 
if not, why—for example, because the file contains a nonseparable color space.

To view an element’s attributes:

In a Web browser: Select the element, and on the Operations palette, click Get 
Attributes.

In Desktop: Select the element, and click View Attributes.

For more information about element attributes, see the Creative Workflow Help. 

Using Hot Folders
A hot folder is a folder that is monitored for incoming files as a trigger for an 
automatic operation. The software that processes the files checks the folder 
location on a regular basis, and automatically processes files found there.

In Desktop, you can create upload hot folders to automatically upload elements to 
specified projects. 

When you create an upload hot folder, you associate it with a project. Then 
whenever an element is placed in the hot folder, the element is automatically 
uploaded to the associated project.

Upload hot folders are useful because you can place elements in a hot folder and 
have them automatically uploaded to a particular project without having to log on to 
the system.

You can place many elements in an upload hot folder and have them upload to a 
single location. This is especially useful if you will be frequently uploading files to the 
same location.

GLI InSite Creative Workflow Customer Quick Start Guide14
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To create an upload hot folder:

1. In Desktop, select the project with which you want to associate an upload hot 
folder.

2. From the File menu, select New Hot Folder.

3. Select any existing folder in your file system or create a new folder to use as the 
upload hot folder, and click Create Hot Folder or OK.

To view and manage all upload hot folders for all projects:

From the Window menu, select Hot Folders.

For more information about hot folders, see the Creative Workflow Help. 

D
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Desktop Feature Summary

The following list summarizes the additional features that are available in Desktop
beyond what is available in a Web browser:
• Upload and download elements using drag-and-drop
• Upload InDesign files that can be viewed in Smart Review
• View elements in Gallery, List, or Table Display mode
• Create your own pick list of elements
• Associate upload hot folders with specific projects, and automatically upload ele-

ments placed in those hot folders
• Associate download hot folders with specific projects, and automatically download

XMP approval metadata for elements that are associated with tasks in those projects
(Desktop for Windows only)

• Manually download XMP approval metadata for individual elements in tasks
• Open elements in their native software
• View low-resolution versions of elements (Desktop for Mac only)
• Set your own Desktop user preferences (Desktop for Mac only)

When working with tasks, Desktop also offers the following capabilities beyond
what is available in a Web browser:

• View the users assigned to a task and the task status for each user
• View only task elements that require changes
• View all of the tasks associated with an element
• Add elements to an existing task and remove elements from a task
• Edit a task to modify its task name, due date, or description, or to turn password

authentication on or off
• Add users to a task or remove users from a task
• Send a reminder e-mail message to any users assigned a task who have not yet set -

their task status 16 InSite Creative Workflow 3.0 Quick Start Guide
• Reset a user’s task status
• Delete tasks
• Inactivate tasks and reactivate inactive tasks
• Set the final status for a task

http://www.glintegrated.com


GLI InSite Creative Workflow Customer Quick Start Guide



www.glintegrated.comwww.glintegrated.com

GLPRINT / AKSESS / 4005 CLARK AVENUE / CLEVELAND, OH 44109-1186 / 216 651-1500 / 800 765-4846 / FAX 216 651-8311

GLDIRECT / 33625 PIN OAK PARKWAY / AVON LAKE, OH 44012-2320 / 440 892-7760 / 800 286-7760 / FAX 800 453-7754

GLI InSite Creative Workflow Customer Quick Start Guide

http://www.glintegrated.com
http://www.glintegrated.com

