Release Notes for ClearIlD 2.6.2

Date: 09/27/2012

Version

ClearlD 2.6.2

ClearlD 2.6.1

ClearlD 2.5

Support Date*

04/01/2010

04/01/2010

04/01/2010

Release Date

09/27/2012

05/29/2012

09/14/2010

*Free upgrade to customers that are in support as of this date.

ClearlID v2.6.2 fixes two bugs that existed with the release of ClearlD v2.6.1 for Photoshop CS6

Bug Fixes and Updates

- Tab 2: Frame Averaging. With the release of Adobe Photoshop CS6 and CID 2.6.1 for CS6, frame
averaging was not working. This has been fixed.

- File > Scripts > ClearID — Import images as Layer Stack from Bridge selection now works with CS6.

- Verification Report updated. Previously there was one header named “Document Info” that listed both
information about your current open Photoshop Document and information about what software was
loaded on the system when the Verification Report was generated. This information is now separated into
two groups. The software and system information has been moved under a new header called “System

Info”.

Ocean Systems@ ClearID@ Verification Report Collapse

PhotoshopDocument Info:
Location = ~/Desktop
Name = Fingerprint 2.psd
Type = RGB Color, 16 bits-per-channel
Dimensions = ( 3008 x 1960 ) pixels

System Info:
Report Generated On: Thu Sep 27 2012 15:45:50 GMT-0400
ClearD® Version: 2.6.2
Photoshop® Version: €36 (13.0.0, 32-bit)
Operating System: Windows 7/64 6.1 Service Pack 1 (32-bit emulation)

Layer: CID ICS: Red Channel Expanded #DDFS4F# v2.6.2/CS6
SHAL = 60B9078205AACF2FF87SEADDS8 1 2408D25DDFS4F (image +alpha)
~> ClearID@®: Interactive Channel Selector [Tab 4]
Photoshop® Layer Properties: Visible, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

Layer: CID PR:LFC 76.33 FA53 N 5 #23C9B4# v2.6.2/CS6
SHAL = S65F9091CFEC74633A904A4 086 CEEEF7 023C9B4 (image-+alpha)
~> ClearID®: Pattern Remover [Tab 5]
Photoshop® Layer Properties: Visible, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

Layer: CID EE:NRR 1 EER 3 DE 100 EE Dark Edges AL false #01B83A# v2.6.2/CS6

SHAL = FSAE1C629B38136502D3F 1 FO300F96E13491B83A (image+apha)

~> ClearID®: Edge Enhancer [Tab 6]

Photoshop® Layer Properties: Visble, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)
Layer: Background

SHAL = SDAGC1578E41888311CO8AFDFF7DB3544EA2D3B2 (image)

Hon-CleariD® Layer

Photoshop® Layer Properties: Visble, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)
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Release Notes for ClearlID 2.6.1

Date: 05/29/2012

Version ClearlD 2.6.1 ClearlD 2.5 ClearlD 2.0.2
Support Date* 04/01/2010 04/01/2010 -
Release Date 05/29/2012 09/14/2010 06/03/2010

*Free upgrade to customers that are in support as of this date.

New and Updated Features

- Compatible with Adobe Photoshop CS6 in 32bit mode
- New registration/unlock code screen and new online unlock code request processing

- Fixed Microsoft Share Point conflict with Interactive Deblur

Ocean Systems® ClearID® > Registration 2.6.1 ) i

*** ClearlD" is currently running in 30-Day Trial Mode ***
ClearlD® Product Key: XXXOXOX-XOO0C-XOO0C-X XXX

Unlocking Your ClearlD License
STEP 1 -Request an Unlock Code:

Click here or go to www.oceansystems.com/cid/uniock

STEP 2 - Enter your ClearlD Seral Number and Unlock Code:

Serial Number: I

Unlock Code: |

STEP 3 - Click "OK* 1o unlock your copy of ClearlD

Ocean Systems

+1 301-476-8015

\ Sales@oceansystems com
SYSTEMS Support@oceansystems.com

Cancel || ok |

New ClearID Registration/Unlock Screen

ClearID 2.6.1 Release Notes 1 5/29/2012



Release Notes for ClearlD 2.5

Date: 09/14/2010

Version ClearIlD 2.5 ClearlD 2.0.2
Support Date 04/01/2010 --
Release Date 09/14/2010 06/03/2010

New and Updated Features

F7 Key added for launching ClearID (New)
- Removing Alpha/Opacity Channels for accommodate PS CS5 change
o Import Images as a Layer Stack now hashes & removes the Alpha Channel if present.

o F8 Key function — Removes alpha channel
- Improved real-time preview, faster launching and faster rendering speeds
- Tab 1 - Use keyboard arrow keys to make adjustments in Video Field Alignment (New)
- Tab 1 - Split Layer Stack into Fields function (New)
- Tab 2 - ClearlD Super-Resolution Functions (New)
- Tab 3 - Interactive Deblur was split into two functions so they open with better default settings
- Tab 4 - Interactive Channel Selector with interactive preview and more channels (New)
- Tab 7 - Verification Report Improved

o The report is now HTML with enhanced formatting.

o Reports Photoshop version and ClearID version information.

o Thumbnail image is now displayed in the verification report.

o Expand and collapse buttons allowing you to see the detail level you want.

Video Overview of New Features

Eﬁl www.oceansystems.com/forensic/forensic-Photoshop-Plugins/

To see our other product and workflow videos in our video library, go to
www.oceansystems.com/support/video library.php

ClearID 2.5 Release Notes 1 06/12/2012



http://www.oceansystems.com/forensic/forensic-Photoshop-Plugins/
http://www.oceansystems.com/support/video_library.php

Reference the new ClearID User Manual for more details on all these features after reviewing them
here.

F7 Key added for launching ClearID

Prior versions of ClearID used the F10 hot key to bring up the Clear ID workflow interface. Due to
changes in Photoshop CS5, we migrated to the F7 key for more consistent performance. F10 will
continue to work with this version of ClearID 2.5, however in testing we experienced intermittent delays
with the interface appearing after F10 was selected.

Testers reported having to “click” on the Photoshop interface after F10 was pressed to open the
ClearlD interface and intermittent delays with the workflow interface opening.

You can also launch ClearlD from PS Filters Menu > ClearID Workflow or PS Files > Scripts > ClearID
Workflow

Removing Alpha/Opacity Channels

Alpha/opacity channels are treated differently in CS5. Images with an alpha channel now display a
“checkered” pattern with no visual information. Additionally, programs like Windows Picture viewer
have issues displaying these images.

Import Images as a Layer Stack removes the Alpha Channel if present now hashes

This tool is located under the main Photoshop menu: File >Scripts>ClearIlD> Import Images as
Layers. This is similar to importing images from the Adobe Bridge: Tools>Photoshop>Load Files
into Photoshop Layers, only the ClearID function will hash the image file layers on import and
remove the Alpha/Opacity channel if it is present.

If you are using TIFF images from DVR dCoder v2.5.2 or later, this should not be an issue. But if
you are using TIFF images created by earlier versions or by other programs, importing images from
the ClearlD> Import Images as a Layer Stack is an extra safeguard in your workflow process.

F8 Key function — Removes Alpha Channel

If you imported images directly from Adobe Bridge instead of using the ClearID> Import Images as a
Layer Stack, you can remove the Alpha Channel on an image or images by using the newly
assigned ClearlD F8 key.

Regardless of which import method you use, your images will get a final hash when you run the
verification report.

New improved real-time preview, faster launching and faster rendering speeds

- Lens and Motion De-Blur, Ultimate Sharpener, Pattern Remover, Frequency Filters

While using any of these filters, open an image and moves the sliders. You should get real-time
updates as you slide them. This is a vast performance increase over ClearlD v2.0. Additionally, on
internal testing, we charted the launching of these plug-ins at up to 40% faster and the rendering
speeds up to 30% faster.

ClearID 2.5 Release Notes 2 06/12/2012



New Use Keyboard Arrow Keys to Make Adjustments in Video Field Alignment

Hold down the CTRL key along with the up, down, left, or right arrow keys to shift the fields.

Split Layer Stack into Fields

If you have imported your images as layers that have two fields, you can now split image(s) into two

separate layers so you have a separate layer for each field.

ClearlD® Workflow [F10 Key] x|

1-Correct Video Artifacts

~ 1-Correct Video Artifacts

ClearID® Single Image Functions Photoshop® Functions
@ Video Field Alignment (VFA) ¢ Delnterlace Video (pIV)
New
ClearID® Layer Stack Functions
€ Split Layer Stack into Fields (LS)
before .
Video Field Alignment on a moving object.
If possible, use video field alignment instead
of deinteriacing to preserve vertical resolution
in the image.
| ) ®
ear Cancel | oK |
Forensic image ClarFication for Photoshon.
CleariD® Workflow [F10 Key] x|
L - Correct Video Artfacts
CleziID® Funcions Photoshop® Functions 0
& Video Field Alignment (VFA) " Delntarlace Video (pIV}

Video Field Algrment on 2 moving cbject.

n the image.

f pocsibie, use video field alfignment instead
of deinterlacing Lo preserve vertical resoltion

A ClearlD =

ClearID 2.5 Release Notes 3
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ClearID Super-Resolution Functi

ons

We added a heading called ClearIlD Super-Resolution Functions. There is detailed information on this

process in the user manual.

- Reduce Image Size (plS) name changed to Adjust Image Size (plS) and moved under super-

resolution functions.

- Align Layers and Average (new) - Open two or more consecutive images and align them to a

target, then average to view more details.
o Hot Keys - CTRL Tab - Next Image, CTRL +Sht + Tab Previous Image, CTRL + arrow

keys nudge images and CTRL + mouse to move large distances.

- Average Layer Stack - Allows you to frame average a layer stack that doesn’t need to be

aligned first.

#  ClearlD® Workflow

=5

2-Resize & Frame Average

| (=) Adjust Image Size (pIS)

ClearID® Function
(O Average Layer Stack (FAS)

New

ClearID® Legacy Function
(O Frame Average (FA)

“ Wa Average
ClearID® Super-Resolution Functions

(O Align Layers and Average (FAAS)

Photoshop® Function
(O Crop to Selection (pCR)

Frame Averaging can reduce noise and
improve details. The dent in the side of this
truck is more visible after averaging 31 frames

If there is a lot of DV compression,there may
be no improvement from Frame Averaging.

ClearTD® Workflow [F10 Key] x|
2-Resize & Frame Average'
2 - Reske + Fame Average
ClaarD: Photoshop® Functions 0
@ frame Aversgs € Crop to Selection (pCR)
€ Reduce Image Sze (pl5)

A ClearlD’

rais Iraga ClerPaarisn or Phetaaboy

Frame Averaging can reduce noise and
improve details. The dent in the =ide of this
truck is more visible after averaging 31 frames

if there fs a lot of DV compression, there may
be no imgrovement from Frame Averaging.

o | 5]
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Interactive Deblur has been split into two functions

This allowed us to apply better default settings so each opens in a mode that provides better results.

- Interactive Lens DeBlur (ID)
- Interactive Motion DeBlur (ID)

ClearlD® Workflow [F10 Key] x|
3-Focus Correction

/7”3 - Focus Correction (Deconvolution)
ClearID® Functions

 Interactive Lens DeBlur (ID)

& Interactive Motion DeBlur (ID)

Photoshop® Functions o
" Smart Sharpen (pSS)

New
Interactive Deblur can be used to correct for
out-of-focus or motion-blurred images.
It is best used for images with little or no
noise or compression artifacts.
' ®
ar Cancel | OK I
Foransio Image ClarFication for Photoshod
CleariDe Workflow [F10 Key] N !l
3-Focus Correction
3 - Focus Comecdon (Deconvouton)
ClaarID® Funcons Photoshop® Functions 0
& Interactive DeBlur (ID) ' Smart Sharpen (pSS)

Interactve Deblur can be used to comect for
out-of-focus or moticn-blured images.

it is best used for images with kttle or no
naise or compression artifacts.

& ClearlD’ e |
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New Interactive Channel Selector (ICS)

This is much improved over the old process. Now you view more color channels and toggle between
them and apply them all in one place.

Hot Keys - Key letters (R, G, B, Y, etc. plus the 7, 1, 2, 3, 4, etc.) and the F1, F2, F3, etc. Space
Bar toggles between the last two images viewed.

CleariD® Workflow [F10 Key] X
4-lmprove Contrast
4 -Imp Contrast
ClearID® Functions Photoshop® Functions o
== ~ Interactive Channel Selector (ICS) € High Pass (pHP)
& Color-Safe Levels (CSL) C Levels (pLV)
 Color-Safe Curves (CSC) € Curves (pCV)
New
Photoshop® Legacy Functions
=P picka Color Channel (pCC) Constrast enhancement using
Color-Safe-Curves to make the details in the
faces more visible while diminishing the
effects of the lights at the top of the image.
There is a limit to how much meaningful
contrast enhancement can be done based on
the original image quality.
) ®
r Cancel I 0K |
Forensio Image ClarFication for Photoshod
ClearlD® Workflow [F10 Key] _j L 5’
4 - Improve Contrast

ClearlD® Funcoons Photoshop® Functons o

& Color-Safe Levels (CSL) € Pick a Color Channel (pec)

€ Color-Safe Curves (C5C) € Hgh Pass (pHP)

€ Levek (pLV)
© Curves [pCv)

Constrast enhancement using
Color-Safe-Curves to make the details n the
faces more visible while dminshing the
effects of the lights at the top of the image.

There is 3 fimit to how much meaningfu!
contrast enhancement can be done based on

the original image quality.

ZClearlD’ o e
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Verification Report Improved

- The report is now HTML with enhanced formatting.

- Reports Photoshop version and ClearlD version information.
- Thumbnail image is now displayed in the verification report.
- Expand and collapse buttons allowing you to see the detail level you want.

Verification Report - Images that were imported via the ClearID - Import Images as Layer Stack

function located in Photoshop > File > Scripts. As such, the images have a hash in the layer name
and a full SHA-1 hash value for each. To learn more about this function, reference the CID training

manual.

QOcean Systems® ClearID® Verification Report
¥ Document Info:

Location = ~fDesktop

Mame = Test 5 5.tif

Type = RGBE Color, 8 bits-per-channel

Dimensions = { 352 x 240 ) pixels

Date/Time = FiJul 23 2010 13:02:326 GMT-0400

ClearID® Version: 2.5

Photoshop® Version: CS5

o

Layer: CID ID:Lens Blur R=0.5 N=1.4 #E9B2E9# v2.5/C55
SHAL = FEAABA3BDEOACOEFB4777008EE3CCR71AREIB2ED (image+alpha)
—= ClearlD®: Interactive Lens DeBlur [Tab 3]
Photoshop@® Layer Properties: Visible, Normazl, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

Layer: CID FAAS: 3 images #D9C475# v2.5/CS5
SHA1 = EG48F7E762FAB76D3AE7A071D565F862E2D9C47S (image-+alpha)
--» ClearID®: Align Layers and Average [Tab 2]
Average based upon stack of 3 Layers:

dX dY Source Hame
24 -4 vans2.0047.tF
0 0 vans2.0048.4F
251 vans2.0040.4f
Photoshop® Layer Properties: Visble, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

ClearID 2.5 Release Notes 7
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Verification Report - Images sent directly from Adobe Bridge.

If you send images directly from Bridge, they will not have the hash in the layer name since they are not

hashed on import, but they will get hashed when you create the verification report.

Ocean Systems® ClearID@® Verification Report  Expand |  Collapse |
v Document Info:

Location = ~/Desktop

Name = Test CS 5.tif

Type = RGB Color, 8 bits-per-channel

Dimensions = ( 352 x 240 ) pixels

Date/Time = FriJul 23 2010 13:09:36 GMT-0400

ClearID® Version: 2.5
Photoshop® Version: CS5

v Layer: vans2.0047.tf
SHA1 = AC45B7B87565DAS58F6965A33250E31C963511EF1 (image+alpha)
Non-ClearID® Layer
Photoshop® Layer Properties: Visible, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

v Layer: vans2.0048.tf
SHA1 = 58AC9ASC7C38FSEBB430F725C5BOFF4E383AESBC (image+alpha)
Non-ClearID® Layer
Photoshop® Layer Properties: Visible, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

v Layer: vans2.0049.tf
SHA1 = EB18166C2203D5B77E407DF221F0B03E67BC5234 (image+zipha)
Non-ClearID® Layer
Photoshop® Layer Properties: Visible, Normal, Graphic Layer, Opacity 100%, Offset (H: 0, V: 0)

v Copyright ©2010, Ocean Systems. All rights reserved.
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Installing ClearID v2.5

Computer Requirements

e Win XP(32/64bit), Vista(32/64bit), Win7 (32/64bit)

¢ Photoshop CS4 and CS5 in (32-bit) only — we recommend you allocate 50% RAM to
Photoshop

e Min Screen 1024x768

Internet Browser Note - Firefox users will need to have it open before clicking the integrated help.

This version of ClearlD 2.5 unlocks “per user” and not “per machine”. A new unlock code will be
required. (This will effect multiple login users...using the same computer) Contact Oceans Systems
Support if assistance is required. Until the program is unlocked, it will run in a 30 day trial.

You can only have one version of ClearID installed on your system at a time

The ClearID v2.5 installer auto-checks for existing ClearID installations on your systems. If one is
found, it will prompt you asking if you would like to remove it before you proceed with your new
installation.

Changing between ClearID v2.5 and previous versions.

If you would like to revert back to an older version of ClearID, you should remove any previous
installations before proceeding.

ClearlD v2.5 and ClearID v2.0.2 installers will automatically check for any previous installations and
prompt you before it un-installs them. If you have ClearID v2.0 or v2.0.1, go to the download page and
upgrade to v2.0.2 since it is a free upgrade and it includes this auto-checking installer. If you choose
not to get this free upgrade, you will need to uninstall the existing ClearlD manually via the add/remove
programs function in windows before installing ClearID v2.0 or v2.0.1.

If you don’t have the ClearID v2.0.2.exe installation handy and you need to install it, you can look on
your system under C:Oceanystems/ClearID. This Ocean Systems folder is where we store the .exe
files for the programs that have been installed on your system. This allows people to back rev if they
need to recreate old work in the version that it was created in.

TIP - Make sure your Photoshop and Bridge versions match when sending images to Photoshop from
Bridge using the Bridge tool for sending images to Photoshop as layers.

If you have two versions of Photoshop installed such as CS4 and CS5 you should match up the
versions for Photoshop and Bridge. For Example - If using Bridge CS4 you should be using Photoshop
CsA.

ClearID 2.5 Release Notes 9 06/12/2012



Installing ClearID v2.5 Actions

Launch Photoshop
In Photoshop, select “Window”

© g bk~ b

new “OS ClearlD (r) 2.5” actions. (Figure 2)

Select “Actions” or Alt+F9 - This will open the Actions interface
Delete your old ClearID Actions - Example “OS ClearID (r) CS4”
Drag the folder into the trash located at the bottom right hand corner of the Actions interface.

Changing between ClearID v2.5 and ClearID v2.0

Don’t forget to load the matching Photoshop “actions” files if you are switching between versions.

In the Actions interface, click the upper right corner to expand the menu, and then select the

Delete your old actions and load the matching actions for the version of ClearlD you are using. Do not
leave two different actions loaded at once as they can cause conflicts.

R A R T S SR N AN

(Figure 1)

ClearID 2.5 Release Notes
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[ | = [0 o5 Clesrin(r) s
IFA b ClearID(r} Warkfl... F10
[ [ [» Repest LestStep  F11
IFA [» Delete Top CID La...F12
¥ |B|p [2 pefauk Actons
IR RN 05 ClaarID{r) 2.5
IFA = ClearID{r} Waorkflow F7
[ | ~ Scripts

File: C:\ClearID H...
[« [ | = FixCSsOpacty F&
[ w Scripts
IFA  Repeat Last Step
[ | ~ Scripts

File: C:z\ClearID H...
[« w Delete Top CID Layer
M| = Serpts

File: C:\ClearID H...
IFA + Legacy ClearlD Work...
[ | ~ Scripts

File: C:\ClearID_H...

-

\Myuic o)

Step 4

4 Step 6

Step 5
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