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dKLook in General 

Purpose 
The purpose of dKLook software is to combine on one screen the following information: 

• Chart from in the local folio 

• Databases of dKart Office 

• Information from the OGC Servers within a pre-defined area. 

Installation of the Program 
The section below describes how to install and run dKLook.  

System Requirements  
dKLook runs on a Microsoft Windows operating system. Before you install the software, make sure 
your equipment meets the following requirements: 

• Microsoft Windows NT 4.0 Service Pack 6, Microsoft Windows 2000, XP; 

• 2 GHz CPU at the minimum; 

• 256 MB of RAM at the minimum; 

• 200 MB of free HDD space; 

• 1024x768 resolution, 256 color monitor required 

Installing dKLook 
Installation Routine 

To install dKLook software: 
1. Log on with administrative rights. 

2. Insert the dKLook installation CD in your CD-ROM drive. 

3. Double click “dKLook.msi” installer icon in Explorer window – the Installation Wizard starts. 

4. Follow the instructions from the Wizard that will appear on the screen. 

5. Restart the computer. 

 
The program will be installed into the Program Files > Jeppesen Marine directory. 

 
Windows 7 and Windows Vista users 
 

dKLook users running Windows Vista or Windows 7 operating systems must be local (computer) administrator 
to get full use of the application and its functions. 

Here in particular users having an active Catalogue/Archive connection and OGC usage. 
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Uninstalling dKLook 
To remove the program from the hard disk: 
1. Run Microsoft Windows uninstall utility by selecting its shortcut from Windows “Start” menu. 

(Start > Settings > Control Panels > Add/Remove Programs) or select the shortcut Start > 
Programs > Jeppesen Marine > dKart Look 5.2 > Uninstall dKart Look 5,2   

2. Follow instructions on the screen. 

Starting/Exiting dKLook 
Start and exit the program using the standard tools of Windows. 
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User’s Interface 

Main Window Layout 
The main window of the program with its major features is shown in Figure 1. 

Figure 1 Main window layout 

 
The key elements of the window are: 

• The main menu (1), the “Standard” (2) and other (3 - 4) toolbars. 

In the menu and on the toolbars the user gets access to the most frequently used 
functionalities of the program. 

• The Charts panel (5) 

Various charts are shown on this panel, which is the key function of the program. 
• The Chart Folio panel (6) 

On this panel, the user gets access to the electronic chart collection management and chart 
display control functionalities. 

• The Found List panel (7)  

On this panel, descriptions are shown of objects located under the cursor right click on the 
chart 
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• The OGC Server (8) and OGC Server Layers (9) panels 

On these panels functionalities are provided to control display of information received from thr 
OGC servers. 

 

Much more panels and toolbars can be shown or hidden in the main window of the program 
as described in “Main Window Customization” on page 11. 
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Main Window Customization 
Showing/ Hiding Panels and Toolbars 

Run one of the menu commands to show/ hide a main or a panel/ toolbar in the main window of the 
program according to Table 1. 

Table 1 Showing/ Hiding panels and toolbars 

Command Panel/ Toolbar Reference 

Window > 
Catalogue (Read 
only) 

Shows/ Hides the Catalogue panel holding 
the entire contents of the Catalogue in the 
form of a tree 

“The Catalogue Tree” on page 44 

Window > 
Catalogue record 
(Read-only) 

Shows/ Hides the Catalogue Record panel 
holding an entry in the Catalogue in a 
tabular form 

“Viewing an Entry in the Catalogue in the 
Table” on page 47 

Window > Chart 
Folio 

Shows/ Hides the Chart Folio panel, on 
which functionalities are provided for chart 
folio management 

“Opening Chart Folio Panel” on page 19 

Window > Found 
List 

Shows/ Hides the Found List panel holding 
the list of objects under the cursor 

“Info on Objects on Charts of the 
Collection (The Found List Tool)” on page 
29 

Window > Geo-
editor table 

Shows/ Hides the coordinate table in a 
geo-query mode 

“Running a Point-Based Geo-Query” on 
page 54 

Window > 
Measuring tool 

Shows/ Hides the Measurements  panel “Measurements on the Chart” on page 27 

Window > OGC 
Sever layers 

Opens/ Hides the OGC Server Layers panel 
"Viewing OGC Server Information" on 
page 41 Window OGC 

Servers 
Opens/ Hides the OGC Server panel 

Window > System 
Messages 

Shows/ Hides the system message panel In this section 

Window > User 
Layer Object  

Shows/ Hides the User Object panel “The User Object Panel” on page 32 

Window > User 
Layer  

Shows/ Hides the User Layer panel “The User Layer Panel” on page 31 

Re-docking Panels 

To dock a panel e.g. to the upper edge of the window: 

 

Drag it holding by the title bar with the left-hand mouse button pressed onto the “∧”-wise control the 
upper part of the window – the blue shaded stripe covers the upper part of the window – and drop, 
Figure 2. 
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Figure 2 Re-docking a panel: case 1 

 
The panel gets stretched across the whole main window. 

To dock a panel e.g. to the upper edge of the Chart panel: 

Drag it holding by the title bar with the left-hand mouse button pressed onto the “∧”-wise control in the 
middle of the Chart panel – the blue shaded stripe covers the upper part of the panel – and drop, 
Figure 3. 

Figure 3 Docking a panel: case 2 

 
The panel gets stretched only across the Chart panel now. 

To convert an independent panel into a tab on the other panel: 

Drag it holding by the title bar with the left-hand mouse button pressed onto the “o”-wise control in the 
middle of the panel – the panel gets shaded in blue – and drop, Figure 4. 

Figure 4 Making a tab 

 
Customizing Default Menus and Toolbars 

To rearrange the default toolbar button and menu items, use the drag-and-drop technique with the 
Customize window open. 

To add a command/button to a default menu/menu item/toolbar: 
1. Run the View > Toolbars > Customize menu command to open the Customize window, 

Figure 5. 
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Figure 5  Adding a command  to a default menu 

 
2. Drag and drop the command/ button from the list in the Commands text box on the 

Commands tab in the Customize window onto the default menu/menu item/ toolbar as Figure 
5 schematically illustrates. 

 
Creating User’s Toolbars 

1. On the Toolbars tab in the Customize window press the New button – the New Toolbar 
window opens, Figure 6. 

2. Enter the new toolbar name in this window and press the OK – the new toolbar appears on the 
screen. 

Figure 6 Creating user’s toolbar: step 1. 

 
3. Fill in the new toolbar with buttons and commands using the drag-and-drop technique as 

shown in Figure 5. 

4. If necessary, dock the new toolbar properly in the main window of the program using the drag-
and-drop technique. 

To return to the default view of a toolbar/menu, press the Reset All button on the Toolbars tab. To 
delete a non-default toolbar, highlight it in the list of toolbars and press the Delete button. 

 
Graphic Interface Style 
Graphic interface elements can be styled in one of the MS design styles. To do so, run the View > 
Application look … menu command and select the style from the sub-menu that will then open. 

Drag e.g. Scale 
and drop it onto 
the main menu 
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Complete Command and Tool Reference 
See the complete list of the main menu commands and tools, brief explanation of effects of each and 
references to more detailed descriptions in the tables in this section below. 

File 
Table 2 The File menu 

Command Effect  Reference 

Load chart Loads a locally stored chart into the Chart 
View 

"Opening a Locally Stored Chart" 
on page 21 

Print  

Prints out a fragment of a chart. “Information Output to a Printer” 
on page 29 

Page Set up 

Print set up 

Print preview 

Exit  Exits the program “Starting/Exiting ” on page 7 

View  
Table 3 The View menu 

Command Effect  Reference 

Overview Overviews the World map “World Map Overview” on page 
23 

Zoom in Zooms in on an area on the chart 

“Rescaling a chart” on page 23 Zoom out  Zooms out on an area on the chart 

Scale Sets a user-defined chart presentation scale 

Toolbars > … Shows/ Hides toolbars in the main window of 
the program 

“Showing/ Hiding Panels and 
Toolbars” on page 11 

Status bar Shows/ Hides the status bar In this section 

Applicat ion look > … Sets the graphic interface style “Graphic Interface Style” on 
page 13 

Dragging mode Sets the continuous chart dragging mode “The Pan/ Drag Chart Modes” on 
page 24 Panning mode Sets the “center at cursor” chart panning mode 

Tools 
Table 4 The Tools menu 

Command Effect  Reference 

“Toolbar_name” > … Duplicates a button on the “toolbar_name” 
toolbar 

In relevant sections of the 
Manual 
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Settings Opens the program settings window “Program Settings” on page 15 

The Window Menu 
Show/ Hide panels in the main window of the program as listed in Table 1. 

Program Toolbars 
Toolbars of the program will be illustrated below in relevant chapters of the Manual. 

Program Settings 
Program settings are places on the tabs in the Settings window opened by running the Tools > 
Settings menu command. 

See the list of setting groups, brief explanations of effects they produce and references to the related 
topics in the text on this Manual below in Table 5. 

Table 5 Program settings 

Tab Effect  Reference 

Presentation Adjusts chart presentation according to S-52 “Adjusting Chart Presentation” on page 
24 

Chart Layers Shows/ Hides chart layers “Showing/ Hiding Chart Layers” on 
page 25 

DB Connect ions Functionalities for building connections to 
databases of dKart Office 

“Building Connections to Databases of 
dKart Office” on page 15 

Catalogue 
presentation 

Catalogue chart frame presentation "Presentation of the Catalogue in the 
Chart View" on page 44 

Measurements Defines the electronic ruler colors "ERBL Tool Colors" on page 17 

Draw on chart Shows/ Hides extra elements in the Chart View "Presentation of Extra Chart Elements" 
on page 25 

Building Connections to Databases of dKart Office 
dKart Look 5.2 may be setup to connect to existing dKart catalogue and dKart Archive databases. 

This will allow for digital catalogue integrated in the viewing experience as well as with an dKart 
Archive connection active, the operator may load the chart data by selecting proper chart record from 
the catalogue view. 

 

dKart Look do NOT come with any database setup tools. 

 
Build connection to the databases of dKart Office  on the DB Connections tab in the program setting 
window, which opens by running the Tools > Settings menu command, Figure 7. 
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Figure 7 The DB Connections tab in the program settings window 

 
1. Click as shown in Figure 7 to open the database connection window, Figure 8. 

Figure 8 The Connect to window 

 
1. Set the “SQL Server” option for the database in the list in the Database type field - more 

fields appear in this window for entering the SQL Server and Archive database names, login 
and password. 

2. Enter these into relevant fields in this window and press Connect. 

Click here to open the 
database connection 
window 

Switch on the 
check box here 
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ERBL Tool Colors 
The program offers the Electronic Ruler and Bearing Line (ERBL) tool for measurements on the chart.  
The operator uses it to build auxiliary points and lines on the chart to measure lengths, distances 
angles, etc. as described in “Measurements on the Chart” on page 27. Colors and widths of these 
points (markers) and lines can be customized by the user on the Measurements tab in the Options 
window, Figure 9. 

Figure 9 The Measurements tab in the Options window 

 

Specify marker and ruler line colors and widths in the respective fields on this tab. 
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Chart Collection Management 
dKLook user can compile the Collection of charts (chart folio) which are permanently on display in the 
main window of the program. Functionalities are provided on the Chart Folio panel for chart collection 
management and display control. 

A chart once added to the Collection stays in it during all later program sessions until the user 
explicitly excludes it. 

Chart Formats 
The list of data formats available for browsing using dKLook includes: 

• Encrypted/ Unencrypted dKart Charts (*.dcf) 

• S-57 edition 3.x (*.000.) 

o S-57 AML 1.0 and 2.1 

o Inland ENC 1.2 

• DAF 

• dKart Raster (*._bp) 

• *.px 

• GeoTIFF (*.tif, *.tiff) 

• Chart Catalogues (*.030, *.031) 

• OZI Explorer (*.map) 

• GeoJPEG 

• Charts Catalogue (*.030, *.031) 

• Multi-level charts (*.mlc) 

Opening Chart Folio Panel 
To open the Chart Folio panel in the view of Figure 35 run the Window > Chart Folio menu 
command. 

Figure 10 The Chart Folio panel 
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Adding a Chart to the Collection 
A chart automatically gets added to the Collection at opening it with dKLook. 

To open a new chart: 

1. Press the  button on the Standard toolbar or run the File > Load chart menu command  – 
the standard Open window opens. 

2. In this window, specify the full chart file name and press the Open button. 

The icon of the new chart appears in the list of charts on the Chart Folio panel and the chart gets 
shown on the Charts panel. 

Excluding a Chart from the Collection 
To exclude a chart from the Collection, select its icon on the Chart Folio panel and press the Del 
Charts button on this panel, Figure 36 . 

Figure 11 

 

Chart Display Control via Dynamic menu 
Use commands in the dynamic menu of the icon of a chart on the Chart List panel to adjust display of 
chart in this or that way as described in Figure 37. 
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Figure 12 Chart display control using dynamic menu command 

 
 

Table 6 Chart display control using dynamic menu command 

Command Effect  

Insert charts Displays a new chart "under" the current one 

Unload selection Hides the selected charts 

Unload all Hides all loaded charts 

Overview bounds Overviews the chart frame 

Overview chart Overviews the chart 

Original scale Shows the chart at the compilation scale 

Opening a Locally Stored Chart 
To open a chart stored locally yet not including it into the collection, run the File > Load chart menu 
command. 
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Chart Display Control 
Use buttons on the “Standard” toolbar and menu commands to control chart display according to 
Table 9. 

The “Standard” Toolbar 
Table 7 The Standard toolbar 

Button Effect  Command 

 Overviews the World Map Tools > Standard > Overview 

 Increase the presentation scale twice (zoom in) Tools > Standard > Zoom In 

 Decrease the presentation scale twice (zoom 

out). 

Tools > Standard > Zoom Out  

 Sets the “center-click” chart panning mode Tools > Standard > Panning mode 

 Sets the continuous chart dragging mode Tools > Standard > Dragging 

mode 

 Returns to the previous chart position and 

presentation scale 

Tools > Standard > Posit ion back 

 Undoes returns to the previous chart position and 

presentation scale 

Tools > Standard > Posit ion 

forward 

 and like Pans the chart to the left/ right/ etc. Tools > Standard > Move view 

point left/ right/ etc. 

 Opens the Help window Help > Help topics 

World Map Overview 
To overview the World map, press the  toolbar button or run the View > Overview menu 
command. 

Rescaling a chart 
• To scale a chart in/out twice, click the  or  toolbar buttons, 

• To zoom in on a region of a chart, drag the cursor across it with left hand mouse button 
pressed. 

• To continuously change presentation scale, rotate the mouse wheel. 
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• To change presentation scale one step back/ forward, press the  or  toolbar button, 
respectively. 

• To display a chart in an Overview mode, run the Overview command in the dynamic menu of 
Error! Reference source not found.. 

If the presentation scale needed to display the chart in an Overview mode turns out small 
enough, only the chart frame will be shown not separate objects on the chart.  

• To display a chart at the compilation scale, run the Original scale command in the dynamic 
menu of Error! Reference source not found.. 

The Pan/ Drag Chart Modes 
With the  toolbar button pressed click at a point on the chart to see the point of the click in the 
center of the Chart panel. 

With the  toolbar button pressed drag the cursor over the chart with left hand mouse button 
pressed to see the chart continuously following the cursor. 

Adjusting Chart Presentation  
To adjust presentation of a chart according to S-52 requirements, run the Tools > Settings menu 
command to open the Options window and set necessary settings on the Presentation tab in this 
window, Figure 38. 

Figure 13 The Presentation tab in the Settings window 
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Showing/ Hiding Chart Layers 
Features on a chart can be grouped into “layers”, e.g. bathymetric data, natural/ cultural features, etc. 
Switch on/ off layers to show/ hide on a chart on the Chart Layers tab in the program settings 
window, Figure 39. 

Figure 14 The Chart Layers tab in the program settings window 

 

Presentation of Extra Chart Elements 
Switch on/ off check boxes on the Draw on chart tab in the program settings window to show/ hide 
extra chart display elements (all names are self-explanatory), Figure 40. 
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Figure 15 The Draw on chart tab 
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Services for Browsing Charts 

Measurements on the Chart 

Running the ERBL Tool 
Run the Window > Measuring tool menu command to show the Measurements panel in the main 
window of the program, Figure 41, or press the  button on the “Enable measuring tool” toolbar, or 
run the Tools > Enable measuring tool > Measuring tool menu command. 

Figure 16 The Measurements panel 

 
To show the “Enable measuring tool” toolbar, run the View > Toolbars > Enable measuring tool 
menu command. 

Measuring Distance and Bearing 
1. Switch on the B, D radio box. 

2. Click over the first point with left mouse button.  

3. The marker stays on the chart. 
Marker color can be customized as described in “ERBL Tool Colors” on page 17.  

4. Move the cursor towards the other point.  

See the cursor permanently connected to the maker with the bearing line during the motion 
and the circle drawn automatically representing all points of the chart equally distant from the 
marker, 

5. Place the cursor exactly over the other point and read the distance from the marker in the D 
field and the bearing in the B field. 

Measuring Route Length 
1. Switch on the Sum radio box. 

2. Place the cursor onto the beginning of the route and click left mouse button. 
The marker stays at the position of the click. 

3. Move cursor to the next waypoint of the route and click again. 

Another marker stays there and a leg is built connected these points. 
Leg color can be customized as described in “ERBL Tool Colors ” on page 17.  

4. Continue in the same way at all other waypoints. 
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5. Once reaching the opposite end of the line/route, read its overall length in the Sum field. 

Press the Delete last button to break off the “rubber string” and bind the cursor to the last but one 
marker. Further pressing this button will erase the markers one-by-one binding the cursor to the 
previous marker. 
Press the Delete All button to erase the entire chain of markers at once. 

Using the Geo-Position Tool 
Use the Geo-position tool of the program to set a “bookmark” on the chart at a pre-defined point and 
then to quickly find it.  

Setting a “Bookmark” on the Chart 
To set a “bookmark” on the chart: 

1. Press the  button on the “Geo-position” toolbar or run the Tools > Geo-position > Open 
dialogue … menu command to open the Positioning window, Figure 42. 

Figure 17 The Positioning window 

 
To show/ hide the  “Geo-position” toolbar run the View > Toolbars > Geo-position menu 

command. 

2. Type the bookmark name in the Position name field. 

3. In the Datum field set the datum which coordinates of the “bookmark” are going to be linked 
to. 

4. In the Scale field enter the scale value to set after the bookmark is found, see “Finding a 
“Bookmark” on the Chart” on page 28. 

5. Enter the coordinates of the bookmark into the LAT and LON fields. 

6. Press Save. 

Finding a “Bookmark” on the Chart 
1. Select the name of the bookmark to find from the drop list in the Position name field. 
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2. Press Set. 
The bookmark will then be found and shown at the scale value set in the Scale field, see step 
4 in “Setting a “Bookmark” on the Chart” on page 28 

Info on Objects on Charts of the Collection (The 
Found List Tool) 
To open the Found List panel, run the Window > Found List menu command. 
Right click at a point on a chart or go around an area in the Chart View with the Shift button pressed/ 
not pressed (depending on the registry key value) on the keyboard – the list appears of objects on the 
charts in the Collection located in a close vicinity of the point of the click or within the area, and their 
attributes on the Found List panel, Figure 43. 

Figure 18 The Found List panel 

 

Highlighting of an object in the list makes the object itself highlighted on the chart. 

Editing System Registry 
To configure the program to open the Found List with or without the Shift key pressed, set the 
following registry key value 
HKEY_CURRENT_USER >Software > HydroSERVICE > dKLook 5.2 > PlugIns > FoundListPanel 
> Usersfit = 0 or 1. 

Information Output to a Printer 
There is a program function to print out the main window of the program in its current view. To do so: 
1. Run the File > Page set-up menu command and set the required settings as to page 

orientation, margin width, etc. in a Page Set up window that will then open. 

2. Run the File > Print menu command – the standard Print window opens. 

3. Set the required print settings in this window, and print. 
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User Layer Editor 

Purpose 
dKart Look user can create his “own” objects to be shown on electronic charts. These can be textual 
comments, unconventional areas, etc. Objects of this kind are grouped and stored in dedicated files, 
or “layers”.  When an electronic chart is on display, the program also reads user layer files to display 
objects in them too located within the chart area. 

User’s objects/ layers can be created, edited and deleted using the dedicated program module, 
namely the User’s Layer Editor (ULE). 
Use layer files reside in the UserLayer sub-folder in the program folder with an extension of *.ule. 

User’s Interface of ULE 
Functionalities are provided on the ULE toolbar and panels for work with user’s objects. 

ULE Toolbar 
Buttons on the ULE toolbar produce effects described in Table 11. 

Table 8 Buttons on the ULE toolbar 

Button Effect  

 Creates a new layer; 

 Renames an existing layer; 

 Deletes an existing layer;  

 
Imports a user layer from an external file; 

 
Exports a user layer data to an external file; 

 
Exports all existing layers each to its own file 

 Enters geometry editing mode; 

 
Creates a point user object; 

 
Creates a sector  

 
Creates a linear user object; 

 
Creates an area user object;  

 
Creates a text  

 Adds a node/ vertex 

 
Deletes a node/ vertex  
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Moves a vertex, symbol or sector; 

 
Inserts a new vertex between existing ones (for lines and 
areas); 

 Make a broken line closed (i.e. make contour) and start 
entering another one; 

 Undo last operation;  

 Redo last operation;  

 
Exits ULE 

To show/ hide the ULE toolbar run the View > Toolbars > User Layer menu command. 

The User Layer Panel 
On the User Layer panel, the user views the list of existing layers and gets access to layer 
management functionalities of the program via the dynamic menu commands as shown in Figure 44. 

Figure 19 The User Layer panel 

 
Under the root node of a layer, e.g. “Fishery” the list of all its objects stand, Figure 53. 
To open the UL panel, run the Window > User Layers Panel menu command. 

Layer Status Indicators 
Different layer icons perform as visual indicators of layer status according to Table 12. 

Table 9 

Icon Status 

 
Shown layer icon 

 
Hidden layer icon 

 
Active layer name 
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Inactive layer name 

Explanations will be given in “Setting the “Active” Status of a Layer” on page 34 below about what 
active status of a layer means. 

The User Object Panel 
On the User Object panel, Figure 45, the user can edit attributes of a user object. 

Figure 20 The User Object panel 

 
To open the UO panel, run the Window > User Object Panel menu command. 

Information on User Objects on the Chart 
User objects are shown “above” electronic charts e.g. as shown in Figure 46. 

Figure 21 A user area on the chart 

 
The list of user objects located at the position of a right click on the chart can be viewed on the User 
Objects tab on the Found List panel. 
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Coordinate Table of a User Object 
Like coordinates of a geo-query (see “Coordinate Table of a Geo-query” on page 54), those of a user 
object are also shown on the Geo-editor panel, Figure 27, in an editing mode. 

User Layer Management 
Right after the start up, the list of existing layers appears on the UL panel, Figure 44. Select a layer in 
this list with a left click and run one of the commands in the dynamic menu of Figure 44: 

• Show/ Hide Layer – to show/ hide all objects of the layer on the chart. 

• Overview Layer – to display the layer in an overview mode. 

• Center Layer – to automatically bring the geometrical center of all objects of the layer into the 
center of the screen. 

• Start editing – to enter the editing mode of an object of the layer, see “Editing an Existing 
User Object” on page 38 for how to continue. 

• Delete Layer – to delete the layer, which implies deletion of all its objects. 

• Rename Layer – to rename the layer. 

• Export (All)/ Import layer – to export (all)/ import the layer to/ from an external file as 
described in “Import/ Export of Layers” on page 34. 

• New Layer – to create e new empty layer as described in “Creating a New Layer” on page 33. 

Creating a New Layer 
To create a new user layer: 

1. Press the  button on the ULE toolbar- the New User Layer Name window opens, Figure 
47. 

Figure 22 Creating a user’s layer 

 

2. Type in the new layer’s name. 
3. Press the OK button.  

Renaming an Existing Layer 

To rename an existing layer: 
1. Select its icon on the UL Panel and run the Rename Layer dynamic menu command, Figure 

44 – the window of Figure 47 opens. 

2. Type a new layer name in this window. 
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Import/ Export of Layers 
Layer exchange is possible between different machines if the users provide access to layer data to 
each other. At export of a layer, layer data are exported to an external file with a *.ule extension on 
the HDD and then transferred onto the other machine on a media of this or that kind. However, in the 
course of the export routine layer data are protected from unauthorized access by means of a 
password. The authorized user on the other machine can “read” the layer data provided he knows the 
password. 

To export a layer: 
1. Select the layer icon on the UL panel and run the Export Layer dynamic menu command, 

Figure 44, or double click the layer icon and press the  button on the ULE toolbar – the 
standard Save as window opens. 

2. In this window navigate to the required directory on the HDD and press Save – the Define 
Password window opens,  

Figure 23 The Define Password window 

 
3. Enter a password in this window or press cancel to set a password-free access to the layer 

file. 

To import a layer: 

1. Press the  button on the ULE toolbar – the standard Open window opens. 

2. In this window navigate to the layer file on the HDD and press Open – the window of Figure 
48 opens for entering the password, if any. 

3. Enter the password in this window and press OK. 

The layer will then be imported into the program and saved to the UserLayer sub-folder in the 
program folder. 

Creating a New Object of a Layer 

Setting the “Active” Status of a Layer  
The “active” status of a layer means that it is the only one that can be edited at the moment, which 
includes adding new object to it and modifying and deleting existing ones.To set this status, double 
click the icon of the layer on the UL panel. See the layer name has got typed in bold, Table 12, and a 
prompt has appeared on the title bar of the panel saying what layer is being edited. 

Entering the “Add Object” Mode 
To enter the “Add Object” mode, press one of the buttons in Table 11 according to the metrics type of 
the object you’re going to create. 
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Creation of a New Symbol 
Defining Attributes of the Symbol 

After you press the  ULE toolbar button, the UO panel takes the view of Figure 49. 
Figure 24 The Attributes tab on the ULO panel 

 
1. On the Attributes tab on this panel, Figure 49, specify attributes of the new symbol. To do 

so: 
1.1 Select a patter from the list in the lower part of the window. 

1.2 Specify symbol color, orientation and font size in the fields of the same names. 
1.3 See the preview of the symbol in the Example box. 

2. On the Description tab, enter general description of the new symbol 

Figure 25 The Description tab on the ULO panel 

 
Building Geometry of the New Symbol 

1. Left click at the location of the new symbol on the chart. 

2. Click again and again, if several identical symbols are going to be created 

See the coordinates of the clicks have appeared on the Geo-editor panel in the form of a table, 
Figure 27. 
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3. After the last symbol is built, right click. 

Creation of a New Sector 

After you press the  ULE toolbar button, the UO panel takes the view of Figure 51. 
Figure 26 

 
On the Attributes and General tabs on this panel, specify attributes of the new sector and enter its 
general description, respectively, by analogy with those of a sector. 

A sector is considered an object with point geometry, which is the location of its vertex. Other 
geometry features of a sector (e.g. angular characteristics) are defined as scalar attributes. So,  build 
geometry of the sector by complete analogy with that of a symbol. 

Creation of a New Line 

After you press the  ULE toolbar button, the UO panel takes the view of Figure 52. 
Figure 27 
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On the Attributes and General tabs on this panel, specify attributes of the new line and enter its 
general description, respectively, by analogy with those of a sector. 

Building Geometry of a New Line 

1. Go on along the line clicking at its vertices. 

See the coordinates of the vertices appearing on the Geo-editor panel in the form of a table.. 

2. Having reached the end of the line, right click. 

Creation of a New Area 

After you press the  ULE toolbar button, the UO panel takes the view of Figure 53. 
Figure 28 

 
On the Attributes and General tabs on this panel, specify attributes of the new area and enter its 
general description, respectively, by analogy with those of a sector. 

Building Geometry of a New Area 

1. Go along the border of the area clicking at its vertices. 
In the process of drawing, the program automatically keeps the border contour permanently 
closed, Figure 54. 

Figure 29 

 
2. Having reached the last vertex, right click. 
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Creation of a Text 

After you press the  ULE toolbar button, the UO panel takes the view of Figure 55. 
Figure 30 

 
On the Attributes and General tabs on this panel, specify attributes of the new area and enter its 
general description, respectively, by analogy with those of a symbol. 

A sector is considered an object with point geometry, which is the location of its vertex. So, build 
geometry of the sector by complete analogy with that of a symbol too. 

Editing an Existing User Object 
To edit a user object: 
1. Select its icon under the root node of the layer it belongs to and run the Edit Object dynamic 

menu command, Figure 56. 
Figure 31 

 
The current attributes of the object get shown on the UO panel e.g. in the view of Figure 57. 
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Figure 32 

 
Figure 57 is obviously much like Figure 49 and Figure 51 - Figure 53 with the only difference for two 
extra buttons named Delete Object and Geometry. 

Editing Attributes of a User Object 
On the UO panel enter new attribute values of a user object as described in “Defining Attributes of the 
Symbol” on page 35. 

Editing Geometry of a User Object 
Press the Geometry button on the UO panel, Figure 57. 

Another technique to enter the geometry editing mode is to left click on the object with the  button 
pressed on the Geo-Editor toolbar. 
The object to be edited gets surrounded with a frame on the chart, Figure 58. 

 

Moving a Node/ Vertex 

1. Point the cursor onto the node/ vertex to move and left click. 
2. Move the cursor to the new position of the node/ vertex and click again. 
3. Press OK on the UO panel, Figure 57 

You can also enter the new coordinate values numerically directly into the coordinate table on the 
Geo-editor panel. 
To undo/ redo an action on the chart, use the Undo and Redo buttons, as usual. 

Deleting a Node/ Vertex 

1. Point the cursor onto the node/ vertex to delete and right click. 
2. Press OK on the UO panel, Figure 57 

To undo/ redo an action on the chart, use the Undo and Redo buttons, as usual. 
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Adding an Extra Vertex onto a Line/ Area Border 

1. Point the cursor onto the leg of the line onto which the extra vertex is going to be added, and 
left click. 
The cursor gets bound to the vertices of the leg with a “rubber string”, Figure 58. 

Figure 33 

 
2. Move the cursor onto the position of the new vertex and left click again. 

Moving an Object as a Whole 
1. Left click within the frame around the object, Figure 58. 

2. Move the cursor to the new position of the object. 

See the frame and the object inside following the cursor while it moves. 

3. Left click again. 

Deleting an Existing Object 

To delete an existing object, press Delete on the UO panel, Figure 57, or press the  button. 
 

 

 

 

 

 

  



 

 
Page 41 of 56 

 Jeppesen is a Boeing Company 

Viewing OGC Server Information 
The program can display information provided by OGC servers. 

Tools for Viewing Information from an OGC Server 
Buttons on the OGC sever toolbar run the functionalities are required for viewing information provided 
by OGC servers according to Figure 30 and Table 8. 

Figure 34 The OGC toolbar 

 
Table 10 The OGC toolbar 

Button Effect Reference 

 
Registers an OGC server "Registering a New OGC Server" on page 41 

 
Drawing of an area to be overlaid 
with OGC information 

"Display of Information from a OGC Server within a 
Pre-defined Area" on page 43  

Deletion of an area to be overlaid 
with OGC information 

 
Redrawing of an area to be overlaid 
with OGC information 

 
Switching the OGC Server data 
overview 

"Switching On The OGC Information Overview" on 
page 43 

Registering a New OGC Server 

1. Press the  OGC toolbar button – the Registered OGC Servers window will open, Figure 
31. 

 
Figure 35 The Registered OGC Servers window 
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2. Press New in his window and enter the OGC server address into the URL text box in the next 
window that will then open, Figure 32. 

Figure 36 The Add New Server window 

 
3. Press OK in this window to see the new OGC server registered n the panel of the same name 

as shown in Figure 33. 

Figure 37 

 
 

 

 
4. Switch on the check box at the left of the server name as shown in Figure 33.  

Viewing the List of OGC Server Layers 
 
1. Click the OGC server name on the OGC Server panel as shown in Figure 33 to open the list of 

its data layers on the OGC Layers panel as shown in Figure 34. 

 

Click here to 
display the list 
of OGC server 
data layers 
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Figure 38 

 

Display of Information from a OGC Server within a 
Pre-defined Area 

1. Press the  OGC toolbar button, drag the cursor across the area in the Chart View within 
which you'd like to the selected OGC server data layer and leave the cursor inside that area. 

2. Switch on the check box at the left of the server layer name as shown in  Figure 34. 

3. To cancel the display,  press the  OGC toolbar button. 

Switching On the OGC Information Overview 

To switch on display of the entire OGC information of the selected layer press the  OGC toolbar 
button. 
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Viewing Catalogue 

The Catalogue Tree 
At regular start-up, contents of the catalogue database is shown on the Catalogue panel as a 
tree of sub-catalogues of national hydrographic agencies, Figure 10. 

Figure 39 

 
To load a national catalogue into the program, run the Load Database dynamic menu 
command, Figure 10 or click at the “+” sign at the left. Then expand the lower levels of the 
tree as shown in Figure 11. 

Figure 40 

 

Presentation of the Catalogue in the Chart View 
1. Set the settings related to presentation of chart frames in the Chart View on the 

Catalogue Presentation tab in the program settings window,  Figure 12 
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Figure 41 The Catalogue presentation tab 

 
2. Select the "Using borders" or "Using coverage" option from the Draw method list. 

3. Select other chart frames drawing options in the Catalogue charts frame options 
group. 

Viewing the Catalogue in a Tabular Form 
All entries of a type in the Catalogue, e.g. ENC cell or paper chart entries, etc., can be 
viewed in the form of a table. To do so, run the Open as Table dynamic menu command, 
Figure 13 – the table of the view of Figure 14 automatically opens on the Catalogue Table 
panel holding all entries of the type. 

Figure 42 
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Figure 43 

 
To manually open the Catalogue Table panel, run the Window > Catalogue Table 

panel menu command.  

In this table press: 
• Attributes - to specify which of the table columns to show in an extra dialogue 

window that will then open, Figure 15. 

Figure 44 

 
• Sort – to sort entries by the attribute in the selected column (scale, navigational 

purpose, etc.) 
• Print – to print out the table. 

• Find – to run the ID-based search for an entry in the Catalogue as described in “ID-
based Search for an Entry in the Catalogue” on page 56. 

• Open – to open the selected entry in the form of a table, Figure 16. 

• Show – to automatically locate and overview the selected entry on the chart, Figure 
16. 

Viewing an Entry in the Catalogue 

Viewing an Entry in the Catalogue on the Chart 
On expanding e.g. the “ENC Cells” root node in the tree, all ENC frames appear on the chart, 
Figure 16. 

Select an ENC entry in the tree to make its frame color-shaded on the chart, Figure 16. 
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Figure 45 Catalogue entry on the chart and as a table 

  
Viewing the Related Chart in the Archive 

If an entry in the Catalogue describes a chart in the Archive, there is a function to load the 
chart itself into the program and show it on the Chart panel. To do so, run the Load from 
Archive dynamic menu command, Figure 11. 

Viewing an Entry in the Catalogue in the Table 
To view an entry in the Catalogue in the form of a table, run the Open dynamic menu 
command – the Catalogue Record panel automatically opens holding the entry description 
table, Figure 16. 

To open the panel manually, run the Window > Catalogue Record menu 
command. 

Queries to the Catalogue 

Entering Query Mode 
To enter the query mode: 
1. Run the Tools > Catalogue > Query Catalogue DB menu command – the first page 

of the query wizard opens, Figure 17. 
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Figure 46 The Query Wizard: page 1 

 
2. In the Database field select a sub-catalogue from the list to which the query is 

addressed, e.g. “ZX, Russian Federation, Morintech Ltd” or select the “All databases” 
option to address the query to all sub-catalogues at a time. 

Figure 47 

 
If a query is addressed to a particular sub-catalogue, there is another query technique 
to obtain the same result, Figure 19 (right part), that is to run the Query dynamic 
menu command as shown in Figure 19 (left part). 

Figure 48 

 

 

3. In the Record Type field, select the type of the entries you’re going to query for, e.g. 
“ENC Cells”. 

Setting Search Criterion 
1. In the Filter field on the first page of the query wizard, Figure 17, select a search 

criterion from the list, e.g. “By Scale”, Figure 20. 
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Figure 49 

 
 

Other options in this list are, Table 6: 

Table 11 Search options 

Search Option Reference 

By Scale “Scale-Based Query” on page 49   

By Coordinates “Coordinate-Based Query” on page 50 

Custom “Custom Query” on page 50 

Load from file  

2. Press Next on the first page of the query wizard, Figure 17. 

Scale-Based Query 
On the second page of a scaled-based query wizard, Figure 21: 

Figure 50 The scale-based query wizard: page 2 

 
1. Switch on the By Scale Range or By Scale Equal to radio box to query for entries 

with a scale within a predefined range or an exact value, respectively. 
2. With the By Scale Range option switched on, press/ release Include buttons to 

include or not include range limits into the search results. 
3. Press Next on the second page of the query wizard. 
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Custom Query 
A custom query means a query based on queried entry attributes, e.g. chart datum, 
navigational purpose, etc. 

On the second page of a custom query wizard: 
1. On the Attributes tab specify attributes of the queried entries. 

Figure 51 

 
2. Repeat the same routine on the Source Reference tab to specify attributes of the 

parent chart. 
3. Press Next on the second page of the query wizard. 

Coordinate-Based Query 
A coordinate-based query to the catalogue returns entries in it overlapping at least partly, a 
pre-defined figure, which the user draws manually on the chart. This can be a set of isolated 
points, a broken line (a route) or an area. 
On the second page of a coordinate-based query wizard, Figure 23: 

Figure 52 The coordinate-based query wizard: page 2 

 
1. In the drop list at the left, select: 
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• On Point – to treat coordinates you’re going to enter as those of isolated 
points. 

• On Area - to treat coordinates you’re going to enter as those of vertices of an 
area. 

• On Route – the same for a route (broken line). 

2. Press Add to open the first line in the coordinate table. 

3. Enter coordinates of a point/area/route into this line. 
Enter coordinates keeping to the rules formulated in “Coordinate Input Rules” on page 
51. 

Keep in mind the following restrictions. 

• You cannot combine different classes of geometrical primitives in one query. 
Use query-combining tool described in “Error! Reference source not found.” 
on page Error! Bookmark not defined. for this purpose. 

• If your choice was the On Area, you cannot define more than one area in one 
query. Use query-combining tool described in “Error! Reference source not 
found.” on page Error! Bookmark not defined. for this purpose. 

4. Press Next on the second page of the query wizard. 

The program offers another technique to enter the coordinates for a query, specifically to 
draw/select a geometrical primitive directly on a chart and take the coordinates from there. 
This is the issue to be discussed in “Geo-Queries to the Catalogue” on page 54. 

Coordinate Input Rules 

In these fields, always enter coordinates as pairs of digits separated by spaces, followed by a 
hemispheric sign. 

For instance, the entered string of the view 

10 00 00 

will be treated by the program as 

10°00′00″N 

Other Query Options 
On the third page of the query wizard, Figure 24: 
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Figure 53  The Query Wizard: page 3 

 
1. Left click in the Frames color field to select entry frame color on the chart on the 

standard palette that will then open. 
2. Switch on the Add to previous query check box to summarize the results of the new 

query to those of the latest one, see more in “Error! Reference source not found.” 
on page Error! Bookmark not defined.. 

Saving and Reusing Queries 
The conditions of a query can be saved to an external file or as “ser-defined”. The later 
means that the query conditions are saved and stored in the catalogue itself thus being 
directly available to the program user, see the list of user-defined queries in the drop list of 
the same name on the first page of the query wizard, Figure 17. 

1. To save the conditions of the query as user-defined, type the user-defined query 
name in the Save as use-defined field, Figure 24. 

2. To save the conditions of the query to an external file, press Save to File, Figure 24, 
and specify the full query file name in a standard Save as window that will then open. 

To reuse a query previously saved to an external file: 
1. Press Load from file on the first page of the query wizard, Figure 17,  and specify 

the full query file name in a standard Open window that will then open. 

2. Press Next on the next pages of the wizard and eventually Finish on the last page to 
re-run the query exactly in its original view, or change the query conditions and then 
re-run. 

To reuse a user-defined query: 

1. Select its name from the list of user-defined queries in the User-defined query drop 
list on the first page of the query wizard, Figure 17. 

2. Press Next on the next pages of the wizard and eventually Finish on the last page to 
re-run the query exactly in its original view, or change the query conditions and then 
re-run. 

Running a Query to the Catalogue 
1. Press Finish on the third page of the query wizard, Figure 24, thus running the 

query. 
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Simplified Query Routine 
If a query for e.g. ENC Cells is addressed to a particular sub-catalogue, e.g. “ZK, Russian 
Federation, Morintech Ltd.” with a “By scale” criterion, and you don’t need extra query 
options described in “Other Query Options” on page 51 and “Saving and Reusing Queries” 
on page 52, follow the simplified query routine. Specifically: 
1. Run the Query > By Scale dynamic menu command as shown in Figure 25 – the 

second page of the scale-based query wizard will open right away, Figure 21. 
Figure 54 

 
However, the Finish button replaces Next in this case. 

2. Set scale conditions on this page as described in “Scale-Based Query” on page 49 
and press Finish. 

By analogy, run e.g. Query > Custom dynamic menu command, Figure 25 to open the 
second page of the custom query wizard, Figure 22, etc. 

Viewing Query Results 
The results of a query are shown on the Catalogue panel in the view of Figure 26. 

Figure 55 

 
Note, that the program will automatically expand only those sub-catalogue root nodes in 
which the query has returned non-zero results, and mark them with a “query” indicator as 
shown in Figure 26. For instance, this figure illustrates that the latest query has returned the 
only paper chart entry in a Russian catalogue.  

Study the results of a query in the same way as the entire catalogue, see “The Catalogue 
Tree” on page 44 and subsequent sections. 

Successful 
query indicator 
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Geo-Queries to the Catalogue 
Functionalities are provided to run a query to the Catalogue for entries in it overlapping, at 
least partly, a pre-defined figure, which the user draws manually on the chart. This can be a 
set of isolated points, a broken line (a route) or an area. 

The “Geo-Query” Toolbar 

Use buttons on the “Geo-query” toolbar to enter one of the drawing modes according to 
Table 7. 

Table 12 The “Geo-query” toolbar 

Button Equivalent command Effect  Reference 

 
Tools > Geo-query 
manager > Insert points 
to geo-editor 

Enters point drawing 
mode 

“Running a Point-Based Geo-
Query” on page 54  

 
Tools > Geo-query 
manager > Insert region 
to geo-editor 

Enters arbitrary region 
drawing mode 

 

 
Tools > Geo-query 
manager > Insert circles 
to geo-editor 

Enters circle drawing 
mode 

 

 
Tools > Geo-query 
manager > Insert areas to 
geo-editor 

Enters rectangle drawing 
mode 

“Rectangular Area-Based 
Query” on page 56 

 
Tools > Geo-query 
manager > Add line to 
geo-editor 

Enters broken line drawing 
mode 

“Running a Route-Based 
Query” on page 55  

 
Tools > Geo-query > 
Accept changes 

Confirms drawing results  

 
Tools > Geo-query > 
Discard changes 

Cancels drawing results 

Coordinate Table of a Geo-query 

Coordinates of a geo-query are shown in a tabular form on the Geo-editor panel in the view 
of e.g. Figure 27. 

Figure 56 The Geo-editor table panel 
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To show the Geo-Query panel, run the Window > Geo-editor table menu command or 

press the  button on the toolbar. 

Running a Point-Based Geo-Query 

1. Press the  button on the “Geo-query” toolbar or run the Tools > Geo-query > 
Insert points to geo-editor menu command. 

2. Left click at the first point on the chart. 

A colored cross stays on the chart. 

3. Left click at other points. 

See coordinates of the points appearing in the coordinate table on the Geo-Query 
panel in the view of Figure 27. 

4. Follow the query making routine until you reach the second page of the coordinate-
based query wizard, Figure 23. 

5. On this page, switch on the From chart option – the coordinate table gets filled with 
coordinates of the points. 

6. Complete the query routine and run the query. 

Running a Route-Based Query 

1. Press the  button on the “Geo-query” toolbar or run the Tools > Geo-query > 
Insert line to geo-editor menu command. 

2. Move the cursor along the route on the chart clicking at its waypoints, Figure 28. 

Figure 57 Drawing a route 

  

At the same time, see coordinates of the points appearing in the coordinate table on 
the Geo-Query panel in the view of Figure 27. 

3. Having set the ending waypoint of the route, right click. 

4. Press to  confirm the configuration on the chart or  to erase it. 
5. Follow the query making routine until you reach the second page of the coordinate-

based query wizard, Figure 23. 

6. On this page, switch on the From chart option – the coordinate table gets filled with 
coordinates of the waypoints of the route. 

7. Complete the query routine and run the query. 
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Rectangular Area-Based Query 

1. Press the  button on the “Geo-query” toolbar or run the Tools > Geo-query > 
Insert area to geo-editor menu command. 

2. Click at a corner of the rectangle on the chart. 

3. Click at the opposite corner. 

See coordinates of the corners have appeared in the coordinate table on the Geo-
Query panel in the view of Figure 27. 

4. Press to  confirm the configuration on the chart or  to erase it. 

5. Follow the query making routine until you reach the second page of the coordinate-
based query wizard, Figure 23. 

6. On this page, switch on the From chart option – the coordinate table gets filled with 
coordinates of the corners of the rectangle. 

7. Complete the query routine and run the query. 

ID-based Search for an Entry in the Catalogue 
You can find and view an entry in the Catalogue without making a query if you know its ID.  
1. Press Find on the Catalogue Table panel, Figure 14 - the Find Record window 

opens, Figure 29. 

Figure 58 The Find record window  

 
2. Type the entry ID in the Number field – the list below will automatically be scrolled 

down to the this ID. 
3. Left click at the ID in the list – the Open and Show buttons get enabled. 

4. Press  

• Select - to overview the frame of the entry on the chart. 

• Open – to open the entry in a tabular form, Figure 16 
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