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Installing 3CX VOIP client 

What is the 3CX VOIP client? 

The 3CX VOIP Client is a small Windows application that allows you to make and receive 

calls via your desktop phone or using a headset connected directly to your computer.  

You can see the extension numbers of other users and whether they are available to take 

calls. Important is that you can use the 3CX VOIP client without having to use the head-

set - you can continue to use your desk based phone if you prefer. 

The 3CX VOIP client ships with all editions of 3CX Phone System, including the Free 

edition. However, in the Small Business, Pro and Enterprise editions, the 3CX VOIP client 

allows you to see the presence of other users on the phone system. In the FREE edition, 

other extensions appear greyed out. 

Installing 3CX VOIP client 

The 3CX VOIP client is a small application and is easy install: 

1. Download the latest 3CX VOIP client from 

http://www.3cx.com/downloads/3CXVoipClient.msi 

2. Click ‘Run’ to execute the setup process. You will be prompted for your preferred 

interface language and to select a location.  

3. The files will be copied. Click Finish to complete installation. 

Configuring 3CX VOIP client for use on the local LAN 

The first time you start the 3CX VOIP client, you will have to configure a number of 

options. 

 

Screenshot 1 – Login to 3CX Phone System 

To set-up 3CX VOIP client: 

1. Start 3CX VOIP client from the 3CX VOIP Client program group or by double-

clicking on the tray icon. 
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2. In the connection drop down, you can specify which connection/location profiles 3CX 

VOIP client should use. For now leave the default ‘In Office’ for first setup. See the 

following paragraph for more information on creating additional connection/location 

profiles. 

3. In the top field enter the hostname or IP of the machine which has 3CX Phone 

System installed.  

4. Enter your extension number and your voice mail pin number (By default the PIN is 

the same as your extension number) You can change this from your voice mail 

menu or from the user portal. 

5. Now select whether you are using a desk phone, or whether you are using a 

headset connected directly to your computer. In this case, 3CX VOIP client will act 

as a soft phone. 

6. Click OK to start 3CX VOIP client. Once you have logged in successfully, your 

extension number will be shown in the phone screen. 

Configuring a Remote Connection 

3CX VOIP client can be used both on the local network, as well as from a remote 

network, for example from home. In this case you will need to create different 

location/connection profiles, since the network connection settings are different. 

This feature requires help from your administrator, who will need to give you the right 

network settings as well as tell you whether you should use the 3CX Tunnel feature or 

make a ‘direct’ connection. 

Configuring a remote connection using the 3CX Tunnel 

To simplify firewall configuration, you can use the 3CX Tunnel feature, which tunnels all 

SIP traffic over a single TCP Port. To set-up a connection profile using a 3CX Tunnel: 

1. Select File > Connections from the menu 
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Screenshot 2 –Creating an Out of the Office Connection 

2. In the Connection Settings dialog, click on the ‘Out of Office’ connection and specify 

the internal IP of 3CX Phone System on the right hand side.  

3. In the section ‘Authentication’, select ‘3CX Phone System’ and enter your extension 

number and pin code. 

4. Click on the tab ‘Tunnel’. Tick the option ‘Use 3CX tunnel’ and then specify the public 

IP and port of the 3CX Phone System machine in the field “Remote end of Tunnel’. By 

default this is 5090. 

5. Click Connect to check that the tunnel is working. The Tunnel status will show you 

whether connection has been successful. 

6. Click on the OK button to exit the dialog. You can rename the profile by right-clicking 

on the profile and giving it a different name. 

To switch to ‘Outside the office mode’ from within the phone, select ‘Action > Connection 

> Out side the office’ from the menu. The connection will be re-established with the new 

connection settings. 

Note: If you wish to use a 3CX Tunnel installed on a different host, simply enter the IP of 

the host with the 3CX Tunnel service installed. In this case you must configure the 

Remote end of the Tunnel on the machine using the tunnel. 
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Configuring a “direct” remote connection 

Using the ‘direct’ mode requires that your administrator has setup the firewall in front of 

3CX Phone System correctly, as well as that your NAT device can handle VOIP. Most 

modern home routers (Linksys, Netgear and so on) are now capable of handling VOIP 

correctly.  

To create an Out of Office connection that does NOT use a 3CX Tunnel: 

1. Select File > Connections from the menu 

 

Screenshot 3–Creating an Out of the Office Connection 

2. In the Connection Settings dialog, click on the ‘Out of Office’ connection and specify 

the public IP of 3CX Phone System on the right hand side. 

3. In the section ‘Authentication’, select ‘3CX Phone System’ and enter your extension 

number and pin code. 

4. Click on the tab ‘GENERAL and enable the option “Use STUN – Resolved Public IP 

Address’. Leave the default STUN server or enter another one.  

5. Now click ‘Apply’. You can rename the profile by right-clicking on the profile and give it 

a different name. 

To switch to ‘Outside the office mode’ from within the phone, select ‘Action > Connection 

> Out side the office’ from the menu. The connection will be re-established with the new 

connection settings. 
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Configuring a connection to a 3rd party VOIP provider/SIP server 

If you want to create connection that must connect to a VOIP provider, or another SIP 

server (for example Asterisk), then create the connection as follows: 

1. Select File > Connections from the menu. Click on the ‘Add’ button to create a new 

connection profile. 

 

Screenshot 4 –Creating an Out of the Office Connection 

2. Now specify the IP of the VOIP provider or SIP server on the right hand side. If in 

doubt, contact your administrator. 

3. In the section ‘Authentication’, select ‘SIP server / VOIP provider’ and enter the 

Account (usually your VOIP provider number or Extension number) and your assigned 

Authentication ID and Password. 

4. If connecting to a VOIP provider or remote SIP server, click on the tab ‘STUN and 

enable the option “Use STUN – Resolved Public IP Address’. Leave the default STUN 

server or enter another one.  

5. Now click ‘Apply’ to save the connection profile. 

To switch to this connection from within the phone, select ‘Action > Connection > 

Connection name’ from the menu. The connection will be re-established with the new 

connection settings. 
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Using the 3CX VOIP client 

Introduction 

3CX VOIP client can work as a soft phone and it can work in combination with a desk 

phone. You can use a desk phone and the 3CX soft phone at the same time. (Because 

3CX supports SIP forking). In this way you can make and receive calls on either the desk 

phone or the soft phone, whichever is more convenient at the time. 

This chapter explains how to use 3CX VOIP client as a soft phone, then explains how it 

can be used with a desk phone and finally it discusses the common features, available in 

both ‘modes’. 

Using the 3CX VOIP client as a SIP phone 

 

Screenshot 5 - 3CX VOIP client in SIP phone mode 

1. Dial Pad 
2. Phone functions 
3. Lines 
4. Status screen 

5. Phone modes 
6. Status panel 
7. Dial 
8. Hang up 

 

If you selected to use 3CX VOIP client with a head set, then the 3CX VOIP client will work 

as a SIP Phone, and the interface will resemble a phone. 

Making calls 

To make a call, simply dial the number on the keypad using your mouse, or enter the 

number using your keypad. Click the green button  or hit the enter key to instruct the 

phone to dial the number. 3CX VOIP client will make the call on the first available line. 
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Answering Calls 

As soon as a call comes in, 3CX VOIP client will ring and show the incoming call on the 

screen of the phone. It will also pop up a small dialog in the system tray informing you of 

the new call. 

 

Screenshot 6 – Answering Calls 

The incoming call will light up the LED on the first available line.  

To answer the call, click on the answer button  or hit the ‘Enter’ key.  

To reject the call, click on the red hang-up button or hit the ‘Escape’ key. The caller will be 

treated as if your phone was busy. The forwarding settings for ‘Call Busy’ will be 

triggered. 

You can answer a call by hitting the “Enter” key, or cancel a call by hitting the 

“Escape” key 

Note: If you already have a call active, the call will be received on the second line, and 

the LED on the second line will flash. To answer this call, click on the line 2 button first. 

Your call on line 1 will automatically be put on hold and the LED one line 1 will flash. 

Transferring calls  

Blind transfer 

A blind transfer transfers the call to another extension without first speaking to the target 

extension. There are 2 ways to perform a blind transfer: 

Method 1 

1. Click on the transfer button   

2. Dial the destination number or double-click on the extension in the status panel and 

click on the dial button  or hit the ‘Enter’ key. 

Method 2 

1. Select the ‘Transfer Call’ option from the Action menu 

2. Enter the extension number to which you want to transfer the call and click OK 

Attended transfer 

An attended transfer is performed by first calling the target extension and speaking to the 

person who is to take the call. There are 2 ways to perform an attended transfer: 
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Method 1 

1. Select the Attended Transfer option from the Action menu 

2. Enter the extension number to which you want to transfer the call and click OK.  

3. After you have introduced the caller to the user of the extension, click on the transfer 

button to transfer the call. 

Method 2 

1. Click on the ‘Line 2’ button and dial the number of the extension you wish to reach. 

Alternatively double-click on the extension in the status panel. The call on ‘Line 1’ will 

automatically be put on hold. 

2. After you have introduced the caller to the user of the extension, click on the transfer 

button and click on ‘Line 1’ to connect both extensions. 

Transferring calls to voice mail 

If you are unable to take a call, you can transfer the call to your Voice mail. You can do 

this by clicking on the icon in the menu bar, or the menu item Action > Transfer to Voice 

mail. The caller will be transferred to your voice mail box where he can leave a message. 

Recording a call 

 

Screenshot 7 – Recording a call 

You can record a call simply by clicking on the record call button. This will record the 

current call in progress and save it as a wav file on the server. To get access to the 

recording, contact your administrator. 
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Call History 

 

Screenshot 8 – Viewing Call History 

You can view the history of calls received and placed by clicking on the ‘History’ button. 

To place a call to a number in the call history, simply double-click on the number to 

launch a call to that number. Alternatively select the entry and click the Redial button. 

Adjusting Microphone level 

 

Screenshot 9 - Adjusting the Microphone level 

The microphone audio level is set by the sound card driver in Windows. To adjust it: 

1. Go to Windows Control Panel and double click on ‘Sounds and Audio Devices’. In the 

Audio tab, click on the Volume button in the Sound Recording section, then use the 

sliders to adjust the microphone recording level. 
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2. Alternatively, double click the speaker icon in the Windows taskbar.  Go to Properties 

and from the Mixer device drop down menu select an Input device, click on OK to 

continue. Moving the sliders up or down will adjust the microphone recording level 

accordingly. 

Using 3CX VOIP client with a desk phone 

 

Screenshot 10 – Using the VOIP client as a desk phone 

If you selected to use 3CX VOIP client with a desk phone, the interface will not have a 

dial pad – all phone calls will be made and received via your desk phone. However, you 

can see the status of other users on the phone system, as well as monitor extension 

status via the status screen. 

Features common to both VOIP client and Soft phone mode 

Status screen 

 

Screenshot 11 – Status Screen 

1. Extension number 

2. Soft Phone/Desktop mode 

3. In office/Out of office mode 

4. Voicemail 

5. Available/Away 

 



 
 3CX Phone System for Windows System for Windows www.3cx.com 

 

Page 16 

The status screen on the phone summarizes important information. It shows 

· Your extension number and name 

· If you have voice mail waiting and if so, how many 

· Whether you are using a desk phone or using the client as a SIP phone 

· Whether your phone is set to ‘in the office’ or ‘out of the office’ mode 

· Whether your status is set to ‘Available’ or ‘Away’ 

Furthermore, when you make or receive a call, the number to be dialled OR the caller ID 

of the caller is shown in the middle of the status screen. Just below it you will get 

information messages about the progress of the call. 

Extension, Line & Queue Status 

3CX VOIP client has an ‘Operator panel’ which allows you to see the status of other 

users. In the FREE edition, other extensions will appear as greyed out. Presence 

information is only available in the commercial editions. 

 

Screenshot 12 - Presence filter buttons 

By default all extensions, lines and queues are listed, however you can filter them using 

the tool bar buttons. 

 

Screenshot 13 - Adding / Removing columns 

If you do not want to expand the columns, and not all the extensions fit, you can click on 

the arrow buttons to browse the remaining extensions in the last available column. 

Specifying Away/Available status 

 

Screenshot 14 – Specifying Away status 

If you temporarily can not answer the phone, you can specify that you are ‘Away’. This 

will show your colleagues that you are not in a position to answer calls.  

All calls that do get sent to your extension will be handled according to the “Phone busy” 

setting configured for your extension. 

To set your extension status, select “Available” or “Away” from the toolbar. Note that this 

setting will persist even if you shut down 3CX VOIP client! 

Preferences 

The preferences dialog allows you to set your 3CX VOIP client preferences. You can 

change your extension options by clicking on the ‘Change Extension options’ button. This 

will launch your default browser and connect the 3CX Phone System User portal. 
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Screenshot 15 - Preferences 

You can also configure the following options for 3CX VOIP client: 

· Tick the option “Automatically start 3CX VOIP client when Windows starts”, so that 

3CX VOIP client will automatically run in the System Tray each time Windows starts. 

· Tick the option “Log me in automatically” so that 3CX VOIP client will use the last 

entered credentials to login automatically to 3CX Phone System.  

· The option “Show Menu Bar” hides or shows the menu bar in the main interface. 

· The option “Action on Ringing” allows you to define how you want 3CX VOIP client to 

notify you when you receive an incoming call: 

a. Show answer dialog – this option will show a dialog which will allow you to 

answer, reject or send the call to voice mail 

b. Show notification popup – this option shows a small popup notifying you of an 

inbound call. 

c. Bring main window to front – This will bring 3CX VOIP client to the front of all 

dialogs. 

· You can select your preferred interface language using the selector 

· In the ‘Multimedia devices’ section, you can select which audio device you wish to use 

for speaking, ringing and listening 
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Launching calls from Microsoft Outlook 

Introduction 

This feature requires a commercial edition of 3CX Phone System for Windows 

If you use Microsoft Outlook or any TAPI compliant application, and store all your phone 

numbers in Outlook contacts, you can easily launch calls directly from Outlook. To do 

this: 

 

Screenshot 16 - Right click on a contact 

1. Right click on the contact in Microsoft Outlook, and select ‘Call contact’ 

 

Screenshot 17 - Microsoft Outlook New Call dialog 

2. The Microsoft Outlook New Call dialog will appear. The first time you use the Microsoft 

Outlook integration, click on ‘Dialing Options’ 
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Screenshot 18 - The Dialing Options dialog 

3. In the section ‘Connect using line’, select the entry 3CX VoIP Client. Click OK to exit 

the dialog. 

4. Now you can click the start call button. The call will be launched using the 3CX VOIP 

client. 

Note: If you are using the ‘Desk phone mode’, then the call will be set-up to your desk 

phone. 
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Call Queue integration 

Introduction 

3CX Phone System has a powerful feature called Call Queues, which allows callers to be 

queued until any of the agents can take the call. The actual configuration of who is an 

agent for a particular Call Queue is done from the 3CX management console 

3CX VOIP Client enables you to take full advantage of this feature by allowing you to 

easily login and logout of the queues, as well as to monitor queue status. 

Logging into a Call Queue 

If you are an agent for a particular queue, you need to login to the queue to let the phone 

system know that you are available to start taking calls. This avoids calls being sent to 

your extension without you being available. 

To login to all Call Queues that you are a member of: 

1. Select Action > Queue > Login to all Queues. 

2. You will now be routed calls as they come into the queue. 

The Queue monitor 

 

Screenshot 19- Monitoring the queues 

The Call Queue monitor allows you to see the available queues, which agents are logged 

in as well as which agents are on a call in the queue. To launch the Queue monitor: 

1. From the ‘View’ menu, select ‘Show Queues’ 

2. If you want the dialog to remain on top, even if you minimize the VOIP client, select 

‘Always on top’. 
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