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Support Information 

Support phone: +1-440-646-3434 

Website: http://www.rockwellautomation.com/support 

New Features and Enhancements 

http://www.rockwellautomation.com/support


 

Interface Element Description of Updates Since Previous Release 

Windows and dialog boxes 

Upload/Download Icons The Micro800 Upload/Download icons are now consistent with other devices. Up arrow indicates upload 

and down arrow indicates download. 

Project Organizer Programs can be dragged and dropped within the Project Organizer to change their execution order. 

The following items have been added to the right-click menu: 

 Connect 

 Diagnose 

 Secure 

 Variable Export / Import 

 Data Protection 

 Document Generator (print) 

The icons for the Programs and User-Defined Function Block groups have been updated. 

An Interrupt icon is now shown when an interrupt is assigned to a program. 

Device Menu Connected Components Workbench now has a context-sensitive Device menu for accessing commonly 

used functionality. The Device menu contains the following items: 

 Build 

 Connect 

 Download 

 Upload 

 Diagnose 

 Secure 

 Change Controller 

 Import 

 Export 

 Data Protection 

 Document Generator (print) 

Download Downloading the project to the controller will automatically Build if the project has changed since the last 

Download. 

When downloading the project to a Micro820, Micro830, or Micro850 controller, a new Download 

Confirmation dialog appears, asking if you wish to Download or Download with Project Values. See the 

Data Upload / Download feature below for more information. 

Variable Grid The Attribute column has been hidden by default. It can be shown by right-clicking on the header and 

selecting Show Column > Attribute. 

When viewing variables in Debug mode using a Micro820, Micro830, or Micro850 controller, the Initial 

Value column is moved left so that it is next to the Physical Value column. 

When viewing variables in Offline mode using a Micro820, Micro830, or Micro850 controller, a new 

column, Project Value, has been added. See the Data Upload / Download feature below for more 

information. 

Micro800 Controller 

Configuration pages 

The Micro800 Controller Configuration page additions, changes and removals: 

 General 

 Memory page now with enhanced memory diagnostics on instruction and data usage   

 LCD Module 

 Startup, includes Diagnose button  

 Startup/Faults, removed 

 Serial Port, includes Diagnose button for CIP and Modbus RTU Driver selections 

 Ethernet, includes Port Settings and Diagnose button 

 Port Settings, removed 

 Internet Protocol, removed 

 Port Diagnostics, removed 

 Real Time Clock 

 Date and Time, removed 

 Memory Card, includes Diagnose button 

 Plug-in Modules - 2080-MEMBAK-RTC 

 Plug-in Modules - 2080-SERIALISOL 



Ladder Diagram Editor  Horizontal space optimized by making labels hidden by default and moved above the comment 

 Improved readability by removing the color gradient background 

 More flexibility in customizing the rung’s visual properties. Right clicking rung provides an easy way to 

reset back to defaults.  

Function Block Editor Function Blocks can be aligned to one another at their top, bottom, left, and right edges, as well as aligned 

with their vertical (center) and horizontal (middle) axes. 

The background grid has been removed. 

PanelView Components 

DesignStation 

The PVc Help is now part of the Connected Components Workbench Help.  

 

 

 

Function Block Description 

RTO The RTO function block is a retentive timer. It increases an internal timer when its input is active, but does 

not reset its internal timer when its input changes to inactive. 

 

 



 

 

 

 

 

 

 

 

 

 

Diagnose View Description 

Controller Allows you to compare the configuration settings of the current project and the connected controller, 

including controller startup, Memory Module, Memory Card and LCD Module. 

Fault Allows you to view the status of the controller, information about any faults that occur and to retrieve a 

detailed fault log. 

Communication Allows you to display real-time statistics for the controller's Ethernet or Serial ports. 



 

 

 

 

Communication Method Statistics Displayed 

Ethernet Ethernet Link Status, Interface Counters, Media Counters  

CIP Serial Diagnostic Counters 

Modbus RTU Link Counters 

 

Feature Description 

Backup and Restore Allows the backup and restore of the CR30’s configuration with the 2080-MEMBAK-RTC plug-

in module. Plug-in must be inserted into slot 1 while connected to the CR30 in order to access the 

backup and restore functions. 

Function Block Name Change Allows changing the name of a Safety Monitoring Function (SMF) or Safety Output Function 

(SOF) block. The feature has built-in name checking to ensure all function block names are valid. 

Mute Lamp Safety Output Function The default assignment for the Mute Lamp Safety Output Function is a single output terminal. 

The preferred assignment is: 

 First available multipurpose terminal, 12 -17 (with a configuration type as No PT). First 

available terminals 18-21 will take second priority (with a configuration default of PT). 

Comparison of downloaded/uploaded 

configuration 

After a Download Success, the downloaded CRC and uploaded CRC are displayed for 

verification purposes. 

Password Protection Prevents unauthorized access and possible tampering with safety relay programs. 

Input Filters Safety Monitoring Functions: 



 Tooltip – Input Filter tooltip for Safety Monitoring Functions. Recommends filters never 

exceed 250 ms. 

 Safety Mat - input filter selection limited to a range of 0-8.  

 Reset – input filter removed. 

 Restart – input filter removed. 

Plug-in Modules The safety relay supports these additional standard I/O plug-in modules: 

 2080-IQ4 plug-in module 

 2080-OB4 plug-in module 

 2080-OW4I plug-in module 

Report Generation Printing a report is available from the logic editor. 

System Requirements 

Component Minimum Requirement Recommended 

Processor Intel Pentium 4 2.8GHz or equivalent Intel Core i5 2.4GHz or equivalent 

RAM memory 2 GB 8 GB or more 

Hard disk space 10 GB free 10 GB free or more 

Optical drive DVD-ROM DVD-ROM 

Pointing device Any Microsoft Windows®-compatible pointing device Any Microsoft Windows®-compatible 

pointing device 

 

 

 



Controller Type Major Firmware Revisions 

Micro810 1.xxx, 2.xxx, and 7.xxx 

Micro820 6.xxx and 7.xxx 

Micro830 1.xxx, 2.xxx, 4.xxx, 6.xxx and 7.xxx 

Micro850 2.xxx, 4.xxx, 6.xxx and 7.xxx 

 

 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/609492
http://www.rockwellautomation.com/rockwellautomation/support
http://www.rockwellautomation.com/rockwellautomation/support/pcdc.page
http://www.rockwellautomation.com/rockwellautomation/support


Software Tested Version 

RSLinx® Classic V3.70.00 

ControlFLASH™ V12.00.01 

 

 

 

 

 

Note: RSNetWorx v21.00 is also available in Studio Professional v21.00. 



Working with Projects in Connected Components Workbench 
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Installation and Upgrades 

 

 

 

 

 

Note: CCW determines the correct components to upgrade and/or install. If there is a reboot requirement, reboot the operating system so 

the install can complete successfully. 

 

Tip: Some Microsoft components may require a restart before the full CCW installation is complete. If Connected Components Workbench 

does not install completely, restart the computer and then re-install CCW. After the Connected Components Workbench installation 

completes, the computer background will return to its default setting. 

 

 



 

 

 

 

 

 

 

 

 

 

Note: Connected Components Workbench determines the correct components to 

upgrade. 

 

 

 



 

 

 

 

Note: Modbus mapping information is stored in the MbSrvConf.XML file located in 

the CCW project structure: CCW\<projectname>\controller\controller and can be 

copied from the original project to the newer one. 

 

 

 

Important: Remove CCW before you remove Microsoft Visual Studio Shell or you will not be 

able to remove CCW. 

 

 

 

 

 



 

 

The directory is <Root of the DVD media>\7.00.00-CCW\Firmware\PVC_Firmware 

Note: This latest firmware v1.80 is required to use new features such as the enhanced Download function, which can be used to 

download to your PVc terminal from CCW. 

Type Includes 

Rockwell Automation  ControlFlash™ 12.00.01 

 Rockwell Windows Firewall Configuration Utility 1.00 

 Rockwell Automation USB CIP Driver Package (x86) or 

 Rockwell Automation USB CIP Driver Package (x64) 

 RSLinx Classic 3.70.00 

 Unified Device Configuration v3.10.0 

 Current Program Updater 

Microsoft .NET Framework  Microsoft .NET Framework 4 Client Profile 

 Microsoft .NET Framework 4 Extend 

Microsoft Visual Studio 2010 Isolated Shell - ENU  Microsoft .NET Framework 4 Multi-Targeting Pack 

 Microsoft SQL Server 2008 R2 Management Objects 

 Microsoft SQL Server System CLR Types 

 Microsoft Visual C++ 2008 Redistributable - x86 9.030729 

 Microsoft Visual C++ 2010 X86 Runtime - 10.0.40219 

 Microsoft Visual Studio 2010 Shell (Isolated) -ENU 

Microsoft Visual Studio 2010 SP1  Microsoft Visual Studio 2010 Tools for Office Runtime (x86) 

 Microsoft Visual Studio 2010 Service Pack 1 

Microsoft - other  MSXML 4.0 SP2 Parser and SDK 

 Microsoft Help Viewer 1.1 

 Microsoft SQL Server Compact 4.0.8482.1 

Other  OPC Core Components Redistributable (x86) 101.2 or 

 OPC Core Components Redistributable (x64) 101.2 

 Virtual COM Port Device Driver 6.3a 

 Adobe Reader 11.0 

http://ab.rockwellautomation.com/Graphic-Terminals/2711C-PanelView-Component-C400-Terminals%23/tab6
http://ab.rockwellautomation.com/graphic-terminals/2711p-panelview-plus-6-terminals


Connected Components Workbench Developer Edition Only 

FactoryTalk  FactoryTalk Activation Manager v3.60.00 (CPR 9 SR 6) 

 FactoryTalk Diagnostics v2.60.00 (CPR 9 SR 6) 

Helpful Resources 

Tips:  If the user interface item does not display a topic, click Help > Search and enter a subject in the search box to locate a 

relevant topic in the help. 

 Connected Components Workbench uses local help only. If the Online Help Consent dialog box appears when you press F1, 

click No, and verify the I want to use local help option is selected. 

 

 

 

http://ab.rockwellautomation.com/
http://www.rockwellautomation.com/rockwellautomation/knowledgebase


Article ID number 

Micro800 basic FAQ Answer ID 116930 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/1

16930 

Micro800 extended technical FAQ Answer ID 1188115 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/1

18815 

Security considerations when using Rockwell Automation Software 

Products 

Answer ID 609492 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/6

09492 

RSNetWorx v11 and Prior Incompatibility with Rockwell 

Automation Software Products 

Product Notice ID 56697 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/5

66967 

 

 

 

 

 

 

 

 

 

 

 

Important Considerations 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/116930
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/116930
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/118815
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/118815
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/609492
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/609492
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/566967
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/566967
http://literature.rockwellautomation.com/
http://literature.rockwellautomation.com/


 

 

 

 

 

Resolved Anomalies 

Connected Components Workbench allows you to install on a Microsoft Windows® operating system using an account that does not have 

administrator privileges. 

Note: It is recommended that Connected Components Workbench is installed on a user account with administrator privileges. 

[APBC00012930] 

If you click a hyperlink on the MSP module page on a computer that does not have IE Explorer installed, Connected Components 

Workbench will continue to respond and operate normally. [APBC00019002] 

If you customize the grid columns in a variable grid and then select Save as default layout settings, the settings will be reset after you 

click Tools > Import and Export Settings and select the No, just reset settings overwriting my current settings option. 

[APBC00016798] 

The Tools -> Execution Order feature is available and works properly on a program that is password protected. [APBC00018113] 

Context-sensitive help is available for all elements in the Structured Text editor. [APBC00011459] 

If you use the Document Generator to create documentation for Programs (POU) that contain large Ladder Diagrams, the generated 

document will correctly display the picture of the Ladder Diagram. [APBC00013865] 



After the Key Read function block is triggered, its output is reset after the rung goes false. You can check the Status bit to verify the 

output results. [APBC00019913] 

The Enter Password dialog box no longer appears when you are working on a UDFB even though you did not modify the program. 

[APBC00018411] 

After completing a successful build, a yellow warning icon does not appear on the instruction block. [APBC00007405] 

If you import a UDFB while an instance variable structure is being viewed, the instruction values refresh properly within the language 

editor. [APBC00018349] 

You will not experience any intermittent issues related to removing the SD memory card while it is being accessed by the Micro800 

controller. [APBC00018115] 

If your program calls nested UDFBs, build results appear in the output window when you build the program. [APBC00018116] 

If you open a project created in a CCW R2.0 or CCW R4.0, then set the initial value of a UDFB and perform a Refactor operation, you 

will not receive an error indicating the initial value has an incorrect format. [APBC00017736] 

Known Anomalies 

If the My Documents folder is mapped to a network drive and the user installing Connected Components Workbench does not have full 

permissions to the network folder the following error might appear: "Error 1325 [FolderName] is not a valid short file name. 

[APBC00021544] 

Connected Components Workbench installs two folders named CCW under "Libraries > Documents". The duplicate folder name is 

inaccurate because the folders contain different files. One folder contains saved project files and the other contains Sample Project files. 

[APBC00021599] 

The first time you launch Connected Components Workbench after installation, if you open two or more instances of CCW at the same 

time, the following error might occur: 

"License is expired; the product has returned to the Free Version." [APBC00020976] 

Workaround: When launching Connected Components Workbench for the first time, do not open multiple instances. If this occurs you 

must uninstall and then re-install Connected Components Workbench. 

When starting Connected Components Workbench, it may hang and a stopped working dialog will appear. Occasionally some of the 

layout settings may be corrupted affecting editing and monitoring variables, because the initiation process was interrupted. Due to 

performance issues, this occurs mostly on VMware machines or when starting Connected Components Workbench for the first time after 

installation. [APBC00022659] 

Workaround: If this occurs reset the Layout settings in Connected Components Workbench: 

 From the Tools menu, select Import and Export settings. 

 Select Reset all settings, and click Next. 

 Click Finish. 



The user manual for the Guardmaster_440C_CR30 is available from the Help > Device Manuals menu. The manual has not been 

updated for CCW 7. [APBC00018733] 

Workaround: To obtain the latest user manual from the Literature Library, go to http://literature.rockwellautomation.com. 

 Additionally, you can click Help > View Help and locate the Safety Relay book in the help table of contents. 

 Go to http://ab.rockwellautomation.com/Relays-and-Timers/Safety-Relays/Guardmaster-440C-CR30#documentation 

If you create a project, leave the project open, switch to a different user, open a new instance of Connected Components Workbench and 

create another project, you may receive a catalog error and you will not be able to create a new project. [APBC00017014] 

If, after you install the English version of CCW, you change the language format text to the Turkish language, you may receive 

unexpected results including the following: 

 Broken help links when you reopen a project. 

 Non-English characters that display when you debug your program. 

 Inability to use the filter feature in a language editor for certain characters. 

 Failed build because the project name or folder contains invalid characters. 

 

If, while using the English version of CCW, you enter non-English characters in a string variable, the characters may not display properly 

after you save, close and then reopen the project. [APBC00015937] 

Workaround: In your operating system, select the language version of non-Unicode programs that will be used in the Language for 

non-Unicode programs. 

If you open multiple projects on a network drive using File > Recent Projects, and then exit or close CCW, the application may not close 

immediately. [APBC00014847] 

Content for the instruction block tooltips, and in the Category and Comment columns of the Instruction Block Selector appear in 

English in the non-English versions of Connected Components Workbench [ ] 

If you add a Block element to a Program (POU) in the non-English versions of Connected Components Workbench, rename the POU in 

the Project Organizer and then click Save or Build a “Detected… modification” error may appear. [ ] 

Workaround: Close the error dialog and continue. 

The labels for Browse and No header or footer in the Document Generator for the non-English versions of Connected Components 

Workbench may be truncated. For example, the label ‘Durchsuchen’ appears as ‘Durchsuche’. [ ] 

The Quick Find and Quick Replace features (Ctrl+F and Ctrl+H) are limited to logic editor. They do not work with devices, global 

variables or UDFBs. Additionally, Quick Find has the following limitations: 

 It does not find any items when the Look In selection is Current Project or Entire Solution. 

 It may not locate all instruction blocks within all containers in the project. 

 It does not find all instances of the same Array element variable in all the programs within a project. 

Workaround: To find items in the project, click Edit > Find and Replace > Quick Find, and click Current Document or All Open 

Documents in the Look In drop-down box. 

The Quick Find and Quick Replace features will be enhanced in a future release  

If the appearance settings in your operating system uses a high-contrast color theme, some workspace elements will display incorrectly. 

For example, ladder rungs and connectors in the program editors, graphics and toolbar in the Controller Details view, and the Device 

Toolbox. [APBC00011574] [APBC00011577] [APBC00011578] 

Workaround: Do not use a high-contrast color scheme.  

If you select View > Document Overview while in the Structured Text language editor, the Document Overview displays a blank page. 

[APBC00004685] 

If the Micro800 controller has 7.0 or pre-6.0 firmware and is password protected by CCW7.0, you cannot connect to the controller with a 

Connected Components Workbench Version that is 6.0 or lower. Access is denied even when the correct password is provided. 

Workaround: Clear the controller’s password by CCW7.0. 

If the Micro800 controller has 7.0 or pre-6.0 firmware and is password protected by CCW6.0 or lower, you cannot connect to the 

controller with a Connected Components Workbench Version that is 7.0. Access is denied even when the correct password is provided. 

Workaround: Clear the controller’s password by CCW6.0 or lower. [APBC00022232] 

When you re-launch Connected Components Workbench after an unexpected shutdown, the Micro800 controller might be locked and 

you will be unable to connect to it from the Connection Browser. [APBC00021900] 

Workaround: The recommended solution to clear the lock on the controller is to restart Windows and the controller. 

The second option is to: 

1. Terminate CCW.Shell.exe and RA.CCW.CommServer.exe 

2. Shutdown RSLinx and restart RSLinx 

3. Restart CCW and try to connect to the controller, the connection may still fail. 

4. Restart CCW and RSLinx and try again, the connection should be established. 

If you remove all the characters in the Name text box in the Controller Configuration pane, you might receive the following error 

message:  

“Controller name cannot be empty,” even though you may be about to enter a name. [APBC00011369] 

http://literature.rockwellautomation.com/
http://ab.rockwellautomation.com/Relays-and-Timers/Safety-Relays/Guardmaster-440C-CR30%23documentation


When you configure an Event Input Interrupt (EII), you can specify which input to use from the Configure Event Input Interrupt (EII) 

dialog box. You cannot, however, specify the edge triggering type (rising or falling edge) from the same dialog box. [APBC00005579] 

Workaround: To specify the EII edge triggering type (rising or falling edge), click Embedded I/O in the controller tree and configure 

the Properties in Input Latch and EII Edge. 

You cannot view or configure parameters for Micro810 LCD modules within Connected Components Workbench. [APBC00005458] 

Workaround: To configure LCD module setup parameters: 

 Download the program to the controller. 

 Configure the setup parameters using the LCD module. 

 Upload the program to Connected Components Workbench. 

 Save the program. 

While in PanelView, if you create decimal values while the regional setting is set to English, and then change the setting to Spanish, the 

PanelView Component incorrectly displays integer values. [APBC00005484] [APBC00005485] 

Workaround: Change the regional settings before making any application changes. 

In the Variable Editor, when viewing a user-defined function block that contains multiple nested functions or function blocks, the nested 

variables may not align correctly within the Logical Value column. If you hide the Logical Value column and then show the column, it is 

moved to the rightmost position in the Variable Editor and the values for the nested variables may not show in the column. 

[APBC00014339] 

If you create a string array using the Global Variables grid, the maximum length is 252 characters. If you create a string array using the 

Data Types grid, the maximum length is 255 characters. [APBC00010227] 

Workaround: Make all string arrays 252 characters or less. 

The SAFEBOOL data type appears as an option in the Arrays grid, but SAFEBOOL is not supported by Micro800 controllers. 

[APBC00010414] 

Workaround: Do not select SAFEBOOL as a data type. 

The maximum number of words for the MSG_MODBUS ElementCnt parameter is 123 even though the LocalAddr specifies 125 

words. If you use a value of 124 or 125 for the ElementCnt you will receive an error indicating a bad MSG file parameter exists. 

[APBC00003889] 

Workaround: Verify the ElementCnt variable uses a value of 123 words or less. 

If you use single quotes in a variable within an array element even when the data type is String, the build may fail. [APBC00011206] 

Workaround: Do not use single quotes in array element variables. 

The allocated memory for a Micro800 controller is not retained on the Memory configuration page after a Controller Change or 

Export/Import project. [APBC00021196] 

The allocated memory value is not retained when you upload. [APBC00021722] 

User-defined global variables with data types BYTE, WORD, LWORD, and DWORD might display as USINT, UINT, ULINT, and 

UDINT data types on LCD displays for Micro800 controllers. [APBC00020820] 

If you use constant values in arithmetic expressions unexpected build errors may occur for the following data types: 

 DWORD 

 LWORD 

 INT 

 SINT 

 UDINT 

 ULINT 

[APBC00021989]  

Workaround: To avoid unexpected build errors use Variables with initial values instead of constant values in arithmetic expressions. For 

example: DWORD data length is 0 to 4294967295.  

 The arithmetic expression 4294967295 + 0 results in an inaccurate build error.  

 The arithmetic expression 4294967295 + any Variable with initial value 0 does not cause a build error. 

Include Logical value upon backup and restore’ functionality does not restore the logical value for the following system variables: 

 _SYSVA_KVBCERR 

 _SYSVA_TCYCYCTIME 

 _SYSVA_TCYWDG 

[APBC00021350] [APBC00021351] 

If you attempt to copy and paste a variable that uses an initial value from one open session of Connected Components Workbench to 

another open session, you may receive an error message similar to one of the following, and the paste operation will not be successful. 

 “Warning: The variable you are pasting having the data type ‘aa’ is non-existent in the current project. Therefore, the variable shall be 

created as an undefined type. 

 The importation of the symbol Controller.Micro850.Micro850.Prog1.v1 was unable to set the field TextInitialValue (1.65) -> 

Exception Message: The value does not match the format of the data type." 

When you copy and paste from one project to another project, CCW may not copy all the properties of the object. If the new project does 

not have all the property objects defined, such as a data type, errors may occur. [APBC00018350] 

Workaround: Copy all data type definitions to the project before you copy the variable.  

If you monitor a variable with an array data type, the variable may display WAIT for its value. [APBC00018556] 

Workaround: Use the variable view to monitor the values for the array.  



In this release, some of the vendor specific instruction blocks and other program elements have not been identified as reserved words. 

When you name a variable, CCW may allow you to name a variable the same as an instruction block even though it should not be 

allowed. When you attempt to build a program with duplicate names, the error message will identify the instruction name as the problem 

rather than the user variable. [APBC00017881] 

If you name a variable the same as an existing program name, you will receive an error when you attempt to build the project. You can 

disregard the error message as a program and a variable can use the same name since they are different object types. Duplicate names in 

this situation will not prevent the project from building. [APBC00018410] 

If you attempt to set the Logical Value for a sub-element of a data type that contains a nested array/structure, you may need to click more 

than once to enable the selection. [APBC00017133] 

If you use the Search option to search and replace content in user-defined function block code, the replace process continues without 

stopping. [APBC00020636] 

Workaround: To stop the continuous Search and Replace process, restart Connected Components Workbench. 

If you assign variables to the COP instruction block instance and start debugging, the Scr and Dest input values do not update. They 

incorrectly display as WAIT. [APBC00014533]  

Workaround: To debug the COP instruction block instance and view the Scr and Dest input values as they update, do not assign a 

variables to the COP inputs. 

If you import a user-defined function block into a password-protected program that already contains an instance of the same UDFB, you 

will not be prompted to enter the program password even though the UDFB instance in the program will be replaced by the newly 

imported UDFB instance. [APBC00018245] 

If you rename a user-defined function block instance that is referenced in a program and then build the controller project, the following 

error message appears: 

“A function, function block, or operator is not defined”. 

UDFB instances must have the same definition to successfully build the controller project. [APBC00016939] 

Workaround: Open the program and reselect the UDFB. 

In a Function Block Diagram program, if you connect the output of an ANY_TO_WORD operator to the input of a UDFB, the compiler 

will display a false positive error that the data types do not match. [APBC00005062] 

Workaround: Use an intermediary variable to transfer a value between the instructions. 

After building a program that uses an ANY_TO_WORD, ANY_TO_DWORD, or ANY_TO_LWORD operator that does not have the 

correct data type defined for the output variable, you might receive the following error message: 

“Expecting a UINT type variable,” even though the output parameters all use a WORD data type. [APBC00007106] 

Note: The error message should state that a WORD type variable is expected. 

In Connected Components Workbench R6 and R7, Defined Word, Const0 is incompatible with all data types on compare instructions. 

[APBC00022224] 

Ladder Diagram programs, if you assign variables by name to an instruction but the variables do not exist yet, a yellow triangle appears 

as expected. When you create the global or local variables and build the program the build succeeds. However, the yellow triangle 

remains in the instruction until you re-assign the variables to the instruction in the Ladder Diagram program. [APBC00019976] 

If you use a Remote Desktop Connection to access a CCW program, the font for some of the comments in the program may change and 

be difficult to read. [APBC00017812] 

Workaround: Double-click the comment to restore the original font. 

When the Recipe function block continuously writes recipe data files to the Recipe sub-folder, the number of files created may exceed the 

maximum allowed limit of 50 files. 

Workaround: See the Micro820 controller user manual for more information about maximum limits. The manual is available from Help 

> User Manuals > Controllers > Micro820. [APBC00017884] 

If you use the AWT command to send characters when the RX (receive) buffer is empty, the characters will not be sent. 

[APBC00017012] 



If you import a file containing Toolbox settings using the Import and Export Setting Wizard and the project contains an LD program, 

the LD Toolbox may not show its controls after the import. Instead, the LD Toolbox will show the text, "There are no usable controls in 

this group. Drag an item onto this text to add it to the toolbox." [APBC00020531] 

Workaround: Right-click the Toolbox and select "Reset Toolbox". 

In the Import and Export Setting Wizard, if you reset all settings and select the option, No, just reset settings, overwriting my 

current settings, some items may not appear in the File and Help menus as expected. [APBC00015185] 

Workaround: If this happens follow these steps: 

1. Save your project. 

2. Close, and reopen Connected Components Workbench to display all the menu items. 

If, while importing variables into a password-protected POU, you click Cancel in the Enter Password dialog box, the import will be 

canceled, which is expected behavior. However, you still may receive an Import was successful message in the output window, which is 

incorrect. [APBC00016089] 

If you try to Import a Micro800 program that contains a password and the program is not compatible with the version of Connect 

Components Workbench that you are using, the Password required dialog box appears. After you enter the password, the Unable to 

start importing dialog appears. [APBC00014022] 

If you import a POU that contains an instruction that is not supported in the target Micro800 project, you will receive an error when you 

build the project, which is expected behavior. However, if you double-click the error item, it will not navigate to the error location in the 

project. [APBC00014443] 

If you import a UDFB program into a project that contains a user-defined data structure or array with the same name as the UDFB, the 

project build will fail, which is expected behavior. However, the error message may indicate a FB symbol duplication error, which is 

incorrect. [APBC00015612] 

If you enter Debug mode after running Connected Components Workbench for an extended period of time, a red X may appear in the 

language editor, and you may receive the following error message: 

“CCW.shell has encountered a problem. We apologize for the inconvenience. Please tell ISaGRAF about this problem” 

[APBC00018407] 

Workaround: If this occurs, close the language editor, verify you are in Debug mode, and then reopen the language editor. 

Note: Any message that identifies ISaGRAF as a contact should actually identify Rockwell Automation as the contact. See Support 

Information for contact information 

If you attempt to build a project that has an invalid Motion Engine Execution Time, you will receive a build error, which is expected 

behavior. If you then delete the Motion Axis without first correcting the Engine Execution Time and build the project again, the build will 

still fail. Note: When you enter an invalid value, the field is outlined in red indicating an error. [APBC00011576] 

Workaround: Follow these steps to resolve the error: 

1. Add an Axis, and enter a valid Motion Engine Execution Time. 

2. Save the project. 

3. Delete the Axis and then save the project again. 

4. Re-build the project. 

If you change the interrupt assigned to a program, Connected Components Workbench does not calculate a new CRC for the program. 

When you attempt to debug a program where only the interrupt has changed, Connected Components Workbench displays a project 

contents mismatch error instead of a CRC mismatch error. [APBC00021071] 

Complex variables, function blocks and instructions that contain members with initial values do not download their logical values to the 

controller. The following instructions contain read-only initial values and are affected by this anomaly: 

 AWA 

 AWT 

 COP 

 HSC 

 IPIDCONTROLLER 

 MSG_CIPGENERIC 

 MSG_CIPSYMBOLIC 

 MSG_MODBUS 

 MSG_MODBUS2 

 PLUGIN_READ 

 PLUGIN_WRITE 

[APBC00021172] [APBC00021254] 



Instructions with a USINT input parameters have the following issues: 

 Debugging these instructions: the USINT input parameters show WAIT. 

 Uploading data values: warning message shows for instructions with USINT inputs and their logical values fail to upload. 

The following instructions have USINT input parameters: 

 MSG_CIPGENERIC      

 MSG_CIPSYMBOLIC    

 PLUGIN_READ         

 PLUGIN_WRITE        

 DLG                

 MUX4B              

 MUX8B  

 RCP          

 MC_AbortTrigger   

 MC_TouchProbe  

[APBC00022484] 

If you download a project to a controller, then upload the project to a computer where the date and time is prior to the date and time on 

the first computer, the second computer cannot Debug or Download to the controller. [APBC00021719] 

Workaround: Follow one of the following steps to resolve the error: 

 Set the date and time of the second computer to be equal to or later than the first computer. 

 On the first computer, export the project to a compressed file, then import the project on the second computer. 

Restore from memory and Load always functionality are contradictory. When a controller in Connected Components Workbench is not 

password protected and Memory module is password protected, the Restore from Memory Module' button is unavailable because of a 

password mismatch. However, if you power cycle the controller and Load always is enabled for the controller, the program is transferred 

to the controller. [APBC00021421] 

Application Notes 

 

 

 



 

 

 

 

Note: If connecting using CAT5-style cabling, be sure to select the correct port (it may 

not be the Windows default). 
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