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1. About Syntralink 

Syntralink enables you to integrate your software applications or automate your PC-related activities. 

Integrations can be performed by extracting information from the user interface of a particular 

product, then transforming it and loading it in another product’s user interface by using export and 

import files (.txt, .csv, xml и др.), web service, etc. 

The automation operations are carried out by recording a sequence of actions, which are recreated 

by Syntralink afterward. 

You are able to implement integrations and automations of applications that are working on one or 

several computers, operated by one or more users. 

Syntralink consists of two modules – client side and server side. The client side module allows you to 

extract and import data from / to your applications, to “listen” to events (such as mouse clicks, file 

creation, etc.) and perform pre-recorded or set-up actions. The server side module is about setting, 

testing and administering your integrations.For more information go to System Architecture. 

2. System architecture 

Syntralink consists of two modules:  

• Input/Output (client side) – this module extracts and imports data from / to your 

applications. It “listens” to events (such as mouse clicks, file creation, etc.) and performs pre-

recorded or set-up actions. You need to install this module on every PC where events should 

be captured or actions performed. The PCs can be within a LAN, corporate intranet, VPN or 

connected over internet. For cloud / Web applications it should be installed on the user PC. 

For applications, accessed remotely (e.g. via terminals), it should be installed on the terminal 

server. The module consists of the Data Input/Output and User Actions Recorder/Performer 

functionalities;  

• Designer and Adminsitration (server side) – with this module you can set up, test and 

administer your integrations. It manages all Input/Output modules by receiving and sending 

requests to them. The module contains the Workflow Designer, Data Processing, Visual 

Process Modeling, Integration Wizard and Administration functionalities. Administration runs 

as a Windows service, so it can run on a separate physical machine from the Designer. 

3. Terms 

• Integration project – The integration and automation processes that are created by 

Syntralink are stored on the disk as integration projects. The integration project is a XML file 

that includes a description of the stages leading to the integration implementation: from 

adding applications for integration to the actual implementation of the integration process. 

The integration project includes one or several integration scripts. This makes the 
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organization of the processes easier and understandable for you. The projects are stored as 

XML files with .sntl extension and available for saving, copying, viewing, editing and carrying 

out repeatedly. A project created on a particular computer can be implemented on many 

others.  

• Integration script – The aggregation of all exchanged data and operations that have been 

carried out in a specific sequence of actions between two or more applications is called an 

‘integration script’ or just a ‘script’. Scripts are made to illustrate the integration process. 

They consist of the so-called 'elements'. Each script can be edited and implemented 

unlimited numbers of time. To be easier for you to organize the processes concerning the 

integration, one or several integration scripts are forming an ‘integration project’. It is 

necessary for each project to have a startup (main) script, which will be the one to start the 

project implementation. By using the tool Script the scripts can be embedded into one 

another allowing the user to control their prosecution in the project implementation.   

• Element – It is a system component that helps you to build integration scripts. Some 

examples of elements are the controls as well as other integration tools that are part of the 

system (encrypting/decrypting data tools, mathematical operations, etc.). An element can 

also be a script that is “put into” another script as its component. 

• Control (from the user interface) – It is a part of a particular application's user interface, 

which gives you the opportunity to import and export data. Some examples of controls are 

the buttons, text fields, drop down menus and other elements of the applications’ user 

interface. Data link - A link that shows the direction of data transfer from one element to 

another, i.e. where data to be extracted from and where to be saved in.  

• Process link –A link that defines which elements cause what kind of events and which are the 

next functions to be carried out. The process link defines the sequence of the integration 

script implementations.  

• Designer – It is a workspace located in the center of the screen. You can use it to create and 

configure integration scripts by adding and connecting elements with drag and drop.   

• Process connector – A place (node) that illustrates the beginning and the end of a process 

link between two elements. The process links can be created by using the left-mouse button 

to drag on the relevant process connector of the first running element to the connector of 

the element which has to be implemented next. 

• Property – An element characteristic that contains information about the element/tool. The 

static properties can be set from the Properties window such as an element title, a color, an 

event actuating execution, etc. There are also dynamic properties, i.e. receiving value during 

the project implementation such as text in a text box, check in a check box and others. The 

element/tool properties are available not only in the Properties window, but also as a list 

situated under its title when it is added in the Designer. Some properties can only present 
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the beginning of a link (output) , some just the end (input) , and others can be both 

(input and output)    

4. Creating an integration / automation  

The process of integration is a process of extracting information from the user interface of a 

particular product, then transforming it and loading it in another product’s user interface.  

The process of automation defines the process of performing a pre-recorded sequence of actions.  

With Syntralink you will be able to implement integration and automation processes of applications 

that are working on one or several computers, operated by one or more users. 

4.1. Summary 

To integrate or automate your applications, you have to go through the following series of steps: 

1. Creating a project: Similarly to how Microsoft Excel creates a new file when it is started, 

Syntralink creates a new integration project. The project represents a document formed as a 

XML file that includes a description of your integration or automation. When you carry out 

more than one integrations or automations, it is advisable to create and save separate 

projects.     

2. Creating a script:  If we use the example above, Microsoft Excel automatically creates a new 

file with empty Worksheets in it. Similarly, Syntralink creates a new project with an empty 

integration script. (If you need you can add more scripts) The scripts include a description of 

specific data and operations by which you can integrate your applications.  

3. Adding a Desktop / Web application: After you have started Syntralink, you need to add the 

applications that you would like to integrate or automate. Syntralink gives you the 

opportunity to integrate and automate desktop and Web-base applications.  

4. Selection of controls: The controls are components of your applications' user interface, 

where output data is extracted from or input data is loaded in (e.g. text fields, drop down 

menus, etc.) or by which specific operations (e.g. buttons) are actuated. For instance, to 

transfer an application data in another one by clicking the button Save, it is necessary to 

choose controls from the first application where from Syntralink will extract the output data,  

the controls from the second application where to load the extracted data as well as the 

button Save by clicking of which all the actions will be realized. The selection is realized by 

specifying a control by the so-called WindowFinder tool. When you select a specific control, 

it appears in the Designer as an element and you can carry out different operations ( e.g. 

input data, mouse click and others).  

5. Usage of embedded tools: In case the data transfer from one application to another, as in the 

example above, is not enough and you need to transform it before you add it in the second 
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application, you can use Syntralink's embedded tools. They represent data processing 

components as mathematical operations, encrypting data, recording in files, etc. To be easier 

for you they are positioned in a special Tool Box and can be used directly in the scripts. The 

tools are universal (general) and can be used in different situations just by changing their 

properties without having to write additional code. Also, they are visualized in the Designer 

as elements and you can use them to perform  various operations (summing up, recording 

files, etc.)    

6. Creating links between elements: You need to connect the elements (i.e. the chosen controls 

and tools) to be able to specify the sequence of implementing your integration. The links 

between the elements are two types – process links and data links. Connecting the elements 

with process links will specify the sequence of your script implementation, and the data links 

– the direction of data transfer between the applications' controls and tools.  

7. Recording actions: If the WindowFinder can not recognize some of the user interface's 

controls  in your active application or when you want to create automation, you can use the 

tool Recorder. It will help you to record a sequence of actions: mouse clicks, entering text 

and others. The recorded actions are saved as a script and can be implemented  separately or 

as a part of an integration project.  

8. Saving a project: Saving a created project allows you to: edit it on a later point of time,   

implement it repeatedly on one or more computers as well as control it by the Admin panel. 

When you save your project, Syntralink generates a file with .slp extension (Syntralink 

Project). It is a XML file and if you need, you can track its code  via different software.  

9. Project implementation: The integration or automation process is realized on one or more 

applications by the project implementation. The project can be carried out during the time it 

is being created (for test purposes) or after it is completed. After it is completed the project 

can be implemented on the local computer by the user who has created it. Another option is 

to be 'uploaded' on the server and carried out repeatedly on schedule that  is set by the 

admin of the module Project Administrating.  

4.2. Create a new project 

A project can be created by the following two types of actions: 

1) Choose File->New Project from the main menu 
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2) Choose New Project from the toolbar 

 

If you have projects that are completed and saved, it is possible to open them for further editing or 

implementing. To make it easier for you Syntralink saves the last projects that have been used as 

Recent Projects and they are available for further processing. 

4.2.1.  Open a project 

There are two ways to open an already created project for further editing or implementing : 

1)Choose File->Open from the main menu 

 

2) Choose Open from the toolbar 

 

Finally, load the project's path in the Open window. 
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4.2.2. Recent projects 

Syntralink saves the last five projects that have been used, so you can load them from the main menu 

File->Recent Projects.  

 

4.3. Create a new script 

Together with a new project Syntralink automatically creates a new script within the project. If it is 

necessary, you can create more scripts by some of the following actions:  

1) Choose Project -> Add Script from the main menu  

 

2)Choose Scripts -> Add Script from the Project Explorer's context menu  

 

 

3) Choose the embedded Script Wizard from the main menu Project -> Script Wizard… 
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4.4. Add applications in the project 

To integrate or automate one or more applications it is necessary to load them in the project. 

Syntralink makes the integration between different desktop and Web applications possible. The 

desktop applications has to run under OS Windows, and the Web one in Internet Explorer browser. 

For further information: System requirements.  

4.4.1. Add a desktop application 

To add desktop applications that you will use to configure integration scripts in the project,  you can 

use some of the following ways:  

1)Choose Project -> Add Application from the main menu  

 

2) Choose Applications -> Add Application from the Project Explorer's context menu 

 

  

After you chose Add Application, you can select a computer from the network on which the 

application is installed by the Select Computer window.  
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Finally, use the Open dialog box to load the desired application’s path. 

3) Choose Computers to select the computer where the application is installed  and then use its 

context menu to click on Add Application 

 

Load the application’s path from the Open window.  

4.4.2. Add a Web application 

You can add a Web application by using some of the following ways:  

1) Choose Project -> Add Web Application from the main menu 
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2) Choose Applications -> Add Web Application from the Project Explorer's context menu  

 

Next step is to load the Web application from a particular computer from the network by using the 

Select Computer dialog box that appears. 

 

Finally, add the desired application by the Add Web Application window. 

 

3) Choose  Add Web Application from the Computers window's context menu to select the 

computer where from you will add an application 
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This action will bring on a window with the same name - Add Web Application: 

 

Enter the web application’s URL and click OK to confirm.  

The confirmed  application will take place in the list of Applications positioned in the #Project 

Explorer. 

 

You can also load a Web application by the button, situated in the right side of the URL field.  

 

4.4.3. Select a computer from the local network 

The integrated applications can be installed on one or more computers that are working in a local 

network or remotely. Therefore, it is necessary for you to indicate  the  computers participating in 
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the project where each one of the applications to be started from . You also need to select a 

computer when you start the Recorder where all your mouse or  keyboard actions will be recorded.  

The computers that you will add in the project can be  LAN or VPN connected as well as by Internet. 

Find more information in System architecture. 

You can do the selection of a computer in the following ways: 

1) Choose Add Application or Add Web Application from the Project's drop down menu 

 

You can also choose Add Application or Add Web Application from Project Explorer's context menu 

 

 

This will bring on a Select Computer window: 
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To select a computer from the network click on Browse: 

 

This will bring on a list of all computers connected in the local network where from you can select 

and add some of them by clicking on the OK  button. 



 

 

Syntralink – User Manual  17 

 

 

2) You can also choose Add Computer from Computers' context menu in the Computers dialog box 

 

  Again, a list of all computers in the local network appears as a result of clicking on the 

Browse button. Adding a computer is the same as explained above. 

 

3) To create a connection to a new server, enter the computer name or IP address in the Add 

Computer window and then press OK to confirm. 
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4.5. Select user interface controls 

When you configure a script, you use only specific user interface application controls. This is 

necessary in order to enter or extract data (e.g. text reading or writing in a text box) from particularly 

chosen controls as well as to track any caused events (e.g. mouse click on a button of the 

application). All controls have to be available during the script modeling, i.e. you have to (pre)load 

them /(in advance) in the Application subgroup situated in the Project Explorer.        

To select application controls you should go through the following steps: 

1)  Select the application from the Applications folder in the Project Explorer  

2) Click the right mouse button on the application and choose Select Elements 

 

3) The WindowFinder dialog box appears. This is a tool for recognizing and selecting controls  from 

the integrated applications’ user interface. With the left mouse button you can drag the 

WindowFinder icon and drop it on the application’s control that you would like to select. 
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4) Now you can specify the name of the element  

 

and choose a Process Member from the drop-down menu.  
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5) Complete the process of control adding by clicking on the Add button. 

 

4.6. Using the embedded tools  

To be easier for you, all the actions that are carried out in the scripts are included in a specific 

Toolbox and can be used directly in the scripts without having to write additional program code. The 

tools are universal and their properties can be set up according to your requirements by using the 

Properties window.  

The embedded tools are situated in the bottom left corner of the screen. They are divided in six 

categories: Standard, IO, Data, Formatting, Control flow and Mathematical tools.  

 

The tools can be sorted by your request.  

You can add them in the script and connect them with the other elements by dragging them with the 

left mouse button into the Designer. 

4.7. Creating links between elements 

Building a script requires an interaction between the elements in the project. This can be done by 

creating two kinds of links between the application's elements: a data link and a process link. You can 

create them by dragging the mouse from one element to another. As a result you can see an arrow 

representing the connection between the elements.  

Data links are designed to transfer data from one element to another. You can create them by 

connecting the elements' properties. Some properties can present only the beginning of a link 



 

 

Syntralink – User Manual  21 

 

(output) , some just the end (input) , and others can be both (input and output)  . They are 

blue colored.   

Process links indicate the sequence of carrying out the script, or in other words, they define which 

element actuates what kind of event and which are the next functions to be carried out.  

You can create them by using the Process Connector  icons, situated in the upper left corner of each 

element. They are red colored and if there is an event causing the performance of an element, also 

called a Process Member,  it is displayed next to the arrow that represents the process link.  

 

 

An example:  

 

The example represents the usage of both links: a data link between the Calculator's text box and the 

Notepad's writing field, and a process link from the '=' button of the Calculator to the Notepad's 

writing field. The process link causes the data transfer as a result of a clicking on the '=' button. The 

data link realizes the data transfer (the figure/number that is entered in the Calculator) to the 

Notepad's text field. As a result of the script implementation, after clicking the '=' button, the 

figure/number that has been entered in the Calculator goes to the Notepad's text file. 
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4.8. Save a completed project 

To be able to edit or implement repeatedly any project that has already been completed, you have to 

save it. There are three possible ways to do this:  

1) Choose File->Save from the main menu  

The project will be saved in the current project’s default directory (if one has ever been saved before) 

with the same name and extension.  

 

2) Choose Save from the Toolbar  

 

3) Choose File->Save as from the main menu 

Using this option for saving your project will give you the opportunity to choose a new directory, 

name and extension for it.  
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All the information that is contained in a project will be saved as a XML file. Choosing the Save 

button from the menu or the toolbar brings on a Save dialog box. You can use it to choose the 

desired directory and enter the name of the project file. The saved file has a .slp extension.   

4.9. Execute a project  

The implementation of a completed project requires a startup script. 

To run a project you have to use the “Play” button in the toolbar or F5 keyboard button.  

Syntralink gives you the opportunity to run your projects not only manually, but also by an 

automatically set schedule for implementation: once or periodically. This can be done by the 

administrator from the Admin panel. 

4.10. Start-up script 

A start-up script is the first script that is implemented in a running project. If there are more scripts, 

you can define the order of their implementation by using the  Script tool. You can set any script as a 

start-up script by choosing the Set as Start Up Script option from its context menu in the Project 

Explorer. 

 

5. Syntralink's user interface  

Syntralink's interface is designed along the lines of/similar to some of the most popular software 

products for graphic design and development.  

1) Menu 

The system's menu is organized as a standard Windows design.  
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2)Toolbar 

 Under the menu bar are located buttons containing the most commonly used functions.  

 

3) Computers window  

The top left side of the screen is organized as a tree containing the names / IP addresses of the 

computers in the local network that are involved in your project.  

 

4)  window 

The toolbox is located in the bottom left corner of the screen. It contains tools that are divided into 

six categories: Standard, IO, Data, Formatting , Control Flow and Mathematical tools.  

 

5) Project Explorer window 

The top right side is organized as a tree structure similar to the Windows Explorer. It contains the 

elements of your project, which are divided into two groups: Applications and Scripts. 
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6) Properties window 

 This window contains information about each element's properties. It allows editing.  

 

7) Designer window 

The center of the screen is a workfield called a Designer. It is designed for modelling/configurating  . 

The Designer is organized in panels/tabs and each script is in a separate panel/tab.  
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5.1. Menu 

 

5.1.1. File 

It contains commands for creating a project, opening an existing project and leaving/exiting the 

program. 

  

→ Create a new project 

→ Open an exisRng project 

→ Save a project 

→ Save a project with the opportunity to choose a new directory name  

and extension. 
→ Access the last five projects that have been used/Recent projects  

→ Exit the program 

5.1.2. Edit 

Menu for editing the contents of an open project.  

 

 

→ Cut (copy and delete) a selected element 

→ Copy a selected element 

→ Put in place/Paste a cut or copied element 

→ Delete a selected element 

5.1.3. View 

It contains commands for controlling Syntralink's interface appearance and more particularly 

operates which windows to be displayed and which to be hidden.   

 

→ Show/Hide the Project Explorer  

→ Show/Hide Computers 

→ Show/Hide the Toolbox 

→ Show/Hide the ProperRes 

→ Show/Hide the Admin Panel 
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→ Show/Hide the Standard Toolbar 

→ Specify whether the Designer to take up the entire screen or not 

5.1.4. Design 

Menu for controlling the view of the Designer. 

 

 

→ AcRvate an automaRc tool alignment 

→ Add grid-lines to align 

→ Export the integraRon script as an image (.jpg /.gif /.png) 

5.1.5. Project 

It contains commands for modeling the integration scripts. There is also a command for additional 

project information.  

 

 

→ Start the Script Wizard 

→ Give the opportunity to add a desktop application 

→ Give the opportunity to add a Web application 

→ Create a New Script with a serial number 

→ Give addiRonal project informaRon 

5.1.6. Tools 

It contains commands for starting the Recorder and for additional settings. 

 

 

→ Starts the Recorder 

→ AddiRonal seSngs for the grid-lines and opportunity to return to 

the default settings 

5.1.7. Window 

Menu for organizing, displaying and hiding the main windows. 

 

→ Close all open scripts and other windows 
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→ Reset/Arrange all the windows by default 

→ Give the opportunity to open and close scripts and other windows 

5.2. Toolbar 

 

 

New Project → Create a new project 

Open → Open a project 

Save → Save a project 

Cut →  Cut (copy and delete) a selected element 

Copy → Copy a selected element 

Paste → Put in place/Paste a cut or copied element 

Delete → Delete a selected element 

  

Find → Search for words in the script that you have entered in the white box 

above the button   

Snap-To-Grid → AcRvate an automaRc tool alignment  

Show Grid → Add grid-lines to align  

Run → Implement the project 

5.3. Computers 

This window contains a list of names / IP addresses of all computers from the local network that you 

use in your project. As you already know, the integration scripts can contain applications, can be 

configured, edited and controlled by one or more computers that are working in the local network or 

remotely. The computers  participating in the project can be connected with a LAN / VPN or Internet 

connection. For more information go to System architecture.   

 The main properties of Computers are the following: 
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5.3.1. Adding a new computer 

Choose Add Computer from the context menu  

 

You can add a computer directly in the list by entering its name or IP address in the writing field. 

After that click OK to confirm. 

 

You are also able to browse a list of all computers in the local network by the Browse button. This 

will open a new window: Computers found in local area network.   

 

If you would like to add a computer from this list in the project, you need to select it  and click OK to 

confirm.  

This will create a connection with the new computer and it will be added at the bottom of the 

Computers list.  

5.3.2. Updating the contents of the list  

You can update the contents of the Computers list by choosing Refresh All from the context menu. 
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5.3.3. Adding an application from a computer  

You have the opportunity to add a desktop or Web application that works on a particular computer. 

To do so use the right mouse button to click on the computer and choose Add Application or Add 

Web Application from its context menu.  

5.3.4. Updating the selected computer 

 

     Choose Refresh from the selected computer's context menu.  

 

5.3.5. Removing a selected computer from the list  

Select the computer that you would like to remove from the list and choose Delete from its context 

menu.  
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 This action will open a warning window for permanently deleting the selected item. Click OK 

to confirm the removal.  

 

5.4. Toolbox 

In the scripts you are allowed to add not only applications, but also embedded in the program tools. 

They are divided into six categories: Standard, IO, Data, Formatting, Control flow and Mathematical 

tools.  

 

The tools can be sorted according to your preference.  

You can add them in the script by dragging them with the left mouse button in the Designer. Connect 

them with the rest of the elements with data and process links. . 

5.4.1. Standard tools  

 
→ Constant 

 
→ Array 

 
→ Delay 
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→ Script 

 
→ C# code 

5.4.2. Input / Output tools 

 
→ File Reader 

 
→ File Writer 

 
→ File System Watcher 

 
→ Key Press 

 
→ Mouse Click 

 
→ Call Web Service 

 
→ E-mail Sender 

 
→ Message Queue 

 
→ Clipboard 

5.4.3. Data tools 

 
→ Data Converter 

 
→ Data Normalizer 

 
→ Data Sort 

 
→ Data Validator 

 
→ XML Node 

 
→ Encrypt 

 
→ Decrypt  

5.4.4. Formatting tools  

 
→ String to Number 

 
→ Format 

 
→ String Splitter 

 
→ String Concatination  
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→ Template 

 
→ CSV Reader 

5.4.5. Control flow tools 

 
→ IF logical operator 

 
→ Cycle operator FOR  

 → Raise Error 

 → Error Handler 

5.4.6. Mathematical tools 

 
→ Sum 

 
→ Subtract 

 
→ Multiply 

 
→ Divide 

 
→ Pow 

 

Each tool is described in detail below. 

5.4.6.1. Constant tool 

It gives you the opportunity to set value to elements that you add in the script. The value may be a 

symbol or a string of symbols, e.g. a number, text, special symbol or other.  Together with the other 

options that are available from the context menu (e.g. renaming, changing the color, etc.), the 

constant tool has a specific feature – encryption. This is how you can use the system to automatically 

enter passwords while the data security remains protected.   

 

 

→ Enter the value of the constant / a number, symbol or string/  

→ By extracRng the tool value, the property resets the constant* 

*If you extract the value of the constant by the Cleared Value  property, after using the tool  even if 

the value has been changed at a runtime, the constant will be reset to its originally entered value.    

Specific properties:  

You can set a value of the constant and choose True or False (from the drop down menu) to store the 

encrypted constant value /Store Encrypted/ from Properties.  
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5.4.6.2. Array tool 

This tool helps you to create an array by sequentially entering its elements. If you need you can use 

the data by extracting it from the array.  The array tool will be helpful for you, because some of the 

other tools require their input or output data to be an array type: for example the list of method 

parameters in the Call Web Service tool.  

 

 

→ Submit input elements/items to store them in the array 

→ Elements/items that are extracted from the array 

5.4.6.3. Delay tool 

Using this tool to delay the operation that is about to be performed next, i.e. not immediately but 

after a certain time interval. You need to use the Delay tool when the application-recipient needs 

some time to process the supplied information and to move on to the next step from the script.  

 

 

→ Enter the delay Rme in milliseconds (1ms=0,001s) 

Specific properties:  

You can enter the delay time manually from Properties → Delay Time where you will have to set it in 

a specific time format: HH:MM:SS (H-hour, M-minute, S-second).  

 

5.4.6.4. Script tool  

It allows main and subordinate script configuration. This is how the tool will help  you to define the 

sequence of script implementation in the project.   

 

Specific properties:  
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Choose Script Name from Properties to indicate the script that you would like to apply the tool on .  

 

5.4.6.5. C# code 

With this tool you can enter the program code, written in C#.  

 

 

→ Submit input data that is used in the expression  

→ A result from the tool implementaRon  

Specific properties: 

 In the Expression field of Properties enter C# 's expression.  

 

 

→ Enter C# 's expression  

5.4.6.6. FileReader tool  

This tool allows you to extract the contents of a text file as a symbol string. The formats supported by 

the FileReader are .txt and .doc. The text in the file has not to be formatted  and contain tables, 

images, diagrams, etc.   

 

 

→ Get the contents of the read file 

→ Enter the full file's path that the tool is about to read * 

 

Specific properties: 

Load the file's path by clicking the | ... | button in the FilePath property.  
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5.4.6.7. FileWriter tool 

Gives you the opportunity to create a file and fill its contents with text which is not formatted and 

doesn't include images, tables, etc. The file is saved with a name and extension you have entered in 

the directory that you have specified. The formats supported by the FileWriter are .txt and .doc.    

  

→ Fill the contents of the file 

→ Enter a name of the folder where the file will be saved  

→ Enter a file name 

Specific properties: 

 

 

 
→ A Directory where to save the file  

→ A file name / an empty file 

5.4.6.8. FileSystemWatcher tool 

With this tool you will be able to see if a new file has been created in the directory entered by you. If 

this has happened, the tool would cause another element's implementation. You are allowed to track  

a file with a specified name that has been created. You can also track the creating of a file according 

to a particular part of its name or extension (.txt, .exe, .jpg, etc.) by using a filter.  

 

 

→ Specify a full path to the directory where you will watch for newly created files  

→ Enter a file name 

→ The tool causes an event when a file has been created 

Specific propeties:  

 

 

 
→ A file name filter 

→ You can manually choose the path via the Open File window 

 

5.4.6.9. KeyPress tool 

Using this tool will give you the opportunity to simulate a keyboard button click as well as a keyboard 

shortcut. To be able to enter a sequence of letters, figures, symbols or other buttons by this tool, it is 

necessary each of them to be in a separate KeyPress tool and a button to be chosen from its 

properties. Also, the tools have to be sequentially connected by a process link.  
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Specific properties:  

  

 
→ Enter a computer name 

→ Manually enter a buWon name 

→ Create a keyboard shortcut 

 
→ Choose a buWon from the drop down menu 

 

5.4.6.10. MouseClick tool 

By using this tool you will be able to simulate a mouse click: left, right or middle with a 

predetermined point. In X and Y properties you need to write the point's coordinates that indicates 

where the cursor to be located while clicking. These are the relative coordinates according to the 

upper left corner of the screen. That's why the maximizing/minimizing, changing the format of the 

screen and so on does not change the coordinates defined by you.   

 

Specific properties:  

 

 

 
→ Enter a computer name 

→ Choose a mouse buWon via the drop down menu 

 

 

 

 

→ Manually enter the cursor coordinate values  

 

5.4.6.11. CallWebService tool  

This is a tool that lets you use (consume) Web services. To extract information you only need to know 

the Web service's address and the names of the methods that are used by the service. You also need 

to set the methods' parameters in advance.  
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→ Enter the method's parameters in a text format* 

→ Receive a result of the method implementaRon 

→ A method name 

→ The method's parameters in a standard (unconverted) format  

Specific properties:  

*You can manually enter the parameters as an array of strings from the element's Properties by 

clicking the | ... | button in the Method String Params property.   

 

 

→ Enter the URL of the web service 

→ The text formaWed method's parameters can be manually 

entered in an array of strings  

5.4.6.12. E-mailSender tool  

With this tool you can send e-mail messages containing a subject, text contents and attached files as 

images, documents and others. Except  the usual needed information that the tool requires for a 

successful delivery (the sender and receiver addresses, a subject, a text message and a path to the 

attached file), it also requires the server address of the e-mail,  the SMTP port for sending as well as a 

valid user name and password.   

 

Enter:  

→ Sender address 

→ Receiver address 

→ Message subject 

→ Message body 

→ A list of the aWached files* 

→ Add aWachment property 

→ Address of outgoing (SMTP) mail server 

→ Port of outgoing (SMTP) mail server 

→ Your user name 

→ Your password 

Specific properties:  
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*You can also attach files by loading their paths from Properties clicking the | ... | button in the 

Attachments property.  

 

5.4.6.13. MessageQueue tool 

The tool is used to send messages to a particular message queue. You can fill the message body as 

well as to define where the message to be sent by entering a path and name of the computer.  

 

 

→ Write the message you would like to send  

→ Choose the path where the message to be sent  

→ Enter a computer name 

5.4.6.14. Clipboard tool  

Depending on the property you choose in the Value of the Clipboard – input or output, the tool 

returns or puts data in the clipboard. 

 

 

→ Value of the clipboard 

5.4.6.15. DataConverter tool  

This tool gives you a variety of opportunities for transformation. You can use it to transform a 

particular symbol in another, e.g. '1' in 'yes', '0' in 'no', a table array in another one via shifted 

columns, etc. 

 

 

→ Symbol or string value, which will be matched 

→ Output symbol or string, which will correspond to the input one 

→ Path to the mapping file (it should be a CSV file) 

→ Index of the field (column), where input data is looked up 

→ Index of the field (column), from where output data is derived 

→ Mapping table of the current element 

Specific properties: 
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You can enter the path to the mapping file by going to Properties and clicking the | ... | button of the 

CsvFilePath property. In the CsvFieldSeparator property you can enter the field (column) separator in 

the mapping table (e.g. comma „,”, semi colon „;”, tab „,”, space or another). 

 

 

→ Enter field (column) separator in the mapping table. By 

default, the separator symbol is period / full stop „.” 

→ Enter the path to the mapping file. 

5.4.6.16. DataNormalizer tool  

The tool allows you to remove spaces/intervals (in a text) or leading zeros (in a number) from a string 

(or a sequence of symbols). By using the tool you can normalize the data according to your needs.  

 

 

→ Select an input text that you would like to be edited 

→ Receive an output text with removed spaces and leading zeros 

5.4.6.17. DataSort tool 

This tool gives you the opportunity to sort data in ascending or descending order. It can only be used 

on table or file data. You can sort data in each column. To select the column you wish to sort, you 

need to enter its name.  

 

 

→ Select the table that is about to be sorted 

→ Receive the sorted table 

→ Column name where the sorRng will be carried out  

5.4.6.18. DataValidator tool  

This autonomous element gives you the opportunity to validate (check the accuracy of) data by 

comparing it with a specified criterion, e.g. if an e-mail is correctly entered (aaa@bbb.ccc), if the 

price value has two digits after the decimal separator and so on. You can specify the criteria yourself 

using the so-called 'Regex' – regular expressions. 

 

 

→ Input data that is about to be validated 

→ Returns True/False depending on the data accuracy 

→ Regular expression for checking the data accuracy 
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5.4.6.19. XMLnode tool  

With this tool you can extract the contents of a node in an XML file. The search of a node is done by 

the XPath expression and the tool returns the XML text from the node, the contents of the input 

node (if any) and the node's index. When the node is found or the search is over, the XMLnode tool 

causes an event. 

 

 

→ Enter formatted XML text 

→ Write a XPath expression 

→ Receive a value of the specified node as well as: 

      → The input XML text 

      → The input node surrounded by the current node tags 

→ An event that is caused when the node is found  

→ An event that is caused when the search is over  

→ Returns the index of a particular node if there are many 

5.4.6.20. Encrypt tool 

This tool gives you the opportunity to encrypt data when you need it for security purposes. In 

contrast to the Constant tool, here data is being encrypted only when it is processed by the tool. To 

be able to encrypt your data you need to use a service key that is set in the system.  

 

 

→ Enter the text that you would like to encrypt 

→ Receive an encrypted text 

5.4.6.21. Decrypt tool  

This is the tool by which you will be able to decrypt your data that has already been encrypted by the 

Encrypt tool. The data takes its normal/usual appearance after you process it with this tool.  

 

 

→ Submit text that is to be decrypted by the tool 

→ Receive a decrypted text 

5.4.6.22. StringToNumber tool 

With this tool you are able to convert a string to a decimal number. You will need this tool when 

another tool requires numbers for input data (e.g. Mathematical tool) and the extracted data are 

usually strings. 
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→ Enter the string that you would like to convert  

→ Receive a decimal number 

Specific properties:  

You can enter a separator for the whole and the fractional part of the received number. This can be 

done from Decimal Separator in Properties. The separator is defined as a period/full stop by default.   

 

5.4.6.23. Format tool  

You can use this tool to format strings by replacing the formatting string markers with elements 

submitted by the tool. The tool is following the .NET convention for formatting strings.  

→ An element that will replace the marker in a formaSng string 

→ Submit the list of elements that will replace the markers in the 

formatting string 

→ Receive a result from the formaSng   

5.4.6.24. StringSplitter Tool  

You can use this tool to split a text into substrings. You can do this by entering a text and defining a 

delimiter by which the “cutting” will be done. If you enter a space/interval delimiter, you will split the 

text into words, if you enter a full stop, you will receive sentences and so on. As a result of the tool 

implementation you receive an array which elements are the newly received substrings.  

 

 

→ Input text that you would like to split  

→ Output strings received from the spliSng  

→ Define delimiter (e.g space, full stop, comma or other symbol)*  

→ Accepts true/false for removing empty strings  

Specific properties:  

You can manually enter the delimiters by clicking the | ... | button in Delimiters from Properties, and 

choose the True/False values from the drop down menu of RemoveEmptyEntries property.   

 
 

→ Add delimiters  
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→ Choose True/False from the drop down menu 

 

5.4.6.25. StringConcat Tool  

With this tool you will be able to join two character strings, i.e. to concatenate two input strings 

(sequence of symbols). The concatenation is done by saving the first string contents in the last one 

and joining the contents of both strings.  

 

 

→ Submit the first string 

→ Add the second string 

→  Receive a string that is formed as a result of joining the first and the 

second string 

5.4.6.26. Template tool  

With the Template tool you can replace the values of the template fields with values that are set by 

you.   

 

 

→ Enter input values to replace the template fields values 

→   Receive a template that is to be replaced with the input values after the 

tool implementation 

5.4.6.27. CSVReader tool  

This tool helps you to extract information from CSV text, which contents represents an electronic 

table that is formatted as a text. Each table row is a new row in the file, the cells are separated by 

commas, and the information that is stored in the cells is surrounded with quotes (by default). To set 

up the tool you should:  

 

 

→ Enter the CVS text where you will extract informaRon from  

→ Extracts text from the current cell 

→ Checks if you have reached the last cell in the “table”  

Specific properties: 

 

 
→ Character indicating a comment. By default: # 

→ Delimiter character between the table cells (comma) 
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→Character allowing quotes to be used as an ordinary symbol (/) 

→ Presence/Absence of a row with column titles in the table. 

 
→ A symbol enclosing the contents of all cells (quotes) 

→ Settings for table cells that are not to be processing 

     → None 

     → Only the ones that are not surrounded with quotes 

     → Only the ones surrounded with quotes 

     → All 

5.4.6.28. If tool  

With this tool, as you probably already know from using MS Excel, you can do a logical condition 

checking. The tool causes a particular event when the input data condition is true and another event 

when the condition is false.    

 

 

→ Input data that you will check with the condiRon * 

→ Receive an event caused when the condition is true 

→ Receive an event caused when the condiRon is false 

Specific properties: 

You need to enter the condition for data checking in the Condition window from Properties.  

 

5.4.6.29. For tool  

With this tool you will be able to repeatedly carry out the same action if you know in advance the 

number of repetitions that you will need. The tool can call and execute another element on every 

turn or exit from the cycle. 

 

 

→ Event caused by every cycle “turning” 

→ Event caused by exiting the cycle 

→ Enter an iniRal value* 

→ Fill in a value of the cycle ending 

→ Current value of the cycle counter 

Specific properties: 
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The initial value and the cycle ending value can be entered manually in the From and To fields in 

Properties. 

 

 

→ IniRal value 

→ Cycle ending value 

5.4.6.30. RaiseError tool  

With this tool you can receive a notification for an error occurrence. You can identify the error 

because after implementing the tool you will be able to find the number and the description of the 

error in Properties. This functionality of the tool  concurs with the possibilities of the ErrorHandler 

tool.  

 

Specific properties: 

 

 

→ Occurred error code  

→ Error descripRon 

5.4.6.31. ErrorHandler tool  

If an error occurs during the integration project implementation, you will need to find the reasons for 

its occurrence, i.e. you need information to be able to remove the error and proceed the 

implementation process. In this case you can use the ErrorHandler tool, which contains information 

for: the error code as well as an understandable description.  

 

 

→ Receive the occurred error number/code  

→ Returns a string with a message describing the occurred error  

5.4.6.32. Sum tool 

With this tool you are able to find the sum of two numbers that you have entered.  

 

→ Enter the first addend 

→ Enter the second addend  
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→ Result: the sum of the both addends (OperandA+OperandB) 

5.4.6.33. Subtract tool  

The tool finds the subtraction between the first and the second number that you have entered.  

 

 

→ Enter a minuend  

→ Enter a subtrahend  

→ Result : their subtracRon (OperandA-OperandB) 

5.4.6.34. Multiply tool 

This tool helps you to multiply two numbers. As a result the tool returns you their product.  

 

 

→ Enter the factor  A 

→ Enter the factor B 

→ Result: their product (OperandA*OperandB) 

 

5.4.6.35. Divide tool 

This tool divides the first number by the second one that you have entered as long as it it is different 

form 0. The tool gives you the quotient of both numbers.  

 

 

→ Enter dividend 

→ Enter divisor that is different from 0 

→ Result: a quoRent (OperandA/OperandB) 

 

5.4.6.36. Pow tool 

With this tool you can raise a number to power specified by you.  

 

 

→ Enter a number 

→ Enter power 
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→ Received result (Operand^Power) 

5.5. Project Explorer 

The Project Explorer has a tree structure resembling the Windows Explorer. It contains a subgroup 

called Applications where all the integrated applications that you have added are visualized, and a 

Scripts subgroup including all the scripts that you have created.   

5.5.1. Adding desktop and Web applications  

You can add applications by choosing Add Application or Add Web Application from the 

Applications context menu.   

 

This will open the Select Computer dialog box where you will be able to choose a computer from the 

local network. Choosing Add Application will allow you to load the desktop application’s path and 

add it in the project from the Open dialog box by clicking the Open button in the bottom right 

corner. 

Choosing Select Computer from the Add Web Application option will cause the opening of a window 

where you will be able to enter the Web application’s URL. The process of adding applications will be 

completed when you click OK to confirm.  

As a result, the applications that you have added are visualized in the Project Explorer’s Applications 

group and you can use them in the integration scripts as well as edit their properties or remove 

them.  

5.5.2. Creating new scripts 

To create a new integration script you have to choose Add Script from the Scripts context menu.  

 

 The new script is added in the bottom of the scripts list as a New Script.  



 

 

Syntralink – User Manual  48 

 

5.5.3. Operating with the desktop applications in the Project Explorer   

 

 

 

→ Add a form to group the applicaRon's controls*  

→ Load the WindowFinder tool to select the elements 

→ Open the selected application 

→ Delete the selected applicaRon** 

→ Rename the selected applicaRon 

→ Open the applicaRon’s Properties window 

*Due to the form you are able to group the controls of the application by your request, which will 

make it easier for you to create and edit the integration script.  

**If you try to delete an application when even one of its controls is already being used in some of 

the  integration scripts, the following warning message will pop up and the deleting process will not 

be possible: 

 

5.5.4. Operating with the Web applications in the Project Explorer  

 

 

 

→ Add a form to group the applicaRon's controls*  

→ Load the WindowFinder tool to select the elements 

→ Open the selected applicaRon 

→ Delete the selected applicaRon** 

→ Rename the selected applicaRon 

→ Open the applicaRon’s Properties window 
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5.5.5. Editing a script  

 

 

 

→ Set the selected script as a Startup script  

→ Open the script in the Designer  

→  Delete the selected script 

→  Rename the selected script 

→ Open the script’s Properties window 

5.6. WindowFinder 

Use the WindowFinder tool to recognize and select controls from the applications’ user interface 

that you have already loaded. Choosing the WindowFinder will automatically start a special 

WindowFinder dialog box together with the specific application where from you will be able to add 

the controls that you will need for proceeding the integration process. 

 

Click the left mouse button on the WindowFinder icon that is positioned in the upper left part of the 

WinwodFinder dialog box and drag it to the application’s control that you would like to select. Any 

control that is recognized by the WindowFinder icon will be enclosed with a red frame.  

Dropping the WindowFinder icon on  a specific control realizes the selection. Syntralink automatically 

fills in the control’s name and adds it in the Control drop down menu. You are allowed to select 

unlimited number of controls from any application.   
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If you would like to delete some of the controls that have been already selected, you have to choose 

the control name from the drop down menu and click the Remove button.  

  

You can enter a new control name 
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or choose a Process Member from the drop down menu. 

 

By the check button you can specify whether the controls to be included in a new script. 

 

You can also use the second check button to connect the elements with a process link   following the 

order of their position in the drop down list. 
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The process of adding controls will be completed when you click the Add button.  

 

5.7. Script Wizard 

To be able to use the ScriptWizard you will need to go through the following steps:  

1) Specify the script name which you would like to create by the ScriptWizard  
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2) Add the applications that you would like to integrate by successive clicking on the following 

buttons: Add Application and Add Web Application  

 

You can rename the applications that you have added by the Rename button. 
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or delete them by the Remove button and click OK in the warning message window that appears. 

 

3) Select controls from the loaded applications. 
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Choose the application’s name, where from you will do the selection, from the drop down list and 

click the Select Controls button.  This will open a WindowFinder dialog box by which you will be able 

to select all the needed controls.    

 

Again, you are able to rename the controls by clicking the Rename button. 
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You can delete the controls that you don’t need by selecting them in the list with the left mouse 

button and then clicking the Remove button. This will open a window with a warning message 

related to the deleting process. Click OK to confirm.  
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4) Create links between the added controls. 

You have to enter all the links in a table of 3 columns. You are now allowed to write in the first 

column and you can use it for selection of rows in the table. In the second column /From:/ you can 

choose the control that will be starting for the created link  

 

In the third one that is titled as /To:/ you can select the control that the created link will be directed 

to. 
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Two controls situated on the same row of the table create a data link between them. 

 

Two controls situated in the same column (below each other) create a process link. 
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You are allowed to change the places of  the links between the elements by selecting the row with a 

mouse click on the leftmost column(if the row is successfully selected, the symbol in this column 

appears as an arrow). Then click the Move Up button to move the row above.  
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Respectively, choose the Move Down button to replace the links below.  

This rotations cause a modification in the script implementation, because they change the direction 

of the process link between the both rows (as it was already explained, the process links can be 

created between two controls situated in the same column – below each other).   

 

To delete a created link you have to select the row where it is described and choose the Remove 

Selected button. This time there is no warning message that appears and the removal is immediately 

realized.  
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5)Complete the script creating by clicking the Finish button. The new script is visualized in the Project 

Explorer. There you will be able to view, edit and implement it. 
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The following buttons are available in the bottom part of the ScriptWizard window while you are 

using it:  

1) Previous button – returns to the previous step. Gives you the chance to load additional 

applications, select new controls or remove the unnecessary ones. 

 

2) Next button – you can move to the next step or reach the final step of the ScriptWizard.  

 

3) Cancel button – you can cancel the ScriptWizard, i.e. you are able to stop the script creating 

 

5.8. Recorder 

The Recorder can help you when the WindowFinder can't recognize a specific application control 

(e.g. image, flash, Silverlight, etc.). During the recording process  all your actions as a mouse click, key 

press or a keyboard shortcut will be recorded in the same order as they have been carried out. You 

can convert a record in a script by using the embedded MouseClick and KeyPress tools. In the 

MouseClick tool's X and Y properties you need to write the relative point's coordinates where the 

cursor to be located during the time of clicking according to the upper left corner of the screen. As a 

result,  the maximizing/minimizing, changing the format of the screen or replacing the user menu 

according to the different users' rights may cause inaccurate record implementation. 

 The Recorder doesn't record/recognize: double clicking, scrolling and mouse selecting. This is why it 

is advisable to work  mostly with the keyboard buttons and shortcuts.  

To be able to start the Recorder, you need to add  all the necessary desktop and Web applications  in 

the project. Choose Tools → Start Recorder from the main menu Tools.  

 

This will bring on a Select Computer window:   
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After having a selected computer where the recorder will run from, all the applications  in the project 

are being loaded and a control recording panel appears. It includes the following buttons:  

 
→ Start recording buWon 

 
→  Pause recording buWon 

 
→ Stop recording buWon 

When the recording is finished, a new script is automatically created and you are able to view, 

rename, edit and repeatedly implement it.  

5.9. Properties 

This window gives you information about the properties of each element and allows you to edit 

them. Most of the embedded tools have special individual properties that are explained in their 

detailed description above, but each of them has some main properties in common:  

 

→ BuWons to sort the properRes in the list   

 

→ An element color in the Designer 

→ An element comment 

→ An element name 

→ An event causing the element’s implementaRon 
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5.10. Designer 

The Designer is a workspace where you can create and configure integration scripts by adding and 

connecting elements. The Designer is organized in tabs for each script. 

 

The Designer’s functionalities include:  

5.10.1. Adding elements from the Project Explorer 

You can drag the elements in the Designer with the left mouse button.  

All the elements of a particular application are the same color by default. You can change their color 

from Properties.    

5.10.2. Adding tools from the Toolbox 

Again, you can add them by dragging with the mouse. All the tools are colored in bright yellow. 

5.10.3. Creating links between elements and tools  

To configure a script you have to connect the elements in the Designer. You can create links between 

them by dragging the mouse from one element to another. As a result, you will see an arrow 

connecting them. There are two types of links: data and process links.  

Data links are designed to transfer data from one element to another. You can create them by 

connecting the elements' properties. Some properties can present only the beginning of a link 

(output) , some just the end (input) , and others can be both (input and output). 
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 Process links indicate the sequence of carrying out the script. You can create them by using 

the Process Connector  icons, situated in the upper left corner of each element. They are red colored 

and if there is an event causing the performance of an element, also called a Process Member, it is 

displayed next to the arrow that represents the process link. 

 

5.10.4. Searching for a text in the controls and elements names 

To be able to search for a text in the controls and the elements, click the Find button in the Toolbar 

after you have entered the word you would like to find in the writing field positioned next to the 

button. 

 

5.10.5. Exporting the integration script as an image 

Exporting the script as an image will give you the opportunity to view and print it. Choose Export as 

Image from the main menu  Design. The image can be saved as .jpg, .gif or .png.  

 

5.10.6. Adding gridlines to align the elements 

Choose Show Grid from: 

• the Toolbar 

 

• the main menu Design 
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5.10.7. Automatically align the elements /Snap-to-Grid/ 

Choose Snap-to-Grid from 

• the Toolbar 

 

• the main menu  

 

5.10.8. Add / delete/ copy / cut / paste elements 

5.10.8.1. Adding elements in the Designer   

You can add elements in the Designer by dragging the controls with the mouse from the Applications 

subgroup in the  or from the Toolbox in the open script.  

5.10.8.2. Deleting elements added in the Designer 

To delete an element that has been added in the Designer, go through some of the following actions:  

1) Choose Delete from the context menu 

 

2) click the Delete button positioned in the Toolbar  
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3) click the Del keyboard button 

 This will bring on the following warning message window concerning the element removal:   

 

 Click OK to confirm.  

5.10.8.3. Copying an element in the Designer  

You can copy an element in the Designer in three different ways:  

1) Choose Copy from its context menu 

 

2)Click the Copy button positioned in the   

 

3) Use the keyboard shortcut Ctrl + C 

5.10.8.4. Cutting an element in the Designer 

1) Choose Cut from its context menu 

 

2) Click the Cut button in the Toolbar  
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3) Use the keyboard shortcut Ctrl + X  

5.10.8.5. Pasting a copied or cut element in the Designer 

1) Click the Paste button in the Toolbar  

 

2) Use the keyboard shortcut Ctrl + V 

5.10.9. Startup element   

If you’d like a particular element from the integration script to run automatically when the script is 

started – without having any event to be caused – you can set it as a startup element. To do this, 

choose Set as Startup Element from its context menu.  

 

5.10.10. Windows 

To be able to control the windows in the Designer, choose  Window  Windows…from the main 

menu Windows. 

 

It includes the following functionalities:  

1) It helps you to indicate the windows (scripts) that you'd like to be active  

Select the name of the script that you would like to activate and click the Activate button. 



 

 

Syntralink – User Manual  69 

 

 

2) Allows you to close one or more open windows  

Select the window that you would like to close with the left mouse button. If you want to close more 

windows, drag the mouse or hold the Ctrl keyboard button, while you are clicking on each of them. 

Then click the Close Window(s) button. 

 

6. Project administration 

In the Admin panel you can carry out the main projects' managing and monitoring functions as well 

as administrating the system as a whole. If you are authorized you can implement one or more 

scripts in real time and set a schedule for the projects' implementation: just once in a specific 

moment or periodically (every day, week, month).  
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Enter the Admin panel from the main menu – View  Admin Panel.  

 

As a result, the system brings on a Login window where you have to enter your user name and 

password. There are two types of users: users with full administrator rights and users with limited 

rights.  

 

You will be allowed to enter the Admin panel after your user name and password are accepted by 

the system. The Admin panel is divided in two parts: left and right. On the left part you can see a list 

of all integration scripts. Whether the project is being implemented at the moment or is temporary 

stopped can be easily recognized from the font of the project's name – only the names of the 

projects that are being implemented in the moment are bold.  . 

 

To be able to operate with the projects in the list you need to select their names and use the control 

implementation buttons situated under the list of projects.  
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The buttons have the following functionalities:  

 
→ A buWon for adding a project in the list /Add/ 

 
→ A buWon for starRng a project in real Rme /Play/ 

 
→ A buWon  for pausing a project’s implementaRon /Pause/ 

 
→ A buWon for stopping a project’s implementaRon /Stop/ 

 
→ A button refreshing the project’s implementation /Retry/ 

 

→ A button for appointing the project's implementation for  a predetermined  

moment  /Task Scheduler/ 

 

→ A panel for setting the implementation time.  

You can select the element from the relevant date or hour and change it by the 

up/down arrows.  

The right side of the panel contains information about the projects: script name, schedule time, XML 

code, script status and ID number.  

 

7. System requirements 

OS: Windows XP / Vista / 7 / Server 2003 / Server 2008; Unicode and localized Windows versions; 

Applications:  32-bit and 64-bit applications; 

Language:  Different languages available;  

Browsers: Internet Explorer. 


