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1 Introducing EssentialPIM Free

Welcome to EssentialPIM Free Edition!

EssentialPIM Free is an absolutely free personal information manager that can store,
manage and encrypt data: day/week/month/year schedules, to do lists for keeping all
your appointments up-to-date, notes (pictures, tables, any formatted text), password
entries, fully-functional mail module and contacts. Offers AES 128-bit encryption, MS
Outlook import/export, search capabilities, versatile print features and adjustable
contacts storage with unlimited number of fields.

Thought out simplicity is the power - our motto. Enjoy.

2 Features

EssentialPIM Free is a full-featured personal information manager, which offers:

Excellent usability. Shortcuts that are fun to use and boost your productivity.
Easy, intuitive tools arranged right where you need them
Security. All data can be password-protected and the database file is encrypted
with the advanced industry standard AES (Rijndael), 256-bit key
Versatile import and export capabilities. You can import and export HTML, RTF,
CSV, TXT and TreePad. You can perform import/export with Microsoft Outlook; and
you can import from Outlook Express
Synchronization with Android and iPhone/iPad
Available in many languages: Bulgarian, Chinese (simplified), Czech, English, French,
German, Hellenic, Hungarian, Indonesian, Italian, Japanese, Norwegian, Polish,
Portuguese, Russian, Slovak, Spanish, etc.
System tray icon with a hotkey for starting and configuring the software
Open-source Firebird database. Advanced users and system administrators get
great flexibility in managing databases

3 License

EssentialPIM(tm) License Agreement.

EssentialPIM is FREEWARE.

Astonsoft Ltd. EssentialPIM VERSION 4 END-USER LICENSE AGREEMENT

IMPORTANT-READ CAREFULLY: This EssentialPIM End-User License Agreement ("EULA")
is a legal agreement between you (either an individual or a single entity) and Astonsoft
Ltd. for the EssentialPIM SOFTWARE(s) identified above, which includes the User's
Guide, any associated SOFTWARE components, any media, any printed materials other
than the User's Guide, and any "online" or electronic documentation ("SOFTWARE"). By
installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the
terms of this EULA. If you do not agree to the terms of this EULA, do not install or use
the SOFTWARE. If the SOFTWARE was mailed to you, return the media envelope,
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UNOPENED, along with the rest of the package to the location where you obtained it
within 30 days from purchase.

1. The SOFTWARE is licensed, not sold.

2. GRANT OF LICENSE.

(a) Freeware.  You may use the SOFTWARE without charge. Astonsoft Ltd. may place
announces of its other PIM-related products into EssentialPIM. Astonsoft Ltd. will not
monitor the content of your use (e.g., sites selected or files used).  
(b) Redistribution of EssentialPIM. You may make copies of the evaluation SOFTWARE
as you wish; give exact copies of the original SOFTWARE to anyone; and distribute the
SOFTWARE in its unmodified form via electronic means (Internet, BBS's, Shareware
distribution libraries, CD-ROMs, etc.). You may not charge any fee for the copy or use
of the evaluation SOFTWARE itself, but you may charge a distribution fee that is
reasonably related to any cost you incur distributing the evaluation SOFTWARE (e.g.
packaging). You must not represent in any way that you are selling the SOFTWARE
itself. Your distribution of the SOFTWARE will not entitle you to any compensation from
Astonsoft Ltd..  You must distribute a copy of this EULA with any copy of the
SOFTWARE and anyone to whom you distribute the SOFTWARE is subject to this EULA.

3. RESTRICTIONS.  You may not reverse engineer, de-compile, or disassemble the
SOFTWARE, except and only to the extent that such activity is expressly permitted by
applicable law notwithstanding this limitation. You may not rent, lease, or lend the
SOFTWARE. You may permanently transfer all of your rights under this EULA, provided
the recipient agrees to the terms of this EULA.  You may not use the SOFTWARE to
perform any unauthorized transfer of information (e.g. transfer of files in violation of a
copyright) or for any illegal purpose.

4. SUPPORT SERVICES. Astonsoft Ltd. may provide you with support services related
to the SOFTWARE. Use of Support Services is governed by the Astonsoft Ltd. polices
and programs described in the user manual, in online documentation, and/or other
Astonsoft Ltd.-provided materials, as they may be modified from time to time. Any
supplemental SOFTWARE code provided to you as part of the Support Services shall be
considered part of the SOFTWARE and subject to the terms and conditions of this
EULA. With respect to technical information you provide to Astonsoft Ltd. as part of
the Support Services, Astonsoft Ltd. may use such information for its business
purposes, including for product support and development. Astonsoft Ltd. will not utilize
such technical information in a form that personally identifies you.

5. TERMINATION. Without prejudice to any other rights, Astonsoft Ltd. may terminate
this EULA if you fail to comply with the terms and conditions of this EULA. In such
event, you must destroy all copies of the SOFTWARE.

6. COPYRIGHT. The SOFTWARE is protected by United States copyright law and
international treaty provisions. You acknowledge that no title to the intellectual
property in the SOFTWARE is transferred to you. You further acknowledge that title
and full ownership rights to the SOFTWARE will remain the exclusive property of
Astonsoft Ltd. and you will not acquire any rights to the SOFTWARE except as
expressly set forth in this license. You agree that any copies of the SOFTWARE will
contain the same proprietary notices which appear on and in the SOFTWARE.

7. NO WARRANTIES. Astonsoft Ltd. expressly disclaims any warranty for the
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SOFTWARE. THE SOFTWARE AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING,
WITHOUT LIMITATION, THE IMPLIED WARRANTIES OR MERCHANTABILITY, FITNESS FOR
A PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF
USE OR PERFORMANCE OF THE SOFTWARE REMAINS WITH YOU.

8. LIMITATION OF LIABILITY. IN NO EVENT SHALL Astonsoft Ltd. OR ITS SUPPLIERS BE
LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL, OR INDIRECT
DAMAGES OF ANY KIND ARISING OUT OF THE DELIVERY, PERFORMANCE, OR USE OF
THE SOFTWARE, EVEN IF Astonsoft Ltd. HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES. IN ANY EVENT, Astonsoft Ltd.'S LIABILITY FOR ANY CLAIM, WHETHER
IN CONTRACT, TORT, OR ANY OTHER THEORY OF LIABILITY WILL NOT EXCEED THE
GREATER OF U.S.$1.00 OR LICENSE FEE PAID BY YOU.

9. U.S. GOVERNMENT RESTRICTED RIGHTS. The SOFTWARE is provided with
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to
restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and
Computer SOFTWARE clause of DFARS 252.227-7013 or subparagraphs (c)(i) and (2) of
the Commercial Computer SOFTWARE-Restricted Rights at 48 CFR 52.227-19, as
applicable.

4 Working with EssentialPIM

EssentialPIM implements a number of features. At the same time, most of them are
intuitive, which allowed to make simple interface. The following topics describe steps
you have to take to work effectively with the program and also make it easier to
organize and synchronize your data.

Calendar - day planning the versatile way
To Do lists - quick and simple list of things to do
Notes - any data can be stored in tree-structured notes
Contacts - all contacts organized
Passwords - powerful password managing tool
Mail - built in e-mail client

4.1 First run

When you run EssentialPIM for the first time, the program creates test.epim database
file, which contains sample appointments, to dos, notes and contacts. Feel free to
create a new database file by choosing File -> New, or editing the created database.

Creating new database:
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4.2 EPIM Today

EPIM Today shows you an overview of all Appointments, Birthdays and To Dos for
nearest days. EssentialPIM Today Settings can be found in Tools -> Options -> EPIM
Today.

Section 1 lists appointments for nearest days (three by default). You can set amount
of listed days in EPIM Today Settings which could be found in Tools -> Options ->
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EPIM Today.

Section 2 lists To Dos for nearest days. Amount of listed days could be also set under
 Tools -> Options -> EPIM Today.

Section 3 consists of two parts. First one lists mail; second - anniversaries and
birthdays. Technically these entries are automatically created appointments from Date
fields in contacts.

Column sizes could be adjusted by dragging dividing lines.

4.3 Calendar

4.3.1 Adding an appointment

The screenshot below explains how to easily add a certain appointment:

(Using mouse, highlight the time needed for the appointment and release the button:
the new appointment pop-up windows appears. Just enter the text and, if necessary,
assign Priority, Category, Completion, Alarms and Re-occurrence, then press OK)

Another way:
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Press Add button. In the opened dialog:

1. select start time
2. enter text
3. assign needed parameters

To enter a non-timed entry for the day: the process is the same, except you need to
check the "All day event" box.

- Exclusive appointment - enabling this option for the appointment will ensure that
this time will not be taken by any other task. If you will try later to add an appointment
with time coinciding with "Exclusive appointment"- EssentialPIM Pro will not let you do
it.
- All day event - that is the appointment that does not have a certain time, rather, it
is assigned to the whole day and will appear on top of each day

4.3.2 Editing an appointment

Appointments could be edited any time by double-click on it. It will open Appointment
Info dialog.
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Subject - Name of the appointment which will be listed in Calendar views.
Location - set a location for the appointment. Last entries will be saved in dropdown

menu.
Start time - set start time of the appointment.
End time - set end time of the appointment.
Duration - automatically calculates appointment end time.
All day event - that is the appointment that does not have a certain time, rather, it is
assigned to the whole day and will appear on top of each day. 
Exclusive appointment - enabling this option for the appointment will ensure that
this time will not be taken by any other task. If you will try later to add an appointment
with time coinciding with "Exclusive appointment" - EssentialPIM Pro will not let you do
it.
Priority - set a priority for the appointment.
Completion - set a rate of completion of the appointment.
Category - set a category for the appointment. 

Reminder section

Reminder could be enabled by checking Reminder check box:
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Reminder could be set At event time or Before appointment.

It is possible to set some additional reminder options by pressing Advanced button:

In this dialog you can assign Default sound or any custom Sound file (*.wav or *.
mp3) for alert.
In the Message section you can set a Custom message for appointment reminder.
You can also assign a program that will run with reminder. You can locate assigned
program via Browse button or by entering path to application manually.

Repeat Appointment section

It is possible to make appointment repeatable by checking Repeat Appointment
check box:

You can set daily, weekly or monthly recurrence of current appointment. By default
there will be created 10 recurrence of current appointment. You can set expire date if
you need more. For more complex recurrence adjusting press Advanced button:
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This dialog allows to adjust recurrence more specifically. I.e. you can set to repeat
appointment every second Tuesday in the month or every third day etc.

4.3.3 Appointments types

There are two types:

Timed entries (appointments that have beginning and end times)
Non-timed entries (all day appointments)

Days in Calendar could be set to variable time scales by clicking on View -> Time
Scale or by right-clicking on the scale in Day and Week views:
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Hours in Calendar are being shown either in 12 or 24 hours formats. The format is
selected automatically based on you current Windows regional settings. You can
change that in Start -> Settings -> Control Panel -> Regional and Language Options.

Working days and hours could be set at Tools -> Options -> Calendar.
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Work time is marked with lighter color in Calendar.

Show only work hours - this option allows to have only work hours shown in Day and
Week views.
Auto scale of hours grid - fits calendar to EssentialPIM's window size.
First day of week - sets first day for the week. This option overrides Windows
regional settings option. 

4.4 To Dos

4.4.1 Adding a to do

To Do module in EPIM allows you to track projects' progress and make a system of
complex relationships within projects.

To Add a To Do press Add button in Action bar:
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In opened dialog:

1. select start time
2. enter text
3. assign settings

4.4.2 Editing a to do

To Do's could be edited any time by double-click on it. It will open To Do Info dialog.

Subject - Name of the to do which will be listed in Today view.
Location - set a location for the to do. All entries will be saved in dropdown menu.
Start time - set start time of the to do.
End time - set end time of the to do.
Priority - set a priority for the to do.
Completion - set a rate of completion of the to do.
Category - set a category for the to do. 

Reminder section
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Reminder could be enabled by checking Reminder check box:

Reminder could be set at the current date and time.

It is possible to set some additional reminder options by pressing Advanced button:

In this dialog you can assign Default sound or any custom Sound file (*.wav or *.
mp3) for alert.
In the Message section you can set a Custom message for to do reminder.
You can also assign a program that will run with reminder. You can locate assigned
program via Browse button or by entering path to application manually.

4.5 Notes

4.5.1 Adding a note

Notes can hold formatted text, tables and images (.jpg, .bmp, .ico, .emf, .wmf formats
supported).

To add a new note, press Add on a left-side bar. 
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Than enter the name for the note in appeared dialog:

You can insert current Date and Time, using Insert command or shortcuts Ctrl+D (Day)
and Ctrl+T (Time)

In the lower window now you can enter the text, insert pictures, tables and lists. Use
the toolbar:

to edit the text in the note.

To change position of any note in the tree, just drag and drop it at desired position.

4.5.2 Notes managing

Arranging Notes

Notes could be arranged in hierarchical structure. It could be edited using standard
deag&drop feature. Notes could be also arranged using Actions bar tools:

Add as Child button creates a sub-note to current one.

Add as Sibling adds a To Do to an active tree.

Move In/Out and Move Up/Down buttons could be used to edit hierarchical
structure. It's also possible to drug & drop Notes to each other to edit hierarchy.
Position change is also possible using standard drag&drop feature.
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Collapse/Expand All buttons easily collapse/expand the whole tree structure

Notes could be also automatically arranged by Name or Last Modified date:
 
Notes could be also automatically arranged by Name or Last Modified date:

4.6 Contacts

4.6.1 Adding a contact

Contacts can hold all of your contacts. It supports Groups, unlimited custom fields,
sorting and multiple views.

To add a contact press Add Contact button in the Actions bar. Enter the data for
your contact, in the pop-up window. Select from different tabs in the contact edit
window to enter Personal Info, Business and Notes. 
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Custom fields

To add a custom field, click on a Add field button. Enter the name for the field and
data type which will be stored in it. There are flowing data types available for contact
fields:

- Text/Number - standard text format which could contain any text or number info
- Date - stores date  
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Show as appointment using category enabled will automatically create annual event
in Calendar.
Show at the bottom of the Calendar module option adds a notification to Calendar 3
days before event.

- Drop-down list - creates drop-down list with values in corresponding field
- Yes/No - creates drop-down with two logical values like Yes/No, True/False, On/Off
or custom use values
- Check box - standard check box

Contacts can hold pictures and photos, for each contact (Contact Info -> Picture).
You can later export the picture from EssentialPIM Pro to your hard drive again
(Save...)

4.6.2 Contacts managing

EssentialPIM supports various ways of displaying, searching and managing options.

To search a contact
Start writing in the Find field. You can also limit the search to a certain field by
choosing specified field from In Field drop down menu.

To change the fields
Shown in the main window, right-click on the names of the fields in the window and put
check on the field that needs to be shown. If you need to change many fields, right-
click on fields names and choose Customize.

To edit a contact
Double-click on it in the main view. A separate window listing contacts details will
open. Edit any of the fields and press OK.

To sort contacts
Click on the name of the field in the main view, according to which it needs to be
sorted.

Letters panel allows easily navigate to a specific letter or number in contacts list. 
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This panel may include multiple language alphabets.

4.7 Passwords

4.7.1 Creating a password

Passwords module helps to manage password/login data for various services. To add a
new record press Add Entry button or go to File -> New -> Password Entry. This
will open the Entry Info dialog window.
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Here you can enter password entry details including notes and add attachments.
Gen button helps to generate a random password for your entry, just check necessary
options and press the Generate button:

Custom fields

You can add your own fields for password entries. Click the Add field button and enter
field name in the appeared dialog window. Edit field, Delete field, Move up and Move
down buttons are used to manage existing fields.

Using passwords

You can copy either User Name or Password into clipboard by selecting a desired
password entry and clicking on Copy User Name or Copy Password buttons.
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Another way is to double click on the User Name and Password fields of the desired
password entry directly from the table. You'll see the "Data copied to clipboard"
message in the status bar, indicating successful execution of the command.

4.8 Mail

4.8.1 Crreating an Account

Click on the Tools menu and select the Account settings option. Then click on the
Add button. 

This will start a wizard which will guide you through whole procedure.

Step 1. Enter your name in the Name field, and your full email address
(username@server.com) in the Email address field, then click on the Next button.
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Step 2. Select your server type, set address and login data for incoming mail, then
click on the Next button. If you are not sure about your server type and address then
you can check it in your mail provider Help area.

Step 3. Set a server address and login data for outgoing mail, then click on the Next
button.
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Step 4. Enter name for your account then click on the Finish button.

4.8.2 Managing Mail

Creating a new message
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Press New Message button to create a new mail.

This will open New Message dialog where you can compose a message. 

New message dialog tool panel represents all basic email editing features:
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From menu contains the list of optional identities with signatures. This list could be
edited under general account settings.

Pressing Select Recipients button will open corresponding dialog which allows to fill To
, Cc and Bcc fields  using EssentialPIMs contacts list.

Once the message was created you can send* it by pressing Send button or save it
as a draft just by closing dialog and saving message as draft.

Send/Receive mail
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Press Send/Receive button to start mail transfer.

Send/Receive Mail dialog will show you status of the process

* - the message will be sent immediately or put to Outbox in accordance with mail options.

4.8.3 Mail Options

General mail options are available from Tools -> Options menu.
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Show grid lines - adds grid lines to Mail module to make mail list easier to read on high
resolution monitors.
Send message immediately - enabling this option will send message immediately
when pressing Send button within composing message dialog. Disabling this option will
move message to Outbox folder first.
Default mail composing format - sets default format for new messages.
Reply to the messages using format in which they were sent - disabling this
option will make replays in default mail composing format.
Check to see if EPIM is the default email program at startup - enable this option
to be sure that EPIM will be always default email client.
Proxy - allows to set up mail transfer via Proxy server.

4.8.4 Account Settings

Account settings are available from Tools -> Account Settings menu.
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Select an account and press Edit button. This will open Account Settings dialog
which consists of four tabs.

General tab allows to set account name and basic user info:
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Identities allows to add optional sender data and signature. This identities list became
available as drop-down menu when composing new mail. 

Server tab contains server addresses and login info for incoming and outgoing mail.
Refer to your mail provider help area if you are not sure what to enter here:
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Outgoing servers section allows to add optional SMTP servers to account and choose
which one will be used.

Default ports for incoming server:
POP3 - 110, 995 (SSL)
IMAP - 143, 993 (SSL)

Default ports for outgoing server:
w/o SSL - 25, 2525
SSL - 465, 587

Advanced tab allows to set additional interaction with the mail server options
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Signature tab represents a small text editor which allows to compose different kind of
signatures:
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4.8.5 Message Rules

EssentialPIM Pro allows to sort incoming mail automatically by using Message rules.
Click on the Tools menu and select Message Rules option. This will open the dialog
which allows to Add, Delete or Edit rules.
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Press Add button to create a rule. This will open Mail Rule dialog which consists of
two parts. Top part contains conditions, you may add or remove them using +/-
buttons. Bottom part contain the actions list what to do with a message if the
condition part is true. The given rule example will move message to folder "folder 1" and
mark it as Read if From field will contain text "John".
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4.9 Synchronizations

4.9.1 Android

EssentialPIM is capable of synchronizing with Android devices. You need to download
and install free Android version of EssentialPIM onto your device [Google Play Link]. You
will be able to synchronize and manage data from the following modules:

Windows EssentialPIM             Android EssentialPIM
Calendar <->     Calendar (Android built-in)

To Do <->     To Do
Notes <->     Notes

Contacts <->     Contacts (Android built-in)
Passwords <->     Passwords

Pre-requisites for synchronization

Device running Android 2.1 or newer version
Common network between Android device and PC. This is usual that your PC and
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Android connect to the same router (Android device uses Wi-Fi, while PC uses Wi-Fi
or cable)

Setting up and running synchronizations

To set up synchronization for the first time, click on File -> Synchronization -> Add
Synchronization -> Android.

Choose modules to synchronize and enter password for Passwords module (you may
need to run EssentialPIM on Android first and set up master password by tapping the
Passwords icon). Once you finish, press Next.
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Now run EssentialPIM on an Android device and choose PC Sync option. 

Enter Server IP address and Port number provided by the synchronization wizard
and press Connect button. EssentialPIM will detect your device and in order to
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prevent any unauthorized synchronization attempts with different devices in the
future, will ask whether to allow synchronization with your particular device. On the
last step you'll be able to change synchronization name and choose synchronization
direction.

On subsequent synchronizations, to start synchronizing, you need to:

Start Windows version of EssentialPIM
Start Android version of EssentialPIM, go to PC Sync and tap Connect

If something does not work, see Troubleshooting Android Synchronization.

4.9.1.1 Troubleshooting

If after tapping the Connect button you see the following connection error message:
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Make sure:

You have read Setting up Android synchronization
You use the latest Windows EssentialPIM version (check Help-> Check For New
version) 
Windows EssentialPIM is on the Pairing Device step in the synchronization Wizard
(if not paired previously. If paired, Windows EssentialPIM needs to be running
without Wizard)
You use common network between Android device and PC (same network)
Firewall allows connections over port 21114 (default), or change the port number
in PC EssentialPIM Wizard
If you are sure all of this is done, but still no go, please email support with
screenshots of your Windows and Android versions of EssentialPIM

4.9.2 iOS (iPhone, iPad)

EssentialPIM is capable of synchronizing with iOS devices. You need to download and
install free iOS version of EssentialPIM onto your device from App Store. You will be
able to synchronize and manage following data:

Windows EssentialPIM             iOS EssentialPIM
Calendar <->     Calendar (iOS built-in)
Contacts <->     Contacts (iOS built-in)

To Do <->     To Do (inside iOS EPIM)
Passwords <->     Passwords (inside iOS EPIM)
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Pre-requisites for synchronization

Devices supported: iPhones 3GS and newer, all iPADs, iPOD 3 and newer (provided
iOS 5 or newer is installed)
iTunes is installed on PC
Common Network between iOS device and PC. This is usual that your PC and iOS
connect to the same router (iOS device uses Wi Fi, while PC uses Wi Fi or cable)

Setting up iOS EPIM synchronization

1. On Windows EPIM, click on File -> Synchronization -> Add Synchronization
-> iPhone/iPad.
A wizard will start that will guide you through setting up a synchronization. This is a

one-time process, after this you will need only start synchronizations from your

device.

2. On "Sync Credentials" step, choose modules to synchronize. 

3. On next, "Pairing Device" step, you should search for "EssentialPIM" on App
Store on your device and install it. 
Tip: Make sure your iPhone/iPad Wi Fi is connected to the same network as your

Windows computer.

4. After you run EssentialPIM on your iPhone/iPad, choose "PC Sync" menu.

You should see this screen (press Start):

Tip: If you do not see "Start" button, make sure your Windows EPIM is now on 
"Pairing Device" step and you have iTunes installed on Windows!

5. At the same time, EssentialPIM on Windows will ask for confirmation: 
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This is needed to prevent any unauthorized synchronization attempts with different
devices in the future.

6. Next, "Sync Options" step presents you with some Options. Default Options are
usually OK.

On subsequent synchronizations, to start synchronizing, you need to:

start Windows EPIM
start iOS EPIM, go to "PC Sync" and press "Start"

If something does not work, see Troubleshooting iOS Synchronization

More details on synchronization

For each EssentialPIM category on Windows, a separate Calendar will be created on
iPhone/iPad (to change this go to Tools-> Options-> Your synchronization and
uncheck "Create calendars in iPhone for each of EPIM categories". In this case all
EPIM categories will be synchronized to one default calendar on your iPhone/iPad).

4.9.2.1 Troubleshooting iOS Synchronization

 If you want to start synchronization, but instead see this screen on iOS EPIM:
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Make sure:

You have read "Setting up iOS EPIM synchronization"
iTunes is installed on PC
You use the latest Windows EPIM version (check Help-> Check For New version) 
Windows EssentialPIM is on "Pairing Device" step (if not paired previously. If
paired, Windows EPIM needs to be running without Wizard)
You use Common Network between iOS device and PC (same network)
Firewall allows connections over port 21108 (default), or change it in PC EPIM
Wizard
If you are sure all of this is done, but still no go, please email support with
screenshots of Windows EPIM and iOS EPIM.

4.10 Import/Export Data

4.10.1 Importing

EssentialPIM makes your transition from other PIM easy. 

You can import: 

Calendars, Contacts and Notes from MS Outlook
Calendars and To Do lists from iCal files
Notes from RTF/TXT, KeyNote, and TreePad files
Contacts from Windows Address Book (WAB), CSV, vCard

Passwords entries from CSV, Roboform (HTML), KeyPass (XML)
Mail from EML

4.10.2 Exporting

EssentialPIM offers a large variety of formats to export your existing data. Export
options are at File -> Export ->

All data can be exported one-by one, or you can select multiple entries using CTRL +
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mouse (for contacts and Notes), or All entries can be exported.
In most cases you can even select which fields to export.

Contacts could be exported to: 

Windows Address Book (*.WAB, can be opened by double-clicking on it in
Windows, also used by MS Outlook Express)
Comma Separated Values (*.CSV, can be opened by MS Excel or Text Editor)
HTML (*.HTML, can be opened by any Internet Browser)
Rich Text Format (.RTF, can be opened by many Text Editors)
Text Files (*.TXT, can be opened by any Text Editor)
vCards (*.VCF, a file format standard for personal data interchange, specifically
electronic business cards)

Notes could be exported to:

HTML (*.HTML, can be opened by any Internet Browser)
Rich Text Format (.RTF, can be opened by many Text Editors)
Text Files (*.TXT, can be opened by any Text Editor)
iPOD

To Do list could be exported to: 

HTML (*.HTML, can be opened by any Internet Browser)
iCal (*.ICS, a standard for calendar data exchange)
iPOD

Contacts could be exported to:

HTML
iCal
iPOD

Mail could be exported to:

EML

Password entries could be exported to:

CSV

4.11 Shortcuts

EssentialPIM Free makes extensive use of shortcuts. Here is the list of them:

Global:

Ctrl+Alt+S Minimize to system tray
Shift+Ctrl+T New Appointment
Shift+Ctrl+O New To Do
Shift+Ctrl+N New Note
Shift+Ctrl+C New Contact
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Shift+Ctrl+M New Message
Shift+Ctrl+P New Password Entry

Switching Between modules:

Ctrl+0 EPIM Today
Ctrl+1 Calendar
Ctrl+2 To Do
Ctrl+3 Notes
Ctrl+4 Contacts
Ctrl+5 Passwords
Ctrl+6 Mail
Ctrl+9 Trash

General:

Ctrl+Q Focus on search box

In Calendar:

Ctrl+D Day View
Ctrl+W Week View
Ctrl+M Month View
Ctrl+Y Year View
Ctrl+E Table View
Ctrl+T Today
Ctrl+G Go to
Ctrl+H Hide/show completed

In To Do:

Ctrl+H Hide/show completed

In Notes:

Ctrl+R Add to root
Ins Add as Child
Ctrl+I Add as Sibling
Ctrl+Alt+Right  Move in
Ctrl+Alt+Left Move out
Ctrl+Alt+Up Move up
Ctrl+Alt+Down Move down
Ctrl+Alt+C Collapse All
Ctrl+Alt+X Expand All

while creating a new Note
Ctrl+D insert current Day 
Ctrl+T insert current Time

In Contacts:

Ctrl+H Hide/show groups



Working with EssentialPIM 47

© 2004-2012 Astonsoft Ltd.

In Mail:

Ctrl+R Reply to Sender
Ctrl+Shift+R Reply to All
Ctrl+W Forward
Ctrl+M Send
Ctrl+Alt+A Send and Receive All
Ctrl+Alt+R Receive All
Ctrl+Alt+X Send All 

In Passwords:

Ctrl+Alt+U Copy User Name
Ctrl+Alt+P Copy PasswordIn Passwords

In text editing standard shortcuts are enabled: Ctrl+X, Ctrl+C, Ctrl+V, Ctrl+Y, Ctrl+A.

All shortcuts could be edited in Tools -> Options -> Shortcuts dialog.

4.12 Printing

EssentialPIM allows you to print out all your information in easy to read form. Print
menu is accessible at File -> Print

What you print will depend on in which view you are currently: in Calendar, Notes, or
Contacts.
All data can be printed one-by one, or you can select multiple entries using CTRL +
mouse (for contacts and Notes), or All entries can be printed.
To rotate the page, in the Print Preview Page, find "Page Setup", or press Alt+U and
you will be able to change the Orientation of the page.

Printing EPIM Today
You can print EPIM Today- exactly as it looks on the screen. 

Printing Calendars
There are several option of how to print Calendars: Day View, Week View and Month
View. All are different options for representing your day schedule. You can also print
several Days, Weeks and Months.

Printing To Do
You can select which To Do's to print and which fields. If you want to select multiple
to do's, use CTRL+ Mouse, or Shift+ Keyboard arrows.

Printing Notes
You can select several, one or all notes to print out into. A tree of all notes is printed
above all notes.

Printing Contacts
You can select which contacts to print out (using CTRL+ Mouse, or Shift+ Keyboard
arrows), or print out all.
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5 Information for translators

Astonsoft Ltd., welcomes people to translate EssentialPIM's program language file into
their native languages. 

Interface
Whole EssentialPIM's interface is contained in ENGLISH.LNG file, which is situated in
EssentialPIM's installation directory. Please feel free to take the file and start
translating. Usually it takes a couple of hours. 

6 Support

Astonsoft Ltd. is committed to supporting its customers. Please feel free to browse
through the below listed topics and find the most appropriate way to get your
question/problem resolved.

6.1 FAQ

6.1.1 General

Q: After upgrade, will my data be preserved?
A: Yes, your data is stored in *.epim file and will be automatically converted to the
new version format.

Q: How do I restore Backups?
A: Backups are regular *.epim files, named "file name_backup_year_month_day_time".
They can be opened from within EPIM using File-> Open menu.

Q: This morning I opened PIM and all my entries had disappeared. What do I do
now?
A: Please search your computer for *.epim files, most probably you have opened a
wrong *.epim file or created a new one, empty.

Q: Can I request a feature?
A: Yes, of course. We actually make a point of listening to our users. That's how
EssentialPIM was developed. Please post your request here: Online Support Forum ->
Suggestions.

Q: Is EssentialPIM translated to ... language?
A: For a current list of translations, please check here. If you do not see EssentialPIM
translated to your language- please feel free to do it. It really is easy. Just visit the
Translators' Page.

Q: How can I help contribute to EssentialPIM's development?
A: You can translate EssentialPIM into your native language, or suggest a feature. We
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value all contributions.

Q: Is EssentialPIM Free really free?
A: Yes, it is completely free. If you download it from our website, we guarantee it is
totally free of any adware, spyware, nag screens, etc.

Q: Will EssentialPIM Free become paid software?
A: No. No, it will definitely never be sold. EssentialPIM is and will stay freeware. If you
are aware of someone selling EPIM Free, please tell us!

Q: Why isn't EssentialPIM open source?
A: EPIM is programmed using the Delphi programming language. We use several external
components, the licenses of which forbid us to re-distribute the source code. Using
quality external components allows us to deliver EssentialPIM to you faster.

Q: How to make EPIM to start with another module?   
A: If you'll disable "Start with EPIM Today" in Tools -> Options -> EPIM Today than
EPIM will start with the last used module.  
 
Q: How to find my database file?   
A: EPIM stores all data in .epim database files. The default paths for EPIM databases
are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista and Seven
If you can't find it anyway than try to search *.epim files on your computer.

Q: I've downloaded your EPIM but the installer would not work. What should I
do?   
A: This is because of incomplete download. Try to redownload instalation file again. If
it still tells that file is corrupted than most probably your browser or provider cached
file and every time you try to re-download it gives you cashed incomplete file again.
Try to clear browser cache or download with any download manager.

Q: Is it possible to run EPIM on Mac OS (Linux)?   
A: Unfortunately no. Only Windows version available for now. 
 
Q: How can I access .epim database directly?   
A: EPIM uses Firebird database engine. You can access database directly using any
Firebird database manager. For example: http://www.mitec.cz/ibq.html Please note
that you should understand how to work with database, otherwise data will be lost.
Default l 
 
Q: My database size is 1,5Mb but backup file size is 350kb? Does backup stores
all my data?   
A: Don't worry all your data is stored in backup. It is compressed. 
 
Q: I have bought other computer but now I want to transfer all my EPIM
program and data to this new computer - can you explain to me how to do this? 
 
A: You should install EPIM to a new computer and register it with your license name
and key. Then you should transfer your database and open it in EPIM (File -> Open).
You can always download EPIM installation file from our site: http://www.essentialpim.
com 
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Q: How can I transfer data to EPIM from another PIM?   
A: Data could be transferred via supported by EPIM formats only. You can find all
supported formats in File -> Import menus. 
 
Q: How to sort records by...   
A: All EPIM items could be sorted by any field. Click on field caption in order to sort by
it. Holding Ctrl button will allow to sort by several fields. 
 
Q: How to change/remove database password?   
A: Do the following to remove or change password: 1. Go to File -> Password
protection 2. Enter your password and press OK 3. Press Clear or enter new password
in appeared dialog  
 
Q: EssentialPIM can not open database from a shared disk   
A: EPIM Free works with local files only.

Q: I've forgotten my database password. How can I recover it?   
A: Unfortunately it's not possible to recover database password. 
  
Q: EPIM became very slow. How to boost performance?
A: First, empty trash and run optimization under "File -> Database management".
If it won't help then create a new database under "File -> New -> EPIM Data File" and
save it. Then sync it with your file using EPIM Synchronizer tool which could be
downloaded from our site - http://www.essentialpim.com/?r=download 
Then open newly synced file under "File -> Open"

Q: Password protection or Optimization option is not active
A: EPIM can't utilize database management tools while mail send/receive processes are
active. Disable "Check mail on start" option and restart EPIM. Password protection and
Optimization options will be active then.

Q: How to delete/archive old records from database?
A: We have a special tool for this - EPIM Archiver/DupeRemover. It can delete or
archive items older then particular date. Tool available from our download page - 
http://www.essentialpim.com/?r=download 

6.1.2 Calendar

Q: How to add national holidays to calendar?   
A: You can import holidays as iCal (.ics) calendar which could be downloaded from
Internet. You could start searching from our iCal's download page: http://www.
essentialpim.com/?r=download&pr=ical 
 
Q: How to generate a list of upcoming birthdays and/or a list of all birthdays.   
A: You should switch calendar to Table view, filter tasks according to Birthday
(Holiday) category and set date ranges. You'll get your list then. 
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6.1.3 Notes

Q: Internet links doesn't work in Notes. The link become blue when I enter it, but
nothing happens when I Click on it.   
A: It works the same as in MS Word. You should click links holding Ctrl button. 

6.1.4 Contacts

Q: How can I delete unnecessary fields from contacts?   
A: Open any contact, select the field you want to delete and press "Delete field"
button. 
 
Q: Is it possible to add additional anniversaries to contact i.e. wife’s birthday or
any other?   
A: Yes, open any contact and press "Add field" button then set Date Field type. EPIM
will create recurring task for this event the same as for birthdays then. 
 
Q: How to add/remove columns to display in Contacts view?   
A: Right-click columns caption and choose fields to display. 
 
Q: How can I add/edit field(s) in contacts?   
A: Open any contact and press “Add field” or select a field and press “Edit field”
correspondingly. 
 
Q: How can I change fields order in Contacts?   
A: Just drag them in preferred order with left mouse button. 
 
Q: Some fields are not listed in Contacts table (main view) and some are not
necessary. How to set to display needed fields?   
A: Right-click on field name caption and choose fields to display from context menu. 
 

6.1.5 Mail

Q: "Socket Error # 10060 Connection timed out" error
A: Make sure that all servers setting were set correctly under "Tools -> Account
Settings -> Edit -> Servers Settings"
If you are not sure about what to enter then login to your account via web interface
and refer to Help area. Search for POP3/IMAP (for incoming mail) and SMTP (for
outgoing mail) settings through FAQs.

Q: How to make mail available offline for IMAP accounts?
A: IMAP accounts download headers only by default. Press "Manage Folders" button
from Actions panel and choose what folders to download fully. Those folders contents
will be available offline then.

6.1.6 Potable version issues

Q: I want to upgrade my U3 version but can't find it on your download page?   



EssentialPIM Free Help52

© 2004-2012 Astonsoft Ltd.

A: Sorry, U3 version won't be supported anymore. You can install version for regular
drives. Download the ZIP file and unzip it on your flash drive and run EssentialPIM.exe.
Launchpad icon could be added with this tool - http://www.softpedia.com/reviews/
windows/Shortcut-Creator-4U3--Review-76269.shtml
 
Q: My EPIM is very slow on my USB stick. How can I boost it up?   
A: EPIM speed depends on your USB stick speed. Try to empty Trash and delete old
unnecessary items. You can also try to Optimize database (File -> Database
management -> Optimize). These measures should boost performance. Try also to
reformat USB drive.
 
Q: Can I use portable EPIM as desktop EPIM?   
A: This is not recommended, although you can try. Just unzip non-U3 version to your
hard drive and run EssentialPIM.exe from program folder. 

 
 
 
 
 
 

6.2 Update

                                                                                                                    
EssentialPIM Free automatically checks for updates once a week. If an updated version
is found, you'll be notified. To check for updates manually, click on Help -> Check For
New Version.

You can always download the latest version of the program from our Web site - www.
essentialpim.com

6.3 Troubleshooting

If you experience any problem with EssentialPIM Free, please follow these steps to find
a solution:

Make sure that you have installed the latest version
Visit our online support community forum at www.essentialpim.com/forum
If you still have not found the answer, do not hesitate to contact us at 
epimsupport@essentialpim.com

7 Contact

Please do not hesitate to contact us:

By e-mail
For general information please e-mail us at epiminfo@essentialpim.com
For sales information please e-mail us at epimsales@essentialpim.com
For technical support please e-mail us at epimsupport@essentialpim.com



Contact 53

© 2004-2012 Astonsoft Ltd.

By fax/phone (Please note, we do not provide support over the phone)
Fax: (+372) 650-79-77
Phone: (+372) 5192-79-21

By post
Astonsoft Ltd.
Laki 9A
Tallinn 10621
Estonia
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