
 
 

Product Datasheet 

www.EmbeddedMarket.com 

Freeduino DIY Kit - Arduino Compatible Do-it-Yourself Kit 

1 

 

 

 

 

  

 

Arduino Compatible  

Do-it-Yourself Kit 

 



 
 

Product Datasheet 

www.EmbeddedMarket.com 

Freeduino DIY Kit - Arduino Compatible Do-it-Yourself Kit 

2 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sr. 

Num. 
Topics Page 

1 

 

About Arduino and DIY 

 

3 

2 

 

Product Contents and Assembly Instructions 

 

4 

 

3 

 

Important information 12 



 
 

Product Datasheet 

www.EmbeddedMarket.com 

Freeduino DIY Kit - Arduino Compatible Do-it-Yourself Kit 

3 

 

     About Arduino & DIY 

 

Arduino is an open-source electronics prototyping platform based on flexible, easy-to-use 

hardware and software.  

 

It's intended for artists, designers, hobbyists, and anyone interested in creating interactive objects 

or environments.  

 

Arduino can sense the environment by receiving input from a variety of sensors and can affect its 

surroundings by controlling lights, motors, and other actuators. 

 

Little understanding of C Programming syntax is enough to use the board for making variety of 

projects and applications. 

 

This product is even recommended for school kids who are aware of C Programming.  

 

This is the most successful method to introduce kids and even elders to the world of 

microcontrollers and embedded systems. 

 

EmbeddedMarket.com is manufacturing Arduino Compatible boards since many years for now.  

 

The original Arduino board comes from Italy and as said above, the Arduino design is open source. 

Thus we at EmbeddedMarket.com have modified the Arduino hardware design for some good 

reasons so that the products will be more powerful and easy to use. 

 

EmbeddedMarket.com makes  

1. Arduino Duemilanove compatible Freeduino-DU fully assembled board with male headers. 

2. Freeduino RichBoard which has many advanced features in addition to the core Arduino 

hardware 

3. Do it yourself kit for Arduino (you are reading documentation for this product) 

4. Arduino hardware is also included in many other development products like EEDT6.0 

 

The Do it yourself concept helps beginners to start from scratch. You start with soldering the 

board and then start using the board. It gives you immense pleasure of constructing your own 

product. 

 

The assembly i.e. soldering process of this Arduino compatible DIY Kit is very simple and is 

discussed in detail on further pages.  

 

It takes 20 - 30 minutes to assemble the board.  

 

 

 

  

 

1. 
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    Product contents & Assembly Instructions 

Warning for kids: The process of soldering & cleaning the PCB requires parents / 

teachers supervision. The soldering process is not recommended for kids below 13 

years old. 

List of components included in the kit: 

 

Printed Circuit Board (PCB) 1 

 

IC ATmega328 microcontroller with 
pre-loaded Arduino-DU bootloader 

1 

 

IC 7805 1 

 

IC Base 28 Pin 1 

 

Red LED 3mm 1 

 

Green LED 3mm 1 

 

Two pin Micro Switch 1 

 

Ceramic capacitor - 0.1uF 
(Marked 104 or 0.1 on capacitor) 

8 

 

Resistance - 1KOhm 4 

2. 
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Resistance  - 10K Ohm 1 

 

Crystal – 16MHz 1 

 

Ceramic capacitor – 22pf 

(Marked as 22 on capacitor) 

2 

 

Electrolytic Capacitor – 10uf/40V 1 

 

Barrel Jack Connector 1 

 

Two Pin Short Link 1 

 

Eight Pin Male header 2 

 

Six Pin Male header Straight 2 

 

Six Pin Male header Right Angle 1 

 

 
 

Three Pin Male header 1 

 

 

 

 

 



 
 

Product Datasheet 

www.EmbeddedMarket.com 

Freeduino DIY Kit - Arduino Compatible Do-it-Yourself Kit 

6 

 

Soldering the board requires certain additional tools and accessories. These items are not 

included in the kit and you should keep them ready before beginning the assembly work. 

Tools and accessories you will need for assembly: 

1. Soldering Gun of 15W to 25W rating.  

 

2. Solder metal wire 22 Gauge  

 

3. Lead cutter  

 

4. Thinner used to clean paint brush or industrial IPA 

 

5. Tooth brush, used or new 

 

To use the board, you will need the Sketch Loader Circuit (made by EmbeddedMarket.com). 

 

Note: 

1. Soldering gun’s tip should be clean. Wipe it on damp sponge in between soldering 

 

2. If your soldering gun is not temperature controlled then let the soldering gun heat up 

to the fullest. It takes couple of minutes. 

 

3. To check soldering gun’s temperature, touch the soldering tip to the soldering metal 

wire and see if it melts easily and quickly.  

 

4. After soldering component, cut component’s lead at safe distance from PCB. Not all 

component leads requires cut. 

 

5. Safe guard your eyes and nose from the fumes generated while soldering. If possible, 

use a fume extractor or use a simple fan of any type to drive the fumes in opposite 

direction so that they won’t come to your face. 

 

6. Do not use plastic chairs for sitting during the soldering process. Such chairs carry 

static charge. Such static charge can damage electronics component easily. 

 

7. Do not store finished PCB in to plastic bags. Static charge from plastic bags can also 

damage the end product. 

 

8. Use antistatic bags or paper bags to store bare electronic products. 
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Below chart shows component placement. Follow the same sequence which is defined, based on 

component’s height.  

 

No component to be inserted at U1. U1 is 6 pin ISP port, not required for the regular usage of the board 

Soldering 

Sequence 

Component 

Marking 

Component Value Polarity Importance 

1 R1, R2, R3, 

R5 

Resistance 1K Ohm None 

2 R4 Resistance 10K Ohm None 

3 C3, C4 Ceramic capacitor 22pf None 

4 C1, C2, C5, 

C6, C8, C9, 

C10, C11 

Ceramic capacitor 0.1 uf None 

5 U2 IC Base 28 Pin 

(Do not solder IC directly) 

Match the notch of IC Base with the 

notch mark on the PCB. 

6 SW1 Two pin Micro Switch None 

7 Y1 Crystal – 16MHz None 

8 D1 Green LED 3mm Insert longer lead in square pad on 

PCB.  

9 D2 Red LED 3mm Insert longer lead in square pad on 

PCB.  

10 U3 IC 7805 Bend IC’s legs and match the hole of 

metallic part of the IC and the 

bigger hole on the PCB 

11 C7 Electrolytic Capacitor 

10uf/40V 

Insert longer lead into Square pad 

on PCB. The square pad is also 

marked with + sign. 

12 JP1 Eight pin male header None. 

13 JP2 Eight pin male header None 

14 JP5 Six pin male header straight 

type 

None 

15 JP6 Six pin male header straight 

type 

None 

16 JP3 Six pin male header right 

angle type 

None 

17 JP4 Two pin male header None 

18 JP7 Barrel Jack Connector None 
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Cleaning the PCB after soldering: 

 

This process is to be done only by adults /parents / teachers. Kids should not attempt 

to clean the PCB. 

 

Soldering metal wire contains flux (rosin). Flux helps better quality soldering. After soldering 

the same flux looks very dirty on the soldering side of the PCB. Thus the PCB needs cleaning. 

 

There are various methods used to clean the PCB.  

 

Below is the simplest one as the cleaning liquid used is easily available in any hardware shop. 

 

Ask for “thinner to clean paint brush” in any hardware or paint shop. Buy a small quantity of it, 

50ml is what you will need, but the hardware shop may sell half a liter minimum. 

 

Note that PCB may get damaged if inappropriate thinner or a strong thinner is used. Before 

beginning the cleaning process, apply a drop of it on corner of PCB and wait for 10 minutes to 

see the results. If you don’t see change in the color of PCB, then you may go ahead with the 

cleaning process. 

 

Wear a clear glass goggle before starting the cleaning job. This will safeguard your eyes from 

sprinkles of the thinner. Dip the toothbrush in to this thinner and rub it on the bottom (solder 

side) of the PCB. Repeat the process for couple of times and keep PCB in direct sunlight or 

under fan to dry. 

 

The thinner is inflammable and has strong smell. It is dangerous if not handled properly. Do not 

let it touch to your face and eyes. Do not taste it. Do not smell / inhale inside the bottle.  

 

Wash hands immediately after you are done with cleaning work.  
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Final step before using the board: 

As your board is assembled and cleaned, you may complete the last step and start using it. 

1. Locate JP4 connector on the board. You have assembled a three pin male header here.  

It has “INT” & “EXT” markings on either side of it.  Connect “two pin short link” between center 

pin and the pin marked with “EXT”. 

 
 

2. Now you are left with only one part i.e. ATmega328 controller. This controller has some firmware 

(piece of software) loaded in it. This piece of software is called as boot-loader.  

 

Pick up the ATmega328 IC and match the notch of IC and notch of the 28 pin IC Base. Push the IC 

into the IC Base gently. Ensure that none of the IC’s leg comes out of the IC Base.  

 

In case if the legs bends, then DO NOT try to straighten with hands. This may break the leg. 

Instead use Nose pliers to straighten it.  

Your board is now ready to be used.   

Let’s start using it: 

1. Keep the Sketch Loader Circuit ready to begin actual usage of the board. The Sketch loader 

circuit is made by EmbeddedMarket.com and needs to be purchased separately. It is not included 

in this product. The Sketch Loader Circuit comes with USB Cable. 

 

2. Download latest Arduino Software from http://arduino.cc/en/Main/Software website 

 

3. Unzip the downloaded file. No installation required. 

 

4. Run arduino.exe 

 

5. Connect one end of USB cable to PC / Laptop 

 
 

 

 

http://arduino.cc/en/Main/Software
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6. Connect the Sketch Loader Circuit to other end of the USB Cable. Two LEDs on the Sketch Loader 

Circuit will blink momentarily and will remain off thereafter. 

 

 
 

7. If PC / Laptop ask for driver, then in the driver installation wizard, select driver file from sub 

directory “drivers\FTDI USB Drivers” located under the above unzipped Arduino software folder.  

The latest FTDI drivers are available at http://www.ftdichip.com/Drivers/VCP.htm 

 

8. After driver installation is over, look into the Arduino Software’s menu, Tools => Serial Port. 

 

9. Select the Serial Port number COMxx where xx is unique number generated on your computer. In 

case you find multiple COMxx entries in this menu then observe which disappears after 

disconnecting the USB Cable from computer. The disappearing one is the correct to select. 

 

10.  Again in the Arduino Software menu, Tools => Board, select “Arduino Duemilanove or Nano w/ 

ATmega328”. This is the type of board you have built above. 

 

11.  Now connect your board to the Sketch Loader Circuit as shown in the picture below. DIY Board 

receives power from your computer’s USB port. 

 

 
 

12.  Again in the Arduino Software menu select, File => Examples => Basic =>Blink. This will open 

the Arduino code for Blinking the Red LED on the board.  

The RED LED is connected to Digital Pin 13. 

 

13.  To upload the LED Blink code to your own built Arduino board, click menu File => Upload to I/O 

Board from the Arduino Software. Alternatively you may also click Upload button from Arduino 

software toolbar. 

 

14. You will find that LED is blinking every second. 

 

15.  You may experiment in the code by adding more delay commands in the code on separate lines 

and upload again to the board. 

http://www.ftdichip.com/Drivers/VCP.htm
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For more experiments, you will need additional I/O boards and shields.  

These are available at EmbeddedMarket.com 

Points to note while using the board for first time: 

1. Two LEDs of Sketch Loader Circuit should blink for a moment immediately after 

connecting it to PC, later both will remain off. These LEDs blinks when there is some data 

transfer to & from PC. 

 

2. On the Arduino DIY board, the Green LED (D1) will glow always when connected to the 

Sketch Loader Circuit. This indicates Power ON 

 

3. The Red LED D2 will glow only if your Arduino code is written it to do so. 

 

4. While uploading the code to your board, if you encounter communication error then 

check the connections from PC to the board via USB cable and the Sketch Loader Circuit. 

Also check the orientation of the ATmega328 IC, you might have pushed it wrongly. In 

such case you may safely remove the IC using a very small tip screw driver. 

 

5. If green LED on the Arduino DIY board is not glowing even after connecting to the Sketch 

Loader Circuit, then check location of “Two pin Short Link” (also called as Jumper Pin) is 

on EXT side. 

 

6. If you want to power the board from external power source instead of the PC, then shift 

the “Two pin Short link” to INT Side on JP4. Ensure that you connect regulated 9V DC 

Power Source to the barrel connector JP7. 

 

7. Ref image of assembled board: 
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          Important information 

 

1. The “Freeduino DIY Kit - Arduino Compatible Do-it-Yourself Kit” product is designed for experiments and is not 

suitable to be used in life support and mission critical products. It should be assembled and soldered under 

expert supervision. 

 

2. Manufactured by: 

 

Embedded Market 

205 Decision Tower 

Next To CityPride 

Satara Road 

Pune 411037 India 

Ph:+91 20 24228818 

For Support- Login to your account at EmbeddedMarket.com and post Support request via Support 

request Link 

Email for Sales – sales@embeddedmarket.com 

Website – www.EmbeddedMarket.com 

 

3. For Product Customization & Bulk orders, contact sales@embeddedmarket.com 

 

4. Arduino is trademark of Arduino.cc 

 

5. Some text on page  3 is copied from arduino.cc 

 

 

 

3. 
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