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1 Introduction

MultiObject Spectroscopy is used to obtain simultaneous spectra of many objects in an EFOSC2
field. MOS is in principle similar to long slit spectroscopy but differs from it in many critical details.
For this reason a separate manual has been devoted to MOS.

1.1 Reference documents

The following documents are referenced in this document:

[1] LSO-MAN-ESO-36100-0004 EFOSC2 Users’ Manual

1.2 Abbreviations and acronyms

The following abbreviations and acronyms are used in this document:

SciOp Science Operations
LSO La Silla Observatory
ESO European Southern Observatory
MOS MultiObject Spectroscopy
EFOSC2 ESO Faint Object Spectrograph and Camera

1.3 Stylistic conventions

The following styles are used:

bold in the text, for commands, etc., as they have to be typed.
italic for parts that have to be substituted with real content.
box for buttons to click on.
teletype for examples and filenames with path in the text.

Bold and italic are also used to highlight words.
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2 Overview

The main stages in carrying out a MOS programme include:

• Obtaining a pre-image of the target field

• Identifying targets on this image such that they do not overlap along the spatial axis

• Defining the slits (location and length) for the above targets

• Punching the above slits on a MOS plate

• Calibrations (wavelength, flat field, mask image)

• Science observations

3 Pre–imaging

It is essential that MOS slits are defined based on a prior image taken with EFOSC2. This minimises
the effect of CCD distortion. The telescope team will endeavour to provide these pre-images, as a
favour to the observer, subject to the following constraints and conditions:

The request should be made well in advance of the run: EFOSC2 is not mounted on the instrument
all the time (see 3.6m telescope schedule). The only time available for obtaining these images is
during the set-up night at the beginning of an EFOSC2 run. The pre-imaging request should reach
the team at least 2 set-up nights ahead of the scheduled observations (typically 4-6 weeks in advance).

All the necessary information including target co-ordinates, finding chart with field centre marked,
image orientation (see below), filter and exposure time must be provided. Please send an email to
the La Silla account lasilla@eso.org where a ticket will be made for your request. You should also cc
your request to the EFOSC2 instrument scientist.

Not more than 3 images will be provided per observer. Additional images if necessary should be
obtained by the observer during their first scheduled night - it takes about an hour (with some
familiarity) from pre-image to loading the masks into the instrument.

The pre-image exposure time should not be more than 5 minutes - if an object is not visible in a 5
minute exposure one will not obtain a useful spectrum unless targets happen to be a cluster of strong
emission-line objects. Observers who need more than the above should apply for the same as part of
their regular proposal.

It is in the observer’s interest to place the request well in advance of their run - to avoid weather
hitches, competition with other scheduled tasks during set-up nights etc.

MOS observers are recommended to arrive in La Silla 2 days prior to the start of their run due to
the need to define and punch plates.

Image Orientation: The orientation (long axis) of the slitlets on the sky, in terms of their position
angle (from north through east), is given by PA = 90 + Rotator Offset Angle. Very Important the
rotator offset angle should be between -100 and +80 degrees (for more details, see section 2.1.4 in [1] or
the adaptor–page at http://www.ls.eso.org/lasilla/sciops/3p6/efosc/docs/Adaptor.html).

4 MOS Slitlet Mask

A choice of 3 punch heads are currently offered:
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• 1.15” x 7.8” (punch #1).

• 1.35” x 11.5” (punch #5).

• 1.75” x 11.5” (punch #6).

4.1 Defining the Slitlets

Given below is a recipe for defining slitlets starting with an image (EFOSC Image.#.fits). The
phrases in boldface give actual computer commands to be typed in, phrases to be substituted are
in italic:

• Login as mos3p6@wlsmos (ask your support astronomer for password).

• cd EFOSC

• mkdir yourname

• cd yourname

• ftp the fits image to this directory

• export DISPLAY=yourmachine:0.0 (only, if you are not physically at wlsmos)

• do xhost +wlsmos on your local machine. (only, if you are not physically at wlsmos)

• xm this opens the tool with which one defines the slitlets (important: do not use the command
xmos)
The MOS mask definition tool is basically a panel which provides an interface between the user
and MIDAS. Apart from the MOS mask definition tool (see Fig. 1) two other windows are
opened, a MIDAS display window and a MIDAS message window where the commands and
their output are reflected.

• Select a valid punch tool option – Note this has to be the first operation after opening the tool
and cannot be changed while working on a mask.

• Load an image using either the Fits → Load and R90 ... option to select FITS files or File
→ Load *.bdf to load images rotated before.

• Change the values for the two parameters listed below and then click on Update Midas on
the panel:

– Object distance from Slit edge . This defines how close to the edge of a slitlet an object
can be placed. Put in a value of choice

– Interslit gap . This defines how far apart in pixels adjacent slits have to be. If 2 slits are
defined with their extremities closer than this value the first slit will be erased.
This is to make sure that the spectra of 2 adjacent slits to do not overlap. However one
can deliberately overlap the slitlets of the reference stars since their spectra are not used.
For this one will have to specify a negative value here. Beware! You will have to take care
to ensure by eye that the slitlets of the target sources do not overlap!

• Change the display intensity cuts Tools → Cuts to something sensible (first enter cut values
on panel, then Update Midas and Tools → Cuts ; or use Tools → Cursor Cuts ).
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Figure 1: The MOS mask definition tool.
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• There are 4 possible slitlet defining operations. First select Options → slit length and then

Slit → object/cursor option:

– slit length minimum - On object Select the object using the rectangular cursor described

under Slits → On object . A slit of the minimum length will be drawn centred on the
object selected. The cursor will then be ready for the next object until the function is
terminated by double clicking the central mouse button.

– slit length minimum - On cursor Select the pixel using the crosswire cursor and a slit of
the minimum length will be drawn centred on it. The cursor will then be ready for the
next object until the function is terminated as described before.

– slit length variable - On object Selecting the object with the rectangular will define the
x-pixel of the slit. The tool will then provide a crosswire cursor for marking (left mouse
button) the upper and lower (y-pixel) limits of the slit. On completing one slit the tool
will immediately provide a rectangular cursor to repeat the process with another object.
The function can be terminated as described before.

– slit length variable - On cursor The tool provides a crosswire cursor for marking 2 points
with a click of the left mouse button. The upper pixel will define the upper slitlet limit
while the lower pixel will define both the lower slitlet limit as well as its x-pixel. On
completing one slit the tool will immediately provide a rectangular cursor to repeat the
process with another object. The function can be terminated as described before.

• Some of the commonly used functions include:

Slits → Delete

Tools → Zoom and Tools → Unzoom

Colour → Clear and Masks → Show All

Masks → Save Mask

Masks → Load Mask

• Finally after everything is done:

– Save the mask one last time and note down the mask name from the message window.

– Get a hardcopy of the image display including the slit graphics via Masks → Print Mask
(best result with slits in white). Print postscript file immediately (if it is not printed
automatically) - it will be overwritten. Mark the reference stars on it - this will be useful
while identifying them at the time of MOS acquisition during the night.

– Send the .mask file to the punching machine Fits → Send Mask mos@w3p6ins , or manu-
ally ftp the .mask file (in directoy EMOS-MASKS) to mos@w3p6ins:/vltdata/tmp/EFOSC-MASK/.

4.1.1 Some Considerations

The 3 reference stars

• should be bright (does not have to be very bright but should stand out in a 20 second exposure)

• should form a spread out triangle

• should not be located close to the margins of the CCD



6 Title of the Document - 1.0 3P6-MAN-ESO-90100-0002

• should always be centred in a slitlet of minimum length using Slits → On Object option.

Slits to the right of centre will yield a spectrum which covers a range blueward of a central slit while
those to the left will cover redder wavelengths.

There is no spatial restriction on the location of targets on the CCD other than for the reference
stars. However if you are using the narrowest punch be prepared to lose 1 or 2 objects close to the
margins of the CCD especially if your reference star locations are less than perfect.

4.1.2 MOS Mask Tool Menu Options

Listed here are the various menu options available and a brief description of the same.

File:

→ Load *.bdf Image If one wants to load the same image a second time one can load the already
existing *.bdf image instead of repeating the rotation of the FITS image described earlier.
→ Quit quits XMOS.

Slits:

→ On Cursor With this option the x-pixel location of the slitlet will be defined by the crosswire
cursor position. One will want to use this option for very faint/diffuse objects on which the next
option will not work. A click of the left button of the mouse will select the pixel under the cursor.
Any number of objects can be chosen one after the other and the function can be terminated by
double clicking the middle button of the mouse.
→ On Object With this option the x-pixel location of the slitlet will be defined by a gaussian
centroid fit to an object. The object area can be defined by the user by the help of the rectangular
cursor provided when this option is chosen. The size of the rectangular cursor can be changed using
the arrow keys to enclose as much of the object as possible while excluding its neighbours. After
positioning the rectangle the object can be selected by clicking the left button of the mouse. Any
number of objects can be chosen one after the other and the function can be terminated by double
clicking the middle button of the mouse.
→ Delete Delete a previously defined slitlet. Select this option and left click close to an existing
slit to erase it – it will still be displayed until Colour-¿Clear and Masks-¿Show All are selected. One
can continue to delete slits one after another until terminating the function by double clicking the
middle button on the mouse.

Masks:

→ Quick Look Shows the slitlets defined so far.

→ Show All Shows the slitlets plus a pair of parallel lines extending all across the CCD defining
the upper (yellow) and lower (green) extent of the slit. This is useful to see if there is an overlap
between slits which is to be avoided.
→ Load Mask Pops up a panel to select a previously defined mask (./Image R#.msk) for display
and further editing
→ Reset Erases all the slitlets defined so far. Previously unsaved work will be lost.
→ Edit Mask Pops up an ascii editor of the mask file.
→ Print Mask In an ideal world dumps the display (the background image + defined slits) on to
the nearest printer. However for the moment it only creates a postscript file in the current directory
(always named screen34.ps - will be overwritten each time this option is selected). This file can be
printed with the command lp screen34.ps. It is important that the image display is in the front of
the screen, and not obscured by another window. (Oct 2002: the printer is not setup on wlsmos at
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the moment– please ftp the postscript file to another computer for printing.)
→ Save Mask This saves the existing slitlet configuration into 2 equivalent files: ./Image R#.msk
and EFOSC-MASK/Image R#.mask. The first file is comprehensible to the MOS mask defining tool
(can be reloaded for further work using Mask-¿Load Mask) while the second is to be used for actual
punching (i.e. the file which is sent by Efosc-¿Send Mask to mos@w3p6ins:/vltdata/tmp/EFOSC-
MASK/). Every subsequent saving of a mask file for the same image will increment the number in
mask name.

Tools:

→ Zoom Use this to zoom in on a subsection of an image - useful in selecting blended objects and
careful placing of slits such that they do not overlap. Select this option and then define the zoom
area by clicking the left mouse button on the two opposite corners. The zoom will always maintain
the aspect ratio.
→ Unzoom Select this to display the whole image. Note that when this option is used all the
graphics will be cleared and will have to be displayed again.
→ Scroll Use this to change the centre of display. Select this option and click left mouse button on
the desired location to move it to the centre.
→ Next Slit Scrolls the display such that the next slit moves into view (in a zoomed display, for
example).
→ Cursor Cut Use cursor to define low and high cut value on image.
→ Cut Useful (though rather unwieldy) for changing the intensity cuts of the image display. Select
this panel and left-click on two pixels - the intensities of the two pixels will define the lower and
upper intensity limits with which the image will be redisplayed.
→ get/cursor Read cursor coordinates from image display system.

Colour:

→ Different colours in which slitlets can be shown.
→ Clear Selecting this clears all graphics - the only way to remove dead wood. Deleted slitlets will
remain on the display until they are Cleared and the redisplayed using Masks-¿Show All

Options:

→ Slit Length Has two sub-options:

→ Minimum The slit length defined is the minimum for to the length of the punch tool used
→ Variable The slit length is defined by the user. Care should be taken to ensure that this

length is longer than the minimum length of the punch tool.

→ Punch Tool This should not be changed for any single mask and has to be defined at the beginning
before loading the image. It has 3 sub-options :
#1: 1.15” width / 7.8” length at EFOSC2
#4,5,8: 1.35” width / 11.5” length at EFOSC2
#6,7: 1.75” width / 11.5” length at EFOSC2
#3: is not a valid EFOSC2 option

→ Distortion Correction has no effect as of now– set it to NO.

File:

→ Load and R90 EFOSC*.fits Image The slits are defined in XMOS along the vertical direction.
Thus an EFOSC2 image has to be rotated by 90 deg to make it compatible with XMOS convention.
This option pops up a file selection panel and the selected FITS file is rotated and converted into a
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MIDAS file (Image R##.bdf) and loaded on the XMOS display.

→ Send Mask Files to mos@w3p6ins This option pops up a file selection panel to send the slitlet
mask files (EFOSC R#.mask in the sub-directory ./EMOS-MASK) to
mos@w3p6ins:/vltdata/tmp/EFOSC-MASK. This is to be carried out at the end of the slit design
process. If for whatever reason this does not work contact the support astronomer and/or do this
FTP manually.

4.2 Punching the slitlets

The machine to punch the masks and its computer are physically situated in the 3.6 telescope
building in the small room adjacent to the 3.6m control room (3rd floor). The whole punching
process is usually performed there.

4.2.1 Starting the MOS Punch Control Panel

The MOS punch control software (see Figure 2) will usually be started by the support astronomer.

If the punch control panel is not running, check STAP wheel lock pin OUT and the X/Y table on
PARK position, log into the w3p6ins as user mos, open an xterm, and type efoopsMosMaint.

If a cold start is needed go to MosInit and select mosInitRun .

Use button Change Ins to select either EFOSC2 or EMMI RILD.

4.2.2 Prepare the MOS mask plate

The mask plate consists of the actual mask surrounded by a strip of protective material. The support
astronomer will demonstrate the preparation of the mask plate. It is essential that the user follows
all the steps carefully else the punch head may get damaged during the punching process.

4.2.3 Do the actual punching

MOS mask plates have to be mounted on the punching machine. Select the desired stap position (pos
2 - 5) and click on loadPlate . Loosen the holding screws, slide in the mask plate with the correct
orientation as shown in Figure 3 and tighten the screws. Do not hold the plate while tightening the
screws or else it might flex. The MOS mask plate should be inserted into the punching machine the
right side in (left-to-right and top-to-bottom). The white cross on the plate has to be face down on
the EFOSC aperture wheel.

Click loadMaskTab to load the mos table.

Click StartPunch to perform the actual punching.

After the punching is done the stap position is moved back so that you can take the mask out.

The MOS mask also has an upper side and a lower side, the adjectives refering to the way the mask
is inserted into EFOSC2. It is essential that the user identifies the upper side - writing the target
field name on the upper side of the mask is a good practice - which has to be done before the user
separates the mask from the protective strip surrounding it. The way to identify the upper side is
also indicated by an image stuck on the wall above the machine.

Remove the tape from the mask plate - keep it pressed flat on the table while doing so to avoid
flexing the mask.
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Figure 2: The MOS punch control software tool
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Figure 3: How to load a plate into the punch machine

Separate the mask from its outer protective strip - there is a small punching machine (not to be
confused with the MOS slitlet punching machine) which is to be used for this. The mask plate has
to be inserted into this punching machine with the right orientation.

4.3 Loading the Mask

The MOS masks will be loaded into the instrument by either the telescope operator or the support
astronomer. Make sure that the lower side of the plate is clearly marked on it.

The telescope needs to be parked in the zenith position before the instrument can be accessed and
this takes a while. One should minimise the number of occasions a mask is loaded during the night
to avoid loss of observing time.

Each MOS mask is loaded into a numbered slot on the slit wheel and the numbered slot is provided
a name in the instrument database (the name will be of the form MOS#n, n : 1-5). The template
definition (in P2PP) is in terms of MOS#n while the instrument recognises only slot numbers on
the slit wheel. The operator will update the database mapping one to the other. Observers with
multiple masks in their programme should keep track of the mapping between their target field name
and MOS#n and provide clear instructions to the observer as to which mask should be associated
with a particular MOS#n.

5 Calibrations

5.1 Checking Slitlet Overlap

The first thing to be checked as soon as the mask is loaded into the instrument is that there is
no overlap between the spectra of adjacent slitlets along the spatial direction. The slitlet defining
software checks for and eliminates overlapping slitlets but the user can override this check (user
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Figure 4: A typical P2PP panel for a MOS mask image.

beware!). The other reason why overlaps occur is because the slitlets were defined using a smaller
punch head than the one actually used for punching.

There is no template for making this check - but a simple way is to do this (or rather request the
telescope operator/support astronomer) is to directly use the OS panel. Select the appropriate grism
and MOS plate (filter free) and take a 10-20 second exposure with the quartz lamp on. Any overlap
between adjacent slitlets will be immediately obvious as the image is displayed on the RTD. In case
of overlap, the observer has to decide whether the mask is still acceptable or a new one has to be
made - hence the admonition to reach La Silla with time to spare!

5.2 Mask Image

The MOS acquisition template works by matching an image of the sky with an image of the slit-
let mask. Using 3 reference objects (usually stars) and their corresponding slitlets, the procedure
calculates the rotation and translation of the telescope field required to align the objects and the
slitlets. For this, the procedure looks for an image of the slitlet mask (EFOSC ImaInt.#.fits) in the
directory w3p6ins:/vlt/insroot/SYSTEM/DETDATA.

This is actually the directory where images observed on the current day are stored. Thus all one
needs to do is take an internal image of the slitlet mask on the same day (during the afternoon or
the same night) and the image file will automatically be placed in the proper directory. In case of
many internal images the user will have to note down the correspondence between the target field
(MOS#n) and the internal image name. This information should be provided to the acquisition
procedure in a panel which pops up demanding the same.

Fig. 4 shows a typical P2PP panel for a MOS mask image. Do not change any of the parameters on
the P2PP panel except for the Slit (i.e. choose some other MOS#n as necessary).

5.3 Other Calibrations

The rest of the calibrations including bias and darks, flat fields, wavelength calibration (He-Ar
lamps) are identical to those needed for long slit spectroscopy and the observer is referred to the
corresponding section in the EFOSC user manual [1]. The only difference is that one has to choose
the appropriate MOS#n for the Starplate in P2PP instead of a long slit.

Note that usually MOS slitlets are not all aligned along the central column and so different slitlets will
cover different spectral ranges. One may have to take a few more arc lamp exposures to compensate
for the reduction in photons for slitlets whose spectra has shifted towards the blue.

6 Science Observations

6.1 Acquisition Template

The MOS acquisition procedure is as follows (after the normal Preset and Focus):

Rotation to align the slitlet mask with the objects

• The acquisition image is displayed and the user (or rather the telescope operator) is asked to
select the three reference stars by clicking on the screen.
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• The mask image is displayed next and one has to select the corresponding 3 slits in the same
order as the reference stars - this step is only done once during the procedure and the slitlet
locations are stored for use during later iterations. Right at the beginning, before the Preset
and Focus, the procedure asks for the name of the slitlet mask image.

• The procedure calculates the rotator offset angle required to align the slitlet mask with the 3
reference stars and then offers the following options:

– rotate and move on to the next step in the acquisition procedure (rotation < 1 degree)

– rotate but take one more acquisition image to make sure the rotation worked fine

– do not rotate but move on to the next step in the acquisition procedure (if the offset <
0.1 degree)

– abort the entire OB.

Translation to move the objects into the slit

• The acquisition image is displayed and the user (or rather the telescope operator) is asked to
select the object by clicking on the screen

• The procedure calculates the telescope offset required to move the object to the x-pixel defined
in the template and on the y-column where the slit is located. It then offers the following
options:

– offset and exit from the acquisition procedure (when the shift is less than 1-3 arcsec
depending on the size of the slit),

– offset but take one more acquisition image to make sure the shift worked fine,

– do not offset but exit from the acquisition procedure (if the offset was very small, say ¡0.1
arcsec, for example),

– abort the entire OB.

The FITS file is named EFOSC AcqMOS.fits

Image through the MOS mask

Usually, aligning the slitlet mask using the 3 reference star works very well. However sometimes
observers tend to live on the edge by choosing stars on the CCD margins (where the distortion is
greater) and/or putting targets at the edges of the slits. On such occasions some of the targets may
not fall on the corresponding slitlets, especially when narrow slits have been punched (we have never
had this problem for the 1.75” slitlets). In order to be sure that all or at least the crucial objects are
on the slits, especially for long integration spectra we recommend that observers take an exposure of
the field through the slit after the acquisition template and before the spectral templates.

This is a regular Spectrocopy template (Efosc spec obs Spectrum) with the starplate set to MOS#n
and the Grism set to Free.

After confirming that the objects are all located where they ought to be one can then relax with nary
a worry for the next hour or two ..... OR decide, if you so wish, to repeat the acquisition procedure
all over again!

Spectra

The MOS science spectroscopy templates are identical to the ones for long slit spectroscopy except
that one uses a MOS mask for a starplate instead of a long slit.
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Figure 5: A P2PP observing block for MOS.

A typical MOS observing block includes an acquisition template, followed by an image of the field
through the slit, and finally the science spectra. Note that one can combine templates with different
grisms. Figure 5 shows an example of an OB comprising a sequence of:

• An acquisition sequence for Mos#4 with a R filter, a 45 second exposure and a rotator offset
angle of 40 degrees (i.e. slit position angle = 40 + 90 = 130 degrees)

• Note : the rotator offset angle has to be set to the value used for the pre-image.

• An image through the MOS mask Mos#4 with a 45 second exposure and R filter.

• 1 spectrum of 1200 seconds with Mos#4, Grism Gr#12, normal readout, no filter and 2x2
binning; followed by

• 1 spectrum of 1800 seconds with Mos#4, Grism Gr#7, normal readout, no filter and 2x2
binning.

Now, all you need are CLEAR SKIES!

oOo
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