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SoftScore - Music notation for the iPad
Welcome
SoftScore is musical notation editing and display application for the Apple iPad.
SoftScore is designed to provide musicians with a portable solution to replace printed 
paper score sheets. SoftScore takes full advantage of the Apple iPad's large screen, high 
quality graphics and light form factor to provide and editable notation application for 
performing musicians. The iPad comfortable sits on a music stand and thus replaces the 
need for printed scores.
The scrolling capability of the iPad allows the musician to view notation in a continual 
vertical form avoiding the inconvenience of pages turns that can distract concentration.
SoftScore supports single instruments and is suitable for monophonic instruments (i.e. that 
play single concurrent notes) such as the flute, saxophone, violin, oboe, brass etc. 
SoftScore provides full transposition though all twelve keys - a particularly useful tool for 
transposed instrument players.
SoftScore is also an ideal tool for teaching - both for musical performance and musical 
theory. With IOS 4.3 and higher the Apple iPad may be connected directly to a projector or 
wall mounted Television making it the perfect class room teaching tool.

PDF Viewer and Notation Editor

SoftScore is both a PDF viewer and a musical notation editor. In PDF mode SoftScore 
allows the musician to display standard formatted PDF music files. By switching to the 
Notation editor the user is able to create and edit standard musical notation and display 
the resulting score in landscape or portrait orientation during performance.

SoftScore Views
SoftScore has three primary views: Performance, Notation Edit and PDF View.
Each view is specifically designed to provide a specific, simple and intuitive interface. 
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Performance View

Performance view is design for the displaying the 
score for the purpose of performance.
In Performance Mode the space provided to the 
score is maximized without the distraction of 
unnecessary menus and the score is locked to 
prevent accidental edits thus allowing the musician to 
focus fully on the music and not be distracted by the 
application.

In this view scores can be scrolled manually or 
automatically - thus allowing hands free 
performance.

In Performance View the functionality remains the 
same in both portrait and landscape orientations 

Main Menu

The Main Menu is located at the bottom of the Performance View Screen.

! ! ! ! ! ! Main Menu
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File Menu

The file menu provides access to the following 
functions:

Open, New, Save, Save As and Clear as 
described below

! File Menu

Open

To open an existing song file, tap on the Open 
button to reveal the  Documents folder.
To open a song file tap on song’s name.

If the song is of file type .smn the Notation 
Editor/ viewer will be launched. 

If the song file type if .pdf the PDF viewer will 
be launched.

Documents Menu
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New

To open a new song tap the New button in the File Menu. The New song dialog will 
appear .

     ! ! ! New Song Dialog

To create a new song, enter the Song Name, Composer, Tempo, Time Signature Key and 
Clef and tap the Create Song button. With the exception of Time Signature all these values 
can be changed later.
If the previous song has not been saved you will receive a warning. To exit this dialog 
without changing the current song click on the screen outside this dialog.
Tapping Create Song will erase the current song and start a new song.
When a new song is created it must then be manually saved, as described below to create 
the song file.

Save

To save the current song tap on the Save button. The song will be saved to the song file 
and the user is returned to the song.
When a song is saved for the first time, the Save As dialog will be displayed.
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After a song is Saved for the first time the file name is display 
in the top left of the score.

Save As

To save the current song with a different file 
name tap the Save As button in the File Menu. 
The following dialog will be displayed.

Select the desired song name and tap Save. It 
is not necessary to enter the file suffix (.smn) 
as this will be added automatically.

Documents Dialog - Save As

Clear

To clear the contents of the current song tap the Clear button in the File Menu.
All notes, rests, chords and ties will be removed. The song title, composer, time signature, 
tempo and key will remain unchanged.
The song file (if the song has previously been saved) will remain unchanged until a 
subsequent Save is performed.
To revert to the previous song, before a Save is performed, simply go to the File Menu and 
select Open as described earlier.
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Deleting A Song File

To delete a song file tap the Open button in the 
FIle Menu. In the Documents folder that opens 
right swipe on the song that you wish to remove 
and select delete to confirm.

Documents Dialog - Delete Song
Edit Menu

Tapping on the Edit Menu button opens the current score in the Notation Edit view. Refer 
to section  ......... for more information on the Notation Editor.

Auto Scroll - start, pause, rewind, speed

The Pause / Rewind and Start Scroll / Speed 
buttons allow the user to control the scroll 
function. The Scroll function automatically scrolls 
the page so the performer does not have to 
manually scroll or turn the page.
Tapping on the Start Scroll / Speed button will 
start the score scrolling. To adjust the scroll 
speed, tap on the Start Scroll / Speed button a 
second time and a speed control will appear as 
shown in the diagram.

! Auto Scroll Controller

User Preferences

Tapping on the User Preferences button opens the preferences and user guide view as 
seen below.
The user preferences view allows the user to change sound settings and display the user 
manual.
These settings are saved on exit and affect all scores i.e. they are specific to the 
application and not to the individual scores.
To return to the Notation Editor view tap on the Done button.
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! ! ! ! ! User Preferences Dialog
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Notation Editor View

The notation editor provides an intuitive 
interface to allow the user to rapidly 
create and edit musical scores.
To enter the Notation Edit select EDit 
from the Main Menu.
For simplicity all editing is performed 
within the space of each bar i.e. edits 
made in one bar will not affect other bars.
Note and rest durations between a semi-
brev (whole note) and semi-quaver 
(sixteenth note) are supported including 
dotted values. The editor also supports 
triplets, ties and chord names. For full 
specifications please refer to specification 
section at the end of this document.

! Landscape Notation Edit View

SoftScore incorporates an automatic bar completion function. Whenever the duration of a 
note is changed the subsequent notes in the same bar will be immediately corrected to 
maintain the musical integrity of the bar.

Similarly, rests are automatically joined to simplify the score and to make sight reading 
easier. In 4/4 timing the third beat of the bar is left exposed in line with engraving 
standards

Selecting notes

Notes may be selected individually or as a group. A group of selected notes can be raised 
or lowered in pitch in semi-tone or octave steps.
To select a note or rest simply tap on the main body. When selected a note will change 
color to blue to show that it is the currently selected note. Note edits, as described below, 
are always performed on the currently selected note. 
To select a group of notes select the first note in the group by tapping it and then select the 
second (subsequent note) note by double tapping it.
To deselect a note or a group of notes tap on another note or rest.

Note Inversion

Notes are automatically inverted when they pass the middle of the stave. Notes that are 
part of a beamed group will invert when the average pitch of the group is above the middle 
of the stave

Editing individual notes

All note changes are made from the Edit Menu as described below.

Edit Menu
In landscape orientation the Edit Menu allows the user to add and delete notes (by 
changing duration), change notes to rests (and vise versa), raise and lower the pitch of a 
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note in semi-tone or octave steps, to step to the next or previous note, to set a note to 
display it’s enharmonic value and to play back and pause the score.

! ! ! ! ! Landscape Edit Bar

Duration

To change a notes duration, select the note by tapping on it or using the Next / Previous 
Note buttons and then tap the appropriate Duration Selection button. The note’s duration 
will change. 
If the selected duration is less than the current note’s duration then a rest will be 
automatically added to fill the missing duration and maintain the musical integrity of the 
bar. If the selected duration is greater then the duration of the current note then 
subsequent notes/rests will be deleted to provide the additional space.
Should a selected note duration exceed the length of the bar then an error sound will be 
heard and the note will remain unchanged. 

Changing a Note to a Rest and vise Versa

To simplify the user interface, musical rest duration buttons are not provided.
To create a rest, first create a note of the same duration and then tap the Change Note / 
Rest button. Like wise a rest can be changed to a note of the same duration by selecting it 
and tapping the Change Note / Rest button.

Ties

To add a tie to a note, select the note and tap the Tie button. If there is not a subsequent 
note that is of the same musical pitch then an error sound will be heard and the tie will not 
be added.
Ties may be added over bar and line breaks.

Triplets

To add a triplet, create and select a note of the full value and then tap the Triplet button.
For example to create a quaver (eight note) triplet select a crochet (quarter note) and tap 
the Triplet button.
To remove a triplet, select the first note in the triplet and select a new duration.
Crochet (quarter note), quaver(eight note) and semi-quaver(sixteenth note) triplets are 
also supported.

SoftScore Version 1.31 release 004

12



Add / Delete Bars

To add or delete a bar, tap on the Add Bar or Delete Bar button accordingly. When a new 
bar is added it is placed immediately before the current bar. When deleting bars the last 
bar in a score cannot be deleted.

Pitch 

When the first note in a song is created it’s pitch is set to the pitch of the selected key. 
Subsequent notes are set to the pitch of the previous note.
To change the pitch of a note tap the semi tone up / down buttons or the octave up / down 
buttons. Alternatively, (in landscape mode only) tap the required pitch on the virtual 
keyboard.

Auto Step

Auto Step automatically steps the selected note (or rest) to the following note (or rest) 
when an edit is made. In most cases this allows for faster input.
Auto Step can occur after either a duration change or when a pitch is set on the virtual 
keyboard - therefore there are two Auto Step buttons - one on the left for duration changes 
and one on the right next to the virtual keyboard for pitch changes.

To turn Auto Step on or off, simply tap the appropriate button. Green indicates that Auto 
Step is turned on.

Enharmonic Values

An enharmonic value is a musical alternative visual representation of the same note. For 
example a Bb may also be written as an A#. Enharmonic values are often used to improve 
the readability of a song.
As an example, if an A# is followed by an A natural and then by another A#, three 
accidentals are required i.e. two sharps and one natural. However if the A#’s are shown as 
Bb’s (thus moving them up to the B line of the stave) only one accidental is required - i.e. a 
flat.

SoftScore provides the option of displaying a note in it’s enharmonic mode. Note that 
switching to an enharmonic value does not change the pitch (sounding) of the note.

If a note has an alternative enharmonic value the Show Enharmonic On / Off button will 
displayed. Tapping the button will shift the note to it’s enharmonic value.

Audio PlayBack

To playback the score tap the playback button. The playback will begin from the currently 
selected note or rest.
To pause play back tap the pause button.
To return to the beginning of a paused song tap the pause button a second time. 

Returning to Performance View

Once you have finished editing the song tap the check mark in the bottom left of the Edit 
Menu to return to Performance View.
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Chord Name Editor

To enter the Chord Name Editor tap on the Chord Entry button on the far right of the Edit 
Menu. The functionality of the Chord Entry Edit Bar are described below.

Chord Entry Edit Bar

! ! ! ! ! ! Chord Entry Bar

To enter a chord name, first select the note and then tap on the respective Chord Root 
Selector Button. To add a chord suffix tap on the respective Suffix button.
To clear a chord name tap on the Clear button.

When a Chord Root button is tapped the previous chord name and suffix is erased.

Whilst in the Chord Entry editor, note pitches may be raised or lowered in semitones or 
octaves using the Up / Down arrowed buttons.

To select the next note tap on the Next / Previous button.

To return to the Edit Menu, tap on the Return to Edit Bar button on the right of the bar.

{ Chord Root Select
Octave 

Up / Down
Semi-tone
Up / Down

Step to 
Next / Previous

Note

{
Chord Su!x Select

Clear

Playback / Pause

Return to
Edit Bar
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Changing Key and Clef
To change the key or clef, double tap on the area between the clef 
mark and the time signature.

The following dialog will open.

! ! ! ! Key and Clef Change Dialog

Changing Key 

Select the desired mode (Major or Minor) and key. To shift the entire score up or down an 
octave select the -1 or +1 buttons.
If the key signature is left unchanged and the octave shift is selected the entire score will 
be shifted up or down an octave without changing key.
To execute the changes tap Save.
If after the song has been transposed some groups of notes are too high or too low then 
group select them as described in .......... above and shift their pitches up and down using 
the arrow buttons on the edit menu.

Changing Clef

To change the song clef (Treble or Bass) select the appropriate button in the dialog above.
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Existing notes will remain in the clef range that they where added in and may need to be 
lowered or raised in pitch to bring them into the appropriate clef.

Changing the Tempo
To change the song tempo double tap on the tempo mark at the 
top left of the score.

The following dialog will open:

! ! ! ! Tempo Change Dialog

Adjust the slider to the required tempo and tap the Select tempo button. The tempo 
determines the song audio playback speed.
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Bar line, Repeat Bars and System Symbols
To change bar line type, repeat bars and system symbols double 
tapping on the appropriate bar line.

The following dialog will open:

! ! ! ! ! Bar Line Edit Dialog

Changing the bar line type

To change the bar line type, e.g. single, double, repeat, final, etc, simply rotate the picker 
wheel to the required bar line. 

Changing first and second time repeat bars

Select the appropriate number of repeat bars before and after the current bar. Up to nine 
repeat bars can be selected. Repeat bars are not recognised during audio playback.

System Symbols

A variety of system symbols are available and may be selected by tapping the appropriate 
button. To remove a system symbol simply select ‘none’. 

Bar Line 
Selector {1st and 2nd Time  

Repeat Selectors 

System Symbol 
Selector 
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Song Preferences

To edit the song preferences tap on the info button at the top left of 
the score.
Song preferences allow for changes to the number of bars 
displayed per line and whether or not enharmonic values are 
displayed in the score.
Song preferences are saved with the current score and do not 
affect other scores.

The following dialog will open:

! ! ! ! ! Song Preference Dialog

Bars Per Line

SoftScore layout scores with a set number of bars per line. This value can be set for both 
portrait and landscape orientations.
To set the required number of lines simply tap on the appropriate button.

Global Enharmonics

SoftScore supports enharmonic note display as described earlier. To turn this function on 
or off use the Global Enharmonics button. When Global Enharmonics is set to OFF all 
notes will be shown in their standard representation relative to the key signature on the 
stave.
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PDF View

SoftScore supports pdf file 
display in portrait and 
landscape view.
To open a pdf file select Open 
from the File Menu and select 
the appropriate file from the 
Documents list.
The selected PDF file will be 
displayed.

To close the PDF file tap the 
Exit button and SoftScore will 
return to the Performance 
View.

PDF Viewer - Portrait
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File Transfer
SoftScore currently allows the transfer of song files, in .pdf or .smn format. from an iPad to 
a MAC or PC via iTunes File Sharing.

iTunes File Sharing

! ! ! ! ! iTunes File Sharing

With the iPad connected to your MAC or PC, open iTunes and select your iPad under 
devices in the left hand column - 1.

Click on Apps - 2, then select SoftScore in the File Sharing area- 3. If File Sharing is not 
visible you may need to scroll iTunes down.
Your SoftScore files are now displayed in the SoftScore Documents area - 4. 

To transfer files from iTunes (on you MAC or PC) to your iPad, simply drag and drop them 
into the SoftScore Documents area - 4.

When the iPad is connected to iTunes the files will be immediately synchronised to your 
iPad. Note that you do not need to perform a manual Sync.
In a similar manner, with the iPad connected to iTunes file changes in SoftScore’s iPad 
documents area will automatically be synchronised to iTunes.
If your iPad is not connected and file changes are made, either on in iTunes or on the 
iPad, then they will be synchronised next time the iPad is connected.
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It should be noted that if file changes are made to the same file in both iTunes and in 
SoftScore, next time the iPad is connected there will be a conflict between the two version 
of the same file and changes made be lost.
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Specification
Version 1.31 supports the following:

Devices: iPad and iPad 2 
Note Durations : Whole Note (semi-brev) to 16th (semi-quaver) including dotted 

durations.
Clefs: Treble
Voices: Single
Time Signatures: 2/2, 3/4 and 4/4
Tempo: 20 - 300 bpm
Bar Line Types: normal, double, final, repeat start and repeat end
1st and 2nd time repeat bars
Screen Orientation: Portrait and Landscape
File Types: PDF and .SMN (SoftScore Music Notation) notation files
Auto beaming: 8th and 16th note (quavers and semi quavers)
Triplets: 1/4, 1/8 and 1/16 note (crotchet, quaver and semiquaver)
Keys: Twelve Major and Minor
Transposition: Through twelve keys with +/- octave pitch shift
Select: Single and multiple note selection
Pitch: C1 - C8 (notes below C4 are currently off stave)
Ties: including tie across bar line and new line.
Auto Scroll: In performance mode with variable scroll speed
Play Back: Audio playback in notation mode
Layout: add and delete bars. User defined number of bars per line
Bars Numbers
Song data: Song Title and Composer.
Sharing: iTunes File Sharing
File Management: Open, New, Clear, Save, Save As, Delete (swipe)
Help files included: Yes
User preference: system and note sounds on/off
Note tail inversions
System symbols: Coda, Segno, D.S, D.C, al Fine, al Coda, Fine
Bass clef
Chords names
VIrtual Keyboard Input
Enharmonic Note replacement (manual) Bass clef
Chords names
VIrtual Keyboard Input
Enharmonic Note replacement (manual)
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