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SHIPCONSTRUCTOR LICENSE AGREEMENT

BEFORE PROCEEDING WITH THE INSTALLATION, YOU MUST ACCEPT THE TERMS OF 
THIS AGREEMENT. INDICATE YOUR ACCEPTANCE OR REJECTION OF THIS 
AGREEMENT BY CLICKING ON THE APPROPRIATE BUTTON. IF YOU CLICK ON 
“REJECT,” INSTALLATION WILL ABORT.

1. License Grant.  ShipConstructor Software Inc., #304 – 3960 Quadra Street, 
Victoria, B.C. Canada, V8X 4A3 (DBA SSI) grants to the person accepting this 
Agreement (the “Licensee”) a non-exclusive, non-transferable right to use (the 
“License”) in object code form those program modules, application programming 
interface (“API”), any other materials provided by SSI under this Agreement, and all 
upgrades, revisions, fixes, updates or enhancements to any of the foregoing 
(“Licensed Materials”) specified in the Licensee’s purchase order or request 
(“Invoice”) solely on the software and hardware listed in the Licensed Materials 
manual (“System Configuration”).  

2. Academic Institutions/Trial Versions.

A. In the event that the Licensee qualifies as an academic institution user in 
accordance with SSI’s specifications (an “Academic Licensee”), the Academic 
Licensee and its faculty, employees and students may use the Licensed Materials 
for the singular purpose of either teaching, training users or undertaking 
research provided that the Licensed Materials, and all copies of the Licensed 
Materials, remain at all times at the Academic Licensee’s premises and the 
Licensed Materials are used for no other purpose than that set forth above. The 
above restrictions are in addition to the restrictions on use set out in Section 5 
below.

B. In the event that the Licensee receives a trial version of the Licensed Materials 
for evaluation purposes, the terms and conditions of this Agreement, excluding 
Sections 15-19, shall continue to apply subject to the following provisions:

(a)    the License pursuant to Section 1 above shall terminate at the end of 
the specified trial period;

(b)    the Licensee shall return the Hardware Key to SSI immediately upon 
expiry of the specified trial period and in any event within 28 days of 
the expiry of the specified trial period;

(c)    in the event that the Licensee does not return the Hardware Key in 
accordance with Section 2B.(b) above, SSI shall be entitled to invoice 
the Licensee for and the Licensee shall pay for the costs of the 
Hardware Key plus all shipping and handling expenses and SSI 
administrative charges; and
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(d)    in the event that the Licensee elects to and does acquire a License, the 
terms and conditions of this Agreement, excluding Section 2B herein, 
shall continue on and apply.

3. Ownership.  All rights, title and interests in and to the Licensed Materials and related 
documentation shall remain the sole property of SSI.  Licensee shall not remove or 
alter any proprietary rights notices on the Licensed Materials and the 
documentation, and shall reproduce such notices on any copies that it makes.  
Licensee shall be liable for the security of the Licensed Materials and the 
documentation in its possession.

4. Expertise Required.  Licensee is responsible for evaluating whether the Licensed 
Materials meets Licensee’s requirements, and for operating the Licensed Materials 
and the results obtained.  The Licensed Materials are intended for ship modeling and 
construction purposes only, and must be used by a person who has expertise and 
knowledge in this field. The Licensed Materials requires independent confirmation of 
the reliability and accuracy of all designs, drawings and other Licensed Materials 
output. An SSI representative may be made available under a separate consulting 
agreement, at the Licensee’s request to provide training and consultation on the 
operation or integration of licensed materials.

5. Limitations on Use.  

Licensee shall:

(a)    not make more copies of the Licensed Materials than are necessary for the 
Licensee’s installation of the Licensed Materials and shall only create 
backup copies for archival or emergency restart purposes;

(b)    maintain a log of the number of and location of all originals and copies of 
the Licensed Materials;

(c)    include SSI’s copyright, trademark and proprietary notices on any 
complete or partial copies of the Licensed Materials in the same form and 
location as the notice on any original work;

(d)    not attempt to defeat any copy protection;

(e)    not modify, any documentation, including any user manuals;

(f)    not modify, translate, reverse engineer, decompile or disassemble the 
Licensed Materials;

(g)    not sublicense, transfer, assign, sell, loan, rent or lease the Licensed 
Materials other than as permitted in this Agreement;

(h)    use the Licensed Materials for its own internal use only;

(i)    not permit any third party to use the Licensed Materials; and
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(j)    thoroughly test any and all custom interfaces in accordance with general 
engineering principles.

6. Delivery and Installation.  All Licensed Materials will be delivered in an electronic 
format by media or method as SSI may elect and will be sent to the Licensee’s 
designated email address or shipping address as specified in the Invoice.  Licensee 
agrees to be responsible for installation of the Licensed Materials.

7. Term of License.  The License term commences on the delivery of the Licensed 
Materials to the Licensee, and, subject to Section 2B above, is either perpetual if so 
requested on the Order, or on a month to month rental or lease basis. If Licensee 
chooses a lease option the license converts to a perpetual term on Licensee’s 
payment of the balance of the perpetual License fee (prior monthly payments 
receiving 80% credit).  All Licenses are subject to termination in accordance with 
this Agreement.

8. System Configuration.  Operation of the Licensed Materials requires use of the 
specified System Configuration, which Licensee shall acquire and implement.  SSI 
shall not be responsible for any operational problems caused by the System 
Configuration.

9. Security.  The Licensed Materials includes security elements which support the 
detection of unauthorized use or copying of the software and which may (a)report 
such unauthorized use or copying to the Licensee, and (b)if applicable based on 
Licensee’s configuration, may report back specific user information such as User 
name and email address.

10.Hardware Keys.  Licensed Materials use requires “Hardware Keys” supplied by SSI, 
which can be used only at the site(s) authorized by SSI.  In the event of a failure of 
the Licensee’s System Configuration, the Licensee may upon advising SSI use the 
Hardware Keys and Licensed Materials on another system and/or location.

11.License Fees.  Licensee shall pay to SSI the License fees applicable for the Licensed 
Materials as set out in and in accordance with SSI’s Invoice.  

12.Services.  Support services after the Warranty Period (as defined in Section 15 
below) are provided by SSI under the terms of the SSI Subscription Agreement.  
Installation, consulting, training and implementation services, if requested by the 
Licensee, shall be provided by separate agreement and at an additional charge.
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13.Taxes.  All amounts payable by Licensee to SSI are exclusive of all commodity taxes, 
including but not limited to applicable sales, use, value added, custom duties, excise 
taxes and other similar government charges, all of which will be paid by Licensee.  If 
Licensee is required by law to withhold any taxes, then Licensee shall pay SSI a 
gross amount of money such that the net amount received by SSI after deducting or 
withholding the required taxes is equal to the amount of the fee originally charged 
by SSI.

14.Interest Charges.  If any amount payable under this Agreement is not paid within 30 
days of becoming due, SSI shall have the right to impose a charge of 2% per month 
(24% annually) on the unpaid balance of the amount, from the due date until the 
date of receipt of all amounts in arrears including interest.

15.Purchase Orders.  Any purchase order (an “Order”) delivered by Licensee shall at 
all times be deemed to incorporate this Agreement by reference and shall be subject 
to the applicable provisions of this Agreement.  Any provisions of an Order shall not 
apply and shall not be binding upon SSI unless they relate to information which was 
requested by SSI.  In the event of a conflict or an inconsistency between the 
provisions of an Order and the terms and conditions of this Agreement, this 
Agreement shall govern and supersede to the extent of such conflict or 
inconsistency.

16.Limited Warranty.  SSI warrants that during a period of 90 days from the date of 
delivery of the Licensed Materials to Licensee (the “Warranty Period”), the 
Licensed Materials will perform substantially in accordance with the Licensed 
Materials documentation specifications, when used in accordance with this 
Agreement on a properly operating System Configuration.  SSI’s sole obligation 
under this Warranty, and Licensee’s exclusive remedy, shall be to use reasonable 
commercial efforts to correct Errors (a bug, defect or other problem incurred by a 
user in operating the Software that prevents the Software from performing in a 
manner consistent with the applicable specifications set out in the User Manual) that 
the Licensee identifies to SSI through fixes or workarounds free of charge.  If SSI 
determines that it is unable to make the Licensed Materials perform substantially as 
warranted, Licensee may terminate the License and receive a refund of a portion of the 
License Fees paid to date.

17.WARRANTY EXCLUSIONS.  THE LIMITED WARRANTY CONTAINED IN SECTION 15 IS 
IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED.  ALL OTHER 
CONDITIONS, WARRANTIES, AND REPRESENTATIONS, EITHER EXPRESS OR 
IMPLIED, ARE EXCLUDED, INCLUDING BUT NOT LIMITED TO CONDITIONS, 
REPRESENTATIONS AND WARRANTIES RELATING TO MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE.  SSI DOES NOT WARRANT THAT THE 
LICENSED MATERIALS ARE COMPLETELY ERROR FREE OR THAT ITS OPERATION WILL 
BE CONTINUOUS AND UNINTERRUPTED. 
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18.Maintenance Services.  Licensee may elect, to obtain maintenance, support and 
upgrade services from SSI in accordance with and subject to the terms of SSI’s 
standard Subscription Agreement.

19.Loss of Data.  SSI shall not be responsible for any loss of or damage to files or data 
caused by the Licensed Materials, or be required to restore or rebuild files or data.  
Licensee shall implementing adequate backup procedures to avoid any loss of files 
and data.

20.Modifications. SSI may, from time to time, provide the Licensee with revisions to 
the Licensed Materials (the “Revised Licensed Materials”).  The Licensee shall test 
any external applications using the revised API before implementing the new 
version. While it is SSI’s intention that the Revised Licensed Materials shall be 
backward-compatible with the immediately prior version of the Licensed Materials, 
SSI does not guarantee or warrant that this shall be so, and SSI shall have no 
liability whatsoever to the Licensee for any failure of the Revised Licensed Materials 
to be backward compatible with any prior version of the Licensed Materials.  
Modifications requested by the Licensee shall be subject to prior written agreement 
as to scope and fees payable.  Ownership of all Licensed Materials modifications 
shall vest in SSI.  SSI does not warrant, guarantee or otherwise commit to 
supporting Licensed Materials that has been superseded by Revised Licensed 
Materials.

21.Confidential Information.  Each party will not use the confidential information of the 
other party for any purpose except for the purpose described in this Agreement, and 
shall not disclose it to any other person except on a confidential basis to its 
employees and representatives who have a need-to-know the confidential 
information for such purposes.  This Section 23 shall not apply to confidential 
information which (a) is or has become readily available to the public in the same 
form other than by an act or omission of the receiving party, (b) was lawfully 
obtained in the same form by the receiving party from a third party not under an 
obligation of confidence to the disclosing party, (c) was in the receiving party’s 
possession in the same and material form prior to its receipt from the disclosing 
party and did not otherwise originate from the disclosing party, or (d) is required to 
be disclosed by operation of law.
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22. Audit Rights. Upon reasonable notice by SSI, which shall be delivered on no more 
than an (annual?) basis, Licensee shall provide a signed statement verifying its 
compliance with the terms of this Agreement. SSI shall also have the right, upon 
reasonable notice and no more than on an annual basis, to inspect Licensee’s 
facilities to verify Licensee’s compliance with such terms. Any such inspection or 
audit shall be conducted either by SSI or by representatives authorized by SSI to 
complete the inspection. If such inspections or audits disclose that the Licensee has 
installed, accessed or permitted access to the Licensed Materials in a manner that is 
not permitted under this Agreement, then Licensee shall be liable to pay for any 
unpaid license fees as well as the reasonable costs of the audit.

23.Termination.  This Agreement may be terminated by either party, immediately by 
written notice, if the other party commits a breach of any material provision of this 
Agreement, including a failure to make payment when due, and fails to correct or 
rectify such breach within 30 days of receipt of the notice requesting it to do so.  
SSI shall be entitled to place time-lock devices and other disabling features in the 
Licensed Materials that become effective in the event that the Licensee has failed to 
comply with its payment obligations hereunder and as set out in SSI Invoices.

24.Effect of Termination.  Upon termination of this Agreement Licensee shall 
immediately cease using the Licensed Materials, and within 14 days of termination 
return all Hardware Keys to SSI.

25.CONSEQUENTIAL DAMAGES.  IN NO EVENT SHALL SSI BE LIABLE FOR ANY LOSS 
OF DATA OR PROFITS, ECONOMIC LOSS OR SPECIAL, INDIRECT, INCIDENTAL, 
CONSEQUENTIAL OR PUNITIVE DAMAGES WITH RESPECT TO THIS AGREEMENT 
OR THE LICENSED MATERIALS, HOWEVER CAUSED, EVEN IF SSI HAD OR SHOULD 
HAVE HAD ANY KNOWLEDGE OF THE POSSIBILITY OF SUCH DAMAGES.

26.DAMAGES LIMITATION.  THE MAXIMUM LIABILITY OF SSI FOR ALL CLAIMS AND 
DAMAGES OF ANY KIND, WHETHER FOR FUNDAMENTAL BREACH OR ANY OTHER 
CAUSE UNDER THIS AGREEMENT, SHALL BE LIMITED IN THE AGGREGATE TO THE 
TOTAL OF ALL FEES PAID BY LICENSEE.

27.LIMITATION OF NON-APPLICABILITY.  IN SOME JURISDICTIONS THE EXCLUSION 
OR LIMITATION OF WARRANTIES OR LIABILITY MAY NOT BE APPLICABLE, AND IN 
SUCH JURISDICTIONS SSI HEREBY LIMITS ITS LIABILITY TO THE FULLEST EXTENT 
PERMITTED BY LAW.
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28.Applicable Law.  This Agreement shall be subject to and construed in accordance 
with the laws of the Province of British Columbia, Canada, excluding its conflict of 
laws rules and the application of the UN Convention on Contracts for the 
International Sale of Goods.

29.References.  SSI shall be allowed to incorporate Licensee’s name in SSI’s customer 
reference list and to use it for marketing.

30.Dispute.  If any dispute arises under this Agreement, a good faith attempt to resolve 
the dispute will be made by senior management of both parties at a mutually 
agreeable site and time.  If the parties are unable to reach agreement within 30 
days after a request for such meeting, the dispute shall be referred to arbitration in 
English, before one arbitrator in Victoria, British Columbia, Canada, in accordance 
with the Commercial Arbitration Act of the British Columbia. 

31.Entire Agreement.  This Agreement contains the entire agreement between the 
parties and shall supersede all prior discussions and agreements between the parties 
regarding its subject matter.

32.Amendment.  Any amendment of this Agreement must be in writing and signed by 
duly authorized representatives of the parties.

33.Waiver.  The waiver by any party of a breach by the other party of this Agreement 
shall not be construed as a waiver by such party of any succeeding breach by the 
other party of the same or another provision.

34.Assignments.  Licensee may not assign or transfer the License or Licensee’s rights or 
obligations under this Agreement without SSI’s prior written consent, and any such 
assignment or transfer without consent shall be null and void. A transfer of all or 
substantially all of the voting stock of the Licensee shall constitute a transfer for 
these purposes and shall be subject to SSI’s prior written consent.

35.Successors and Assigns.  This Agreement will bind and enure to the benefit of the 
parties and their respective successors and permitted assigns.

36.Severability.  In the event that any provision of this Agreement is declared invalid, 
illegal or unenforceable by a court having jurisdiction, then the remaining provisions 
shall continue in full force and effect.

37.Force Majeure.  Except as related to Licensee’s obligation to make payments to SSI, 
neither party shall be liable for delays or non-performance if such delays or non-
performance are beyond such party's reasonable control.  A delayed party shall 
promptly notify the other party in writing stating the cause of the delay and its 
expected duration and shall use commercially reasonable efforts to remedy a delay 
or non-performance as soon as reasonably possible.
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38.Survival.  The provisions of Sections 3, 5, 11, 13, 14, 17 and 20-30 shall survive the 
expiry or termination of this Agreement.

39.Language.  It is the express will of the parties that this Agreement and related 
documents have been prepared in English.  C’est la volonté expresse des parties que 
la présente Convention ainsi que les documents qui s’y rattachent soient rédiges en 
anglais.
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MarineDrafting

Introduction
ShipConstructor MarineDrafting is a powerful feature that helps shipbuilders to save time and avoid costly mistakes while 
creating 2D documentation such as classification, approval, workshop, and other drawings. The tool provides the ability to 
automatically generate 2D representation views of planar areas sectioned across the ShipConstructor 3D model at user-
specified locations.

MarineDrafting produces output that is far superior compared to geometrical sections and planar projections generated 
by such AutoCAD commands as SECTION and FLATSHOT. The key advantage of MarineDrafting is that the 2D views 
display shipbuilding-specific representations of structural parts including stiffeners, plates, brackets, and faceplates. For 
example, a stiffener attached to a plate part may be represented by a single line of a custom style. Depending on 
whether the stiffener is visible or not in a particular view, the line may change its type by turning from solid to dash-type. 
If the stiffener has endcuts, the representation geometry may also include additional 2D symbols to show the endcuts.

The 2D documentation produced by MarineDrafting remains fully linked to the original 3D model. If the model changes at 
some point, it will be possible to easily update all the associated 2D views with the latest changes. Note that the update 
procedure is intelligent: it is capable of preserving all of the custom modifications applied to MarineDrafting views prior to 
the update. In addition, the Production Drawing Revisions... command allows the user to conveniently monitor changes in 
the MarineDrafting drawing introduced by the update operation.

Every bit of the representation geometry in a MarineDrafting view is a native AutoCAD object that is linked to its source 
part. This allows the user to customize the output extensively. The link also allows MarineDrafting drawings to have BOM 
tables that can automatically label 2D representations in a way similar to labeling production drawings.

The second benefit is that the user can quickly navigate to parts in the original 3D model drawing from the 
MarineDrafting drawing.

Concepts

Output Drawing
An Output drawing is a general type of a production drawing that can be generated from a combination of sources such 
as model drawings, product hierarchy assemblies, distributed systems and branches, and volume definitions. Output 
drawings can have Bill of Materials and labeling added. For the purpose of a source for MarineDrafting only the parts 
need to be present. Output drawings are accessed on the Output page of the Navigator. Output drawings can be 
organized into user-defined folders. You cannot use the folder names MD and PipeLink as these are reserved.
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Output page in Navigator

MarineDrafting Drawing
MarineDrafting drawings are generated from a single output drawing. They are located in the MD subfolder to the output 
drawing’s folder. When a new MarineDrafting drawing is created, the source Output will be automatically XRef’ed into the 
MarineDrafting drawing. The link to the Output drawing should not be removed manually.

MarineDrafting View
A MarineDrafting view consists of two components: a view control and a 2D view. Each MarineDrafting view represents 
one view of a section of the model ( eg. a frame). 
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A MarineDrafting View

View Control
The view control is a custom object that consists of a bounding box, a section plane, and a view direction arrow. It is 
placed in the area of space in the 3D model to define which parts will be used for the MarineDrafting view and for 
defining the location of the section plane where to slice the 3D model.
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Bounding Box
The bounding box defines the area of space that contains a group of ShipConstructor parts that need to be represented in 
a MarineDrafting view. All ShipConstructor parts as well as non-ShipConstructor geometry that fall within the extents, or 
intersect the extents, of a bounding box will appear in the associated 2D View when the user updates the view. The 
nearest plane of the bounding box is used to determine sectioned objects. If an object intersects both section plane and 
the near bounding box plane, the object is sectioned.

Section Plane
Along with bounding boxes, section planes are important components of the MarineDrafting view setup process. Each 
section plane goes through the parts of the 3D model. Usually, a section plane slices through one or more major plate 
parts somewhere between the two sides of the plate. For example, in a frame view, a section may be a vertical plane that 
slices though the thickness of a bulkhead. The exact location of the section plane is important as it predetermines what 
2D representations of objects captured by the view bounding box will be. For example, an object located in front or behind 
the section plane as well as an object that lies in the section plane may all have different 2D representations. The section 
plane should be close to the moldplane of the plate when the part is beveled to avoid a space between the plate and the 
shell.

The location of a section plane is defined by the position of its section plane coordinate system icon (see the definition 
later). You will want to keep each section plane coordinate system icon within the thickness extents of the associated 
bounding box. The automated creation places the section plane slightly away from the moldplane of plate parts so that 
parts just touching the plate are not sectioned.

The section plane component of the View Control is visualized by the coordinate system icon and the view direction arrow.

View Direction Arrow
The view direction arrow is placed at the center of the bounding box and touching the section plane. The arrow points in 
the same direction as the direction of view.

View Coordinate System Icon
Each view control has a view coordinate system icon. The icon defines the location of the section plane and the position 
of the origin of the output. The icon should be placed such that the section plane intersects the bounding box.

Section Plane Coordinate System Icon
The section plane coordinate system icon defines the location of the section plane of the MarineDrafting view as well as 
the origin and the orientation of the local coordinate system that applies to that view. In the 2D view, the section plane 
coordinate system icon is represented by the 2D representation view coordinate system icon.
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Origin Point Relationship between Section Plane Coordinate System and 2D View Coordinate System

2D View
2D Views are the core output of ShipConstructor MarineDrafting. Representation views contain geometry that represents 
modeled objects according to shipbuilding-specific drafting standards rather than general drafting standards.

Each 2D View is defined by its MarineDrafting section plane (see the definition later) and the bounding box (see the 
definition later). All objects contained or intersected by the bounding box are included into the 2D view. Note that 2D View
geometry may change depending on the object location relative to the section plane of the 2D view.

2D Views are placed in model space. A paperspace layout will show 2D views, Bill of Materials, and labeling.
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2D View Coordinate System Icon
Each 2D View is supplied with a coordinate system icon explaining the local coordinate system in that view. There is a 
direct correspondence between the coordinate system in the 2D view and the coordinate system in the source 
MarineDrafting section taken across the 3D model. Because 2D views are the product of the section plane definition 
process, the user cannot change the origin and direction of the local coordinate system in the 2D View. That can only be 
done in the original MarineDrafting section plane. However, the user has access to a number of other parameters that he 
or she can modify for the 2D view coordinate system icon. For example, the user can change the icon text and axis 
appearance.

Reference Line
A reference line is a custom ShipConstructor object that is an axis with important locations marked on it. Reference lines 
are meant to represent centerline, baseline, or a location for reference for a 2D view. You have an option to create 
reference lines automatically when automatically creating MarineDrafting views. Reference lines can be also be inserted 
into the any drawing as a point of reference to locations in the ship coordinate system.

Reference lines uses Hull Location Groups to indicate locations as ticks on the reference line. You can have primary ticks 
with labels that indicate the location name and secondary ticks to use as minor structure locations.

Example Reference line

Getting Started

Configuration
There are a number of steps that need to be observed to achieve desired results for MarineDrafting. This will most likely 
be an iterative process of generating views to get the desired settings.

Template Drawings
An output template drawing must exist to create an output drawing. The output template doesn’t require any specific 
settings for MarineDrafting drawings.

A MarineDrafting template drawing must exist to create a MarineDrafting drawing.

Layers
MarineDrafting uses layers extensively. The layer names are customizable using both the View Creation Settings (page 8)
and View Generation Settings (page 13). Objects generated by MarineDrafting use the BYLAYER convention so that the 
look of the 2D view can be pre-configured in the template.

Blocks
MarineDrafting uses pre-defined blocks for symbols for:

• Plate seams – the plate seam symbol is inserted automatically

• Continuous/Intercostal symbols
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• Line mode stiffener Endcuts. When a stiffener is drawn in single line mode and contains an endcut, the 
block with the endcut name is placed at the end of the stiffener. If that block does not exist one is created.

Plate seams and continuous/intercostal symbol blocks are references that exist in the 2D view so they can be updated 
without having to update the view. However, endcut blocks are placed and exploded.

Endcut Block
Endcuts are typically represented by sniped or square lines.

Orientation of stiffener for endcut block.

If an endcut block does not exist when the MarineDrafting view is generated or updated, a new block is created 
containing a vertical line.

If an endcut name contains invalid block name characters they will be replaced with underscore characters. Endcut block 
references are exploded during the generation process.

Text Styles for MarineDrafting
Text Styles are used by the MarineDrafting icon and the reference line. If you want to see the ℄ character then you should 
create a text style for one of the ISOC fonts (ISOCPEUR, ISOCP1, ISOCT,…).



Getting Started

8

Charmap program showing the centerline character

Linetypes
Special linetypes can be used in MarineDrafting. Typically hidden lines are shown with a dashed linetype. You can also 
use a center linetype for the reference lines. Remember to set up LTSCALE so the paperspace layouts look correct.
Linetypes will need to be applied to the layers that you setup for MarineDrafting.

Reference Line Styles
Reference lines can be inserted into a MarineDrafting view to represent baseline and centerline. Styles can be configured 
to show locations like frames, buttocks and waterlines. Create at least four reference line styles that represent the six 
reference lines you can need. If you want to show locations as ticks on the reference line, set those up using SC Utilities > 
Reference Lines > Edit Location Groups… (page 287).

View Creation Settings
The View Creation Settings are options available when creating a MarineDrafting view. A description of the setting is 
shown at the bottom of the dialog when the setting is clicked.

For Layer settings, you can type in a new layer name, or use one an existing one from the drop list.
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View
Minimum Area for View Creation – Plate parts are used for the automatic creation of MarineDrafting views. This setting 
allows some control of what plate parts generate views. Since you probably don’t want every bracket to define a view set 
this value to an area large enough to avoid creating those views.
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Bounding Box Depth – The depth of the bounding box contributes to determining which parts are used in a 
MarineDrafting view. Parts are sectioned if they intersect the front plane of the box and the section plane. The bounding 
box can be resized after creation using the grip points on the box.

Layer – The layer to place new view control objects. 

Default Direction – Sets up the view direction for each of the view types when a view is created. The view direction can be 
changed after a view is created. Only perpendicular view directions are supported.

2D View Coordinate System
Size – The size of the 2D View coordinate system.

Text Margin – The distance of the text below the 2D View coordinate system origin.
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Text Size – The size of the text for the label of the 2D View coordinate system object. The text size can be customized to 
have various heights by using the MText formatting code.

Text Style – The text style of the text for the label of the 2D View coordinate system object. The text font can be 
customized to have alternate fonts by using the MText formatting code.

Layer – The layer to place 2D View coordinate system objects during creation of views.

Geometry Margin – Distance of the 2D View coordinate system origin from the lower left corner of the extents of the 2D 
View.
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Placement
Gap between Views – The vertical distance between the extents of tiled 2D View views.

Gap between View Types – The horizontal distance between the extents of the columns of frames, longitudinals, and 
decks.

View Name Strings
The view name strings can contain special fields that are replaced when the view is created. The strings can use AutoCAD 
MText formatting conventions.

<POSITION > - Uses the position of the section plane from the origin. The field allows for linear units and precision 
arguments that are specified with %lu and %pr respectively.

The following table lists the valid values for linear units argument. 

Value Description

1 Scientific

2 Decimal

3 Engineering (feet and decimal inches)

4 Architectural (feet and fractional inches)

5 Fractional

Number of decimal places of precision to include in the string; if -1, uses the current value of the AutoCAD LUPREC 
system variable.

Examples:

String Description Example Value
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<POSITION %lu2 %pr0 > Whole numbers 25000

<POSITION %lu2 %pr2 > Decimal numbers with 2 digits 25000.00

<POSITION %lu4 %pr4 > Architectural in feet inches sixteenths 25’-4 1/16”

<LOCATION > - Uses a close location of the section plane to the location group specified with Frame Location Group 
Name (or -SCMDFRAMELOCGROUP), Longitudinal Location Group Name (or -SCMDLONGLOCGROUP, Deck Location Group 
Name or (-SCMDDECKLOCGROUP)

<VIEWDIRECTION > - Is replaced by the ViewDirection field of the view object. It takes its content from the direction 
strings (Aft String, Forward String, Starboard String, Port String, Down String, Up String).

Frame Location Group – The location group to indicate the valid planes of frames and the names of those frames. If a 
potential new MarineDrafting view section plane is NOT in the location group then no MarineDrafting view is created. For 
example: The selected location group has only one frame location (Frame 10 at 10 000 mm) then no matter how many 
other frame’s plate parts are in the drawing only Frame 10 will be created).

Longitudinal Location Group – The location group to indicate the valid planes of longitudinals and the names of those 
longitudinals. If a potential new MarineDrafting view section plane is NOT in the location group then no MarineDrafting 
view is created. For example: The selected location group has only one longitudinal location (LNGBHD_3000 at 3000 
mm) then no matter how many other frame’s plate parts are in the drawing only LNGBHD_3000 will be created).

Deck Location Group – The location group to indicate the valid planes of decks and the names of those decks. If a 
potential new MarineDrafting view section plane is NOT in the location group then no MarineDrafting view is created. For 
example: The selected location group has only one deck location (MAINDECK at 5000 mm) then no matter how many 
other deck’s plate parts are in the drawing only MAINDECK will be created).

Aft String – Alias for 'Looking Aft' to use for the <VIEWDIRECTION> keyword and properties.

Forward String – Alias for 'Looking Forward' to use for the <VIEWDIRECTION> keyword and properties.

Starboard String – Alias for 'Looking Starboard' to use for the <VIEWDIRECTION> keyword and properties.

Port String – Alias for 'Looking Port' to use for the <VIEWDIRECTION> keyword and properties.

Down String – Alias for 'Looking Down' to use for the <VIEWDIRECTION> keyword and properties.

Up String - Alias for 'Looking Up’ to use for the <VIEWDIRECTION> keyword and properties.

After a view is created only the <VIEWDIRECTION> field remains as a field.

Reference Lines
Layer – Layer to place reference lines when creating new MarineDrafting views.

Filter Styles by Location Group Direction – Shows only the reference line styles in the droplist for each reference line style 
that match the direction required. This is an aid for clarifying the style to select. Turn this setting off if you have one 
reference line style that is used for multiple directions. This can be the case when no locations are displayed.

Frame View > Transverse > Style – The reference line style for transverse locations in frame views.

Frame View > Transverse > Distance from Origin in Z - The transverse location of the vertical reference line in frame 
views.

Additional Styles and Distance from Origins are similar.

View Generation Settings
The View Generation Settings are options when generating MarineDrafting views. A description of the setting is shown at 
the bottom of the dialog when the setting is clicked.

For layer settings, you can type in a new layer name, or use one an existing one from the drop down.
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Stiffener Cross Sections for Attached Stiffeners
Generate – Cross-section polylines will be generated next to a stiffener that is attached to a plate.
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Cross-sections are inserted at the piecemark point of the stiffener and are placed on toe direction side of the line. When 
the stiffener is on the far side of the plate, the shape is inverted.

Distance from Stiffener – The distance to offset the cross-section polyline from midpoint of the stiffener moldline. 
Positive value is in the direction of throw of the stiffener.
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Layer – Layer to place the cross-section polylines on.

Stiffener Attached to Plate Tolerance - Maximum distance that a stiffener is away from a plate and considered attached 
to the plate. Attached stiffeners are displayed as single line.

Curved Sections
Generate Thickness Side – Generate the section the solid instead of the mold surface.

The left image has Generate On and the right image has it Off

Plate Seam Symbol
Generate – Block containing a plate seam symbol will be generated at each calculated plate seam location. Plate seams 
are determined by sectioned plate edges and the Insertion Tolerance.

Insertion Tolerance – Tolerance to determine when to insert a plate seam symbol block. The distance between the ends 
of plate sections that are less than this value will have a symbol.
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Block Name – The name of the block to use when inserting plate seam symbols. If this block name does not exist at the 
time of generation then the block will be defined. When defining the block for the plate seam symbol, define the symbol 
starting at the origin and oriented vertically.

Initial Size – If the block doesn’t exist with Block Name when inserting symbols a new block is created and this initial size 
determines the size of the objects placed in the block.

Default Plate Seam Symbol

Layer – Layer to place the plate seam symbol blocks.

Intercostal/Continuous Symbols
These symbols indicate which intersecting plates continue through the intersection.

Generate – Determines if intercostal and continuous symbols will be placed in the 2D View. The symbols indicate the 
relationship between plate parts in the primary plane and plate parts out-of-plane.

Intercostal Block Name – Name of the block to use for intercostal symbols. Only one arrow of the symbol needs to be 
modeled. If the block does not exist then a block will be defined with the initial settings.

Continuous Block Name – Name of the block to use for continuous symbols. Only one arrow of the symbol needs to be 
modeled. If the block does not exist then a block will be defined with the initial settings.

Initial Size – When the block does not exist, a block containing an arrow is created with a symbol of this size.

Detection Distance – The distance from the out-of-plane plates to test for primary plane plates. If plates have a weld gap 
then make this value at least as large as the weld gap.
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A will have an intercostal symbol inserted, B will not

Intercostal Layer – Layer to place the intercostal symbol blocks.

Continuous Layer – Layer to place the continuous symbol blocks.

Distributed Systems Connection
Generate Points - Points will be generated at connection locations. Without the points accessories at those connections 
cannot be labeled.

Layer – Layer to place the connection points on.

Penetration
Generate Points - Points will be generated at penetration locations. Without the points, penetration accessories at those 
penetrations cannot be labeled.

Layer – Layer to place the penetration points on.

Unmodified Output
Erase – On update of a view, are the unmodified 2D View objects erased or moved to the Unmodified output layer.

Layer - Layer to place unmodified 2D View objects during update of a MarineDrafting view if Erase is unchecked.

Removed Parts
Erase – On update of a view, are the 2D View objects for parts that were removed during the update erased? If Checked
the objects are erased. If not Checked, the objects are placed on the Removed Parts layer.

Layer - Layer to place removed part 2D View objects during update of a MarineDrafting view if Erase is unchecked.

Structure
Layers – Layers for the different types of structure parts. A Visible layer is one that indicates that object is visible from the 
current view direction. Typically this will be represented by continuous linetype. A Hidden layer is one that indicates that 
the object is hidden from the current view direction. Typically this will be represented by a dashed linetype.



Getting Started

19

Distributed Systems
Layers – Layers for the different types of structure parts. A Visible layer is one that indicates that object is visible from the 
current view direction. Typically this will be represented by continuous linetype. A Hidden layer is one that indicates that 
the object is hidden from the current view direction. Typically this will be represented by a dashed linetype.

Electrical
Layers – Layers for the different types of structure parts. A Visible layer is one that indicates that object is visible from the 
current view direction. Typically this will be represented by continuous linetype. A Hidden layer is one that indicates that 
the object is hidden from the current view direction. Typically this will be represented by a dashed linetype.

Misc
Layers – Layers for the different types of structure parts. A Visible layer is one that indicates that object is visible from the 
current view direction. Typically this will be represented by continuous linetype. A Hidden layer is one that indicates that 
the object is hidden from the current view direction. Typically this will be represented by a dashed linetype.

Non Part refers to all objects in the bounding box that are not parts or part views.

Create Layers
Create Layers – If checked, the layer names specified in the settings will be created if they don’t exist. This only shows up 
when the View Generation Settings is run and not when generating/updating views. This allows the configuration of the 
layer properties without having to manually create each layer. When layers are created the hidden layers are color 8 and 
dashed linetype and visible layers are color 7 and continuous linetype. The Original 2D View Geometry Layer is frozen.

Output Drawing
Output drawings are intermediate drawings that contain the parts of the 3D model. They can be used as standalone 
production output drawings but for the purpose of creating MarineDrafting drawings they are the source. No special layers 
or settings are required for this drawing. Output drawings can be organized in a folder structure you define. You should 
create a separate folder structure for the output drawings that will be used by MarineDrafting. Do not create a deep folder 
structure as there is a 255 character limit for the full path and file name.
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MarineDrafting Drawing
MarineDrafting drawings are the drawings that represent classification, approval, workshop, or like 2D representation 
drawings. MarineDrafting drawings use a single output drawing as a source. They are located in the Navigator 
underneath.

Creating
You can create a MarineDrafting drawing in one step or two. The only difference is that the two step process opens the 
Output drawing and allows you to further manage the parts that will be in the output drawing. You can remove parts that 
you may not want to appear in the MarineDrafting drawing by erasing them.

One Step
Create a MarineDrafting drawing by clicking New MarineDrafting on the Output page in the Navigator. This starts a wizard 
that steps you through the creation process.

Step 1
You choose if you going to create a new Output drawing or use an existing output drawing. This allows you to have one 
output drawing used to create several MarineDrafting drawings in the future. If you do not select New then the next step 
will be Step 5.
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Step 2
Enter the name of the new Output drawing. You may want to name your Output drawings with a different name than your 
MarineDrafting drawings to make it easier to identify each.
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Step 3
Select the template drawing for the Output drawing.
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Step 4
Select the sources for the Output drawing. You are selecting which parts will be used in the MarineDrafting drawing. If 
there are certain parts in the Output drawing that you don’t want to include, you can later open the Output drawing and 
erase those parts.
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Step 5
Enter the name of the MarineDrafting drawing. You may want to limit the number of layouts in the MarineDrafting view to 
one to improve performance. This means you may end up using the same Output drawing to generate many 
MarineDrafting drawings.
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Step 6
Select the template drawing for the MarineDrafting drawing. This is the template drawing you have configured 
beforehand.
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The resulting MarineDrafting drawing will contain an Xref of the Output drawing.

Create Views
You are ready to create 2D views. The easiest way is to run the Create Views Automatically. This will automatically create 
views based on plate parts in the Output drawing. Note that if you have reference lines configured to be created then you 
should confirm the Distance from Origin settings so the reference lines are near the output. For instance, if the model is 
located around 100m forward from the origin then Distance from Origin in X should not be 0. It should be a frame of 
reference for that area like the aft unit break.

Bad placement of reference line
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Better placement of reference line

Generating Views
After some 2D Views are created, you can run Update Views to generate the 2D view output.

Detailing
MarineDrafting drawings contain a feature that remembers manual changes. When a 2D View object is erased it isn’t 
actually erased. It is placed on the Original 2D View Geometry Layer (typically SCMD Original, that is usually left frozen). 
When the next update is run that 2D View object will be regenerated. The regenerated objects will be geometrically 
compared to the objects on the Original 2D View Geometry Layer and if they match the regenerated object is erased.

When a 2D View object is modified a copy of the object before the change is placed on the Original 2D View Geometry
Layer (typically SCMD Original). When the next update is run, that 2D View object will be regenerated. The regenerated 
objects will be geometrically compared to the objects on the Original 2D View Geometry Layer and if they match the 
regenerated object is erased. 

The effect is that manual changes are maintained and any new changes that occur will show up.

To completely erase the 2D view geometry you will need to erase it from the Original 2D View Geometry Layer or erase 
both the 2D View coordinate system icon and the 2D view geometry.

Updating
Updating MarineDrafting drawings is slightly different than updating other production drawings. In production drawings 
you run Update Drawing and you see a window of the modified parts. In a MarineDrafting drawing, running Update 
Drawing will silently update the output drawing and then update the 2D Views. If you want to change sources or see the 
update parts window to re-add erased parts, you can update the Output drawing separately.



MarineDrafting Procedures

28

MarineDrafting Procedures

Move a MarineDrafting Drawing
There may be circumstances where you want to move an output drawing or a MarineDrafting drawing to another folder.

To move a MarineDrafting drawing

1. In Windows Explorer, move the MarineDrafting drawing to the destination folder. It must be in an MD folder. You may 
be required to create the destination MD folder if it does not exist.

2. In Windows Explorer, move the Output drawing to the destination folder. If the Output drawing is linked to other 
output that isn’t being moved do not move it.
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3. In Navigator on the Output page, select the output drawing and right click and choose Relink.

4. Click OK.
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5. Relink the MarineDrafting drawing located in the Unregistered MD folder.

6. Click OK.

7. If you have a <FILEPATH> keyword, it will require updating the drawing.

Create a View
Creating views is more easily done using the automatic method of creation.

To create a views

1. Choose SC MarineDrafting > Create Views Automatically… (page 193).
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2. Change any options that require changing depending on the view being generated like the reference line distance 
from origins.

3. Click OK.
Select position of output: 

4. Select a point on to place the tiled 2D Views. You can now remove unwanted views or generate views.
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Manually creating a MarineDrafting view is an alternate way to create a view. Manual view creation only supports 
orthogonal views. To manually create a view for a skewed view, use ROTATE3D.

To create a view manually

1. Set up the view direction to isometric to be able to draw the bounding box.

2. Choose SC MarineDrafting > Create a View… (page 193).
Enter orientation [Frame/Longitudinal/Deck] <Frame > : 

3. Type the desired option.
Enter name for view: 

4. Enter the name for the view (Eg. FRAME 50).
Select section origin:

5. Click on the point to make the section origin.
Select first corner:

6. Click on the point that represents first corner of the bounding box. 
Select second point:

7. Click on the point in the opposite corner of the bounding box. If the opposite corner is in two dimensions then you 
see another prompt for a third point.
Select thickness point:

8. Click the third point to represent the thickness of the bounding box.
Select output location:

9. Click the location to place the 2D view coordinate system origin.

Copy Objects to 2D View
There may be cases where you want to show something in the 2D view where it isn’t a part or isn’t in the bounding box. If 
the object is located in the ship coordinate system you can use this command to convert it to show in a 2D view.

To copy objects to a 2D view

1. Choose Production > MarineDrafting > MarineDrafting Copy Object to 2D View
Select Objects:

2. Click on the objects you want to copy.
Select MarineDrafting view:

3. Click either on the 2D view icon or the MarineDrafting view control.

Add a Reference Line after 2D View was Created
If you didn’t remember to set up reference lines prior to creating the 2D views, you can manually add them after.

To create a reference line in a MarineDrafting view

1. Set up the current User Coordinate System (UCS) so that the reference line will be generated on the X or Y access of 
the UCS.

2. Choose Production > Production Utilities > Create Reference Line. Depending on the orientation of the UCS, the 
prompt will show relevant directions.
Enter direction [Longitudinal/Transverse] <Longitudinal>:

3. Choose the direction.

4. A reference line is created in the ship coordinate system and you need to transform it to the 2D view.

5. Choose Production > MarineDrafting > MarineDrafting Copy Object to 2D View
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Select Objects:
6. Click on the reference line you want to copy.

Select MarineDrafting view:
7. Click either on the 2D view icon or the MarineDrafting view control.
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ShipConstructor
ShipConstructor is a set of software tools for planning the production of ships and offshore structures, designing and 
modeling hull, structure, piping, HVAC, penetrations, and equipment, and generating production documentation to enable 
efficient fabrication.

Assembly sequence
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Production output

Note: ShipConstructor consists of several modules that you can purchase separately. This document describes 
features in various ShipConstructor modules. If you do not have a license for all ShipConstructor modules, you may 
not be able to use some of the features described in this document. For more information on ShipConstructor 
modules and licensing, visit www.ShipConstructor.com.

Projects, Models, Drawings and Libraries
All work in ShipConstructor is done on a specific project. A project represents a single vessel. As you work on a project, 
you build a three-dimensional digital model of the vessel.

3D product model courtesy of Marinette Marine Corp. and Genoa Design International
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Database Driven Relational Object Model (DDROM)
ShipConstructor uses a fundamentally new technology for creating, storing, and updating part information: the Database 
Driven Relational Object Model (DDROM). 

DDROM is similar to parametric modeling. Parametric modeling is a way of defining geometry in which geometric 
dependencies are built-in, so that editing one shape will cause other shapes to change size or location. 

For example, when you update a part after it has been defined, any objects related to the part that are affected by the 
update are also modified.

When you work in ShipConstructor, you create and work within drawings. Each drawing is only an interface between you 
and the model that is stored in the database. The model is a three-dimensional representation of the entire vessel. Each 
project contains many model drawings, but only one model.

Objects in the database 

Manager
Another part of each project is the Manager. Manager is where you set up stock items and other rules or conventions.



ShipConstructor

38

Workspace and Tools
Most ShipConstructor tools are available within AutoCAD from special menus and toolbars or by typing commands in the 
command line.

The ShipConstructor menu, SC Utilities menu and SC Advantage Pack menus are always available. Other menus are also 
available depending on the type of drawing you have open.
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ShipConstructor menu

SC Utilities menu

The toolbars available to you when using ShipConstructor are controlled by the current AutoCAD Workspace you have 
loaded.

Toolbar buttons with a small black triangle let you access a Flyout toolbar containing more tools.

You can also access certain ShipConstructor tools by clicking the right mouse button. The menu that appears depends on 
the type of object you select or click on. These menus are called right-click menus (or sometimes shortcut menus).
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You can also use many of AutoCAD’s tools when working on a ShipConstructor project.

Some ShipConstructor tools run independently of AutoCAD.

Navigator
One of the most frequently used tools is Navigator. Navigator lets you open and create drawings and is found at 
ShipConstructor > Navigator (page 231).
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Getting Started
This section describes how to start running ShipConstructor and how to perform basic administrative tasks in 
ShipConstructor.

Start ShipConstructor

To start ShipConstructor

1. Do either of the following:

• From the Windows Start button, choose Start > All Programs > ShipConstructor 2014 > ShipConstructor 2014.

• On the Windows Desktop, double-click the ShipConstructor shortcut icon. Do not use the AutoCAD shortcut.

Make sure you see the ShipConstructor and SC Utilities menu in the menu bar. If not, contact your system 
administrator, or see the Installation Guide for troubleshooting information.

Check Your System Text Size
ShipConstructor’s windows are designed for the Smaller – 100% (default) text size in Windows 7. If you are using the 
Medium – 125% or Larger - 150% text size in Windows 7, some ShipConstructor windows will not display properly.

To check your system font

1. Choose SC Utilities > 3D Viewpoint (page 269) to open the Select View window.

If you are using the small system font, the circles are aligned with the 3D grid points.
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Smaller – 100% text size

If you are using the medium or large text size, the circles are misaligned with the grid.
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Medium – 125% text size

To set your system font in Windows 7

1. Right-click on your Windows Desktop and choose Personalize, then Display (or from the Windows Start menu, 
choose Start > Control Panel to open the Control Panel, then double-click the Display icon) to open the Display 
Properties window.

2. Set the text size to Smaller – 100% (default)
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3. Click OK.

Note: If text is too small for you to read, reduce the resolution of your display. In the Display window, select the 
Adjust resolution option and set Resolution to a lower value. For example, if your current Screen resolution is 
1600 x 1200, reduce it to 1280 x 1024. However, do not use a Resolution less than 1024 x 768.

Open a Project

Note: For more information on project setup and administration, see the Project Management manual.

To open a project

Note: You can also open a project from Manager by choosing File > Change Project.

1. Choose ShipConstructor > Navigator to open Navigator. 

If you do not currently have a project open (for example, after initially starting ShipConstructor), the Register Project
window appears.

If you currently have a project open, Navigator appears. Select the project from the component list (for example, 
SC2009Demo) and click Change Project to open the Register Project window.
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2. Select the project from the list or click Browse to locate a project file. (A ShipConstructor project file has a *.pro
extension.)

3. Enter your User name and Password.

Note: For the project templates, the User name is ShipConstructor and the Password is shipcon.

If you do not have a user account, ask your system administrator to set one up, or see User Accounts in the Project 
Management manual for details.

4. Click Open.

Note: If this is the first time you open a project after starting ShipConstructor, the Licensing window appears. See 
Get Licenses (page 45) for details.

Get Licenses
You can turn on and off licenses to enable or disable ShipConstructor modules. You can purchase ShipConstructor 
modules separately at various levels (based on number of parts). You can also use a combination of local locks (located 
on your computer) and network locks (located on a network-accessible computer).

For details on setting up licenses, see the Installation Guide.

To turn on or off licenses

1. Choose ShipConstructor > Licensing (page 266) to open the Licensing window.
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2. Set the options (see Licensing Window (page 266)).

3. Click OK.

Re-Login to ShipConstructor
If you have different user accounts for different roles, you may need to change who you are logged in to ShipConstructor 
as. To do so, re-open the project and enter a different user name and password (see Open a Project (page 44)).

Reload a Project Database
Whenever you or anyone else makes changes to a project in Manager, you must reload the project database for the 
change to appear in your ShipConstructor session.

To reload the project database

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.

2. Select the project node in the component tree on the left side of Navigator (for example, SC2009Demo).

3. Click Reload DB.
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Change Your Password
User passwords are configured using the Administrator utility.  Please consult the section Change User Passwords in the 
Project Management manual.

Drawings
Drawings give you access to the project model data. ShipConstructor saves the parts in the drawings but actually stores 
the parts in the database. If there is any discrepancy between the drawing and the database, the database is considered 
to be correct. 

Note: ShipConstructor stores AutoCAD objects in the drawings only (not in the database).
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Open a Drawing

To open a drawing

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.

Note: To open a drawing from a unit other than the current unit, select the project at the top of the component 
list, then select the unit in the Unit list.

2. Select the type of drawing in the component list (for example, Structure or Pipe).

Note: To open a unit drawing, select the unit name in the component list (for example, U12).

3. Select the drawing in the drawing list.

Note: To open the drawing in read-only mode, click on the Read Only check box.

4. Click Open.

Create a Drawing

To create a drawing

Note: The following procedure describes how to create drawings in general. For information on creating specific 
types of drawing, see the appropriate section of this manual.

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.

Note: To create a drawing for a unit other than the current unit, select the project at the top of the component list 
(for example, SC2009Demo), then select the unit in the Unit list.

2. Select the type of drawing in the component list (for example, Structure or Pipe).

Note: If the drawing list contains folders, select the folder for the sub-type of drawing.

3. Click New.

Note: The New button label may be different for different drawing types (for example, New Piping, New 
Arrangement, Create, or Create Spool Dwg).

The New Drawing window appears.

4. Type a File Name for the drawing.

Note: To open the new drawing, click on the Open new drawing check box.

5. Click OK.

Lock or Unlock a Drawing
You can lock drawings so others can open them and view them but not save any changes to the drawing.

To lock or unlock a drawing

1. In Navigator, click the padlock icon beside the drawing name.

• A dark padlock icon means the drawing is locked.

• A dimmed padlock icon means the drawing is unlocked.

Note: If clicking the lock icon does not seem to work, you may not have permissions to lock or unlock the 
appropriate drawing files.
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Rename a Drawing

To rename a drawing

1. In Navigator, right-click on the drawing name and choose Rename.

2. Enter a new name.

3. Press Enter.

Delete a Drawing

To delete a drawing

1. In Navigator, right-click on the drawing name and choose Delete.

Save a Drawing
It is important for the user to click File > Save in AutoCAD to save the current (structural) drawing periodically. This 
ensures that the drawing and the project database remain synchronized. 

Note: The automatic saving feature through AutoCAD will not save ShipConstructor drawings.

Closing a Drawing
Erased parts are deleted from the database when the drawing is closed and you have saved the drawing. If AutoCAD 
crashes without closing a drawing, any parts that were deleted in that session will be left in the database. The next time 
the drawing is opened, a synchronize warning will ask you to choose to keep the objects that are only in the database.

Set Up Composite Drawings
You can create composite drawings in ShipConstructor and use AutoCAD’s XCLIP command to create composite deck or 
frame drawings. Composite drawings make the design process easier and let you see exactly what is happening around a 
deck or specific frame, including the structure, pipe, equipment, and HVAC components, without making any permanent 
changes to your drawings.

To create a composite drawing

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.



Drawings

51

2. Choose Composite in the component list.

3. Click New.

4. Enter a File Name for the drawing.

5. Click OK.

The Mlink Manager window appears. 

6. Select the drawings you want displayed in the composite drawing.

7. Click OK.
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Insert (Link) a Drawing into Another Drawing
Each drawing contains a relatively small portion of the entire project. Sometimes you want to see more of the project 
than is contained in a single drawing. To do so, you can insert (link) other drawings into the current drawing. This type of 
link is referred to as a model link or mlink. When you mlink other drawings into the current drawing, the objects in those 
drawings are visible in the current drawing. However, you cannot modify objects that are mlinked into the current 
drawing.

For example, if you are modeling structural components, you may want to see other structural elements, equipment, or 
piping by mlinking them into the current planar group drawing. Similarly, if you are modeling piping, you may want to see 
a few key structural drawings by mlinking them into the current pipe drawing. Mlinking lets you easily see the spatial 
relationships between drawings.

You can also use mlinks to control which drawings are included in a unit drawing. In some cases, it may take a long time 
for ShipConstructor to open the unit drawing because you have very complex planar group drawings. If so, you may want 
to temporarily remove certain mlinked drawings to allow the unit drawing to load faster. In other cases, you may want to 
use mlinks to include pipe and equipment in the unit drawing.

You can also use mlinks to create a composite drawing of the entire vessel (see Set Up Composite Drawings (page 50)).

Note: It can take several minutes for ShipConstructor to mlink all unit drawings into a composite drawing. (For 
example, it can take over thirty minutes to mlink all nine units of a reasonably sized project and pipe and equipment 
into a composite drawing.) 

To mlink drawings into the current drawing

1. Choose ShipConstructor > Model Link (page 258) to open the MLink Manager.
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2. Select the drawings to insert (link) into the current drawing.

3. Click OK.

Tip: After inserting (linking) a drawing into another drawing, you can use AutoCAD’s XCLIP command to hide 
parts of the linked drawing. For details, see xclip in AutoCAD Help.

To reload mlinked drawings

1. Choose ShipConstructor > Model Link (page 258) to open the MLink Manager.

2. Click Reload.

To remove an mlinked drawing

1. Choose ShipConstructor > Model Link (page 258) to open the MLink Manager.

2. Remove the checkmark from the drawings to remove the drawing from the current mlinked drawing.

Tip: To remove all mlinked drawings, click Uncheck All.

3. Click OK.

Configuring Viewport Dependant Display Options
Viewports in ShipConstructor can be configured with a subset of the options available globally. These selections will only 
show inside the specified viewport. This can be done inside of a Template or a production drawing.

Configuration changes made to the Viewport Display Options will override those same settings in the global display 
options. Each option will default to using the global option, even if other options are overrode unless the Use Global 
Option check box is unchecked the global option for that value will be used. If the Use Global Value option is unchecked 
then the value of that row will be used to determine the display settings for that viewport.                                  

1. Choose Viewport Display Options > Set… (page 327).

2. If you were previously inside of a model space viewport the options for that viewport will be displayed, else you will 
be prompted to select the viewport that you wish to configure.
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3. Once a viewport has been selected the Viewport Display Options window will appear. The option grid has three 
columns. 

• Option: The names of the different options as well as categories under which the options are organized.

• Use Global Option: If checked then the global display options will be used instead of these options, if 
unchecked then the viewport specific option will be used.

• Value: The viewport specific value for this option. This value will only be used if the Use Global Option is 
unchecked.

Below the grid is the Description field, it will contain a description of the selected option.

4. Once configuration is done click OK to continue.
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Exporting ShipConstructor Drawings
ShipConstructor drawings are similar to standard AutoCAD drawings, except they contain many custom objects. If you are 
running AutoCAD (without ShipConstructor) and try to open a ShipConstructor drawing, the following message appears.

You can install the ShipConstructor Object Enabler (page 58), a free download from www.ShipConstructor.com, that lets 
you open ShipConstructor drawings in AutoCAD.

You may also generate a document from your original ShipConstructor drawings that can be opened without 
ShipConstructor installed or the ShipConstructor Object Enabler (page 58) there are a number of methods depending on 
what you wish to produce.

• Export To Dwg: A function to export a single ShipConstructor drawing.

• Export Documents: An Exported Document that includes the entities from one or more original ShipConstructor 
drawings.

• Bound Approval Drawings: An Approval Drawing that has been exported into native format to avoid 
modifications to the source drawings modifying it and to allow it to be viewed independent of ShipConstructor.

Export To Dwg
The Export To Dwg feature provides you with the ability to export a ShipConstructor document to a native AutoCAD 
document that can be viewed without the use of ShipConstructor or the ShipConstructor Object Enabler. The user is given 
the ability to select what elements of a drawing are exported and separate the elements of complex ShipConstructor
parts onto separate layers in the new document.

Any parts that are MLinked into the drawing being exported will have local copies created out of native AutoCAD entities 
using the same settings to determine what elements of parts are included and the layer they are placed upon.

1. Choose SC Utilities > Export > Export To Dwg… (page 289) or type SCEXPORTDWG at the command line

The current drawing will be closed when the export drawing is created, so ShipConstructor will ask you if you 
wish to save the current drawing before proceeding.

2. A Save As window will appear with a generated name for the document. Set the file name and location as 
needed. Click Save and the Export To Dwg Configuration window will appear.
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3. The Export To Dwg Configuration: The interface to configure the export will display the available options in the 
main grid. Items that are displayed under another item are dependent upon the item above them to be enabled 
for them to be enabled. 

Example: Structure>Part>Solid>Green is set to Show in the above picture, but if Structure>Part>Solid was set 
to Hide then any dependant values, such as Green, would be be treated as having the value Hide and the tree 
under Solid would be collapsed for easier navigation.

Note: The configuration options for each module are discussed in the module’s display option documentation.

Layer Templates

The Layer Template feature allows you to separate elements of the drawing out onto separate layers based 
on what option it is related to and the original layer it was placed upon.

The default setting for a layer template, <Source Layer>, means that that element will be left on exactly the 
same layer as it is in the original drawing.

If you wish to create an exported document that has all of the Structure solids on a layer called _SOLIDS 
then replace the layer template for Structure>Plate>Solids with _SOLIDS. If the layer does not already 
exist a new layer with that name will be created and all solids from structure elements will be placed upon 
it. Note that while the Stiffener Green is also a solid it is dealt with separately and if you wish it to be on 
the _SOLIDS layer it will also need to have the same Layer Template. You may place as many or as few 
options on the same layer as you wish.
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Example: If an entity on layer _REV is exploded with the template “_SCEntity<Source Layer>” it will be placed 
on the layer “_SCEntity _REV”

Note: <Source Layer> is a special token in a Layer Template, it refers to the Source Layer and it will be 
replaced with the name of the source layer.

The buttons on the bottom left of the window are used to manage configurations.

• Use Current Display Opts will read the current global display options from the source Approval Document 
and configure the UI accordingly.

• Load From File allows you to read in an previous Bound Approval Document Configuration and configure 
the UI accordingly.

• Save to File allows you to save the current settings in the UI to a text file that can be used to configure other 
Bound Approval Document configurations.

Export Drawings
ShipConstructor drawings can be exported to standard AutoCAD drawing format. This lets you use the solid model in 
other applications that do not support the object enabler. During export, ShipConstructor converts all custom objects to 
standard AutoCAD objects. Structure parts are exported as 3D solids and production geometry. In the standard AutoCAD 
drawing, exported solids are on the DrawingName_SOLID layer and production geometry is on the 
DrawingName_PRODUCTION layer.

To export ShipConstructor drawings

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.

2. Select Export in the component list.

3. Click New to open the New Export Drawing window.

4. Enter a name.
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5. Click the check box for the drawings to include in the EXPORTED drawing.

6. Click OK.

Object Enabler
You will not be able to open ShipConstructor drawings in plain AutoCAD without ShipConstructor or the ShipConstructor 
Object Enabler. The object enabler is a separate installation that contains a portion of ShipConstructor that allows the 
custom objects to be accessible. The object enabler contains no commands and is not connected to the project database. 
You cannot edit parts or construction lines. Changes or additions to non-ShipConstructor objects are permitted.

Note: Object Enabler is available as a free download from www.ShipConstructor.com. Do not install both the object 
enabler and ShipConstructor on the same computer.

Views
You can adjust the view within any drawing.



Exporting ShipConstructor Drawings

59

Select a 3D or 2D View

To select a 3D or 2D view

1. Choose SC Utilities > 3D Viewpoint (page 269) to open the Select View window.

2. Select the 3D tab.

3. Select a point within the 3D ship hull image.

Note: You can also manually enter the viewpoint values beside VPoint.

4. Click OK.

Switch Between Paper Space and Model Space
Each drawing contains two types of views.

• The model space view represents your model in three-dimensions. You use the model space view for modeling and 
drafting.

• The paper space view represents your model in two-dimensions as it would be printed or plotted on paper. You can 
use the paper space view for creating a finished layout for printing or plotting.

To switch between paper space and model space

1. At the bottom of the drawing window, click the Model tab to switch to model space or click the Layout tab to switch 
to paper space.

Note: A drawing can have more than one Layout tab.
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Windows and Editors
When a window or editor opens, there are numerous features designed to help you accomplish the task you are doing. 
Some of the most commonly used features are the following:

• If information is sorted in a column; you can click the column name to sort the list alphanumerically. 

• Click the column name a second time to sort the information in reverse alphanumerical order. 

• If a window consists of more than one tabbed panel, you can move between tabs using the left and right arrow keys 
(only when a tab name is highlighted).

• Press Tab to navigate among the window’s elements.

• Press Esc to close a window.

Structural Design Workflow
The workflow of ShipConstructor will differ between companies due to the specific work processes of the company. The 
following example is a typical high-level flowchart of the Structure discipline.
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Library Setup

Overview
Each project contains various libraries with all the stocks, materials, and standards that you will use in the project. Before 
you begin work on a project, you must set up these project libraries. You can also import project libraries from another 
project or from an XML file that you have exported from another project. Virtually all the settings can be changed after 
parts have been modeled.

Supplied Libraries
ShipConstructor comes with three template XML files that contain sample standards and stocks. By default these files 
are found at C:\Program Files\ShipConstructor2009\ProjectTemplates.

• MetricTemplate.XML – metric stocks and standards

• ImperialTemplate.XML – imperial stocks and standards

• PipeCatalog.XML – pipe catalogs

Catalog Setup Workflow
This manual is organized in the order that you will typically set up a project.

Project Settings
There are certain settings that ShipConstructor uses throughout a project. Before you begin work on a project, you must 
set these project settings. We recommend that you do not modify certain project settings after you have begun work on a 
project. See General > Project Settings (page 217) for details.  

You can also import project settings from another project or from an XML file that you have exported from another 
project. We recommend that you do not modify the project settings after you have begun work on a project.

Set Project Settings

To set the structure options

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Project Settings (page 217) to open the Project Settings window.

3. Open the Structure section and set the options. See General > Project Settings (page 217).

4. Click OK to close the Project Settings window.

Import Project Settings

To import project settings

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Project Settings (page 217) to open the Project Settings window.



Library Setup

63

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

Export Project Settings

To export project settings

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Project Settings (page 217) to open the Project Settings window.

3. Click Export XML to open a File Browser.

4. Enter a name for the XML file.

5. Click Save.

User Permissions
See the Project Management manual for details on how to use User Permissions.

ShipConstructor is designed to be used by a team of people. Each company will have different types of people, so we will 
present a typical case. 

Structure Team Roles
Project Manager:

• Schedules and plans the project

• Organizes team

• Corresponds with client

Structural Designer:

• Approves contract drawings 

• Creates structural detail design

Structural Lead:

• Ensures that standards are maintained 

• Is responsible for the model

Build Strategist:

• Develops the build strategy for the project 

• Coordinates scheduling

Modeler: 

• Models all structure and generates parts

Nester:

• Creates nest and nests parts

• Tracks stock

Production Detailer: 

• Details assembly drawings

CAD Administrator:

• Creates users and maintains databases

• Manages communication about issues with ShipConstructor Software Inc. and applies patches
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People in the team may have more than one of these roles. The different roles in the project require different 
permissions. We recommend that you set up permission groups for each role.

Materials
Each part is fabricated from a specific type of material (for example, Aluminum 5086). You must set up the materials you 
plan to use in the project. In ShipConstructor, a material is actually a grouping of material grades. For example, the 
material Aluminum might contain the grades 5086, 6061, and 5052.

Create a Material

To create a material

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Click New Material.

4. Type a name for the material and press Enter.

Create a Grade

To create a grade

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Select the Material in which to create a grade.
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4. Click New Grade.

5. Enter a name for the grade and press Enter.

6. Make sure Density Units is set to the units you want to use to specify the density.

7. Double-click the Density field for the new grade, enter a value (measured in the Density Units), and press Enter.

ShipConstructor uses density values to calculate part weight.

Rename a Material or Grade

To rename a grade

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Double-click the material or grade to rename (or right-click the material or grade and choose Rename).

4. Enter a new name for the material or grade and press Enter.

Import Materials and Grades

To import materials and grades

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

6. Check the materials in the Import column that you want to import and click OK.

Export Materials and Grades

To export materials and grades

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Check the Export check boxes for the materials and grades to export.

4. Click Export XML to open a File Browser.

5. Enter a name for the XML file.

6. Click Save.

Delete a Material or Grade

To delete a material or grade

Note: You cannot delete a material or grade that is currently in use in the project.  You can produce a log of all 
stocks/standards that use a particular material grade by selecting the material grade which is checked “In Use”, and 
clicking Usage Log.

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Select the material or grade.

4. Click Delete.
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View Material Usage
It is possible to see a list of all the stocks that use a selected material grade. A check mark in the In Use column indicates 
that the material grade is being used by stocks.

To list all stocks using a specific grade

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Materials (page 222) to open the Materials window.

3. Select the grade you want.

4. Click Usage Log.

ShipConstructor displays a list of all stocks using the selected grade.

Manufacturers
A manufacturer is a company that manufactures certain items used in your project (for example, pipe stock and
insulation). When you create such an item, you must assign it a manufacturer.

Create a Manufacturer

To create a manufacturer

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Manufacturers (page 223) to open the Manufacturers window.
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3. Click New to create a new manufacturer.

4. Enter a name for the manufacturer and press Enter.

View Manufacturers Usage
It is possible to see a list of all the stocks that use a selected manufacturer. A check mark in the In Use column indicates 
that the manufacturer is being used by stocks.

To list all stocks using a specific manufacturer

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Manufacturers (page 223) to open the Manufacturers window.

3. Select the manufacturer you want.

4. Click Usage Log.

ShipConstructor displays a list of all stocks using the selected manufacturer.
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Finishes
Parts often have a finish applied to them (for example, paint). You must set up the finishes you plan to use in the project. 
A finish type is a group where you can set up similar types of finishes. For example, you may have a finish type named 
Paint that contains finishes like antifouling, primer, and enamel.

Create a Finish Type

To create a finish type

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Click New Type.

4. Type a name for the finish type and press Enter.

Create a Finish

To create a finish

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Select the finish type that the new finish will belong to.

4. Click New Finish.

5. Type a name for the finish and press Enter.

Rename a Finish or Finish Type

To rename a finish or finish type

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Double-click the finish or finish type to rename (or right-click the finish or finish type and choose Rename).

4. Type a new name and press Enter.

Import Finishes and Finish Types

To import finishes

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

Export Finishes and Finish Types

To export finishes

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Check the Export check boxes for the finishes and finish types to export.

4. Click Export XML to open a File Browser.
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5. Enter a name for the XML file.

6. Click Save.

Delete a Finish or Finish Type

To delete a finish or finish type

Note: You cannot delete a finish or finish type that is currently in use in the project.

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Select the finish or finish type.

4. Click Delete.

View Finishes Usage
It is possible to see a list of all the parts that use a selected finish. A check mark in the In Use column indicates that the 
finish is being used by parts.

To list all parts using a specific finish

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Finishes (page 224) to open the Finishes window.

3. Select the finish you want.

4. Click Usage Log.

Insulation
Insulation is not used by the Structure module. 

Some stocks include insulation. If you plan to use stocks with insulation, you must define the various insulation.

You must set up the insulation you plan to use in the project. An insulation type is a group where you can set up similar 
types of insulations. 

Create an Insulation Type

To create an insulation type

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Click New Type.

4. Type a name for the insulation type and press Enter.

Create an Insulation Catalog

To create an insulation catalog

1. Open the Insulation window.

2. Click Edit Catalogs to open the Insulation Catalogs window.

3. Click New to create a new insulation catalog.

4. Enter a name for the insulation catalog and press Enter.
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Create an Insulation

To create an insulation

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Select the insulation type that the new insulation will belong to.

4. Click New Insulation.

5. Type a name for the insulation and press Enter.

Rename an Insulation or Insulation Type

To rename an insulation or insulation type

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insualtion window.

3. Double-click the insulation or insulation type to rename.

4. Type a new name and press Enter.

Import Insulation and Insulation Types

To import insulation

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

Export Insulation and Insulation Types

To export insulation

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Check the Export check boxes for the insulation and insulation types to export.

4. Click Export XML to open a File Browser.

5. Enter a name for the XML file.

6. Click Save.

Delete an Insulation or Insulation Type

To delete an insulation or insulation type

Note: You cannot delete an insulation or insulation type that is currently in use in the project.

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Select the insulation or insulation type.



Library Setup

71

4. Click Delete.

View Insulation Usage
It is possible to see a list of all the parts that use a selected insulation. A check mark in the In Use column indicates that 
the insulation is being used by parts.

To list all parts using a specific insulation

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Insulation (page 225) to open the Insulation window.

3. Select the insulation you want.

4. Click Usage Log.

Text Styles
Text styles let you control the appearance of plate part text (marklines and piecemarks) in production drawings.

To set up a text style, you must set up both a ShipConstructor text style name (which applies to the entire project) and an 
AutoCAD text style with the same name that defines the appearance of the text, which applies to an individual drawing. 
Whenever you insert text of a certain style, ShipConstructor formats it using the AutoCAD text style of the same name (or 
using the Standard style if there is not an AutoCAD text style with the same name).

For example, to standardize the appearance of piecemark text in assembly drawings, you would do the following. Set up 
a ShipConstructor text style named Piecemark and an AutoCAD text style named Piecemark in the assembly drawing 
template. When inserting text in any drawing, use the ShipConstructor text style Piecemark. You do not necessarily need 
to set up an AutoCAD text style named Piecemark in all drawings, since it is the appearance of text in the assembly 
drawing that you are trying to standardize. Conversely, different modelers can set up their own AutoCAD text styles 
named Piecemark in their own drawings. As long as they use the ShipConstructor text style Piecemark, all text of that 
style will be formatted consistently in the assembly drawings.

Create a Text Style

To create a text style

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Text Styles (page 226) to open the Text Styles window.

3. Click New.

4. Enter a name for the text style and press Enter.

5. Click OK to close the Text Styles window.

Delete a Text Style

To delete a text style

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Text Styles (page 226) to open the Text Styles window.

3. Select the text style you want to delete.

4. Click Delete.

5. Click OK to close the Text Styles window.
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Accessory Packages
An accessory package is a collection of accessories (for example, nuts, bolts, gaskets, and washers) that accompany a 
penetration package, a pipe hanger, a pipe connection, or an HVAC connection. Accessory packages are not displayed in 
drawings but are listed in BOMs and reports.

When setting up accessory packages, you first define accessory types. Accessory types are groups or categories of similar 
types of accessories. For example, you can define an accessory type named bolts. After defining accessory types, you can 
then define specific accessories. Finally, you create accessory packages and add accessories to them.

For PipeLink drawings, fill in the PipeLink component filed for accessory types, and the bolt diameter and bolt length if 
applicable for accessories.

Create an Accessory Type

To create an accessory type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, click New Type to create a new accessory type.

4. Enter a name for the accessory type (for example, Bolts, Gaskets, Nuts, or Washers) and press Enter.

Create an Accessory Package

To create an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory package you want to create.

4. Click New to create a new accessory package.

5. Enter a name for the accessory package and press Enter.

Create an Accessory

To create an accessory

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, select the accessory type.

4. Click New Acces. to create a new accessory of the selected type.

Note: The New Access. button changes to the name of the selected accessory type.

5. Enter a name for the accessory and press Enter.

6. Enter a Description and Weight for the accessory.

Copy an Accessory Package

To copy an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages to list.
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Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to copy.

5. Click Copy to copy the accessory package.

6. Enter a name for the copied accessory package and press Enter.

Delete an Accessory Package

To delete an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to delete.

5. Click Delete to delete the accessory package.

Delete an Accessory or Accessory Type

To delete an accessory or accessory type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, select the accessory or accessory type that you want to delete.

4. Click Delete.

Add or Remove an Accessory To or From an Accessory Package

To add or remove an accessory to or from an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to add or remove an accessory to or from.

Accessories that currently belong to the accessory package are listed under Spec Filter.

5. To add an accessory to the accessory package, under Accessories select the desired accessory and click Add.

Note: To add several of the same type of accessory, add the accessory once and set the Qty value.

To remove an accessory from the accessory package, under Spec Filter select the desired accessory and click 
Remove.

Add or Remove an Accessory Package To or From a Spec

To add or remove an accessory package to or from a spec

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.
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3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to add or remove to or from a spec.

5. Click Assign Spec to open the Accessory Package Specs window.

6. Check the check box of the specs you want to add the accessory package to.

To remove an accessory package from a spec, uncheck its check box.

7. Click OK to close the Accessory Package Specs window.

Import Accessory Packages
You can import accessory packages from another project or from an XML file that was exported from another project.

To import accessory packages

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

6. Click OK to close the Accessory Packages window.

Export Accessory Packages
You can export accessory packages to an XML file (for example, to import into another project or to edit using other 
software).

To export accessory packages

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Check the Export check boxes for the accessory packages you want to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.

8. Click OK to close the Accessory Packages window.

Naming Conventions
Naming conventions control how ShipConstructor automatically names elements of your project such as drawings, parts, 
spools, penetrations, and so on.

There are many types of naming conventions. ShipConstructor organizes them within a tree.

You can set up several different naming conventions within each category, but only one naming convention in each 
category can be the active naming convention that is used by ShipConstructor.

A naming convention is composed of elements. You set up a naming convention by choosing various elements, arranging 
them in order, and setting their values. When ShipConstructor automatically generates a name, it formats the name 
using the elements of the active naming convention.
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Naming Conventions Window

The Naming Conventions window consists of three information views.

• Naming Conventions tree (left)

• Naming Convention Elements list (top right)

• Element Details list (bottom)

Naming Conventions Tree
The Naming Conventions tree displays all the ShipConstructor entity types that names can be generated for and the 
naming conventions created for those entities. For each naming convention, ShipConstructor uses the Active column to 
show if the naming convention is the active naming convention for the entity type. Through the InUse column, 
ShipConstructor shows if there are any entities in the project that have a name generated with each naming convention.

Naming conventions can be defined at any level in the tree and apply to an entity type and all of its children entity types. 
For example, you define a naming convention PartNameConvention (convention A) for Structure > Parts and a naming
convention PlateNameConvention (convention B) for Structure > Parts > Plate. 
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If you create a part of any type other than Structure > Parts > Plate, ShipConstructor will use naming convention A to 
generate the name. If you create a Structure > Parts > Plate, ShipConstructor will apply naming convention B.

You can define multiple naming conventions for each entity type. Depending on the type of entity, ShipConstructor may or 
may not allow you to pick a name convention to use when creating entities. In cases where you are not offered a choice, 
the Active naming convention is used. 

Naming Convention Elements List
A naming convention consists of elements that can be added, removed, and re-ordered. The elements list shows the 
elements of a naming convention and their order. The elements list shows element properties in the selected naming 
convention. Changing the properties of an element is done using the Details list.

There are three types of elements:

1. Static strings

2. Database items

3. Auto-Incrementing numbers

Static strings are user-entered text such as a word or a symbol (for example, a hyphen (-) to separate other elements).  

Database items are a property of the entity for which the name is being generated. For example, the spec that an HVAC 
duct belongs to or the thickness of the plate stock that a plate part is made from. There are many different types of 
database items to choose from depending on the entity type that you are defining a naming convention for. The 
properties of a database item element are as follows:

• Number of characters – The maximum number of characters to display from the database item string.

• Start Point -- The position to start counting the number of characters from. The options are Beginning or End.

• Offset – The number of characters to skip from the offset before including the number of characters.

• Use As Name Seed – Indicates whether or not to use this element when determining the next auto-number 
choice. This will be explained in more detail below.
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Auto-Incrementing numbers are used to facilitate the creation of unique names. The properties of an auto-incrementing 
number are the following:

• Number of digits – A number representing the minimum number of digits used to display the auto-number. Can 
be set to Auto to automatically use as many digits as the number consists of. For example, if the generated 
number is 56 and the number of digits is set to 4, the auto-number would display as 0056. If the number of 
digits was set to Auto the number would display as 56.

• Start Value – The auto-number of the first generated name.

• Increment – The incremental value to add to each auto-number to calculate the next number. For example, an 
increment of 1 would create 6, 7, 8, 9, and an increment of 3 would create 6, 9, 12, 15.

• Recycle Numbers – A yes or no value. If you set the value to yes, then any entities that are renamed or deleted 
will have their name go back into a pool to be re-used again. For example, if you have recycling enabled and you 
create plate parts named P-67, P-68, and P-69 and then delete part P-68, the next plate part that you create will 
have the name P-68, not P-70.

Element Details List
The Details list shows the properties of the element selected in the Elements list.

Create a Naming Convention
Before being able to add, edit, and remove elements, create and change aliases, and modify the naming convention 
itself, you must create your naming convention.  

To create a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. In the Name Conventions pane, select the type of naming convention to create. Creating a lower level naming 
convention will override one at a higher level.

4. Click New. ShipConstructor creates a new entry in the tree with a default name.

5. Type a name for the naming convention and press Enter.

6. Add elements to the naming convention. See Add an Element to a Naming Convention (page 78)
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Add an Element to a Naming Convention

To add an element to a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. In the Name Conventions pane, select the naming convention.

Any existing elements are displayed in the Elements pane.

Under Elements, a button with one of the labels described above allows you to add an element.

If the label doesn’t match the element you want to add, click to show the other types of elements.

Note: Make sure each naming convention consists of at least one Static element and one AutoNumber element.

4. The new element is listed under Elements and is automatically selected.

The element’s properties are listed in the window.

5. Set the Value for each Property. See Edit an Element of a Naming Convention (page 78).

6. Click Test to generate a sample name.

7. If you are satisfied with your convention, click OK to close the Naming Conventions window.

Edit an Element of a Naming Convention

To edit an element of a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention.

4. Under Elements, select the element you want to edit.

5. Beneath the Elements pane, set the Value for each Property.

6. Click Test to generate a sample name.

7. If you are satisfied with your convention, click OK to close the Naming Conventions window.

Re-order Elements in a Naming Convention

To re-order elements in a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention.

The naming convention’s elements are listed in the Elements pane in order.

4. From the Elements pane, select the element and then click the up and down arrows to move the element 
up or down in the list

5. Click Test to generate a sample name.

6. If you are satisfied with the convention, click OK to close the Naming Conventions window.

Remove an Element from a Naming Convention

To remove an element from a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention.
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4. Under Elements, select the element you want to remove.

5. Under Elements, click Delete.

Activate a Naming Convention
Because you can set up many naming conventions, you must choose one to be the active naming convention for a 
project.

To activate a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention you want to activate.

4. Click Set Active.

A checkmark appears beside the naming convention, indicating that it is the active naming convention for that 
category.

Rename a Naming Convention

To rename a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention you want to rename.

4. Click Rename.

5. Enter a new name and press Enter.

Delete a Naming Convention

To delete a naming convention

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Under Name Conventions, select the naming convention you want to delete.

4. Click Delete.

Managing Aliases
Aliases are used in naming conventions to customize the way that some database items are displayed. For example, 
when defining a naming convention for a structure plate part, you may include the part side in the name. By default the 
part sides are displayed as Port, Starboard, and Centerline. You may, however, want to shorten those to PT, ST, and C. 
This can be accomplished using naming convention aliases.

To start the alias manager

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Naming Conventions (page 228) to open the Naming Conventions window.

3. Click the Manage Aliases button on the bottom left on the Naming Conventions window to open the Alias Manager
window.
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To define an alias

1. Open the Alias Manager.

2. Select the Database Item you wish to create an alias for from the drop-down box.

3. Double-click under the Alias column the row corresponding to the item you wish to create an alias for.

4. Type your alias and press the Enter key.

5. Click the OK button.

Generating Names in Groups
The Generate Names window is used for generating names for groups of items without having to open drawings. 

To open the Generate Names window

1. Click the Generate Names button in the Naming Convention window.
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The Generate Names window displays a hierarchy of ShipConstructor entities representing categories of nameable items 
in ShipConstructor.

To Regenerate Names for a Set of ShipConstructor Entities

1. Click the checkboxes in the tree corresponding to the ShipConstructor entities that you wish to regenerate names for

2. Click the Generate button

For all of the entities contained in the groups selected in the tree, ShipConstructor regenerates names using the Name 
Convention that was used to generate the original name. Any entities that do not have an existing generated name will 
not have names generated for them. 

ShipConstructor also attempts to keep the same auto number for the regenerated names. For example, you change a 
naming convention to remove the part side element. The part whose name is Unit01-Port-436 will be renamed to Unit01-
436 if that name is available. Otherwise, it will take the next available name. This feature is also beneficial because when 
regenerating names, if the naming convention definition has not been changed, parts that already have a generated
name will not have their name changed.

There are two additional checkbox options on the Generate Names window.

• Generate Names for Items without Currently Generated Name

• Use Active Name Convention

Selecting the Generate Names for Items without Currently Generated Name option will generate names for all 
ShipConstructor entities that match the groups selected in the tree regardless of whether or not they have an existing 
generated name. If the Use Active Name Convention option is not set, entities that have an existing generated name have 
their names regenerated using the Name Convention their name was last generated with. Entities that do not have a 
generated name will have a name generated using the current Active Name Convention.

Selecting the Use Active Name Convention option will cause all generated names to be generated using the current active 
Name Convention for their category.

Naming Convention Concepts

Understanding Seeding
Seeding allows you more control over how your names are generated. This is best illustrated by an example. Suppose you 
have a naming convention defined with three elements: Material - System - Auto-number. The auto-number starting 
number is one and the increment is one. The first part you create may have a name like:

M1-FreshWater-001

In this example, the part is made from a material named M1 and is in the Fresh Water system. For this example we will 
assume that both the Material element and the System element are seeds. If you create a new part that was also made 
from material M1 and in system Fresh Water, the name will be as follows:

M1-FreshWater-002

If you create a third part that was made of material M1 but was in the Salt Water system, ShipConstructor will generate a 
part name as follows:

M1-SaltWater-001

Notice how the number has restarted at 1. This is because one of your seed elements has changed, in this case the 
System. If you create a fourth part, this time back in the Fresh Water system but with material M2, ShipConstructor would 
generate a name as follows:

M2-FreshWater-001

Again the numbering scheme has changed because the combination of your two seed elements does not match anything 
we have seen previously. If you now create a fifth and sixth part made from material M2 and in system Fresh Water, 
ShipConstructor will generate the names as follows:

M2-FreshWater-002

M2-FreshWater-003

To further illustrate the nature of seeding, consider the following example. To make things simple, pretend that you are 
again working with a fresh project and have not generated the names above. You define a name convention identical to 
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the one in the example above (Material - System - Auto-number) except that instead of both the Material and System
elements being seeds, only the Material is a seed element. Following the same procedure as above your part names will 
look as follows:

M1-FreshWater-001

M1-FreshWater-002

M1-SaltWater-003

Notice how even though the system changed from Fresh Water to Salt Water, the numbering scheme did not change; it 
continued counting up. This is because the system is not a seed element. If you create two more parts, the names will be 
as follows:

M2-FreshWater-001

M2-SaltWater-002

Notice how the numbering scheme changed the first time because the material element changed but continued counting 
up the second time.

Database Elements
The power in naming conventions lies in the ability to generate names based on entity attributes stored in the database. 
The following are descriptions of all the database elements currently supported by ShipConstructor. 

Assembly
Assembly returns the primary build strategy assembly name of an ancestor assembly of your entity. Which level’s 
assembly name is returned depends on which Assembly Tree Level you select from the Tree Level drop-down list. The list 
of assembly levels depends on how you structure your Product Hierarchy tree. 

Note: If the part is in an assembly with a level higher than selected assembly tree level, nothing is returned for that 
element.

Extrusion Profile Standard Type
Extrusion Profile Standard Type applies to stiffeners. Examples of extrusion profile standard types are angle, bulb flat, 
structural pipe, custom, and tee. Extrusion profile standard types can be aliased using the Naming Convention Alias 
Manager.

File Path
File Path applies to Plate Nests. It returns the path to the plate nest drawing starting from the Nest folder. The purpose of 
the file path element is to allow users to put the build strategy location in the plate nest name.

This is done by creating a directory structure in the Nests folder that matches the build strategy and then putting plate 
nest drawings at the appropriate location in the folder structure. 

Major Stock Type
Major Stock Type applies to all Structure parts. Examples of major stock types are plate, extrusion, corrugated and plank. 
Major stock types can be aliased using the Naming Convention Alias Manager.

Material
Material returns the material name of the stock.

Material Grade
Material Grade returns the material grade of the stock.

Nest Drawing
Nest Drawing returns the nest drawing name of plate nests.
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Nominal Size
Nominal Size returns the nominal size of the pipe stock.

Part Side
Part Side returns the side of the ship on which the structure part lies.

Part Type
Part Type applies to Structure parts. Examples of part types are plate, stiffener, corrugation, faceplate, and plank. Part 
types can be aliases using the Naming Convention Alias Manager.

Planar Group Model Drawing
Planar Group Model Drawing returns the planar group model drawing that the structure part is modeled in.

Plate Stock Length
Plate Stock Length returns the length of the plate stock item that the structure part is made from.

Plate Stock Width
Plate Stock Width returns the width of the plate stock item that the structure part is made from.

Pressure Rating
Pressure Rating returns the pressure rating of the pipe stock.

Profile Plot Drawing
Profile Plot Drawing returns the profile plot drawing name of profile nests.

Project
Project returns the name of the ShipConstructor project.

Remnant
Remnant returns the name of the remnant that the plate nest was cut from.

Sheet Stock
Sheet Stock returns the name of the sheet stock that the HVAC stock is made from.

Stock
Stock returns the name of the stock that the part is made from.

System
System returns the spec level, system level, or branch level system name of the system of your entity. Which level is 
returned depends on your selection in the Tree Level drop-down list.

Note: If the entity is in a system with a level higher than the selected system tree level, nothing is returned for that 
element

Thickness
Thickness returns the thickness of the plate stock that the plate part is made from.

User-Defined Attributes
User-defined attributes let you define custom attributes to hold arbitrary data associated with a part (for example, model 
number, process codes, or custom identifiers), making it easier to manage parts. You can set up user-defined attributes 
for Structure, Pipe, and HVAC. Attributes assigned to parts can have four states: not required, required and deferrable, 
required and not deferrable, and finally, required default deferred. Stock attributes have two: required or not required.
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The same attribute can be assigned to different object types, each with their own required state and default value.

Create a User-Defined Attribute

To create a user-defined attribute

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > User-Defined Attributes (page 227) to open the User-Defined Attributes window.

3. Click New.

4. Enter a name for the attribute and press Enter.

5. Optionally, add a description.

6. Click OK to close the User-Defined Attributes window.

Assign a User-Defined Attribute to a Material Grade

To assign a user-defined attribute to a part or stock

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > User-Defined Attributes (page 227) to open the User-Defined Attributes window.

3. Select the attribute on the left side of the window

4. Select the part or stock on the right side of the window.

5. Click the right arrow button .

The attribute is now listed beneath the part or stock.

Note: To remove an attribute from a part or stock, select the attribute on the right side of the window and click 

the left arrow button .

6. Set the Required state.

7. Optionally, set a default value.

8. Click OK to close the User-Defined Attributes window.

When you add a user-defined attribute to stocks or a stock size, the attribute will appear as an additional column in 
the stock list (or stock size list). Required attributes appear with a * after their name.

When you add a user-defined attribute to parts, the attribute will appear on the User Attributes tab of the Part
Properties window. Required attributes will already be assigned to the part.
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Default Values on Required User-Defined Attributes
Required user attributes do not have to have a default value, with one notable exception. If the attribute is either 
“required” (for stocks and stock sizes) or “required not deferrable” (for parts), and those objects already exist, then a 
default value must be provided.

For example, if an attribute is assigned to the plate part type, and it is set as “required not deferrable”, and there are no 
plate parts created yet, then the attribute does not need a default value.  However, if some plate parts already exist, a 
default value must be provided.

This is because an object cannot have a required attribute without a value: all the existing objects will need a value for 
the new attribute.

This requirement prevents the User-Defined Attributes window from closing, if there are any missing default values.  A 
message window will appear listing the attribute name and the object type for that attributes.

Import a User-Defined Attribute

To export a user-defined attribute

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > User-Defined Attributes (page 227) to open the User-Defined Attributes window.

3. Click Import UDAs.

4. Browse to the selected xml or pro file.

5. Click OK.

Part User-Defined Attributes
User-defined attributes are values that can be associated with any part type. The list is defined in Manager. Those 
attributes can be assigned to each part type. And then that attribute can be either be required or not required for the part 
type. The required state has three levels to it: required and deferrable, required and not deferrable, and required default 
deferred. Deferrable attribute can be deferred for later; therefore, it’s not required to provide a value during the creation 
(or editing). However, a value will need to be provided later.

Required attributes are automatically assigned to a part during creation. The deferred state is set if the attribute is 
required default deferred. The default value will also be set, if one was provided. Attributes set as required and not 
deferrable must have a value before the properties window can be closed. This also applies to any required and 
deferrable or required default deferred attributes without the “deferred” state set and no value.

Providing a value allows the user to continue, or simply set the “deferred” state (for those attributes that can be deferred). 
The “deferred” state checkbox is gray for required and not deferrable attributes.

The left side of the properties window lists all the available attributes. Only non-required attributes can be in the list. 
Default values will be used, if set. Providing/editing the value for a deferred attribute will clear the deferred state.

The right side lists all the attributes assigned to this part, along with their required and deferred states, and attribute 
value. Only non-required attributes can be removed from this list.

The following is an image of the User Attributes page in the Part Properties window:
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All related parts will have the same user attributes. Adding or removing an attribute to a part will also add or remove that 
attribute to all related parts. However, the values do not have to be same between related parts.

Utility Procedures

Activate a UCS

To activate a UCS from an object

1. Choose SC Utilities > Activate UCS (page 270) to open the UCS window.

2. Click Activate from Object.

3. Select the object.

ShipConstructor calculates the UCS differently for different types of objects:

• Standard AutoCAD objects – ShipConstructor determines the UCS plane of the object.

• ShipConstructor parts – ShipConstructor lets you choose the UCS:

• Stiffeners – ShipConstructor displays the following window, letting you select one of four UCSs associated 
with an end of a stiffener.
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• Plates – ShipConstructor displays the following window.

To activate a UCS

1. Choose SC Utilities > Activate UCS (page 270) to open the UCS window.

Select the UCS from Activate from list.

2. Click Activate.

Select a UCS Viewpoint
Selecting a UCS viewpoint is the easiest way to obtain a plan view to the currently active UCS, especially if the UCS is 
canted, such as for a sloping deck.

To select a UCS viewpoint

1. Choose SC Utilities > 3D Viewpoint (page 269) to open the Select View window.

2. Click the Plan tab.
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Views for the current UCS are listed under Current UCS.

If you are currently in a planar group drawing, the views for the construction UCS are listed under Construction UCS.

Note: The view names are based on the orientation of the UCS, for example, Looking Aft.

3. Select a view.

4. Click OK.

Activate a Layer
When you activate a layer, the objects on the layer become visible and available to edit.

To activate a layer

1. Choose SC Utilities > Layer > Activate (page 278) to open the Select Layer to Activate window.

2. Select the layer you want to activate.

3. Click OK.

Deactivate a Layer
When you deactivate a layer, the objects on the layer become hidden and are unavailable for editing (that is, they 
become frozen).

To deactivate a layer

1. Choose SC Utilities > Layer > Deactivate (page 278) to open the Select Layer to Deactivate window.

2. Select the layer to deactivate.
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3. Click OK.

Copy Objects from One Layer to Another

To copy objects from one layer to another

1. Choose SC Utilities > Layer > Copy Geometry to (page 279)

2. Select the objects you want to copy.

3. Press Enter

The Copy Geometry to Layer window appears.

4. Select the layer to copy the objects to.

5. Click OK.

Move Objects from One Layer to Another

To move objects from one layer to another

1. Choose SC Utilities > Layer > Move Geometry to (page 279)

2. Select the objects you want to move.

3. Press Enter

The Move Geometry to Layer window appears.

4. Select the layer to move the objects to.

5. Click OK.

Mirror Parts

Mirror Parts About the Centerline
You can mirror one or more parts about the centerline. Each part automatically receives a new part name. You can swap 
text strings in the mirrored parts, as indicated in the window below.

To mirror a part about the centerline

1. Choose SC Utilities > Mirror about Centerline (page 280)

2. Select all objects that you want to mirror and then press Enter. 

The parts are mirrored to the desired side. All mirrored parts are assigned new names automatically. The project 
database is also updated with the new parts. Using the above window as an example, the word PORT will be 
replaced with STBD in the starboard versions of the parts.

Mirror Catamaran Hulls 
You can mirror parts for catamaran hulls saving hours of work when modeling twin-hulled vessels. The AutoCAD MIRROR
command lets you mirror about any line.

Object Display

Hide or Show Objects
Sometimes it is difficult to select an object when many other objects are near it. You can hide objects to make it easier to 
see or select the objects you are interested in. This is especially helpful when many objects are on the same layer.
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Note: When you hide an object, ShipConstructor does not move it to a hidden layer. Instead, ShipConstructor simply 
does not display the object.

To hide objects

1. Select the objects to hide.

2. Choose SC Utilities > Hide Objects (page 272)

To show objects

1. Choose SC Utilities > Unhide Objects (page 273)

ShipConstructor shows the objects, one at a time, that you most recently hid.

If you choose SC Utilities > Unhide Objects (page 273) again, ShipConstructor will continue showing objects in the 
reverse order that you hid them.

To show all objects

1. Choose SC Utilities > Unhide All Objects (page 273)

Display Objects in Wireframe, Hidden Line, or Shaded Mode
You can control whether objects in your drawing are displayed in wireframe, hidden line, or shaded mode.

To display objects in wireframe, hidden line, or shaded mode

1. Choose the mode you want from View > Visual Styles.

Display Information for an Object within an MLinked Drawing
You can list information on an object within a model linked (mlinked) drawing, providing more information for the 
designer during modeling, checking, or reviewing of a particular area in the 3D product model.

To display information for an object within an mlinked drawing

1. Choose SC Utilities > List Item within Block/Xref (page 289)

2. Select the object within your drawing that you want to see information about.

The information appears within the command line.

Part Views
A Part View is a snapshot of a part that can be loaded into any drawing to be used for reference or for enhanced display 
capabilities. Part Views cannot be edited and changes made directly to the Part View will not affect the parts they were 
created from.

Part View Advantages
• Load a view of any part into any ShipConstructor drawing

• Improved Live Sectioning support

• Flexible to support many loading strategies (ie.Load via Assembly, Extents, Relationships…ect)

Supported ShipConstructor Entities
• All Structure Parts

• All Pipe Parts

• All HVAC Parts

• Equipment
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• Supports

• Standard Assemblies (as individual parts)

• Hangers

Licensing
User will need to have a valid Universal, Structure, Pipe, Equipment, HVAC, or Electrical license and up-do-date 
ShipConstructor subscription to run any of the PartView commands.

Loading Part Views
When Part Views are loaded any parts which currently exist in the current or any M-Linked drawings will not be created as 
Part Views. If a Part View is loaded into a drawing in which there is already a Part View in the drawing for the same 
contained part then the existing Part View will be updated and a new Part View is not created.

Export

Export a ShipConstructor Drawing to an AutoCAD only Drawing
You may wish to open a ShipConstructor drawing on a machine that does not have ShipConstructor. To facilitate this 
ShipConstructor has a command that creates a drawing containing only AutoCAD entities from any ShipConstructor 
drawing.

To export a ShipConstructor drawing to an AutoCAD only drawing

1. Choose the SC Utilities > Export > Export to Dwg… (page 289) menu command.

2. If any changes have been made to the current drawing, you will be asked if you wish to save. Click Yes to continue 
with the export.

3. The Export To Drawing Configuration dialog will appear. Select the part attributes in the drawing that are to be 
exported by selecting either Show or Hide under the Value column. Define a layer name for the attribute by 
overriding the text in the Layer Tempate column. By default, the layer name that is curently assigned to the attribute 
is exported as indicated by the <Source Layer> text.  
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4. In the Save As window that appears, choose a location and name for the exported drawing and click Save.

5. The export will proceed and will open up the new AutoCAD drawing when it is complete.

Note: Everything in the ShipConstructor drawing will be exported to the new drawing, including any hidden objects or 
layers.

Export ShipConstructor Drawings to NavisWorks Drawings
It is possible to export the current drawing to a NavisWorks NWC file.

To export ShipConstructor drawings to a NavisWorks drawing

1. Open a drawing with the drawing options you want to see in the exported files.



Library Setup

93

2. Choose SC Utilities > Export > Export to NWC (page 289).

3. If any changes have been made to the current drawing, you will be asked if you wish to save. Click Yes to 
continue with the export.

4. A window will appear where you can select the drawings from the ShipConstructor hierarchy that you wish 
to export.

5. Click OK to continue. 

6. Each selected drawing from Step 3 will automatically be opened in ShipConstructor and exported to the 
chosen NavisWorks drawing format. 

7. The exported files are created in the same folder as the original drawing with the same name and NWC 
extension.

Unit Setup
You must decide how you want to divide your vessel (project) into production units (also known as blocks). The size of a 
unit is usually determined by the maximum weight that the shipyard can handle. Once you have decided where the unit 
breaks will occur, you can set up and name the units in ShipConstructor. When you create a unit in ShipConstructor, you 
simultaneously create a unit drawing.

A typical unit

Create Units

To create a unit

Note: You can create a unit from within an empty drawing or from within a drawing that contains the sections for the 
new unit.

1. In the Navigator, select the Project page.
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2. Click New Unit to open the New Unit window.

3. In the Unit Name text box, type a unit name.

4. Select whether to create a blank drawing as a new unit drawing (the default), or use the current drawing as a new 
unit drawing.

5. Click OK.

Delete Units
There is no easy way to delete a unit, because each unit is linked to so many other parts of a project.

To delete a unit

1. Use the Navigator to delete all planar group drawings, pipe drawings, HVAC drawings, and equipment arrangement 
drawings for the unit.

2. Use Windows Explorer to delete the folder for the unit.

3. Use the Product Hierarchy palette to delete the unit.

Product Hierarchies
Product hierarchies are the sequence of grouping parts together. The build strategy is the main product hierarchy. The 
build strategy is the sequence that the parts in your project will be physically assembled in. Product hierarchy is also 
referred to as product work breakdown structure (PWBS).

Product hierarchies consist of several levels. At the lowest level, individual parts are assembled to form minor 
assemblies. At the next level, minor assemblies are combined to form panels. At subsequent levels, panels are combined 
to form assemblies, assemblies are combined to form stages, stages are combined to form units, and units are 
combined to form the completed project.

The first step in developing a product hierarchy is to divide your project into units. See Unit Setup (page 93). The top level 
of the product hierarchy is always the project, and the project is always divided into units. Typically you perform this step 
of the product hierarchy before you begin designing parts. (Some shipyards prefer to name their project based on the unit 
they belong to.)
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Next, you set up the available sub-levels that you potentially want to use within your units. See Set Up Assembly Levels
(page 101). These levels are referred to as assembly levels. The levels listed above are ShipConstructor’s default 
assembly levels, but you can modify them as necessary.

Note: The word assembly has several meanings. In the general sense, an assembly (or assembly level) refers to any 
level within or under the unit. In the specific sense, an assembly refers to the level above panel (that is, an assembly 
is composed of several panels). An assembly (or assembly item) can also mean any item of several parts (for 
example, assembly XYZ could refer to a panel, a unit, or other item).

Next, you decide which specific stages to use for each specific unit, which specific assemblies to use for each specific 
stage, and so on. See Set Up Assemblies (page 104). For example, you may want to divide unit U12 into five stages: 
COLDOUTFIT, HOTOUTFIT, HVAC, PIPING, and STRUCTURE. At the lowest level, you assign individual parts to assemblies. 
See Assign Parts, Spools, or Assemblies to Assemblies (page 106). Obviously, you cannot perform this step in the product 
hierarchy process until you have actually created your parts.

When assigning parts to assemblies, it is helpful to use a product hierarchy drawing so you can see all parts within a unit. 
See Setting up Multiple Product Hierarchies (page 95).

Finally, you must decide on a time schedule for each assembly, indicating when it will be completed.

Setting Up Multiple Product Hierarchies
You can set up multiple hierarchies within a project. For example, in addition to the build strategy used for assembly, you 
may want to create a separate hierarchy used for a SWBS breakdown, another for weight quality control and analysis, 
and a third for paint planning.

To create a new product hierarchy

1. Choose ShipConstructor > Product Hierarchy (page 261).
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2. Choose Tools > Product Hierarchy > New.

3. Enter a new Product Hierarchy name and click OK.

All parts will be assigned to the appropriate unit assembly of the new product hierarchy. Each product hierarchy has 
its own levels.

Copy Product Hierarchy
This feature allows you to create a new Product Hierarchy from an existing Product Hierarchy.  You can choose if 
you want to copy Assembly and Part hierarchy, or just the Assembly hierarchy.
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What is copied:
• Assemblies
• Assembly Levels
• Assembly User-Defined Attributes
• Finishes
• Part locations if you choose to copy Assembly and Part hierarchy.

Notes: If you are copying the Primary Product Hierarchy, Units and Standard Assemblies will become Assemblies 
in the new Product Hierarchy.

If you choose to copy only the Assembly hierarchy, parts will be located in their default “Unassigned” Assembly.  For 
example, Structure parts would be located in the “Unassigned Structure” Assembly.

To copy an existing product hierarchy
1. Open the Product Hierarchy palette.

2. Select the Product Hierarchy you wish to copy.

3. From the menu, select Tools > Product Hierarchy> Copy…

4. Provide the name of the new Product Hierarchy

5. If you want to copy part assignments to Assemblies, select Copy Part Locations

6. Click OK

To copy an existing product hierarchy from the command line
1. Run the -SCProductHierarchyCopy command.

2. Provide the name of the Product Hierarchy that you want to copy.

3. Provide the name of the new Product Hierarchy.

4. Indicate if you want to copy the Assembly and Parts hierarchy (yes) or just the Assembly hierarchy (no).

A new Product Hierarchy will be created, and can be viewed in the Product Hierarchy palette.

Export a Product Hierarchy to another ShipConstructor project
A product hierarchy can be exported to an xml file for importing into another ShipConstructor project.

To export an existing product hierarchy
1. Open the Product Hierarchy palette.

2. Select the Product Hierarchy you wish to export.

3. From the menu, select Tools > Product Hierarchy> Export…

4. Provide the name of the xml file for saving the export data.

To export an existing product hierarchy from the command line
1. Run the -SCProductHierarchyExport command.

2. Provide the name of the Product Hierarchy that you want to export.

3. Provide the name of the xml file for saving the export data.

Import a Product Hierarchy from another ShipConstructor project
A product hierarchy can be imported from an xml file that was exported from another ShipConstructor project.

What is imported:

• Assemblies

• Assembly Levels



Library Setup

98

• Assembly User-Defined Attributes

Note:If you are importing a Primary Product Hierarchy, Units and Standard Assemblies will become Assemblies in the 
new Product Hierarchy.

To import a product hierarchy
1. Open the Product Hierarchy palette.

2. From the menu, select Tools > Product Hierarchy> Import…

3. Provide the name of the xml file containing the importing Product Hierarchy.

If the import is successful, a new Product Hierarchy will be created.

To export an existing product hierarchy from the command line
1. Run the -SCProductHierarchyImport command.

2. Provide the name of the xml file containing the importing Product Hierarchy.

If the import is successful, a new Product Hierarchy will be created.  To view this new product hierarchy, open the 
Product Hierarchy palette.

Set Up Product Hierarchy Drawings
A product hierarchy drawing contains all the parts for a unit, including structure, equipment, piping, HVAC, and so on. You 
usually set up a product hierarchy drawing for a unit so you can see the parts as you develop a product hierarchy. You can 
make a specific assembly visible and check that all required parts are in that build stage or change the parts involved in a 
build stage by dragging them to another build stage.

Create a Product Hierarchy Drawing

To create a product hierarchy drawing

1. In Navigator, select the Product Hierarchy page.

2. Click New.
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3. Choose a template from which to base the appearance of the new drawing.

4. Enter a new drawing name and click OK.

5. The New Product Hierarchy Drawing window appears.
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6. Select the drawings to include in the product hierarchy drawing.

7. Click OK.

Note: If any parts are created after you create a product hierarchy drawing, the new parts will not appear in the 
drawing unless you update it.

Rename a Product Hierarchy Drawing

To rename a product hierarchy drawing

1. In Navigator, select the Product Hierarchy page.

2. Right-click the product hierarchy drawing and choose Rename.

3. Enter a new name and press Enter.

Delete a Product Hierarchy Drawing

To delete a product hierarchy drawing

1. In Navigator, select the Product Hierarchy page.



Library Setup

101

2. Right-click the product hierarchy drawing and choose Delete.

Set Up Assembly Levels

To set up assembly levels

Note: You may want to create a product hierarchy drawing before setting up assembly levels (see Create a Product 
Hierarchy Drawing (page 98)). The product hierarchy drawing will help you see the parts as you develop a product 
hierarchy. You can make a specific assembly visible and check that all required parts are in that build stage or 
change the parts involved in a build stage by dragging them to another build stage. (If you open an old product 
hierarchy drawing, any parts that have been created after the drawing was created or updated do not appear in the 
drawing.)

1. Do either of the following:

• Within a product hierarchy drawing, choose ShipConstructor > Product Hierarchy (page 261)

• Within any drawing, click on the Assembly Toolbar

The Product Hierarchy palette appears.
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Note: When the Product Hierarchy palette is open, you can continue to perform commands in the drawing, such 
as changing your view, changing the shading mode, and so on. You can also dock the palette to the AutoCAD 
window.

The tabs represent different product hierarchies. The default product hierarchy is Build Strategy. To select a different 
product hierarchy, click its tab. To create a new product hierarchy, choose Tools > Product Hierarchy > New and enter 
a name for the product hierarchy. To delete a product hierarchy, click its tab and then choose Tools > Product 
Hierarchy > Delete. To rename a product hierarchy, click its tab and then choose Tools > Product Hierarchy > 
Rename.

2. Choose Tools > Edit Levels… to open the Edit Levels window.

This window lists the levels of the current product hierarchy. Later, you will assign parts and assemblies to the 
various levels. A typical configuration for levels is:

• Project – The top level of the product hierarchy.

• Unit – Every project must have at least one unit. A typical project consists of several units. A smaller project may 
have only one unit (Hull plus wheel house).

• Stages – Often the final assembly is carried out using many stages that usually combine assemblies and 
panels. A unit can contain several levels of stages; in some cases, there can be twenty levels of stages between 
the assembly and the unit.

• Assembly – An assembly (also known as a 3D assembly) consists of several panels, plus some individual parts. 
A typical assembly might be a double bottom, a wing tank, or something similar.

• Panel – A panel may be flat or curved and traditionally consists of one or more plate parts plus several 
stiffeners.

You can add, delete, or re-order levels to suit your project.

To add a level, select the level to create a new level under, click New, and enter a name for the level.

To delete a level, select the level and click Delete.

To re-order a level, select the level and click the arrow buttons to move the level up or down.

Set Up User-Defined Attributes

You can create your own attributes for assigning values to Assemblies.  User-defined attributes are assigned to a product 
hierarchy, and each Assembly in that product hierarchy will have its own attribute values.  For more information, see User-
Defined Attributes (page 83).
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To create a new user-defined attribute

1. From the Product Hierarchy palette (see Set Up Assembly Levels (page 101)) menu,
select Tools > User-Defined Attributes…

2. Click New.

3. Enter a name for the attribute and press Enter.

4. Optionally, add a description.

5. Click OK to close the User-Defined Attributes window.

To assign an user-defined attribute to a Product Hierarchy

1. From the Product Hierarchy palette (see Set Up Assembly Levels (page 101)) menu,
select Tools > User-Defined Attributes…

2. Select the attribute on the left side of the window.

3. Select a product hierarchy on the right side of the window.

4. Click the right arrow button to assign.
The attribute is now listed under the product hierarchy.

5. Change the Required and Default values as needed.  Required attributes must have default values, and will be 
applied to each assembly in the product hierarchy.

To remove an user-defined attribute

1. From the Product Hierarchy palette (see Set Up Assembly Levels (page 101)) menu,
select Tools > User-Defined Attributes…

2. Select the attribute to be removed from a product hierarchy on the right side of the window.

3. Click the left arrow to remove.
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Set Up Assemblies

Add an Assembly to the Product Hierarchy

To add an assembly to the product hierarchy

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select an assembly to add a sub-assembly 
to, and choose Tools > Assembly > New. This option is also available if you right-click on the assembly.

The New Assembly window appears.

2. Set the options:

• Name – The name of the new assembly.

• Number – To create more than one assembly, enter the number of assemblies to create. (If you set Name to
FR122 and set Number to 3, ShipConstructor will create assemblies FR122, FR123, and FR124.) To create one 
assembly, set Number to 1.

• Interval – If Number is greater than 1, Interval is the interval between the numbers used in the assembly names.

• User-Defined Attributes – You may specify values for any user-defined attributes assigned to the current Product 
Hierarchy (see Set Up User-Defined Attributes (page 102)).  To specify a value, select the Attribute, make sure 
attribute is enabled with a check in the checkbox, then type a value in the Value field.  Attributes can be reset to 
their default value by clicking on the “Reset” button.

• Level – The level for the new assembly. (The list consists of assembly levels below the assembly you selected in 
the Product Hierarchy palette.)

• Finishes – All finishes.
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• Selected Finishes – Finishes assigned to the assembly. Select a finish from the Finishes list. Click the left arrow 
button to assign the finish to the assembly. You can use the up and down arrow buttons to reorder the finishes. 
Click the right arrow button to unassign a finish.

3. Click OK.

Rename an Assembly

To rename an assembly

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the assembly you want to rename
and choose Tools > Assembly > Rename. This option is also available if you right-click on the assembly. Unit-level 
assemblies cannot be renamed.

The assembly name in the tree is now editable.

2. Enter a new name and press Enter.

Edit an Assembly

To edit an assembly

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the assembly you want to edit and 
choose Tools > Assembly > Edit. This option is also available if you right-click on the assembly.

The Edit Assembly window appears.

2. Change the options.

3. Click OK.
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Delete an Assembly

To delete an assembly

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the assemblies you want to delete.

2. Choose Tools > Assembly > Delete.

ShipConstructor deletes the assemblies.

If the assembly contains parts, ShipConstructor re-assigns the parts to the parent of the deleted assembly.

If the assembly contains sub-assemblies, ShipConstructor deletes the sub-assemblies.

Change the Level of an Assembly
You may want to change the level of an assembly if you are adding a new assembly level but have already created some 
assemblies and need to move them up or down within the product hierarchy. If an assembly has the level directly below 
the level of its parent, and its level is the level directly above the level of its children, its level cannot be changed.

To change the level of an assembly

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the assemblies and choose Tools > 
Assembly > Edit or right-click on the assembly.

The Edit Assembly window appears.

2. Select the new level for the assemblies in the Level list.

3. Click OK.

Copy an Assembly

To copy an assembly to another assembly

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the assemblies you will copy and 
choose Tools > Copy Assemblies. This option is also available if you right-click on the assembly.

2. Select the assembly to paste the copied assemblies to and choose Tools > Paste Assemblies.

Assign Parts, Spools, or Assemblies to Assemblies
All three different types of objects (assemblies, spools, and parts) in the Product Hierarchy are assigned to an assembly. 
These assignments can be modified by assigning those objects to another assembly. There are two methods to do this.

To assign parts or assemblies to an assembly (method 1)

Note: You cannot undo (Edit > Undo) a product hierarchy assignment.

1. Select the parts (or spools or assemblies) in the current drawing or in the Product Hierarchy palette.

If you select parts in the drawing, they are automatically selected in the Product Hierarchy palette, and vice versa.

You can select multiple parts by holding down the Shift or Ctrl key.

2. In the Product Hierarchy palette, drag and drop the selected objects onto the target assembly to assign them to.  
When the Product Hierarchy is not split to the current project, then the parts cannot be moved, and “Product 
Hierarchy split to another project” is displayed in a tooltip window.
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To assign parts to an assembly that is beyond the limits of the Product Hierarchy palette, while dragging the parts, 
move the cursor above or below the Product Hierarchy palette to scroll the display within the Product Hierarchy
palette up or down. (To scroll to the top or bottom of the Product Hierarchy palette, hold down the Ctrl key while 
dragging. To scroll one page at a time, hold down the Shift key.)

You can assign an assembly to another assembly only if the moved assembly is below the level of the target 
assembly.

To assign parts to an assembly (method 2)

Note: You cannot undo (Edit > Undo) a product hierarchy assignment.

1. Select the parts and/or assemblies to reassign.

2. Choose Tools > Assign to Assembly.

3. The Select Assembly window appears.

4. Select the assembly to assign the object to.

5. Click OK.
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Find, Zoom, Remove, Hide, and Show Parts

To find a part

2. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), choose Tools > Find. This option is also 
available if you right-click on an assembly. The Find window can also be used to search for assemblies and/or 
spools.

The Find window appears.

3. Enter the full or partial name of the part.

4. Click OK.

ShipConstructor selects the part.

5. If the slected part is not the one you were searching for, you can choose Tools > Find Next (or press F3) to select the 
next part in the tree that contains the specified search word.

To zoom in to a part in the drawing

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the parts or assemblies to zoom in
to.

2. Right-click on any of the selected parts or assemblies and choose Zoom To.

3. If the parts are in the current drawing, ShipConstructor will zoom the drawing view so the parts fill the view.

To remove parts from a drawing

Warning: If you remove parts from a planar group drawing or curved group drawing, the parts will be deleted.

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), select the parts or assemblies.

2. Right-click on the selected parts and assemblies and choose Unload.

ShipConstructor removes the parts from the current drawing.

To hide or show parts in the drawing

1. In the Product Hierarchy palette (see Set Up Assembly Levels (page 101)), click the light bulb beside the part or 
assembly.

• Part is in the current drawing and it is visible.

• Part is in the current drawing but is not visible (Hidden).

• Part is not in the current drawing.
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• Assembly or spool with some hidden parts and some visible parts

When you click on the light bulb, ShipConstructor changes the part’s (or assembly’s) visibility in the current drawing. 
You can also use SC Utilities > Hide Objects, SC Utilities > Unhide Objects, and SC Utilities > Unhide All Objects to 
hide or show (unhide) parts.

Renaming Parts
Parts with generated names can be renamed through a variety of methods. The most common one is being assigned to a 
new assembly. Renaming, or changing the level of, an assembly that has parts assigned to it (or any of its children) will 
also regenerate the names of those parts. Names will only be generated from the part assembly assignments in the 
primary product hierarchy. Parts with user-defined names (such as Standard Parts) will never be renamed.

Parts will be renamed only when the current user owns the parts for that unit and their naming convention requires it.  
Only Structure parts and Hangers are affected by this, because the other part types do not allow assembly elements in 
their naming conventions.

If a project is split in such a way that separate users have control of a unit’s parts and that unit’s product hierarchy, then, 
after modifying the product hierarchy, those parts, with naming conventions indicating that the parts need to be renamed 
due to the modification, will not be renamed. If the user makes a change to the product hierarchy tree such that parts 
that he does not own will be modified, a window will appear warning him of this, and optionally listing the affected parts.

By default, when parts are renamed, they use their current autonumber: the elements in that name related to their 
location in the product hierarchy will be modified. However, some users prefer to model all their parts before defining the 
complete product hierarchy, and only assigning those parts later. This can cause parts to have exceptionally high 
autonumbers.

To allow the user to have their parts use the lowest number possible, there is an option for renaming. This option is 
available only to Structure.

In the Options menu, under Naming > Structure, there are two choices: Keep Autonumber and First Available. The default 
is Keep Autonumber. In the bottom right corner of the Product Hierarchy palette, there is an image indicating the current 
naming option: Keep Autonumber uses a “05 -> 05” image, and First Available uses a “05 -> 01” image.

Keep Autonumber does just that: parts will try and keep their autonumber when renamed. If that autonumber is 
unavailable (there may already be a part at the target assembly with that number), then it will look at all the identical 
parts for the part and try use their autonumbers, and if none of those are available, then it will use the next available 
number.

First Available will make the parts use the lowest autonumbers possible. If the part has identical parts, with generated
names, already at the target assembly, then find the lowest autonumber from that group, and use that number for the 
part being moved. If the part doesn't have identical parts at the target assembly, or none of the identical parts have 
generated names, then find the next available autonumber, and use the lower between the next autonumber and the 
part’s current autonumber. If that number is unavailable, then it will use the autonumber of an identical part, if it has any.
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Miscellaneous Geometry Tasks

Toolpath
The Toolpath command connects objects such as lines, arcs, and polylines to a closed toolpath. The function eliminates 
duplicate objects and corrects small gaps. If a gap is discovered that exceeds the GAptol shown on the command line, an 
error window appears. An error window can look like this:

Click the Create Circles button to create end circles that make it easy to find the problem. For example:

Create a Closed Toolpath
1. Choose SC Utilities > Toolpath (page 279)

Select objects or [GAptol=0.1]:
2. Window select all the objects. 

It does not matter if you select objects that are not part of the toolpath. The command only connects objects with no 
gaps or a gap less than the GAptol.

3. Press Enter.

4. The result of the toolpath operation appears in an information window. Click OK. 

Dihedral Angle
Use the Dihedral Angle command to determine the angle between two non-parallel planar objects. The dihedral angle 
between two planes is the angle between their two normal unit vectors .You can see the dihedral angle of two planes by 
looking at the planes along their intersection line.

Find the Dihedral Angle between Two Planar Objects
1. Choose SC Utilities > Dihedral Angle (page 280)

Note: ShipConstructor creates the dimension.style SCON_DihedralAngle for displaying dihedral angles in the drawing.

2. Select the two.objects you want to determine the dihedral angle for.

3. Press Enter.
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4. ShipConstructor displays the four possible dihedral angles as arcs. Select the dihedral angle that you want to display 
in the drawing by clicking on its arc.

Convert a 3D Object to a 2D Object
You can convert a 3D object to a 2D object on the XY plane of the current UCS. When you do so, ShipConstructor removes 
the Z component of the object. For example, a circle that is not parallel to the current UCS is converted to an elliptical 
polyline.

This may be useful if, for example, a polyline is slightly out of plane, or if you defined objects on the thickness throw UCS
and now want them in the construction UCS.

To convert a 3D object to a 2D object

1. Choose SC Utilities > 3D to 2D (page 276)

2. Select the objects to convert.

Project Shapes
You can project a shape from an orthogonal plane (frame, deck, longitudinal bulkhead) to a skewed plane along the X, Y, 
or Z axis of the world coordinate system.

Note: Projected circles that produce elliptical shapes are converted to line segmented polylines.

To project shapes from an orthogonal plane to a skewed plane

1. Choose SC Utilities > Orthographic Projection (page 277)

2. Select the objects you want to project.

3. Type the projection direction (in the world coordinate system): X, Y, or Z.

Reduce the Number of Vertices on Polylines
Some polylines may contain a large number of vertices. You can reduce the number of vertices on a polyline by removing 
vertices that are below a certain tolerance value. You may want to do this for various reasons:

• Display speed – Polylines that contain a large number of vertices take longer to display. Reducing the number of 
vertices on polylines can speed up your display. This is especially important when displaying solids. (If you create a 
solid from polylines that contain a large number of vertices, then the solid will also contain a large number of 
vertices and will slow down your display.)

• Computing speed – Computer calculations, such as interference checking, take longer for solids containing many 
vertices.

• File size – ACIS solids containing many vertices use enormous amounts of disk space.

• NC machine limitations – Many cutting machines will move erratically or start and stop at each polyline segment if 
there are too many vertices spaced closely together.
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Two identical frame sections. The upper frame section has many vertices (tolerance = 1 mm). The lower frame section has fewer vertices 
(tolerance = 3 mm).

To reduce the number of vertices on a polyline

1. Choose SC Utilities > Remove Vertices Below Tolerance (page 277)

2. Select the polyline you want to reduce.

3. Press Enter.
[No fit arcs] Tolerance <0.05>: 

4. To change the fit arcs option, type N for no fit arcs or F for fit arcs and press Enter.

5. Enter a tolerance value.

Tip: In general, a 0.1 mm (1/32”) tolerance is a good compromise between speed and accuracy.

6. Press Enter.

Convert an Ellipse or Spline to a Polyline
NC machines do not understand ellipses or splines. You must convert them to polylines.

To convert an ellipse or spline to a polyline

1. Choose SC Utilities > Convert Ellipse/Spline to Polyline (page 278)

The default tolerance appears in the command line.

2. To change the tolerance, type T and press Enter. Then type the tolerance and press Enter.

A good tolerance value is about 0.1 mm (1/32”).

3. Select the ellipse or spline you want to convert.

4. Press Enter.
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Create a Reference Line
Reference lines are useful reference locations in any drawing. They can be used to show positions of items in the vessel 
or as baselines for dimensioning. They can be created when the view is created. However if you forgot to setup reference 
lines during creation then you can manually create them after.

To create a reference line

8. Set up the current User Coordinate System (UCS) so that the reference line will be generated on the X or Y access of 
the UCS.

9. Choose Production > Production Utilities > Create Reference Line. Depending on the orientation of the UCS, the 
prompt will show relevant directions.
Enter direction [Longitudinal/Transverse] <Longitudinal>:

10. Select the axis direction desired.

A reference line is created across the extents of the drawing. 

Import Reference Line Styles
Reference line styles once set up can be copied around to different template or production drawings by importing them 
from a source drawing that has the st

To import reference line styles

1. Open the drawing you want to import reference line styles into.

2. Choose Production > Production Utilities > Import Reference Line Styles
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3. Browse for the source file.

4. Choose Yes to overwrite existing styles if the names match. Choose No if you do not want to overwrite existing 
reference line styles.
Imported 7 Reference Line Styles

The number of styles that were imported is output to the command window.

Set Up Snapping
ShipConstructor includes several snap settings that make it easier to work in three dimensions.

To set up snapping

1. Choose SC Utilities > Snap (page 290) to open the Drafting Settings window.

2. Set the options.
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• Project into UCS – Projects the picked point into the current UCS. For example, when drawing a line that you 
want in the UCS, you can pick points at elevation and they will be projected down onto the UCS. You can choose 
to project perpendicular to the plane (Orthogonal), along the WCS X axis (Longitude), along the WCS Y axis 
(Transverse), or along the WCS Z axis (Vertical).

• Absolute Ortho – Lets you draw orthogonal about the world coordinate system, independent of the current UCS. 
(The AutoCAD ORTHO command only lets you draw orthogonal to the current UCS.)

• Free End – See the HVAC manual for details. 

• End Axis Intersections – See the HVAC manual for details.

• Profile Corners – See the HVAC manual for details.

• Profile Edges – See the HVAC manual for details.

3. Click OK.

Invalid Parts

If there are any problems creating or drawing a part, that part may become invalid. Invalid parts are usually displayed 
hatched, as shown below:
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Invalid parts - if a valid boundary is not found the part is displayed as an X.

A part can become invalid for many reasons: the boundary is not closed, problems with the geometry or solid creation, or 
corrupt data in the database, for example. It is not always possible to determine the exact cause. The main purpose of 
invalid parts is to provide a mechanism to delete parts from the database that may otherwise not show up in the drawing. 
Deleting and re-creating the part is usually the best solution, but there are some common problems that may be fixed. 
These solutions may not be applicable to all part types:

• Check that the piecemark is inside the part's boundary. If not, move it back inside with the grip points.

• Check that the part's boundary is closed. If not, adjust the part’s boundary objects or add boundary lines to close 
any gaps.

• If a curved plate solid is created from a Rhino file, its production geometry will be shown as invalid. (See Curved 
Plate Creation in Stucture manual).

If the part remains invalid then the only other option is to delete and re-create the part. Also note that any commands run 
on the invalid part may not function as expected.

Checks

Check Interferences
Interference checking is a vital step in ShipConstructor that is used to detect part collision problems or to add 
penetrations for pipe and HVAC through structure. 

The interference drawing can also be used as a virtual reality fly-through. 
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Create an Interference Drawing

To create an interference drawing

1. In Navigator, select the Interference page.

2. Click New.

3. Choose a template from which to base the appearance of the new drawing.

4. Enter a name for the interference drawing and click OK.

The New Interference Drawing window appears.
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5. Click the check box beside the drawings you want to include in the interference drawing.

6. Click OK.

Checking Interferences
Typically, you create an interference drawing that includes several planar group drawings within it and then check 
interferences within the interference drawing. (You can also check interferences from within a planar group drawing.) 
ShipConstructor then checks the solids within the current drawing for collisions. (ShipConstructor does not check Xref
solids.)

Running the List command on the interference solid will list the interfering part names, and the volume and extents of 
the interference.

To check interferences

1. Create an interference drawing that includes the planar group drawings you want to check (see Create an 
Interference Drawing (page 117)).

2. Open the interference drawing you want and select an isometric viewpoint.

3. Choose SC Utilities > Check Local Interferences (page 289) to open the Interference List window.
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Note: You can continue using ShipConstructor with the Interference List window open. For example, you may 
want to change your viewpoint without closing the Interference List window. You can also close the Interference 
List window and re-open it by choosing SC Utilities > Check Local Interferences (page 289).

4. Click Run Check.

The two Solid Object Types lists let you control which types of objects to check for interferences.

Below the two lists is the number of possible interferences that ShipConstructor will check.

The Minimum Interference Volume lets you ignore very small interferences that might be due to computer rounding 
errors or are so small that they would not be noticed during construction.

5. Click OK to start the interference check.

The check may take several minutes.

ShipConstructor lists interferences in the Interference List window.

6. To have a better view of an interference in the drawing, turn on Center, right-click on the interference, and choose 
View. ShipConstructor hides all solids except for those involved in the interference. (You may need to move the 
Interference List window to see them.) Click the and buttons to zoom in and out.

7. To display the properties of an interference, right-click on it and choose Solution.
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The Solutions window displays the Physical Properties of the interference and lets you enter a suggested Solution.
For example: Shorten Stiffener.

8. To generate an interference report, in the Interference List window select the interferences to include in the report 
and click Report to open the Interference Report window.

9. Enter a Name for the interference report, select the information to include in the report, and click OK.

ShipConstructor displays the report in Notepad and saves the text file in <project 
folder>\LogFiles\<unit>\Interference\<my interference drawing> <time stamp>.txt.

Check Local Interferences
You can also check for interferences in a single planar group drawing without creating an interference drawing. This will 
only check for collisions between objects in a single drawing, but it eliminates the additional overhead of creating a new 
interference drawing.

To Check Local Interferences

1. Open the planar group drawing that you want to check for interferences.
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2. Choose SC Utilities > Check Local Interferences (page 289) to open the Interference List window.

3. Follow the steps described above in the Check Interferences section, starting at step 4.

Check Product Hierarchy
Checking the product hierarchy is not an automated command. You need to check the assignment of parts to 
assemblies. There can be cases where a modeler has mis-assigned a part to the wrong assembly or the assembly stages 
are not completely known at the time of modeling.

To check an assembly

1. Create a product hierarchy drawing. 

2. Check for correct assignment of parts to assemblies.

To check assemblies

1. Create assembly drawings for the unit.

2. Open each assembly drawing and verify that all the parts are there.

Check a Unit
When you check a unit, ShipConstructor checks the complete unit and its structure model drawings for errors. Before the 
check is run, you may choose to repair errors. If you select No, no modifications will be done to the drawings and errors 
will only be reported in the log file.

The unit check also updates the drawings to reflect any standards changes (if the option to repair errors was selected). 
When a change in the standards would change the physical properties of a part, the drawings need to be opened and 
saved to update weight and center of gravity data.

Checking a unit will also check that template drawings used by any of those unit’s drawings are both registered to the 
project and the drawing file exists. If the option to repair errors is selected, missing drawing files will be removed from the 
project, and any drawings that are not registered will be. Currently, the template types checked are Assembly, 
Pipe/HVAC/Equipment Arrangement, and Pipe/HVAC Spool.

To check a unit drawing

1. Choose ShipConstructor > Check > Check Unit (page 260)

ShipConstructor checks the unit drawing and displays the following message when finished; including a log file that
contains a summary of the check.
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Note: This log file can be rather long. Any errors and warnings can be easily found by searching (using Notepad’s Edit 
> Find) for either “Error” or “Warning”.

Update Model and System Drawings
You can use the Update Model and System Drawings command to recreate drawings in your project, or update them if 
they are out-of-date, using information from the database. This is especially useful if you do not have the permissions 
required to edit or create drawings, since otherwise the drawing would have to update itself every time it is opened.

To update model and/or system drawings

1. Choose ShipConstructor > Update Model and System Drawings (page 261).

2. The Select Drawings to Update window appears. 
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Select the drawings you wish to recreate or update using the ShipConstructor database. Optionally you may check 
the Ignore Up-To-Date box, which will improve the speed of the command by not updating files that do not require 
updating from the database.

3. Click the OK button. ShipConstructor will open and update each of the selected drawings.

4. When the operation is complete, a status message is displayed along with the option to open a log file containing a 
detailed breakdown of the status for each selected file.

Note: You can also find the log file in the LogFiles folder contained in your project’s main folder.
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Production Concepts
Production Drawings
Production drawings are designed to leverage AutoCAD’s modelspace, paperspace drawing layout. The exception to this 
is plate nest and profile plot drawings which are model space only production drawings.

Drawings are created from template drawings. Each type of production drawing has its own folder for template drawings. 
Most of the setup is done in the template drawings.

Production Objects
Production drawings contain special read-only versions of the parts. Parts still show the same properties as they do in 
model drawings. Parts still follow the drawing options available in model drawings, allowing you to show the components 
of the parts that you want visible. Parts can be moved around in the drawing to represent the assembly process. However, 
parts should not be moved because they are in the wrong position in the model. Changes required in the model should be 
done in model drawings. Parts can be copied for further customizing of the appearance of the production drawing.
Composite parts (Standard Assemblies, Supports, Penetrations) that are contained in one object in the model drawing 
are separated into their individual component parts in production drawings.

When production drawings are created production objects are created in model space at the same position as they are in 
the ship coordinate system.
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Bill of Materials
The ShipConstructor Bill of Materials (BOM) includes customizable and convenient functions:

• Management of all production drawing BOMs is performed through a unified interface, the BOM Definitions
manager.

• BOMs have full merging, sorting, and grouping capability – even on hidden columns.

• You have control of object listing order in tables.

• Column heading aliasing. 

• BOM tables use standard AutoCAD tables.

• BOM Functionality is identical regardless of drawing type.

• Consistent item numbering across all sheets.

• Updating without losing formatting.

• Revisions.

BOM Functionality Overview
ShipConstructor projects can have any number of user-customizable BOM definitions available for use in target 
production drawing types. As shown in the following diagram, multiple tables can be inserted in a production drawing, 
each referencing a master list.
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One master list exists per BOM definition. The first time a BOM table is inserted in a drawing, its master list is created. 
Subsequent table insertions all reference the initial master list.

BOM content is determined at the time of BOM update. Collectors, specified by the BOM definition, organize the objects in 
the drawing into relevant groups (for example, Pipe, Accessories, and Spools) and process the BOM data into data blocks. 
The data blocks are then compiled into the master list with the tables being updated to reflect the master list data.

The order of the items listed in the BOM depends on primary and secondary factors. The primary order is determined by 
the collector. Each collector provides its own formatted data block. Within each data block, the row order is determined 
by the field sort order specified of the BOM definition.

Collectors process the data for their respective objects according to the format specified by the BOM definition. Therefore, 
each block of collector data is sorted according to the field sort order specified by the BOM definition.

Item numbering is performed on the master list at the time of BOM update. Tables inserted with the List Only Visible
option retrieve their item numbering from the master list to ensure consistent numbering across all sheets. Item numbers 
can have user-defined prefix text (for example, SP–001).

To understand how collector use works, we will use an example: You have a Pipe arrangement drawing that contains 
structure, pipe, and HVAC, and you need two different bills of materials: a pipe stock BOM and spool list.

The pipe stock BOM must list all pipe items, HVAC items, and connection accessories, but not structure. This can be 
achieved by creating two BOM definitions, one for the stocks and one for the spool list.

The stock BOM should list the objects in a specific order: Pipe objects, HVAC objects, Pipe connection accessories, and 
then HVAC connection accessories.

To create a stock BOM that accomplishes the requirement, a BOM definition is created that includes the following 
collectors: Pipe Part, HVAC Part, Pipe Connection Accessories, and HVAC Connection Accessories. Order them as 
specified above; the BOM lists the items in the order specified

To create the spool list, another BOM definition is created that only includes the pipe spool collector.

Both of these BOMs can exist in the same drawing.

Virtually all other aspects of a BOM can be customized, including the following:

• Items included and their order.

• User-defined column header text.

• Each field can be sorted ascending or descending, in user-defined sequence.

• Rows can be merged dependent or independent of equivalent field data.

• Field properties such as units, display format (decimals or fractions), and rounding can be edited individually.

BOM Collectors
Item rows in the BOM are determined by the collectors. A collector gathers parts with specific properties (Is it part of a 
sub-assembly?, Is it a structure part?...). If a part is not collected it remains for lower collectors to possibly gather. 
Collectors can have collector options that apply to each instance of a BOM table in a drawing. Collector options let you 
filter further down to a smaller subset of parts.

Labeling
Labeling occurs on a per viewport basis. Labeling of production drawings uses the first column of BOM tables as the text 
in the labels. Labels are placed in paperspace and point to parts in the viewport.

Leader Distribution Lines
Distribution lines are used to layout the labels so that they are aligned and easy to manipulate as a group.

Keywords
Keywords are placeholders for fields that represent a property of the drawing. Each production drawing contains a base 
set of keywords and some keywords specific to the drawing type. Keywords are updated when the production drawing is 
created, updated or update all keywords is run.
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Getting Started with Production
Production drawings contain a number of components that should to be configured to make for a streamline process for 
creation. The process of generating good looking production drawings can be a try and see process. The ShipConstructor 
template projects include sample template drawings that are configured.

Production Setup Checklist
1. Project Settings

2. Permissions

3. Dimension Styles

4. Label Styles

5. Table Styles

Production Project Settings
Production drawings have a few project settings that are primarily for controlling automatic labeling.

To change project settings

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Project Settings (page 217) to open the Project Settings window.

3. Change the settings as needed. Production drawings are mainly affected by the General, Report and Production 
Drawings settings.

4. Click OK to save and close the Project Settings.

Permissions
Production drawings have permissions for each type of drawing. Set up the permissions so that only the authorized users 
can access the production drawings. See the Project Management manual on how to set up user permissions.

Dimension Styles
AutoCAD Dimension styles are used in production drawings for dimensioning and for parameters to labeling. The name of 
the dimension style in the project’s dimension style must match the name in the dimension style in the drawing or else 
the label parameters are used from the Standard style. You may want to setup separate dimension styles for each of the 
different production drawing types. This will ensure that changes to one production drawing type’s settings won’t affect 
other types of production drawings. However, if you want to have a uniform style across many production drawing types, 
then less dimension styles may be preferred.

To add a dimension style

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Production Output > Dimension Styles (page 299) to open the Dimension Styles window.
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3. Click New and enter a name for the dimension style.

4. Click OK to save and close the Dimension Styles.

5. Open the production drawing template and verify a dimension style exists with the same name.

Label Styles
Label styles are used in production output drawings to label parts. Labels in most production drawings reside in paper 
space so be aware of the scale of the paper when entering values.

To add a label style

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Production Output > Label Styles (page 295) to open the Label Styles window.

3. Click New and enter a name for the new label style.

4. Change the properties of the label style.

5. Click OK to save and close the Label Styles.

Setting up Label Text Styles
In Label Styles catalog in Manager, each label style is referenced to a specific dimension style name.
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The actual dimension style should exist in the production drawing. If it doesn’t, the Standard dimension style will be used. 
The dimension style in the production drawing must be named exactly the same as the field in the Label Styles catalog in 
Manager.

The simplest way to ensure that all production drawings have properly named dimension styles is to predefine required 
dimension style in production drawing templates.

In AutoCAD, each dimension style is referenced to a Text Style.
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ShipConstructor labels get their text styles from the text style that is assigned to the dimension style that is associated 
with the label style:

Setting up Label Text Sizes
A situation with the text size is similar, but a little bit more complex. If the destination text style has zero height, the 
height of the label text comes from the associated dimension style. Otherwise, it will be the height from the text style 
definition. The same convention AutoCAD dimension text uses.
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When everything is set, but label bubbles and text still have wrong sizes
When everything is set, but label bubbles and text still have incorrect sizes, the user should check scaling parameters in 
the production drawing. There are a few scaling parameters to be aware about:

• The Scale to View setting should always be turned off for labels that live in paper space. Scale to View is an old 
ShipConstructor setting that was introduced back in the times when ShipConstructor labels were placed in the model 
space. Currently, the only type of the drawing where labels appear in the model space is the plate nest drawing. In 
the rest of the drawings, labels live in the paper space, so additional scaling to view is not required in these drawings. 
If the Scale to View setting happens to be turned on for paper space labels, the size of the label will change 
depending on the current zoom of the layout, which may not be a desired behavior.

• AutoCAD Plot Scale that can be set in the Page Setup dialog affects the overall scale of the entire layout view.
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• Dimension styles have their own scaling that affect the text size.
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Label sizes are affected by scaling settings of the associated dimension style.

BOM Definitions Manager
ShipConstructor integrates all Bill of Materials management through the BOM Definitions manager. The BOM Definitions
manager lets you create and edit existing BOMs for all production drawing types.

Access the BOM Definitions manager through Manager (General > Production Output > Bill Of Materials (page 299)).

Assembly Drawing Naming Conventions
Assembly drawings are the only drawings that require a naming convention be configured. You will need to set up the 
product hierarchy level prior to setting up the naming convention.
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Example Assembly Drawing naming convention

Global Dimension to Point
A Global Dimension to Point is used to indicate the distances from a given point to selected planes. The global dimension 
to points can be displayed either as dimensions or as labels.  The text displayed in the dimensions and labels can be 
customized to display the information in any format specified by the user. 
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The main grid will display all the available UCS’s in the project, or if Current Unit Only is selected it will display all 
available UCS’s in the current unit. Up to 3 different UCS’s can be selected one in each direction X, Y, Z.  If a UCS is 
selected that is in the same direction as an already selected UCS the previously selected UCS will be unchecked. The 
preview window will be updated with the newly selected UCS to indicate what will be displayed. The top yellow row can be 
used to filter through the grid to find the appropriate UCS.
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To create a global dimension to point

1. Open the drawing you want to add the global dimension to.

2. Choose Global Dimension To Point (page Error! Bookmark not defined.).

3. Click the Marking Type option: Dimension or Label. This will change the preview to display the text that will be used 
for the global dimension. If creating a dimension, enter the dimension offset. This value is the length of the extension 
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line for the dimension. Select a style to be used for the global dimension. The dimension and label styles are defined 
in Manager.

4. Choose the UCS’s to measure the dimensions from. If necessary edit the display text to display the appropriate 
keywords.

5. Click OK. If a label is created, select a point for where to place the label and press ENTER.

Creating a New BOM Definition
Utilizing the BOM Definition Manager, you can manage all the Bill of Material for your project. To create a new BOM:

1. Select the drawing type for which the BOM is intended.

2. Optionally, check the Default Collectors checkbox so that a reasonable subset of Collectors (page 302) is included in 
when you create your BOM.

3. Press the New button.

4. Set the properties for the BOM in the BOM definition grid. 

5. Choose and order the Collectors (page 302) that are appropriate for your BOM.

6. Add BOM Fields by pressing the Add/Remove button. You can choose from a predefined set of production fields or 
choose from any of the user-defined attributes that have been added to your project.

Note: You can modify BOM definitions after they are in use and they will be updated the next time a BOM update is 
performed. 

To create a BOM definition

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Production Output > Bill Of Materials (page 299) to open the BOM Definitions window.

3. Select the type of drawing in the BOM Definitions list that you want to create a BOM for.

4. Click New.

5. Enter the Style Name and fill in the remaining items in the BOM Definitions list.

6. With the style selected, Click Add/Remove in the Fields section.
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7. Place a check next to each field you want to include in the BOM. For BOMs that include structure parts only include 
fields that have Module S. P is for Pipe, H is for HVAC. 

Note: For structure BOMs you should include Part Name and Quantity fields. Item # is required for labeling parts.

8. Click OK to return to the BOM Definitions window. You will see that the fields are added to the fields list.

9. Click the ellipsis button in the sort column so that at least one column is sorted.

Warning: If you do not sort the rows then the order of the rows is random and not guaranteed to be the same after an 
update.

10. Set the Merge column to Yes as necessary to merge identical rows in the table.

11. Use the and buttons to organize the order of the columns. The top field will be the leftmost column in the 
table.

12. Review the Collectors sections to ensure the types of parts that you want in the BOM table are in the Included
collector list. Assign a label style to each collector that you want labeled.

13. Click OK to close the BOM Definitions.

Deleting an Existing BOM Definition
BOMs that are currently being used by production drawings should not be deleted, as this will prevent the BOM tables 
from updating.  You will need the Edit BOM permission to delete a BOM.

To delete an existing BOM:

1. Choose ShipConstructor > Manager (page 258) to open Manager.

2. Choose General > Production Output > Bill Of Materials (page 299) to open the BOM Definitions window.

3. Select an existing BOM

4. Click Delete. A window will prompt to confirm.

Set Up a Production Drawing Template
You can control the layout of all production drawings using drawing templates. ShipConstructor includes one default 
drawing template that you can use or modify.

Note: There must be at least one drawing template defined before you can create a production drawing of the same 
type.
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Create a Drawing Template

To create a drawing template

1. Choose ShipConstructor > Navigator to open the Navigator.

2. Select the Templates page.

3. Select the folder for the drawing type you want to create a template drawing for.

4. Click New <type> to open the New Drawing window. Where <type> is the type of drawing. The button changes text 
based on the selected folder.

5. Enter a name for the drawing and click OK.

6. Insert your company title block, or create one.

7. Set up as many viewports as you need.

8. Set up the properties of the viewports. The Shade plot property is a property that is used by labeling if project setting 
Labels Point to Visible Edges is Yes.

Insert Keyword into a Production Drawing Template
You can insert various keywords into a production drawing template. When you generate a production drawing, 
ShipConstructor automatically replaces the keyword with the appropriate information. Keywords are updated any time 
the drawing is updated.

To insert a keyword into a production drawing template

1. In the production drawing template, activate paper space.

2. Choose Production Utilities > Insert Keyword (page 339) to open the Insert Keyword window.
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The list of available keywords depends of the type of production drawing you are in.

3. Select the keyword to insert.

4. Change the text properties now in this window or later using AutoCAD. Keywords are based on AutoCAD text objects 
so all the properties of text objects are available.

5. Click OK.

6. Select the location for the keyword.

The keyword is created as a new ShipConstructor keyword object.

Note: To change the prefix (PreText) or postfix (PostText) text of the keyword, use the property palette.

Insert a BOM Table into a Production Drawing Template
You can now predefine a BOM definition for use within a production drawing template. This enables you to format an 
empty BOM table to your specifications (correct text style, size, and so on) before creating a production drawing.

Note: To insert the BOM table, there must already be an assembly BOM definition defined. See Creating a New BOM 
Definition (page 138).

To insert a BOM table

1. In the drawing template, activate paper space (except for plate nest and profile plot drawings).

2. Choose Format > Table Styles to customize the table style to be used for the BOM table. Be sure that the name of 
the table style matches the Acad TableStyle name in the BOM Definition.

3. Choose BOM > Insert BOM Table… (page 328).
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4. Select a BOM definition.

5. Click Next.

6. Enter the options for the BOM table.
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7. Click Select viewports.
Select viewport:

8. Select the main viewport in the paperspace layout.

9. Click Finish.

10. Select the location of the empty BOM.

Edit BOM Collector Options
This command allows the user to alter a Bill of Materials Collector options. For example, the Pipe Collector allows the 
user to select which object types to include/exclude. By using this command you can adjust the filtering of object types to 
suit your needs.

To change the BOM collector options

1. Choose BOM > Edit Collector Options (page 331)
Select Table: 

2. Select the BOM table.
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3. The Adjust the Collector options as necessary.

Note: you will be notified if the BOM that you selected has no configurable Collector options.

Set Up Viewports
Each viewport can contain annotations such as labels that point to parts containing the text from a BOM. Viewports can 
be set up to label from specific BOM tables.

For assembly drawings there is an additional option. Show KeyMap will show the keymap xref geometry. The keymap 
drawing typically contains an outline of the vessel’s hull to indicate where the assembly is in the overall vessel.

To set up viewports

1. In the template drawing, activate paper space (except for plate nest and profile plot drawings).
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2. Choose Viewport Options… (page 324) to open the Viewport Options window.

3. To enable labeling of parts in the viewport, choose Label items from all BOMs or check individual Label checkboxes 
for each BOM you want to label from.

4. Click OK.

Set Up Drawing Options
Drawing options control the look of parts in all drawings. In production drawings you will want production objects to look 
a specific way like don’t show spool break symbols. Setting up the drawing options in the templates reduces the amount 
of work that has to be done in each production drawing. 

To set up drawing options

1. Choose Drawing Options > Edit All Drawing Options…
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2. Change the settings and click OK.

Set Up Viewport Display Options
In some cases you want one viewport to show the parts differently than other viewports. Some drawing options can be 
controlled at the viewport level.

To set up viewport display options

1. Choose Viewport Display Options > Set…
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2. Change the settings and click OK.

Set Up Labeling Settings
In some cases using the default label settings for the project may need to be overridden. Settings can be stored in the 
drawing to override the project setting.

To set up label on visible edge

1. Choose Label > Label on Visible Edge On/Off (page 334).
Labels point to visible edges [Yes/No] <No (Project Setting)>:

2. Type Yes. If the project setting was set to Yes then no need to overwrite it.
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To reset label settings to use the project settings

1. Choose Label > Label Reset Automatic Settings (page 336).
This command will reset all label settings back to Project Settings, continue? [Yes/No] <No>:

2. Type Yes.

Set Up Non-ShipConstructor Settings
To have all the settings preconfigured before anyone generates a production drawing maintains standards and speeds up 
the process. AutoCAD settings like text styles, dimension styles, plot settings, VIEWRES, LTSCALE, object snaps, layers, 
linetypes, dimensions, detail and symbol blocks should be set up to your company standards.

Weld Symbol Table in an Assembly Drawing Template
You can insert a table object into the template drawing, which will contain all the weld symbols and their corresponding 
scenarios. The table in the template drawing is a simple 1x2 empty table that will automatically be filled in during the 
creation/update of the assembly drawing.

To insert a Weld Symbol Table

1. In the assembly drawing template, activate paper space.

2. Choose Insert Weld Symbol Table

3. Select a table style, scale for the Weld Symbols, and an alignment for the table’s cells.

4. Click OK.

5. Select a location for the empty table.

Predefined Assembly Format
(Assembly Drawings Only)

When creating an assembly drawing, you can choose to use predefined templates. The predefined assembly format 
allows you to set up which template drawing is used for each assembly level. Setting up the predefined templates 
requires an assembly template drawing.

To set up predefined templates

1. In Manager, choose General > Production Output > Predefined Assembly Format (page 305) to open the Predefined 
Assembly Drawing Format window.
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2. For each assembly level (Levels), select a template to use for assembly drawings (Template Drawing). (To set up an 
assembly drawing template, see Set Up a Production Drawing Template (page 139).)

3. Click OK.

Tip: The Pipe or HVAC drawing options you set in template drawing will be inherited in the final output drawing. We 
recommend that you disable all modeling aids such as free end arrows in order to produce the cleanest output 
drawings.

Volumes
Volumes are used when creating various production drawings. Volumes can be created in any ShipConstructor drawing 
through the Volume Manager. When creating a production drawing, any parts contained within the volume selected will 
be included in the production drawing.

Volume Manager
The volume manager can be used in any ShipConstructor drawing to define a volume. Volumes are used when creating 
production drawings. The volume manager is a palette, and as such, can be docked while running ShipConstructor, so 
users can easily switch drawings while trying to define a volume that encompasses all the parts that are wanted.

To create a new volume

1. Choose ShipConstructor > Manage > Volume Manager (page 315). The existing volumes for the project are loaded in 
the palette.
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2. Select a volume folder or click New Folder to create a folder.

3. Click New Volume. A new row appears.

4. Enter a name for the volume.

5. If you know the coordinates of the volume enter those in the columns and proceed to step 9.

6. If you do not then open a drawing that contains the references you need.

7. Click Pick Min.
Select a minimum point:

8. Click Pick Max.
Select a maximum point:

9. Click Save. The new volume is saved to the database and ready to be used as a source for production drawings.

Creating Production Drawings
Creating production drawings is done using a drawing creation wizard. Each production drawing type has a different 
wizard.

When a production drawing is generated it will update any BOM tables and keywords present.

Edit Production Drawings
When some production drawings are generated they can just be reviewed and plotted but others may require detailing 
work.

Any of the set up performed in the template drawing can also be performed in the production drawing.

Insert an Orientation Icon into an Assembly Drawing
Orientation icons are useful in displaying the directions when it is not clear how the assembly is oriented.
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3D Orientation icon

To insert an orientation icon into an assembly drawing

1. Choose Orientation Icon (page 320)

The 2D/3D Orientation Icon window appears.

2. Select the type of icon (3D or 2D), the length of the direction lines (Scale), and any other options.

3. Click OK.

4. Select the location for the icon.

Mark an Assembly’s CG Position in an Assembly Drawing
You can insert a mark into an assembly drawing indicating the assembly’s center of gravity (CG). This can be important 
for lifting documentation and when you are planning to move heavy assemblies. The CG position is located using a 
SConCGPoint object. This object cannot be moved and will be updated if the drawing is updated.

If you need to rotate the assembly in the assembly drawing (see Rotate an Assembly in an Assembly Drawing (page 
152)), then you first need to mark the assembly’s CG position and explode the SConCGPoint.

To mark an assembly’s CG position

1. In the assembly drawing, make sure you are in model space.

2. Choose CG Point (page 321)

ShipConstructor inserts a SConCGPoint object at the CG point.

Change the View in an Assembly Drawing
When you change the view of an assembly, all annotations will not move. This is because annotations are always in paper 
space.

To change the view in an assembly drawing

1. Double-click on a view to activate model space.

2. Use the view controls to change the view.
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Rotate an Assembly in an Assembly Drawing
You may want to rotate the assembly within an assembly drawing to view the assembly from a different angle. For 
example, you may want to rotate an assembly so it appears upside down if that is the way it will be assembled. The 
preferred procedure is to orbit around to the correct view position instead of rotating parts. 

When you create assembly drawings, only visible sub-assemblies are annotated. If you later rotate the assembly, you may 
expose otherwise hidden (and un-annotated) sub-assemblies. After rotating an assembly, you must re-auto-annotate the 
drawing to ensure that all components are labeled.

Note: The SConCGPoint object will not be rotated when the parts are rotated. You can move the CG point by exploding 
it. However, updating the drawing will not update the exploded CG point.

To rotate an assembly in an assembly drawing

Note: Before rotating an assembly, make sure you mark its CG position (see Mark an Assembly’s CG Position in an 
Assembly Drawing (page 151).)

1. In the assembly drawing, double-click within the viewport to switch to model space.

2. Choose Modify > 3D Operation > Rotate 3D.

3. Type all and press Enter to select all objects.

4. Press Enter to finish selecting objects.

5. Type the axis to rotate the assembly about and press Enter.

6. Press Enter to accept the default rotation point (0, 0, 0).

7. Type the angle to rotate the assembly and press Enter.

Insert a Quality Control Matrix into an Assembly Drawing
A quality control matrix is a table of dimensions that you can insert into an assembly drawing and that production can 
use to verify the accuracy of an assembly after its fabrication.

After fabrication, production can measure the distances between points on the physical assembly and enter the values 
into the empty fields of the quality control matrix.

Note: You can insert a quality control matrix into any ShipConstructor drawing, but they are most useful for assembly 
drawings.

To insert a quality control matrix into an assembly drawing

1. In the assembly drawing, double-click within the main viewport to switch to model space.

2. Choose SC Utilities > Create Quality Matrix (page 281) to open the Quality Matrix Options window.
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3. Set the options and click OK.

4. Click the points on the assembly that you want to include dimensions between. For example, click points on one 
plate part to generate a quality control matrix for that panel.

Update BOMs

To update all BOM tables

1. Choose BOM > Update BOMs (page 328).

2. All the BOM tables are updated from the objects contained in the drawing.

Viewport Clipping
ShipConstructor includes functionality to create precise viewport clipping planes. Unlike standard AutoCAD clip planes, 
ShipConstructor clipping lets you pick the front and back point to define the clip planes.

To clip a viewport

Note: Before running the command you need to switch to the viewport in which the clipping plane is to be applied.
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1. Choose Clip current view from the SC Utilities menu.

2. If the drawing is in paper space it will prompt you to select the viewport to make active.

3. The command line prompts you to: Enter Point on Plane 1. Choose a point on one of the clipping planes to be used 
(whether it is the front or back clipping plane will be determined by ShipConstructor).
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Before clipping

After clipping
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4. The command line prompts you to enter a second point: Enter Point on plane 2. Choose a point on the second 
clipping plane (whether it is the front or back clipping plane will be determined by ShipConstructor). 

Note: If the clipping planes are not to your liking you can remove them with the command SC Utilities > Remove 
clip (see below).

Remove clip

To clear a viewport clip

1. Choose Remove clip from the SC Utilities menu.

2. Select the viewport to clear the clip.

Export a BOM from an Arrangement Drawing to a Text File
Use the AutoCAD command TABLEXPORT. This command outputs a csv file (comma separated value) to a location that 
you specify.

Labeling

Automatic Labeling
Automatic labeling places distribution lines around the extents of the geometry and places labels on the distribution 
lines. The arrow points of the labels can optionally point to the piecemark point (for parts without piecemarks this is the 
logical center of the part) or to a visible edge of parts. If a viewport has any existing distribution lines none will be created 
and the automatic labeling will use the existing line(s).

Label to Visible Part Edges
This option places label’s arrow point on the edge of parts. Visible refers to visible in the viewport when plotted. The 
viewport’s Shade plot property controls this.

Options
Adjacent Part Edge Tolerance
A labelling rule checks if a possible label point’s distance to other part’s visible edges. If the distance is less than this
tolerance the label point will be rejected as a label point. This value is in paperspace units. The recommended value is the 
value of the thickness of a cross section of a plate in paperspace units.

Distribution Mode

The distribution mode determines how the labels are distributed on distribution lines. There are three possible 
distribution modes: Nearest, Center, Equidistant. Nearest is the recommended mode.

Edge Corner Clearance Distance
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This setting controls how close to the end of a part’s edge that a label’s arrow point can be. The value is in paperspace 
units.

Edge Determination Minimum Angle

This setting controls how segments of a part are connected into edges. Two Adjacent straight segments are connected 
when their angle is less than this setting.

Remove Curved Plate Parts HLR

This setting determines if curved plate parts will be included into the Hidden Line Removal (HLR) algorithm. If 
curved plates are removed then the outline of curved plate is used instead. This means that parts may be visible 
when they are indeed hidden. If curved plates are not removed, the time to generate labels can significantly increase. 
It is recommended to set this to Yes.

Label All
This command labels all the parts from the BOMs that are assigned to label a viewport across all layouts. Labels are 
placed on the _ANNOTATION layer. The text in the label comes from the first column in the BOMs assigned to the 
viewport. If a part has multiple labels then those labels are stacked.

Labels are generated only once. Subsequent running of Label All will:

• Update the label text and label styles of existing labels. Labels are not moved.

• Add new labels for new parts. Labels will be placed around existing labels.

• Delete labels for removed parts

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent. Tracking 
can be turned off with Track Label Positions.

To label parts from BOMs

1. Choose Label > Label All (page 332)

Manual Labeling
Label parts individually with manual placement of the labels. This is an alternative method to automatic labeling. The 
label style and text contents are used from the BOMs associated with the viewport where the part was selected. The 
number of leader segments follows the label style setting. The command allows you to label a sequence of parts without 
having to restart the command. If you select a part that has been previously labeled then the previous label is removed.

To manually label a part

1. Choose Label > Manual Label (page 331)

2. The first column text in the BOM table will be used as the label text and label style of the BOM or in the 
corresponding collectors of the BOM will be used if specified.
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To find what label style it is using go to Manager > General > Production Output > Bill of Materials. Select the BOM 
definition used to create the table. If the collector has a label style then it will be that style. If it is <none> then the 
label style will be the BOMs label style.

Select a part to label:
3. Select a part to label. The selected point will be the position where the arrow points to.

Specify label position (1 seg)[Multi-segment]:
4. Specify label position. (1 seg) indicates that the label style has the Num Segments value of 1. If your label style has 

more than one segment then you will be prompted to pick the remaining segment points. If you type in an ‘M’, you 
are permitted to select more leader points than the style has. Press Enter will finish the Multi-segment label mode.
Select a part to label [Copy]: 

5. After you create the first label, you can switch to Copy Label mode by typing in ‘C’. In this mode, you can continue to 
label parts with only having to select the part and not the label position. The label geometry will be the same as the 
previous label.
Select part to copy label [lAbel]:

6. You can switch back to manual label mode by typing ‘A’.

7. Press Esc at anytime will end the labeling.

Copy Label
Lets you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of the 
selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label.

To copy a label for labeling another part

1. Choose Label > Copy Label (page 332)
Select the source label:

2. Select the source label. The system will find out the related BOM table for copying label text and styles.
Select a part: 

3. Select a part to label. The selected point will be the position where the arrow points to and all other geometry 
information will be copied from the source label.

4. Press Esc at anytime will end the labeling.

Label Current Layout
Similar to Label All (page 157) but only affects the current layout.

Label Viewports
Similar to Label All (page 157) but only affects the selected viewports. 

Label Viewports from BOM
1. Choose Label > Label Viewports from BOM (page 333).

Select BOM tables:
2. Select the BOM tables you want to label from.

Select viewports:
3. Select the viewports you want to label. If the BOM is not already assigned to the viewport then it will be and assigned 

default values for Minimum Leader Length and Label Spacing.

Label from Parts
This command will label all the parts selected by the user from the selected table.
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To label from parts

1. Activate the viewport you want to label.

2. Choose Label > Label from Parts (page 333).
Select parts to label: 

3. Select the parts to label. The parts will be automatically labeled. 

Note: The rules for BOMs assigned to viewport for labeling still applies. This means selected parts may not actually 
qualify to be labeled.

Label on Visible Edge On/Off
The arrow points for labels can point at two types of points: the piecemark or center point of the part or any visible edge. 
This setting controls that option.

To set labels to point to edges of parts

1. Choose Label > Label on Visible Edge On/Off (page 334).
Labels point to visible edges [Yes/No] <No (Project Setting)>:

2. Enter Yes.

3. If labels are already placed, run Label > Delete All Labels (page 333).

4. Choose Label > Label All (page 332).

Adjacent Part Edge Tolerance
This tolerance setting filters out potential arrow points on edges that are too close to each other. When arrow points are 
close another part it can be difficult to know what part the arrow it pointing at.

To change the adjacent part edge tolerance

1. Choose Label > Adjacent Part Edge Tolerance (page 335).
Enter adjacent part edge min distance<2.0 (Project Setting)>:

5. Enter new value. If you choose a large value then potentially all possible label points are filtered out and the arrow 
must revert to labeling the longest edge.

6. If labels are already placed, run Label > Delete All Labels (page 333).

7. Choose Label > Label All (page 332).

Curved Plates in Visible Edge Detection On/Off
This setting is to allow the use of curved plates in the visible edge detection calculation. Curved plates are complex parts 
that take extremely long to process if included. When the setting is off, the edges of the curved plate are used.

To use curved plate solids in label edge detection

1. Choose Label > Curved Plates in Visible Edge Detection On/Off (page 335).
Labels point to visible edges [Yes/No] <No (Project Setting)>:

8. Enter Yes.

9. If labels are already placed, run Label > Delete All Labels (page 333).

10. Choose Label > Label All (page 332).

Label Reset Automatic Settings
The label settings that come from project settings can be overriden in the drawing. This command resets the values to 
follow the project settings.

To reset the overriden label settings

1. Choose Label > Label Reset Automatic Settings (page 336).
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Reset all label settings back to Project Settings [Yes/No] <No>:
2. Enter Yes.

Track Label Positions
Label tracking is enabled by default and moves the labels when you pan or zoom inside a viewport that is labeled. 
Depending on the user, this may be a feature that generates unwanted changes to the labels when inspecting the 
drawing. If the label tracking is turned off, it is recommended to save the viewport’s viewport so that it can be restored so
that the labels point at the correct positions.

To turn off label tracking

1. Choose Label > Track Label Positions (page 333).
Enable label tracking [Yes/No] <No>:

2. Select No. The labels will now not move automatically in all drawings.

Update a Production Drawing
ShipConstructor arrangement drawings can be updated. Drawings that need updating can easily be identified in 
Navigator.

Identifying Drawings that Require Updating
Arrangement drawings that contain parts that have been changed are identified in Navigator.

To identify out of date arrangement drawings

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select HVAC or Pipe in the component list.

3. Click the Show Out of Date button.
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Out-of-date arrangement drawings can be identified by the exclamation mark icon ( ). 

Updating an Arrangement Drawing
Arrangement drawings can be updated in ShipConstructor. This lets you keep all the detail work done to an arrangement 
drawing while importing new parts and geometry, removing unneeded geometry or updating existing parts.

The following items are affected during a drawing update:

• All parts are updated to reflect the latest geometry in the source model drawings.

• The Bill of Materials (BOM).

• All keywords.

• The imported non ShipConstructor geometry

Note: When ShipConstructor updates the non-ShipConstructor entities, it only deletes and re-imports geometry that 
was brought in during the drawing creation to update process. Any additional geometry added by you to the 
arrangement drawing will be unaffected by a drawing update, regardless of which layer the geometry resides on.

Copied Parts in Arrangement Drawings

In an arrangement drawing, you can copy any number of production parts. During an update, the copies of the parts also 
are updated. The following rules apply while updating copied production parts.

• If the original part is deleted from the arrangement drawing by the update process, all its copies are also deleted.

• If the original part is moved or its geometry changes, the copies are also moves and have their geometry changed. 
They will move relative to the original part while updating.

To update an arrangement drawing

1. Choose SC Arrangement > Update Drawing to start updating the drawing.

2. The Update Drawing Wizard appears (see also Update Arrangement Drawing Wizard Reference (page 188)).
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3. All sources that currently make up the arrangement drawing are selected in the various source trees with the layers 
specified for those sources will be remembered from creation or the last time it was updated. In addition, a 
summary of all sources can be seen on the right side of the screen. Add or remove sources as necessary. You also 
set the destination layers for where new parts from these sources will be placed. Existing parts will stay on their 
current layer. Conflicts arising from parts being brought in from multiple sources with different layers will be resolved 
later.  Click Next.

Note: You can optionally not show spools as a source with the Show Spools check box. You can also force spools 
to override any possible layer conflicts caused by parts existing in multiple selected sources with the Spool 
Layers override conflicts check box

4. ShipConstructor automatically determines all the drawings to collect parts from to populate the arrangement 
drawing. In addition to ShipConstructor parts, you can also import non-ShipConstructor geometry. All drawings that 
you currently have imported non-ShipConstructor geometry from will be checked. Select all drawings that you also 
want to import non-ShipConstructor geometry from and set destination layers for all non-ShipConstructor geometry. 
Click Finish. 

5. The Modified Part Information window appears. 
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6. You can use the Modified Part Information window to inspect parts that have changed during this update. Click OK to 
continue the update process.

7. The Bill of Materials (BOM) in this drawing will now be updated. Depending on the size of your drawing and the BOM 
definition, this may take some time.

8. The Layer Conflict Resolution window appears if there are any conflicts between destination layers of any parts in the 
drawing.(see also Layer Conflict Resolution Reference (page 188)). 

9. You can use the Layer Conflict Resolution window to sort out the destination layer for any conflicted parts.
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Update All Keywords

To update keywords

1. Choose Update Drawing (page 316).

2. The keywords in the drawing update regardless of the status of the parts.

OR

1. Choose Production Utilities > Update All Keywords (page 321).

2. The keywords in the drawing update without updating the parts.

OR

1. Select keywords you wish to update.

2. Choose Update on the right-click menu.

BOM Revisions
When BOM tables are updated, they are rebuilt each time to reflect the current state of the drawing. This does not allow 
the user to see how the drawing changes affected the BOM tables. It also may renumber the items, causing existing 
labels to be incorrect.

BOM Revisions allow the user to save the current state of the Bills of Material in the drawing (or layout), so that when the 
BOM tables are updated, they will be able to compare the new BOM data with the old BOM data and display those 
changes to the user.

To prevent the original BOM tables appearance from changing, new items in the BOM are appended to the end of the 
table, and removed items have their text changed to use strikeout. Any changes to existing items are simply updated into 
their rows. This allows the items to maintain their original item numbering, preventing the user from having to relabel 
everything.

To use BOM revisions best, a Revision column should be added to the BOM definitions. This column will display one of 
three possible values:

- nothing, for when no revisions exist

- the current revision, such as “Rev.0”

- the “modified” state, which is the current revision prepended with “*”, such as “*Rev.0”. This state indicated 
that something in this row was modified during an update.

BOM Revisions can be defined for any paperspace layout in production drawings. Alternatively, the user can define a 
revision for the entire drawing (all layouts), instead of for just the current layout.

An example of how the BOM table evolves is shown:

This is a BOM table in a Pipe Arrangement drawing after creation. The user defines a revision called “A”. The empty 
Revision column is filled with this name.
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Then they update the drawing. Some parts have been added, and others have been removed. The result looks like this:

The changed parts have the “*A” identifier. The removed parts used strikeout text. New rows are appended to the end, 
continuing the item numbering, and not re-ordering it.

New Revision
Revisions can be created at any time: the user simply needs to provide a name, and an optional description. The new 
revision name must not be used in the layout (or drawing, if creating a revision for all layouts). The revision saves the 
current user and the date and time of creation.

If this is the first revision in the drawing, the empty Revision column for all BOM tables in the layout (or drawing) are 
changed to the revision name.  If it’s not the first revision, then all the rows with the “*” identifier are changed to the new 
revision. This way, only items that have changed during the BOM updating are tagged as belonging to the new revision.

To create a revision

1. Choose BOM Revisions > New BOM Revision in Current Layout (page 336) or BOM Revisions > New BOM Revision in
All Layouts (page 336)

2. Provide a name for the revision
Enter a name for the new revision:

3. Provide a description for the revision (this can be left blank)
Enter a description for the new revision <none>:

4. The revision is created in the specified layouts
Revision 'Rev.A' created in layout 'Master BOM'
Or
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Revision 'Rev.A' created in 2 layouts

Delete Revision
When deleting revisions, only the current revision can be deleted.  Any BOM item with the current revision is changed to 
be the previous revision with the “*” identifier. If no previous revision exists, then the Revision column is left blank.

Using the “all layouts” command to delete revision requires that the current revision in all those layouts have the same 
name.

To delete a revision

1. Choose BOM Revisions > Delete BOM Revision from Current Layout (page 336) or BOM Revisions > Delete BOM 
Revision from All Layouts (page 337)

2. The current revision is deleted
Revision 'Rev.A' deleted in layout 'Master BOM'
Or
Revision 'Rev.A' deleted in 2 layouts

Delete All Revisions
Instead of deleting each revision one by one, the user can simply delete all revisions. The BOM tables will not be restored 
to the original state, but will be left as they currently appear (except that all Revision columns are reset to a blank value)

To delete a revision

1. Choose BOM Revisions > Delete All BOM Revisions from Current Layout (page 337) or BOM Revisions > Delete All 
BOM Revisions from All Layouts (page 337)

2. All revisions are deleted
3 revisions deleted in layout 'Master BOM'
Or
3 revisions deleted in 2 layouts

List Revisions
Information about the revisions in the current layout can be printed to the command line. Revisions are listed with their 
name, description, user and date/time of creation.

To list revisions

1. Choose BOM Revisions > List BOM Revisions (page 337)

2. Choose R (or enter) to display the revisions
Select what to list [Revisions/Operations/All]<Revisions>:

3. Choose N (or enter) to avoid seeing a long list of parts changed per revision.
List parts? [No/Yes]<No>:

4. The revisions are then listed at the command line

Inspect a Plotted Assembly Drawing
After plotting an assembly drawing, visually inspect the plotted drawing for format and content. Make sure things like 3D 
orientation icons and weld symbols are included and that every part is annotated.
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Update Production Drawings
This command will allow the update of multiple production drawings at once. As this is a time consuming process the 
only user input required is the initial setup and once started the update will continue without user input until complete.

1) Enter the command SCUPDATEPRODUCTIONDWGS

2) Select the drawings to update from the list.

a. Check the “Ignore up to date drawings” to avoid calling update on any up to date drawings that are 
selected.

3) Click “Ok” to begin updating drawings. The updater will now open each drawing and call the silent update 
drawing command –SCUPDATEDWGSILENT. Once the process has completed a log file will be opened.

Production Drawing Revision Palette
The Production Drawing Revision Palette is used to see the changes to the production drawing to know who and when 
someone changed the production drawing and what was changed. The Production Drawing Revision Palette is a tool that 
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shows the history of changes to the current production drawing. A list of all the part changes is shown and those changes 
can be visualized. This palette will automatically refresh when the current drawing changes.

Show Out-of-Date Parts

To show out-of-date parts

1. Choose Drawing Revisions Palette… (page 318).

2. Select the action rows that have occurred since the drawing was last detailed.

3. Click Override All Part Colors. You can now visualize the parts that have changed and you can inspect any details that 
need manual changes.

Output Drawings
Output drawings are drawings created from numerous sources to be used to create MarineDrafting, or PipeLink drawings 
from.
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Generate Output Drawings

To create output drawings

1. Choose ShipConstructor > Navigator (page 231) to open Navigator.

2. Select the Output page.

3. Click New Output to bring up the Create Output Drawing Wizard.

Note: The folder selected will be preselected in the wizard.
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4. Select a folder for the Output drawing, enter a valid name, and click Next.
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5. Select a Template drawing and click Next.
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6. Select sources for the output drawing. Choose from drawings, Systems, Assemblies, and Volumes. Click Finish.

Volumes are created using the Volume Manager (page 149). 

Update Output Drawings

You can change the sources of the output drawing or refresh the output drawing by updating it.

1. When in an Output drawing, type SCUPDATEDWG to bring up the Update Output Drawing Wizard.
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2. Change sources if needed Click Finish.

Part Property Labels

ShipConstructor supports extraction of part properties for display in production drawings. Information normally displayed 
in the AutoCAD properties window can be displayed in label form. ShipConstructor provides the means to select AutoCAD 
fields for insertion into a user editable MText block that is then optionally attached to an AutoCAD label.

The MText block uses AutoCAD fields to extract information from ShipConstructor objects. For a thorough understanding 
of the AutoCAD fields and how to optionally specify formatting, see the AutoCAD help documents.
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Access the Part Property Label function through SC Utilities > Property Label.

Properties
Lists the properties for the selected object. Values are shown for reference only and will be evaluated when the fields are 
updated.

Dimension Style
Selects the dimension style for the AutoCAD leader object.

Field Text
Double click the field or click the right arrow button to insert the field into Field text box. Insertion occurs at the current 
cursor position. You can add or edit the text inside the Field text box as needed.
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The behavior of insertion is dependent on the cursor position with the field text. If the position is within a field, then the 
field will be replaced by the new one. If the cursor is not within a field then the field is inserted at the cursor position.

Select Object
Allows selection of other objects for field selection. This does not replace the object references currently inserted within 
the fields; rather it updates the field list. This allows for the creation of MText blocks that reference multiple objects.

Placing Field Labels

To Place a Part Property Label

1. Choose SC Utilities > Property Labels > Property Label

2. Select the property that you wish to insert from the property list. Double click or use the right arrow button to 
insert the property into the field text box. The field is shown in raw field form, allowing the experienced user to 
edit the details directly.

3. Add any additional text as required to the label text and then click the OK button once complete

4. Select the leader origin.

5. Select the leader tail position. The MText will be attached once command is completed

Note: Step 4 can be skipped if the ShipConstructor variable SCSetSingleClickFieldLabel is set to <1> . 
When the option is toggled on, then the first leader point is the item selection point. When labeling in Model 
Space the behavior may not be as desired the UCS projected selection point when labels are placed in Model 
Space.

Copying Field Labels
Field labels can be copied using standard AutoCAD techniques or by using the ShipConstructor field copy commands. 

Copying by AutoCAD techniques does not replace the object references within the fields. Another command must be run 
afterward if object references are to be changed. The ShipConstructor copy methods replace the object references during 
the copying procedure. 

The SCFieldLabelCopy command copies the MText block and then prompts the user to select a new object reference 
place and place a new leader section.

To Copy a Field Label / MText

1. Choose SC Utilities > Property Labels > Copy Property Label

2. Select the leader or mtext. ShipConstructor automatically determines the association between the label and 
mtext (if any)

3. Select the new part to replace the object reference within the field.

4. If the mtext is associated with a leader select the new leader origin.

5. Select the mtext or leader tail position.

The SCFieldLabelCopyQuick command copies the mtext block and then prompts the user to select a new object reference 
and position. The existing leader geometry is retained.

To Quick Copy a Field Label / MText

1. Choose SC Utilities > Property Labels > Quick Copy Property Label

2. Select the leader or mtext. ShipConstructor automatically determines the association between the label and 
mtext (if any).

3. Select the new part to replace the object reference within the field.

4. Select the leader or mtext position.
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If AutoCAD methods are used to copy the label/mtext to a new position and you wish to replace the object reference 
within the field, use the SCReplaceObRefInField command to select a new object to use as reference. Note that all object 
references within the field will be replaced using this command and as a result, ill formed fields may result. 

To Replace Object References within MText

1. Choose SC Utilities > Property Labels > Replace Object Reference

2. Select the mtext containing the fields.

3. Select the new object to ‘point’ the fields to. 

The AutoCAD effect of improperly evaluated fields is to display ‘####’ in place of the field. You can display the field in its 
raw form and edit the field by using the SCEditField command. 

To Edit Fields in MText

1. Choose SC Utilities > Property Labels > Edit Fields

2. Select the mtext containing the fields.

3. Edit the text within the Field text box.

Leader Distribution Lines
Leader distribution lines allow ShipConstructor labels to be automatically aligned and spaced. Leaders when attached to 
a distribution line, adjust as necessary when the line is moved, resized, or rotated. Leader distribution lines behave 
exactly like AutoCAD lines and therefore can be modified in the same manner as AutoCAD lines. 
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Distribution Lines – The leader distribution lines are visible as light gray lines in the above image. Distribution lines do not plot.

Leaders can be manipulated in several ways with respect to distribution lines:

1. Dragged off a leader distribution line. The leader will be detached from the distribution line such that any further 
manipulation of the line will not affect the leader.

2. Repositioned along the distribution line. The leader’s new position along the line is maintained even if the line is 
subsequently manipulated.

3. Dragged onto another distribution line. The leader is detached from the first line and attached to the new line.

4. Bulk transfer to another distribution line. Using the SCTRANSFERLEADERS command, the selected labels are 
transferred to another distribution line.

5. Distribution line manipulation. Transform the line using any of the standard AutoCAD methods. The labels will 
remain attached. 

Note: In order for individual leader manipulations to be effective when positioning on distribution lines, enable the 
Nearest Osnap.

Line dependent variables:
1. Bubble spacing - Bubble spacing can be set on a per-line basis. This forms the minimum spacing between the 

labels. 

2. Leader attachment position – To ensure consistent label positioning, distribution lines enforce leader consistent 
insertion modes among all the leaders on the line.

3. Distribution mode – Can be:

a. Nearest – Labels stay on positions along the line which are the closest possible to their represented parts. 
Nearest mode is the default setting when a distribution line is created.

b. Center – labels are centered in the middle of distribution lines.
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c. Equidistant – labels bubbles are evenly distributed on the line.

Leader Insertion Mode
This command is used to modify the insertion mode of all the labels connected to selected distribution lines.

To set the leader insertion mode

1. Choose Set Leader Insertion Mode (page 339).

Select distribution lines: 

2. Select the distribution lines.
Enter an insertion mode [Left/Right/Center/closest Horizontal] <H>:

3. Enter the new insertion mode.

Redistributing Leaders on a Distribution Line
This command is used to redistribute leaders on the distribution line in one of the three modes.

To Redistribute Leaders

4. Choose Redistribute Leaders (page 339).
Select distribution lines: 

5. Select the distribution lines.



Getting Started with Production

179

Enter a distribution mode [Center/Nearest/Equidistant] <Nearest>:
6. Enter one of the three distribution modes.

Exporting Drawings to Native AutoCAD Drawings
Export to Dwg generates a drawing that can be opened by AutoCAD without ShipConstructor being present on the 
computer. 

The export process allows the user to configure the viewport display options that are used when generating the output 
entities. The default settings are read from the ShipConstructor source drawing's model space configuration. These 
options can be changed through the UI or the command line when performing an export.

There are a number of steps to export a ShipConstructor drawing to a regular .dwg that can be read by AutoCAD. First the 
original drawing is copied to a temporary location to avoid making changes to the source document. Then all of the xrefs 
will be removed and a local copy of the data will be created in a block with the same name as the xref block. Once that is 
done all ShipConstructor entities will be replaced with native AutoCAD entities, which will be generated according to the 
display options provided. When all ShipConstructor entities have been successfully removed the drawing will be copied to 
the final location. The default name for the new file is the original file's name with '_Export' and, if necessary, a unique 
number appended to the end.

Layer Templates

Layer templates are used to give fine grained control of where output entities are placed in the new drawing. The 
templates consist of static text that will be included as is in the layer name as well as any instance of the text  '<Source 
Layer>' which will be replaced with the name of the layer the source entity is on. The line '<Source Layer>' can be 
included anywhere in the layer template and can be included multiple times.

If the new layer does not exist it will be created and the new entity or entities will be placed on it.

Source Layer Layer Template Final Layer

_Parts ExportedParts ExportedParts

_Parts <Source Layer> _Parts

_Parts ExportLayer<Source Layer> ExportLayer_Parts

_Parts <SourceLayer>A<Source Layer>B _PartsA_PartsB

To export a drawing

1. Open the drawing you want to export.

2. Choose SC Utilities > Export > Export to DWG.

3. The drawing being exported will be closed when the export drawing is created. If you have made changes that 
haven’t been saved ShipConstructor will bring up a window asking to save those changes.
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Change any options and click OK.
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4. Select a folder and enter a drawing name for the exported drawing.

5. To load a previously saved configuration use the 'Load' button and select the configuration file to read.

To export a drawing without windows

1. Enter the command –SCEXPORTDWGSILENT.
Enter filename [Config]<C:\Export\MyAssemblyDrawing_Export.dwg>:

2. The export will use the ShipConstructor display settings of the current document, if you want to use other settings 
enter Config will allow you to enter an optional file name on the command line from which export settings can be 
read. These files can be generated using Export to Dwg and the save option in the window.

3. Enter a file name or use the default filename that is generated.

4. The file is exported.

Create Arrangement Drawing Wizard Reference
The Create Arrangement Drawing wizard is a tool for generating arrangement drawings.
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The first page of the wizard is for entering a drawing name. The Next button will be disabled until a valid drawing name is 
entered. There is also error text that shows up underneath the name textbox to let you know what is wrong with the 
name.
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The second page of the wizard is where you select your arrangement template drawing.
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The third page of the wizard is where you select the various sources that you want to include in your arrangement drawing 
and the layers of where to put them. You can select an arbitrary number of sources to include in your arrangement 
drawing. A summary of all selected sources and their layers appears on the right side of the screen under Selected 
Sources.

While choosing sources for your drawing, selecting a root node in the tree will also select anything underneath that node. 
So if you want to create an arrangement drawing containing an entire system with all its branches, simply click on the 
system.  When selecting assemblies, you can avoid selecting the branches by using the Control key (Control-Click).

You may also choose to retain the layers of the part from its model drawing source at this step. Choosing Retain Model 
Drawing Layers from the dropdown in the layer column will cause the layers from all model drawings containing parts in 
the current source to be copied into the arrangement drawing and the parts will be moved to the copy of the layer of their 
source. This brings in all layers from the source, not just ones used by parts in the given source.  If multiple model 
drawings to bring layers in from have layers with the same name, the first one encountered will be taken and further 
layers of that name will be ignored.  
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The last page of the arrangement drawing creation wizard lets you choose which drawings non-ShipConstructor geometry 
will obtained from and the layers to put them on.  The drawings presented in this tree are computed based on the sources 
you have selected during Step 3 of the arrangement drawing creation process.  The layer column behaves similar to that 
of the previous step.

Note: Any geometry imported using this mechanism has a special tag attached to it for the purpose of identifying it. 
When the drawing is updated, only the non-ShipConstructor entities brought into the drawing with this process are 
updated. Any custom geometry you manually add to the arrangement drawing will be unaffected during a drawing 
update.
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Layer Conflict Resolution Reference

The Layer Conflict Resolution window is used when creating or updating arrangement or assembly drawings.  It allows 
you to easily move any parts that were given multiple layers to go to in source selection.

The window will appear when creating or updating production drawings where layers are defined with sources if there are 
any parts with multiple source layers defined. The list labeled Layer Conflicts shows all the sources that contain conflicted
parts, and a status icon for each conflict.  You can select any of the conflict in this list, and, depending on the View
options, the conflicted parts from the selected conflict will be highlighted, centered, and zoomed to. The list labeled 
Layers shows the possible layers for the currently selected conflict on the Layer Conflicts list. The Use for all button will 
assign the checked layer in the Layers list to all conflicts where that layer is an option.

Status Icons
The X icon signifies that the conflict hasn’t been resolved.

The Check Mark icon signifies that it has been resolved.

The Exclamation Mark icon signifies that it is resolved but was changed by the Use for all button.

Once all conflicts are resolved the OK button will be enabled and you can press it to move the conflicted parts to the 
selected layers.

Update Arrangement Drawing Wizard Reference
The Update Arrangement Drawing Wizard appears when an arrangement drawing is updated. It lets you add and remove 
sources for ShipConstructor parts as well as sources for non-ShipConstructor geometry. 
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All sources that are currently used to populate this drawing are summarized under the Selected Sources heading. In 
addition, the sources are also pre-selected in the main source trees with the layer specified entered in the Layer column, 
and the appropriate nodes expanded for easy visual identification.

To add or remove sources from this arrangement drawing, use the check boxes in the source trees. You may add any 
number of sources to one drawing. The Layers column works the same here as it does for creation of an arrangement 
drawing, except that parts for each source that are already in the arrangement drawing will remain on their current layer.
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The second page of the wizard shows you all drawings that ShipConstructor entities will be obtained from to create the 
arrangement drawing. If you want to also bring in non-ShipConstructor geometry, such as lines and solids from those 
drawings, select them here. Any drawings that you have already obtained non-ShipConstructor entities from will be pre-
selected. The Layers column behaves similar to that of the previous step.

Note: While updating non-ShipConstructor entities, only entities that were brought into the drawing with this process 
will be affected. If you have custom annotations or any other geometry in the arrangement drawing, it will not be 
affected during updating.
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5.
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Appendix

Command Reference

SC MarineDrafting > Create Views Automatically…

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Create Views Automatically…
Command ...... SCMDAUTOCREATE
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure.......

Creates MarineDrafting Views by using plate parts in the output drawing link.

SC MarineDrafting > Create a View…

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Create a View…
Command ...... SCMDCREATE
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Create a View (page 30)

Creates a MarineDrafting View manually.

SC MarineDrafting > Update Views…

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Update Views…
Command ...... SCMDUPDATE
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Generating Views (page 27)

Updates all or selected views. This generates the 2D View geometry and removes any previous, unmodified 2D View 
objects.
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SC MarineDrafting > List Source Part

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > List Source Part
Command ...... SCMDLISTPART
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Lists the list information from the source part of a 2D View geometry object in the commandline window. This can be 
used to get information about the source part that is not listed in the property palette.

SC MarineDrafting > Copy Objects to 2D View

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Copy Objects to 2D View
Command ...... SCMDCOPYOBJECTS
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Copy Objects to 2D View (page 32)

Makes a copy of the selected objects in the ship coordinate system, transforms them to the selected MarineDrafting 2D 
View and runs convert 3D to 2D on valid geometry objects. 

SC MarineDrafting > Open Output Drawing

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Open Output Drawing
Command ...... SCMDOPENSOURCE
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Opens the output drawing that is the source to the MarineDrafting drawing.

SC MarineDrafting > Repair Link to Output Drawing

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Repair Link to Output Drawing
Command ...... SCMDREPAIRSOURCE
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Repairs the link to the output drawing that is the source to this MarineDrafting drawing.
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SC MarineDrafting > Reverse View Direction

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Reverse View Direction
Command ...... SCMDREVERSEVIEW
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Reverses the view direction for the selected MarineDrafting views. 

Note: When reversing the view direction, the output when updated will mirror about the section coordinate system 
origin. Moving the section coordinate system icon may be necessary to achieve the desired results.

SC MarineDrafting > Repair Property Label Fields

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > Repair Property Label Fields
Command ...... SCMDREPAIRLABELS
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

If property labels are created by selecting 2D view output geometry there is a link to the part in the output drawing 
referenced by the output drawing xref. If the output drawing becomes detached, the field links to the parts can be broken. 
Run Repair Property Label Fields to repair those fields.

SC MarineDrafting > View Creation Settings…

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > View Creation Settings…
Command ...... SCMDCREATESETTINGS
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... View Creation Settings (page 8)

Settings used to control the creation of MarineDrafting views. The settings are stored in the drawing.

SC MarineDrafting > View Generation Settings…

Button .............
Ribbon ............ Production tab > MarineDrafting panel
Menu ............... SC MarineDrafting > View Generation Settings…
Command ...... SCMDGENERATESETTINGS
Permissions ... General > Edit MarineDrafting
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... View Generation Settings (page 13)

Settings used to control the generation of MarineDrafting views. The settings are stored in the drawing.
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Commandline Commands

-SCMDLAYERSCREATE

Command ...... -SCMDCREATELAYERS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Creates the layers that are in the View Creation Settings (page 8) and the View Generation Settings (page 13). Helpful if 
you want to setup the layer properties in the template drawing without having to create the layers manually.

-SCMDMINPLATEAREA

Command ...... -SCMDMINPLATEAREA
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Minimum Plate Area For View Creation in View Creation Settings (page 8).

Plates with this area or larger are used to define a view. The value is stored in the drawing.

-SCMDBOUNDBOXDEPTH

Command ...... -SCMDBOUNDBOXDEPTH
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Bounding Box Depth in View Creation Settings (page 8). The value is stored in the drawing.

The depth of the bounding box when creating new views. The length and width use the extents of the parts.

-SCMDVIEWLAYER

Command ...... -SCMDVIEWLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Layer in View Creation Settings (page 8). The value is stored in the drawing.

Layer to place the new view control objects.

-SCMDFRAMESTRING

Command ...... -SCMDFRAMESTRING
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Default Direction > Frame View Direction in View Creation Settings (page 8). The value is stored in the 
drawing.

The contents of the text in new 2D View Coordinate System objects for frames. The formatting is the same that are 
available for MText.
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-SCMDLONGSTRING

Command ...... -SCMDLONGSTRING
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Default Direction > Longitudinal View Direction in View Creation Settings (page 8). The value is stored in the 
drawing.

The contents of the text in new 2D View Coordinate System objects for longitudinals. The formatting is the same that are 
available for MText.

-SCMDDECKSTRING

Command ...... -SCMDDECKSTRING
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits View > Default Direction > Deck View Direction in View Creation Settings (page 8). The value is stored in the 
drawing.

The contents of the text in new 2D View Coordinate System objects for decks. The formatting is the same that are 
available for MText.

-SCMDOCSSIZE

Command ...... -SCMDOCSSIZE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Size in View Creation Settings (page 8). The value is stored in the drawing.

Size of new 2D View coordinate system objects.

-SCMDOCSTEXTMARGIN

Command ...... -SCMDOCSTEXTMARGIN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text Margin in View Creation Settings (page 8). The value is stored in the drawing.

Distance between 2D View coordinate system icon and text label.

-SCMDOCSTEXTSIZE

Command ...... -SCMDOCSTEXTSIZE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text Size in View Creation Settings (page 8). The value is stored in the drawing.

Text size of new 2D View coordinate system objects.
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-SCMDOCSTEXTSTYLE

Command ...... -SCMDOCSTEXTSTYLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text Style in View Creation Settings (page 8). The value is stored in the drawing.

Text style of new 2D View coordinate system objects.

-SCMDOCSLAYER

Command ...... -SCMDOCSLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Layer in View Creation Settings (page 8). The value is stored in the drawing.

Layer to place new 2D View Coordinate System objects.

-SCMDOCSGEOMMARGIN

Command ...... -SCMDOCSGEOMMARGIN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Geometry Margin in View Creation Settings (page 8). The value is stored in the 
drawing.

Distance between 2D View coordinate system icon and the minimum extents of the 2D View geometry.

-SCMDVIEWGAP

Command ...... -SCMDVIEWGAP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Placement > Gap Between Views in View Creation Settings (page 8). The value is 
stored in the drawing.

Vertical gap between new 2D views of the same orientation.

-SCMDVIEWTYPEGAP

Command ...... -SCMDVIEWTYPEGAP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Placement > Gap Between View Types in View Creation Settings (page 8). The value is 
stored in the drawing.

Horizontal gap between the frames / longs / decks columns of new 2D views.
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-SCMDFRAMELOCGROUP

Command ...... -SCMDFRAMELOCGROUP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Frame Location Group in View Creation Settings (page 8). The value is stored in 
the drawing.

Location group to use for <LOCATION > keyword in Frame View Name String. The entered name is validated against 
location group names in the database. Location Groups can be created using the command SCEDITLOCATIONS.

-SCMDLONGLOCGROUP

Command ...... -SCMDLONGLOCGROUP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Longitudinal Location Group in View Creation Settings (page 8). The value is 
stored in the drawing.

Location group to use for <LOCATION > keyword in Longitudinal View Name String. The entered name is validated 
against location group names in the database. Location Groups can be created using the command SCEDITLOCATIONS.

-SCMDDECKLOCGROUP

Command ...... -SCMDDECKLOCGROUP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Deck Location Group in View Creation Settings (page 8). The value is stored in 
the drawing.

Location group to use for <LOCATION > keyword in Deck View Name String. The entered name is validated against 
location group names in the database. Location Groups can be created using the command SCEDITLOCATIONS.

-SCMDLOOKAFT

Command ...... -SCMDLOOKAFT
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Aft String in View Creation Settings (page 8). The value is stored in the drawing.

Sets the alias for 'Looking Aft' to use for the <VIEWDIRECTION > keyword and properties palette.

-SCMDLOOKFORWARD

Command ...... -SCMDLOOKFORWARD
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Forward String in View Creation Settings (page 8). The value is stored in the 
drawing.

Sets the alias for 'Looking Forward' to use for the <VIEWDIRECTION > keyword and properties palette.
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-SCMDLOOKSTARBOARD

Command ...... -SCMDLOOKSTARBOARD
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Starboard String in View Creation Settings (page 8). The value is stored in the 
drawing.

Sets the alias for 'Looking Starboard' to use for the <VIEWDIRECTION > keyword and properties palette.

-SCMDLOOKPORT

Command ...... -SCMDLOOKPORT
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Port String in View Creation Settings (page 8). The value is stored in the 
drawing.

Sets the alias for 'Looking Port' to use for the <VIEWDIRECTION > keyword and properties palette.

-SCMDLOOKSTARDOWN

Command ...... -SCMDLOOKSTARDOWN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Down String in View Creation Settings (page 8). The value is stored in the 
drawing.

Sets the alias for 'Looking Down' to use for the <VIEWDIRECTION > keyword and properties palette.

-SCMDLOOKUP

Command ...... -SCMDLOOKUP
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Text > Up String in View Creation Settings (page 8). The value is stored in the drawing.

Sets the alias for 'Looking Up' to use for the <VIEWDIRECTION > keyword and properties palette.

-SCMDREFLINELAYER

Command ...... -SCMDREFLINELAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Layer in View Creation Settings (page 8). The value is stored in the 
drawing.

Sets the layer to place new reference line objects.
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-SCMDDLFRAMESTYLEX

Command ...... -SCMDDLFRAMESTYLEX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Frame View > Transverse > Style in View Creation Settings (page 
8). The value is stored in the drawing.

Sets the reference line style for transverse locations in frame views. The entered name is validated against reference line 
style names in the drawing.

-SCMDDLFRAMELOCX

Command ...... -SCMDDLFRAMELOCX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Frame View > Transverse > Distance from Origin in Z in View 
Creation Settings (page 8). The value is stored in the drawing.

Sets the vertical location of transverse reference line in frame views. The value is in project length units and relative to 
the ship coordinate system origin.

-SCMDDLFRAMESTYLEY

Command ...... -SCMDDLFRAMESTYLEY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Frame View > Vertical > Style in View Creation Settings (page 8).
The value is stored in the drawing.

Sets the reference line style for vertical locations in frame views. The entered name is validated against reference line 
style names in the drawing.

-SCMDDLFRAMELOCY

Command ...... -SCMDDLFRAMELOCY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Frame View > Vertical > Distance from Origin in Y in View Creation 
Settings (page 8). The value is stored in the drawing.

Sets the transverse location of vertical reference line in frame views. The value is in project length units and relative to 
the ship coordinate system origin.

-SCMDDLLONGSTYLEX

Command ...... -SCMDDLLONGSTYLEX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Longitudinal View > Longitudinal > Style in View Creation Settings
(page 8). The value is stored in the drawing.

Sets the reference line style for longitudinal locations in longitudinal views. The entered name is validated against 
reference line style names in the drawing.
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-SCMDDLLONGLOCX

Command ...... -SCMDDLLONGLOCX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Longitudinal View > Longitudinal > Distance from Origin in Z in 
View Creation Settings (page 8). The value is stored in the drawing.

Sets the vertical location of longitudinal reference line in longitudinal views. The value is in project length units and 
relative to the ship coordinate system origin.

-SCMDDLLONGSTYLEY

Command ...... -SCMDDLLONGSTYLEY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Longitudinal View > Vertical > Style in View Creation Settings (page 
8). The value is stored in the drawing.

Sets the reference line style for vertical locations in longitudinal views. The entered name is validated against reference 
line style names in the drawing.

-SCMDDLLONGLOCY

Command ...... -SCMDDLLONGLOCY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Longitudinal View > Vertical > Distance from Origin in Z in View 
Creation Settings (page 8). The value is stored in the drawing.

Sets the longitudinal location of vertical reference line in longitudinal views. The value is in project length units and 
relative to the ship coordinate system origin.

-SCMDDLDECKSTYLEX

Command ...... -SCMDDLDECKSTYLEX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Deck View > Longitudinal > Style in View Creation Settings (page 
8). The value is stored in the drawing.

Sets the reference line style for longitudinal locations in deck views. The entered name is validated against reference line 
style names in the drawing.

-SCMDDLDECKLOCX

Command ...... -SCMDDLDECKLOCX
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Deck View > Longitudinal > Distance from Origin in Z in View 
Creation Settings (page 8). The value is stored in the drawing.

Sets the transverse location of longitudinal reference line in deck views. The value is in project length units and relative to 
the ship coordinate system origin.
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-SCMDDLDECKSTYLEY

Command ...... -SCMDDLDECKSTYLEY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Deck View > Transverse > Style in View Creation Settings (page 8).
The value is stored in the drawing.

Sets the reference line style for transverse locations in deck views. The entered name is validated against reference line 
style names in the drawing.

-SCMDDLDECKLOCY

Command ...... -SCMDDLDECKLOCY
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits 2D View Coordinate System > Reference Lines > Deck View > Transverse > Distance from Origin in Z in View 
Creation Settings (page 8). The value is stored in the drawing.

Sets the longitudinal location of transverse reference line in deck views. The value is in project length units and relative to 
the ship coordinate system origin.

-SCMDGENSTIFFCROSSSECTION

Command ...... -SCMDGENSTIFFCROSSSECTION
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Stiffener Cross Sections for Attached Stiffeners > Generate in View Generation Settings (page 13). The value is 
stored in the drawing.

If Yes, cross-section polylines will be generated next to a stiffener that is attached to a plate.

-SCMDSTIFFCROSSSECTIONOFFSET

Command ...... -SCMDSTIFFCROSSSECTIONOFFSET
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Stiffener Cross Sections for Attached Stiffeners > Distance from Stiffener in View Generation Settings (page 13). The 
value is stored in the drawing.

The distance to offset the cross-section polyline from midpoint of the stiffener moldline. Positive value is in the direction 
of throw of the stiffener. The value is in project length units.

-SCMDSTIFFCROSSSECTIONLAYER

Command ...... -SCMDSTIFFCROSSSECTIONLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Stiffener Cross Sections for Attached Stiffeners > Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place the cross-section polylines on.
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-SCMDGENCURVEDSECTIONTHICKNESS

Command ...... -SCMDGENCURVEDSECTIONTHICKNESS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Curved Sections > Generate Thickness Side in View Generation Settings (page 13). The value is stored in the 
drawing.

If Yes, generates the section the solid instead of the mold surface.

-SCMDGENPLATESEAMSYMBOL

Command ...... -SCMDGENPLATESEAMSYMBOL
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Plate Seam Symbol > Generate in View Generation Settings (page 13). The value is stored in the drawing.

If Yes, a block containing a plate seam symbol will be generated.

-SCMDPLATESEAMSYMBOLINSTOL

Command ...... -SCMDPLATESEAMSYMBOLINSTOL
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Plate Seam Symbol > Insertion Tolerance in View Generation Settings (page 13). The value is stored in the drawing.

Tolerance to determine when to insert a plate seam symbol block. The distance between the ends of plate sections that 
are less than this value will have a symbol. The value is in project length units.

-SCMDPLATESEAMBLOCKNAME

Command ...... -SCMDPLATESEAMBLOCKNAME
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Plate Seam Symbol > Block Name in View Generation Settings (page 13). The value is stored in the drawing.

Name of the block to use for plate seam symbols. If the block does not exist then a block will be defined with the initial 
settings. Name is validated against AutoCAD symbol name restrictions.

-SCMDPLATESEAMSYMBOLSIZE

Command ...... -SCMDPLATESEAMSYMBOLSIZE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Plate Seam Symbol > Initial Size in View Generation Settings (page 13). The value is stored in the drawing.

When the block does not exist, a block is created with a symbol of this size. The value is in project length units.
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-SCMDPLATESEAMLAYER

Command ...... -SCMDPLATESEAMLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Plate Seam Symbol > Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place the plate seam symbol blocks. Layer can either exist already or name is validated against AutoCAD symbol
name restrictions and will be created.

-SCMDGENINTCONTSYMBOLS

Command ...... -SCMDGENINTCONTSYMBOLS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Generate in View Generation Settings (page 13). The value is stored in the 
drawing.

If Yes, generates the intercostal and continuous symbols.

-SCMDINTCONTSYMBOLSIZE

Command ...... -SCMDINTCONTSYMBOLSIZE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Initial Size in View Generation Settings (page 13). The value is stored in the 
drawing.

When the block does not exist, a block containing an arrow is created with a symbol of this size. The value is in project 
length units.

-SCMDINTSYMBOLBLOCKNAME

Command ...... -SCMDINTSYMBOLBLOCKNAME
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Intercostal Block Name in View Generation Settings (page 13). The value is 
stored in the drawing.

Name of the block to use for intercostal symbols. Only one arrow of the symbol needs to be modeled. If the block does 
not exist then a block will be defined with the initial settings. Name is validated against AutoCAD symbol name 
restrictions.

-SCMDCONTSYMBOLBLOCKNAME

Command ...... -SCMDCONTSYMBOLBLOCKNAME
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Continuous Block Name in View Generation Settings (page 13). The value is 
stored in the drawing.

Name of the block to use for continuous symbols. Only one arrow of the symbol needs to be modeled. If the block does 
not exist then a block will be defined with the initial settings. Name is validated against AutoCAD symbol name 
restrictions.
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-SCMDINTSYMBOLLAYER

Command ...... -SCMDINTSYMBOLLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Intercostal Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place the intercostal symbol blocks. Layer can either exist already or name is validated against AutoCAD symbol 
name restrictions and will be created.

-SCMDCONSTSYMBOLLAYER

Command ...... -SCMDCONSTSYMBOLLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Continuous Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place the continuous symbol blocks. Layer can either exist already or name is validated against AutoCAD symbol 
name restrictions and will be created.

- SCMDINTDETECTDIST

Command ...... - SCMDINTDETECTDIST
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Intercostal > Continuous Symbols > Detection Distance in View Generation Settings (page 13). The value is stored in 
the drawing.

The distance from the out-of-plane plates to test for primary plane plates. If plates have a weld gap then make this value 
at least as large as the weld gap. 

-SCMDGENHEPCONNECTIONS

Command ...... -SCMDGENHEPCONNECTIONS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Distributed Systems Connection > Generate Points in View Generation Settings (page 13). The value is stored in the 
drawing.

If Yes, points will be generated at connection locations.

-SCMDHEPCONNECTIONLAYER

Command ...... -SCMDHEPCONNECTIONLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Distributed Systems Connection > Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place the connection points on. Layer can either exist already or name is validated against AutoCAD symbol 
name restrictions and will be created.
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-SCMDGENPENETRATIONS

Command ...... -SCMDGENPENETRATIONS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Penetration > Generate Points in View Generation Settings (page 13). The value is stored in the drawing.

If Yes, points will be generated at penetration locations.

-SCMDPENETRATIONLAYER

Command ...... -SCMDPENETRATIONLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Penetration > Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place the penetration points on. Layer can either exist already or name is validated against AutoCAD symbol 
name restrictions and will be created.

-SCMDERASEUNMODIFIED

Command ...... -SCMDERASEUNMODIFIED
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Unmodified 2D View Geometry > Erase in View Generation Settings (page 13). The value is stored in the drawing.

On update of a view, the unmodified 2D View geometry objects are erased (if Yes) or moved to the Unmodified 2D View 
geometry layer (if No).

-SCMDUNMODIFIEDLAYER

Command ...... -SCMDUNMODIFIEDLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Unmodified 2D View Geometry > Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place unmodified 2D View geometry objects during update of a MarineDrafting view if Erase is unchecked. Layer 
can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDERASEREMOVEDPARTS

Command ...... -SCMDERASEREMOVEDPARTS
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Removed Parts > Erase in View Generation Settings (page 13). The value is stored in the drawing.

On update of a view, 2D View geometry objects that are generated from parts that no longer exist in the production 
drawing are erased (if Yes) or moved to the Removed layer (if No). 
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-SCMDREMOVEDLAYER

Command ...... -SCMDREMOVEDLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Removed Parts > Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place 2D View geometry objects of removed parts during update of a MarineDrafting view if Erase is unchecked.
Layer can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDORIGINALLAYER

Command ...... -SCMDORIGINALLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Original 2D View Geometry Layer in View Generation Settings (page 13). The value is stored in the drawing.

When 2D View geometry objects are modified a copy of the original 2D View geometry object is placed on this layer.
Layer can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDSECTIONLAYER

Command ...... -SCMDSECTIONLAYER
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Section Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place 2D View geometry objects from sectioned objects. Layer can either exist already or name is validated 
against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLATEVISIBLE

Command ...... -SCMDLAYERPLATEVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Plate Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from plate parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLATEHIDDEN

Command ...... -SCMDLAYERPLATEHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Plate Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from plate parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.
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-SCMDLAYERSTIFFENERVISIBLE

Command ...... -SCMDLAYERSTIFFENERVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Stiffener Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from stiffener parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERSTIFFENERHIDDEN

Command ...... -SCMDLAYERSTIFFENERHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Stiffener Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from stiffener parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERFACEPLATEVISIBLE

Command ...... -SCMDLAYERFACEPLATEVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Faceplate Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from faceplates. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERFACEPLATEHIDDEN

Command ...... -SCMDLAYERFACEPLATEHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Faceplate Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from faceplates. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERCORRUGATEDVISIBLE

Command ...... -SCMDLAYERCORRUGATEDVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Corrugated Plate Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from corrugated plate parts.
Layer can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.
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-SCMDLAYERCORRUGATEDHIDDEN

Command ...... -SCMDLAYERCORRUGATEDHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Corrugated Plate Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from corrugated plate parts.
Layer can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLANKVISIBLE

Command ...... -SCMDLAYERPLANKVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Plank Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from plank parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLANKHIDDEN

Command ...... -SCMDLAYERPLANKHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > HIdden Plank Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from plank parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLATEOOPVISIBLE

Command ...... -SCMDLAYERPLATEOOPVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Plate Out of Plane Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from plate parts that are not in 
the plane of the section. Layer can either exist already or name is validated against AutoCAD symbol name restrictions 
and will be created.

-SCMDLAYERPLATEOOPHIDDEN

Command ...... -SCMDLAYERPLATEOOPHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Plate Out of Plane Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from plate parts that are not in 
the plane of the section. Layer can either exist already or name is validated against AutoCAD symbol name restrictions 
and will be created.
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-SCMDLAYERPLATEOOPFVISIBLE

Command ...... -SCMDLAYERPLATEOOPFVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Plate Out of Plane Near Layer in View Generation Settings (page 13). The value is stored 
in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from plate parts that are not in 
the plane of the section and near side of the section plane. Layer can either exist already or name is validated against 
AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLATEOOPFHIDDEN

Command ...... -SCMDLAYERPLATEOOPFHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Plate Out of Plane Near Layer in View Generation Settings (page 13). The value is stored 
in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from plate parts that are not in 
the plane of the section and near side of the section plane. Layer can either exist already or name is validated against 
AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPLATELINEHIDDEN

Command ...... -SCMDLAYERPLATELINEHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Plate Line Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from plate parts attached to the 
far side of the primary plate plane. Layer can either exist already or name is validated against AutoCAD symbol name 
restrictions and will be created.

-SCMDLAYERPLATEOOPPARTIALLYVISIBLE

Command ...... -SCMDLAYERPLATEOOPPARTIALLYVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Plate Partially Visible Out of Plane Layer in View Generation Settings (page 13). The 
value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from partially visible out of 
plane plate parts. Layer can either exist already or name is validated against AutoCAD symbol name restrictions and will 
be created.

-SCMDLAYERSTIFFENERLINEVISIBLE

Command ...... -SCMDLAYERSTIFFENERLINEVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Stiffener Line Layer in View Generation Settings (page 13). The value is stored in the 
drawing.
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Layer to place visible 2D View geometry objects from objects in the view bounds that are from stiffeners attached to the 
near side of the plate. Layer can either exist already or name is validated against AutoCAD symbol name restrictions and 
will be created.

-SCMDLAYERSTIFFENERLINEHIDDEN

Command ...... -SCMDLAYERSTIFFENERLINEHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Stiffener Line Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from stiffeners attached to the 
near side of the plate. Layer can either exist already or name is validated against AutoCAD symbol name restrictions and 
will be created.

-SCMDLAYERSTIFFENERFLANGETHICKNESSVISIBLE

Command ...... -SCMDLAYERSTIFFENERFLANGETHICKNESSVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Visible Stiffener Flange Thickness Layer in View Generation Settings (page 13). The value is 
stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from flange thickness line of
stiffeners shown as solids. Layer can either exist already or name is validated against AutoCAD symbol name restrictions 
and will be created.

-SCMDLAYERSTIFFENERFLANGETHICKNESSHIDDEN

Command ...... -SCMDLAYERSTIFFENERFLANGETHICKNESSHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Structure > Hidden Stiffener Flange Thickness Layer in View Generation Settings (page 13). The value is 
stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from flange thickness line of 
stiffeners shown as solids. Layer can either exist already or name is validated against AutoCAD symbol name restrictions 
and will be created.

-SCMDLAYERPIPEVISIBLE

Command ...... -SCMDLAYERPIPEVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Visible Pipe Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from pipe parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.
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-SCMDLAYERPIPEHIDDEN

Command ...... -SCMDLAYERPIPEHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Hidden Pipe Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from pipe parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERHVACVISIBLE

Command ...... -SCMDLAYERHVACVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Visible HVAC Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from HVAC parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERHVACHIDDEN

Command ...... -SCMDLAYERHVACHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Hidden HVAC Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from HVAC parts. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYEREQUIPMENTVISIBLE

Command ...... -SCMDLAYEREQUIPMENTVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Visible Equipment Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from equipment parts. Layer 
can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYEREQUIPMENTHIDDEN

Command ...... -SCMDLAYEREQUIPMENTHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Hidden Equipment Layer in View Generation Settings (page 13). The value is stored in 
the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from equipment parts. Layer
can either exist already or name is validated against AutoCAD symbol name restrictions and will be created.
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-SCMDLAYERHANGERVISIBLE

Command ...... -SCMDLAYERHANGERVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Visible Pipe Hanger Layer in View Generation Settings (page 13). The value is stored 
in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from pipe hangers. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERHANGERHIDDEN

Command ...... -SCMDLAYERHANGERHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Distributed Systems > Hidden Pipe Hanger Layer in View Generation Settings (page 13). The value is stored 
in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from pipe hangers. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERCABLESUPPORTVISIBLE

Command ...... -SCMDLAYERCABLESUPPORTVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Electrical > Visible Cable Support Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from cable supports. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERCABLESUPPORTHIDDEN

Command ...... -SCMDLAYERCABLESUPPORTHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Electrical > Hidden Cable Support Layer in View Generation Settings (page 13). The value is stored in the 
drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from cable supports Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERNONPARTVISIBLE

Command ...... -SCMDLAYERNONPARTVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Misc > Visible Non Part Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are not parts. Layer can either exist 
already or name is validated against AutoCAD symbol name restrictions and will be created.
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-SCMDLAYERNONPARTHIDDEN

Command ...... -SCMDLAYERNONPARTHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Misc > Hidden Non Part Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are not parts. Layer can either exist 
already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPARTVIEWVISIBLE

Command ...... -SCMDLAYERPARTVIEWVISIBLE
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Misc > Visible Part View Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place visible 2D View geometry objects from objects in the view bounds that are from partviews. Layer can either 
exist already or name is validated against AutoCAD symbol name restrictions and will be created.

-SCMDLAYERPARTVIEWHIDDEN

Command ...... -SCMDLAYERPARTVIEWHIDDEN
License............ Universal, MarineDrafting
Permissions ... Edit MarineDrafting drawing

Edits Layer > Misc > Hidden Part View Layer in View Generation Settings (page 13). The value is stored in the drawing.

Layer to place hidden 2D View geometry objects from objects in the view bounds that are from partviews. Layer can 
either exist already or name is validated against AutoCAD symbol name restrictions and will be created.
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Appendix A: Menus, Tools & Commands

Manager Menus

File > Import Stocks >
Lets you import Manager settings from another project or from an XML file that was exported from another project, either 
for All Modules or for an individual menu in Manager (General, Structure, Pipe, HVAC, Equipment). See the Project 
Management manual for details.

File > Export Stocks >
Exports Manager settings to an XML file, either for All Modules or for an individual menu in Manager (General, Structure, 
Pipe, HVAC, Equipment). See the Project Management manual for details.

File > Exit
Closes Manager. You are prompted to save any unsaved data.

General > Project Settings

Menu ............... General > Project Settings

Toolbar............
Navigator ........ Settings (with the project selected)
Permissions ... None
Procedure....... Project Settings (page 62)

Opens the Project Settings window, letting you set various project-wide settings.
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Distributed System Supports

Electrical

Equipment

General 

Administrator > Automatic Save – Specifies ShipConstructor’s behavior when AutoCAD triggers an automatic save
(auto-save).

Off – AutoCAD’s auto-save has no effect on the ShipConstructor drawing or database.
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OnUserControl – The ShipConstructor drawing and database are saved when the auto-save triggers.

OnResetOnStart – The ShipConstructor drawing and database are saved when the auto-save triggers. 
Additionally, each time you connect to a project, the AutoCAD auto-save settings are automatically set to be 
enabled (using a default time of 10 minutes between saves). After you have connected to a project you 
may turn off the auto-save in the AutoCAD options, but next time you connect it will be re-enabled.  

Note: You may enable or disable AutoCAD’s automatic save, and specify a time after which an auto-save will be 
triggered in the Open and Save tab of the AutoCAD Options window (Tools > Options menu).

Bill Of Materials > ‘N/A’ Text – When a field in the BOM table is not applicable for a part, the field contains the 
specified text.

Bill Of Materials > ‘Varies’ Text – When a row in the BOM table is a grouping of items and the data for the items is 
different for a field, the field contains the specified text.

Display Length Decimal Places – Indicates the precision of length values displayed in the user interface.

Display Length in ft in 1/16 format – Length measurements displayed in the user interface are displayed in a 
standard feet, inches, and inch-fractions format or in decimal format.

Display Length Units – Indicates the units of length values displayed in the user interface.

Display Weight Decimal Places – Indicates the precision of weight values displayed in the user interface.

Display Weight Units – Indicates the units of weight values displayed in the user interface.

Minimum Interference Volume – The minimum volume that will result in an interference. This lets you filter out very 
small interferences during interference checking that may be the result of parts just touching, interpolation errors by 
the computer, or interferences so small that production will not notice them.

Project ID – The unique project identifier.

Project Length Units – The length units used throughout the project (for example, the units that AutoCAD geometry 
will be drafted in). Do not change this setting after you have begun working on a project.

View From Aft – This setting indicates which direction modeling in Frame Planar Group Model Drawings will take 
place. This setting should be on if you prefer looking at frames from aft to forward. This setting is determined when 
the project is create and is not changeable.

Hull

HVAC

HVAC Colors

HVAC Sizes

Penetrations

Pipe

Pipe Colors

Pipe Sizes

PipeLink

Bolt Diameter Units - Defines the units for bolt diameters in PipeLink PCF files.

Bolt Length Units - Defines the units for bolt lengths in PipeLink PCF files.

Bore Units - Defines the units for component nominal sizes in PipeLink PCF files.

Coordinate Units - Defines the units for all coordinates in PipeLink PCF files.

Rotation Units - Defines the units for rotational gap entries in support attributes in PipeLink PCF files.

Weight Units - Defines the units for component weights in PipeLink PCF files.

Production Drawings

Import Layer – The default setting for part layers when creating a production drawing. Source Name – uses the name 
of the source for the layer name; Retain Model Drawing Layers – Places parts on the same layer as they are in the 
model drawings.|keyword=Import Layer

Automatic Labeling
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Adjacent part edge tolerance - Edges will be less likely to be labeled if they are closer than this distance to an 
edge of another part. Default value is 0.5 mm. See Label > Adjacent Part Edge Tolerance (page 335).

Distribution Mode - Automatic distributing functions will use this setting as the distribution mode. User can set 
the value to one of the three distribution modes – Nearest, Center, and Equidistant. Default Value is Nearest.

Edge Determination Minimum Angle - See Label > Edge Determination Minimum Angle (page 335).

Edge Corner Clearance Distance - See Label > Corner Clearance (page 335).

Label Point to Visible Edges - See Label > Label on Visible Edge On/Off (page 334).

Remove Curved Plate Parts HLR - See Label > Curved Plates in Visible Edge Detection On/Off (page 335).

Reports

Company Name – A text field that can be inserted into production drawings as a keyword. This is included in the 
header of reports.

Hull Number – A text field that can be inserted into production drawings as a keyword.

Job Number – A text field that can be inserted into production drawings as a keyword.

Project Description – A text field that can be inserted into production drawings as a keyword.

Project Name – The descriptive name of the project that will appear in report headers and title pages.

Standard Assemblies

Structure 

Allow Remote Profile Cutouts – Include cutouts from Profiles in different units when adding cutouts to a plate.

AutoOrient Text – When looking at text in structure parts, the text can be viewed as being always readable no matter 
your viewpoint. This is not the default AutoCAD behavior. You may be more used to the AutoCAD behavior to verify 
you are looking from the back side.

The difference on the text when viewing from the back side

AutoOrient Text 

3D PDM – This setting affects the text while in any product model drawing.

Arrangement Drawings – This setting affects the text while in pipe, HVAC or equipment arrangement drawings.

Assembly Drawings – This setting affects the text while in assembly drawings.

Nest Drawings – This is always on because marked text should always be readable.

Spool Drawings – This setting affects the text while in pipe or HVAC spool drawings.

Bend Tolerance (deg) – The minimum angle (in degrees) at which a curved faceplate is considered to have a bend. A 
curved faceplate following the hull is usually represented by a polyline with small straight-line segments. The 
directional change from segment to segment is usually very small (in the order of 1/10 of a degree). Bends this 
small are not producible in a shipyard environment. However, over the length of the faceplate, the total directional 
change is quite likely very large. The Bend Tolerance lets you set a threshold above which the bend will be listed in 
the bend report. When the accumulated values of directional change of the polyline segments exceed the Bend 
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Tolerance value, the directional change is listed. Changing this value after faceplates have been made does not 
affect their bend data.

NC-Pyros Export – Interface to same options in Export To NC-Pyros window. See Structure manual.

Planar Group Tolerance – The maximum distance that planes defined by additional geometry selected when creating 
a planar group can be offset from the plane that is used to define the planar group. Sometimes geometry imported 
into AutoCAD from other software is not exactly in one plane. 

Plate Flange Default Text – The default text to use on the label of a plate flange.

Plate Nesting 

Display FS Marking as Dashed – Yes – Far side marks (the bottom side as it is shown in the nest drawing) is 
shown using the SConDashed Linetype style: No – Far side marks are shown as they will be actually marked.

Nest Corner – See Autonesting Options 

Nest Fit Method – See Autonesting Options

Nest Rotation Angle – See Autonesting Options

Nest Vertically – See Autonesting Options

Solid Creation Tolerance – Determines how accurate ShipConstructor solids are. Solids are used for visual 
representation, interference checking, and the calculation of weight and center of gravity. Solids are not used for 
production. Set Solid Creation Tolerance to 0 to ensure solids exactly match the production geometry or increase the 
value to decrease the accuracy of solids and reduce file size.

Stiffener Marking Type –Controls how ShipConstructor marks stiffeners on plates. A setting of Extents marks the full 
length of the stiffener while a setting of Contact marks only the length of the stiffener which contacts the plate.

The difference between Contact setting and Extents setting.

Structure Colors 

Construction Line Colors 

Offset Construction Line Color – The color of all Offset construction lines.

Planar Group Hull Trace Color – The color of all HullTrace construction lines.

Planar Group Plane Color – The color of all PlanarGroupPlane construction lines.

User Color – The color of all User construction lines.

Draft Colors

Draft Cut Color – The color assigned to the _Draft_Cut layer in structure model drawings.

Draft Mark Color – The color assigned to the _Draft_Mark layer in structure model drawings.

Draft NoProcess Color – The color assigned to the _Draft_NoProcess layer in structure model drawings.

NC-Pyros Colors – The colors of parts when displayed in a nest drawing or after they have been assigned to a nest. 
This makes it easy to differentiate between parts that have been assigned to a nest and parts that are in a nest 
drawing but have not yet been nested.

Bevel Angle Color – Color of the Bevel angle text

Bevel Mark Color– Color of the Bevel mark text

Bevel Standard Color– Color of the Bevel standard text

Inset Color – Outside cut that is in a hole of another part.

Inside Color – Inside cuts. 

Mark Color – Marking on the plate.
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NoProcess Color – Text and lines that are there for reference but not marked on the plate.

Outside Color – Outside cuts.

Plate Stock Color – Stock plate border.

Remnant Colors – Colors of the remnant components in the DXF file after being exported

Remnant Cutline Color – Remnant cutline.

Remnant Hatch Color – Remnant hatch.

Remnant Text Color – Remnant text.

Nest Part Colors 

Outdated Part Color – Part that has been modified after it has been nested.

Unassigned Part Cut Color – A temporary color to signify that the part is not assigned to a nest.

Unassigned Part Mark Color – Temporary color to signify that the part is not assigned to a nest.

Unassigned Part NoProcess Color – Temporary color to signify that the part is not assigned to a nest.

Part Invalid Color – When a plate part cannot generate a boundary, the part will change to this color. It is good to 
make this a distinctive color that will stand out clearly.

Plate Part Colors

Part Bevel Color – Color of bevel code text.

Part Cut Color – Color of lines that will be cut by the NC machine.

Part Mark Color – Color of lines that will be marked by the NC machine.

Part NoProcess Color – Color of lines that will not be processed by the NC machine.

Profile Part Colors

Part Green Color – When adding Green to a stiffener or faceplate, the green is represented by a solid using the 
Part Green Color.

Twisted Stiffener Import Units – The units of STR stringer files from ShipCAM or Maxsurf when creating new twisted 
stiffeners.

Use Surface Name for Part Name – Creating curved plate parts can be named from the surface name in the Hull 
drawing or the DXF filename if using Curved Plates > New…. If this is set to No, a new autonumbered name is 
generated.

Weld Shrinkage Icon Size – The default size of the weld shrinkage icon. 

Weld

General > User Permissions

Menu ............... General > User Permissions

Toolbar............
Permissions ... General > Edit User Permissions
Procedure....... User Permissions (page 63)

Opens the User Permissions window, letting you set up user permissions and permission groups. See User Permissions in 
the Project Management manual for details.

General > Materials

Menu ............... General > Materials

Toolbar............
Permissions ... General > Manager > Edit Materials
Procedure....... Materials (page 64)

Opens the Materials window, letting you create and edit materials.
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Export– Checked materials and grades are exported when you click Export XML.

Material – Lists materials and grades. Right-click on a material or grade to Rename it, Delete it, or create a New Material
or New Grade.

Density – The density of the material, measured in the Density Units. Before entering a Density value, set the Density 
Units to the units for the value you want to enter.

In Use – Indicates with a checkmark which materials and grades are currently in use in the project.

Density Units – The Density of materials and grades are measured in the Density Units. Before entering a Density value, 
set the Density Units to the units for the value you want to enter. To display material densities in another unit, change the 
Density Units.

New Material – Creates a new material.

New Grade – Creates a new material grade for the selected material.

Delete – Deletes the selected material or grade.

Import – Lets you import materials and grades from another project or from an XML file that was exported from another 
project.

Export XML – Exports the checked Export materials and grades to an XML file.

General > Manufacturers

Menu ............... General > Manufacturers
Toolbar............ None
Permissions ... General > Manager > Edit Manufacturers
Procedure....... Manufacturers (page 66)

Opens the Manufacturers window, letting you create and edit manufacturers.
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In Use – Indicates with a checkmark which manufacturers are currently in use in the project.

Manufacturer Name – Lists manufacturers.

New – Creates a new manufacturer.

Delete – Deletes the selected manufacturer.

General > Finishes

Menu ............... General > Finishes
Toolbar............
Permissions ... General > Manager > Edit Finishes
Procedure....... Finishes (page 68)

Opens the Finishes window, letting you create and edit finishes.
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Export – Checked finishes and finish types will be exported when you click Export XML.

Finish Name – Lists finishes and finish types. Right-click on a finish or finish type to Rename it, Delete it, or create a New 
Finish or New Finish Type.

In Use – Indicates with a checkmark which finishes and finish types are currently in use in the project.

New Type – Creates a new finish type.

New Finish – Creates a new finish for the selected finish type.

Delete – Deletes the selected finish or finish type.

Import – Lets you import finishes and finish types from another project, from an XML file that was exported from another 
project or from a Common Parts Catalog (CPC) bulk import file.

Export XML – Exports the checked Export finishes and finish types to an XML file.

Usage Logs – Generates a list of all parts using the selected finish.

General > Insulation

Menu ............... General > Insulation
Toolbar............ None
Permissions ... General > Manager > Edit Insulation
Procedure....... See the HVAC manual

Opens the Insulation window, letting you create and edit insulation. 
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Export – Checked insulation and insulation types will be exported when you click Export XML.

Insulations – Lists insulation and insulation types. Right-click on a insulation or insulation type to Rename it, Delete it, or 
create a New Insulation.

In Use – Indicates with a checkmark which insulation and insulation types are currently in use in the project.

New Type – Creates a new insulation type.

New Insul. – Creates a new insulation for the selected insulation type.

Delete – Deletes the selected insulation or insulation type.

Import – Lets you import insulation and insulation types from another project, from an XML file that was exported from 
another project or from a Common Parts Catalog (CPC) bulk import file.

Export XML – Exports the checked Export insulation and insulation types to an XML file.

Usage Logs – Generates a list of all parts using the selected insulation.

General > Text Styles

Menu ............... General > Text Styles
Toolbar............ None
Permissions ... General > Manager > Edit Text Styles
Procedure....... Text Styles (page 71)

Opens the Text Styles window, letting you create and edit text styles.
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General > Accessory Packages

Menu ............... General > Accessory Packages
Toolbar............ None
Permissions ... General > Manager > Edit Accessory Packages
Procedure....... See Pipe manual

Opens the Accessory Packages window, letting you create and edit accessory packages. See Accessory Packages in the 
Pipe manual for details.

General > User-Defined Attributes

Menu ............... General > User-Defined Attributes
Toolbar............ None
Permissions ... Structure > Manager > Edit Materials
Procedure....... User-Defined Attributes (page 83)

Opens the User-Defined Attributes window, letting you create user-defined attributes and apply them to materials. User-
defined attributes allow you to add custom fields to ShipConstructor.

Available Attribute List – Global list of user defined attributes.

Attribute list – List of user-defined attributes that have been asssigned to types (in the general case, Material Grades).

Required – Is the user-defined attibute required for every instance of the type?

Default – The default value when a new type is created.

New – Creates a new user-defined attribute.
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Delete – Deletes the selected user-defined attribute. The attribute cannot be in use.

Usage Log – Generates a log file that shows where the selected user-defined attribute is being used.

Import UDAs – Imports user-defined attributes from another project or an XML file. Only the user-defined attributes 
assigned to the same types listed in the Attibute list will be shown.

Import – Check each user-defined attribute that you need to import.

General > Naming Conventions

Menu ............... General > Naming Conventions
Toolbar............ None
Permissions ... Structure > Manager > Edit Naming Conventions
Permissions ... Pipe > Manager > Edit Naming Conventions
Permissions ... HVAC > Manager > Edit Naming Conventions
Permissions ... Penetrations > Manager > Edit Naming Conventions
Permissions ... General > Manager > Edit Assembly Drawing Naming Conventions
Procedure....... Naming Conventions (page 74)

Opens the Naming Conventions window, letting you create and edit naming conventions.
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Naming Conventions Window

Name Conventions – Lists all naming conventions, grouped by type. Active naming conventions are indicated by a 
checkmark. Select a naming convention to display its Elements.

New – Creates a new naming convention within the selected group.

Delete – Deletes the selected naming convention.

Set Active – Makes the selected naming convention the active naming convention for its group.

Manage Aliases – Opens the Alias Manager, letting you change the the names of sub-categories that are used to organize 
naming conventions.

Elements – Lists the elements (the components that make up a naming convention) of the selected naming convention 
in order. Select an element to display its properties below.

Up/Down Arrows – Moves the selected element up or down in the list of elements, letting you re-order them.

New – Opens the Select Type window, letting you add an element to the selected naming convention.

Delete – Deletes the selected element from the selected naming convention.

Property, Value – Displays the properties and values of the selected element and lets you edit the values.

Understanding Seeding
Seeding gives you more control over how your names are generated. This is best illustrated by an example. Suppose you 
have a naming convention defined with three elements: Material-System-Auto-number with the auto-number starting at 1 
and the increment being 1. The first part you create may have a name like this:

M1-FreshWater-001

In this example, the part is made from a material named M1 and is in the Fresh Water system. For this example we will 
assume that both the Material element and the System element are seeds. If you create a new part that was also made 
from material M1 and in system Fresh Water, the name will be as follows:

M1-FreshWater-002

If you create a third part that was made of material M1 but was in the Salt Water system, ShipConstructor will generate a 
part name as follows:
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M1-SaltWater-001

Notice how the number has restarted at 1. This is because one of your seed elements has changed, in this case the 
System. If you create a fourth part, this time back in the Fresh Water system but with material M2, ShipConstructor would 
generate a name as follows:

M2-FreshWater-001

Again the numbering scheme has changed because the combination of your two seed elements does not match anything 
we have seen previously. If you now create a fifth and sixth part made from material M2 and in system Fresh Water, 
ShipConstructor will generate the names as follows:

M2-FreshWater-002

M2-FreshWater-003

To further illustrate the nature of seeding, consider the following example. To make things simple, pretend that you are 
again working with a fresh project and have not generated the names above. You define a name convention identical to 
the one in the example above (Material-System-Auto-number) except that instead of both the Material and System
elements being seeds, only the Material is a seed element. Following the same procedure as above your part names will 
be as follows:

M1-FreshWater-001

M1-FreshWater-002

M1-SaltWater-003

Notice how even though the system changed from Fresh Water to Salt Water, the numbering scheme did not change; it 
continued counting up. This is because the system is not a seed element. If you create two more parts, the names will be 
as follows:

M2-FreshWater-001

M2-SaltWater-002

Notice how the numbering scheme changed the first time because the material element changed but continued counting 
up the second time.

Database Elements
The power in naming conventions lies in the ability to generate names based on entity attributes stored in the database. 
The following are descriptions of all the database elements currently supported by ShipConstructor. 

Assembly returns the primary product hierarchy assembly name of an ancestor assembly of your entity. Which level’s 
assembly name is returned depends on which Assembly Tree Level you select from the Tree Level drop-down list. The list 
of assembly levels depends on how you structure your Product Hierarchy tree. 

Note: If the part is in an assembly with a level higher than the selected assembly tree level, nothing is returned for 
that element.

Extrusion Profile Standard Type applies to stiffeners. Examples of extrusion profile standard types are angle, bulb flat, 
structural pipe, custom, and tee. Extrusion profile standard types can be aliased using the Naming Convention Alias 
Manager.

File Path applies to Plate Nests. It returns the path to the plate nest drawing starting from the Nest folder. The purpose of 
the file path element is to let you put the product hierarchy location in the plate nest name.

This is done by creating a directory structure in the Nests folder that matches the product hierarchy and then putting 
plate nest drawings at the appropriate location in the folder structure. 

Major Stock Type applies to all Structure parts. Examples of major stock types are plate, extrusion, corrugated and plank. 
Major stock types can be aliased using the Naming Convention Alias Manager.

Material returns the material name of the stock.

Material Grade returns the material grade of the stock.

Nest Drawing returns the nest drawing name of plate nests.

Nominal Size returns the nominal size of the pipe stock.

Part Side returns the side of the ship on which the structure part lies.



Appendix A: Menus, Tools & Commands

231

Part Type applies to Structure parts. Examples of part types are plate, stiffener, corrugation, faceplate, and plank. Part 
types can be aliases using the Naming Convention Alias Manager.

Planar Group Model Drawing returns the planar group model drawing that the structure part is modeled in.

Plate Stock Length returns the length of the plate stock item that the structure part is made from.

Plate Stock Width returns the width of the plate stock item that the structure part is made from.

Pressure Rating returns the pressure rating of the pipe stock.

Profile Plot Drawing returns the profile plot drawing name of profile nests.

Project returns the name of the ShipConstructor project.

Remnant returns the name of the remnant that the plate nest was cut from.

Sheet Stock returns the name of the sheet stock that the HVAC stock is made from.

Stock returns the name of the stock that the part is made from.

System returns the spec level, system level, or branch level system name of the system of your entity. Which level is 
returned depends on your selection in the Tree Level drop-down list.

Note: If the entity is in a system with a level higher than the selected system tree level, nothing is returned for the 
System of that element.

Thickness returns the thickness of the plate stock that the plate part is made from.

ShipConstructor Menu

ShipConstructor > Navigator

Button .............
Ribbon ............ ShipConstructor tab > Navigation panel > Navigator
Menu ............... ShipConstructor > Navigator
Command ...... SCNAVIGATE
Permissions ... None
License............ None

Opens the Navigator, letting you create and open drawings and perform other drawing-related functions.

Note: You must use Navigator to create, open, or move drawings so that ShipConstructor can keep track of them. Do 
not use Windows Explorer, or ShipConstructor will not be able to properly associate the drawings with the project.



Appendix A: Menus, Tools & Commands

232

Navigator

Component List – Each project is divided into several components or folders. The components of the current project are 
listed in the Component List. The first component is the project name. Within the project are one or more units and 
several project-wide components (Hull, Space Allocation, Output, Nest, Profile Plot, Templates). Within each unit are 
several unit-related components (Structure, Pipe, HVAC, Support, Spools, Support Construction, Equipment, Product 
Hierarchy, Interference, Weld Management, Assembly, Composite, Approval, Export). When you select an item in the 
Component List, the associated drawings are listed in the Drawing List and the associated buttons are displayed on the 
Page.

To customize the Component List, right-click within it and choose Customize to open the Customize the Navigator
window. Select the items you want to appear in the Component List and click OK.

Drawing List – The Drawing List lists the drawings associated with the selected item in the Component List.

Each drawing in the Drawing List is displayed with the following:
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• A lock icon, (locked) or 

(unlocked) – Clicking the lock icon locks (or unlocks) the 
drawing so it cannot (or can) be modified. (If clicking the lock icon does not seem to work, you may not have 
permissions to lock and unlock the appropriate drawing files.) A locked file is set as read-only.

• Drawing name – Right-click on the drawing name to display a menu of commands.

• User – The name of the user who currently has the drawing open (as read/write).

• Last Date Modified – The date that the drawing was last modified. (You may need to scroll across or resize Navigator
to see this information.)

• Preview – The Preview is a preview image of the drawing selected in the Drawing List.

• Local Only Drawing icon – The drawing exists on the local file system and not on the server.

• Database Only Drawing icon – The drawing exists on the server and not on the local file system.

Sometimes a preview image does not appear. If ShipConstructor has automatically modified a drawing (for example, if 
you make a change in one drawing, ShipConstructor may automatically update other drawings), a preview image does 
not appear until the next time you open and save the drawing.

Page – The Page buttons let you perform functions related to the selected item in the Drawing List. The following items 
are found on all pages:
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• Read Only – If this is turned on when you open a drawing, you cannot modify and save the drawing. If Read Only is 
turned off when you open a drawing, you can modify and save the drawing.

• Close Current – If this is turned on when you open a drawing, ShipConstructor will automatically close the current 
drawing. This option is only available when you are working in multiple document interface (MDI) mode. 
ShipConstructor has been optimized for single drawing compatibility mode (SDI), so we recommend using SDI mode. 
To switch between MDI mode and SDI mode, type “SDI” at the AutoCAD command line. Use “1” for SDI.

Other items are different for each page (see below).

Project Page

The Project page lets you create, open, and modify unit drawings and perform project-related functions.

Change Project – Opens the Register Project window, letting you switch to another project.

User Permissions – Opens the User Permissions window (See General > User Permissions (page 222)).

Settings – Opens the Project Settings window (See General > Project Settings (page 217)).

Open – Opens the selected unit drawing.

New Unit – Adds a unit to the current project. See Create Units (page 93) for details.

Reload DB – Reloads the settings from the project database into ShipConstructor. Use Reload DB whenever you make 
changes to the project settings in Manager.

Revisions – Displays changes made to the current project. See ShipConstructor > Revisions for details.

Unit Page
The Unit page lets you open a unit drawing.

Structure Page
The Structure page lets you create, open, and modify structure drawings (planar group drawings and curved plate 
drawings). See Structure manual.
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Open

Permissions ... Structure > Model Drawings - Edit

Opens the selected structure drawing.

New

Permissions ... Structure > Model Drawings - Create/Delete
Permissions ... Structure > Model Drawings - Edit

Creates a new planar group. See the Create Planar Group Drawings section in the Structure manual for more information.

Properties

Permissions ... Structure > Model Drawings - Edit

Opens the Edit Properties window, letting you edit the properties of the selected planar group drawing.

Right-Click Menu – Lets you open, delete, or modify the properties of the selected structural drawing or create a new 
structural drawing.

Delete

Permissions ... Structure > Model Drawings - Create/Delete
Permissions ... Structure > Model Drawings - Edit

Deletes the selected planar group drawing and all the parts in it.

Distributed Systems Page
The Distributed Systems page is a grouping page for all the Distributed Systems pages.
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Pipe Page
The Pipe page lets you create, open, and modify pipe model and pipe arrangement drawings. See the Pipe manual for 
details.

Open

Permissions ... Pipe > Modeling > Pipe Models – Edit
OR
Permissions ... Pipe > Pipe Arrangements – Edit

Opens the selected drawing.

New

Permissions ... Pipe > Modeling > Pipe Models – Create/Delete
Permissions ... Pipe > Modeling > Pipe Models – Edit
OR
Permissions ... Pipe > Pipe Arrangements – Create/Delete
Permissions ... Pipe > Pipe Arrangements – Edit

Creates a new drawing.

Show Out of Date

Shows a next to each pipe arrangement drawing that has parts in it that have changed or parts that have been added 
or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected drawing or create a new drawing.

Reattach

Permissions ... Pipe > Pipe Arrangements – Create/Delete

Reattaches an existing drawing to a registered pipe arrangement drawing that has its drawing file missing. The selected 
drawing is checked to ensure it is a pipe arrangement drawing.

Rename

Permissions ... Pipe > Modeling > Pipe Models – Edit
OR
Permissions ... Pipe > Pipe Arrangements – Edit

Renames the selected drawing.

Delete

Permissions ... Pipe > Modeling > Pipe Models – Create/Delete
Permissions ... Pipe > Modeling > Pipe Models – Edit
OR
Permissions ... Pipe > Pipe Arrangements – Create/Delete
Permissions ... Pipe > Pipe Arrangements – Edit

Deletes the selected drawing.
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HVAC Page
The HVAC page lets you create, open, and modify HVAC model and HVAC arrangement drawings. 

Open

Permissions ... HVAC > Modeling > Modeling
OR
Permissions ... HVAC > HVAC Arrangements – Edit

Opens the selected drawing.

New

Permissions ... HVAC > Modeling > Model Drawings – Create/Delete
Permissions ... HVAC > Modeling > Modeling
OR
Permissions ... HVAC > HVAC Arrangements – Create/Delete
Permissions ... HVAC > HVAC Arrangements – Edit

Creates a new drawing.

Show Out of Date

Shows a next to each HVAC arrangement drawing that has parts in it that have changed or parts that have been 
added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected drawing or create a new drawing.
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Reattach

Permissions ... Pipe > HVAC Arrangements – Create/Delete

Reattaches an existing drawing to a registered HVAC arrangement drawing that has its drawing file missing. The selected 
drawing is checked to ensure it is a HVAC arrangement drawing.

Rename

Permissions ... HVAC > Modeling > Modeling
OR
Permissions ... HVAC > HVAC Arrangements – Edit

Renames the selected drawing.

Delete

Permissions ... HVAC > Modeling > Model Drawings – Create/Delete
Permissions ... HVAC > Modeling > Modeling
OR
Permissions ... HVAC > HVAC Arrangements – Create/Delete
Permissions ... HVAC > HVAC Arrangements – Edit

Deletes the selected drawing.

Support Page
The Support page lets you create, open, and modify support and hanger model drawings. See the Pipe manual for details.

Open

Permissions ... Distributed Systems Supports > DS Support & Hanger Drawings – Create/Delete

Opens the selected support and hanger drawing.

New

Permissions ... Distributed Systems Supports > DS Support & Hanger Drawings – Create/Delete

Creates a new support and hanger drawing.

Right-Click Menu – Lets you open, rename, or delete the selected support and hanger drawing or create a new composite 
drawing.

Rename

Permissions ... Distributed Systems Supports > DS Support & Hanger Drawings – Create/Delete

Renames the selected support and hanger drawing.

Delete

Permissions ... Distributed Systems Supports > DS Support & Hanger Drawings – Create/Delete

Deletes the selected support and hanger drawing.
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Pipe Spool Page
The Pipe Spool page lets you create, open, and modify pipe spool drawings. See the Pipe manual for details.

HVAC Spool Page
The HVAC Spool page lets you create, open, and modify HVAC spool drawings belonging to the registered unit.

Open

Permissions ... HVAC > Spools > Spool Drawings – Edit

Opens the selected HVAC spool drawing. If you check the box Read Only, you will not be able to modify or save changes to 
the drawing.

Create

Permissions ... HVAC > Spools > Spool Drawings – Create/Delete

Opens the Spool Drawing Wizard to create a spool drawing. See Create Spool Drawing Wizard Reference in the HVAC
manual for details.

Reattach Drawing

Permissions ... HVAC > Spools > Spool Drawings – Edit

Reattaches an existing drawing that was detached and moved to the Deleted_Spool_Drawings folder. This scenario can 
commonly happen as a result of adding spool breaks. The selected drawing is checked to ensure it is a HVAC spool 
drawing. The spool in the Navigator must not have a drawing to be able to use the Reattach drawing command.
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Right-Click Menu

Delete

Permissions ... HVAC > Spools > Spool Drawings – Create/Delete

Deletes the selected HVAC spool drawing.

Lock/Unlock Spool

Permissions ... HVAC > Spools> HVAC Spools – Lock / Unlock

Locks or unlocks the selected HVAC spool (and its drawing).

Model Drawing Right-Click Menu

Lock/Unlock Spools

Permissions ... HVAC > Spools> HVAC Spools – Lock / Unlock

Locks or unlocks all the approved HVAC spools (and their drawings) in the selected HVAC model drawing.

Support Construction Page
The Support Construction page lets you create, open, and modify support construction drawings. See the Pipe manual for 
details.

Open

Permissions ... Distributed Systems Supports > Construction Drawings – Edit

Opens the selected support construction drawing.

New

Permissions ... Distributed Systems Supports > Construction Drawings – Edit

Creates a new support construction drawing.

Show Out of Date

Shows a next to each support construction drawing that has parts in it that have changed or parts that have been 
added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected support construction drawing or create a new 
support construction drawing.
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Reattach

Permissions ... Distributed Systems Supports > Construction Drawings – Edit

Reattaches an existing drawing to a registered support construction drawing that has its drawing file missing. The 
selected drawing is checked to ensure it is a support construction drawing.

Rename

Permissions ... Distributed Systems Supports > Construction Drawings – Edit

Renames the selected support construction drawing.

Delete

Permissions ... Distributed Systems Supports > Construction Drawings – Edit

Deletes the selected support construction drawing.

Equipment Page
The Equipment page lets you create, open, and modify equipment model and equipment arrangement drawings. See the 
Equipment manual for details.

Open

Permissions ... Equipment > Equipment Parts in Drawings – Edit
OR
Permissions ... Equipment > Equipment Arrangements – Edit

Opens the selected drawing.

New

Permissions ... Equipment > Equipment Parts in Drawings – Edit
OR
Permissions ... Equipment > Equipment Arrangements – Edit

Creates a new drawing.

Show Out of Date

Shows a next to each equipment arrangement drawing that has parts in it that have changed or parts that have been 
added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected drawing or create a new drawing.
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Reattach

Permissions ... Equipment > Equipment Arrangements – Edit

Reattaches an existing drawing to a registered equipment arrangement drawing that has its drawing file missing. The 
selected drawing is checked to ensure it is an equipment arrangement drawing.

Rename

Permissions ... Equipment > Equipment Parts in Drawings – Edit
OR
Permissions ... Equipment > Equipment Arrangements – Edit

Renames the selected drawing.

Delete

Permissions ... Equipment > Equipment Parts in Drawings – Edit
OR
Permissions ... Equipment > Equipment Arrangements – Edit

Deletes the selected drawing.

Electrical Page
The Electrical page lets you create, open, and modify electrical cable model, electrical wireway model, and wireway 
arrangement drawings. See the Electrical manual for details.

Open

Permissions ... Electrical > Cable Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Arrangement Drawings – Edit

Opens the selected drawing.

New

Permissions ... Electrical > Cable Model Drawings – Create/Delete
Permissions ... Electrical > Cable Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Model Drawings – Create/Delete
Permissions ... Electrical > Wireway Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Arrangement Drawings – Create/Delete
Permissions ... Electrical > Wireway Arrangement Drawings – Edit

Creates a new drawing.

Show Out of Date

Shows a next to each electrical wireway arrangement drawing that has parts in it that have changed or parts that 
have been added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected drawing or create a new drawing.
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Reattach

Permissions ... Electrical > Wireway Arrangement Drawings – Create/Delete

Reattaches an existing drawing to a registered electrical wireway arrangement drawing that has its drawing file missing. 
The selected drawing is checked to ensure it is an electrical wireway arrangement drawing.

Rename

Permissions ... Electrical > Cable Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Arrangement Drawings – Edit

Renames the selected drawing.

Delete

Permissions ... Electrical > Cable Model Drawings – Create/Delete
Permissions ... Electrical > Cable Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Model Drawings – Create/Delete
Permissions ... Electrical > Wireway Model Drawings – Edit
OR
Permissions ... Electrical > Wireway Arrangement Drawings – Create/Delete
Permissions ... Electrical > Wireway Arrangement Drawings – Edit

Deletes the selected drawing.

Product Hierarchy Page
The Product Hierarchy page lets you create, open, and modify product hierarchy drawings. See Product Hierarchies (page 
94).
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Open

Permissions ... General > Edit Product Hierarchy Drawings

Opens the selected product hierarchy drawing.

New

Permissions ... General > Edit Product Hierarchy Drawings
Procedure....... Create a Product Hierarchy Drawing (page 98)

Creates a new product hierarchy drawing. A product hierarchy drawing is used to visualize the parts in the unit when 
developing the product hierarchy tree of parts. This drawing will contain read-only copies of the parts that can be selected 
individually.

Show Out of Date

Shows a next to each drawing that has parts in it that have changed or parts that have been added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected product hierarchy drawing or create a new 
product hierarchy drawing.
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Reattach

Permissions ... General > Edit Product Hierarchy Drawings

Reattaches an existing drawing to a registered product hierarchy drawing that has its drawing file missing. The selected 
drawing is checked to ensure it is a product hierarchy drawing.

Rename

Permissions ... General > Edit Product Hierarchy Drawings
Procedure....... Rename a Product Hierarchy Drawing (page 100)

Renames the selected product hierarchy drawing.

Delete

Permissions ... General > Edit Product Hierarchy Drawings
Procedure....... Delete a Product Hierarchy Drawing (page 100)

Deletes the selected product hierarchy drawing.

Interference Page
The Interference page lets you create, open, and modify interference drawings.

Open

Permissions ... General > Edit Interference

Opens the selected interference drawing.

New

Permissions ... General > Edit Interference

Creates a new interference drawing.
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Show Out of Date

Shows a next to each drawing that has parts in it that have changed or parts that have been added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected interference drawing or create a new 
interference drawing.

Reattach

Permissions ... General > Edit Interference

Reattaches an existing drawing to a registered interference drawing that has its drawing file missing. The selected 
drawing is checked to ensure it is an interference drawing.

Rename

Permissions ... General > Edit Interference

Renames the selected interference drawing.

Delete

Permissions ... General > Edit Interference

Deletes the selected interference drawing.

Weld Management Page
The Weld Management page lets you create, open, and modify weld management drawings. See the Weld Management
manual for details.

Open

Permissions ... Weld Management > Weld – Edit

Opens the selected weld management drawing.

New

Permissions ... Weld Management > Weld – Edit

Creates a new weld management drawing.

Show Out of Date

Shows a next to each drawing that has parts in it that have changed or parts that have been added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected weld management drawing or create a new 
weld management drawing.
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Reattach

Permissions ... Weld Management > Weld – Edit

Reattaches an existing drawing to a registered weld management drawing that has its drawing file missing. The selected 
drawing is checked to ensure it is a weld management drawing.

Rename

Permissions ... Weld Management > Weld – Edit

Renames the selected weld management drawing.

Delete

Permissions ... Weld Management > Weld – Edit

Deletes the selected weld management drawing.

Assembly Page
The Assembly page lets you create, open, and modify assembly drawings. See Structure manual.

Open

Permissions ... Structure > Assembly Drawings – Edit

Opens the selected assembly drawing.
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Create

Permissions ... Structure > Assembly Drawings – Edit

Creates a new assembly drawing.

Update Keymap
Creates or updates the drawing KEYMAP that contains the HullTrace construction lines for the current unit. The keymap 
drawing is referenced in assembly drawings as an overlay of the current assembly. It gives reference to where the 
assembly is located in the unit or vessel. The keymap drawing can contain any objects. It is recommended that you 
prepare the keymap drawing after it has been created.

Show Out of Date

Shows a next to each drawing that has parts in it that have changed or parts that have been added or removed.

Right-Click Menu – Lets you open, reattach, rename, or delete the selected assembly drawing or create a new assembly 
drawing.

Reattach

Permissions ... Structure > Assembly Drawings – Edit

Reattaches an existing drawing to a registered assembly drawing that has its drawing file missing. The selected drawing 
is checked to ensure it is an assembly drawing.

Rename

Permissions ... General > Assembly Drawings – Edit

Renames the selected assembly drawing.

Delete

Permissions ... General > Assembly Drawings – Edit

Deletes the selected assembly drawing.

Composite Page
The Composite Page lets you create, open, and modify composite drawings (drawings that you can use to MLink in other 
drawings in order to see multiple modules together). See Set Up Composite Drawings (page 50).
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Open

Permissions ... General > Edit Composite Drawings

Opens the selected composite drawing.

New

Permissions ... General > Edit Composite Drawings

Creates a new composite drawing.

Right-Click Menu – Lets you open, rename, or delete the selected composite drawing or create a new composite drawing.

Rename

Permissions ... General > Edit Composite Drawings

Renames the selected composite drawing.

Delete

Permissions ... General > Edit Composite Drawings

Deletes the selected composite drawing.

Approval Page
The Approval page lets create, open, and modify approval drawings.
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Open

Permissions ... General > Edit Approval

Opens the selected approval drawing.

New

Permissions ... General > Edit Approval

Creates a new approval drawing.

Right-Click Menu – Lets you open, rename, or delete the selected approval drawing or create a new approval drawing.

Rename

Permissions ... General > Edit Approval

Renames the selected approval drawing.

Delete

Permissions ... General > Edit Approval

Deletes the selected approval drawing.

Export Page
The Export page lets you create, open, and modify export drawings. Export drawings are created by exporting any number 
of ShipConstructor drawings to a standard AutoCAD drawing.
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Open

Permissions ... General > Edit Export

Opens the selected export drawing.

New

Permissions ... General > Edit Export

Creates a new export drawing.

Right-Click Menu – Lets you open, rename, or delete the selected export drawing or create a new export drawing.

Rename

Permissions ... General > Edit Export

Renames the selected export drawing.

Delete

Permissions ... General > Edit Export

Deletes the selected export drawing.

Hull Page
The Hull page lets you create, open, and modify hull and pinjig drawings. See the Hull manual for details.
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Open

Permissions ... Hull > Lofting
Permissions ... Hull > Edit Stringers
AND
Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Opens the selected drawing.

New

Permissions ... Hull > Edit Lofting
AND
Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Creates a new drawing.

Right-Click Menu – Lets you open, copy, rename, or delete the selected drawing or create a new drawing or folder.

New Folder

Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Creates a new folder as a subfolder of the hull or pin jig root folder.  Subfolders of these folders are not allowed.

Copy

Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Copies the selected drawing, prompts for the new drawing name, and registers the new drawing with project.

Rename

Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Renames the selected drawing or folder.
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Delete

Permissions ... Hull > Create/Delete Drawings
OR
Permissions ... Hull > Edit Pin Jigs

Deletes the selected drawing or folder.

Space Allocation Page
The Space Allocation page lets you create, open, and modify space allocation drawings. See the Space Allocation manual 
for details.

Open

Permissions ... Space Allocations > Space Allocations – Edit Model

Opens the selected space allocation drawing.

New

Permissions ... Space Allocations > Space Allocations – Edit Model

Creates a new space allocation drawing.

Right-Click Menu – Lets you open, rename, or delete the selected space allocation drawing or create a new composite 
drawing.

Rename

Permissions ... Space Allocations > Space Allocations – Edit Model

Renames the selected space allocation drawing.

Delete

Permissions ... Space Allocations > Space Allocations – Edit Model

Deletes the selected space allocation drawing.

Output Page
The Output page lets you create, open, and modify output drawings, marinedrafting drawings, and pipelink files.

Open

Permissions ... Production > Output – Edit
Permissions ... Production > MarineDrafting – Edit

Opens the selected drawing. PipeLink files do not require permissions to open.

New Output

Permissions ... Production > Output – Create/Delete
Permissions ... Production > Output – Edit

Creates a new output drawing.
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New MarineDrafting

Permissions ... Production > MarineDrafting – Create/Delete
Permissions ... Production > MarineDrafting – Edit
Permissions ... Production > Output – Create/Delete
Permissions ... Production > Output – Edit

Creates a new marinedrafting drawing.

Show Out of Date

Shows a next to each drawing that has parts in it that have changed or parts that have been added or removed.  
MarineDrafting drawings and PipeLink files are out of date if their parent Output drawing is out of date.

Right-Click Menu – Lets you open, rename, or delete the selected drawing or folder or create a new drawing or folder.

New Folder

Permissions ... Production > Output – Create/Deleted
Permissions ... Production > MarineDrafting – Create/Deleted

Creates a new folder as a subfolder of the selected folder.

Rename

Permissions ... Production > Output – Edit
Permissions ... Production > MarineDrafting – Edit

Renames the selected drawing or folder.

Delete

Permissions ... Production > Output – Edit
Permissions ... Production > MarineDrafting – Edit

Deletes the selected drawing or folder.

Nest Page
The Nest page lets you create, open, and modify plate nest drawings. See Plate Nesting in Structure manual.
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Open

Permissions ... Structure > Plate Nest > Edit

Opens the selected plate nest drawing.

New

Permissions ... Structure > Plate Nest > Edit

Creates a new plate nest drawing.

Unnested Parts
List all un-nested parts within an assembly. See SC Plate Nest > Part > List Un-nested Parts in Structure manual.

Right-Click Menu – Lets you open, rename, or delete the selected plate nest drawing or folder or create a new plate nest 
drawing or folder.

New Folder

Permissions ... Structure > Plate Nest > Edit

Creates a new folder as a subfolder of the plate nest root folder.  Subfolders of these folders are not allowed.
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Rename

Permissions ... Structure > Plate Nest > Edit

Renames the selected plate nest drawing or folder.

Delete

Permissions ... Structure > Plate Nest > Edit

Deletes the selected plate nest drawing or folder.

Profile Plot Page
The Profile Plot page lets you create, open, and modify profile plot drawings. See Profile Plots in Structure manual.

Open

Permissions ... Structure > Profile Plots > Edit

Opens the selected profile plot drawing.

New

Permissions ... Structure > Profile Plots > Edit

Creates a new profile plot drawing.

Right-Click Menu – Lets you open, rename, or delete the selected profile plot drawing or create a new profile plot 
drawing.
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Rename

Permissions ... Structure > Profile Plots > Edit

Renames the selected profile plot drawing.

Delete

Permissions ... Structure > Profile Plots > Edit

Deletes the selected profile plot drawing.

Templates Page
The Templates page lets you create, open, and modify various types of template drawings.

Open

Permissions ... General > Edit Template Drawings

Opens the selected template drawing.

New [Template Name]

Permissions ... General > Edit Template Drawings

Creates a new template drawing. The name of the button and the type of template drawing created is based on the 
selected folder in the Drawing List.

Right-Click Menu – Lets you open, rename, or delete the selected template drawing or create a new template drawing.
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Rename

Permissions ... General > Edit Template Drawings

Renames the selected template drawing.

Delete

Permissions ... General > Edit Template Drawings

Deletes the selected template drawing.

ShipConstructor > Manager

Button .............
Ribbon ............ ShipConstructor tab > Applications panel > Manager
Menu ............... ShipConstructor > Manager

Toolbar............
Command ...... SCMANAGER
Permissions ... None

Opens the Manager window, letting you set up project settings, project libraries, and user permissions.

ShipConstructor > Project > New Project
See the Project Management manual.

ShipConstructor > Project > Copy Project
See the Project Management manual.

ShipConstructor > Model Link

Button .............
Ribbon ............ ShipConstructor tab > Navigation panel
Menu ............... ShipConstructor > Model Link
Command ...... SCMLINK
Permissions ... None
Procedure....... Insert (Link) a Drawing into Another Drawing (page 52)

Lets you insert (link) drawings into the current drawing.
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MLink Manager

The MLink Manager lists all of the drawings in the project. You can mlink a drawing into the current drawing by clicking its 
check box so a checkmark appears. You can remove an mlinked drawing from the current drawing by clicking its check
box so it is empty.

Lock – Locks the layer that the MLink is placed on. Each MLink is placed on its own layer. 

New MLinks – Only newly added MLinks will be placed on locked layers

All MLinks – All MLinks are placed on locked layers.

Current Unit Only – Limits the tree of model drawings to show only the current unit of the current drawing.

Check Visible – Checks only the model drawings that are in the current filter.

Uncheck All – Unchecks all drawings in the list.

Reload All XRefs – Reloads all mlinked drawings (based on the latest saved version) into the current drawing. For 
example, if changes have been made to mlinked drawings, you may want to Reload them into the current drawing.

ShipConstructor > Planar Group > Transfer Objects to Group
See the Structre manual.

ShipConstructor > Penetration Manager
See the Pipe manual.
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ShipConstructor > Check > Check Project

Button .............
Ribbon ............ SC Utilities tab > Check panel
Menu ............... ShipConstructor > Check > Check Project
Command ...... SCCHECKPROJECT
Permissions ... Structure > Modeling
Procedure....... Check a Unit (page 121)

Runs the Check Unit command on all units in the project. The option to repair errors or just log errors is displayed before 
the check is run. (See Procedure:  Check a Unit).

Check Project will also check all template drawings. Repair Errors will confirm that the registered files exist and that all 
files found of those types are registered.

ShipConstructor > Check > Check Unit

Button .............
Ribbon ............ SC Utilities tab > Check panel
Menu ............... ShipConstructor > Check > Check Unit
Toolbar............ None
Command ...... SCCHECKUNIT
Permissions ... Structure > Modeling
Procedure....... Check a Unit (page 121)

Checks the 3D Unit drawing and all planar group model drawings within the unit. An option to repair errors or log errors is 
displayed before the check is run. If Repair Errors is not selected, any modifications listed below will not be performed.  
Check Unit will perform the following checks:

• Makes sure the 3D Unit drawing file exists. If the 3D Unit drawing does not exist, then an empty 3D Unit drawing 
will be created.

• Checks to see if ShipConstructor specific drawing information exists in drawing. If the unit drawing does not 
have this drawing information or it is corrupt, ShipConstructor will create or fix the drawing information.

• Calls the Planar Group Check for all planar group model drawings in the unit

• Checks that all markings lie within the boundaries of the part that they are associated with. If any part of a mark 
symbol or text lies outside the part boundary, it will be noted in the generated log file. 

• Checks that the template drawings for Assembly, Pipe/HVAC/Equipment Arrangement, and Pipe/HVAC Spool 
drawings exist and are registered to the project. Repair Errors will register any files not already registered and 
missing drawing files will be removed. 

Note: Unlike ShipConstructor 2005, checking a unit does not xref all the planar group model drawings into the 3D Unit 
drawing.

ShipConstructor > Check > Check Templates

Button .............
Ribbon ............ SC Utilities tab > Check panel
Menu ............... ShipConstructor > Check > Check Templates
Command ...... SCCHECKTEMPLATES
Permissions ... Structure > Modeling

Checks that all registered drawings exist, and that all files in the Template folders are registered. Repair Errors will create 
missing drawings, or register un-registered drawings.
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ShipConstructor > Check > Fix Duplicate Drawing Names

Button .............
Ribbon ............ SC Utilities tab > Check panel
Menu ............... ShipConstructor > Check > Fix duplicate production drawings
Toolbar............ None
Command ...... SCFIXDUPLICATEPRODDWGS
Permissions ... None

Prior to ShipConstructor 2011 R2, it was possible to generate multiple records in the database for the same drawing. 
After updating to ShipConstructor 2011 R2 or later, you may see drawings in Navigator with “$Duplicate$” in the name. 
Run this command to fix those duplicate drawing records.

Running this command multiple times has no ill effects.

ShipConstructor > Update Model and System Drawings

Button .............
Ribbon ............ SC Utilities tab > Update panel
Menu ............... ShipConstructor > Update Model and System Drawings
Command ...... SCUPDATEMODELANDSYSTEMDRAWINGSQUICK
Permissions ... None
Procedure....... Update Model and System Drawings (page 122)

Recreates or updates selected model and system drawings from the database.

ShipConstructor > Update Production Drawings

Button .............
Ribbon ............ SC Utilities tab > Update panel
Menu ............... ShipConstructor > Update Production Drawings
Command ...... SCUPDATEPRODDWGS
Permissions ... None
Procedure....... Update Production Drawings

Updates existing production drawings.

ShipConstructor > Product Hierarchy

Button .............
Ribbon ............ ShipConstructor tab > Main panel
Menu ............... ShipConstructor > Product Hierarchy
Command ...... SCPRODUCTHIERARCHY
Permissions ... General > Product Hierarchy > Product Hierarchy – Edit
......................... General > Product Hierarchy > Product Hierarchy Levels – Edit
License............ Universal or ProductHierarchy
Procedure....... Product Hierarchies (page 94)

Opens the Product Hierarchy palette, letting you setup assembly levels and assemblies and assign parts to assemblies.



Appendix A: Menus, Tools & Commands

262

ShipConstructor > Profile Nesting

Button .............
Ribbon ............ Nest & Profile Plots tab > ProfileNest panel
Menu ............... ShipConstructor > Profile Nesting
Command ...... SCPROFILENEST
Permissions ... Structure > Profile Nest > Profile Nests – Edit
License............ Universal or ProfileNest

Opens the Profile Nest window and Profile Nest Manager window, letting you nest parts on profile stocks.
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Profile Nest Manager

Show Parts/Nests of Type – Lists the profile stocks used in the unit. Select a profile stock to display a list of parts (under 
Unnested Parts) and a list of nests (under Nests) for that stock.

Endcut Filter – Filters the Unnested Parts list based on endcut type. Only parts having the selected endcut types (at either 
end of the part) are displayed. You can also select No Endcuts to display parts without endcuts.

Bend Filter – Filters the Unnested Parts list to display Straight Parts, Bent Parts, and Curved Parts.

Trim Filter – Filters the Unnested Parts list to display Trimmed Parts and Non-Trimmed Parts.

Standard Assemblies – If checked, the filter will display assemblies from standard assemblies, and their parts.

Purchased – If checked, Standard Assemblies tagged as “Purchased” will also be displayed.

Dist. Sys. Supports – If checked, Distributed Systems Supports are displayed.

Nested Parts – Includes nested parts in the Unnested Parts list.

Unnested Parts – Lists unnested parts that use the selected profile stock (under Show Parts/Nests of Type) and lets you 
add parts to nests.

Add – Adds the parts selected under Unnested Parts to the nests selected under Nests. If no nest is selected, 
ShipConstructor tries to create nests for the selected parts.

Remove – Unnests the parts selected under Nests or unnests all parts from nest selected under Nests.

Nests – Lists the nests for the selected profile stock (under Show Parts/Nests of Type), and the parts within each nest.
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Create Nests – Creates an empty profile nest.

Delete Selected Nests – Deletes the selected profile nests and unnests any parts within them.

Issue Selected Nests – Marks the selected profile nests as issued, indicating that it is available for production to cut.

Un-issue Selected Nests – Removes the selected profile nests’ issued status.

Cut Selected Nests – Marks the selected profile nests as cut, indicating that the physical plates have been cut.

Un-cut Selected Nests – Removes the selected profile nests’ cut status.

Check All Visible Nests – Checks all nests (listed under Nests) to see if any parts have been changed, that the parts still 
fit on the nests and their remnants, and if the stock of any of the parts has been changed. If any part properties have 
changed, ShipConstructor displays a text file containing a list of the changes.
Show Nests – Filters the Nests list to display UnIssued nests, Issued nests, and Cut nests.

ShipConstructor > Revisions

Button .............
Ribbon ............ ShipConstructor tab > Manage panel
Menu ............... ShipConstructor > Revisions
Command ...... SCREVISIONS
Permissions ... None
Procedure....... See below
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This window queries revisions in the current project.  Each revision has the following value:

By default, selecting the Search button without changing any options shows all revisions to the project, but the number of 
revisions can be quite large.  Various options are given for restricting the number of retrieved revisions:

• Category – The category of revisions (Category column) from different areas of ShipConstructor.  At least one 
category needs to be selected.

• Revision Type – The type of revision (Type column).  At least one type needs to be selected.  Right-click options allow 
you to select all or select none.

• From and To – Optional – Provides a starting and ending date for revision date (Date column).  To provide a date, 
select the check box and select the date area.

• Date Sort Order – Determines the date sort direction

Descending (present to past) order.

Ascending (past to present) order.

• Object – Optional – The object the revision pertains to.

• User Name – Optional – The username of the person making the change.

• Rows Per Page – Determines how many revisions to retrieve per page.  Revisions are returned in pages since the 
number of revisions can be quite large.  If the number of revisions exceeds the rows per page, the remaining 
revisions will be available in successive pages.

• Search – Runs the query to fetch rows of revisions.

Other options:

• Filter Row – After rows are fetched, further filtering is performed in the filter row.

• Export Page – A page can be exported to a file in these formats: Text, Microsoft Excel™, or HTML.

• Clear Filters – Clears the filter row.

• Row right-click – Allows you to select search values using values in the currently selected row.
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ShipConstructor > Licensing

Button .............
Ribbon ............ ShipConstructor tab > Manage page
Menu ............... ShipConstructor > Licensing
Command ...... SCLICENSE
Permissions ... None
Procedure....... Get Licenses (page 45)

Lets you obtain and change licenses for individual ShipConstructor modules.

Licensing Window

Network – Opens the Network License Settings window, letting you set up a list of computers ShipConstructor searches 
for licenses. ShipConstructor searches for licenses from the servers in the order they are listed in the Network License
Settings window.
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• LicenseServer – The list of computers that have network locks attached to them. Any computer with ShipConstructor 
installed can be a license server. You can specify computers using TCP/IP address, computer name, or 
\\DOMAIN\computer. The <Local Computer> address is equivalent to IP: 127.0.0.1. Only network locks will allow 
licenses to be used across a network.

• New – Adds a new license server to the list.

• Delete – Deletes the selected license server from the list. The list must have at least one computer in it. If you try to 
delete all license servers, the <Local Computer> item is added automatically.

• Move Up – Moves the selected server up in the list.

• Move Down – Moves the selected server down in the list.

• Port – The default port is 3960. You should not need to change this value unless there is a port conflict with another 
program. If you change the port number, you must also change the port number on all license servers.

• OK – Saves the list and refreshes the modules list in the Licensing window.

Refresh List – Refreshes the module list. This option is useful when locks are moved or license servers are added. If new 
locks are attached they will be recognized and loaded.

Module – Shows which modules are available (based on available locks). The grayed out modules are not available. Use 
the check boxes to obtain a license for certain modules.

Parts – The number of parts used in the current project for each module.

Level (Max Parts) – The license level and the maximum number of parts you can have in a project for each module. If you 

have more than one level available or different options then you will see the ellipsis button . Clicking this button will 
show a table of the available levels.

If a row is disabled then that license level is not selectable and the reason is displayed in the status column.

• For Structure, ManualNest, AutomaticNest, ProfileNest, and MarineDrafting, the number of structure parts per level 
is 750. For example, Level 3 allows you to work on projects with a maximum of 2,250 structural parts.

• For Product Hierarchy, the number of parts per level is 1,950. For example, Level 3 allows you to work on projects 
with a maximum of 5,850 total parts.

• For Pipe, and DistSystemSupport the number of pipe parts per level is 400. For example, Level 3 allows you to work 
on projects with a maximum of 1,200 pipe parts.



Appendix A: Menus, Tools & Commands

268

• For Equipment, the number of parts per level is 150. For example, Level 3 allows you to work on projects with a 
maximum of 450 equipment parts.

• For HVAC, the number of parts per level is 400. For example, Level 3 allows you to work on projects with a maximum 
of 1,200 HVAC parts.

• For Electrical, the number of cable support parts per level is 100. For example, Level 3 allows you to work on projects 
with a maximum of 300 cable support parts.

• For Penetrations, the number of penetrations per level is 150. For example, Level 3 allows you to work on projects 
with a maximum of 450 penetrations.

• P&ID DesignValidation and PipeLink do not have levels. They require a Pipe license.

Lic Avail – The number of licenses available (that is, the total number of licenses minus the number of licenses currently 
in use).

Lic Total – The total number of licenses.
Status – Shows information about a license. The following is a list of statuses and what they mean.

Status Action

In Use All the licenses for this module are used up by other users. You cannot get a license until 
another user gives up their license or you force release that license using 
LicenseMonitor.

Old version The version in the lock is lower than the software needs. If your Subscription is up-to-
date, contact your dealer.

License is not WorkShare If the project is a WorkShare (formerly Project Split & Merge) project (project has a split 
project) only licenses which support WorkShare will be able to be used on this project.

Subscription Expired! The Subscription expiry date is older than the release date of this version of the 
software. Contact your dealer in order to renew your Subscription.

Part Count Exceeded! The License has a part count limit that is exceeded by the part count in the project. 
Contact your dealer to upgrade the level of the license.

Release Date – The date that the software was released.

Project Type – Indicates if the project is a WorkShare project or not.

Server – The name of the license server computer

Lock Name – The name of the lock. This usually contains the serial number as well.

Expiry Date – The date when the lock expires.

Days Left – The number of days until the lock expires.

Subscription Expiry Date – The subscription expiry date stored in the lock. You are permitted to install software that has 
release dates prior to this date.

Type – Indicates if the lock is an ordinary ShipConstructor lock or a WorkShare (formerly Project Split & Merge) lock.

Show this window during Project Register – Displays the Licensing window whenever you register a project. Turn this 
option off if you always get the same licenses or only use a local lock.

OK – Gets the selected licenses from the license servers.

ShipConstructor > ShipConstructor Help 
Lets you access the ShipConstructor online help and individual manuals (in PDF format).
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ShipConstructor > About ShipConstructor

Button .............
Ribbon ............ ShipConstructor tab > Help
Menu ............... ShipConstructor > Licensing
Command ...... SCABOUT
Permissions ... None

Displays the ShipConstructor version numbers.

Version – The version of the ShipConstructor program.

SC Utilities Menu

SC Utilities > 3D Viewpoint

Button .............
Ribbon ............ ShipConstructor tab > Main panel
Menu ............... SC Utilities > 3D Viewpoint
Command ...... SCVPOINT
Permissions ... None
Procedures ..... Select a UCS Viewpoint (page 87)

Lets you select a 3D or 2D view from several pre-defined, standard views.
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SC Utilities > Activate UCS

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Activate UCS
Command ...... SCUCSLIST
Permissions ... None
Procedure....... Activate a UCS (page 86)

When this command is used in the structure module, it enables the use of PlanarGroup Planes, activates a UCS (or 
PlanarGroup Plane), or creates a new UCS (or PlanarGroup Plane). Every PlanarGroup Plane has a UCS. However, you can 
make new UCSs that will not create PlanarGroup Planes.

- UCS has an associated PlanarGroup Plane

- UCS only

New Out of Plane – Creates a new UCS out of plane with the current UCS. You define the new plane by picking two or 
three points. 

New Parallel – Creates a new UCS parallel with the current UCS.
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Activate from Object – Sets a named UCS to be the current UCS or creates a UCS from a selected object. For most objects 
there is only one possible UCS.

Selecting a plate part brings up the following selection window. If the throw of the plate is centered, then there are 
three options.

Selecting a stiffener part will bring up the following selection window.

Add Currrent UCS – Adds the currently selected UCS to the database.

Rename – Allows you to rename the selected UCS in the list. For Planar Group Planes, you cannot rename the prefix.

Delete – Deletes the selected UCS in the list.

Activate – Activates the selected UCS in the list.
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SC Utilities > UCS > Flip UCS X

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > UCS > Flip UCS X
Command ...... SCFLIPUCS
Permissions ... None
Procedure....... None

Changes the current UCS so that the X Axis is pointing towards the –X Axis direction. 

SC Utilities > UCS > Flip UCS Y

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > UCS > Flip UCS Y
Command ...... SCFLIPUCSY
Permissions ... None
Procedure....... None

Changes the current UCS so that the Y Axis is pointing towards the –Y Axis direction. 

SC Utilities > UCS > Swap UCS XY Axis

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > UCS > Swap UCS XY Axis
Command ...... SCSWAPUCSXY
Permissions ... None
Procedure....... None

Changes the current UCS so that the X Axis is pointing towards the Y Axis direction and the Y Axis is pointing towards the 
X Axis direction. 

SC Utilities > Hide Objects

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Hide Objects
Command ...... SCHIDE
Permissions ... None
Procedure....... Hide or Show Objects (page 89)

Hides the objects selected. Hidden objects are remembered in the order you hid them while you are in the current 
drawing.
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SC Utilities > Unhide Objects

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Unhide Objects
Command ...... SCUNHIDE
Permissions ... None
Procedure....... Hide or Show Objects (page 89)

Shows hidden objects (SC Utilities > Hide Objects (page 272)) in the reverse order that you hid them.

SC Utilities > Unhide All Objects

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Unhide All Objects
Command ...... SCUNHIDEALL
Permissions ... None
Procedure....... Hide or Show Objects (page 89)

Shows all hidden objects (SC Utilities > Hide Objects (page 272)).

Note: When determining if an object is not visible in the drawing, run this command and turn on and thaw all layers.

SC Utilities > Clip Current View

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Clip Current View
Toolbar............ None
Command ...... SCCLIPVIEW
Permissions ... None

Clip Current View is a utility function that provides a convenient method for setting up AutoCAD clipping planes inside a 
viewport.

Note: Before running the command, you need to switch to the viewport in which the clipping plane is to be applied.
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1. The command line prompts you to:
Enter Point on Plane 1:

2. Choose a point on one of the clipping planes to be used (whether it is the front or back clipping plane will be 
determined by ShipConstructor).

3. The command line prompts you to enter a second point:
Enter Point on plane 2:

4. Choose a point on the second clipping plane (whether it is the front or back clipping plane will be determined by 
ShipConstructor). 

Note: If the clipping planes are not to your liking you can remove them with the command SC Utilities > Remove 
Clip (see below).
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Before clipping.

After clipping.

SC Utilities > Remove Clip

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > Remove Clip
Toolbar............ None
Command ...... SCCLEARCLIP
Permissions ... None

This command removes the AutoCAD clipping planes (SC Utilities > Clip Current View (page 273)) from the currently 
selected viewport.
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SC Utilities > 3D to 2D

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > 3D to 2D
Menu ............... SC Utilities > 3D to 2D
Command ...... SCCONV
Permissions ... None
Procedure....... Convert a 3D Object to a 2D Object (page 111)

Converts a 3D object to a 2D object on the XY plane of the current UCS.

The direction of projection for the 3D to 2D command

This command works on the following object types:

• Lines

• Arcs

• Circles

• Polylines

• 3D Polylines

• Text, MText

• Points

• Solids (not 3D solids)

• User Construction Lines
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SC Utilities > Orthographic Projection

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Orthographic Projection
Menu ............... SC Utilities > Orthographic Projection
Command ...... SCPROJECTONTOUCS
Permissions ... None
Procedure....... Project Shapes (page 111)

Projects a shape onto the current UCS. You choose the direction to project from one of the three orthogonal world 
directions (X, Y, or Z).

The direction of projection for the orthographic projection command

This command only works on lines.

SC Utilities > Remove Vertices Below Tolerance

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Remove Vertices Below Tolerance
Menu ............... SC Utilities > Remove Vertices Below Tolerance
Command ...... SCBELOWTOL
Permissions ... None
Procedure....... Reduce the Number of Vertices on Polylines (page 111)

Reduces the number of vertices on a polyline by removing vertices within a given tolerance and converting the segment 
to a straight line. If line segments form an arc and are within the tolerance, an arc is inserted into the polyline.
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This command is helpful in reducing the complexity of some curves or sections that will be used in the model. Since the 
NC machine cannot usually cut any more accurate than 0.01, there is no need to have a model more accurate.

SC Utilities > Convert Ellipse/Spline to Polyline

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Convert Ellipse/Spline to Polyline
Menu ............... SC Utilities > Convert Ellipse/Spline to Polyline
Command ...... SCCONVELLIPSE
Permissions ... None
Procedure....... Convert an Ellipse or Spline to a Polyline (page 112)

Converts an ellipse, arc, circle, or spline to a polyline with only straight line segments using the displayed tolerance. The 
tolerance is the maximum deviation from the original curve.

SC Utilities > Layer > Activate

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Activate > Activate
Menu ............... SC Utilities > Layer > Activate
Command ...... SCACTLAYER
Permissions ... None
Procedure....... Activate a Layer (page 88)

Turns the selected layer on and thaws it if it is frozen.

SC Utilities > Layer > Deactivate

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Activate > Deactivate
Menu ............... SC Utilities > Layer > Deactivate
Command ...... SCDELAYER
Permissions ... None
Procedure....... Deactivate a Layer (page 88)

Turns the selected layer off and freezes it.
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SC Utilities > Layer > Copy Geometry to

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Activate > Copy Geometry to
Menu ............... SC Utilities > Layer > Copy Geometry to
Command ...... SCCOPYGEO
Permissions ... None
Procedure....... Copy Objects from One Layer to Another (page 89)

Copies objects to the selected layer. Objects inside blocks are also moved to the destination layer.

SC Utilities > Layer > Move Geometry to

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Activate > Move Geometry to
Menu ............... SC Utilities > Layer > Move Geometry to
Command ...... SCMOVEGEO
Permissions ... None
Procedure....... Move Objects from One Layer to Another (page 89)

Moves objects from one layer to another. If you move a block, the objects inside the block are also moved to the 
destination layer.

SC Utilities > Toolpath

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Toolpath
Menu ............... SC Utilities > Toolpath
Command ...... SCTOOLPATH
Permissions ... None
Procedure....... Create a Closed Toolpath (page 110)

Creates a closed polyline (when possible) from lines that have no gaps. If the connected path is not closed, you will see 
the following warning. Duplicate lines will generate warnings that allow you to remove them.

The command allows you to set the gap tolerance that is used to bridge gaps between the selected curves. The default 
gap tolerance is 0.1.



Appendix A: Menus, Tools & Commands

280

SC Utilities > Fillet

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Fillet
Menu ............... SC Utilities > Fillet
Command ...... SCFILLET
Permissions ... None
Procedure....... None

Creates a fillet between two curves. AutoCAD’s fillet command can fail to generate a result when two complex polylines 
are filleted.

SC Utilities > Mirror about Centerline

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Mirror about Centerline
Menu ............... SC Utilities > Mirror about Centerline
Command ...... SCMIRRORCL
Permissions ... None
Procedure....... None

Makes a copy of the selected objects and mirrors them about the vessel’s centerline.

SC Utilities > Dihedral Angle

Button .............
Ribbon ............ Structure Modeling tab > Utilities panel > Dihedral Angle
Menu ............... SC Utilities > Dihedral Angle
Command ...... SCDHANGLE
Permissions ... None
Procedure....... Find the Dihedral Angle between Two Planar Objects (page 110)

Determines the dihedral angle between two planar objects
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This command works on the following object types:

• Plates

• Stiffeners with a straight construction line

• Faceplates with a straight construction line

• Any object that is planar

SC Utilities > Reload Drawing

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Reload Drawing
Menu ............... SC Utilities > Reload Drawing
Command ...... SCRELOAD
Permissions ... None
Procedure....... None

Updates all parts and construction lines in the drawing to reflect what is stored in the database. This command simulates 
the closing and opening of the current drawing. You cannot undo this command. Any objects that were erased will be 
removed from the database.

SC Utilities > Create Quality Matrix

Button .............
Ribbon ............ Structure Production > Modeling/Production Utilities tab > Create Quality Matrix 
Menu ............... SC Utilities > Create Quality Matrix
Command ...... SCQUALMTX
Permissions ... None
Procedure....... Insert a Quality Control Matrix into an Assembly Drawing (page 152)

Inserts a quality control matrix into a drawing. A quality control matrix is used for dimensional checking. It shows the 
straight-line distances between selected points.
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After inserting the matrix, any of the dimension points or labels can be moved. The length values will be updated when a 
View > Regen is run. The format of the lengths in the matrix is controlled by the Format > Units settings.

Quality Matrix Options

Label

Bubble style – The style of the bubble surrounding the letter label.

Bubble Size/Bubble Margin/Diameter – The size of the bubble. For the Bubble and Rectangle styles this is a margin 
between the text and the bubble. If Scale dimensions to layout is checked then this value is in paperspace units; 
otherwise it is in model space units.

Leader Length – The length of the leader line between the picked dimension point and the label.

Text style – The style of the text within the label.

Text size – The size of the text within the label. If Scale dimensions to layout is checked then this value is in 
paperspace units; otherwise it is in model space units.
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Arrow size – The size of the arrow. Setting this value to zero will suppress the displaying of an arrow. If Scale 
dimensions to layout is checked then this value is in paperspace units; otherwise it is in model space units.

Orient To View – Orients the label to be facing you when you are looking from any viewpoint.

Scale dimensions to layout (Paper space) – If enabled, the labels will be scaled to paperspace; otherwise model 
space units are used.

Label Layer – Layer to place all the labels on.

Matrix
Text style – The text style of the text in the matrix of dimensions. This lists all the text styles in the current drawing.

Text size – The size of the text for the matrix of dimensions. This also determines the size of the matrix. If you started 
the command while in a layout then this value will be in paperspace units.

Text Layer – Layer to place the dimensions on.

Matrix Layer – Layer to place the matrix and column headers on

Dimension Points

Picked Points – When picking points, ShipConstructor uses that point as the dimension point.

Points Projected to Current UCS – When picking points, ShipConstructor creates a dashed line from that point to a 
point on the current UCS and dimensions from that point. This makes it easier to pick points, since you do not have 
to zoom in close and make sure you are picking points on the front of the plate.

SC Utilities > Reference Lines > Style Manager…

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... SC Utilities > Reference Lines > Style Manager...
Command ...... SCRLINESTYLES
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Edit production drawing if in a production drawing or edit model drawing if in model drawing

Shows the reference line style manager. Styles are stored in the drawing. When style settings are changed any reference 
line that uses that style is updated to reflect the style change except where properties are overridden.
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Styles – Lists all the reference line styles in the current drawing.

Set Current - Sets the current reference line style. New reference lines use the current style.

New… - Create a new reference line style.

Modify… - Modifies the properties of the selected reference line style.

Delete – Deletes the selected reference line style. If a reference line style is in use or the Current Style, or the Standard 
style then you can’t delete it.
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Ticks
Ticks are small segments on the reference line that represent locations and can be used for familiarization with the area 
of the vessel that is being shown or to dimension from. Reference lines allow you to show two types of ticks: primary and 
secondary. Primary ticks are for locations you want to show the name of the location. The name of the location comes 
from the locations in the location group. Secondary ticks are to optionally show ticks for locations that you don’t want to 
have names shown for.

Tick Alignment – The alignment of the ticks relative to the reference line. Possible values: Centered, Above/Left, 
Below/Right.

Location Group Filter – Locations can optionally be marked as ticks on the reference line. This filter determines which 
location groups are shown in the Primary and Secondary Location Group lists.

Primary > Text Height – The height of the text labels of the primary ticks in modelspace units.

Primary > Text Margin – The distance of the text label to the primary tick in modelspace units.

Primary > Text Style - The AutoCAD text style to use for the primary tick text.

Primary > Text Position – The position of the text relative to the reference line. Possible values: Above/Left, Below/Right.

Primary > Text Orientation – The rotation of the text. Possible values: Parallel to line, Perpendicular to line, Reverse 
Parallel to line, Reverse Perpendicular to line. Parallel is 0 degrees rotation relative to the reference line. Perpendicular is 
270 degrees rotation relative to the reference line. Reverse Parallel is 180 degrees rotation relative to the reference line.
Reverse Perpendicular is 90 degrees rotation relative to the reference line.
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Primary > Tick Size – The length of the primary tick line in modelspace units.

Primary > Location Group – The location group that will be used to locate the primary tick lines. Use SCEDITLOCATIONS to 
create or edit the location groups.

Secondary > Tick Size – The length of the secondary tick line in modelspace units.

Secondary > Location Group – The location group that will be used to locate the secondary tick lines. Use 
SCEDITLOCATIONS to create or edit the location groups.

Text – The text to show as a label for the reference line.

Text Height – The height of the text label in modelspace units.

Text Margin - The distance of the text label to the reference line in modelspace units.

Text Style - The AutoCAD text style to use for the text label.

Text Position – The position of the text relative to the reference line. Possible values: At Start Centered, At Start 
Above/Left, At Start Below/Right, At End Centered, At End Above/Left, At End Below/Right. The Start means the start of 
the line. Typically this is the left or bottom end of the line.

Text Orientation – The rotation of the text. Possible values: Parallel to line, Perpendicular to line, Reverse Parallel to line, 
Reverse Perpendicular to line. Parallel is 0 degrees rotation relative to the reference line. Perpendicular is 270 degrees 
rotation relative to the reference line. Reverse Parallel is 180 degrees rotation relative to the reference line. Reverse 
Perpendicular is 90 degrees rotation relative to the reference line.

Text Color – The color of the text label and the primary location texts.
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SC Utilities > Reference Lines > Import Styles…

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... SC Utilities > Reference Lines > Import Styles...
Command ...... SCRLINESTYLEIMPORT
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Edit production drawing if in a production drawing or edit model drawing if in model drawing
Procedure....... Import Reference Line Styles (page 113)

Imports all reference line styles from the selected drawing into the current drawing. The command will ask if you want to 
overwrite existing reference line styles. No means styles that already exist in the current drawing will be unchanged. Text 
styles used in the reference line styles that are imported are also imported if they don’t exist.

SC Utilities > Reference Lines > Remove Style Override

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... SC Utilities > Reference Lines > Remove Style Override
Command ...... SCRLINEREMOVESTYLEOVERRIDE
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Edit production drawing if in a production drawing or edit model drawing if in model drawing

Reference lines can have properties that differ from the style they are derived from when they are edited from the 
property palette. This command removes any overridden values of a reference line and reverts the values back to the 
style’s values.

SC Utilities > Reference Lines > Update Locations

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... SC Utilities > Reference Lines > Update Locations
Command ...... SCRLINEUPDATE
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Edit production drawing if in a production drawing or edit model drawing if in model drawing

Updates reference line locations if the location groups have changed.

SC Utilities > Reference Lines > Edit Location Groups…

Button .............
Ribbon ............ ShipConstructor Tab > Manage Panel
Menu ............... SC Utilities > Reference Lines > Edit Location Groups...
Command ...... SCEDITLOCATIONS
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Hull > Edit location groups

Edits the Hull location groups. Hull location groups are used in the Hull module for marking curved plates, in the Structure 
module for marking plates, and in reference lines for indicating locations.



Appendix A: Menus, Tools & Commands

288

Type – The type of the location group.

Name – The name of the location group.

Description – An optional description of the location group.

Create – The date the location group was created.

Modified – The date the location group was last modified.

# Locations – The number of locations in the location group.

Color – A color associated with the location group. The color is used in surface marklines in Hull drawings.

Edit Locations – Shows the window to edit the individual locations in the selected location group.

New – Creates a new location group.

Copy – Creates a copy of the selected location group and places it at the bottom of the list.

Export – Exports the location group to a LOC file.

Delete – Deletes the selected location group.

Skewed Plane – Shows the window to edit the properties of the skewed plane for skewed location groups.

SC Utilities > Reference Lines > Create

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... SC Utilities > Reference Lines > Create
Command ...... SCRLINE
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Permissions ... Edit production drawing if in a production drawing or edit model drawing if in model drawing
Procedure....... Create a Reference Line (page 113)

Creates a reference line with the current reference line style. The reference line is created in the current UCS and along a 
selected primary axis. The reference line spans the extents of the drawing. The reference line is movement locked unless 
it’s in a MarineDrafting drawing. If you want to move the line use the middle point grip to retain the correct locations.
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SC Utilities > List Item within Block/Xref

Button .............
Ribbon ............ SC Utilities tab > Visual panel
Menu ............... SC Utilities > List item within Block/Xref
Command ...... SCLISTSUBENT
Permissions ... None
Procedure....... Display Information for an Object within an MLinked Drawing (page 90)

Displays LIST information for an object within an mlinked or other XREFed drawing.

SC Utilities > Check Local Interferences

Button .............
Ribbon ............ SC Utilities tab > Tools panel
Menu ............... SC Utilities > Check Local Interferences
Command ...... SCINTERCHECK
Permissions ... None
Procedure....... Check Local Interferences (page 120)

Checks for collisions between objects in a single drawing without having to create an Interference drawing.

SC Utilities > Export > Export to DWG…

Button .............
Ribbon ............ SC Utilities tab > Export panel
Menu ............... SC Utilities > Export to DWG...
Command ...... SCEXPORTDWG
Permissions ... None
Procedure....... Export a ShipConstructor Drawing to an AutoCAD only Drawing (page 91)

Exports the current drawing as an AutoCAD only drawing. The entire drawing will be duplicated with only native AutoCAD 
entities, including any hidden objects or layers.

Note: The export loads the current drawing options into the options window.

SC Utilities > Export > Export to NWC

Button .............
Ribbon ............ SC Utilities tab > Export panel
Menu ............... SC Utilities > Export > Export to DWG...
Command ...... SCNWCOUT
Permissions ... None
Procedure....... Export ShipConstructor Drawings to NavisWorks Drawings (page 92)

Exports selected drawings as separate Navisworks NWC files. The resulting files are placed beside the original drawing 
with the same filename with extension NWC. The current drawing’s drawing options are used in each of the selected 
drawings to export. This is convenient so that no matter what the drawing options are saved in each drawing, the display 
will be consistent in the NWC files. The export settings are used from the NWOPT settings. 
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SC Utilities > Snap

Button .............
Ribbon ............ SC Utilities tab > Tools panel
Menu ............... SC Utilities > Snap
Command ...... None
Permissions ... None
Procedure....... None

Opens the AutoCAD Drafting Settings window with the ShipCon Snap tab selected, letting you set the ShipConstructor 
snap options.

SC Utilities > Random Color

Button .............
Ribbon ............ Structure Modeling tab > Modeling Utilities panel > Random Color
Menu ............... SC Utilities > Random Color
Command ...... SCRANDCOLOR
Permissions ... None
Procedure....... None

Assigns a random color to each of the selected entities in the current drawing.

SC Utilities > ShipCAM > Import Files

Button .............
Ribbon ............ None
Menu ............... SC Utilities > ShipCAM > Import Files
Command ...... SCIN
Permissions ... None

Lets you import a 3D wireframe model from ShipCAM into the current drawing. This utility function can be run in plain 
AutoCAD.

SC Utilities > ShipCAM > Convert IGES to Mesh

Button .............
Ribbon ............ None
Menu ............... SC Utilities > ShipCAM > Convert IGES to Mesh
Command ...... IGES2MSH
Permissions ... None
Procedure....... None

Converts an IGES file to a ShipCAM MSH file. This function is made available because of issues with ShipCAM import of 
IGES files. This utility function can be run in plain AutoCAD.
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Command Line Commands

Show Extended Data

Menu ............... SC Utilities > Show Extended Data
Command ...... SCXDATA
Permissions ... None
Procedure....... None

Shows the some hidden ShipConstructor information that is tagged to non-ShipConstructor objects. Only a few objects 
have extended data attached to them.

Copy Product Hierarchy

Menu ............... None
Command ...... -SCPRODUCTHIERARCHYCOPY
Permissions ... General > Product Hierarchy > Product Hierarchy – Edit
License............ Universal or ProductHierarchy
Procedure....... None

This command creates a copy of an existing product hierarchy.  You may specify if you want to copy either the Assembly 
hierarchy or Assembly and parts hierarchy.

Export Product Hierarchy

Menu ............... None
Command ...... -SCPRODUCTHIERARCHYEXPORT
Permissions ... None
License............ Universal or ProductHierarchy
Procedure....... None

This command exports an existing product hierarchy to an xml file.

Import Product Hierarchy

Menu ............... None
Command ...... -SCPRODUCTHIERARCHYIMPORT
Permissions ... General > Product Hierarchy > Product Hierarchy – Edit
License............ Universal or ProductHierarchy
Procedure....... None

This command imports a product hierarchy from an xml file that has been generated by the Export Product Hierarchy 
command.
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Part View Load via Extents – SCPARTVIEWLOADBYEXTENTS

Button .............
Ribbon ............ SC Utilities > PartView > Load Extents
Menu ............... SC Utilities > PartViews > Load By Extents
Command ...... SCPARTVIEWLOADBYEXTENTS
Permissions ... none
Procedure....... None

Loads all supported ShipConstructor parts which reside in or intersect the specified WCS extents. The jig for the extents 
selection works best if WCS is your current UCS and you are in an isometric view.  You may also type the desire extents in 
on the command line. This command should work in all ShipConstructor drawings 

Part View Load via Selected Object Extents – SCPARTVIEWLOADBYSELECTEDEXTENTS

Button .............
Ribbon ............ SC Utilities > PartView > Load Selected Extents
Menu ............... SC Utilities > PartViews > Load By Selected Extents
Command ...... SCPARTVIEWLOADBYSELECTEDEXTENTS
Permissions ... none
Procedure....... None

Similar to Load via Extents, this command takes a selection set as input and loads all supported ShipConstructor parts 
which reside in or intersect the specified WCS extents of the objects in the selection set.  

Part View Load Associated Structure Parts – SCPARTVIEWLOADASSOCIATED

Button .............
Ribbon ............ SC Utilities > PartView > Load Associated
Menu ............... SC Utilities > PartViews > Load Associated
Command ...... SCPARTVIEWLOADASSOCIATED
Permissions ... none
Procedure....... None

Loads all parts that are related to the selected parts (directly or indirectly) via a mirror or an identical relationship. This 
command only works within a structure model drawing.  

Part View Refresh Part Views in Drawing – SCPARTVIEWREFRESH

Button .............
Ribbon ............ SC Utilities > PartView > PartView Refresh
Menu ............... SC Utilities > PartViews > Refresh
Command ...... SCPARTVIEWREFRESH
Permissions ... none
Procedure....... None

Refresh all Part Views in the current drawing from the database.
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Part View Delete All Part Views in Drawing – SCPARTVIEWDELETEALL

Button .............
Ribbon ............ SC Utilities > PartView > PartView Delete All
Menu ............... SC Utilities > PartViews > Delete All
Command ...... SCPARTVIEWDELETEALL
Permissions ... none
Procedure....... None

Deletes all Part Views in the current drawing.

Diagnostic Commands

Command Trace - Enable

Menu ............... None
Command ...... SCENABLECMDT
Permissions ... None
Procedure....... None

Records all the commands that are run and saves them to a log file. This is sometimes useful in recording a long process 
of commands that help support staff reproduce a problem a user is encountering.

The log files are saved to the <project>\TraceLogs folder. These log files are ASCII text files that can be viewed with any 
text file viewer.

Command Trace - Disable

Menu ............... None
Command ...... SCDISABLECMDT
Permissions ... None
Procedure....... None

Turns off the recording of commands. Recording is otherwise stopped when ShipConstructor is closed.

Debug Trace - Enable

Menu ............... None
Command ...... SCENABLEDT
Permissions ... None
Procedure....... None

Turns on the showing of internal warnings or errors to the AutoCAD command line. You should not need to use this 
command unless instructed to do so.

Debug Trace - Log

Menu ............... None
Command ...... SCENABLEDTLOG
Permissions ... None
Procedure....... None

Generates a log file of the internal warnings or errors. The warnings are also displayed on the AutoCAD command line. 
The log files are saved to the <project>\TraceLogs folder. These log files are ASCII text files that can be viewed with any 
text file viewer.
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Debug Trace - Disable

Menu ............... None
Command ...... SCENABLEDT
Permissions ... None
Procedure....... None

Stops the debugging mode. See Debug Trace - Enable (page 293).

Performance Monitor - Start

Menu ............... None
Command ...... SCSPM
Permissions ... None
Procedure....... None

Starts the performance monitoring diagnostic tool. Performance monitoring is an internal command that aids in 
determining the bottlenecks. You should not need to use this command unless instructed to do so.

Performance Monitor - End

Menu ............... None
Command ...... SCEPM
Permissions ... None
Procedure....... None

Stops the performance monitoring. See Performance Monitor - Start (page 294).

Performance Monitor - Display

Menu ............... None
Command ...... SCDPM
Permissions ... None
Procedure....... None

Outputs the performance monitor data to an Excel spreadsheet and opens Excel.

DataManager Dump

Menu ............... None
Command ...... SCDUMPDM
Permissions ... None
Procedure....... None

This is an internal command that outputs cached (in memory) data to an XML file. You should not need to use this 
command.
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Appendix: Production Command Reference

Production Menu in Manager

General > Production Output > Label Styles

Menu ............... General > Production Output > Label Styles
Toolbar............ None
Permissions ... General > Manager > Edit Label Styles
Procedure....... Label Styles (page 129)

Label styles are used to define annotations in production drawings. Label styles are used to define structure part 
piecemarks.

Label Styles

Export – Checkbox used to select label styles when exporting to XML.

In Use – Check indicates that the label style is referenced by other setting in ShipConstructor. Typically this will be in BOM 
Definitions.

Label Style Name – The name of the label style.

Insertion Mode – When a label has a leader, this setting controls how the leader will be attached to the label.
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Bubble Style - The type of outline that will be around the text of the label. 

Bubble Size - Determines the size of the bubble. The size of the bubble depends on the style of the bubble.

Various types of bubble styles for labels. They’re shown with a bubble size of 8mm and a text size of 0.18.

Bubble Style Size Calculation
Circle Diameter = Text Height + Bubble Size
Square Length = Bubble Size
Triangle Height = Base Length = Bubble Size
Octagon Width = Height = Bubble Size
Rectangle Height = Text height + 2 * Bubble Size

Width = 2 * Text Width + Bubble Size
Bubble Height = Text Height + Bubble Size * 1.5 * Number of Lines

Width  = Text Height + Text Width + Bubble Size * 1.5 * Number of Lines

Leader - Whether or not the label has a leader pointing to the object that is labeled.

Acad Dimension Style - The AutoCAD dimension style to use for some properties of the label. The list is from Dimension 
Styles (page 128). 

The text height of the label inherits its value from the dimension style’s Text height.
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The size of the arrow of the label’s leader inherits its value from the dimension style’s Arrow size.
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Num Segments – The number of segments to include in the leader. This only affects manual labeling. Automatic labeling 
uses a maximum of 1 segment.

Scale to Viewport – Is the size of the label scaled depending on the viewport’s scale. This means that the size values are 
in paperspace units and no matter what the zoom scale of the viewport the label is always the same size. Typically this 
can be turned off. It is intended for labels in modelspace but ShipConstructor mainly labels in paperspace.

Orient to View – When labels are placed in modelspace (atypical), the orientation of the label can be set to always face 
the view direction and be horizontal. Since ShipConstructor mainly labels in paperspace, this can be turned off.

Include Wipeout – A wipeout blocks out what is behind a label. If No, the background objects behind the label show 
through.

New – Creates a new dimension style link.

Delete – Deletes the selected label style. If the label style is In Use then deletion will be denied.

Import – Imports label styles from an XML file.

Export XML – Exports the checked label styles to an XML file.

Usage Log – Generates a log file that shows where the selected dimension style is used.
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General > Production Output > Dimension Styles

Menu ............... General > Production Output > Dimension Styles
Toolbar............ None
Permissions ... General > Manager > Edit Dimension Styles
Procedure....... Dimension Styles (page 128)

The list of dimension styles that correspond to dimension style names in production template drawings. The dimension 
style is used in the label style. The names should match a dimension style in the drawing. The case of the name does not 
have to match.

New – Creates a new dimension style link.

Delete – Deletes the selected dimension style link. If the dimension style is In Use then deletion will be denied.

Usage Log – Generates a log file that shows where the selected dimension style is used.

General > Production Output > Bill Of Materials

Menu ............... General > Production Output > Bill Of Materials
Toolbar............ None
Permissions ... General > Manager > Edit Bill Of Materials
Procedure....... Bill Of Materials (page 126)

ShipConstructor integrates all Bill of Materials management through the BOM Definitions manager. The BOM Definitions
manager lets you create and edit existing BOMs for all production drawing types.

Access the BOM Definitions manager through Manager > General > Production Output > Bill of Materials.
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BOM Definitions
The list of BOM definitions broken down into each production drawing type. Pipe Spool drawings have special BOM 
Definitions for Bending Tables, Cutlist, Corner Point Location Tables, and Global Position Location Tables.

Export – Checkbox to indicate if which BOM Definitions to export when Export XML is chosen.

Definition Name – Name of the BOM definition.

Title – Title to display in the AutoCAD table.

Note: Only tables using table styles that contain the Title section will display the Title text.

Acad TableStyle – AutoCAD tablestyle to use for BOM tables. If the specified tablestyle is not found at the time of 
insertion, then the STANDARD style is used.

Label Style – ShipConstructor label style to use for labeling from the BOM. This style can be overridden by the Collectors >
Label Style.

Row # prefix text – Precedes item number with text in both table and label.

New - Creates a new BOM definition. If the Default Collectors checkbox is checked then a hardcoded default list of 
collectors is added.

Copy – Create a new BOM definition from the currently selected BOM. The collectors and fields will be the same as the 
selected BOM definition.

Delete - Deletes the selected BOM definition. If the BOM definition is in use, it cannot be deleted.

Default Collectors – If selected, any new BOM definitions will include reasonable collectors for the current production 
drawing type. You can modify the collectors and their order after creation.

Fields
Lets you customize aspects of the fields that appear in your BOM:

• Choose which fields to include in the BOM.

• Alias the field names to something appropriate for your company.

• List the order the fields will be displayed in.

• Specify sorting, merging, and visibility of the included fields.

• Specify properties specific to the type of field included, be it a decimal, length, weight, or other type of value. 
Fields with manageable properties are indicated by a white background in the Field Props column.
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Field name – The name of the field that is in the BOM table.

Alias – The name of the column header to appear in the table.

Visible – Is the column going to be visible in the table. Invisible columns may be needed to sort in a specific desired order 
but the column won’t be shown in the AutoCAD table.

Sort Details – Is the column used for sorting rows in the table?

Sort – Checkbox to indicate the table uses the selected column to sort rows.

Sorting method

Ascending – Rows are sorted by ascending value in this column.

Descending – Rows are sorted by descending value in this column.

Sort Order – Sorting by multiple columns is possible. The priority given to each column is determined by the Sort 
Order. Sort Order 1 is sorted first. If two columns have the save value for the Sort Order 1 column then Sort Order 2 
column is ordered.

- Moves selected fields up in the listing order or toward the first column of the table.

- Moves selected fields down in the listing order or toward the last column of the table.

Add/Remove – Adds or removes production fields or user attribute fields. Production fields are those provided by 
ShipConstructor and that exist in every project. Attribute fields are special fields that are defined by the user for the 
project. All attribute fields are listed, regardless of whether they logically make sense for the BOM definition.

Note: The BOM Labeling procedure extracts the text contained in the first column of the table. (Typically the Item # 
field would be the first field but you could for instance use a field such as ‘Spool Name’, etc.) 
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Field List

Production Fields – Hardcoded list of BOM fields

Attribute Fields – The list of user defined attribute string fields.

PEL User Attributes – The list of user defined attribute fields for the new style user defined attributes available for project 
equipment list parts.

Include – Checkbox to indicate if the field is in the BOM table definition.

Field – The name of the field

Module – The list of modules that this field applies to. H – HVAC, P, - Pipe, S – Structure, EQ – Equipment, EL – Electrical, 
G – General, HL – Hull

Field Types – The type of the field data.

Description – The description of the field.

Collectors
Collectors are responsible for gathering objects in a drawing to be included in a BOM and then processing the object data 
for display in the BOM.

Note: Collector order is important because each collector returns information specific to the objects it collects. 
Resultant information for each collector is then compiled in the order specified by the BOM definition.

Collectors are specific for each production drawing type. The following table lists the collectors available per drawing type.

List – the list of collectors included in the selected BOM definition.

Included – The name of the collector that is included.

Label Style – Label style to use for this collector. If all collectors or this BOM table will use the same label style, then the 
collector label style can be set to <none>.

- Moves selected collectors up in the listing order and moves the rows generated by those collectors towards the top 
of the table.

- Moves selected collectors down in the listing order and moves the rows generated by those collectors towards the 
bottom of the table.
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- Adds the selected collector from the available collector list to the included collector list.

- Removes the selected collector from the included list back to the available collector list.

Available – The list of available collectors for the selected drawing type.

The following table lists the collectors and their functions. 

Collector Description Additional Functionality
All Accessories Collects the accessories from all part types that 

can have accessories (Equipment, pipe 
connections, HVAC connections, Cable Supports, 
Penetrations, Pipe Hangers).

Assembly Collects parts that are in subassemblies based 
on the primary product hierarchy.

A row for each direct subassembly that contains 
parts is shown.

Include Standard Assemblies – if checked 
this will collect parts in standard 
assemblies 

Filter Only – Allows the collector to collect, 
but not display the items in the BOM. 
Useful if you want to only include items 
directly within the Assembly and not from 
sub assemblies.

Bending Info Lists information necessary to cut and bend pipe Typically links* to Cutlist BOM in order to 
maintain consistent item numbering.

Cable Support 
Accessories

Collects accessories from cable support parts.

Cable Support Part Collects cable support parts.

Corner Point Lists the end positions and change of direction 
points within a run of pipe in pipe coordinates.

Cannot currently: include other fields or 
change column ordering. Typically links* to 
Global Point BOM in order to maintain 
consistent item numbering.

Distributed System 
Support

Collects all parts that are part of supports. This 
only included profiles and plates and not the pipe 
hangers.

Equipment Accessories Collects the accessories from all equipment 
parts.

Equipment Part Collects all equipment parts.

General Part Collects all parts and returns part level 
information for each.

Warning: The general part collector can take 
a significant amount of time to process data 
on larger projects and should not be used 
often.

Global Point Collects free ends of Piping for listing: the 
distance to nearest planar group in the three 
primary directions, and the connectivity of the 
free end.

Cannot currently: include other fields or 
change column ordering. Typically links* to 
Corner Point BOM in order to maintain 
consistent item numbering.

HVAC Connection 
Accessories

Queries all HVAC- HVAC connections and 
retrieves accessory package information from 
them.

HVAC Part Finds and returns information for all HVAC parts. Lets you specify the type and spool status 
of the objects listed in the BOM.

HVAC Spool Gathers all HVAC objects and organizes them into 
their spools. Returns information for each spool.



Appendix: Production Command Reference

304

Penetration 
Accessories

Queries all penetrations in the drawing and 
retrieves accessory package information from 
them.

Penetration 
Component

Gathers all Penetration component parts and 
reports information for the items contained in 
each.

Pipe Connection 
Accessories

Queries all pipe-pipe connections and retrieves 
accessory package information from them.

Plate Nest Finds and returns all objects in a Nest drawing 
specific to a particular nest.

Pipe Hanger Find and returns information for all Pipe Hanger 
parts.

Lets you choose from all the hanger part 
types

Pipe Hanger 
Accessories

Queries all Pipe Hangers and retrieves accessory 
package information from them.

Pipe Part Finds and returns information for all pipe parts. Lets you specify the type and spool status 
of the objects listed in the BOM.

Pipe Spool Gathers all Pipe objects and organizes them into 
their spools. Returns information for each spool.

Profile Plot Collects all objects in a Profile Plot drawing 
specific to a particular nest.

Standard Assembly Collects all parts that are part of standard 
assemblies.

Structure Part Collects structure parts. Collector Options let you select the Part 
Types to collect.

Corrugated Plate, Curved Plate, Profile, 
Penetration Components, Plank, Plate, 
Twisted Profile

Weld Collects weld objects

Wireway Leg Collects electrical wireway leg parts

Merging Rows 
Rows with common field values can be merged. There are only two requirements for two rows to be merged:

1. The rows must be produced by the same Collector.

2. For each field where Merge Identical has been set to Yes, the row must have the same value as the one above. 

Fields that are not marked as Merge Identical are merged appropriately e.g. Total Length is summed, quantities are 
summed, etc. Where values differ in merged cells, the value “Varies” will be displayed.

There is one exception to the rule of summation however, and this is for the ‘Length’ field. It is not summed so that the 
BOM can produce output like:

Item # Quantity Length Stock Name

4 6 48-5/16” P-SM-CS_00.75_40_A53-B

Where each of the six pipes is 48-5/16” long. Use the “Total Length” field (and Alias the name to your company 
standards) if you need to sum the lengths of the objects.

Merging Columns
It is sometimes necessary to show information that is contained in different locations within objects, in the same cell. For 
instance, an Assembly Bill of Materials may list assemblies, spools, structure parts, pipe parts, etc.. Rather than 
displaying multiple columns to display the relevant name information, you can merge the data into the same column, 
thereby reducing the total number of columns displayed in the BOM table.

In order to merge the columns, the columns must:

• Have the same Field Alias. Rename the field alias from the default to the required name.
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• Be consecutively ordered within the BOM definition

• Contain mutually exclusive data. i.e. only one of the fields will return data. If more than one field returns values, 
then ‘varies’ will be displayed in the cell.

General > Production Output > Predefined Assembly Format

Menu ............... General > Production Output > Predefined Assembly Format
Toolbar............ None
Permissions ... General > Manager > Edit Predefined Assembly Format
Procedure....... Predefined Assembly Format (page 148)

Predefined assembly format is a way to assign specific templates to assembly levels. When an assembly drawing is 
created it uses the template assigned to its level.

Select Product Hierarchy – The list of product hierarchies in the project.

Levels List

Levels – List of all levels for the selected product hierarchy.

Template – The assembly template drawing assigned to the assembly level. The list contains all registered assembly 
template drawings in the project.

Ribbon Tabs (page Error! Bookmark not defined.)

Template Tab

General Panel

Navigator

See ShipConstructor > Navigator (page 231)

Edit All Drawing Options

See Drawing Options > Edit All Drawing Options… (page 322)
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Structure Drawing Options

See Drawing Options > Structure Drawing Options… (page 323)

Pipe Drawing Options

See Drawing Options > Pipe Drawing Options… (page 323)

HVAC Drawing Options

See Drawing Options > HVAC Drawing Options… (page 323)

Equipment Drawing Options

See Drawing Options > Equipment Drawing Options… (page 323)

Hanger and Support Drawing Options

See Drawing Options > Hanger and Support Drawing Options… (page 324)

Save Drawing Options

See Drawing Options > Save Drawing Options (page 324)

Load Drawing Options

See Drawing Options > Load Drawing Options (page 324)

Insert BOM table

See BOM > Insert BOM Table… (page 328)

Insert Keyword

See Production Utilities > Insert Keyword (page 339)

Viewport Options

See Viewport Options… (page 324)

Set Viewport Display Options

See Viewport Display Options > Set… (page 327)

Load Viewport Display Options

See Viewport Display Options > Load… (page 328)

Save Viewport Display Options

See Viewport Display Options > Save… (page 327)

Toggle List Only Visible

See BOM > Toggle List Only Visible (page 331)
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Edit Collector Options

See BOM > Edit Collector Options… (page 331)

MarineDrafting Template Panel
View Creation Settings

See MarineDrafting manual.

View Generation Settings

See MarineDrafting manual.

Reference Line Style Manager

See SC Utilities > Reference Lines > Style Manager… (page 283).

Reference Line Import Styles

See SC Utilities > Reference Lines > Import Styles… (page 287).

Reference Line Edit Location Groups

See SC Utilities > Reference Lines > Edit Location Groups… (page 287).

PlateNest Panel
Define Border

See Structure manual.

Check Nest Template Drawing

See Structure manual.

Update from a Previous Version

See Structure manual.

ProfilePlot Panel
Draw Border

See Structure manual.

Draw Web Area View

See Structure manual.

Replace Legacy Keywords

See Structure manual.

ProfileSheet Panel
Draw Border

See Structure manual.

Draw Area

See Structure manual.

Replace Legacy Keywords

See Structure manual.
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Production Tab

Main Panel

Navigator

See ShipConstructor > Navigator (page 231)

Edit All Drawing Options

See Drawing Options > Edit All Drawing Options… (page 322)

Structure Drawing Options

See Drawing Options > Structure Drawing Options… (page 323)

Pipe Drawing Options

See Drawing Options > Pipe Drawing Options… (page 323)

HVAC Drawing Options

See Drawing Options > HVAC Drawing Options… (page 323)

Equipment Drawing Options

See Drawing Options > Equipment Drawing Options… (page 323)

Hanger and Support Drawing Options

See Drawing Options > Hanger and Support Drawing Options… (page 324)

Save Drawing Options

See Drawing Options > Save Drawing Options (page 324)

Load Drawing Options

See Drawing Options > Load Drawing Options (page 324)

Model Link

See ShipConstructor > Model Link (page 258)

3D Viewpoint

See SC Utilities > 3D Viewpoint (page 269).

Product Heirarchy

See ShipConstructor > Product Hierarchy (page 261)



Appendix: Production Command Reference

309

Production Utilities Panel
Update Drawing

See Update Drawing (page 316)

Viewport Options

Update All Keywords

See Production Utilities > Update All Keywords (page 321)

Insert Keyword

See Production Utilities > Insert Keyword (page 339)

CG Point

See CG Point (page 321)

Orientation Icon

See Orientation Icon (page 320)

BOM Panel

Update BOMs

See BOM > Update BOMs (page 328)

Insert BOM Table

See BOM > Insert BOM Table… (page 328)

Edit Collector Options

See BOM > Edit Collector Options… (page 331)

Toggle List Only Visible

See BOM > Toggle List Only Visible (page 331)

Production Drawing Revisions Palette

See Drawing Revisions Palette… (page 318)

New BOM Revision in Current Layout

See BOM Revisions > New BOM Revision in Current Layout (page 336)

New BOM Revision in All Layouts

See BOM Revisions > New BOM Revision in All Layouts (page 336)

List BOM Revisions

See BOM Revisions > List BOM Revisions (page 337)

Delete BOM Revision from Current Layout

See BOM Revisions > Delete BOM Revision from Current Layout (page 336)

Delete BOM Revision from All Layouts

See BOM Revisions > Delete BOM Revision from All Layouts (page 337)
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Delete All BOM Revisions from Current Layout

See BOM Revisions > Delete All BOM Revisions from Current Layout (page 337)

Delete All BOM Revisions from All Layouts

See BOM Revisions > Delete All BOM Revisions from All Layouts (page 337)

Labeling Panel

Manual Label

See Label > Manual Label (page 331)

Auto Label All

See Label > Label All (page 332)

Auto Label Layout

See Label > Label Current Layout (page 332)

Auto Label Parts

See Label > Label from Parts (page 333)

Label Viewports

See Label > Label Viewports (page 332)

Label Viewports from BOM

See Label > Label Viewports from BOM (page 333)

Delete All Labels

See Label > Delete All Labels (page 333)

Delete Labels in Current Layout

See Label > Delete Labels in Current Layout (page 334)

Copy Label

See Label > Copy Label (page 332)

Label on Visible Edge On/Off

See Label > Label on Visible Edge On/Off (page 334)

Curved Plates in Visible Edge Detection On/Off

See Label > Curved Plates in Visible Edge Detection On/Off (page 335)

Adjacent Part Edge Tolerance

See Label > Adjacent Part Edge Tolerance (page 335)

Corner Clearance

See Label > Corner Clearance (page 335)
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Edge Determination Minimum Angle

See Label > Edge Determination Minimum Angle (page 335)

Label Reset Automatic Settings

See Label > Label Reset Automatic Settings (page 336)

Track Label Positions

See Label > Track Label Positions (page 333)

Create Leader Distribution Line

See Create Leader Distribution Line (page 338)

Attach to Viewport Tracking

See Attach to Viewport Tracking (page 338)

Redistribute Leaders

See Redistribute Leaders (page 339)

Set Leader Insertion Mode

See Set Leader Insertion Mode (page 339)

Adjust Leader Spacing

See Adjust Leader Spacing (page 338)

Transfer Leaders to Other Line

See Transfer Leaders to Other Line (page 339)

Property Label Panel

Property Label

See Property Label > Property Label (page 351)

Copy Field Label

See Property Label > Copy Field Label (page 351)

Copy Field Label Quick

See Property Label > Copy Field Label Quick (page 351)

Edit Field Label

See Property Label > Edit Field Label (page 352)

Replace Object References

See Property Label > Replace Object References (page 352)

Set Single Click Field Label

See Property Label > Set Single Click Field Label (page 352)

Spool Panel

Rotate Dimension
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See SC Spool Drawing > Rotate Dimension (in Pipe of HVAC Manual)

Align Dimension Text to Current View

See SC Spool Drawing > Align Dimension Text to Current View (in Pipe of HVAC Manual)

Re- Dimension

See SC Spool Drawing > Re-Dimension (in Pipe or HVAC manual)

Label Connecting Spool/Assembly

See SC Spool Drawing > Label Connecting Spool/Assembly (in Pipe or HVAC manual)

MarineDrafting Panel

Auto Create Views

See MarineDrafting manual.

Update Views

See MarineDrafting manual.

Open Output Drawing

See MarineDrafting manual.

Create a View

See MarineDrafting manual.

View Creation Settings

See MarineDrafting manual.

View Generation Settings

See MarineDrafting manual.

List Source Part

See MarineDrafting manual.

Copy to 2D View

See MarineDrafting manual.

Reverse View Direction

See MarineDrafting manual.

Repair Property Label Fields

See MarineDrafting manual.

Repair Link to Output Drawing

See MarineDrafting manual.

PipeLink Panel

Show PipeLink Manager

See Pipe manual.
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Generate PipeLink File for Drawing

See Pipe manual.

Export PipeLink File

See Pipe manual.

Approval Drawing Panel

Insert Group

See Structure manual.

Save As Bound Approval

See Structure manual.

Commands

Edit Production Drawing Permission
Many of the commands in production are common across all production drawing types. In order to allow permissions 
based on production drawing type, ShipConstructor checks the drawing type to determine the permission.

Editing production drawing is linked to permissions in the following table.

Production Drawing Permission

Any Template Drawing General > Edit Template Drawings

Assembly Structure > Assembly Drawings – Edit

Equipment Arrangement Equipment > Equipment Arrangements – Edit

HVAC Arrangement HVAC > HVAC Arrangements – Edit

HVAC Spool HVAC > Spools > Spool Drawings - Edit

Interference General > Edit Interference

MarineDrafting Production > MarineDrafting – Edit

Output Production > Output – Edit

Pipe Arrangement Pipe > Pipe Arrangements – Edit

Pipe Spool Pipe > Spools > Spool Drawings – Edit

Pipe Support Construction Distributed System Supports > Construction Drawings - Edit

Product Hierarchy General > Edit Product Hierarchy Drawings

Weld Management Weld Management > Weld – Edit

Wireway Arrangement Electrical > Wireway Arrangement Drawings – Edit

Revisions Add/Edit Permission
Many of the commands in production are common across all production drawing types. In order to allow permissions 
based on production drawing type, ShipConstructor checks the drawing type to determine the permission.

Add/Edit Revisions is linked to permissions in the following table.
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Production Drawing Permission

Assembly Structure > Assembly Drawing Revisions – Add/Edit

Equipment Arrangement Equipment > Equipment Arrangement Drawing Revisions – Add/Edit

HVAC Arrangement HVAC > HVAC Arrangement Drawing Revisions – Add/Edit

HVAC Spool HVAC > Spools > Spool Drawing Revisions – Add/Edit

MarineDrafting Production > MarineDrafting Drawing Revisions – Add/Edit

Output Production > Output Drawing Revisions – Add/Edit

Pipe Arrangement Pipe > Pipe Arrangement Drawing Revisions – Add/Edit

Pipe Spool Pipe > Spools > Spool Drawing Revisions – Add/Edit

Pipe Support Construction Distributed System Supports > DS Support Construction Dwg Revisions –
Add/Edit

Wireway Arrangement Electrical > Wireway Arrangement Drawing Revisions – Add/Edit

Revisions Remove Permission
Many of the commands in production are common across all production drawing types. In order to allow permissions 
based on production drawing type, ShipConstructor checks the drawing type to determine the permission.

Remove Revisions is linked to permissions in the following table.
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Production Drawing Permission

Assembly Structure > Assembly Drawing Revisions – Remove

Equipment Arrangement Equipment > Equipment Arrangement Drawing Revisions – Remove

HVAC Arrangement HVAC > HVAC Arrangement Drawing Revisions – Remove

HVAC Spool HVAC > Spools > Spool Drawing Revisions – Remove

MarineDrafting Production > MarineDrafting Drawing Revisions – Remove

Output Production > Output Drawing Revisions – Remove

Pipe Arrangement Pipe > Pipe Arrangement Drawing Revisions – Remove

Pipe Spool Pipe > Spools > Spool Drawing Revisions – Remove

Pipe Support Construction Distributed System Supports > DS Support Construction Dwg Revisions –
Remove

Wireway Arrangement Electrical > Wireway Arrangement Drawing Revisions – Remove

ShipConstructor > Manage > Volume Manager

Button .............
Ribbon ............ ShipConstructor tab > Manage panel
Menu ............... ShipConstructor > Volume Manager
Command ...... SCVOLUMEMGR
Permissions ... General > Edit Volumes
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Volumes (page 149)

New Folder – creates a new folder under whatever volume folder is selected to organize different volumes. If no volume 
folder is selected, it creates a root folder.

New Volume – creates a new volume under whatever volume folder is selected.

Delete – Deletes selected volumes and volume folders.

Pick Min – when a volume is selected, click this to pick the minimum extents of the volume in the current drawing. Note -
if the selected point is larger in any dimension than the max extents, the dimension will be swapped so as to maintain 
true min and max extents of the volume.

Pick Max – when a volume is selected, click this to pick the maximum extents of the volume in the current drawing. Note 
- if the selected point is smaller in any dimension than the min extents, the dimension will be swapped so as to maintain 
true min and max extents of the volume.
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Save – saves the volumes and volume folders.

Refresh – refreshes the data from the project.

Import – imports volumes and their volume folders.

Export – exports the selected volumes and their selected folder structure. Selecting a volume to export will automatically 
select its folder structure. Selecting a folder will automatically select its children.

Show – click on the volumes’ light bulb to show the volume in the current drawing.

To rename a volume or folder – just double click on the name cell to bring the cell into edit mode. If a name violates any 
of the naming constraints, there will show a warning on the bottom of the palette as to why.

To edit the min and max extents without picking a point – simply double click to edit the desired cell.

Volume List

Export – Checkbox to indicate which volumes to export.

Volumes – the name of the volume or volume folder.

Show – An option to display the volume in the current drawing.

Min L – The minimum extent of the volume in the longitudinal direction.

Min T – The minimum extent of the volume in the transverse direction.

Min V – The minimum extent of the volume in the vertical direction.

Max L – The maximum extent of the volume in the longitudinal direction.

Max T – The maximum extent of the volume in the transverse direction.

Max V – The maximum extent of the volume in the vertical direction.

Update Drawing

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... Update Drawing
Command ...... SCUPDATEDWG
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Update a Production Drawing (page 160)

Updates the parts, BOM tables, and keywords within a production drawing. Annotation labels are updated but new parts 
to the drawing are not labeled. If a CG point exists in the drawing it will be updated.

In MarineDrafting drawings it will update the MarineDrafting views that are out-of-date.

In spool drawings it will ask to redimension the spool drawing.

The Modified Part Information window is used while updating existing production drawings. It helps you to inspect parts 
that will change during this update process.
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The main table shows you a list of parts that are affected by updating this drawing. The parts are split into several 
categories. You can multi-select any of the parts in this list, and, depending on the View options, the parts will be 
highlighted, centered, and zoomed to.

Note: If you are in one of the Paper space layouts and you do not have a viewport selected, the largest viewport will be 
automatically chosen to highlight entities in. If you want to use a different viewport, simply activate it.

Reasons why parts are being updated

• New Parts – If an existing source (such as a system) has had parts added to it, the parts will show up here. Or, 
because you selected new sources in the drawing creation wizard.

• Removed Parts – These are parts that will be removed for any reason, including the source being removed entirely or 
the part being deleted out of the source.

• Modified Parts – Any parts that have had any of their attributes changed will show up here.

• User Deleted Parts – Parts that have been manually deleted out of the production drawing. Select the parts using the 
checkbox beside them to re-insert them. To re-insert multiple parts, select all the parts that are to be re-inserted. 
Click the checkbox for one of the selected parts, the checkboxes for all the selected parts will be checked. Deleted 
parts can be previewed using both the Show/Preview Checked Parts and the Refresh Preview controls.

View

The view options control what happens when you click on a part in the updating part list. 

• Center – Centers on all selected parts.

• Highlight – Highlights all selected parts.

• Zoom – Zooms to all selected parts.

Part Color overrides

To visually aid in identifying parts, all parts that are not affected by the update process are temporarily displayed in a light 
grey color. All affected parts have custom color overrides that control how the parts appear while the Modified Part 
Information window is visible.

• New – Set the color of the parts that have been newly added to this drawing.

• Modified – Set the color of the parts that are being updated because any of their attributes or their geometry has 
changed.

• Removed – Set the color of the parts that are being removed from this drawing

• Deleted – Set the color of the parts that have been deleted by the user from this drawing. This corresponds to the list 
of User Deleted Parts from the modified parts table.

• Unchanged – Set the color of the parts that are unaffected by the update of the drawing
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Show Removed Parts - If you do want to see parts that are being removed from this drawing. This is useful if you have 
removed an entire source and do need to know exactly what is being removed.

Show/Preview Checked Parts - If you do want to see parts that you deleted intentionally from this drawing. When 
enabled, all the parts with their checkboxes checked with appear in the drawing, using the User Deleted color. 
Unchecking will hide all checked parts.

Refresh Preview – If the list of checked parts has changed and you want to preview any parts added to that list.

Drawing Revisions Palette…

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... Drawing Revisions Palette…
Command ...... SCPRODREVVIEW
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Show Out-of-Date Parts (page 168)

Shows the Production Drawing Revisions Palette for the current drawing. The information is stored in the drawing.
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Title – Shows the title of the current drawing whose revisions it shows.

Action List – The list of actions performed on the current drawing since it was created. Any drawings unaltered since 
ShipConstructor 2011 R2 will only have a Created Drawing action. The default order to the list is newest on top.

Action – The type of action performed (Eg. Created Drawing, Updated Drawing, Deleted Parts, Created Revision, and 
Created MarineDrafting View).

User – The user who performed the action.

Description – The number of parts affected or the revision description.

Details – The layout names if the action was for revisions, the name of the MarineDrafting view if the action was for 
MarineDrafting views.

Date – The date and time of the action.

Part List – The list of parts associated with the selected actions.

Module – The major module that the part from.

Part Type – The type of part.

Part Name – The name of the part.



Appendix: Production Command Reference

320

Change – The change in state of the part between the selected actions.

Override All Part Colors – If checked the colors of the parts will change from their current colors to the color scheme of 
New, Modified, Removed, Unchanged). Parts will not lose any information if the color overriding is turned on.

Center – Centers the selected part in the current viewport.

Highlight – Highlights the selected part.

Zoom – Enables the zoom slider to zoom into the selected part.

Reload – The icon in the upper right hand corner gets the latest action data from the current drawing.

MarineDrafting drawings can contain multiple 2D Views, the drop list allows you to zoom to a part in a specific view.

Zoom to 2D View

Show/Hide View panel button – minimizes the View panel in the palette. Colors are still togglable on the panel header 
while minimized.

Orientation Icon

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... Orientation Icon
Command ...... SCASSORIENT
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting 
Procedure....... Insert an Orientation Icon into an Assembly Drawing (page 150)

Inserts an orientation icon into a production drawing. The orientation icon can be 3D for iso drawings or 2D for 2D 
drawings. The style of the icon is not changeable after it is inserted.
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Axis Size – The size of the icon in project units.

Axis Label Size – The size of the direction text.

Create Arrows – Decides if there are arrows at the end of the axis lines.

Type  3D, 2D

Show in current viewport only – If checked, will place the icon on a layer that is only visible in the current viewport.

CG Point

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... CG Point
Command ...... SCINSERTCG
Permissions ... Edit Production Drawing Permission (page 313)
License............ None
Procedure....... Mark an Assembly’s CG Position in an Assembly Drawing (page 151)

The command inserts a SConCGPoint object at a center of gravity (CG) position of the current assembly. The SConCGPoint 
is exactly like an AutoCAD point object except you cannot move it. The command also changes the current Point style to 

(34).  You can change the style of the CG point by using the point style options. The orientation of the point is based 
on the orientation of the current UCS. If a SConCGPoint already exists in drawing, it will be moved to the correct CG 
position. 

Note: Running Update Drawing (page 316) will move the SConCGPoint to the updated CG position.

Production Utilities > Update All Keywords

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Update All Keywords
Command ...... SCUPDATEALLKEYWORDS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Update All Keywords (page 164)

Updates all keywords in paper space in the drawing.
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Drawing Options > Edit All Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > Edit All Drawing Options...
Command ...... SCDWGOPTIONSALL
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Displays all the drawing options.
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Drawing Options > Structure Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > Structure Drawing Options...
Command ...... SCDWGOPTIONSSTRUCT
Permissions ... None
License............ None
Procedure....... SC Structure > Show / Hide Options

Displays the structure drawing options.

Drawing Options > Pipe Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > Pipe Drawing Options...
Command ...... SCDWGOPTIONSPIPE
Permissions ... None
License............ None
Procedure....... See the Pipe manual for details

Displays the pipe drawing options.

Drawing Options > HVAC Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > HVAC Drawing Options...
Command ...... SCDWGOPTIONSHVAC
Permissions ... None
License............ None
Procedure....... See the HVAC manual for details.

Displays the HVAC drawing options.

Drawing Options > Equipment Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > Equipment Drawing Options...
Command ...... SCDWGOPTIONSEQUIP
Permissions ... None
License............ None
Procedure....... See the Equipment manual for details.

Displays the Equipment drawing options.
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Drawing Options > Hanger and Support Drawing Options…

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Drawing Options > Hanger and Support Drawing Options
Command ...... SCDWGOPTIONSHANGANDSUPPORT
Permissions ... None
License............ None
Procedure....... See the Equipment manual for details.

Displays the Hanger and Support drawing options.

Drawing Options > Save Drawing Options

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Equipment Drawing Options
Command ...... SCSAVEDRAWINGOPTIONSFROMFILE
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... See the Equipment manual for details.

Saves the current drawing’s drawing options to a file. An SCDO file is created and it can be used either the drawing 
options or the viewport display options.

Drawing Options > Load Drawing Options

Button .............
Ribbon ............ Production tab > Main panel
Menu ............... Assembly > Load Drawing Options
Command ...... SCLOADDRAWINGOPTIONSFROMFILE
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... None

Loads drawing options from a selected SCDO file into the current drawing.

Viewport Options…

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Viewport Options…
Command ...... SCVPORTOPTIONS
License............ None
Permissions ... None

Lets you indicate whether an assembly drawing viewport is a keymap viewport or a normal viewport and whether 
ShipConstructor will insert automatic annotations into the viewport.
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Show KeyMap – Shows the Keymap layer in the selected viewport. Enabled only in Assembly drawings.

Label items from all BOMs – Flag used by labeling to determine what viewports to label. When checked, all BOMs in the 
current layout will be labeled in the selected viewport. When unchecked, only BOMs checked in Label column will be 
labeled. 

BOM list – List of BOM tables in the current layout. Used to label specific BOMs for the selected viewport.

Minimum leader length – The distance to offset the distribution lines from the extents bounding box when automatic 
labeling the selected viewport. The value is in paper space units.
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Label Spacing – The distance between labels on new distribution lines created when automatic labeling.

The data entered in the window is saved as Xdata on the viewport object. The value is in paper space units. The label 
spacing is applied to the distribution line.
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Viewport Display Options > Set…

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Viewport Display Options > Set...
Command ...... SCDWGOPTIONSVIEWPORT
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Set Up Viewport Display Options (page 146)

Configure the viewport specific display options for a specific viewport.

Viewport Display Options > Save…

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Assembly > Viewport Display Options > Save…
Command ...... SCSAVEVIEWPORTDRAWINGOPTIONSTOFILE
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... None

Saves the selected viewport’s display options to a file. An SCDO file is created and it can be used either the drawing 
options or the viewport display options.
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Viewport Display Options > Load…

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Assembly > Viewport Display Options > Load…
Command ...... SCLOADVIEWPORTDRAWINGOPTIONSFROMFILE
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... None

Loads display options from a selected SCDO file and applies them to the selected viewport.

BOM > Update BOMs

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... Update BOMs
Command ...... SCUPDATEBOMS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Update BOMs (page 153)

Updates all the BOM Tables in the drawing.

BOM > Insert BOM Table…

Button .............
Ribbon ............ Production tab > BOM panel 
Menu ............... Insert BOM Table...
Command ...... SCINSERTBOM
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Insert a BOM Table into a Production Drawing Template (page 141)

Inserts a BOM table using a wizard.
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1. Step 2 lets you select BOM types. BOM functionality depends on the production drawing type. All drawing types 
except for Nest and Profile plots require that the BOM be inserted in paper space only. Nest and Profile Plots are 
inserted in model space only.
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Table Options
Specify the physical table properties:

• Column width – the initial column width of the table. You can easily adjust the widths of the columns afterwards.

• Row height – Default number of lines per row of table. Actual height varies with table style and text style.

• Maximum number of rows per table – any non-zero value will cause additional tables to be populated in the direction 
specified by the wrap property below. 

List

All rows generated by the collectors are compiled into the BOM data master set. You can control the items listed in the 
BOM Table by choosing one of the two options:

• List All – Lists all items in the compiled master BOM.

• List Only Visible – Items displayed in the BOM will be based on objects’ viewport visibility. Items that are visible in 
any of the viewports within the layout will be listed. Object layer visibility and viewport clipping are respected.

The numbering of items remains consistent across all layouts regardless of whether List All or List only visible is chosen.

Wrap Properties – Choices are enabled when a value greater than zero is entered in the Maximum number of rows per 
table field.

• Table wrap direction – Direction that new tables should be added.

• Spacing – Space between newly created tables.

Label Options

The labeling procedure works in conjunction with the BOM. Only objects that are referenced by a particular BOM are 
labeled. Label text is retrieved from the first column specified by the BOM definition.

The label style used for labeling is defined in the BOM definition. You can specify one main one for the BOM definition 
and one for each collector. The collector label style overrides the BOM definition label style if one is specified.
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ShipConstructor marks viewports that you select with AutoCAD xdata. Once selected, the objects in the viewport will be 
labeled by any of the part labeling commands. You can manage selected viewports in two ways:

• Using the BOM Definitions Wizard

a. Select viewports – choose the viewports that you want to be labeled.

b. Highlight selected – Highlights viewports currently selected for labeling.

• Using the SCVPORTOPTIONS command

If not viewport is selected then the BOM table will not label any parts.

BOM > Edit Collector Options…

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... Edit Collector Options...
Command ...... SCTWEAKBOMOPTIONS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Edit BOM Collector Options (page 143)

Allows the user to change the BOM Collector options.

BOM > Toggle List Only Visible

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... Toggle List Only Visible
Command ...... SCTOGGLELISTVISIBLE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Toggles the variable in the BOM to list only those parts visible or not. Requires an update to the BOM table to show the 
change.

Label > Manual Label

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Manual Label
Command ...... SCLABELMANUAL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Manual Labeling (page 157)

Manually label parts from a BOM. This is an alternative method to automatic labeling. The label style and text contents 
are used from the selected BOM. The selection of the leader arrow is the pickpoint where you selected the part. The 
number of leader segments follows the label style setting.

This command can be used in conjunction with Copy Label from BOM so complete the labeling. If you select a part that 
has been previously labeled then the previous label is removed.
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Label > Copy Label

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Copy Label
Command ...... SCLABELCOPY
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Copy Label (page 158)

Lets you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of the 
selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label. 

Label > Label All

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label All
Command ...... SCLABELALL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Label All (page 157)

Generates labels for all new BOM items and places them on the _ANNOTATION layer. 

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

When label tracking is on, even though labels are placed in paper space, they now track the objects in model space so 
that if the user pans, zooms, or orbits in the viewport, the labels track accordingly and remain synchronized to the objects 
that they represent.

Label > Label Current Layout

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Auto Label Layout
Command ...... SCLABELLAYOUT
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Label Current Layout (page 158)

Automatically labels parts from the current viewport and places them on the _ANNOTATION layer.

New labels are only generated if they are missing from the viewport. 

Label > Label Viewports

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label Viewports
Command ...... SCLABELVIEWPORTS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Label Current Layout (page 158)

Automatically labels parts from the selected viewports and places them on the _ANNOTATION layer.
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New labels are only generated if they are missing from the viewport. 

Label > Label Viewports from BOM

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label Viewports from BOM
Command ...... SCLABELVIEWPORTSFROMBOMS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure.......

This command turns on the labeling for the selected BOMs for the selected viewports and labels the parts in the 
viewports.

Label > Label from Parts

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label from Parts
Command ...... SCLABELPARTS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Label from Parts (page 158)

Labels the selected parts from the BOMs associated with the viewport. If no BOM is associated with the viewport then no 
labels will be created. If the current space is paperspace, then the command will switch to tiled model space to select 
parts in model space.

Label > Track Label Positions

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Track Label Positions
Command ...... SCLABELTRACK
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Track Label Positions (page 160)

Setting to control if labels to parts are moved or stretched when panning and zooming in a viewport or the part is moved. 
The setting is saved on the computer so when it is changed it affects all drawings for that user on the computer.

Label > Delete All Labels

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Delete All Labels
Command ...... SCLABELDELETEALL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Deletes all SConLabel objects and leader distribution lines from all layouts. This command is used when complete 
relabeling is needed.
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Label > Delete Labels in Current Layout

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Delete Labels in Current Layout
Command ...... SCLABELDELETELAYOUT
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Deletes all SConLabel objects and leader distribution lines from the current layouts. This command is used when 
complete relabeling is needed.

Label > Label on Visible Edge On/Off

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label on Visible Edge On/Off
Command ...... SCLABELONVISIBLEEDGE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Set Up Labeling Settings (page 147)

Turns labels automatic label generation from label to piecemark to label on visible part edge.

By default the project setting is used Production Drawings > Automatic Labeling > Labels point to visible edges.
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Label > Curved Plates in Visible Edge Detection On/Off

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Curved Plates in Visible Edge Detection On/Off
Command ...... SCLABELREMOVECURVEDPLATEHLR
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Curved Plates in Visible Edge Detection On/Off (page 159)

Turns on option to include curved plates in hidden line calculation when label on visible part edge is on.

Label > Adjacent Part Edge Tolerance

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Adjacent Part Edge Tolerance
Command ...... SCLABELADJACENTTOL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Adjacent Part Edge Tolerance (page 159)

Edges will be less likely to be labeled if they are closer than this distance to an edge of another part.

Label > Corner Clearance

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Corner Clearance
Command ...... SCLABELCORNERCLEARANCE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

The closest distance a label’s arrow point can be to the end of an edge of a part when automatic labeling and label on 
visible edge is on.

Label > Edge Determination Minimum Angle

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Edge Determination Minimum Angle
Command ...... SCLABELEDGEDETERMINATIONANGLE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Line segments will be considered part of the same edge if they are less than this angle away from tangent.
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Label > Label Reset Automatic Settings

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Label > Label Reset Automatic Settings
Command ...... SCLABELRESETALL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Label Reset Automatic Settings (page 159)

Resets the automatic label generation settings in the current drawing to use the project settings.

BOM Revisions > New BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > New BOM Revision in Current Layout
Command ...... SCPRODREVNEW
Permissions ... Revisions Add/Edit Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... New Revision (page 165)

Creates a revision in the current layout.

BOM Revisions > New BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > New BOM Revision in All Layouts
Command ...... SCPRODREVNEWALL
Permissions ... Revisions Add/Edit Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... New Revision (page 165)

Creates a revision in all layouts.

BOM Revisions > Delete BOM Revision from Current Layout

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > Delete BOM Revision from Current Layout
Command ...... SCPRODREVDEL
Permissions ... Revisions Remove Permission (page 314)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Delete Revision (page 166)

Deletes the current revision in the current layout.
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BOM Revisions > Delete BOM Revision from All Layouts

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > Delete BOM Revision from All Layouts
Command ...... SCPRODREVDELALL
Permissions ... Revisions Remove Permission (page 314)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Delete Revision (page 166)

Deletes the current revision in all layouts.

BOM Revisions > Delete All BOM Revisions from Current Layout

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > Delete All BOM Revision from Current Layout
Command ...... SCPRODREVCLEAR
Permissions ... Revisions Remove Permission (page 314)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Delete All Revisions (page 166)

Deletes all revisions in the current layout.

BOM Revisions > Delete All BOM Revisions from All Layouts

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > Delete All BOM Revision from All Layouts
Command ...... SCPRODREVCLEARALL
Permissions ... Revisions Remove Permission (page 314)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Delete All Revisions (page 166)

Deletes all revisions in all layouts.

BOM Revisions > List BOM Revisions

Button .............
Ribbon ............ Production tab > BOM panel
Menu ............... BOM Revisions > List BOM Revisions
Command ...... SCPRODREVLIST
Permissions ... None
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... List Revisions (page 166)

List the information about the revisions in the current layout.
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Adjust Leader Spacing

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Adjust Leader Spacing
Command ...... SCCREATEDISTRIBUTIONLINE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Adjust Leader Spacing

Adjust minimum leader spacing setting on the leader distribution line. This setting will be used when Redistribute 
Leaders is used.

Attach to Viewport Tracking

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Attach to Viewport Tracking
Command ...... SCATTDL
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Attach to Viewport Tracking

Viewport tracking allows certain objects to translate in accordance with pan and zoom operations in the viewport.  The 
following objects can be attached to viewport tracking:

• Distribution lines

• ShipConstructor labels (SConLabel)

• AutoCAD leaders

• MText

• AutoCAD Text

• Lines

Create Leader Distribution Line

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Create Leader Distribution Line
Command ...... SCCREATEDISTRIBUTIONLINE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Create Leader Distribution Line

Creates a line that can be used to easily align and move labels as a group. This leader distribution line is a non-printed 
line.
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Set Leader Insertion Mode

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Set Leader Insertion Mode
Command ...... SCDISTLINESETINSERTIONMODE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Set Leader Insertion Mode (page Error! Bookmark not defined.)

Adjusts the insertion mode of all labels on line. The four possible modes are: Left, Right, Center, closest Horizontal. The 
closest horizontal mode will use the left or right alignment depending on which one is closer to the leader point.

Redistribute Leaders

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Redistribute Leaders
Command ...... SCLABELREDISTRIBUTE
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Redistributing Leaders on a Distribution Line (page 178)

Redistribute leaders on the leader distribution line in one of the three distribution modes – Nearest, Center and 
Equidistant. All leaders will be automatically uncrossed and distributed on the line.

Transfer Leaders to Other Line

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Transfer Leaders to Other Line
Command ...... SCTRANSFERLEADERS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting
Procedure....... Transfer Leaders to Other Line

Move leaders from one distribution line to another.

Production Utilities > Insert Keyword

Button .............
Ribbon ............ Production tab > Production Utilities panel
Menu ............... Insert Keyword
Command ...... SCINSERTKEYWORD
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting 
Procedure....... Insert Keyword into a Production Drawing Template (page 140)

Lets you insert a keyword into a production drawing template.
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Keywords
The list of available keywords to place in the HVAC spool template drawing.

Text Style
The selected text style for the keywords selected under Keywords. This is a list of available text styles from within the 
drawing. If you created more text styles using AutoCAD for this drawing, the text styles you created appear in this list.

Text Size
The size of the text. 

Rotation
The rotation of the text.

Note: If a keyword does not seem to update when you have created your spool drawing, your project settings may not 
be fully set up. For example, if you chose <JOB NUMBER> as one of your keywords, and this keyword still shows the 
same text as the template in your generated spool drawing, this means that the project settings for the job number 
have not yet been set. To complete the settings, go to Manager > General > Project Settings.

You can update specific keywords manually by selecting a keyword, right-clicking, and selecting Update from the right-
click menu. 
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Common Keywords
Keyword Description

<COMPANY NAME> Company name from Project Settings

<FILE NAME> The file name only

<FILEPATH> The complete path and file name 

<HULL NUMBER> Hull Number from Project Settings > Reports

<JOB NUMBER> Job Number from Project Settings > Reports

<LAST UPDATE DATE AND TIME> The date and time of the last update of this drawing. The value is 
formatted using the region settings on the computer.

<LAST UPDATE DATE> The date of the last update of this drawing. The value is formatted 
using the region settings on the computer.

<PROJECT DESCRIPTION> Project Description from Project Settings > Reports

<PROJECT  NAME> Project Name from Project Settings > Reports

<REVISION DATE AND TIME> The date and time of the last revision for the layout the keyword is on.
The value is formatted using the region settings on the computer.

<REVISION DATE> The date of the last revision for the layout the keyword is on. The value 
is formatted using the region settings on the computer.

<REVISION DESCRIPTION> The description entered for the last revision for the layout the keyword 
is on.

<REVISION NAME> The name entered for the last revision for the layout the keyword is on.

<REVISION OPERATION DATE AND TIME> The date and time of the last operation (revision added, drawing 
updated) for the layout the keyword is on. The value is formatted using 
the region settings on the computer.

<REVISION OPERATION DATE> The date of the last operation (revision added, drawing updated) for 
the layout the keyword is on. The value is formatted using the region 
settings on the computer.

<REVISION OPERATION USER> The user name of the last operation (revision added, drawing updated) 
for the layout the keyword is on.

<REVISION USER> The user name of the revision for the layout the keyword is on.

<USER> The current user name

Keywords for Arrangement Template Drawings
Keyword Description

<ASSEMBLY CGs> The Center of Gravity of each assembly source for the 
arrangement drawing. A row for each assembly will be 
shown. The rows are sorted by the name of the assembly.
The value will be N/A when the drawing has no assembly 
sources. Each center of gravity is shown as lcg, tcg, vcg.

<ASSEMBLY LEVELS> The level (rank) name of each assembly source for the 
arrangement drawing. A row for each assembly will be 
shown. The rows are sorted by the name of the assembly. 
The value will be N/A when the drawing has no assembly 
sources.

<ASSEMBLY NAMES> The name of each assembly source for the arrangement 
drawing. A row for each assembly will be shown. The 
rows are sorted by the name of the assembly. The value 
will be N/A when the drawing has no assembly sources.

<ASSEMBLY {User Defined Attribute}s> The user defined attribute value of each assembly source 
for the arrangement drawing. A row for each assembly 
will be shown. The rows are sorted by the name of the 
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assembly. The value will be N/A when the drawing has no 
assembly sources. One keyword for each User Defined 
Attribute.

<FULL ASSEMBLY NAMES> The full path of the assembly tree that this assembly 
belongs to of each assembly source for the arrangement 
drawing. A row for each assembly will be shown. The 
rows are sorted by the name of the assembly. The value 
will be N/A when the drawing has no assembly sources.

<SHORT ASSEMBLY NAMES> The name of the assembly and its direct parent of each 
assembly source for the arrangement drawing. A row for 
each assembly will be shown. The rows are sorted by the 
name of the assembly. The value will be N/A when the 
drawing has no assembly sources.

Keywords for Assembly Template Drawings
Keyword Description

[Product Hierarchy] <LEVEL : {Assembly Level}  
ASSEMBLY NAME>

The level (rank) name of the assembly in every build 
strategy. A keyword is available for each level in all 
product hierarchies.

[Product Hierarchy] < {User Defined Attribute}> User Defined Attributes of the assembly in every product 
hierarchy. A keyword exists for each user defined 
attribute.

<ASSEMBLY CG> The Center of Gravity of the assembly

<ASSEMBLY LCG> Longitudinal component of the Center of Gravity of the 
assembly

<ASSEMBLY LEVEL> The level (rank) name of the assembly

<ASSEMBLY NAME> The name of the assembly

<ASSEMBLY PROPERTIES> The level name, weight, center of gravity, and finishes of 
the assembly

<ASSEMBLY TCG> The transverse component of the Center of Gravity of the 
assembly

<ASSEMBLY VCG> The vertical component of the Center of Gravity of the 
assembly

<ASSEMBLY WEIGHT> The total weight of the assembly

<FULL ASSEMBLY NAME> The full path of the assembly tree that this assembly 
belongs to

<SHORT ASSEMBLY NAME> The name of the assembly and its direct parent

Keywords for Spool Template Drawings
Keyword Description

<ASSEMBLY {User Defined Attribute}> User Defined Attributes of the primary product hierarchy 
assembly the spool is assigned to. A keyword exists for 
each user defined attribute.

<SPOOL ASSEMBLY> The immediate assembly the spool is assigned to.

<SPOOL BRANCH> The branch of the system the spool belongs to.

<SPOOL CG> The Center of Gravity point of the spool.

<SPOOL FINISHES> The finishes assigned to the spool.

<SPOOL FULL ASSEMBLY NAME> The entire assembly chain from the project down to the 
spool’s assembly.
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<SPOOL FULL SYSTEM> The Spec / System / Branch of the spool.

<SPOOL LCG> The longitudinal component of the Center of Gravity point 
of the spool.

<SPOOL NAME> The name of the spool.

<SPOOL PROPERTIES> The rank, immediate assembly, weight, center of gravity 
point, and finishes.

<SPOOL SHORT ASSEMBLY NAME> The spool assembly and its direct parent assembly.

<SPOOL SPEC> The spec that the spool belongs to.

<SPOOL SYSTEM> The system that the spool belongs to. See Spool Branch 
keyword for the Systems’ branch.

<SPOOL TCG> The Transversal component of the Center of Gravity point 
of the spool.

<SPOOL VCG> The Vertical component of the Center of Gravity point of 
the spool.

<SPOOL WEIGHT> The total weight of the spool.

<{User Defined Attribute}> User Defined Attributes of the spool, one keyword for each 
UDA

Keywords for Pipe Spool Template Drawings
Keyword Description

<PIPE SPOOL CLASS> The class of the system that the spool belongs to.

<PIPE SPOOL RELATIVE DENSITY> The relative density of the system that the spool belongs 
to.

<PIPE SPOOL TEST METHOD> The Test method of the system that the spool belongs to.

<PIPE SPOOL TEST PRESSURE> The Test pressure of the system that the system belongs 
to.

Keywords for HVAC Spool Template Drawings
Keyword Description

<HVAC SPOOL AIR FLOW> The air flow of the system that the spool belongs to.

Keywords for Pipe Support Construction Template Drawings
Keyword Description

<Support CG> The Center of Gravity of the support.

<Support Full Assembly Name> The full name of the assembly that the support is assigned 
to, in the primary product hierarchy.

<Support LCG> The Longitudinal component of the Center of Gravity point 
of the support.

<Support Name> The name of the support.

<Support TCG> The Transversal component of the Center of Gravity point 
of the support.

<Support Template Type> The template type of the support.

<Support Template> The template name of the support.
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<Support VCG> The Vertical component of the Center of Gravity point of the 
support.

<Support Weight> The combined weight of all the component parts for a 
support.
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Plate Nest Template Drawings
Keyword Description

<NEST AREA> Area of the nest

<NEST CUT DISTANCE> Combined distance of all cuts made

<NEST CUT FEED> Cutting speed of the NC Machine used

<NEST DATE> Date of creation. The value is formatted using the region settings on the 
computer.

<NEST ESTIMATED TIME> Estimated time to cut and mark this nest, based on cut/mark/fast feeds 
and distances, and piercing time.

<NEST EXPORT DATE> Date when the nest was exported. The value is formatted using the 
region settings on the computer.

<NEST EXPORT TIME> Time when the nest was exported. The value is formatted using the 
region settings on the computer.

<NEST EXPORT USER> The user who exported the nest

<NEST FAR FINISHES> Common finishes for far side markings

<NEST FAST FEED> Fast travel speed of the NC Machine used

<NEST FAST TRAVEL DISTANCE> Combined distance of all fast travel made

<NEST FINISHES> Common finishes for both far and mark side

<NEST HEAT NUMBER> Heat number of the plate stock used

<NEST ISSUE DATE> Date when the nest was issued. The value is formatted using the region 
settings on the computer.

<NEST ISSUE TIME> Time when the nest was issued. The value is formatted using the region 
settings on the computer.

<NEST ISSUE USER> The user who issued the nest

<NEST LENGTH> Length of the nest

<NEST LIKE/MIRROR> The LIKE alias if a single nest, or the LIKE/MIRROR alias if a Like/Mirror 
nest

<NEST MARK DISTANCE> Combined distance of all markings made

<NEST MARK FEED> Marking speed of the NC Machine used

<NEST MARK FINISHES> Common finishes for mark side markings

<NEST NAME> Name of the nest

<NEST NCCODE GENERATE DATE> Date when the nest’s NCCode was generated. The value is formatted 
using the region settings on the computer.

<NEST NCCODE GENERATE TIME> Time when the nest’s NCCode was generated. The value is formatted 
using the region settings on the computer.

<NEST NCCODE GENERATE USER> The user who created the nest’s NCCode

<NEST NCCUT DATE> Date when the nest was cut. The value is formatted using the region 
settings on the computer.

<NEST NCCUT TIME> Time when the nest was cut. The value is formatted using the region 
settings on the computer.

<NEST NCCUT USER> The user who cut the nest

<NEST NC-MACHINE NAME> Name of the NC Machine used

<NEST NUMBER OF PIERCES> Amount of pierces on the nest

<NEST PART AREA> Area of all parts assigned to the nest

<NEST PART WEIGHT> Weight of all parts assigned to the nest

<NEST REMNANT LIST> Lists of all remnants created from this of the nest
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<NEST REMNANT NAME> Name of the remnant this nest was created from

<NEST REMNANT WEIGHT> Weight of all remnants created from this nest

<NEST SCRAP UTILIZATION> Percentage of the area that is not parts over the area of the item used to 
create the nest

<NEST SCRAP WEIGHT> Remaining weight after subtracting part and remnant weight from the 
nest stock weight

<NEST SIZE> Length x Width of the nest

<NEST STOCK AREA> Area of the item used to create the nest 

<NEST STOCK LENGTH> Length of the item used to create the nest

<NEST STOCK NAME> Name of the item used to create the nest (remnant name if created 
from a remnant, or the plate stock name if created from raw stock)

<NEST STOCK PLATE LOCATION> Indicator keyword for the location of the stock plate in the nest template 
drawing

<NEST STOCK SIZE> Length x Width of the item used to create the nest

<NEST STOCK UTILIZATION> Percentage of the area that is parts and remnants over the area of the 
item used to create the nest

<NEST STOCK WEIGHT> Weight of the item used to create the nest

<NEST STOCK WIDTH> Width of the item used to create the nest

<NEST TIME> Time of creation. The value is formatted using the region settings on the 
computer.

<NEST USER> The user who created the nest

<NEST UTILIZATION> Percentage of the area of all parts over the area of the item used to 
create the nest

<NEST WEIGHT> Weight of the nest

<NEST WIDTH> Width of the nest

<PLATE STOCK AREA> Area of the original plate stock

<PLATE STOCK LENGTH> Length of the original plate stock

<PLATE STOCK MATERIAL> Material of the original plate stock

<PLATE STOCK NAME> Name of the original plate stock

<PLATE STOCK SIZE> Length x Width of original plate stock

<PLATE STOCK THICKNESS> Thickness of the plate stock used

<PLATE STOCK WEIGHT> Weight of the original plate stock

<PLATE STOCK WIDTH> Width of the original plate stock
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Profile Plot Template Keywords
Keyword Description

<CUTOUTS> The upper left corner of the table of cutouts

<ENDCUT_END> The endcut at the end of the stiffener

<ENDCUT_START> The endcut at the start of the stiffener

<FLANGE_POSITION> The lower left 

<INVERSEBENDS_POSITION> The lower left corner of the inverse bend view

<MATERIAL> The material and grade of stock for the parts in the plot

<MIN_HEIGHT> The minimum height for the offsets dimensions used in 
the offsets view

<OFFSETS_POSITION> The lower left corner of the offsets view

<OFFSETS_SPACING> The offsets spacing value used to dimension the offsets 
view

<PLOT_UNIT> The common unit of the parts in the plot. If the parts 
belong to different units then ‘Varies’ will be displayed

<PROFILE_POSITION> The lower left corner of the profile cross-section view

<SCALE> The scale of the plot relative to the full size stiffener

<STOCK_DESC> The Description field of the stock for the stiffeners in the 
plot

<STOCK_NAME> The stock name of the stiffeners in the plot

<TRIM_E_FLG> The trim on the stiffener’s end flange

<TRIM_E_WEB> The trim on the stiffener’s end web

<TRIM_S_FLG> The trim on the stiffener’s start flange

<TRIM_S_WEB> The trim on the stiffener’s start web

Profile Plot Sheet Template Keywords
Keyword Description

<PART_LIST> A list of parts that are in plots in this sheet.

<PLOT_DATE> The date and time the sheet was created or last updated. 
The value is formatted using the region settings on the 
computer.

<PLOT_SCALES> The common scale of the plots for this sheet. If the 
scales are different then ‘Varies’ will be displayed.

<SHEET_NAME> The name of the profile plot sheet

<SHEET_UNIT> The common unit of the parts in the plot. If the parts 
belong to different units then ‘Varies’ will be displayed.
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Update from a Previous Version

Button .............
Ribbon ............ Production tab > Production Utilities
Menu ............... Update from a Previous Version
Command ...... SCUPDATEPREVIOUSTEMP
Permissions ... None
License............ None

Develop Product Hierarchy

Button .............
Ribbon ............ Production tab > Main
Menu ............... Develop Product Hierarchy
Command ...... SCPRODUCTHIERARCHY
Permissions ... None
License............ Universal or ProductHierarchy
Procedure....... Product Hierarchies (page 94)

Opens the Product Hierarchy window, letting you setup assembly levels and assemblies and assign parts to assemblies.
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Labeling > Global Dimension to Point

Button .............
Ribbon ............ Production tab > Labeling panel
Menu ............... Global Dimension to Point
Command ...... SCDISTANCEFROMPOINT
Permissions ... Edit Production Drawing Permission (page 313)
License............ None
Procedure....... Global Dimension to Point (page 135)

Indicates the distance from selected planes to a given point as a label or a dimension.

Editing the Text
The text displayed for the Global dimensions can be customized to display words or specific keywords.  

The available keywords are:

• Distance – The distance in the current units between the selected point and the plane.

• Direction To – The direction from the point to the plane.
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• Direction From – The direction from the plane to the point.

• +/- To – Positive if the plane point is greater than the picked point in the given direction, otherwise negative.

• +- From - Negative if the plane point is greater than the picked point in the given direction, otherwise positive.

• UCS Name – The name of the UCS being used.

To edit the text for a global dimension first select the global dimension type Dimension or Label. The preview window will 
update to display the appropriate text. Then click the edit button. The preview window will change to display the keywords 
and text used to generate the global dimensions and a box with the available keywords will appear on the side. To add a 
keyword to the text place the cursor where the keyword should be inserted and then double click on the keyword in the 
list. Regular text can also be placed anywhere in the text. To delete a keyword, highlight the keyword and press the 
backspace button. To finish editing press the edit button again. This will close the keyword list and the preview will 
change to display the appropriate text.

The default button will place a default text in the preview box; the default text is Distance DirectTo UCSName.
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To allow for multiple types of keywords to be used; the global dimension styles can be saved out. The style will save the 
global dimension type, the label or dimension style, and the keywords used. To save a style, click the Save Global 
Dimension Style button. Enter a name for the style in the dialog that is displayed and click OK. To load the style back, 
click the Load Global Dimension Style button. The list of stored styles will appear on the right side of the dialog. Double 
click on the appropriate style and the stored values will be loaded. To delete a saved style, click the Delete Global 
Dimension Style button. The list of available styles will be displayed, select the style to delete and click the Delete Global 
Dimension Style button. Click OK to confirm the deletion of the style.

To select the planes closest to the selected point click the Select Closest Planes button. The planes closest to the point 
will be selected and all other previously selected ones will be unselected.

The UCS’s called also be saved as datum planes. These datum planes are used to store a UCS in each direction so that 
they can be easily reloaded and used for MOC 20other global dimensions. To store a UCS as a datum plane, check the 
plane in the grid to use as datum planes, right click on the grid and select Save as Datum Plane. To reload the datum 
planes click the Select Datum Planes button.

Property Label > Property Label

Button .............
Ribbon ............ Production tab > Property Label panel > Property Label
Menu ............... Property Label > Property Label
Command ...... SCOBJFIELDLABEL
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Inserts a leader containing a field. The fields are a list of properties from a selected part.

Property Label > Copy Field Label

Button .............
Ribbon ............ Production tab > Property Label panel > Copy Field Label
Menu ............... Property Label > Copy Field Label
Command ...... SCFIELDLABELCOPY
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Copies fields from one leader and creates new leader for another part.

Property Label > Copy Field Label Quick

Button .............
Ribbon ............ Production tab > Property Label panel > Copy Field Label Quick
Menu ............... Property Label > Copy Field Label Quick
Command ...... SCFIELDLABELCOPYQUICK
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Copies mtext block and creates new leader using original leader geometry.  Also allows user to select new item to change 
the object references within the fields.
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Property Label > Edit Field Label

Button .............
Ribbon ............ Production tab > Property Label panel > Edit Field Label
Menu ............... Property Label > Edit Field Label
Command ...... SCEDITFIELD
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Select mtext and edit the text and fields.

Property Label > Replace Object References

Button .............
Ribbon ............ Production tab > Property Label panel > Replace Object References
Menu ............... Property Label > Replace Object References
Command ...... SCREPLACEOBJREFINFIELD
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Select mtext and then select new object to point the fields to.

Property Label > Set Single Click Field Label

Button .............
Ribbon ............ Production tab > Property Label panel > Set Single Click Field Label
Menu ............... Property Label > Set Single Click Field Label
Command ...... SCSETSINGLECLICKFIELDLABEL
Permissions ... Edit Production Drawing Permission (page 313) or edit model drawing if in model drawing
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Toggles the ShipConstructor variable that determines whether first leader pick point is acquired by when the object is 
selected, or whether it is determined by separate point selection.

Label Connecting Assembly

Ribbon ............ None
Menu ............... None
Command ...... SCCONASSEMBLY
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Creates a label for an end of a pipe or HVAC that indicates the connecting assembly to the end similar to Label 
Connecting Spool.

Purge BOMs

Ribbon ............ None
Menu ............... None
Command ...... SCPURGEBOMS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

This immediately purges erased BOMs from the drawing. Normally it takes opening and closing the drawing twice to 
permanently remove all references to BOMs after the last table has been erased for a BOM.
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Clear All BOMs

Ribbon ............ None
Menu ............... None
Command ...... SCCLEARALLBOMS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

This immediately erases all references to BOM definitions yet leaves the current BOM tables intact.

Unlink All BOMS

Ribbon ............ None
Menu ............... None
Command ...... SCCUNLINKBOMS
Permissions ... Edit Production Drawing Permission (page 313)
License............ Universal, Structure, Pipe, HVAC, Equipment, Electrical, or MarineDrafting

Removes linked BOM references. Note that auto-linked BOMs will have their linkages reinstated the next time a BOM is 
inserted into the drawing.
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