
User’s Guide

                                          CD Library II Software
                                                 for Windows XP and Vista

CD Library II 4.0 Software
CD Library software for CD Library products



Important Information for Owners of CD Library 
product

NOTE: If you own a CD Library product, refer to the installa-
tion manual that came with your product for relevant 
warnings, cautions, maintenance and cleaning instructions.

Safety Warnings and Precautions

Warning: To reduce the risk of fire or electric shock, 
do not expose the CD Library product to rain or mois-
ture.

For operating safety and to avoid damage, carefully read and 
observe these instructions:

• Read the guide that came with your product carefully, 
familiarizing yourself with all warnings and cautions.

• You must connect the USB cable that came with your CD 
Library product to a computer that has a USB-compliant 
port and that bears the USB logo. This is for operating 
safety and to avoid damage to the CD Library product.

• Avoid setting up and using the CD Library product in an 
area with excessive levels of dust, humidity and smoke.

• Avoid leaving cables on the floor. If you must run a cable 
over the floor, lay the cable in a flat, straight line, and 
secure it to the floor with tape or a cable management 
strip in a contrasting color. Handle cables carefully and 
avoid excessive bending. 
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CHAPTER 1 Overview

About CD Library
CD Library software is a powerful CD catalog/CD database 
software for managing your CD/DVD collection for all win-
dows platforms.

The CD Library software allows you to organize not only by 
title, database location, media category, but also by media 
category. 

Through the easy-to-use interface, you can you load and 
personalize metadata tags and create customized, easy-to-
access library databases as simply as inserting CDs in your 
CD Library device (see the following figure). 

FIGURE 1. CD Library II DC-300

Features
• Powerful management tool

• Friendly and simple operation

• Retrieve CDs quickly and accurately

• Categorize your CDs into media type

• Simple and advanced searching

• Supports multiple formats: Data CD’s, Audio CD’s, DVD-
Video’s, Video CD’s
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CHAPTER 2 Getting Started

Before You Begin
CD Library II software not only supports Windows XP Home 
and Pro, but also Windows XP x64 edition and Windows Vista 
(32bit and 64bit). 

Read the following information for installation requirements:

Requirements
• Operating system: Windows XP/Vista

• Minimum memory size: 128MB

• CD Library product
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CHAPTER 3 Installing the CD Library 
Software

Prior to installing the software perform the following:

• Connect the CD Library device to a power source and a 
USB port of the computer.

• Insert the CD Library II software CD to begin your 
installation.

Installing the Software

After placing the CD Library software in the CD-ROM drive, 
the CD Library installation screen displays.

FIGURE 2. CD Library Installation screen
1. Select Install 4.0.
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The Installer Language screen displays.

FIGURE 3. Language screen
2. Select the desired language and then click OK to 

continue.

The Welcome to the CDLIB 4.0 Setup Wizard screen 
displays.

FIGURE 4. CDLIB 4.0 Setup Wizard screen

3. Click Next to continue.
The Choose Components screen displays. 
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FIGURE 5. Choose Components screen
4. Select CDLIB.
5. Click Next to continue.

The Choose Install Location screen displays.

FIGURE 6. Choose Install Location screen
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The default destination folder is C:\Program Files\CDLIB.

6. Click Install.

The Installing screen displays indicating that CD Library II 
installation is in progress.

FIGURE 7. Installing screen
7. When complete, click Next to continue.

The Registry Editor screen displays.

FIGURE 8. Registry Editor screen
8. Click Yes to store the settings and options in the 

database.

The Completing the CDLIB 4.0 Setup Wizard screen 
displays.
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FIGURE 9. Completing the CDLIB 4.0 Setup Wizard screen
9. Click Finish to run CDLIB 4.0.

The Add new machine CD LIBRARY 300 screen displays.

FIGURE 10. Add new machine screen
10. Enter the machine name.

For example: As seen in Figure 10, the machine 
number is 22139.

11. Click OK.
Installation is now complete. For more information 
on using the CD Library II see Basic Operations on 
page 8 in the following section. 
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Basic Operations
There are several ways to run your CD Library II 4.0 
software. 

• Double-click or right-click and open, on the CDLIB short-
cut located on the desktop. The icon is as seen in the 
figure below.

FIGURE 11. CDLIB icon
Or

• Navigate to Start, click All Programs go to CDLIB and
then select CDLIB.

Or

• Navigate to C:\Program Files\CDLIB to execute 
CDLIB.exe directly.
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CHAPTER 4 Using CD Library

Understanding the Interface
The following screen provides a brief definition of the various 
menu elements for the Graphical User Interface (GUI), which 
includes the Menu Bar, the Tool Bar, the Main Database
Area, and the Tree Directory.

FIGURE 12. CD Library UI screen

 Menu Bar Tool Bar

Main Database Area

     

Tree Directory

Status Line
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Menu Bar

FIGURE 13. Menu Bar
The Menu Bar as indicated in FIGURE 13. contains the 
following functions:

• File: Restore and backup databases, and print functions. 
See Using the File Menu on page 17.

• Function: Power on/off and reset functions. See Using the 
Function Menu on page 24.

• System Setting: System setup, setting password and 
swap machine ID functions. See Using the System Setting 
Menu on page 24.

• Help: Online help function. See Using the Help Menu on 
page 28.

Tool Bar

FIGURE 14. Tool Bar
The Tool Bar as indicated in FIGURE 14. contains the fol-
lowing functions:

•  Backup: Saves database to allocated drive.

•  Restore: Restores database for use.

•  Add New Disc: Adds new disc entry to library.

•  Add New Category: Adds new category to library.

•  Advanced Search: Search function with advanced 

options.
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•  Insert/Retrieve Disc: Ejects and inserts disc into 

device.

•  Delete: Removes data entry from library.

•  Print: Provides a print out of library entries.

•  Display: Displays entries by detail, icon and list in 

Main Database Area.

•  Mode: View Tree Directory in category or 

machine display.

•  Exit: Close CD Library software.

For detailed information regarding the usage of the Tool Bar
menu, see Using the Tool Menu on page 29.

Main Database Area
Select an item in the Main Database Area and right-click to 
view the following sub-menu options as seen in the following 
figure.

FIGURE 15. Main Database Area screen

• Edit Title: Edit the disc title.

• Remove Disc: Remove the disc from the library. A Con-
firm screen displays, Click OK to delete current data.

• Insert/Retrieve: Insert or retrieve a disc from the CD 
Library device.

• Print: Print the disc titles in an excel format.The Print
Management screen displays. Click Print.
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• Edit: Edit the disc title information. For example, the user 
can delete and add another Image for a disc (as seen in 
FIGURE 16. ).

FIGURE 16. Edit screen

Status Line
The Status Line as seen in FIGURE 12. shows the status of 
the following items (for display only):

FIGURE 17. Status Line screen

• ID: Displays the unique machine ID embedded inside the 
IC chip.

• ID NAME: Displays the ID number of the product 
connected to the computer.

• SLOT: Displays the slot number of the disc.
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Tree Directory
The tree directory as seen in FIGURE 12. allows the user to 
add, search, rename, and delete a disc. Right-click to view 
the submenu options as explained in the tables below. 

FIGURE 18. Tree Directory screen

Tree Root level

Item Description Refer to

Add New Category To add a new category Page 29

Advanced Search To search for a disc with
advanced options

Page 32

Table 1: ALL DATA

Tree Root level

Category level

Disc level
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Category level

Disc level

Item Description Refer to

Add New Disc To add a new disc Page 30

Rename To rename a disc      -

Delete Category To delete a category      -

Advanced Search To search for a disc with
advanced options

Page 32

Table 2: Category

Item Description Refer to

Insert/Retrieve Disc To get a disc Page 33

Edit Title To edit a disc title Page 11

Remove To delete a disc      -

Table 3: Disc
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Additional Interface Menus
Additional Interface menus are located below the Tree Direc-
tory menu. The additional menus include: Image, Data and 
Remark. The three types of categories are seen in FIGURE 
12.

Image
Select the image tab to view the uploaded image of a partic-
ular entry.

FIGURE 19. Image screen

Data
Select the Data tab to display the disc information of a par-
ticular entry. 

FIGURE 20. Data screen
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The following information can be found in the Data tab

• CD Title: Displays the CD title that you entered while 
adding a new disc.

• Library: Displays the unique machine ID number.

• Category: Displays the category the disc belongs. For 
example Music, Software, VCD, DVD.

• Location: Displays the slot number of the disc inserted in 
the CD Library.

• Volume Name: Displays the volume name of the disc.

• Serial Number: Displays the serial number of the disc.

• Barcode: Displays the barcode of the disc.
• Other: Displays the information entered while adding a 

new disc.

Remark
As seen in the figure below, the Remark tab displays a list of 
songs for a music CD.

FIGURE 21. Remark screen
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CHAPTER 5 Managing CD Library

The menu options in the Menu Bar are described in detail in 
this chapter. See FIGURE 12. for reference.

Using the File Menu
As shown in the figure below, the File tab in the Menu Bar
has four functions in the CD Library:

FIGURE 22. File screen

Databases
A database is your personal collection of information stored 
in a library format. There are two types of database formats 
supported by CD Library software:

• 3.5 database (DB)

•  4.0 database (MDB)

The default destination is C:\Program Files\CDLIB once
the CD Library II is installed.
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Backup Database
As an Administrator you can backup your database to any 
drive. An appropriate backup destination is D:\ or 
C:\Program Files\CDLIB\Backup.Follow the steps below to 
backup your database.

1. Navigate to File in the Menu Bar and select Backup
Database. A dialog box displays as shown in the 
figure below.

FIGURE 23. Backup MDB screen
2. Select D:\ from the drop down list and then select 

Backup. A file called CDLIB.MDB is generated.
3. Click OK and confirm to replace old data.

Note: A new CDLIB.MDB file is generated every time you 
backup new data.
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Restore Database
Select to import and restore a CD Library database.

This feature allows you to import and restore earlier data-
base versions for use with your current product. The func-
tions are listed as follows:

• Import *.DB (3.5 format)

• Import *.MDB (4.0 format)

Importing a 3.5 Database (.DB)
1. To upgrade from version 3.5 to 4.0, navigate to 

File>Restore Database>Import.DB.
2. In the library folder 

(C:\Program Files\CD Library\DBF), select the 
CDLIB.DB to import the earlier database (see following 
figure).

FIGURE 24. Import Database screen (*.DB)
Note: The 3.5 format is not supported by Vista and XP 64bit 
OS systems. Importing of a 3.5 database formats must be 
accomplished through the use of a 32bit OS system.
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Importing a 4.0 Database (.MDB)
In order to import a database *.MDB, follow the steps below:

1. If CD Library II 4.0 is installed, then CDLIB.MDB is 
created in C:\Program Files\CDLIB.

2. Navigate to File> Restore Database and then click 
Import*.MDB.

The Import MDB screen displays as seen in FIGURE 25.

FIGURE 25. Import MDB screen
3. Select C:\ (where c: is your destination drive) from the 

drop-down list.
4. Click OK to import CDLIB.MDB. 

A CDLIB file is generated in 
C:\Program Files\CDLIB\Backup.
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User Privileges
These privileges are for Microsoft Vista users only. 

For regular users, Windows Vista is a safer and more secure 
operating system than other Windows versions. 

As a normal user, you can only backup your database only in 
C:\Program Files\CDLIB\Backup.

As an administrator, you can backup databases to any drive 
other than C:\Program Files\CDLIB.

Using the Software
Follow the steps below to run the software as an 
administrator:

1. Right click on the CD Library icon on the desktop, and 
select Properties.

FIGURE 26. Run as administrator screen



CD Library II 4.0                             22

The CDLIB properties screen displays as seen in FIGURE 27.

FIGURE 27. Compatibility screen
2. In the Compatibility tab, choose Run this program as 

an administrator.
3. Click Apply to accept the settings.
4. Click OK to run the software as an administrator.
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Print Management
The print options for the CD library are:

• Select ALL DATA from the tree directory and then click

 to print.

or

• Select any category from the Tree Directory, example: 

Category DVD, and then click  to print.

or

• Navigate to File in the Menu Bar and then select Print.
The Print Management screen as seen below displays 
for all the above options. Click Print.

FIGURE 28. Print Management screen
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Using the Function Menu
As shown in the figure below, the Function tab in the Menu
Bar contains three options:

FIGURE 29. Function screen

Power On 
Select Power On to power on the CD Library device.

Power Off
Select Power Off to power down the CD Library device.

Reset
Select Reset to reset the CD Library device.

Using the System Setting Menu
The System Setting menu allows for system configuration 
including: language, main font, e-mail settings, host 
address, retrieve disc log, set password, and swap machine 
IDs.

FIGURE 30. System Setting screen
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Configuring System Setting
To configure the system settings, follow the steps below.

1. Click System Setting from the Menu Bar and then 
select System Setting.

The Setup dialog box displays.

FIGURE 31. Setup screen
2. Open the Language drop-down list and select the 

desired language (default is English). 

Note: For other languages see the following guidelines:

• Navigate to C:\Program Files\CDLIB\Language

• Open Language.eng, erase English and enter the lan-
guage name of your choice, for example: German or 
French.

• Save the file as Language.ger or Language.fre

• In the setup screen (see Figure 31. Setup screen), select 
the corresponding language.

3. Click Setup Font to define the default of the user inter-
face.
Selections available: Color, font size, and font style.

4. E-mail Setting: The default e-mail setting, is CDDB 
(Compact Disc Database) or FreeDB.
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• CDDB/FreeDB: is a database for software applications to 
lookup audio CD information over the internet. 
For example: Artist name, CD title, track list and other 
additional information.

5. Host Address: The default e-mail setting, is for CDDB or 
FreeDB.

6. Retrieve Disc Log: Select this radio button to log 
retrieve/insert entries. The following screen displays 
prompting the user to enter the reason for retrieving or 
inserting.

FIGURE 32. Insert Retrieve Disc screen
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• When Retrieve Disc Log is checked, the Record option 
in the tree directory provides further information about 
the log entries.

FIGURE 33. Tree Directory: Record screen

• Machine List: This field displays the list of CD Library 
devices connected to the computer.

7. Click Save to save your settings.

Setting a Password
1. Navigate to System Setting in the Menu Bar and then 

click Password to enter your password. The Password
screen displays as shown below.

FIGURE 34. Password screen
2. Type new password and re-enter to confirm the 

password.
3. Click OK to save the password settings.
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Swap ID
The CD Library device has a unique ID that lets you store 
CD/DVD information in the database. Navigate to System 
Setting and then select Swap ID to swap IDs between 
machines.

FIGURE 35. Swap ID screen

Using the Help Menu
Online help is provided for users of the CD Library software.

By clicking on the Help menu, further information about the 
CD Library 4.0 and usage of the software is available.

FIGURE 36. Help Menu
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Using the Tool Menu
Adding a New Category
To add a new category in the CD Library follow the steps 
below:

1. Click in the Tool Bar and a New category is cre-

ated in the tree directory.
2. Right-click on the New category to view the following 

options:

• Add New Disc: Add a new disc to the category.

• Rename: Rename the category.

• Delete Category: Delete the category.

• Advanced Search: Search tab with advanced options.
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Adding a New Disc
Prior to adding a new disc make sure to insert the disc in the 
CD Library device.

1. To add a new disc, click in the Tool Bar.

The Add New Disc screen displays.

FIGURE 37. Add New Disc screen
2. Update the appropriate fields as desired.

• Machine Name: Select the machine name from the 
drop-down menu.
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• Slot: The software updates the slot number automati-
cally. If required, select the check box and change the slot 
number.

• Category: Click  to view the drop-down list and 

then double-click to select a category.

• Disc Title: Enter a name for the disc inserted.

• Barcode: Enter the barcode of the CD. The barcode is 
usually located on the reverse of the CD cover.

• Remark: Enter a note or a remark in this field. For exam-
ple, “my favorite CD”.

• Other: Enter any other information about the disc. For 
example, if you lend this CD to a friend, enter the date 
and the name of your friend in the field.

• Image: Click Select File and browse to the respective 
image to be inserted. Click Delete to remove the Image 
selected.

• Drives: The software updates the drive information. Use 
the default value or select an alternate drive from the list.

• Retrieve Disc Information: Select the check box to 
retrieve disc information.

• Get CDDB: Retrieve CDDB information from the Internet. 
CDDB is an online-based Compact Disc Database that 
downloads artist names, album titles, track names etc. 
from the internet.

3. Click OK to add the disc.

Note: To Edit disc information right-click on the disc in the 
main database area. See page 11 for more information.
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Search/Advanced Search
Search
Search for disc titles by entering the keyword in the Search 
Data tab and the results are displayed as shown in the 
figure below.

FIGURE 38. Search Data screen

Advanced Search
The Advanced Search as seen in the figure below gives you 
the following options:

FIGURE 39. Advanced Search screen
Enter Search String and select criteria:

• Disc Title

• File Name

• Directory Name

• Remark

• Other

• Barcode
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Insert/Retrieve Disc
To insert or retrieve a disc, the following options are 
available:

• Select the disc from the main database area and then 

click  in the Tool Bar to insert/retrieve a disc.

 or 

• Right-click on the disc in the main database area and 
select Insert/Retrieve.

Note: Right-click on the disc and select Remove Disc to
delete from the CD library.

Display and Mode Options
Display Options
There are three Display options in the Tool Bar: Detail, List 
and Icon.

Click  in the Tool Bar to select the options from the 

drop-down list. 

• Detail: Click  from the Display drop-down list to 

view the data in detail display. The Disc Title, Machine
Name, Slot, and Category are displayed in the main 
database area as seen in the figure below.

FIGURE 40. Detail screen
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• List: Click  from the Display drop-down list to view 

the data in list display

FIGURE 41. List screen

• Icon: Click  from the Display drop-down list to 

view the data in icon display.

FIGURE 42. Icon screen

Mode Options
There are two mode options for the CD Library: Category 
and Machine. 

Click  to view the drop-down list options.

• By Category : displays the tree directory by media 

category.

• By Machine : displays the tree directory by machine 

numbers.
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