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Chapter 1 Introduction

1.1 The Benefit to Virage Logic Customers

Integrator Online ™ provides you access to the functionality of Virage Logic's Embed-1t!® Integrator
software. If you are a System-on-a-Chip designer evaluating Virage Logic Products, you can generate
memory instances and study the trade-offs between memory-core types and variants. You can thus
make better decisions about the suitability of Virage Logic intellectual property for inclusion in your
designs. If you are adesigner considering Virage Logic's Compiler Tools, you can use the software
without having to install it on your own computers.

Integrator Onlineis available both as a client-side Java application deployed using Sun's Java™ Web
Start technology and a browser-based tool. The interface of the browser-based and client-side Java
versions of Integrator Online are almost identical to each other, and also very similar to Embed-It®
Integrator. However, the client-side Java version of the tool has many features that make the usage,
customization and generation of memory instances as easy as possible. Hence, it is recommended that
you use the client-side Java application instead of the browser-based tool wherever possible. An
Integrator Online command line client is also available for execution and can be used according to
instructions in Chapter 3, “Integrator Online: Command Line Access’ on page 17.

1.2 What You Need to Run Integrator Online™

All you need to be able to run Integrator Online as a client-side Java application is a Java Runtime
Emvironment (JRE) 1.4.2 + and Java™ Web Start software. The Web Start software is available free
of charge at http://java.sun.com/products/javawebstart/. The default locale for Integrator Onlineis set
to English(US).

To run the browser-based client, you need an active Internet connection and a Java 1.1 enabled
browser. Once a Virage Logic staff member has set up an account for you, you can ssmply go to the
URL they provide you, log in, and start using the tool.
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Chapter 2 Running the Integrator Online

Once your Integrator Online account has been created, you will receive an email from the Integrator
Online Account Administrator providing you with your User Name and IOL Key, aswell asthe
URL s for the browser-based and client-side versions of Integrator Online.

To run the client-side Java version of Integrator Online, simply enter the URL for that version into
any browser window. The application will be downloaded and launched, as shown in Figure 2-1,
“Login Window”. Integrator Online supports HT TPS connection for secure instance generation. Note
that this version runs in a separate window from your browser. Also, note that you must have JRE
1.4.2+ and Sun's Java™ Web Start (JWS) software installed before you run the client-side version of
Integrator Online. In section 1.2, “What You Need to Run Integrator Online™” of this guide, thereis
information on how to obtain the necessary software.
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The next time you use the client-side Java version of Integrator Online, it will launch from the copy
that was downloaded and installed the first time if Integrator Online is not updated on the server, and
it will start up much faster.

Figure 2-1 Login Window

[ d Integrator Online =101 x|
Project Help
VIRAGE
Dﬁu}‘%%( m b | W LOGIC
Flease login
«/|=] 8]
Semver:

User.| | RAGE

0L Key : | |

In the Login Window, enter your user name in the field marked User and your IOL Key in thefield
marked IOL Key and press Login.
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Once you have successfully logged in, the Main window shown in Figure 2-2, “Main Window”

appears:

Figure 2-2 Main Window
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Thiswindow has the menu bar, the toolbar below the menus and the status bar at the bottom. The area
between the toolbar and the status bar is occupied by a three-part window.

» ThereisaProject Tree that appears when you create a new component or import an existing
component into your project. The Project Tree shows the components by their names and
associated views. Indicator “lights’ for each component in the Project Tree provide the status
of each action run on the component. Gray means that the component has not been generated
yet. Green means successful run without Errors or Warnings. Red means Errors/Warnings are

encountered during run.
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* ThereisaViews Areathat shows an output view for a component in the Project Tree.
Highlighting an output view for a component in the Project Tree and double-clicking the

mouse displays the file contents in the Views area. Use the ™ button if you want to show

the Views areaonly and the . button to show Messages and Views windows concurrently.

» ThereisaMessages Areathat displays all information messages that occur when you apply a

command to aproject. Usethe &l putton if you want to show the Messages area only and

the LJ button to show Messages and Views windows concurrently.

—

2.1 Working with Memory Components

Integrator Online application provides you with an easy way to work with memory components. Only
afew successive steps are required to create a new component and generate an output view for it.

To create a new component, you simply select a compiler and start configuring the component by
supplying necessary parameters and data. Information on different memory parameters and data that
you may need to supply during component configuration stage isavailablein section 2.1.1, “Creating
aNew Component”.

Integrator Online also enables you to create components based on existing *.cfg files that contain
component configuration. See section 2.1.2, “Importing a Component” for more details on how you
import a component.

After you configure your component, you must generate it to create an output view for it. See
“Generating a Component” on page 13. The component creation process involves afew formal
procedures that Integrator Online accomplishes automatically. When you generate a component, the
tool automatically sets up aninitial directory structure for the component on the server. When you
attempt to download the filesfor the generated component, theinitial directory structureis preserved.
See “Downloading the Generated Files” on page 14.

At any time during your work, you can consult this User’s Manual for assistance by selecting Help
> User’s Manual from the menu option or by pressing the F1 key on your keyboard.

Page 6 ~ Copyright 1998 - 2011 ~ Virage Logic Corporation ~ Proprietary Information ~ Do Not Duplicate



2.1.1 Creating a New Component

Selecting Component > New menu option ( DéF ) opens the Select Compiler dialog shown in Figure
2-3, “Select Compiler Window” below:

Figure 2-3 Select Compiler Window
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By default, the compilers added to your account by the Administrator are listed by type of compiler.
Integrator Online alows to configure memory and ROM compilers only.

Click on the node handle beside the name of compiler to display the sub-categories of available
compilers. The tree of sub-categoriesis based on compiler identification information including target
foundry (Foundry), process geometry (Process), compiler name (Compiler) and compiler revision
level (Revision). Once you have navigated down to selecting a specific compiler, the Compiler Info
area on the right-hand side of the Configure Compiler dialog displays al the identification
information for the compiler.
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You can also check the Choose by Compiler Name checkbox to list the compilers by name. After you
choose the required compiler, select the Configure button to open the Configure Component dialog
shown in Figure 2-4, “ Configure Component Window” below:

Figure 2-4 Configure Component Window
x|
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The Configure Component dialog can look slightly different for two or more compilers of the
same type, depending on the features available for that compiler.

The general instance parameters to supply are:
e TheNumber of Words in the instance.
e The number of Bits in Word for the memory instance.

e The Column Mux Option (or number of physical columns per 1/0O pin). It provides the set of
valid CM values and identifiers for the various estimated aspect ratios for the compiler. You
can select the CM from the valuesin the pull down list. The options available in the pull down
list will vary depending on the values set for Number of Words and Number of Bits.

* TheFrequency (in MHz) at which the memory instance is to operate.
» Thewrite ports for the memory instance.

* TheRead ports for the memory instance.

e TheNumber of Banks (horizontal banks) for the memory instance.
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e TheNumber of Vertical Banks for the memory instance.
e TheNumber of Bits in Subword for the memory instance.
* Thesignal Metal for the memory instance.

* TheRedundancy enable for the memory instance: true for a STAR and false for an ASAP
memory.

* Thereisaso acheck box for Automatic Memory Naming. If you check this box, the Memory
Name field will befilled in automatically for you.

On the right hand side of the General Parameters window you can define and edit the operating
points, or PVT conditions, for which datawill be generated during the instance generation process.
Three operating points are aready listed when you start setting the parameters, each with a Process
condition, Operating Voltage (V), and Junction Temperature (C) already defined. Click the New
button to add an operating condition or the Edit button to change the parameters for an existing
operating point. In either case, the PV T window appears as shown in Figure 2-5, “PVT Window”
below:

Figure 2-5 PVT Window
xq

Process Candition: T (Typical)

Operating Voltage ) | |

Junction Temperature{C): | |

Mame: | |

2k Cancel

Specify the Process Condition, Operating Voltage (V), and Junction Temperature (C), and assign a
Name to the operating point you are adding or changing. Just like the General Parameter Window, as
you click in each field and enter values for the operating parameters, Integrator Online shows you the
allowed values and ranges for each parameter in the Status Area at the bottom of the window. When
you download the output files for an instance, Integrator Online creates a subdirectory under the
instance directory for each operating point. The Name you specify for each operating point in the
above window becomes the name of the subdirectory. If available for the specific compiler, enter/
modify the bias voltage valuesto be used for corner definition. Click the ok buttoninthe PVT
Window after you finish adding the new operating point or making the changes to an existing one.
Thiswill save the changes you made and take you back to the window with parametersin the General
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tab. Clicking Cancel discards any changes to the operating points and takes you back to the to the
window with parametersin the General tab.

Use the check boxesin each PV T row to enable or disablea PV T. A selected check box for aPVT
means that thisPVT is enabled and will be generated while running component generation. A
deselected one is greyed out and means that it will not be generated while running component
generation. Using the check box in the header of the PV T table, you can enable or disable all PV Ts.

[ |Enable | Process | Voltage V) | Temp (C) | Mame
v FFQB 0.99 -40 ffobOp...
[vi TTDE 0.9 25 1dbop...
v SSDB 0.9 125.0
1 0,81 ~41
1 : 0.99 125 T
1 SSDB .81 o lssd0p. .
1 FEQE .99 fTogbOpD
Iaw Edlit Dealzta Dafaults

[_] Run Instance Characterization

On the General tab, clicking Ok saves all the settings, including memory parameters and PV T
conditions that define the compiler output files.Clicking the Defaults button in the General tab
restoresall PV T valuesto their default values. Clicking Apply keeps the Configure Component dialog
open for you to enter edits for additional component configurations based on the same compiler.

Any PVT that matches a user-characterized corner in the characterization database cannot be edited
or deleted. Upon edit or delete operations an error message is displayed warning that the given user-
characterized corner can only be enabled or disabled for instance generation.

The Views tab lists the views you can generate for a given memory. These define the output files that
will be generated for the memory. Views available for the compiler you selected but which you do not
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have a license for will be grayed out. You can select which specific views have to generated for your
memory.

Figure 2-6 Configure Component Dialog - Views Tab
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Thetop portion of thetab listsfront-end views, the datasheet views are in the middle, and the backend
views are along the bottom. Buttons at the bottom of the dialog enable you to change the settings for
all the views you have access to with one click. The All Off button turns off the generation of all the
views active on the views tab, while All On turns on the generation of all licensed views.

Clicking the Advanced tab on the Configure Component dialog takes you to the Advanced Parameters
window. This window contains a number of additional parameters that control the instance and
associated Views generated by Integrator Online. The Advanced Parameters window comes up with
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these parameters set to their default values, as shown in Figure 2-7, “ Advanced Parameters Window”
below:

Figure 2-7 Advanced Parameters Window
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For parameters that have arange, Integrator Online shows you the allowed values and rangesin the
Status Area at the bottom of the window. Use the Advanced Parameters window when you need to
generate an instance with more specific settings than the basic parameters in the General Parameters
window can provide. These parameters are a subset of the Embed-1t!® control parameters that are
available to the user of Virage Logic's Embed-It! ® Integrator software. Click the Ok button to save
any changes you specify for the advanced parameters. Clicking Cancel discards any change to the
advanced parameters. Clicking Apply enables you to apply chnages to the additional component that
you configure based on the current compiler.

The component you have created and configured will be displayed and highlighted in the Project
Tree. You can also click Apply to keep the Configure Component dialog open to enter edits for
additional component configurations based on the same compiler. Use the Compiler Information tab to
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view the compiler identification information, including target foundry (Foundry), process geometry
(Process), compiler name (Compiler) and compiler revision level (Revision).

2.1.2 Importing a Component

Existing components can be imported into an Integrator Online project from other projects using the
Component > Import menu option. Different components and variations have just one type of
configuration file *.cfg that can be read by Integrator Online.

In the Import Component dialog, select the Configuration Files (*.cfg) optionsin the Files of Type
field. Browse over to the *.cfg file you want, click on it in the browse pane and press Import to import
it. Note that trying to import the same component twice will cause Integrator Online to produce an
error saying that duplicate instance names are not allowed.

2.1.3 Generating a Component

Indicator “lights’ for each component in the Project Tree provide the status of each action run on the
component. Gray means that the component has not been generated yet. Green means successful run
without Errors or Warnings. Red means Errors/Warnings are encountered during run. When you want
to generate a component, only those components that have gray and red indicators lightsin the
Project Tree can be generated.

Selecting Run > Generate menu option starts the generation process of a selected component.
Selecting the Run > Generate All menu option starts the process of generating the instances that have
Not [Generated] status in the Project Tree. In either case, thiswill display the progress of the
generation process while it istaking place in the Messages Area.

The status Area in the lower left hand corner of the Main window informs you of progress while the
generation isin progress. During thistime, only the Abort toolbar button isactive. The Messages Area
in the Main window displays the progress of the process as it happens. When instance generation is
complete, the Status Area says Ready. You can now see all generated instancesin the Project Tree with
the status changed to [Generated).

The scriptslist is displayed in the Run->Script menu of Integrator Online if there are scripts installed
for your account.

Eun

Generate All FE

Generate F5

Script i) om_script -
i r Latom_script 2
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Select the script you want to execute. To terminate a running script, the Abort button can be used. Al
other actions will be unavailable while the script runs.

2.1.4 Downloading the Generated Files

After you generate a component, its output files stay residing on the server until you download the
files. Once you decide to download them, you have three options to choose from: All, Component,
and view. Note that you downloadable are only the generated components with green indicator light
in the Projrcet Tree.

If you want to download all components and their output views that are in the Project Tree, simply
use the Project > Download > All menu option. In the Save As dialog, browse over to (or create) a
directory where you want your files to be downloaded to and press the Save As button. Thiswill start
the process of downloading al components into the download directory you defined. While the files
are downloaded, only the Abort button is active in the Download dialog. Use the Abort button if you
want to stop downloading the files and the Close button to close the Download dialog when the
download is complete.

If you want to download a component, simply highlight its name in the Project Tree and select
Project > Download > Component menu option. In the Save As dialog, browse over to (or create) a
directory where you want the component to be downloaded to and pressthe Save As button. Thiswill
start the process of downloading the selected component into the download directory you defined.
Whilethefiles are downloaded, only the Abort button isactive in the Download dialog. Use the Abort
button if you want to stop downloading the files and the Close button to close the Download dialog
when the download is compl ete.

If you want to download a view, simply highlight its name in the Project Tree and select Project >
Download > View menu option. In the Save As dialog, browse over to (or create) a directory where
you want your views to be downloaded to and press the Save As button. Thiswill start the process of
downloading the selected views into the download directory you defined. While the files are
downloaded, only the Abort button is active in the Download dialog. Use the Abort button if you want
to stop downloading the files and the Close button to close the Download dialog when the download
is complete.

2.2 Performing Certain Tasks on Components

Integrator Online menu bar has a number of menu options that help you perform certain tasks on
already created components:

» Edit the selected component. See “Editing the Selected Component” on page 15.

»  Show the output view for a selected component in the Views area. See “ Showing the Output
View for a Selected Component” on page 15.

* Delete the selected component from the Project Tree. See “Editing the Selected Component”
on page 15.

Page 14 ~ Copyright 1998 - 2011 ~ Virage Logic Corporation ~ Proprietary Information ~ Do Not Duplicate



» Generate all componentsin the project. See “Generating a Component” on page 13.
* Abort running the job. See “Generating a Component” on page 13.

Most of these options are realized as toolbar buttons and popup menus that open upon right-click on a
component or its view in the Project Tree.

2.2.1 Editing the Selected Component

The Edit and Delete commands in the Component menu of the Integrator Online let you perform
editing and delete operations on the component currently selected in the Project Tree. These
commands work in the same way as Edit and Delete commands that appear in the popup menu upon

right-click on the name of the component in the Project Tree. You can also use the 65% and [
toolbar buttons to perform the editing and delete operations on the selected component.

If you select Component > Edit menu option, it displays the Configure Component dialog where you
can change the general and advanced parameters for the selected component as required or view the
compiler identification information for the component on the Compiler Information tab in the
Configure Component dialog. Click the ok button when you finish your edits to save the changes.
This operation cleans the views for the former component if it was generated and changes the state of
the new component to NOT Generated.

2.2.2 Showing the Output View for a Selected Component

The Views area allows you to look at the compiler output views generated for the component.
Highlight the desired view in the views subtreein the Project Tree and select Component > Show View
menu option. You can also double-click the selected view in the Project Tree. In either case, it
displaysthe contents of the selected filein the Views area. Components with status [NOT GENERATED]
have only the Configuration file available for preview in the Views area.

You cannot change the values of the components directly in the Views area. Only text and HTML
files can be viewed in the Views area. Any external referencein HTML fileswill be openedina
separate Internet browser window for preview. Binary files such as GDS must first be downloaded in
order that you can preview them with the corresponding software. Just as with the Messages area, you

can show the Views area only by using the ™ button.

2.2.3 Deleting a Component

To delete a component from the project, simply highlight its name in the Project Tree and select
Component > Delete menu option. Thiswill remove the component from the Project Tree.
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2.3 Disconnecting and EXxiting

Use the Project > Disconnect menu option to disconnect from the server and the Project > Exit menu
option to exit the Integrator Online. When you disconnect the connection with the server, the

Integrator Online Login Window shown in Figure 2-1, “Login Window” appears. When you exit the
Integrator Online, this window disappears after you confirm that you want to exit Integrator Online.
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Chapter 3 Integrator Online: Command
Line Access

Integrator Online command line client is implemented as asingle jar (Java archive) file. Application
contacts the server, passes the memory configuration, initiates generation of the memory instance and
then downloads all output filesto the client host. If the processfails, it exits with a non-zero code and
the corresponding error message is displayed.

The usage of the Integrator command lineis:

java -jar rvmc.jar -u hostname[:port] -1 loginname [-p password] -c configuration_file
[-d destination] [-k] [-f] [-h]

Table 3-1, “Command Line Options’ below describes the purpose for each of the options:

Table 3-1 Command Line Options

Option Purpose

-u hostname [:port_number] Server host name and port number

-l login_name User login name

-p I0OL key IOL key. If not specified, user will be prompted to

enter it in the interactive mode. If the server is
installed with the —p option disabled, you will get an
error when you use the command line client.

-c configuration_file_name The memory configuration to generate. RVMC can
accept more than one configuration file per session.
Use the -c option to specify the path to the directory
that contains the *.cfg file(s).

jJava —-jar rvmc.jar -u iol.server.com -I
UserName -c /path/to/cfg files

RVMC will recursively search and process all *.cfg
filesin the specified directory within a single session.

-d destination Directory nameto download instanceinto. The default
is the current working directory.

-k Keep acopy of the generated instance on the server.
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Option Purpose

-f Overwrite, if thereis an instance with the requested
name on the server.

-h Print usage information and exit

The exit codes are:

0 - Success

1 - Connection error

2 - Access denied

3 - Configuration file not found

4 - Parameter check error

5 - Generation Failed

6 - Destination directory does not exist
7 - Command line parsing error

8 - Unexpected errors

Notethat if your network communicates with the Internet viaa proxy server, Integrator Online alows
using Java keys for specifying the proxy server name and proxy port number in the commands. The
format for such commands can have the following view:

Java -Dhttp.proxyHost=your_ proxy_server_nhame -
Dhttp.proxyPort=your_proxy_port_number -jar rvmc.jar -u iol2._viragelogic.com
etc.

where your_proxy_server_name and your_proxy_port_number must be replaced with the actual
values for your proxy server name and proxy port number, and the etc. meansall other command
line options to use.

If atermination signal is detected, RVMC closes current connection correctly, which is accompanied
by "Logging out..." text message in the command line. The next connection session may be
established as soon as the interrupted connection is closed.
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Appendix A: Output File Structure

Integrator Online's output files reside in the instance directory.

The instance directory contains back-end files for building the memory as well as a subdirectory for
each operating point.

The subdirectories each contain a set of front-end views for the respective operating point. The names
and number of filesin each sub-directory is the same. For example, if you specified an instance
named ts128x8cm4 and operating points named Best, Typical, and Worst, the instance directory will
contain the following files and subdirectories:

ts128x8cm4.cfg Configuration File
ts128x8cm4.gds GDSII File
ts128x8cm4_func.v Verilog Netlist File
ts128x8cm4.cir Spice Netlist File
ram1. ts128x8cm4 Abstract LEF File
ram1. ts128x8cm4 Log File

Best Subdirectory containing Front-End Views for Best Operating Point
Typical Subdirectory containing Front-End Views for Typical Operating Point
Worst Subdirectory containing Front-End Views for Worst Operating Point.
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The contents of the subdirectories depend on the values for various advanced parameters. As an
example, a subdirectory for the instance mentioned above might include the following:

ts128x8cm4.ds Datasheet

ts128x8cm4.llef Logical LEF

ts128x8cm4.summ Summary

ts128x8cm4_stim.v Testbench for Verilog Behavioral Model and Verilog Netlist
ts128x8cm4.v Verilog Model

ts128x8cm4.vhd Vital Model (VHDL)

ts128x8cm4_qa.txt Compiler QA Information

ts128x8cm4.1ib Synopsys Model

ts128x8cm4_vhd_stim.v Verilog Behavioral Model and VHDL Behavioral Model Testbench

ts128x8cm4_vhd_wrapper.v Verilog Wrapper for VHDL.
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