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Introduction 

Introduction 
BET Viewer is a system for displaying and evaluating the results of Brain Electrical Tomography 
(BET). Brain Electrical Tomography integrates the functional information provided by the 
Electroencephalogram (EEG) or Magnetoencephalogram (MEG) with the anatomical information 
provided by Magnetic Resonance Imaging or Computer Assisted Tomography. BET makes it possible 
to localize in the brain the sources of physiologic or pathologic actvities, thereby opening new ways 
to study normal brain processes such as cognition or abnormal brain processes such as epilepsy.  

BET requires a solution for the inverse problem of the EEG. This is the problem of estimating the 
intracerebral generators given voltage measurements taken from the scalp. Complex calculations 
using the recorded electric activity, the coordinates of the scalp electrodes where the EEG was 
recorded and tomographic anatomical information lead to an electrical tomography describing the 
distribution of cortical currents that generate the recorded electric activity. This tomographic 
solution can then be represented in image form using the BET Viewer.    

In order to visualize the solution, the BET Viewer needs to be configured with the current elements 
in the solution, the grid used to localize these intracerebral currents, and the anatomical images 
needed for visualization.  The anatomical images can provide the whole brain or only parts of the 
brain (segments).    

The grid is built over the whole image volume although only the points that intercept with the 
chosen segments are used for the calculation as showed in Figure 1. This segmentation could show 
the complete brain or just the gray matter, as illustrated in Figure 2.   

The anatomical image can contain several million voxels and the grid is built so that it embraces the 
largest number of voxels in the regions of interest for the inverse solution. The resolution and 
accuracy of BET depends, among other factors, on the number of points in the grid, although there 
are limits to the number of points imposed by the inverse solution. The values for the image voxels 
that do not intercept with the grid points are obtained by interpolation.  
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Introduction 

 

 

Figure 1. Location of the grid in the image volume 
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Introduction 

 
 

 

Figure 2. Segmentation of the image. 

 
The "configuration" for BET is stored in a ASCII file with extension .CFG. The elements are:    

The anatomical image which used by BET can be an individual image obtained from Magnetic 
Resonance Imaging or Computed Assisted Tomography, an average image across many individuals 
or an atlas image.     

 

Configuration 
 
Volume Image Specifies the full path and name for the files (.VOX 

and .HDR) containing the complete three dimensional 
anatomical image.  
  

Segmentation Solution Specifies the full path and name of the files (.SEG and 
.HDR) containing the segmentation of the anatomical 
image used for constraining the tomography. 
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Segmentation Brain Specifies the full path and name of the files (.SEG and 
.HDR) containing the segmentation of the anatomical 
image used to define the brain. 
 

Grid Specifies the full path and name of the file (.XYZ) 
containing the grid used to calculate the solution.  
 

Top View Specifies the full path and name of the file (.3D) 
containing a 3D rendering of the brain corresponding 
to the anatomical image seen from above. 
 

Left View Specifies the full path and name of the file (.3D) 
containing a 3D rendering of the brain corresponding 
to the anatomical image seen from the left. 
 

Index Specifies the full path and name of the file (.IND) 
containing indexes to the points of the grid used to 
calculate the solution. 
 

Atlas Specifies the full path and name for the files (.VOX 
and .HDR) containing the atlas attached to the 
anatomical image. 

 
 
The anatomical image which used by BET can be an individual image obtained from Magnetic 
Resonance Imaging or Computed Assisted Tomography, an average image across many individuals 
or an atlas image.     

BET Viewer can work in two different execution environments:   

• Stand-alone: the system can load and visualize tomographic solutions already calculated and 
stored on disk. 

• Linked to a program for calculating the inverse solution: BET viewer will then be called to 
visualize the Brain Electrical Tomography images as they are calculated    

BET Viewer provides both 2D and 3D visualization of tomographic solutions, sequences of these 
visualizations (like movies), and different tools to explore and measure the Brain Electrical 
Tomography.    

BET Viewer is a Windows-9x/Windows NT compliant 32-bit application that requires large amounts 
of memory. At least 64 Mbytes of RAM is needed for the program to work efficiently. Since the 
application is devoted to evaluating color images, a video adapter that allows True Color (24 bits) is 
recommended.   
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Working screen 

Working screen 
Once BET has been loaded and initialized, the system's main screen is presented. BET Viewer has 5 
work sheets with a menu bar, a toolbar and a status bar common to the 5 sheets although there will 
be elements that will be available or not depending of the active work sheet. 

Application title including tomographic solution and 
active configuration 

  
 

 

ToolbarHorizontal menu 

Work sheets

Atlas information bar 
Status bar

Figure 3. Elements of the main screen of BET Viewer. 

 
 The Atlas information bar will be enabled only if the anatomical image of the active 

configuration has an associated atlas or the active configuration includes an atlas. 
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Working screen 

Toolbar 
BET Viewer has a toolbar with buttons for the more frequently used commands.  

 

 

Figure 4. BET Viewer toolbar. 

 

Elements of the toolbar 
 

 Open image configuration 

 Open tomographic  solution 

 Use  grid steps 

 Show orthogonal bars 

 Set Tomographic mode 

 Set Inverse tomographic mode 

 Set Map mode 

 Set Image mode 

 Set Black&White mode 

 Set Isocontour mode 

 Show solution maximum 

 Change palette 

 Print Preview 

 
Print all work sheets 

 Zoom image 

 Show vectors 

 Scale image 

 Show previous solution 

 Show next solution 

 Show first  solution 

 Show last solution 

 Scale  solution 

A detailed explanation of these commands will be given in the following chapters. 
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Working screen 

Status bar 
BET Viewer has a status bar describing in several fields the current state of the active work 
sheet and other contextual information.  

 Image coordinates  
 Sequence 

Indicator 
Talairach 
coordinates  

Active Solution  Tomography 
value  

 Active configuration 
 
 

Figure 5. BET Viewer status bar. 

 
 
 

Pressing the right button of the mouse on the fields of the bar gives further 
information: 

 
Active 
configuration 

The active image configuration is described. 
 

Sequence indicator  This field shows which image in a sequence is presently 
imaged (see command Go to Solution). 
 

Image coordinates This field describes of the x y z coordinates (BET system) used 
by the BET Viewer for the present tomograms. 
 

Talairach 
coordinates 

This provides the equivalent Talairach coordinates if the 
anatomical image of the active image configuration is in 
Talairach space. 
 

 
 
 The Talairach coordinates are showed only if the anatomical image of the active 

image configuration is in Talairach space. 
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Work sheets 
BET Viewer has 5 work sheets. When a tomographic solution is loaded the Orthogonal Planes sheet 
automatically becomes the active work sheet.  Three other sheets are also enabled: All Slices, 3D 
View and Maximum Intensity Projection, but these are nor visible unless selected.  The Electrode 
View sheet is enabled only when an electrode coordinates file is loaded. 

The names of the sheets appear on tabs at the upper edge of every sheet (just below the tool bar). To 
move from sheet to sheet, click the sheet tabs. 
 

Orthogonal Planes 
This work sheet visualizes the tomography in 3 orthogonal planes: axial, coronal and 
sagittal. The sheet also provides the values of the active scale and palette, two 3D surface 
renderings of the brain showing the views from the top and left, and a control for moving 
the cursors that define the planes. The X coordinate defines the sagittal plane, the Y defines 
the axial and the Z defines the coronal plane. In the top view of the brain the cursors 
corresponding to the sagittal (vertical cursor) and coronal (horizontal cursor) plane are 
shown. In the left view of the brain the cursors corresponding to the coronal (vertical 
cursor) and axial (horizontal cursor) plane are shown.    
 
The slices to be visualized can be selected by changing the cursor values in the boxes on 
the sheet or by dragging the mouse over the 3D views to the desired slice. The orthogonal 
slices to the slice where the operating system cursor lies, can be visualized too by pressing 
the mouse left button. If the anatomical image is aligned in Talairach space, the Talairach 
button is enabled and by pressing it a dialog is presented for selecting cursor coordinates in 
Talirach’s system. 
 
 In each one of the visualized slices the orientation is indicated in the superior border, 
where R indicates right, L left, A anterior and P posterior.  The slice orientation can ne 
changed with the Slice Orientation command. Aditionally, orthogonal bars (with the option 
Show orthogonal bars) can be superimposed over every plane showing the position of the 2 
orthogonal planes. 
  
 
When the mouse is moved over the slices the value and voxel coordinates are indicated in 
the status bar. 
 
 
 
 

 Depending of the current state of the option Grid's steps the cursors will move from 
voxel to voxel (inactive state) or in the grid steps.  The tomograms are directly 
calculated for slices intercepting the grid or interpolated if the slices are not on the 
grid. 

 

8  User Manual, BET Viewer , Version 1.3 



Work sheets 

 Axial plane Coronal plane
 

 

Active
palette and 
current scale 
values

Sagittal plane 

Figure 6. Orthogonal Planes work sheet. 

 
 Pressing the right button of the mouse over an elements of the sheet brings up a local 

menu with the commands available for the selected element. 
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All Slices 
This work sheet shows all the tomographic slices that intercept the grid of the selected 
plane. The plane used in this sheet is selected through the command Plane in All Slices in 
the View menu. An auxiliary reference window gives a 3D rendering of the brain showing 
(by means of a line cursor) the position in the brain of the slice selected by the mouse on 
the work sheet. This window also shows the values of the active scale and palette. Dragging 
the line cursor in this reference window shows the corresponding slice on the work sheet. 
The presence on screen of the auxiliary reference window can be controlled with the 
command All Slices Reference of the View menu. 
 
In each one of the visualized slices the orientation is pointed out in the superior border, 
where R indicates right, L left, A anterior and P posterior.    
When the mouse is moved over the slices the voxel coordinates are indicated in the status 
bar. The value for each voxel is not shown in this work sheet. 
 
 

 When pressing the right button of the mouse over the elements of the sheet a local 
menu is showed with commands available to these elements . 

 Auxiliary reference window
 

 

Figure 7. All Slices work sheet. 

 
 The presence on screen of the auxiliary reference window can be controlled with the 

command All Slices Reference of the View menu. 
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3D View 
This work sheet visualizes the tomography in 3 dimensions. The 3D visualization requires 
time. Depending on the volume of the image, angles of rotation selected etc., the rendering 
can take up to several minutes. When first activated, this sheet appears empty because it 
works as a "container " where the renderings will be "stored". An auxiliary window is 
attached to this sheet for selecting the different parameters to use in the 3D rendering. 
 

 
 
 

In this sheet is not possible to render the tomography in Black & White and 
Isocontour modes. 
 
 

 

3D parameters 
auxiliary 

Figure 8. 3D View work sheet. 

The Render button in the auxiliary window called 3D Parameters starts the rendering once 
the desired parameters are established. A progress indicator of the rendering then replaces 
the status bar. The Cancel button interrupts the rendering at any time.  
 

 The rendering process is carried out as a background task so that the user can 
continue working with other components of the BET Viewer. The system will notify 
the user if he or she tries to execute an operation that would invalidate the 
rendering.. 

 
 Pressing the right button of the mouse over an element of the work sheet brings up a 

local menu with commands available to the selected element. 
 

The sheets composing the 3D Parameters window are described next:: 
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Rotation 
In this sheet the rotation angles for the 3D rendering are set.  
 
Angles There are two ways for setting the angles: by directly editing the desired value 

in box existent for each angle or by means of the 6 buttons which can increase 
or decrease the rotation angle in steps of 5�. A preview of the sheet shows the 
results of applying the active values of the angles for each axis using a model 
human head. 

 

 

Angles edition 

Buttons for editing 
angles 

Preliminary view

Figure 9. Rotation sheet in 3D Parameters. 

 
 This sheet shows the position of the image relative to the BET coordinate system. 

When the rotation angles are 0 the head looks directly at the observer. 
 

Light 
This sheet sets the illumination parameters for the 3D rendering. There are three parameters 
for controlling the rendering illumination: position of the light, light intensity and amount of 
reflection.    
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Buttons for editing 
position 

Position 
coordinates 
edition 

Intensity 
coefficien 

Reflection 
coefficient 

Preliminary view 

Figure 10. Light sheet in 3D Parameters. 

 
 
Position The position of the light indicated through the coordinates X, Y, Z can 

be set by directly editing the values for each coordinate or by pressing 
the 6 buttons that increase or decrease the coordinate for each axis in 
steps of 5. The default initial position of the light is (0,0,-1) meaning 
that the light points to the front of the head. 
 

Intensity The intensity is a real value between 0.0 and 1.0. The rendering process 
combines this coefficient with other factors to achieve the depth effect. 
An intensity coefficient of 0.0 ignores the incident light, whereas an 
intensity coefficient of 1.0 ignores all other factors. The default initial 
value is of 0.5. 
 

Reflection The reflection coefficient is an integer value between 1 and 10 that 
controls the amount of reflection of light from the 3D surface. Higher 
values cause highlights and give a metallic appearance to the surface 

 
The Default button allows restoring the implicit values for each parameter. In the preview 
of the sheet the result of applying the active values for each parameter is shown with a 
model human head. 
  

 The default illumination parameters lead to reasonable renderings. These parameters 
should be changed only if some unusual illumination is wanted.  
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Misc. 
This sheet sets two other two parameters for the 3D rendering. 
 
Thresholds This parameter sets the detection thresholds in the anatomical image of 

the skin and the cerebral cortex. These values can be changed using the 
edit box existent for each surface. There is no need to change the 
default values unless the user wants to "experiment". Wrong values can 
invalidate the surface detection process. The Default button allows 
restoring the default values for each surface. 
 

Background This parameter sets the background color of the 3D rendering. The 
default initial value is Black. 

 

 

Background color 
selection 

Detection thresholds 
selection 

Figure 11. Misc. sheet in 3D Parameters. 

Visibility 
This sheet varies the visibility of the cerebral cortex in the 3D rendering. With this 
parameter it is possible to reduce the rendering time by inhibiting the rendering in the part 
of the head that does not correspond to the brain.  To set this parameter the following 
controls are used: 
 
All Cortex If this toggle is turned on all the brain is visible and the other controls 

are disabled. 
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Y This parameter can be directly edited or controlled with the scroll bar. 
The brain will be visible at vertical values above the selected Y 
coordinate. 

 
The left view of the anatomical image shows the visibility achieved if the current value of 
the parameter is applied. 
 
 

 

Left image view 

Y coordinate 
edition 

Visibility toggle for 
cortex 

Figure 12. Visibility sheet in 3D Parameters. 

 

Box Cut 
This sheet sets the parameters for cutting out a cubic box from the 3D rendering of the 
image. Activating this parameter makes it possible to see into the interior of the image 
volume. The controls on the sheet indicate if the option is applied as well as the position 
and size of the cube to extract. 
 
Apply Box Cut Activating option box turns on the cutting algorithm and enables the 

other controls. 
 

Position These parameters set the position of the left inferior corner of the 
cube. The 3 controls, one for each coordinate, are controlled by 
either an edit box or a scroll bar. 
 

Size This parameter sets the size of the cube is set. The 3 controls, one for 
each coordinate, are cotrolled by either an edit box or a scroll bar. 
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The preview superimposes on a model human head the position and size of the extracted 
cube (in red) relative to the cube that represents the full image volume (in white). The 
coordinates axes are indicated in blue. 
 

 

Box cut toggle 

Position coordinates 
edition 

Cube size edition

Preliminary view

Figure 13. Box cut sheet in 3D Parameters. 

 
 The preview shows the position of the image volume relative to the active rotation 

angles.  When the rotation angles are 0 the head is looking directly at the observer. 
The parameters shown in the figure would extract a cube corresponding to the right 
posterior area of the image volume. 

 

Movie 
This sheet sets the parameters for carrying out a 3D animation. The resulting animation is 
stored in standard Windows format .AVI.  
 
 
Generate 
movie 

If this option is turned on a 3D animation will be generated instead of a 
single view when pressing the Render button.  Otherwise the remaining 
other will be disabled. 
 

Starting from 
current 
parameters 

When this option is activated, the animation (depending on the type of 
animation) will begin from the active values of the 3D parameters already 
set (Rotation, Light, Box Cut, etc.). 
 

Movie type Select the animation type from an option list: 
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 Spins … This type of animation generates rotations of the image 
volume around one of the 3 possible axes. When selected, 
the edit box Step is enabled.  As many frames as needed 
will be generated to complete a full rotation of 360 ° 
around the selected axis using the selected step.  
 

 Cortex 
visibility 

This type of animation generates views of the image volume 
with increasing or decreasing visibility of the cerebral 
cortex. When selected, the edit boxes Step and Limit are 
enabled. As many frames as needed will be generated to 
arrive at the selected limit taking into account the selected 
step. The step sign determines if the visibility increases or 
decreases (see Visibility sheet).  
 

 User 
defined 

This type of animation generates animations defined by the 
user. When selected, a dialog is presented for loading the 
file that contains the animation definition. These files have 
extension .MUS. Once loaded the file'ss name is shown in 
the Input file box.  

 Sequence This type of animation generates temporal animations in 3D 
if the active tomographic solution is a sequence.  When 
selected two edit boxes Start and Stop are shown for setting 
the solutions that will be used as start and stop frames in the 
movie respectively. This type is visible only if if the active 
tomographic solution is a sequence. 

 
 Format of the .MUS files  
 The file will have as many lines as frames in the animation. Each line has 

the following format: 
 
AX AY AZ YV AppC XPC YPC ZPC XSC YSC ZSC XL YL ZL I R 
 where: 

 
 AX Rotation angle on the axis X 

 AY Rotation angle on the axis Y  

 AZ Rotation angle on the axis Z  

 YV Coordinate Y for visibility 

 AppC 1 if Box Cut is carried out, 0 if not  

 XPC X coordinate for positioning the Box Cut 

 YPC Y coordinate for positioning the Box Cut 

 ZPC Z coordinate for positioning the Box Cut 

 XSC Size in X axis of the Box Cut  

 YSC Size in Y axis of the Box Cut  

 ZSC Size in Z axis of the Box Cut  

 XL X coordinate for positioning the light 

 YL Y coordinate for positioning the light 

 ZL Z coordinate for positioning the light 
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 I Intensity coefficient of the light 

 R Reflection coefficient of the light 

 
 
Once the Render button is pressed a dialog window requests a filename for the animation 
that will be generated in .AVI format. The chosen name will appear in the Output file box. 
During the animation, the number of frames rendered will be monitored in the Frames 
rendered box.  
 

 

Toggle for generating 
movie 

Toggle for using current 
parameters 

Movie type 
selection 

Movie type 
parameters 

AVI file for storing 
the movie 

Figure 14. Movie sheet in 3D Parameters. 

 
 

 The progress bar of the animation that replaces the status bar during the rendering 
shows the progress of each frame separately (and not the progress of the whole 
animation process).  
 

 The animation can be played with any multimedia player supporting the .AVI format 
or with the command Play Movie. 
 

 If the Cancel button is pressed during the generation of the animation sequence the 
user can save the frames generated until that moment. 
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Max. Intensity Projection Max. Intensity Projection 
Like the Orthogonal Planes sheet this work sheet shows the tomography in 3 orthogonal 
planes. All the slices of each plane are projected together onto one slice. If the anatomical 
image has a template for this purpose, this is used; otherwise the projection is carried out 
onto the middle slice in each plane.  

Like the Orthogonal Planes sheet this work sheet shows the tomography in 3 orthogonal 
planes. All the slices of each plane are projected together onto one slice. If the anatomical 
image has a template for this purpose, this is used; otherwise the projection is carried out 
onto the middle slice in each plane.  
The projection shows at each point of the slice the maximum intensity of all slices in that 
plane (see use Maximum). The view is similar to what would be seen if the active areas 
were in a "glass head." The sheet also shows the values of the active scale and palette. 

The projection shows at each point of the slice the maximum intensity of all slices in that 
plane (see use Maximum). The view is similar to what would be seen if the active areas 
were in a "glass head." The sheet also shows the values of the active scale and palette. 
    
  

  
  
  

In this sheet it is possible to visualize the tomography in either Map or Black & White 
modes. 
In this sheet it is possible to visualize the tomography in either Map or Black & White 
modes. 

  

Work sheets 
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Figure 15. Max. Intensity Projection work sheet. 

 
 
 
 

When moving the mouse cursor over the slices the coordinates are only fully 
reported in the status bar if the current voxels intercept the grid. Otherwise only the 
two coordinates that intercept the plane are reported.  
 

 
 
 

In this work sheet the command Show vectors is disabled. The command Show grid 
is disabled if the projection is carried out over a template associated with the 
anatomical image.  
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Electrode View 
This work sheet shows the electrode positions on the 3 dimensional anatomical image. The 
sheet behaves in the same way as the 3D View sheet and there is a similar auxiliary 
window for selecting the different parameters to use in the 3D rendering. 
 

 

3D Parameters auxiliary 
window 

Figure 16. Electrode View work sheet. 

 
In the auxiliary window the Render button starts the rendering once the desired parameters 
have been set.  The Cancel button, which is enabled when the rendering begins, allows the 
rendering to be interrupted at any time. A progress indicator replaces the status bar.  This 
progress is divided in two parts: anatomical image rendering and electrode rendering.  

 
 This sheet is enabled when loading a file of electrode coordinates with the command 

Open Electrodes File. Pressing the right button of the mouse over any element of the 
sheet brings up a local menu with commands available to this element. 
 

 The rendering process is carried out as a background task, allowingthe user to 
continue working with BET Viewer.  The user is notified if he or she tries to execute 
any operation that could invalidate the rendering. 
 

 
The 3D Parameters window which sets the parameters for the rendering has 3 sheets: Rotation, Light 
and Misc.  The Rotation and Light sheets have the same function as those already described in the 
3D Parameters window of the work sheet 3D View. The sheet Misc. adds further parameters:  
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Misc. 
In this sheet the following parameters are set for the 3D rendering.  
 
Thresholds This parameter sets the detection thresholds in the anatomical image of 

the skin and the cerebral cortex. These values can be changed using the 
edit box existent for each surface. There is no need to change the 
default values unless the user wants to "experiment". Wrong values can 
invalidate the surface detection process. The Default button allows 
restoring the default values for each surface. 
 

Background This parameter sets the background color of the 3D rendering. The 
default initial value is Black. 
 

Electrode Color This button changes the color used for rendering the electrodes. When 
pressed opens the Windows standard dialog for selecting colors. 
 

Show Identifier If this toggle is turned on the rendering will include the electrode name 
and the Font button will be enabled to allow a standard Windows 
standard dialog to select the font. 
 

 

 

Skin detection 
threshold selection 

Background color 
selection 

Electrode color 
selection 

Toggle for identifying 
electrodes 

Font identifier selection

Figure 17. Misc. sheet for Electrode View work sheet 

. 
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Working with BET Viewer 
Once it has been loaded and initialized, the BET Viewer is ready to start the working session. At the 
beginning of the working session, only the Orthogonal Planes sheet will be enabled. The remaining 
sheets will be enabled once a tomographic solution is loaded.  

 
 The loading and initializations is a slow process which, depending on the power and 

memory capacity of the computer, can take up to several minutes. 
 
 

Changing the configuration 
During the working session the configuration can be handled with several commands. With 
the commands Edit Image Configuration and New Image Configuration the user can 
change the configuration or create a new one. The command Open Image Configuration 
allows the user to select and load a stored configuration.  

 

Loading tomographic solutions  
If the application is working in stand-alone mode, the tomographic solutions are loaded by 
means of the command Open Solution. If the application is executed from another module, 
the tomographic solution is loaded automatically when giving the corresponding command 
in that module. The loaded solution becomes the active solution and once loaded, the 
remaining work sheets are enabled.  
 

Changing the active work sheet  
The active work sheet is changed by clicking the sheet tab for the desired sheet. The 
selected sheet will then become the active work sheet. 
 

Changing the visualization mode  
BET Viewer has five visualization modes: Tomographic, Inverse Tomographic, Image, Map, 
Black & White and Isocontour. To change the mode use the commands Tomography Mode, 
Inverse Tomography Mode, Image Mode, Map Mode,  Black & White Mode and Isocontour 
which appear in the toolbar or the View menu. The selected mode will become the active 
visualization mode. 
 

Working with the image  
In the sheets Orthogonal Planes, All Slices and Max. Intensity Projection the tomographic 
solution is visualized in 2D by means tomographic slices. The tomographic solution is 
visualized in each work sheet using the active visualization mode as well as the active 
solution and image scale. To change the solution scale use the command Scale Solution 
and for changing the image scale the Scale Image will be used. 
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How to make a 3D rendering?  
To obtain a 3D rendering of the tomographic solution, activate the 3D View work sheet (see 
3D View). The minimum steps needed to achieve a rendering are: 
 
• Set the rotation angles.  Activate the Rotation sheet of the 3D Parameters window and 

using the preview put the volume in the desired position (see Rotation).   

• Set the visibility of the brain cortex. Activate the Visibility sheet of the 3D Parameters 
window and using the preview set the visibility of the cortex in the desired position (see 
Visibility).   

• To see the interior of the image volume activate the Box Cut sheet of the 3D Parameters 
window and using the preview set the size and position of the cube to extract (see Box 
Cut). If not desired, pass on to the next step. 

• Press the Render button in the 3D Parameters window to start the rendering process. 
This process is carried out as a background task allowing the user to continue with 
other tasks. 

 

Changing the palette  
BET Viewer is distributed with a set of color palettes for visualizng the tomographic 
solution. The selected palette will be used in all the work sheets except the Black&White 
mode. When beginning a new working session the last used palette will be selected. To 
change the palette the command Change Palette will be used.  
 

Printing the tomographic solution  
BET Viewer can print the contents of the different work sheets.  The Print Setup command 
configures the printer and selects the pages to print. The Print command prints the selected 
sheets. The Add Comment command adds comments or observations to the work sheets for 
printing. The Print Preview command previews the sheets as they will appear on paper. 
 

How to visualize the electrodes?  
To obtain a 3D rendering of the electrodes requires loading the file of electrode coordinates 
by means of the Open Electrodes File. Inmediately after 5 renderings are generated 
automatically corresponding to the front, back, top, left and right views of the head. To 
obtain a different view the minimum steps needed to achieve it are: 
 
• Activate the Electrode View work sheet (see Electrode View) 

• Set the rotation angles.  Activate the Rotation sheet of the 3D Parameters window and 
using the preview put the volume in the desired position (see Rotation).   

• To change any of the default values for rendering the electrodes, activate the Misc. 
sheet and change the desired parameter (see Misc. in Electrode View).   
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• Press the Render button in the 3D Parameters window to start the rendering process. 
This process is carried out as a background task so that the user can continue with other 
tasks. 

Working with animations  
There are two animation (movies) types in BET Viewer:  
 
• Temporal animation using the command Generate Movie in the Display menu, or by 

using the the Movie sheet of the Parameters 3D in the work sheet 3D View with the 
movie type Sequence. 

• 3D animation using the Movie sheet of the Parameters 3D in the work sheet 3D View 

The temporal animation with Generate Movie is only enabled when working with a 
sequence of solutions. In both types the animation generated is saved in .AVI format 
allowing it to be used with any multimedia player or with the command Play Movie in the 
Display menu. 
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Description of comnands 
This section descirbes all the commands, specifying for each the menu where it belongs, the hot-key 
combination (if available), and the toolbar button (if it exists). 
 

New Image Configuration (Ctrl-N) 
This command in the File menu creats a new configuration (see Configuration). When 
activated, a form for changing the elements of the configuration appears. The elements that 
appear when the form is presented correspond to the active configuration. Pressing the Ok 
button brings up a dialog window for saving the configuration.  
 

 

Figure 18. Form for Image Configuration. 

 
 

Edit Image Configuration  
This command in the File menu allows editing an existent configuration (see Configuration). 
When activated, a dialog for selecting the configuration to be edited appears. Once the 
configuration is loaded, a form for editing the elements of the configuration appears. 
Pressing the Ok button brings up a dialog window for saving the configuration.  

User Manual, BET Viewer, Version 1.3 25



Description of comnands 

Open Image Configuration (Ctrl-O) 
 This command in the File menu allows loading an image configuration (see Configuration). 
When activated, a dialog for selecting the desired configuration appears. Once the 
configuration is selected, the loading and reinitialization process starts. 
 

 When a new configuration is loaded all the work sheets are reinitialized, and the 
previous contents of the work sheets are lost.  

Open Atlas 
This command in the File menu loads an atlas file for viewing over the anatomical image in 
the active configuration (see Show Atlas). When activated a dialog for selecting the desired 
atlas file is presented. 

Open Electrodes File 
This command in the File menu loads a file of electrode coordinates for later visualization 
on the anatomical image.  When activated, a dialog for selecting the desired file appears 
and inmediately after 5 renderings are generated automatically corresponding to the front, 
back, top, left and right views of the head.  
 

 When a new file of electrode coordinates is loaded the work sheet Electrode View is 
enabled or reinitialized (thus losing its previous contents).  

 

Open Solution (F2) 
This command in the File menu loads a tomographic solution. When activated, a dialog for 
selecting the desired solution appears.  
 

 

Solution 
type 
selection 

Figure 19. Dialog for Open Solution. 

26  User Manual, BET Viewer , Version 1.3 



Description of comnands 

 
There are five possible solution types:  .TXT, .ENG, .ORT,  .MDL and .MOD. The .TXT and 
.ENG files are ASCII files, the .ORT and .MDL files are binary files storing floating point 
numbers in single precision (4 bytes).  
 
The .TXT and .ORT files include information about the orientation and magnitude of the 
generators. The .ENG and .MDL files only include information about the magnitude. The 
solution files can contain a single solution or a sequence of them. There are specific 
commands for working with a sequence of solutions. 
The .MOD files, correspond to the models obtained for the electrical tomography by the 
Quantitative Analysis of the EEG (frequency domain). 
 

Open fMRI 
This command in the File menu loads a fMRI file. When activated, a submenu appears for 
selecting which variant will be used for loading the fMRI file: Individual or Atlas. When the 
Individual option is selected a dialog is presented for setting  the elements needed for fMRI 
visualization. 
 

 
 
The anatomical images can be in VOX or ANALYZE format. The fMRI files are loaded only 
in ANALYZE format. The Segmentation file is optional, if no file is set, the segmentation is 
generated automatically by the system. However is recommened to set a segmentation file 
as precise as possible in order to obtain better results in visualization. The grid step by 
default is 3 and can be changed by the user in order to increase accuracy in the 
visualization. It is user’s responsibility to guarantee coregistring between the anatomical 
image and the fMRI file. 
 
When the Atlas option is selected a dialog is presented for selecting the fMRI file to load. In 
this option the fMRI is plotted over the ICBM brain template requiring in this case a 
previous normalization and coregistering with this brain. 

Save Solution 
This command in the File menu saves a tomographic solution. When activated, a dialog for 
editing the name for the solution to be saved appears. If the active solution includes 
information about the orientation of the generators (.TXT, .ORT) it is possible to save it 
without that information by selecting the .ENG or .MDL type in the dialog. 
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Import 
This command in the File menu imports an image volume in ANALYZE ™ format or iMagic 
format as a tomographic solution. When activated, a dialog for selecting the desired image 
appears. If the image to be imported contains more than one volume the generated solution 
will be considered a sequence.  
 

 Only  the ANALYZE ™  images stored in transverse orientation (axial) can be 
imported.  
 
To be imported the image dimensions should match with the anatomical image 
dimensions or grid dimensions of the active configuration. 

 

Export 
This command in the File menu exports a tomographic solution (or a sequence of them) to  
an image in ANALYZE ™ format or iMagic format. When activated, a dialog for editing the 
name for the solution to be exported appears. The dialog allows to select the image type to 
export for the ANALYZE format: grid image or full image. If the grid image type is selected 
only the solutuion values matching with the grid will be exported, obtaining in this way a 
more compact and reduced in size image. The full image type saves all the image values. 

Add Comment 
This command in the File menu adds comments to the sheets for printing. When activated, 
a window for editing the desired text appears. In the window there is an option list (In Page) 
for selecting the sheet where the comment will appear. The comment added using the All 
option appears in all the sheets before the comment specific to the particular sheet. 
 

 

Page selection

Figure 20. Add comments window. 

 
 
 
 

The comments will appear on the printed page after the content of the sheet.  
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Print Setup 
This command in the File menu sets the characteristics of the printer. When activated, a 
dialog that also sets the paper size and orientation appears.  
 

 

Figure 21. Printer selection dialog. 

 
 It should be kept in mind when selecting the paper size that some sizes are not valid 

for printing in BET Viewer.  
 

Print Preview 
This command in the File menu replaces the main window of the application for a window 
where a preview shows the work sheets as they would look on paper when printed. The 
window has a toolbar with commands for adjusting the preview. 

Toolbar of Print Preview 
 
 
 
 
 
 
 

 

Previous page 

Next page 

Current page(s) 
indicator 

One page 
activation

Two pages 
activation

Full screen 
activation

Print all pages

Zomm % selection

Close preview

Figure 22. Print preview toolbar. 
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Toolbar 

Page header 

Comments added 
to the page 

Figure 23. Print preview. 

 

The work sheets Orthogonal Planes and Max. Intensity Projection are printed in a single 
page respectively but the remaining sheets can take more than a page depending on their 
contents. The work sheets Orthogonal Planes and Max. Intensity Projection are therefore 
numbered 1 and 2. The work sheet All Slices will start on page 3 and will use as many 
pages as needed. The numbering will then continue with the work sheets 3D View and 
Electrode View. 
 

 
 
 

Depending on the form of the mouse cursor:  or , when pressing the left 
button of the mouse the magnification of the page will be increased or reduced.  

 
In the page headers the following elements appear: application logo, center where BET 
Viewer is installed, company (or distributor) logo, active tomographic solution, active 
configuration and page number.  

Print (Ctrl-P) 
This command in the File menu prints of the BET Viewer work sheets (see Print Preview). 
When activated, a dialog is shown for setting the characteristics of the printer and the pages 
to print.  When the Ok button is pressed the printing starts.  
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Figure 24. Printing dialog. 

Exit 
This command in the File menu allows leaving the application after confirmation. 
 

 
 
 

When BET Viewer is executed through a linked system, special attention should be 
paid when closing the application because undesired effects can be caused in the 
linked system. It is therefore recommended that the BET Viewer be closed prior to 
returning to the linked system. 

Copy 
This command in the Edit menu copies the contents of the active work sheet to the 
Windows clipboard.  
 

 
 
 
 

This command is only enabled if the active work sheet has content.  

Copy To 
This command in the Edit menu allows copying the content of the active work sheet to a 
Windows bitmap file. When activated a dialog for selecting the name of the file appears. 
The dialog also shows the existent files on disk. 
 
 
 
 Preliminary view 

in real size 
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Preliminary 
view

Bitmap type selection

Figure 25. Copy to bitmap dialog. 

 
 
 
 
 

This command is only enabled if the active work sheet has content.  

Copy Options 
This command in the Edit menu sets the background color of the bitmaps saved with the 
commands Copy or Copy To. When activated, a dialog for setting the 3 possible 
background colors appears.  
 

 

Figure 26. Selection of background color dialog. 

 
 
 
 
 

The selection made with this command is also used for the bitmaps used in the 
animations generated by the command Generate Movie.  

 

 

32  User Manual, BET Viewer , Version 1.3 



Description of comnands 

Clear all 
This command in the Edit menu erases all the renderings that have been carried out in the 
work sheets 3D View and Electrode View. 
 

 
 
 

This command is only enabled when there is at least one rendering. For erasing only 
one of the renderings the command Clear this should be used instead of Clear all.  

Show Maximum (F8) 
This command in the Display menu makes the work sheet Orthogonal Planes show the 3 
planes containing the point where the tomographic solution reaches its maximum 
magnitude (see Use Maximum)  
 

 
 
 

This command is only enabled in the work sheet Orthogonal Planes.  

Scale Image 
This command appears in the Display menu and in the local menus of all the work sheets.  
By means of this command it is possible to scale the anatomical image to obtain better 
contrast for the image. When activated, a window is presented with several controls that 
allow carrying out the scaling: 
  
Minimum This parameter sets the minimum of the scale using either the edit 

box or the scroll bar. 
 

Maximum This parameter sets the maximum of the scale. 
 

Threshold This parameter, which is only enabled if the active visualization 
mode is Black & White, controls the threshold for the image-
contouring operation (see Black & White Mode).  
 

Best Fit If this toggle is turned on, the parameters Maximum and Minimum 
are adjusted automatically using the last slice on which the mouse 
cursor was located.  
 

Preview If this toggle is turned on, the window is enlarged to preview the last 
slice on which the mouse cursor was located using the active 
parameters for scaling.  
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Figure 27. Scale image window. 

 
 
 
 

This command scales the anatomical image and not the tomographic solution. Use 
the command Scale Solution for scaling the solution.  

 

Zoom Image 
This command appears in the Display menu and in the local menus of all the work sheets.  
This command makes it possible to magnify that part of the image indicated by the mouse 
cursor. 

Preliminary 
view 

Mimimum, 
Maximum and 
Threshold 
values edition 

When activated, a window is opened for showing with the active zoom factor the area of 
the image where the mouse cursor is located. Pressing the left mouse button increases the 
zoom factor. If the left button is pressed in combination with any of the Shift keys the zoom 
factor is decreased. The zoom factor varies between 2x and 20x. 
 
When this command is activated the form of the mouse cursor changes to or 
to indicate the direction of the magnification. 
 

34  User Manual, BET Viewer , Version 1.3 



Description of comnands 

 

Current zoom 
factor 

Zoom window

Figure 28. Zoom image window. 

 
 
 
 

The zoom window stays open until it is explicitly closed by the user.  

 

Scale Solution 
This command appears in the Display menu and in the local menus of all 
the work sheets.  By means of this command is possible to scale the active 

tomographic solution. When activated, a window is shown that sets the scale type and its 
parameters. There are 8 scale types: 
 
MaxMin In this scale type the values minimum and maximum for scaling the 

tomographic solution are defined. When this type is selected two edit 
box are shown: Minimum and Maximum for editing the values. The 
toggle Best Fit automatically adjusts the scale based on the extreme 
values of the tomographic solution.  
 

Threshold With this scale type is possible to focus on the positive and negative 
values in the tomographic solution. When this type is selected the 
edit box Threshold is shown to define the threshold that will be used 
as the scale limit in both directions: positive and negative. The toggle 
Best Fit automatically adjusts the scale based on the extreme value of 
the tomographic solution. 
 

Step This scale type highlights the peak values inside the tomographic 
solution. When this type is selected the edit box Step is shown for 
defining the scaling parameter which is a positive value. Bigger 
values cause more highlighted peaks. A value of 0 is equivalent to a 
Threshold scale with Best Fit turned on. 
 

Pos/Neg Peak This scale type explicitly visualize the peak positive and negative 
values inside the tomographic solution. This effect is achieved by 
temporarily zeroing all the values in the tomogram that do not 
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coincide with the peak values. When this scale type is selected, the 
edit box Maximum is shown to define the value that will serve as 
extreme value in both directions. The toggle Best Fit is also shown 
which when turned on automatically adjusts the scale based on the 
extreme value of the tomographic solution. 
 

Positive Peak This scale type explicitly visualize the peak positive and negative 
values inside the tomographic solution. This effect is achieved by 
temporarily zeroing all the values in the tomogram that do not 
coincide with the peak values. When this scale type is selected, the 
edit box Maximum is shown to define the value that will serve as 
extreme value in both directions. The toggle Best Fit is also shown 
which when turned on automatically adjusts the scale based on the 
extreme value of the tomographic solution. 
 

Percent With this scale type it is possible to work with the values of the 
tomographic solution in relative rather than real magnitudes. 
Conceptually it is similar to the MaxMin type but the values are 
scaled by percent. For the percent conversion the maximum value of 
the tomographic solution is taken as 100% converting the rest of the 
values in relation to the maximum. When this type is selected two 
edit boxes are shown: Minimum and Maximum for defining the 
values in % and the toggle Best Fit which when turned on causes an 
automatic adjustment based on the extreme values of the 
tomographic solution. 
 

Peak Percent This scale type is similar to Percent but here it is possible to 
determine the sign of the peak value that will be taken as the 
reference of 100%. When this type is selected the edit box Minimum 
is shown to define the minimum value in % (the maximum is always 
100) as well as a radio control Peak to set the sign of the peak value. 
 

Spot With this scale type only the values of the tomographic solution 
included in the interval defined by the parameters are visualized. 
When this type is selected the edit boxes Minimum and Maximum 
are shown to define the interval used for scaling. If the minimum and 
maximum of the solution are given as parameters then this scale type  
is equivalent to a MaxMin scale with Best Fit turned on. Contrasting 
with the Maxmin scale type, the values outside the interval are not 
plotted. 
 

Spot bipolar This scale is similar to Spot., only the values of the tomographic 
solution included in the interval defined by the parameters are 
visualized. When this type is selected the edit boxes Minimum and 
Maximum are shown to define the interval used for scaling in the 
positive direction. The solution values outside the interval (positive 
and negative directions) are not plotted. 

 
 
 
 

The BIPOLAR palette (see Change Palette) is recommended when using the following 
scale types: Threshold, Step, Pos/Neg Peak and Positive Peak.  
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If the toggle Keep scale parameters is turned on, every time a new tomographic 
solution is loaded, it will be scaled using the last scale parameters used. Otherwise 
the scale parameters will be adjusted automatically using the extreme values of each 
tomographic solution.  
 

 

 

Tipo de escala 

Parámetros del tipo 
de escala

Figure 29. Scale solution window. 

 
 
 
 

The toggle Sequence best fit only appears if  the current tomographic solution is a 
sequence. When turned on, an automatic fit is done using the extreme values of  the 
whole sequence and not only  the extreme values of the current solution (as the Best 
Fit toggle does). 
     

 Notice that this command scales the tomographic solution and not the anatomical 
image. Use the command Scale Image for the anatomical image. 
 

Change Palette 
This command appears in the Display menu and in the local menus of all the work sheets. 
Using this command is possible to change the active palette by selecting a new one or by 
editing the present one. When this command is activated a window is shown with several 
controls: an option list indicating the active palette's name, the active palette's preview, an 
option for interpolating the palette and the Edit button for editing the palette.  
 
The palettes in BET Viewer can use up to 256 colors.  If the palette does not have 256 
colors (as usual) and the option for interpolating is set, the application linearly interpolates 
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the present colors up to 256 to obtain the palette that is actually used in the work sheets. If 
the option for interpolating is not set, the palette will be used without interpolation. 
 
By means of the option list it is possible to select any one of the available palettes. Once the 
window is closed with the Ok button the newly selected palette will become the active 
palette of the application.  If the Edit button is pressed the window is enlarged adding new 
controls to change the palette. 
 

 

Palette 
selection 

Preliminary 
view 

Number of 
colors 

Current colorInterpolation 
option 

Button for 
changing color 

Buttons for 
moving colors 

Add and Delete  
color buttons

Button for 
editing 
palette 

Figure 30. Change palette window. 

 
The first element that appears is a vertical bar divided by the quantity of real colors that 
compose the palette. The colors are denoted in bottom up order from 0 to the number of 
colors-1. The number of colors is indicated in the box Colors.. Dragging the mouse over the 
cursor (  ) to the right of this bar sets the active color. The active color can also be selected 
with the edit box Current. 
 
There are also 5 buttons for editing the palette: 
 

 

This button changes the active color. When pressed, opens the 
standard Windows dialog for selecting colors.  
 

 

This button moves the active color up in the palette. It is disabled 
when the active color is the last one in the palette. 
 

 

This button allows moving the active color down in the palette. It is 
disabled when the active color is the first one in the palette. 
 

 

This button adds a new color in the palette. When pressed, opens the 
standard Windows dialog for selecting colors. Once chosen, the new 
color becomes the active color and is inserted after the previously 
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active color. It is disabled when the palette reaches the maximum of 
256 allowed colors. 
 

 

This button erases the palette's active color. The following color 
becomes the new active color. This button is disabled when the 
palette reaches the minimum of 2 colors. 

 
When pressing the Ok button a dialog for saving the recently edited palette is presented if 
any editing was carried out. The palette files are stored as files .LEV in the application's 
directory. 
 

 
 
 

The palette GRAYS cannot be altered since it is the one used by the Black & White 
visualization mode. The palette BIPOLAR can be edited but should keep its name. 

 

Show time course 
This command in the Display menu shows the temporal course (if a sequence is loaded) of 
a selected voxel. When activated a dialog is presented containing a plotting window 
showing the temporal course of the voxel indicated by the orthogonal cursors in the 
Orthogonal Planes sheet. 
 
The dialog can be closed with the Close button at any moment staying visible for allowing 
updating of the plotting window with a new voexl whenever the cursor position is changed. 
If the cursor position is updated by pressing the Alt key in conjunction with the left button 
mouse a new voxel is added to the plotting window instead of updating it. 
 

 
 
The vertical bar in the plotting window is a cursor for selecting a temporal point inside the 
temporal course. The tomographic solution corresponding to that point is updated in the 
working sheets whenever the cursor is updated. 
In the dialog other elements are presented. The combo box Voxel allows to select the active 
voxel (if more than one is plotted). The voxel visibilty can be set wit the check box besides 
the combo box as well as the color and thickness of the wave. The following combo box 
shows the current temporal instant as well as the voxel’s value in that temporal position. 
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Generate Movie 
This command in the Display menu creates a temporal animation using the sequence 
already loaded. When activatated, the command shows a dialog for selecting the filename 
for saving the animation in .AVI format. Once the selection is made, the animation begins 
starting with the first solution in the sequence  and using the active parameters for working 
with sequences (see Scale Solution and Step in Sequence).  
 

 
 
 

The animation generated can be played with any multimedia player supporting the 
.AVI format or with the command Play Movie. 

 
 
 

Movie generation can be aborted by pressing the Esc key. 

 
 

Play Movie  
This command appears in the Display menu. With this command it is possible to play any 
.AVI animation created with Generate Movie, with the 3D View work sheet or any other 
application. When pressed a dialog is shown for loading the .AVI file desired. Once the file 
is loaded a window is shown with 7 buttons: Play, Play, Stop, First frame, Rewind, Fast 
forward, Last frame and Close that will control the execution of the animation.  There is 
also a track bar which monitors the animation status. 
 

 

Figure 31. Play movie window. 
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Next Solution 
This command in the Display menu.loads the tomographic solution following the active 
one in the sequence (see Open Solution) taking into account the defined step (see Step in 
Sequence). The command is disabled if the active tomographic solution is not a sequence 
or if it is the last one in the sequence. 
 

Previous Solution 
This command in the Display menu loads the tomographic solution before the active one in 
the sequence (see Open Solution) taking into account the defined step (see Step in 
Sequence). The command is disabled if the active tomographic solution is not a sequence 
or if it is the first one in the sequence. 

First Solution 
This command in the Display menu loads  the first tomographic solution of the sequence 
(see Open Solution). The command is disabled if the active tomographic solution is not a 
sequence or if the active solution is the first one in the sequence. 
 

Last Solution 
This command in the Display menu loads the last tomographic solution of the sequence 
(see Open Solution). The command is disabled if the active tomographic solution is not a 
sequence or if the active solution is the last one in the sequence. 
 

Go to Solution 
This command in the Display menu. selects a particular solution inside the sequence (see 
Open Solution). The command is disabled if the active tomographic solution is not a 
sequence. 
 

 

Figure 32. Go to Solution dialog. 
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Step in Sequence 
This command in the Display menu setts the step which will be used for moving between 
solutions in the sequence. (see Open Solution). The command is disabled if the active 
tomographic solution is not a sequence.  

 

 

Figure 33. Step in sequence dialog. 

Set labels 
This command in the Display menu allows tu set labels for the current sequence loaded. 
When activated a dialog is presented for setting the parameters needed for generating 
automatically the sequence labels. There are 3 edit boxes: Initial Value, Sampling rate and 
Units. The Initial Value field allows to set by using digits the starting value for the sequence 
labels. Sampling rate will indicate the numeric value needed for obtaining the label for the 
next labels. The label value in a given instant is calculated by adding the label value in the 
previous instant with 1/ Sampling rate. The Units field will indicate the units used if any. 
The command is disabled if the active tomographic solution is not a sequence. 
 

 
 

Toolbar 
This command in the View menu works as a toggle: when turned on the toolbar is 
visualized under the horizontal menu of the application; otherwise the toolbar is hidden, 
leaving more space on screen for the work sheets. 
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Status bar 
This command in the View menu works as a toggle: when turned on the status bar is 
visualized in the bottom of the main window application; otherwise the status bar is 
hidden, leaving more space on screen for the work sheets.  
 

Atlas information bar 
This command in the View menu works as a toggle: when turned on the Atlas information 
bar is visualized at the bottom of the main window application above the status bar; 
otherwise the Atlas information bar is hidden leaving more space on screen for the work 
sheets. This bar shows the name of the anatomical structure where the mouse cursor is 
located. 
 

 This command only is enabled if the anatomical image of the active configuration 
has an associated atlas or the active configuration includes an atlas. 

 

Full Screen 
This command in the View menu works as a toggle: when turned on the main window 
application is maximized and at the same time the horizontal menu, the toolbar, and the 
status bar are hidden, leaving the whole available space on screen for the work sheets. Use 
the Esc key to return to the normal mode. 
 

Show orthogonal bars 
This command in the View menu works as a toggle:  when turned on, bars indicating the 
position of the 2 orthogonal planes to every plane are shown on it. 
 

 
 
 

This command only is enabled in the work sheet Orthogonal Planes.  

 
 

Grid's steps 
This command in the View menu works as a toggle: when turned on, the cursors of the 
sheet Orthogonal Planes will move only in the grid's steps and when turned off they will 
move from voxel to voxel. The tomographic values are directly calculated for the slices 
intercepting with the grid and interplolated for other slices. 
 

 
 
 

This command only is enabled in the work sheet Orthogonal Planes.  
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Show grid 
This command in the View menu works as a toggle: when turned on, the grid points are 
superimposed on the tomographic slices visualized in the work sheets. The activation of this 
command inactivates the command Show vectors and vice versa. 
 

 

Figure 34. Overlapping of the grid on the tomographic slices. 

 
 

 The overlapping of the grid is not carried out in the 3D View sheet and the command 
is disabled in that sheet.  
 

 The overlapping of the grid is carried out only over the slices intercepting the grid. 
 

Show vectors 
E This command appears in the View menu.  It works as a toggle, when turned on, the 
vectors which indicate the generators direction are superimposed on the tomographic slices 
visualized in the work sheets. The activation of this command inactivates the command 
Show grid and viceversa. The vectors are visualized by means of arrows that point in the 
corresponding direction of the current dipoles. If the direction is perpendicular to the plane, 
it will be indicated with a point or a cross if the vector is "entering" or "leaving" respectively. 
 
 

 Overlapping of the vectors is not carried out in the 3D View or in the Max. Intensity 
Projection sheets and the command is disabled in these sheets. If the type of active 
tomographic solution does not contain information about the direction of the 
generators, e.g. .ENG files, the command is also disabled. 
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 Overlapping of the vectors is carried out only over the slices intercepting the grid. 

 
 
 

 

Figure 35. Overlapping of the vectors on the tomographic slices. 

Show Atlas 
This command in the View menu works as a toggle: when turned on, the atlas is 
superimposed on the tomographic slices in the work sheets.  
 

 The overlapping of the atlas is not carried out in the 3D View or in the Max. Intensity 
Projection sheets and the command is disabled in these sheets.  
 

 This command is only enabled if the anatomical image of the active configuration 
has an associated atlas or the active configuration includes an atlas. 
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Figure 36. Overlapping of the Atlas on the tomographic slices. 

Grid/Vector style 
This command in the View menu brings up a window to define the style for visualizing the 
grid (with the command Show grid) and  the vectors (with the command Show vectors). 
The Complement or Solid style can be selected using the radio control. The style 
Complement uses the color complementary to the color already on screen. The style Solid 
draws using a specified color. If the Solid style is chosen the Color button is enabled and 
pressing it brings up the standard Windows dialog for selecting colors. 
 

 

Figure 37. Selection of style dialog for grid and vectors. 

Atlas settings 
This command in the View menu set the atlas configuration for viewing. When activated, a 
dialog is presented for setting visibility, color and style for the different structures present in 
the atlas. 
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With the Structures list it is possible to select the structure(s) for changing its attributes 
(visibility and color). The commands Load and Save allow to load and save respectively 
visibility and color settings from/to a ATS file for using them in ulterior working sessions. 

Plot Maximum in sequence 
This command in the View menu works as a toggle: when turned on, every time a solution 
is loaded from the sequence (see Open Solution), the Orthogonal Planes sheet will visualize 
the solution in the 3 planes containing the point where the tomographic solution reaches its 
maximum magnitude and the solution will be scaled automatically using its extreme values 
(see Use Maximum). The command is disabled if the active tomographic solution is not a 
sequence.  
 

Tomography Mode 
This command in the View menu sets the active visualization mode to tomography. In this 
mode the integration of the color of the tomographic solution with the anatomical image is 
carried out using the intensity of the anatomical image as the intensity coefficient for the 
color. The voxels of the anatomical image with more intensity will have a brighter color in 
the tomographic solution. This command is one of several options to set the active 
visualization mode: Inverse Tomography Mode, Map Mode, Image Mode and Black&White 
Mode. 
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Figure 38. Tomographic visualization mode. 
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Inverse Tomography Mode Inverse Tomography Mode 
This command in the View menu sets the active visualization mode to inverse tomography. 
In this mode the integration of the color of the tomographic solution with the anatomical 
image is carried out in the same way as in the Tomographic mode using the intensity of the 
anatomical image as intensity coefficient for the color, but the inverse of the intensity of the 
anatomical image is used. The voxels of the anatomical image with more intensity will have 
a darker color in the tomographic solution and vice versa. This command is one of several 
options to set the active visualization mode: Tomography Mode, Map Mode, Image Mode 
and Black&White Mode. 

This command in the View menu sets the active visualization mode to inverse tomography. 
In this mode the integration of the color of the tomographic solution with the anatomical 
image is carried out in the same way as in the Tomographic mode using the intensity of the 
anatomical image as intensity coefficient for the color, but the inverse of the intensity of the 
anatomical image is used. The voxels of the anatomical image with more intensity will have 
a darker color in the tomographic solution and vice versa. This command is one of several 
options to set the active visualization mode: Tomography Mode, Map Mode, Image Mode 
and Black&White Mode. 
  

Description of comnands 
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Figure 39. Inverse Tomographic visualization mode. 

 
 
 
 

With this mode is possible to highlight the color in the gray matter and to attenuate 
the color in the white matter of the brain. 
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Map Mode 
This command in the View menu sets the Map mode as the active visualization mode. In 
this mode there is no integration of the color of the tomographic solution with the 
anatomical image.  The tomographic solution is visualized independently of the underlying 
anatomical image. This command is one of several options to set the active visualization 
mode: Tomography Mode, Inverse Tomography Mode, Image Mode and Black&White 
Mode. 
 

 

Figure 40. Map visualization mode. 

 
 
 
 

With the Map mode is possible to visualize details of the tomographic solution that 
might be hidden if the solution were integrated with the anatomical image . 
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Image Mode 
This command in the View menu sets the Image mode is set as the active visualization 
mode. In this mode as in the Map mode there is no integration of the color of the 
tomographic solution with the anatomical image.  The anatomical image is visualized 
ignoring the corresponding tomographic solution. This command is one of several options 
to set the active visualization mode: Tomography Mode, Inverse Tomography Mode, Map 
Mode and Black&White Mode. 

 

 

Figure 41. Image visualization mode. 

 
 
 
 

The Image mode is very convenient for visualizing the details of the anatomical 
image that could not be easily observed when integrated with the tomographic 
solution. 
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Black & White Mode 
This command in the View menu sets the Black & White mode as the active visualization 
mode. In this mode the tomographic solution is visualized with a gray palette (GRAYS) and 
the anatomical image is reduced to contours. There is no real integration of the color of the 
tomographic solution with the anatomical image. This command is one of several options 
to set the active visualization mode: Tomography Mode, Inverse Tomography Mode, Map 
Mode and Image Mode. 
 

 
 
 

To control the contouring of the anatomical image the command Scale Image should 
be used to vary the Threshold parameter and its relationship with Maximum and 
Minimum. 
 

 
 
 

The Black & White mode is very convenient for printing on printers without color 
capability. 

 
 
 

Since the palette is automatically change in this mode, the palette should be checked 
when changing to another visualization mode. 

 

 

Figure 42. Black & White visualization mode. 
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Isocontour Mode 
This command in the View menu View sets the Tomographic mode as the active 
visualization mode. In this mode the tomographic solution is visualized through isocontours 
that are superimposed on the underlying anatomical image. This command is one of several 
options to set the active visualization mode: Tomography Mode, Inverse Tomography 
Mode, Map Mode, Image Mode and Black&White Mode. 
 

 

Figure 43. Isocontour visualization mode. 

 
 
 
 

The command Isocontour style controls how the isocontours cover the image. 
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Invert Black & White 
This command appears in the View menu. It works as a toggle to invert the palette direction 
in the Black & White visualization mode (see Black & White Mode). 
 

 
 
 

This command only is enabled if the active visualization mode is Black & White. 

 

Use Maximum 
This command appears in the View menu. It works as a toggle, when not active the action 
in the commands Show Maximum and Plot Maximum in sequence is inverted becoming 
Show Minimum and Plot Minimum in sequence. The work sheet Max. Intensity Projection 
becomes Min. Intensity Projection also, plotting in this case only the values with the 
minimum intensity. 
 

Invert MIP back. 
This command appears in the View menu. It works as a toggle, when not active the image 
background in the sheet Maximun/Minimun Intensity Projection is plotted in black. When 
active the background is inverted and becomes white. 
 
 

Isocontour style 
This command in the View menu sets the way in which the isocontours are plotted (see 
Isocontour Mode). By means of an edit box it is possible to set  the step between  an 
isocontour and the next one. When the step is small the the isocontours will cover more of 
the image and viceversa. 
 

 

Figure 44. Dialog for Isocontour style. 
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Slice orientation 
This command in the View menu brings up a dialog window to selecting the orientation of 
the slices in each plane appears.  
 

 

Figure 45. Slice orientation dialog. 

 

Plane in All Slices 
This command in the View menu opens a dialog window to select which orthogonal plane 
will be shown in the All Slices work sheet (see All Slices). 
 
 

All Slices Reference 
This command in the View menbrings up the auxiliary reference window in the All Slices 
work sheet (see All Slices).  
 
 

Contents 
This command in the Help menu opens the BET Viewer help system using the standard 
Windows help system. 
 

 
 
 

The shortcut key F1 provides help specific to some windows in the application. 

Keyword Search 
This command in the Help menuopens the BET Viewer help system for keyword search 
using the standard Windows help system. 
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Using Help 
This command in the Help menu opens the standard Windows help system explanations. 
 
 

About 
This command in the Help menu shows information about the application.  
 
 
 
 

What's This ? 
This command appears in the local menus of the work sheets 3D View and Electrode View. 
When activated, a window shows the parameters used for the rendering on which the 
mouse cursor is located when it was carried out. The window can be closed by pressing the 
left button mouse or the Esc key.  
 

 

Figure 46. Parameters report for the rendering 3D. 

Clear this 
This command in the local menus of the work sheets 3D View and Electrode View deletes 
the rendering on which the mouse cursor was located. For deleting all the renderings the 
command Clear all should be used.  

 

Show Identifiers 
This toggle command in the local menu of the Electrode View work sheet shows the names 
of the visible electrodes.  
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