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1. SQLGate for MySQL Introduction 

1.1. Introduction 
SQLGate for MySQL is a database management tool which helps you with an easy development and  

management for MySQL database applications. 

It shortens development time and increases business efficiency of database manager and application developer by  

providing user-friendly interface and various features. 

If you use features such as SQL Tuning feature and Query Builder, you can create and execute SQL easily. Moreover,  

you can work by connecting to server conveniently without installing MySQL client. 

 

 

 

1.2. Technical Support 
If you have any questions about this software, refer to this document or post questions on the Technical Forum in  

company’s homepage (http://www.sqlgate.com/en/support/). 

Technical Support : +82-2-338-1876 
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2. Product Specification 

2.1. Major Specification 
 Unicode Support 

SQLGate supports Unicode. Multilingual can be handled through it.  

UTF8, UTF16, AL32UTF8 character sets are supported. 

 

 User Friendly Interface  

It consists of editor, grid and user friendly interface, which are convenient and powerful features.  

It satisfies user’s needs by providing various styles and options to grid, such as XP, Float, Office and so on.  

 

 Access by using MySQL Protocol Directly 

It supports optimized method, which acceses to MySQL directly throught TCP/IP by using MySQL protocol,  

without MySQL Client installation or ODBC registration.  

 

 SSH Tunneling 

When users try to access to MySQL, which is available to access through SSH service,  

they can access with self SSH Tunneling feature of SQLGate without installing additional program.  

 

 Easy and Fast Query Execution  

Users can create and execute SQL code easily, if they use SQL Query Editor and Query Builder. 

 

 Powerful Object Browser 

It helps inquiry, creation, modification and deletion for each user through object browser.  

Users can inquire easily and quickly by linking with SQL Query Editor. 

 

 Database Monitoring Features of Various Types  

It provides various database monitoring features, such as Process Manager, User Manager, Database Information and  

Server Statics.  

 

 Tool of Various Features Provision  

Even beginner can handle several database management tasks by providing various tools, such as Database Backup,  

Import/Export Utility Wizard, editor and so on.  

 

 Report Tool to Print as Desired Types 

Users can design directly and print out data by using Report Designer and shorten creation time of various reports. 

 

 ER Design Feature 

Users can create ERD (entity-relationship diagram) by reversing relationship between tables in ER Design window  
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without installation of separate program. 

 

 

2.2. Operation Environment 
 Operation Environment 

All of Windows Family OSs  

Over Intel Pentium 4 

Over 512MB Memory  

Over 50MB free hard disk space 

 

 Configuration  

Features of folders, which are composed program, are as follows.  

Bin : Composed of execution files and ini, dat files  

Languages : Folder to support multilingual  

Report : Folder to save report samples  

Screen : Dll files, which are needed at form configuration 

Webscript : Webscript template file 

Workspace : Temporary save folder for SQL Query Editor 
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3. Main Menu 

3.1. File 
3.1.1. New 

It creates new SQL Query Editor or Query Builder window. 

SQL QUERY EDITOR : Select [File] > [New] > [SQL Query Editor] on the main menu or press the shortcut key,  

< Ctrl+N > or the [ ] button. 

Query Builder : Select [File] > [New] > [Query Builder] on the main menu or click the [ ] button. 

ER Design : Select [File] > [New] > [ER Design] on the main menu or click the [ ] button. 

 

 

3.1.2. New Connection 

Select [File] > [New Connection...] on the main menu or click the [ ] button. 

 

 

 [Login] 
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Host : IP address of the server, which operates MySQL server 

SSH Tunnelling : Select when access by using SSH service 

User : Connection account 

Password : Password 

Save Password : Select whether to save password 

Port : Port number of MySQL server 

Database : Database name to connect to MySQL server 

Character Set : Character set of client  

Date Format : Date type format 

Color : Select color by session when you connect to several MySQLs 

[Test Connection] : Execute connection test to inputted information 

 

 [SSH] 

 

Authentication Kind : Select SSH access authentication method. 

Password : Authentication with password on SSH login. 

Public key : Authentication with key file on SSH login. 

SSH Server IP Address : IP address of the server, which operates SSH server. 

SSH Port : Port number of SSH server. 

User : Connection account 

Password : Password 

MySQL Connection : Access method to MySQL server by using SSH service. 

Connect SSH Directly : Access to MySQL server directly through SSH service. 

Local Port Forwarding : Access to MySQL by forwarding port to local PC. 

Listen Port : Input port number when forwards local port. 

 

 

3.1.3. Disconnect 
Disconnects to currently connected MySQL server. 

Select [File] > [Disconnect] on the main menu. 

 

 

 

3.1.4. Disconnect All 
Disconnects to currently all connected MySQL servers. 

Select [File] > [Disconnect All] on the main menu. 
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3.1.5. Reconnect 
Reconnects to currently connected MySQL server. 

Select [File] > [Reconnect] on the main menu. 

 

 

3.1.6. Change Password 
Select [File] > [Change Password…] on the main menu. 

You can change password of a user, who is currently connected. 

 

 

 

3.1.7. Open 
If you select [File] > [Open …< Ctrl+O >] on the main menu, Open File dialog will be shown. 

If you select a file, the file will be opened on SQL Query Editor. If SQL Query Editor doesn’t exist,  

the file will be opened after executing new SQL Query Editor. 

 

 

3.1.8. Recent Files 
If you select [File] > [Recent Files] on the main menu, list of recently opened files is shown. 

If you select a file, the file will be opened on SQL Query Editor. If SQL Editor doesn’t exist,  

the file will be opened after executing new SQL Query Editor. 

 

 

3.1.9. Save 
If you select [File] > [Save < Ctrl+S >] on the main menu, you can save contents on SQL Query Editor. 

 

 

3.1.10. Save As 
If you select [File] > [Save As...< Ctrl+Shift+S >] on the main menu, you can save contents on SQL Query Editor  

as new name. 

 

 

3.1.11. File Encoding 
If you select [File] > [File Encoding] on the main menu, you can convert encoding type of SQL Query Editor into  

ANSI, Unicode, Swapped Unicode or UTF-8. 
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3.1.12. File Type 
If you select [File] > [File Type] on the main menu, you can convert file type of SQL Query Editor into Default,  

Windows(CR/NL), Macintosh(CR) or Unix(NL). 

 

 

3.1.13. Close Window 
If you select [File] > [Close Window] on the main menu, you can close the current window. 

 

 

3.1.14. Close All Windows 
If you select [File] > [Close All Windows] on the main menu, you can close all windows. 

 

 

3.1.15. Print Preview 
Select [File] > [Print Preview] on the main menu to open preview window. 

 

 

3.1.16. Print 
Select [File] > [Print…] on the main menu to print contents on SQL Query Editor. 

 

 

3.1.17. Printer Setting 
Select [File] > [Printer Setting…] on the main menu to set printer and page setting. 

 

 

3.1.18. Exit 
Select [File] > [Exit] on the main menu to close program after disconnecting connected session. 
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3.2. Edit 
3.2.1. Undo 

Cancel the just previous task.  

Select [Edit] > [Undo] on the main menu or press the shortcut key < Ctrl+Z >. 

 

 

3.2.2. Redo 
Re-execute canceled task. 

Select [Edit] > [Redo] on the main menu or press the shortcut key < Shift+Ctrl+Z >. 

 

 

3.2.3. Cut 
Cut off selected contents.  

Select [Edit] > [Cut] on the main menu or press the shortcut key < Ctrl+X >. 

 

 

3.2.4. Copy 
Copy selected contents to clipboard. 

Select [Edit] > [Copy < Ctrl+C >] on the main menu or press the shortcut key < Ctrl+C >.  

 

 

3.2.5. Paste 
Paste contents in clipboard. 

Select [Edit] > [Paste < Ctrl+V >] on the main menu or press the shortcut key < Ctrl+P >.  

 

 

3.2.6. Paste from the code 
Paste SQL statement by extracting from content of clipboard.  

Select [Edit] > [Paste from the code] > [Paste from the code] on the main menu  

or press the shortcut key < Shift+Ctrl+C >. 

※ Ex) Clipboard : “select * from member”  

※ Paste in the code : select * from member 

 

 

3.2.7. Select All 
Select all texts in editor. 

Select [Edit] > [Select All < Ctrl+A >] on the main menu or press the shortcut key < Ctrl+A >.  

 

3.2.8. Clear All 
Clear all texts in editor. 

Select [Edit] > [Clear All] on the main menu.  

 

3.2.9. Find and Replace 
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Find or Replace contents in editor. 

Select [Edit] > [Find and Replace] > [Find… < Ctrl+F >] on the main menu. 

To replace, select [Edit] > [Find and Replace] > [Replace… < Ctrl+R >] on the main menu. 

 

 

3.2.10. Bookmark 
Add, Move or Delete bookmark in editor. Select [Edit] > [Bookmark] on the main menu. 

Select [Edit] > [Bookmark] on the main menu. 

- [Toggle Bookmark] : Add bookmark. 

- [Goto Bookmark] : Move to bookmark. 

- [Clear All Bookmarks] : Delete all bookmarks. 

 

 

3.2.11. Goto line 
Move to inputted line at the Goto line dialog. Select [Edit] > [Goto line… < Ctrl+G >] on the main menu or  

press the shortcut key < Ctrl+G>. 

 

 

 

3.2.12. Word Wrap 
The text wraps around if it is longer than horizontal area of the editor. 

Select [Edit] > [Word Wrap] on the main menu.  

 

 

3.2.13. Show Space/Tab/Carriage Return 
Space, Tab and Carriage Return will be shown among texts in editor. 

Select [Edit] > [Show Space/Tab/Carriage Return] on the main menu.  

 

 

3.2.14. Toggle Folding 
Set to fold editor. 

Select [Edit] > [Toggle Folding] on the main menu.  

 

 

3.2.15. Comment Block 
Make selected text in editor into comments.  

Select [Edit] > [Comment Block] on the main menu or press the shortcut key < Ctrl+- >. 

 

 

3.2.16. Uncomment Block 
Remove blocked comments of selected texts in editor. 
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Select [Edit] > [Uncomment Block] on the main menu or press the shortcut key < Shift+Ctrl+- >. 

 

 

3.2.17. Convert to 
Convert selected texts in editor into upper case, lower case, upper/lower case or  

convert only first character into upper case.  

Select a submenu of [Edit] > [Convert to] on the main menu. 

 
 

3.2.18. Increase Indent 
Indent one line in editor. (Shortcut key < Tab >) 

Select [Edit] > [Increase Indent] on the main menu.  

 

 

3.2.19. Decrease Indent 
Unindent on line in editor. (Shortcut key < Shift + Tab >) 

Select [Edit] > [Decrease Indent] on the main menu.  

 

 

3.2.20. Convert SQL 
Convert texts in editor into Delphi, Visual Basic, ASP, PHP, JSP code and copy to clipboard.  

Select a submenu of [Edit] > [Convert SQL] on the main menu. 

 

 

 

3.2.21. Description Schema 
Open Description Schema window about the keyword, where a cursor is located in editor. (Shortcut key < F4 >) 

Select [Edit] > [Description Schema] on the main menu. 

 

 

3.2.22. Editor Options 
Set options of editor. 

Select [Edit] > [Editor Options…] on the main menu. 

 

 [General] 

Set general options.  
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 [Font] 

Set font options.  

 

If specific text is broken in editor, change the Character Set. 

 

 [Highlight] 

Set highlight options.  

 

If you select highlight option or select sentence in editor, highlights will be selected automatically. 
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 [Code Template] 

Add, Edit or Delete code template. 

 

If you press < Ctrl+J > in editor, template will be displayed. 

 

 [Keyword Template] 

Add, Edit or Delete keyword template. 
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 [Auto Completion] 

Set whether to use Auto Completion feature. 

 

- Code Auto Completion < Ctrl+J > : Display contents in code template. 

- Keyword Auto Completion < Ctrl+K > : Keyword Auto Completion will be displayed  

if you type more than 3 characters. 

- Reuse SQL < Ctrl+M > : Checked sentences are displayed among contents in SQL history. 

- Field Auto Completion < . > : Display field lists next to table alias. 

- Keyword Change Case Auto Completion : Display completed keyword by Keyword Auto Completion  

in distinguishing upper/lower character. 

- Auto Completion for Change Case of Object Name : Selected object by Table Auto Completion  

in distinguishing upper/lower character. 

- Table Auto Completion < Ctrl+H > : List object next to From/into/set. You can use it optionally  

when there are too many objects. 

 

※ You should select Keyword Auto Completion < Ctrl + K > at [Auto Completion] tab to execute it  

in SQL Query Editor. 
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3.3. View 
3.3.1. Object Panel 

Object panel can be docked at the left or right of the main window and it can search and manage objects. 

If you select an object, detail information about the object will be shown at the bottom of the window. 

If you click the right mouse button after selecting an object, you can add, delete, edit or manage it. 

You can add SQL to SQL Query Editor or PL/SQL Query Editor simply by using Object Scripting feature. 

You can join, sort and filter between objects by dragging and dropping an object to Query Builder. 

You can create various queries and check results with only simple operation. 

Select [View] > [Object Panel] on the main menu or click the [ ] button. 
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 Object Scripts 

If you click the right mouse button after selecting Table or View objects, you can use Object Scripts menu,  

helping SQL creation. 

 

- [Paste | Select] : Paste Select script of the selected object to SQL Query Editor. 

- [Replace | Select] : Change the Select script of the selected object in SQL Query editor. 

- [New Tab | Select] : Open Select script of the selected object in new tab. 

- [New Window | Select] : Open Select script of the selected object in new SQL Query Editor window. 

- [Drop Script]: Paste Drop script of the selected table or view to SQL Query Editor. 

- [Insert Script] : Paste Insert script of the selected table or view to SQL Query Editor. 

- [Update Script] : Paste Update script of the selected table or view to SQL Query Editor. 

- [Delete Script] : Paste Delete script of the selected table or view to SQL Query Editor. 
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3.3.2. SQL History 
SQL Query Editor saves SQLs, which executed successfully. 

Check [Tools] > [Options …] > [SQL Query Editor] > [Auto Save SQL History] to save SQL history. 

 

- Auto Save SQL History : Option for whether to save. When checked, SQL will be saved. 

- Max Save Count of SQL History : 

 Unlimited : Save all without limitation. 

 Count : Save as much as inputted number. 

- Store Point of SQL History : 

 After Execution : Save only succeeded query command. 

 Before Execution : Save all query commands. 

 

Select [View] > [SQL History …] on the main menu or click the shortcut key < F8 > or the [ ] button. 
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You can add folder by selecting [New Group] on the context menu (by clicking right button of the mouse)  

after selecting [User Directory] in the left tree. 

 

DML is saved to [SQL History] group basically and other SQLs are saved to [Proc/Func History] group. 

SQL can move from SQL history list to the other group through drag&drop. 

If you double click grid, the selected SQL transfers to SQL Query Editor. 

You can save or open SQL history through [Open File] or [Save File] button. 

 

 SQL Reuse 

Check at the [Reuse] checkbox of [User Directory] group and SQL histories, which are contained in sub groups. 

 

 

Call it through the shortcut key < Ctrl+M > in SQL Query Editor. 

Select one among reuse lists. 
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SQL, which is saved in SQL history, is inputted automatically. 

 

 

3.3.3. SQL Align Options 
It is option for alignment feature of created SQL. 

Select [View] > [SQL Align Options…] on the main menu. 

 

- Default : Set Upper/Lower case, Clear Comment, Remove Blank and Separator of keyword. 

- Line break : Set location of line to change. 

- Align & Indent : Set alignment of Keyword, Operator, AS Keyword, Comment, AND/OR and so on. 

- Comma : Set blank before/after comma. 

- Parenthesis : Set blank before/after parenthesis. 

- Operator : Set blank before/after operator. 
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3.4. Query 
3.4.1. Create SQL 

If you select [File] > [New] > [SQL QUERY EDITOR] on the main menu or press the shortcut key< Ctrl+N > or  

the  button, SQL Query Editor window will be shown. You can use up to 20, if you use tab.  

You can use SQL Query Editor and grid in each tab separately. 

 

 Context Menu of SQL QUERY EDITOR Tab 

You can use up to 20, if you use tab. You can use SQL Query Editor and grip in each tab separately. 

If you click the right mouse button in tab, context menu will be shown. 

 

[Close < Ctrl+Alt+D >] : Close the tab. 

[Close All But This] : Close all tables except the current tab. 

[Close All] : Close all tabs. 

[Add Editor < Ctrl+Alt+N >] : Add a tab. 

[Open File < Ctrl+O >] : Open a file in the current tab. 

[Save As…] : Save SQL in the current tab as another name. 

[Save < Ctrl+S >] : Save SQL in the current tab. 

[Print Preview < Ctrl+P >] : Preview contents to print in the current tab. 

 

 Context Menu of SQL QUERY EDITOR 

If you click the right mouse button in SQL Query Editor, following popup window will be shown. 

 

[Run SQL < F5 >] : Execute SQL in editor /  Execute SQL of the selected text 

[Run SubQuery block < Alt+F5 >] : Execute blocked SQL where cursor is located 

[Run Current SQL < Ctrl+F5 >] : Execute only SQL where cursor is located 

[Run Current SQL & Modify < F6 >] : Execute SQL and modify 

[Execution plan of current SQL < F7 >] : View execution plan of SQL 

[Execution plan Block SQL < Alt+F7 >] : View execution plan of blocked SQL where 

cursor is located 

[Query Description < Shift+F4 >] : Field definition by analyzing SQL statement 

[Row Count < F12 >] : Count records where cursor is located at 

[SQL Align < F9 >] : Align all SQLs in editor 

[Undo < Ctrl+Z >] : Cancel execution 

[Redo < Shift+Ctrl+Z >] : Re-execute  

[Cut < Ctrl+X >] : Cut off 

[Copy < Ctrl+C >] : Copy 

[Paste < Ctrl+ V>] : Paste 

[Paste from the code] : Extract SQL from other program codes 

[Clear All] : Clear all 

[Find and Replace] : Find, Find Next, Find All, Find from first , Find the last 

[Bookmark] : : Toggle bookmark 

[Goto line < Ctrl+G >] : Move directly to the line by inputting line number 

[Word Wrap] : WordWrap 
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[Show Space/Tab/Carriage Return] : Show space, tab and carriage return character 

[Toggle Folding] : Show + and - symbols 

[Comment Block < Ctrl+- >] : Set comment 

[Uncomment Block < Shift+Ctrl+- >] : Release comment 

[Convert to] : Convert to upper/lower character  

[Increase Indent] : Indent the line where cursor is located 

[Decrease Indent < Shift+Tab >] : Unindent line where cursor is located 

[SQL CONVERT] : Convert into Delphi, Visual Basic, ASP, PHP and JSP code 

[Description Schema < F4 >] : Show Describe window of keyword where cursor is 

located 

[Editor Options] : Open editor options window 

 

 

3.4.2. Run SQL 
Executes created SQL in SQL Query Editor. If several SQLs are executed, it is separated with semicolon <;>.  

Select [Query] > [Run] on the main menu or press the [ ] button or < F5 > key. 

In case of Select statement, execution results are displayed as grid type in [Data] tab at the bottom 

In case of non Select statement, execution results are displayed in [Message History] tab. 

Select the [ ] button or press < ESC > key to cancel execution.  

 

 

If you select text in SQL Query Editor, only selected text will be executed. 

 



SQLGate for MySQL User Manual 
 

< 25 >    http://www.antwiz.com 

 

If there is no selected block, all SQLs will be executed. 

In case of executing several SQLs, use semicolon < ; > to separate. 

 

 

If you click the [ ] button on the above image, grid will be displayed horizontally without re-executing SQL. 
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3.4.3. Run Current SQL 
Executes SQL, where cursor is located, only in SQL Query Editor.  

Select [Query] > [Run Current SQL] on the main menu or press the [ ] button,  

< Ctrl+F5 > key or < Ctrl+Enter > key. 

 

Execute SQL (‘SELECT * FROM help_category’) in the line, where cursor is located. 

 

 

3.4.4. Run SubQuery block 
Run subquery in the line, where cursor is located, in SQL Query Editor. Subquery can be executed even it is not in 

block. Font color of subquery in editor is changed automatically. Also the [Run SubQuery block < Alt+F5 >] button 

is activated. 

 

Select [Query] > [Run SubQuery block] on the main menu or press the [ ] button or < Alt+F5 > key. 

 

※ Background color of subquery is changed automatically. 
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3.4.5. Run Current SQL & Modify 
You can run created SQL in SQL Query Editor and modify data in grid. 

Run Current SQL & Modify is available to run for one Select query. Primary Key column should be included to select 

script to run. 

Select [Query] > [Run Current SQL & Modify] on the main menu or press the [ ] button or < F6 > key after 

creating Select query statement. 

Navigation is displayed at grid of [Data] tab as modification mode. 

You can insert/modify/delete by selecting grid. 

 
 

3.4.6. Execution plan of current SQL 
Executes Execution Plan for created SQL in SQL Query Editor. Results will be shown as tree type after executing 

‘Explain Plan’ command, which saves execution plan to plan table. Plan table must exist to execute Execution Plan.  

Press [Query] > [Execution plan of current SQL] on the main menu, the [ ] button or < F7 > key. 

Results can be checked at [Execution plan] tab.  
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If you select table at [Object Name] column, you can check information, columns and indexes about the table at [Ta

ble Info] tab. 

If you select index at [Object Name] column, you can check columns and property values about the index at [Index I

nfo] tab. 

Check [View plan object info] for above feature. 

 

3.4.7. Query Description 
You can preview columns by using Query Description feature before executing a query manually, if it is created as 

subquery type, joined query of several tables or took long time to execute. 

 

1. Create SQL in SQL Query Editor.  

2. Select [Query] > [Query Description] on the main menu or press the [ ] button or < Shif+F4 > keys.  

3. Column information of SQL will be shown. 

 

 

3.4.8. Add to User SQL 
Saves created SQL in SQL Query Editor to User Directory of [SQL History…]. 

Select [Query] > [Add to User SQL…] on the main menu or press the shortcut key < Shift+F8 >.  

 

If you click the [OK] button after selecting SQL name and group, it will be saved. 

Saved user SQL can be checked in [SQL History].  

 

3.4.9. SQL Align 
Aligns created SQL in SQL Query Editor automatically. 

Press [Query] > [SQL Align] on the main menu, the [ ] button or < F9 > key after creating SQL. 
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3.5. Create 
3.5.1. New Database 

Creates database on the connected MySQL server. 

To create database, CREATE privilege is needed.  

Select [Create] > [Database…] on the main menu. 

 

1. Input name of database to crate at Name. 

2. Select a Character Set.  

3. Select a Collation.  

4. Click the [View SQL] button to check SQL. 

5. Click the [OK] button. 

 

3.5.2. New Table 
Creates a table on database. Three methods, Defined Column, Defined Query and Object Table, are provided. 

Select [Create] > [Tables] on the main menu. 

 
 

 [General] 

1. Select a Database. 

2. Input name of table to create at Name. 

3. Select a ENGINE. 

4. Select ROW_FORMAT. 
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 [Table Options] 

1. Input MAX_ROWS. 

2. Input MIN_ROWS. 

3. Input KEY_BLOCK_SIZE. 

4. Input AUTO_INCREMENT. 

5. Input AVG_ROW_LENGTH. 

6. Select submenus of Advanced. 

7. Select submenus of Character Set. 

8. Input name of column at Column. 

9. Select date type of column at Data Type. 

10. Input size of column at Size. 

11. If it is a Primary Key, check PK?. 

12. Input default at DEFAULT. 

13. Input comment of field at Comment. 

14. Repeat steps of column addition for as much as you want to add. 

15. Click the [View SQL] button to check SQL. 

16. Click the [OK] button. 

 

 

3.5.3. New Index 
Creates Primary key, Unique key and Full text on table in database. 

Select [Create] > [Index…] on the main menu. 

 

 PRIMARY KEY 

1. Select a Database. 

2. Input name of index to create at Name.  

3. Select Tables to create Primary Key. 

4. Check at [Primary Key] check box. 

5. Select columns to use as primary key at left list of Table Columns and then move them to right list  

by clicking [ ](Add All) or [ ](Add). 
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6. Click the [View SQL] button to check SQL. 

7. Click the [OK] button. 

 

 UNIQUE 

1. Input name of index to create at Name. 

2. Select Tables to create Unique Key. 

3. Check at [UNIQUE] check box. 

4. Select columns to use as unique key at left list of Table Columns and then move them to right list by click

ing [ ](Add All) or [ ](Add). 

5. Click the [View SQL] button to check SQL. 

6. Click the [OK] button. 

 

 FULL TEXT 

1. Input name of index to create at Name. 

2. Select Tables to create Full text index. 

3. Check at [Full text] check box. 

4. Select columns to use as full text index at left list of Table Columns and then move them to right list  

by clicking [ ](Add All) or [ ](Add). 

5. Click the [View SQL] button to check SQL. 

6. Click the [OK] button. 

 

 

3.5.4. New View 
Creates new view on database.  

To create view CREATE VIEW privilege is needed. 

Select [Create] > [View] on the main menu. 

 

1. Select a Database. 

2. Input name of view at Name. 
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3. Select an Algorithm. 

4. Select a Definer.  

5. Select a SQL Security. 

6. Input SQL to use as view in Editor window. 

7. Click the [Validate SQL] button to check that SQL is correct. 

8. Click the [View SQL] button to check SQL. 

9. Click the [OK] button. 

 

 

3.5.5. New Stored Procedure 
You can create Function and Procedure easily. 

Select [Create] > [Procedure…] on the main menu. 

 

1. Input name of object to create, parameter and return type on [New Function/Stored Procedure] window. 

 

2. Click the [OK] button. 

3. Creation statement is added to SQL Query Editor.  
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3.5.6. New Function 
You can create Function and Procedure easily. 

Select [Create] > [Function…] on the main menu. 

 

1. Input name of object to create, parameter and return type on [New Function/Stored Procedure] window. 

 

2. Click the [OK] button. 

3. Creation statement is added to SQL Query Editor.  

 

 

3.5.7. New Trigger 
Creates trigger on table and database. 

Select [Create] > [Triggers…] on the main menu. 

 

When to use : Input condition for the trigger is executed. 

Editor : Input SQL that trigger will execute manually or procedure to call on execution. 
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3.5.8. New Event 
Creates new event on database.  

Select [Create] > [Event] on the main menu. 

 

1. Select a Database. 

2. Input name of event at Name. 

3. Select Schedule or input manually. 

4. Select Options. 

5. Input SQL to execute manually or procedure to call on execution in Editor window. 

6. Click the [View SQL] button to check. 

7. Click the [OK] button. 
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3.6. Security Manager 
Security Manager can inquire user and privilege of database and add, modify and delete them. 

DBA can manage user and role of MySQL easily by using Security Manager.  

To use Security Manager, SUPER privilege is needed.  

Click [Manager] > [Security Manager] on the main menu. 

 

 [User] 

 

You can inquire information, such as User ID, Host, privilege and so on. 

 

 Tool Button of [User] 

- Refresh : Refresh.  

- New User : Create new user. 

- Modify : Modify user information and role. 

- Delete : Delete the selected user. 

 

 [Privilege] 

 

Select a user who you want to inquire privilege in user list at left. 

- Inquire Privilege : Object privileges of the user, who is selected in user list window, in database display  

at right grid. 

- Modify Privilege : If you check at checkbox, which is relevant to privilege of the object on right grid,  

privilege is granted. If you uncheck it, privilege is revoked. 

- Only types of selected object at Tables, View, Procedure and Function checkbox display on right grid. 
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3.6.1. New User 
Creates new user on database. To create user, CREATE USER privilege is needed.  

Select [Security Manager] > [New User] button on the main menu. 

 

1. Input User Name. 

2. Input Host.  

3. Input Password. 

4. Input the inputted password at Confirm Password again. 

5. MAX_QUERIES_PER_HOUR : Input available Query count to inquire per 1 hour. (In case of 0, unlimited) 

6. MAX_UPDATES_PER_HOUR : Input available Query count to update per 1 hour. (In case of 0, unlimited) 

7. MAX_USER_CONNECTIONS : Input maximum connection count. (In case of 0, unlimited) 

8. MAX_CONNECTIONS_PER_HOUR : Input concurrent connection count of the user. (In case of 0, unlimited) 

9. Select privilege check box to grant privilege. 

10. Click the [View SQL] button to check SQL. 

11. Click the [OK] button. 
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3.7. Database Information 
Checks configuration and status of server, which is connecting to MySQL database, in Database Information. 

Select [Manager] > [Database Information] on the main menu. 

 

 

 

 [Server Variables] 

Check setting value of server, which is connecting to current database. 

 

 [Server Status] 

Check status of server, which is connecting to current database. 

- Aborted_clients : Disconnected count because connection of client is terminated abnormally 

- Aborted_connects : Failure count of connecting to MySQL 

- Bytes_received : Received bite count from all clients 

- Bytes_sent : Sent bite count to all clients 

- Connections : Tried count, which connect to mysql server 

- Created_tmp_disk_tables : Temporary table count, which exists on created disk during sql statement execut

ion  

- Created_tmp_tables : Temporary table count, which exists on created memory during sql statement executi

on 

- Created_tmp_files : Count of temporary files, which are created by mysqld  

- Delayed_insert_threads : Delayed count of using insert handler threads  

- Delayed_writes : Wrote rows count as INSERT DELAYED  

- Delayed_errors : Count of rows, which are occurred error when wrote as INSERT DELAYED clause  

(Including duplicate key)  
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- Flush_commands : Exceeded flush command count  

- Handler_delete : Deleted rows count from table  

- Handler_read_first : First entry count, which is read from index  

- Handler_read_key : Request count to read row that exists key  

- Handler_read_next : Request count to read the right behind row in key sequence  

- Handler_read_rnd : Request count to read row on the basis of fixed location 

- Handler_read_rnd_next : Requesting count to read ‘next row’ in data file 

- Handler_update : Requesting count to update rows in table 

- Handler_write : Requesting count to insert rows to table 

- Key_blocks_used : Count of using blocks in key cache 

- Key_read_requests : Requesting count to read key block in cache 

- Key_reads : Count of reading key block from disk physically 

- Key_write_requests : Requesting count to wirte key block in cache 

- Key_writes : Count of writing key block in disk physically 

- Max_used_connections : Maximum concurrent connection count 

- Not_flushed_key_blocks : Count of blocks that contents of key cache are changed but those  

are not saved to disk yet 

- Not_flushed_delayed_rows : Delaying row count because of INSERT DELAY 

- Open_tables : Currently opened table count 

- Open_files : Currently opened file count 

- Open_streams : Count of currently opened stream, which is used to use at logging 

- Opened_tables : Opened table count until now 

- Select_full_join : Joined count without key (It must to be 0) 

- Select_full_range_join : Join count, which is used range search in reference table 

- Select_range : Join count, which used range at first table  

- Select_scan : Join count, which scanned first table 

- Select_range_check : Count of join that there is no key to check key usage after using each row 

- Questions : Sent query count from server 

- Slave_open_temp_tables : Temporary table count, which is opened by current slave thread 

- Slow_launch_threads : Thread count, which has more than connected slow_launch_time 

- Slow_queries : Query count, which takes more than long_query_time 

- Sort_merge_passes : Merge count, which must use sort algorithm 

- Sort_range : Sorted range count 

- Sort_rows : Sorted row count 

- Sort_scan : Executed sort count by table scan 

- Table_locks_immediate : Count, which obtained table lock immediately 

- Table_locks_waited : Count, which cannot obtain table lock immediately and needs standby 

- Threads_cached : Count of thread, which is in thread cache  

- Threads_connected : Opened connection count currently 

- Threads_created : Count of thread, which is created to handle connection  

- Threads_running : Count of thread, which is not in sleeping status 

- Uptime : Time from server start until now 
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3.8. View Table Information 
 

“View Table Information” feature which can check table information in database in detail! 

 

1. Select [Manager] - [Table Information]. 

 

 

2. You can check table information. You can check each table in database. 
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3.9. Process Manager 
Displays status of session, which is connected to MySQL database in Session Browser. 

Also, you can kill user session. To use Session Browser, Process privilege is needed. 

Select [Manager] > [Process Manager] on the main menu or click the [ ] button. 

 

 Process 

You can see process list of user, who is connecting to current database at process tab. You can monitor information,  

such as Id, User, Host, db, Command, Time, State, Information of process and so on. 

You can inquire current SQL information of the selected process at bottom tab. 

 

 

 

3.10. Database Backup 
Backs up user, table, procedure/function, view, trigger and data, which are contained in database by  

using self backup feature without provided tool by database. 

Select [Manager] > [Database Backup] on the main menu. 

 

 

 Database Backup 

- Generate Header : Whether to display header 

- Add-drop-table : Whether to add Drop statement before object creation statement 
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- Database Backup : Whether to back up database 

- Backup Users : Whether to back up users 

- Backup Routines : Whether to back up routines 

- Back up Tables : Whether to back up tables 

- Backup Views : Whether to back up views 

- Back up Triggers : Whether to back up triggers 

- Backup Data : Whether to back up data 

 Add-locks : Whether to add LOCK 

 Complete-insert : Whether to add field list of table to INSERT statement 

 Extended-insert : Whether to add Extended statement 

 Disable-keys : Whether to add DESABLE 

 Delayed-insert : Whether to add DELAYED 

- Insert Type :  

 INSERT : Create only INSERT statement 

 INSERT IGNORE : Ignore insertion of data, which is violated to PRIMARY and UNIQUE  

 REPLACE INTO : If it is violated to PRIMARY and UNIQUE, update data 

 

 Select Table 

 

 

Select tables to back up at left table list and then move them to right list by clicking [ ](Add All) or [ ](Add). 

1. Select a Database. 

2. Input path to back up and file name at Backup File. 

3. Select necessary options at [Options] tab. 

4. If you want to back up data, select table at [Selected Tables] tab. 

5. Click the [Backup] button to execute database backup. 

3.11. Database Restore 
Restores database with backup file, which is backed up by database backup. 

Select [Manager] > [Database Restore…] on the main menu. 
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1. Select backed up file(.SQL) on Open Restore SQL file window 

2. The execution script of the selected file is added to SQL Query Editor. 

3. Click the [Restore] button. 

 

 

3.12. Table Manager 
3.12.1. Analyzer Tables 

Updates status after analyzing key districution of table. Table is locked during analysis. (read lock) 

This feature is applied only for that table uses MyISAM, BDB or InnoDB engine. 

 

Select [Manager] > [Table Manager] > [Analyzer Tables…] on the main menu. 

 

1. Select a Database. 

2. Select tables to analyze at left table list and then move them to right list by clicking [ ](Add All) or 

[ ](Add). 

3. Click the [OK] button to execute analysis command. 

 

 

3.12.2. Check Tables 
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This feature is to check that errors are on table. 

If there is an error, message will be printed out at Msg_text field and table restore is available  

with Repair tables feature. 

 

Select [Manager] > [Table Manager] > [Check Tables…] on the main menu. 

 

1. Select a Database. 

2. Select tables to check at left table list and then move them to right list by clicking [ ](Add All) or 

[ ](Add). 

3. If you click the [OK] button, command to check will be executed. 
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3.12.3. Repair Tables 
This feature is to repair when errors are on table. 

This is applied only for that table uses MyISAM or ARCHIVE engine and SELECT and INSERT privileges are needed. 

 

Select [Manager] > [Table Manager] > [Repair Tables…] on the main menu. 

 

1. Select a Database. 

2. Select tables to repair at left table list and then move them to right list  

by clicking [ ](Add All) or [ ](Add). 

3. If you click the [OK] button, command to check will be executed. 
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3.12.4. Optimize Tables 
If you delete data in table, which uses variable-length data types (VARCHAR, VARBINARY, BLOB, TEXT) or  

update to longer data than previous one, previous records are deleted logically and spaces are remained physically.  

In case of update, longer data than previous is saved and only position is specified again. 

It optimizes spaces, which are deleted logically and fragmented physically, to quicken access speed of table  

and reduce disk usage. 

 

Select [Manager] > [Table Manager] > [Optimize Tables…] on the main menu. 

 

1. Select a Database. 

2. Select tables to optimize at left table list and then move them to right list by clicking [ ](Add All) or  

[ ](Add). 

3. If you click the [OK] button, command to optimize will be executed. 

 

 

3.12.5. Truncate Tables 
Deletes all data in table. 

Select [Manager] > [Table Manager] > [Truncate Tables…] on the main menu. 
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1. Select a Database. 

2. Select tables to truncate at left table list and then move them to right list by clicking [ ](Add All) or 

[ ](Add). 

3. If you click the [OK] button, command to delete will be executed. 

 

 

3.13. Tools 
3.13.1. Object Reports 

If you use Object Report Tool, you can design and print out various reports by yourself. 

You can handle report writing easily and fast because report can be designed and printed out in template format. 

Object report template files are stored in Report folder in .fr3 file format. 

You can select report type at left panel and set printout options at right panel in object report tool. 

Select [Tools] > [Reports] > [Object Reports] on the main menu or click the [ ] button. 

 

1. Select a type of report to print out at left tree. 

2. Select a schema and object to print out at right panel. 

3. Select font to print out at the Report Font. 

4. If you click the [Design] button, you can design reports. 
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5. If you click the [Preview] button, you can it in advance. 

6. If you click the [Print] button, report will be printed out. 

7. If you click the [Export File] button, you can select format to print out reports. 

※ PDF,EXCEL,RTF,BMP,JPG,TEXT,EMAIL,HTML 
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 Design Report 

 

1. Select a report at left tree. 

2. Click the [Design] button. 

3. You can edit design to other formats that you want to print out. 

4. Select the [File] > [Save] buttons after editing. 

 

 Preview 

 

1. Select a report at left tree. 

2. Click the [Preview] button. 
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3.13.2. Export Data 
You can export data in table by using Export Data in various formats, such as DBF, Text, CSV File, MS Excel, MS Access,  

SQL file and so on. 

Select [Tools] > [Export Data] on the main menu or click the [ ] button. 

1. Select table to export, then click the [Start] button. 

 

 

2. Set File Type. 

 

 

3. Set a file to export. 

 

 If records exceed 6 hundred thousand, a file will be created additionally every 6 hundred thousand by  

selecting Records Count of Each File. 

 If you input a file name to export as ExportObject.xls, ExportObject001.xls, and ExportObject002.xls…  

files will be created. 

 



SQLGate for MySQL User Manual 
 

< 51 >    http://www.antwiz.com 

4. Click the [Run] button. 
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3.13.3. Import Data 
You can import data in various formats files, such as MS Excel, DBF, Text, CSV File and so on,  

to table by using Import Data.  

Select [Tools] > [Import Data…] on the main menu or click the [ ] button. 

 

1. Select a table to import, then click the [Start] button. 

 

 

2. Set type of original file. 

 

 

3. Specify path and type of original file to import. 
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4. Set data type. Set Dates, Times and Numbers format. 

 

 First Row : First Row to import (If there is row name in first row, set as 2.) 

 Last Row : Last Row to import (Default is blank) 

 

5. Map column of original file onto row of target table. Click the [Auto Columns Mapping] button  

to map automatically, then make sure that each column is mapped correctly. 

 

 

 

6. Check Column Mapping between target table and original source file. 

 

7. Preview data. Make sure that mapping between data of original source file and column of target table is  

done correctly. 
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8. Select the Import Mode and then click the [Execute] button. 

 

 Add : Add record to target table. 

 Update : Update records in target table. 

 

※ You have to select necessary field in mapping step on update. 

 

 

9. Update items are activated as follows. 

 

 Add/Update : Update if record exists in target table or add if not. 

 Delete : Delete if record exists in target table. 
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 Copy : Delete all records in target table and adds record to original source file. 

 Append New : Add records only if there is no record in target table.  

 If you set key of column in column mapping confirmation step, you can select one among Update,  

Add/Update, Delete mode. 

 

10. Import result will be shown. 

 

 Error log will be shown if error is occurred. 

 

 

3.13.4. Options 
Sets options of program.  

Select [Tools] > [Options…] on the main menu or click the [ ] button. 

 

 [General] 

 

- Themes : Select theme of program. Default and Dream are provided. 

- Automatic Updates : 

 Enable A&utomatic Updates : When checked,it checks update automatically whenever program executes. 

- Select Language : Select a language to use at program. Korean, English, Japanese, Chinese, German,  

French and Spanish are provided. 

- Start Window : 

 SQL QUERY EDITOR : Executes SQL Query Editor automatically when starts program. Default is SQL Query Editor. 

 Object Explorer : Executes Object Explorer automatically when starts program. 

 

 [MySQL Configuration] 
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- Fetch Records Options : 

 Fetch All Records : Display all records in grid after inquiry. 

 Partially fetch records : Fetch partially after inquiry. Fetch rows means records count to fetch partially. 

- Query Options : 

 Date Format : Set date type to display in grid. 

- Keep Connection : When checked, keep connection of session continuously. 

 Reconnection Check Time : Set automatic reconnection time. 

 

 [SQL QUERY EDITOR] 

Editor options, alignment options, SQL history save options and so on. 

 

- Query Editor Options : Set query editor options. If you click the [Options…] button,  

new window will be shown to set. 

- SQL Align Options : Set SQL alignment options. If you click the [Options…] button,  

new window will be shown to set. 

- Auto &Save SQL History : Set options whether to save or not. If you check this,  

SQL will be saved automatically. 

 Unlimited : Save all without limitation. 

 Count : Save only inputted count. 
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- Store point of SQL History : 

 After Execution : Save only succeeded queries. 

 Before Execution : Save succeeded or failed queries. 

- Show Grid at Startup : When checked, grid will be displayed when executes SQL Query Editor.  

If it is not checked, only editor will be shown and grid will be shown after executing query. 

- Display SQL Hint on Tab : When checked, SQL will be shown as hint when mouse over tab. 

 

 [Object Explorer] 

Select objects to display in Object Explorer/Object Panel. 

 

- Bring to front : When checked, Object Browser will be shown on top. 

- Visible Objects : Select objects to display on object panel. 

 

 [Grid] 

You can change Display Null in grid and grid style. 

 

- Display NULL : Display NULL value in grid. Set background. 

- Font color of &multiple-line : Set background color when text in grid has carriage return value.  

(Only one line of data is displayed in grid, so you cannot know how many lines in grid.) 

- Grid Type : Change grid type. (Standard/Flat/Ultra Flat/Office) 

- Grid Style : Change grid style. You can change grid style manually. 

 

 [Query Shortcuts] 
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You can set specific commands as shortcut keys, < Alt+1 ~ 10 >. 

 

 

If you select keyword in SQL Query Editor and then press the shortcut key, SQL command will be executed. 

 

Above example is execution result of shortcut key,  

which is defined as SELECT * FROM &Var, after selecting inputted keyword. 

※ SQL = SHOW * FROM Inputted keyword 

 

 [SQL Conversion Options] 

Sets format to use at SQL conversion. Sets conversion format of  

escape character and separator by program language. 
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3.14. Window 
3.14.1. Tile Horizontally 

Tiles windows horizontally. 

Select [Window] > [Tile Horizontally] on the main menu.  

 

 

3.14.2. Tile Vertically 
Tiles windows vertically.  

Select [Window] > [Tile Vertically] on the main menu.  

 

 

3.14.3. Cascade 
Tiles windows in cascade. 

Select [Window] > [Cascade] on the main menu.  

 

 

3.14.4. Arrange Icons 
Arranges window icons. 

Select [Window] > [Arrange Icons] on the main menu. 

 

 

3.15. Help 
3.15.1. Help 

Opens help file.  

Select [Help] > [Help] on the main menu. 

 

 

3.15.2. Activation 
Authenticates program as formal commodity. 

Select [Help] > [Activation…] on the main menu. 

 

If you input the license key of 16 digits and click the [Activation] button, program authentication will be finished. 

 

3.15.3. Update Check 
Checks latest update information. Currently using version and latest version are displayed. 

Select [Help] > [Update Check…] on the main menu. 
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3.15.4. About SQLGate 
Inquires program information. 

Select [Help] > [About SQLGate] on the main menu. 
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4. SQL QUERY EDITOR 

4.1. Multi-Query 
You can execute several SQLs simultaneously and checks results in grid. 

Also, you can compare data more easily. Separator of command is (;). 

 

 

If you click the [ ] button, you can see in horizontal grid. 
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4.2. Run SubQuery block 
You can find subquery in complex SQL automatically and execute it. 

 

Runs subquery in the line, where cursor is located, in SQL Query Editor. Subquery can be executed  

even it is not in block. Font color of sub query in editor is changed automatically.  

Also the [Run SubQuery block < Alt+F5 >] button is activated. 

Select [Query] > [Run SubQuery block] on the main menu or press the [ ] button or shortcut key < Alt+F5 >. 

 

4.3. Multi-Tab 
Several tabs can be added in SQL Query Editor so you don’t need t open several SQL Query Editor.  

Press shortcut key, < Ctrl+Alt+N >, or click the [ ] button on the toolbar. 
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If you add or modify SQL in SQL Query Editor, (*) symbol will be displayed on the tab. 

 

 

If you modify SQL after saving SQL, you can check modified line in gutter. 

 

 

If you add code, yellow line is marked in gutter as below. Also, (*) symbol is displayed on the tab. 

 

 

 

4.4. Table Auto Completion 
Table lists are displayed after From/Into/Update keyword automatically. 

You can create SQL statement faster through this feature. 

If you press shortcut key < Ctrl+H >, table auto completion will be executed wherever. 
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4.5. Field Auto Completion 
If you input dot <.> in SQL Query Editor, alias or field of table will be displayed. 

 

 

 

4.6. Code Auto Completion 
Code Auto Completion is a useful feature that you save often using code in advance and call them whenever you need.  

If you press shortcut key, < Ctrl+J >, code auto completion will be executed. 

If you input ‘Selectw’ in SQL Query Editor and then press < Ctrl+J > keys,  

it will be converted into ‘select * from where’ code. 

 

 

 

 

4.7. Paste from the code 
This is a feature to extract only SQL in development code. 

For example, it can extract SQL statement only in PHP code that includes SQL. 

 

 

Copy above PHP code to clipboard and then select the [Paste from the code] on the context menu in  

SQL Query Editor or press shortcut key, < Ctrl+Shift+V >. Only SQL statement will be extracted like below. 
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4.8. Specify background color of text 
 

You can change background color of table that you want to find and display it in SQL Query Editor. 

If you select [Find All] when you find wanted word, you can find all same words  

and specify background color to found words. 

Moreover, you can specify background color for each word differently. 

 

1. If you click the [ ] button after selected a table that you want to see,  

background color will be changed to desired color. 

 

 

2. If you specify background color of the same object in another editor, the specified background color of the previous 

editor will be removed. 

According to the below image, you can see that the background color of the EMPLOYEES table  

in SQL1 editor is removed when the background color of the EMPLOYEES table, which is the same object,  

is specified in SQL2 editor even though the background color of the EMPLOYEES table was specified in SQL1 editor. 
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3. When you specify the background color of an object, which is not specified background color  

in the previous editor, in other editor, the background color will not removed in the previous editor. 
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4.9. Limit feature 
 

Limit feature is for that you inquire quickly by specifying desired portion of data.  

If you assign the start line and number of data, it will show you as much as data that you want. 

 

Work speed is improved because it reduces search time  

when you search lots of data and you can check desired portion of data quickly without using query. 

 

1. This is result when you do not use Limit feature.  

 

You can check total 450 datas. 

 

2. Click the [Apply] button after checking Limit and assigning the start line and display count. 

 

You can check 20 datas from the first as result. 

 

3. If you click the Next page button, it shows you as much as set display count. 
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You can check 20 datas from the 21th again. 
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5. Execute Procedure 

Helps to execute existing procedure and function. 

 

1. Select a procedure or function and the click the [Run] on the context menu. 

2. Input parameter of procedure. 

 

 

3. Click the [OK] button. 

 

4. Execution script will be added to SQL Query Editor. 

 

 

5. Click the [Run] button to execute function or procedure and check results. 
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6. Object Explorer 

6.1. Table 
It provides overall features about tables that inquires, creates, modifies and deletes table lists by owner and  

detail information of each table. 

Select [View] > [Object Explorer] on the main menu or click the [ ] button on the toolbar. 

 

 

 Tab Information of Tables 

- [Column] : You can inquire, create, delete and print out column information of the selected table. Also,  

you can inquire and modify column comment and table comment. 

- [Index] : You can inquire, add, modify, delete, print out and rebuild index information of  

the selected table. 

- [Triggers] : You can inquire, add, modify, delete, print out, enable and disable trigger information of  

the selected table. 

- [Data] : You can inquire, add, modify, delete and print out all data of the selected table. 

- [Scripts] : You can inquire DDL by wanting option and save it.  

- [Properties] : You can inquire creation option of the selected table and storage information. 

 

 Context menu of Tables 

 

- [Add] 
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 [Column] : Add columns to the selected table.  

 [Constraint] : Add constraints to the selected table. 

 [Index] : Add indexes to the selected table. 

 [Trigger] : Add triggers to the selected table. 

- [New Table] : Provide CREATE TABLE wizard that can create table.  

- [Alter] : Change column and comment of the selected table. 

- [Delete(Drop/Truncate)] : Execute Drop, Truncate command to the selected table. 

- [Rename] : Change name of the selected table. 

- [Copy] : Copy the selected table. Provides Only Table Structure, Table Structure and Data. 

- [Edit Comment] : Modify table comment and column comment. 

- [Row Count] : Display record count of the selected table’s data. 

- [Object Reports] : Print out information of the selected table as reports. 

- [Script Report] : Print out script of the selected table as reports. 

- [Export Data] : Export the selected table. (Excel, Csv, SQL and so on) 

- [Import Data] : Import the selected table. (Excel, Csv, SQL and so on) 

- [Filter] : Filter and sort lists by using the Filter window. 

- [Refresh] : Refresh. 

 

6.2. View 
Inquires view list by owner and detail information of view and performs overall features about view, such as creation,  

modification, deletion, rebuilding and so on. 

 
 Tab Information of View 

- [Column] : You can inquire and print out column information and comment of the selected view. 

- [Data] : You can add, modify, delete and print out data of the selected view. 

- [Scripts] : You can inquire creation script by wanting options and save it. 
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 Context menu of View 

 

- [New View] : The New View window pops up.  

- [Alter] : The Alter View window of the selected view pops up. 

- [Delete] : Drop the selected view. 

- [Row Count] : Show record count of the selected view’s data. 

- [Filter] : Filter and sort lists by using the Filter window. 

 

 

6.3. Triggers 
Inquires trigger list of the selected owner and detail information and performs overall features about trigger,  

such as creation, modification, deletion and so on. 

 

 
 

 Tab Information of Triggers 

- [Properties] : You can check information of the selected trigger. 

- [Scripts] : You can check creation script of the selected trigger. 
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 Context menu of Triggers  

 

- [New Trigger] : The New Trigger window pops up. 

- [Alter] : The Alter Trigger window of the selected trigger pops up. 

- [Delete] : Drop the selected trigger. 

- [Filter] : Filter and sort lists by using the Filter window. 

 

 

6.4. Procedure / Function 
Inquires procedure/function list of the selected owner and detail information and performs overall features about 

procedure, such as creation, modification, deletion and so on. 

 
 

 Tab Information of Procedure/Function 

- [Properties] : Display information of the selected procedure/function. 

- [Scripts] : Display creation script of the selected procedure/function. 
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 Context menu of Procedure/Function 

 

- [New Function] : The New Function/Stored Procedure window pops up. 

- [Alter] : Alter the selected procedure. 

- [Delete] : Drop the selected procedure. 

- [Run] : Execute the selected procedure. 

- [Filter] : Filter and sort lists by using the Filter window. 
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7. Query Builder 

You can create quires only by draging&dropping easily and check results by using Query Builder. 

You can join, sort and filter query objects (query, view, column and so on) with simple mouse operation and  

check results by creating various queries.  

Select [File] > [New] > [Query Builder] on the main menu or click the [ ] button on the toolbar.  

 Tables/View Select 

Open the Object Panel by selecting [View] > [Object Panel] on the main menu or clicking the [ ] button on  

the toolbar.  

Select needed table or view in object panel and drag&drop at query builder by using mouse.  

Check columns to display in SQL.  

 

 

 Join 

Select a line between objects, that join was established and then click the [Property] on the context menu.  

 

Select <Inner Join>/<Outer Join>. 
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 Set Where, Select, Group Sorting Condition 

You can add, modify and delete Where, selection, group and sorting condition at the bottom of query builder. 

 

 View SQL 

If you select the [SQL] tab, you can check the created SQL. 

 

 Run 

Press the shortcut key, <F5>, or click the [ ] button. SQL is executed and you can check results. 



SQLGate for MySQL User Manual 
 

< 78 >    http://www.antwiz.com 

8. ER Design 

You can create ERD (entity-relationship diagram) by applying Reverse Engineering to relationship between tables in  

ER Design window. It provides basic features, which are necessary for ERD edit, such as group area,  

text box and so on also provides ERD print, file saving and importing. 

Select [File] > [New] > [ER Design] on the main menu or click the [ ] button. 

 

 Screen Composition 

 

 

 ER Design ToolBar 

[Select / ] : It is a feature to select object in drag area by dragging mouse on the Canvas. 

[Move / ] : Move the selected object. 

[Resize / ] : Resize group area. 

[Delete / ] : Delete the selected object. 

[Panning Hand / ] : Move working area of Canvas by dragging mouse. 

[Zoom Out / ] : Zoom out working area of Canvas. 

[Zoom In / ] : Zoom in working area of Canvas. 

[Region / ] : Add the [Region] object, which ties up objects into one group. 

[Text Box / ] : Add sentence with simple contents on Canvas. 
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[1:1 Non-Identifying-Relationship/ ] : Set the [1:1 Non-Identifying-Relationship] between table objects. 

[1:n Non-Identifying-Relationship/ ] : Set the [1:n Non-Identifying-Relationship] between table objects. 

[n:m Non-Identifying-Relationship/ ] : Set the [n:m Non-Identifying-Relationship] between table objects. 

[SQL 보기 / ] : Inquire creation script of currently designed ERD. 

 

 Canvas 

This is working space that you can place ERD objects (Table, Text Box, Region Object) on the screen manually.  

You can design ERD in easier way. 

 

 Select Database 

Tables of the selected database in select database are displayed on table list 

 

 Filter Table List 

This is a feature to filter table list and it shows only table name, which has inputted word, in table list. 

 

 Select All 

Check all checkboxes by table in table list. 

 

 Table List 

Display only table, which has filter word, among tables of the selected schema in select schema. 

If there is no filtering word, all table lists of the selected database are displayed. 

 

 Add Table 

If you drag to Canvas or double click it after selecting a table in table list,  

the selected table will be revered and putted on Canvas. 

If you click the [Add] button, checked tables in table list will be reversed and putted on Canvas. 

 

 Map 

 

- Show table on Canvas and currently working area briefly. You can move working area of Canvas  

by clicking the mouse or dragging. 

- If you click the [Zoom Out] button, contract Canvas. 

- If you click the [Zoom In] button, expands Canvas. 
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8.1. Table Object 

 

This is an added object on Canvas after that you select a table from table list.  

Displays column list of table, primary key, data type, logical field name and so on. 

 

 

8.2. Table Object Menu 

 

Click the right mouse button at table object and then select the Change Table Display Options on  

the context menu to open Change Table Display Options window. 

- Reflected in All Tables : Reflect changed option value of table display to all tables. 

- View Table Logical Name : Display with logical name of table. 

- 1Column..nColumn : Select items to display at table object. 

- [OK] : Reflect changed option value of table display to table. 

 

 

- Delete Object : Delete the selected object. 

- Align: Align the table to up, down, left and right / horizontal, vertical. 

- Refresh : Refresh the table. 

- Reference table (Parent table) / Referrer (Child table) : If there is a constraint on the table,  

- the parent or the child table of the selected table will be called automatically. 
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8.3. Relationship 

 

If you select one among 1:1 Non-Identifying-Relationship / , 1:n Non-Identifying-Relationship / 

, n:m Non-Identifying-Relationship /  on the [ER Design] tool after that click original table object and  

target table object in order, logical relationship of tables will be set. 

 

 

8.4. Change Relationship object 
If you double click the relationship object, the Change Relationship window will pop up. 

 

- Relationship Type : Select one among 1:1 / 1:n / n:m. 

- Logical Relationships : When checked, display as dotted line. 

- Source Table : Original table of relationship is displayed. 

- Target Table : Target table of relationship is displayed. 

- Relationship Keys : Relationship column lists between original table and target table are displayed. 

 Source Column Name : Column list of original table, which is related to column of target table, is displayed. 

 Target Column Name : Column list of target table, which is related to column of original table, is displayed. 

- Add : If you click the [Add], you can input columns, which are going to be target of relationship key,  

additionally. 

- Delete : If you select relationship key list and then click the [Delete],  

the selected relationship key will be deleted. 

- Comment : Input description of relationship. 

 

 

 

 

 



SQLGate for MySQL User Manual 
 

< 82 >    http://www.antwiz.com 

8.5. Group Area 

 

Ties up table, text objects to one group. 

Object in group area moves with group area when moves group area. 

 

Modify Name/Color/Comment after popping up Edit Region window by double clicking. 

 

 

 

8.6. Text Box 

 

Add sentence of simple contents on Canvas. 

Open the text box edit window by double clicking, then edit contents in text box. 

 
 

 

8.7. Setup Print 

 

Select [File] > [Print] on the main menu to open the Setup Print window. 
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- Print Page 

 All Pages : Print out whole model. 

 Selected Pages : Print the selected model in model. 

- Model : Select only a model, that you want to print out, with mouse in status pressing the < Ctrl> key. 

- [Page Setup] : Page setup window shows up. 

- [Print…] : Print model through printer. 

 

 

8.8. Page Setup 

 

- [Choose a printer…] : Select a printer to print out after popping the Choose a Printer window up. 

- Page Size : Select paper to print. 

- Direction : Select orientation of print paper, vertical or landscape. 

- Pages 

 Landscape : Select how many pages to print widthwise. 

 Vertical : Select how many pages to print pale wise. 

- Width : Set width to print on print paper by dragging mouse. 

- [Printer Setting] : Back to previous window. 

 

 

8.9. Find Table Object 

 

Select [Edit] > [Find and Replace] > [Find] on the main menu or press the shortcut key, < Ctrl+F>,  

to open the Find Table window. 

Input a word to search among table names at the Keyword. 

If you click the [OK], the Find Table window is closed and it finds out that table by  

moving working area of Canvas after finding table object, which has keyword. 

Press the < F3 > key to find next table. 
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9. Trivia 

 

9.1. Table of shortcut keys 
 

Common New Ctrl + N Cut Ctrl + X 

Open Ctrl + O Copy Ctrl + C 

Save Ctrl + S Paste Ctrl + V 

Save As Ctrl + Shift + S Select all Ctrl + A 

Undo Ctrl + Z Delete Del 

Redo Shift + Ctrl + Z   

Search Find Ctrl + F Find in Files Shift + Ctrl + F 

Find Next F3 Toggle Bookmark Ctrl + Alt + Num 

Replace Ctrl + R Goto Bookmark Ctrl + Num 

Paste from the code Shift + Ctrl + V Goto line Ctrl + G 

SQL  

History 

SQL History F8 Copy to Clipboard Ctrl + C 

Delete SQL Del Open File Ctrl + O 

Append to editor Ctrl + Enter   

Edit Comment Block Ctrl + - Capitalize Ctrl + I 

Uncomment Block Shift + Ctrl + - Increase Indent Tab 

Upper Case Ctrl + U Decrease Indent Shift + Tab 

Lower Case Ctrl + L Description Schema F4 

Query  

Editor 

Run SQL / Compile F5 Run SubQuery block Alt + F5 

Stop ESC Run Current SQL & Modify F6 

Close Ctrl + Alt + D Execution plan of current SQL F7 

Add Editor Ctrl + Alt + N Execution plan Block SQL Alt + F7 

Previous Editor Ctrl + Alt + Left Query Description Shift + F4 

Next Editor Ctrl + Alt + Right Add to User SQL Shift + F8 

Open File Ctrl + O SQL Align F9 

Save Ctrl + S Table Auto Completion Ctrl + H 

Print Preview Ctrl + P Paste from the code Shift + Ctrl + V 

Show Grid F11 SQL Row Count F12 

Run Current SQL Ctrl + F5   

ER Design Find Ctrl + F Delete Del 

Option Code Auto Completion / Templ

ate 

Ctrl + J Reuse SQL Ctrl + M 

Keyword Auto Completion Ctrl + K Field Auto Completion . 

Help Help F1   

 

 


