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Getting Started
Chapter 1
This User's Manual will help you to use the EXAMgen Test Generator quickly and easily. 
To use this manual to the greatest advantage, we recommend the following:

1. Verify your package contents and the hardware requirements; then install the soft-
ware. If you are already familiar with running Windows programs, you should be able 
to install the software and create exams without reading the manual.

2. Practice creating a basic exam very quickly by following the steps in “Making an 
Exam” on page 4. This is the easiest way to learn how to use the program’s basic fea-
tures. We encourage you to experiment with EXAMgen and its features.

3. Try out the techniques for working with exams as you read Chapter 2: How to Make 
an Exam. The diagrams summarize most of EXAMgen’s features and functions.

Once you are comfortable with the basic functions of the program, refer to the remaining 
chapters to learn how to browse Test Items, write your own questions, and manage user-
created databases.

Basic Skills
This manual assumes that you are familiar with and comfortable operating a typical Win-
dows application. EXAMgen is easy to use, but it does require the following basic skills:

• using a mouse (single and double-clicking, shift-clicking, control-clicking)
• dragging and dropping objects between lists and windows
• using buttons, check boxes, and radio buttons
• using various menu styles (popup menus, menu bars, etc.)
• opening, closing, and resizing windows
• opening, saving, saving as..., printing, and quitting documents

For tutorials on these skills, refer to your computer’s user manual or one of the many 
excellent books for beginners. Better yet, ask a friend; sometimes the best source of infor-
mation is someone who has already done what you need to do.
Getting Started 1
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Note
This manual uses the following convention for picking items from a menu: menu head-
ing>item>sub-item. “Click” means pressing the left mouse button once; “double click” 
means pressing the left mouse button twice. “Right click” means pressing the right 
mouse button once.

Before You Start
In addition to this manual, ensure that you have the following materials:

• Install CD with EXAMgen Test-Generator program and database files 
• Database Manual (containing all of the questions in the database)

Note
All Master Database Installers on CD contain the EXAMgen program

Hardware Requirements
Make sure that your computer meets the following minimum requirements:

• 486-based PC running Windows 95/98/ME/NT/2000/XP/2003
• 32MB RAM 
• Hard Disk with 5MB free (You'll need more space as you add or create databases.)

Registration and Guarantees
Registration
Registration is required in order to be eligible for special offers, upgrade pricing, and free 
technical support. You may register in either of the following ways: 

• online—http://www.examgen.com/
• telephone—1.800.736.8172

60-Day Money-Back Guarantee
The 60-day money-back guarantee gives you 60 days from the shipping date on the pack-
ing slip during which to try out the program and review the content of the database.

If you are not satisfied and decide to return the database, please call 800-736-8172 to get 
a Return Merchandise Authorization (RMA) Number. You must indicate the RMA Num-
ber on each returned package to receive proper credit.

All returned material MUST be deleted from every machine on which it was installed and 
all duplicate copies of disks and manuals MUST be destroyed. Violations of these rules 
(illegal copies) will be subject to legal action.
User’s Manual
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Site-License Guarantee
EXAMgen databases are site-licensed to one specific building (building of record) or 
individual (private purchase) only, as defined in writing on the purchase order or invoice.

A building site-license offers you the following guarantees:

• The program may be installed on any number of computers in the licensed school 
building.

• Any full-time employee in the licensed school building may install the program on 
a personal computer at home.

• Duplication of manuals or disks is allowed subject to the above conditions.
The building site-license is non-transferable. If an employee leaves the employ of the 
building of record, the licensed holder is responsible for retrieving and deleting all copies.

In the event a school district purchases for multiple school buildings, Examgen Inc. 
licenses will be assigned to each of the designated school buildings. This is determined by 
the purchase order and as specified in writing by the district office.

Installation
The EXAMgen program (contained in every master database installer on CD) must be 
installed prior to installing a content database. The Database Installer needs to be able to 
find the EXAMgen program on the hard disk. If it does not find the program, you may 
get erratic results.

Note
Installing a Master Database from a CD automatically installs the EXAMgen Program.

Installing the Exam Generator
Insert the CD. The installer should start automatically. If installation does not begin auto-
matically, install the EXAMgen program using Start>Settings>Control Panel>Add/
Remove Programs>Add New Programs. Follow the prompts.

Databases are installed in a default Database folder in the EXAMgen folder. If databases 
are installed or moved elsewhere, the program cannot locate them. Also, the installation 
program adds two fonts—Examgen Font I and Examgen Font II—to the system’s font 
folder. Do not delete these fonts; doing so produces unreadable text!

Creating a Shortcut on the Desktop
1. Locate the EXAMgen program (EXAMgen/Database) using Windows Explorer. 

2. Right click on the EXAMgen program filename.

3. Select Create Shortcut.

4. Drag and drop the newly created shortcut icon onto the desktop.
Getting Started 3
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3. Choose test item(

1. Choose a databas
2. Choose a chapter
Starting EXAMgen
Start the EXAMgen Test Generator program in either of these ways:

• Start>Programs>EXAMgen>  EXAMgen
• Double-click the desktop shortcut

Making an Exam
Making a simple exam is easy using the step-by-step instructions in this section. Before 
you dive in, take a minute to familiarize yourself with the main window. Start EXAMgen. 
Click once to clear the splash screen and reveal the EXAMgen Main Window. You are 
ready to make your first exam.

Figure 1-1. EXAMgen Main Window

1. Choose a database.

2. Choose a chapter.

3. Select a test item by clicking on an item number. The selected item is highlighted in 
blue. 

Database Section Exam Section

s).

e.
.

Exam ListTopic List
User’s Manual



EXAMgen 4.4
Note
Double-click on the item to view the entire question in the Database Browser. Close (X) 
the Database Browser and return to the Main Window.

4. Insert a selected item into the Exam List in any of the following ways:

• Press Enter.
• From the main window, click Insert to add a selected test item to the exam.
• From the Database Browser, click Insert to Exam. 
• Drag and drop a selected item into the Exam List.

5. Click Exam Settings to change the font, font size, number of columns, page margins, 
etc. Close the Exam Settings window and return to the main screen.

6. Select File>Print Preview to verify that the format and content are correct.

7. Make any needed changes.

8. Select File>Print to print the exam. 

Congratulations! You’ve just made your first test the EXAMgen way. 
Getting Started 5
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How to Make an Exam
Chapter 2
This chapter introduces many of the basic definitions and concepts used throughout this 
manual and provides a description of the application’s Main Window and its functionality. 
Most of what you need to know to operate the application is discussed here.

The fastest and easiest way to learn how to use the application is to experiment with it. 
We recommend that you poke around in the menus, double-click on items, etc. to learn 
where things are located and what the application can do.

Note
This manual uses the following convention for picking items from a menu: menu head-
ing>item>sub-item. “Click” means pressing the left mouse button once; “double click” 
means pressing the left mouse button twice. “Right click” means pressing the right 
mouse button once.

This chapter covers the following issues:

• EXAMgen Databases 
• Personal Library Databases
• Test Items and the structure of an exam
• Starting the Application
• The Main Window
• Selecting and Adding Questions to an Exam
• Organizing the Exam
• Formatting Exams for Printing
• Saving, Recalling, Previewing, and Printing Exams

Databases
EXAMgen databases are similar to traditional databases. They are collections of ques-
tions and other types of items stored in a computer file and managed by the EXAMgen 
Test Generator Software. The EXAMgen application uses two types of databases: 
EXAMgen Databases and Personal Library Databases.
How to Make an Exam 7
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EXAMgen Databases
EXAMgen Databases are test-item collections created by EXAMgen Inc. These database 
files can be recognized by the .B33 extension in the filename. These databases cannot be 
modified by the user in any manner. They contain all the special symbols, graphics, and 
textual content needed to completely access, format, preview, and print each Test Item.

EXAMgen Databases are organized into chapters which are classified by a chapter name 
and number. Each question in the database is uniquely identified by the database name, 
the chapter number, and the question number. These references correspond exactly to 
the organization of questions in the printed manual (e.g., Biology, Chapter 3, 
Question 47).

Personal Library Databases
Personal Libraries are databases that are created and maintained by the user and can be 
recognized by the .PLH extension in the filename. Like EXAMgen Databases, they con-
tain everything you need to access, format, preview, and print a complete exam.

Use the Personal Library Manager to accomplish the following:

• create any number of new questions
• copy existing questions from EXAMgen databases and exams into their Personal 

Library
• edit, duplicate, or delete Test Items
• write Common Blocks and link or unlink questions to them
• import graphics (.BMP, .JPG, .PNG, .TIF)
• organize Test Items by topic using Sections
• create Custom Items
• rearrange or alter the sequence of Test Items
• create multiple Personal Libraries

For information on creating and managing Test Items in Personal Libraries, see Chapter 
4: Personal Library Manager.

Database Test Items
Database Test Items are individual questions or other blocks of text (such as sections and 
instructions) that are stored in a database file to be retrieved as needed by the EXAMgen 
application. 
User’s Manual
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Starting EXAMgen
Start the EXAMgen Test Generator as follows: Start>Programs>EXAMgen>  
EXAMgen

Click the splash screen to reveal the EXAMgen Main Window. Practically all of the pro-
cedures needed to create, organize, format, and print an exam are located in the Main 
Window.

Main Window
EXAMgen was designed to do almost everything from one central screen, the Main Win-
dow. The Main Window is divided into three basic sections: the database section (left side 
of the window), the exam section (right side of the window), and the menu bar. Fre-
quently, other popup windows are activated from this screen, but when they are closed, 
you automatically return to the Main Window. 

Table 2-1: Test Item Types

Icon Test Item Type Explanation

Short Answer EXAMgen supports short answer questions. The user 
can control the size of the answer space at the Exam 
level, the Section level, or individually at the Question 
level.

Multiple Choice EXAMgen supports multiple choice questions with up to 
five wrong answers. The program automatically scrambles 
the answer order and arranges answers in a horizontal or 
vertical format. Questions can be changed from multiple 
choice to short answer questions at the Exam level, the 
Section level, or individually at the Question level.

True/False EXAMgen supports true/false questions (using the short 
answer question format).

Fill-in-the-Blank EXAMgen supports fill-in-the-blank questions (using the 
short answer question format).

Common Block A Common Block is a table, graph, diagram, illustration, 
or block of text that is referred to by several questions.

Custom Item A Custom Item is a block of text created by the user and 
are used to introduce instructions, reference tables, etc. 
into an exam. Once a Custom Item is inserted into an 
exam, its position does not change even if the Test Items 
around it are scrambled. 

Section A Section is a “tool” used to group Test Items together 
or organize them by topic, to insert instructions or com-
ments into the printed exam, and to control the print for-
matting of the Test Items in the Section.
How to Make an Exam 9
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The amount of information visible in the Main Window depends on the size of the win-
dow. Users generally find it best to maximize the Main Window when working with 
EXAMgen.

Take a few minutes to familiarize yourself with the Main Window. Examine the com-
mands in the menu bar and the various popup menus and windows. These are the tools 
you will use most frequently to construct and format your exams.

Controls
A Control is anything on the screen that you can interact with using the mouse or key-
board. There are five basic controls you’ll use in the Main Window: list box, dialog box, 
edit box, check box, and radio button.

The Main Window is divided into three parts:

• Database Section
• Exam Section
• Menu Bar

Table 2-2: Controls

Control Name Explanation

list box A list box is a part of the screen that has scroll bars and contains 
a list of Test Items. Examples of list boxes are the Exam List, the 
Question Selection List, and the Topic List. The objects in a list 
box can be selected (highlighted) by clicking on them and, in 
some cases, rearranged by using drag and drop. Many times dou-
ble-clicking on an object in a list box opens a dialog box or 
Browser window.

dialog box A dialog box is a popup window that prompts the user for infor-
mation and contains at least one control. The dialog box must be 
closed to return to the Main Window. No other program func-
tions can be completed while a dialog box is open.

edit box An edit box is a window in which the user enters text informa-
tion.

check box A check box is a box whose function can be turned On (checked) 
or Off (unchecked) by clicking on the box.

radio button A radio button is a circle whose associated function becomes 
active when clicked on. Clicking on another radio button auto-
matically deactivates the previous selection.
User’s Manual
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ion
Figure 2-1. Main Window

Database Section
The Database Section is the left-hand portion of the Main Window. It is used to choose a 
Database (and chapter), to select question numbers, to insert the questions into the Exam 
List, and to access the Database Browser. 

Screen appearance and controls may differ slightly depending upon whether the active 
database is an EXAMgen Database or a Personal Library.

Database Section Exam Sect

Exam ListTopic List

Question
Selection 

List 
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Figure 2-2. Database Section of the Main Window

Database Selection Menu. This pull-down menu is used to activate (select) a database. 
All available databases (including Personal Libraries) are listed and are stored in the 
EXAMgen Database folder. In the Database Selection menu, EXAMgen Databases are 
listed first followed by Personal Libraries. Personal Library file names are preceded by 
P.L. 

Chapter Selection Menu. This pull-down menu displays a list of chapters in the active 
database. The chapter pull-down menu appears only when an EXAMgen Database is 
selected. Personal Libraries (as well as Supplemental Updates) have only one chapter. 

Question Selection List. The numbered boxes display the question numbers in the 
active database and chapter. These reference numbers are used to select questions for 
your exam. Each question is classified as Multiple Choice, Short Answer, True/False, Fill-
in-the-Blank, and sometimes as a Custom Item (Personal Libraries only). Double-clicking 
on any one of these items opens the Database Browser Window which allows the user to 
view the database's Test Items on the screen.

Topic List. All of the topics in the active database and chapter are displayed in the Topic 
List located at the bottom of the Database Section. Clicking on a topic highlights (selects) 
all of the questions (in the Question Selection List) pertaining to that topic.

Insert Button. Click to add the selected (highlighted) questions in the Question Selec-
tion List to the Exam List. If only one question is selected, the question is inserted into 
the exam. 

If more than one question is highlighted, the “Insert Questions” dialog box opens. This 
dialog box tells you how many questions are selected, prompts you to enter the number 
User’s Manual
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of questions to be inserted into the exam, and whether to add the questions randomly 
(default) or in numerical order. 

Edit Button. Click to open the Personal Library Manager Window. This button is only 
active for Personal Libraries. The button is inactive (grayed out) for EXAMgen Databases 
because its questions cannot be altered.

Exam Section
The Exam Section is the group of controls located at the right-hand portion of the Main 
Window. 

The Exam Section is used to display the Test Items chosen for the exam, to manage the 
organization of the exam, and to access the various Settings dialog boxes that control the 
exam's formatting and printing options. 

Figure 2-3. Exam Section of the Main Window

Exam List. The Exam List is a single-column list box containing references to all of the 
Test Items to be printed in the exam. The question references consist of an icon repre-
senting question type, the exam question number, the database source, the chapter 
source, and the question number source. The organization of the references in the Exam 
List reflect the final organization of the Test Items on the printed test. 

The Exam List displays all of the Test Items in the exam (Common Blocks, Sections, 
Questions, etc.), Common Block and Section linkages, the organization of the exam.

You’ll use the Exam List to do the following tasks:

• move and remove Test Items in the exam
• organize the exam into Sections

Total Questions

The Item (or 
Section) Settings 
(depending on 
whether a Test Item 
or Section is 
selected) dialog 
opens when you 
click this button.

Exam List

Remove a Test Item

Open the Exam Settings 
dialog.
How to Make an Exam 13
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• add instructions and comments to the exam
• specify the exam’s text formatting and print options

Exam Settings Button. Click to open the Exam Settings dialog box. These settings 
control the print formatting, fonts, columns, spacing, etc., for the entire exam. These set-
tings are global to the entire exam; however, some of these settings can be overridden by 
the Section Settings and the individual Question Settings. For more details, see “Format-
ting Exams for Printing” on page 22.

Section Settings Button. Click to open the Section Settings dialog box for the selected 
Section Heading. These settings control the print formatting for a specific Section of an 
exam. These settings override the Exam Settings and revert to the Exam Settings at the 
end of the Section. For more details, see “Formatting Exams for Printing” on page 22. 

Item Settings Button. Selecting any question from the Exam List and clicking this but-
ton opens the Item Settings dialog box. These settings control the formatting for this 
particular question and override both the Exam Settings and Section Settings. The next 
question reverts to the previously defined Section or Exam settings. For more details, see 
“Formatting Exams for Printing” on page 22.

Remove Button. Click to remove the selected Test Item(s) from the exam.

Menu Bar
The Menu Bar is located at the top of the window and contains a variety of pull-down 
menus.

File Menu
The File menu provides a familiar series of Windows File menu options tailored to 
EXAMgen.

Table 2-3: File Menu

Menu Item Shortcut Function

New Exam Ctrl+N Creates a new, untitled exam.
Open Exam Ctrl+O Opens an existing exam.
Close Ctrl+W Closes the current exam.
Save Exam Ctrl+S Saves the current exam; if the exam has not been previ-

ously saved, the Save As dialog box opens.
Save Exam As Opens the Save As dialog box and saves the current 

exam with a user-specified name.
Revert Opens a dialog box that asks if you would like to revert 

to the previously saved version of the exam.
Page Setup Opens the standard Windows Print Setup dialog box.
Print Preview Opens the Print Preview Window where the fully-for-

matted exam can be viewed before printing.
Print Ctrl+P Opens the standard Windows Print dialog box.
Exit Quits the application.
User’s Manual
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Edit Menu 

 

The Edit menu provides some or all of the options listed in Table 2-4 when the Main 
Window, the Editor Window, or the Personal Library Manager Window is active. 

 
 
Table 2-4: Edit Menu 

 
Menu Item Shortcut Function 
Cut Ctrl+X Cuts the selected area and stores it in memory. 
Copy Ctrl+C Copies the selected area and stores it in memory. 
Paste Ctrl+V Pastes the last information stored in memory. 
Clear  Clears or deletes the selected text or Test Item(s). 
Select All Ctrl+A Selects everything in the active window. 

 
 
Database Menu 

 

The Database menu affects only the Question Selection List. 
 
 
Table 2-5: Database Menu 

 
Menu Item Shortcut Function 

Find Ctrl+F Searches the active database for a keyword or phrase 
(2-character minimum). A list of Test Items 
matching the search criteria is displayed in the 
Search Browser Window. Test Items can be viewed 
and inserted into the exam from this window. 

Insert Selection 
to Exam 

 
 

Database 
Browser 

 

Ctrl+I Adds selected questions from the Question Selec- 
tion List to the exam. If more than one question is 
selected, the Add Questions dialog box opens. 

Ctrl+B Brings up the Database Browser Window for 
browsing the current Database, beginning with 
the selected question. (See Chapter 3: Browsers.) 

 
State Standards  Opens a menu of available State Standards. When 

standards are selected they will be applied to the 
Databases that have selected standards available. 

 
Personal Library Menu 

 
 
Table 2-6: Personal Library Menu 

 
Menu Item Shortcut Function 

 

New Personal 
Library 

 
 

Open Personal 
Library 

 

Edit Selected 
Library 

Opens a dialog box requesting a new Personal 
Library name. When a name is entered, EXAMgen 
creates and opens a new, blank Personal Library. 

 

Opens a menu of available personal libraries. 
 
 
Ctrl+E Opens the Personal Library Manager Window for 

the active Personal Library Database. 
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Exam Menu
The Exam menu affects only the Test Items in the Exam List.

Selecting and Adding Questions to an Exam
Creating an exam is the process of selecting questions from the Question Selection List in 
the Database Section and adding them to the Exam List in the Exam Section. A single 

Table 2-7: Exam Menu

Menu Item Function

Exam Settings Opens the Exam Settings dialog box.
Item Settings Opens the Item Settings dialog box for a selected 

question.
Insert New Section Inserts a new Section into the current exam, 

immediately after the selected Test Item.
Remove Selected Removes the selected Test Item(s) from the cur-

rent exam.
Exam Browser Opens the Exam Browser Window to view the 

Test Items in the current exam.
Clear Exam Deletes the current exam contents.
Reset Print Version Resets the serial number and re-scrambles multi-

ple choice answers, creating a new answer key.

Once you've printed an exam, the exam is 
assigned a unique ID number. As long as you do 
not make any structural changes to the exam (add, 
delete, or move questions) and do not exit from 
EXAMgen, the next time you select File>Print, 
you get a (nearly) identical version of the same 
exam, with the same serial number and answer key. 

This allows you to change the exam margins, font, 
font size, etc. without generating a new serial 
number. 

Note
If you save an exam, quit the program, and re-
open the saved exam, you cannot re-create a pre-
viously printed serial number.

Exam Browser Opens the Exam Browser Window to view the 
Test Items in the current exam.

Language Preference Provides non-English versions for some data-
bases. Check the desired language. A translation 
that is grayed out is not available for the chosen 
database.
User’s Manual
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exam can contain Test Items from many different EXAMgen and Personal Library Data-
bases. 

The process is simple:

1. Select a database from the Database Selection Menu.

2. Choose a chapter from the Chapter Selection Menu (for EXAMgen Databases only). 
Available question numbers appear in the Question Selection List; available topics are 
displayed the Topic List.

3. Select (highlight) desired questions. 

4. Add the questions to the exam list.

Note
Just for practice, try each of the methods for selection and insertion listed. If you wish to 
review the steps involved in making a simple exam, review “Making an Exam” on page 4.

Selecting Questions
There are a variety of methods used to select and add questions to an exam. You can 
select questions individually or in groups. 

Select individual questions in either of the following ways:

• Using the mouse—click on a question number.
• Using the keyboard—type-in a question number.
• Browse and insert from the Database Browser.
• Search for questions containing a key work using Database>Find.

Select multiple questions in the following ways:

• Click one question number and then shift-click on another question number to 
select those two and all the questions between them.

• Ctrl-click multiple question numbers.
• Click on a topic in the Topic List to select all questions pertaining to that topic.
• Shift-click topic names in the Topic List to select several topics in a continuous 

range.
• Control-click to select multiple topics.

Note
When you add a group of questions to an exam, the Insert Questions dialog box prompts 
the user for more input.

Browse and Insert. The Database Browser Window lets you step through and view the 
items in the database, question by question. Click Insert to Exam to insert a displayed 
question into the exam. (See Chapter 3: Browsers for more information.)

Search and Add. Use Database>Find to create a list of test items that contain a particu-
lar keyword or phrase. A list of references satisfying the search criteria is displayed in a 
Search Browser Window. Each Test Item in the list may be viewed on-screen by clicking 
on its reference. Click Insert to Exam to include the displayed question in the exam.
How to Make an Exam 17
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Inserting Selected Questions into an Exam
Insert selected questions into an exam in any of the following ways:

• Click Insert button at the top of the window.
• Drag and drop the selected questions into the Exam List.
• Press <enter>.
• Database>Insert Selection to Exam (Ctrl+I).
• Double-click on a question.
• Database>Database Browser (Ctrl+B) to open the Database Browser Window; 

click the Insert to Exam.

Note
The Database Browser is a window that allows you to view each question in a database 
on the screen. Open the Database Browser as follows: Database>Browse Database, or 
double-click a question number in the Question Selection List.

Once a question is inserted into an exam, the question number is grayed out in the Ques-
tion Selection List. This means that the questions have already been added to the exam 
and cannot be duplicated.

Insert Questions Dialog Box. The Insert Questions dialog box allows you to randomly 
insert questions from a selected group of questions. The default value is the total number 
of selected questions, excluding questions already in the exam. Type-in the number of 
questions that you want to add to the exam. 

Note
If you want EXAMgen to randomly choose the specified number of questions from the 
selected items, check Add Randomly. If Add Randomly is unchecked, the program adds 
the specified number of questions in sequential order.

Viewing an Exam
Double-click on a Test Item in the Exam List to bring up the Exam Browser Window. 
Step through the questions in your exam using the Next Question (>>) and Previous 
Question (<<) buttons. Viewing an exam works much like browsing a database with the 
Database Browser Window; however, only those questions placed in the exam are dis-
played. Another way to view your results is to select File>Print Preview.

Organizing an Exam
Before printing the exam, you might want to reorganize the Test Item references in the 
Exam List. 

The first Test Item at the top of the Exam List is always a Section (discussed in more detail 
below). Nested beneath the section are the Test Items that will be printed in the exam.
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Exam Elements
An EXAMgen exam is made up of four basic elements: questions, sections, common 
blocks, and custom items. 

Questions
The questions in the exam have the following attributes:

• an icon indicating question type
• the question number as it appears in the printed exam
• a database reference indicating from where the test item originated (database, 

chapter #, question #)

Sections
All exams have at least one section; most have multiple sections. Sections serve many 
purposes and functions:

• Sections are used to group and organize the Test Items in an exam. For example, 
the easier questions can be put in a first section, more difficult questions in a sec-
ond section, and free response questions in a third section. The EXAMgen appli-
cation scrambles Test Items only within the section to which they are linked.

• Sections control the basic formatting and printing characteristics of its linked Test 
Items. 

• Sections may be used to insert titles and instructions into the printed exam.
Test Items that are linked to a Section appear indented below the Section marker.

All of the questions and Custom Items in an exam must be linked to a Section. The first 
Test Item in the Exam List is always a Section and cannot be removed. The EXAMgen 
application automatically inserts a Section at the top of the Exam List.

Common Blocks

An icon that looks like a three-leaf clover  denotes a Common Block. A Common 
Block is a table, graph, diagram, illustration, or block of text that is referred to by several 
questions. The program automatically moves, groups together, and indents all the ques-
tions in a Section that are linked to a Common Block. 

Note
When printed, the Common Block is preceded by a line of text: “Questions # through # 
refer to the following.” If a Common Block contains only a single question, the program 
merges the Common Block content and the question content into a single question.

Custom Items
Custom Items are user-defined blocks used to introduce instructions, reference tables, 
etc. into an exam. Custom Items are created and stored in Personal Libraries; any of the 
standard Insert procedures may be used to add them from the Question Selection List to 
the Exam List. Think of Custom Items as a library of instructions or diagrams that can be 
recalled and duplicated within an exam. 
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Note
A Custom Item cannot be inserted into a Common Block. 

Once a Custom Item is inserted into an exam, its position does not change even if the 
Test Items around it are scrambled. For this reason, it is recommended that Custom 
Items be inserted immediately following a Section break (so that they remain in the 
proper relative order to the linked test items).

Viewing Exam Questions
Double-clicking on a question in the Exam List or selecting the menu command 
Exam>Exam Browser opens the Exam Browser Window. You can step through and look 
at each question in the exam using the Next (>>) and Previous (<<) buttons. 

The Exam Browser always integrates a Common Block’s contents with the linked ques-
tion to display the question in its entirety. Multiple questions linked to a Common Block 
print in the manner described above in Common Blocks, not as viewed in the Exam 
Browser.

Once you have selected the Test Items for an exam, you can print the exam; the printed 
exam appears almost exactly as it does in the Exam List. By using sections and custom 
items, you can organize and manage an exam’s structure and format.

Controlling Exam Structure
An exam’s basic structure is controlled through the use of section breaks and the place-
ment of common blocks.

Inserting a Section
Select the Test Item immediately above the point where you want to insert the Section; 
then, Exam>Insert New Section.

A new, untitled Section appears in the Exam List below the insertion point. You can add 
as many Sections as you need and write individual instructions or titles for each Section 
using the Section Settings dialog box controls. (See “Formatting Exams for Printing” on 
page 22.) 

When you insert a Section, all of the Test Items below it and up to the next Section 
Marker (or to the end of the exam) are included in the new Section. 

Re-sequencing test items
Test Items can be moved around within the Exam List by dragging and dropping them 
from one location to another.

Moving a Question
Select the question(s) that you want to move using the click, shift-click, or control-click 
selection methods. Drag and drop the selected questions into the new location.
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Moving a Common Block
When you move a Common Block, you move all its linked questions. Click on the Com-
mon Block marker; drag and drop it into a new location. Moving Common Blocks is sub-
ject to several restrictions:

• Questions belonging to a Common Block may be moved only within that Com-
mon Block or to another Section.

• If a question linked to a Common Block is moved to another Section, copies of 
the Common Block and the question are inserted into the new Section.

• Common Blocks cannot be inserted into other Common Blocks.
• Questions that are not linked to a Common Block cannot be moved into or linked 

to a Common Block (except in the Personal Library Manager).
• A linked question cannot be unlinked from a Common Block (except in the Per-

sonal Library Manager).

Moving a Section
Move one section’s content to another section as follows:

1. Create the new section.

2. Move (drag and drop) the desired content into the new section.

3. Delete the original (now empty) Section.

Moving Custom Items
Custom Items can be moved within the Exam List by dragging and dropping them from 
one location to another. It is recommend that Custom Items be placed directly following 
a Section.

Removing Test Items from an Exam

Removing a Question
Select the question(s) from the Exam List; then, either click Remove or use 
Exam>Remove Selected.

Removing a Common Block
Select the Common Block Marker; then, either click Remove or use Exam>Remove 
Selected. Questions linked to the Common Block are automatically removed as well.

Removing a Custom Item
Select the Custom Item to be removed; then, either click Remove or use Exam>Remove 
Selected.

Removing a Section Marker
Select the Section to be removed; then, either click Remove or use Exam>Remove 
Selected. The Test Items (nested beneath the removed section marker) are appended to 
the end of the previous Section. 
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Note
The first Section in an exam cannot be removed. 

Removing a Section and its Contents
Select the Section and some or all of its Test Items; then, either click Remove or use 
Exam>Remove Selected. Any unselected Test Items are appended to the end of the pre-
vious Section.

Removing All Contents from an Exam
Select Exam>Clear Exam. Another method is to click on the first Section, shift-click on 
the last Test Item, and either click Remove or use the Exam>Remove Selected.

Formatting Exams for Printing
The EXAMgen Test Generator application uses settings (collections of parameters) to 
specify printing options. Some formatting choices to consider are page layout, font size, 
number of versions, answer blanks, rule lines, number of columns, question ordering, 
spacing parameters, etc. These format settings can be viewed and modified in three dif-
ferent Settings dialog boxes: Exam Settings dialog box, Section Settings dialog box, and 
Item Settings dialog box.

Exam Settings
The parameters shown in the Exam Settings dialog box apply to all of the Test Items in 
the Exam List. Some of these properties can be overridden at the Section level and a few 
can be overridden at the Question level. 

When you create a new exam, the Exam Setting parameters establish (globally) Section or 
question parameters until changed and overridden. It is recommended that you establish 
global settings in the Exam Settings dialog box first—before changing Section or Ques-
tion Item Settings. 

Changing Exam Settings (after making changes to the Section or Question Item Settings) 
does not affect any parameters previously set by the user.
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Figure 2-4. Exam Settings Dialog Box

Accessing the Exam Settings Dialog Box
To open the Exam Settings dialog box, click Exam Settings or use Exam>Exam Settings. 
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Table 2-8: Exam Settings Dialog Box Controls 

Control Function 

Font Offers a menu of fonts. For best results, do not use cursive 
fonts or “extended” font styles. 

Size Offers a menu of sizes for the selected font. A font size of 
between 10 points and 12 points is recommended. 

Columns Defines the number of columns to be used. For best results, 
use 1 or 2 columns. Using 3 or 4 columns gives varied results 
depending upon font (narrow fonts are best) and font size 
choices (10 to 12 point). When using multiple columns, 
always preview the exam before printing to make sure you 
are getting the results that you want. 

The EXAMgen Test Generator application is an expert- 
based system, which means that the application makes deci- 
sions to give better results. For example, if a question with a 
large graphic does not fit into three columns, the application 
moves the question to where it fits best. A paper-saving fea- 
ture, called cascading columns, moves and arranges the 
questions in three columns, then two columns, and finally a 
single column. Cascading columns works only when Allow 
Print Reordering is checked. 

Versions Sets the desired number of printed versions of the exam. 
Multiple versions of an exam are made by scrambling the 
answer order of multiple choice questions and/or scram- 
bling question order. 

Each exam version prints a unique code number in the top 
right-hand corner of the exam that matches the code num- 
ber printed on the answer key. The number following the 
dash represents the version number (e.g., version 2 is 
denoted by 6349-2). 

Answer Labels Defines how the multiple choice answer labels are printed: 
bold and non-bold lowercase letter, uppercase letter, number, or 
ovals. 

Margins Sets margins for the printed exam. For the best results, use 
default EXAMgen settings. 

Defaults Only two default preferences are ever available: EXAMgen 
default settings and the most recently saved user-default set- 
tings. 

Factory Defaults   Returns all settings back to the EXAMgen default settings. 
Load Defaults Toggles defaults from the EXAMgen settings to the most 

recently saved user settings. 
Save As Defaults   Saves the settings currently displayed in the Exam Settings 

dialog box only. The next time you start the application, the 
Exam Settings uses these saved values. 
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Section Settings 
The parameters shown in the Section Settings dialog box apply to all of the Test Items 
within the selected Section in the Exam List. The default parameters are the settings 
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Answer Key Creates and prints an answer key for each version of the 
exam. It is recommended that this option always be checked.

Print Origins Includes, when checked, the database references (question 
source) in the printed answer key. This option is available 
only when Answer Key (above) is checked. 

Allow Print 
Reordering

Enables, when checked, the program to make decisions 
regarding the order of questions in the exam. 

This option becomes active only when part or all of an exam 
is being printed in two or more columns. If the program 
determines that a question cannot fit in the specified col-
umn width or length, the cascading columns feature 
becomes active and moves the question to a wider column 
or to full-page width at the end of the Section. If the check box 
is not checked, the question order does not change, and the 
number of columns changes based on question sequence.

Scramble Ques-
tions

Scrambles, when checked, the order of the questions for all 
exam versions. 

Section order does not change, but the Test Items linked to 
the Section do scramble within the Section. Custom Items 
do not scramble. Common Blocks scramble, and all ques-
tions linked to a Common Block are scrambled within the 
Common Block.

Column Rule 
Lines

Prints, when checked, a vertical rule between columns. This 
feature becomes active when printing part or all of the exam 
in two or more columns.

Answer Blanks Inserts, when checked, an Answer Blank in front of each 
question number.

Sections Start 
New Page

Prints, when checked, each Section at the start of a new 
page.

Convert M.C. to 
S.A.

Converts, when checked, all multiple choice questions to 
short answer questions. 

Be aware that not all multiple choice questions are appropri-
ately worded to be good short answer questions. The best 
place to use this feature may be in the Section Settings or 
Item Settings dialog boxes.

S.A. Answer 
Lines

Establishes the number of blank text lines (approximately 6 
lines per inch) allocated to for a short answer response.

Table 2-8: Exam Settings Dialog Box Controls (Continued)

Control Function
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defined in the Exam Settings dialog box. Any changes made to the Section Settings over-
ride global Exam Settings.

Figure 2-5. Section Settings Dialog Box

Accessing the Section Settings Dialog Box
To open the Section Settings dialog box, click on a Section Item in the Exam List and 
either double-click on the Section Item or click Section Settings.

Table 2-9: Section Settings Dialog Box Controls

Control Function

Text The text property controls are the same as those listed in the Exam 
Settings: Font, Size, and Columns. 

Comment The comment edit box accepts your own section description or 
name. Your description appears only in the Exam List, not in the 
printed exam.
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Item Settings
The parameters shown in the Item Settings dialog box apply to an individual question 
within the Exam List. The default parameters are the settings defined in the Section Set-
tings dialog box. Any changes made to the Item Settings override the global Exam Set-
tings and the Section Settings.

Figure 2-6. Item Settings Dialog Box

Header/
Instructions

Instructions and Section titles can be added to an exam in two 
ways. They can be added in the Section Settings dialog box in the 
Header/Instructions edit box or they can be created as Custom 
Items. Most often, titles and instructions are added using the Sec-
tion Settings. 

The Header/Instructions text of the exam’s first Section always 
prints at the top of the first page. The default contents of this Sec-
tion’s Header/Instructions edit box is a Student Name Blank.

All additional Sections have empty Header/Instructions edit 
boxes. The Header/Instructions text always prints at the beginning 
of a Section. 

To add more extensive or complex instructions to an exam, use a 
Custom Item. We recommend creating a Personal Library contain-
ing only Custom Items with instructions and tables that you may 
frequently use. One advantage to using Custom Items, besides its 
reusability, is that they support bitmap graphics and scientific and 
mathematical notation. The Header/Instructions edit box in the 
Section Settings dialog box does not. 

Once the Custom Item has been created and saved, simply insert it 
into the Exam List directly below the Section Heading. Custom 
Items do not change their relative position in the exam even if the 
Test Items are scrambled.

Options The option property controls are the same as those listed in the 
Exam Settings: Scramble Question Order, Answer Blanks, Start 
New Page, Convert M.C. to S.A., and S.A. Answer Lines.

Load from Exam Resets all section settings to those of the exam settings.

Table 2-9: Section Settings Dialog Box Controls (Continued)

Control Function
How to Make an Exam 27



EXAMgen 4.4

28
Accessing the Item Settings Dialog Box
To open the Item Settings dialog box, select a question in the Exam List and click Item 
Settings, or select Exam>Item Settings. 

Saving, Recalling, Previewing, and Printing 
an Exam
Once all of the formatting decisions have been made and you are ready to print your 
exam, you should save it, preview the exam on the screen, and print the exam, including 
all of its versions.

Saving and Recalling an Exam

Saving an Exam
To save an exam, use File>Save Exam (Ctrl+S) or File>Save Exam As. These commands 
open the standard Windows Save and Save As dialog boxes. Exams may be saved to any 
location on the computer.

Recalling an Exam
To recall a previously saved exam, use the File>Open (Ctrl+O) command in the menu 
bar. This command opens the standard Windows Open dialog box. Exams may be 
retrieved from any location on the computer.

Setting up Pages
Before previewing and/or printing the exam, make sure that there aren’t any settings in 
the Print Setup dialog box that need to be changed first. The EXAMgen application sup-
ports changing paper size (letter size, legal size), and changing page orientation (portrait, 
landscape). To change any of these settings, select File>Page Setup. This command opens 
the standard Windows Print Setup dialog box.

Table 2-10: Item Settings Dialog Box Controls

Control Function

Source Identifies the question’s database reference (database, chapter, ques-
tion #).

Description Offers an opportunity to enter a description or name for the ques-
tion. This descriptive text is viewed only in the Exam List; it does not 
print.

Options Option property controls are the same as those listed in the Exam 
Settings: Convert to S.A., Print in Single Column (forces the question 
to print in the wide, single column format), Answer Blank, and S.A. 
Answer Lines.

Load from Exam Resets Item Settings to those of the Section Settings.
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Previewing a Formatted Exam
Print Preview allows you to view the fully-formatted exam on the screen before you print 
it. 

Figure 2-7. Print Preview

To access the Print Preview Window, select File>Print Preview from the menu bar. A 
fully-formatted view of the exam is displayed on the screen. 

Note
Only the first version of an exam can be previewed on the screen. 
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Once you like what you see and have no further changes to make, click Print to open the 
standard Windows Print dialog box. The program prints the specified number of copies, 
versions, and a single answer key for each version. This method of printing is recom-
mended strongly.

Printing an Exam
To print an exam, select File>Print (Ctrl+P) from the menu bar. This command opens 
the standard Windows Print dialog box where you can specify the number of copies, spe-
cific pages, print destination, etc. (See Figure 2-8. )

Note
EXAMgen prints one version of an exam until the user adds or deletes test items, 
changes item sequence, or resets the print version.

Figure 2-8. Windows Print Dialog Box

Table 2-11: Print Preview Controls

Control Function

Print Prints the exam.
Cancel Cancels the print function and returns to the Main Window.
Zoom-/+ Shrinks and enlarges the view.
<< and >> Steps backward and forward through the document one page 

at a time. The text above these buttons tells you the total num-
ber of pages in the exam and what page number you are cur-
rently on.
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Resetting the Print Version
To reset the print version of a test, use Exam>Reset Print Version. This command resets 
the serial number and re-scrambles multiple choice answers, creating a new answer key.

Once you've printed an exam, the exam is assigned a unique ID number. As long as you 
do not make any structural changes to the exam (add, delete, or move questions) and do 
not exit from EXAMgen, the next time you select File>Print, you get a (nearly) identical 
version of the same exam, with the same serial number and answer key. 

This allows you to change the exam margins, font, font size, etc. without generating a 
new serial number. 

Note
If you save an exam, quit the program, and re-open the saved exam, you cannot re-create 
a previously printed serial number.

Answer Keys
EXAMgen automatically prints an answer key for each version of an exam unless the 
Answer Key check box in the Exam Settings dialog box is unchecked.

Each exam version prints a unique code number (e.g., 6349-1) in the top right-hand cor-
ner of the exam that matches the code number also printed in the top right-hand corner 
of the answer key. The number following the dash represents the version number (e.g., 
the second version is denoted by 6349-2). These code numbers change every time an exam is 
printed. To correlate an answer key with an exam, simply match the code number on the 
exam with the number on the answer key. 

If you checked the Print Origins check box in the Exam Settings dialog box, then the 
database references (question source) is also printed in the answer key. (See Figure 2-9. )
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Answer Key

Answer Key with Print Origins

Figure 2-9. Answer Key Options
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Browsers
Chapter 3
Browsers are popup windows used to view Test Items on the screen. The EXAMgen 
Test Generator application uses three different browsers: a Database Browser, an Exam 
Browser, and a Search Browser. Each Browser popup window displays a fully-formatted 
Test Item on the screen, but these windows differ regarding the circumstances in which 
they are used and what controls they offer.

Browser Controls
Each of the three Browsers use the following controls: Next Question, Previous Ques-
tion, and edit boxes. Other controls are used by individual browsers, which are indicated 
in each heading.

Next Question (>>)
Click this button to display the next Test Item in the database, exam, or search list. If the 
displayed Test Item is the last item in the database, exam, or search list, the button 
becomes inactive (grayed out). 

Previous Question (<<)
Click this button to display the previous Test Item in the database, exam, or search list. If 
the displayed Test Item is the first item in the database, exam, or search list, the button 
becomes inactive (grayed out). 

Question or Item Edit Boxes 
Either of these edit boxes appearing at the top left-hand screen of the Browser Window 
displays the reference number of the Test Item being shown.

Typing a valid question number into the edit box displays that Test Item on the screen. 
When an invalid number is entered, either the first or last question number is displayed. 

• In the Database Browser, the viewer displays the typed-in Test Item of the current 
chapter. 

• In the Exam Browser, the viewer displays the typed-in Test Item of the current 
exam. 

• In the Search Browser, the viewer displays the Test Item reference from the result-
ing search.
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Database Selection Menu (Database Browser)
This menu allows the user to select another database to browse. Selecting a database 
name in this menu displays the first question in the first chapter of the selected database.

The Search Browser also has a Database Selection menu, but it is grayed-out. The pur-
pose of this menu is only to inform the user of the name of the database that was 
searched. The user cannot change databases from this window.

Chapter Selection Menu (Database Browser)
This control is active for EXAMgen Databases only. Use the Chapter Selection menu to 
select a chapter to browse in the active EXAMgen Database.

Topic Selection Menu (Database Browser)
This control is active for EXAMgen Databases only. Use the Topic Selection menu to 
select a topic to browse in the current chapter. The first item displayed is the first ques-
tion in the selected topic group.

Edit Button (Database and Search Browsers)
This button is active for Personal Library Databases only. Click Edit to open the Editor 
Window where the viewed Test Item can be edited.

Insert to Exam Button (Database and Search Browsers)
Click to insert the currently displayed Test Item into the exam. The Test Item is inserted 
below the last highlighted item in the Exam List.

Browse Source Button (Exam Browser only)
Click to browse the database from which the currently displayed Test Item originated. 
This button activates a Database Browser Window. To return to the Exam Browser, close 
the Database Browser.

Remove Button (Exam Browser only)
Click to delete the currently highlighted Test Item from the Exam List.

Database Browser
The Database Browser is used to view Test Items in both EXAMgen and Personal 
Library Databases. 
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Figure 3-1. Database Browse (typical)

If the Test Item viewed in the Browser is linked to a Common Block, the Database 
Browser automatically integrates the Common Block with the linked question for each 
question in the Common Block.

• In EXAMgen databases, the Database Browser displays questions only.
• In Personal Libraries, the Database Browser displays both questions and Custom 

Items.

Accessing the Database Browser
To access the Database Browser Window, either highlight a Test Item from the Question 
Selection List and select Database>Database Browser (Ctl+B) from the menu bar or 
double-click the Test Item to quickly start the Database Browser.

The first item displayed by the Database Browser is the highlighted or double-clicked 
Test Item.
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Exam Browser
The Exam Browser is used to view Test Items in the Exam List. 

Figure 3-2. Exam Browser (typical)

As in the Database Browser, when the question viewed in the Exam Browser is linked to 
a Common Block, the Exam Browser automatically integrates the Common Block with 
each linked question. The Exam Browser Window displays questions and Custom Items, 
but skips over Sections.

Accessing the Exam Browser
To access the Exam Browser Window, either highlight a Test Item from the Exam List 
and select Exam>Exam Browser from the menu bar or double-click the Test Item to 
quickly start the Browser

The first item displayed by the Exam Browser is the highlighted or double-clicked Test 
Item.

Search Browser
After a search (i.e., Find operation) is completed, the Search Browser Window becomes 
active. A list of reference numbers (chapter and Test Item numbers) satisfying the search 
criteria is displayed in the Search List Box to the left of the Search Browser Window. (See 
Figure 3-4. )
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Accessing the Search Browser
To open the Search Browser Window, you must first run a search using the menu bar 
command Database>Find (Ctl+F). This opens the Find dialog box, which is used to 
select a database to be searched and to enter a search keyword or phrase.

Figure 3-3. Find Dialog Box

Figure 3-4. Search Browser

Table 3-1: Find Dialog Box Controls

Search Menu Selects the database to be searched. The default database is the 
name of the database currently displayed in the Main Window. 
All chapters of the specified database are searched for every 
occurrence of the word or phrase entered in the Find edit box.

Find Edit Box Use this edit box to enter the keyword or phrase to be found 
in the selected database. The entered search word or phrase is 
not case-sensitive.

Find Button Click Find to begin the search and to open the Search Browser 
Window.

Cancel Click Cancel to end the search process.
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Personal Library Manager
Chapter 4
Personal Libraries are created and maintained by the user. The Personal Library Manager 
is the tool used to create, edit, organize, and maintain Personal Libraries.

Use the Personal Library Manager to accomplish the following tasks:

• write new Test Items of various types and save them to a Personal Library
• organize the Test Items in the Personal Library List into logical groups
• edit Test Items and their properties in the Personal Library List
• copy Test Items from EXAMgen databases, Personal Libraries, and exams into the 

Personal Library List
• print a manual of Personal Library Test Items 

To learn how to write and edit your own questions, review Chapter 5: The Editor.

Personal Libraries behave exactly like EXAMgen databases when it comes to selecting 
Test Items and formatting and printing exams. However, Personal Libraries and EXAM-
gen databases differ in the following ways:

• The organization and content of EXAMgen databases cannot be modified.
• Personal Libraries have only one chapter.
• Every Test Item in a Personal Library has a unique serial number.

Personal Library Manager Window
Open the Personal Library Manager Window in any of the following ways:

• Personal Library>New Personal Library
• Personal Library>Open Personal Library
• Select an existing Personal Library from the Database drop-down menu (Main 

Window), and click Edit.
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Figure 4-1. Personal Library Manager Window

The Personal Library Manager Window displays the contents of a Personal Library. It is 
the focal point for creating, organizing, and managing Personal Libraries. 

Table 4-1: Personal Library Manager Window Controls

Control Function

Personal Library 
List 

All Test Items in the Personal Library are displayed. The Personal 
Library List is used to do the following:

• Introduce new Test Items into a Personal Library.
• Re-sequence Test Items within the Personal Library.
• Select Test Items for browsing, editing, duplicating, and delet-

ing.
• Set parameters that control the printing of a Personal Library 

manual.
New Item Inserts a new Test Item into the Personal Library List. 
Edit Item Opens the Editor Window where the selected Test Item can be mod-

ified.
Remove Deletes selected Test Items from the Personal Library List.
File Menu Close (Ctrl+W)—closes the active Personal Library Manager Win-

dow. 

Page Setup—opens the standard Windows Print Setup dialog box.

Print Personal Library (Ctrl+P)—prints a manual of the items in the 
associated Personal Library Manager Window.

Personal Library List 
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Personal Library Serial Numbers
Each time a new Test Item (question, Custom Item, Common Block, or Section) is added 
to a Personal Library, it is assigned a unique serial ID number. Serial numbers are 
assigned sequentially in the order they where added to the Personal Library. Once a serial 
number is assigned, it is not repeated or used again in that Personal Library. 

The purpose of assigning each Test Item a unique serial number is so that the EXAMgen 
application can find the correct Test Item, even if it has been edited, moved, or deleted. 

The Test Items in the Question Selection List and in the printed Personal Library manual 
are referred to by a serial number. 

• Test Item serial numbers in the Question Selection List are arranged in numerical 
order. The Test Items displayed in the Personal Library List can be rearranged and 
may no longer appear in numerical order. Therefore, when selecting questions 
using the Topic List, the highlighted questions may appear scattered all over the 
screen following rearrangement of Test Items.

• Test Items in the printed Personal Library manual are arranged in the exact order 
that they are arranged in the Personal Library List.

To find an item in the Personal Library List, key in the item’s serial number.

If a Test Item is deleted from a Personal Library, its serial ID is retired forever. This 
ensures that when you recall and print an exam, the correct Test Item is retrieved even if 
its position in the Personal Library has been changed. If an exam calls for a Personal 
Library Test Item that has been deleted, you receive an error message.

Edit Menu Copy (Ctrl+C)—copies selected Test Items in the Personal Library 
List to the clipboard.

Paste (Ctrl+V)—inserts the Test Items on the clipboard into the Per-
sonal Library List.

Select All (Ctrl+A)—selects all the Test Items in the Personal Library 
List.

Personal Library 
Menu

New P.L. Item (Ctrl+N)—opens the dialog box in which a new Test 
Item may be created and inserted into the Personal Library List.

Edit P.L. Item (Ctrl+E)—opens the Editor Window for the selected 
Test Item in the Personal Library List.

Duplicate Item (Ctrl+D)—creates a duplicate or clone of the 
selected Test Item in the Personal Library List.

P.L. Section Settings (Ctrl+S)—active when a Section Item is 
selected. Opens the P.L. Section Settings dialog box.

Database Menu Find (Ctrl+F)—opens the Find dialog box that allows you to search 
for a word or phrase in a Personal Library.

Database Browser (Ctrl+B)—opens the Database Browser Window.

Table 4-1: Personal Library Manager Window Controls (Continued)

Control Function
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As a consequence of moving and deleting Test Items, serial numbers may be missing and 
out of order.

Managing Personal Libraries
Managing Personal Libraries involves the following tasks:

• Creating a New Personal Library
• Copying Test Items into a Personal Library
• Adding New Questions into a Personal Library
• Editing Test Items in a Personal Library
• Moving, Deleting, Duplicating, Copying, and Pasting Test Items within a Personal 

Library
• Using Common Blocks and Linking Questions
• Managing Custom Items
• Organizing a Personal Library Using Sections

Creating a New Personal Library
To make a new Personal Library, select Personal Library>New Personal Library from the 
Main Window menu bar and enter a unique name in the New Personal Library dialog 
box. After choosing a name, click OK and a new Personal Library Manager Window dis-
plays. The new Personal Library file is created in the EXAMgen/Database folder.

Figure 4-2. New Personal Library Dialog Box

Copying Test Items into a Personal Library
Test Items may be copied from Personal Libraries, EXAMgen Databases, or exams into 
the active Personal Library. 

Copy a selected Test Item in a source window in either of the following ways:

• Drag and drop Test Items between the source window and the Personal Library 
List.

• Copy the Test Item to the clipboard, position the cursor at the insertion point in 
the Personal Library List, and paste in the Test Item after the insertion point.

Both of these procedures insert the question, any Common Block to which it is linked, 
and reference numbers into the Personal Library. Links between a Test Item and its 
related Common Block are automatically reestablished in the Personal Library.

When a question is linked to a Common Block and that Common Block already exists 
within a section of the Personal Library, the new question and its reference number are 
automatically merged with the existing Common Block.
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Adding Test Items to a Personal Library
While in the Personal Library List, choose an insertion point and either select Personal 
Library>New P.L. Item (Ctrl+N) or click New Item.

Figure 4-3. New Personal Library Item dialog box

From the New Personal Library Item dialog box, choose a Test Item type:

• Short Answer question
• Multiple Choice question
• True/False question
• Fill-In-The-Blank question
• Common Block
• Custom Item
• Personal Library Section
• Print Command

An empty Test Item of the selected type is inserted into the Personal Library List beneath 
the insertion point. For all items except Section, the Editor Window opens for the new 
Test Item, ready to accept options settings and text.

Editing Test Items in a Personal Library
To edit any Test Item in a Personal Library, click on the Test Item and either select Per-
sonal Library>Edit P.L. Item (Ctrl+E) or click Edit Item to open the Editor Window. To 
learn how to maneuver around the Editor Window and how to create and edit new Test 
Items, see Chapter 5: The Editor.

Editing a Personal Library List

Moving Test Items
To move listed Test Items, drag and drop one or more Test Items to any new location 
within the Personal Library List.

Deleting Test Items
To remove a Test Item or group of Test Items from the Personal Library List, select the 
Test Item(s) to be deleted and click Remove.
Personal Library Manager 43



EXAMgen 4.4

44
Duplicating, Copying, and Pasting Test Items
To duplicate (clone) a Test Item within a Personal Library List, select the Test Item to be 
duplicated and choose Personal Library>Duplicate Item (Ctrl+D) from the menu bar. 
The duplicate Test Item is inserted directly below the highlighted Test Item.

Test Items may be copied and pasted from EXAMgen Databases, from other Personal 
Library Databases, and from within a Personal Library using normal copy-and-paste pro-
cedures. A copied Test Item is inserted directly below the insertion point.

Creating Common Blocks and Linking Questions
The Personal Library gives the user complete editorial control over Common Blocks 
(commonly shared information referred to by one or more questions). 

Create a Common Block as follows:

1. Highlight the position (in the Personal Library List) below where you want to insert a 
new Common Block. 

2. Use Personal Library>New P.L. Item (Ctrl+N) to open the New P.L. Item dialog box.

3. Select Common Block. 

4. Type-in a descriptive name for the new Common Block. An empty Editor Window 
automatically opens. (See Chapter 5: The Editor to learn about using the Editor Win-
dow to insert graphics into new Common Blocks.

Linking to and Unlinking from a Common Block
Multiple questions may be linked to a Common Block by dragging and dropping the 
question onto the Common Block. The linked question(s) appear indented below the 
Common Block. 

Figure 4-4. Common Block Linkages

To unlink a question from a Common Block, drag and drop the question to a new loca-
tion. When dragging a question, a red arrow and line indicates the question's position. To 

Common Block 
with

Linked Questions

Unlinked Item
(Short Answer Type)
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unlink the question, make sure the arrow snaps to the left, outside the domain of the 
Common Block. The question reference is no longer indented under the Common Block 
Header.

Copying and Duplicating Common Blocks
To duplicate a Common Block within a Personal Library, select the Common Block 
Header to be duplicated and select Personal Library>Duplicate Item (Ctrl+D). The 
duplicate Common Block Header is inserted directly after the highlighted Common 
Block and all its linked questions.

To create a copy of the Common Block, select Edit>Copy (Ctrl+C), click on an insertion 
point, and select Edit>Paste (Ctrl+V).

Deleting Common Blocks and Linked Questions
To delete a Common Block and all its linked questions, select the Common Block Header 
from the Personal Library List, shift-click on the last question linked to the Common 
Block, and click Remove.

To delete only the Common Block (not linked questions), highlight the Common Block 
Header, and click Remove. 

Moving Common Blocks
To move a Common Block and all its linked questions, highlight the Common Block 
Header; then, drag and drop the selection to the new location. 

Note
A Common Block cannot be moved into another Common Block.

Creating Custom Items
Custom Items are units that store tables, instructions, and formulas. Unlike Sections, Cus-
tom Items can contain anything, including text, diagrams, and special notation. 

Frequently used Custom Items include the following:

• Chemistry reference tables
• Mathematical formulas and charts
• Earth Science reference tables
• Test instructions

Note
Consider creating a Personal Library entirely of Custom Items. 

Create a Custom Item as follows:

1. In the Personal Library List, highlight the position above where you want to insert a 
new Custom Item. 

2. Use Personal Library>New P.L. Item (Ctrl+N) to open the New P.L. Item dialog 
box, and select Custom Item. An empty Editor Window opens.
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3. Enter a descriptive name for the new Custom Item in the Database edit box. Review 
Chapter 5: The Editor to learn about using the Editor Window to insert graphics into 
new Custom Items.

Sections
The most common way to organize Test Items and to control the printing features (when 
printing a Personal Library manual) is to use Sections. 

As an organizational tool, a Section may be used as a topic heading or title that appears in 
the Personal Library List, the Main Window Topic List, and as a title for a printed manual 
of Test Items.

Creating a Section

Create a Section as follows:
1. In the Personal Library List, highlight the position above where you want to insert a 

new Section. 

2. Use Personal Library>New P.L. Item (Ctrl+N) to open the New P.L. Item dialog 
box, and select Personal Library Section. The new Section is inserted directly after 
the highlighted Test Item. 

Changing a Personal Library Section Description
Change the description associated with a Personal Library Section as follows:

1. Double-click on the Personal Library Section Item in the list. The P.L. Section Set-
tings dialog box opens.

Figure 4-5. P. L. Section Settings Dialog Box

2. Enter a descriptive title into the Title edit box. (The default description is “Untitled.”)

3. Press OK. The new descriptive title for the Personal Library Section appears in the 
Personal Library List in the Personal Library Manager Window.

Linking Test Items to a Section
A Section contains a group of Test Items. Linked Test Items appear indented below the 
Section Header. 
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Figure 4-6. Section Linkages

To link Test Items to a Section, drag and drop the highlighted Test Item(s) to the Section 
Heading. When you drag one or more Test Items, a small red arrow and line indicate the 
exact placement of the Test Item(s). 

Note
A Section may not be inserted or moved into a Common Block or another Section. 

When selecting questions for an exam using the Topic List, all the questions linked to the 
selected Section title are highlighted in the Main Window’s Question Selection List. If 
there are no Sections in the Personal Library, no topics appear in the Topics List.

Deleting Sections
To delete the Section and all its linked Test Items, select the Section Header from the Per-
sonal Library List, shift-click on the last Test Item linked to the Section, and click 
Remove.

To delete a Section only, highlight the Section Header and click Remove. All Test Items 
linked to that Section merge with the Section preceding it.

Moving Sections
To move a Section and all its linked questions, highlight the Section Header; then, drag 
and drop the selection into the new location. A Section may not be moved into a Com-
mon Block or another Section.

To move the Section only, first unlink the Test Items linked to it.

Browsing Personal Library Test Items
You may open a Database Browser Window in a Personal Library from the Main Win-
dow or from the Personal Library Manager Window.

Section Header 
with

Linked Test Items
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From the Main Window, open a Database Browser Window (for a Personal Library) as 
follows: 

1. Select a Personal Library as the Database. 

2. Double-click the Test Item (in the Question Selection List) that you wish to browse, 
or choose the Database>Database Browser (Ctrl+B).

From the Personal Library Manager Window, open a Database Browser Window (for a 
Personal Library) as follows:

1. Select the Test Item you wish to browse from the list.

2. Choose Database>Database Browser (Ctrl+B).

Note
Pressing Edit from the Database Browser opens the Editor Window with the currently 
displayed Test Item displayed, ready for editing. This feature is not available for EXAM-
gen databases. When you close the Editor, the program returns to the Database Browser 
Window.

Printing a Manual of Personal Library Test Items

Formatting a Manual
The font, font size, number of columns, forced page breaks, and spacing are all con-
trolled by print commands.

Inserting a Print Command
Insert a print command as follows:

1. From the Personal Library Window, click New Item.

2. Choose Print Command.

3. Choose the type of command. 

• Columns—adjusts the number of columns
• New Page—starts a new printed page
• Text Font—changes the font
• Text Size—changes the font size

Note
Each command applies to subsequent items (i.e., those items following the item for 
which the Print Command is issued).

Accessing the P.L. Section Settings Dialog Box
To access the P.L. Section Settings dialog box, click on a Section in the Personal Library 
List and either select Database>P.L. Section Settings from the menu bar or double-click 
on the Section Header.
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Printing
Select File>Print Personal Library (Ctrl+P) from the Personal Library Manager Window. 
This command automatically sends an image (Print Preview) of your Personal Library to 
the screen. If the library preview displays correctly, click Print. 
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The Editor
Chapter 5
The Editor allows you to customize a Personal Library. The Editor has three basic func-
tions:

• to write new Personal Library Test Items
• to edit and modify existing Personal Library Test Items
• to edit Test Item descriptions appearing in the Personal Library List

Test Item Components (Question Parts)
To better understand the Editor, it is important to realize that all Test Items are made up 
of one or more sub-units called Question Parts. A Question Part may be a question stem, 
a correct answer, a wrong answer, or just a single block of text (as in a Common Block). 
You’ll use the Editor to create or edit individual Question Parts. 

When a multiple choice question (with three or more question parts) is changed to a 
short answer question (with only two question parts), the extra answers are hidden but 
not removed. If you revert to a multiple choice question, the extra question parts become 
visible and accessible.

Editor Window
Access the Editor Window in a Personal Library as follows:

• From the Database Browser, click Edit to go directly to the Editor Window.

Table 5-1: Test Items and Question Parts

Test Item Type Question Parts

Common Block question stem 
Custom Item custom item content
Short Answer question stem and correct answer
True/False question stem and correct answer
Fill-in-the-Blank question stem and correct answer
Multiple Choice question stem, correct answer, and up to five 

incorrect answers
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• From the Question Selection List in the Main Window, select any Test Item and 
click Edit. The Personal Library Manager Window opens.

• From the Personal Library Manager Window, select a Test Item and either (a) click 
Edit Item or (b) double-click on the Test Item. 

Figure 5-1. Editor Window

The Editor Window is divided into four sections:

• Question Preview Box
• Question Editor Box
• Menu Bar
• Tool Box

Question Preview 
The Question Preview Box is located at the top right-hand side of the Editor Window. 

The Question Preview Box is used in the following ways:

• to display the complete, fully-formatted Test Item as it would appear when printed
• to select the Question Part to be displayed and edited in the Question Editor Box
• to display and mark the correct answer for multiple choice questions

Selecting Question Parts
To select the Question Part to be edited, click on the Question Part in the Question Pre-
view Box. A rectangle surrounding the Question Part indicates the selected component. 
The editable form of the Question Part is displayed in the Question Editor Box located 
immediately below the Question Preview Box.
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Designating a Correct Answer (Multiple Choice Questions)
The Question Preview Box is also used to indicate the correct answer for a multiple 
choice question. The correct answer is indicated by a red cursive “C.”

By default, the first answer position (the second question part) contains the correct 
answer. We recommend that the correct answer always be in the first answer position. 

To designate a Question Part as the correct answer, double-click on the correct Question 
Part in the Question Preview Box. The EXAMgen application automatically takes care of 
scrambling the answer order and printing the indicated correct answer in the answer key. 

Question Editor
The Question Editor Box is located in the bottom right-hand region of the Editor Win-
dow, below the Question Preview Box. 

The Question Editor Box is used in the following ways:

• to cut, paste, edit, and add text, insert graphics, and add special characters or sym-
bols to a Question Part

• to apply special attributes to text, such as text styles (italic, bold, underline, etc.), 
indents, justification/alignment, Main Lines, non-breaking spacing, GT-Block text 
compression (used for radicals and fractions)

The text displayed in the Question Editor Box corresponds to the Question Part selected 
(enclosed in a rectangle) in the Question Preview Box. As you edit the text in the Ques-
tion Editor Box, the fully-formatted result of your typing appears in the Question Pre-
view Box.

Editor Menu Bar

Table 5-2: File Menu

Menu Item Shortcut Function

Close Ctrl+W Closes the Question Editor.
Insert Graphic Opens the Explorer dialog box for locating and 

picking the desired graphic.

Table 5-3: Edit Menu

Menu Item Shortcut Function

Undo Ctrl+Z Undoes the previous action.
Cut Ctrl+X Cuts the selected area and stores it in memory.
Copy Ctrl+C Copies and stores the selected area.
Paste Ctrl+V Pastes the last information stored in memory.
Clear Clears or deletes the selected text or Test Item(s) 

without closing the editor.
Select All Ctrl+A Selects everything in the active window.
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Style Menu
Most styles are toggles, meaning they can be turned On (checked) and Off (unchecked). 
Check marks before each style in the Styles menu indicates that the style is active for the 
selected text. Multiple styles can be applied to any highlighted block of text.

The most commonly used styles are Plain Text, Bold, Italic, Underline, Overline, Super-
script, Subscript, and Non-Break. Overline is most often used to indicate mathematical 
segments. Non-Break is used to group words or equations together so that they do not 
break during word-wrapping.

To apply a text style, select the text in the Question Editor Box and choose a text style 
from the Style menu, or use one of the shortcut commands listed next to the style. 

To remove a text style from a block of text, uncheck the style in the Style menu.

Format Menu
Formats are attributes that affect whole lines or paragraphs of text and graphics.

Table 5-4:  Item Menu

Menu Item Shortcut Function

New Question Part Ctrl+N Adds a “choice” to multiple choice items. 
Not available for other items.

Delete Current Part Ctrl+D Deletes a “choice” to multiple choice items. 
Not available for other items.

Make Current Answer 
Correct

Ctrl+M Assigns the correct response in a teacher-
made test item.

Save Item Ctrl+S Saves the item.
Save Item As Saves the item with a user-defined name.
Force Wide During 
Printing

When this option is checked, the Test Item 
prints full-page width (single column), 
regardless of the specified number of col-
umns.

Maintain Answer 
Order

If this option is ON (checked), then the 
answer order of the question is not scram-
bled.

When answers refer to a graph with labels 1, 
2, 3, 4, you may prefer not to scramble the 
answer order. Arrange the answers in the 
order you want; then, double-click the cor-
rect answer in the Question Preview Box, 
and check Answers Fixed. Now the multiple 
choice answers print in the order in which 
they appear in the Editor Window.
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Table 5-5:  Format Menu

Menu Item Shortcut Function

Justify Left Ctrl+[ Aligns text or graphics to the left margin. 
Justify Center Ctrl+\ Centers text or graphics.
Justify Right Ctrl+] Aligns text or graphics to the right margin.
Graphics Text Ctrl+G Graphics Text (GT) Blocks vertically com-

press text. GT Blocks are frequently used in 
mathematics and science exams.

GT Blocks maintain vertical (stacking) align-
ment between characters in adjacent rows of 
text and bring these rows of text closer 
together (half-line spacing). Multi-character 
symbols span lines and connect seamlessly.

See “Graphics Text” on page 57.
Mainline A Mainline marks a line of text or a graphic 

where a label (e.g., a question number or 
answer letter) is to be inserted. For example, 
if an answer is a fraction, you would proba-
bly want the answer label to line up with the 
fraction bar rather than with the numerator. 

The default Mainline is always the first line 
in a Question Part. Because only one Main-
line is allowed per Question Part, setting a 
new Mainline replaces the old Mainline. The 
non-default setting of this attribute is used 
almost exclusively with Graphics Text (GT) 
Blocks.

To apply a Mainline, click on the line of text 
or graphic (set the text cursor) where the 
Mainline is to be and choose Format>Main-
line. The Mainline is automatically set at the 
beginning of the selected paragraph or 
graphic.
The Editor 55



EXAMgen 4.4

56
Figure 5-2. Indents Dialog Box

Indents Users can independently set and override 
default Indent properties through the 
Indents controls (see Figure 5-2. ): 

First Line—Sets the left margin position of 
text or graphics in the first line of a para-
graph. (See Figure 5-3. ) To create a para-
graph indent, either use a Tab or reverse the 
values of the Left edit box to 0 and the First 
Line edit box to .25 (or any positive value, in 
inches).

Left—Controls the spacing parameters of 
the first Tab Indent in the first line. It also 
sets the left margin position of subsequent 
word-wrapping lines in the paragraph. A 
hanging indent can be created by setting the 
Left edit box value to any positive value in 
inches and the First Line edit box value to 0. 
(See Figure 5-3. )

Right—Sets the right margin position of the 
selected paragraph. The indenting capability 
of the EXAMgen application is relatively 
basic, but may require a bit of practice to 
achieve the desired results. Be aware that 
changing fonts and font sizes can affect the 
relative size of user-specified indents.

Table 5-5:  Format Menu (Continued)

Menu Item Shortcut Function
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Figure 5-3. Indents (examples)

Graphics Text
Examples of text requiring graphics text (GT Blocks) include the following:

• stacked fractions
• nuclear symbols requiring simultaneous superscripts and subscripts
• geometric notation
• arcs
• rays
• drawing notation spanning more than one text line 
• radicals
• multi-line parenthesis and brackets
• radicals
• stacked division
• sigmas

Because the vertical alignment of characters is important when creating special notation, 
a monospaced Courier font becomes the default font. Test Items, using the Graphics 
Text feature, are always printed in the Courier font.

Using Graphics Text
The following rules govern Graphics Text:

• Each line of a GT block must be terminated with a <return>.
• A Question Part may contain more than one GT Block.
• Two adjacent GT Blocks automatically merge into a single GT Block.

First-line IndentHanging Indent
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Figure 5-4. GT Block Compression (with Sigma)

Figure 5-5. GT Block Spacing

Resulting text (following 
Graphics Text Compres-
sion)

What you type into the 
Question Editor Box

To emulate nor-
mal spacing in the 
final product, a 
blank line may be 
needed between 
lines in the Ques-
tion Editor Box.
User’s Manual



EXAMgen 4.4
Creating a GT Block. To put text into a GT block, select the lines of text and choose 
Format>Graphics Text. The Graphics Text menu command may be toggled On and Off.

In the Question Editor Box, a rectangle denoting Graphics Text is drawn around the con-
verted lines of text. Graphics Text Blocks always encompass entire paragraphs (until a 
block of text is terminated by a <return>). If any part of a paragraph is highlighted, the 
entire paragraph is included in the GT Block.

The text in the Question Preview Box automatically becomes Courier and the lines 
become vertically compressed. In some cases, a blank line must be inserted between lines 
of text to emulate normal spacing. (See Figure 5-5. )

Removing a GT Block. To remove a GT Block, select the lines of text in the GT Block 
to be removed, and choose Format>Graphics Text to toggle off the GT Block attribute. 

All the paragraphs associated with the highlighted text are removed from the Graphics 
Text Block, and the GT rectangle disappears from the Question Editor Box. On occa-
sion, it may be necessary to delete blank lines and end-of-line returns to revert the text to 
normal spacing.

Font
EXAMgen offers a variety of font styles.

Size
Text may be set in a variety of sizes from 8 point to 72 point.

Tool Box
The Tool Box is located on the left-hand side of the Editor Window. It contains check 
boxes, pull-down menus, buttons, special character palettes, and a text box. These con-
trols are arranged into three groups according to their functions.
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Figure 5-6. Tool Box

Item Group
The Item Group contains the controls that manage the characteristics and properties of 
Personal Library Test Items.

Test Item Type
This menu is used to specify or change the type of the Test Item shown in the Question 
Preview Box. The following Test Item types are available:

• Short Answer Questions
• Multiple Choice Questions
• True/False Questions
• Fill-in-the-Blank Questions
• Common Blocks
• Custom Items

For example, to change a short answer question into a multiple choice question, change 
the Test Item type to multiple choice and add new Question Parts for the wrong answers.

New Part
The New Part button inserts in a new, empty Question Part behind the last Question Part 
in the Question Preview Box.

Remove Part
The Remove Part button deletes the selected Question Part and all its contents from the 
Question Preview Box.

Item Group

Character Palettes Group

Database Group

Test Item Type

New/Delete Part
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Character Palettes
The Character Palettes Group contains the controls used to introduce special characters 
into a Test Item. 

Palettes
This pull-down menu lists the palette names of special characters and symbols provided 
by the EXAMgen Font 1 and EXAMgen Font 2 fonts. To make finding and using the 
font characters easy and convenient, the special characters and symbols are organized 
into separate palettes:

• Spanish (uppercase)
• Spanish (lowercase)
• Greek (uppercase)
• Greek (lowercase)
• Logic & Sets
• Operators
• Geometry
• Brackets & Parenthesis
• Braces
• Sigmas
• Radicals and Division
• Fractions
• Chemistry & Physics
• Miscellaneous
• More Miscellaneous

Selecting a palette causes the related set of characters to be displayed in the grid below the 
Palettes pull-down menu. 
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Figure 5-7. Character Palettes
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Special Characters, Symbols, and Graphics
The EXAMgen application allows the user to insert a wide range of characters directly 
into the text, such as Greek symbols, mathematics notation, reaction arrows, large brack-
ets, and radicals. 

In the EXAMgen application, there are four unique character types: 

• special characters
• in-line symbols
• stacked symbols
• graphics

Special characters are simply font characters that fit into a single character cell, such as 
Greek symbols, degree signs, mathematical notation, etc. Special characters can be placed 
into the text by positioning the cursor at the insertion point, selecting a character palette 
from the Palettes pull-down menu of the Character Palettes Group, and clicking on the 
desired character in the Palettes grid. 

Figure 5-8. Special Characters

In-line symbols are made up of a combination of two or more adjacent characters that 
create a single symbol of any desired length. Examples of these include reaction arrows 
and geometric notation (arcs, rays). In-line symbols may be inserted into the text by posi-
tioning the cursor at the insertion point, selecting the character palette from the Palettes 
pull-down menu of the Character Palettes Group, and clicking on the desired series of 
characters in the Palettes grid. (See Figure 5-9. )
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Figure 5-9. In-line Symbols

In-line symbols can also be created by typing in a series of characters on the keyboard. 
Increasing the number of certain characters increases the in-line symbol’s horizontal 
length. (See Figure 5-10. for examples of in-line symbols created by both keyboard and 
palette.)

Table 5-6: Keyboard Commands for Common In-line Symbols

Keyboard Command Description of In-line Symbol

<=> or <===> Double-headed reaction arrow (short and long)
<-> or <---> Double-headed arrow (short and long)
<> or <>>> Small double-headed arrow (short and long)
--> or ---> Arrow pointing to the right (short and long)
<-- or <--- Arrow pointing to the left (short and long)
^^ or ^^^ Arc (requires Graphics Text Block attribute)
>> or >>> Ray or small headed arrow (ray requires Graphics 

Text Block attribute)
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Figure 5-10. In-line Symbols (Keyboard and Palette Options)

Stacked symbols are made of multiple characters and characters cells, aligned both verti-
cally and horizontally to achieve a single, large symbol. These fonts require the vertical 
compression characteristic of Graphics Text Blocks. Some examples of these are radicals, 
sigmas, large brackets, etc. (See Figure 5-11. )

Add blank lines to accommodate 
arcs, lines, rays, and fractions.

Some arrows do not need 
extra lines.
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Figure 5-11. Stacked Symbols

Graphic files may be imported directly into text as a single character cell. Use File>Insert 
Graphic in the Question Editor to add a graphic.

Note
Color graphics are converted to black and white during the import process.
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Figure 5-12. Inserting a Graphic

Database
The Database Group contains the controls related to saving, naming, and cloning a Test 
Item:

• Save—Saves the changes made to the Test Item displayed in the Editor Window to 
the Personal Library Database and overwrites the previous versions.

• Save As—Saves a copy of the currently displayed Test Item in the Editor Window 
as a new Test Item in the Personal Library Database. A copy of the Test Item is 
inserted below the original (parent) Test Item. Save As is the same as cloning or 
duplicating a Test Item.

• Database edit box—Allows you to name the currently displayed Test Item. Giving 
your Test Items descriptive names helps you to organize and find them. These 
titles print when printing a manual of a Personal Library Database. (See “Printing a 
Manual of Personal Library Test Items” on page 48.)

Use File>Insert Graphic 
in the Question Editor to 
add a graphic.
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Quick Reference
Chapter 6
ion
Main Window
See “Main Window” beginning on page 9.

Database Section Exam Sect

Exam ListTopic List

Question
Selection 

List 
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Main Window: Database Section
See “Database Section” beginning on page 11.

Main Window: Exam Section
See “Exam Section” beginning on page 13.

Total Questions

The Item (or 
Section) Settings 
(depending on 
whether a Test Item 
or Section is 
selected) dialog 
opens when you 
click this button.

Exam List

Remove a Test Item

Open the Exam Settings 
dialog.
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Settings
Exam Settings
See “Exam Settings” beginning on page 22.

Section Settings
See “Section Settings” beginning on page 26.

Item Settings
See “Item Settings” beginning on page 27.
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Personal Library Section Settings
See “Sections” beginning on page 46.

Browsers
Database Browser
See “Database Browser” beginning on page 34.
User’s Manual



EXAMgen 4.4
Exam Browser
See “Exam Browser” beginning on page 36.

Search Browser
See “Search Browser” beginning on page 36.
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Personal Library
Personal Library Manager
See “Personal Library Manager Window” beginning on page 39.

New Personal Library Dialog Box
See “Creating a New Personal Library” beginning on page 42.

New Personal Library Item Dialog Box
See “Adding Test Items to a Personal Library” beginning on page 43.
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Editor
Editor Window
See “Editor Window” beginning on page 51.

Tool Box
See “Tool Box” beginning on page 59.

Item Group

Character Palettes Group

Database Group

Test Item Type

New/Delete Part
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Graphics Text (GT Blocks)
See “Graphics Text” beginning on page 57.

Resulting text (following 
Graphics Text Compres-
sion).

What you type into the 
Question Editor Box.

To emulate nor-
mal spacing in the 
final product, a 
blank line may be 
needed between 
lines in the Ques-
tion Editor Box.
User’s Manual
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Character Palettes
See “Character Palettes” beginning on page 61.
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Symbols—Keyboard Commands
See “Special Characters, Symbols, and Graphics” beginning on page 63.

Add blank lines to accommodate 
arcs, lines, rays, and fractions.

Some arrows do not need 
extra lines.
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Indents
See “Format Menu” beginning on page 54.

First-line IndentHanging Indent
Quick Reference 79
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Notes
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Index
A
Adding a Question 17

add randomly 18
Alignment 55
Answer Key 31–32

B
Basic Skills 1
Before You Start 2
Browse

and insert 17
browse source button (exam browser only) 34
browser controls 33
personal library test items 47

Browser
(illustrations) 72–73
controls 33
database 35
exam 36
search 37

C
Chapter Selection Menu 12

database browser 34
Character Palettes 61, 62
Common Block 19

copying and duplicating 45
creating common blocks and linking questions 44
links and 44
move 21, 45
remove 21

Controls 10
Copying

test items 44
Correct Answer

designating a (multiple choice questions) 53
Custom Item 19

creating 45
moving 21
removing 21

D
Database 67

browser 34, 35
accessing 35
insert to exam button 34

general 7, 8

menu 15
section 11
test items 8

Database Browser
database selection menu 12, 34

Delete
common blocks and linked questions 45
section 47
test item 43

Duplicating
test items 44

E
Edit 15

button 13
database and search browsers 34

menu 15, 53
personal library list 43
test items in a personal library 43

Editor 51, 52
menu bar 53

Exam
clear 22
controlling structure 20
elements 19
inserting selected questions into 18
list 13
making an 4
organizing 18
previewing a formatted exam 29
recalling 28
section 13
selecting and adding questions 16
settings 22–25

button 14
view 18

Exam Browser 36
Exam Generator

installing the 3
Exam Menu 16
EXAMgen

launching 4, 9
F
File Menu 14
Find Dialog Box 37
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Font
size 59
style 59

Format Menu 54, 55
Formatting

exams for printing 22
manual 48

G
Graphics 63

color conversion 66
importing 66
inserting 67

Graphics Text 57
compression (illustration) 58
creating 59
removing 59
spacing (illustration) 58

GT Block. See Graphics Text
Guarantee 2
H
Hardware Requirements 2
I
Indents

(illustration) 57
dialog box 56

In-line Symbols 64
keyboard and palette options 65

Insert 17
a section 20
graphic 67
print command 48
questions in an exam 18

Insert Button 12
Insert Questions Dialog Box 18
Insert to Exam (Database and Search Browsers) 34
Installation 3
Item Edit Box 33
Item Group 60
Item Menu  54
Item Settings 27

button 14
dialog box 27

J
Justification 55

K
Key 31

answer 32
options 32
print origins 32

Keyboard Commands
common in-line symbols 64

L
Link

common block and 44
test items to a section 46

M
Main Window 4, 9, 11

database section 12
exam section 13

Mainline 55
Menu Bar 14
Move

common block 21, 45
custom item 21
question 20
section 21, 47
test item 43

Multiple Choice Questions
correct answer 53

N
New Part 60
New Personal Library Dialog Box 42
New Personal Library Item Dialog Box 43
Next Question (>>) 33

O
Organizing an Exam 18

P
P.L. See Personal Library
Page Set-up 28
Palettes 61
Pasting

test items 44
Personal Library

accessing section settings 48
adding test items 43
browsing test items 47
changing a section description 46
copying test items into a 42
creating 42
databases 8
edit personal library list 43
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managing personal libraries 42
menu 15
Personal Library Manager 39, 40
section settings dialog box 46
serial numbers 41

Preview
exam 28–29

Previous Question 33
Print

exam 28
resetting the version number 31

Print Command
inserting 48

Print Dialog Box 30
Print Preview 29, 30
Printing 49

exam 30
full-page width (single column) 54
manual of personal library test items 48

Q
Question 19

edit box 33
editor 53
move 20
parts 51

selecting 52
preview 52
remove 21
selecting 12
selecting and adding to an exam 16
viewing 20

R
Recalling an Exam 28
Registering EXAMgen Software 2
Remove

common block 21
contents from an exam 22
custom item 21
graphics text block 59
part 60
question 21
section and its contents 22
section marker 21
test items from an exam 21

Remove Button 14
exam browser only 34

Re-sequencing test items 20
Resetting the Print Version 31

S
Save

exam 28
recall an exam and 28

Search
add and 17

Search Browser 36, 37
accessing 37
insert to exam 34

Section 19, 46
creating 46
delete 47
inserting 20
links 47
marker

removing 21
move 21, 47
removing 22
settings 26

button 14
dialog box 26

Serial Numbers
personal library 41

Setting up Pages 28
Shortcut

creating a desktop shortcut 3
Site-License 3
Special Characters 63
Starting EXAMgen 4, 9
Structure

controlling 20
Style Menu 54
Symbols 63

stacked 66

T
Test

creating a 4
Test Item

components (question parts) 51
delete 43
link to a section 46
move 43
removing 21
re-sequencing 20
type 9, 60

Test Number
resetting 31

Tool Box 59, 60
Topic List 12
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Topic Selection Menu (Database Browser) 34

V
View

questions 20
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