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CHAPTER 1

GUIDE AUTHOR BASICS
GUIDE Author is a powerful authoring system you can use to
generate custom electronic publications or prototype electronic
documents for volume production. GUIDE Author provides:

♦ Robust hypermedia authoring tools that enable you to create
and refine electronic publishing applications in a ‘what you
see is what you get’ (WYSIWYG) environment

♦ Full user interface customization

♦ The LOGiiX macro system that enables you to add intelligence
to GUIDE electronic publications

About GUIDE Author

GUIDE Author is a great way to get started with intelligent electronic
publishing. Whether you want to create a custom publication or a
prototype document before you begin volume production, GUIDE
Author gives you the power to build the best.

For example, you have complete control over the look and feel of
your publications. You can specify which onscreen controls to in-
clude, what they look like, and where they appear. You can break
long documents into smaller, more manageable frames. You can
even suppress normal Microsoft® WindowsTM (Windows) controls
like minimize buttons and sizing handles.
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And, when you’re ready to move beyond basic hypertext links,
GUIDE Author can take you where you want to go. You can create
‘Hotspots’ on images—even multiple Hotspots on the same graphic
—to activate links and other commands to add graphical navigation
to electronic publications. You also get full integration of multimedia
objects like sound, video, and animation, as well as dynamic links
to other applications.

LOGiiX Adds Intelligence to Publications

Electronic publications produced with GUIDE Author can do much
more than display information; they can respond to the individual
needs of users. LOGiiX, GUIDE’s robust macro language, enables
you to create truly intelligent publications that can automatically
adjust to readers’ actions.

LOGiiX intelligence gives you the power to transfer knowledge more
effectively. By producing ‘smart’ publications, you can help those
who use your information to get the job done right the first time.
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About This Manual

This chapter describes GUIDE Author fundamentals. The rest of the
manual describes GUIDE Author concepts and functionality in detail:

♦ Chapter 2 shows you how to define program and document
windows

♦ Chapter 3 explains how to work with text

♦ Chapter 4 explains how to work with graphics

♦ Chapter 5 covers creating interactive Objects and links

♦ Chapter 6 details GUIDE Author’s search capabilities to find
text, Objects, and links

♦ Chapter 7 explains how to edit interactive Objects

♦ Chapter 8 describes GUIDE Author’s Glossary

♦ Chapter 9 covers printing

♦ Chapter 10 discusses advanced topics such as launching other
applications, using interpreters to open and close documents
automatically, and how to incorporate multimedia elements
such as sound, animation, and video into GUIDE documents

♦ Chapter 11 covers troubleshooting
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Using GUIDE Author

To start GUIDE Author, double-click on the GUIDE Author program
icon in the program group or choose the application from the Start
menu. GUIDE Author’s menus are listed across a bar just below the
application window title bar. To pull down a menu, simply click on
the menu’s name in the menu bar. You can move the mouse pointer
over a menu command and click or use keyboard shortcuts to acti-
vate commands.  For more information about keyboard shortcuts,
please see “Using Keyboard Shortcuts” in the Welcome to... manual.

The GUIDE Author Command Reference (part of GUIDE Author’s
online help system) offers alphabetical listings of all GUIDE Author
menu commands and options with complete descriptions of their
functionality.  Menu options followed by ellipses (...) indicate that
dialogs are available to offer additional options when you choose
those commands.

Figure 1-1
The GUIDE Author application window

Tool Bar

Formatting Ribbon
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Using GUIDE Author’s Tool Bar

A tool bar across the top of GUIDE Author’s application window
provides fast access to frequently used authoring commands. Rather
than use menu commands or keyboard shortcuts, you can click on
tool bar icons to perform file operations and editing functions, change
document status settings, link GUIDE Objects, and navigate through
GUIDE document Frames.

GUIDE Author automatically displays the tool bar at the top of the
application window. You can turn the tool bar off by choosing the
Tool Bar command from the Tools menu. Alternatively, you can
choose Program Options from the Tools menu, clear the Tool Bar
option in the Program Options dialog, and then click OK to return
to the GUIDE Author application window. In either case, you can
reverse these moves to display the tool bar again.

The tool bar displays all its available icons when the application
window is maximized on a video graphics array (VGA) monitor
configured to display 640x480 pixels.  If the tool bar can’t be dis-
played completely, GUIDE Author clips it from the right end.  All
the tool bar icons except Open are disabled if no GUIDE documents
are open.

From left to right, the icons and their corresponding functions are:

ICON FUNCTION DESCRIPTION

Open Click on this icon to open a GUIDE document.

Save Saves the active GUIDE document.  If the
active document is new and untitled, the Save
Document dialog displays.

Cut Removes any selected text or graphics from the
document and places it in the Clipboard.

Copy Copies selected text or graphics from the
document into the clipboard.
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Paste Copies the Clipboard’s contents into
the document at the insertion point.

Freeze Turns off linking activity so you can
select and edit the label text of Objects.
When the document is frozen, the icon
appears to be recessed (pushed in). You
can click on the icon again to turn the
Freeze function off.

Show Symbols Displays symbols to indicate Object
boundaries.  When symbols are dis-
played, the icon looks like it’s pushed
in.  You can click on the icon again to
hide the symbols.

Show Ruler Displays the ruler to show margin and
tab settings for selected text.  When the
ruler is onscreen, the icon appears to
be recessed.  To hide the ruler, click on
the Show Ruler icon.

Insert Hotspot Inserts a blank graphic element you
can make into a Button or other type
of Object in a selected diagram Frame.
Hotspots are transparent by default.

Expansion Button Creates an Expansion Button using the
current selection for the Button’s label.
If nothing is selected, an Expansion
Button with no label is created.

Expansion Creates an Expansion from any text
selected in the active document.

ICON FUNCTION DESCRIPTION
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Note Button Creates a Note Button using the current
selection for the Button label. If nothing
is selected, GUIDE Author creates a
Note Button with no label.

Reference Button Creates a Reference Button using the
current selection for the Button label.
If nothing is selected, a Reference Button
with no label is created.

Command Button Creates a Command Button from the
current selection.  If nothing is selected,
GUIDE Author creates a Command
Button with no label.

Reference Point Creates a Reference Point and uses the
current selection for the Object label.
If nothing is selected, GUIDE Author
creates a Reference Point with no label.

Start a Link Begins a link from the selected Object.

Connect Link Completes a link to the selected
GUIDE Object.

Attributes Opens GUIDE Author’s Object
Attributes dialog. Select an Object or
position your insertion cursor between
the symbols of an Object before you
click on this icon.

Previous Frame Displays the previous Frame.

Next Frame Displays the next Frame in sequence.

ICON FUNCTION DESCRIPTION
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Using the Formatting Ribbon

GUIDE Author’s formatting Ribbon, located at the top of your screen
below the tool bar, allows you to easily perform text formatting
functions such as choosing fonts, font size, text style, text alignment,
and a relative or absolute ruler.  For more information about GUIDE
Author’s ruler, please see “Working with Text.”

GUIDE Author automatically displays the Ribbon at the top of the
application window below the tool bar. To turn it off, choose the
Ribbon command from the Tools menu. Alternatively, you can choose
Program Options from the Tools menu to open the Program Options
dialog and clear the Ribbon option. Ribbon options are the same
as those defined in the Text Style and Ruler dialogs, which are
explained in “Working with Text.”

The Ribbon allows you to easily select text and ruler formatting by
choosing any of these combinations:

FONT LIST

The wide box on the left side of the Ribbon shows the font applied
to the currently selected text. Click anywhere on the box to pull
down a list of the other available fonts.  To change the font for
selected text, simply click on the name of the font you want to use.

FONT SIZE

The point size of the currently selected text displays in this box.
Click on the arrow next to the box to pull down a list of point sizes
and select the size you want to use or type a new size over the
number shown in the text box.
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TEXT STYLES

These icons are provided on the Ribbon to allow you to choose
bold, italic, or underlined text.

TEXT ALIGNMENT

The lined icons provided on the Ribbon allow you to align text to
the left, center, or right.

RELATIVE RULER

Expresses ruler units as a percentage of the document window’s
width so tabs and margin settings vary in proportion to the window’s
size. When you resize the document window, text wraps to fit the
new window width.

ABSOLUTE RULER

Displays ruler units in fixed units (inches or millimeters) so that tabs
and margins have absolute (fixed) values. When you resize a docu-
ment window, these values do not change and text does not wrap
to accommodate the new window width.

FRAME NAME

Displays the name of the current Frame in the active document. If
the Frame has a name, this text appears on the far right of the Ribbon.
If the active Frame has no name or no documents are open, this
space is blank.
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Getting Help

When you need help or more information about GUIDE Author,
press the F1 key or select Author Help from the Help menu. GUIDE
Author’s online help system contains complete command references
for GUIDE Author and LOGiiX, GUIDE Author’s built-in scripting
language.

Opening Documents

To open a new GUIDE document, pull down the File menu and click
on New.  To open an existing GUIDE document, choose Open from
the File menu or click on the Open icon on the tool bar. When the
Open Document dialog opens, you can do one of the following:

♦ Select the directory that contains the file you want to open from
the Look In list, double-click on the folder containing the file,
select the file, and click Open.

♦ Type the entire path name for the file you want to open, including
the drive letter and directory, in the File Name box and choose
Open. If the file is in the active directory, you can simply type
in the file name (make sure you include the file extension).

The Open Document dialog displays file names with .gui extensions
by default (.gui is the default extension for GUIDE documents). To
see other types of files, replace *.gui in the File Name edit box with
*.* to view all available files in the directory or with *. followed by
the file extension for a particular type of file, for example, *.txt.

To ensure you don’t accidentally change a document, check the
Open As Read-Only box when you open it. For more information
about opening documents, please see Open in the GUIDE Author
Command Reference.
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Saving Documents

To save a document, you can choose Save from the File menu or
click on the tool bar’s Save icon to save active GUIDE documents
that have been named and saved previously. To save new documents
for the first time or to save an existing GUIDE document under a
new name, choose Save As from the File menu.

Save As also allows you to save the active document as a GUIDE
document or as an ASCII text file. Both Save and Save As record all
the changes made to a GUIDE document on disk: content additions
or edits, document options, window settings, formatting, color settings,
new Objects, etc.

If you’ve saved a document previously, GUIDE Author performs
Save in the background without prompting you for a name or other
information.  However, if you select Save As, the Save Document
dialog opens. This dialog allows you to name or rename documents,
specify a path for the drive and directory where you want to store
this version of the document, choose a different file format, and
designate the file as read-only.

GUIDE Author supports long file names. So GUIDE document file
names can be more than eight characters, and the optional exten-
sion can be more than three characters. The default extension for
GUIDE document files is .gui, but you may want to use a different
extension for some GUIDE files to make them easier to identify. For
example, if you save your control panel documents as .cp and publi-
cation body documents as .gui, you can tell which files are which
from a glance at your publication directory. When you create a full
text index for a GUIDE publication, you can index files by extension
and exclude control panel documents from the full text index to
save time.
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GUIDE (*.gui) Format

When you save a file as a GUIDE document, the file name appears
in the document window’s title bar after the file is saved unless you
assign a caption to the document. Document captions can be as-
signed through the Document Properties dialog, which is accessed
from the Properties option in the Document menu.

Text Only (*.txt) Format

The Text Only (*.txt) option under Save As Type in the Save
Document dialog saves files as ASCII text with no GUIDE document
structure or text formatting.  This means that special fonts, point sizes,
and type style settings are discarded. If you select Text Only (*.txt)
for the file format, the Save As Text dialog appears after you click on
Save in the Save Document dialog. The Save As Text dialog offers
these options:

OPTION DESCRIPTION

Carriage Return at Specifies whether to save carriage returns at
the end of each paragraph or line, and the
number of characters per line.

Tabs Specifies whether or not tabs should be saved
as spaces; the tab pitch determines how many
spaces are in each tab.

Save All Saves all Expansions; if this option is not
checked, GUIDE Author saves only the
Expansions currently displayed.

OK Saves the text file as specified and returns
you to GUIDE Author’s application window.

Cancel Discards the entire Save As procedure and
returns you to the active document window.



GUIDE Author User’s Manual 19

GUIDE Author Basics

GUIDE Author User’s M
anual

Note that GUIDE Author automatically appends the file extension
.gui to all file names in the Save Document dialog. If you want to
save a document as ASCII text, you need to change the file extension
in the file name text box and choose that format from the Save As
Type list.

Closing a Document

To close a document, choose Close from the File menu or press
Ctrl+F4. Either command closes the active document window in the
same way as clicking on the window’s Close box.

If you try to close an untitled document or one with unsaved changes,
GUIDE Author asks, “Do you want to save changes?” Click No to
close the document without saving the changes; choose Yes to save
the document with the changes. If the document has not been named,
the Save Document dialog appears. Choose Cancel to abandon the
close procedure and return to the active document window.

For more information on closing documents, please see Close in the
GUIDE Author Command Reference.

Exiting GUIDE Author

To exit GUIDE Author, click on the Close box in the application
window or choose Exit from the File menu. If you’ve made any
changes to open documents without saving them, GUIDE Author
asks, “Do you want to save changes?”  If you answer Yes, GUIDE
Author opens the Save Document dialog so you can name the
document, if necessary, and select a directory in which to store
the GUIDE file. Choose No to discard any changes you’ve made.
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CHAPTER 2

DEFINING WINDOWS
This chapter describes how to customize the GUIDE Author appli-
cation window and GUIDE document windows. You’ll also learn
how to navigate through the document and create Frames to divide
the document into readable chunks of information.

Configuring the Application Window

To change GUIDE Author’s application window, pull down the Tools
menu and click on Program Options. Alternatively, you can open the
Program Options dialog at any time by pressing Ctrl+Y.

Figure 2-1 shows the Program Options dialog. To select options, click
the check boxes beside the option names; if the box contains a check
mark ( ), it’s active. A dimmed check box means the option is not
available.
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NOTE:

If the Title Bar,
Thick Border,
and Thin Border
options are all
unchecked, the
window displays
with no border.

Application window choices you can make in GUIDE Author’s
Program Options dialog include:

OPTION DESCRIPTION

Title Bar If you don’t check this option, GUIDE Author’s
application window has no menu bar, title bar,
system menu, zoom box, or close box, and you
cannot move the window around on the screen.

Thick Border To give a window a thick border, check Thick
Border. Checking this box also allows you to
resize the application window.

Thin Border To specify a thin border for the GUIDE Author
window application, check Thin Border. If you
choose this option, the application window
can’t be resized.

Figure 2-1
GUIDE Author’s Program Options dialog 
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Tool Bar Check this option to display GUIDE Author’s
tool bar near the top of the application window.
The tool bar features icons that give you fast,
easy access to many of GUIDE Author’s func-
tions.  For more information about the tool bar,
please see Chapter 1, “GUIDE Author Basics.”

Ribbon Turn this option on to display GUIDE Author’s
formatting Ribbon.  The Ribbon icons give you
fast, easy access to text formatting functions.  For
more information about the formatting Ribbon,
please see Chapter 1, “GUIDE Author Basics.”

Menu Bar Check this box to display the menu bar and
provide access to menus.

Control Menu Check this box to display the Close box in the
application title bar and provide access to con-
trol menu commands.

Minimize Box Check this option to display the Minimize box
in the right of the title bar. Readers can click on
this box to reduce GUIDE Author’s application
window to an icon on the Windows desktop or
a button on the taskbar.

Maximize Box Check this option to display the Maximize box
in the right of the title bar. When GUIDE
Author is maximized, it fills the screen.

Status Bar Check this option to display the Status Bar at
the bottom of application window. The Status
Bar provides additional information as you pass
the cursor over each menu item.

To configure the application window, check or clear options in the
Program Options dialog, then click Save Settings. This saves your
preferences for GUIDE Author’s application window in the configu-
ration file, gauthor.cnf, and applies those settings whenever you open
GUIDE Author.

OPTION DESCRIPTION
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Configuring Document Windows

To configure the windows that display GUIDE documents, pull down
the Document menu and click Properties. The Document Properties
dialog opens (Figure 2-2).  You can choose from these options in the
Document Properties dialog:

OPTION DESCRIPTION

Maximize Check this box to maximize the document
window within the GUIDE Author application
window.

Title Bar Check this option to display a title bar over
the document window.

Thick Border Check this option to give the document
window a thick border.

Thin Border Check this option to give the document a thin
border.  A window with a thin border can’t be
resized with the mouse; however, you can use
the Size command on the document window’s
control menu or the Ctrl+F8 keyboard short-
cut to resize the window.

Scroll Bar Check this box to display the scroll bar for the
document window.

Close Box Deactivates the Close box in the title bar so
that the documentation window cannot be
closed by the user.

Maximize Box Removes both the Maximize and Minimize
icons from the title bar so that the document
window cannot be resized.

File Displays the file’s path and name; you can’t
change this parameter.
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Figure 2-2
The Document Properties dialog

Caption An optional caption that appears in place
of the document’s file name in the document
window title bar; type in the caption you’d
like (up to 128 characters) in the text box.

Show Caption Check this option to display in the docu-
ment window title bar the text entered in
the Caption text box.

Show Frame Name Check this option to display in the docu-
ment window title bar the Frame name.

Stay Back Keeps a document’s Buttons active, but
forces the document itself to stay in the
background;  most useful for control panel
documents.

Save Window Position Check this box to save the size and position
of the document window.

OPTION DESCRIPTION
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Share Definitions Check this option to allow Command Buttons
and Note Buttons in other documents to use
Definitions from the active document.

Full Path References Saves the full path name for the link; GUIDE
applications search the path rather than just
look in the current directory when the link is
activated. This makes the location fixed; if you
move a linked document, you must change
the path references accordingly.

Left/Right Margin Sets the left and right margin for text, in pixels.

Top Margin Sets the space between the top of the Frame
and the first line of text, in pixels.

Tabs Enter the size of tabs in inches or millimeters
to determine the default tab spacing. The unit
of measurement, which can be inches or milli-
meters, is set in the Program Options dialog.

Make Default Check this box to make the active document
options the defaults for all new documents.
If this box is not checked, your changes apply
only to the active document.

To use the options in the Document Properties dialog, pull down
GUIDE Author’s Document menu and click Properties to open the
Document Properties dialog, and then check or uncheck options for
the configuration you want for the active document window. When
you’re done, click OK to save the changes or on Cancel to discard the
changes. To apply the same attributes to all new windows for new
GUIDE documents you create in GUIDE Author, click Make Default
before you click OK. This saves your settings to GUIDE Author’s
configuration file so that all new document windows are created
according to the options you’ve specified.

OPTION DESCRIPTION
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Arranging Document Windows on the Screen

You can use the commands on GUIDE Author’s Window menu to
manage open document windows within the application window.
For example, the screen may look cluttered if several document win-
dows are open. You can pull down the Window menu and choose the
Cascade command to arrange the windows neatly on the screen in
a cascading formation.

When more than one document is open on the screen, it may be
difficult to see the title bars for all the documents. You can pull down
the Window menu to view a list of open documents; the list shows
captions for those open documents that have been assigned captions,
and path names for those open documents without captions. A check
mark indicates the document that’s currently active; to make another
open document the active document, click on its caption or path
name in the list.

To close a document window, you can click on the Close box in the
upper right corner of that window.  If you have several document
windows on the screen and want to close them all at the same time,
you can simply pull down the Window menu and click on Close All.
If you have made changes in any documents, GUIDE Author prompts
you to save each document before it closes that document window.

Setting Document Background Color

The Document Color command on GUIDE Author’s Document
menu allows you to set the background color for the active GUIDE
document or save the same background color as your preference for
every document. When the Document Color dialog appears, it dis-
plays a list of available colors in sample boxes. To set the background
color for the active document, select the color you want from the list,
then click on OK. To make that background color the default for every
new document window that you open, click on Make Default before
you click on OK.
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Displaying the Ruler

GUIDE Author uses a ruler to format text (see Figure 2-3). You can set
margins and tabs as well as align text to the left, center, or right of
the ruler. For more information about the ruler, please see “Working
with Text” later in this manual.

To display the ruler, click on the ruler icon in the tool bar or pull down
the Document menu and choose Show Ruler. The ruler displays at
the top of the active document window.

Figure 2-3
The ruler displayed over a GUIDE document window

Ruler
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Document Window Display Options

To change the display text size for more comfortable reading, you
can pull down the Document menu and choose the Text Larger or
Text Smaller option. Each time you choose either of the options, the
display size for text increases or decreases to the next point size
shown on the GUIDE Author’s point size list as shown on the format-
ting Ribbon or in the Text Style dialog.

Whenever you create a GUIDE Object, GUIDE Author places special
symbols around the Object. If the symbols aren’t visible, you may
accidentally type within the area you’ve defined as an Object. To
display Object symbols, pull down the Document menu and then
choose Set Display to open that dialog. Click on Show Symbols if
the option is not checked. The Set Display dialog also includes the
option Show Paragraphs; paragraph symbols display in the active
document if this option is checked.

If your documents include many graphics, you can use GUIDE
Author’s default graphic (a plain gray box labeled with information
about the graphic it represents), which appears in place of detailed
images to conserve memory. This also allows you to work more rap-
idly when you edit documents in GUIDE Author because you don’t
have to wait for graphics to draw. To display the default graphic, pull
down the Document menu and choose Set Display, and then turn
off Show Graphics in the Set Display dialog if the option is checked.
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Using Frames

Frames provide a way to structure GUIDE documents by dividing
them into ‘pages’, or easily manageable chunks of related informa-
tion. Instead of scrolling through entire documents, readers can use
the commands on the Navigate menu or the Frame navigation icons
on the tool bar to move quickly from Frame to Frame. You can also
use these keyboard shortcuts to navigate Frames:

♦ To move to the first Frame, press Ctrl+1.

♦ To move to the previous Frame, press Ctrl+2.

♦ To move to the next Frame, press Ctrl+3.

♦ To move to the last Frame, press Ctrl+4.

GUIDE documents can contain only a single Frame for each individual
screen or paragraph. Since Frames feature scroll bars, you can make
them as long as you like.

To create a Frame:

1 Move to the Frame positioned just before the location where
you want to insert the new Frame.

New Frames are always inserted after the active Frame.

2 Pull down the Edit menu and click on Insert Frame.

GUIDE Author inserts a blank Frame.

3 Continue creating your document, adding text or graphics in
the new Frame until you want to insert another Frame.
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To cut, copy, paste, and delete Frames, use the clipboard or the
Frame commands on the Edit menu. Cut a Frame to remove it from
the document and insert it into the Clipboard. Copying a Frame 
duplicates the Frame, leaves the original in the document, and inserts
the copy in the Clipboard. Deleting a Frame removes it from the
document and clears it completely. You can use Paste from the Edit
menu to insert a copy of a Frame that’s already in the Clipboard into
a document.

You can create Frame names to help you locate a Frame you want to
edit, so that you don’t have to move sequentially through each Frame
looking for certain information. To name a Frame, pull down the
Navigate menu, choose Frames, and type a name into the text box
in the Frames dialog.

You can display the name of the active Frame in GUIDE Author’s
formatting Ribbon. To display a Frame name, open the Document
menu, choose Properties, and check the Show Frame Name option
in the Document Properties dialog.
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CHAPTER 3

WORKING WITH TEXT
This chapter describes how to work with text.  You’ll learn how to:

♦ Select text

♦ Set the ruler, margins, and tabs

♦ Set and change text style

♦ Set and change text color

♦ Copy, move, and delete text

♦ Search for strings of text

♦ Find and replace text

Selecting Text

To select text, hold the mouse button down and drag the pointer over
the text you want to select. However, if you move the pointer past an
Object’s symbol, GUIDE Author automatically selects the rest of the
sentence. This prevents you from selecting text across an Object’s
boundary.You can select text outside of an Object’s symbols or part
of the text inside symbols, but you cannot start a selection outside an
Object and end it inside an Object.
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Using the Ruler

GUIDE Author uses a ruler to format text. The ruler enables you to
set margins and tabs and to align text to the left margin, the center
of the window, or the right margin. To display the ruler, either click the
Ruler icon in the tool bar or pull down the Document menu and
choose Show Ruler. The ruler appears at the top of the application
window between the formatting Ribbon and the document text (see
Figures 3-1 and 3-2). You can use the mouse pointer or the Ruler
dialog to change margin and tab settings.  The rel (relative) and abs
(absolute) icons on the formatting Ribbon allow you to choose the
ruler’s current measuring mode and switch between modes.

Figure 3-1
Absolute ruler using millimeters to measure a GUIDE document
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Using an Absolute Ruler

When you use an absolute ruler, GUIDE Author measures docu-
ment windows in inches or millimeters (whichever is checked in the
Program Options dialog), and the ruler reflects those absolute incre-
ments. When you resize document windows that use an absolute
ruler, the text does not wrap to adjust to the size of the window. To
select the absolute ruler mode, click on the abs icon in the Ribbon.
The ruler features unit markings, labeled at regular intervals, as well
as markers to indicate the left margin, first line indent, default tabs,
set tabs, and the right margin. The left margin, first line indent, default
tabs, and right margin markers look like small triangles.  Tabs that you
set are indicated by arrows that point up to the ruler where you have
set a tab stop.

Figure 3-2
Absolute ruler using inches to measure a GUIDE document
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Using a Relative Ruler

When you use a relative ruler, GUIDE Author measures the screen
proportionally; for example, tabs are expressed as a percentage of the
window’s width. You can always see all of the window’s contents,
no matter how wide or narrow the window, and no horizontal scroll
bar is necessary. GUIDE Author wraps text to adjust to the size of the
window and resizes graphics. To choose the relative mode, click the
rel icon in the Ribbon.

There are three measurements labeled on the relative ruler (0%, 50%,
and 100%) along with a triangular left indent marker, a triangular
right indent marker, and an arrow that points up to indicate the indent
level for the first line in a paragraph. These marks control the left
margin, the right margin, and where the first line starts.

Figure 3-3
A relative ruler with tab and margin settings shown in Figure 3-2
measured as a percent of the total ruler
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Using the Mouse Pointer to Set Margins

You can use the mouse pointer to change margins, which are the
offset between the edge of the document window and the content
area. You must select any paragraphs that you want to apply new
margins, tabs, etc., to.

To set the right margin:

1 Select the paragraphs you want to change. If you are creating
a new document, start with Step 2.

2 Position your pointer over the right margin marker (the trian-
gular marker that points left on the far right of the ruler), and
then press and hold the mouse button.

3 Drag the marker to reposition the right margin.

4 Release the mouse button.

To set the left margin:

1 Select the paragraphs you want to change. If you’re creating
a new document, start with Step 2.

2 Press and hold the mouse button over the left margin marker (the
bottom triangle that points right at the far left of the ruler; the
triangle on the top is the marker for the first line indent).

3 Drag the marker to where you want the left margin to end and
text to begin.

The first line marker (the top triangle) moves along with the
bottom marker. To indent the first line of the selected para-
graphs from the left margin, click on the top marker and drag
it to the position you want. The top triangle moves indepen-
dently from the left marker margin on the bottom.

4 Release the mouse button.
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Using the Mouse Pointer to Set Tabs

You can add, delete, and modify a ruler’s tab settings with the mouse
pointer. To add a tab, simply click anywhere on the ruler where you
want a tab to appear. To delete a tab, point at the tab marker and
drag it off the side or below the ruler. When the mouse pointer moves
beyond the edge of the ruler, the tab disappears. To reposition a tab,
drag it to its new location.

Using the Set Ruler Dialog

You can also use the Ruler command on GUIDE Author’s Format
menu to open the Ruler Settings dialog, where you can change
margins, indents, tabs, and text alignment.  When you make entries
in this dialog and click OK, the ruler reflects your changes.

GUIDE Author applies the exact changes made in the dialog to all
selected paragraphs, regardless of any individual rulers set for each
paragraph.  You can click on the applicable Alignment option in
this dialog to align the selected text or any text you type after the
insertion cursor to the left, center, or right. When you make changes
to more than one paragraph, the current settings for the paragraph at
the beginning of the selection display in both the ruler and the Ruler
Settings dialog.
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Choosing a Text Style

GUIDE Author’s default text style is 10-point Arial (a TrueTypeTM font)
in a plain typeface. To set the text style, you can use GUIDE Author’s
formatting Ribbon or use the Text Style dialog. To reformat a portion
of a document, select the text you want to reformat before you set text
style attributes.

To set a document’s text style in the Text Style dialog:

1 Position the text cursor where you want the text style to begin.

2 Pull down the Format menu and choose Text Style.

3 To choose a font, click on a font name in the Font list.

4 To choose the point size you want, click on that size in the
Size list just to the right of the Font list.

5 Choose the style you want by checking or unchecking the
Plain, Bold, Italic, Underline, Strikeout, Superscript, Boxed, and
Subscript boxes (you can choose more than one).

NOTE:

‘Plain’ is used in
GUIDE electronic
publishing tools
to refer to text
that has no special
type style such
as bold, italic,
or underlining
applied to it. Some
applications refer
to plain text as
‘normal’ or ‘regu-
lar’ text.

6 If you want to make these settings the default text style, click
on Make Default.

Any new documents you create will use the default type style
you’ve just specified.

7 Click on OK to save the new text style or click on Cancel to
retain the settings shown when you first opened the dialog.
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Figure 3-4
The Text Style dialog, showing Arial 14-point bold selected

Changing Text Color

You can change the color of text on an Object-by-Object basis.
Since top-level text is an Object, if you select any text in the top level
and change its color, all the top-level text changes color, not just the
selected text. To highlight specific words or phrases in color, you
must first make them into an Object, for example, a Group. To
change the color of text:

1 Positions the insertion cursor in the Object whose text color
you want to change.

2 Pull down the Format menu and click on Text Color.

The Text Color dialog appears with a sample that shows its
current color.

3 Click on the Text box or arrow next to the box to drop down
a list of available colors and choose one.

The color box displays your selection.
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4 Click on OK to apply the color to the text.

The text color reverts to the default at the beginning of
the next Object.

If you want to make your color settings apply to all new documents,
click on Make Default.  If Make Default is not checked, GUIDE
applies your changes only to the active document.

Palette Handling

GUIDE Author can handle a single 256-color palette on a 256-color
screen. This prevents palette conflicts. If the computer’s graphics
capabilities include 64,000 colors, all graphics should appear in their
true color range.

Please note, however, that GUIDE electronic publishing tools only
support solid colors. When you work with the palette, the color
shown under the color mixer on the right side of the box labeled
Color|Solid shows how the color will display in GUIDE documents,
in both GUIDE Author and GUIDE Reader. Any additional shading
shown on the left side of the Color|Solid box does not appear in
GUIDE documents.

Changing the Background Color of Text

To change the background color of text:

1 Place the text cursor inside the symbols for the Object whose
background color you want to change.

2 Pull down the Format menu and click on Text Color.

The Text Color dialog appears with a sample to show the
current color.
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3 Open the Background drop-down box and choose the color you
want.

4 Click on OK to apply the background color.

The background color reverts to its default color when the text
reaches the beginning of the next Object.

Copying Text

GUIDE Author uses the Windows Clipboard to copy text:

1 Select the text you want to copy.

2 Click on Copy in the Edit menu or on the tool bar’s Copy icon.

GUIDE Author copies the selected text to the Clipboard.

3 Move the pointer to the position where you want to insert the
copy of the text and click to place the insertion point.

4 Pull down the Edit menu again and click on Paste or use the
tool bar’s Paste icon.

GUIDE Author takes a copy of the text in the Clipboard and
inserts it at the position you marked in the document. The
copied text remains in the Clipboard until you copy or cut
another selection into the Clipboard.

Moving Text

GUIDE Author also uses the Windows Clipboard to move text:

1 Select the text you want to move.
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2 Pull down the Edit menu and click on Cut or use the Cut icon
on the tool bar.

GUIDE Author deletes the text from the document and puts
it in the Clipboard.

3 Position the text cursor where you want to insert the cut text.

4 Use the Edit menu’s Paste command or the tool bar icon.

GUIDE Author makes a copy of the text from the Clipboard
and inserts it into the GUIDE document, beginning at the
position you marked. The cut text remains in the Clipboard
until you cut or copy another selection into the Clipboard.

Deleting Text

To delete text in a document, select the text you want to remove, and
then choose Clear from the Edit menu. You can also press Delete or
the backspace key to delete selected text from a GUIDE document.

To delete text from a document but retain a copy, use the Cut com-
mand from the Edit menu or the tool bar’s Cut icon. This removes the
text from the document and places it in the Clipboard.

Searching for Text

The Find option on the Edit menu searches for characters in the
active document in a set of documents you specify or in documents
linked to the active document. This option allows you to define the
text you want to search for and where you want to search for it.
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Defining the Search

You start a search by pulling down the Edit menu and clicking on
Find. When the Find dialog opens, enter the text you want to find in
the Find What text box. Then choose from these options:

OPTION DESCRIPTION

Options Sets the scope and characteristics of the search.

Select Files Identifies files to search and where to look for them.

Find Next Starts the search at the insertion point in the active
document to find the next occurrence of the Find
statement. Choose Find Next repeatedly to find each
occurrence of the text string. If you choose this option
after the previous search has reached the end of the
document, GUIDE Author asks if you want to con-
tinue the search from the beginning of the document.
Choose Yes to continue the search or No to end it.

Figure 3-5
The Find dialog
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Setting Search Scope and Characteristics

If you choose Options in the Find dialog, the Find Options dialog
opens to offer the following choices:

OPTION DESCRIPTION

Match Whole Searches only for whole words that match.
Words Only If you check this option, the Find statement

“text” returns “text” but not “texture.” If you
uncheck this option, the search finds both.

Case Sensitive Searches text that exactly matches the upper-
and lowercase characters typed in the Find
statement. If Case Sensitive is checked, “Case”
finds “Case” but not “case.” If Case Sensitive
is not checked, the search finds both words.

Enable Wildcard Enables you to use the wild card character, a
Characters question mark (?), in place of specific characters

in the Find statement. GUIDE Author substitutes
the wildcard for any character. For example, the
statement “tr??” would find “tree,” “trap,” and
“trim.”

Search Hidden Includes all Expansions in the search, even if
Material they are not displayed. If this option is not

checked, GUIDE Author searches only the part
of the document that is displayed (the current
state of expansion).

Search Document Searches the active document’s Definitions
and Definitions window if this option is checked.

Simple Searches for a single Find statement.

Complex Displays multiple edit boxes so you can search
(AND, OR) for up to four Find statements. A button between

each edit box allows you to specify a logical
operator to combine the results of the search.

If you combine two Find statements with a
logical AND, a document must contain both
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statements to count as a “hit.” A document that
contains just one of the Find statements won’t be
reported.

If you combine two Find statements with a
logical OR, a search reports a document that
contains either statement as a ‘hit.’

Active Only Searches only the active document.

Active and Linked Includes linked documents in the search.

Selected Allows you to select documents to include in
Documents the search.

Save Settings Check this option and choose OK to record the
changes you’ve made to the options in the con-
figuration file, making them the defaults that
apply every time you open GUIDE Author. If
you don’t check Save Settings, GUIDE Author
only saves the Find option changes for the active
document.

Figure 3-6
The Find Options dialog
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Defining Where to Search

GUIDE Author allows you to search for a string of text in the active
document, a set of documents, or documents linked to the active
document. You specify where to search, using the options in the
Search Which Documents panel of the Find Options dialog.

OPTION DESCRIPTION

Active Only Searches the active document.

Active and Linked Includes linked documents in the search. If
you select this option, Select Files is activated
in the Find dialog.

Selected Documents Enables you to specify documents you want
to include in the search. If you select this
option and click OK, the Find dialog re-
opens with the Select Files button now
active. You can click Select Files to open
that dialog. You can use the Add button to
add files to be scanned. Selected files are
listed in the Files to Scan list. To change the
directory, select a new directory from the
Look In list in the Add Files to Catalog dia-
log and choose Open. You can use the Shift
and Ctrl keys with the mouse to select
multiple files in a directory. Click Clear All
to discard all files in the Files to Scan list.
To remove individual files from the search,
select the file name and choose Remove.
When you are finished, choose OK.

If you choose a file in the Select Files dialog, and then click OK,
GUIDE Author displays these options in the Find dialog:

OPTION DESCRIPTION

Scan Scans all documents linked to the active document or
all the selected documents and lists those that contain
the Find statement and the number of occurences of
the statement in each.
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Go To Displays the first occurrence of the Find statement in
the document that you’ve selected in the Find dialog,
and then displays the Find dialog again so that you can
click Find Next to display other occurrences in the
document or choose other options.

Find Next Occurrence

If you want to find the next occurrence of a text string, click on the
Find Next button. GUIDE Author highlights the next occurrence of
the string. To find more occurrences of the string, click on the Find
Next button again. GUIDE Author repeats this action so that you
can see all occurrences of the string.

When it reaches the end of the document, GUIDE Author asks you
if you want to continue searching from the beginning of the docu-
ment. Choose Yes to start the search again from the beginning or
choose No to end the search.

Searching in Linked Documents

GUIDE Author lets you search for occurrences of a string in docu-
ments that are linked to the active document:

1 Pull down the Edit menu and click on Find.

2 Click on Options to open the Find Options dialog.

3 Select options to define the search characteristics.

4 Click on the Active and Linked button, then click on OK.
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5 Click on Scan to find the names of the documents linked to
the active document that contain the Find statement.

GUIDE Author displays the names of the documents and the
number of occurrences of the string you’re searching for. This
information appears in the list.

6 Select any document you want to search in from the list, then
click on Go To to open that document.

7 Click on Find Next to search for the next occurrence.

Replacing Text

The Replace option lets you search for and change an alphanumeric
character or string of alphanumeric characters. To search for a string
of characters in the active document:

1 Pull down the Edit menu and click on Replace.

2 Enter the new character string you want to change in the
Replace edit box and enter the character string you want to use
in the With edit box.

3 Click the Options button, define the search in the Find Options
dialog, making sure you choose Active Only under Search Which
Documents. Then click on OK.

4 Click on Find Next.

5 When an occurrence of the text is found and highlighted, use one
of the Replace options to change the string:

♦♦♦♦♦ Click Replace to change the first occurrence.

♦♦♦♦♦ Click Replace All to change all the occurrences of the
string without navigating to each occurrence.

♦♦♦♦♦ Click Replace, then Find to replace the first occurrence
of the Find What text, then find the next hit.



50 GUIDE Author User’s Manual

Working with Text

Figure 3-7
The Replace dialog; click Options to open the Find Options dialog

You can also find and change a string of characters in a set of docu-
ments that you specify:

1 Pull down the Edit menu and click Replace.

2 Enter the character string you want to change in the Replace
edit box, and then type the character string you want to substi-
tute for the Replace string in the With edit box.

3 Click Options, and then define the search in the Find Options
dialog. Make sure you include Selected Documents, then click
OK.

4 Click Select Files to open the Select Files dialog and choose the
documents you want to search.

To look at the files in a specific directory, click Add to open
the Add Files to Catalog dialog, select the directory from the
Look In list, and then click Open. GUIDE Author displays all
the files in that directory. You can also enter the file name
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directly in the File Name edit box or use the Shift and Crtl
keys with the mouse to select multiple files. In the Select Files
dialog you can remove all documents from the Scan list by
clicking Clear All. To remove a specific document from the list,
select it and click on Remove.

5 Click OK to close the Select Files dialog.

6 Click Scan.

GUIDE Author searches through all the documents you select-
ed and looks for occurrences of the Find What text. If GUIDE
Author finds any occurrences of the word in any of the docu-
ments, it lists all the names of scanned documents that contain
the Find What text and the number of occurrences of that string
in each document.

7 Select a document from the list and click Go To to open it.

8 Click Find Next to find the first hit of the Find What text.

9 When an occurrence of the text is found and highlighted, use
one of the Replace options to change the string:

♦♦♦♦♦ Click Replace to change the first occurrence.

♦♦♦♦♦ Click Replace All to change all the occurrences of the
string without navigating to each occurrence.

♦♦♦♦♦ Click Replace, then Find to replace the first occurrence
of the Find What text, then find the next hit.

Changing Text in Linked Documents

You can find and change a string of characters in documents that
are linked to the active document:

1 Pull down the Edit menu and click on Replace.

2 Enter the new character string you want to change in the
Replace edit box and enter the character string you want to use
in the With edit box.
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3 Click the Options button to define the search in the Find Options
dialog. Be sure to choose the Active and Linked Files before you
click on OK.

(Please refer to “Defining the Search” for an explanation of
each option in the Find Options dialog.)

4 Click on Scan.

GUIDE Author searches through the active document and all
documents linked to it for the Find What text. If GUIDE Author
finds any hits in any of the documents, it lists all the names of
scanned documents that contain the Find What text and the
how many occurrences it found in each document.

5 To open a document, click on its name, and then on Go To.

6 Click Find Next to find the first occurrence.

7 When an occurrence of the text is found, use one of the Replace
options to change the string:

♦♦♦♦♦ Click Replace to change the first occurrence.

♦♦♦♦♦ Click Replace All to change all the occurrences of the
string without navigating to each occurrence.

♦♦♦♦♦ Click Replace, then Find to replace the first occurrence
of the Find What text, then find the next hit.
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CHAPTER 4

WORKING WITH GRAPHICS
Graphics play an integral role in any information presentation;
GUIDE publications are no exception. This chapter covers how to
bring graphics into GUIDE documents, how GUIDE Author handles
graphics, how to resize and crop graphic images, how to display and
hide graphics, and how to lock graphics from editing.

About Graphics

To include graphics in GUIDE documents, you can import them from
other paint or drawing applications.  GUIDE Author can import and
display many different types of graphics files:

GRAPHICS FILE FORMAT EXTENSION FILTER

AutoCAD *.dxf guidedxf.dll
Bitmap *.bmp guidebmp.dll
CALS Tiff *.ras guideras.dll
CGM (Computer Graphics metafile) *.cgm guidecgm.dll
Corel Draw *.cdr guidecdr.dll
DIB *.dib guidebmp.dll
Digital Research *.gem guidegem.dll
Enhanced Metafile *.emf guidewmf.dll
EPS (Encapsulated PostScript) *.eps guideeps.dll
GIF (Graphics Interchange Format) *.gif guidegif.dll
HPGL (Hewlett-Packard) *.plt guideplt.dll
JPEG *.jpg guidejpg.dll
Lotus *.pic guidepic.dll
Micrografx *.drw guidedrw.dll
Microsoft Paint *.msp guidemsp.dll
Paintbrush *.pcc or *.pcx guidepcx.dll
Table *.tmf guidetv.dll
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TIFF (Tagged Image File Format) *.tif guidetif.dll
Windows metafile *.wmf guidewmf.dll
WordPerfect *.wpg guidewpg.dll

GUIDE Author offers two options to import stand-alone graphics
into GUIDE documents: You can use the Windows Clipboard or the
Place Graphic command on GUIDE Author’s Edit menu. Graphics
imported with source documents are converted to the .wmf (Win-
dows Metafile) format. To import stand-alone graphics, use GUIDE
Author’s Place Graphic command.

Inserting Graphics through the Clipboard

When you bring graphics into GUIDE documents through the Clip-
board, you can add any image created in a Windows application.
To paste graphics into a GUIDE document from the Clipboard:

1 Open the graphics file in the application used to create it.

2 Select the image(s) you want to import into a GUIDE document,
and then copy or cut those items to place them in the Clipboard.

Cut removes a graphic from application files and puts it into
the Windows Clipboard, overwriting the Clipboard’s previous
contents. Copy makes a copy of a selected graphic and leaves
the original in the application file; the copy goes into the Clip-
board, overwriting its previous contents.

3 Close the drawing application and start GUIDE Author.

4 Open the GUIDE document where you want to add the graphic.

5 Position the insertion cursor where you want to place the
graphic in the GUIDE document.
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6 Pull down GUIDE Author’s Edit menu and choose Paste or click
on the Paste icon on the tool bar.

GUIDE Author copies the Clipboard’s contents, creates a dia-
gram at the position you specified with the pointer, and inserts
graphics from the Clipboard into the diagram. The diagram, its
components, and uses will be discussed later in this chapter.
The contents of the Clipboard won’t change until you cut or
copy new material to overwrite them.

Placing Graphics

Whether you want to create a new GUIDE document or add new
information to an existing GUIDE document, it is easy to incorporate
new graphics at any time. If you have a working knowledge of desk-
top publishing, you already understand the basics of importing graphics
into GUIDE documents.

To import a graphic into a GUIDE document with the Place Graphic
command:

1 Open or create the GUIDE file in which you want to place a new
graphic.

2 Position the insertion cursor in the GUIDE document where you
want to place the new graphic.

3 Pull down the Edit menu and click on Place Graphic.

The Place dialog opens.
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Figure 4-1
GUIDE Author’s Place dialog

4 Select the graphics file you want to import.

5 Check or uncheck Link to file.

If you check Link to file, you can include the image in the
document without actually importing the graphic. Linking a
graphics file helps to minimize the size of GUIDE documents
(see the next section, “About Internal and External Graphics”).

6 Click on Open.

GUIDE Author creates a diagram in the document at the inser-
tion point and places the graphic inside the diagram. If you are
unable to import the graphic, you will see an error message.
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About Internal and External Graphics

If you check the Link to file option in the Place dialog when you
place a graphic, GUIDE Author creates a ‘pointer’ to the graphic file,
but doesn’t actually include the graphic as part of the GUIDE docu-
ment. Every time the document displays, the viewing application
(GUIDE Author or GUIDE Reader) retrieves the graphic file from disk
and displays it.

Graphics that are linked to but are not actually a part of GUIDE
documents are called external graphics. If you don’t check Link to
file, the graphic is copied into the GUIDE document as an internal
graphic and becomes a part of the GUIDE document file.

External graphics offer two notable advantages: You can modify
graphic files in their native applications and see those changes
reflected in GUIDE documents linked to that graphic file the next
time you open those documents. Linking graphics externally also
saves a considerable amount of disk space.

About the Default Graphic

You can use a default graphic to indicate the space and location
occupied by graphics in GUIDE documents. The default graphic
is a gray box labeled with a file name when it represents external
graphics, or the word ‘Internal’ if the image it represents is part of
the GUIDE document. The default graphic redraws much more
quickly than detailed images, so you can work faster. To use the
default graphic, choose Set Display from the Document menu and
uncheck Show Graphics in the Set Display dialog. When you are
finished editing or want to see the actual graphics again, simply open
the Set Display dialog again and recheck Show Graphics.
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The default graphic also displays when an external graphic file can’t
be found, for example, if the graphic file has been renamed or deleted.
If this is the case, follow the preceding instructions for placing a
graphic, under “Inserting Graphics through the Clipboard,” or for
replacing the renamed or deleted graphic, under “Placing Graphics.”

Figure 4-2
The default graphic appears if Show Graphics is not checked or if an
externally linked file can’t be found
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About Graphic Elements and Diagrams

Diagrams enclose all graphics in GUIDE documents. Each image
within a diagram is called a graphic element. A single diagram
can contain several graphic elements to create a composite image.
GUIDE Author creates diagrams automatically when you paste or
place graphic images into GUIDE documents unless you already
have a diagram selected when you place the file. If this is the case,
the new graphic file is inserted into the diagram you’ve selected as
an additional graphic element.

The diagram includes a viewing window to display the graphic image
and a clipping frame that enables you to crop the image. These
components surround the graphic elements placed in that diagram.
When you click on a graphic in a GUIDE document, GUIDE Author
highlights the viewing window boundaries with a thin black line, the
clipping frame with a thin gray line, and the graphic element you
clicked on with sizing handles (small black boxes) at the corners
and sides to show that the graphic is selected.

To select a graphic element for editing, simply click on it. When
sizing handles surround the graphic element you want to edit, it’s
selected. To select multiple graphic elements, hold down the Shift
key and click on additional graphic elements you want to select. To
resize a graphic element, position the pointer over one of the handles
so the cursor changes to a plus sign (+), then drag the mouse to resize
the selected graphic element.

Graphic diagrams also contain an invisible grid that can help you
reposition and resize graphics more precisely. If the Diagram Grid
option on GUIDE Author’s Format menu has a check mark beside it,
you can move or resize graphics in increments of four pixels (please
see “Sizing or Moving Graphics Incrementally,” later in this chapter).

GUIDE interprets diagrams as in-line text characters. For example,
you can use the space bar and carriage return key to move them:
Insert spaces in front of a diagram to move it to the right; remove or
add carriage returns before and after the diagram to move it up or
down. You can stretch the diagram to cover the area on the page
where you want to position a graphic, enlarge the clipping frame, and
then use the mouse to reposition a graphic anywhere inside the clip-
ping frame’s boundaries.
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When GUIDE Author imports an image, it positions it along the base
line of the text wherever the cursor is located. If you place an image
within a paragraph and the document is wider than the paragraph,
text follows the image on the same line. If the graphic is taller than
the accompanying text, the spacing between the text line that con-
tains the image and the previous line will increase. If you want the
graphic to be on its own line, simply hit the carriage return after the
graphic is imported.

Viewing Windows

Viewing windows are created automatically as part of a diagram and
show the diagram’s boundaries. You can use the viewing window to
confine a graphic to a smaller area or include oversized images in a
document. To select the viewing window, click anywhere between
the black line that indicates the viewing window boundary and the
gray line that outlines the clipping frame. When a sizing handle
(a small black square) appears at the bottom right corner of the dia-
gram/viewing window, position the pointer over it.  When the cursor
changes to a plus sign, drag to resize the diagram and viewing window.
You can also choose the Diagram Info command from the Format
menu while a diagram is selected to open the Diagram Info dialog
and edit the values in the boxes under Viewing Window to resize a
viewing window.

If a graphic element is too big to fit in the viewing window, scroll bars
appear on the viewing window that enable readers to pan and zoom
the image. The viewing window now looks like a small window
within the larger document window. The image in its uncropped state
remains unchanged. This feature enables you to include oversized
images in your documents or to magnify graphics for more detail.
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Figure 4-3
A graphic diagram in a GUIDE document; note the viewing window
that delineates the diagram boundaries, the clipping frame inside the
viewing window, and the graphic element surrounded by sizing
handles (small black squares) within the clipping frame

Figure 4-4
A graphic diagram selected so that the viewing window and clipping
frame can be resized
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Clipping Frames

A clipping frame inside the viewing window encloses all the graphic
elements pasted or placed in the diagram. The clipping frame is for
visual reference; it also provides you with a way to crop, or clip, the
graphic. You can resize, add, delete, and crop graphic elements
within the clipping frame.

When you click between the diagram/viewing window boundary and
the clipping frame to select a diagram, you also select the clipping
frame as illustrated by the sizing handles that appear at the corners
and on the sides of the thin gray line that shows the clipping frame’s
boundaries. You can drag these handles with the mouse pointer to
resize the clipping frame.

When you resize the clipping frame, any part of a graphic element
that falls outside the clipping frame’s boundary is hidden from view
as though that portion of the image has been clipped off (no scroll
bars appear to allow the graphic element to be panned or zoomed).
When you enlarge or reduce a clipping frame, it centers itself within
the viewing window after it resizes.

Figure 4-5
The clipping frame crops or hides portions of the graphic element from
view.
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About Hotspots

Hotspots are special graphic elements, usually transparent, that you
can overlay on a graphic or a part of a graphic. You can then make
the Hotspot into a GUIDE Object to provide links from that particu-
lar area of the image to related information. For example, a techni-
cal drawing of a printed circuit board might have a Hotspot over a
specific chip. When a reader clicks on the Hotspot, a link displays
information concerning the chip’s function, part number, replace-
ment procedure, etc.

To overlay a Hotspot on a graphic in a GUIDE document and make
the Hotspot into a Button:

1 Click on a graphic to select it.

2 Pull down the Format menu and click on Insert Hotspot or click
on the Insert Hotspot icon in the tool bar.

The Hotspot appears in the upper left corner of the clipping
frame as an invisible rectangle outlined by its sizing handles.

3 Click on the Hotspot, hold the mouse button down, and drag the
Hotspot to the desired position within the clipping frame.

Once the Hotspot is in place, you can drag on its sizing
handles to enlarge or reduce it.

4 Pull down the Make menu and click on the type of Button you
want the Hotspot to be (for example, Note Button).

5 Link the Button.

For information on how to link Buttons, please refer to Chapter 5,
“Creating Objects and Links.”
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Colored, Transparent, and Shaped Hotspots

GUIDE Author supports colored, transparent and shaped hotspots.

Radio buttons in the Element Info dialog (from the Format menu) let
you specify the shape of the Hotspot highlight. There are three options:
None (the shape will be a rectangle but without a border), Ellipse, or
Square (the shape will be a rectangle). With the Transparency options
in the Element Info dialog you can create a Hotspot that is opaque,
semi-opaque (both shape and background show through), or trans-
parent (no border or filled shape).

A color drop-down box in the Element Info dialog allows you to set
the color of the highlight to one of the 16 possible GUIDE colors.

SHAPE/ NONE SQUARE (RECTANGLE) ELLIPSE
TRANSPARENCY

Transparent Not visible Square outline Elliptical outline

Semi-opaque Not visible Filled square that Filled ellipse that
is see-through is see-through

Opaque White Opaque filled Opaque filled
rectangle square ellipse
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Figure 4-6
The Element Info dialog for a selected Hotspot

Elliptical Hotspot Behavior

♦ When a Hotspot has an elliptical shape, clicking outside of the
ellipse will not activate the Hotspot.

♦ When a Hotspot has an elliptical shape and it is an expansion,
note, command or reference button, the cursor will change to
the relevant icon only when it is placed within the ellipse of the
Hotspot.

♦ An elliptical Hotspot inside a table (TMF file) cannot be assigned
to an expansion or expansion button.

♦ When a Hotspot has an elliptical shape and it is an expansion,
note, command or reference button, and you click on it, the click
will highlight the ellipse.



66 GUIDE Author User’s Manual

Working with Graphics

The Format Menu for Graphics

The options on GUIDE Author’s Format menu change depending
on what you’ve selected for editing. When you select a graphic,
commands that enable you to edit graphics replace the text and ruler
options on the Format menu. The graphic Format commands are:
Push to Back, Pull to Front, Restore Size, Insert Hotspot, Element
Info, Lock Diagram, Diagram Grid, Show Elements, and Diagram
Info. To use these commands, select a graphic element or diagram
that you want to edit, then pull down the Format menu and select a
command:

COMMAND DESCRIPTION

Push to Back Moves the selected graphic element to the back
of the diagram so that it’s behind any other
graphic elements in the diagram.

Pull to Front Unlike windows, graphic elements don’t auto-
matically come to the top of the stack when you
select them.  You can select a graphic element
that’s partially obscured by other graphic elements,
then choose this command to bring the selected
graphic element to the front.

Restore Size This command ‘undoes’ any resizing done on a
selected graphic element, returning it to the di-
mensions it had when it was first imported into
the GUIDE document.

Insert Hotspot Inserts a transparent Hotspot into a selected dia-
gram; you can then turn the Hotspot into a Button
and link it to information that relates to the specific
part of the graphic the Hotspot covers, for example,
a particular chip on a drawing of a printed circuit
board.
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Element Info Displays information about a selected graphic
element: whether it’s an internal or external
graphic, its type (bitmap, metafile, or Hotspot), the
Hotspot Border, Transparency, its Object ID num-
ber, any Object name assigned, its position in its
clipping frame, and the original dimensions of the
graphic element when it was imported into the
GUIDE document.

Lock Diagram Locks and unlocks graphic diagrams. You select a
diagram you want to lock by clicking on its clip-
ping frame and choosing Lock Diagram. When a
graphic is locked, its graphic elements cannot be
moved or resized, nor can the clipping frame be
resized. A check mark beside the Lock Diagram
command on the menu indicates that a selected
diagram is locked. It is a good idea to lock dia-
grams before you edit them.

Diagram Grid Turns on an invisible grid that can help you repo-
sition and resize graphics more precisely (please
see “Sizing or Moving Graphics Incrementally”).
A check mark appears beside Diagram Grid on
the Format menu if the grid is active.

Show Elements You may hide graphic elements when you reduce
the size of a clipping frame. This command en-
ables you to recover and display hidden graphic
elements in the upper left corner of the clipping
frame. If you can’t see all the elements, use Push
to Back and Pull to Front to restack them. If any
portion of a graphic falls within the clipping frame,
this command won’t move that element. The
GUIDE Show Hotspots command will outline all
Hotspots with a black rectangle, or a black ellipse
for elliptical hotspots.
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Diagram Info Opens a dialog that shows the diagram’s Object
Name (if it has one; if it doesn’t, you can type one
into the text box), Object ID number, zoom ratio,
the offset of viewing from the left and top edges
of the clipping frame, the margin between the
diagram and surrounding text elements in pixels,
the clipping frame’s width and height in pixels,
the viewing window’s width and height in pixels,
and the coordinates for the center of the viewing
window over the clipping frame region to help
you zoom. The Diagram Info dialog also has three
options you can check: Lock Diagram prevents
graphics from being resized or edited, Disable
Zoom won’t allow readers to enlarge or reduce
their view, and Crop to Fit resizes the diagram
window to fit within the document window. If
Crop to Fit is checked (the default), graphic ele-
ments remain at their full size and are cropped to
fit the diagram; if this option is turned off, GUIDE
resizes graphic elements to fit within the diagram
rather than cropping them.

Checking Graphic Element Information

If you can’t remember whether graphic elements are internal or
external graphics or if they are bitmaps or metafiles, you can use the
Element Info command on the Format menu to find out.

The Element Info dialog shows:

♦ Whether the selected graphic element is an internal or external
graphic

♦ Whether the selected graphic element is a bitmap, metafile, or
Hotspot

♦ The selected graphic element’s Object ID number
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♦ Any Object name assigned to that graphic element; you can
change the text in the Name box to edit the graphic element’s
Object name or, if no text appears in the Name box, type in an
Object name for the graphic element

♦ The selected graphic element’s position from the sides of the
clipping frame shown in pixels

♦ The unscaled size of the graphic element

♦ The Hotspot Border information concerning shape.

♦ The Transparency information concerning the three possibilities
of Opaque, Semi-Opaque, or Transparent.

Edit the text shown in the Name field to change the graphic element’s
Object name. If no text appears next to Name, the graphic element
has not been assigned an Object name; you can type in text to name
the graphic element Object if you like.

You can use the Location option to reposition graphic elements in
the clipping frame (please see “Moving Graphic Elements,” later in
this chapter). Enter a number in the Left, Top, Width, and/or Height
text boxes. Repositioning a graphic element may tuck part of it under
the clipping frame. For example, if an unscaled graphic element is
523 pixels high and you enter a height of 600, the lower part of the
graphic element disappears under the bottom of the clipping frame.

The Name text box in the Element Info dialog enables you to assign
or change an Object name for the graphic or Hotspot. An Object
name is a character string used to identify a GUIDE Object in special
operations conducted by LOGiiX scripts, for example, when search-
ing for Objects. For more information, please refer to Chapter 5,
“Creating Object and Links”; Chapter 6, “Finding Objects and Links”;
and the online LOGiiX Command Reference.
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Figure 4-7
The Element Info dialog for the selected bitmap

Checking Diagram Information

You can select a diagram, and then pull down the Format menu and
choose Diagram Info to open a dialog where you can see information
about the diagram and change some of its attributes. The Diagram
Info dialog shows you the diagram’s Object Name, if it has one; if it
doesn’t, you can type one into the Name box. The diagram’s Object
ID number displays in the upper right corner.

Three check boxes enable you to control how the graphics display: 
Lock Diagram prevents graphics from being resized or otherwise
edited, Disable Zoom prevents readers from zooming graphics, and
Crop to Fit resizes the diagram window to fit within the document
window. If the Crop to Fit option is checked (the default), graphic
elements remain full size and are cropped to fit inside the diagram;
if this option is turned off, GUIDE resizes the graphic elements to fit
within the diagram rather than cropping them.
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Zoom Ratio shows how far the image has been zoomed; a ratio of
1:1 indicates that graphic has not been zoomed. The numbers in the
Viewing Offset boxes indicate the position of the viewing window
from the left and top edge of the clipping frame. The boxes beneath
Margins show the distance between the diagram and surrounding
text elements in pixels. The Clipping Frame section shows the clip-
ping frame’s width and height in pixels. The information under
Viewing Window indicates the viewing window’s width and height
in pixels. You can edit the numbers in these boxes to change the
diagram’s characteristics. Viewing Center shows the center of the
viewing window over the clipping frame region; this information
can be helpful when you zoom.

Figure 4-8
The Diagram Info dialog
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Zooming Graphics

You can ‘zoom in’ to magnify a part of a graphic to view it in more
detail or ‘zoom out’ for an overview. You can use the right mouse
button or the plus and minus keys on the keypad to zoom in or out
on graphics in GUIDE Author or GUIDE Reader. In GUIDE Author,
you can also use the Diagram Info command on the Format menu.
With the exception of the Diagram Info command, the following
procedures can also be used in GUIDE Reader.

If a graphic is already at its original size and you want to magnify
it to the fill the viewing window, double-click the secondary mouse
button while the pointer is positioned over the graphic. To enlarge a
graphic gradually, select the graphic and repeatedly tap the plus (+)
key until you are satisfied with the graphic’s magnification.

To zoom in on a specific point on a graphic with the mouse:

1 Position the mouse pointer over the graphic slightly above and
to one side of the area you want to magnify.

2 Press and hold down the secondary mouse button as you drag
the pointer diagonally across the area you want to enlarge to
define an enlargement frame.

As you drag the pointer, a rectangle forms around the area
you’ve defined.

3 Release the mouse button when you have drawn a box around
the area you want to zoom in on.

The box disappears and the area magnifies.

To zoom in on graphics with the Diagram Info command, choose
Diagram Info from the Format menu, and then edit the numbers in
the Multiplier and/or Divisor boxes. If the ratio is 1:1, the graphic is
at its original scale. If you enter a 5 as a multiplier (you can enter
only positive numbers), the graphic is magnified five times its normal
size. To zoom out, enter a divider that is larger than the multiplier,
for example, a 5:10 ratio reduces the graphic in its viewing window
to half its normal size.
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To quickly zoom out from an enlarged graphic to its original size
in the document, double-click the right mouse button. To gradually
reduce a graphic’s size, simply tap the minus key (-) until the graphic
is the desired size. These techniques to reduce graphics work in both
GUIDE Author and GUIDE Reader.

Panning Graphics

Panning enables you to move up, down, and across an image to see
different areas in detail.  If you enlarge (zoom in on) a graphic, you
may need to pan it to see all its detail. To pan a graphic in GUIDE
Author or GUIDE Reader:

1 Click on the graphic with the primary mouse button to select it.

2 Tap the up, down, left, and right arrow keys on your keyboard
repeatedly to pan the graphic in the desired direction.

Cropping Graphics

Cropping a graphic lets you control what part of a graphic displays
in the clipping frame. For example, cropping can be useful if you
have a drawing that includes a logo that you want to hide, or you
want to emphasize a particular area of a graphic.

To crop a graphic:

1 Click anywhere on the clipping frame to select it.

The sizing handles of the clipping frame appear. Be sure to
activate the sizing handles of the clipping frame and not the
small black squares along the graphic’s border.
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2 Move the pointer over the middle handle on the side of the
graphic you want to crop.

The cursor shape changes into a plus sign (+) when it is posi-
tioned directly over the handle.

3 Hold the mouse button down and drag the plus sign until only
the portion of the image you want to retain remains in view.

For example, if you drag the bottom handle up, the bottom part
of the graphic begins to disappear under the clipping frame. If
you drag a side handle toward the center of the graphic, that
side of the graphic begins to disappear under the clipping frame.

Recovering Hidden Graphic Elements

You can make clipping frames so small that the graphic elements
inside them are hidden. To recover and display hidden graphics:

1 Select the clipping frame.

2 Pull down the Format menu and click on Show Elements.

If you can’t see all the elements, use Push to Back and Pull to Front
to restack them. If any portion of a graphic element falls within the
clipping frame, Show Elements won’t move it.

Moving Graphic Elements

You may want to reposition graphic elements in clipping frames. To
move graphic elements one at a time, click on the graphic element
you want to reposition to select it; when the sizing handles appear,
reposition the mouse pointer over the selected graphic, hold the pri-
mary mouse button down and drag the mouse to move the graphic
element to the position you want in the clipping frame.
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To move several graphic elements at once, select the first graphic
element, then hold down the Shift key and click on other elements
you want to move. Position the mouse pointer over any of the selected
graphic elements, then hold the mouse button down and drag the
group of graphic elements to the desired position. GUIDE Author
moves all the selected graphic elements at once.

You can also use the Element Info dialog’s Location option to
reposition graphic elements:

1 Click on a graphic element you want to reposition.

2 Pull down the Format menu and choose Element Info.

This opens the Element Info dialog.

3 Edit the numbers in the Left, Top, Width, and Height text boxes.

The numbers indicate the element’s distance in pixels from the
top, bottom, and left edge of the clipping frame and the graphic
element’s height. Repositioning a graphic element may tuck
part of it under the clipping frame. For example, if the unscaled
graphic element is 523 pixels high and you enter a height of
600, the bottom of the graphic element is hidden under the
bottom of the clipping frame.

Sizing Graphics

To resize a graphic:

1 Click anywhere on the graphic to select it.

The sizing handles (small black squares along the graphic’s
border) appear when the graphic is selected.

2 Move the pointer over any sizing handle on the border of the
graphic until the cursor shape changes into a plus sign (+).

If the pointer shape is an arrow, you don’t have the pointer
properly positioned over a handle; if you drag the mouse, you
will move the graphic instead of resizing it.
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3 Hold the mouse button down and drag the plus sign cursor
away from the selected sizing handle to resize the graphic.

To make the graphic smaller, drag the pointer toward the
middle of the graphic. You can drag the pointer away from
the middle to make the graphic bigger. The sizing handles on
the corners resize the graphic’s contents; the handles in the
middle along the sides stretch or compress the graphic.

You can use the Restore Size command from the Format menu to
return a graphic to the size it was immediately before you changed it.

Sizing More than One Graphic at a Time

You can size more than one graphic elements in the same clipping
frame at the same time. This process allows you to resize a group of
graphic elements while preserving their relative positions in the docu-
ment. To simultaneously size multiple graphics:

1 Click on the first graphic to select it.

2 Press F3 and hold down the mouse button.

One set of sizing handles appears around the group of graphic
elements you’ve selected.

3 Move the mouse around on a resize handle until the pointer
changes to a plus sign.

4 Click and drag the mouse until the group of graphic elements is
the size you want.

GUIDE Author resizes all the graphic elements at once.
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Sizing Diagrams

To resize a diagram, select the diagram, position the mouse pointer
over the sizing handle in the lower right corner so that the cursor
shape turns into a plus sign, and then drag the mouse until the
diagram is the size you want. You can also resize diagrams in the
Diagram Info dialog:

1 Select one of the frames or click on a graphic element to select
its diagram. Only one sizing handle appears in the lower right
corner of the selected diagram.

2 Pull down the Format menu.

3 Choose Diagram Info to open the Diagram Info dialog.

4 Enter different numbers in the Width and/or Height text boxes of
the Viewing window option.

The numbers represent pixel measuring units; the number of
pixels to an inch varies according to the computer’s graphics
adapter, system setup, etc.

Sizing or Moving Graphics Incrementally

The diagram grid enables you to resize or move the graphic elements
in steps. This gives you more control over sizing. When the diagram
grid is active, GUIDE Author performs sizing in increments of four
pixels. To resize a scaled graphic in steps:

1 Select a graphic.

2 Pull down the Format menu.
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3 Click on Diagram Grid.

Although you can’t see it, the diagram grid divides the diagram
into units of four pixels.

4 Move your pointer across the graphic’s corner handle until you
see the pointer change shape into a plus sign (+).

5 Press the mouse button and drag the corner out slowly.

You’ll see the graphic element jump outward from the corner
four pixels at a time as you drag.

Copying Graphics

If you select an entire diagram when you copy graphics into the
Clipboard from GUIDE documents, the copy retains the original
graphic’s zoom ratio, its current cropping and clipping frame position,
and its colors. You can also copy multiple graphic elements or even
a single graphic element rather than an entire diagram.

Moving Graphics Between Clipping Frames

You can use the Cut, Copy, and Paste options from the Edit menu
or their tool bar icons to move graphic elements from one clipping
frame to another in the same document or from a clipping frame in
one document to a clipping frame in another document. To move
graphic elements from one clipping frame to another:

1 Select the graphic element or elements you want to move.

2 Pull down the Edit menu and click on Cut or Copy.

You can also use the Cut or Copy tool bar icons to insert the
graphic element(s) into the Clipboard.
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3 Select the clipping frame where you want the graphic element(s)
to appear.

4 Pull down the Edit menu again and click on Paste or use the
Paste icon on the tool bar.

GUIDE Author inserts a copy of the Clipboard contents into
the selected clipping frame in the same position that it occu-
pied in the original clipping frame. If the new clipping frame
is smaller than the graphic’s original clipping frame, you may
not be able to see a graphic element after you have pasted it
into the new clipping frame. If this is the case, either enlarge
the second clipping frame or pull down the Format menu and
click on Show Elements.

Inserting Multiple Elements into Diagrams

GUIDE Author centers the first imported graphic in the diagram and
highlights the viewing window. If you begin to add other graphics
without enlarging the diagram, subsequent graphics are placed on top
of the first one. To include more than one graphic element in the
same diagram:

1 If you intend to use the Clipboard rather than GUIDE Author’s
Place command, cut or copy the graphic element you want to
add into the diagram to insert that graphic into the Clipboard.

2 Select the diagram, making sure that any graphic elements
already inserted into the clipping frame are not selected.

3 Select the Paste or Place option from the Edit menu or click on
their tool bar icons to insert another graphic element into the
selected diagram.

The graphic element appears in the top left corner of the clip-
ping frame. Because the size of the diagram is determined by
the size of the first graphic element, the second graphic ele-
ment may overflow the confines of the clipping frame and be
partially hidden. You can enlarge the clipping frame to see all
of the graphic elements.
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Restacking Graphic Elements

You can stack graphic elements on top of one another and then
change the order of graphics in the stack. You can pull one or more
graphic elements to the front or push one or more graphic elements
to the back.

To pull graphic elements to the front, click on the graphic element
or elements you want to restack, then pull down the Format menu,
and click on Pull To Front. To push graphic elements to the back,
click on the graphic element or elements you want to restack, pull
down the Format menu, and click on Push To Back.

Grouping Graphic Elements

Grouping graphic elements allows you to treat them as one Object
that can be resized, cropped, etc. To group graphic elements:

1 Click on a graphic element that you want to include in a group.

2 Hold down the Shift key as you click on the other graphics you
want to include in the group.

3 Pull down the Make menu and choose Group.

Locking Graphics

GUIDE Author provides a locking feature to prevent graphics from
being inadvertently panned, zoomed, or resized. To prevent pan-
ning, select a graphic diagram and turn off the Crop to fit box in the
Diagram Info dialog under the Format menu to remove scroll bars
from the screen. When you check the Disable Zoom box in this
dialog, readers can’t zoom in and out on graphics.
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There are two ways to lock diagrams from editing: You can choose
Lock Diagram from the Format menu while the diagram you want to
lock is selected or check the Lock Diagram option in the Diagram
Info dialog. Locking graphics prevents readers from resizing or
repositioning graphic elements and from resizing the viewing win-
dows or clipping frames for those graphics.

You cannot scale and crop graphic elements, viewing windows,
or clipping frames when Lock Diagram is active. If the paragraph’s
ruler margins are too narrow to display the diagram, you can unlock
the diagram to fit it within the available space. Scaled diagrams let
you see a reduced view of the graphic elements.

Deleting Diagrams and Graphic Elements

To delete diagrams, all their graphic elements, and the associated
viewing window and clipping frame:

1 Drag your pointer across both frames and all graphic elements.

2 Choose Clear from the Edit menu or press the Delete key.

To delete one or more graphic elements in a diagram:

1 Select the graphic element or elements you want to delete.

2 Choose Clear from the Edit menu or press the Delete key.
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CHAPTER 5

CREATING OBJECTS AND LINKS
You structure text and graphics in GUIDE documents by defining
Objects and linking them. An Object can be a single word, a sentence,
a paragraph, a graphic, or even a collection of graphics. Just about
anything you can select with your mouse can be made into an
Object. Objects can also be linked to information and devices outside
GUIDE, including spreadsheets, video sequences, and audio clips.
For detailed descriptions of GUIDE Object types, components, be-
havioral attributes, and link information, please see “About GUIDE
Objects” in Chapter 3 of Welcome to GUIDE Author.

GUIDE Author’s Object-oriented information model provides an in-
tuitive framework for organizing information. When you define your
information as Objects, you can attach attributes that determine the
behavior and presentation of Object, and how they relate to other
Objects in GUIDE publications.

Using Freeze

Objects in GUIDE documents are active or inactive depending on
whether you activate the Freeze option. To create or modify Buttons
and other Objects, Freeze must be turned on so that Objects aren’t
‘hot’ (active). When you move the pointer over Objects with Freeze
on, the Objects behave like regular text and graphics. The pointer
displays as the insertion point (I-bar), allowing you to edit the Objects.

To turn Freeze on or off, use the Freeze command on the Document
menu or the Freeze icon on the tool bar. There is a check mark
before Freeze in the Document menu when Freeze is on. To
change the Freeze state temporarily, press and hold the Ctrl key.
This switches Freeze on or off for as long as you hold down Ctrl.
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Creating Objects in GUIDE Author

No matter which type of Object you want to make, you follow the
same procedure:

1 Select the text or graphic you want to make into an Object.

2 Pull down the Make menu.

3 Choose the command or appropriate icon in the tool bar for the
type of Object you want to make.

Generally, it’s easier to create Objects and links when GUIDE
Object symbols are visible. Use the Show Symbols command on the
Document menu or the Show Symbols icon on the tool bar to display
Object symbols.

Using Objects for Fielded Searches

One special use of Objects is in indexed documents. You can mark
portions of your documents as fields, which can speed up searches by
reducing the amount of data to be searched. You do this by treating
the fields as Objects in GUIDE.

Say you mark portions of the documents in a collection as fields, using
three field names: “North America,” “South America,” and “Europe.”
Your readers can then search in all documents of the collection or
specify just one of the fields to narrow their search. For example,
if readers select the appropriate index in GUIDE Reader’s Query
dialog, they can use the IN operator to create a trucks IN Europe
query to search for all instances of “trucks” only in those portions
of the documents designated as fields named “Europe.”



GUIDE Author User’s Manual 85

Creating Objects and Links

GUIDE Author User’s M
anual

With GUIDE Author you can easily create fields that your readers can
use to locate information in GUIDE Reader. First, you enclose the
data for a proposed field with a reference point. That is, with your
GUIDE document open, select the portion of text you want to desig-
nate as a field. Then choose Reference Point from the Make menu to
create a reference point, and with the text still selected, right-click
on the text and choose Attributes from the pop-up menu to open the
Object Attributes dialog. Check the Search Field box under Object
Attributes and enter a name for the field in the Object Name text box.
The name you use will display in the Query dialog when you use the
index for this document collection to conduct a search in GUIDE
Reader.

You can have up to 32 named fields in your document collection
(there’s no limit to the total number of fields); one field can even be
nested within another. A field name can have up to 240 alpha-
numeric characters; single spaces are allowed, but punctuation and
quotation marks aren’t.

Making Objects from Graphics

You can make Objects from graphics the same way you create
Objects from text:  select a graphic element, make it into a Button,
create a target Object, and link it to the graphic Button. You can
make an entire graphic element into a Button or overlay Hotspots on
specific parts of a graphic (the next section in this chapter, “Creating
Hotspots on Graphics,” covers this topic in detail).

For example, to create a graphical Expansion Button, simply select
a graphic element, and then choose Expansion Button from the Make
menu or click on the Expansion Button icon in the tool bar. GUIDE
Author displays a graphic Expansion stub that is already selected and
shows its sizing handles (small black squares that frame the stub) in
the top left corner of the clipping frame. You’ll also notice that the
cursor changes shape when you choose Expansion Button.
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Because the Expansion stub is already selected, you can choose Paste
from the Edit menu or use the Paste icon on the tool bar to replace
the default stub contents with graphics from the clipboard automati-
cally. You can also use the Edit menu’s  Place Graphic command to
place graphic elements into the stub. (Since the Expansion stub is
inside the graphic’s clipping frame, only graphics can be pasted or
placed into the graphic Expansion stub. If you want to link the graphic
to text, make it into a Note Button or Reference Button rather than
into an Expansion Button.)

You can resize and move the Expansion stub just like a graphic
element: To resize the stub, drag one of the handles toward or away
from the stub’s center. To move the Expansion stub, freeze the docu-
ment if it isn’t already frozen, then click on the Expansion stub, hold
the mouse button down, and drag the stub into position.

Creating Hotspots on Graphics

You may decide that you want to place a Button on a background
graphic in a specific location, but you don’t want to make the entire
graphic into a Button. You can insert special graphic elements called
“Hotspots” into a clipping frame, then position them over graphic
elements and make each Hotspot into an Object.

For example, if you have an image of a flower garden, you can
insert Hotspots, position them over different types of flowers, make
the Hotspots into Note Buttons with verbal descriptions of individual
flowers. When readers click on a Hotspot, a window pops up with
information on the type of flower that’s covered by the invisible
Hotspot.
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To insert a Hotspot into a diagram to overlay a particular area of the
graphic element and make the Hotspot into a Button:

1 Click on the graphic to select it.

2 Pull down the Format menu and click on Insert Hotspot or click
on the Insert Hotspot icon on the tool bar.

A Hotspot appears in the top left corner of the graphic diagram;
sizing handles (small black squares) surround the Hotspot to
show that it is selected.

3 To resize the Hotspot, move your pointer over a corner sizing
handle until the pointer turns into a plus sign (+). Hold the
mouse button down and drag until the Hotspot is the size you
want.

Hotspot border and transparency can also be set by selecting
Element Info from the Format menu.

4 To move the Hotspot, place your pointer on the Hotspot (not
over one of its sizing handles), press the mouse button, and drag
the Hotspot to the desired location over the graphic element
within the clipping frame.

5 Pull down the Make menu and select the type of Button you want
to make from the Hotspot (for example, choose Note Button) or
use the tool bar icon for that type of Button.

6 Link the Button to an appropriate target Object.
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Creating Links

When you create an Expansion Button or a Group, GUIDE Author
automatically creates the link between the Expansion Button and
Expansion or between each Object and its Group. To link other types
of Buttons to their target Objects, however, use the Start a Link
command. Start a Link starts a new link from a source or target
Object in preparation to link it to another Object.

The order in which you create and link Objects in GUIDE Author
usually doesn’t matter as long as you start the link at one end and
connect it at the other. For example, you could create a Definition
first, and then create a Note Button to display it or vice versa. You
can start the link at the Definition or the Button. Whichever you cre-
ate first, the Object you click on to activate the link is defined as the
source Object; the Object the link takes you to is the target Object.

Starting a Link

To use the Start a Link command:

1 Place the insertion point between the source Object’s symbols
or, if the source Object is a graphic, click on the graphic.

2 Pull down the Make menu and click on Start a Link or use the
Start a Link icon on the tool bar.

GUIDE Author links Expansion Buttons and Expansions automatically,
so this linking procedure applies to Note Buttons, Reference Buttons,
and Command Buttons. You can also use GUIDE Author’s pop-up
menu to create links; please see “Shortcuts for Creating and Linking
Objects“ later in this chapter.
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If a link from an Object has already been started, the Connect Link
menu command text tells you what type of Object the link originates
from (for example, Link from Reference Button). Connect Link does
not apply to Expansion Buttons and Expansions because GUIDE
Author links them automatically.

If you want to prevent Objects in a document from being changed or
unlinked, you can protect each one individually or protect the entire
document. Pull down the Tools menu and choose the Set Protection
command. When the Set Protection dialog opens, select Entire
Document or Selection, then click on Protect.

IMPORTANT:

You must place
the insertion point
inside the symbols
of the Object you
want to link to or
select a graphic
Object before you
choose Connect
Link or End Link.

Connecting a Link

Once you start a link, use the Connect Link command from the Make
menu or the pop-up menu, or use the End Link icon on the tool bar
to complete it.  Connect Link completes a link initiated with the Start
a Link command. The Connect Link command is not available unless
you have already chosen Start a Link. If you link an existing Object
with a new Reference Point or Definition, any previous link is lost.
Although you can create multiple links to an Object, you can only
create one link from an Object.
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Shortcuts for Creating and Linking Objects

The following procedure outlines a quick method to make a Note
Button and Definition using keyboard shortcuts:

1 Click on the Note Button icon or type Ctrl+Shift+N to create
a Note Button.

2 Enter the text you want to use for the Button label.

3 Press Ctrl+Shift+W to open the Definitions window.

4 Type the text for the note into the Definitions window.

5 Close the Definitions window to return to the active document.

You can also use the pop-up menu and tool bar icons to create
Buttons, start links, and connect links:

1 Make sure Freeze is off.

2 Move the mouse pointer over the Object you want to link.

3 Press Shift and hold down the secondary mouse button.

4 When the pop-up menu appears, select a command, then
release the mouse button.

The commands on the pop-up menu vary depending on the
type of Object you selected and its current link. When you
create a source Object, the pop-up menu provides options to
start the linking process. When you create a target Object, the
pop-up menu provides commands to complete links.
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To create a Note Button and its Definition using shortcuts:

1 Place the insertion point where you want to create the Note
Button or select text you want to use for the Note Button label.

2 To make a Note Button, click on the Note Button icon on the tool
bar or type Ctrl+Shift+N.

3 If you didn’t select existing text, type in the new text you want
for the Note Button label.

4 Position the pointer over the Note Button you just created, press
the secondary mouse button to display the pop-up menu.

5 Choose Make Definition from the pop-up menu.

A Definition is automatically created and linked to the Note
Button.

6 Enter, place, or insert the text or graphics for the Definition.

7 Close the Definitions window to return to the active document.

The Note Button is linked to the Definition.

You can also create a Command Button and its Definition using this
method, except that you use the Command Button icon on the tool
bar or the keyboard shortcut in Step 2.
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Displaying and Printing Definitions

To display the Definitions for an entire document, pull down the Make
menu and click on Definitions Window. GUIDE Author displays the
Definitions for all the Note Buttons and Command Buttons in the
active GUIDE document in a separate window.

To display a Definition for a particular Note Button or Command
Button, click on the secondary mouse button while the cursor is over
the Note Button or Command Button to display the pop-up menu,
then click on Show Definition. GUIDE Author displays the Defini-
tions window for that document scrolled to the Definition for the
Note Button or Command Button. The text for that Definition blinks
briefly to highlight it.

You can also print the content in the Definitions window. To do this,
open the Definitions window, then choose the Print command from
the File menu.
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CHAPTER 6

FINDING OBJECTS AND LINKS
This chapter describes how to find Objects and links in GUIDE
documents. The ability to find Objects and test the integrity of links
becomes important when you have large or complex documents to
manage. For example, you may decide that a publication no longer
needs a particular Object. However, before you delete the Object,
you need to determine if other Objects maintain links to it. Also, if
you create documents with many Objects, you need to check that
all Objects are correctly linked. GUIDE Author’s tools for finding
Objects and links can help you accomplish essential development
and maintenance tasks like these.

Finding Objects

The Find Objects command on the Tools menu finds all Objects
defined in the active document. This is useful when you want to see
a list of Objects, change information about selected Objects, or gen-
erate an index for a document.

Click on the Options button in the Find Objects dialog to open the
Find Objects Options dialog to tailor the information that the search
results report to fit your particular needs with these options:

OPTIONS DESCRIPTION

Text Displays the text label, Object type, and ID
number of any Object found, and indicates
whether the Object is based on text or
graphics.

Object Name Displays the Object type, the ID number,
and the name of any Object found.
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Figure 6-1
GUIDE Author’s Find Objects dialog

Figure 6-2
The Find Objects Options dialog
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Referenced File Name Displays the names of target documents for
any Reference Buttons, Note Buttons, or
Command Buttons found in the active
document.

Save Settings Check Save Settings to make the options
you have selected the defaults that apply
each time you start GUIDE Author. If Save
Settings is not checked, GUIDE Author uses
the changes for the current session only.

To use the Find Objects command:

1 Pull down the GUIDE Author’s Tools menu.

2 Click on Find Objects.

GUIDE Author displays the Find Objects dialog.

3 Check the boxes for the types of Objects you want to search for.

 4 Click on Options in the Find Objects dialog to choose the type
of information you want the search results to report.

5 Click on OK to return to the Find Objects dialog where the Scan
option is now available.

6 Click on Scan.

GUIDE Author searches for the types of Objects you specified,
and then lists the Objects found and related information about
those Objects based on the options you chose in Step 4. To
scan again using different options, repeat Steps 3 and 4.

OPTIONS DESCRIPTION
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7 After the scan, you can select an Object from the ‘hitlist’ to
activate the Go to and Info options.

8 Click on Go to to navigate to the selected Object’s location in
the active document or Definitions window; the Object blinks
briefly to help you locate it.

9 Choose Info to display the selected Object’s attributes and
change them if you wish.

10 Choose Save to save the entire list of Objects as a GUIDE docu-
ment that contains reference links to each Object on the hitlist.
GUIDE Author opens the hitlist document for you to view and
edit.

11 Double-click on the close boxes for any dialogs or windows
opened during your Find Objects session and return to the
active GUIDE document.

Finding Links

Find Links on GUIDE Author’s Tools menu searches for links to a
selected Object (the target Object) in active, linked, and selected
documents. For example, an Expansion Button may be the target of
several Reference Buttons; Find Links enables you to locate all
Reference Buttons linked to that Expansion Button. This command is
particularly useful to check the existence or integrity of links and to
determine the implications of deleting an Object. You can configure
link searches with these option (click the Options button in the Find
Links dialog):

OPTION DESCRIPTION

Text Displays the text label, Object type, and ID number
of any Objects linked to the target Object.

Object Name Displays the name, Object type, and ID number of
any Object linked to the target Object.

Active Only Includes only the active document in the search.
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Active Includes linked documents in the search. A linked
and Linked document has at least one Reference link from the

active document that contains the target Object.
Documents that maintain links to the active docu-
ment aren’t considered linked for searching purposes.
If the active document contains any Reference links
to other GUIDE files, this option lets you include
linked documents in the search. If you select Active
and Linked, GUIDE Author scans all GUIDE files
linked to the active document and lists only those
linked to the target Object. The Object types, ID
numbers, and optional user-defined names of linked
Objects also display.

Selected Lets you select documents to include in the search.

Save Settings Writes the new settings to the configuration file,
making them the defaults that apply every time you
start GUIDE Author.  If this box is not checked, the
changes apply only for the current session.

Figure 6-3
The Find Links dialog

OPTION DESCRIPTION
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To use Find Links:

1 Place the insertion point between the target Object’s symbols.

Hold the Ctrl key down to temporarily freeze Object activity.

2 Pull down the Tools menu.

3 Click on Find Links to open the Find Links dialog.

4 Click on Options in the Find Links dialog to define the scope
of the search and results presentation.

5 Click on OK to return to the Find Links dialog.

When you click on Selected in the Find Links Options dialog,
GUIDE Author enables Select Files in the Find Links dialog.
Select Files opens a dialog where you can choose files to in-
clude in the search. You can click on Add to open the Add
Files to Catalog dialog to locate the files you want to scan.
When you return to the Select Files dialog, the selected files
appear in the Files to Scan list.

Repeat this process until you’ve selected all the documents
that you want to include in the search. Click on Clear All to
discard all the files in the Files to Scan list. To delete individ-
ual files, select the file name and choose Remove. When you
are finished, choose OK to return to the Find Links dialog.

6 Click on Scan in the Find Links dialog.

GUIDE Author searches for links to the selected Object based
on the Find Links option you chose in Step 4 and returns a list
of documents and Objects linked to the selected target Object.

7 After the scan, you can click on a document or link name in the
hitlist to activate the Go to option.

When you click on Go to, GUIDE Author opens the document
that contains the linked Object; the Object blinks briefly to
help you locate it.
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Figure 6-4
Selecting files for a Find Links scan

8 Click on an Object ID in the hitlist to activate the Info option.

When you choose Info, GUIDE Author displays the selected
Object’s attributes; you can change them if you like.

9 Choose Save to save the entire list of Objects as a GUIDE docu-
ment that contains reference links to each Object on the hitlist.
GUIDE Author opens the hitlist for you to view and edit.

10 Close any dialogs or windows opened during your Find Links
session and return to the active GUIDE document.
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CHAPTER 7

EDITING OBJECTS
You can edit the appearance, behavior, and label text or graphics
of GUIDE Objects to help readers recognize them. You can set or
change the appearance of Objects in several ways.

You can change the label text style to make it bold, italic, etc. You
can change the color of label text or its background, enclose Objects
in a box or leave them unboxed, and choose a specific cursor pattern
that appears whenever a reader moves the mouse pointer over an
Object of that type.

Changing Object Text

The styles applied to Object label text help highlight Objects in
GUIDE documents. The default text styles for GUIDE Objects are:

OBJECT DEFAULT TEXT STYLE

Expansion Button Bold

Expansion Plain

Note Button Underlined

Reference Button Italic

Command Button Italic

Reference Point Plain

Definition Plain
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To change the style of label text for all Objects of a certain type:

1 Pull down the Document menu and click on Object Styles.

2 Select an Object type, then check the box next to the text style
you want to use for that type of Object.

For example, if you want all Expansion Buttons to appear in
italic type, select Expansion Button, then Italic. Repeat this
process for different Object types until you assign all the
Object styles you want.

Options across the bottom of the Object Styles dialog apply
styles to all Objects regardless of type. Click on All Plain if you
want all Objects to have plain text labels. Click on Default
Styled to return Object labels to the default text style for each
type of Object. Click on Default Boxed to use default text styles
for Objects with the addition of a box around their text labels.

3 Check Make Default in the Object Styles dialog if you want to
change the default text styles for Objects to the configuration
you’ve just defined.

This applies the active Object styles to all Objects in both
the active document and any new documents you create. If
Make Default is not checked, the Object styles you’ve defined
apply only to the active document.

GUIDE Author adds the appearance attributes you set with Object
Styles to any text Object you’ve already created and to those you
subsequently create. You can use the commands from the Format
menu or options on GUIDE Author’s formatting Ribbon to add these
characteristics to styles for individual Objects.
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Changing Object Colors

You can change the color of text or background in Object labels to
highlight them. Using color to highlight text and background makes
it easy for readers to recognize Objects. To change the color of an
Object’s text label:

1 Use the Ctrl key or the Freeze icon on GUIDE Author’s tool bar
to freeze Object activity, and then position the insertion point
anywhere inside an Object but between the Object’s symbols.

2 Pull down the Format menu and click on Text Color.

3 When the Text Color dialog opens, click on the color shown in
the Text or Background box, depending on which you want to
change.

A list of available colors drops down.

4 Click on the color you want to use; the sample area in the Text
Color dialog gives you a preview of the Object label.

Repeat this process until you’re satisfied with the color of both
the text and its background.

5 Click OK  to apply the color to the Object label or click Cancel
to discard it.
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Setting the Cursor Pattern

The shape of the mouse pointer, or cursor, changes when it is over a
GUIDE Object. The cursor patterns you assign for Object types not
only highlight the location of Objects in your GUIDE documents,
they can also indicate the type of Object the cursor is over and sug-
gest its purpose.

You can choose Attributes from the Make menu and select a pattern
from the Cursor list in the Object Attributes dialog to set the cursor
shape for an Object type. You can also use the pop-up menu to
change the cursor pattern:

1 Move the mouse pointer over an Object, and then click once
with the secondary mouse button to display the pop-up menu.

2 Choose Set Cursor.

The Set Cursor dialog opens to display the ID number for the
Object’s current cursor pattern. To see a list of available cur-
sor patterns, click on the pattern display or the arrow beside
it. Scroll until you see the pattern you want, then select it. The
list folds away and the new pattern displays in the box.

3 Click on OK to return to the active GUIDE document where the
new cursor pattern displays when the mouse pointer is over an
Object of the type you selected before you chose Set Cursor.

NOTE:

One of the cursor
patterns you can
choose is the Win-
dows hourglass
(ID #242).  When
you select this
pattern, the cursor
dialog displays the
hourglass.  This is
just the cursor
pattern you’ve
chosen; its appear-
ance does not
mean that the
application has
paused or stopped
responding. When
you move the
pointer outside
the dialog, the
cursor reverts
to an arrow.

For a complete list of available cursor patterns and their ID numbers,
see “Initializing GUIDE Author” in the Welcome to GUIDE Author
manual.

Setting the Horizontal Size of a Note

When you click on a Note Button, its Definition displays in a pop-up
window. To reset the horizontal size of a Note Definition’s tempo-
rary window:

1 Choose Definitions Window from the Make menu to open
the Definitions window for the active GUIDE document.
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Figure 7-1
GUIDE Author’s Set Cursor dialog

2 Select a Note Definition.

3 Choose Show Ruler from the Document menu or click on the
Ruler icon in the tool bar to display the text ruler in the Defini-
tions window.

4 Click on the abs icon on the tool bar to set the units on the
Definitions window’s ruler to absolute.

5 Adjust the right margin marker to size the window horizontally.

6 To change the pop-up window’s vertical size, add or delete
carriage returns inside the Definition symbols.

7 Close the Definitions window, and then click on the Note But-
ton linked to that Definition to display the Definition’s pop-up
window and check its new size.
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Changing Object Behavior

Objects in GUIDE are composed of three components: data (the text
or graphics used to label, or make, the Object), presentation attributes,
and behavioral attributes. In addition, information associated with
each Object (the Object type, Object ID number, and its link status,
for example) give it a unique identity in the GUIDE environment
and specify its relationship with other Objects.

The data component is the text or graphic that appears on the screen
when the Object displays. In the case of Command Definitions, data
consists of the instructions or LOGiiX script that executes when a
reader clicks on the associated Command Button.

Presentation attributes apply primarily to text Objects. These attri-
butes determine how the data is displayed and include text styles,
fonts, sizes, effects, and colors. Behavioral attributes define what
happens when a reader clicks on a source Object or when a target
Object displays. For example, you can specify that a source Object
blinks whenever it’s activated or that a target Object appears at the
top of the document window when it first displays.

You can control more than Object appearance; you can also set or
change Object behavior. How an Object behaves depends on its
Object type and the attributes that can be assigned to it. Please see
the table “Behavior Attributes for GUIDE Objects” at the end of this
chapter.

You can use the Attributes command to change Object behavior.
To access the Object Attributes dialog, place the insertion point
between the Object’s symbols, pull down the Make menu, and
choose Attributes or click on the Attributes icon in the tool bar.
You can also access Attributes through the pop-up menu.

NOTE:

The Object at the start of a link is the source Object; an Object at the end of a link is
the target Object. When the target Object is in a different document than the source
Object, the document at the end of the link is called the target document.
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The Object Attributes dialog shows the type of Object you’re work-
ing with, its Object ID number, and any assigned Object name. The
listings vary according to the type of Object you’ve selected. You can
type text in the Object Name field to assign a specific name for that
Object. Object names display in the hitlist (search results) when you
use the Find Object or Find Links command on the Tools menu to
search for Objects. If you select a Reference Button, Note Button, or
Command Button (a source Object) before you selected Attributes
from the Make menu, the target Object’s ID number and the name of
the document that contains the target Object appears in the Object
Attributes dialog.

You can redirect a link to a target Object manually; simply change
the target document name and Object ID number in the Object
Attributes dialog, then check Local Link or Remote Link to specify
whether the link is local or remote. Check Remote Link if you plan
to connect this link to an Object in another document.

Figure 7-2
GUIDE Author’s Object Attributes dialog
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The following table provides detailed descriptions of Object attributes.
Note that not all attributes can be applied to all types of Objects.
Also keep in mind that when an Object is a link target, you can only
define it with Top of Window and Blink on Arrival attributes. When
Objects become part of the backtrack record by being selected, they
can only be defined with the Object Action and Arrival at Target
attributes. Command Definition behavior depends on the contents of
the LOGiiX script that executes when a reader clicks on the associ-
ated Command Button.
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BEHAVIOR ATTRIBUTES FOR GUIDE OBJECTS

ATTRIBUTE APPLIES TO BEHAVIOR

Object Attributes
Top of Window Expansion Buttons The Expansion (the target Object) displays at

the top of the active document window when
it unfolds.

Groups The Group displays at the top of the document
window when a reader folds an Expansion in
that Group.

Remain Expansion Buttons The Expansion Button remains visible when
its Expansion unfolds.

Groups The active Expansion Button unfolds and the
labels of folded Expansion Buttons and any
text or graphics inside the Group displays
when Remain is applied.

Limited Fold Expansion Buttons After the Expansion unfolds, it remains open.
The only way you can fold it away again is to
click on the Expansion Button (normally, you
click on an Expansion to fold it).  This prevents
the Expansion from folding accidentally.

Blink on Expansion Expansions The Expansion blinks briefly when it unfolds.

Blink on Folding Expansion Buttons The Expansion Button blinks briefly after its
Expansion folds away.
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Local Link Reference Buttons Specifies that the link is local (the target
Note Buttons Object is in the same GUIDE document).
Command Buttons

Remote Link Reference Button Specifies a remote link (the target Object
Note Button resides in another document).
Command Button

Close this Document Reference Buttons If a Reference Button is linked to a remote
Object, this attribute closes the document
that contains the Reference Button after the
document that contains its Reference Point
opens.

Keep Document Active Reference Buttons Keeps the document that contains the
Reference Button active even after the
document that contains its target Object
opens.

Close Target on Backtrack Reference Buttons Closes the document you backtrack from
when you backtrack to a Reference Button.
This allows you to ‘chain’ through a series of
GUIDE documents but keep just one
document open.

BEHAVIOR ATTRIBUTES FOR GUIDE OBJECTS (CONTINUED)

ATTRIBUTE APPLIES TO BEHAVIOR

Object Attributes  (Continued)
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When a Link Target
Top of Window Expansion Buttons Objects can be both the source and target

Expansions of links. If an Object is the target of a link,
Groups you can apply this attribute to display the
Reference Buttons Object at the top of a document window
Reference Points after a Reference action.
Note Buttons
Command Buttons

Blink on Arrival Expansion Buttons The Object blinks briefly when it first
Expansions displays. The Object also blinks on arrival
Groups if it displays as the result of a backtrack
Reference Buttons action.
Reference Points
Note Buttons
Command Buttons

Expand on Arrival Expansion Buttons This attribute ensures that Expansion
Buttons that are the target Object of links
expand before they display.

Search Field Reference Points This attribute facilitates searches in
selected portions or ‘fields’ of documents.

Backtrack Record
Object Action Expansion Buttons Records the Object’s action in the

Groups backtrack record.
Reference Buttons
Note Buttons
Command Buttons

Arrival at Target Reference Buttons Records arrival at the target Object for
backtracking.

BEHAVIOR ATTRIBUTES FOR GUIDE OBJECTS (CONTINUED)

ATTRIBUTE APPLIES TO BEHAVIOR



112 GUIDE Author User’s Manual

Editing Objects

Removing GUIDE Structure from Objects

You can remove GUIDE Object structure but leave intact the text or
graphics used to label Objects. To ‘unmake’ an Object:

1 Activate Freeze, if necessary.

2 Position the insertion point somewhere between the symbols of
the Object you want to unmake.

3 Pull down the Make menu and click on Unmake.

The text of the Unmake command varies on the menu according
to the type of Object you’ve selected to unmake.

GUIDE Author removes the Object structure and formatting, but
leaves intact the text or graphic that was used to label the Object in
the GUIDE document. GUIDE Author can unmake Objects that are
nested inside other Objects. For example, if you created a Reference
Point inside an Expansion, you can position the pointer between the
Reference Point symbols and choose Unmake to remove the Refer-
ence Point but leave the Expansion. Conversely, if you position the
insertion point inside the Expansion but outside the Reference Point
symbols and choose Unmake, GUIDE Author removes the Expansion,
but leaves the Reference Point.

When you unmake a folded Expansion Button, GUIDE Author unfolds
the Expansion. If the Button and its Expansion were created from text,
GUIDE Author inserts the Expansion text after the Expansion Button
label text in the document.



GUIDE Author User’s Manual 113

Using the Glossary

GUIDE Author User’s M
anual

CHAPTER 8

USING THE GLOSSARY
You can use GUIDE Author’s Glossary to store nearly anything you
use frequently— text, graphics, scripts, etc.— so you have that
material readily available to insert into GUIDE documents as you
create and edit them. Quick access to this ‘boilerplate’ material
reduces the amount of time you spend on repetitive activities such
as opening files, and cutting and pasting.

This chapter describes how to use GUIDE Author’s Glossary. You’ll
learn how to add, retrieve, change, and delete items from the Glossary.

Figure 8-1
GUIDE Author’s Glossary dialog
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Adding Items to the Glossary

To add an item to the Glossary:

1 Select the item (text, graphic, or Object) that you want to
add to the Glossary.

2 Pull down the Tools menu and click on Glossary or press
Ctrl+G.

3 Click on New under Get Selection.

GUIDE Author displays a dialog where you can name your
new Glossary item.

4 Type a unique name for the new Glossary item over Unnamed
in the Item Name text box.

5 Click on New to accept the name, close the Item Name dialog,
and return to the Glossary dialog.

Your new item is highlighted in the Glossary Items list.

6 Click on the close box in the title bar of the Glossary dialog.

Another dialog appears to ask if you want to save changes
to the Glossary. Click Yes to save the revised Glossary, No
to discard the new item, or Cancel to return to the Glossary
dialog.
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Displaying a Glossary Item’s Contents

You can display what a Glossary item contains as well as its name:

1 Pull down the Tools menu and click on Glossary.

2 Select the item you want to see from the Glossary Items list in
the Glossary dialog, and then click on Show.

GUIDE Author displays the contents of the Glossary
item you selected.

3 Click anywhere on the window that displays the Glossary item’s
contents to close it and return to the Glossary dialog.

Changing a Glossary Item Name

To rename a Glossary item, but leave its contents unchanged:

1 Pull down the Tools menu and click on Glossary.

2 Select the item you want to change from the Glossary Items list
in the Glossary dialog.

3 Click Rename in the Glossary dialog.

4 Type over the current name in the Item Name text box.

5 Click Rename to accept the new item name and return to the
Glossary dialog.

6 Click on the close box in the title bar of the Glossary dialog to
close it.

Another dialog appears to ask if you want to save changes
to the Glossary. Click Yes to save the revised Glossary, No to
discard the new item, or Cancel to return to the Glossary dialog.
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Inserting Glossary Items into Documents

To insert an item from the Glossary into a GUIDE document:

1 Position the insertion point where you want to insert the
Glossary item into the document.

2 Pull down the Tools menu and click on Glossary.

3 Select the name of the item you want to insert from the
Glossary Items list in the Glossary dialog, then click on Insert.

GUIDE Author inserts the Glossary item, closes the Glossary
dialog, and returns you to the active document.

Scripts are often inserted from the Glossary as Definition Objects. If
you can’t insert a Glossary item, make sure the insertion cursor is in
the Definitions window but not in a Definition Object, and try again.

A quicker way to insert a Glossary item into a GUIDE document:

1 Position the insertion point where you want to insert the
Glossary item.

2 Press Ctrl+G to open the Glossary dialog.

3 Select the Glossary item you want to insert into the document
from the Glossary Items list in the Glossary dialog, and then
click Insert to paste the item into the document.
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Changing a Glossary Item’s Contents

You can change the contents of a Glossary item without changing
its name:

1 Select the text or graphics you want to use to replace the
contents of a current Glossary item.

2 Pull down the Tools menu and click on Glossary.

3 Select the name of the Glossary item you want to modify from
the Glossary Items list in the Glossary dialog, and then click on
Modify in the Get Selection field.

4 When GUIDE Author displays a dialog that shows the name of
the Glossary item you selected, click on Modify.

GUIDE Author modifies the contents of the item in the Glossary
and returns you to the Glossary dialog. If you click on Cancel,
GUIDE Author does not modify the Glossary item.

Deleting a Glossary Item

To delete an item from the Glossary:

1 Pull down the Tools menu and click on Glossary.

2 Select the item you want to delete in the list from the
Glossary Items list in the Glossary dialog.

3 Click on Delete.

4 Click on OK to delete the item when GUIDE Author asks you to
confirm the deletion; choose Cancel if you change your mind.

When you click on OK, GUIDE Author deletes the item from the
Glossary. When you click on Cancel, GUIDE Author retains the
item in the Glossary.
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CHAPTER 9

PRINTING DOCUMENTS
In this chapter, you’ll learn how to prepare documents for printing,
how to print documents on various printer types, and how to print
portions of a document or an entire document.Before you print a
document, make sure that you have selected a printer that is prop-
erly connected to your computer.

Page Setup

GUIDE Author’s Page Setup dialog lets you control how documents
appear when you print them. This step is optional. Page Setup
options include:

OPTIONS DESCRIPTION

Margins You can set the left, right, top, and bottom margins
by typing new values into the appropriate edit
boxes. The abbreviation that follows the edit boxes
specifies whether the margins are measured in
inches or millimeters.

Orientation Click on Portrait to orient contents vertically on
the page or on Landscape for a horizontal page
format.

GUIDE Style The As Display option prints Object text in the
type styles you’ve chosen with the Set Object
Styles command. When you choose this option,
the appearance of Objects in the printout approxi-
mately matches their appearance on the computer
screen. Select None if you want GUIDE Author to
ignore Object typefaces.
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Footer Text Enter any text you want to appear across the bot-
tom of printed pages in the Footer Text box.

Page Numbers Click on the box to turn page numbering on; click
on the box again to turn page numbering off. If
this option is checked, GUIDE Author centers page
numbers at the bottom of printed pages unless you
also specify footer text, in which case footers print
in the lower left corner and page numbers in the
lower right corner on each page.

Make Default If you check this option and choose OK, GUIDE
Author records your page setup specifications in
the configuration file, making them the defaults
that apply every time you create a new document.
If this box is not checked, GUIDE Author saves
the changes only for the active document.

To use the Page Setup dialog:

1 Pull down the File menu and click on Page Setup.

The Page Setup dialog displays.

2 Select one or more print options in the Page Setup dialog.

3 Choose OK to save the options for GUIDE Author’s Print and
Print All commands.

Printing the Active Frame

You can print the entire document or just the active Frame at its cur-
rent level of expansion (only Expansions that are currently unfolded
appear in the printout).

1 Choose Print from the File menu.

GUIDE Author opens the Print dialog.  

OPTIONS DESCRIPTION
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2 Select the range of pages to print.

Choose All to print all pages in the active Frame. To specify
individual pages for printing, enter the page numbers in the
From and To edit boxes.

3 You can change the print quality in the Printer Properties dialog.

4 If you want to print to an Encapsulated PostScript (EPS) file
rather than on paper, check Print to File in the Print dialog,
and then click Properties. When the Printer Properties dialog
opens, click PostScript to open that tab dialog, and choose
Encapsulated Postscript (EPS) from the drop-down list. Click
OK to return to the Print dialog.

5 Type the number of copies you want to print into the Copies
text box.

6 Choose OK to print the Frame at its current level of expansion.

Printing an Entire Document

You can print an entire GUIDE document, including all Frames
and all Expansions, even those that are hidden. The document’s
Note Definitions automatically print on a separate page at the end
of the printout. To print an entire document, choose Print All from
the Print dialog. Please see the preceding section “Printing the
Active Frame” for a description of options available in the Print
dialog.

NOTE:

If you just want to print a document’s Definitions, choose the Definitions Window
command from the Navigate menu before you select the Print option.
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CHAPTER 10

ADVANCED TOPICS
This chapter describes advanced topics you’ll find useful in creating
and refining electronic publications in GUIDE Author. You’ll learn
how to:

♦ Launch other applications from GUIDE documents

♦ Control the serial port

♦ Use opcl3.dll to open and close documents

♦ Add a control panel

♦ Use LOGiiX to add multimedia to publications

♦ Prepare GUIDE documents for publication on the Internet

About Interpreters

GUIDE Author supports interpreters that can access external systems:
logiix.dll provides access to LOGiiX, a powerful macro language,
launch3.dll launches other applications, opcl3.dll opens and closes
documents, and serial3.dll controls the serial port. Scripts that call
these interpreters reside in the Definitions windows of GUIDE
documents as Command Definitions that execute when users activate
linked Command Buttons. For detailed information about LOGiiX,
see the LOGiiX User’s Manual and the online LOGiiX Command
Reference.
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Launching Other Applications

You can use Command Buttons to launch other GUIDE publications,
Windows-based applications, or even non–Windows-based applica-
tions. For example, you could create a Command Button that launches
a spreadsheet and then returns you to your GUIDE publication.

To launch another application from a GUIDE document, simply
create a Command Button and link it to a Definition that calls the
launch3.dll interpreter provided with GUIDE Author. You can assign
special parameters to maximize the launched application and mini-
mize your GUIDE publication.

Launching Windows Applications

To write a Command Button Definition to launch Windows applica-
tions, enter syntax similar to this in the Definitions window:

#launch
load c:\pathname\application

#launch specifies the use of the (launch3.dll) interpreter. The load
option tells GUIDE Author to load a specific application and open
it minimized (as an icon on the Windows desktop). Substitute the
drive letter, path, and name for the application you wish to run, for
example, load c:\windows\excel.exe.

After the Definition has been linked to a Command Button, the
Windows application launches whenever a reader clicks on the
associated Command Button.
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Launch Options

You can use options in Command Definitions that launch other appli-
cations from GUIDE publications for varying effects: load launches
the specified application as an icon (minimized), run opens the appli-
cation at its normal size, and zoom maximizes the application to fill
the entire screen when it is launched.

The syntax for load is described in the previous section. The syntax
for the run option is the same:

#launch
run c:\path\application

for example, run c:\windows\excel.exe

The syntax for the zoom option is:

#launch
zoom c:\path\application

for example,  zoom c:\windows\excel.exe

You can use an icon option before load, run, or zoom to minimize
the GUIDE application that contains the Command Button that
launches the other application before the application specified in
the Command Definition opens. The syntax is:

#launch
icon
run c:\path\application

for example, run c:\windows\excel.exe
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Controlling the Serial Port

You can use Command Buttons to drive any device connected to the
serial port of your computer. You can control a videodisc player,
modem, or other serial peripheral.

To use GUIDE’s serial interpreter (serial3.dll) to drive a serial device,
first create a Command Button, and then write a script for its Command
Definition similar to this:

#serial
port in com1:
port out com1:
mode in com1:1200,N,8,1
mode out com1:1200,N,8,1
synch out 2000
data out “go\0d\0a“

#serial specifies the serial interpreter. The port commands tell the
serial interpreter which ports to use for input and output. The mode
commands initialize the serial port for input and output; the syntax
is the same as that for the DOS mode command.

The synch command sets a time-out in milliseconds for the serial port.
If the input or output transfer doesn’t take place before this time-out
occurs, the transfer is abandoned. A zero time-out is equivalent to
asynchronous output.

The data out command sends the string surrounded with quotes to
the output port. A data in command asks the interpreter to pause until
it receives a specified data string from the currently selected input
port.
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Using opcl3.dll

Another GUIDE interpreter, opcl3.dll, it allows you to use certain
commands such as open or close in a Command Definition. The
opcl3.dll commands are similar to the LOGiiX functions of the same
names. For more information about LOGiiX, see the LOGiiX User’s
Manual and the online LOGiiX Command Reference. Table 10-1 lists
opcl3.dll commands and parameters; these commands only function
in the active GUIDE document.

To use a opcl3.dll command, first create a Command Button, and then
write a script for the Button’s Command Definition similar to this:

#opcl
CommandName (parameters)

#opcl is the alias for the open/close interpreter; this line passes
instructions that follow to the opcl3.dll interpreter. CommandName
(parameters) identifies the command(s) and parameter(s) you want
to use in the script (please see Table 10-1).

After the Definition has been linked to a Command Button, the
interpreter executes the specified commands according to the script
parameters whenever a reader clicks on that Command Button.
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TABLE 10-1 — OPCL3.DLL COMMANDS AND PARAMETERS

COMMAND PARAMETERS DESCRIPTION

Version No parameters Displays a message box that identifies the version of the
open/close interpreter in use

Wait Time Waits for the number of seconds specified by Time

Open DocumentName Opens (activates) the document specified by
DocumentName

Close DocumentName Closes the document designated by the
DocumentName parameter if it’s open

CloseAll No parameters Closes all open GUIDE documents

TopLevel No parameters Performs the Top Level command

Backtrack No parameters Performs the Backtrack command

FirstFrame No parameters Performs the First Frame command

PrevFrame No parameters Performs a Previous Frame command

NextFrame No parameters Performs the Next Frame command

LastFrame No parameters Performs the Last Frame command

GoToFrame FrameNumber Goes to the document Frame specified by
FrameNumber

SendToBack No parameters Sends the document to the back of the stack of open
documents

ReferenceTo DocumentName Simulates a Reference action from the active
ObjectName document to the document and Object specified by

DocumentName and ObjectName

NameAction ObjectName Activates the GUIDE Button specified by ObjectName

Beep No parameters Sounds an audible beep
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Creating a Control Panel

To create a control panel document:

1 Use a painting or drawing application that’s compatible with
Windows to create the control panel icons or use the icons
provided in GUIDE Author’s Glossary.  When you are finished,
copy the icons to the Clipboard.

2 Open a new GUIDE document, and position its window where
you want the control panel to appear each time it is opened.

3 Paste your icons into the document.

4 If your icons are represented as a single graphic element,
insert a Hotspot and place it over each icon.

For more information about Hotspots, please see “Working
with Graphics” earlier in this manual.

5 Make each Hotspot into a Command Button.

For more information about Command Buttons, please see
“Creating Objects and Links” earlier in this manual.

TIP:

Use one large
control panel
graphic rather than
many small ones
for better perfor-
mance.

6 Make a Definition.

To make a Definition, choose Definition from the Make menu
or the pop-up menu. Your Definition might contain an open/
close interpreter command or a LOGiiX script. For detailed
information about LOGiiX, see the LOGiiX User’s Manual and
LOGiiX Command Reference.

7 Use the Properties command to set the Stay Back attribute for
the control panel document.

This ensures that the control panel’s Buttons remain available
when publication content documents are active.  (Please see
“Creating Objects and Links” for more information about the
Stay Back attribute.)

8 Uncheck the Title Bar and Scroll Bar display options in the
Document Properties dialog and give the control panel a thin
border or no border.
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9 Use Document Properties to lock the control panel document
from zooming.

10 Position the document accurately using the Ctrl+F7 (move)
and Ctrl+F8 (resize) accelerator keys.

Using Multimedia

Multimedia is an exciting and dynamic field. Opening your doc-
uments to media besides text and graphics adds new depth and
dimension to the information you present. GUIDE Author allows
you to embed animation, digital audio, and video sequences into
GUIDE documents through LOGiiX scripts.

Using multimedia in GUIDE documents isn’t complicated. Start by
deciding what media is most appropriate for your information and
audience. For example, consider this scenario: you would like to dis-
tribute a GUIDE document that teaches people to tune an automobile
engine. One of the procedures involved in an engine tune-up is
changing the spark plugs. Rather than explain it all with words, you
can link a video clip to the document through Buttons and include a
full motion demonstration of a person changing spark plugs. Readers
who want to see how it’s done can click on the Button and view the
video sequence; those who already know how to change spark plugs
can skip the demonstration.

Consider another scenario: Your GUIDE document is a language
lesson. Users read phrases on the screen and click on the phrases to
hear how they are spoken. The phrases in the text are Buttons linked
to audio recordings.

Any kind of media that can be digitized can be incorporated into
GUIDE documents. By now, most people are familiar with audio
compact discs (CDs); audio from a CD can be incorporated into a
computer application. MIDI (Musical Instrument Digital Interface)
allows you to control your own musical instrument (for example, a
synthesizer) from your computer.

Incorporating multimedia in GUIDE publications requires careful
planning and some simple programming with LOGiiX. You’ll find
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the results are worth the minimal effort involved. Typical media
devices include videodisc players, CD players, animation players,
and MIDI sequencers.

Three LOGiiX functions named mciSendString, mciGetLastError,
and mciGetErrorString give you access to the capabilities of the
Windows Media Control Interface (MCI). The MCI allows you to
work with media through a high-level interface and to control video
displays, audio hardware, videodisc players, and videotape players.
Because the MCI handles the interface between GUIDE publications
and various media and devices, you can easily add any number of
multimedia features to GUIDE documents. Please see your Windows
or Microsoft Multimedia Development Kit documentation for more
information about multimedia and the MCI.

Using LOGiiX Multimedia Functions

Windows includes the  file mmsystem.dll, which is a dynamic link
library that provides functions that enable GUIDE publications to
display multimedia files and control various multimedia devices. The
mmsystem.dll uses the MCI to translate between GUIDE documents
and multimedia components.

Three LOGiiX functions — mciSendString, mciGetLastError, and
mciGetErorString — pass text strings that instruct the MCI to play
media elements. You can also use the mciWaitNotify function with
mciSendString to execute another command while the media ele-
ment is playing. And you can use LOGiiX multimedia functions to
test the success of a procedure and to display any error messages
generated. To use the multimedia functions, simply include them in
LOGiiX scripts. For more information on LOGiiX programming, see
the LOGiiX User’s Manual.

For convenience, you might want to set up a standard Definition that
includes a routine with the new functions, then refer to that Definition
in other multimedia scripts. You might also want to make the Defini-
tion a Glossary entry so you can use it later. For more details about
the MCI functions, please refer to the documentation for Windows
or the Microsoft Multimedia Development Kit.
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Multimedia Troubleshooting

If you get unexpected results from a script or media player, you
should check to make sure that:

♦ All external hardware has power.

♦ All cables and connections are secure.

♦ You installed all required software drivers correctly.

♦ The LOGiiX scripts that correspond to various tasks are correct.
If a syntax error occurs, you should see an error message that
identifies the problem; however, if the script logic is in error (for
example, if lines are in the wrong order), you won’t see an error
message. Check the script.

Also remember to consult the documentation for equipment and soft-
ware you are using in conjunction with GUIDE publications.

Publishing Documents on the Internet

You can publish GUIDE documents on the Internet if you place them
on a World Wide Web server. This is a particularly good distribution
solution for documents that change daily, for example, government
regulations or financial data that need to be updated and distributed
each day to staff at other locations.

You can also use the protocols described in this section to publish
GUIDE documents on internal Web servers.

You can create a Reference Button in a source document linked to
target documents on an Internet server to give readers access to the
information. The source document may be on a local network, on a
computer’s hard drive, or on a CD-ROM.
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Readers must be connected to their Internet servers before they
can access documents with HyperText Transfer Protocol (HTTP)
links. If you place documents on the Internet, you must modify your
infacces.ini file to include Internet items. For more information about
editing the infacces.ini file, see “Initializing GUIDE Author” in
Chapter 2 of Welcome to GUIDE Author.

To create an Internet reference:

1 Create a Reference Button in a source document stored on your
local hard drive.

2 Pull down GUIDE Author’s Make menu and choose the Attributes
command to open the Object Attributes dialog.

3 Click on the Remote Link.

The Target Document option displays.

4 Enter the path to the target document URL (Uniform Resource
Locator) on the Internet in the following order:  the HyperText
Transfer Protocol (HTTP), server name, directory path, and
GUIDE file name.

For example, an entry could look like this:

http://www.orcas.com/regs/daily.gui

Please note that two forward slashes are required between
http: and the server name in accordance with URL protocol.

5 If you want to open the document on the Internet at a particular
Reference Point, make sure the correct Target Object ID is en-
tered in the related text box of the Object Attributes dialog.
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Figure 10-1
The Internet path is recorded in the Target Document text box in
GUIDE Author’s Object Attributes dialog

HTTP Relative Links

With GUIDE Professional Publisher, you can use relative links when
publishing your electronic documents on a Web server. Consider
the following four examples. In each case, a link has already been
established to doc1.gui and we are now linking doc1.gui to doc2.gui.
The reference for doc2.gui would be entered in the Target Document
field of the Object Attributes dialog, as explained above. The ex-
amples show where the Web server will look for doc2.gui in each
case:

/dir/doc2.gui looks for a path starting at the virtual
root of the Web server
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doc2.gui looks for the file in the same directory
as doc1.gui

dir/doc2.gui looks for the file in the subdirectory dir

../doc2.gui looks in the parent directory of the direc-
tory that contains doc1.gui

HTTP Proxy Servers

GUIDE Professional Publisher provides proxy server handling so
that you can offer access to your Web site on the Internet through
a “firewall machine.” This is done by entries in the infacces.ini file.
When you install GUIDE Author, the following section and entries
appear in the initialization file:

[remote settings][remote settings][remote settings][remote settings][remote settings]
directory=c:\guide
cache=500

where directory identifies the directory for your cache. To complete
this section of the initialization, you’d add two settings, such as:

proxy=nntest.infoaccess.com
noproxies=www.washington.edu;www.infoaccess.com;

www.planet.net

The proxy setting refers to your firewall machine. With this particular
entry, the server is nntest.infoaccess.com. However, if the URL you
are seeking specifies one of the hosts in the noproxies list, GUIDE
goes directly to that server instead.
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Troubleshooting

GUIDE Author User’s M
anual

CHAPTER 11

TROUBLESHOOTING
This chapter contains information that will help you correct actions
you didn’t mean to take. GUIDE Author includes commands to let you
cancel your most recent action and that enable you to discard any
changes to document’s content or window you make during a single
authoring session.

Using Undo

The Undo option in the Edit menu lets you reverse your most recent
action, including Undo itself.  For example, if you make a Button and
it’s the most recent thing you’ve done, you can use Undo to reverse
the action. If making the Button wasn’t your most recent action, use
the Unmake option described in Chapter 7, “Editing Objects.”  The
following actions can be reversed:

Cut
Copy
Paste
Clear
Place
Delete Frame
Cut Frame

This means that if you use any of these command options by mistake
or change your mind, you can pull down the Edit menu, click on
Undo, and GUIDE Author reverses the action.

IMPORTANT:

Undo applies only
to your most
recent action
in GUIDE Author.
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Using Revert Content

The Revert Content option in the File menu undoes any changes you
made to the active document since the last time you saved it. For
example, you may have changed a font, added a few graphics, and
made some Expansion Buttons. If you decide that you preferred the
document the way it was before you made changes during this edit-
ing session, pull down the File menu and click on Revert Content.

Using Revert Window

The Revert Window option in the File menu reverses any changes
you’ve made to the active document window size or position. When
you use Revert Window, GUIDE Author undoes any window style,
size, or position changes made since the last time you saved the ac-
tive document. To use this option, pull down the File menu and click
on Revert Window.
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