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Building a Salvo Application with
Keil's C51 C Compiler and
uVision IDE

Introduction

Before You Begin

This Application Note explans how to use Kall's
(http://www.keil.com/) C51 compiler and pVision IDE to create a
multitasking Salvo application for the 8051 family of
microcontrollers.

We will show you how to build the Salvo application contained in
\'sal vo\ ex\ ex1\ mai n. ¢ for a generic 8051 microcontroller using
the Kell tools. For more information on how to write a Salvo
application, please see the Salvo User Manual.

If you have not already done so, install the C51 and pVision tools.
With the pVision IDE you will be able to run and debug this
application in the ssimulator or on real hardware (if available).

Creating and Configuring a New Project

Create anew pVision project using Project > New Project. In the
Create New Project window, navigate to your working directory
(in this case we've chosen c:\tenp) and enter a name for the
project (we'll use nyex1) in the File Name field:
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Figure 1: Creating the New Project

Click on Save to continue. The Select Devices for Target

"Target 1' window appears. Under the CPU tab select and expand
Generic:
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Figure 2: pVision Device Selection Window with Generic
8051 Selected

Select 8051 (all Variants) and click on OK to continue.

Now let's setup the project's options for Salvo's pathnames, etc.
Choose Project > Options for Target Target 1' > C51 and
define any symbols you may need for your project in the
Preprocessor Symbols > Define area' In the Include Paths,
add\ sal vo\i nc:
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Figure 3: C51 Options for Target

Click on OK to finish configuring your project.

Adding your Source File(s) to the Project

Now it's time to add files to your project. Choose Project >
Targets, Groups, Files > Groups / Add Files, select Source
Group 1 under Available Groups, click on Add Files to
Group..., navigate to your project's directory, select your mai n. c
and click on Add. Y our project window should now look like this:

x|

=i Target1
B3 Source Group 1
- [#] main.c

" Biries [Freos | QBooks |

Figure 4: pVision Project Window with your Source
File(s)

Click on Close after you are adding source files to your project.

Creating Groups for Salvo Files

For legibility and organizational purposes, we recommend you add
additional groupsto your project to hold Salvo files. They are:

Salvo Configuration File
Salvo Libraries
Salvo Sources
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Add these groups now using Project > Targets, Groups, Files >
Groups / Add Files > Group to Add. When done, your project
window should look like this:

=

=84 Target1
ES Source Group 1
o [#] mainc
4 Salvo Configuration File
3 Salvo Libraries
[ Sakvo Sources

1 Files |ﬁ| Regs ] [:QBooks I

Figure 5: pVision Project Window with your Source
File(s) and Salvo Groups

Adding Salvo-specific Files to the Project

Adding a Library

Now it's time to add the Salvo files your project needs. Savo
applications can be built by linking to precompiled Salvo libraries,
or with the Salvo source code files as nodes in your project.

For alibrary build, a fully-featured Salvo freeware library for the
C51 compiler is sfc51sdab. |ib.? Choose Project > Targets,
Groups, Files > Groups / Add Files, select Salvo Libraries
under Available Groups, click on Add Files to Group..., choose
Library file (*.lib) under Files of type, navigate to the
\'sal vo\ | i b directory, and select sf c51sdab. | i b:

Add Files to Group 'Salvo Libraries' 2] x|
Lackin: |3 lib - & = 25

I sicE 1 lxab lib PcicEladaclh  Rsichlsdmblin

i B stcsisdmelin Esf
| S ] o f
| S o] B f
BB sfcf 1 sdtelib o f
BB <fc5 1 simalib R <f
BB <fc51siab lib B <f
BB sfcs1size lib <t

T sfcE T lxma. lib
I stcE1lkmb lib
P sfcE1lkme lib
sfch1 bdalib
I sfo5 1 Ixth lib
I sfc5 1 Ixte lib
I sfc5 1 sdaalib
P =fcs1sdab lib

schere.Ilb sfc51sdma.\|b

Lo I
File narme: |5f051 sdab lib Add
Files of type: ILibrary file (*lib) j Close |

Figure 6: Adding the Library to the Project

Click on Add, then on Close when you are finished. You can find
more information on Salvo librariesin the Salvo User Manual.

Y our project window should now look like this:
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Figure 7: Vision Project Window for Library Build

The salvocfg.h Header File

You will also need a sal vocf g. h file for this project. To use the
library selected in Figure 6, your sal vocf g. h should contain only:

#def i ne OSUSE_LI| BRARY TRUE
#def i ne OSLI BRARY_TYPE OSF
#def i ne OSLI BRARY_GLOBALS osD
#defi ne OSLI BRARY_CONFI G CSA
#defi ne OSLI BRARY_VARI ANT cSB

Listing 1: salvocfg.h for a Library Build

Create this file and save it in your project directory, e.g.
c:\temp\sal vocfg. h. We aso recommend adding it to the
project's Salvo Configuration File group using Project > Targets,
Groups, Files > Groups / Add Files, etc.

Note To add a header file (*. h) to a Group, in the Get Filetype
window you must specify that the file is of type Text Document
file for it to be accepted.

Proceed to Building the Project, below.

Adding Salvo Source Files

If you have a Salvo distribution that contains source files, you can
do a source code build instead of alibrary build. The application in
\ sal vo\ ex\ ex1\ mai n. ¢ contains calls to the following Salvo user
services.

0S_Del ay() OSl ni t ()

OS Wi t Bi nSem() GSSi gnal Bi nSem()
OSCr eat eBi nSem() OSSched()

OSCr eat eTask() OSTi ner ()

CSEi ()
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You must add the Salvo source files that contain these user
services, as well as those that contain internal Salvo services, to
your project. The Reference chapter of the Salvo User Manual lists
the source file for each user service. Internal services are in other
Salvo source files. For this project, the completelistis:

bi nsem ¢ mem c

del ay. c port 8051. c
event.c gins.c
init.c sched. ¢
inittask.c timer.c

To add these files to your project, choose Project > Targets,
Groups, Files > Groups / Add Files, select Salvo Sources
under Available Groups, click on Add Files to Group..., choose
C source file (*.c) under Files of type, navigate to the
\'sal vo\ src directory, select® the *. ¢ files listed above, and click
on Add:

Add Files to Group 'Salvo Sources'
Loakin: | sre [ ci
M array.c destroyc inittaskc msng.c
I binserm.c Pefage Pinittch.c Prmsggic [ e
B binsem?2.c Petagec Pintilc B ponsost o | BEL
Y chik.c Peidc Plicensec Pponciac s
debug = event.c mem.c punvﬁ.c sl
delay.c \dle.c msg.c priu.c ta
delayE.c \nit.c mng.c qdel.c ta
H delaydc Pinitech.c Pimsgo.c Prgins.c Pta
4| | 2l
File name: I"t\merc" "delay.c" "ewventc" "init.c" “initask o' "me Add

Files of type: IC Source file . j Close |

Figure 8: Adding Salvo Source Files to the Project

Click on Close when finished. Your project window should now
look like this:

=14 Target1

EG Source Group 1

main.c
+ Salvo Configuration File
B Salvo Libraries
=25 Salvo Sources
timer.c
delaw.c
event.c
init.c
inittask.c
mem.c
portdisl c
gins.c
sched.c

- [#] hinzem.c

N Files |@ Regs ] I;QBooks I

Figure 9: Project Window for a Source Code Build
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The salvocfg.h Header File

You will aso need a salvocfg.h file for this project.
Configuration files for source code builds are quite different from
those for library builds (see Listing 1, above). For a source code
build, the sal vocf g. h for this project contains only:

#def i ne OSBYTES OF DELAYS 1
#def i ne OSENABLE_| DLI NG_HOOK TRUE
#def i ne OSENABLE_BI NARY_SEMAPHORES TRUE
#def i ne OSEVENTS 1
#def i ne OSTASKS 3
#define OSLOC ALL data

Listing 2: salvocfg.h for a Source Code Build

Create this file and save it in your project directory, e.g.
c:\tenp\sal vocfg.h. We aso recommend adding it to the
project's Salvo Configuration File group using Project > Targets,
Groups, Files > Groups / Add Files, etc.

Note To add a header file (*. h) to a Group, in the Get Filetype
window you must specify that the file is of type Text Document
file for it to be accepted.

Building the Project

For a successful compile, your project must also include a header
file (eg. reg51. h) for the particular chip you are using. We
recommend that you include it in your project'ssal vocf g. h. For a
library build, your sal vocf g. h would look like this:

#i ncl ude <reg51. h>

#def i ne OSUSE_L| BRARY TRUE
#defi ne OSLI BRARY_TYPE OSF
#defi ne OSLI BRARY_GLOBALS osD
#def i ne OSLI BRARY_CONFI G OSA
#defi ne OSLI BRARY_VARI ANT osB

Listing 3: salvocfg.h with Target-specific Header File

With everything in place, you can now build the project using
Project > Build Target or Project > Rebuild all target files.
The build results can be seen in the Build window:
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Bui | ding targer 'Target 1'
conpiling timer.c...

conpi ling delay.c...

conpiling event.c...

conpiling init.c...

conpiling inittask.c...

conpiling nmemc...

conpi ling port8051.c...

conpiling gins.c...

conpi ling sched.c...

conpi ling binsemc...

i nking...

Program Si ze: data=46.0 xdata=0 code=1028
"nmyex1" — 0 Error(s), O Warning(s).

Listing 4: Source Code Build Results

This example uses a total of 46 bytes of RAM in the dat a space,
and 1028 bytes of ROM in the code space.

Note The library-based projects supplied in the Salvo for 8051
family distributions use \sal vo\ src\mem ¢ and the appropriate
entries in the sal vocf g. h header file to minimize the RAM usage.
See the Libraries chapter in the Salvo User Manual for more
information.

Testing the Application

You can test and debug this application using the pVision
simulator or real hardware. You launch the debugger after a
successful build by choosing Debug > Start/Stop Debug
Session.

You can use al of the IDE's supported features when debugging
and testing Salvo applications. This includes breakpoints, profiling,
watch windows, tracing, etc.
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Figure 10: Testing a Salvo Application in pVision
Debugger

Note uVision supports debugging at the source code level. Only
applications built from the Salvo source code enable you to step
through Salvo services (e.g. OSCreateBinSen()) at the source
code level. Regardless of how you build your Salvo application,
you can always step through your own C and assembly code in the
IDE / debugger.

Troubleshooting

C51 Error: can't open file 'salvo.h'

If you fail to add \ sal vo\i nc to the project's include paths (see
Figure 3) the compiler will generate errors like these:

H[Build target 'Target 1°'

T |compiling main.c. .. :l
main.c(15): error C318: can't open file 'salvo.h'
MAIN.C(28): error C132: '__0SLabel': not in formal parameter list
MAIN.C(28): error Cl41: syntax error near '_OSLabel'’
MAIN.C(33): error C132: ' 03Label': not in formal parameter list
MAIN.C({33): error Cl41l: syntax error near 'void'
MAIN.C(34): error C132: 'Taskl': not in formal parameter list
MAIN.C(34): error Cl4l: syntax error near '{'
MAIMN.C(37): error Cl3Z: 'P1': not in formal parameter list
MAIN.C(38): error C132: 'O5_Delay': not in formal parameter list
MAIN.C(39): error Cl4l: syntax error near '}’
compiling timer.c... -
ATl Bt fl] »

Figure 11: Compiler Error due to Missing \salvo\inc
Include Path
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By adding \ sal vo\i nc to the project's include path, you enable
the compiler to find the main Salvo header filesal vo. h, aswell as
other included Salvo header files.

If you fail to create a sal vocf g. h header file in the project's own
directory, the compiler will generate errors like these:

2[Byild target 'Target 1 ﬂ
T|compiling main.c...

ConBALVOSINCSBALYVO.H(279) 1 error C318: can't open file 'salvocfg.h'

MAIM.C(37): error C202: 'P1': undefined identifier

compiling timer.c...
CNEBALVOSTNCNSALYVO H
complling delay.c...

(279):

ConBALVOSINCNBALVO . H(279) : error C318: can't open file 'salwvocfg.h'
(279):
(279):

error C318: can't open file 'salvocfg.h'

compiling event.c...

CnBALVOSINCWBALYVO .H

compiling init.c...

CnBALVOSINCNSALYVO H( 279 error C318: can't open file 'salvocfg.h'

compiling inittask.c... -
K

ATATw T Buita fl3

Figure 12: Compiler Error due to Missing salvocfg.h

279 error C318: can't open file 'salvoctfg.h'

By adding the project's own directory to the project's include path,
you enable the compiler to find the project-specific header file
sal vocf g. h.

Cannot See Window Upon Opening Project

Example Projects

If you can't see a particular window after opening an pVision
project that's part of a Salvo distribution, it may be because your
display's resolution is less than that used to create the project.
Select Window > Tile Horizontal to make al open windows
visible.

Example projects for the C51 compiler and pVision IDE are found
in the \sal vo\tut\tul-6\sysi directories. The include path for
each of these projects includes \sal vo\tut\tul\sysi, and each
project defines the sysl symbol.

Complete projects using Salvo source code are contained in the
project files\sal vo\t ut\t ul- 6\ sysi\tul- 6pro. Uv2.

Complete projects using Salvo standard libraries are contained in
the project files \sal vo\tut\tul-6\sysi\tul-6le. W2. These
projects also define the MAKE_W TH_STD_LI B symbol.

Complete projects using Salvo freeware libraries are contained in
the project files \sal vo\tut\tul-6\sysi\tul-6lite. Uv2.
These projects also define the MAKE_W TH_FREE_LI B symbol.

10
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This Salvo project supports awide variety of targets and compilers. For use with
pVision and the C51 compiler, it requires the SYSI defined symbol, as well as
the symbols MAKE_W TH_FREE_LI B or MAKE_W TH_STD_L1I B for library builds.
When you write your own projects, you may not require any symbols.

This Salvo Lite library contains al of Salvo's basic functionality. The
corresponding Salvo LE and Pro library is slc51sdab.lib.

Y ou can Ctrl-select multiple files at once.
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