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Introduction
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Thank you for choosing our product, we wish you lot of fun using it. 

What is EMX ?
The EMX, also known as « Electribe MX » is a hardware audio workstation designed by Korg. It can generate synthesizer
and drum sounds, and can record patterns and songs. Go to « Korg » web site for more information.

What is DirectEMX for?
DirectEMX is a VSTi/AU MIDI plug-in that allows you to control in real-time every sound shaping parameters of the Korg
EMX in your DAW.

As a benefit of the host integration, DirectEMX provides an incredible feature set including total recall and parameters  
automation, combined with the power, stability and punchy sound of the EMX.

You must own the Korg EMX to use DirectEMX.

DirectEMX Features
- Full parameters control and automation from a VST host software (5 Synth parts and 9 drum parts)
- A clean and helpful interface specially designed for the EMX
- Total recall : The whole state of the EMX is saved in the DAW project and can be loaded back.
- System-Exclusive dumps : Get all the patterns of your EMX in the DirectEMX interface, then modify and

reverse-engineer existing patches easily.



Installation & Requirements
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Installation
To install DirectEMX on your system, simply copy the DirectEMX plugin file in your plugins directory:
- Windows:  Copy « DirectEMX.dll », the default path is « C:\Program Files\VSTPlugins »
- Mac VST : Copy « DirectEMX.vst » to /Library/Audio/Plug-Ins/VST
- Mac Audio Unit : Copy « DirectEMX.component » to /Library/Audio/Plug-Ins/Components

Requirements
PC minimum requirements:

- Pentium III 800 Mhz 
- 512 MB RAM 
- Windows XP/Vista/7 
- MIDI interface 
- VST 2.4 compliant host 

MAC: 

- OS X 10.5 or 10.6
- Intel Core Duo
- 1 GB RAM
- MIDI interface 
- VST 2.4 compliant host 



MIDI Mode
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DirectEMX features 2 midi modes: Host and DirectMidi

Host mode:
In host mode the MIDI messages are going through the host software (ie Cubase, Live…). 
Advantage:  The MIDI device is shared between the host and DirectEMX.
Disavantages:  It requires to setup host tracks correctly ; All the MIDI messages may not not be transmitted (host filtering), 
making it incompatible with DirectEMX on some cases. Sysex are not supported.

DirectMidi mode:
In DirectMidi mode the MIDI messages are directly exchanged between DirectEMX and the MIDI device (ie sound card).
Advantage: No setup is needed in the host software, all MIDI messages are exchanged including sysex, giving expanded
possibilities (Pattern name, full dumps…), and this is independant of the host.
Disavantages:  The MIDI device is dedicated to DirectEMX, but notes and midi messages that are not used by the EMX are 
forwarded to the host. Some MIDI interfaces may not be compatible as they don’t manage sysex correctly, however DirectEMX
will try to repair corrupted Sysex messages to enhance compatibility.



Setup tab
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Knob mode determines the way you 

use the mouse to control the knobs.

In DirectMIDI mode you have to 

select the MIDI device where your 

EMX is connected.

Indicates whether the 

device could be opened

This indicates if an EMX hardware has 

been detected (DirectMIDI only)

Dumps of the current pattern or 

Banks (DirectMIDI only)



Host compatibility
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DirectMIDI mode:
In DirectMIDI mode, the transmission of MIDI messages is not dependant of the Host. The only compability issue may come 
from the MIDI device used.

Host mode:

Host\Feature Integration Controller Dumps

Cubase SX v3~6

FL Studio v8 v9 Needs manual
mapping

Sonar v8

Live v8

Acid pro v7

- Integration : DirectEMX is fully functional to control, automate and recall all the parameters of the EMX.

- Controller : The Korg EMX can be used as a midi controller and DirectEMX interface is automatically updated when 
a parameter value changes. Also EMX internal motion sequences can be seen on DirectEMX interface. 

- Dumps : It is possible to dump pattern banks (or just current pattern) from the EMX by receiving MIDI Sys-Ex 
message in DirectEMX.

DirectEMX mostly rely on MIDI message. You may 
encounter some compatibility issues with some hosts 
that does not manage MIDI messages properly.

Here is our non-exhaustive compatibility chart, you 
may get the last updated version at 
www.directsynth.com (support section).

http://www.directsynth.com/


EMX Configuration
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As DirectEMX relies on MIDI communication, your EMX must be properly connected and configured:

• Use a MIDI cable to connect the MIDI OUT connector of your sound card to the EMX’s MIDI IN connector.
• Use a MIDI cable to connect the MIDI IN connector of your sound card to the EMX’s MIDI OUT connector.

Make sure the MIDI configuration of your EMX is set to the factory settings: (Refer to the MIDI mode section of your EMX manual)

Synth Parameter CC

Osc type CC#70

Osc Edit1 CC#14

OscEdit2 CC#15

Glide CC#5

Filter type CC#83

Filter cutoff CC#74

Filter resonance CC#71

Filter Eg int CC#79

Filter drive CC#84

Level CC#7

Pan CC#10

Eg Time CC#75

Amp Eg CC#86

Synth Parameter CC

Roll CC#85

Fx send CC#91

Fx select CC#81

Mod type CC#87

Mod depth CC#90

Mod speed CC#89

Mod dest CC#88

Mod bpm sync CC#82

Motion seq sw CC#80

Global Parameter CC

FX Chain CC#23

FX1 Parameter CC

FX Type CC#12

FX Edit1 CC#92

FX Edit2 CC#93

FX Motion Seq sw CC#20

FX2 Parameter CC

FX Type CC#13

FX Edit1 CC#94

FX Edit2 CC#95

FX Motion Seq sw CC#21

FX3 Parameter CC

FX Type CC#24

FX Edit1 CC#25

FX Edit2 CC#26

FX Motion Seq sw CC#22

Parts Channels

Synth1 1

Synth2 2

Synth3 3

Synth4 4

Synth5 5

Drums 10

MIDI Filter Value

PCEN oooo



DirectEMX Interface
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How to use in hosts: general rules
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DirectMIDI mode:
•This mode is enabled as default in DirectEMX
•Make sure the MIDI device where you have connected your EMX is not used by the host software. You will have to disable it
from a setting menu.
•To send notes from the host to the EMX, create a midi track and select input/output to DirectEMX plugin. Then use 1~5 
channels for Synth parts, and 10 for drums.
•For automation, it works the same way than in host mode, you may refer to host mode configuration pages.

Host mode:
•As the default mode is DirectMIDI you will have to select « Host » In DirectEMX.
•Make sure the MIDI device where you have connected your EMX is enabled the host software.
•To send notes from the host to the EMX, create a midi track and select output to the MIDI interface where your EMX is
connected. Then use 1~5 channels for Synth parts, and 10 for drums.
•This mode is not available for the Audio Unit version.



How to use with Cubase
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1. Add « DirectEMX » VST by using the « Devices->VST Instruments » menu (or F11 key). 

2. In DirectEMX select the MIDI interface where your EMX is connected.
If the devices could be opened and that the EMX hardware had been detected then you should be able to 
control the EMX from DirectEMX and vice versa.

3. To send notes to the EMX, create a MIDI track, then send Input and output to « DirectEMX ». Then use 
1~5 channels for Synth parts, and 10 for drums.

4. For automation expand the « VST Intruments » and « DirectEMX » tracks and select
one or more parameters to automate.

DIRECT MIDI MODE



How to use with Cubase (1/2)
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1. Add « DirectEMX » VST by using the « Devices->VST Instruments » menu (or F11 key). In DirecEMX click 
on « Host » to change midi mode 

2. Add a MIDI Track and set « IN » to « DirectEMX », and « OUT » to your midi interface where the EMX is 
connected (« Multiface Midi » in our case). Also set « Channel » to « ANY ».

This midi track will send midi from DirectEMX to the EMX. We have renamed this midi track to « EMX 
Send ».

3. You should now be able to control the EMX from DirectEMX. Confirm the « Sync now? » question from 
DirectEMX interface. This will transmit the current pattern to the EMX.

On your EMX select the first synth part. Now change the filter type of the first synth part from DirectEMX. 
You should see that it is also changing on the EMX. If not, check your midi interface and cables. Also the 
midi track has to be selected with the record button enabled (red).

HOST MODE



How to use with Cubase (2/2)
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4. Now we are going to enable the control of DirectEMX from the EMX.
Add another MIDI track. Set « In » to the MIDI interface where the EMX is connected (« Multiface Midi » 
in our case). Set « Out » to « DirectEMX ». Set « Channel » to « ANY ». Rename this track to « EMX 
Receive »

5. Now enable the record buttons for both midi tracks.

IMPORTANT : Always make sure these 2 buttons are enabled, else the midi sync with the EMX will not 
work.

Turn a knob on the EMX, it moves in the DirectEMX interface! (make sure you are working on the same 
part between the EMX and DirectEMX, else you won’t see the visual feedback).

Now you should normally be able to control the EMX from DirectEMX and vice-versa.

6. For automation expand the « VST Intruments » and « DirectEMX » tracks and select
one or more parameters to automate.

HOST MODE



How to use with Live (1/2)
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1. In « Options->Preferences->MIDI » make sure your midi interface is set to « OFF » for tracks Input/Output.
In our case, the midi interface where the EMX is connected is « Multiface Midi »

2. Create a midi track and rename it to « DirectEMX »,
then set « Midi from » to « No input »

3. In the left browser select the Plug-in tab and drag&drop DirectEMX
to the MIDI track.

4. In DirectEMX select the MIDI interface where your EMX is connected.
If the devices could be opened and that the EMX hardware had been detected then you should be able to 
control the EMX from DirectEMX and vice versa.

DIRECT MIDI MODE



How to use with Live (2/2)
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5. To send notes to the EMX, create another MIDI track, rename it to « Synth1 »
Set « MIDI from » and « MIDI To » to DirectEMX.
Select Track-In to « 1-DirectEMX » (Note: select 1~5 for synth parts, 10 for the drums)

6. Set Monitor to « Auto » when you want to send notes from Live sequencer
Set Monitor to « In » when you want to send notes from a MIDI keyboard

7. For parameters automation, first move the desired parameter in DirectEMX interface,
then it will appear in the parameters list.

DIRECT MIDI MODE



How to use with Live (1/2)
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1. In « Options->Preferences->MIDI » make sure your midi interface is set to « ON » for tracks Input/Output.
In our case, the midi interface where the EMX is connected is « Multiface Midi »

2. Create 2 midi tracks. Rename the first one to « DirectEMX » and the other
one to « EMX Send ».

3. In the left browser select the Plug-in tab and drag&drop DirectEMX
to the first MIDI track. In DirecEMX click on « Host » to change midi mode

4. In the DirectEMX track, set « Midi from » to « No input »
In The EMX Send track, set « Midi from » to « DirectEMX »,
Monitor « IN » and « MIDI to » to your midi interface (multiface in our case).

You should now be able to control the EMX from DirectEMX. Note that on Live
the channel is set in the midi track, not in DirectEMX. To control drum
parts select channel 10.

You can try to change the Synth 1 part filter type from DirectEMX, it should change on the EMX.
(Select channel 1 in Live and select the synth 1 part in the EMX).

HOST MODE



How to use with Live (2/2)
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5. If you want to control DirectEMX from the EMX, add a third MIDI track, rename it « EMX Receive »
Set « MIDI from » to your midi interface (Multiface midi in our case),
Set Monitor to « IN » and « MIDI To » to DirectEMX.

Turn the Cutoff knob of the Synth 1 part from the EMX, it should move
in the DirectEMX interface.

Note: In the EMX Receive track, change the « Track In » parameter to select the channel you want to use.

6. For parameters automation, first move the desired parameter in DirectEMX interface,
then it will appear in the parameters list.

Known bugs due to Live wrong MIDI NRPN management:
- When sending Mutes from the EMX, sometimes a part mute will not have the right value on DirectEMX.
- If a « Drum wave » send by the EMX is not received by DirectEMX, try sending the « Drum 6A wave » then

the « Drum1 wave ». Then it should work.

HOST MODE



How to use with FL Studio (1/2)
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1. Add « DirectEMX » VST by using the « Channels->Add one » menu.
If « DirectEMX » is not in the list, use the « More… » item to add new VST
instruments. (refer to your FL Studio manual).
In DirecEMX click on « Host » to change midi mode 

2. In Options->MIDI settings, associate a port number to the midi interface where the EMX is connected. 
« Multiface Midi » in our case, and we have selected port « 0 ».

3. In DirectEMX left menu, select « Show MIDI output port », then on the right select port « 0 »

Now DirectEMX  should be able to control the EMX. Change the filter type of the first synth part in 
DirectEMX, it should also change on the EMX (make sure the first synth part is also selected on the EMX).

HOST MODE



How to use with FL Studio (2/2)
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4. You can also use the EMX to control DirectEMX but this has to be configured manually. This is due to FL 
Studio midi parameters management.
For example:

• Move the Synth 1 part Cutoff knob on DirectEMX
• On DirectEMX left menu, select « Last tweaked parameter »

then « Link to controller ».
• Now turn the cutoff know on your EMX
• You should see it moving on the DirectEMX interface.

5. For parameter automation use DirectEMX left menu, then
select « Browse parameters ». All the parameters will show up
on the left list.

6. If you want to send notes to each part, we suggest not to use the « Midi out » plugin provided with fl 
studio because it will send level and pan midi messages. Instead you can find on the web free vst
« midi out» plugins for that.

HOST MODE



How to use with Reaper (1/2)
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1. In Options->Preferences, then in MIDI Devices, check that the device connected to the EMX 
("multiface" in my case) is "Enabled+Control" (for midi in) and "Enabled" (for midi out). 

2. Track->Insert virtual Instrument on new track. Then select DirectEMX. In DirecEMX click on 
« Host » to change midi mode

HOST MODE



How to use with Reaper (2/2)
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3. In the new track click on the small "io" button, then select your midi device in "Hardware output" 

4. Select Synth1 part on both the EMX and DirectEMX, if you turn a knob on the EMX you should see it moving in 
DirectEMX. Then in DirectEMX change the filter type, you should see the led changing on the EMX

HOST MODE



How to use with Sonar
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1. Create a new blank project

2. In Options->Global->VST Plug-ins, make sure that a folder 
points to a location where you have copied DirectEMX.dll

3. Insert->Soft Synths->DirectEMX ; make sure that "Simple 
instrument track" and "Enable MIDI output" are checked.
In DirecEMX click on « Host » to change midi mode

4. On the created track, set the INPUT to the midi interface that is 
connected to the EMX, select omni channel. From this point 
you should be able to control DirectEMX from the EMX. For 
example, move the cutoff knob of Synth1, you should see it 
moving on DirectEMX.

5. Insert->MIDI track ; Set INPUT to "DirectEMX 1 - Omni" ; Set 
OUTPUT to the midi interface where is connected the EMX. You 
should now be able to control the EMX from DirectEMX. For 
example, change the filter type of Synth1 in DirectEMX, you 
should see the led changing on the EMX.

6. Make sure you have enabled the « Input echo » button on both 
tracks

HOST MODE



How to use with Logic
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1. Add « DirectEMX » Audio unit by adding a software instrument track. Then Click on I/O and select
« AU MIDI-controlled effects -> DirectSynth -> DirectEMX »

2. In DirectEMX select the MIDI interface where your EMX is connected.
If the devices could be opened and that the EMX hardware had been detected then you should be
able to control the EMX from DirectEMX and vice versa.

3. To send notes to each part of the EMX, create another instrument track (In this example we’ll send
to Synth2), then go to Logic menu « Windows->Environment »

4. Click on the upper arrow of the new track (here « Synth 2 ») and link to the DirectEMX track. Then
set the midi channel, here we set 2 for synth 2. (1 to 5 for synths, 10 for drums)

Audio Unit / DIRECT MIDI 
MODE



MIDI Dumps (1/2)
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MIDI Dump is a feature that makes it possible to get the whole EMX content in DirectEMX.
The 256 patterns can be dumped by banks of 64 (A, B, C, D).

Once dumped, the content of the patterns are available in DirectEMX. This enables the user to analyze or 
modify them easily. Also the patterns can be saved and retransmitted to the EMX.

This feature is not available on every host software. You can refer to the host compatibility chart for more 
information.

1. Open your host software and configure a track so that MIDI is sent to DirectEMX
2. On the EMX, press the MIDI Key (the key will light)
3. Hold down the shift key and press step key 12 (MIDI utility)
4. The value display will indicate « Filter ». Turn the dial to change this to « Dump », and press key 12
5. Turn the dial to select the data you want to transmit (PtBnkA, PtBnkB, PtBnkC or PtBnkD)
6. Press key 12 once again to transmit the data.
7. Wait about 2 minutes, then you should see the « Accept pattern bank » question on DirectEMX

8. Once accepted you will have access to the patterns from the patch list of the plugin.

HOST MODE



MIDI Dumps (2/2)
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To use the Dumps in Cubase check the following:

- Go in Preferences -> MIDI -> MIDI Filter
- Make sure that « Sysex » is unchecked.

HOST MODE



Contact
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- For any news or updates : www.directsynth.com

- For any questions or support : support@directsynth.com

http://www.directsynth.com/
mailto:support@directsynth.com

