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Introduction
The Raptor HDx uses the same proven technology base as the standard definition Raptor X and 
earlier Raptor HD products that total nearly 200 in use around the world. The HDx can be 
operated from a 12VDC battery for easy integration into smaller carts and more run-and-gun 
systems used by commercial video assist operators. The input voltage range is 10-16VDC with a 
current draw of about 5 amps during normal operation; the deck can draw up to 7 amps during 
start-up.

The Raptor HDx uses a single 3.5-inch fixed internal 2TB hard drive, which can hold about 60 
hours of high quality HD material. The HDx records .avi files using a highly efficient Motion-
JPEG codec that has a variable quality setting, balancing picture quality and recording time to 
best suit the job requirements. The application software (version 2.2.2.6 and above) also records 
standard definition DV codec .avi files, allowing for about 150 hours of SD video that is fully 
FCP-compliant.

The front panel of the HDx resembles the popular standard definition Raptor 50VA, but currently 
does not support all of the same advanced playback functions, such as jog/shuttle. The HDx was 
designed to be operated primarily with an attached VGA monitor and USB keyboard & mouse.

Since the Raptor HDx is designed around an internal computer running a custom version of 
Windows XP Embedded, the system has a boot-up time of about 60 seconds. We recommend that 
the HDx be powered from a UPS (uninterruptable power supply), if using the factory-supplied 
AC to DC power supply. This can help prevent sudden reboots, since power can be interrupted 
frequently in the hectic production environment.
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Common Tasks
This section shows how to complete common tasks. Please refer to the Main Interface section for 
details concerning specific controls and features.

Connections
Please refer to Appendix C, page 40 for information on the various connectors and I/O ports on 
the Raptor HDx. Also, the Raptor HDx ships with a breakout cable; see page 41.

Video Input
It is necessary to set the video input in the software application. If you know exactly what your 
input signal is (interface, resolution, framerate), you can set it directly. Otherwise, the Raptor 
HDx provides a mechanism to detect the resolution and framerate for a given input. The HDx 
must be set to “Live” to allow video input to be set.

Auto-detection

Simply pull down the Options menu, open the 
Video Input sub-menu, open the sub-menu 
corresponding to your video input, and select 
Auto-detect.
Auto-detection for SDI is shown to the left.

Auto-detection can also be activated via the Front 
Panel: OPTION + RECORD + >>.

For more information, see Auto detection on page 23.

Changing Input Manually
The Raptor HDx supports a wide variety of formats for video input. These are accessed via the 
Options > Video Input menu. Please see Video Input on page 23 for more information.

Audio Input
The Raptor HDx supports both XLR analog audio input and Embedded audio. These can be 
selected in the Options > Audio Input menu (see page 25).



Raptor HDx User Manual 7

Backup Clips
The Raptor HDx provides a mechanism for copying the data on the internal drives to an external 
storage device, in such a way that it can be restored to the deck in the event of data loss. 

1. Plug in your USB drive.

2. Pull down the File menu.

3. Select Backup deck.

The following window will appear.

On the left side of this window,

4. In Source, select [Internal storage].
5. In Destination, select your external drive 

by its drive letter (probably D). If it is not 
listed, close this window and return to step 
1.

6. Choose the Backup deck tab to copy 
everything, or choose the Copy clips tab to 
copy individual clips (hold CTRL and left-
click clips to select multiple clips at a 
time).

If it is uncertain how much time is available to 
perform the backup operation, consider checking 
the box to skip very large files (larger than 5GB), 
which is located on the right side of the window. 
Generally, the backup can be interrupted with the 
Stop copy button; however, once the deck starts 
backing up a large file, it cannot be interrupted.

Finally, click the Start copy button.

The status will be shown in the large pane on the 
right side of the window.
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If the copy must be stopped, simply click the Stop 
copy button, which is enabled when a copy 
operation is in progress.

When everything is finished, close the Backup 
window.

Delete Clips
There are two ways to delete clips – manually select clips to delete using Windows, or delete all 
clips from the application. There are safeguards in place to avoid accidental deletion.

Selecting Clips Manually using Windows

First, open Windows Explorer on the Local Disk:

1. Open the Tools menu.

2. Select the last item, “Launch Windows 
Explorer on local disk.”

This opens to E:\RXVideo, which contains all of 
the video recorded on the deck.

Simply delete the .avi files representing the 
video you wish to delete. The file names follow the 
following format: Scene_Take_Camera.avi
After deleting the files, close Windows Explorer 
and return to the Raptor software.

Since clips were deleted, it is advisable to force the 
software to re-read the clips from disk (see page 
11).

file:///E:/RXVideo
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Deleting All Clips
This section describes the procedure to delete all clips from the deck using the software 
application. This is useful when starting a new job and reclaims all available storage on the deck. 
Note that it is also possible to delete all clips via the manual method described above.

1. Open the File menu.

2. Select Delete all clips from this deck.
This produces the following dialog box.

To continue with the process of deleting all clips 
on the deck, you must select “Yes” – if you select 
“No” the process will be aborted immediately.

Upon selecting “Yes” in the previous dialog, this 
dialog appears. This is your final confirmation – 
enter the number of clips on the deck to confirm 
deletion. Then select “OK” – if you select 
“Cancel” the process will be aborted immediately.
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This dialog is the last chance to abort the delete 
process. Select “Yes” to delete all clips or “No” to 
return to the application.

A final dialog will show the progress of the delete 
process, which could take some time, depending 
on the number and size of clips on the deck.

Rename Clips
There is currently no feature within the application software that allows the renaming of recorded 
clips. If you wish to rename recorded clips, follow these instructions.

1. Open the Tools menu.

2. Select “Launch Windows Explorer on local 
disk.”

This opens My Computer at the video folder, 
E:\RXVideo. This folder contains .avi video files, 
as well as .txt and .ini files that are used to store 
clip attributes.

Example:

102A_13_A.avi

Final:
103_01_A.avi

3. Locate the video file that represents the clip 
you wish to rename. The naming 
convention is: Scene_Take_Camera.avi

4. Click the file name once to edit it, and 
follow the same naming convention: 
Scene_Take_Camera.avi
The filename may not contain spaces, and 
you must use the underscore character to 
separate scene, take, and camera ID.
The take should be a number.
The camera ID should be a capital letter 
and be valid for the deck setup you are 
using.
Also, do not remove the .avi at the end of 
the file name.

5. Close Windows Explorer (red X button in 
upper right corner).

6. Notify the application of the new name by 
Re-reading clips (instructions below, page 
11).

Scene name Camera ID

Take number

file:///E:/RXVideo
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Re-Read Clips on Local Deck
It is necessary for the deck to re-read clips if they are copied directly to the video folder or 
moved, renamed, or deleted.

1. Open the File menu.

2. Select “Re-read clips on local deck.”

This can take some time (up to a couple minutes), 
and the main status block contains a rough count 
of how many clips have been processed during the 
re-read process.
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Technical Specifications

Supported Modes
• High Definition:

◦ 720p @ 50, 59.94 and 60

◦ 1080PsF @ 23.98 and 24.00

◦ 1080i @ 50, 59.94 and 60

• Standard Definition: NTSC and PAL

Video I/O
• HD-SDI, HDMI, Component, Composite, Y/C

Audio I/O
• Two-channel balanced XLR analog

• Two-channels of HD-SDI & HDMI embedded audio

Internal Storage
• 2TB Hard drive

Power
• 10-16VDC; optimal 5-6A @ 12VDC

• Uninterruptible Power Supply (UPS) strongly recommended

Weight and Dimensions
• 2U chassis (8.5” W × 3” H × 13” D / 21.59 cm W × 7.62 cm H × 33.02 cm D)

• Weight: 8 lb. (3.63 kg)

Optional Accessories
• 15-pin VGA Monitor, USB keyboard (US layout) & mouse

• Gigabit router (Linksys RVS4000 or equivalent) and Cat5 cables

• HD-SDI Reclocking Distribution Amplifier (suggested AJA model HD10DA)

• 3rd Party HD-SDI capable video monitor (please ensure 24-frame compatibility)
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Main Interface
This is the main application window. The sections that follow detail its contents and operation.

Source List

Machine
Controls

Clip Attributes

Deck Status
And

Video Window

Miscellaneous Options & Status Quick Mix
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Deck Status

Audio Level (VU Meters)
The VU meters measure the audio levels in both channels of audio, scaled logarithmically from 
-50dB on the far left to +3dB on the far right.

Monitor (Video Window)
The video window shows the video corresponding to the current state of the deck. In Live and 
Record, it shows a passthrough of the input. In any of the playback states, it shows the video 
accordingly (play, pause, scrubbing).

Double-click anywhere on the video window to change to an enhanced view, in which the video 
window takes up the majority of the screen. Double-click again to return to normal view.

Normal video window Enhanced video window
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Timeline
The timeline shows information about the clip currently cued (it is blank in Live):

Deck Status block
The title of the Deck Status block contains information about the current video format (see Deck 
Status screenshot above). This includes the interface (SDI), resolution (1280x720), frame/field 
rate (59.940), and audio input (XLR analog audio).

The first main line of the status block displays the current motion state, which can be Live, 
Recording, Play, and will also show special operations during startup, when copying clips, and 
when an error occurs.

Finally, the status block shows the current clip name. In Live, this will be the name of the next 
recorded clip; in playback mode, this is the name of the cued clip.

The remaining recording time is displayed in the Machine Controls area (see p. 15).

Machine Controls

Playback: Play
Press the Play button to play/pause the cued clip. (Keyboard shortcut: SPACE)

Playback: In & Out
Press In or Out to seek to the In-point or Out-point of the clip. If these have not been specified, 
they are the first and last frames, respectively. (Keyboard shortcut: I / O)

Time from In-point
Time from Out-point

Current PositionIn-point Out-pointBookmarks

Head End
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Playback: 1s
Press 1s (on the left side of Play) to move one second toward the head of the clip (if the current 
location is less than one second from the first frame, it will move to the first frame). Likewise, 
press 1s (on the right side of Play) to move toward the last frame of the clip (again, if one second 
past the current location is beyond the last frame, it will move to the last frame). (Keyboard 
shortcut: Ctrl + Left arrow / Ctrl + Right arrow)

Playback: 1f
Similar to 1s, 1f moves in frame increments.
(Keyboard shortcut: Left arrow / Right arrow)

Playback: B
Press B to navigate backward (left of Play button) or forward (right of Play button) between 
bookmarks. Bookmarks are represented by a small diamond above the timeline (see page 15). 
(Keyboard shortcut: Tab (forward) / Shift + Tab (backward) )

Recording: Time Available
In the heading area of the recording controls, an estimate of the remaining recording time is 
displayed in hh:mm:ss format. This is based on remaining disk space and the data rate of the 
current video format.

Recording: Live
Press Live to get ready to record. In Live, the deck passes the input to its outputs, including the 
Monitor video window. (Keyboard shortcut: Ctrl + L)

Recording: Record
Once in Live, the Record button is enabled. Press it to begin recording immediately. Its border 
will flash to indicate that the deck is recording. (Keyboard shortcut: Ctrl + R)

Recording: Abort
During record, it is possible to abort a recording. As a safeguard against an accidental abort, you 
must first enable the Abort button by pressing Enable abort; after this, you can abort the 
recording with no further confirmation by pressing Abort.

Recording: In, Book, Out
During record or playback, these three buttons can be used to place markers in a clip's timeline. 
In marks the current frame as the in-point of the clip; Book places a bookmark at the current 
frame; Out marks the current frame as the out-point of the clip. See also Timeline, 15. Note that 
a clip can only have one in-point and one out-point, but an unlimited number of bookmarks. 
(Keyboard shortcuts for In, Book, Out: I / B / O)
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Source List

The Source List maintains the list of clips on the deck. To refresh the listing, use the Re-read 
clips function (see p. 11). The various columns present the information that can be set in the Clip 
Attributes area (described below), in addition to the date and time of the recording and its 
length. In the lower right corner, the total number of clips present is shown along with their 
combined length.

Sorting
The list may be sorted by clicking the column header (Scene-Clip-Take, Print, Speed, Notes, 
Created, Length, Resolution, and Rate).

Searching
The list may also be searched, using the controls in the upper-left corner of the list:

1. Enter your query in the text box.

2. Select a direction to search, starting at the currently-selected clip (Up or Down).

3. Press the Find button. Successive presses will continue searching through the list until 
the end is reached. (Keyboard shortcuts: Ctrl + F and F3)

It is also possible to jump from scene to scene using the Prev scene and Next scene buttons.

Filters
In the lower-left corner of the source list are controls for filtering the list. You can select either a 
date or scene, or both, and only show clips that match these criteria.

Press Clear filters to return to a full list of all clips present on the deck.
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Clip Attributes
This information area, located in the lower left portion of the application window, displays 
information regarding the current clip (in cued/playback state) or the clip about to be recorded 
(in Live).

The Scene and Take may be set.

Any Notes may be added to help identify or describe the clip. In some cases, additional 
information may be reported in the Notes field of a clip.

The Speed setting allows for off-speed playback and recording; the base framerate is given as a 
reference to the right of the box (see also Preferences: normal camera rate, p. 28).

The JPG Q setting allows fine-tuning of the quality of the Motion JPEG recording (this is a 
number, from 45-95). A higher JPG Q number causes recordings to occupy more space on the 
disk, which reduces the remaining recording time available. For DV AVI (the default in SD), this 
setting has no effect.

The Rehearsal and Print take checkboxes allow you to mark clips accordingly; these do not 
affect the recording itself.

Miscellaneous Options & Status

Network Master
For networked operation, this box may be checked to declare that this deck is the master deck. It 
will then list all the other decks on the local network, and allow this deck to synchronize their 
operation. If the deck is connected to the network, the text may change to “Another deck is 
master” to indicate that a network master is already present. See Network Operation, p. 31.

Loop Playback
If checked, when a clip is played and the out-point (could be the end of the clip) is reached, the 
deck will locate to the in-point of the clip (if not specified, then the first frame) and continue 
playback.
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Camera ID
This feature is useful for multi-camera operation, with a deck capturing the output of each 
camera. The decks can be connected together in networked and synchronized operation, or 
operated independently. The Camera ID is saved in the file name of the clip, so it is very easy to 
identify them later, even if the clips are all consolidated into the same location for review or 
editing.

Network Status
In the lower-right corner of the application window, the network status is displayed. It consists of 
the following components:

Connection Status will read “CONNECTED” or “DISCONNECTED.”

IP Address shows the current IP address (if connected), or 127.0.0.1 (if disconnected).

Network Name is “RHD” followed by a 4-digit serial number.

This entire status line is shown in boldface when the deck is part of a networked setup
(see p. 31).

Connection Status IP Address Deck name on network
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Quick Mix

Quick Mix is used to overlay a still frame (either selected from video on disk or a JPG image) 
over either live or previously-recorded video. The Quick Mix panel is initially hidden – simply 
click “^ Quick Mix” on the bottom edge of the screen to expose these settings.

Controls
To use the mixer, check the box labeled Enable mixer.
Grab plate will use the current frame as the background plate.

Locate to plate will seek to the clip and frame the current plate was taken from.

Plate settings
Scale is a percentage value used to size the plate.

Opacity is a percentage representing how strongly the plate is overlaid onto the video.

Position offsets may be specified here, relative to the upper left corner.

Crop settings may also be specified.
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File Menu
The File menu contains operations that apply to the deck and the clips on it.

Backup deck & Copy clips Provides clip backup and clip copying to external 
media (see Backup Clips, p. 7).

Burn DVD Launches an application that can be used to write 
data from the deck to DVD (requires external USB 
DVD writer to be connected).

Eject DVD Provides a convenient way to eject any disc in an 
external DVD drive, if present.

Export Clip List Saves a simple text file containing all of the 
information in the Source List (see p. 17) to a 
location of your choosing.

Re-read clips on local deck Scans the video folder, recognizing clips and 
refreshing the source list. (see also Source List, p. 
17; and Re-read clips, p. 11)

Re-read clips on remote decks When connected to a network of Raptor HDx 
decks, scans the other connected decks for linked 
clips.
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Delete all clips from this deck Restores the deck to an empty state, reclaiming its 
full capacity and removing all video.

Restart deck A soft reboot of the operating system and 
application software (will not power-cycle).

Shutdown deck Shuts down the deck gracefully. The deck must 
then be powered up by disconnecting and 
reconnecting the power supply.
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Edit Menu

Delete Current Bookmark
When a clip has been cued and there is a bookmark at the current location, this menu item will be 
enabled. Click to remove the bookmark at the current frame.

Options Menu

Video Input Sub-Menu
The Video input menu. Subsequent instructions 
will refer to the sub-menus contained in the Video 
input menu.

Auto-detect video input (all)

Each input video type supports auto-detection of 
the input video format. Simply choose Auto-detect 
from the appropriate sub-menu.

An example for SDI Auto-detection is shown to 
the left.
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SDI

SDI, or Serial Digital Interface, can carry multiple 
signal formats.

Select the desired input resolution and framerate to 
change the Raptor HDx video format.

Component

The Raptor HDx supports component video.

Select the desired input resolution and framerate to 
change the Raptor HDx video format.

HDMI

The Raptor HDx supports HDMI input.

Select the desired input resolution and framerate to 
change the Raptor HDx video format.

Y/C

The Raptor HDx supports Y/C input.

Select the desired input resolution and framerate to 
change the Raptor HDx video format.
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Composite

The Raptor HDx supports composite input.

Select the desired input resolution and framerate to 
change the Raptor HDx video format.

Audio Input Sub-Menu
The Audio Input sub-menu allows you to choose between XLR analog audio and Embedded 
audio. Default: XLR analog audio.

Downconverter Sub-Menu
The Raptor HDx has a hardware downconverter, 
which is enabled by default. This sets the SDI 
output adjacent to the input (see Rear Panel, p. 40) 
to the down-converted signal specified:

• Letterbox 16:9

• Anamorphic 16:9

• Center-cut 4:3

• None (no down-conversion)

Once set, also specify the analog video output:

Analog video output Sub-Menu
The Raptor HDx application controls which type 
of analog signal is sent over the breakout cable: 
Component, Y/C, and Composite.

Simply select the desired format.

The Raptor HDx will only allow one type of 
analog video output at a time.

Loop Playback
When enabled and a clip is playing, when the out-point is reached, it will seek to the in-point and 
continue playback. See Miscellaneous Options: Loop Playback on page 18.
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Show Big Video Window
Select this menu item to enable the enhanced video window display. This feature is equivalent to 
double-clicking on the Monitor window and is also accessible via the Ctrl+W keyboard shortcut. 
Please see page 14 for more information.

Combine matching clips in list for sync playback
This feature applies only to networked operation. When checked, it will consolidate the source 
list (see p. 17) to account for clips that were recorded in sync on different cameras during 
previous networked operation. It will then be possible to have synchronized playback of these 
clips across multiple decks. See page 31 for a more complete description of networked operation.

Screen Resolution
To change the screen resolution:

 1. Open the Options menu.
 2. Open the Screen resolution sub-menu.
 3. Select the desired resolution from the list. 

Only resolutions supported by the currently-
attached monitor are listed.

The resolution change is not saved for the next 
power-up; the application will use the highest 
available resolution it can recognize when it starts.
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Preferences

Auto-check network master at 
startup

When checked, this deck will become a network 
master every time it starts up (see Network Master, 
p. 18 and Network Operation, p. 31).

Show Quick Mix controls Toggles showing the Quick Mix control panel 
below the source list (see Quick Mix,p. 20).

Show single field when paused Displays only one field of video in pause mode. 
Default: checked.

Record NTSC or PAL to DV AVI files Use DV instead of Motion JPEG for both NTSC 
and PAL recordings. Default: checked.

Show Recording status in maroon Change text color of “Recording (00:00.00)” in 
Status Block to a dark red color (when un-checked, 
the text is blue). See Deck Status Block, page 15.

Don't change list sort order on FP 
button press

Normally, doing playback using the front panel 
causes the source list to sort by date created. This 
option allows you to avoid that behavior.

Clear notes on scene changes If checked, when the “scene” text box contents 
change, the notes field will be cleared. Default: 
checked.
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Show IP address on front panel This causes the IP address to be displayed on the 
front panel Pause + Out keypress instead of the 
deck name. This is useful if you manage the deck 
using Remote Desktop for Mac.

Don't scan external media for clips Suppress scanning external media when they are 
attached. Default: scan external media.
Note: this prevents clip backup to USB hard 
drives.

Save audio flags to notes Save notes about audio input status (e.g. only one 
channel, muted audio, etc).

Generate ALE files for Avid ALE files are generated when a clip is recorded 
with valid timecode present. Avid will then import 
this original timecode with the supplied ALE.

Reset all preferences to factory 
defaults

Resets all preferences, setting only Show single 
field when paused, Record to DV AVI files, 
Clear notes on scene changes, and camera speed 
to 24fps. This requires restarting the deck to save 
all settings.

Normal camera rate for off-speed calculations

Select the base rate of the camera for calculations 
of off-speed operation. Three rates are supported: 
24, 25, and 30fps.
Once set, the base rate is shown in the Clip 
Attributes area next to the Speed box (see p. 18).
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VFX Menu

Locate to plate frame When using a background plate, seeks to the clip 
and frame the current plate was taken from.

Clear mixer settings Clears mixer settings to 0 except: scale 100% and 
opacity 50%.

Choose image to use for 
background plate

Allows inclusion of a JPG image for the 
background plate by browsing the RXVideo folder 
on the deck.

Capture still Saves the current frame to JPG.
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Tools Menu

Set Date and Time This opens the Windows dialog to set the system 
date and time.

Launch disk speed test This utility tests the data transfer rate of the 
internal disk(s).

Launch Decklink control panel This utility allows configuration of the Decklink 
HD Extreme video card.

Launch Remote Desktop This starts the Windows Remote Desktop client, 
which can be used to directly control other decks 
on the network.

Launch Disk Defragmenter If necessary, the disks may be defragmented. This 
is not normally needed.

Launch video disks error check 
(quick)

Provides basic drive diagnostics. This check 
requires the application to be closed, and after the 
check is complete, the deck will restart. After 
selecting this menu item, there is a warning and 
confirmation to proceed.

Launch detailed hard drive testing 
tool (slow)

This is a thorough disk check (not repair). It also 
requires the application to be closed and the deck 
to be restarted (after the testing is complete). After 
selecting this menu item, there is a warning and 
confirmation to proceed.

Launch Windows Explorer on local 
disk

Opens My Computer in the video folder 
(E:\RXVideo).
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Help Menu

The first item, Keyboard Shortcuts, provides the identical resource as is available in Appendix A, 
p. 37.

The remainder of the Help Menu displays information concerning the version of the application. 
This information may be requested when contacting Playback Technologies for support.

Networked Operation

Equipment and Wiring
It is recommended to use a single Gigabit (10/100/1000) router (such as the Linksys RVS4000), 
and one (1) Cat5 cable for each deck connected. It is not recommended to connect the router to 
the Internet, or to connect Raptor HDx decks to an existing router that is used by other computers 
and to access the Internet.

Setup
1. Connect all the cables to the router.

2. Choose one deck to be the central point of control for all decks' recording and playback 
and set its Camera ID (see page 19) to A (this is just a convention, not a requirement).

3. On the remaining decks, set the Camera IDs to all different letters (B, C, D, etc).

4. Verify that all the decks are connected to the network (see Network Status, p. 19).

5. Set the A deck to be the Network Master, either via the Network Master checkbox in the 
Options area (p. 18) or the Front Panel (p. 38). At this point, the Master will scan the 
network and the other decks will respond. All the decks will synchronize their source 
lists; the Camera column will specify which decks the clips were recorded on, by Camera 
ID.

6. Once this process is complete, the Master should show a small status block (above the 
source list) showing the other decks, including their Camera IDs (p. 19) and Network 
Names (p. 19), their current clip name, and their current motion state (Live, Play, etc). 
Make sure that all of their boxes are checked and that there is no red text in any box. (A 
common cause for red text is different clip names. Change or re-type the clip name for 
the next recording on the Master and all remotes will be updated).
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VGA screen of Network Master (A) with one other connected deck

VGA screen of remote deck (B) connected to Master
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Synchronized Recording
Once all the decks are connected, any operation done on the Master will be passed to each of the 
other connected decks. They will begin and end recording simultaneously, place in-points, out-
points, and bookmarks in a synchronized fashion, and record scene and clip names together.

Synchronized Playback
Similarly, properly connected decks will cue clips and perform all playback commands in 
synchronized fashion, provided the clips are shared amongst them (note the A B camera ID).
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Network access to video files
When a Raptor HDx is connected to a local network, it provides easy access to the video 
recorded on the deck, for backup and editing. You will need to know the network name of the 
deck, once it is connected to the network (lower-right corner of the application window; see p. 
19). Connect both the computer you will be working on and the Raptor HDx to the same LAN 
for this to work.

For Windows users
In order to work with the video stored on the deck, you need to map a network drive from a PC 
(desktop or laptop) to the Raptor HDx.

1. On the PC, Open My Computer.
2. From the Tools menu, select Map Network 

Drive...

3. For Drive, choose an available letter.
4. Then, for Folder, enter the network name 

of the deck (like RHD1057) followed by 
RXVideo, like this: \\RHD1057\RXVideo

5. You may choose to leave the Reconnect at 
logon box checked so that you do not have 
to complete this process at the beginning of 
every session.

6. Click Finish to complete the process.



Raptor HDx User Manual 35

A new window should appear, showing the 
contents of the video folder on the deck.

You may now use the video files that are stored on the deck directly on your PC.

For Macintosh users
In order to work with the video stored on the deck, you need to connect to the Raptor HDx as a 
Windows server.
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1. From the Finder's Go menu, select 
Connect to Server...

2. For Server Address, enter an address 
similar to the following: 
smb://RHD1057/RXVideo
You will need to replace RHD1057 with the 
network name of your deck.

3. You may be prompted for a password – 
simply choose “Guest.”

4. A new Finder window will open, showing 
the contents of the video folder on the 
deck. After this point, the deck will appear 
by name (e.g. rhd1057) in the Finder's 
sidebar under “Shared.”

Now you can use the files on the deck as though they were stored on your local computer.
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Appendix A. Application Keyboard Shortcuts
This reference is accessible via the Help menu – choose Keyboard Shortcuts.

Key Combination Function
Ctrl+R Start recording
Ctrl+L Go to Live
Enter In Live, starts recording.  In Record, stops recording.

When selecting clips in list, cues clip immediately.
B Place bookmark at current frame
I In Record, marks current frame as in-point.

In Play/Pause, seeks to in-point.
O In Record, marks current frame as out-point.

In Play/Pause, seeks to out-point.
Up arrow Cue in-point / head / previous clip
Down arrow Cue next clip
Ctrl+Up arrow Go to previous scene
Ctrl+Down arrow Go to next scene
Spacebar Toggle play/pause.  After typing in search box, executes search. When 

selecting a clip in list, cues clip immediately.
Left arrow Seek back one frame
Ctrl+Left arrow Seek back one second
Right arrow Seek forward one frame
Ctrl+Right arrow Seek forward one second
Tab Go to next bookmark in current clip
Shift+Tab Go to previous bookmark in current clip
Ctrl+F Selects text in find box – press enter to execute search
F3 Repeat last find
Ctrl+P Toggle “Print Take”
Ctrl+G Clicks “Grab Plate” button
Ctrl+M Toggles “Enable mixer” checkbox on or off
Ctrl+S Select “Scene” text box
Ctrl+T Select “Take” text box
Ctrl+N Select “Notes” text box
Ctrl+D Select “Speed” combo box
Ctrl+W Toggle normal/enhanced video window
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Appendix B. Front Panel Keystrokes
The keystrokes listed below correspond to the 12 buttons and the knob on the front panel. The 
keys must be pressed in the order indicated.

Keystrokes
Key 1 Key 2 Key 3 Notes
Record If in Live, starts recording. If not in Live, goes to Live.

Press twice to start recording from Play or Pause.
Play If paused, starts playing. If playing, pauses.
Play << Scans backward at -4x
Play < Scans backward at -2x
Play > Scans forward at 2x
Play >> Scans forward at 4x
Pause If in playback: pauses the DDR. If in Record: stops recording.
Pause << Decrease next playback speed: used for setting variable speed 

playback. * see notes
Pause >> Increase next playback speed: used for setting variable speed 

playback.  * see notes
Pause < > Asks to confirm, then deletes current clip ***future feature
In, Out If in Play or Pause, locates to In-point or Out-point.

If in Record, saves current frame as In-point or Out-point
Next, 
Prev

If in Play or Pause, locates to Bookmarks: Next or Prev.
If in Record, Next places a bookmark at the current frame.

Option In, 
Out, 
Next, 
Prev

Save current frame: In, Out, and Bookmark (Next).
Option + Prev deletes a bookmark, if one has been set at 
the current frame.

< Frame steps backward
> Frame steps forward
<< Locates to In-point or head of current clip, or cues previous 

clip.
If in Live, locates to most recently recorded clip.

>> Locates to head of next clip.
Jog/

shuttle 
push

Pause deck if in Play or Record. Toggles between clip or 
scene mode.
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Key 1 Key 2 Key 3 Notes
Option Play Loop-plays between In & Out
Option < Locates back one second
Option > Locates forward one second
Option << Locates to first frame of video on deck *** future feature
Option >> Locates to last frame of video on deck *** future feature
Option < > Asks to confirm, then deletes all video from the hard disk 

(must hold for about 1 second).
Option Pause In Live, names next clip. Otherwise, renames current clip.

** see notes
Pause In Displays internal temperature
Pause Out Displays system information

(Versions, Network Name and IP Address)
Pause Next Asks to confirm, then shuts down Raptor HDx
Pause Prev Asks to confirm, then toggles network master
Option Record Prev Cycles through available VGA screen resolutions

(at least 1024x768)

* Reverse Play
Use the “decrease next playback speed” command. After you select the fastest variable playback 
speed, the display will show a series of "-" speeds.

** Clip Naming
The Raptor HDx does not currently support renaming existing clips from the front panel.

To name the next recording, the deck must be in Live. This is when the deck is stopped and the 
REC button's LED is lit (not flashing). Press Option and Pause. Follow the on-screen menu to 
delete, select and change characters.

Use the << and >> keys to select characters, and the < and > keys to modify the current character. 
Next inserts a blank space and Prev deletes the current character. Press Play to save and exit.

Turning the Jog/Shuttle wheel will let you quickly select characters. Pushing the 
Jog/Shuttle knob will move the cursor one character to the right.

*** Future Feature
Keystrokes for future features are listed because they are reserved for those functions. These 
features are not yet included in Raptor HDx shipments.
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Appendix C. Rear Panel I/O Diagram
The following diagram shows the purpose of each I/O port on the rear panel of the Raptor HDx.
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Appendix D. Breakout Cable
The Raptor HDx utilizes a breakout cable for all analog audio and analog video I/O. HD-SDI and 
HDMI in and out are part of the rear panel connectors (see p. 40).

Some of the connectors on the breakout cable are not used in the current product design. This 
includes the RS-422 Deck Control 9-pin D-SUB, the two AES audio in/out BNC's and the 
External Reference BNC.

The remaining 6 BNC's are “multiplexed” or switched between the desired analog video format 
you need to record and playback. The BNC's are marked Y in, Y out, R-Y in, R-Y out, B-Y in, and 
B-Y out.
To record and playback composite NTSC/PAL, use the Y in & Y out connectors. This requires 
specifying the analog video output to Composite (see p. 25).

Two channels of balanced audio in/out are also in the breakout cable.

The following table describes each connector.

Connector Type Function Notes
9-pin D-SUB-F (2) Deck Control RS-422, Unused
BNC-M (3) R-Y In
BNC-M (4) Y In For Composite input (see page 25)
BNC-M (5) B-Y In
BNC-M (6) Ref In Unused
BNC-M (7) R-Y Out
BNC-M (8) Y Out For Composite output (see page 25)
BNC-M (9) B-Y Out
BNC-M (10) AES/EBU Out Unused
BNC-M (11) AES/EBU In Unused
XLR-M (12) Audio Out Left Always available as output (including when 

embedded audio is selected with HD-SDI or 
HDMI, p 25).

XLR-M (13) Audio Out Right

XLR-F (14) Audio In Left
XLR-F (15) Audio In Right
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Appendix E. Further Support

Warranty
Playback Technologies, Inc. warrants that each Raptor HDx will be free from defects in materials 
and workmanship, covering parts and labor for a period of one year from the date of purchase.

Email Support
Steve Irwin: steve24@playbacktech.com

Steve Sexton: steves@playbacktech.com

Phone Support
Call Playback Technologies at +1-818-556-5030, Monday-Friday 9am-5pm except U.S. 
holidays.

If you call when the office is closed, please leave a voicemail message including your contact 
information; we are sometimes able to respond outside of normal business hours.

Mailing Address
Playback Technologies, Inc.

135 N. Victory Blvd.

Burbank, CA 91502

mailto:steves@playbacktech.com
mailto:steve24@playbacktech.com
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