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1 Introduction

Disclaimer: This software is provided ”AS IS” without warranty of any kind. This is develop-
mental code, and we make no pretension as to it being bug-free and totally reliable. Use at your
own risk. We will accept no liability for any damages incurred through the use of this software.
Use of the SplitsTree4 is free, however the program is not open source.

Type-setting conventions: In this manual we use e.g. Network→NeighborNet to indicate the
NeighborNet menu item in the Network menu. We use e.g. Main:Source to indicate the Source

tab in the Main window.

How to cite: If you publish results obtained in part by using SplitsTree4 , then we require that
you acknowledge this by citing the program as follows:

• D.H. Huson and D. Bryant, Application of Phylogenetic Networks in Evolutionary Stud-
ies, Molecular Biology and Evolution, 23(2):254-267, 2006. software available from
www.splitstree.org, or

• D.H. Huson, SplitsTree: A program for analyzing and visualizing evolutionary data. Bioinfor-
matics, 14(10):68–73, 1998.

Evolutionary relationships are usually represented using phylogenetic trees, based on a model of
evolution dominated by mutations and speciation events. More realistic models must also account
for gene genesis, loss and duplication events, hybridization, horizontal gene transfer or recombina-
tion. Here, phylogenetic networks have a role to play.

Moreover, network methods also provide a value tool for phylogenetic inference even when retic-
ulation events do not play an important role. The combined effect of sampling error and
systematic error makes phylogenetics an uncertain science, and network methods provide tools
for representing and quantifying this uncertainty.

The aim of SplitsTree4 is to provide a framework for evolutionary analysis using both trees and
networks. The program takes as input a set of taxa represented by characters (that is, aligned
sequences), distances, quartets, trees or splits and produces as output trees or networks using a
number of different methods.

This document provides both an introduction and a reference manual for SplitsTree4 .
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2 Getting Started

This section describes how to get started.

First, download an installer for the program from from www.splitstree.org, see Section 3 for details.

Use the File→Open menu item to open a file containing data such as character sequences, distances
or trees. The file must be in one of the following formats: Nexus, ClustalW, Phylip, FastA or
Newick. Alternatively, select the Main:Source tab of the Main window and enter data in one of
these formats by hand.

Example files are provided with the program. They are contained in the examples sub directory
of the installation directory. The precise location of the installation directory depends upon your
operating system.

Use the different menu items to determine which methods are applied to the input data. The
Distances, Trees and Network menus contain items that determine how to compute distances,
trees or a network from the given data. Some of the methods provided have parameters that can
be set using the Analysis→Configure Pipeline or Analysis→Configure Recent Methods

items.

The computed data can be viewed in text form in the Main:Data tab and can be saved using the
File→Save As item.

The computed network or tree is displayed in the Main:Network tab. Attributes of the network
can be changed by selecting nodes or branches (also called edges) and using the Nodes and Edges

dialog which is reachable using the View→Nodes and Edges item.

Individual blocks of data can be saved in a number of different formats using the File→Export

item. The network displayed in the Main:Network tab can be saved in a graphics format using
the File→Export Image item.

3 Obtaining and Installing the Program

SplitsTree4 is written in Java and requires a Java runtime environment version 1.4.2 or newer, freely
available from www.java.org.

SplitsTree4 is installed using an installer program that is freely available from www.splitstree.org.
There are four different installers, targeting different operating systems:

• splitstree windows 4.6.exe provides an installer for Windows.

• splitstree macos 4.6.sit provides an installer for Mac OS.

• splitstree linux 4.6.rpm provides a RPM package for Linux.

• splitstree unix 4.6.sh provides a shell installer for Linux and Unix.
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4 Program Overview

In this section, we give an overview over the main design goals and features of this program. Basic
knowledge of the underlying design of the program should make it easier to use the program.

SplitsTree4 is written in the programming language Java. The advantages of this is that we can
provide versions that run under the Linux, MacOS, Windows and Unix operating systems. Addi-
tionally, this makes it possible for the program to support plug-ins that can add new functionality
to the program, such as new methods and import or export modules. A potential draw-back is that
an algorithm implemented in Java will generally run slower than the same algorithm implemented
in C or C++.

Earlier versions 1 −−3 of the program [16] were written in C++ and only contain a small part of
what is now available with SplitsTree4 .

SplitsTree4 uses multi-threading and supports multiple documents. This means that that you can
work on more than one data set simultaneously, in different windows, and run multiple calculations
simultaneously, making use of multiple processors, when available.

A document consists of an individual data set and possesses its own Main window. The document
is discarded, when its window is closed. The program is based on the Nexus format, as introduced
in [25] and the data associated with a document is organized into blocks, and each such block of
data is represented by a corresponding “block” in the Nexus format. The blocks are:

• Taxa: the names of all taxa.

• Unaligned: unaligned sequences.

• Characters: aligned character sequences.

• Distances: pairwise distances between taxa.

• Quartets: (possibly weighted) quartet topologies.

• Trees: list of (possibly partial) trees.

• Splits: (possibly weighted) splits.

• Network: phylogenetic tree or network.

• ST Assumptions: contains all methods and options used to compute data.

• ST Bootstrap: bootstrap support of splits.

The first eight blocks Taxa, Unaligned, Characters, Distances, Quartets, Trees, Splits and
Network are organized as a pipeline and data is processed from left-to-right along this pipeline.
Any non-empty document must contain a Taxa block and will usually contain an ST Assumptions

block. All other blocks are optional and the presence or absence of some block depends on the set
of computations that the user has selected.
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We will use the term source block to denote the left-most block in the pipeline (excluding the
Taxa block). The source block contains the original data that is provided to the program. Any
computations performed by the program will update blocks from left to right along the pipeline,
starting after the source block. Note that some types of computations do not fit into this pipeline
design, for example SplitsTree4 cannot provide any method that takes a Splits block and produces
a Trees block, because the latter occurs before the former in the pipeline.

Typically, the user will provide a source-block and will then use different menu items to determine
how the program will compute data along the pipeline until a Network block has been computed
and an image of the network has been drawn in the Main window.

The program is designed to keep all blocks in the pipeline synchronized by enforcing that the
different blocks only contain data that has been computed via the pipeline. For example, if you
attempt to load data from a file in Nexus format that contains a Taxa and two or more other
blocks, e.g. a Characters block or Distances block, then the program will request you to choose
which of the two latter blocks you want to keep. (This does not apply if the file was created by
SplitsTree4 using the File→Save or File→Save As command, in which case the blocks in the
file are synchronized, and so none must be discarded and no computations are necessary).

Once a source block has been provided, the program will proceed to perform a chain of default
calculations , which differ, depending on the type of the source block. In the case of a Characters

block, the program will use UncorrectedP, NeighborNet and then EqualAngle to compute a
network for the data. In the case of a Distances block, NeighborNet and EqualAngle are
used. In the case of a Trees block, the first tree in the block is displayed using the EqualAngle

algorithm.

The data contained in the different blocks of the pipeline is displayed in the Main:Data tab. The
data contained in the source block is edited using the Main:Source tab.

The program is designed to operate in two differents modes: in a GUI mode, the program provides
a GUI for the user to interact with the program. In command-line mode, the program reads
commands from a file or from standard input and writes output to files or to standard output.

5 Splits, Trees and Networks

Here we give a brief introduction to some of the concepts from phylogenetics that the program is
based on.

Evolutionary relationships between taxa are usually represented using a phylogenetic tree .
Such trees are often computed from molecular sequence data, either directly, using methods such
as parsimony, or indirectly, by first computing a distance matrix and then applying a method such
as Neighbor-Joining.

Such approaches implicitly or explicitly model the evolution of a single gene under the assumption
that the process is dominated by two types of events, mutations and speciation events. Under more
complex models of evolution, i.e. involving gene loss and duplication, or hybridization, horizontal
gene transfer or recombination, a single phylogenetic tree will often not be an appropriate repre-
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sentation of the phylogentic history or of the different incompatible phylogenetic signals. Also, the
presence of noise in a data set, or uncertainty due to inadequacies of the underlying model up on
which a tree inference is based, may also make it necessary to use a more general graph, that is, a
network , to represent the data.

The aim of SplitsTree4 is to provide a frame-work for computing phylogenetic networks. As the
name of the program suggests, it is based on the fundamental mathematical concept of a split .
For example, if we are given an alignment of binary sequences

a 010011010110

b 100001011110

c 011001101110

d 010001101111

then each non-constant column in the alignment defines a split of the taxon set consisting of those
taxa with the value 0 and those with the value 1. For example, the first column partitions the taxa
into two sets {a, c, d} and {b}, and thus gives rise to the split {a,c,d}

{b} (= {b}
{a,c,d}), while the fourth

column does not define a split because the characters are constant.

Mathematically, for a set of X taxa any phylogenetic tree T defines a set of such splits called the
split encoding Σ(T ) of T , as follows: deletion of any branch (also called edge ) e in the tree
produces two subtrees, TA and TB , say, and they give rise to a split S = A

B
= B

A
, consisting of the

set A of all taxa contained in TA and the set B of all taxa contained in TB . In the literature, a
split A

B
is sometimes denoted by A|B or {A,B}.

For example, consider the tree T displayed in Figure 1. Its split encoding Σ(T ) contains 5 trivial
splits that separate a single taxon from all other taxa, and 2 non-trivial splits that contain at
least two taxa in both parts. The trivial splits are:

{a}

{b, c, d, e}
,

{b}

{a, c, d, e}
,

{c}

{a, b, d, e}
,

{d}

{a, b, c, e}
and

{e}

{a, b, c, d}
,

and the non-trivial ones are:
{a, b}

{c, d, e}
and

{a, b, e}

{c, d}
.

Figure 1: An unrooted phylogenetic tree.

A fundamental result in mathematical phylogeny states that any given set of splits Σ corresponds
to some phylogenetic tree T , with Σ(T ) = Σ, if and only if Σ is compatible [6]. Thus, any
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phylogenetic tree may be viewed as a graph whose task it is to give a visual representation of a
given set of compatible splits.

A phylogenetic tree can be thought of as an idealized representation of the historical relationships
among a set of taxa; and tree building methods are attempts to find a the set of compatible splits
that are most consistent with the data according to some algorithm. Often there are multiple
tree that are equally consistent with the data, i.e. multiple sets of compatible splits. In general
that collection of splits will be incompatible. Moreover, there exist inference methods such as
split decomposition and Neighbor-Net that compute a set of incompatible splits from the data in
the form of a given distance matrix. Note that split decomposition produces a set of splits that
are called weakly compatible , while Neighbor-Net produces a set of splits that is circular , as
originally defined in [1].

A split network is a more general type of phylogenetic graph that can represent any collection
of splits, whether incompatible or not [1]. For a compatible set of splits, it is always possible to
represent each split by a single branch, and thus the resulting graph is a tree. In general, however,
this will not be possible and in a split network usually a whole band of parallel branches (also
called parallel edges ) is required to represent a single split. A phylogenetic tree is therefore a
special case of a split network. In SplitsTree4 , if you click on any branch in the representation of
a split network, then all branches corresponding to the same split will be highlighted. If one were
to delete all branches corresponding to a given split S, then the remaining graph will consist of
precisely two components, GA and GB , and, as above, the we have S = A

B
, where A is the set of

all taxa contained in GA and B is the set of all taxa contained in GB .

There is an important difference between phylogenetic trees and more general split networks: Any
rooted tree has a direct interpretation in evolutionary terms: the leaves represent taxa and the
internal nodes represent speciation events. In a (possibly rooted) split network, the internal nodes
do not have such a direct interpretation. Instead, split networks must be viewed on a more abstract
level as networks giving a visual representation of incompatible signals, that is, showing how “tree-
like” or “certain” parts of a phylogeny are.

A reticulate network is used to describe reticulate evolution and there are two types of
such networks, one is the hybridization network and the other is the recombination network
. A hybridization network describes evolution in the presence of hybridization events such as
allopolyploidization or diploid hybridization, and in both cases the net effect is that a new
species arises that has obtained some of its genes via one ancestral species and the other genes via
another ancestral species. A recombination network is used to describe evolution in the presence
of recombination events. As presently implemented in SplitsTree4 , such recombination networks
can only be computed for binary sequences. Such sequences may, for example, indicate the
presence or absence of a certain restriction site at a certain position. There are two main differences
between hybridization networks and recombination networks. First, the former are based on gene
trees, whereas the latter are based on sequences. Second, a recombination network is additionally
annotated by inferred sequences at each of the nodes and the mutations that happen along each
of the branches. Moreover, the recombination nodes are usually annotated with a description of
which parts of the two ancestor sequences are used in the recombination event.

In contrast to split networks, these types of networks can be directly interpreted in evolutionary
terms. Recent research has revealed that there are strong connections between split networks and
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reticulate networks [21, 22] and these are used in SplitsTree4 to provide methods for computing
reticulate networks.

A more detailed discussion of the fundamental concepts can be found in [17] and [20].

6 Opening, Reading and Writing Files

To open a file, select the File→Open menu item and then browse to the desired file. Alternatively,
if the file was recently opened by the program, then it may be contained in the File→Open Recent

submenu.

The native file format of SplitsTree4 is based on the Nexus format, see [25]. However, the program
can also parse a number of other formats, including ClustalW format for aligned sequences, Phylip
format for sequences and distances, FastA format for aligned distances and Newick format for
trees. Earlier versions had separate Open and Import menu items; these have now been combined.

If a file is opened while the Main:Network tab or Main:Data tab is open, then the program
will attempt to parse and execute the file. If the file is a complete Nexus file previously gen-
erated by SplitsTree4 , then the network described in the file will be displayed. If the file is in
some other format, then, depending on the type of content, the program will perform a chain of
default calculations.

If a file is opened while the Main:Source tab is opened, then the contents of the file is read into
the program and displayed as text in the Source-tab, but no computation is performed.

To save the complete data associated with a given window in SplitsTree4 ’s native Nexus format,
use the File→Save or File→Save As menu items. To save selected blocks of data, or to export
data in a different file format, use the File→Export . A picture of the computed network can be
saved using the File→Export Image menu item.

7 Estimating Distances

Many methods in phylogenetics begin by estimating distances between the taxa. This is done by
taking sequences two at a time and estimating the average number of mutations that occurred on
the paths from them to their most recent common ancestor. If the rate of mutation was constant,
then this will be proportional to their divergence time. SplitsTree4 provides a large number of
methods for estimating distances, for sequences and other types of data.

The UncorrectedP method computes the proportion of positions at which two sequences differ.
For DNA or RNA sequences, there are choices over how ambiguous state codes (such as W, M, V)
are handled. Ignore, means that these states are treated as missing states. ’Average’ means that
the contribution at a site is averaged over all possible resolutions of the ambiguous codes, with
the exception that sites having the same ambiguous code contribute zero. ’Match’ looks at each
possible state in each sequence, counts one if the state is not a possible resolution of the ambiguous
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code in the other sequence, and normalises the count by the number of states for each ambiguous
code.

The Distances menu lists several standard distance estimation methods. Most of these have
parameters that can be changed. When you select the menu item the Pipeline window will open
and will display a panel for setting the parameters of the method. If you always use the same
parameters for a given method, or if the method has no parameters, then selecting the “Don’t show
this dialog to configure this method again” will prevent the dialog from appearing again. All meth-
ods can be configured using the Pipeline window, accessed by Analysis→Configure Pipeline

or Analysis→Configure Recent Methods .

8 Building and Processing Trees

The Tree menu provides a number of methods for constructing trees, both from distance and
character data. The following distance-based methods are available: NJ, BioNJ, UPGMA, Buneman

and Refined Buneman.

The program provides ‘front-ends’ for several tree based programs, currently PhyML and Phylip.
SplitsTree4 will pass these programs the current sequences, and place any trees produced in the
SplitsTree4 Trees block. Our distribution of SplitsTree4 does not provide any external programs,
so you must install them separately. In the dialog that is associated with such a method you
must specify the location of the external application, e.g. using the PhyML Path text field. Once
entered, the program will remember this entry as the default value.

SplitsTree4 provides a number of methods for processing a collection of trees. The pmenu-
itemTreesTreeSelector menu contains items to select individual trees or to compute a consensus
of trees. If the Trees→TreesSelector is selected, then the Trees→Previous Tree and
Trees→Next Tree items can be used to move from one tree to the next in the Trees block.
Pressing the shift-key when selecting either of these methods will move to the first tree, or the last
tree, respectively. The Trees→ConsensusTree can be used to compute the majority or strict
consensus tree.

As with distances, when you select such a menu item the Pipeline window will open and will
display a panel for setting the parameters of the method. If you always use the same parameters
for a given method, or if the method has no parameters, then selecting the “Don’t show this dialog
to configure this method again” will prevent the dialog from appearing again. All methods can
be configured using the Pipeline window, accessed by Analysis→Configure Pipeline or
Analysis→Configure Recent Methods .

9 Building and Drawing Networks

The Network menu provides methods for computing phylogenetic networks from character se-
quences, distances and trees.
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Methods that compute a split network directly from character sequences provided in the
Characters block are ParsimonySplits, MedianNetwork SpectralSplits. Note that the Me-
dian network method requires binary sequences. However, given DNA or RNA, this program will
detect all sites that contain precisely two character-states and will build a Median network from
these.

Two methods for computing split networks from distances provided in the Distances block are
SplitDecomposition and NeighborNet.

If a set of phylogenetic trees in the Trees block all contain the full set of taxa listed in the Taxa

block, then the ConsensusNetwork method can be applied to compute a consensus network. If,
however, the Trees block contains partial trees, that is, trees that do not necessarily all involve
identical sets of taxa, then the SuperNetwork or FilteredSuperNetwork method can be used to
compute a super network.

The Networks menu also provides two methods for computing reticulate networks. If the Trees

block contains more than one tree, then the HybridizationNetwork method can be used to
compute a hybridization network for the given data set. More precisely, the HybridizationNetwork

requires that the Trees and Splits blocks are present and non-empty. If the Characters block
contains binary sequence data, then the RecombinationNetwork method can be used to compute
a recombination network.

The Draw menu determines which algorithm is used to construct the final visualization of the
tree or network. Existing methods are EqualAngle, RootedEqualAngle, Phylogram and
ReticulateNetwork. Additionally, the Draw→HideSelectedSplits can be used to remove se-
lected splits from the network and the Draw→Select Trees can be used to highlight different
trees contained in a split network.

10 Main Window

With SplitsTree4 , multiple documents can be opened and worked on simultaneously. Each docu-
ment is represented by a Main window. Additional windows or dialogs are sometimes opened to
perform certain tasks.

The Main window has three tabbed panes:

• the Main:Network tab is used to display the computed tree or network,

• the Main:Data tab can be used to inspect all data associated with a given document in text
format, and

• the Main:Source tab can be used to inspect or edit the “source” data from which all other
data is derived.

We now discuss each separately:
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10.1 Network Tab

The Main:Network tab is used to display the computed tree or network. A status line of
text along the bottom of the network pane gives a summary of the data, such as number of taxa,
length of sequences, etc, and a summary of the methods used to compute the network. Optionally,
a scale bar can be displayed in the upper left corner of the Network-tab to indicate the scale of
branches. The scale bar is can be turned on or of using the Preferences:General tab. The scale
bar can be configured using the Preferences:Status Line tab.

10.2 Data Tab

The Main:Data tab provides a textual display of the data associated with the given document in
the program’s native Nexus format, organized in a linear list of items that can be either collapsed
or expanded. This view of the data is read-only.

10.3 Source Tab

The Main:Source tab provides an editable view of the source data associated with the given
view. This view provides three different functionalities, namely:

• data can be entered by hand or by copy-and-paste, in any of the file formats that the program
supports, see Section 20,

• once the data has been executed, the source data is displayed in Nexus format, and

• if an error is encountered while parsing an input file, the file is opened and the line in which
the error was detected is selected.

10.4 Tool bar

The tool bar associated with the window provides buttons for quick access to many of the menu
items. It can be configured using the The Preferences:Toolbar tab.

11 Graphical Interaction with the Network

We now describe how the user can interactively modify the layout and attributes of the displayed
network. The View menu is used to rotate, move, and zoom in and out. Alternatively, the view
can be changed using a wheel mouse, together with the following modifier keys:
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none zoom in and out.
ALT/option rotate
Command/apple move horizontally
Command/apple & ALT/option move vertically

Here are additional modifications that can be performed:

• The graph can be dragged around by clicking and dragging a node.

• If all selected nodes lie on one side of a band of parallel branches representing a single split,
then clicking and dragging on one of the nodes will change the angle of the branches.

• By default, clicking on an edge will select all edges representing the same split, and all nodes
on the smaller side of the represented split. To select all nodes on the other side of the split,
use the View→Invert Selection menu item. To allow selection of individual edges,
deselect the Split-Selection Mode check box in the Preferences:General tab.

• Select a node by clicking on it. Click outside of the network and drag a rectangle to select
several nodes at once. Hold the shift key and click to add or remove further nodes from the
set selected.

• Click on a text label to edit it.

• Double-click on an edge to edit its label.

• By default, node labels are automatically positioned and cannot be moved. To allow inter-
active positioning of node labels, deselect the View→Auto Layout Node Labels check
box.

• Many aspects of the visual representation of nodes and edges can be modified using the
Node and Edge Window, which is opened using the View→Nodes and Edges menu item.

12 Main Menus

We now discuss all menus of the Main window. Some of the menus differ, depending upon which
tab is selected in the Main window.

12.1 File Menu

The File menu contains the usual file-related items:

• The File→New item opens a new Main window and selects its Main:Source tab.
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• The File→Open item provides an Open File dialog to open a file containing input data
in one of the supported formats.

If the file contains character sequences, then the program must know whether the sequences
are DNA, RNA, protein or “standard” (0,1) data. In Nexus files, the datatype is explicitly
given. In other file formats this not always the case. If the program cannot guess the data
type (e.g., if all character states are ’A’), then the program will display a Choose Datatype

dialog and prompt the user to specify the data type.

If the current document is non-empty, then the selected file is opened in a new Main window.

• The File→Open Recent submenu provides access to recently opened or saved files.

• The File→Replace item is used to replaced the current data by a new data set.

• The File→Duplicate item duplicates the current document and opens it in a new Main

window.

• The File→Close item closes the current document.

• The File→Save item saves the current document to its file, if known.

• The File→Save As item provides a Save As dialog and saves the current document to
selected file.

• The File→Export item opens the Export dialog which is used to save individual data
in a number of different formats.

• The File→Export Image item opens the Export Image dialog which is used to save the
current network in a number of different formats.

• The File→Tools item provides a submenu of tools. The File→Tools→Load Trees

item can be used to merge a set of trees into one document. This item opens a dialog
for opening multiple files. The program parses all given files and extracts any trees found
in them and opens a new Document containing all trees found. The File→Tools→Load

Multi-Labeled Tree item can be used to read a single tree containing multiple labels and
to convert it into a single-labeled split network (and will be made available upon publication of
the paper describing this new method). The File→Tools→Concatenate Sequences item
can be used to concatenate sequences from different files into one document. It requires that
each of the input files uses exactly the same set of taxon labels. The File→Tools→Group

Identical Haplotypes tools is used to detect multiple identical sequences or taxa. These
are recognised from the Characters or, if there is no Characters block, from the distances
block. Only selected sites are used to test if two taxa are distinguishable. A new document
is created; identical taxa are collapsed into a single taxa with label ’TYPEx’ (x ranging from
1, 2, 3, . . ., and the original taxa stored in the info field of the Taxa block. Note that files
with hundreds or thousands identical sequences can cause Splitstree to stall. One solution is
to cancel the computations after data is read in, then using this tool to create a new smaller
document containing only distinct sequences.

• The File→Print item is used to print the current network.

• The File→Quit item quits the program, after asking whether to save unsaved changes.
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12.2 Edit Menu

The Edit menu contains the usual edit-related items:

• The Edit→Undo item is used to undo text-editing, interactive network manipulation and
any item chosen from the View menu.

• The Edit→Redo item is used to redo text-editing, interactive network manipulation and
any item chosen from the View menu.

• The Edit→Cut item is used to cut text.

• The Edit→Copy item is used to copy text or to copy the current network as an image.

• The Edit→Paste item is used to paste text.

• The Edit→Select All item is used to select all nodes and edges of a network.

• The Edit→Invert Selection item is used to invert the selection of nodes.

• The Edit→Taxon Sets submenu is used to select all nodes labeled by a given taxon set
or to add new taxa sets to the SETS block. The SETS block can be copied to other files
to provide a convenient method to quickly label or select taxa in different taxa groups. The
Edit→TaxonSets→All item selects all taxa. The Edit→TaxonSets→New taxa set...

item creates a new taxa set with the currently selected taxa and a name provided by the
user. Note that the name should be a valid NEXUS name. If a set exists with this name, it
is overwritten. The Edit→TaxonSets→Clear All Taxa Sets... removes all taxa sets
from the SETS block.

• The Edit→Find/Replace item opens the Find/Replace dialog.

• The Edit→Go to Line item is used to scroll to a particular line in the Main:Source

tab.

• The Edit→Preferences opens the Preferences window.

12.3 View Menu

The View menu contains items that control aspects of the visualization of a network.

This menu changes depending on which tab on is in. In the Main:Network tab, the View menu
contains the following items, which are all undo-able and redo-able:

• The View→Reset item resets the layout of the network, if used while in the Main:Network

tab, and it clears the text area, while in the Main:Source tab.

• The View→Zoom In item is used to zoom into the network.
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• The View→Zoom Out item is used to zoom out from the network.

• The View→Rotate Left and View→Rotate Right items are used to rotate the
network.

• The View→Flip item changes the layout of the network to it’s mirror image.

• The View→Nodes and Edges item opens the Nodes and Edges window that is used to
modify the graphical attributes of the nodes and edges of the network.

• The View→Highlight Confidence item opens the Confidence window that can be used
to control how confidence values for splits or edges are highlighted in the network.

• The View→Auto Layout Node Labels check box item controls whether node labels are
automatically positioned or whether the user can interactively reposition them.

In the Main:Data tab, the View menu contains the following items:

• The View→Expand All and View→Collapse All items expand and collapse all nodes
in the displayed data tree.

• The View→Characters , View→Distances and View→Splits submenus control
the format used to write the Characters, Distances and Splits blocks, respectively.

In the Main:Source tab, the View menu only contains a View→Reset item, which is used to
clear the source text area.

12.4 Data Menu

The Data menu contains the following items:

• The Data→Keep Only Selected Taxa item removes all taxa from the analysis, whose
nodes in the network are unselected. All data associated with the removed taxa is removed
from the original source block and all subsequent data is recomputed.

• The Data→Exclude Selected Taxa item removes all taxa from the analysis, whose nodes
in the network are selected. All data associated with the removed taxa is removed from the
original source block and all subsequent data is recomputed.

• The Data→Restore All Taxa item restores all taxa that where previously removed using
either of the previous two menu items, or by the next menu item.

• The Data→Filter Taxa item opens the Pipeline:Taxa:Filter tab that can be used
to interactively include or exclude taxa from the analysis.

• The Data→Exclude Gap Sites item excludes from computation all sites in a Characters

block that contain a gap or missing character in any of the sequences.
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• The Data→Exclude Parsimony-Uninformative Sites item excludes from computation
all sites in a Characters block that are parsimony-uninformative, that is, which are constant
across all but one sequence.

• The Data→Exclude Constant Sites item excludes from computation all sites in a
Characters block that are constant across all sequences.

• The Data→Restore All Sites item restores all sites that where excluded using the
above menu items.

• The Data→Filter Characters item opens the Pipeline:Characters:Filter tab that
can be used to interactively include or exclude sites from the analysis.

• The Data→Greedily Make Compatible item uses a greedy approach to makes the splits
in the Splits block compatible: in decreasing order of weight, the algorithm adds the next
split to the set of kept splits, if it is compatible with all splits that have already been kept.

• The Data→Greedily Make Weakly Compatible item uses a greedy approach to makes the
splits in the Splits block weakly compatible: in decreasing order of weight, the algorithm
adds the next split to the set of kept splits, if it is weakly-compatible with all splits that have
already been kept.

• The Data→Exclude Selected Splits item removes all splits from the analysis, whose
edges in the network are selected. The Splits and Network block are modified accordingly.
See also: Draw→Hide Selected Splits .

• The Data→Restore All Splits item restores all splits that were excluded using the
previous menu item.

• The Data→Filter Splits item opens the Pipeline:Splits:Filter tab that can be
used to interactively include or exclude splits from the analysis.

• The Data→Filter Trees item opens the Pipeline:Tree:Filter tab that can be used
to interactively include or exclude trees from the analysis.

• The Data→Set Tree Names item opens a dialog that allows one to set the tree names.

In the Main:Source tab, the Data contains three commands for processing the text contained in
the source text area displayed in the tab:

• The Data→Execute item parses the text in Nexus format and executes it.

• The Data→Convert to Nexus item parses the text in any of the supported file formats
(see Section 20), including old Nexus, and converts it into Nexus format and replaces the
text in the source text area by the converted text.

If either of the first two items is used and the text contained in the text area is not in Newick
format, then a dialog is displayed that allows the user to request to import the text before parsing
it.
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The Data→Load item is particularly useful if you would like to load a large data set and would
like to prevent the program from performing any initial calculations . First open the file ausing
the File→Open item while in the Main:Source tab, then use the Data→Load item to “load” the
data into the program and then switch to the Main:Network. No calculations will be performed
until you choose some menu item.

12.5 Distances Menu

The Distances menu contains the following items:

• The Distances→UncorrectedP item requests the program to compute distances using
the UncorrectedP method.

• The Distances→LogDet item requests the program to compute distances using the
LogDet method.

• The Distances→HKY85 item requests the program to compute distances using the HKY85

method.

• The Distances→JukesCantor item requests the program to compute distances using the
JukesCantor method.

• The Distances→K2P item requests the program to compute distances using the K2P

method.

• The Distances→K3ST item requests the program to compute distances using the K3ST

method.

• The Distances→F81 item requests the program to compute distances using the F81

method.

• The Distances→F84 item requests the program to compute distances using the F84

method.

• The Distances→ProteinMLdist item requests the program to compute distances using
the ProteinMLdist method.

• The Distances→NeiMiller item requests the program to compute distances using the
NeiMiller method.

• The Distances→GeneContentDistance item requests the program to compute distances
using the GeneContentDistance method.

12.6 Trees Menu

The Trees menu contains the following items:
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• The Trees→NJ item requests the program to compute a tree using the NJ method.

• The Trees→BIONJ item requests the program to compute a tree using the BIONJ method.

• The Trees→UPGMA item requests the program to compute a tree using the UPGMA method.

• The Trees→BunemanTree item requests the program to compute a tree using the
BunemanTree method.

• The Trees→RefinedBunemanTree item requests the program to compute a tree using
the RefinedBunemanTree method.

• The Trees→TreeSelector item requests the program to compute a tree using the
TreeSelector method.

• If the Trees→TreesSelector is selected, then the Trees→Previous Tree and
Trees→Next Tree items are used to move from one tree to the next in the Trees block.
Pressing the shift-key when selecting either of these methods will move to the first tree, or
the last tree, respectively.

• The Trees→ConsensusTree requests the program to compute compute the majority or
strict consensus tree.

• The Trees→PhylipParsimony item requests the program to compute a tree using the
PhylipParsimony method.

• The Trees→PhyML item requests the program to compute a tree using the PhyML method.

12.7 Network Menu

The Networks menu contains the following items:

• The Networks→NeighborNet item requests to compute a network using the NeighborNet

method.

• The Networks→SplitDecomposition item requests to compute a network using the
SplitDecomposition method.

• The Networks→ParsimonySplits item requests to compute a network using the
ParsimonySplits method.

• The Networks→ConsensusNetwork item requests to compute a network using the
ConsensusNetwork method.

• The Networks→SuperNetwork item requests to compute a network using the
SuperNetwork method.

• The Networks→FilteredSuperNetwork item requests to compute a network using the
FilteredSuperNetwork method.
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• The Networks→MedianNetwork item requests to compute a network using the
MedianNetwork method.

• The Networks→SpectralSplits item requests to compute a network using the
SpectralSplits method.

• The Networks→HybridizationNetwork item requests to compute a network using the
HybridizationNetwork method.

• The Networks→RecombinationNetwork item requests to compute a network using the
RecombinationNetwork method.

12.8 Analysis Menu

The Analysis menu contains the following items:

• The Analysis→Bootstrap item opens the Bootstrap dialog.

• The Analysis→Show Bootstrap Network item opens a new Main Viewer depicting a
network that is based on all splits that occurred in any of the bootstrap replicates. Note that
this item is enabled only after bootstrapping has been completed.

• The Analysis→Show Confidence Network item opens a new Main Viewer containing
a network that represents a 95% confidence set for the trees or networks estimated. Note
that this item is enabled only after bootstrapping has been completed.

• The Analysis→Estimate Invariable Sites uses the capture-recapture method of [24].

• The Analysis→Compute Phylogenetic Diversity is enabled when a set of taxa are
computed. It computes the sum of the weights for all splits that separate these taxa into two
non-empty groups. On a tree, this is equivalent to the phylogenetic diversity measure of [9],
as these splits will be exactly those lying on a path between two taxa.

• The Analysis→Conduct Phi test for Recombination tests for recombination using
the Phi test of [4].

• The Analysis→Configure Pipeline item opens the Pipeline window which can be
used to configure the parameters of a given method.

• The Analysis→Configure Recent Methods submenus lists all recently used methods
and can be used to open the Pipeline window in the appropriate tab to configure the
parameters of a given method.

12.9 Draw Menu

The Draw menu contains the following items:
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• The Draw→EqualAngle item requests to draw a network using the EqualAngle method.

• The Draw→RootedEqualAngle item requests to draw a rooted network using the
RootedEqualAngle method.

• The Draw→ConvexHull item requests to draw a network using the ConvexHull method.

• The Draw→Phylogram item requests to draw a tree using the Phylogram method.

• The Draw→NoGraph item requests that no network be computed.

• The Draw→Select Characters item opens the Pipeline:Characters:Select tab that
can be used to select individual characters (that is, sites in the given sequence alignment) to
be displayed on the nodes of the network. set of selected input trees.

• The Draw→Hide Selected Splits item can be used to remove all selected splits di-
rectly from the depicted network. This does not change the Splits block. See also:
Data→Exclude Selected Splits .

• The Draw→Hide Non-Selected Splits item can be used to remove all non-selected
splits directly from the depicted network. This does not change the Splits block. See also:
Data→Exclude Selected Splits .

• The Draw→Hide Incompatible Splits item can be used to remove all splits that are
incompatible with the set of currently selected splits directly from the depicted network. This
does not change the Splits block.

• The Draw→Redraw All Splits item redraws the network using all splits, including those
excluded using the previous menu item.

• The Draw→Select Trees item opens the Pipeline:Trees:Select tab that can be used
to select all splits in a given network that are contained in a given set of selected input trees.

12.10 Window Menu

The Window menu contains the following items:

• The Window→About item shows information about the version of SplitsTree4 .

• The Window→How to Cite item gives instructions on how to cite the program.

• The Window→Nexus Syntax submenu provides the syntax of all Nexus blocks that
SplitsTree4 can process.

• The Window→Command Syntax item summarizes the syntax of the commands that can
be used with the command-line mode version of the program, or which can be present in an
input file.

• The Window→Enter a Command item allows entry of a single command.
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• The Window→Message Window item opens the message window.

The bottom of the Window menu contains a list of all open windows.

12.11 Configuring Methods

By default, selecting a menu item that applies some method to the given data, such as e.g. the
Trees→NeighborJoining , will open up a dialog in the Pipeline window which one can use to
configure the method by selecting appropriate options. For methods that have no options, or that
are always used with the same options, selecting the Don’t show this dialog for this method again
checkbox will tell the program not to open the dialog in the future, but rather to immediately apply
the named method. Note that configuration dialogs hidden in this way can still be accessed using
the Analysis→Configure Recent Methods submenu.

13 Popup Menus

Right-clicking on the Main window will open a popup menu. There are three different menus that
will appear, depending upon what is hit by the mouse click.

If the mouse is clicked on a node of a network, then this opens the Node popup menu, which has
the following items:

• The Copy Label copies the node label to the system clipboard.

• The Edit Label opens a dialog to edit the current node label.

• The Exclude Selected Taxa excludes the selected taxa from all computations.

• The Show Name labels the selected node by the names of any correspond taxa.

• The Show Id labels the selected node by the ids of any correspond taxa.

• The Hide Label hides the label of the selected node.

• The Configure opens the Nodes and Edges:Nodes tab of the Nodes and Edges window.

If the mouse is clicked on a edge of a network, then this opens the Edge popup menu, which has
the following items:

• The Copy Label copies the edge label to the system clipboard.

• The Edit Label opens a dialog to edit the current edge label.

• The Show Id labels the selected edge by the id of the corresponding split.

23



• The Show Weight labels the selected edge by the weight of the corresponding split.

• The Show Confidence labels the selected edge by the confidence of the corresponding
split.

• The Show Interval labels the selected edge by the confidence interval of the corresponding
split.

• The Hide Label hides the label of the selected edge.

• The Configure opens the Nodes and Edges:Edge tab of the Nodes and Edges window.

If the mouse is clicked on the drawable region of the window, but not on any node or edge, then
the Window popup menu will open, which has the following items:

• The Zoom In item is a short-cut to the View→Zoom In menu item.

• The Zoom Out item is a short-cut to the View→Zoom Out menu item.

• The Reset item is a short-cut to the View→Reset menu item.

• The Reset Label Positions item resets all node labels to their default positions.

• The Restore All Taxa item restores all excluded taxa.

• The Restore All Splits item restores all excluded splits.

14 Tool Bar

For easier access to frequently used options and methods, SplitsTree4 provides a tool bar at the top
of the Main window. The tool bar can be configured using the Preferences:Toolbar tab. By de-
fault, the tool bar contains the following items: File→Open , File→Duplicate , File→Save As

, File→Print , File→Export Image , Edit→Find/Replace , View→Reset , View→Zoom In

, View→Zoom Out , View→Rotate Right , View→Rotate Left , Edit→Preferences ,
Window→Message Window , Draw→EqualAngle , Draw→RootedEqualAngle , Draw→Phylogram

, Trees→Previous Tree and Trees→Next Tree .

15 Pipeline Window

The Pipeline window is accessed using the Analysis→Configure Pipeline item. It con-
trols all aspects of the computational pipeline that SplitsTree4 uses. It is organized into nine
tabs, reflecting the order of the blocks in the pipeline: Pipeline:Taxa, Pipeline:Unaligned,
Pipeline:Characters, Pipeline:Distances, Pipeline:Quartets, Pipeline:Trees and
Pipeline:Splits.
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This is a potential source of confusion, because in the main menus of the Main window we organize
the methods by the type of their output, rather than by the type of their input, as is done here.

Each tab in controls how a block of the given type is processed to produce a block of a subsequent
type. Each of the tabs contains upto three sub-tabs, as mentioned below. Here we now describe
each of the main tabs:

15.1 Taxa Tab

The Pipeline:Taxa tab consists of precisely one Pipeline:Taxa:Filter sub-tab, which is
used to include (show) or exclude (hide) taxa from all calculations. All taxa listed in the show list
are included in all calculations, where as all taxa listed in the hide list are removed from the data
set. If a set of taxa are selected in the network displayed in the Main window, then these can be
added to the show or hide list by pressing the appropriate From Graph button. Press Show

All or Hide All to show all hide all known taxa.

Please note that the set of “shown” or “hidden” taxa will change automatically when viewing
different partial trees to reflect the set of taxa contained in the current tree.

15.2 Unaligned Tab

The Pipeline:Unaligned tab consists of precisely one sub-tab. The
Pipeline:Unaligned:Method sub-tab is used to choose and configure a method to apply
to the current Unaligned block. Currently, the program provides three methods:

• The NoAlign item simply adds gaps to the ends of sequences to make the all have the same
length.

• The ClustalW item can be used to call the program ClustalW externally to compute an
alignment of the sequences.

• The Muscle item can be used to call the program Muscle externally to compute an alignment
of the sequences.

15.3 Characters Tab

The Pipeline:Characters tab has three sub-tabs. The Pipeline:Characters:Method sub-
tab is used to choose and configure a method to apply to the current Characters block. See
Section 21 for a description of all available methods.

The Pipeline:Characters:Filter sub-tab is used to exclude certain sites from the analysis.
By default, the sites remain present in the Characters block and are simply masked during
calculations. To remove the sites completely, press the Delete button.
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The Pipeline:Characters:Select sub-tab is used to select certain sites in the Characters

block for display of sites in the network.

15.4 Distances Tab

The Pipeline:Distances tab has only one sub-tab. The Pipeline:Distances:Method

sub-tab is used to choose and configure a method to apply to the current Distances block. See
Section 21 for a description of all available methods.

15.5 Quartets Tab

The Pipeline:Quartets tab has only one sub-tab. The Pipeline:Quartets:Method sub-tab
is used to choose and configure a method to apply to the current Quartets block. See Section 21
for a description of all available methods.

15.6 Trees Tab

The Pipeline:Trees tab has three sub-tabs. The Pipeline:Trees:Method sub-tab is
used to choose and configure a method to apply to the current Trees block. See Section 21 for a
description of all available methods.

The Pipeline:Trees:Filter sub-tab is used to exclude trees sites from the analysis.

The Pipeline:Trees:Select sub-tab is used to highlight a set of trees in the displayed network
by selecting all splits in the network that are contained in the set of chosen trees.

15.7 Splits Tab

The Pipeline:Splits tab has two sub-tabs. The Pipeline:Splits:Method sub-tab is used
to choose and configure a method to apply to the current Splits block. See Section 21 for a
description of all available methods.

The Pipeline:Splits:Filter sub-tab is used to modify the weights of splits using a least
squares optimization, or to exclude certain splits from the analysis. Possible filters are:
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Greedy Compatible uses a greedy approach to makes the splits
compatible: in decreasing order of weight, the
algorithm adds the next split to the set of kept
splits, if it is compatible with all splits that have
already been kept.

Closest Tree makes the splits compatible by computing the
“closest tree”

Greedy Weakly Compatible uses a greedy approach to makes the splits
weakly compatible: in decreasing order of
weight, the algorithm adds the next split to the
set of kept splits, if it is weakly-compatible with
all splits that have already been kept.

Weight Threshold removes any split whose weight does not ex-
ceed the given threshold. Pressing the [Set but-
ton will open a histrogram and slider to set the
threshold.

Confidence Threshold removes all splits whose confidence does not ex-
ceed the given threshold. A confidence value
usually lies in the range [0, 1] and can be ob-
tained by bootstrapping, for example. Press-
ing the [Set button will open a histrogram and
slider to set the threshold.

Set Maximum Dimension greedily removes a subset of splits that cause
boxes in the network of dimension higher than
the given threshold, as described in [18].

None applies no filter.

Use the Exclude Selected Splits to remove all splits that are currently selected in the
displayed network.

16 Export and Export Images Dialogs

16.1 Export

The Export dialog is opened using the File→Export item. It is used to save individual blocks
of data in any of the formats described in Section 20. The dialog show two lists. On the left, the
set of available Nexus blocks. Is listed. Depending on the selection of blocks made by the user, on
the right, the set of available export formats is listed.

Most of the dependences between blocks and formats should be apparent. One interesting feature
is the following. If one has enabled graph editing using the Allow Graph Editing option in the
Preferences:General tab and has interactively constructed a phylogenetic tree, then this tree can
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be saved in Newick format. Hence, SplitsTree4 can be used for editing trees.

16.2 Export Image

The Export Image dialog is opened using the File→Export Image item. This dialog is used
to save a picture of the current network in a number of different formats. The following graphics
formats are supported:

• JPEG, “Joint Photographic Experts Group”.

• GIF, “Graphics Interchange Format”.

• EPS, “Encapsulated PostScript”.

• SVG, “Scalable Vector Graphics”.

• PNG, “Portable Network Graphics”.

• BMP, “Bitmap”.

There are two radio buttons, the Save whole image to save the whole image, and the Save

visible image to save only the part of the image that is currently visible in the main viewer. If
the chosen format is EPS, then selecting the Convert text to graphics check box will request
the program to render all text as graphics, rather than fonts.

Pressing the apply button will open a standard file save dialog to determine where to save the
graphics file.

17 Preferences Window

The Preferences window is opened using the Edit→Preferences item.

This window controls program preferences . Many of the preferences are persistent, that is,
they remain effective even after closing and re-opening the program. To “remember” these choices,
SplitsTree4 creates and maintains a properties file , which is placed in the users home directory
and is called something like .SplitsTree.def .

It has five tabs.

The Preferences:General tab controls general aspects of the program:
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Allow Graph Editing if set, the user can add or delete nodes and edges from dis-
played network. To create a node, control-double click on
the canvas. To create an edge between two nodes, control-
click on a node and then drag create an edge. If dragging
ends on a second node, then this is connected to the first,
otherwise, a new node is created. To delete a node or delete
an edge select it and press the delete key.

Maintain Edge Lengths Usually, when interacting with a displayed network, we want
the network to maintain edge lengths.

Show Scale Bar The program uses a small scale bar in the top left hand
corner of the Main:Network tab to indicate the scale of the
network.

use Split-Selection Mode When this feature is on, clicking on an edge will select all
edges that correspond to the same split.

Any choices made here can either be applied to the current document or can be made the default
for all subsequently opened documents.

The Preferences:Defaults tab controls the default sizes, shapes, colors and fonts for nodes
and edges, see also Nodes and Edges .

The Preferences:Layout tab controls aspects of the layout of trees and split networks:

Recompute The taxon layout is recomputed each time the Splits block
is modified.

Stabilize Use the union of the set of current splits and of the previ-
ously computed splits to compute a taxon layout. This is
useful when one wants to compare two different networks
computed on the same taxon set: by switching back and
forth between the two computations, the program will find
a joint taxon layout for both graphs, if one exists. In this
case, both graphs will be laid out in such a way that in both
graphs the taxa appear in approximately the same region of
the canvas.

Snowball Similar to the previous method, this method uses all splits
ever computed in a given dataset to produce a taxon layout.
This doesn’t work very well.

Use this layout Use the provided taxon layout to draw the network.

The Preferences:Toolbar tab allows the user to interactively configure the tool bar.

The Preferences:Status Line tab allows the user to configure the status line displayed
along the bottom of the Main:Network tab.

Here, two items are of particular interest. If the displayed graph was computed either by the
BunemanTree or SplitDecomposition method, then the pair-wise distances in the graph may
under estimate the true distances in the given Distances block. The difference between the two
can be expressed in terms of the fit value, which is activated using the Fit check box, which is
defined as the sum of all pairwise distances in the graph divided by the sum of all pairwise distances
in the given matrix, times 100. This is not applicable to other tree or network building methods.
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For other methods, please use the LSFit item, which computes the least squares fit between
the pairwise distances in the graph and the pairwise distances in the matrix.

18 Additional Windows and Dialog

Here we list all other windows.

18.1 Open File

The Open File dialog is opened using the File→Open item. Use it to open any file containing
phylogenetic data in one of the formats described in Section 20.

If an error is encountered, then the file is opened in the MainSource tab. If possible, the offending
line is highlighted.

18.2 Choose Datatype

When opening a file containing character sequences, or importing sequences from the Main:Source

tab, the program must know whether the sequences are to be interpreted as DNA, RNA, protein
or “standard” (0,1) data. In Nexus files, the datatype is explicitly given. In other file formats this
is usually not the case. The program employs a simple heuristic to guess the datatype. If this fails
(e.g., if all character states are ’A’), then the program will display a Choose Datatype dialog
and prompt the user to specify the datatype.

The choices are:

• dna,

• rna,

• protein,

• standard, which means 0, 1 data, and

• unknown, which the program cannot deal with.

18.3 Save As

The Save As dialog is opened using the File→Save As item. Its purpose is to save the
complete state of a document in Nexus format. To save parts of the document in Nexus format,
or in some other supported format listed in Section 20, use the Export dialog.
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18.4 Find/Replace Window

The Find/Replace window is opened using the Edit→Find/Replace item. Its purpose is
to find and/or replace text. Such searches can be performed either in the Main:Source tab or in
the Main:Network tab. In the latter case, find and replace is performed in all visible node and
edge labels. Note that changing a node label only changes the label displayed in the network. The
original taxon label provided in the Taxa block remains unchanged.

18.5 Node and Edge Window

The Nodes and Edges window is opened using the View→Nodes and Edges item. Its purpose
is to modify the appearance of nodes and their labels, and edges and their labels, in the displayed
network. This window has two tabs:

The Nodes and Edges:Nodes tab is used to control the appearance of nodes. It can be used
to set node size, node shape, node color and node font. Moreover, it can be used to determine
whether nodes are labeled by taxon names, taxon ids, or both.

The Nodes and Edges:Edges tab is used to control the appearance of edges. It can be used to
set edge width, edge color, and edge font. Moreover, it can be used to determine whether edges are
labeled by split weights, split ids, split confidences, or some combination. If the splits block contains
confidence intervals for the edges (for example, in a confidence network) then these intervals can
be displayed by selecting the intervals check box.

Please note that any changes made only apply to the currently selected nodes or edges. If there are
no edges or nodes selected, then changes will apply to all nodes and edges. Any change made in
this dialog box can be reversed using Edit→Undo .

18.6 Highlight Confidence Window

The Highlight Confidence Window is opened using the View→Highlight Confidence

window item.

Use this window to request that edges and/or edge shading is done to reflect the confidence values
associated with each split.

18.7 Bootstrap Window

The Bootstrap window is opened using the Analysis→Bootstrap item. Enter the Number

of Replicates and then press Run to execute.
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18.8 Message Window

The Message window is opened using the Window→Message Window item. The program writes
all messages to this window.

18.9 About Window

The About Window is opened using the Window→About item. It reports the version of the
program.

19 Nexus Blocks

In this section we describe the Nexus format, as implemented in SplitsTree4 , based on the
definition provided in [25]. Unfortunately, there exist two variants of the Nexus format, which we
will call old Nexus and new Nexus . SplitsTree4 is based on the latter, as this is what is
defined in [25]. Given a file formatted in old Nexus, the program will often be able to parse it as
it contains code to automatically convert from old to new Nexus format. However, the algorithm
that does this does not provide a full implementation of the old Nexus format and thus sometimes
it will be necessary to reformat a file by hand.

It is easy to tell the difference between old Nexus and new Nexus: if a file in Nexus format contains
a Taxa block, then it is new Nexus. Most blocks in both formats have the same name and similar
syntax. One main difference is that the Characters block in new Nexus is called a Data block
in old Nexus.

In the following syntax descriptions, we used upper case letters for keywords, square brackets for
optional statements and curly brackets to indicate a list of choices.

19.1 Taxa Block

The Taxa block is the only mandatory block in a Nexus file. Its purpose is to list the names of
all taxa. It has the following syntax:

BEGIN TAXA;

DIMENSIONS NTAX=number-of-taxa;

[TAXLABELS taxon_1 taxon_2 ... taxon_ntax;]

[TAXINFO info_1 info_2 ... info_ntax;]

END;
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The TAXLABELS statement is optional, if it is followed by a source block that contains all taxa
labels.

19.2 Unaligned Block

The Unaligned block contains unaligned sequences. It has the following syntax:

BEGIN UNALIGNED;

[DIMENSIONS NTAX=number-of-taxa;]

[FORMAT

[DATATYPE={STANDARD|DNA|RNA|NUCLEOTIDE|PROTEIN}]

[RESPECTCASE]

[MISSING=symbol]

[SYMBOLS="symbol symbol ..."]

[LABELS={LEFT|NO}]

;]

MATRIX

[taxonlabel1] sequence ,

[taxonlabel2] sequence ,

...

[taxonlabelN] sequence

;

END;

19.3 Characters Block

The Characters block contains aligned character sequences. It has the following syntax:

BEGIN CHARACTERS;

DIMENSIONS [NTAX=number-of-taxa] NCHAR=number-of-characters;

[FORMAT

[DATATYPE={STANDARD|DNA|RNA|PROTEIN}]

[RESPECTCASE]

[MISSING=symbol]

[GAP=symbol]

[SYMBOLS="symbol symbol ..."]

[LABELS={NO|LEFT}]

[TRANSPOSE={NO|YES}]

[INTERLEAVE={NO|YES}]

[TOKENS=NO]

;]
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[CHARWEIGHTS wgt_1 wgt_2 ... wgt_nchar;]

[CHARSTATELABELS character-number [character-name]

[ /state-name [ state-name... ] ], ...;]

MATRIX

sequence data in specified format

;

END;

19.4 Distances Block

The Distances block contains a matrix of pairwise distances. It has the following syntax:

BEGIN DISTANCES;

[DIMENSIONS [NTAX=number-of-taxa];]

[FORMAT

[TRIANGLE={LOWER|UPPER|BOTH}]

[[NO] DIAGONAL]

[LABELS={LEFT|NO}]

;]

MATRIX

distance data in specified format

;

END;

19.5 Quartets Block

The Quartets block contains a list of quartets. It has the following syntax:

BEGIN Quartets;

DIMENSIONS [NTAX=number-of-taxa] NQUARTETS=number-of-quartets;

[FORMAT

[LABELS={LEFT|NO}]

[WEIGHTS={YES|NO}]

;]

MATRIX

[label1] [weight1] a1 b1 : c1 d1,

...

[labeln] [weightn] an bn : cn dn,

;

END;
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19.6 Trees Block

The Trees block contains a list of phylogenetic trees. It has the following syntax:

BEGIN Trees

[PROPERTIES PARTIALTREES={YES|NO};]

[TRANSLATE

nodeLabel1 taxon1,

nodeLabel2 taxon2,

...

nodeLabelN taxonN

;]

[TREE name1 = tree1-in-Newick-format;]

[TREE name2 = tree2-in-Newick-format;]

...

[TREE nameM = treeM-in-Newick-format;]

END;

19.7 Splits Block

The splits block contains a list of splits. It has the following syntax:

BEGIN Splits;

[DIMENSIONS [NTAX=number-of-taxa] [NSPLITS=number-of-splits];]

[FORMAT

[LABELS={LEFT|NO}]

[WEIGHTS={YES|NO}]

[CONFIDENCES={YES|NO}]

[INTERVALS={YES|NO}]

;]

[THRESHOLD=non-negative-number;]

[PROPERTIES

[FIT=non-negative-number]

[leastsquares]

[{COMPATIBLE|CYCLIC|WEAKLY COMPATIBLE|INCOMPATIBLE}]

;]

[CYCLE [taxon_i_1 taxon_i_2 ... taxon_i_ntax];]

[SPLITSLABELS label_1 label_2 ... label_nsplits;]

MATRIX

[label_1] [weight_1] [confidence_1] split_1,

[label_2] [weight_2] [confidence_2] split_2,

....
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[label_nsplits] [weight_nsplits] [confidence_nsplits] split_nsplits,

;

END;

19.8 Network Block

The Network block contains the definition of a phylogenetic network. It has the following syntax:

BEGIN NETWORK;

DIMENSIONS NTAX=number-taxa NVERTICES=number-vertices NEDGES=number-edges;

[DRAW

[ROTATE=rotation]

;]

[TRANSLATE

[vertex_1 taxon_1,

vertex_2 taxon_2,

...

vertex_ntax taxon_ntax,]

;]

VERTICES

1 x_1 y_1 [WIDTH=n] [HEIGHT=n] SHAPE=[RECT|OVAL][FGC=color]

[BGC=color] [LINE=n],

2 x_2 y_2 [WIDTH=n] [HEIGHT=n] SHAPE=[rect|OVAL][FGC=color]

[BGC=color] [LINE=n],

...

nvertices x_nvertices y_nvertices [WIDTH=n] [HEIGHT=n]

SHAPE=[RECT|OVAL][FGC=color] [BGC=color] [LINE=n],

;

VLABELS

vertex_id label [X= xoffset Y=yoffset] [FGC=color] [FONT=font],

...

vertex_id label [X= xoffset Y=yoffset] [FGC=color] [FONT=font],

EDGES

1 vertex_id vertex_id [ECLASS=n] [FGC=color] [LINE=n],

2 vertex_id vertex_id [ECLASS=n] [FGC=color] [LINE=n],

...

nedges vertex_id vertex_id [FGC=color] [LINE=n],

[ELABELS

edge_id label [X= xoffset Y=yoffset] [FGC=color] [FONT=font],

...

edge_id label [X= xoffset Y=yoffset] [FGC=color] [FONT=font],

;]

[INTERNAL

edge_id [x y] [x y] ...,
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...

edge_id [x y] [x y] ...,

;]

END;

19.9 Bootstrap Block

The Bootstrap block contains the results of a bootstrap analysis. It has the following syntax:

BEGIN ST_BOOTSTRAP;

[DIMENSIONS [NTAX=number-of-taxa] [NCHAR=number-of-characters]

[NSPLITS=number-of-splits];]

[FORMAT

[LABELS={LEFT|NO}]

[SPLITS={NO|YES}]

[ALL={YES|NO}]

;]

[RUNS=the-number-of-runs;]

[LENGTH={sample-length | SAME}];

[SEED=random-number-seed;]

[SAVEWEIGHTS={yes|no};]

[FIXSPLITS={yes|no};]

[COMPUTEDIST={yes|no};]

[OUTPUTFILE=file-name;]

[MATRIX

[label_1] value_1 [split_1,]

[label_2] value_2 [split_2,]

....

[label_nsplits] value_nsplits [split_nsplits,]

[label_nsplits+1] value_(nsplits+1) [splits_(nsplits+1),]

....

[label_n] value_n [splits_n,]

;]

END;

19.10 Sets Block

The Sets block can be used to define sets of taxa or characters. It has the following syntax:

BEGIN Sets;

[TAXSET taxset-name = taxon-list;]

[CHARSET charset-name = character-list;]
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[CHARPARTITION charpart-name = 1:charset-name|character-list [,...];

...

END;

19.11 ST Assumptions Block

The ST Assumptions block controls the processing of the data along the pipeline. It contains
all choices made by the user that affect computations. It has the following syntax:

BEGIN ST_ASSUMPTIONS;

[UNALIGNTRANSFORM=name [parameters];]

[CHARTRANSFORM=name [parameters];]

[DISTTRANSFORM=name [parameters];]

[SPLITSTRANSFORM=name [parameters];]

[SPLITSPOSTPROCESS

[[NO] LEASTSQUARES]

[FILTER={GREEDYCOMPATIBLE|WEAKLYCOMPATIBLE|WEIGHT VALUE=value

|CONFIDENCE VALUE=valueDIMENSION VALUE=value|NONE};]

[EXTAXA={NONE|list-of-original-taxa-labels};]

[EXCHAR={NONE|list-of-original-char-positions};]

[EXCLUDE [[NO] GAPS] [[NO] NONPARSIMONY]

[{NO CONSTANT|CONSTANT [number]}]

[[NO] CODON1] [[NO] CODON2] [[NO] CODON3];]

[EXTREES={NONE|list-of-original-tree-labels};]

[LAYOUTSTRATEGY={STABILIZE|SNOWBALL|KEEP};]

[[NO] AUTOLAYOUTNODELABELS;]

[UPTODATE;]

END;

20 File Formats

By default, SplitsTree4 reads and writes data in Nexus format. The program can read and export
the following additional formats: FastA , Phylip and ClustalW :
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Name file suffix data type

new Nexus .nex, .nxs taxa, unaligned sequences,
aligned sequences (charac-
ters), distances, quartets,
trees, splits, networks

old Nexus .nex, .nxs aligned characters, distances,
trees

[25]

FastA .fa, .fasta unaligned sequences, or
aligned characters

Phylip .phy, .dst, .dist aligned characters or dis-
tances

[10]

ClustalW .aln aligned characters [32]

21 All Methods

Here we list all methods supported by SplitsTree4 . We describe the usage and list the input and
output Nexus blocks.

Binary2Splits : This method converts binary characters to splits.

Usage: Binary2Splits AddAllTrivial=<boolean> MinSplitWeight=<int>

Input: Characters

Output: Splits

BioNJ : This method computes the Bio-NJ tree [12].

Usage: BioNJ

Input: Distances

Output: Trees

BunemanQuartets : This method computes all quartets with positive Buneman index [6].

Usage: BunemanQuartets threshold=<double>

Input: Distances

Output: Quartets

BunemanTree : This method computes the Buneman tree [6].

Usage: BunemanTree

Input: Distances

Output: Splits

ClustalW : This method externally runs the ClustalW sequence alignment program [32].
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Usage: ClustalW GapOpen=<int> GapExtension=<double>

WeightMatrix=<java.lang.String> OptionalParameter=<java.lang.String>

PathToCommand=<java.lang.String>

Input: Unaligned

Output: Characters

Coalescent : This method transforms a set of quartets to a set of splits representing a binary
phylogenetic tree by applying the coalescent method described in [26].

Usage: Coalescent

Input: Quartets

Output: Splits

ConsensusNetwork : This method computes the consensus splits of trees [2, 15] to produce a
consensus network.

Usage: ConsensusNetwork Threshold=<double> EdgeWeights=<String>

Input: Trees

Output: Splits

ConsensusTree : This method computes different types of consensus trees.

Usage: ConsensusTree EdgeWeights=<String> Method=<String>

Input: Trees

Output: Splits

ConvexHull : This method computes a splits graph using the convex hull extension algorithm [7].

Usage: ConvexHull Weights=<boolean> ScaleNodesMaxSize=<int>

Input: Splits

Output: Network

DNA2Splits : This method converts DNA characters to splits by setting the majority state against
all other states.

Usage: DNA2Splits AddAllTrivial=<boolean> MinSplitWeight=<int>

Input: Characters

Output: Splits

DQuartets : This method compute all quartets with positive isolation index [1].

Usage: DQuartets threshold=<double>

Input: Distances

Output: Quartets
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EqualAngle : This method computes a planar split network for a circular (sub-)set of splits [7].
If the RunConvexHull option is chosen, then the convex hull algorithm is subsequently applied
to obtain a graph for the complete set of splits. This method provides a number of heuristics
for obtaining a better layout [11]: set DaylighIterations to ≈ 5 to apply the equal daylight
heuristic, set OptimizeBoxesIterations to ≈ 10 to apply the box opening heuristic and set
SpringEmbedderIterations to ≈ 500 to apply a modified spring embedder.

Usage: EqualAngle UseWeights=<boolean> RunConvexHull=<boolean>

DaylightIterations=<int> OptimizeBoxesIterations=<int>

SpringEmbedderIterations=<int>

Input: Splits

Output: Network

FilteredSuperNetwork : This method computes a super-network from partial trees using the
Z-closure algorithm [18] and a distortion filter [23].

Usage: FilteredSuperNetwork MinNumberTrees=<int> MaxDistortionScore=<int> EdgeWeights=<String>

AllTrivial=<boolean> UseTotalScore=<boolean>

Input: Trees

Output: Splits

F81 : This method calculates distances using the Felsenstein-81 model [31].

Usage: F81 Maximum_Likelihood=<boolean> Estimate_Base_Frequencies=<boolean>

Base_Freqs=<N double1 double2 ... doubleN> Normalize=<boolean>

Input: Characters

Output: Distances

F84 : This method Calculates distances using the Felsenstein-84 model [31].

Usage: F84 Maximum_Likelihood=<boolean> Estimate_Base_Frequencies=<boolean>

Normalize=<boolean> TRatio=<double> A=<double> C=<double> G=<double>

T_U=<double>

Input: Characters

Output: Distances

GapDist : This method calculates the “gap distance” from a set of sequences.

Usage: GapDist

Input: Characters

Output: Distances

GeneContentDistance : This method compute distances based on gene content [19].
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Usage: GeneContentDistance UseMLDistance=<boolean>

Input: Characters

Output: Distances

Hamming : This method calculates distances using the Hamming distance. This is identical to the
UncorrectedP method.

Usage: Hamming ignoregaps=<boolean>

Input: Characters

Output: Distances

HKY85 : This method calculates distances using the Hasegawa, Kishino and Yano model.

Usage: HKY85 Estimate_Base_Frequencies=<boolean> Normalize=<boolean>

TRatio=<double> A=<double> C=<double> G=<double> T_U=<double>

P_Invar=<double> Gamma=<double>

Input: Characters

Output: Distances

HybridizationNetwork : This method computes a hybridization network [21]. The present
implementation operates by calling the ReticulateNetwork method.

Usage: HybridizationNetwork Which=<int> Method=<String> ShowSplits=<boolean>

OutGroup=<String> MaxAngle=<int> MaxReticulationsPerTangle=<int>

ShowSequences=<boolean> ShowMutations=<boolean>

Input: Splits

Output: Network

JukesCantor : This method computes distances using the Jukes Cantor model [31].

Usage: JukesCantor Maximum_Likelihood=<boolean>

Input: Characters

Output: Distances

K2P : This method calculates distances using the Kimura-2P model [31].

Usage: K2P Maximum_Likelihood=<boolean> TRatio=<double>

Input: Characters

Output: Distances

K3ST : This method calculates distances using the Kimura-3ST model [31].

Usage: K3ST Maximum_Likelihood=<boolean> TRatio=<double> AC_vs_ATRatio=<double>

Input: Characters

Output: Distances
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LogDet : This method Calculates the LogDet-distance [30].

Usage: LogDet Impute_Gaps=<boolean>

Input: Characters

Output: Distances

LogHamming : This method calculates distances using the log-Hamming distance.

Usage: LogHamming ignoregaps=<boolean>

Input: Characters

Output: Distances

MedianNetwork : This method computes an (unreduced) median network [2]. It uses all sites in
the character alignment that contain exactly two different states, and no gaps or missing states. If
UseRYAlphabet is selected, then DNA and RNA sequences are translated using R = {A,G} and
Y = {C, T,U}. If UseRelaxedSupport is selected, a character need only be constant on one side
of a split to count toward the support of the split.

Usage: MedianNetwork AddAllTrivial=<boolean> MinimalSupport=<int>

UseRYAlphabet=<boolean> LabelEdges=<boolean> UseRelaxedSupport=<boolean>

Input: Characters

Output: Splits

Muscle : This method externally runs the Muscle sequence alignment program [8].

Usage: Muscle Maxiters=<int> ClusterMethod_1=<String>

ClusterMethod_2=<String> DistanceMeasure_1=<String>

DistanceMeasure_2=<String> ObjectiveScore=<String>

LogFile=<boolean> LogFileName=<String>

OptionalParameter=<String> PathToCommand=<String>

Input: Unaligned

Output: Characters

NeiMiller : This method computes distances from restriction-sites using the Nei and Miller
method [27].

Usage: NeiMiller

Input: Characters

Output: Distances

NJ : This method computes the Neighbour-Joining tree [28].

Usage: NJ

Input: Distances

Output: Trees
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NeighborNet : This method computes the Neighbor-Net splits [5] to produce a Neighbor-Net
network.

Usage: NeighborNet Variance=<String> Minimize_AIC=<boolean>

Input: Distances

Output: Splits

Noalign : This method obtains a trivial sequence alignment by adding gaps to the end of each
sequence to make all sequences have the same length.

Usage: Noalign

Input: Unaligned

Output: Characters

NoGraph : This method prevents the program from constructing a final network.

Usage: NoGraph

Input: Splits

Output: Network

NoSplits : This method prevents the program from constructing splits from a set of trees.

Usage: NoSplits

Input: Trees

Output: Splits

ParsimonySplits : This method computes the set parsimony splits [1].

Usage: ParsimonySplits

Input: Characters

Output: Splits

PhylipParsimony : This method computes the maximum parsimony tree from DNA sequences
using an external call to the Phylip package [10].

Usage: PhylipParsimony PhylipPath=<String> SearchMode=<String>

NumberOfTreesToSave=<int> InputOrderSeed=<int> InputOrderJumbles=<int>

OutgroupRoot=<String> ThresholdParsimony=<double>

TranversionParsimony=<boolean> WeightsFile=<String>

Input: Characters

Output: Trees

Phylogram : This method computes a traditional phylogenetic tree.

Usage: Phylogram Weights=<boolean> Cladogram=<boolean> Outgroup=<String>

UseOutgroup=<boolean>

Input: Splits

Output: Network
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PhyML : This method calculates maximum likelihood trees from DNA sequences using PHYML
[13].

Usage: PhyML PHYMLPath=<String> TreePath=<String> Bootstrap=<boolean>

NumberOfBootstrapReplicates=<int> PrintBootstrap=<boolean>

SubstitutionModel=<java.lang.String>

OptimiseEquilibriumFrequencies=<boolean>

EquilibriumFrequenciesEmpirical=<boolean> FrequencyA=<double>

FrequencyC=<double> FrequencyG=<double> FrequencyT=<double>

SubstitutionParameterAC=<int> SubstitutionParameterAG=<int>

SubstitutionParameterAT=<int> SubstitutionParameterCG=<int>

SubstitutionParameterCT=<int> SubstitutionParameterGT=<int>

EmpiricalBaseFrequencyEstimates=<boolean>

GammaDistributionParameter=<double>

GammaDistributionParameterFixed=<boolean>

InvariableSitesProportion=<double>

InvariableSitesProportionFixed=<boolean>

NumberOfSubstitutionCategories=<int> OneSubstitutionCategory=<boolean>

OptimiseStart=<boolean> OptimiseStartKeepingTopology=<boolean>

TstvRatio=<double> TstvRatioFixed=<boolean> UseBioNJstart=<boolean>

OptimiseRelativeRateParameters=<boolean>

Input: Characters

Output: Trees

ProteinMLdist : This method calculates maximum likelihood protein distance estimates using
the following models: cpREV45 , Dayhoff , JTT , mtMAM , mtREV24 , pmb ,
Rhodopsin and WAG [31].

Usage: ProteinMLdist Gamma=<double> Model=<String> PInvar=<double>

Estimate_variances=<boolean>

Input: Characters

Output: Distances

PTreeSplits : This method computes the parsimony splits tree [1].

Usage: PTreeSplits

Input: Characters

Output: Splits

RecombinationNetwork : This method compute a recombination network from binary sequences
[22]. If the given data is not 0, 1 data, but DNA, then only those sites are considered that show pre-
cisely two different states. The present implementation operates by calling the ReticulateNetwork

method.

Usage: RecombinationNetwork MinSplitWeight=<int> Which=<int> Method=<String>
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ShowSplits=<boolean> OutGroup=<String> MaxAngle=<int>

MaxReticulationsPerTangle=<int> ShowSequences=<boolean>

ShowMutations=<boolean>

Input: Characters

Output: Network

ReticulateNetwork : This method compute a reticulate network from splits [22].

Usage: ReticulateNetwork MinSplitWeight=<int> Which=<int> Method=<String>

ShowSplits=<boolean> OutGroup=<String> MaxAngle=<int>

MaxReticulationsPerTangle=<int> ShowSequences=<boolean>

ShowMutations=<boolean>

Input: Characters

Output: Network

RefinedBunemanTree : This method computes the Refined Buneman Tree [3]. This module was
implemented by Lasse Westh-Nielsen and Christian N. S. Pedersen.

Usage: RefinedBunemanTree

Input: Distances

Output: Splits

ReticulateNetwork : This method computes a reticulate network [21].

Usage: ReticulateNetwork Which=<int> Method=<String> ShowSplits=<boolean>

OutGroup=<String> MaxAngle=<int> MaxReticulationsPerTangle=<int>

ShowSequences=<boolean> ShowMutations=<boolean>

Input: Splits

Output: Network

RootedEqualAngle : This method computes a rooted split network using the rooted equal angle
algorithm [11].

Usage: RootedEqualAngle OptimizeDaylight=<boolean> UseWeights=<boolean>

RunConvexHull=<boolean> DaylightIterations=<int> OutGroup=<String>

MaxAngle=<int> SpecialSwitch=<boolean>

Input: Splits

Output: Network

RYSplits : This method computes all RY splits.

Usage: RYSplits

Input: Characters

Output: Splits

SpectralSplits : This method computes all splits arising using spectral analysis [14].
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Usage: SpectralSplits Threshold=<double> Method=<String> Weight_ATvsGC=<double>

Weight_AGvsCT=<double> Weight_ACvsGT=<double>

Input: Characters

Output: Splits

SplitDecomposition : This method computes the split decomposition [1].

Usage: SplitDecomposition

Input: Distances

Output: Splits

SuperNetwork : This method computes a super-network from partial trees using the Z-closure
algorithm [18].

Usage: SuperNetwork EdgeWeights=<String> ZRule=<boolean> NumberOfRuns=<int>

SuperTree=<boolean> ApplyRefineHeuristic=<boolean>

Input: Trees

Output: Splits

TreeSelector : This method is used to select a single tree from a set of trees.

Usage: TreeSelector Which=<int>

Input: Trees

Output: Splits

UncorrectedP : This method calculates uncorrected (observed, ”P”) distances. This is identical
to the Hamming method.

Usage: Uncorrected_P ignoregaps=<boolean>

Input: Characters

Output: Distances

UPGMA : This method computes UPGMA tree [29].

Usage: UPGMA

Input: Distances

Output: Trees

22 Command-Line Options and Mode

SplitsTree4 has the following command-line options :
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-g <switch> (default=true): GUI mode

-p <String> (default="$HOME/.SplitsTree.def"): Properties file

-i <String> (default=""): Input file

-x <String> (default=""): Execute this command at startup

-V <switch> (default=false): show version string

-S <switch> (default=false): silent mode

-d <switch> (default=false): debug mode

-s <switch> (default=true): show startup splash screen

-h <switch> (default=false): Show usage

Launching the program with option -g will make the program run in non-GUI command-line
mode , first reading commands from a file supplied with the -i option, if any, then executing any
command given with the -x option, and then finally reading additional commands from standard
input.

Please be aware that the command-line version of the program uses the same properties file as the
interactive version. So, any a preferences set using the interactive version of the program will also
apply to the command-line version of the program. It this is not desired, then please use the -p

option to supply a different properties file.

Commands provided to the program from within a file must be grouped together in a SplitsTree

block so:

begin SplitsTree;

commands...

end;

Here we list all commands known to SplitsTree4 :

EXECUTE FILE=file - open and execute a file in Nexus-format

OPEN FILE=file - open (but don’t execute) a file in Nexus-format

IMPORT FILE=file [DATATYPE={PROTEIN|RNA|DNA|STANDARD|UNKNOWN}] - open (but don’t execute) a file

old-Nexus format

LOAD FILE=file - open or import a file

LOAD TREEFILES=file1 ... filen - load trees from one or more files

LOAD CHARFILES=file1 ... filen - concatenate sequences from one or more files

LOAD FILE=file - open or import a file

SAVE FILE=file [REPLACE={YES|NO}] [APPEND={YES|NO}] [DATA={ALL|list-of-blocks}]

- save all data or named blocks to a file in Nexus format

EXPORT FILE=file FORMAT=format [REPLACE={YES|NO}] [APPEND={YES|NO}]

[DATA=list-of-blocks]

- export data in the named formatAA

EXPORTGRAPHICS [format={EPS|PNG|GIF|JPG|SVG}] file=file [REPLACE={YES|NO}]

[TEXTASSHAPES={YES|NO}] [TITLE=title]

- export graphics in specified format (default is EPS)

UPDATE - rerun computations to bring data up-to-date

BOOTSTRAP RUNS=number-of-runs - perform bootstrapping on character data
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DELETEEXCLUDED; - delete all sites from characters block that are

currently excluded

ASSUME assumption - set an assumption using any statement defined

in the ST_ASSUMPTIONS block

SHOW [DATA=list-of-blocks] - show the named data blocks

CYCLE {KEEP|cycle} - set the graph layout cycle to KEEP or to a given cycle

HELP - show this info

HELP DATA=list-of-blocks - show syntax of named blocks

HELP TRANSFORM=transform - show usage of a specific data transformation

VERSION - report version

ABOUT - show info on version and authors

QUIT - exit program

To begin or end a multi-line input, enter a backslash ’\’

23 Examples

Example files are provided with the program. They are contained in the examples sub directory
of the installation directory. The precise location of the installation directory depends upon your
operating system.
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parsimony-uninformative, 18
ParsimonySplits, 20, 44
partial trees, 12, 41, 47
Paste, 16
Phylip, 38, 39, 44
PhylipParsimony, 20, 44
Phylogram, 22, 24, 44
PHYML, 45
PhyML, 20, 45
PhyML Path, 11
Pipeline, 24
pipeline, 6
Pipeline:Characters, 25
Pipeline:Characters:Filter, 25
Pipeline:Characters:Method, 25
Pipeline:Characters:Select, 26
Pipeline:Distances, 26
Pipeline:Distances:Method, 26
Pipeline:Quartets, 26
Pipeline:Quartets:Method, 26
Pipeline:Splits, 26
Pipeline:Splits:Filter, 26
Pipeline:Splits:Method, 26
Pipeline:Taxa, 25
Pipeline:Taxa:Filter, 25
Pipeline:Trees, 26
Pipeline:Trees:Filter, 26
Pipeline:Trees:Method, 26
Pipeline:Trees:Select, 26
Pipeline:Unaligned, 25
Pipeline:Unaligned:Method, 25
pmb, 45
PNG, 28
Preferences, 16, 24, 28
preferences, 28
Preferences:Defaults, 29
Preferences:General, 28
Preferences:Layout, 29
Preferences:Status Line, 29
Preferences:Toolbar, 13, 29
Previous Tree, 11, 20, 24
Print, 15, 24

properties file, 28
ProteinMLdist, 19, 45
PTreeSplits, 45

Quartets, 34
Quit, 15
Quit command, 48

recombination, 9
recombination network, 9, 12, 45
RecombinationNetwork, 21, 45
Redo, 16
Redraw All Splits, 22
RefinedBunemanTree, 20, 46
Replace, 15
Reset, 16, 17, 24
Reset Label Positions, 24
Restore All Sites, 18
Restore All Splits, 18, 24
Restore All Taxa, 17, 24
restriction-sites, 43
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Save command, 48
Save visible image, 28
Save whole image, 28
scale bar, 29
Select All, 16
Select Characters, 22
Select Trees, 12, 22
sequence alignment, 39, 43, 44
Set Maximum Dimension, 27
Set Tree Names, 18

56



Sets, 37
Show All, 25
Show Bootstrap Network, 21
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Show Confidence Network, 21
Show cycle command, 48
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split, 8
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split network, 9
split weights, 31
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View→Zoom In, 16, 24
View→Zoom Out, 17, 24
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Window, 22, 24
Window→About, 22, 32
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Window→Message Window, 23, 24, 32
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