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About this 
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What is a Content Management System (CMS) 

Overview of CMS 
 
Databases are used to help manage structured content (information organized into columns and rows), such 
as financial data or HR records. 
 
However, over 80% of enterprise content is unstructured, consisting of documentation, notes, procedures, 
etc. Managing content has become a time‐consuming task for people working in large organizations. 
According to some studies people who work with information spend up to 40% of their time finding, 
preparing, processing and filing content. 
 
Some of the problems associated with unstructured content include: 
 

• Files are ineffectively classified (naming, location)   
• Scattered across different computers   
• Insecure – access permissions are not regulated   
• Difficult to find files   
• Potentially inaccurate (which version is the most current)  

 
 
A content management system (CMS) is designed to help manage unstructured content. The content 
management system used at McGill is called Documentum. This system manages the life cycle of content: 
 

Create Edit Review Publish Archive 
 
It also manages descriptive properties of each file, controls access to content based on user permissions, 
and enforces business rules and regulatory requirements. 
 

Browser Requirement 
Webtop requires Internet Explorer version 7 or 8 for full functionality and limited functionality is available 
using Mozilla Firefox 2.0. 
 
XMAX requires Internet Explorer version 7 or 8 for full functionality and does not work in Mozilla Firefox 2.0, 
Chrome, or Safari. 
 

Installation Requirement 
The following installation steps are for Internet Explorer 7 & 8 and are required before using Webtop or XML 

document in XMAX: 
 

Add the Webtop URL to your browser's trusted sites.  

 
1. From the IE menu, click Tools > Internet Options.  
2. Go to the Security tab and click Trusted sites from the box at the top labeled Select a zone to view...  



 

  830 September 2014 

3. Click the Sites button.  
4. Type in the URL https://cms.mcgill.ca/ and click Add.  
5. Click Close.  
6. Click OK.  

 

Set the security settings to Low for trusted sites, to allow the ActiveX control to run.  

 
1. From the IE menu, click Tools > Internet Options.  
2. Go to the Security tab and click Trusted sites from the box at the top labeled Select a zone to view...  
3. Click Custom level... at the bottom of the window.  
4. At the bottom of the dialog, in the dropdown labeled Reset to: select Low (This is the Default level for IE 6).  
5. Click OK on the Security Settings dialog.  
6. Click OK again on the Internet Options dialog.  

 

If Popup‐Blocker is turned on, add the Webtop URL to your browser's list of pop‐up exceptions: 

 

1. From the IE menu, click Tools > Internet Options.  
2. Go to the Privacy tab.   
3. If the Turn on Pop‐up Blocker check box is not checked you don't need to continue; just click Cancel. 

Otherwise, click Settings in the Pop‐up Blocker area at the bottom of the dialog.   
4. Type in the URL https://cms.mcgill.ca/ and click Add.  
5. Make sure the Filter level at the bottom of the dialog is set to "Low: Allow pop‐ups from secure sites".   
6. Click Close.  
7. Click OK.  

 
Note: Once you have made these changes, close your browser and reopen it in order for the new security settings 
to take effect. 

 

Understanding the eCalendar workflow 
 
A workflow is an automated series of tasks assigned sequentially from user to user. When you complete a workflow 

task, the workflow automatically sends a task to the next user in the workflow. 
 
The procedure of the eCalendar workflow is: 
 
The Managing Editor will initiate the workflow by sending out an email in Outlook to start the review process. 

The general workflow passes through these roles: 
 
         Editor    Approver           Coordinator      Coordinator 2          Copy Editor       Technical Verification 
 
 
Each topic has been assigned an editor, approver, coordinator, and second coordinator based on subject expertise. A 
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notification is sent to each person in the workflow, both in Outlook and Webtop, to notify them when it is time to take 

action on a given topic. The task can be accessed through their Webtop inbox. Each task contains a topic that needs to 

be reviewed or edited. Topics are pieces of eCalendar content in XML format. 
 
Editor: after clicking on the link from the email, an Editor logs into Webtop, selects a topic, reads the 

instructions, verifies the content of the assigned XML document(s), modifies the document (if needed), and then 

submits the document to the Approver. 
 
Approver: can additionally modify content, or accept the content and forward it to the Coordinator. The Approver can 

also choose to write a comment and reject the topic back to the editor for more changes to be made. The editor will 

make changes and send the topic back to the approver for another review. 
 
Coordinators: will sign off on the document. However, if a coordinator rejects the changes, he or she can send it to the 

Approver or the Editor. The coordinator will see the document again for another review and sign‐off. 

 

Copy Editor: will verify that all content is free of typos, grammatically correct, and contains consistent styling. If there 

are major inconsistencies or the information is unclear, the copy editor will either contact the appropriate performer 

directly to discuss the change, or reject the topic back to them. 
 
Technical Verification: will verify all information for consistency and accuracy. 
 
Roles are described further under: Getting Started for Individual Roles. 
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Webtop – Content Management System 
 

What is Webtop 

Webtop is the web‐based interface you will use to access content stored in the Documentum 
content management system.  
 
The Webtop interface is a very powerful tool which allows you to: 
 

• Create files and folders   
• View the contents of files and folders   
• Edit files   
• View and change the properties of files   
• …and much more  

 
However, for the eCalendar, you will only be using the features that have been defined for you based on your 
role (Editor, Approver, or Coordinator). 

Browser Requirements 
Webtop requires Internet Explorer version 7 or 8 for full functionality. Limited functionality is available 
using Mozilla Firefox 2.0. 
 

Log into Webtop 

To access contents of the CMS, you need to log into Webtop. Enter the URL for the system in your browser address bar:  

https://cms.mcgill.ca/webtop and go to the site. 
 

1. Enter your McGill Username.   
2. Enter your McGill Password.   
3. Select the Repository containing the content for the eCalendar.   
4. For greater security, do NOT check the Remember my credentials checkbox.   
5. Click Login to proceed.  

 

To access the Webtop quickly in the future: 

 
Save the Webtop URL as a Favorite in your browser. Click Favorites > Add to Favorites in the Internet Explorer toolbar. 
 
Or, create a shortcut to that URL on your desktop: 
 

1. Right‐click on your Windows desktop and select New > Shortcut.   
2. Paste in the URL:  https://cms.mcgill.ca/webtop and click Next.   

Type in a name such as “McGill Webtop” and click Finish. 
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Exploring Webtop Interface 

The Webtop interface looks very similar to Microsoft Explorer in Windows. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Webtop interface: Navigation tree in left‐hand pane, Contents on the right. 
 
 

Tree pane 

 
In the left‐hand pane you see a tree‐view structure of files. There are different types of functions: 
 
Inbox – This contains tasks and notifications. 
 
Saved Searches – This contains pre‐defined searches that you have saved 
 
Subscriptions – You can subscribe a file to someone or yourself for easier access to the file. This file will appear 

in the Subscriptions function. When you access this file from the Subscriptions function, the file is retrieved 

from its original repository location. 
 
My Files – This is a list of files that are your recent files. Note that this will not be used for the eCalendar. 
 
Categories – Categories are not being used at McGill. 
 
My Home Cabinet – This is similar to My Documents in Windows. It allows you to store links (shortcuts) to the 

files and folders from other cabinets for easy access. When you have included some folders in this cabinet, 

click the plus sign next to a folder to expand the view or click the minus sign next to a folder to collapse the 

view. 
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Cabinets – These are all the cabinets in the current repository that you have permission to view. Note that you 

may not have permission to edit all of the files within these cabinets. Click the plus sign next to a folder to 

expand the view, or the minus sign to collapse the view. 

 

Content Pane – Depending on what you choose from the Tree pane, you will see its folder and/or files in the content 

pane. The content pane of the My Home Cabinet includes the navigation path, menu bar, viewing options, 

files/folders listing. 
 
Menu bar – The menu bar above the content pane contains context‐sensitive actions that you can perform depending on what 
is selected. 
 
Navigation path – The Navigation path is located just below the menu bar. It is similar to “breadcrumbs” that you may see on 
web pages, it shows the folder hierarchy of the current contents. You can click on folders within the path to navigate back up 
the hierarchy. 
 
Viewing options  

You can view your files and folders in details or thumbnail view
3 

   
 

  

2 
 

 1  
 

 
1. This allows you to choose if you want to view your files and folders in details or thumbnail view.   
2. This only appears if there is a large number of items for viewing.   
3. This allows you to choose the number of items to display on a page.  

 
Files/folders listing  
When you select a folder from the Tree pane, the list of files within that folder appears on the content pane. Here 

you can view the default setting details of each file, such as: 
 

• Format – type or application associated with the file (Word, HTML, XML, JPEG, etc.)   
• Name – of the file or folder   
• Modified – date the file or folder was last updated   
• Category – special project‐specific designation for certain files   
• Version – the current version number for the file  

 
 
You can customize the default attributes that appear in this view by clicking the icon that looks like this: 
 
In the Preferences: Display Settings: Columns for Cabinets window, use the left and right arrow buttons to add 

or remove attributes (properties); use the up and down arrow buttons to position the attributes from left to 

right within the content pane. 
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Note that changes made using this button only affect the content that you are currently viewing. To change 

the default column settings  for all cabinets, click Tools > Preferences  from  the Menu bar, click  the Columns 

tab, and follow the same procedure. 

 

Logging Out 
When you are finished working in the CMS or if you are leaving your workstation unattended, click the Logout button, 

in the upper left corner of the screen. 
 
 
 
 
 
 
 

 
This ensures that your session is closed properly and that no one else can access files or folders while you are away. 

The CMS keeps track of all file modifications and you are responsible for any changes made to files in your name. 
 

Managing Files 
Documentum, like other content management systems, uses a system of locking files such that when you are 

editing a file no one else can edit that same file. This is also referred to as “checking out” the content. When 

you have finished making changes to the file, you need to “check in” that file so that others can access it. 
 

In the content pane, files that are checked out to you have a key icon   next to them and files that 

are checked out to others have a lock icon  . 
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Note: When you check out a file, the system automatically creates a temporary copy of the file in your 

local computer. For example, if you use Word 2003, you can click on File> Save As and then you will see 

where it is being saved. 

 

The location of the temporary copy could be in the following path: 

C:\\Documents and Settings\your_local_username\Documentum\Checkout 

OR 

C:\\Users\your_local_username\Documentum\Checkout 
 

Procedure to manage your files 
The procedure of managing your files is: 
 

1. Edit your file to modify it   
2. Check in your file when you are finished editing it  

 
There are two other ways to manage your files: 
 

• Check out: it locks the file to prevent others from modifying it   
• Cancel check out: cancels the lock on the selected file (Note: you will lose any changes to the file.) 

 

Editing a file 
When you edit a file, the system will automatically check out the file so that others cannot modify it. 
 
To edit a file: From the content pane, right‐click on the file and select Edit from the pop‐up menu. The file 

will be automatically checked out to you (locked for others) and it will open in the application associated 

with it. (Note that you can also select the file and click File > Edit from the menu.) 

 

 

 
 
 
 
 
 

 
 

After you click on Edit, you will see a key icon    and other users will see a lock icon    next to the file.  
This means: 
 

 Others cannot make changes to it 
 Others can only view the last version(s) 

 The Edit function is disabled for other users 

 Others cannot see new changes being made 
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If you work with Webtop from multiple computers, be sure to Check In any files before moving to the other computer – 

otherwise they will be locked on the computer where they were originally checked out. 

Checking In a file 
 
When you are finished editing a file, you need to Check In the file to save it in Webtop and others can access 

it. The procedure of checking in the file also saves it with a new version number, so that there is a record of 

the changes made since the last time it was edited. 
 
You can tell if your file is still checked out by looking for the key icon   beside the file name: 
 

1. From the content pane, right‐click on the file and select Check In from the pop‐up menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 

(Alternatively, you can select the file and click File > Check In from the Webtop menu.) 

 
2. The  Check  In window  allows  you  to  add  details  about  the  current  version  of  the  file  that  you  are 

checking in:  

a. Display the name of the document.  
b. Select the version number of the document. 
c. Depending on your project, you may want  to provide a Description  to help  identify 

this particular version. 
 
 
 
 
 
 
 a 
 
 
 b 
 

   c 
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3. The following additional option is available when you click Show options in the Check In window:   

a. Subscribe  to  this  file:  This  allows  you  to  have  a  quicker  access  to  the  file.  The  file  is  linked  to  your 

Subscriptions which is located on the Tree pane.  

 

4. Click OK to continue. The message area will display a confirmation: Checkin successful. In the content pane, you will 

notice that the key icon has disappeared and the Version number of the file reflects the settings you specified when 

you checked it in.  
 

Note: if you do not see the Version column, you can add it using the Column preferences icon.  
 

Checking Out a file 
When you check out a file, it will automatically check out the selected file and lock it so other users cannot modify it. It is 

recommended to use the Check Out procedure when you want to lock the file because you are not finished with it and you 

don’t want others to work on it. 
 
To Check Out a file: From the content pane, right‐click on the file and select Check Out from the pop‐up menu. (Alternatively, 

you can select the file and click File > Check Out from the menu.) 

If you use the Check Out procedure and you want to now edit the file, you can do so by selecting File > Edit. 

 

Cancel Checkout 

If you checked out a file, but did not end up making any changes to that file, you can choose Cancel Checkout to effectively undo 

the checkout. In this case, any changes you may have made to the local copy of the file will not be saved. 

Searches 

Advanced search 
After you log into Webtop, 

1. On the top of the Tree pane, click on the drop down arrow    

2. Click Advanced.    

3. An Advanced Search: General window appears and change the following fields:  

a. Beside Object Type  field,  click on  the drop‐down  list  and  select eCalendar Document  (eCalendar 
_document).  

b. Beside Properties field, there are three drop down  lists. Follow these steps to add the Editor, Approver 
and Coordinator role criteria:  
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i. Select the same criteria  (Editor, =  , and your name)  in drop down  lists as the following 
screenshot for the Editor role:  

ii. To add another role, click on Add another property  link. Another set of criteria will appear and 
select Or.  

iii. Select the same criteria  (Approver, =  , and your name)  in drop down  lists as the following 
screenshot for the Approver role:  

iv. To add another role, click on Add another property  link. Another set of criteria will appear and 
select Or.  

v. Select the same criteria  (Coordinator, =  , and your name)  in drop down  lists as the following 
screenshot for the Coordinator role:  

c. Click on Search button when you are ready to begin your search. 

4.  The Search Results will appear on the Content pane. 

Saved searches 
You can now save your search results to put it in the Saved Searches from the Tree pane. 
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How to save your search results 

1.  After you have finished the steps for Advanced search, you will be in a Search Results view in the Content pane. 

2. Click Save.    
3. A Save Your Search window appears and change the following fields:  

a. Beside Name field, enter a name for your save results (e.g. Editor)  

b. Beside Description field, enter a description to describe your save results (e.g. eCalendar topics) or leave it 
blank if desired.  

c. Make sure you uncheck Include Results and Make Public  

d. Click OK.  

How to view your save results and begin editing the XML document 

1. From the Tree pane, click Saved Searches.  
2. You will see the name of your save results on the Content pane. Double‐click on the name of your saved results.  

3. You will see all the XML documents that are assigned to you. Right‐click on the XML document and select Edit 
from the pop‐up menu.  

4. Follow the instruction on  how to insert elements in XMAX.  
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Webtop Inbox 
Your Inbox contains tasks and notifications. Tasks are electronic assignments. For example, a task can be assigned to you 

manually by the Managing Editor. 

Notifications are messages that an event has occurred. For example, if you are working on some documents jointly with co‐

workers and you want to be notified whenever one of those documents is edited and checked in. Here is a screenshot of 

the Webtop Inbox: 

1 2 

3 

4 

1. Inbox options 2. Inbox items 3. Notifications 4. Task icons 

Inbox options 

Availability status 

This is used to inform others that you are available or not available. Note that this feature is not currently being used for  

eCalendar work. 

The default status is available. If you are not available, for example, going on vacation, do the following: 

1. Click on I am available link.  

2. Put a check mark on I am currently unavailable… 

3. Click Edit to assign it to someone else.  

4. Find the person you want to reassign the task to and click OK.  
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Get next task automatically 

Leave this box unchecked: 

 
 
 

Note that this feature is not currently being used for eCalendar work. 

Inbox items 
In the Inbox, different types of items are identified by their icon: 

Default Columns 
 
 
 
 

 
Subject: This contains the name of the XML document and the type of task. Each role will have a different task 

description displayed under the Subject column. 

• For the Editor, there are three types of task:  
1. Edit ‐ when you need to view the content and make necessary changes to the document  

2. Edit (more changes needed)  ‐ when the Approver has sent the document back to you; check the 

comments to see what other changes are needed.  

3. Create New Topic – this will be used for future production cycles of the eCalendar.  

• For the Approver, there is only one task type called, “Approve”.  

• For Coordinator, there is only one task type called, “Coordinator sign off”.  

From: It identifies who created the file by their username. 

Date Received: The date and time the task was assigned. 

Due Date: The date and time the task needs to be completed. Note that this feature is not currently being used in the 

eCalendar project. 

Status: The status will change based on your interaction with the task. When you receive the task, the status is Dormant. 

The status changes to Acquired once you open the task (whether or not you open the actual document). 

Repository: It will tell you the location of the file. 

Priority: Not currently being used at McGill. 
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Note: If you want to change the default columns: 

1. Click Tools > Preferences.  

2. Click Columns tab.  

3. Scroll down to Inbox and click Edit.  

4. Choose which attributes you want to display on the inbox content pane  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Notifications 
There are two different notification types: 

Change notification: Notifies you when file(s) have been checked in. From the Subject column, you will see this: 

Turn on change notification: 

1. From the task view, right‐click the file  

2. Select Turn on Change Notification from the pop‐up menu  

Read notification: Notifies you when someone has read the file(s). From the Subject column, you will see this: 

Turn on read notification: 

1. From the task view, right‐click the file  

2. Select Turn on Read Notification from the pop‐up menu.  
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Task view 

From the Inbox listing, click on the task to see this view: 

1 

2 

Task view in Content pane includes: 1) Tabs and 2) Action buttons 

Tabs 

The tabs are Info, Comments, and Progress. 

Info tab 
This tab contains the name of the document, the name of who sent it and instructions. The bottom half of this tab 

contains the attached XML document and this is where you can take action on the document such as view, edit, turn on 

notifications and more. 
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Comments tab 
This tab allows you to enter any comments about the XML document. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To add a comment: 

1. Click Add  
2. In the Comment field, type your comment.  
3. Select one of the following radio buttons:  

a. For subsequent recipients ‐ Sends the comment to all users performing all future tasks in the workflow.  

b. For next recipients only ‐ Sends the comment only to the users performing the next task in the workflow.  

4. Click OK. 

Note: Enter any comments about the document before you click on any of the action buttons (Forward, Finish, Reject). You will not 
be able to add comments once the document is submitted to another user of the workflow. 

Progress tab 
This tab allows you to see the upcoming as well as past events of the workflow. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Action buttons 
The action buttons are different for Editor, Approver, and Coordinator. 
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• Editor  

You will see all of these buttons in each of the tabs.  

 Next/ previous: allows you to navigate through the tabs 
 Finish: sends it to the Approver 
 Close: brings it back to the main Inbox which is your list of tasks 


• Approver  

You will see all of these buttons in each of the tabs.  

 Next/ previous: allows you to navigate through the tabs 
 Forward: sends it to the Coordinator 
 Reject: sends it back to the Editor 
 Close: brings it back to the main Inbox which is your list of tasks 


• Coordinator  

You will see all of these buttons in each of the tabs.  

 Next/ previous: allows you to navigate through the tabs 
 Forward: you have to sign off and it will send it to the Managing Editor 
 Reject: sends it back to the Editor or Approver 
 Close: brings it back to the main Inbox which is your list of tasks 

Getting Started for Individual Roles 
The following is step by step instructions for the Editor, Approver, and Coordinator in Webtop: 

Editor’s role 
After you log into Webtop: 

1. If you clicked on the task  link from an email, the task view will open automatically. Otherwise, go to the Inbox 

from the tree pane and double‐click on the task.  
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2. From the Info tab, read the instructions  

3. Edit the XML document:  

a.  From the bottom of the Info tab, right‐click on the document and click Edit.  

b. Follow the instruction on how to insert  elements in XMAX.  

4. Complete the task:  

a. Once you have made your changes to your XML document and you are ready to send it to the Approver, 

click Finish.  

b. Click OK.  

Approver’s Role 

After you have logged into Webtop: 

1. If you clicked on the task  link from an email, the task view will open automatically. Otherwise, go to the Inbox 

from the Tree pane and double‐click on the task.  

2. From the Info tab, read the instructions  

3. Edit the XML document:  

a.  From the bottom of the Info tab, right‐click on the document and click Edit.  
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b. Follow the instruction on how to insert elements in XMAX.  

4. Reject a task: if you feel that you need the Editor to further modify the topic, you can reject the task back to the 

Editor.  

a. From the Info tab perform action buttons; click Reject.  

b. The task will be removed from your Inbox and sends it back to the Editor.  

c. Once the Editor has made the changes to the document, the task will be returned to you.  

5. Complete the task: Once you have made your changes to your XML document and you are ready to send it to the 

Coordinator, click Forward.  

Coordinator’s Role 

After you have logged into Webtop: 

1. If you clicked on the task  link from an email, the task view will open automatically. Otherwise, go to the Inbox 

from the Tree pane and double‐click on the task.  

2. From the Info tab, read the instructions  

3. Edit the XML document:  

a. From the bottom of the Info tab, right‐click on the document and click Edit.  

b. Follow the instruction on how to insert  elements in XMAX.  



2730 September 2014 

4. Reject a task: if you feel you need the editor or approver to further modify the topic, you can reject the task back to 

the Editor or Approver.  

a. From the Info tab perform action buttons; click Reject.  

b. Choose if you want to reject it to the Approver or Editor.  

c. The task will be removed from your Inbox and sends it back to the Editor or Approver.  

d. The task will be returned to you when the additional changes have been made.  

5. Complete the task:  

a. Once you have made your changes to your XML document and you are ready to send it to the Managing Editor 

click Forward.  

b. You will be prompted to sign off using your McGill Password (of your McGill Username).  

c.  Click OK. 
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XMAX 

What is XMAX 

XMAX is integrated with Webtop. It is used to create and modify XML documents. Elements are used to identify distinct 

types of content such a paragraph, lists, tables, and more. The eCalendar uses a small subset of the available elements and 

they are described below. XMAX has many capabilities such as text editing, spell checking, and XML validation. 

Browser requirement 
XMAX only works in Internet Explorer 7 or 8. 

Getting started for the individual’s role 

The following are steps on how to access XMAX and how to edit XML document for the Editor, Approver and Coordinator. 

Editor’s role 
Once you log into Webtop, click on a task from the Inbox Content pane. Then, the Task view will open. 

1. Right‐ click on the XML document at the bottom of the Info tab and click Edit. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
2. XMAX will open. 

You will see a pop up window indicating that Change Tracking is on. Click OK. 

3. Review the content of the document and make modification if needed (See section on  XML elements) 
4. Spell check your document (See  Spell checker for more information) 
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5. Save (File > Save) 
6. Check In (File > Check In) 
7. The Checkin window displays. Click OK. Ignore the version radio buttons as we will not be using this 
8. XMAX will close and you will return to Webtop Inbox 
9. Double‐click on the task corresponding to the document that you just edited. The Task view will open 
10. At this point, you shouldn’t see the key icon beside the document name from Info tab. 
11. Add any comments about the document from the Comments tab. 
12. Click Finish to submit it to the Approver. 

 
• Make sure that you have finished making all your changes to the document 
• If you see the key icon beside your document from the Task view, this means that you have 

the file  checked out and you need to  check it in. 
• Add all your comments 

Approver’s role 
Once you log into Webtop, click on a task from the Inbox Content pane. Then, the Task view will open. 

1.  Right‐ click on the XML document and click Edit. 

XMAX will open. 

2.  You will see a pop up window indicating that Change Tracking is on. Click OK. 

• Make sure that you have finished making all your changes to the document 
• If you see the key icon beside your document from the Task view, this means that 

you have the file checked out and you need to  check it in. 

• Add all your comments 
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3. Review the content of the document and make modification if needed (See section on  XML elements) 
4. Spell check your document (See  Spell checker for more information) 
5. Save (File > Save) 
6. Check In (File > Check In) 

Click OK. Ignore the version radio buttons as we will not be using this. 
7. XMAX will close and you will return to Webtop Inbox. 
8. Double‐click on the task corresponding to the document that you just edited. The Task view will open. 

At this point, you shouldn’t see the key icon beside the document name from Info tab. 
9. Add any comments about the document from the Comments tab. 
10. Click Forward to submit it to the Coordinator. 

Coordinator’s Role 

Once you log into Webtop, click on a task from the Inbox Content pane. Then, the Task view will open.  

1. Right‐ click on the XML document and click Edit 

XMAX will open. 

2. You will see a pop up window indicating that Change Tracking is on. Click OK. 
3. Review the content of the document and make modification if needed (See section on  XML elements)  

4. Spell check your document (See  Spell checker for more information)  

5. Save (File > Save)  

6. Check In (File > Check In)  

The  Checkin window displays. Click OK. Ignore the version radio buttons as we will not be using this. 
7. XMAX will close and you will return to Webtop Inbox.  
8. Double‐click on the task corresponding to the document that you just edited. The Task view will open. At 

this point, you shouldn’t see the key icon beside the document name from Info tab. 

9. Add any comments about the document from the Comments tab 

10. Click Forward to submit it to the Copy Editor. 
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If you click on any of the action buttons, this will remove the XML document from your Inbox and you will not be 

able to make any more changes to it. Therefore, before clicking on any of the action buttons: 

 Make sure that you have finished making all your changes to the document 

 If you see the key icon beside your document from the Task view, this means that you have the file 

checked out and you need to  check it in. 

 Add all your comments. 

XMAX interface 

The application interface includes a variety of visual components to identify and manage content. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4: XMAX interface‐ Menu and toolbars on the top, the content area on the left side, the element list on the right side 

Menu and toolbars 
Menu bar 
This menu bar includes File, Edit, View, Insert, Tools, Table, and Help. 

 
 
 



3230 September 2014 

Standard toolbar 
This toolbar includes icons for common tasks such as saving, find, copy, paste and etc. 

 
 
 

Formatting toolbar 
This toolbar includes icons for applying common formats such as bold, italic, and lists. 

 
 
 

Table toolbar 
This toolbar includes icons for working with tables such as merging, inserting, deleting rows or columns and etc. 

 
 
 

Content area 
The content area is where you add or modify content using XML elements. 

View 
There are two views that you can choose to display your XML document: Tag and Normal view. These two views are 

located on the left‐bottom of the interface. 

Tag view 
This is the default view. It shows the beginning and the end of each  element using icons. We recommend that you use 

this view to ensure that you don’t have any broken elements and to easily see what elements are being used as well as 

what elements you are inserting. 
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Normal view   
Normal view is used to see the text without the element tags. 

Element list pane 
The Element List is where you choose elements to insert into your document. Depending on the location of your cursor 

within the content area, the system will display the list of other elements that can be used. 

General Word Processing Functions 

XMAX has the following word processing functions: 

Selecting, deselecting text 
To select text you need to highlight it and there are several ways to do this. Using the mouse or the keyboard, you can 

select text character by character word by word, and paragraph by paragraph. 

Select a word 
Double click on the word to select 

Select words, paragraph, 
1. Use the mouse and click to where you want the insertion to start the selection  
2. Click once and continue to hold down the mouse while dragging across multiple  letters to where you want the 

end selection to stop.  

Deselect text 
If a word or paragraph is selected, click somewhere else in the document to deselect or double click within the selected 

area. 

Delete text 
1. Select the text that you want to delete.  
2. Press on Delete on the keyboard.  

Cutting, copying, pasting text 
If you decide to cut, copy, and paste text, we recommend that you do these functions in Tag view. If you do it in the 

Normal view, you may break some elements in the document. As a result it will create an invalid XML. 

Clear text 
When you clear a text, it removes the text from the document and does not store it in the clipboard for pasting 

somewhere else in the document. 

1. Select the text.  
2. Press Delete on the keyboard.  
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Cut text 
When you cut a text, you are removing the text and putting it in the clipboard for pasting somewhere else in the 

document. 

1. Select the text.  
2. Click Edit > Cut (Ctrl +x)  

Copy text 
When you copy a text, you are not removing the text from its original location instead you are storing it in the clipboard 

for pasting somewhere else in the document. 

1. Select the text.  
2. Click Edit > Copy (Ctrl + c)  

Paste text 
When you paste a text, you are inserting text that was last cut or copied to the clipboard. 

1. Insert the cursor to the correct location by using the mouse and click on the location where you want the text to be 

paste  

2. Click Edit > Paste(Ctrl + v)  

Undo text 
You can use undo action until the last time you saved the file. 

To Undo, click Edit > Undo (or use the keyboard shortcut, Ctrl + z) 

Save file 
You should save your file on a frequent basis, such as when you have made a major change or have finished modifying a 

small change. 

To Save, click File > Save (or click on the icon   from the toolbar) 

Note: if you forget to save your file and you clicked on File> Check In, the system will ask you if you want to save the file. 

Note: Ctrl + s will not save your document. 

Find or find/ replace 
Find 
You can quickly search for every occurrence of specific word or phrase in your document. 

1. Click Edit > Find and Replace (or click on the icon   from the toolbar)  
2. Beside Find field, enter the word or phrase that you are looking for in the document. 
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3. Click Find.  

Find/ Replace 
You can automatically replace a word or phrase with another‐ for example, you can replace Winter 2008 with Summer 

2009. When you replace a word or phrase, you have to set the appropriate criteria for your replacement action. 

1. Click Edit > Find and Replace (or click on the icon   from the toolbar)  
2. Beside Find field, enter the word or phrase that you are looking for in the document.  

3. Beside Replace field, enter the new word or phrase    
4. Click on the checkbox(es) for the replacement criteria.  

5. Click Replace, Replace, Find or Replace All.  

Elements 

Elements are similar to HTML tags. Elements define which tags you are allowed to insert in your document. Tags have a 

beginning (left‐side) and end (right side). 

The beginning tag also allows you to collapse or expand the element. 

• If it is collapsed, it looks like this:   .  

• If it is expanded, it looks like this   .  
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An element can also be nested within another element. For example, the bold element is nested within the paragraph 

element. 

• 

Inserting an element 
Depending on where your cursor is in the content area, the Element List pane will display the elements that you can use at 

that point. This feature ensures that you will not make any error in your XML document. For example, if you put your 

cursor at the end of the paragraph tag, and you want to insert a bold element, the bold element will not display in the 

Element List pane. 

1. Position your cursor in the content area (this will depend on the type of element you want to insert, see  

Commonly used elements)  

2. Choose an element from the Element list by clicking on it.  

Selecting an Element 

To select any element that is already inserted in the document, it is best to click on the end tag of the element. Here are 

different scenarios of selecting an element: 

• An element:  

• An element within other elements  

• A group of nested elements (e.g. in this paragraph element, you are also selecting the bold and italic element.)  

Commonly used elements 
This section describes the commonly used elements for the eCalendar project. 

Paragraph <p> 
 
 
 

To insert a paragraph element you can either, 

1. Position your cursor within the body element but not within an existing paragraph, table, or lists element  

2. Choose <p> from the Element List  

or 
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1. Place your cursor after an existing end paragraph tag    

2. Start typing (this will automatically create the correct paragraph XML element).  

Formatting elements 

Bold <b> 
 
 
 

This is used for when you want to emphasize on a word or phrase. 

To insert a bold element, you can use either of the two methods below. 

1. Select a text or some text within a paragraph, table, or lists element  

2. Choose <b> from the Element List  

3. You will see the bold tag and start typing your text or  

1. Place your cursor within a paragraph, table, or lists element  

2. Choose <b> from the Element List  

3. You will see the bold tag and start typing your text  

Note: The first method will not display as track changes. 

Underline <u> 
 
 
 

This is used when you want to underline a word or phrase. 

To insert an underline element, you can use either of the two methods below. 

1. Select a text or some text within a paragraph, table, or lists element  

2. Choose <u> from the Element List  

3. You will see the bold tag and start typing your text or  

1. Place your cursor within a paragraph, table, or lists element  

2. Choose <u> from the Element List  

3. You will see the underline tag and start typing your text  

Note: The first method will not display as track changes. 

Italic <i> 
 
 
 

This is used when you want to emphasize on a word or a phrase. 
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To insert an italicized element, you can use either of the two methods below. 

1. Select a text or some text within a paragraph, table, or lists element  

2. Choose <i> from the Element List  

3. You will see the italicized tag and start typing your text 

or  

1. Place your cursor within a paragraph, table, or lists element  

2. Choose <i> from the Element List  

3. You will see the italicized tag and start typing your text  

Note: The first method will not display as track changes. 

Citation <cite> 
 
 
 

This is used to italicize the reference material (e.g. book, journal, etc.) 

To insert a citation element, you can use either of the two methods below. 

1. Select a text or some text within a paragraph, table, or lists element  
2. Choose <cite> from the Element List  
3. You will see the citation tag and start typing your text  

or  

1. Place your cursor within a paragraph, table, or lists element  
2. Choose <cite> from the Element List  
3. You will see the citation tag and start typing your text  

Note: The first method will not display as track changes. 

Note <note> 
 
 
 

This is used for drawing attention to a point and the content in the note element will have a different format from the 

document. 

To insert a note element, you can: 

1. Position your cursor within the body element but not within an existing paragraph, table, or lists element  
2. Choose <note> from the Element List  
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Lists elements 

Simple List 
 
 
 
 
 
 
 
 

 
This is used when you want to create an address. 

To insert a simple list element, you can: 

1. Position your cursor within the body element but not within an existing paragraph, table, or lists element  
2. Choose <sl> from the Element List  
3. Start typing your text (it will automatically create a sub‐list)  
4. If you want to add more sub‐list item for the simple list element, position your cursor before the end of the </sli> 

tag and press enter on your keyboard. This will automatically create a new sub‐list.  

Unordered list <ul> 
 
 
 
 
 
 

The default unordered list is a bullet and you can create a dashed list. You should create the unordered list by itself and 

not within a paragraph element. 

To create a bulleted list (default): 

1. Put your cursor at the end of a paragraph, table, or ordered list element.  
2. Choose < ul> from the Element List.  
3. Choose <li> from the Element List to start the list or just start typing and the <li> will be created automatically.  
4. If you want to add another <li>, put the cursor before the end of </li> tag and press Enter on the keyboard.  

To create a dashed list: 

1. Put your cursor at the end of a paragraph a paragraph, table, or ordered list element.  
2. Choose < ul> from the Element List.  
3. Choose <li> from the Element List to start the list or just start typing and the <li> will be created automatically.  
4. If you want to add another <li>, put the cursor before the end of </li> tag and press Enter on the keyboard.  
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5. Once you finished creating your unordered list, you have to change the type attribute field to dash.  
a. Click one of the end </li> tag to select it  
b. Click View > Attribute Inspector  
c. Locate type attribute and enter the word “dash”  

d.  Turn off the Attribute Inspector by clicking on View > Attribute Inspector 

Note: you will only see changes to the style of the list, once it is published. 

Ordered list <ol> 
The default ordered list is a numbered list and you can create other types of list (see Table 1). You should create the 

unordered list by itself and not within a paragraph element. 
 
 
 
 
 

 

Table 1 

List type Displays Attribute Inspector(Type)
 

   
 

Alphabetic a. b. c. alpha
 

   
 

Upper alphabetic 
A. B. C. upperalpha  

 
 

   
 

Roman i. ii. iii. roman
 

   
 

Upper roman I. II. III. upperroman
 

   
 

To create a numbered list (default): 

1. Put your cursor at the end of a paragraph, table, or unordered list element.  
2. Choose < ol> from the Element List.  
3. Choose <li> from the Element List to start the list or just start typing and the <li> will be created automatically.  
4. If you want to add another list item, put the cursor before the end of </li> element and press Enter on the 

keyboard.  
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To create other lists: 

1. Put your cursor at the end of a paragraph, table, or unordered list element.  
2. Choose < ol> from the Element List.  
3. Choose <li> from the Element List to start the list or just start typing and the <li> will be created automatically.  
4. If you want to add another list, put the cursor before the end of </li> element and press Enter on the keyboard.  
5. Once you finished creating your ordered list, you have to change the type attribute field.  

a. Click one of the end </li> tag to select it  

b. Click View > Attribute Inspector  

c. From the Attribute Inspector pane, locate type attribute.  

d. From Table 1 above, choose the list type you want to use and beside the type attribute field enter the 

corresponding Attribute Inspector (Type) column. For example, in this screenshot, we are choosing the 

alphabetic list type and we entered ”alpha” in the type field.  

e. Turn off the Attribute Inspector by clicking on View > Attribute Inspector. 

Note: you will only see changes to the style of the list, once it is published. 

Table 

This is used to create a table in your XML document. 
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To insert a table: 

1. Click Table > Insert Table.  

2. Select the number of rows and columns.  

 
3.  Click OK. You should see the Table inserted in your XML document. 

For other Table features, do the following: 

1. Once you insert the table, put your cursor inside a cell.  
2. Click Table menu and choose any of the features from the Table drop down list  

Note: Do not insert a Table from the Element List pane; use the Insert menu. 
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Short title <title> vs long title<ltitle> 

A short title and long title appear at the beginning of the XML document. 

A short title is a title of the XML document. You will only be able to modify the text of a short title and you should insert a 

comment (Insert>Comment) beside the short title element as to why you are changing the short title. 

A long title is to further describe the short title. For example, the short title is Admission Requirements and the long title is 

Admission Requirements‐ Law faculty. You will only be able to modify the text of a long title. 

Comment 
 
 
 

Comment element is hidden from the final publication of your document. It is used to indicate the reasons for the new 

change, to ask questions to others in the workflow, or to add additional information about the changes made in the XML 

document. For example, when you change the title of the document, you would use a comment element to explain for the 

change. 

To insert a comment element, 

1. Position your cursor within the body element  
2. Click on Insert > Comment  

Linking <xref> 

<xref> element is used within a paragraph element. There are two different ways to link: 

A. Link to a file: This allows you to create a link to another file.  
1. Put your cursor to where you want to insert the website  
2. Click Insert > Cross Reference  
3. Find the file by choosing the correct cabinet  
4. When you find your file, click and drag the file to the where you want put in content area.  
5. Click Yes in the pop‐up window. This is how it looks like when you link to another file 
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6. Verify that the scope attribute field in the Attribute Inspector pane is internal.  
a. Click text inside the <xref> tag.  
b. Click View > Attribute Inspector  
c. Scroll down to locate scope attribute  
d. The scope attribute field should be internal, if not type the word, “internal”  
e. Turn off the Attribute Inspector by clicking on View > Attribute Inspector  

If you want to replace the web address with a text: 

1. Click and drag with your mouse to highlight the web address (make sure you don’t delete the xref)  
2. Type the desired text  

Note: You can only link to files that appear under your faculty cabinet in the Tree pane. You can’t link a file within 

the same topic. 

 
B. Link to a website: This allows you to create a link to a website onto your XML document.  

1. Put your cursor to where you want to insert the website  

2. Click Insert menu> Web Link  

3. Enter the whole web address  

4. Click OK.  

This is how it looks like when it is inserted in the content area.  

5. Verify if that the scope attribute field in the Attribute Inspector pane is external:  

a. Click text inside the <xref> tag.  

b. Click View > Attribute Inspector  

c. Scroll down to locate scope attribute  

d. The scope attribute field should be external, if not type the word, “external”  

e. Turn off the Attribute Inspector by clicking on View > Attribute Inspector  
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If you want to replace the web address with a text: 

1. Click and drag with your mouse to highlight the web address (make sure you don’t delete the xref)  

2. Type the desired text  

Note: After you have entered the text, hover your mouse over the beginning or end xref tag to see the web 
address. 

Mailto 

This allows you to create an email address onto your XML document. 

1. Put your cursor to where you want to insert the email address  
2. Click Insert > Email  
3. Enter the email address  

4. Click OK.  

This is how it looks like when it is inserted in the content area.  

5. Verify that the scope attribute field in the Attribute Inspector pane is external.  
a. Click text inside the <xref> tag.  
b. Click View > Attribute Inspector  
c. Scroll down to locate scope attribute  
d. The scope attribute field should be external, if not type the word, “external”  
e. Turn off the Attribute Inspector by clicking on View > Attribute Inspector  
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If you want to replace the email address with a text: 

1. Click and drag with your mouse to highlight the email address (make sure you don’t delete the xref)  
2. Type the desired text  

Advanced Elements 

Subtopic <topic> 

A subtopic is created when it is desired to have a topic that is always linked to the topic above it. In a PDF rendition it will 

have a header in bold, with no numbering. Before creating a subtopic, you may want to consider creating a new standalone 

topic instead. Please consult the managing editor at ecalendarsupport.es@mcgill.ca regarding the various options before 

proceeding to create a subtopic. 

A subtopic will look like this in XML: “The National Program since 1968 and the Faculty’s New Curriculum”. An example of a 

topic that has several subtopics would be “Tuition Fees”. To see where a subtopic ends, click on the end </topic> tag; this 

will highlight the whole subtopic. 

 
 
 
 
 

How to create a Subtopic topic 

1. Put your cursor before the end </topic> tag at the end of the chunk  
2. Double click on topic in the element list (It should have a default Topic ID, if not save it with the invalid code and 

consult the managing editor)  
3. Double click on title and enter the title of the subtopic  
4. Put your cursor after the /title tag, double click on ltitle in the element list and enter the long title  
5. Put your cursor after the /ltitle tag, double click on body in the element list and enter the text for the subtopic  
6. Go to the View menu and click on Attribute Inspector  
7. Click on the title tags of the subtopic and locate “numbered” in the Attribute Inspector; type no in the field next to 

numbered.  

Superscript <sup> 

This is useful for when displaying indicators (e.g. numbers, symbols) that appear smaller and are above the baseline. For 

example, May 5th (the superscript is th). 

Subscript <sub> 

This is useful for when displaying indicators (e.g. numbers, symbols) that appear smaller and are below the baseline. For example, a 

chemical compound 2O; the subscript is 2. 
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Tips for Inserting Elements 

The following are tips to keep in mind when you insert an element: 

• Use the elements that is mentioned on  Commonly used elements and advanced elements .  
• Don’t create a table, notes, and list element within a paragraph element; it is best to create a table element by 

itself.  
• You can insert accented characters using the keyboard shortcuts (e.g. alt + 130) or on a PC computer use the 

Character Map (Click Start menu > All Programs > System Tools > Character Map).  
• All special characters work in XMAX; it will transform them in the special encoding code if necessary.  
• Use the “Enter” button carefully. Hitting the ‘Enter’ button inserts a new element For example, if you are in a list, 

pressing the ‘Enter’ button inserts a new list item.  
• You have to insert the following elements within a paragraph, table, or lists element:  

o Bold 
o Underline 
o Cite 
o Italicize 
o Linking <xref> 
o Mailto 

  

Track Changes 
Track changes allow you to keep track of any modifications when any modifications are made to content – inserted, 

deleted, moved or modified text in the XML document. 

When you edit your XML document, a pop‐up window appears. Click OK to turn on the Track Changes. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Track Changes are always on. You will then default to tag view. Any modifications to your document will be reflected  in 

your document. Be aware, however, that several modifications are not tracked – changes to elements (e.g. bold,  italics, 

underline), additions or deletions of rows of existing tables. When this occurs, please create a comment to describe and 

highlight the change that you have made. 
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Track changes display 
Since Track Changes  is automatically turned on, modifications you make appear  in a format that  is according to system 

defaults. Here  is an example of how track changes are displayed on an XML document for adding, deleting, and moving 

content. The text is displayed in revision marks. 

• Adding and moving    

• Deleting    

Viewing track changes 
If you already see some track changes when you access the document, it means that another user has already modified 

the XML document. If you hover over the changed text, a popup displays the name of the user who made the 

modification as well as the date the modification was made. 
 
 
 
 
 
 
 

How to use Track Changes 

In the XML document, you can use the system to go to the next or previous change. Go to Tools and select the following 

drop down actions: 

 
 
 
 
 
 
 
 
 
 
 
 

Next Change 
To view the next change, click Tools > Next Change. This will place your cursor to the next modified content in the 

document. 

Previous Change 
To view the previous change, click Tools > Previous Change. This will place your cursor to the previous modified content in 

the document. 

Spell Checker 
As with all documents, it is good practice to perform a spell check on it before saving and checking it in. 
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How to use the Spell Checker 
To invoke the Spell Checker: 

1.  Click Tools > Spellchecker 

2.  The Writing Tools pop‐up box will appear with the spelling error. 

Note: Use this feature the same as you would use in any other Spell Checker tool such as in Word. 

3. After the system has verified all the spelling errors  in your XML document, you will see the following message 

and click Yes to close the Spell Checker.  

Set the Language 

You can also set the language of your preference. 

To set the language: 

1. After you have opened the XML document, click Tools > Spellchecker.  
2. From the Writing tools pop‐up window, click on Options > Language.  
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3. A Select Language pop‐up window appears and select the language you desire.  

4. Put a check on Save as default Writing Tools language.  

5. Click OK.  

Validation 
XML documents have to adhere to a set of rules. These set of rules ensure that you do not break the required structure 

when you modify your document. The Element List pane is one of the ways the system validates the XML language. Using 

the Element List pane is preferred since only the Element Lists that can be correctly inserted in the current location are 

listed. This will prevent errors. 

The other way is you can use the Validation feature to thoroughly check your document. Validation finds and reports any 

errors that are found. There are two types of validation errors that may occur: 

1. Missing content  
2. Content that is tagged incorrectly  

Two ways to validate your XML document 
You can perform a check at any time to find validation errors in your document. There are two ways to validate your 

document: you can validate the whole document or validate a selection of your document. 
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1. To validate your document:  
a.  Click Tools > Validate Document.  

2. To validate a selection of your document:  
a. Select the section that you would like to validate.  
b. Click Tools > Validate Selection  

Understanding the Validation Errors 

Errors 
If your document has validation errors, a Validation Log containing a list of one or more error messages displays. For 

example, in the following screenshot, you inserted an unordered element and changed the list type to a dash instead of a 

bullet in the Attribute Inspector pane. You validate your document and it gives you an error indicating that it does not 

recognized the name “dashes,” this means that you have entered the wrong Type name, the name should be “dash.” 
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Note: if you did not understand the errors you can go to the location of an error by double‐click the error message. 

No errors 
If your document does not have any errors the following message displays. Click OK 

 
 
 
 
 
 
 
 
 
 

Best Practices 
When working with XML documents for eCalendar, we recommend the following best practices: 

Do’s Don’ts 
  

• Save any major or minor changes •     Do not modify Prolog information 
•     Use undo feature when you make a mistake • Do not use the Internet Explorer menu 
• Check In when you are finished with your topic • Do not use the Internet Explorer back/forward button

• Use the Comment element  if you are changing the 

Short Title 

• Use only the elements mentioned under the section  

Commonly used elements  

Support 

Login and technical issues: 

o Contact IT Customer Services at 514‐398‐3398 or itsupport@mcgill.ca  

 Questions about the eCalendar process, Webtop, and XMAX: 


o Contact ecalendarsupport.es@mcgill.ca   


