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Naudy Automatic Model interpretation (T43) 
The Naudy Automatic Model tool is a powerful interpretation tool for inferring the 
size, shape and position of magnetic sources using line data.

It can display:
• The inferred geological structures with a profile of the original TMI data, 

indicating similarity coefficients, size, shape and position.
• A profile of a field calculated from the inferred geological structures overlaid in 

the original TMI data, indicating the accuracy of the solutions.
• The extension to support Magnetic tensor gradients has been made during 2011. 

Very similar workflows are supported for this signal to the standard TMI case. 
The main difference lie in the location of anomalies, the determination of the 
magnetization vector direction, and the verification that the anomaly is caused by 
a 2D geology structure. This last point is particularly important, as a TMI signal 
cannot be expected to provide this information.

The tool can then optimise the inferred structures by repeatedly:
1 Calculating and comparing their field with the observed magnetic field, then
2 Adjusting their size, shape and position to improve the fit.
Naudy Automatic Model can save the results as an INTREPID or GEOSOFT points 
dataset, in a format for importing to the Potent modelling package, and joined into 
coherent sheet-like 3D dykes, described by “HOT-SPOT” structural data, for import 
into Geomodeller, the geologists editing and modelling package.

Naudy Automatic Model performs the modelling on data from single, selected 
traverse lines of magnetic surveys.  On each line profile, the tool estimates the 
number, position, dip-angle, and depth to magnetic source.  You can choose ‘body-
type’ as an initial model parameter of the model (for example, dyke, step, flat prism).  
There are various options for estimating strike for the TMI case. Historically, the 
method assumed that the strike of any elongated body is oriented orthogonal to the 
traverse line. A trend-matching method can be used to estiamte the strike locally 
throughout the survey. Once you have a Full magnetic tensor signal, this is not a 
necessary step, as the signal conatins enough local curvatures of the field to un-
ambiguously provide a strike direction for a 2D body.
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Naudy Automatic Model concepts
Body See definition of  ‘Inferred geological structure’ below.
Body strike Direction of an inferred geological structure when viewed from above.
Body dip The angle between the horizontal plane and the long axis of the inferred  

geological structure when viewed in a vertical section at right angles to Body 
strike.

Calculated field The magnetic field that would result from inferred geological 
structures.

Clearance field The height of the measurement sensor above the ground surface. 
This allows source depth estimates to be corrected for aircraft height above 
ground.

Depth increment factor (dif).  INTREPID divides the depth range for calculating 
Naudy solutions into sections according to the depth increment factor.  The height 
of the next depth section is dif times that of the section above.  See Scanning for 
Naudy solutions.

Depth range The range of depths for finding and reporting Naudy solutions.  
INTREPID will not calculate solutions outside this range.

Depth range section See definition of ‘Depth increment factor’ above for an 
explanation.

Distance factor When resampling Naudy solutions INTREPID examines a region 
surrounding each solution.  If the region contains one or more other solutions, 
INTREPID retains the solution with the lowest similarity coefficient and rejects 
the others.  The X and Depth distance factors determine the size of the region 
examined around each solution.  See Resampling the Naudy solutions.

Dyke See definition of ‘Inferred geological structure’ below.
Forward modelling Calculating a model by manually setting parameters and 

examining the calculated results (as opposed to inversion modelling which 
automatically adjusts the parameters so that the calculated result will closely 
match the observed data). 

Geomodeller The sister product, Geomodeller, has a specially tailored import 
facility to directly receive, via a CSV file, the output from this tool, to rapidly help 
create a coherent 3D dyke swarm model. The interface is designed to allow you to 
do repeated trials, to best extract those geology bodies you wish to further 
interpret, in the context of creating a more holistic geology model.

HOT-SPOT Each solution for a 2D body along a profile, can be thought of as an 
intersection between the induced response from a geological body, as observed 
from an airborne sensor. The step of then collecting and sorting all the individual 
solutions into a set of coherent and consistent observation of a set of dykes, is 
sometimes called “Worming”.

Inferred geological structure After calculating Naudy solutions for a line, 
INTREPID can infer the size and position of geological structures likely to cause 
the observed magnetic field.

Interpolation method When preparing line data for the Naudy Automatic Model, 
INTREPID resamples it so that the data points are evenly spaced along the line.  
This involves interpolating between existing data points.  You can select the 
interpolation method.  See Querying lines and setting resampling options.

Inversion process / Inversion modelling See the definition of ‘Refining inferred 
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geological structures’
Naudy model The assemblage of inferred geological structures calculated for all or 

part of a dataset.
Naudy model point dataset Point dataset created by the Naudy Automatic Model 

tool containing Naudy model data.
Naudy sources / Naudy solutions An initial calculation derived from the observed 

magnetic field indicating potential sources for the field and leading to the 
calculation of inferred geological structures.

MTDYKE This is a companion tool, that can take the direct ‘WORMS” output from 
Naudy, via the CSV file format, and predict on to a draped elevation grid, the 
forward model response of the dykes that have been found. In this case, each 
HOT_SPOT body is modelled. Alternatively, the tool also has provision for 
modelling the full 3D sheet-like triangulated description of the same dykes, as 
calculated by geomodeller.

Observed field TMI, Vertical derivative of TMI, Magnetic tensor gradients (FTMG) 
or Gravity tensor gradients (FTG) field recorded in the input line dataset for 
which you wish to calculate inferred geological structures.

Potent modelling package A software package published by PC Potentials which 
enables you to perform interactive magnetic and gravity forward and inversion 
modelling.  

Refining inferred geological structures After calculating Naudy solutions and 
initial inferred geological structures, INTREPID can automatically refine them by 
repeatedly adjusting their size and position and comparing the calculated field 
with the observed field.   See Refining inferred structures and optimising the 
calculated field.

Resampling mode (data preparation) When preparing line data for the Naudy 
Automatic Model, INTREPID resamples it so that the data points are evenly 
spaced along the line.  You can specify whether the even spacing is  geographic 
(based on the X and Y fields) or chronological (based on the Fiducial field).  See 
Resampling mode for data preparation.

Resampling Naudy solutions After calculating Naudy solutions INTREPID selects 
the best ones for the next stage of the process.  See Resampling the Naudy 
solutions.

Similarity coefficient A measure of the similarity between the calculated field of a 
Naudy solution and the observed field.  Similarity coefficients range from 0 to 5, 
where 0 represents perfect match and 5 a low similarity. Method is based on  
scaled autocorrelation between the measured and calculated horizontal and 
vertical field  components of the symmetric parts of the signal profiles. See 
Finding and resampling Naudy solutions.

Source region See definition of ‘Distance factor’ above for an explanation.
Threshold A cutoff value for similarity coefficients above which INTREPID will 

reject a Naudy solution during the resampling process.  See Resampling the 
Naudy solutions

TMI See definition of ‘Total magnetic intensity (TMI) field’ below.
Total magnetic intensity (TMI) field INTREPID uses the total magnetic intensity 

field as the source of data for calculating the Naudy model.  References to the Z 
field of the input dataset in this chapter mean its TMI field.

Trend points See definition of ‘Spline gridding sample points’ above.
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Trend grid A grid created using the trend spline gridding process.  See Specifying 
body strike for the Naudy model point dataset.

Vertical derivative of TMI INTREPID is also able to use the first vertical 
derivative of TMI as the source for calculating the Naudy model

Signal field In this chapter, references to the signal field of the input line dataset 
mean the TMI, Vertical derivative of TMI, magnetic tensor gradients or Gravity 
tensor gradients field.  The field called Elevation in Naudy model point datasets 
contains the estimated Depth to the top of the source model after correction for 
Clearance if requested.
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Using the Naudy Automatic Model tool
The flowchart shown here shows the essential steps in the Naudy Automatic Model 
process.  
Library | Help | Top © 2012 Intrepid Geophysics  | Back | 



INTREPID  User Manual Naudy Automatic Model interpretation (T43) 6
Library | Help | Top  | Back | 
Library | Help | Top © 2012 Intrepid Geophysics  | Back | 



INTREPID  User Manual Naudy Automatic Model interpretation (T43) 7
Library | Help | Top  | Back | 
>> To use Naudy Automatic Model with the INTREPID graphic user interface
1 Choose Naudy Auto Model from the Interpretation menu in the Project Manager, 

or use the command naudyd.exe.  INTREPID displays the Naudy Automatic 
Model Main window.

2 File-> Load Options: If you have previously prepared file specifications and 
parameter settings for Naudy Automatic Model, load the corresponding task 
specification file using Load Options from the File menu. (See Specifying input 
and output files for detailed instructions.)  If all of the specifications are correct in 
this file, go to step 11.  If you wish to modify any settings, carry out the following 
steps as required.  

3 File-> Load Line Dataset: Specify the dataset and Data field for the Naudy 
Automatic Model.  Use Load Line Dataset from the File menu.  (See Specifying 
input and output files for detailed instructions.) Note the support for full tensor 
magnetic gradient signals.  The extension to gravity gradient signal is also a very 
viable possibility, though the development and proving work is lagging. 
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INTREPID displays the first line from the dataset in the Naudy Automatic Model 
window.

4 File-> Save Model As: Once you have completed your modelling run you must 
specify a new output Naudy model point dataset to save your results using Save 
Model As from the File menu. This behaviour is new in Intrepid V4.2.2. In earlier 
versions the model results file was specified at the start of modelling operations
Or
It is no longer possible to load an existing Naudy model point dataset which you 
wish to view, extend or modify in INTREPID V4.2.2. It is available again in V5.0 

5 File-> Specify Report: Before proceeding with a modelling session it is 
recommended that the user specify a report file name for saving the progressive 
results of a session. Naudy uses a default file name and this will is appended to 
from session to session making it difficult to track results and settings at a later 
time.

6 File->Export Dykes to Geomodeller: You must have saved the model first. 
Options are presented to allow you to select and influence the number, length, 
sampling frequency etc. of a what amounts to a geophysics derived set of strucural 
geology observations of any dykes present in the survey.

 Note: During the Naudy Automatic Model session you can at any time: 
• View line statistics, 
• Change line resampling options, 
• Zoom the display in and out, and 
• Display different line profiles.
• View-> Plan Window: Display the current Naudy model in a plan view window.
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(See Navigating the profile and model display, Querying lines and setting 
resampling options and Plan view for detailed instructions.)
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• Specify the search complexity for the process and whether you wish to refine the 
inferred geological structures using the inversion process.  (See Search complexity 
and refinement options for detailed instructions.)

• Start a Potent 4 modelling session from the Interpret menu for the currently 
displayed line's model.

• Save the existing Naudy model point dataset at any point in the modelling 
process. Reloading model point datasets is no longer possible in INTREPID 
V4.2.2. (See Specifying input and output files for detailed instructions.)

7 Interpret-> Earths Magnetic Field: Specify the Earth's core magnetic field 
data for the survey if you wish to override the automatic calculation from the 
IGRF model.  See Specifying the Earth's core magnetic field data for detailed 
instructions. 

8 Interpret->Model Parameters: Select the required parameters from the 
Advanced Model Options. You can remove the Clearance from the estimated body 
depths and specify the search complexity for the process and whether you wish to 
refine the inferred geological structures using the inversion process.  (See Search 
complexity and refinement options for detailed instructions.)

9 Interpret-> Sensitivity Test Parameters: Display the Model Parameters and 
Testing Options dialog box

   Specify the parameters
   A. Scan for solutions
   B. Resample the Naudy solutions
   C. Create the Model and finally 
   Opt. Refine the Model using Inversion. 
Repeat the search and resample with different parameters as required.  (See 
Finding and resampling Naudy solutions for instructions)  INTREPID 
displays graphically the similarity coefficients and position of Naudy 
solutions.

10 Specify the line spacing of the input dataset and create the Naudy model for the 
current line, calculating shape, size and position of inferred geological structures 
and the initial calculated field (See Creating the model: inferred structures and 
initial calculated field for instructions).  INTREPID displays the inferred 
geological structures.

11 If required, specify the number of inversion iterations, then refine the inferred 
geological structures and optimise the fit of the calculated field with the observed 
field.  See Refining inferred structures and optimising the calculated field for 
instructions.

12 Repeat steps 7-10 as required until you are satisfied with the results.
13 Interpret->Model Parameters: For regularly spaced line data specify Body 

Strike Options (Calculate trends) to provide estimated body strike information for 
the inferred structures.  See Specifying body strike for the Naudy model point 
dataset for instructions.Apply the process to some or all of the dataset lines using 
Process from the Naudy Automatic Model window.  See Calculating the model for 
all or part of the dataset for instructions.

14 If you wish to record the specifications for this process in a .job file in order to 
repeat a similar task later or for some other reason, use Save Options from the file 
menu.  See Displaying options and using task specification files for detailed 
instructions.
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15 File-> Save Model As: Once you have completed your modelling run you must 
specify a new output Naudy model point dataset to save your results using Save 
Model As from the File menu. 

16 If you wish to adjust the process and apply it again, repeat steps 6–12 (using the 
same dataset and TMI field). 

17 Edit->Clear Model for All Lines: Alternatively you can clear the model for the 
the current line and continue or clear the model for all lines and start again with a 
new set of parameters before saving your model results.

18 File-> Quit: To exit from Naudy Automatic Model, choose Quit from the File 
menu. If you have not saved your model results you will be prompted with a 
summary of the number of results saved and be given the opportunity to Cancel, 
Save the results and then Quit.

___

You can execute Naudy Automatic Model as a batch task using a task specification 
(.job) file that you have previously prepared.  See Displaying options and using task 
specification files for details.

Specifying input and output files
To use Naudy Automatic Model, 
• File-> Load Line Dataset: You will need to specify the line dataset to be loaded 

and the database field to be processed.
• File-> Save Model As:When you have finished your modelling session you must 

specify a Naudy model point dataset for saving the calculation results.
• File-> Save Trend Point Data: You can also save trend point data calculated 

during a modelling session to an Intrepid or Geosoft database.
• File-> Save Worm Line Data: Worm line data generated from the above trend 

calculations can also be saved. This is not to be confused with the next, recetly 
released feature.

• File->Export Dykes to Geomodeller: The full model solution set is resorted, 
and searched, to form 3D dykes that link the individual HOT-SPOT solutions,that 
are spatially coherent. Susceptibilities, RMS error estimates, thickness, dip and 
strike are part of the solution set. A set of linear summary dykes is laso available 
as a seperate CSV file.

• File-> Specify Report: Before proceeding with a modelling session it is 
recommended that the user specify a report file name for saving the progressive 
results of a session. Naudy uses a default file name and this will is appended to 
from session to session making it difficult to track results and settings at a later 
time.
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• Choose the options as required from the File or Interpret menu.  The illustrations 
below show the file menu before and after loading a line dataset.

In each case INTREPID displays an Open or Save As dialog box.  Use the directory 
and file selector to locate or specify the file you require.  (See "Specifying input and 
output files" in Introduction to INTREPID (R02) for information about specifying 
files).  

INTREPID may need to obtain information from the dataset aliases.  If you select 
geographic or chronological resampling (See Resampling mode for data preparation), 
the dataset must have aliases identifying appropriate field names.

See "Vector dataset field aliases" in INTREPID database, file and data structures 
(R05) for more information about aliases.

Alias Field 

For geographic resampling:

X X coordinate (geographic location)

Y Y coordinate (geographic location)

For chronological resampling:

Fiducial Fiducial count
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Summary of file operations
File menu options
Load Lines Use this option to specify the line dataset for modelling.  INTREPID will 

prompt you to specify the line dataset, the magnetic or gravity field to be 
modelled. The resampling mode can be set by Right clicking in the top profile 
window once the dataset is loaded. (See Resampling mode for data preparation).  
If you have selected geographic resampling and there are no valid X and Y aliases 
specifying the geographic location fields INTREPID will also display Open dialog 
boxes for you to specify them.
INTREPID will then open the dataset and display the profile of the first line in 
the Naudy Automatic Model main window. For a tensor signal, the tensoir must 
have been formed in the database as a proper tensor signal object. Check via the 
jFmanager TAB for its data type. If properly formed, once you have chosen the 
magnetic tensor field, the 6 components of the tensor are shown in the top panel, 
in an analogous manner to the TMI. Support for FTG or full tensor gravity 
gradiometry profile data is still in its infancy, as this Naudy method has 
traditionally been associated with magnetics. The quality and signal content in 
modern FTG profile data, does however, allow for an extension of this tool to 
support FTG data. INTREPID saves model data to a temporary dataset whenever 
it performs a model calculation operation. Saving the model results to a database 
file of your own is not required until the end of a session.  See Calculating the 
model for all or part of the dataset and Saving the model as a point dataset for 
details.

Load Existing Model You can not load an existing Naudy model point dataset for 
continuing work in version 4.5, but you can at V5.0 of Intrepid.

Save Model As Use this to save your current results Naudy model point dataset. 
Load Options If you wish to use an existing task specification file to specify the 

Naudy Automatic Model process, use this option to select the task specification 
file required.  INTREPID will load the file and use its contents to set all of the 
parameters for the Naudy Automatic Model process.  (See Displaying options and 
using task specification files for more information).

Save Options If you wish to save the current Naudy Automatic Model file 
specifications and parameter settings as a task specification file, use this option to 
specify the filename and save the file.  (See Displaying options and using task 
specification files for more information). 

File operations from the Interpret menu
Load Trend Point Data Use this option to load a previously saved trends dataset to 

assist with calculating the strike of the inferred geological structures.  See 
Specifying body strike for the Naudy model point dataset for details.

Resampling mode for data preparation
The Naudy Automatic Model tool requires data points in the line dataset to be evenly 
distributed with no internal gaps.  When INTREPID loads a line dataset it 
immediately resamples if this is not the case.  

INTREPID replaces nulls using the cubic spline, linear or nearest neighbour 
interpolation method.  The default method is linear interpolation.  You can change 
the method using the Current Line Statistics and Options dialog box (See Querying 
lines and setting resampling options for instructions).
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The Naudy Automatic Model tool performs further resampling and interpolation of 
this prepared data using its own methods as necessary for its process.

You can select one of three resampling modes.  For two of these modes you need 
certain aliases as described below.
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>> To select the resampling mode
1 Load a line dataset for modeling as described above. Right click in the upper 

profile panel and INTREPID displays the Resampling Mode dialog box.

2 Select the resampling mode (Linear, Cubic Spline, Nearest Neighbour) by toggling 
the required option.

3 Geographic ('Geo-Located') INTREPID examines the X and Y fields of the 
dataset and resamples the data so that it is distributed evenly with respect to 
distance.  If you choose this option your line dataset must have properly defined X 
and Y aliases.

      Use Fixed Spacing Use this text box to specify the resampling interval in kms
.     Use Average Spacing (Default) Use this text box to use the average sampling 

interval in kms
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The Naudy Automatic Model main window
The following diagram summarises the components of the Naudy Automatic Model 
main window.

Upper plot 
The black line shows the measured’ two dimensional magnetic profile for the given 
traverse line.  The red line shows the ‘predicted’ magnetic profile that would result 
from the Naudy-derived solution (the magnetic bodies shown in the lower plot), that 
is, the optimal number, position, dip-angle and depth of magnetic bodies pre-
described either as ‘dyke-shapes’ or ‘step-shapes’. 

Lower plot

The lower plot contains the Naudy solutions.  It illustrates the optimal number, 
position, dip-angle and depth of magnetic bodies required to give the best possible 
match of ‘measured’ to ‘predicted’ magnetic intensity signal for the given traverse 
line. 

The bottom right-hand legend indicates goodness of fit (solution quality), for each 
individual ‘body’, by means of colour-coding. You can easily see a measure of overall 
solution quality for the traverse line by comparing the black and red profiles in the 
upper plot. 
Horizontal axis
The horizontal axis on both the upper and lower plots represents the distance in 
metres from the start of the traverse line.
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Vertical axis in the upper plot
The vertical axis in the upper plot represents the magnetisation in nT.  Notice that 
the data is de-trended as it is ‘relative change’ in magnetic signal that is most 
important for determining location of magnetic bodies. 
Vertical axis in the lower plot
The vertical scale in the lower plot represents depth (in metres) below observation 
height or ground level if the Remove Clearance option is chosen. The body ‘depth to 
top’ is corrected for aircraft clearance (RADALT) in this case.  The cross on top of each 
modelled body directly marks the ‘top of the magnetic source’.  The size of this cross 
corresponds directly to the slenderness ratio of the modelled body.

Inferred geological structure colours
The Naudy model display colour indicates the inferred geological structure's 
similarity coefficient.  Red indicates a high quality solution (less than 2).  Blue 
indicates medium quality (between 2 and 3).  The legend in the model display area is 
a guide to these colours.

See Finding and resampling Naudy solutions for details about the similarity 
coefficient.
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Navigating the profile and model display
In the upper data display section the Naudy Automatic Model window shows (in 
black) a profile of the observed field for a single line and (in red) the current 
calculated field from the current model.  These profiles are 
• The original input data field and 
• The current calculated field.
The horizontal scales of the input or observed field and calculated field are 
synchronised, so that you can compare corresponding values for any data point.

You can navigate the dataset display in the following ways.
• Viewing the profile of any line in the dataset;
• Zooming in on any section of a profile or model solution.
Selecting a line you wish to view
When you first load a line dataset, INTREPID displays the input data for the first 
line in the dataset.  You can display other lines using the Next, Previous and Go To 
command buttons.

The Naudy Automatic Model automatically sorts line numbers into ascending order, 
irrespective of their actual order in the dataset.  

When you view a line in the Naudy Automatic Model main window
• If the option Always Regenerate Model in the Interpret menu is turned on 

(Default) then INTREPID always recalculates and displays the inferred geological 
structures and calculated field even if a prior model exists for that line 

• If the option Always Regenerate Model in the Interpret menu is turned off and a 
model exists for the line, INTREPID will display its inferred geological structures 
and calculated field. 

See Viewing and recalculating individual lines during the specification process for 
details about model recalculation for individual lines.  

See Calculating the model for all or part of the dataset for further information about 
obtaining an up to date model for a desired set of lines. 
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>> To view the Next or Previous line (according to line number)
1 If the Automatic Modelling Options and Testing dialog box is open, close it 

(Choose Accept or Cancel).   
2 Use Next or Previous from the Naudy Automatic Model window to view the next 

or previous line respectively.

>> To view the line of your choice
1 If the Automatic Modelling Options and Testing dialog box is open, close it 

(Choose Accept or Cancel).   
2 Choose Go To in the Naudy Automatic Model window.  INTREPID displays the 

Select Line dialog box.
3 Select (click) the number of the line you wish to view, then choose OK.  

INTREPID displays the line.
Enlarging and reducing (zooming) the profile display 
You can enlarge the profile display (zoom in) to display only part of a line profile, then 
zoom out again when you have finished.

When you zoom in, INTREPID will
• Always synchronise the horizontal scale of the two data areas,
• Set the vertical scale of the field profile according to the height of the zoom area 

you specified and the profiles included in the selection,
• Set the vertical scale of the inferred geological structures to match their 

horizontal scale and maintain the original aspect ratio.
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>> To zoom in on an area of the display
1 Move the mouse pointer to one corner of the region that you wish to enlarge.  Hold 

down the left button and drag to the diagonally opposite corner of the region.  
INTREPID displays a light blue frame defining the region you select.

2 Release the mouse button.  
INTREPID will enlarge the display to show only those points you selected.

>> To zoom out
Double click anywhere in the zoomed display (left mouse button).
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Querying lines and setting resampling options
You can display information about the current line and select a range of options for 
processing it, as described in this section.

>> To query the current line and select options

1 Right button click the line display.  INTREPID displays the Current Line 
Statistics and Options dialog box.

2 View the statistics and select options as required, then choose Accept.
No of Samples The number of data points in the current line that have values for 

the current observed field.
No of Interpolated Samples The number of data points in the current line derived 

by resampling and used for the Naudy Automatic Model calculations.
Max Signal Value, Min Signal Value, Mean Signal Value, Signal StdDev, 

Nulls  INTREPID displays basic observed field statistics for the current line.
Nyquist Frequency The highest frequency possible in the spectral domain given the 

current resampling rate1. 
Sample Spacing (Geographic resampling only) This parameter corresponds to the  

distance between interpolated samples.  You can modify this to increase or 
decrease the resampling rate and thus the Nyquist frequency1 or use the Average 
Spacing (the maximum and minimum values of the sample spacing are reported 
to the user)
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Interpolation Method Use these options to specify Linear, Cubic Spline, Nearest 
Neighbours interpolation for the resampling data preparation process (See 
Resampling mode for data preparation).
Cubic Spline interpolation uses a curve through a number of original data points 
on each side of the position for the resampled point.
Nearest neighbours uses a 'triangulation' technique to determine the value for a 
position based on the values at neighbouring original data points.

Detrend Method INTREPID automatically detrends the input data field before 
displaying and modelling it in Naudy. The user can choose which method to use 
when detrending.

Average Line Direction INTREPID displays the average bearing (North towards 
the top as in a compass) of the current line in this diagram.

Detrend Raw and Filtered Line This check box does not apply to this tool. 
Detrending of the input field is always on

Overlay Filtered Line This check box does not apply to this tool.
Zoom both lines This check box does not operate in this tool.  All zoom operations 

synchronise both display areas.

1. In the current version of INTREPID, this statistic is available only if you are using 
geographic resampling.  If you require the corresponding statistic for chronological 
resampling, contact our technical support service.  See Resampling mode for data 
preparation for further details.
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Plan view
You can display a plan view of the current model.  It shows all lines for which the 
model exists, with the inferred geological structures superimposed on the lines.

>> To display the plan view
1 If you will only be using Similarity colour mode where colours represent the 

similarity coefficient of the inferred geological structures, go to step 4.
2 Inspect the model for some lines to determine the range of depths of the inferred 

geological structures.
3 If the Model Parameters and Testing dialog box is not open, choose Sensitivity 

Test Parameters.. from the Interpret menu to display it.
For Depth colour mode display, INTREPID will assign the range of colours to 
depths between 0 and the Finishing at Depth value specified here.  This is likely 
to be a smaller number than you use as a maximum for calculating the Naudy 
solutions.  Specify the Finishing at Depth value required, then choose OK.  

See ‘The range of depth values in the legend’ below for further explanation.
4 Choose Plan Window from the Options menu.  

INTREPID displays the Plan View window.
5 Choose Change Mode to switch between the Depth, Similarity or Trend colour 

displays as required. Trend is only available if the Calculate Trends option is 
turned on in Model Parameters

6 When you have finished with the Plan View, choose Close.
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7 If you will be calculating further Naudy solutions, return the Finishing at Depth 
in the Automatic Modelling Options and Testing dialog box to an appropriate 
value for this process.
The Plan View window shows lines for which the current model exists.  The 
inferred geological structures are coloured rectangles superimposed on the lines.

The rectangle dimension perpendicular to the lines simply indicates the line 
spacing, allowing you to identify the line from which the solution originates.

The rectangle dimension parallel to the lines indicates the widths of the 
inferred geological structures, and corresponds to the width as displayed in the 
profiles in the Naudy Automatic Model main window.

The colour of the rectangle either corresponds to the depth of the inferred 
geological structure or the similarity coefficient.  The colour legend in the lower 
right corner has a label indicating the current display mode.

The range of depth values in the legend (Depth colour mode) The maximum 
value corresponds to the current Finishing at Depth setting in the Scan section of 
the Automatic Modelling Options and Testing dialog box. It does not necessarily 
correspond to the value of this parameter at the time the model was calculated.  
See Scanning for Naudy solutions for details about this parameter.  See ‘Depth’ in 
Finding and resampling Naudy solutions for details about the depth result.

The similarity coefficient values in the legend (Similarity colour mode) 
correspond to the possible values for this calculated result.  See Finding and 
resampling Naudy solutions for details about this result.

Change mode Choose this to switch between the Depth, Similarity or Trend colour 
displays.

Close Choose this to close the Plan View window.
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Specifying the modelling process
This section describes how to specify the Naudy Automatic Model process.  During the 
specification process you will calculate and view the results for your specifications for 
individual lines as required for optimising the specifications.  This calculating and 
viewing is intended only to assist you with the specifications.  When you are ready to 
calculate the model for the dataset, you will use the Process button in the Naudy 
Automatic Model window.  See Calculating the model for all or part of the dataset for 
instructions about this next step.

You can specify the Naudy Automatic Model using options from the Interpret menus. 

Here is an outline of the specification process.  The following sections give detailed 
instructions for each step.

>> To specify the Naudy Automatic Model process
1 Specify the Earth's core magnetic field if you wish to override the automatic 

calculation. (See Specifying the Earths core magnetic field data).
2 You will firstly develop and test the model using individual lines.  Display a 

suitable line for this process.  You can display different lines at any time during 
specification and testing if required.  Ignore any default model that INTREPID 
displays for the line when it first appears. 
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3 Select Interpret-> Model Parameters and set the Advanced Model options 
specified in the following dialog.. These options control the way your model search 
will be targeted to the geological/geophysical environment of your survey and how 
solutions will be further filtered, refined and reported. For TMI aeromagnetic 
surveys, we recommend
1 Dykes
2 Use Naudy-derived dips ( the aspect that is most susceptible to noise)
3 adjust poor dips
4 calculate trends ( precompute the body strikes - very important)
5 No negative susceptibility
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4 Select Interpret -> Sensitivity Test Parameters and the Model Parameters 
and Testing dialog box. It will remain open while you develop and test the model.  
You will use it for steps 4–7.
• View different lines of the dataset and zoom in and out.  INTREPID will 

automatically calculate and refine the model with the current settings for any 
line that you display.  You need to close the the Modelling Parameters and 
Testing dialog box before viewing different lines.

5 Specify and search for Naudy solutions.
6 Specify the resampling criteria and resample the Naudy solutions.
7 Create the model for the line.  INTREPID displays initial inferred geological 

structures and the calculated field profile.
8 Refine the model by adjusting the inferred geological structures.
9 Choose OK to close the Model Parameters and Testing (Sensitivity Test 

Parameters) dialog box. 
10 If required, return to the Advanced Modelling Options (Model Parameters) 

dialog to revise the search target style, complexity and solution refinement/
filtering options for processing the whole dataset ie Calculate trends, remove 
clearance from estimated depths etc.

The next step is to calculate and refine the model for some or all lines from the 
dataset.  See Calculating the model for all or part of the dataset for instructions.

Remanence
Remanence is also a big subject, so for TMI, a negative susceptibility is a poor-man’s 
method of indicating dykes that could have reversed vector components to the IGRF.

The big interest however comes with FTGM, or magnetic tensor gradients. Suddenly, 
it is no longer possible to fit a simple DYKE to every anomaly, if in fact the anomaly is 
caused by something that is not inherently 2D in nature. (With TMI, you can always 
find a 2D solution to every anomaly.)  Further, once there is a 2D body, the tensor 
gradient components very clearly also carry a great deal of rotational information 
about the induced magnetic response vector, so a new algorithm is delivered here 
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that, at step 2, searches for a magnetic vector’s 2 primary orientation measures, 
inclination and declination, that best explains the tensor gradient component 
distribution. Following this, a bounded, non-linear inversion of the geometry factors 
and the susceptibility is undertaken to improve the estimation of the DYKE HOT 
SPOT, to best fit the observed field.

This is another first for potential field geophysics from INTREPID. Horst Holstein 
has delivered most of the required modelling and inversion theroy here. Anglo/
DeBeers have also pushed the developement of the magnetic Tensor survey technique 
to make it quite viable, and now best magnetic survey practice.
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Viewing and recalculating individual lines during the specification process
You can view different lines during the specification process.  Before changing to 
another line you must close the Model Parameters and Testing dialog box.  
INTREPID displays inferred geological structures and calculated field for the newly 
displayed line according to the following rules. 

When you view a different line:
• If you display a line for which no model exists and the Always Regenerate Model 

option in the Interpret menu is turned on, INTREPID will immediately calculate and 
display the model for the line using the current settings.
INTREPID will perform the model calculation for the new line according to the 
parameters you have set in both the Model Parameters and Testing and 
Advanced Modelling Options dialog boxes.  The parameters controlling the 
process include the complexity of the search and whether to perform model 
refinement.  See Search complexity and refinement options for details.

• If you display a line for which a model exists and the Always Regenerate Model 
option in the Interpret menu is turned off, INTREPID displays the existing model for 
the line.  If you wish to recalculate the model using the current specifications, 
simply choose as many buttons from the sequence 'Scan, Resample, Create the 
Model and Refine the Model' as required to update the calculations for the line.

To continue model specification with the newly displayed line, simply display the 
Model Parameters and Testing  dialog box and continue.

See Selecting a line you wish to view for details about displaying different lines.

___

At any stage during or after the specification process you can transfer the current line 
to the Potent modelling software by selecting Interpret->Start Potent 4 Modelling 
Session from the main menu bar.
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Specifying the Earth's core magnetic field data
The Naudy Automatic Model tool requires an Earth's core magnetic field data for use 
in its calculations.  It requires the data for a horizontal and vertical component 
calculation and for producing the calculated field.

INTREPID normally calculates the Earth's core magnetic field data from the IGRF 
model using the survey date 1 January 1980.  We regard this as sufficiently accurate 
for the purposes of the Naudy Automatic Model tool. 

You can override this automatic calculation if required and enter your own field 
intensity, inclination and declination.

See The geomagnetic reference field in INTREPID (R15) for a discussion of this topic.

>> To specify the Earth's core magnetic field data for this Naudy Automatic 
Model session
1 Choose Earth’s Magnetic Field from the Interpret menu.  INTREPID displays 

the Set Field Components dialog box.

2 Specify the Field Strength (intensity), Declination and Inclination.
3 Turn off the Calculate IGRF using Dataset check box.
4 Choose OK.

>> To automatically calculate the Earth's core magnetic field data from the 
dataset
(This is the default state for the tool)
1 Choose Earth’s Magnetic Field from the Interpret menu.  INTREPID displays 

the Set Field Components dialog box.
2 Turn on the Calculate from Dataset check box.
3 Choose Accept.
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Finding and resampling Naudy solutions

>> To calculate Naudy solutions for a line, including similarity coefficient, 
position and depth
1 Specify the depth range to search, then calculate the Naudy solutions.  You can 

also specify advanced options: the width of the Naudy operator, the depth 
increment, and the body strike.  See Scanning for Naudy solutions for details.

2 Resample and thin out the Naudy solutions:
• Specifying a maximum similarity coefficient and minimum amplitude for 

inclusion, and 
• Selecting the solution with the lowest similarity coefficient if several solutions 

occur close to each other.
See Resampling the Naudy solutions for details.

___
Similarity coefficient This is a measure of the similarity between the calculated 

field of a Naudy solution and the observed field.  Similarity coefficients range from 
0 to 5, where 0 represents a good match and 5 represents zero similarity.  For 
Naudy solutions used to calculate inferred geological structures, INTREPID will 
save this data in the Naudy model point dataset as field Similarity.

Position The scanning process calculates the location of Naudy solutions.  For 
Naudy solutions used to calculate inferred geological structures, INTREPID will 
save this data in the Naudy model point dataset as fields X and Y.

Depth The scanning process calculates the depth below the data acquisition height of 
Naudy solutions or below the ground if the Clearance option is selected and the 
dataset contains a Clearance field with the alias correctly set.  For Naudy 
solutions used to calculate inferred geological structures, INTREPID will save 
this data in the Naudy model point dataset as field Z.
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Scanning and Resampling dialog box options
Use the upper two sections of the Model Parameters and Testing dialog box to 
specify and test this part of the process.

If you wish to specify advanced options, use the Advanced Model Options dialog 
box.  Choose Model Parameters from the Interpret menu to display this dialog 
box.  This dialog box is not designed to remain open like the Model Parameters and 
Testing dialog box.  You must choose Accept before INTREPID will use your 
settings. 
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Naudy solutions display
The following illustration shows a line's Naudy solutions displayed as small squares 
after scanning and resampling.  The horizontal position of the squares indicates their 
geographic position (corresponding to the line above.  Their vertical position indicates 
the depth of the Naudy solutions (according to the scale on the vertical axis.  The size 
of the squares indicates their similarity coefficient.  A large square  indicates a low 
similarity coefficient.

Scanning for Naudy solutions
The following steps assume that you have 
• Selected and displayed the line for scanning and 
Ignore any inferred geological structures that INTREPID displays for the line before 
you commence.  This process will overwrite them.

>> To scan for Naudy solutions
1 Select the Interpret->Model Parameters and specify, width of Naudy operator,  

depth increment, finer sampling with depth, remove clearance, body type (Dykes, 
Steps, Intrasediments), Dip search strategy  and body strike options (calculate 
trends for regularly spaced lines) in the Advanced Model Options dialog .

2 Select Interpret->Sensitivity Test Parameters and specify the Start and 
Finish depth and the maximum allowed Absolute Susceptibility in the Model 
Parameters and Testing dialog box

3 Choose Scan.  INTREPID will calculate and display the Naudy solutions.
Starting depth / Finishing at depth Use these to specify the depth range for 

finding and reporting Naudy solutions.  INTREPID will not calculate solutions 
outside this range.

Restrict Maximum Absolute Susceptibility Use this parameter to limit the range 
of predicted absolute susceptibility
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Width of Naudy operator as a multiple of depth (Advanced option) INTREPID 
uses a variable number of data points for calculating solutions, depending on the 
depth of the solution.  The number of data points used is a multiple of the depth of 
the solution.  This parameter specifies the factor for the number of data points 
used for each depth.  The default value is 2. If the Naudy operator is too wide, 
INTREPID may inadvertently introduce part of a neighbouring anomaly into the 
calculation.  If it is too narrow, INTREPID may only examine the peak of an 
anomaly and fail to obtain information about its true shape.

Increase successive depths by a factor of (Depth increment) (Advanced option) 
Use this to specify the depth increment factor (dif).  INTREPID divides the depth 
range into sections according to the depth increment factor.  The depth section 
closest to the surface has a height equal to start depth x dif.  The height of the 
next depth section is dif times that of the section above.  Deeper sections, 
therefore, are larger than shallower ones.  INTREPID records the depth of a 
Naudy solution as the depth of the section to which it belongs.  

Specifying constant body strike (Advanced option) You can specify a constant 
body strike for inferred geological structures that may result from the Naudy 
solutions.  The default body strike is perpendicular to the line direction.
For Naudy solutions used to calculate inferred geological structures, INTREPID 
will save this data in the Naudy model point dataset as field Strike.  
At the formal processing stage, if you have regularly spaced lines and you select 
the Calculate Trends option then individual body strikes will be estimated using 
the trend data. These strike estimates will be writtne to the Strike field.  See 
Specifying body strike for the Naudy model point dataset for details.

—Use a fixed body strike of  Use this to specify a fixed strike for inferred geological 
structures.  0 represents North and positive values represent clockwise rotation 
(e.g., 90 represents East).

—Set bodies perpendicular to the line Use this check box to specify the strike for 
inferred geological structures as perpendicular to the line direction.  This will 
override any existing Fixed Body Strike setting. 

—Calculate Trends (requires evenly spaced parallel lines) Use this option to derive 
trends from your input data field that can be used to infer the body strike.

 —Edit Trend Filters Clicking on this button opens the following dialog box with 
options for controlling the estimation of trends for your input data field.
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Resampling the Naudy solutions
The following steps assume that you have 
• Selected and displayed a line,
• Scanned it for Naudy solutions and
• Displayed the Model Parameters and Testing dialog box.

>> To resample Naudy solutions
1 Specify the similarity coefficient and intensity thresholds for rejecting inferior 

solutions.
2 If required, specify the advanced options, Width of Naudy operator, Depth Bias 

factor and Finer Sampling with Depth option.
3 Choose Resample.  INTREPID will resample the collection of Naudy solutions, 

rejecting those with similarity coefficient above the threshold and selecting the 
best solution in each solution region.

Naudy threshold greater than (Similarity coefficient threshold) INTREPID will 
reject Naudy solutions with similarity coefficients above the level that you specify 
here.

TMI anomaly less than (Intensity threshold) Use this to specify the minimum 
amplitude (in nT) of anomalies to include in the calculation.

Thin solutions using depth factors of (Depth distance factors) (Advanced option) 
INTREPID examines a region surrounding each solution.  If the region contains 
one or more other solutions, INTREPID retains the solution with the lowest 
similarity coefficient and rejects the others.  The Naudy operator width and Depth 
distance factors determine the size of the region examined around each solution.

      This thinning option is no longer available to the user. The thinning 
operation is now applied automatically using sensible defaults of 0.5 and 
0.5 (half the depth sample interval and half the body separation
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Creating the model: inferred structures and initial calculated field
After you have calculated and resampled the Naudy solutions, INTREPID can 
calculate the model and display the corresponding inferred geological structures.  It 
will also display the calculated field for the structures as a red curve superimposed on 
the black original (observed) line profile.

INTREPID will perform the model calculation according to the parameters you have 
set in both the Automatic Modelling Options and Testing and Advanced Options 
dialog boxes.  If you have turned on either of the Always Invert options, INTREPID 
will automatically refine the model after creating it.  See Refining inferred structures 
and optimising the calculated field for details about the refinement process.  See 
Search complexity and refinement options for details about the Always Invert 
options.

The following step assumes you have scanned for Naudy solutions and resampled 
them and that the Automatic Modelling Options and Testing dialog box is open.

>> To calculate the model and display the inferred geological structures
1 Specify the line spacing for the model. 

2 Choose Create the Model.
INTREPID will calculate and display the inferred geological structures.  It will 
also display the calculated field in red superimposed on the black observed field 
profile.  Depending on the search complexity and refinement options, it may also 
refine the model.  The following illustration shows a model calculated with all of 
these options turned off.

Assuming a line spacing of Use this to specify the line spacing of the input line 
dataset in metres.  INTREPID will set the length of the inferred geological 
structures (the dimension perpendicular to the line direction viewed from above) 
equal to this value and record the length in the D field of the Naudy model point 
dataset.  See Illustration of length and body strike for a diagram showing inferred 
geological structure length.
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Refining inferred structures and optimising the calculated field
After INTREPID has calculated the inferred geological structures, it can refine them 
by modifying their 
• Width (parallel to the line direction), 
• Depth, 
• Horizontal position
• Dip and / or 
• Susceptibility.
The goal of the refinement process is to arrive at a set of inferred geological structures 
whose calculated field most closely matches the observed field along the line.

The refinement process is 'self-conditioning'.  Its effectiveness improves within a 
single set of iterations.  Thus one set of 20 iterations is more effective than two sets of 
10.

You can perform the refinement process more than once if required.  Increase the 
maximum number of iterations if you find that repeated refinement is necessary
The Automatically Invert option (Advanced Model Options) 
If you select the Automatically Invert check box in the Model Parameters->Advanced 
Options dialog box, INTREPID will automatically refine models as part of the 
creation process. 

The Automatically Invert option is equivalent to Refine the Model in the Automatic 
Modelling Options and Testing dialog box.  In this case you will not normally need to 
perform the steps described below.  If you do choose Refine the Model with 
Automatically turned on, INTREPID will perform another set of refinement 
iterations.

INTREPID will automatically cease iterations if it is failing to improve the fit of the 
calculated field. 

See Search complexity and refinement options for details about the Automatically 
Invert check boxes
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Refining the model

>> To refine the inferred geological structures and optimise the calculated 
field for the current line
The following steps assume that you have displayed the Model Parameters and 
Testing dialog box, scanned for Naudy solutions and resampled them, then created 
the model, displaying the inferred geological structures, and that the Automatically 
Invert option is turned off in the Advanced Options dialog box.
1 Specify the number of inversion iterations.

2 Choose Refine the Model.  
INTREPID will refine the inferred geological structures for the current line, then 
display them and the refined calculated field.  

___
Up to ___ inversion iterations This parameter specifies the maximum number of 

refinement iterations INTREPID will perform in a refinement operation.  If this 
parameter is too low, you may not obtain the optimum fit for the calculated field.  
If the parameter is too high, the process may take additional time without benefit.
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Specifying body strike for the Naudy model point dataset
When you create the model, you can specify a constant body strike for all inferred 
geological structures.  See ‘Specifying constant body strike’ in Scanning for Naudy 
solutions for details.

INTREPID can include individual body strike data for each inferred geological 
structure. 

You can obtain body strike information by turning on the Calculate Trends option 
in the Advanced Model Options dialog.  

If you specify Calculate Trends,  INTREPID will adjust the values in the Strike field 
of the Naudy model point dataset to incorporate this data.
1 Choose Model Parameters from the Interpret menu.  INTREPID displays the 

Advanced Model Options dialog box.  
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Turn on Calculate Trends and specify the trend filters, the Connect Trend angles 
limit in degrees and the Search Rectangle sizes for the across and along line trend 
search in the Advanced Trend Detection Filter Options dialog box shown 
below.  This option relies on designing a series of 1D filters to create high pass 
“bumps” in the profiles, that can be matched between lines, thereby estimating 
local strike of the geology. The deeper strucural trends are allowed to be different 
to the surface trends, via a similar 1D filtering strategy.
This approach overcomes one of the main limitations to automation of the Naudy 
algorithm, when dealing with TMI data, that is the error in depth and body 
shapes when there is a strike error. Other implimentations tend to apply a strike 
correction after the body is found, assuming a body normal to the profile. With 
this implimentation, all the complications of a post-fix go away.
Of course, in the tensor case, a strike is directly implied in the ratio of the 2 
invariants of the tensor signal. The zero eigenvector for a 2D body lies in the 
strike direction.
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Search complexity and refinement options
You can specify the search complexity and whether to always refine the data.  
INTREPID will always use these settings when it calculates the model, i.e., when you
• Choose Create the Model in the Model Parameters and Testing dialog box;
• Display a line for which no model exists;
• Process your selection of lines formally (using the Process button).

>> To specify the complexity and extent of the calculation and refinement 
process.
1 Choose Advanced Options from the Interpret menu.  INTREPID displays the 

Advanced Options dialog box which contains the search complexity and 
refinement options.

Turn on the check boxes according to your requirements, then choose Accept.
2 If you turn on the Automatically Invert option:
• INTREPID will be automatically refining the model whenever you create a model 

for a line.  
      Specify the required number of inversion iterations in the corresponding text box 

next to the Opt. Refine the Model button in the Model Parameters and 
Testing dialog box.  See Refining inferred structures and optimising the 
calculated field for details about this parameter.                                             
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Illustration of length and body strike
The following illustration shows the effect of the line spacing and the body strike data 
on the inferred geological structures. You are asked to specify the line spacing as a 
parameter.

Calculating the model for all or part of the dataset
After you have specified the Naudy Automatic Model process you can apply it to some 
or all lines in the dataset.

You can calculate and refine the model for a list of lines, a range of lines, a single line 
or all lines.

INTREPID automatically saves the model values in a temporary output dataset. The 
user must select File->Save Model As to save his own set of output models.

3D Dyke Geometry
The option uder the File menu to export the final emsemble, to Geomodeller format, 
produces, after a clustering of the soltuions, an ordered list of HOT_SPOT bodies in a 
csv file, with each identified 3D dykes’s points sorted into a following order, with a 
newly created TAG eg DYKE1, 2 etc. Geomodeller’s implicit geology modelling 
algorithms are clever enough to then turn these foliation observations, into 3D 
surfaces that are either finite, or continue right across the project.

The Tutorial K exercise distributed with Geomodeller, illustrates this functionality.

There is obviously enough information contained in this automatic interpretation of 
magnetic survey data, to accomplish a good starting point in any 3D geology 
modelling environment, if Geomodeller can manage the task. This represents a very 
big boost in productivity for the geoscientist. The Naudy depth cookbook also contains 

Length and strike of inferred geological structures

Before INTREPID calculates the length, the inferred geological
structures have infinite length.

INTREPID assigns a length equal to the dataset line spacing
before saving the model solutions point dataset.

If you specify and enable a spline gridding sample points dataset
INTREPID assigns a strike to each structure before saving the
model solutions point dataset.

Aquisition lines
viewed from above

Represents a
Naudy source
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comments on this aspect.

The clustering algorithm developed here, joins HOT_SPOT solutions in a recursive 
search for “WORMS”. There is a comprehensive report in the log file, as to how many 
simple bodies there are to begin with, and how the joining has managed to reduce the 
candidate 3D dykes to a more manageable set. The use of the inversion RMS measure 
to further cull HOT-SPOT solutions from each 3D worm, means that you are not over-
specifying foliation data along the dyke, while still capturing its variable width and 
susceptibility estimates.

You can bias the search to the more linear of features, or, the other way, to favour 
ring dykes.

You can choose the option to allow you to add pinch-out points at the end of dykes 
that might fade within the project boundary, thus allowing you to create a 3D model 
with dykes having limited extents.

At the bottom of this dialog, there is the options for calculating a geophysical grid 
with the newly sorted “WORM” bodies. The option of using the infinetly thin body 
formulatioin, which is then post multiplied by a dyke thickness, or a slower 3D facet 
model of the worms, is given. What is happening behind the scenes, is the creation of 
a V5.0 protbuf message, passing the DYKE geometry and properties to the MTdyke 
tool, to do the required job.

This gives you a quick ability to see how much of the observed signal has been 
captured by the DYKE model.
Worm Formation Log
The following is a sample report extracted from the naudy_depths.log file that is 
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created automatically during this process. We have annotated the report as an aid to 
helping you to interpret the process.

Actual Number of Simple Bodies used for worms 329  ORIGINAL Naudy solution count
Initial Worm count = 105                           First go at forming WORMS
3D Body Data  from naudyd to File OriginalWorms.csv,  Original Worm count = 105, Export to Geomodeller Worms 
0, Total simple bodies used 0
Conditioned, sorted worm step 17 duplicate bodies, 1 out of order, 0 strike issues, 0 dip issues
3D Body Data  from naudyd to File joiningWorms1.csv,  Original Worm count = 91, Export to Geomodeller Worms 
28, Total simple bodies used 105
Conditioned, sorted worm step 25 duplicate bodies, 0 out of order, 0 strike issues, 0 dip issues
3D Body Data  from naudyd to File joiningWorms2.csv,  Original Worm count = 87, Export to Geomodeller Worms 
25, Total simple bodies used 85
Conditioned, sorted worm step 7 duplicate bodies, 1 out of order, 0 strike issues, 0 dip issues
3D Body Data  from naudyd to File joiningWorms3.csv,  Original Worm count = 84, Export to Geomodeller Worms 
25, Total simple bodies used 95
Conditioned, sorted worm step 7 duplicate bodies, 0 out of order, 0 strike issues, 0 dip issues
3D Body Data  from naudyd to File joiningWorms4.csv,  Original Worm count = 82, Export to Geomodeller Worms 
26, Total simple bodies used 101
Conditioned, sorted worm step 12 duplicate bodies, 0 out of order, 0 strike issues, 0 dip issues
3D Body Data  from naudyd to File joiningWorms5.csv,  Original Worm count = 79, Export to Geomodeller Worms 
26, Total simple bodies used 99
Conditioned, sorted worm step 7 duplicate bodies, 0 out of order, 0 strike issues, 0 dip issues
Final Worm count = 79                After a recursive joining process, number of WORMS
Lines with unknown strike = 0
Box tests = 85589, angle tests 378, proximity tests 349, Join Worm Recursive level 5
Conditioned, sorted worm step 6 duplicate bodies, 0 out of order, 0 strike issues, 0 dip issues
Linearization Summary
 Dyke        nPts Strike Dip Length Thickness Linear_deviation RMS_ERROR  Susceptibility Similarity  startX       
sY        endX        eY
Dyke1,    4,  142,   80,     164.3,     37.39,       5.0,       0.7,     0.00291,    1.0,    531844.31, 
7410115.06, 531743.70, 7410244.94
Dyke2,   17,  128,   76,     818.4,     43.89,       8.9,      25.7,     0.03926,    1.1,    531967.40, 
7410554.50, 531324.06, 7411060.33
Dyke3,    6,  144,   68,     338.9,     37.66,       8.0,       7.8,     0.01460,    0.9,    531659.58, 
7410075.37, 531465.14, 7410352.89
Dyke4,    4,  102,   71,     147.3,     51.46,      10.2,       0.6,     0.00207,    1.4,    532252.90, 
7411351.51, 532109.05, 7411383.44
Dyke5,   16,  133,   78,     775.1,     42.67,       8.7,      31.3,     0.04236,    0.7,    531333.02, 
7410258.57, 530769.80, 7410791.05
Dyke6,    6,  129,   77,     258.5,     55.84,      11.0,      33.9,     0.04088,    1.1,    531298.11, 
7410571.88, 531099.53, 7410737.36
Dyke7,   15,  131,   72,     758.4,     52.25,      15.2,      11.3,     0.02641,    1.1,    531061.91, 
7410354.83, 530492.76, 7410856.13
Dyke8,    4,  148,   82,     137.4,     70.19,       9.3,      29.6,     0.06061,    1.3,    531064.73, 
7410781.03, 530993.60, 7410898.54
Dyke9,    4,  125,   57,     141.1,     51.16,      15.0,       1.1,     0.00196,    1.2,    531615.26, 
7411761.93, 531501.02, 7411844.68
Dyke10,    8,  124,   81,     342.5,     77.03,       7.9,      20.8,     0.04587,    1.3,    530960.20, 
7410889.42, 530678.48, 7411084.26
Dyke11,    4,  134,   65,     151.5,     57.80,       0.2,      10.9,     0.02639,    1.6,    530906.49, 
7410902.06, 530797.97, 7411007.73
Dyke12,    5,  105,   61,     149.0,     38.92,       9.2,      10.2,     0.00738,    1.6,    531125.42, 
7411243.33, 530981.47, 7411281.96
Dyke13,    6,  136,   82,     470.2,     53.92,       6.9,       5.4,     0.03324,    1.1,    530873.38, 
7410934.86, 530547.15, 7411273.42
Dyke14,    5,  102,   72,     467.0,     55.26,       6.7,       1.6,     0.00434,    1.6,    531336.44, 
7411548.72, 530879.80, 7411646.58
Dyke15,    8,  146,   70,     432.1,     43.47,      15.7,       6.3,     0.01271,    1.0,    530896.43, 
7411288.80, 530658.46, 7411649.51
Dyke16,    8,  142,   80,     299.7,     47.83,      10.2,       8.0,     0.00901,    1.2,    530544.52, 
7410983.14, 530362.99, 7411221.66
Dyke17,    4,  119,   77,     147.9,     34.51,       8.1,       2.9,     0.00512,    0.9,    530764.82, 
7411453.30, 530635.65, 7411525.41
Dyke18,    5,  131,   64,     197.6,     44.76,       3.1,       4.7,     0.01340,    0.9,    530503.68, 
7411334.13, 530355.70, 7411465.11
Dyke19,    7,  121,   53,     276.5,     42.10,       7.4,       0.9,     0.00208,    1.7,    530976.94, 
7412246.62, 530740.30, 7412389.68
Dyke20,    4,   35,   64,     266.2,     57.78,       2.7,       2.7,     0.00391,    1.5,    530341.70, 
7411441.79, 530496.82, 7411658.16
Dyke21,    7,  118,   78,     279.6,     76.74,      10.3,       5.2,     0.02023,    1.2,    530355.06, 
7411526.37, 530108.75, 7411658.71
Dyke22,    5,  138,   66,     195.9,     41.38,       6.9,       1.2,     0.00224,    1.6,    530337.95, 
7411746.20, 530208.14, 7411892.98
Dyke23,    4,   86,   82,     240.2,     91.81,       8.1,      55.7,     0.04371,    1.3,    530129.97, 
7411665.63, 529890.10, 7411652.58
Dyke24,    4,  122,   73,     144.9,     36.63,       3.6,       7.0,     0.01802,    1.9,    529884.56, 
7411240.96, 529761.77, 7411317.82
Dyke25,    7,  133,   70,     313.8,     29.86,       6.5,       1.8,     0.00385,    1.0,    530255.08, 
7411953.91, 530027.85, 7412170.29
Dyke26,    4,  123,   75,     140.0,     41.75,       2.2,       1.9,     0.00531,    1.0,    530148.40, 
7412185.71, 530031.03, 7412262.10
Geomodeller minimum number hot spots / worm : 4
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3D Body Data  from naudyd to File D:/test_data/FullTests/naudyd_test/mat_basil/eni_d.csv,  Original Worm count 
= 79, Export to Geomodeller Worms 26, Total simple bodies used 100
Before thinning - Mean length 6.576923, Max length 17.000000
After  thinning - Mean length 5.730769, Max length 10.000000
Exported 3D body Linear Summary  from naudyd to File D:/test_data/FullTests/naudyd_test/mat_basil/
Summary_eni_d.csv,  Original Worm count = 79, Geomodeller Linear Summary Dykes 26

Data created during the model specification
Each time you view a line for which no model exists, INTREPID calculates and 
refines the currently specified model for it. This line then joins the collection of lines 
for which the model exists in the temporary file mentioned above.

If you change the specifications for the model and a previously viewed line is then not 
included in your selection of lines to be processed, it will remain in the Naudy model 
point dataset even though it may have undesirable or out of date results.  

In order to prevent this from happening, use the Edit-> Clear Model for Current 
Line or Clear Model for All Lines options before commencing the formal 
processing of the dataset.

INTREPID will overwrite the model results for any lines that you have previously 
displayed and are included in your selection of lines to be processed.

Performing the model calculation on the selected lines

>> To perform the model calculation (and refinement process if selected) for 
specified lines in the dataset
1 Ensure that you have specified according to your requirements
• The model, 
• The search complexity and refinement options and 
• The calculate trends option is turned on for regularly spaced lines.
2 Save the output models when you have completed your processing using           

File->Save Model As
3 Choose Process from the Naudy Automatic Model window.

INTREPID displays the Lines to Model dialog box.
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4 Select the option corresponding to your line selection method.
Select from List, Select a Range, Select a Line, Select All 
5 If you selected Select from List, move the line numbers between the Dataset Line 

Numbers and Selected Line Numbers list boxes as required.  (The Selected Line 
Numbers list box shows a list of the lines for processing and the Dataset Line 
Numbers list box shows a list of lines that are not for processing.)
To move a line number to the other list select (click) it so that it is highlighted, 
then choose >> Add >> or << Remove <<.
If you selected Select a Range, enter the first and last line numbers to be processed 
into the corresponding text boxes. 
If you selected Select a Line, enter the number of the line required in the 
corresponding text box.  
Note: For Select a Range and Select a Line you can enter line numbers or the 
words start and end which signify the first and last line numbers.

6 When you have specified the lines for processing, choose Accept.
7 INTREPID will process the dataset as specified.  
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Saving the current model results
• As INTREPID performs model calculations it saves them to a temporary points 

dataset.
• During or after the model specification and testing process you can save the 

currently displayed line's model to your own points dataset.

Saving the model as a point dataset

>> To save the output dataset
Use Save Model As  from the File menu as required. 

Exit
To exit from Naudy Automatic Model choose Quit from the File menu.
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Structure of Naudy model point datasets
Each data point on a Naudy model point dataset represents an inferred geological 
structure.

Naudy model point datasets have the following fields

Field (new) Field (old) Description

Width A Width of inferred geological structure in the line direction 
(before the body strike is changed by trend calculation).

Dip B (or D) Dip of inferred geological structure (rotation about axis 
perpendicular to the line direction).

DepthExtent C Height (depth extent) of inferred geological structure.

Length D (or B) Length of inferred geological structure perpendicular to 
the line direction (before the body strike is changed by 
trend calculation).

BodyType BodyType Code indicating whether inferred geological structure is a 
dyke or a step.

Susceptibility Ka Magnetic susceptibility of inferred geological structure.

Similarity Similarity Similarity coefficient of inferred geological structure.

Strike Strike Absolute strike of inferred geological structure 
(0 = North) INTREPID initially obtains this from the line 
direction but may modify it during trend calculation.

Depth Z Depth estimate for inferred geological structure.

Depth_Bin_No (new) Naudy Automatic Model classifies solutions into groups 
(bins) by depth.  This field contains the bin number of the 
current inferred geological structure.

Depth_of_Bin (new) Depth of the bin (group) to which the current inferred 
geological structure belongs.

groupID (new) Field for use by users for their own purpose (intended for 
manually classifying inferred geological structures into 
groups)

X X East–West geographic location

Y Y North–South geographic location

LineIndex Line Line number of line from which INTREPID derived the 
inferred geological structure.

LineBearing (new) Average bearing of line from which INTREPID derived 
the inferred geological structure, calculated Naudy 
Automatic Model tool.

LineDp (new) Interpolation increment along line from which INTREPID 
derived the inferred geological structure.
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LineNPoints (new) Number of interpolated points in line from which 
INTREPID derived the inferred geological structure.

LineX0 (new) Coordinates of first point in line from which INTREPID 
derived the inferred geological structure.

LineY0 (new)

Haz RemAz Declination of inferred geological structure's remanent 
magnetic field.  All inferred geological structures 
currently have 0 remanent fields.

H RemH Intensity of inferred geological structure's remanent 
magnetic field.  All inferred geological structures 
currently have 0 remanent fields.

Hinc RemInc Inclination of inferred geological structure's remanent 
magnetic field.  All inferred geological structures 
currently have 0 remanent fields.

MC_Length MC_Length Scaled version of field Length for use in hard copy 
composition (being phased out).

MC_Slope MC_Slope Scaled version of field Dip for use in hard copy 
composition (being phased out).

MC_Width MC_Width Scaled version of field Width for use in hard copy 
composition (being phased out).

(no longer in use) Plunge Plunge of inferred geological structure (rotation about 
axis in the line direction).  All inferred geological 
structures currently have Plunge = 0.

(no longer in use) Isotropy Isotropy = 1 if the magnetic susceptibility of the 
inferred geological structure is direction independent (all 
INTREPID solutions data currently has this value).

(no longer in use) Density (not in use)

(no longer in use) Dip (not in use)

(no longer in use) Kb (not in use)

RMS_ERROR - The misfit of the calculated body to the observed signal, as 
estimated during an inversion stage, is now also reported.

Field (new) Field (old) Description
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Displaying options and using task specification files 
Displaying options

See Querying lines and setting resampling options for information about displaying 
the pre-model settings for the current line.  

See Specifying the modelling process for information about displaying the model 
calculation and refinement specifications.  

Using task specification files
You can store sets of file specifications and parameter settings for Naudy Automatic 
Model in task specification (.job (OLD), or .task (NEW)) files. 

>> To create a task specification file with the Naudy Automatic Model tool
1 Specify all files and parameters.
2 If possible, execute the task (choose Apply) to ensure that it will work.
3 Choose Save Options from the File menu.  Specify a task specification file 

(INTREPID will add the extension .job)  INTREPID will create the file with the 
settings current at the time of the Save Options operation.

For full instructions on creating and editing task specification files see INTREPID 
task specification (.job) files (R06). With V5.0 Intrepid, we have introduced the 
GOOGLE protobuf language as a means of specifying all the data procesisng options 
for all tools in Intrepid and Geomodeller. This has then also been published, and you 
can find the “Intrepid_tools.proto” file with any installed version of Intrepid. Within 
this file, a formal definition and lexicon for the options available within this Naudy 
tool are given. One of the big advantages gained by this development, is the 
unambiguous specification and the rigourous parser and checking of the task files, 
together with explicit error reporting, when you get it wrong.

>> To use a task specification file in an interactive Naudy Automatic Model 
session
1 Load the task specification (.job, or .task) file (File menu, Load Options).
2 Modify settings as required.
3 Choose Process.   See Calculating the model for all or part of the dataset for 

instructions.
4 Save the Naudy model point dataset if required.  See Saving the model as a point 

dataset for instructions.

>> To use a task specification file for a batch mode Naudy Automatic Model 
task
Type the command naudyd.exe with the switch –batch followed by the name (and 
path if necessary) of the task specification file.  

For example, if you had a task specification file called surv329.job in the current 
directory you would use the command

naudyd.exe –batch surv329.job ( old syntax)

naudyd.exe –batch surv329.task ( new syntax)
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Task specification file notes and example
Here is an example of a Naudy Automatic Model task specification file.

# Example task file V5.0 protbuf syntax - naudy
#  manual or automatic
#  outputs, combine all the by line solutions into a coherent 
“worm dyke” for use in Geomodeller
# Usage: fmanager -batch ebagoola_geomodeller_export.task

IntrepidTask {
Naudy {  
InputLines: “../datasets/ebagoola_S..DIR”;
InputSignal: “../datasets/ebagoola_S..DIR/smooth_mag”;

# InputClearance: “../datasets/ebagoola_S..DIR/radAlt”;
OutputNaudyModel: “../datasets/ebagoola_nau1..DIR”;
ReportFile: “ebagoola_geomodeller.rpt”;
MagneticField {

Magnitude: 56959.39;
Declination: 6.25;
Inclination: -62.5;
SurveyYear: 2004;
SurveyMonth: 1;
SurveyDay: 1;

}
processType: ALL_LINES;  # do full survey
SampleMode: XY_BASED; # treat spatially
VerticalDerivative: false;  # use the TMI
AutoIGRF: true;   # turn on for 
StartDepth: 70.0;  # No bodies in the air gap
EndDepth: 2000.0;
WindowFactor: 1.5;
MinAmplitudeCutoff: 1.0;  # 1 nT noise floor
MaxAmplitudeCutoff: 100.0;  # highest anomaly to consider
LineSpacing: 400.0;
DipRange: false;  # just start with vertical
WidthRange: false;  # just one aspect ratio of width to depth
UseDerivedDip: true;  # use the estimated dip
UseFinerVerticalSampling: false;  #
allowNegativeSusc: false;
AlwaysInvert: false;
CullOnNaudyDip: true;
FixOnNaudyDip: true;
DumpSimilarity: false;
ForceOntoProfile: false;
MaxInvertIterations: 5;
MaximumBodySimilarityToKeep: 3.0;  # keep better solutions 

with similarity less than 3
RemoveClearance: true;
BodyType: Dyke;  # look for dykes
Geomodeller_minimum_number_hot_spots: 4;
Create3D_DykeLinears: true;
Trends {

StrikeCode: ST_CALC;  # estimate the strikes/trends 
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within the survey
ShallowFilter: “naudyShallowTrendFilter.fdf”;
DeepFilter: “naudyDeepTrendFilter.fdf”;
VeryDeepFilter: “naudyVeryDeepTrendFilter.fdf”;
ShallowTolerance: 2.0;
DeepTolerance: 5.0;
VeryDeepTolerance: 0.5;
AlongLine: 3.0;
AcrossLine: 3.5;

}
Worms {

OutputGeomodeller: “ebagoola_dykes.csv”;
Geomodeller_minimum_number_hot_spots: 4;
CreateDykeLinears: true;
RequiredMagnetization_Worms: MAG_ALL;
MakeFiniteDykes: true;
CullReversePolarity: true;   # make sure the right hand 

rule is being applied
BestFitting: true;
BestFittingPercent: 50;  # just take best fitting 

solutions, 50% of them
}

}}

The older, V4 syntax, but still support for now,is shown following 
-

Process Begin
   Name = naudyd
   Parameters Begin
      LineIO Begin
         InputLines = "/disk1/survey/ebagoola"
      LineIO End
      NaudyOptions Begin
         InducingFieldIntensity = 41036.9029453278
         InducingFieldAzimuth = 0.64450229434569
         InducingFieldInclination = 28.277338372818
         AutoIGRF = 1
         StartDepth = 50.0
         EndDepth = 30000.0
         DepthIncrement = 1.1
         AmplitudeCutoff = 2.0
         BodyStrike = 0.0
         AutoStrike = 1
         BinSizeX = 0.5
         BinSizeZ = 0.5
         LineSpacing = 200.0
         TrendCellSize = 70.0
         Complexity = 0
         AutoStrikeOut = 1
         MaxInvertIterations = 10
         Threshold = 3.0
         BodyCode = "BT_DYKE"
      NaudyOptions End
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WormOptions Start
Geomodeller_minimum_number_hot_spots = 4
CreateDykeLinears = 1
RequiredMagnetization_Worms = MAG_ALL
MakeFiniteDykes = 1
CullReversePolarity = 1   
BestFitting = 1
BestFittingPercent = 50  

WormOptions End
      ProcessParameters Begin
         Process = "ALL_LINES"
         StartLineNumber = 0
         EndLineNumber = 0
         NoOfLines = 0
         SampleMode = "XY_BASED"
      ProcessParameters End
   Parameters End
Process End

Here is a more fully annotated version-

##  more annotated job file showing all options, with most of the enumerates
Process Begin

Name = naudyd
OutputNaudyModel= data/nau1..DIR
OutputWorms= data/worm1..DIR
OutputTrends= data/trend1..DIR
InputLines= raw/TeisaDsubset1..DIR
InputZ= raw/TeisaDsubset1..DIR/MagFinal
#InputModel= data/nau1..DIR   ##  can update an existing model
#InputTrends= data/trend1..DIR  ## can use existing trends database
Parameters Begin

Field Begin
InducingFieldIntensity= 51649.9080802049
InducingFieldAzimuth= 3.8918163236731
InducingFieldInclination= -51.896640692569

Field End
NaudyOptions Begin

AutoIGRF= 1
VerticalDerivative = 0
StartDepth= 70.0
EndDepth= 2000.0
WindowFactor= 1.5
MinAmplitudeCutoff= 0.0
MaxAmplitudeCutoff= 100.0
BodyStrike= 0.0
LineSpacing= 200.0
DipRange= 0
WidthRange= 0
UseDerivedDip= 1

## if trying to dip match more exactly at the surface for a BIF
naudyUseFinerSampling= 0  

## now for model body types
UseStep= 0
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UseString= 0
UseDyke= 1

# options for admisable bodies
allowNegativeSusc= 0
AlwaysInvert= 1
CullOnNaudyDip= 1
FixOnNaudyDip= 1
DumpSimilarity= 1

##  solver assumes a vertical section, so XY coords not alwys on a real profile
ForceOntoProfile = 1
MaxInvertIterations= 5
Threshold= 3.0

#  BT_DYKE, BT_SLAB
BodyCode= “BT_DYKE”

NaudyOptions End
WormOptions Start

Geomodeller_minimum_number_hot_spots = 4
CreateDykeLinears = 1
RequiredMagnetization_Worms = MAG_ALL
MakeFiniteDykes = 1
CullReversePolarity = 1   # make sure the right hand rule is 

being applied
BestFitting = 1
BestFittingPercent = 50  # just take best fitting solutions, 

50% of them
WormOptions End

Trends Begin
## ST_PERPENDICULAR, ST_USER, ST_TRENDS, ST_CALC

StrikeCode= “ST_CALC”
ShallowFilter = “naudyShallowTrendFilter.fdf”
#ShallowFilter = “naudyDeepTrendFilter.fdf”
DeepFilter = “naudyDeepTrendFilter.fdf”
#VeryDeepFilter = “naudyVeryDeepTrendFilter.fdf”
ShallowTolerance = 2.
DeepTolerance = 5.
#VeryDeepTolerance = 5.
Rectangle Begin

AlongLine = 3.0
AcrossLine = 3.5

Rectangle End
Trends End
ProcessParameters Begin

##  ALL_LINES, SINGLE_LINE, LINE_RANGE, LINE_SELECTION
Process= “ALL_LINES”
#StartLineNumber= 7754400
#EndLineNumber= 776200
#NoOfLines= 20

#  XY_BASED, FID_BASED, FIXED_MODE
SampleMode= “XY_BASED”

ProcessParameters End
Parameters End

Process End
Library | Help | Top © 2012 Intrepid Geophysics  | Back | 


	Naudy Automatic Model interpretation (T43)
	Naudy Automatic Model concepts
	Using the Naudy Automatic Model tool
	Specifying input and output files
	Summary of file operations
	Resampling mode for data preparation

	The Naudy Automatic Model main window
	Inferred geological structure colours
	Navigating the profile and model display
	Querying lines and setting resampling options

	Plan view
	Specifying the modelling process
	Remanence
	Viewing and recalculating individual lines during the specification process
	Specifying the Earth's core magnetic field data
	Finding and resampling Naudy solutions
	Creating the model: inferred structures and initial calculated field
	Refining inferred structures and optimising the calculated field
	Specifying body strike for the Naudy model point dataset
	Search complexity and refinement options
	Illustration of length and body strike

	Calculating the model for all or part of the dataset
	3D Dyke Geometry
	Data created during the model specification
	Performing the model calculation on the selected lines

	Saving the current model results
	Saving the model as a point dataset
	Exit
	Structure of Naudy model point datasets

	Displaying options and using task specification files
	Displaying options
	Using task specification files
	Task specification file notes and example



