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1 Introduction

Welcome to the Manzanita Systems MPEG Stream Identifier (MPEGID).  MPEGID is an easy-to-use program
with a full graphical user interface (GUI).  It rapidly identifies and characterizes MPEG and related format media
files that are commonly used in today's digital video and streaming applications.  MPEGID tells you the type of
the file and displays important properties of its content.  Both elementary stream files and multiplexed stream
files can be identified with MPEGID.  If the input file is a multiplexed stream, individual elementary streams
within the multiplex will also be identified and their properties will be displayed.

MPEGID identifies all of the following types of media formats:

MPEG-1 Video Elementary Stream

MPEG-2 Video Elementary Stream

MPEG-4 AVC/H.264 Video Elementary Stream

MPEG-4 Part 2 Video Elementary Stream

MPEG Layer I Audio Elementary Stream

MPEG Layer II Audio Elementary Stream

MPEG Layer III (MP3) Audio Elementary Stream

AC-3 (Dolby Digital) Audio Elementary Stream

Enhanced AC-3 (Dolby Digital Plus) Audio Elementary Stream

AAC Elementary Stream (ADTS)

AAC Elementary Stream (ADIF)

AAC Elementary Stream (LOAS/LATM)

DTS Audio Elementary Stream

DTS-HD Audio Elementary Stream

DTS-HD Master Audio Elementary Stream

WAV Audio Data

Manzanita Private Stream XML Data

Manzanita SI Table XML Data

Manzanita SCTE35 Splice Information XML Data

Manzanita SCTE35 Splice Information Text Data

Manzanita DVB Subtitle XML Data

Manzanita DVB Teletext XML Data

MPEG-1 System Stream

MPEG-2 Program Stream, including Video Object (VOB) File

MPEG-2 Transport Stream
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MPEG-4 ISO Base Media File

SMPTE 302M Elementary Stream in MPEG-2 Transport Stream

Private Stream in MPEG-2 Program Stream

User Private Stream in MPEG-2 Program Stream

User Private Stream in MPEG-2 Transport Stream

Private Stream 1 Data in MPEG-2 Transport Stream

Private Stream 2 Data in MPEG-2 Transport Stream

SCTE35 Splice Information in MPEG-2 Transport Stream

DVB Subtitle Stream in MPEG-2 Transport Stream

DVB Teletext Stream in MPEG-2 Transport Stream

AAC Elementary Stream in MPEG-4 ISO Base Media File

MPEGID has an integrated Demultiplexer tool, which allows you to extract and save video, audio, and data
streams from existing system stream, program stream, VOB, transport stream, or MPEG-4 ISO base media
files.

A command line executable is included with the MPEGID installation.  It enables execution of MPEGID in batch
files or scripts for high-volume applications.

The Demultiplexer tool and command line MPEGID are only available with the full, registered version of
MPEGID, and not with the demo version.



MPEGID User's Manual, V4.04

Copyright ©  2006 - 2012 Manzanita Systems, Inc.

1.1 What's New in MPEGID Version 4.0

MPEGID Version 4.0 is a major release that has the following new features: 

DTS-HD audio streams are identified.

Wave Audio (WAV) streams are identified.

Manzanita SCTE35 Splice Information XML Data files are identified.

Manzanita SI Table XML Data files are identified.

Private Stream 2 data in MPEG-2 transport stream files is detected.

MPEG-4 ISO Base Media files with movie fragments ("moof box") are supported.

AAC Spectral Band Replication in MPEG-4 ISO Base Media files is reported.

Video chroma format is detected and reported in MPEG-2 video elementary streams and MPEG-4 AVC/
H.264 video elementary streams.

MPEG-1 and MPEG-2 video is detected in MPEG-4 ISO Base Media files.

Demultiplexer supports MPEG-4 ISO Base Media files with movie fragments ("moof box").

Demultiplexer saves SCTE35 data in Manzanita SCTE35 Splice Information XML Data format.

Demultiplexer saves Private Stream 2 data in Manzanita Private Stream XML Data format.

Demultiplexer can save AAC stream in LOAS/LATM format.

Output of command line Demultiplexer can be sent to standard output (stdout) as well as saved to a file.

1.2 Overview

Identifying and characterizing a media file with MPEGID is as easy as dragging and dropping the file from a file
browser/explorer window onto the MPEGID interface.  If the input file is a video or audio elementary stream,
MPEGID will display a list of properties that characterize its content.  If the file is a multiplexed stream, a tree
structure is shown that illustrates the hierarchy of components in the multiplex.  The properties of each
component in the multiplex, including audio and video elementary streams in the multiplex, are also displayed.

For MPEG-1, MPEG-2, MPEG-4 AVC/H.264, and MPEG-4 Part 2 video elementary streams, MPEGID may
display the following properties:

File Size

Duration

Bit Rate

Frame Rate

Profile

Level
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Resolution

Aspect Ratio

Chroma Format

For MPEG Layer I, MPEG Layer II, MPEG Layer III (MP3), AC-3 (Dolby Digital), Enhanced AC-3 (Dolby Digital
Plus), AAC (ADTS, ADIF, LOAS/LATM), DTS, DTS-HD, and DTS-HD Master audio elementary streams, MPEGID
may display the following properties:

File Size

Duration

Bit Rate

Sample Rate

Number of substreams (Enhanced AC-3 and DTS-HD Master only)

Audio Object Type (AAC LOAS/LATM only)

Number of sub-frames (AAC LOAS/LATM only)

Spectral Band Replication (SBR) extension detected (AAC only)

For SMPTE 302M audio elementary streams, MPEGID displays the following properties:

Bit Rate

Number of Channels

channel_id

Sample Size

For WAV audio files, MPEGID displays the following properties:

Bit Rate

Sample Rate

Format

Number of Channels

Word Size

For MPEG-1 System streams, MPEGID displays the following properties:

File Size

Duration

Mux Rate

stream_id of each elementary stream

Properties of each elementary stream
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For MPEG-2 Program and VOB streams, MPEGID displays the following properties:

File Size

Duration

Program Mux Rate

stream_type of each elementary stream

stream_id of each elementary stream

VOB subtype of each AC-3 (Dolby Digital) elementary stream (VOB streams only)

Properties of each elementary stream

For MPEG-4 ISO Base Media files, MPEGID displays the following properties:

File Size

Duration

track_ID of each elementary stream

Properties of each elementary stream

For MPEG-2 transport streams, MPEGID displays the following properties:

File Size

Transport Packet Size

Duration

Transport Rate

program_number associated with each program

PCR PID and PMT PID for each program

PID of each elementary stream

stream_id and stream_type of each elementary stream

Descriptors (if present) associated with each elementary stream

Properties of each elementary stream

To give you the fastest results, MPEGID only inspects the beginning of the input file to determine its contents. 
Therefore, the characteristics that are displayed are those that are present initially in the stream.  Any changes,
for example, in the bit rate, that occur later in the stream will not be noted.  

1.3 About this Manual

This online manual completely documents the use of MPEGID.  The following chapters are presented:

Getting Started  covers installation of MPEGID.

The MPEGID User Interface  describes all menus, controls, and displays available in the MPEGID
program.

9

14
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Using MPEGID  details how to identify media files with MPEGID.  It describes the results that are
displayed by MPEGID for each type of file.

Additional Support  presents Frequently Asked Questions (FAQ) about MPEGID, a list of pertinent
references, and tips for getting additional help and support.

Purchasing and License Agreement  gives information for purchasing the full version of MPEGID and
outlines the terms of the license agreement that covers the MPEGID software and associated
documentation.

This manual assumes that you have familiarity with the basic MPEG syntax and semantics.

22

49

54



Chapter II

Getting Started



Getting Started 9

Copyright ©  2006 - 2012 Manzanita Systems, Inc.

2 Getting Started

This chapter helps you install and start MPEGID.  It contains the following sections: 

Installing MPEGID  describes installation of the MPEGID program to your hard drive.

Starting MPEGID  explains how to start the MPEGID program on your computer.

Installing Your License Key  describes how to install the key that allows you to run the full version of
MPEGID.

The MPEGID program will run as a demo version until you install the license key that you will receive
when you register your copy with Manzanita Systems, or unless you have a dongle for any licensed
Manzanita product installed on your system.  The demo version does not allow you to use the
demultiplexer function and command line execution, both of which are supported in the full version.

2.1 Installing MPEGID

The latest version of MPEGID is always available for download from the Manzanita Systems website at:

http://www.manzanitasystems.com/mpegid.html   

MPEGID is available for the following platforms:

Windows

Linux

Mac OS  

2.1.1 Windows

MPEGID is provided in a single self-extracting executable for installation on Windows systems.  Typically, the
file name includes the version number, e.g.,  mpegid-4.0.exe.

 Windows 2000, Windows Server 2003, Windows XP, Windows Vista, Windows 7, or Windows Server 2008
is recommended for MPEGID V4.0.  MPEGID may work on Windows 98, Windows ME, and Windows NT, but it
is not officially supported on these platforms.

 If you currently have an earlier version of the MPEGID software installed on your system, you should
uninstall it before installing MPEGID V4.0.

To install MPEGID from the self-extracting installation file on the target Windows system:

1. Open the folder in which you downloaded the MPEGID installation file using My Computer or the Windows
Explorer and double-click on it.   

2. Follow the on-screen instructions to install MPEGID on your computer. 

3. If you are going to use the command line version of MPEGID, make sure that the item labeled "Add
to PATH variable" is checked in the checklist of components to install. 

9
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 If there are other versions of MPEGID installed on this same machine, then you must check the PATH
environment variable and make sure that the newest version is the only one listed. If the old application

is uninstalled, the path reference to the older version should have been removed.

2.1.2 Linux

The minimum system requirement for installing MPEGID on a Linux system is:

i386+ compatible processor

fontconfig 2.4.2 or later is needed to use the GUI

Both RPM and tar distributions are available for installation of MPEGID on Linux.  The files will be named, for
example, mpegid-4.0-1.i386.rpm  and mpegid-4.0.tgz . 

 If you currently have an earlier version of the MPEGID software installed on your system, you should
uninstall it before installing MPEGID V4.0.

To install MPEGID from the RPM package:

 1. Use RPM per your normal procedure to install the MPEGID package. 

 For example:
su
rpm -i mpegid-4.0-1.i386.rpm

To install MPEGID from the tar file: 

1. Log in as root user and unpack the archive into /opt.  

 For example:
su
cd /opt
tar xzf /path/to/archive/mpegid-4.0.tgz

2. Create symbolic links from the MPEGID executables to a directory which is in your PATH variable, or
include the location of the MPEGID executables in the PATH variable.  The MPEGID GUI program is called 
gmpegid.  The command line version of MPEGID is called mpegid.

 For example:
ln -s /opt/manzanita/mpegid/bin/gmpegid /usr/bin/gmpegid
ln -s /opt/manzanita/mpegid/bin/mpegid /usr/bin/mpegid

3. If the system is running GNOME or KDE, a desktop entry can be created by making links to files in the /
desktop directory.

 For example:
ln -s /opt/manzanita/mpegid/desktop/mpegid.desktop /usr/share/applications/
mpegid.desktop
ln -s /opt/manzanita/mpegid/desktop/mpegid.png /usr/share/icons/hicolor/32x32/
apps/mpegid.png 
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2.1.3 Mac OS

The minimum system requirements for installing MPEGID on Mac OS X are:

Mac OS X V10.4 or newer

MPEGID is provided as a disk image, e.g., mpegid-4.0.dmg, for installation on Mac OS X systems.  

 If you currently have an earlier version of the MPEGID software installed on your system, you should
uninstall it before installing MPEGID V4.0.

To install MPEGID from the disk image:

1. Double-click on the mpegid-4.0.dmg file icon to mount it as a disk image volume.  

2. Drag the MPEGID application to your /Applications folder.

3. If you intend to run the command line version of MPEGID, the complete path of the MPEGID binary must be
added to the PATH environment variable. The provided Set Environment.command script can be used to
add the /Applications/mpegid.app/Contents/MacOS path to the ~/.MacOSX/environment.plist file.
Double-click on the Set Environment icon and follow the directions.

2.2 Starting MPEGID

After MPEGID is installed, it will run as a demo version until you unlock the full version with a license key.  

The procedure for starting the GUI version of the MPEGID program is the same whether you are running the
demo version or the full version.  For a description of the command line version of MPEGID, see the section 
Identifying from the Command Line .

To start MPEGID on Windows:

1. Choose Start > Programs > Manzanita Systems > MPEGID 4 from the Windows Start menu, or double-
click the  MPEGID icon on the Desktop.

To start MPEGID on Linux:

1. If you have created a desktop entry for MPEGID, choose the MPEGID item from the Sound & Video
(Multimedia) submenu of your Start (Launch) menu.

or

1. At a shell prompt, enter the line:

gmpegid

 If you get a message that the name that you entered is not recognized as a command, then the
MPEGID executable is not in a location that is recognized by the PATH environment variable.  You should
either create a symbolic link from the MPEGID program to a directory which is in your PATH variable or
include the location of the MPEGID program in the PATH variable.  

46
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To start MPEGID on Mac OS X:

1. Double click on the MPEGID application in your Applications folder.

On all platforms, if you have not yet installed a valid license key, a dialog box will be displayed that gives you
information about the demo version.  The Enter License Key button allows you to install a new license key .
Click Use Demo to open the MPEGID program in demo mode.  You may now begin identifying your media files.

If you have installed a license key for the full version of MPEGID, or if you have a hardware dongle for any
Manzanita product connected to your computer, then the full version of MPEGID will immediately open when
you start the program.  

2.3 Installing Your License Key

MPEGID is initially installed as a demo version.  You will need a valid MPEGID license key or have a hardware
dongle for any licensed Manzanita product on your system to unlock the full version.  With the full version, you
will have access to the Demultiplexer and command line execution.

You will receive a license key when you register your copy of MPEGID with Manzanita Systems and pay a
registration fee.  The section, Purchasing a Registered Copy , in this manual gives instructions on how to
order your registered copy.

 It is recommended that you record and save your license key.  You will need it if you ever re-install MPEGID.

To install the MPEGID license key:

1. Start the MPEGID GUI program. 

 A dialog box will be displayed that gives you information about the demo version.  

2. Click the Enter License Key button.

3. Enter your license key in the labeled textbox.  The license key will be 26 characters separated with
dashes (-) into 6 groups, for example, “37XDK-18CR3-2QA47-7D3NT-B631S-4”. 

4. Enter your company name or organization in the textbox labeled Company Name.

5. Click the OK button. 

If the license key was successfully installed, a dialog box will appear informing you that the MPEGID
program will quit.

6. Start the MPEGID GUI program again. 

The full version of MPEGID will open.  You may now begin identifying your media files.

12
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3 The MPEGID User Interface

The MPEGID user interface consists of a single, simple window. It has the following components:

 

 

Menu Bar
The Menu Bar provides menus to open an input media file, save a report file, run the Demultiplexer, and set
display preferences.  It also provides access to the online help system.

Stream Title Bar
The Stream Title Bar tells you the type of the input media file.

Multiplex Pane
The Multiplex Pane shows a graphical representation of the contents of the input media file.  It is only displayed
if the input file is a multiplexed stream.

Property Pane
The Property Pane displays a list of stream properties and their values.  If the input file is a multiplexed stream,
the properties for the component that is currently selected in the Multiplex Pane are highlighted.

15
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3.1 Menu Bar

The Menu Bar at the top of the interface gives you access to MPEGID's main functions.  The tables below
summarize the commands on the Menu Bar.

File >

Identify... Opens the Open Input File dialog box that allows
you to specify a media file for identification and
characterization.

Ctrl+O

Save Report As... Saves the properties of the current input file in a
text file.

Ctrl+S

Quit Closes the MPEGID program. Ctrl+Q

Edit >

Demux... Extracts a single, selected elementary stream
from a multiplexed stream and saves it as a binary
file.  The input file must be an MPEG-1 system
stream, MPEG-2 program stream, VOB, MPEG-2
transport stream, or MPEG-4 ISO base media file.

Ctrl+D

Preferences... Sets the format (decimal or hexadecimal) in which
stream_id, PID, and stream_type values are
displayed.

Help >

Manual Opens the online User's Manual.

About Displays information about your copy of the
MPEGID program.



MPEGID User's Manual, V4.016

Copyright ©  2006 - 2012 Manzanita Systems, Inc.

3.2 Stream Title Bar

The Stream Title Bar spans the MPEGID interface just below the Menu Bar.  When the MPEGID program initially
starts, the Stream Title Bar will be a blank space.  After you open an input file, its type will be displayed in the
Stream Title Bar as both a description and an icon.

The following types may be displayed in the Stream Title Bar:

Icon Description

MPEG-1 Video Elementary Stream

MPEG-2 Video Elementary Stream

MPEG-4 AVC/H.264 Video Elementary Stream

MPEG-4 Part 2 Video Elementary Stream

MPEG Layer I Audio Elementary Stream

MPEG Layer II Audio Elementary Stream

MPEG Layer III (MP3) Audio Elementary Stream

AC-3 (Dolby Digital) Audio Elementary Stream

Enhanced AC-3 (Dolby Digital Plus) Audio Elementary Stream

AAC Elementary Stream (ADTS)

AAC Elementary Stream (ADIF)

AAC Elementary Stream (LOAS/LATM)

DTS Audio Elementary Stream

DTS-HD Audio Elementary Stream

DTS-HD Master Audio Elementary Stream

WAV Audio Data

Manzanita Private Stream XML Data

Manzanita SI Table XML Data

Manzanita SCTE35 Splice Information XML Data

Manzanita SCTE35 Splice Information Text Data

Manzanita DVB Subtitle XML Data
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Icon Description

Manzanita DVB Teletext XML Data

MPEG-1 System Stream

MPEG-2 Program Stream*

MPEG-2 Transport Stream

MPEG-4 ISO Base Media File

Unknown**

* Video Object (VOB) files are identified as MPEG-2 Program Streams.

** The input file was not recognized by MPEGID.
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3.3 Multiplex Pane

The Multiplex Pane occupies the panel on the left side of the MPEGID window below the Stream Title Bar when
the input file is a multiplex of component streams (MPEG-1 System Stream, MPEG-2 Program Stream, VOB,
MPEG-2 Transport Stream, or MPEG-4 ISO Base Media File).   It is not present when the input file is a single
elementary stream or XML data file.

The Multiplex Pane displays a tree structure that depicts the hierarchy of the multiplex.  The root node of the tree
signifies the multiplex file itself.  Each node that branches from the root node represents a component of the
multiplex.  These branch nodes show the multiplexed video, audio, and data streams that are identified in the
file.  If the input file is an MPEG-2 Transport Stream, the Multiplex Pane will also display a Program node for
each program that is found.  In this case, the video, audio, and data streams that are assigned to a given
program will branch from the associated Program node.

For example, the MPEG-2 transport stream in the example below has one program, identified with Program
Number 2.  This program contains one video elementary stream and two audio elementary streams.  The
Multiplex Pane displays an MPEG-2 Transport Stream root node, and a Program Number 2 node with one
video branch node and two audio branch nodes.  When the MPEG-2 Video Elementary Stream node is
selected in the Multiplex Pane as shown, its detailed properties are highlighted in the Property Pane.  
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The following types of root nodes may appear in the Multiplex Pane:

Icon Description

MPEG-1 System Stream

MPEG-2 Program Stream1

 MPEG-2 Transport Stream

MPEG-4 ISO Base Media File

1 Video Object (VOB) files are identified as MPEG-2 Program Streams.

The following types of branch nodes may appear in the Multiplex Pane:

Icon Description

Program Number N2

MPEG-1 Video Elementary Stream

MPEG-2 Video Elementary Stream

MPEG-4 AVC/H.264 Video Elementary Stream

MPEG-4 Part 2 Video Elementary Stream

MPEG Layer I Audio Elementary Stream

MPEG Layer II Audio Elementary Stream

MPEG Layer III (MP3) Audio Elementary Stream

AC-3 (Dolby Digital) Audio Elementary Stream

Enhanced AC-3 (Dolby Digital Plus) Audio Elementary Stream

AAC Elementary Stream (ADTS)

AAC Elementary Stream (LOAS/LATM)

AAC Elementary Stream (MP4)

DTS Audio Elementary Stream

DTS-HD Audio Elementary Stream

DTS-HD Master Audio Elementary Stream

SMPTE 302M Elementary Stream

User Private Stream

Private Stream

Private Stream 1

Private Stream 2

DVB Subtitle Stream
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Icon Description

DVB Teletext Stream

SCTE35 Splice Information

Unrecognized stream content

No data seen for this elementary stream

2 N is the value of the program_number that is assigned to the program in the Program Association
Table (PAT).   The Program Number node will only be displayed if the input file is identified as a MPEG-2
Transport Stream.

3.4 Property Pane

The Property Pane displays a list of properties that characterize the input file and each of its component
streams.  If the input file is a multiplexed stream (MPEG-1 System Stream, MPEG-2 Program Stream, MPEG-2
Transport Stream, or MPEG-4 ISO Base Media File), then the Property Pane occupies the panel to the right of
the Multiplex Pane.  In this case, the Property Pane displays all properties of the multiplex with indenting to
distinguish individual components and to indicate hierarchy.  When you click on a node in the Multiplex Pane,
the properties of the corresponding component are highlighted in the Property Pane. 

The chapter, Using MPEGID , in this manual describes the properties for each stream and multiplex
component that are displayed in the Property Pane.

22
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4 Using MPEGID

Identifying and characterizing a media file is as simple as opening up the file in MPEGID.  MPEGID will display
important properties of the stream that the file contains.  If the input file contains a multiplexed stream (MPEG-1
System Stream, MPEG-2 Program Stream, MPEG-2 Transport Stream, or MPEG-4 ISO Base Media File),
MPEGID will also display a graphical representation of the multiplex. 

This chapter contains the following sections:

Identifying Your Media File  explains how to open an input media file for identification and
characterization.

Viewing the Multiplex Structure  describes use of the graphical representation that is displayed for
multiplexed streams.

Interpreting Stream Properties  gives a detailed description of the properties that are displayed for
each type of stream and multiplex component.

Saving a Report File  tells how to save the stream properties in a text file.

Demultiplexing an Elementary Stream  documents use of the demultiplexer utility.

Identifying from the Command Line  describes the command line version of MPEGID.

4.1 Identifying a Media File

You can open a media file in MPEGID by dragging and dropping the file from a file browser/explorer window
onto the MPEGID interface, or by using the Identify function on the File Menu.  MPEGID will automatically identify
the input file once it has been opened. 

To open and identify an input media file using drag-and-drop:

1. Select the input file in a graphical file system browser/explorer.  Drag and drop the file onto the Stream
Title Bar, Multiplex Pane or Property Pane of the MPEGID interface.

MPEGID will open the input file and identify it.  The Stream Title Bar will display the identity of the file.  If
the input file is an elementary stream, a list of properties will be displayed in the Property Pane below the
Stream Title Bar.  If the input file is a multiplexed stream, then both the Multiplex Pane and Property
Pane will display the results of the identification.

If MPEGID does not recognize the format of the input file, it will display an error message.

To open and identify an input media file using the Identify function:

1. Choose File > Identify... from the Menu Bar.  The Open File dialog box will appear.

2. Browse your system to select the input file, then click Open.

The Open File dialog box will close, and MPEGID will open the input file and identify it.  The Stream Title
Bar will display the identity of the file.  If the input file is an elementary stream, a list of properties will be
displayed in the Property Pane below the Stream Title Bar.  If the input file is a multiplexed stream, then
both the Multiplex Pane and Property Pane will display the results of the identification.

If MPEGID does not recognize the format of the input file, it will display an error message.
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4.2 Viewing the Multiplex Structure

If your input media file is an MPEG-1 System Stream, MPEG-2 Program Stream, VOB*, MPEG-2 Transport
Stream, or MPEG-4 ISO Base Media File, MPEGID will display a tree diagram in the Multiplex Pane that
represents the contents of the multiplexed stream.  This tree illustrates the hierarchical structure of the
multiplex, showing the individual elementary streams that are contained in it.  If the input stream is an MPEG-2
Transport Stream, the tree will show all programs that are defined in the multiplex, and all elementary streams
that are mapped to each program.

The root node of the tree represents the multiplexed stream itself.  Each node that branches from the root node
represents a component of the multiplex.  For MPEG-1 System Streams, MPEG-2 Program Streams, and
MPEG-4 ISO Base Media Files, only elementary stream nodes may branch from the root node.  For MPEG-2
Transport Streams, one or more Program nodes branch from the root node.  Each Program node may have
one or more elementary stream nodes branching from it.  See the section, Multiplex Pane , for a description
of the types of nodes that may be depicted in the Multiplex Pane.

When you click on a node in the Multiplex Pane, the properties of the corresponding component are highlighted
in the Property Pane. 

* VOB files are identified by MPEGID as MPEG-2 Program Streams.

4.3 Interpreting Stream Properties

The Property Pane displays important properties of the input stream.  If the input file is a multiplexed stream,
then the Property Pane presents the properties hierarchically to mirror the graphical representation in the
Multiplex Pane.  When an individual node in the Multiplex Pane is selected, the properties of the corresponding
component will be highlighted in the Property Pane.

Any portion of the results that are displayed in the Property Pane can be selected, copied to the clipboard, and
pasted in a document.  You can also save the entire contents of the Property Pane in a report file  for later
reference.

This section gives detailed descriptions of the properties that are displayed for each type of stream and
multiplex component.

 It is important to remember that MPEGID only looks at the beginning of the input file to determine its identity
and stream properties.  Therefore, any changes that occur later in the file will not be reflected in the displayed
properties.

The Property Pane displays the following types of properties:

General File Properties

MPEG-1 Video Elementary Stream Properties

MPEG-2 Video Elementary Stream Properties

MPEG-4 AVC/H.264 Video Elementary Stream Properties

MPEG-4 Part 2 Video Elementary Stream Properties

MPEG Audio Elementary Stream Properties

AC-3 Audio Elementary Stream Properties

Enhanced AC-3 Audio Elementary Stream Properties
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AAC Elementary Stream (ADTS) Properties 

AAC Elementary Stream (ADIF) Properties

AAC Elementary Stream (LOAS/LATM) Properties

AAC Elementary Stream (MP4) Properties

DTS Audio Elementary Stream Properties

DTS-HD and DTS-HD Master Audio Elementary Stream Properties

WAV Audio Data Properties

SMPTE 302M Audio Elementary Stream Properties

Manzanita XML Data Properties

Private Stream Properties

User Private Stream Properties

Private Stream 1 and Private Stream 2 Properties

SCTE35 Splice Information Properties

DVB Subtitle Stream Properties

DVB Teletext Stream Properties

MPEG-1 System Stream Properties

MPEG-2 Program Stream Properties

MPEG-2 Transport Stream Properties

MPEG-2 Program Properties

MPEG-4 ISO Base Media File Properties
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4.3.1 General File Properties

For all supported types of media files, the Property Pane will display the following properties:

File

The File property is the full pathname of the input file. 

Type

The Type property is the file type that was determined by MPEGID. 

File Size

The File Size property gives the size of the input file in bytes. 

Duration

The Duration property gives an estimate of the length of the stream in hours, minutes, and seconds. 
MPEGID bases this estimate on the File Size of the input file and the bit rate that is determined from the
stream.  For video and audio elementary streams, the bit rate is explicitly specified in the stream syntax. 
For MPEG-1 System Streams and MPEG-2 Program Streams, the bit rate is the initial mux_rate value
specified in the stream.  For MPEG-2 Transport Streams, MPEGID estimates the bit rate from the PCR
(Program Clock Reference) values in the beginning of the stream.  Note that this property is only an
estimate.  The actual duration will be different if a bit rate change occurs in the stream, or if the actual rate
varies from that specified in the stream syntax.

4.3.2 MPEG-1 Video Elementary Stream Properties

The following properties are displayed in the Property Pane for an MPEG-1 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the video elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG-1 Video
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream Only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.  Generally, MPEG-1 video elementary streams are assigned a stream_type value
of 1.  The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which
the stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the MPEG-1 Video Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line. The Descriptors property
is only displayed if the MPEG-1 Video Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the video elementary
stream.   Generally, MPEG-1 video elementary streams are assigned a stream_id value from 224 to 239
(0xE0 to 0xEF).   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The
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base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  The
stream_id property is only displayed if the MPEG-1 Video Elementary Stream is a component of an MPEG-
1 System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  The Bit Rate property will be set to "VBR" if the video stream is variable bit rate.

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) that is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size
fields in the video sequence header.

Aspect Ratio

The Aspect Ratio property is the value specified in the aspect_ratio_information field in the video
sequence header.

4.3.3 MPEG-2 Video Elementary Stream Properties

The following properties are displayed for an MPEG-2 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

This property is the value of the PID that is associated with the video elementary stream.   The value may
be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in decimal, or if
prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu function.  The PID property is
only displayed if the MPEG-2 Video Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream Only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.   Generally, MPEG-2 video streams are assigned a stream_type value of 2.  The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the MPEG-2 Video Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the MPEG-2 Video Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

This property is the stream_id value that appears in PES headers for the video stream.   Generally, MPEG-
2 video streams are assigned a stream_id value from 224 to 239 (0xE0 to 0xEF).   The value may be
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specified in decimal, or if prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu
function.  The stream_id property is only displayed if the MPEG-2 Video Elementary Stream is a
component of an MPEG-1 System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 ISO base
media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  If the video stream is variable bit rate, the Bit Rate property will be set to the maximum bit rate at
which the stream is encoded.

Profile

The Profile property is determined from the profile_and_level_indication field in the video elementary
stream syntax.  

Level

The Level property is determined from the profile_and_level_indication field in the video syntax.  

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) that is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size
fields in the video sequence header.

Aspect Ratio

The Aspect Ratio property is the value specified in the aspect_ratio_information field in the video
sequence header. 

Chroma Format

The Chroma Format property indicates the format of the chrominance information in the video and will be
one of the following: 4:2:0, 4:2:2 or 4:4:4. 

4.3.4 MPEG-4 AVC/H.264 Video Elementary Stream Properties

The following properties are displayed in the Property Pane for an MPEG-4 AVC/H.264 Video Elementary
Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the video elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG-4 AVC/H.264
Video Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
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the Program Map Table.   Generally, H.264 / AVC / MPEG-4 part 10 video streams are assigned a
stream_type value of 27 (0x1B).  The value may be specified in decimal, or if prefaced with a "0x", in
hexadecimal.  The base in which the stream_type property is displayed is set by the Edit > Preferences
menu function.  The stream_type property is only displayed if the MPEG-4 AVC/H.264 Video Elementary
Stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the MPEG-4 AVC/H.264 Video Elementary Stream is a component of an MPEG-2
Transport Stream.

stream_id (MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the video elementary
stream.   Generally, video elementary streams are assigned a stream_id value from 224 to 239 (0xE0 to
0xEF).   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id
property is only displayed if the MPEG-4 AVC/H.264 Video Elementary Stream is a component of an
MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 ISO base
media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  If the video stream is variable bit rate, the Bit Rate property will be set to the maximum bit rate at
which the stream is encoded.

Profile

The Profile property is determined from the profile_idc field in the video elementary stream syntax.  

Level

The Level property is determined from the level_idc in the video elementary stream syntax.  

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps).  It is calculated from the time_scale
and num_units_in_tick fields when they are present in the video stream.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size
fields in the video sequence header.

Chroma Format

The Chroma Format property indicates the format of the chrominance information in the video and will be
one of the following: 4:2:0, 4:2:2 or 4:4:4. 
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4.3.5 MPEG-4 Part 2 Video Elementary Stream Properties

The following properties are displayed for an MPEG-4 Part 2 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

This property is the value of the PID that is associated with the video elementary stream.   The value may
be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in decimal, or if
prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu function.  The PID property is
only displayed if the MPEG-4 Part 2 Video Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 The base in which the stream_type property is displayed is set by the Edit > Preferences menu function.
The stream_type property is only displayed if the MPEG-4 Part 2 Video Elementary Stream is a component
of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line. The Descriptors property
is only displayed if the MPEG-4 Part 2 Video Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_id (MPEG-2 Transport Streams only)

This property is the stream_id value that appears in PES headers for the video stream.   Generally, video
elementary streams are assigned a stream_id value from 224 to 239 (0xE0 to 0xEF).   The value may be
specified in decimal, or if prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu
function.  The stream_id property is only displayed if the MPEG-4 Part 2 Video Elementary Stream is a
component of an MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 ISO base
media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  If the video stream is variable bit rate, the Bit Rate property will be set to the maximum bit rate at
which the stream is encoded.

Profile & Level

The Profile & Level property is determined from the video elementary stream syntax.

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) if it is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified in the video stream syntax.
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Chroma Format

The Chroma Format property indicates the format of the chrominance information in the video and will be
one of the following: 4:2:0, 4:2:2 or 4:4:4. 

4.3.6 MPEG Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for an MPEG Layer I Audio Elementary Stream,
MPEG Layer II Audio Elementary Stream, or MPEG Layer III (MP3) Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG Audio
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   Generally, MPEG audio Layer I and II elementary streams are assigned a
stream_type value of 3, and Layer III streams have a stream_type value of 4.  The value may be specified
in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_type property is
displayed is set by the Edit > Preferences menu function.  The stream_type property is only displayed if
the MPEG Audio Elementary Stream is a component of an MPEG-2 Transport Stream.  

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the MPEG Audio Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, MPEG audio (all Layers) streams are assigned a stream_id value from 192 to 223
(0xC0 to 0xDF).   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The
base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  The
stream_id property is only displayed if the MPEG Audio Elementary Stream is a component of an MPEG-1
System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax.  

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.
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4.3.7 AC-3 Audio (Dolby Digital) Elementary Stream Properties

The following properties are displayed in the Property Pane for an AC-3 (Dolby Digital) Audio Elementary
Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the AC-3 Audio Elementary
Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 Generally, AC-3 audio streams are assigned a stream_type value of 129 (0x81).   The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the AC-3 Audio Elementary Stream is a component of an MPEG-2 Transport
Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the AC-3 Audio Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the AC-3 audio
elementary stream.   Generally, AC-3 audio streams are assigned a stream_id value of 189 (0xBD).   The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id property
is only displayed if the AC-3 Audio Elementary Stream is a component of an MPEG-2 Program Stream or
MPEG-2 Transport Stream.

VOB sub-type (VOBs only)

The VOB sub-type is an identifier that is unique for each Dolby AC-3 stream in the VOB.  The VOB sub-type
property is only displayed if the AC-3 Audio Elementary Stream is a component of a VOB-type MPEG-2
Program Stream.  

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.
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4.3.8 Enhanced AC-3 (Dolby Digital Plus) Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for an Enhanced AC-3 (Dolby Digital Plus) Audio
Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the Enhanced AC-3 Audio
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 Generally, Enhanced AC-3 are given a value of 135 (0x87).   The base in which the stream_type property
is displayed is set by the Edit > Preferences menu function.  The stream_type property is only displayed if
the Enhanced AC-3 Audio Elementary Stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the Enhanced AC-3 Audio Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the AC-3 audio
elementary stream.   Generally,  Enhanced AC-3 audio streams are assigned a stream_id value of 189
(0xBD).   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id
property is only displayed if the Enhanced AC-3 Audio Elementary Stream is a component of an MPEG-2
Program Stream or MPEG-2 Transport Stream.

VOB sub-type (VOBs only)

The VOB sub-type is an identifier that is unique for each Enhanced AC-3 Audio Elementary Stream in the
VOB.  The VOB sub-type property is only displayed if the Enhanced AC-3 Audio Elementary Stream is a
component of a VOB-type MPEG-2 Program Stream.  

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.

Number of substreams

Indicates the total number of substreams embedded in the Enhanced AC-3 stream.  This property is only
displayed if substreams are present. Note that the Bit Rate property is the total bit rate of all substreams.
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4.3.9 AAC Elementary Stream (ADTS) Properties

MPEGID identifies Advanced Audio Coding (AAC) data in Audio Data Transport Stream (ADTS) container
format.  

The following properties are displayed in the Property Pane for an AAC Elementary Stream (ADTS): 

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the AAC Elementary
Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the AAC elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 Generally, AAC streams are assigned a stream_type value of 15 (0x0F).   The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the AAC Elementary Stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the AAC Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the AAC elementary
stream.   Generally, AAC streams are assigned a stream_id value from 192 to 223 (0xC0 to 0xDF).   The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id property
is only displayed if the AAC Elementary Stream is a component of an MPEG-2 Program Stream or MPEG-2
Transport Stream.

Bit Rate

AAC (ADTS) streams are always encoded at a variable bit rate.  For the Bit Rate property, MPEGID
estimates the bit rate (in bps) from the audio frames in the initial buffer. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.   

Spectral Band Replication (SBR)

The Spectral Band Replication property will only be displayed if an SBR extension is detected in the AAC
stream. 

4.3.10 AAC Elementary Stream (ADIF) Properties

MPEGID identifies Advanced Audio Coding (AAC) data in Audio Data Interchange Format (ADIF) container
format.  
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 AAC data can not be multiplexed while in the ADIF container format.  As such, MPEGID will never identify an
AAC Elementary Stream (ADIF) as a component of a multiplexed data file.

The following properties are displayed in the Property Pane for an AAC Elementary Stream (ADIF): 

Bit Rate

AAC (ADIF) streams can be either variable or constant bit rate.  If it is variable bit rate, the Bit Rate property
will be set to VBR.  If the stream is constant bit rate, the Bit Rate property will be set to the rate in bits per
second (bps) that is specified in the audio elementary stream syntax.

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.  

4.3.11 AAC Elementary Stream (LOAS/LATM) Properties

MPEGID identifies Advanced Audio Coding (AAC) data in both Low-overhead MPEG-4 Audio Transport Multiplex
(LATM) and Low Overhead Audio Stream (LOAS) formats.

The following properties are displayed in the Property Pane for an AAC Elementary Stream (LATM/LOAS): 

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the AAC Elementary
Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the AAC elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 Generally, AAC Elementary Stream (LATM/LOAS) are assigned a stream_type value of 17 (0x11), 14496-3
MPEG-4 Audio.   The base in which the stream_type property is displayed is set by the Edit > Preferences
menu function.  The stream_type property is only displayed if the AAC Elementary Stream is a component
of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the AAC Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the elementary stream.  
Generally, audio streams are assigned a stream_id value from 192 to 223 (0xC0 to 0xDF).   The value
may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id
property is displayed is set by the Edit > Preferences menu function.  The stream_id property is only
displayed if the AAC Elementary Stream is a component of an MPEG-2 Program Stream or MPEG-2
Transport Stream.

Audio Object Type

MPEG-4 audio support many different audio codecs.  The Audio Object Type describes the codec used to
create this MPEG-4 audio stream
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Number of sub-frames

This property gives the number of sub-frames contained in each AAC audio frame.  Sub-frames are used
to expand the number of channels supported by the audio stream.

Bit Rate

The Bit Rate for AAC LOAS/LATM streams comes from aac_getinfo field, which is an estimate of the bit
rate (in bps) from all audio frames in the initial buffer.  

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.   

Spectral Band Replication (SBR)

The Spectral Band Replication property will only be displayed if an SBR extension is detected in the AAC
stream. 

4.3.12 AAC Elementary Stream (MP4) Properties

When AAC audio data in ADTS or LATM/LOAS container format is multiplexed in an MPEG-4 ISO Base Media
File, the headers are stripped off and the data is multiplexed as raw AAC frames.  MPEGID identifies this
multiplexed AAC data as AAC Elementary Stream (MP4).  

The following properties are displayed in the Property Pane for an AAC Elementary Stream (MP4): 

track_ID

The track_ID property is the value that identifies the AAC elementary stream in the MPEG-4 ISO base
media file.

Bit Rate

AAC elementary streams that are multiplexed in MPEG-4 ISO base media files are encoded at a variable
bit rate.  For the Bit Rate property, MPEGID estimates the bit rate (in bps) from the audio frames in the
initial buffer. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.   

Spectral Band Replication (SBR)

The Spectral Band Replication property will only be displayed if an SBR extension is detected in the AAC
stream. 

4.3.13 DTS Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a DTS Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
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by the Edit > Preferences menu function.  The PID property is only displayed if the DTS Audio Elementary
Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the DTS Audio Elementary
Stream in the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in
hexadecimal.  Generally, DTS audio streams are assigned a stream_type value of 0x06.   The base in
which the stream_type property is displayed is set by the Edit > Preferences menu function.  The
stream_type property is only displayed if the DTS Audio Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the DTS Audio Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, DTS audio streams are assigned a stream_id value of 189 (0xBD).   The value may
be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id
property is displayed is set by the Edit > Preferences menu function.  The stream_id property is only
displayed if the DTS Audio Elementary Stream is a component of an MPEG-2 Program Stream or MPEG-2
Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the DTS Audio Elementary
Stream syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the DTS
Audio Elementary Stream syntax.

4.3.14 DTS-HD and DTS-HD Master Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a DTS-HD Audio Elementary Stream or DTS-HD
Master Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the DTS-HD audio elementary stream.  
The PID value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified
in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is
set by the Edit > Preferences menu function.  The PID property is only displayed if the DTS-HD audio
elementary stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Program Stream and MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
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 Generally, DTS-HD audio streams are assigned a stream_type value of 0x06.   The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the  DTS-HD audio streams is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the DTS-HD audio stream is a component of an MPEG-2 Transport Stream.

stream_id (MPEG-2 Program Stream and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the DTS-HD audio
stream.   Generally, DTS-HD audio streams are assigned a stream_id value of 189 (0xBD).   The value
may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id
property is displayed is set by the Edit > Preferences menu function.  The stream_id property is only
displayed if the DTS-HD audio stream is a component of an MPEG-2 Program Stream or MPEG-2
Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the DTS-HD audio stream in the MPEG-4 ISO base media
file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the DTS-HD audio stream
syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the DTS-HD
audio stream syntax.

Number of substreams

The Number of substreams indicates the total number of substreams embedded in the DTS-HD audio
stream.  Note that the Bit Rate property is the total bit rate of all substreams.

4.3.15 WAV Audio Data Properties

MPEGID identifies Waveform (WAV) audio format files.  WAV audio data is never found multiplexed in MPEG-1
System Stream, MPEG-2 Program Stream, MPEG-2 Transport Stream, or MPEG-4 ISO Base Media Files.

The following properties are displayed in the Property Pane for a WAV Audio Data file:

Bit Rate

The Bit Rate property is the number of bits per second (bps) of audio PCM samples. 

Sample Rate

The Sample Rate property is the number of audio samples per second (sps) for each channel .

Format

The Format property identifies the audio codec used to code the WAV audio file.

Number of Channels

The Number of Channels property is the number of audio channels present in file .
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Word Size

The Word Size property is the number of bits and bytes used to store each sample in the WAV file.

4.3.16 SMPTE 302M Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a SMPTE 302M Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the SMPTE 302M Audio
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.
 Generally, SMPTE 302M audio streams are assigned a stream_type value of 6.   The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the SMPTE 302M Audio Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.  The Descriptors property
is only displayed if the SMPTE 302M Audio Elementary Stream is a component of an MPEG-2 Transport
Stream.

stream_id (MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, SMPTE 302M audio streams are assigned a stream_id value of 189 (0xBD).   The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id property
is only displayed if the SMPTE 302M Audio Elementary Stream is a component of an MPEG-1 System
Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is computed from the sample rate, sample
size, and number of channels. 

Number of Channels

This property is the number of channels that are present in the stream as encoded in the audio syntax. 

channel_id

SMPTE 302M supports up to eight channels in one elementary stream.  The Channel ID is the channel
number of the first data channel in this stream.  This feature allows more than eight channels to be
carried using multiple elementary streams.
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Sample Size

SMPTE 302M supports 16-, 20-, and 24-bit word size.  This parameter gives the size of the samples in
this stream.

4.3.17 Manzanita XML Data Properties

The Manzanita Systems MPEG-2 Transport Stream Multiplexer supports insertion of many types of data
into transport streams, including Private Stream 1, Private Stream 2, System Information (SI), SCTE
Splice Information, DVB Subtitle Stream, and DVB Teletext Stream.  To control multiplexing of the data,
the input files must be in a specific XML format that has been defined by Manzanita Systems. 

MPEGID identifies the following types of files that use a Manzanita-specific XML format:

Manzanita Private Stream XML Data

Manzanita SI Table XML Data

Manzanita SCTE35 Splice Information XML Data

Manzanita SCTE35 Splice Information Text Data

Manzanita DVB Subtitle XML Data

Manzanita DVB Teletext XML Data

MPEGID only reports General File properties for the Manzanita XML Data file, and does not inspect the content.

4.3.18 Private Stream Properties

MPEG-2 program streams can contain privately defined data streams in addition to audio and video
elementary streams.  Like audio and video, these streams are segmented in PES packets, however, their
stream_id identifies them as Private Streams.   MPEGID reports the presence of Private Streams, however, it
does not inspect the content.

The following property is displayed in the Property Pane for a Private Stream:

stream_id 

The stream_id property is the stream_id value that appears in PES headers for the Private Stream.  
Private Streams are identified by the stream_id values of 0xBD (private_stream_1) and 0xBF
(private_stream_2).   The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal. 
The base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  

4.3.19 User Private Stream Properties

MPEG-2 program streams and MPEG-2 transport streams can contain privately defined data streams in
addition to audio and video elementary streams.  Each data stream is carried by a unique PID and is identified
in the transport stream's Program Map Table as a User Private Stream.   User Private Streams may or may not
be contained in PES packets.  MPEGID reports the presence of User Private Streams, however, it does not
inspect the content.

The following properties are displayed in the Property Pane for a User Private Stream:
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PID

The PID property is the value of the PID that is associated with the User Private stream.   The PID value
may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in decimal, or
if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set by the Edit >
Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the User Private Stream in the
Program Map Table.   User Private Streams are identified by the stream_type values of 0x80 through 0xFF
(inclusive).  The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors that are associated in the PMT with the data stream are shown.  The hexadecimal data
bytes for each descriptor that is present  are displayed on a separate line.

4.3.20 Private Stream 1 and Private Stream 2 Properties

Private Stream 1 and Private Stream 2 are data streams that are contained in PES packets.  They are
specifically identified by their stream_id in the PES packet header.  MPEGID reports the presence of Private
Stream 1 and Private Stream 2 in MPEG-2 transport streams, however, it does not inspect the content.

The following properties are displayed in the Property Pane for Private Stream 1 and Private Stream 2 data:

PID

The PID property is the value of the PID that is is associated with the Private Stream 1 or Private Stream 2
data stream.   The PID value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value
may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property
is displayed is set by the Edit > Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the Private Stream 1 or Private
Stream 2 data in the Program Map Table.   Private Stream 1 and Private Stream 2 are assigned a
stream_type value in the User Private range of 128 through 255 (0x80 through 0xFF), inclusive.  The value
may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors that are associated in the PMT with the data stream are shown.  The hexadecimal data
bytes for each descriptor that is present  are displayed on a separate line.

stream_id 

The stream_id is the value that identifies the stream in PES headers.   Generally, Private Stream 1 is
assigned a stream_id value of 0xBD, and Private Stream 2 is assigned a stream_id of 0xBF. The value
may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id
property is displayed is set by the Edit > Preferences menu function.

4.3.21 SCTE35 Splice Information Properties

The transport method for carrying information about upcoming splice points in MPEG-2 transport streams is
defined in the SCTE standard, "Digital Program Insertion Cueing Message for Cable" (ANSI/SCTE 35 2007).
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MPEGID reports that a data stream is SCTE35 Splice Information if it is identified in the program's PMT as an
SCTE35 Splice Infomation Table stream.  MPEGID does not, however, inspect the content of the stream.

The following properties are displayed in the Property Pane for SCTE35 Splice Information:

PID

The PID property is the value of the PID that is associated with the SCTE35 Splice Information stream.  
The PID value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified
in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is
set by the Edit > Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the SCTE35 Splice Information
stream in the Program Map Table.   SCTE35 Splice Information streams are assigned the value 0x86, or
"SCTE35 Splice Infomation Table".  The value may be specified in decimal, or if prefaced with a "0x", in
hexadecimal.  The base in which the stream_type property is displayed is set by the Edit > Preferences
menu function.  

Descriptors

Any descriptors that are associated in the PMT with the data stream are shown.  The hexadecimal data
bytes for each descriptor that is present  are displayed on a separate line.

4.3.22 DVB Subtitle Stream Properties

DVB subtitling systems are specified in ETSI EN 300 743 for carrying program related subtitles and other
graphical elements in MPEG-2 transport streams.  MPEGID reports that a data stream is a DVB Subtitle
Stream if it is associated in the program's PMT with a DVB Subtitle descriptor.  MPEGID does not, however,
inspect the content of the stream.

The following properties are displayed in the Property Pane for a DVB Subtitle Stream:

PID

The PID property is the value of the PID that is associated with the DVB Subtitle Stream.   The PID value
may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in decimal, or
if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set by the Edit >
Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the DVB Subtitle Stream in the
Program Map Table.   DVB Subtitle Streams are assigned the value 0x06, or "PES Private Packets".  The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.

stream_id 

The stream_id is the value that identifies the stream in PES headers.   Generally, DVB Subtitle Streams
are assigned a stream_id value of 0xBD, or "Private Stream 1". The value may be specified in decimal, or
if prefaced with a "0x", in hexadecimal.  The base in which the stream_id property is displayed is set by
the Edit > Preferences menu function.



MPEGID User's Manual, V4.042

Copyright ©  2006 - 2012 Manzanita Systems, Inc.

4.3.23 DVB Teletext Stream Properties

The transport method for conveying System B Teletext in DVB transport streams is specified in ETSI EN 300
472.  MPEGID reports that a data stream is a DVB Teletext Stream if it is associated in the program's PMT with
a DVB Teletext descriptor.  MPEGID does not, however, inspect the content of the stream.

The following properties are displayed in the Property Pane for a DVB Teletext Stream:

PID

The PID property is the value of the PID that is associated with the DVB Teletext Stream.   The PID value
may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be specified in decimal, or
if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set by the Edit >
Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the DVB Teletext Stream in the
Program Map Table.   DVB Teletext Streams are assigned the value 0x06, or "PES Private Packets".  The
value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors that are associated in the PMT with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.

stream_id 

The stream_id is the value that identifies the stream in PES headers.   Generally, DVB Teletext Streams
are assigned a stream_id value of 0xBD, or "Private Stream 1". The value may be specified in decimal, or
if prefaced with a "0x", in hexadecimal.  The base in which the stream_id property is displayed is set by
the Edit > Preferences menu function.

4.3.24 MPEG-1 System Stream Properties

In addition to General File Properties and individual elementary stream properties, the following property is
displayed if the input media file is an MPEG-1 System Stream:

Mux Rate

The Mux Rate property is the rate in bits per second (bps) that is specified by the initial mux_rate field in
the stream syntax.  

4.3.25 MPEG-2 Program Stream Properties

In addition to General File Properties and individual elementary stream properties, the following property is
displayed if the input media file is an MPEG-2 Program Stream:

 Video Object (VOB) files are identified as MPEG-2 Program Streams.

Program Mux Rate

The Program Mux Rate property is the rate in bits per second (bps) that is specified by the initial
program_mux_rate field in the stream syntax.  
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4.3.26 MPEG-2 Transport Stream Properties

In addition to General File Properties, MPEG-2 Program Properties, and individual elementary stream
properties, the following properties are displayed if the input media file is an MPEG-2 Transport Stream:

Transport Packet Size

The Transport Packet Size property is the number of bytes between successive transport packet sync
bytes. This interval is assumed to be constant over the length of the transport stream. 

Transport Rate

The Transport Rate property is the rate in bits per second (bps) that is computed from the PCRs in the
beginning of the transport stream.  Note that the Transport Rate value is only an estimate.  The actual
transport rate may change later in the stream.  

4.3.27 MPEG-2 Program Properties

An MPEG-2 Transport Stream generally contains one or more programs.  For each program in the input
transport stream, MPEGID displays a set of MPEG-2 Program properties. 

The following properties are displayed for each MPEG-2 Program in an MPEG-2 Transport Stream:

program_number

The program_number property is the value that is associated with this program in the transport stream's
Program Association Table (PAT).  It is the same as the Program Number that identifies the program in
the Multiplex Pane.  

PMT PID

The PMT PID property is the PID value of the stream that carries the Program Map Table (PMT) associated
with this program.  The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The
base in which the PMT PID property is displayed is set by the Edit > Preferences menu function. 

PCR PID

The PCR PID property is the PID value of the stream that carries the Program Clock Reference (PCR) for
this program.  The value may be specified in decimal, or if prefaced with a "0x", in hexadecimal.  The base
in which the PCR PID property is displayed is set by the Edit > Preferences menu function. 

Program Descriptors

Any descriptors that are defined in the PMT for this program are shown.  The hexadecimal data bytes for
each descriptor that is present  are displayed on a separate line.

Number of PMT Entries

The Number of PMT Entries is the number of elementary stream and data PIDs that are designated to be
part of this program in the PMT.

4.3.28 MPEG-4 ISO Base Media File Properties

In addition to General File Properties, the properties of each individual elementary stream contained in the
media file will be displayed in the Property Pane for an MPEG-4 ISO Base Media File.  
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4.4 Saving a Report File

After you have identified a media file, you can save the results in a report file for future reference.  The report file
is a simple text file that contains all of the information displayed in the Property Pane.

 If you just want part of the Property Pane results in a document, you can select the area that you want, copy
it to the clipboard, and paste it in the document.  

To save a report file:

1. Choose File > Save Report As... from the Menu Bar.  The Save As dialog box will appear.

2. Browse your system to select the desired location to save the report file, enter the report name in the File
Name box, then click Save.
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4.5 Demultiplexing an Elementary Stream

The MPEGID program includes a utility that will extract a single elementary stream from an input MPEG-1
System Stream, MPEG-2 Program Stream, MPEG-2 Transport Stream, or MPEG-4 ISO Base Media File and
save it as a binary file.  Multiple elementary streams may be extracted from a given input stream file by
repeatedly running the Demultiplexer.

 The demultiplexer function is not available with the demo version of MPEGID.

To demultiplex an elementary stream:

1. Open and identify  the input file.  The file must be an MPEG-1 system stream, MPEG-2 program
stream, VOB, MPEG-2 transport stream, or MPEG-4 ISO base media file.

2. Select the node in the Multiplex Pane that represents the elementary stream you wish to demultiplex.

3. Choose Edit > Demux... from the Menu Bar, or click the right mouse button on the node and then click on
the Demux... function in the submenu.  The Demultiplex As dialog box will appear.

If the selected stream is an AAC Elementary Stream in an MPEG-4 ISO Base Media File, then a dialog box
will open that allows you to select between saving the output file in LOAS/LATM format or ADTS format.

If the selected stream is a common encrypted MPEG-4 ISO Base Media File, then a dialog box will open
that displays a Key Identifier (KID) value, and prompts you for the AES encryption key.  The key should be
entered in hexadecimal.

4. Browse your system to select the desired location to save the demultiplexed stream, enter the output file
name in the File Name box, then click Save.  

Depending upon the size of the input file, it may take several minutes for the stream to be demultiplexed.  A
dialog box will display the progress of the demultiplex operation.  When demultiplexing is complete, a dialog
box will display the final size of the output file.  

 If your input file is on a remote location on a network, the demultiplexing progress may not be displayed, or
it may not be accurately updated because of network latency.  

22
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4.6 Identifying from the Command Line

The MPEGID installation includes a command line version that enables execution of MPEGID in a command
prompt or shell window.  The output of the command line version is identical to the results that are displayed in
the Property Pane of the GUI version.  The command line MPEGID can be run in batch files or scripts for high-
volume or automated applications.  Its output can be directed to a file for a saved text report.

You may also demultiplex an elementary stream from an input MPEG-1 system stream, MPEG-2 program
stream, MPEG-2 transport stream, or MPEG-4 ISO base media file using the command line MPEGID.

 The command line executable is not available with the demo version of MPEGID.

To run the command line version of MPEGID:

1. (Windows only) Open an "MS-DOS" Command Prompt window.

2. At the command prompt or in a script, enter the line:

mpegid [-b buffer_size] input_file

input_file The name of the input media file.  The name may be specified by full path, relative
path, or by filename only.  If only the filename is given, then MPEGID will look for the
input file in the current directory.

-b 
buffer_size

Optional.  The amount of data that MPEGID should inspect, where buffer_size is

a number of kilobytes.

 If you get a message that the name that you entered is not recognized as a command, then the MPEGID
command line executable is not in a location that is recognized by the PATH environment variable.  On a UNIX
system (Linux or Mac OS X) you should either create a symbolic link from the MPEGID program to a directory
that is in your PATH variable or include the location of the MPEGID program in the PATH variable.  On a
Windows system, you need to add the path of the MPEGID installation folder to the PATH variable.

To demultiplex an elementary stream from the command line:

1. (Windows only) Open an "MS-DOS" Command Prompt window.

2. At the command prompt or in a script, enter the line:

mpegid -d id [-l] [-v subtype] input_file [output_file] [-k key_file]

-d Runs the demultiplexer.

id If input_file is a system stream or program stream, then id is the value of the

stream_id that identifies the elementary stream that will be demultiplexed.  If the file
is a transport stream, then id is the value of the PID that identifies the elementary

stream.   If the file is an MPEG-4 ISO base media file, then id is the value of the

track_ID that identifies the elementary stream. 

input_file The name of the input multiplex file.  The file must be an MPEG-1 system stream,
MPEG-2 program stream, MPEG-2 transport stream, or MPEG-4 ISO base media
file.  The name may be specified by full path, relative path, or by filename only.  If only
the filename is given, then MPEGID will look for the input file in the current directory.
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-l Optional, only applicable if the selected elementary stream is AAC audio and 
input_file is an MPEG-4 ISO base media file. When present, the option

indicates that the output file should be saved  in LOAS/LATM format.  By default
when the option is not present, the demultiplexed AAC audio will be saved in ADTS
format.

-k key_file Only applicable if input_file is a common encrypted MPEG-4 ISO base media

file.  When present, key_file specifies the name of the file containing the

decryption key (first 16 bytes contain the binary key).  The name may be
specified by full path, relative path, or by filename only.  If only the filename is given,
then MPEGID will look for the input file in the current directory.
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5 Additional Support

This chapter includes more information about using the MPEG Stream Identifier and where to go if you have
additional questions.  It has the following sections: 

Frequently Asked Questions (FAQ)  is a list of questions and answers that includes tips for using
MPEGID.

References  is a reference list of MPEG standards documents.

Technical Support  tells you how to contact Manzanita Systems for technical support assistance.

5.1 Frequently Asked Questions (FAQ)

Before reporting any problems, please check this list to see if there is a known solution: 

Why does MPEGID identify Video Objects (VOBs) as MPEG-2 Program Streams?

VOB files used in DVD-Video are just MPEG-2 Program Streams with additional data streams that contain
navigation and search information.  MPEGID displays the VOB sub-type that uniquely identifies each AC-3
(Dolby Digital) audio stream in the program stream.

MPEGID can't identify a stream that I believe is an MPEG stream.  Why not?

The stream may be corrupted or may not be using a valid format.  However, if you think MPEGID is
incorrect in its identification, contact our technical support (email support@manzanitasystems.com).  We
would be interested in analyzing your stream to see why it cannot be identified.  

MPEGID reports a Duration for my stream that seems wrong.  When I play the stream, the duration is
longer than the one given by MPEGID.  Why?

Your stream may be variable bit rate or there may be a rate change somewhere in the stream.  For all
input streams except transport streams, MPEGID gets the bit rate from the stream syntax, which for
variable rate streams is usually the maximum bit rate.  For transport streams, MPEGID determines the bit
rate from the initial PCRs in the stream.  Because the Duration is calculated from the input file size and
the bit rate, it may be different than the actual duration.

I have transport stream files that I know contain System Information data streams.  These streams don't
appear in the Multiplex View.  Why not?

For transport streams, MPEGID only identifies elementary streams that are listed in a Program Map Table.
 System Information PIDs that are not defined in a PMT will not be shown.

I've installed MPEGID on my Linux system and I tried running the command line version.  I get a
"command not found" message.  What's wrong?

If you get a message that the name that you entered is not recognized as a command, then the MPEGID
executable is not in a location that is recognized by the PATH environment variable.  You should either
create a symbolic link from the MPEGID program to a directory which is in your PATH variable, or include
the location of the MPEGID program in the PATH variable.

I find MPEGID to be very useful, but I frequently use files that are in a standard format that is not supported
by MPEGID.  Can you add this format?  It would be helpful to me.

We are very interested in getting input from our customers.  We would definitely like to add new formats to
future releases of MPEGID.  Please send your request to support@manzanitasystems.com.  Any
information, e.g., specifications and references, about your format is helpful.  

49

51

52

mailto:support@manzanitasystems.com
mailto:support@manzanitasystems.com


MPEGID User's Manual, V4.050

Copyright ©  2006 - 2012 Manzanita Systems, Inc.

MPEGID identifies the output of my encoder as a transport stream.  When I try to play it on a decoder, it
doesn't play correctly.  What is wrong?

MPEGID does not verify input streams for compliance.  Manzanita Systems offers a compliance and
verification program, the MPEG-2 Transport Stream Analyzer (MP2TSAE).  MP2TSAE will perform a full
analysis on your transport streams.  Please visit our website, www.manzanitasystems.com, for more
information about MP2TSAE. 

The output in the Multiplex Pane indicates "No data seen for this elementary stream" but I know that that
elementary stream exists.  Also, in the Property Pane, there is a description of the stream.  Why is that?

This is because MPEGID only looks at a limited portion of the beginning of the file.  If the elementary
stream data does not occur in that portion of the stream, i.e., its first occurrence is later in the stream than
what was analyzed, then MPEGID will indicate that it did not see the data for this stream.  However,
because the stream was listed in the PMT, it will be acknowledged in the Property Pane as being defined
in the multiplex. 

When I demux a Private Stream such as subtitles or teletext, why does MPEGID say that XXX bytes were
written, but the actual file size is larger?

This is because the XXX number is the size of the actual data, but the file also includes XML code that will
enable the file to be inputted to the Manzanita Multiplexer for multiplexing as Private Stream 1 into a
transport stream. 

I ran MPEGID on an MP4 media file with one MPEG-2 video stream on track 1.  The report did not show the
aspect ratio of the video.  Why not?

The aspect ratio information in an MPEG-4 ISO Base Media file will only be reported if it is present in a
'moov' box, otherwise MPEGID does not display this parameter. 

http://www.manzanitasystems.com/mp2tsa.html
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5.2 References

The following list of documents is the primary references used by MPEGID:

1. ISO/IEC 11172-1:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 1 : Systems.

2. ISO/IEC 11172-2:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 2 : Video.

3. ISO/IEC 11172-3:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 3 : Audio.

4. ISO/IEC 13818-1:2007: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 1: Systems.

5. ISO/IEC 13818-2:2000: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 2: Video.

6. ISO/IEC 13818-3:1998: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 3: Audio.

7. ISO/IEC 13818-7:2006: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 7: Advanced Audio Coding (AAC).

8. ISO/IEC 14496-10 Information Technology - Coding of audio-visual objects - Part 10: Advanced Video
Coding.

9. ISO/IEC 14496-12:2004: Information technology -- Coding of audio-visual objects - Part 12: ISO base
media file format.

10. ISO/IEC 14496-14:2003: Information technology -- Coding of audio-visual objects - Part 14: MP4 file format.

11. ISO/IEC 14496-15:2004: Information technology -- Coding of audio-visual objects - Part 15: Advanced
Video Coding (AVC) file format.

12. Advanced Television Systems Committee: ATSC Digital Television Standard, Document A/53 Revision E,
with Amendments No. 1 and 2.

13. Advanced Television Systems Committee: Guide to the Use of the ATSC Digital Television Standard,
Document A/54. 

14. Advanced Television Systems Committee: Digital Audio Compression (AC-3, E-CA-3) Standard,
Document A/52 Revision B. 

15. Advanced Television Systems Committee: Program and System Information Protocol for Terrestrial
Broadcast and Cable, Document A/65 Revision C with Amendment No. 1.

16. ETSI EN 300 472 V1.31 (2003-05) Digital Video Broadcasting (DVB); Specification for conveying ITU-R
System B Teletext in DVB bitstreams.

17. ETSI EN 300 743 V1.31 (2006-11) Digital Video Broadcasting (DVB); Subtitling systems.

18. SCTE 35 2007: Digital Program Insertion Cueing Message for Cable.
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5.3 Technical Support

Manzanita Systems provides this online User's Manual with your copy of MPEGID as the first level of support.  If
you do not find an answer to your question in the User's Manual, contact Manzanita Systems technical support
by phone, fax, or email.  Manzanita Systems technical support is available as follows:

Phone

1-858-679-8990
Monday through Friday
9:00 AM - 5:00 PM PST

Fax

1-858-679-8991

Email

support@manzanitasystems.com

Web Site 

www.manzanitasytems.com

mailto:support@manzanitasystems.com
http://www.manzanitasystems.com/index.html
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6 Purchasing and License Agreement

This chapter tells you how to register your copy of MPEGID and acquire a license key to unlock the full version. 
It contains the following sections:

Registration Benefits  gives the benefits to which you are entitled as a registered user of MPEGID.

Purchasing a Registered Copy  gives the pricing and ordering instructions for MPEGID.

Unregistered User License Agreement  is the legal agreement to which you are bound when you
install and run the demo version of the MPEGID program.

Registered User License Agreement  is the legal agreement to which you are bound when you install
and run the full, registered version of the MPEGID program.

6.1 Registration Benefits

As a registered user, you will receive the following benefits:

An activation key to unlock the full version of MPEGID.  The full version entitles you to run your copy of
MPEGID for an unlimited time.

An integrated demultiplexer to extract video, audio, and data streams from input system stream, program
stream, transport stream, and MPEG-4 ISO base media files.

Access to a command line version of MPEGID.

A software license that entitles you to update your copy of MPEGID with future patches and releases*.

Free technical support by email or phone for at least 90 days starting from your registration date.

* Manzanita Systems reserves the right to introduce an upgrade charge for major new releases.

6.2 Purchasing a Registered Copy

When you register your copy of MPEGID with Manzanita Systems, you will be given a license key that will enable
you to unlock the full version.  The MPEGID license agreement  entitles no more than one user to use a
single registered copy at a time.  

Pricing

The registration fee for MPEGID is $49.95 USD per single user license.

Purchasing by Credit Card

You must contact Manzanita Systems to register and pay your MPEGID registration fee.  You can use your
MasterCard, VISA, or American Express card.  

Your order can be placed 24 hours a day, 7 days a week by fax at 1-858-679-8991 or by email to 
mpegid@manzanitasystems.com.

You can also call 1-858-679-8990 between the hours of 8:00 AM and 5:00 PM (Pacific Time), Monday
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through Friday (except US holidays).

Please provide your name, credit card number, expiration date, billing address, telephone number, and
email address when you order. 

Your license key will be emailed to you within one (1) business day.  Therefore, it is important that you
provide your valid email address.  

Submitting a Purchase Order

We can accept purchase orders from government and accredited educational institutions and major
corporations.  Please address questions to sales@manzanitasystems.com, or call us at 1-858-679-
8990.

mailto:sales@manzanitasystems.com
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6.3 Unregistered User License Agreement

This is the legal agreement to which you are bound when you install and run the demo version of the MPEGID
program.  The demo version of MPEGID is provided at no charge to you for your evaluation.  

As an unregistered user of MPEGID you agree to the following:

1. You are free to share copies of MPEGID with others, however, you may not alter the software in any way.

2. You may not sell copies of MPEGID or otherwise distribute it for profit.

3. You may not reverse engineer, decompile, or disassemble the MPEGID program.

4. By installing and using MPEGID, you acknowledge that you have read this license, understand it, and
agree to be bound by all of its terms.

Copyright  MPEGID is owned by Manzanita Systems, Inc. and is protected by United States copyright laws and
international treaty provisions.  Therefore you must treat the MPEGID software like any other copyrighted
material.  You may not print copies of any user documentation provided in "online" or electronic form.

Limited Warranty and Remedies  The MPEGID program is provided "as is" without warranty of any kind, either
express or implied, including, but not limited to warranties of merchantability or fitness for a particular purpose.
 In no event shall Manzanita Systems, Inc. be liable for any damages whatsoever (including, without limitation,
damages for loss of business profits, business interruption, loss of business information, or other pecuniary
loss) arising out of the use or inability to use MPEGID, even if Manzanita Systems, Inc. has been advised of the
possibility of such damage.
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6.4 Registered User License Agreement

This is a legal agreement between you (either an individual or an entity) and Manzanita Systems, Inc.  By
installing the MPEG Stream Identifier (MPEGID) software package and by using the full, registered MPEGID
program, you agree to be bound by the terms of this Agreement.  

Grant of License  This License Agreement ("License") permits you to use one copy of the MPEGID software,
which may include user documentation provided in "online" or electronic form.  The MPEGID software is
licensed as a single product.  Its component parts may not be separated for use on more than one computer
or by more than one user at any time.  The software is "in use" on a computer when it is loaded into the
temporary memory (i.e. RAM) or installed into the permanent memory (e.g. hard disk) of that computer.

Copyright  The MPEGID software is owned by Manzanita Systems, Inc. and is protected by United States
copyright laws and international treaty provisions.  Therefore you must treat the MPEGID software like any other
copyrighted material.  You may not print or distribute copies of any user documentation provided in "online" or
electronic form.

Other Restrictions  This License is your proof of license to exercise the rights granted herein and must be
retained by you.  You may not rent or lease the MPEGID software, but you may transfer your rights under this
License on a permanent basis, provided you transfer this License, the MPEGID software and all accompanying
printed materials, retain no copies, and the recipient agrees to the terms of this License.  You may not reverse
engineer, decompile, or disassemble the MPEGID program.

Limited Warranty  Manzanita Systems, Inc. warrants that the MPEGID program will perform substantially in
accordance with the accompanying printed material and on-line documentation for a period of 90 days from the
date of purchase.  Manzanita Systems, Inc. additionally warrants that the MPEGID program is believed to be
free from defect of workmanship and material or viruses.  Manzanita Systems, Inc. will provide technical
support to investigate and resolve any problems reported by you within the warranty period.

Customer Remedies  Manzanita Systems' entire liability and your exclusive remedy shall be, at Manzanita
Systems' option, either (a) return of the price paid or (b) repair or replacement of the MPEGID software that
does not meet this Limited Warranty and that is returned to Manzanita Systems with a copy of your receipt.  This
Limited Warranty is void if failure of the MPEGID software has resulted from accident, abuse, or misapplication.
 Any replacement MPEGID software will be warranted for the remainder of the original warranty period or 90
days from the date of purchase, whichever is longer.

No Other Warranties To the maximum extent permitted by applicable law, Manzanita Systems, Inc. disclaims
all other warranties, either express or implied, including but not limited to implied warranties of merchantability
and fitness for a particular purpose, with respect to the MPEGID software and any accompanying
documentation.

No Liability for Consequential Damages  To the maximum extent permitted by applicable law, in no event shall
Manzanita Systems, Inc. be liable for any damages whatsoever (including, without limitation, damages for loss
of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of
the use or inability to use the MPEGID software, even if Manzanita Systems, Inc. has been advised of the
possibility of such damage.
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