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What  i s  J ux ta ?  

Juxta is an open-source cross-platform tool for comparing and collating 

multiple witnesses to a single textual work. The software allows you to 

set any of the witnesses as the base text, to add or remove witness texts, 

to switch the base text at will, and to annotate Juxta-revealed 

comparisons and save the results. 

 

Juxta presents several kinds of analytic visualizations. The most basic 

collation offers a split frame comparison of a base text with a witness 

text, along with a display of the digital images from which the base text 

is derived. Additionally, Juxta has several visualizations for the collation 

of multiple witnesses. Juxta can display a heat map of the textual variants 

that allows you to locate—at the level of any textual unit—all witness 

variations from the base text. You can also view the collation as a 

histogram, which displays the density of all variation from the base text 

and serves as a useful finding aid for variants in long documents. Finally, 

Juxta can output a lemmatized schedule (in HTML format) of the textual 

variants in any set of comparisons. 

 

I n s t a l l i ng  Jux ta  

Juxta is a Java-based application that can run on any modern personal 

computer. We have packaged it for Windows, Mac OSX, and UNIX 

operating systems. To obtain the Juxta installer, go to 

http://www.juxtasoftware.org/download.html and click on the link for 
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your operating system. Save the installer to your computer and then 

double-click its icon to run it. Simply follow the prompts from there and 

Juxta will be ready for use. 

 

Sys t em Requ i remen t s  

Juxta requires Java 1.5 to run and has been tested on Windows XP and 

later, as well as Mac OS X 10.6.8. The Windows installer will optionally 

install Java for you if it isn’t present and the Macintosh includes Java by 

default. 

 

Get t ing  S t a r t ed  

The Juxta installation includes several sample collations, which can be 

accessed from the File menu. Select “File”, then “Open Sample”  

(File → Open Sample) and then select a JXT file for the sample you wish 

to view. The three sample collations are:  

 

Damozel—a collation of seven versions of the poem “The Blessed 

Damozel” by Dante Gabriel Rossetti. Demonstrates the use of Juxta XML 

files to associate images and milestones with text. 

 

Renaissance—a collation of two versions of Walter Pater’s Studies in the 

History of the Renaissance. Demonstrates the collation of prose texts. 

 

Whitman's Leaves of Grass—a collation of three versions of Walt 

Whitman’s “Leaves of Grass”. The source TEI XML was contributed by 

the Walt Whitman Archive. 
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The Display Window, General. Opening a collation displays a list of 

witness documents on the left (in the Comparison Explorer panel) and on 

the right a transcription of one of the witness texts as the “base text” (at 

the beginning, it chooses the first of the listed witnesses). At the top is a 

menu with a set of standard editing functions for adding and removing 

witnesses, and for several other operations. Below this menu is a toolbar 

with a set of icons. Running the mouse over them displays the functions 

they perform. There is also an input box for entering words to search for 

in all the texts in the comparison set. See the section on searching 

below. 

 

The upper panel at the right (Document Panel) displays a transcription of 

the base text in Collation View by default. The two buttons at the bottom 

of the Document Panel toggle between Collation View and Comparison 

View, which displays a side-by-side comparison of texts. The texts for 

comparison are chosen from two drop-down lists above the Document 

Panel. The text on the left will be treated as the base text. The lock icon 

between the drop-down lists (“on” by default) can be clicked to unlock 

the text transcriptions so they can be independently scrolled. 

 

The lower right panel is an area for displaying additional information 

about the witness texts and collation. Just below this lower right panel 

are five buttons that allow you to control which information is displayed 

in the panel. When Juxta starts, “Source” is the default selection, 

displaying the source XML or plain text of the transcription currently 

chosen in the Document Panel. “Images” displays any digital images 

included in the Juxta XML file (this feature is not available for plain text 

or TEI files). By default, images are locked to their transcriptions in the 

Document Panel above, so that scrolling through the transcriptions will 
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call up page images in succession. Images may be unlocked from their 

transcriptions by clicking the lock button below the panel. Next to the 

lock button are two buttons for zooming the image view in and out. 

Next, “Notes” displays your annotations. The lock button at the lower 

right unlocks the notes display from the transcriptions. The trashcan 

button deletes the selected note. “Moves” displays all the moves you 

specify. Clicking on a move scrolls the documents to display the moved 

text. The trashcan button discards the selected move. (Please see the 

section below on collating passages that appear out of order.) “Search” 

displays the results of the last search operation. Clicking on a search item 

scrolls the texts in the Document Panel to show the item in context. 

 

Collating and Annotating Operations, General. Clicking a witness text in 

the Comparison Explorer on the left will make it the base text. The box to 

the left of each witness text can be unchecked to remove it from the 

collation. The boxes to the right of each witness text visualize (in shades 

of blue) the global degree of difference between the base text and this 

witness, with degree of difference signaled by increase in the gradient 

color difference. 

 

When the Document Panel is in Collation View, a “heat map” is 

superimposed (in blue) on the base text. Blue highlighting signals 

degrees of variance between the base text and the witnesses being 

compared. Clicking on any highlighted area in the heat map displays a 

list of variants in a box in the right margin. You can also click and drag 

the mouse to highlight a region and display all of the variants for the 

highlighted section. Clicking on the star in the pop-up box allows you to 

enter annotations for that difference. 
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You can create a new comparison set (File → New Comparison Set) and 

then add your own documents (Edit → Add Document). Documents 

must be in either a specific XML format – described later in this 

document – or a plain text format. Loading a document automatically 

collates it using the current collation settings. 

 

When you are ready to publish your collation and annotations from 

Juxta, you can output a critical apparatus as an HTML document (File → 

Generate Critical Apparatus). You can also save your comparison set 

(File → Save or File → Save As) for later work or for sharing with others 

who use Juxta. These outputs preserve all annotations added in Juxta. 

 

Collating passages that appear out of order. In the side-by-side difference 

view, indicate the moved passage by dragging the mouse over the 

passage in both the base and the witness texts. The move button (on the 

upper right, next to the selection of the witness text) will be enabled 

when passages on both sides have been selected. Click the move button 

and the move will be created. You will see an outline of the passages 

and a line connecting them. There is also an entry in the Moves panel for 

each move created. Clicking the entry brings the move into view. 

 

Searching in all text. Juxta’s Search feature allows you to find a word or 

phrase in all the texts in the current collation set. Type the search terms 

you want in the input box that appears on the tool bar and press the 

enter key (or click the button to the right of the input box). The results 

are displayed in the Search panel, and all the matching terms are 

highlighted in the texts. Clicking on a search result in the Search panel 

causes it to scroll into view. The search works for whole words only, so 

if you search for “work”, for example, the term “working” will not be 
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found. If you search for more than one word, then it finds them in any 

order, as long as they appear close to each other in the text. For instance, 

searching for “question be” in Hamlet will return (among other results) 

“be, that is the question.” 
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J ux t a  Use r  In t e r f ace  

The major functional areas of the Main Window are shown below. These 

panels can be resized by clicking and dragging the divider bars.  

 

 

 

 

 

Toolbar 

 

 

The toolbar is a place to find the most commonly used functions in Juxta. 

From left to right, these functions are: 

 

Open Comparison Set – Loads a comparison set from a previously saved 

.jxt file. 
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Save Comparison Set – Saves the current comparison set to a .jxt file. 

 

Add Document – Imports a new document into the comparison set (see 

Add Document Dialog). 

 

Remove Document – Removes the currently selected document from the 

comparison set. 

 

Edit Base Document Properties – Opens a dialog for editing the 

document properties of the currently selected document (see Document 

Properties Dialog). 

 

View Histogram – Opens the Collation Histogram (see Collation 

Histogram Dialog). 

 

Generate Critical Apparatus – Generates a critical apparatus for the 

currently selected document (see Generate Critical Apparatus Dialog). 

 

Toggle Location Markers – Toggles the location marker display on or off 

in the Document Panel. For plain text files, Juxta displays line numbers. 

Juxta XML files may be marked up with custom location markers (for 

example, numbering by page, paragraph, or stanza). 

 

Collate Documents – Opens a dialog allowing you to change the 

collation filters. By default, Juxta ignores whitespace, punctuation, and 

case; you may change these filters for the open Comparison Set and re-

collate the witnesses. When a new document is added to the 

Comparison Set, it is automatically collated using your chosen filters. 
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Search Text In Files – Type in the input box and click the button to 

search for a term or terms in all documents in the comparison set. Note 

that you can see a list of recently searched-for terms by clicking the 

triangle just to the right of the input box. See “Searching in all text” 

above. 

 

 

 

Comparison Explorer 

 

The Comparison Explorer displays 

all documents in the current 

comparison set. These documents 

are automatically collated against 

one another.  

 

 

Documents can be added or removed from the list by using the Add 

Document and Remove Document buttons on the toolbar. You can 

modify the display name of a document by editing its “short name” field 

in the Document Properties Dialog. 

 

Documents can be sorted by date or alphabetically. The date used for 

sorting the witnesses is called the “Sort Date” and is set in the Document 

Properties Dialog. 

 

The document highlighted in green is the current base document, from 

which comparisons are made. Each of the documents has a meter to the 

right indicating its degree of difference from the base document. Placing 
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the mouse pointer over a given document reveals this value expressed as 

a number.  

 

To the left of the document name is a checkbox. Deselecting this 

checkbox temporarily excludes the document from the collation results. 

This exclusion is applied throughout the rest of Juxta's computations and 

outputs. For example, excluded documents do not appear in the critical 

apparatus output. 

 

 

 

Document Panel 

The Document Panel can 

display the results of collating 

multiple documents or it can 

display a side-by-side 

comparison of two documents. 

To facilitate this, the Document 

Panel has two modes: Collation 

View and Comparison View. These modes can be toggled with the 

buttons at the bottom of the panel.  

 

Line numbering and other location markers can be summoned by 

clicking on the “Toggle Location Marks” button on the toolbar.  

 

Collation View – When the Collation View is selected, Juxta displays a 

collation of all selected witnesses against the current base document. 

The current base document is the document highlighted in green in the 

Comparison Explorer to the left of the Document Panel. 
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The text is color coded to indicate the degree of variance evident at any 

particular area of the text. Lighter shades of blue indicate that fewer 

witnesses vary from the base text at this location. The darker the shade of 

blue, the more witnesses differ at this location.  

 

Clicking on the text itself reveals all variants for a particular location. The 

variants appear in the right-hand margin of the text as shown below: 

 

 

 

You can add critical annotations by clicking the grayed-out star that 

appears within the green witness label. This will activate an “Edit Note” 

dialog box. After you add text and click “OK” to save it, the note will 

appear in the Secondary Panel (when the “Notes” display is selected) 

and the star in the witness label will appear in bold ( ). Clicking the 

star or double-clicking the note in the Secondary Panel will open the 

“Edit Note” dialog again. 

 

There are three types of differences reported by Juxta. They are marked 

with the following glyphs in the witness labels: 

 

— Indicates a difference between base and witness text at this 

location. 
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— Indicates that there is text present at this location in the witness 

text where there is no such text present in the base text. 

— Indicates that there is text present in the base text that is not 

present at this location in the witness text. 

 

Comparison View – The Comparison View allows side-by-side 

inspection of two texts. While the Collation View shows the status of the 

base text relative to all other texts in the collation, the Comparison View 

focuses on just two texts at a time. As you scroll through the comparison, 

the two texts are kept in step with one another. Line numbering and 

other markings can be summoned in this view by clicking the “Toggle 

Location Marks” button on the toolbar.  

 

 

 
Secondary Panel 

The Secondary Panel houses 

supporting information relevant to 

the document or documents 

currently being displayed in the 

Document Panel. The Secondary 

Panel has five modes: Source, 

Images, Notes, Moves, and Search. These modes can be selected by 

clicking the buttons at the bottom of the panel. 

 

Source – The Source mode displays the source XML or plain text of the 

transcription currently chosen in the Document Panel. When you are in 

Source mode, an Edit button appears to the lower right of the Secondary 

Panel. Clicking the Edit button allows you to alter the chosen text and 



 
 

Juxta Manual: 13 

save your altered version as a new witness. (The new witness will not 

include any choices of additions or deletions you may have made using 

the Edit Revisions feature in the Document Panel.) 

 

Images – If an image is associated with the current base text, it will 

display in the Images mode. The image can be panned by clicking and 

dragging, and zoomed using the buttons to the lower right of the 

Secondary Panel. Images are associated with location markers or 

milestones in the process of importing a document in XML format 

(described below). 

 

Notes – The Notes mode shows a table of your annotations to this 

comparison set. For each annotation, the following columns of 

information are displayed: 

 

Base Text – The base text for the difference this note marks. 

Witness Text – The witness text for the difference this note marks. 

Lemma – The text heading that heads the list of variants. 

Notes – The text of the annotation itself.  

 

The lock button at the lower right controls the tracking of the document 

display. When the lock is closed, clicking on an annotation in the 

Secondary Panel will make the text in the Document Panel jump to the 

relevant location. When the lock is open, clicking on an annotation in 

the Secondary Panel does not change the position of the text in the 

Document panel. The trashcan button in the lower right deletes the 

selected note or notes. Double-clicking on a note in the Secondary Panel 

opens the Edit Note dialog. 
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Moves – When you mark moved passages in the witness texts, a list of 

moves becomes available in the Moves mode of the Secondary Panel 

(see “Collating passages that appear out of order,” above.) Clicking on a 

move in the list makes the Document Panel display the witness texts in 

Comparison View with the moved passage brought into view on the left 

and highlighted in dark yellow on both sides. If the corresponding 

passage is not visible in the document on the right, scrolling the 

Document Panel up or down should bring it into view. 

 

Search – The Search mode displays the results of your last search 

operation. Clicking on a search item scrolls the texts in the Document 

Panel to show the item in context, highlighted in dark yellow. By default, 

all of the search hits in the document are highlighted in medium yellow. 

A button to the lower right of the Search panel toggles this highlighting 

on and off. 

 

 

 

Add Document Dialog 

The Add Document Dialog allows 

you to add a document to the 

comparison set. It can be summoned 

by clicking the Add Document 

button on the Main Window toolbar 

or by choosing “Add Document …” 

from the Edit menu. Juxta can import 

documents either as plain text or as XML files. If plain text is selected, 

then the text is assumed by default to be UTF-8 encoded. Alternate text 

encodings can be selected from the encoding drop-down list at the 
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bottom of the dialog. If a Juxta XML document is selected, then the 

encoding is determined by reading specifications in the XML file. The 

bibliographic data for TEI and Juxta XML files can be previewed to the 

left of the file chooser. Selecting a document adds it to the collation and 

re-collates the comparison set to take into account this new addition. 

 

 

Document Properties Dialog 

The Document Properties Dialog can be 

summoned by clicking the Edit Base 

Document Properties button on the toolbar 

or by choosing “Edit Document Properties” 

from the Edit menu. This dialog allows you 

to view and update the bibliographic 

information for the currently selected 

document. The short title identifies this document in the Comparison 

Explorer and serves as the witness sigla for this document in an exported 

critical apparatus. In fact, the entirety of the bibliographic information is 

output as part of the critical apparatus. 

 

 

Edit Note Dialog 

The Edit Note Dialog can be 

summoned by clicking on the 

annotation star in the witness label 

after clicking on a blue-shaded 

variant in Collation View (see 

Collation View above) or by 

double-clicking on an existing 
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note in the Secondary Panel. This dialog allows you to view and update 

the currently selected note. When working with Juxta XML files, you 

have the option of checking the “Include Image” box, which adds a link 

to the base text’s image for this note in the critical apparatus. The image 

is obtained from the XML location marker that denotes the location of 

this difference. 

 

 

 
Select Font Dialog 

The Select Font Dialog can be 

summoned by selecting “Change 

text font …” from the View menu or 

by pressing Ctrl-T (or Apple-T on a 

Mac). This dialog allows you to 

control the display font for the text 

in the Document Panel. 

 
 

Collation Histogram Dialog 

The Collation Histogram dialog can 

be summoned by clicking the View 

Histogram button on the toolbar or 

by choosing “Histogram Graph” 

from the View menu. This dialog 

displays a graph of the frequency of 

difference over the length of the currently selected document. The short 

name of the currently selected document is displayed below the graph. 

Clicking on an area of interest in the graph jumps the text in the 
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Document Panel to the relevant location and creates a green highlighted 

bar in the graph; the highlighted bar can be dragged from side to side on 

the graph to scroll the text through the Document Panel.  

 

Below the graph is the Filter Strength Slider. This slider allows you to 

temporarily filter out minor differences in spelling and punctuation in 

order to reveal more substantive differences. This feature is especially 

useful in large documents with many minor changes. 

 

 

Collation Dialog 

When documents are added to the 

comparison set, Juxta 

automatically collates them 

against all of the other documents 

in the set. The Collation Dialog is 

useful when you wish to re-collate the comparison set with new filter 

settings. The following filters are available: ignore white space; ignore 

punctuation; and ignore case. This dialog can be summoned by clicking 

the Collate Documents button in the toolbar or by choosing “Collate …” 

from the Collation menu. 

 

 

XML Parsing Templates 

For each witness in a Comparison Set, you can fine tune how Juxta 

parses the XML representation of the witness to prepare it for collation. 

These choices are represented in what we call a “parsing template.” 

Parsing templates can be reused for an entire set of files, streamlining the 
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process of intaking new witnesses into a Comparison Set. Parsing 

templates can also be archived and reused in future Comparison Sets. 

 

Parsing templates allow you to configure a number of different things 

about how Juxta represents a given witness. You can choose to 

“EXCLUDE” (ignore) a particular element type, “INCLUDE” (opposite of 

“EXCLUDE”), or “MAKE NOTABLE.” “MAKE NOTABLE” notes the type 

of tag that contains the text and marks the text as changed when the 

element type changes. This could be used to note changes from “b” to 

“i” tags, for example. You can also specify whether or not a newline (aka 

a line break) should be added after the element. For example, if parsing 

an XHTML document, one might wish to make “br” and “p” tags have 

line breaks after them. You can also specify a “Target XPath”. This is an 

XPath to the XML element which encompasses the text that is to be 

collated. 

 

Importing an XML File 

When you add a file to a comparison set that is in XML format, Juxta will 

either match it with an existing parsing template or prompt you to create 

a new parsing template. If one or more parsing templates match the 

schema of the newly added file, the Select Parse Template Dialog is 

displayed. You may then select the appropriate template. If there are no 

parsing templates that match this schema, the “XML Template Editor” is 

displayed. This will allow you to create a new template for this XML file. 

 

Modifying Templates 

You can modify the existing parsing templates in a comparison set by 

selecting Edit → Edit XML Parsing Templates or by clicking on the “Edit 

Templates...” button in the Select Parse Template Dialog. 
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Edit Templates Dialog 

This dialog allows you to create new templates, edit existing ones, and 

delete templates. Clicking on “New” or “Edit” brings up the XML 

Template Editor Dialog. There are two groups of parsing templates: 

“Current Templates” and “Archived Templates”. You can toggle between 

these groups using the drop-down field at the top of the dialog. The 

Current Templates are available in the currently active comparison set. 

These templates can be selected in the Select Parse Template Dialog to 

parse a given witness. The Archive Templates do not affect the current 

comparison set. The archived templates are your own personal library of 

templates that can be reused from project to project. An archived 

template may be restored to be used in the current Comparison Set. 

Likewise, the current templates can be archived for future use. To 

archive a template from the Current Templates, select it and then click 

the “Archive” button. To restore a template from the archive, select it 

and then click on the “Restore” button. 

 

Select Parse Template Dialog 

This dialog allows you to select an existing template with which to 

process the current witness. See Juxta XML Parsing Templates for more 

information. 
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Revision Site Controls 

When you open an XML file 

that has addition and deletion 

spans marked (by TEI <add> 

and <del> tags), two 

additional buttons will appear 

near the Document Panel. At 

the upper right of the panel is 

the “Toggle revisions view” 

button. Clicking it once reveals the deletions and additions highlighted 

in gray. Deletions are marked by a strikethrough line in dark red text; 

additions are indicated in blue underlined text. 

 

Using the right and left 

arrows that appear beneath 

the Document Panel, you can 

quickly jump from the current 

revision site (indicated in dark 

gray) to the next or previous 

one. Clicking the “Toggle 

revisions view” button again 

will return the Document 

Panel to Collation View (the heat map). 

 

By default, Juxta ignores addition and deletion spans in collating texts. If 

you wish to incorporate additions and deletions in your collation, you 

can click the “Edit Revisions” button at the lower right of the Document 

Panel. This turns the Document Panel into an editing window with a red 

border. Several control buttons appear below the Document Panel.  
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The right and left arrow buttons allow you to navigate through all the 

additions and deletions in the document. When an addition or deletion 

is selected (highlighted in dark gray), clicking “accept” will incorporate 

the revision into your collation. Clicking “reject” will maintain the 

default behavior of Juxta, excluding the revision from collation. For 

example, Juxta by default will collate convm as “con”. If you accept 

both the deletion of on and the addition of vm, Juxta will collate the 

word as “cvm”. You can also click buttons to “Accept All” or “Reject 

All” revisions. After making your choices, click the “Save changes and 

recollate” button (two arrows making a circle) at the lower right of the 

Document Panel to incorporate the revisions into your collation. 

Alternatively, you may click the “Discard changes” (trashcan) button to 

leave the text as you found it. 
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XML <note> Tag Support 

As of version 1.6, Juxta supports display of text enclosed in <note> tags 

in XML documents. The text is not included in the document collation, 

but is displayed in the right margin of the Display Panel. 

 

 

 

The  Pe r i l s  o f  “P la in  Tex t ”  

There is one thing that every scholar manipulating and preparing digital 

texts should know about “plain text” files: there is no such thing as a 

plain text file. All text files, whether they explicitly specify it or not, are 

encoded when they are saved to disk. Possible encodings include “utf-8” 

and “cp-1252” formats.  

 

This fact can cause problems as the file moves from one computer and 

operating system to another. This is because different computer 

operating systems make differing assumptions as to how “plain text” or 

“ascii” files are encoded. For example, files prepared on Windows 

machines with applications like Notepad can generate code in the CP-

1252 format, which is a Microsoft Windows™ specific encoding. If these 

files are then shared across the network to a Mac computer and opened 

as “plain text” they may be corrupted on the screen.  
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We recommend using a cross-platform compatible encoding format such 

as UTF-8. When Juxta loads plain text files, it assumes that they are 

encoded in this format. Most text editing programs will allow you to 

specify the encoding type of a plain text file.  
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