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Overview
Agisoft PhotoScan is an advanced image-based 3D modeling solution aimed at creating professional
quality 3D content from still images. Based on the latest multi-view 3D reconstruction technology, it
operates with arbitrary images and is efficient in both controlled and uncontrolled conditions. Photos can
be taken from any position, providing that the object to be reconstructed is visible on at least two photos.
Both image alignment and 3D model reconstruction are fully automated.

How it works
Generally the final goal of photographs processing with PhotoScan is to build a textured 3D model. The
procedure of photographs processing and 3D model construction comprises three main stages.

1. The first stage is photographs alignment. At this stage PhotoScan searches for common points on
photographs and matches them, as well as it finds the position of the camera for each picture and refines
camera calibration parameters. As a result a sparse point cloud and a set of camera positions are formed.

The point cloud represents the results of photos alignment and will not be directly used in the further
3D model construction procedure (except for the point cloud based reconstruction method). However
it can be exported for further usage in external programs. For instance, the point cloud model can be
used in a 3D editor as a reference.

On the contrary the set of camera positions is required for further 3D model construction by PhotoScan.

2. The next stage is building geometry. Based on the estimated camera positions and pictures themselves
a 3D polygon mesh, representing the object surface, is build by PhotoScan. Four algorithmic methods
available in PhotoScan can be applied to 3D mesh generation: Arbitrary - Smooth, Arbitrary - Sharp,
Height field - Smooth and Height field - Sharp methods. Additionally there is a Point Cloud based
method for fast geometry generation based on the sparse point cloud alone.

Having built the mesh, it may be necessary to edit it. Some corrections, such as mesh decimation,
removal of detached components, closing of holes in the mesh, etc. can be performed by PhotoScan.
For more complex editing you have to engage external 3D editor tools. PhotoScan allows to export the
mesh, edit it by another software and import it back.

3. After the geometry (i.e. the mesh) is constructed, it can be textured and / or used for orthophoto
generation. Several texturing modes are available in PhotoScan, they are described in the corresponding
section of this manual.

About the manual
Basically, the sequence of actions described above covers most of the model processing needs. All these
operations are carried out automatically according to the parameters set by user. Instructions on how to
get through these operations and descriptions of the parameters controlling each step are explained in the
corresponding sections of the Chapter 3, General workflow.

In some cases, however, additional actions may be required to get the desired results. For instance, pictures
taken using uncommon lenses such as fish-eyes may require preliminary calibration of optical system
parameters. In some capturing scenarios masking of certain regions of the photos may be required to
exclude them from the calculations.  Having built up a model, you can set a reference system for it and
carry out typical meaurements such as calculating the surface area and volume of the model. All these
advanced functions are described in the Chapter 4, Advanced use.
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It can take up quite a long time to reconstruct a 3D model. PhotoScan allows to export obtained results
and save intermediate data in a form of project files at any stage of the process. If you are not familiar with
the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can also find instructions on the PhotoScan installation procedure and basic rules for
taking "good" photographs, i.e. pictures that provide most necessary information for 3D reconstruction.
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Chapter 1. Installation
System requirements

Minimal configuration

• Windows XP or later (32 or 64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)

• Intel Core 2 Duo processor or equivalent

• 2GB of RAM

Recommended configuration

• Windows XP or later (64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)

• Intel Core i7 processor

• 12GB of RAM

The number of photos that can be processed by PhotoScan depends on the available RAM and
reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPx, 2GB
RAM is sufficient to make a model based on 20 to 30 photos. 12GB RAM will allow to process up to
200-300 photographs.

OpenCL acceleration
PhotoScan supports accelerated geometry reconstruction due to the graphics hardware (GPU) exploiting.

NVidia
GeForce 8xxx series and later.

ATI
Radeon HD 5xxx series and later.

PhotoScan is likely to be able to utilize processing power of any OpenCL enabled device, provided that
OpenCL drivers for the device are properly installed. However, because of the large number of various
combinations of video chips, driver versions and operating systems, AgiSoft is unable to test and guarantee
PhotoScan's compatibility with every device and on every platform.

The table below lists currently supported devices (on Windows platform only). We will pay particular
attention to possible problems with PhotoScan running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

NVIDIA AMD

GeForce GTX Titan Radeon HD 7970

GeForce GTX 680 Radeon HD 6970

GeForce GTX 580 Radeon HD 6950

GeForce GTX 570 Radeon HD 6870
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NVIDIA AMD

GeForce GTX 560 Radeon HD 5870

GeForce GTX 480 Radeon HD 5850

GeForce GTX 470 Radeon HD 5830

GeForce GTX 465  

GeForce GTX 285  

GeForce GTX 280  

Although PhotoScan is supposed to be able to utilize other GPU models and being run under a different
operating system, AgiSoft does not guarantee that it will work correctly.

Note

• OpenCL acceleration can be enabled using OpenCL tab in the Preferences dialog box.

• Using OpenCL acceleration with mobile video chips is not recommended because of the low
performance of mobile GPUs.

Installation procedure

Installing PhotoScan on Microsoft Windows
To install PhotoScan on Microsoft Windows simply run the downloaded msi file and follow the
instructions.

Installing PhotoScan on Mac OS X
Open the downloaded dmg image and drag PhotoScan application to the desired location on your hard
drive.

Installing PhotoScan on Debian/Ubuntu
Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive.
Start PhotoScan by running photoscan.sh script from the program folder.

Restrictions of the Demo mode
Once PhotoScan is downloaded and installed on your computer you can run it either in the Demo mode
or in the full function mode. On every start until you enter a serial number it will show a registration box
offering two options: (1) use PhotoScan in the Demo mode or (2) enter the serial number to confirm the
purchase. The first choice is set by default, so if you are still exploring PhotoScan click the Continue button
and PhotoScan will start in the Demo mode.

The employment of PhotoScan in the Demo mode is not time limited. Several functions, however, are not
available in the Demo mode. These functions are the following:

• saving the project;

• exporting reconstruction results (you can only view a 3D model on the screen).
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To use PhotoScan in the full function mode you have to purchase it. On purchasing you will get the serial
number to enter into the registration box on starting PhotoScan. Once the serial number is entered the
registration box will not appear again and you will get full access to all functions of the program.



4

Chapter 2. Capturing photos
Before loading your photographs into PhotoScan you need to take them and select those suitable for 3D
model reconstruction.

Photographs can be taken by any standard digital camera, as long as you follow some specific capturing
guidelines. This section explains the general principles of taking and selecting pictures that provide the
most appropriate data for 3D model generation.

Basic rules
• Use a digital camera with reasonably high resolution (5 MPix or more).

• Wide angle lenses suit better for reconstructing spatial relations between objects than telephoto ones.

• Avoid not textured and flat objects or scenes.

• Avoid shiny and transparent objects.

• Avoid unwanted foregrounds and moving objects as much as possible.

• Shoot shiny objects under a cloudy sky.

• Shoot pictures of the scene with a lot of overlap.

• Capture most important scene content from multiple viewpoints (3 or more).

• Do not crop or geometrically transform the images.

• More photos is better than not enough.

• Spending some time planning your shot session might be very useful.

• If you intend to set a reference coordinate system for reconstructed 3D model, make sure to identify
or place on ground markers that will be used to set reference coordinate system and scale. Measure
reference distance.

• Make sure to study the following schemes and read the list of restrictions before you get out for shooting
photographs.

Capturing scenarios
The following figures represent several typical capturing scenarios:
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Facade (Incorrect) Facade (Correct)

Interior (Incorrect) Interior (Correct)

Isolated Object (Incorrect) Isolated Object (Correct)

Restrictions
In some cases it might be very difficult or even impossible to build a correct 3D model from a set of
pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs
PhotoScan can process only unmodified photos as they were taken by a digital photo camera. Processing
the photos which were manually cropped or geometrically warped is likely to fail or produce highly
inaccurate results. Photometric modifications do not affect reconstruction results.
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Lack of EXIF data
To estimate the field of view for each photo PhotoScan uses the information saved in the EXIF part of each
picture. If EXIF data are available you can expect to get the best possible 3D reconstruction. However 3D
scene can also be reconstructed in the absence of EXIF data. In this case PhotoScan assumes that the 35mm
focal length equivalent equals to 50 mm and tries to align the photos in accordance with this assumption.
If the correct focal length value differs significantly from 50 mm, the alignment can give incorrect results
or even fail. In such cases it is required to specify initial camera calibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are
given in the Camera calibration section

Lens distortion
The distortion of the lens being used to capture the photos should be well simulated using the Brown's
distortion model. Otherwise it is almost impossible to build a precise 3D model. Fish eyes and ultra-
wide angle lenses are poorly modeled by the distortion model implemented, which leads to inaccurate
reconstructions.
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Chapter 3. General workflow
Processing of images with PhotoScan includes the following main steps:

• loading photos into PhotoScan;

• inspecting loaded images, removing unnecessary images;

• aligning photos;

• building 3D model;

• editing 3D model;

• exporting results.

If you are using PhotoScan in the full function (not the Demo) mode, intermediate results of the image
processing can be saved at any stage in the form of project files and can be used later. The concept of
projects and project files is briefly explained in the Saving intermediate results section.

The list above represents all the necessary steps involved in the construction of a textured 3D model from
your photos. Some additional tools, which you may find to be useful, are described in the Chapter 4,
Advanced use.

Preferences settings
Before starting a project with PhotoScan it is recommended to adjust the program settings for your needs.
In Preferences dialog (General Tab) available through the Tools menu you can indicate the path to the
PhotoScan log file to be shared with the AgiSoft support team in case you face any problems during the
processing. On the Open Tab you need to check that all OpenCL devices detected by the program are
checked. PhotoScan exploits GPU processing power that speeds up the process significantly.

Depth Filtering modes

At the stage of 3D model reconstruction PhotoScan calculates depth maps for every image. Due to same
factors, like poor texture of some elements of the scene, noisy or badly focused images, there can be some
outliers among the points. To sort out the outliers PhotoScan has several inbuilt filtering algorithms that
answer the challenges of different projects.

Mild
If the geometry of the scene to be reconstructed is complex with numerous small details on the
foreground, then it is recommended to set Mild depth filtering mode, for important features not to
be sorted out.

Aggressive
If there area to be reconstructed does not contain meaningful small details, then it is reasonable to
chose Aggressive depth filtering mode to sort out most of the outliers.

Moderate
Moderate depth filtering mode brings results that are in between the Mild and Aggressive approaches.
You can experiment with the setting in case you have doubts which mode to choose.



General workflow

8

Loading photos
Before starting any operation it is necessary to point out what photos will be used as a source for 3D
reconstruction. In fact, photographs themselves are not loaded into PhotoScan until they are needed. So,
when you "load photos" you only indicate photographs that will be used for further processing.

To load a set of photos

1.
Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on
the Workspace pane.

2. In the Add Photos dialog box browse to the folder containing the images and select files to be
processed. Then click Open button.

3. Selected photos will appear on the Workspace pane.

Note

• PhotoScan accepts the following image formats: JPEG, TIFF, PNG, BMP, PPM, OpenEXR
and JPEG Multi-Picture Format (MPO). Photos in any other format will not be shown in the
Add Photos dialog box. To work with such photos you will need to convert them in one of the
supported formats.

If you have loaded some unwanted photos, you can easily remove them at any moment.

To remove unwanted photos

1. On the Workspace pane select the photos to be removed.

2. Right-click on the selected photos and choose Remove Items command from the opened context

menu, or click Remove Items toolbar button on the Workspace pane. The selected photos will be
removed from the working set.

Inspecting the loaded photos
Loaded photos are displayed on the Workspace pane along with flags reflecting their status.

The following flags can appear next to the photo name:

NC (Not calibrated)
Notifies that the EXIF data available is not sufficient to estimate the camera focal length. In this case
PhotoScan assumes that the corresponding photo was taken using 50mm lens (35mm film equivalent).
If the actual focal length differs significantly from this value, manual calibration may be required.
More details on manual camera calibration can be found in the Camera calibration section.

NA (Not aligned)
Notifies that external camera orientation parameters were not estimated for the current photo yet.

Images loaded to PhotoScan will not be aligned until you perform the next step - photos alignment.

Aligning photos
Once photos are loaded into PhotoScan, they need to be aligned. At this stage PhotoScan finds the camera
position for each photo and builds a point cloud model.
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To align a set of photos

1. Select Align Photos... command from the Workflow menu.

2. In the Align Photos dialog box select the desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Alignment having been completed, computed camera positions and a sparse point cloud will be displayed.
You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches
between any two photos use View Matches... command from the Tools menu.

The point cloud and estimated camera positions can be exported for processing with another software if
needed.

Incorrectly positioned photos can be realigned.

To realign a subset of photos

1. Reset alignment for incorrectly positioned photos using Reset Photo Alignment command from the
photo context menu.

2. Set markers (at least 4 per photo) on these photos and indicate their projections on at least two
photos from the already aligned subset. PhotoScan will consider these points to be true matches. (For
information on markers placement refer to the Setting coordinate system section).

3. Select photos to be realigned and use Align Selected Photos command from the photo context menu.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Alignment parameters

The following parameters control the photo alignment procedure and can be modified in the Align Photos
dialog box:

Accuracy
Higher accuracy setting helps to obtain more accurate camera position estimates. Lower accuracy
setting can be used to get the rough camera positions in a shorter period of time.

Pair preselection
The alignment process of large photo sets can take a long time. A significant portion of this time period
is spent on matching of detected features across the photos. Image pair preselection option may speed
up this process due to selection of a subset of image pairs to be matched. In the Generic preselection
mode the overlapping pairs of photos are selected by matching photos using lower accuracy setting
first. In the Ground Control preselection mode the overlapping pairs of photos are selected basing
on the measured camera locations (if present).

Constrain features by mask
When this option is enabled, features detected in the masked image regions are discarded. For
additional information on the usage of masks please refer to the Using masks section.
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Building model geometry
Before starting to run 3D model reconstruction procedure one need to check that Depth Filtering mode
is set correctly. To read about Depth Filtering modes please refer to the Preferences settings section of
the manual.

3D model reconstruction is a computationally intensive operation and can take a long time, depending on
the quantity and resolution of loaded photos. It is recommended to build a model with the lowest quality
first to estimate the applicability of the chosen reconstruction method, and then to recompute the results
using a higher quality setting. It is also recommended to save the project before building the geometry.

To build a 3D model

1.
Check the reconstruction volume bounding box. To adjust the bounding box use the Resize Region

and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to
the desired positions. If the Height field reconstruction method is applied, the red side of the
bounding box will define the reconstruction plane. In this case make sure that the bounding box is
correctly oriented.

2. Select the Build Geometry... command from the Workflow menu.

3. In the Build Geometry dialog box select the desired reconstruction parameters. Click OK button when
done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Reconstruction methods
PhotoScan supports several reconstruction methods and settings, which help to produce optimal
reconstructions for a given data set.

Object type

Arbitrary
Arbitrary object type can be used for modeling of any kind of object. It should be selected for
closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the
object modeled, which comes at a cost of higher memory consumption.

Height field
The Height field object type is optimized for modeling of planar surfaces, such as terrains
or basreliefs. It should be selected for aerial photography processing as it requires lower amount of
memory and allows for larger data sets processing.

Geometry type

Sharp
Sharp geometry type option leads to more accurate reconstruction results and does not introduce
extra geometry, like hole filling "patches". Manual hole filling is usually required at the post
processing step.

Smooth
Smooth geometry type option produces watertight reconstructions with no or little holes on resulting
surface. Large areas of extra geometry might be generated with this method, but they could be easily
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removed later using selection and cropping tools. Smooth setting is recommended for orthophoto
generation.

Point Cloud
Point Cloud quality setting is used for fast 3D model generation based solely on the sparse point
cloud. This method generates holeless model with extrapolated geometry.

Reconstruction parameters
Quality

Specifies the desired reconstruction quality. Higher quality settings can be used to obtain more detailed
and accurate geometry, but require longer time for processing.

Face count
Specifies the maximum face count in the final mesh. 0 for Arbitrary object type - if no decimation is
required, for Height Field - automatically estimated recommended value.

Filter threshold
Specifies the maximum face count of small connected components to be removed after surface
reconstruction (in percent of the total face count). The 0 value disables connected component filtering.

Hole threshold (Height field - Sharp method only)
Specifies the maximum size of holes to be filled after surface reconstruction (in percent of the total
surface area). The 0 value disables automatic hole filling.

Note

• PhotoScan tends to produce 3D models with excessive geometry resolution, so it is recommended
to perform mesh decimation after geometry computation. More information on mesh decimation
and other 3D model geometry editing tools is given in the Editing model geometry section.

Building model texture
To generate 3D model texture

1. Select Build Texture... command from the Workflow menu.

2. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Texture mapping modes
The texture mapping mode determines how the object texture will be packed in the texture atlas. Proper
texture mapping mode selection helps to obtain optimal texture packing and, consequently, better visual
quality of the final model.

Generic
The default mode is the Generic mapping mode; it allows to parameterize texture atlas for arbitrary
geometry. No assumptions regarding the type of the scene to be processed are made; program tries
to create as uniform texture as possible.
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Adaptive orthophoto
In the Adaptive orthophoto mapping mode the object surface is split into the flat part and
vertical regions. The flat part of the surface is textured using the orthographic projection, while vertical
regions are textured separately to maintain accurate texture representation in such regions. When in
the Adaptive orthophoto mapping mode, program tends to produce more compact texture
representation for nearly planar scenes, while maintaining good texture quality for vertical surfaces,
such as walls of the buildings.

Orthophoto
In the Orthophoto mapping mode the whole object surface is textured in the orthographic
projection. The Orthophoto mapping mode produces even more compact texture representation
than the Adaptive orthophoto mode at the expense of texture quality in vertical regions.

Spherical
Spherical mapping mode is appropriate only to a certain class of objects that have a ball-like form.
It allows for continuous texture atlas being exported for this type of objects, so that it is much easier
to edit it later. When generating texture in Spherical mapping mode it is crucial to set the Bounding
box properly. The whole model should be within the Bounding box. The red side of the Bounding
box should be under the model; it defines the axis of the spherical projection. The marks on the front
side determine the 0 meridian.

Single photo
The Single photo mapping mode allows to generate texture from a single photo. The photo to be
used for texturing can be selected from 'Texture from' list.

Keep uv
The Keep uv mapping mode generates texture atlas using current texture parameterization. It can
be used to rebuild texture atlas using different resolution or to generate the atlas for the model
parametrized in the external software.

Texture generation parameters
The following parameters control various aspects of texture atlas generation:

Texture from (Single photo mapping mode only)
Specifies the photo to be used for texturing. Available only in the Single photo mapping mode.

Blending mode (not used in Single photo mode)
Selects the way how pixel values from different photos will be combined in the final texture.

Average - uses the average value of all pixels from individual photos.

Mosaic - gives more quality for orthophoto and texture atlas than Average mode, since it does not
mix image details of overlapping photos but uses most appropriate photo (i. e. the one where the pixel
in question is located within the shotest distance from the image center). Mosaic texture blending
mode is especially useful for orthophoto generation based on approximate geometric model.

Max Intensity - the photo which has maximum intensity of the corresponding pixel is selected.

Min Intensity - the photo which has minimum intensity of the corresponding pixel is selected.

Fill holes
Enables hole filling for contiguous, orthophoto-like texture generation. Recommended for use only
combined with Height-field geometry reconstruction mode. It is recommended to disable hole filling
option when texturing stand-alone objects reconstructed in Arbitrary mode.
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Atlas width
Specifies the width of the texture atlas in pixels.

Atlas height
Specifies the height of the texture atlas in pixels.

Color depth
Specifies the target texture color depth (Standard or HDR). HDR texture generation requires HDR
photos on input.

Saving intermediate results
Certain stages of 3D model reconstruction can take a long time. The full chain of operations could easily
last for 4-6 hours when building a model from hundreds of photos. It is not always possible to finish all
the operations in one run. PhotoScan allows to save intermediate results in a project file.

PhotoScan project files may contain the following information:

• List of loaded photographs with reference paths to the image files.

• Photo alignment data such as information on camera positions, point cloud model and set of refined
camera calibration parameters for each photo.

• Masks applied to the photos in project.

• Reconstructed 3D model with any changes made by user. This includes geometry and texture if they
were built.

• Depth maps for cameras.

• List of added markers and information on their positions.

• Structure of the project, i.e. number of chunks in the project and their content.

You can save the project at the end of any processing stage and return to it later. To restart work simply
load the corresponding file into PhotoScan. Project files can also serve as backup files or be used to save
different versions of the same model.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file
to another location do not forget to move or copy photographs with all the folder structure involved as
well. Otherwise, PhotoScan will fail to run any operation requiring source images, although the project
file including the reconstructed model will be loaded up correctly.

Exporting results
PhotoScan supports export of processing results in various representations: sparse and dense point clouds,
camera calibration data, 3D models. Orthophotos and digital elevation models can be generated according
to the user requirements.

Point clouds and camera calibration data can be exported right after photo alignment is completed. All
other export options are available after the geometry is built.

In some cases editing model geometry in the external software may be required. PhotoScan supports model
export for editing in external software and then allows to import it back, as it is described in the Editing
model geometry section of the manual.
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Point cloud export

To export sparse or dense point cloud

1. Select Export Points... command from the File menu.

2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

3. In the Export Points dialog box select desired Type of point cloud - Sparse or Dense. To export a
dense point cloud choose an appropriate quality value.

4. Specify the coordinate system and indicate export parameters applicable to the selected file type.

5. Click OK button to start export.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

In some cases it may be reasonable to edit sparse point cloud before exporting it. To read about point cloud
editing refer to the Editing sparse point cloud section of the manual.

PhotoScan supports point cloud export in the following formats:

• Wavefront OBJ

• Stanford PLY

• XYZ text file format

• ASPRS LAS

Note

• Saving color information of the point cloud is supported by the PLY, TXT and LAS file formats.

• Saving point normals information is supported by the OBJ, PLY and TXT file formats.

Camera calibration and positions data export
To export camera calibration and positions data select Export Cameras... command from the Tools menu.

To export / import only camera calibration data select Camera Calibration... command from the Tools
menu.

PhotoScan supports camera data export in the following formats:

• PhotoScan structure file format (XML based)

• Bundler OUT file format

• CHAN file format

• Boujou TXT file format

• Omega Phi Kappa text file format
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• PATB Exterior orientation

• BINGO Exterior orientation

• AeroSys Exterior orientation

• Inpho project file

Note

• Camera data export in Bundler and Boujou file formats will save sparse point cloud data in the
same file.

• Camera data export in Bundler file format would not save distortion coefficients k3, k4.

3D model export

To export 3D model

1. Select Export Model... command from the File menu.

2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

3. In the Export Model dialog specify the coordinate system and indicate export parameters applicable
to the selected file type.

4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Note

• If the model is exported in local coordinates, PhotoScan can write a KML file for the exported
model to be correctly located on Google Earth.

PhotoScan supports model export in the following formats:

• Wavefront OBJ

• 3DS file format

• VRML

• COLLADA

• Stanford PLY

• Autodesk DXF

• Autodesk FBX

• Google Earth KMZ

• U3D

• Adobe PDF



General workflow

16

Some file formats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in a separate file. The
texture file should be kept in the same directory as the main file describing the geometry. If the texture
atlas was not built only the model geometry is exported.

Orthophoto export
Orthophoto export is normally used for generation of high resolution imagery based on the source photos
and reconstructed geometry. The most common application is aerial photographic survey processing, but
it may be also useful when a detailed view of the object is required. Orthophoto is often accompanied by
the digital elevation model (see the next section).

In order to export orthophoto in the correct orientation it is necessary to set the coordinate system for
the model first. Since PhotoScan uses original images to build an orthophoto, there is no need to build
a texture atlas.

To export Orthophoto

1. Select Export Orthophoto... command from the File menu.

2. In the Export Orthophoto dialog box specify coordinate system to georeference the Orthophoto.

3. Select Blending mode to be used for texture mapping (for details please see the Building model
texture section).

4. Check Write KML file and / or Write World file options to create files needed to georeference the
orthophoto in the Google Earth and / or a GIS .

5. Click Export button to start export.

6. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

7. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Note

• Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

• World file specifies coordinates of the four angle vertices of the exporting orthophoto. This
information is already included in GeoTIFF file, however, you could duplicate it for some
reason. If you need to export orthophoto in JPEG or PNG file formats and would like to have
georeferencing data this informations could be useful.

PhotoScan allows to export Orthophoto in different planar projections as well. To export Orthophoto in a
planar projection choose Planar Projection Type in Export Orthophoto dialog. You can select projection
plane and orientation of the Orthophoto. PhotoScan provides an option to project the model to a plane
determined by a set of markers (if there are no 3 markers in a desired projection plane it can be specified
with 2 vectors, i. e. 4 markers).

Note

• Default value for pixel size in Export Orthophoto dialog refers to ground sampling resolution,
thus, it is useless to set a smaller value: the number of pixels would increase, but the effective
resolution would not.
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• PhotoScan allows for automatic hole filling. Check Fill Holes option in the Export Orthophoto
dialog to generate holeless orthophoto.

• Split in blocks option in the Export Orthophoto dialog can be useful for exporting large projects.

• To export a particular part of the project use Region section of the Export Orthophoto dialog.

The following formats are supported for orthophoto export:

• JPEG

• PNG

• TIFF

• GeoTIFF

• Multiresolution Google Earth KML mosaic.

Note

• While exporting (Geo)TIFF file LZW compression is applied. If you need an original file or, on
the contrary, more compressed file, you should use external software to do the transformation.
However, one should be carefull with the selected tool not to lose georeferencing information
(in case of GeoTIFF file) during compression/decompression procedure.

DEM export
Digital elevation models (DEMs) represent the model surface as a regular grid of height values, and are
often used for aerial photographic survey data. Digital elevation model can be combined with orthophoto
to produce a 3D model of the area.

To export DEM

1. Select Export DEM... command from the File menu.

2. In the Export DEM dialog box specify coordinate system to georeference the DEM.

3. Check Write KML file and / or Write World file options to create files needed to georeference the
DEM in the Google Earth and / or a GIS.

4. Click Export button to start export.

5. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Note

• Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

• World file specifies coordinates of the four angle vertices of the exporting DEM. This information
is already included in GeoTIFF elevation data as well as in other supported file formats for DEM
export, however, you could duplicate it for some reason.
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PhotoScan allows to export DEM in different planar projections in the same way as it is done for orthophoto
export. (See previous section.)

Note

• Unlike orthophoto export, it is sensible to set smaller pixel size compared to the default value in
DEM export dialog; the effective resolution will increase.

• Export DEM dialog allows to crop invalid DEM (i. e. DEM parts corresponding to the areas
visible on less than 2 source photos). The values for the points of the grid that couldn't be
calculated will be set to the value indicated in no-data value box.

• Split in blocks option in the Export DEM dialog can be useful for exporting large projects or
meeting special DEM requirements.

• To export a particular part of the project use Region section of the Export DEM dialog.

The following formats are supported for DEM export:

• GeoTIFF elevation data

• Arc/Info ASCII Grid (ASC)

• Band interlieved file format (BIL)

• XYZ file format

Processing report generation
PhotoScan supports automatic processing report generation in PDF format, which contains the basic
parameters of the project, processing results and accuracy estimates.

To generate processing report

1. Select Generate Report... command from the File menu.

2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

PhotoScan processing report represents the following data:

• Orthophoto and digital elevation model sketch.

• Camera parameters and survey scheme.

• Image overlap statistics.

• Camera positioning error estimates.

• Ground control point error estimates.

Note

• Processing report can be exported only after geometry is constructed and georeferenced.
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Chapter 4. Advanced use
Splitting project

In some cases it is very hard or even impossible to generate 3D model of the whole object in one go. This
could happen for instance if the total amount of photographs is too large to be processed at a time. To
overcome this PhotoScan offers the possibility of splitting the set of photos in several separate "chunks"
within the project. The alignment of photos, building geometry and forming the texture atlas may be
performed on each chunk separately and then the resulting 3D models may be combined together.

Working with chunks is no more difficult than using PhotoScan following the general workflow. In fact,
in PhotoScan always exists at least one active chunk and all the 3D model processing workflow operations
are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D
models from separate chunks into one model.

Creating a chunk

To create new chunk click on the Add Chunk toolbar button on the Workspace pane or select Add
Chunk command from the Workspace context menu (available by right-clicking on the root element on
the Workspace pane).

After the chunk is created you may load photos in it, align them, generate mesh surface model, build texture
atlas, export the models at any stage and so on. The models in the chunks are not linked with each other.

To move photos from one chunk to another simply select them in the list of photos on the Workspace pane,
and then drag and drop in the desirable chunk.

Working with chunks
All operations within the chunk are carried out following the common workflow: loading photographs,
aligning them, building geometry model, building texture atlas, exporting 3D model and so on.

Note that all these operations are applied to the active chunk. When a new chunk is created it is activated
automatically. Save project operation saves the content of all chunks.

To set another chunk as active

1. Right-click on the chunk title on the Workspace pane.

2. Select Set Active command from the context menu.

To remove chunk

1. Right-click on the chunk title on the Workspace pane.

2. Select Remove Items command from the context menu.

Aligning chunks
After the "partial" 3D models are built in several chunks they can be merged together. Before merging
chunks they need to be aligned.
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To align separate chunks

1. Select Align Chunks command from the Workflow menu.

2. In the Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-
click. Set desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

Aligning chunks parameters

The following parameters control the chunks alignment procedure and can be modified in the Align Chunks
dialog box:

Method
Defines the chunks alignment method. Point based method alignes chunks by matching photos
across the different chunks. Marker based method uses markers as common points between
different chunks. The details on using markers are available in the Setting coordinate system
section.Camera based method is used to align chunks based on estimated camera locations.
Corresponding cameras should have the same label.

Accuracy (Point based alignment only)
Higher accuracy setting helps to obtain more accurate chunk alignment results. Lower accuracy setting
can be used to get the rough chunk alignment in the shorter time.

Preselect image pairs (Point based alignment only)
The alignment process of many chunks may take a long time. A signficant portion of this time is spent
for matching of detected features across the photos. Image pair preselection option can speed up this
process by selection of a subset of image pairs to be matched.

Constrain features by mask (Point based alignment only)
When this option is enabled, features detected in the masked image regions are discarded. For
additional information on the usage of masks refer to the Using masks section.

Note

• Chunk alignment can be performed only for chunks containing aligned photos.

• There is no need to perform chunk alignment for georeferenced chunks, as they are already in
the same coordinate frame.

Merging chunks
After alignment is complete the separate chunks can be merged into a single chunk.

To merge chunks

1. Select Merge Chunks command from the Workflow menu.

2. In the Merge Chunks dialog box select chunks to be merged and the desired merging options. Click
OK button when done.

3. PhotoScan will merge the separate chunks into one. The merged chunk will be displayed in the project
content list on Workspace pane.
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The following parameters control the chunks merging procedure and can be modified in the Merge Chunks
dialog box:

Merge models
Defines if models from the selected chunks are merged.

Merge markers
Defines if markers from the selected chunks are merged (only markers with the same labels would
be merged).

Chunks merging result (i.e. photos, points and geometry) will be stored in the new chunk and it may be
treated as common chunk (e.g. the model can be textured and/or exported).

Batch processing
PhotoScan allows to perform general workflow operations with multiple chunks automatically. It is useful
when dealing with a large number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the
chunks selected by the user.

Batch processing can perform the following operations:

• Align Photos

• Build Geometry

• Build Texture

• Decimate Mesh

• Import Cameras

• Export Model

• Align chunks

• Save project after every completed operation

To start batch processing

1. Select Batch Process... command from the Workflow menu.

2. Click Add to add the desired processing stages.

3. In the Add Job dialog select the kind of operation to be performed, the list of chunks it should be
applied to, and desired processing parameters. Click OK button when done.

4. Repeat the previos steps to add other processing steps as required.

5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.

6. Click OK button to start processing.

7. The progress dialog box will appear displaying the list and status of batch jobs and current operation
progress. To cancel processing click the Cancel button.
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Camera calibration

Calibration groups
While carrying out photo alignment PhotoScan estimates both internal and external camera orientation
parameters, including nonlinear radial distortions. For the estimation to be successfull it is crucial to apply
the estimation procedure separately to photos taken with different cameras. Once photos have been loaded
in the program, PhotoScan automatically divides them into calibration groups according to the image
resolution and/or EXIF metadata like camera type and focal length. All the actions described below could
and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To create a new calibration group

1. Select Camera Calibration... command from the Tools menu.

2. In the Camera Calibration dialog box, select photos to be arranged in a new group.

3. In the right-click context menu choose Create Group command.

4. A new group will be created and depicted on the left-hand part of the Camera Calibration dialog box.

To move photos from one group to another

1. Select Camera Calibration... command from the Tools menu.

2. In the Camera Calibration dialog box choose the source group on the left-hand part of the dialog.

3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera
Calibration dialog box.

Camera types
PhotoScan supports two major types of camera: frame camera and spherical camera. Camera type can be
set in Camera Calibration dialog box available from Tools menu.

Spherical camera. In case the source data within a calibration group was shot with a spherical
camera, camera type setting will be enough for the program to calculate camera orientation parameters.
No additional information is required.

Frame camera. If the source data within a calibration group was shot with a frame camera, for successful
estimation of camera orientation parameters the information on approximate focal length (pix) is required.
Obviously, to calculate focal length value in pixel it is enough to know focal length in mm along with
pixel size in mm. Normally this data is extracted automatically from the EXIF metadata.

In case source images lack EXIF data or the EXIF data is insufficient to calculate focal length in pixels,
PhotoScan will assume that focal length equals to 50 mm (35 mm film equivalent). However, if the initial
guess values differ significantly from the actual focal length, it is likely to lead to failure of the alignment
process. So, if photos do not contain EXIF metadata, it is preferable to specify focal length (mm) and
pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools menu.
Generally, this data is indicated in camera specification or can be received from some online source. To
indicate to the program that camera orientation parameters should be estimated based on the focal length
and pixel size information, it is necessary to set the Type parameter on the Initial tab to Auto value.
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Camera calibration parameters
If extra wide lenses were used to get the source data, the information on focal length and pixel size may
fail to be sufficient to estimate camera orientation parameters successfully. Once you have tried to run
the estimation procedure and faced poor results, you can improve them thanks to the additional data on
calibration parameters.

To specify camera calibration parameters

1. Select Camera Calibration... command from the Tools menu.

2. Select calibration group, which needs reestimatiopn of camera orientation parameters on the left side
of the Camera Calibration dialog box.

3. In the Camera Calibration dialog box, select Initial tab.

4. Modify the calibration parameters displayed in the corresponding edit boxes.

5. Set the Type to the Precalibrated value.

6. Repeat to every calibration group where applicable.

7. Click OK button to set the calibration.

Note

• Alternatively, initial calibration data can be imported from file using Import button on the Initial
tab of the Camera Calibration dialog box.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos
processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera
Calibration dialog box.

If very precise calibration data is available, to protect it from recalculation one should check Fix calibration
box. In this case initial calibration data will not be changed during Align Photos process.

Adjusted camera calibration data can be saved to file using Import button on the Adjusted tab of the Camera
Calibration dialog box.

Calibration parameters list
fx, fy

Focal length in x- and y-dimensions measured in pixels.

cx, cy
Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane.

skew
Skew transformation coefficient.

k1, k2, k3, k4
Radial distortion coefficients.

p1, p2
Tangential distortion coefficients.
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Automatic refinement of camera calibration parameters
By default PhotoScan considers specified camera calibration parameters as the initial guess, and refines
them later during the photo alignment. That is generally a desirable behaviour. However in the cases when
the camera calibration parameters are known precisely (like in case of a metric camera), it may be required
to protect camera calibration parameters from optimization. To fix the camera calibration parameters select
the Fix calibration check box on the Initial tab of the Camera Calibration dialog box.

Using masks

Overview

Masks are used in PhotoScan to specify the areas on the photos which can otherwise be confusing to
the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of
processing:

• Alignment of the photos

• Building 3D model geometry

• Building 3D model texture

• Exporting Orthophoto

Alignment of the photos
Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts
of the photos are not taken into account while estimating camera positions. This is important in the
setups, where the object of interest is not static with respect to the scene, like when using a turn table
to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In
this case a small number of useful matches can be filtered out mistakenly as a noise among a much
greater number of matches between background objects.

Building 3D model
While building the model, masked areas are not used in the surface generation process. Masking can
be used to reduce the resulting model complexity, by eliminating the areas on the photos that are not
of interest.

Masked areas are always excluded from processing during surface reconstruction and texture
generation stages.

Let's take for instance a set of photos of some object. Along with an object itself on each photo some
background areas are present. These areas may be useful for more precise camera positioning, so it is
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better to use them while aligning the photos. However, impact of these areas at the building geometry
stage is exactly opposite. If they are used for building geometry the resulting model will contain object
of interest and its background. Background geometry will "consume" some part of mesh polygons
that could be otherwise used for modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision
and quality of geometry reconstruction.

Building texture atlas
During texture atlas generation, masked areas on the photos are not used for texturing. Masking areas
on the photos that are occluded by outliers or obstacles helps to prevent the "ghosting" effect on the
resulting texture atlas.

Loading masks
Masks can be loaded from external sources, as well as generated automatically from background images
if such data is available. PhotoScan supports loading masks from the following sources:

• From alpha channel of the source photos.

• From separate images.

• Generated from background photos based on background differencing technique.

• Based on reconstructed 3D model.

To import masks

1. Select Import Masks... command from the Tools menu.

2. In the Import Mask dialog select suitable parameters. Click OK button when done.

3. When generating masks from separate or background images, the folder selection dialog will appear.
Browse to the folder containing corresponding images and select it.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following parameters can be specified during mask import:

Import masks for
Specifies whether masks should be imported for the currently opened photo, active chunk or entire
Workspace.

Current photo - load mask for the currently opened photo (if any).

Active chunk - load masks for active chunk.

Entire workspace - load masks for all chunks in the project.

Method
Specifies the source of the mask data.

From Alpha - load masks from alpha channel of the source photos.

From File - load masks from separate images.
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From Background - generate masks from background photos.

From Model - generate masks based on reconstructed model.

Mask file names (not used in From alpha mode)
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.

{fileext} - extension of the source photo.

{camera} - camera label.

{frame} - frame number.

{filenum} - sequential number of the mask being imported.

For example, {filename}_mask.png template can be used if masks are available in PNG format and
have a _mask suffix.

Tolerance (From Background method only)
Specifies the tolerance threshold used for background differencing. Tolerance value should be set
according to the color separation between foreground and background pixels. For larger separation
higher tolerance values can be used.

Editing masks
Modification of the current mask is performed by adding or subtracting selections. A selection is created
with one of the supported selection tools and is not incorporated in the current mask until it is merged with
a mask using Add Selection or Subtract Selection operations.

To edit the mask

1. Open the photo to be masked by double clicking on its name on the Workspace / Photo pane. The
photo will be opened in the main window. The existing mask will be displayed as a shaded region
on the photo.

2. Select the desired selection tool and generate a selection.

3.
Click on  Add Selection toolbar button to add current selection to the mask, or  Subtract

Selection to subtract the selection from the mask.  Invert Selection button allows to invert current
selection prior to adding or subtracting it from the mask.

The following tools can be used for creating selections:

 Rectangle selection tool
Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools
were applied.

 Intelligent scissors tool
Intelligent scissors is used to generate a selection by specifying its boundary. The boundary is formed
by selecting a sequence of vertices with a mouse, which are automatically connected with segments.
The segments can be formed either by straight lines, or by curved contours snapped to the object
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boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the
selection, the boundary should be closed by clicking on the first boundary vertex.

 Intelligent paint tool
Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image
regions, bounded by object boundaries.

 Magic wand tool
Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic
Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower
tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool.
Higher value broadens the range of colors selected.

Note

• To add new area to the current selection hold the Ctrl key during selection of additional area.

• The masks are generated individually for each image. If some object should be masked out, it
should be masked out on all photos, where that object appears.

Saving masks
Created masks can be also saved for external editing or storage.

To export masks

1. Select Export Masks... command from the Tools menu.

2. In the Export Mask dialog select suitable parameters. Click OK button when done.

3. Browse to the folder where the masks should be saved and select it.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following parameters can be specified during mask export:

Export masks for
Specifies whether masks should be exported for the currently opened photo, active chunk or entire
Workspace.

Current photo - save mask for the currently opened photo (if any).

Active chunk - save masks for active chunk.

Entire workspace - save masks for all chunks in the project.

File type
Specifies the type of generated files.

Single channel mask image - generates single channel black and white mask images.

Image with alpha channel - generates color images from source photos combined with mask
data in alpha channel.
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Mask file names
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.

{fileext} - extension of the source photo.

{camera} - camera label.

{frame} - frame number.

{filenum} - sequential number of the mask being exported.

For example, {filename}_mask.png template can be used to export masks in PNG format with _mask
suffix.

Note

• When importing/exporting mask for the current photo only, PhotoScan will prompt for the actual
image instead of image folder. Mask file names parameter will not be used in this case.

Editing sparse point cloud
The following point cloud editing tools are available in PhotoScan:

• Automatic filtering based on specified criterion

• Manual points removal

Note

• Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit
menu.

Filtering points based on specified criterion
In some cases it may be useful to find out where the points with high reprojection error are located within
the cloud, or remove points representing high amount of noise. Point cloud filtering helps to select such
points, which usually are supposed to be removed.

PhotoScan supports the following criteria for point cloud filtering:

Reprojection error
High reprojection error usually indicates poor localization accuracy of the corresponding point
projections at the point matching step. It is also typical for false matches. Removing such points can
improve accuracy of the subsequent optimization step.

Reconstruction uncertainty
High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small
baseline. Such points can noticably deviate from the object surface, introducing noise in the point
cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
to remove them before building geometry in Point Cloud mode or for better visual appearence of the
point cloud.
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Image count
PhotoScan reconstruct all the points that are visible at least on two photos. However, points that are
visible only on two photos are likely to be located with poor accuracy. Image count filtering enables
to remove such unreliable points from the cloud.

To remove points based on specified criterion

1.
Switch to Point Cloud view mode using Point Cloud toolbar button.

2. Select Gradual Selection... command from the Edit menu.

3. In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold
level using the slider. You can observe how the selection changes while dragging the slider. Click
OK button to finalize the selection.

4.
To remove selected points use Delete Selection command from the Edit menu or click  Delete
Selection toolbar button (or simply press Del button on the keyboard).

Manual points removal
Incorrect points can be also removed manually.

To remove points from the sparse cloud manually

1.
Switch to Point Cloud view mode using Point Cloud toolbar button.

2.
Select points to be removed using  Rectangle Selection,  Circle Selection or  Free-Form
Selection tools. To add new points to the current selection hold the Ctrl key during selection of
additional points. To remove some points from the current selection hold the Shift key during
selection of points to be removed.

3.
To delete selected points click the  Delete Selection toolbar button or select Delete Selection

command from the Edit menu. To crop selection to the selected points click the  Crop Selection
toolbar button or select Crop Selection command from the Edit menu.

Editing model geometry
The following mesh editing tools are available in PhotoScan:

• Decimation tool

• Automatic filtering based on specified criterion

• Manual face removal

More complex editing can be done in the external 3D editing tools. PhotoScan allows to export mesh and
then import it back for this purpose.

Note

• For face removal operations such as manual face removal and connected component filtering
it is possible to undo the last mesh editing operation. There are Undo/Redo commands in the
Edit menu.
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Please note that undo/redo commands are not supported for mesh decimation and this operation
can not be undone.

Decimation tool
Decimation is a tool used to decrease the geometric resolution of the model by replacing high resolution
mesh with a lower resolution one, which is still capable of representing the object geometry with high
accuracy. PhotoScan tends to produce 3D models with excessive geometry resolution, so mesh decimation
is usually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands polygons. While it is acceptable to work with
such a complex models in 3D editor tools, in most conventional tools like Adobe Reader or Google Earth
high complexity of 3D models may noticeably decrease application performance. High complexity also
results in longer time required to build texture and to export model in pdf file format.

In some cases it is desirable to keep as much geometry details as possible like it is needed for scientific and
archive purposes. However, if there are no special requirements it is recommended to decimate the model
down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in
Google Earth and alike tools.

To decimate 3D model

1. Select Decimate Mesh... command from the Tools menu.

2. In the Decimate Mesh dialog box specify the target number of faces, which should remain in the final
model. Click on the OK button to start decimation.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Note

• Texture atlas is discarded during decimation process. You will have to rebuild texture atlas after
decimation is complete.

Face filtering on specified criterion
In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding
the "main" model or big unwanted faces. Mesh filtering based on different criteria helps to select faces,
which usually are supposed to be removed.

PhotoScan supports the following criteria for face filtering:

Connected component size
This filtering criteria allows to select isolated fragments with a certain number of polygons. The
number of polygons in all isolated components to be selected is set with a slider and is indicated in
relation to the number of polygons in the whole model. The components are ranged in size, so that
the selection proceeds from the smallest component to the largest one.

Polygon size
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be
selected is set with a slider and is indicated in relation to the size of the whole model. This fuction can
be useful, for example, in case the geometry was reconstructed in Smooth type and there is a need to
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remove extra polygons automatically added by PhotoScan to fill the gaps; these polygons are often
of a larger size that the rest.

To remove small isolated mesh fragments

1. Select Gradual Selection... command from the Edit menu.

2. In the Gradual Selection dialog box select Connected component size criterion.

3. Select the size of isolated components to be removed using the slider. You can observe how the
selection changes while dragging the slider. Click OK button to finalize the selection.

4.
To remove the selected components use Delete Selection command from the Edit menu or click 
Delete Selection toolbar button (or simply press Del button on the keyboard).

To remove large polygons

1. Select Gradual Selection... command from the Edit menu.

2. In the Gradual Selection dialog box select Polygon size criterion.

3. Select the size of polygons to be removed using the slider. You can observe how the selection changes
while dragging the slider. Click OK button to finalize the selection.

4.
To remove the selected components use Delete Selection command from the Edit menu or click 
Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that PhotoScan always selects the fragments starting from the smallest ones. If the model contains
only one component the selection will be empty.

Manual face removal
Unnecessary and excessive sections of model geometry can be also removed manually.

To remove part of the faces manually

1.
Select rectangle, circle or free-form selection tool using  Rectangle Selection,  Circle Selection

or  Free-Form Selection toolbar buttons.

2. Make the selection using the mouse. To add new faces to the current selection hold the Ctrl key
during selection of additional faces. To remove some faces from the current selection hold the Shift
key during selection of faces to be removed.

3.
To delete selected faces click the  Delete Selection toolbar button or use Delete Selection command

from the Edit menu. To crop selection to the selected faces click the  Crop Selection toolbar button
or use Crop Selection command from the Edit menu.

To grow or shrink current selection

1. To grow current selection press PageUp key in the selection mode. To grow selection by even a larger
amount, press PageUp while holding Shift key pressed.
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2. To shrink current selection press PageDown key in the selection mode. To shrink selection by even
a larger amount, press PageDown while holding Shift key pressed.

Editing mesh in the external program

To export mesh for editing in the external program

1. Select Export Model... command from the File menu.

2. In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the
file name to be used for the model and click Save button.

3. In the opened dialog box specify additional parameters specific to the selected file format. Click OK
button when done.

To import edited mesh

1. Select Import Mesh... command from the Tools menu.

2. In the Open dialog box, browse to the file with the edited model and click Open.

Note

• PhotoScan suppots loading models in Wavefront OBJ and Stanford PLY file formats only. Please
make sure to select one of these file formats when exporting model from the external 3D editor.

Setting coordinate system
Many applications require data with a defined coordinate system. Setting the coordinate system also
provides a correct scaling of the model allowing for surface area and volume measurements and makes
model loading in geoviewers and geoinformatics software much easier. Some functionality like digital
elevation model export is available only after the coordinate system is defined.

PhotoScan supports setting a coordinate system based on either ground control point (marker) coordinates
or camera coordinates. In both cases the coordinates are specified in the Ground Control pane and can be
either loaded from the external file or typed in manually.

Setting coordinate system based on recorded camera positions is often used in aerial photography
processing. However it may be also useful for processing photos captured with GPS enabled cameras.
Placing markers is not required if recorded camera coordinates are used to initialize the coordinate system.

In the case when ground control points are used to set up the coordinate system the markers should be
placed in the corresponding locations of the scene.

Using camera positioning data for georeferencing the model is faster since manual marker placement is
not required. On the other hand, ground control point coordinates are usually more accurate than telemetry
data, allowing for more precise georeferencing.

Placing markers
PhotoScan uses markers to specify locations within the scene. Markers are used for setting up a coordinate
system, photo alignment optimization, measuring distances and volumes within the scene as well as for
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marker based chunk alignment. Marker positions are defined by their projections on the source photos.
The more photos are used to specify marker position the higher is accuracy of marker placement. To define
marker location within a scene it should be placed on at least 2 photos.

Note

• Marker placement is not required for setting the coordinate system based on recorded camera
coordinates. This section can be safely skipped if the coordinate system is to be defined based
on recorded camera locations.

PhotoScan supports two approaches to marker placement: manual marker placement and guided marker
placement. Within the manual approach the marker projections should be indicated manually on each photo
where the marker is visible. Manual marker placement does not require 3D model and can be performed
even before photo alignment.

In the guided approach marker projection is specified for a single photo only. PhotoScan automatically
projects the corresponding ray onto the model surface and calculates marker projections on the rest of
the photos where marker is visible. Marker projections defined automatically on individual photos can be
further refined manually. Reconstructed 3D model surface is required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also
reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any
specific reasons preventing this operation.

To place a marker using guided approach

1. Open a photo where the marker is visible by double clicking on its name.

2.
Switch to the marker editing mode using Edit Markers toolbar button.

3. Right click on the photo at the point corresponding to the marker location.

4. Select Create Marker command from the context menu. New marker will be created and its projections
on the other photos will be automatically defined.

Note

• If the 3D model is not available or the ray at the selected point does not intersect with the model
surface, the marker projection will be defined on the current photo only.

• Guided marker placement can be performed in the same way from the 3D view by clicking on

the corresponding point on the model surface using Create Marker tool. While the accuracy
of marker placement in the 3D view is usually much lower, it may be still useful for quickly
locating the photos observing the specified location on the model. To view the corresponding

photos use Filter by Markers button from the Photo pane toolbar.

To place a marker using manual approach

1.
Create marker instance using Add marker button on the Workspace pane or by Add Marker
command from the Chunk context menu (available by right clicking on the chunk title on the
Workspace pane).

2. Open the photo where the marker projection needs to be added by double clicking on the photos name.
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3.
Switch to the marker editing mode using Edit Markers toolbar button.

4. Right click at the point on the photo where the marker projection needs to be placed. From the context
menu open Place Marker submenu and select the marker instance previously created. The marker
projection will be added to the current photo.

5. Repeat the previous step to place marker projections on other photos if needed.

Note

• If a marker has been placed on at least two aligned images PhotoScan will find the marker

projections on the rest of the photos. The calculated marker positions will be indicated with 
icon on the corresponding aligned photos in Photo View mode.

Defined marker locations can be later refined manually by dragging their projections on the corresponding
photos.

To refine marker location

1. Open the photo where the marker is visible by double clicking on the photo's name. Automatically

placed marker will be indicated with icon.

2.
Switch to the marker editing mode using Edit Markers toolbar button.

3. Move the marker projection to the desired location by dragging it using left mouse button. Once the

marker location is refined by user, the marker icon will change to 

Note

• To list photos where the marker locations are defined, select the corresponding marker on the

Workspace pane. The photos where the marker is placed will be marked with a  icon on the
Photos pane.

PhotoScan automatically assigns default labels for each newly created marker. These labels can be changed
using the Rename... command from the marker context menu.

Assigning reference coordinates
To reference the model the real world coordinates of at least 3 points of the scene should be
specified. Depending on the requirements, the model can be referenced using marker coordinates, camera
coordinates, or both. Real world coordinates used for referencing the model along with the type of
coordinate system used are specified using the Ground Control pane.

The model can be located in either local Euclidean coordinates or in georeferenced coordinates. For
model georeferencing a wide range of various geographic and projected coordinate systems are supported,
including widely used WGS84 coordinate system. Besides, almost all coordinate systems from the EPSG
registry are supported as well.

Reference coordinates can be specified in one of the following ways:

• Loaded from a separate text file (using character separated values format).

• Entered manually in the Ground Control pane.



Advanced use

35

• Loaded from GPS EXIF tags (if present).

To load reference coordinates from a text file

1.
Click Import toolbar button on the Ground Control pane. (To open Ground Control pane use
Ground Control command from the View menu.) Browse to the file containing recorded reference
coordinates and click Open button.

2. In the Import CSV dialog select the delimiter and indicate the number of the data column for each
coordinate. Indicate columns for the orientation data if present.

3. Click OK button. The reference coordinates data will be loaded onto the Ground Control pane.

Note

• In the data file columns and rows are numbered starting from 0.

• If reference coordinates of a marker / camera position for a photo are not specified in the loading
file the current value will be kept for them.

• An example of a coordinates data file in the CSV format is given in the next section.

To assign reference coordinates manually

1.
Switch to the View Source mode using View Source button from the Ground Control pane toolbar.
(To open Ground Control pane use Ground Control command from the View menu.)

2. On the Ground Control pane double click on x/y/z cells to assign values to corresponding coordinates.

3. Repeat for every marker / camera position needed to be specified.

4. To remove unnecessary reference coordinates select corresponding items from the list and press Del
key.

5.
Click Update toolbar button to apply changes and set coordinates.

To load reference coordinates from GPS EXIF tags

•
Click Import EXIF button on the Ground Control pane. (To open Ground Control pane use Ground
Control command from the View menu.) The reference coordinates data will be loaded into the
Ground Control pane.

After reference coordinates have been assigned PhotoScan automatically estimates coordinates in a local
Euclidean system and calculates the referencing errors. To see the results switch to the View Estimated or

View Errors modes respectively using View Estimated and View Errors toolbar buttons. The largest
error will be highlighted.

To set a georeferenced coordinate system

1. Assign reference coordinates using one of the options described above.

2.
Click Settings button on the Ground Control pane toolbar.
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3. In the Ground Control Settings dialog box select the Coordinate System used to compile reference
coordinates data.

4. Specify the assumed measurement accuracy.

5. Indicate relative camera to GPS system coordinates if present in Camera Correction section of the
Ground Control Settings dialog box.

6. Click OK button to initialize the coordinate system and estimate geographic coordinates.

Note

• In Select Coordinate System dialog it is possible to ease searching for the required georeferencing
system using Filter option. Enter respective EPSG code (e.g. EPSG::4302) to filter the systems.

• Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh
precision).

To view the estimated geographic coordinates and reference errors switch between the View Estimated

and View Errors modes respectively using View Estimated and View Errors toolbar buttons. The
largest error will be highlighted. A click on the column name on the Ground Control pane sorts the markers
and photos by the data in the column. At this point you can review the errors and decide whether additional
refinement of marker locations is required (in case of marker based referencing), or if certain reference
points should be excluded.

To save the errors and / or estimated coordinates use Export toolbar button on the Ground Control pane.

To reset a chunk georeferencing use Reset Transform command from the chunk context menu on the
Workspace pane. [R] indicator of a chunk being georeferenced will be removed from the chunk name.

Note

• Unchecked reference points on the Ground Control pane are not used for georeferencing. Use
context menu to check / uncheck selected items.

• After adjusting marker locations on the photos, the coordinate system will not be updated

automatically. It should be updated manually using Update toolbar button on the Ground
control pane.

• PhotoScan allows to convert the estimated geographic coordinates into a different coordinate
system. To calculate the coordinates of the camera positions and / or markers in a different

coordinate system use Convert toolbar button on the Ground Control pane.

Example of a reference coordinates file in CSV format
The reference coordinates can be loaded onto the Ground Control pane using character separated text file
format. Each reference point is specified in this file on a separate line. Sample reference coordinates file
is provided below:

# <label>       <x>          <y>          <z>
IMG_0159.JPG    40.165011    48.103654    433.549477
IMG_0160.JPG    40.165551    48.103654    434.724281
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IMG_0161.JPG    40.166096    48.103640    435.630558

Individual entries on each line should be separated with a tab (space, semicolon, comma, etc)
character. All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding photos or markers basing on the
label field. Camera coordinates labels should match the file name of the corresponding photo including
extension. Marker coordinates labels should match the labels of the corresponding markers in the project
file. All labels are case insensitive.

Note

• Character separated reference coordinates format does not include specification of the type of
coordinate system used. The kind of coordinate system used should be selected separately.

Optimization of photo alignment
PhotoScan estimates internal and external camera orientation parameters during photo alignment. This
estimation is performed using image data alone, and there may be some errors in the final estimates. The
accuracy of the final estimates depends on many factors, like overlap between the neighboring photos, as
well as on the shape of the object surface. These errors can lead to non-linear deformations of the final
model.

During georeferencing the model is linearly transformed using 7 parameter similarity transformation (3
parameters for translation, 3 for rotation and 1 for scaling). Such transformation can compensate only a
linear model misalignment. The non-linear component can not be removed with this approach. This is
usually the main reason for georeferencing errors.

Possible non-linear deformations of the model can be removed by optimizing the estimated point cloud
and camera parameters based on the known reference coordinates. During this optimization PhotoScan
adjusts estimated point coordinates and camera parameters minimizing the sum of reprojection error and
reference coordinate misalignment error.

To achieve greater optimizing results it may be useful to edit sparse point cloud deleting obviously
mislocated points beforehand. To read about point cloud editing refer to the Editing sparse point cloud
section of the manual.

Georeferencing accuracy can be improved significantly after optimization. It is recommended to perform
optimization if the final model is to be used for any kind of measurements.

To optimize photo alignment

1. Set the marker and / or camera coordinates to be used for optimization (if not done yet).

2.
Click Settings toolbar button on the Ground Control pane and set the coordinate system (if not
done yet).

3. In the Ground Control Settings dialog box specify the assumed accuracy of ground control
measurements, as well as the assumed accuracy of marker projections on the source photos.

4. Indicate relative camera to GPS device coordinates if present in Camera Correction section of the
Ground Control Settings dialog box.

5. Click OK button.
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6.
Click Optimize toolbar button. In Optimize Photo Alignment dialog box check additional camera
parameters to be optimized if needed. Click OK button to start optimization.

7. After the optimization is complete, the georeferencing errors will be updated.

Note

• Step 4 can be safely skipped if you are using standard GPS (not that of superhigh precision).

• The model data (if any) is cleared by the optimization procedure. You will have to rebuild the
model geometry after optimization.

Generally it is reasonable to run optimization procedure based on markers data only. It is due to the fact that
GCPs coordinates are measured with significantly higher accuracy compared to GPS data that indicates
camera positions. Thus, markers data are sure to give more precise optimization results. Moreover, rather
often GCP and camera coordinates are measured in different coordinate systems, that also prevents from
using both cameras and markers data in optimization simultaneously.

When performing optimization based on markers data, a 0 accuracy can be specified for marker
coordinates. In this case PhotoScan will assume that marker coordinates are known exactly, and will
exclude their real coordinates from the optimization procedure. This can help to obtain more accurate
results when marker coordinates are measured with high accuracy.

In case optimization results does not seem to be satisfactory, you can try recalculating with lower values
of parameters, i.e. assuming ground control measurements to be more accurate.

Scale bar based optimization
Scale bar is program representation of any known distance within the scene. It can be a standard ruler or a
specially prepared bar of a known length. Scale bar is a handy tool to add supportive ground control data
to your project. They can prove to be useful when there is no way to locate ground control points all over
the scene. Scale bars allow to save field work time, since it is significantly easier to place several scale
bars with precisely known length, then to measure coordinates of a few markers using special equipment.
Surely, scale bar based information will not be enough to set a coordinate system, however, the information
can be successfully used while optimizing the results of photo alignment.

To add a scale bar

1. Place markers at the start and end points of the bar. For information on marker placement please refer
to the Setting coordinate system section of the manual.

2.
Switch to Create Scale Bar mode using the Model view Toolbar button.

3. Click the start point marker and then the end point marker. The scale bar will be created and an instant
added to the Scale Bar list on the Ground Control pane.

4.
Switch to the View Source mode using the Ground Control pane toolbar button.

5. Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

To run scale bar based optimization

1. On the Ground Control pane check all scale bars to be used in optimization procedure.
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2.
Click Settings toolbar button on the Ground Control pane. In the Ground Control Settings dialog
box specify the assumed accuracy of scale bars measurements.

3. Click OK button.

4.
Click Optimize toolbar button. In Optimize Photo Alignment dialog box check additional camera
parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, cameras and markers estimated coordinates will be updated as well as
all the georeferencing errors. To analyze optimization results switch to the View Estimated mode using
the Ground Control pane toolbar button. In scale bar section of the Ground Control pane estimated scale
bar distance will be displayed.

To delete a scale bar

1. Select the scale bar to be deleted on the Ground Control pane.

2. Right-click on it and chose Remove Scale Bars command from the context menu.

3. Click OK for the selected scale bar to be deleted.

What does the errors in the Ground Control pane mean?

Cameras section

1. Error (m) - distance between the input (source) and estimated positions of the camera.

2. Error (deg) - root mean square error calculated over all three orientation angles.

3. Error (pix) - root mean square reprojection error calculated over all feature points detected on the
photo.

Markers section

1. Error (m) - distance between the input (source) and estimated positions of the marker.

2. Error (pix) - root mean square reprojection error for the marker calculated over all photos where
marker is visible.

Scale Bars section

• Error (m) - difference between the input (source) scale bar length and the measured distance between
two markers representing start and end points of the scale bar.

Performing measurements
PhotoScan supports measuring of distances between control points, as well as of surface area and volume
of the reconstructed 3D model.

Distance measurement
PhotoScan enables measurements of direct distances between the points of the reconstructed 3D scene. The
points used for distance measurement must be defined by placing markers in the corresponding locations.
Model coordinate system must be also initialized before the distance measurements can be performed.
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For instructions on placing the markers, refining their positions and setting coordinate system please refer
to the Setting coordinate system section of the manual.

To measure distance

1. Place the markers in the scene at the locations to be used for distance measurement.

2.
Switch to the scale bar creating mode using the Create Scale Bar toolbar button (available in the
Model view).

3. Click on the pair of markers to be used for distance measurements.

4. A new scale bar will be created and a scale bar instance added to the Scale Bars list on the Ground
Control pane.

5.
Switch to the estimated values mode using View Estimated button from the Ground Control pane
toolbar.

6. The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

Note

• Please note that the scale bar used for distance measurements must be unchecked on the Ground
Control pane.

Note

• The distance values measured by PhotoScan are displayed in meters.

Surface area and volume measurement
Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale
or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to
the Setting coordinate system section of the manual.

To measure surface area and volume

1. Select Measure Area and Volume... command from the Tools menu.

2. The whole model surface area and volume will be displayed in the Measure Area and Volume dialog
box. Surface area is measured in square meters, while mesh volume is measured in cubic meters.

Volume measurement can be performed only for the models with closed geometry. If there are any holes
in the model surface PhotoScan will report zero volume. Existing holes in the mesh surface can be filled
in before performing volume measurements using Close Holes... command from the Tools menu.

Note

• If coordinate system is not defined for the model PhotoScan will allow to calculate area and
volume of the model. However, the values obtained will be absolutely meaningless as the unit
of measurement is not defined.
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Working with coded and non-coded targets

Overview
Coded and non-coded targets are specialy prepared, yet quite simple, real world markers that can add up
to successfull 3D model reconstruction of a scene. The difference between coded and non-coded targets is
that while a non-coded target looks like an ordinary full circle, the coded target has a ring parted in black
and white segments around the central full circle.

Coded targets advantages and limitations
Coded targets (CTs) can be used as markers to define local coordinate system and scale of the model or as
true matches to improve photo alignment procedure. PhotoScan functionality includes automatic detection
and matching of CTs on source photos, which allows to benefit from marker implementation in the project
while saving time on manual marker placement. Moreover, automatic CTs detection and marker placement
is more precise then manual marker placement.

PhotoScan supports two types of circle CTs: 12 bit and 16 bit. While 12 bit pattern is considered to be
decoded more precisely, 16 bit pattern allows for a greater number of CTs to be used within the same
project.

To be detected successfully CTs must take up a significant number of pixels on the original photos. This
leads to a natural limitation of CTs implementation: while they generally prove to be useful in close-range
imagery projects, aerial photography projects will demand too huge CTs to be placed on the ground, for
the CTs to be detected correctly.

Coded targets in workflow
Sets of both patterns of CTs supported by PhotoScan can be generated by the program itself.

To create a printable PDF with coded targets

1. Select Print Markers... command from the Tools menu.

2. Specify the CTs type and desired print parameters in Print markers dialog.

3. Click OK.

Once generated, the pattern set can be printed and the CTs can be placed over the scene to be shooted
and reconstructed.

When the images with CTs seen on them are uploaded to the program, PhotoScan can detect and match
the CTs automatically.

To detect coded targets on source images

1. Select Detect Markers... command from the Tools menu.

2. Specify parameters of detector in Detect markers dialog according to the CTs type.

3. Click OK.

PhotoScan will detect and match CTs and add corresponding markers to the Ground Control pane
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Non-coded targets implementation
Non-coded targets (NCTs) cannot be matched automatically, however, they are helpful from the marker
location accuracy point of view. Once the NCTs are matched manually, PhotoScan can refine marker
location, placing the marker instant precisely in the center of the circle.

To refine marker (based on non-coded target) location

1. Select markers to be refined on the Ground Control pane

2. Select Refine Markers... command from the Tools menu.

3. Click OK.

4D processing

Overview
PhotoScan supports reconstruction of dynamic scenes captured by a set of statically mounted synchronized
cameras. For this purpose multiple image frames captured at different time moments can be loaded for
each camera location, forming a multiframe chunk. In fact normal chunks capturing a static scene are
multiframe chunks with only a single frame loaded. Navigation through the frame sequence is performed
using Timeline pane.

Although a separate static chunk can be used to process photos for each time moment, agregate multiframe
chunks implementation has several advantages:

• Coordinate systems for individual frames are guaranteed to match. There is no need to align chunks to
each other after processing.

• Each processing step can be applied to the entire sequence, with a user selectable frame range. There is
no need to use batch processing, which simplifies the workflow.

• Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.

• Markers can be tracked automatically through the sequence.

• Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be also efficient (with some limitations) for processing of disordered photo sets of
the same object or even different objects, provided that cameras remain static throughout the sequence.

Managing multiframe chunks
Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout
used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance.
The following data layouts can be used with PhotoScan:

a. All frames from corresponding camera are contained in a separate subfolder. The number of subfolders
is equal to the number of cameras.

b. Corresponding frames from all cameras are contained in a separate subfolder. The number of subfolders
is equal to the number of frames.
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c. All frames from corresponding camera are contained in a separate multilayer image. The number of
multilayer images is equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of
multilayer images is equal to the number of frames.

Once the data is properly organized, it can be loaded into PhotoScan to form a multiframe chunk. The
exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants
c and d) layout is used.

To create a chunk from multifolder layout

1.
Select Add Folder... command from the Workflow menu.

2. In the Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

3. In the Add Photos dialog select the suitable data layout. For layout a) above select "Create multiframe
cameras from folders as cameras". For layout b) select "Create multiframe cameras from folders as
frames".

4. Created multiframe chunk will appear on the Workspace pane.

To create a chunk from multilayer images

1.
Select Add Photos... command from the Workflow menu or click Add Photos toolbar button.

2. In the Add Photos dialog box browse to the folder containing multilayer images and select files to
be processed. Then click Open button.

3. In the Add Photos dialog select the suitable data layout. For layout c) above select "Create multiframe
cameras from files as cameras". For layout d) select "Create multiframe cameras from files as frames".

4. Created multiframe chunk will appear on the Workspace pane.

It is recommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame
selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe
chunks additional processing parameters allowing to select the range of frames to be processed will be
provided where appropriate.

Tracking markers
PhotoScan allows to automatically track marker projections through the frames sequence, provided that
object position doesn't change significantly between frames. This greatly simplifies the task of labeling of
a moving point if the number of frames is large.

To track markers through the frame sequence

1. Scroll frame selector in the Timeline pane to the 1st frame. Add markers for the 1st frame as described
in the Setting coordinate system section.

2. Select Track Markers... command from the Tools menu.
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3. Adjust the starting and ending frame indices if necessary. Default values correspond to tracking from
the current frame to the end of sequence. Click OK button to start tracking.

4.
Check tracked marker locations. Automatically tracked markers will be indicated with icons. In
case of a placement error at some frame, adjust the wrong marker location within the frame where

the failure occurred. Once the marker location is refined by user, the marker icon will change to 

5. Restart tracking from that frame using Track Markers... command again.

Note

• If the ending frame index is smaller than the starting index, tracking will be performed in the
backwards direction.

• Automatic marker tracking is likely to fail in case when structured light is used to add texture
details to the object surface, as the light pattern will not be static with respect to the moving
object surface.

Multispectral imagery
PhotoScan supports processing of multispectral images saved as multichannel (single page) TIFF files.
The main processing stages for multispectral images are performed based on the master channel, which
can be selected by the user. During orthophoto export, all spectral bands are processed together to form a
multispectral orthophoto with the same bands as in source images.

The overall procedure for multispectral imagery processing does not differ from the usual procedure for
normal photos, except the additional master channel selection step performed after adding images to the
project. For best results it is recommended to select the spectral band which is sharp and as much detailed
as possible.

To select master channel

1. Add multispectral images to the project using Add Photos... command from the Workflow menu or

Add Photos toolbar button.

2. Select Set Master Channel... command from the chunk context menu in the Workspace pane.

3. In the Set Master Channel dialog select the channel to be used as master and click OK button. Display
of images in PhotoScan window will be updated according to the master channel selection.

Note

• Multispectral orthophoto export is supported in GeoTIFF format only. When exporting in other
formats, only master channel will be saved.

Python scripting
PhotoScan supports Python API, using Python 3.3 as a scripting engine.

Python commands and scripts can be executed in PhotoScan through one of the following options:

• PhotoScan Console pane can serve as standard Python console;
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•
Click Run Script button on Console pane toolbar or use Run Script... command from the Tools
menu to run a Python script.

For details on PhotoScan functionality accessible through Python scripts please refer to Python API
Reference document available on AgiSoft official website (http://www.agisoft.ru/products/photoscan/
professional/).

http://www.agisoft.ru/products/photoscan/professional/
http://www.agisoft.ru/products/photoscan/professional/
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Appendix A. Graphical User Interface
Application Window

General view of application window.

Model view
Model view tab is used for displaying 3D data as well as for 3D model and point cloud editing. The view
of the model depends on the current processing stage and is also controlled by mode selection buttons on
the PhotoScan toolbar.

Model can be shown in textured, solid, shaded, or wireframe mode. Along with the model the results of
photo alignment can be displayed. These include point cloud and camera positions.

PhotoScan supports the following tools for navigation in the 3D view:

Tool Keyboard modifier

Rotation Tool Default

Pan Tool Ctrl key pressed

Zooming Tool Shift key pressed

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the

 Navigation toolbar button.

Note

• Zooming into the model can be also controlled by the mouse wheel.
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Photo view
Photo view tab is used for displaying individual photos as well as masks  and markers on them.

Photo view is visible only if any photo is opened. To open a photo double-click on its name on the
Workspace, Ground Control, or Photos pane.

Workspace pane
On the Workspace pane all elements comprising the current project are diplayed. These elements can
include:

• List of chunks in the project

• List of cameras in each chunk

• List of markers in each chunk

• Depth maps for separate chunks

• 3D models in separate chunks

Buttons located on the pane toolbar allow:

• Add chunk

• Add photos

• Add marker

• Enable or disable certain cameras or chunks for processing at further stages.

• Remove items

Each element in the list is linked with the context menu providing quick access to some common
operations.

Photos pane
Photos pane displays the list of photos / masks / depth maps in the active chunk in the form of thumbnails.

Buttons located on the pane toolbar allow:

• Add photos (cameras)

• Enable / disable certain cameras

• Remove cameras

• Rotate selected photos clockwise / counterclockwise

• Increase / decrease icon's size

• Switch between types of thumbnailing images

• Filter cameras by feature points or by markers
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Console pane
Console pane is used for:

• Displaying auxiliary information

• Displaying error messages

• Python commands

Buttons located on the pane toolbar allow:

• Save log

• Clear log

• Execute Python script

Ground Control pane
Ground Control pane is designed for:

• Displaying camera and / or marker coordinates

• Displaying scale bars lengths

• Displaying camera orientations

• Displaying estimation errors

Buttons located on the pane toolbar allow:

• Import / export reference coordinates

• Convert reference coordinates from one system to the other

• Optimize estimation and update data

• Switch between source coordinates, estimated coordinates, and errors views

• Indicate coordinate system and measurement accuracy to be assumed through Settings dialog

Timeline pane
Timeline pane is designed for:

• Working with multi-frame chunks

Buttons located on the pane toolbar allow:

• Add / remove frames from chunk

• Play / stop frame sequence

• Adjust frame rate through Settings dialog

Note

• To open any pane select a corresponding command from the View menu.
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Menu Commands

File Menu  

 New
Creates an empty PhotoScan project.

 Open...
Opens PhotoScan project file.

 Append...
Appends existing PhotoScan project file to the
current one.

 Save
Saves PhotoScan project file.

 Save As...
Saves PhotoScan project file with a new name.

 Export Model...
Saves 3D model.

 Export Points...
Saves sparse / dense point cloud.

 Export Orthophoto...
Generates orthophoto based on the reconstructed
geometry.

 Export DEM...
Generates digital elevation model based on the
reconstructed geometry.

 Generate Report...
Generates PhotoScan processing report in pdf
format.

 Exit
Quits the application. Prompts to save active
project.

Edit Menu  

 Undo
Undo the last editing operation.

 Redo
Redo the previously undone editing operation.

 Delete Selection
Removes selected faces from the mesh or selected
points from the point cloud.

 Crop Selection
Crops selected faces / points.

 Invert Selection
Inverts current selection.

 Grow Selection
Grows current selection.

 Shrink Selection
Shrinks current selection.

 Gradual selection...
Selects faces / points based on the specified
criterion.

View Menu  

 Point Cloud
Displays sparse point cloud reconstructed during
photo alignment.

 Shaded
Displays 3D model in the shaded mode.

 Solid
Displays 3D model in the solid mode.
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View Menu  

 Wireframe
Displays 3D model in the wireframe mode.

 Textured
Displays 3D model in the textured mode.

 Show Cameras
Shows or hides camera positions estimated during
image alignment.

 Show Trackball
Shows or hides the trackball.

 Show Info
Shows or hides the mesh information on-screen
display.

 Perspective/Orthographic
Switches visualisation view between Perspective
and Orthographic.

 Workspace
Shows or hides Workspace pane.

 Timeline
Shows or hides Timeline pane.

 Ground Control
Shows or hides Ground Control pane.

 Photos
Shows or hides Photos pane.

 Console
Shows or hides Console pane.

Workflow Menu  

 Add Photos...
Loads additional photos to be processed by
PhotoScan.

 Add Folder...
Loads additional photos from folders to be
processed by PhotoScan.

 Align Photos...
Generates camera positions and sparse point cloud.

 Build Geometry...
Generates 3D model geometry.

 Build Texture...
Generates 3D model texture.

 Align Chunks
Aligns multiple chunks.

 Merge Chunks
Merges multiple chunks into the single chunk.

 Batch Process...
Opens Batch Process dialog box.

Tools Menu  

 Decimate Mesh...
Decimates mesh to the target face count.

 Close Holes...
Closes holes on the model surface.

 Detect markers...
Creates markers from coded targets on photos.

 Track markers...
Tracks marker locations across the frame
sequence.

 Refine markers...
Refines marker projections.
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Tools Menu  

 Print markers...
Generates printable PDF file with coded targets.

 Import Mesh...
Imports edited mesh from the external program.

 Import Texture...
Imports edited texture from the external program.

 Import Cameras...
Imports camera positions and orientation data.

 Import Markers...
Imports marker projections.

 Import Masks...
Imports masks or creates mask from model or
background.

 Export Texture...
Exports model texture.

 Export Cameras...
Exports camera positions and orientation data.

 Export Markers...
Exports marker projections.

 Export Mask...
Exports masks templates.

 Undistort Photos...
Removes nonlinear distortions by warping source
photos.

 Measure Area and Volume...
Displays surface area and volume of the model.

 View EXIF Data...
Displayes EXIF data for the photos in the active
chunk.

 View Matches...
Displayes matches for the photos in the active
chunk.

 View Mesh Statistics...
Collects and displays mesh statistics.

 View Mesh UVs...
Displays mesh UV mapping.

 Camera Calibration...
Shows camera calibration dialog box.

 Preferences...
Shows preferences dialog box.

 Run Script...
Opens Python Run Script dialog box.

Photo Menu  

 Navigation
Switches to navigation mode.

 Rectangle Selection
Rectangle selection tool.

 Intelligent Scissors
Intelligent Scissors selection tool.

 Intelligent Paint
Intelligent Paint selection tool.

 Magic Wand
Magic Wand selection tool.

 Edit Markers
Switches to marker editing model.

 View Points
Shows detected features used for alignment of the
current photo.
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Photo Menu  

 Add Selection
Adds current selection to the mask.

 Subtract Selection
Subtracts current selection from the mask.

 Invert Selection
Inverts current selection.

 Reset Mask...
Resets mask for the current photo.

 Turn Shading On/Off
Turns mask shading on or off.

Help Menu  

 Contents
Displays help contents.

 Check for Updates...
Checks if PhotoScan update is available for
download.

 Activate Product...
Activates / deactivates the product using the
activation key.

 About PhotoScan...
Displays program information, version number and
copyright.

Toolbar Buttons

General commands  

 New
Creates a new PhotoScan project file.

 Open
Opens a PhotoScan project file.

 Save
Saves a PhotoScan project file.

3D view commands  

 Navigation
Navigation tool.

 Rectangle Selection
Rectangle selection tool.

 Circle Selection
Circle selection tool.

 Free-Form Selection
Free-form selection tool.

 Resize region
Volume selection tool.

 Rotate Region
Volume rotation tool.

 Create Marker
Marker placement tool.

 Create Scale Bar
Scale bar creation tool.

 Delete Selection
Removes selected faces / points.

 Crop Selection
Crops selected faces / points.
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3D view commands  

 Undo
Undo the last editing operation.

 Redo
Redo the previously undone editing operation.

3D view settings  

 Point Cloud
Shows / hides sparse point cloud reconstructed
during image alignment.

 Shaded
Displays 3D model in the shaded mode.

 Solid
Displays 3D model in the solid mode.

 Wireframe
Displays 3D model in the wireframe mode.

 Textured
Displays 3D model in the textured mode.

 Show Cameras
Shows / hides camera positions, reconstructed
during image alignment.

 Show Aligned Chunks
Shows / hides aligned chunks.

 Reset View
Resets model view.

Photo view commands  

 Navigation
Switches to the navigation mode.

 Rectangle Selection
Rectangle selection tool.

 Intelligent Scissors
Intelligent scissors tool.

 Intelligent Paint
Intelligent paint tool.

 Magic Wand
Magic wand tool.

 Edit Markers
Switches to marker editing mode.

 View Points
Shows / hides feature points used for alignment of
the photo.

 Add Selection
Adds current selection to the mask.

 Subtract Selection
Subtracts current selection from the mask.

 Invert Selection
Inverts current selection.

 Undo
Undo the last mask editing operation.

 Redo
Redo the previously undone mask editing
operation.

 Rotate Right
Rotates the photo clockwise.

 Rotate Left
Rotates the photo counterclockwise.

 Zoom In
Increases magnification.
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Photo view commands  

 Zoom Out
Decreases magnification.

 Turn Shading On/Off
Turns mask shading on or off.
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Appendix B. Troubleshooting
Photo alignment succeeds, but the resulting
camera positions appear to be wrong

The main reasons for the wrong photo alignment are listed below:

• Small overlap between the photos

• Object movement against the background scene

• Insufficient number of object surface details captured by the camera

• Strong blur or noise on the source photos

To obtain more information about the reason for alignment failure for the specific dataset it may be helpful
to inspect feature points used for alignment of the photos as seen by the PhotoScan algorithms.

To inspect feature points used for alignment

1. Open the photo to be inspected by double-clicking on its name on the Workspace pane. The photo
will be displayed in the main window.

2.
Switch to the point view mode using  View Points toolbar button. The points used for alignment
of the photo will be overlayed on the image.

Depending on the observed point placement the following recommendations may help to solve the
problem:

Problem Possible reason Recommended solution

Not enough points were
used.

Low image quality or
too small photo overlap.

Try making better photos with a better camera
placement. Pay attention to the camera settings,
like proper level of ISO. Use a tripod if required.
Setting a proper lighting may be also helpful to
capture higher amount of surface details.

The majority of points
used belong to the
background objects.

The object was not static
during capturing or
occupies only a small
area on the photos.

Mask out background regions or consider
shooting another photo set so that the object spans
significant area on the photos. If masking of the
background areas is used, make sure that Constrain
features by mask option in the Align Photos dialog
box is checked.

Reconstructed geometry appears to be cut and
some important parts are missing

Usually this indicates that a wrong reconstruction volume was selected. By default PhotoScan uses an
automatic reconstruction volume selection algorithm, which can produce undesirable selections in some
cases. All object parts outside of the selected reconstruction volume are cropped and are not included in
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the final model. Too large reconstruction volume selections are also undesirable as they result in longer
processing time and greater memory consumption.

To overcome this problem a manual reconstruction volume selection tool should be used.

Note

• The photos must be aligned before the reconstruction volume can be defined.

To select the reconstruction volume manually

1.
Select the manual reconstruction volume selection tool using  Select Volume toolbar button.

2. Modify the displayed bounding box by dragging the corners of the box to the desired locations.

3. Before starting to reconstruct geometry make sure that Selection option is chosen from the
Reconstruction volume drop down list.

The photos included in the project file can't
be opened and operations from the Workflow
menu fail

Probably the locations of photos have changed in respect to the location of the project file. The references
to the original photos are stored in the project files in the form of relative paths. These references become
invalid when the project file alone is moved to another location, or when the photos are moved without
changing the project file placement.

To change the relative paths to the photos

1. Open the context menu of the photo by right-clicking on its title in the Workspace/Photo pane.

2. Select Change Path... command from the context menu.

3. Browse to the folder containing the photo, select it and click OK.

4. Apply to the active chunk or to the entire workspace if all the photos are located in the same folder.

Alternatively, you can move either photos or the project itself with the purpose to make relative paths
valid while keeping them the same.

To identify the expected photo location

1. Open the context menu of the photo by right-clicking on its title in the Workspace pane.

2. Select Show Info... command from the context menu.

3. A dialog box with information on the selected photo including the path to the image data file will
be displayed.

To fix the problem move the photos to the original locations indicated by the data displayed in the
information dialog box.
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If the relative location of the project file in respect to the photos location must be changed, the project file
should be resaved using the Save As... command from the File menu.

To move the project file in respect to the source photo locations

1. Open the project to be moved using Open... command from the File menu.

2. Select Save As... command from the File menu. Browse to the folder where the project file should be
placed and specify the destination file name for the project. Click Save button to save the project.

Once the project file was saved to a new location, the original project file can be removed, if necessary.
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