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AMPView 

Welcome 

AMPView is a Finite Element pre and post processor with interactive graphic interface. It is 
planned to be the link between the meshes that we generate from solid models in AMPSolid 
and the full range of data required for a Finite Element Analysis. The user may call our 
AMPSol solvers directly from AMPView or generate data for another F.E.Solver. This manual 
is organized with an overview in the introduction section. Then each of the top menu items is 
fleshed out in individual chapters. This is followed by several tutorial examples. Throughout the 
manual we will be using a quarter gear solid generated in AMPSolid and stored as gear_st.dat. 
The _st denoting that it is a file for the stress and thermal analysis of the quarter gear. 
 
In the description of the menu options we will make use of several prefix symbols. We will use 
the ">" symbol to denote a sub-menu. The "||" and "&&" symbols for "or" and "and" will also be 
used where appropriate. 
 
The online reference manual is provided in a context-sensitive manner such that if you use the 

 icon to place on the menu or item, it will provide the most relative help associated with the 
subject.  You can also hit the function key F1 to get the immediate help content or go to the 
"Help" to browse the complete reference manual. 

Introduction 

The AMPView program is unique in the sense that it allows the user to select mesh entities in 
two ways. The first method is to allow selection by using the geometric entities of the solid 
model used to create the mesh in AMPSolid. The second method uses the finite element 
entities to define the model for analysis. The first method is the preferred method because it 
allows a full analysis model to be defined without tying it down directly to nodes and elements. 
As a result, the mesh for a particular solid model can be changed without requiring changes to 
the AMPView data file (.dat). 
 
The AMPView features can be explained by looking at the top menu in Fig. 1.1. 
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Moving from left to right: 
1. File. The file menu controls the import and/or export of data as well as the usual opening 

and printing of data. The AMPSol analyzers are run from this menu. 
2. Selection. Implements the actual selection of the Geometric and/or F. E. data. The user 

may choose to access elements and nodes in both groups as well as individual items. 
3. AMPSol. Allows the user to create data for the control of the F.E. Analysis, specify 

boundary conditions under cursor control, define material behavior through graphic 
selection and finally to create and update a material library. The data definition follows a 
consistent pattern. A geometric entity is first defined (selected) graphically. This is followed 
by appropriate selection of the type of condition that is to be attached to it. Finally the 
nonlinear version is controlled by increments in time. Static incremental loading is 
controlled in pseudo time steps. Previously defined data can be edited and reviewed 
graphically. 

4. AMPSol RESULT. This controls the post-processing of data from a AMPSol Analysis. The 
user selects the type of data to be plotted. The display can be in deformed or undeformed 
mode including animation. Finally the user may slice the solid to view internal elements. 
This menu also includes an FE inquirer that is a feature for inquiring and plotting values 
and/or time history at a particular node. 

5. Finite Element. This is the detailed control of display/grouping/create/delete and 
import/renumbering of finite element and nodes.  

6. View. This menu controls the nitty gritty of graphic display such as zooming, background 
colors, lighting and etc. 

7. Display. This also controls the details of the view. The type of projection and the 
handedness of the axis. 

8. Options. This controls the F.E. details of the display. The user may specify nodes or 
element faces, edges and other similar details. 
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9. Windows. This gives the usual Windows controls as well as the display of toolbars and 
status bars. 

10. Help. This provides the user with this document online as well as context sensitive help 
that is menu dependent. 

 

Some of the menu items have been implemented as icons. Their purpose and function are 
explained below. As usual all clicking is done with the left mouse cursor. Also, as the standard 
of the Windows application, these icons can be dragged and placed to any user-desired 
position. This is usually necessary if you have a very small screen, or working on a notebook 
with limited screen size. To move these icon base, just drag the frame containing the icon to 
the desired position.  If you drag these icon bars away from AMPView's border position, they 
become floating icon bar and can be placed on any screen position to increase the working 
window size. To move these icon bar back, simply drag them back to any border and "dock" 
them 

File Menu 

The File Menu 

The file menu is shown below. 

  
 

The current version of AMPView is designed to handle a single model, but can have multiple 
views for model display. This is due to the internal animation control design. If the user desires 
to view a different model, the current model will need to close and the new model opened, or to 
activate another instance of AMPView and examine the new model there.  
 
File>Close||Save||Save As 
These sub-menus follow the usual Windows functions. The mesh data is read in by opening 
the appropriate .dat file generated from the solid model in AMPSolid. 
 

Analyze Model 
File>Analyze Model 

This starts the AMPSol F. E. analysis of the current model. Any edited files that will be used 
here should be saved.  It is suggested after the AMPSol F.E. analysis is finish, the user 
examines the analysis log to check for possible analysis warning or error.  It is also suggested 
to close the AMPSol analysis widow to conserve memory usage. 
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Read AMPSol Result 
 

File>Read Latest Result 
This instructs the program to read in the AMPSol results from an analysis in preparation for 
post processing of the AMPSol Results.  For an analysis contains several time steps, it is not 
necessary to wait for the analysis to finish. Instead, as soon as a step result is finished from 
the AMPSol analysis windows, clicking this button will read the existing finished step results. If 
the analysis is of eigen analysis types such as modal or buckling analysis, then a separate 
result file can be read to for eigen mode examination. 
 
File>Read AMPSol Result… 
This menu is for precise reading of the result for either the standard output file, or to 
alternatively read in the modal, buckling, or eigen analysis result. 
 
File>Copy to Clipboard 
This copies the current scene image into the Windows' clipboard area as a standard clipboard 
meta file.  The user can then insert this into other application if they accept the standard 
clipboard format. 
 
File>Print||Print Preview||Print Setup 
These also follow the usual Windows functions and need not be defined here. 
 
File>Previously accessed files 
The last ten files used are listed here. 
 
File>Exit 
This terminates the use of AMPView. The user is prompted to save all files created or 
changed. 
 

System Storage Files 

In order to achieve a seamless integration between our three programs, we have implemented 
a common database that is shared among all our programs. The storage of model information 
has however been split up into several functional files to give the user maximum flexibility in re-
using previously defined data as well as minimum work in creating similar models. The 
following files are used. 
 
1. The *.sat file. This file stores the solid model data in ACIS format. It is used and optionally 

created in AMPSolid. 
2. The *.flx file. This file stores the flex cell data that represents the flex cells that were 

created at any stage of the mesh generation. When the mesh generation process is 
comp0lete in AMPSolid, the flex cell keeps the final mesh data. 

3. The *.fe file. This file contains the raw mesh data. Its format is dictated by the VSMesh 
program, which can be tailored by each user to fit a FE program of choice. 

4. The *.geo file. This file stores the solid model entity mapping to the FE mesh. This file 
changes with each mesh. The user is advised to give each mesh generated a unique 
name. 

5. The *.dat file. This file is the model file. It contains the model data created in AMPView. 
The user is also advised to create a different file for each mesh. The previously defined 
data can be copied by saving the original file in the new name. 
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6. The *.out file. This stores the result of the FE analysis with the AMPSol Solvers. It is 
created in the solvers but also used in AMPView for post-processing. The results are 
stored at the nodes. 

7. The *.rs file. This file is created for restart analysis. At the end of an analysis, the program 
stores the state of the program for later restart analysis. 

 

Selection Menu 

The Selection Menu 

The selection menu gives two ways to pick the finite element entities. The first selects the FE 
entities by choosing solid model entities. The second selects FE entities directly. The first 
method gives the user flexibility in altering the mesh without having to change the other model 
data. All selections are indicated by a change in color of the entities changed. The menu is 
shown below. 

 
 
All selection implementation inside AMPView follows the Windows' selection guideline as 
commonly used in most Windows application.  To add an item to the selection list, hold the 
"SHIFT" key while clicking the left mouse button on the object.  To toggle the selected item in 
the current selection list, hold the "CTRL" (Control) key while clicking the left mouse button.  In 
this toggle mode, an item in the selection list will be removed if it has already been selected, or 
it will be added if it is not in the selection list.  If you click the left mouse button along, the 
selection buffer is first cleared, then the selected item is then added to the selection buffer. 
 
The selection process as described is a very typical operation in all CAD/CAE programs. It is 
much easier to think of the selection as a "state", and there is a selection buffer associated 
with each state. The selection is usually stored in the database index such as material index or 
boundary condition geometry index.  When you revisit the setting by selecting the geometry or 
material index, the selected items stored are immediately recalled into the current selection 
buffer and highlighted. You can then toggle the selection item to add/remove from the current 
selection buffer, and then save the modified selection.  The ability to recall/store/modify the 
selection items is very powerful, especially when there are items in a complex model that are 
hidden, and you can not see it or select it at one time. 
 
When lots of geometry faces/sides are hidden, and you want to make a very complex selection 
for boundary condition geometry items or material definition,  you want to build up the selection 
items in sequence.  You first select/save the first item and store the selection in the 
geometry/material index desired.  After that, unhide/hide till the subsequence face or geometry 
face is shown, then go back to the stored index that you want to add to it. The instance that 
you select the index that you want to modify, the previous existing selection items will be 
recalled into the current selection buffer and highlighted. You can then add the desired 
selection to the selection buffer then save/store the selection list. 
 

Selection Geometric FE Select 
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The Geometric FE Select is based on selecting from the original solid model entities that were 
used in creating the FE mesh in AMPSolid. This is the most flexible method of selection, 
because it associates specific solid model entities with the finite element mesh entities. When 
the mesh is changed either due to adaptive meshing or requested re-meshing, AMPSolid 
automatically associates the new finite element entities with the solid model entities. The result 
is that FE models created with Geometric FE selections need not be changed when the mesh 
changes. Using their corresponding icons as shown below can also choose the menu options 

 
Multiple entities are selected by depressing the Shift key (for addition to the selection) or the 
Ctrl key (for toggle selection). 
 
Selection>Geometric FE Select>Elements in a body 
This selects all finite elements contained in a solid block.  

 
Selection>Geometric FE Select>Elements on a Surface 
This selects 2D elements. 

 
Selection>Geometric FE Select> Solid Element Faces on a Surface. 
This selects all the element faces that are contained in a solid block face. In conditions where 
nodal quantities are implied (such as fixed displacements); the element faces are in turn 
converted to all the nodes contained in the solid block face. 
 
Selection>Geometric FE Select> Nodes on a surface 
This selects all the nodes on a solid block surface. 
 
Selection>Geometric FE Select> Nodes on a Edge 
This selects all finite element nodes on a solid block edge. 
 
Selection>Geometric FE Select> Element Sides on a Edge 
This selects element sides in a 2D mesh. 
 
Selection>Geometric FE Select> Node of a geometry Vertex 
This selects a single Vertex of a solid block. 
 
Selection>Geometric FE Select> Elements on a Geometry Edge 
This selects all elements on a geometry edge. This is usually for beam/rod elements only. 
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Selection FE Select 
 

 
Fig 3.3 FE Select 

 
This selection selects the Finite Element entities directly. Selection is made either with a cursor 
or by creation of an enclosing window. Multiple entities are selected by depressing the Shift 
key (for addition to the selection) or the Ctrl key (for toggle selection). 
 
Selection>FE Select>Element Only || Elem Face Only || Elem Edge Only || Node Only 
This allows the user to select according to one of the named F.E. entities. The options can also 
be selected from the icons shown below. 
 

  
 
This defines the method of selection that will be used in the geometric entities such as text 
string, cutting plane, etc. 
Finally, to remove the current selection, the user can just make a "empty" selection by clicking 
the mouse button on a window position away from the model, or just click the last selection 
toolbar icon "blue cube" (the cube without any highlight) to remove all selection items. 

Selection Geometry Entity 
 

This selection selects the associated geometry entities directly. Selection is made either with a 
cursor or by creation of an enclosing window. Multiple entities are selected by depressing the 
Shift key (for addition to the selection) or the Ctrl key (for toggle selection). 
 

Selection>Geometry Entity>Geometry Entity Geometry Entity 
This selects by using the cursor. If there is a selectable geometric entity under the cursor, it will 
be highlighted. 

 
Fig. 3.4 Geometry Entity Selection mode 
 
Selection>Geometry Entity>Select Entity by Window 
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The user drags a rectangle window to enclose the required entities on the screen. The 
selection window will show up as soon as the mouse left button is pressed and the mouse is 
dragged. 
 
Selection>Geometry Entity>Delete Selected Entity 
This will deleted the selected geometric object. 
 
Selection>Geometry Entity>Translate Selected Entity 
This will translate the selected geometric object. The use of this function is basically to move a 
geometric entity such as annotation text from one position to another. 
 
Selection>Geometry Entity>Rotate Selected Entity 
This will rotate the selected geometric object about its local axes.  
 
Selection>UnSelectAll 
This unselects the current FE or geometric entities selected. 

Geometric Entities conversion to FE geometry 

The geometric Entities form the Solid Model can be used to select Element faces, sides and/or 
nodes. The FE quantities corresponding to these geometric entities (surfaces, edges and 
vertices) are then used to specify FE geometry for Boundary Conditions as well as material 
definition. The advantage of using geometric quantities is that the models can be built without 
regard to the finite element mesh size or distribution. That is, once the boundary conditions 
and material properties are defined, it is possible to re-apply a different mesh size and still use 
the same boundary/material definition that have been applied on the geometric entities.   
This is especially important when adaptive meshing control is used since the mesh will either 
be refined during the analysis, or possibly refined by the user manually. In such case, the 
definition of the boundary condition and material properties will applied only to the geometry 
face/edge/body, and not to a specific finite element mesh.  This is also convenient when 
testing a model since a coarse mesh can be built and quickly tested. Once the model behavior 
is achieved, the user can just refine the finite element mesh size (as defined in the *.fe file) and 
still use the same model definition file (defined in *.dat file). 

 

Analytical Geometry 

Selection>Analytical Geometry 

 
Fig. 3.5 Analytical Geometry Menu 
 
During analysis, sometimes an analytical geometry is needed for geometrical boundary 
condition, e.g. contact.  This session allow the user to define the analytical geometry for 
analysis use. 

Geomtry Line 
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Selection>Analytical Geometry>Line 

 
Fig. 3.6 Analytical Line Geometry 
 
Analytical geometry line is defined by using a point and a direction vector.  If the length of the 
line is left to be the default value zero, the line is a infinite long line. Otherwise, it is a finite line 
segment.  
Geometry line can only be used in 2D contact analysis. When a line is used as the auxiliary 
geometry for contact analysis, the contacting side must be defined by either the left side or the 
right side of the line from the starting point of the line.  The line can also move in the time/step 
analysis along this normal direction by using time movement scaling index.  In such case, the 
line moves laterally, and the movement magnitude is controlled by the time scaling factor.  

Geometry Plane 

Selection>Analytical Geometry>Plane 

 
Fig. 3.6 Analytical Plane Geometry 
 
Analytical geometry plane is defined by using a point and a plane normal vector. The plane 
passes through this point with a normal direction as specified. 
When a plane is used as the auxiliary geometry for contact analysis, the contacting side must 
be defined by selecting either the side along the normal direction, or the reverse side. The 
plane can also move in the time/step analysis along this normal direction by using time 
movement scaling index.  In such case, the plane moves laterally, and the movement 
magnitude is controlled by the time scaling factor. 
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Selection Filter 

Selection>Selection Filter 

  
 
The selection filter is usually used to select the face that is hidden under another face or faces. 
It is usually useful turn on the Display/UseTransparency when this option is activated to 
confirm the internal face selection. 

 

The Model Menu 

The Model Menu 

This menu allows the user to specify all the system controls, material properties and boundary 
conditions for a F.E. Analysis. The top sub-menus are shown in Fig. 4.1. The AMPSol solvers 
share the AMPView database so their input are defined seamlessly by the AMPView menus. In 
developing the AMPSolid and AMPView GUIs the developers had an objective of allowing the 
user to perform visual analysis where an FE Analysis is carried out interactively and with no 
reference to element and nodal details. It is for this reason too that the user will not find a 
User's manual for the AMPSol Solvers. The use of the program is in fact embedded in the 
documentation of the Interactions in AMPView. The Appendix On AMPSol Capabilities will 
summarize the features available in the AMPSol Solvers.  

  
Fig. 4.1 The Model Menu 
 
The user should note the convention for creating the model data here. The options below the 
top menu are called sheets. Thus we have the System Sheet, the Define Sheet and the 
Conditions Sheet. The options below the Sheets are called Pages. If there are finite element 
entities to be selected, we usually start the definition by selecting a geometric F.E. entity from 
the Geometry Page. AMPView turns this entity into a list of elements (elements, faces or 
edges) or nodes. The appropriate condition or material is then selected from a Property page 
and attached to the geometric entity. Both the geometric selection and the specified conditions 
can be reviewed and/or edited. 

Model/System Menu 

The Model/System/Controls Menu 

This menu enables the overall F.E. Analysis Controls to be set. 
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Fig. 4.2 The Model>System >System Control Page. 
 
Model>System>Controls>Title 
The user starts by giving a title for the analysis. 
 
Model>System>Controls>Multi-Physics>Continuum Stress||Thermal Temperature||Fluid 
Flow||Electro||Magneto||User Defined 
The checked boxes here allow a combination of the selected Physics. The grayed check boxes 
are due to either unavailable license or unreleased options. If the electro-field is activated, it is 
necessary to specify whether the analysis is based on a conductive potential-current analysis 
or a dielectric potential-electric field Intensity analysis.  

 
Model>System>Controls>Solution Controls 
The user is allowed to select from one of the options in this sub-menu: 
 
Static/Steady state 
This specifies a static or a steady state solution is desired. 
 
Transient Dynamic Response 
This specifies an analysis by step-by-step integration in time. 
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Followings are the available eigen analysis types: 
 

Free Vibrations Modal Analysis 
This performs a standard modal analysis to extract the desired modes of vibrations. The 
generalized eigen problem is K -λM = 0, where K is the system stiffness and M is the 
consistent mass matrices. The natural frequency ϖ is computed from solution ϖ = sqrt(λ), and 
will be recorded in the solution file (with filename extension ".eig"). 
 
Modal Vibrations Analysis with Stress Stiffening 
This performs a standard modal analysis to extract the desired modes of vibrations. Before the 
modal analysis, a static analysis is performed and the stress stiffening effect is included for the 
modal analysis. The generalized eigen problem is (K+Ks) -λM = 0, where Ks is the additional 
stress stiffness matrix computed during the initial static analysis. 
 
Thermal Harmonic Modal 
This calculates the thermal harmonic modes of temperature patterns. The generalized eigen 
problem is Kc -λMt = 0, where Kc is the system conductivity matrix and Mt is the consistent 
thermal mass matrix formed by scaling the consistent thermal mass matrix by the thermal heat 
capacity 

 
Euler Instability Buckling 
This calculates the linear Euler buckling modes of the system. The generalized eigen problem 
is K -λKs = 0, where K is the system stiffness and Ks is the stress stiffness matrix. 
 
Linearized Instability Buckling with Geometric Stiffness 
This is a linearized predicting of the nonlinear buckling load calculation. The initial geometric 
stiffness Kg is computed based on the given loading, then the generalized eigen problem of 
(K+Kg) -λ(Ks+ Ks') = 0 is solved. Ks' is the 2nd order stress stiffness matrix based on the 
geometric deformation.  
 
In-Situ Eigen Analysis 
After either a successful static or dynamic analysis, the user can specify to perform either a 
modal or an instability buckling analysis in the same analysis. Although it is possible to restart 
the problem and then specify an eigen analysis, this is a convenient method of performing "in-
situ" eigen analysis.  In such way, the "in-situ" stiffness and mass matrices (or the stiffness and 
the stress stiffness matrices) represent the state at the end of the analysis, and the eigen 
solution give the "in-situ" prediction of the eigen problem. 
For the in-situ modal analysis, the generalized eigen problem is Kt -λM = 0, where Kt is the 
system tangent stiffness matrix. For the in-situ instability buckling analysis, the  generalized 
eigen problem is Kt -λKs = 0, where Ks is the stress stiffness matrix based on the finished 
state. 

 
Dynamic Frequency Response/High Frequency Analysis 
This specifies a frequency domain steady state solution is desired. 
 
Explicit Dynamic Analysis 
Use Explicit Central Difference Method as the transient dynamic analysis method rather than 
the default implicit method. 
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Model>System>Controls>Solution Controls>Eigenvalue Analysis Specific/No of Modes. 
The user specifies the number of eigen modes to be computed.  All eigen analysis will have 
their eigen modes and eigen values result recorded in the eigen solution file (with filename 
extension .eig).  
 
Model>System>Controls>Dimension>3D || 2D Plane Strain || 2D plane Stress ||2 ½ D 
axisymmetric. 
This specifies the geometric dimension of the analysis. Note that for 2D analysis, only the first 
two coordinates of the nodal position data will be used. Effectively, the model should only be 
construct on XY plane if 2D analysis is desired.  In the axisymmetric analysis, the first 
coordinate is the radial dimension.  
 
Model>System>Controls>Geometry Reference Frame Formulation>Small Strain ||Total 
Lagrangian Formulation || Updated Lagrangian Formulation 
If small strain is used, the program will use only the small deformation linear strains in the 
stress calculations. For large deformation and rotation, either Total Lagrangian (TL) or 
Updated Lagrangian (UL) can be used.  The difference between these two large strain 
calculation modes is simply the difference of the reference frame.  The TL always uses the 
original state for the frame of reference, and the UL uses the most recent state of position for 
reference.  In the TL formulation, the Green-Lagrangian strains and the 2nd Piola-Kirchhoff 
stresses are used, while the Cauchy stresses and the infinitesimal strains are used in the UL 
formation with respect to the most recent deformed state. Although the internal stress and 
strain calculated using these two methods are completely different, but the converged results 
will be almost similar since the final result is expressed in the engineering Cauchy stresses 
and strains. 
 
Model>System>Controls>use ALE for coupled Lagrangian Eulerian Analysis 
When the fluid flow region is used along with the Lagrangian solid element, If small strain 
formulation is used, the coupling between the fluid governing Navier-Stokes equations and the 
solid continuum equations are automatically coupled.  However, if large deformation analysis 
option is activated, the Lagrangian solid region will penetrate into the Eulerian flow region, 
especially the solid elements deform very large.  In such case, it is necessary to activate the 
Arbitrary Lagrangian-Eulerian formulation for the fluid region.  For the time being, only the 
updated Lagrangian formulation is supported when ALE method is activated.  The processor 
will automatically relocate the Eulerian fluid node based on the Lagrangian solid elements' 
nodal movement, and will try to smooth out the distortion as much as possible.  In ALE 
analysis, the Eulerian variables' results are spatially mapped into the newly relocated node 
position, and all associated nodal and element variables are carried forward for the 
subsequent analysis step.  Optional controls for the ALE method are the step interval for the 
ALE processing, and the meshing adjustment and smoothing controls. 
 
Model>System>Controls>Enable Multi-CPU Treading 
This will take advantage of multiple CPU's if they are present.  AMPSol FE processor is 
capable of initiating multithread processing whenever possible during the analysis, and the use 
of the threading will take advantage of the SMP feature of operation systems NT and Windows 
2000 that support multiple CPU's. 
 
Model>System>Controls>Available No of Processors 
For multiple-CPU machine, this will show the current count of CPU's.  By specifying a number 
other than the default value, the user can limit the no of CPU's to be used in the multi-thread 
tasks. 
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This section gathers the possible execution options that affect the whole analysis. 
Execution Options Function 
Plane Stress Specify plane stress geometry 
Axisymmetric Specify axisymmetric geometry 
Multithread N threads. This will control the processor usage. 
Acceleration Globally applied acceleration field, subject to time scale if it is 

specified. 
Solver Wave Frontal, JPCG Iterative, direct in-core 
Strain Formulation Small Strain, Total Lagrangian, updated Lagrangian 

The Model/System/Solution Iteration Control 

This specifies the iteration procedure to be adopted. 

 
Fig. 4.4 The Model>System>Iteration Controls page 
 
Model>System>Iteration Control>Solver Controls. 
The user is given the option to choose the type of procedure to be adopted in the initial 
iteration and subsequent iterations in each analysis step.  The sparse direct solver is the 
default selection as it uses the most up to date sparse matrix solution scheme. In general, 
sparse direct solver should be used since there is no approximation involved.  The iterative 
sparse solver allows a solution speed up by a solution error tolerance control, and can usually 
achieve a faster solution time.  
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The frontal direct solver utilizes the element-by-element assembly and factoring technology to 
reduce the memory needed for solving large problems and is provided as a backup to the 
sparse direct solver.  And for extremely large problem with limited memory constraint, the 
element-by-element Jacobian Preconditioned Conjugate Gradient (JPCG) solver can be used 
since it uses a matrix free iteration method, but is generally slower than the sparse iterative 
solver.  
 
Model>System>Iteration Control>Iterative Solver Controls. 
Currently, following methods are available for sparse iterative solver: 
PCG:         Preconditioned Conjugate Gradient method 
BiCGSTAB:    BiConjugate Gradients Stabilized method 
MLBiCGSTAB: a BiCGSTAB variant based on Multiple Lanczos Starting Vectors 
TFQMR:       Transpose-Free QMR (Quasi-Minimal Residual) 
BGMRES:      Block General Minimal Residual 
These sparse iterative methods use an incomplete LU factorization matrix as the 
preconditioner for the iteration method.  Since all iterative solver techniques are sensitive to 
the condition of the equation being solved, it should always be used with small enough error 
control to ensure the solution is correct. The default error_norm for the iterative solver is 1.e-6, 
and the incomplete LU factoring skip tolerance is automatically determined based on the ratio 
of the minimum to the maximum diagonal of the equations. This setting is found to be a reliable 
technique from our empirical testing, and this default setting handles well for most problems 
including shells, high order p element and general problems. In general, this error norm can be 
lowered to around 1.e-4 for most problems to speed up the solution time.  For most problems, 
this factor_tol is generally found to in the range of 1e-2 to 1e-8. If necessary, the user can 
overwrite the automatic setting so the tolerance will be computed based on the value of 
factor_tol times the maximum diagonal term of the equations.  Relaxing these tolerances may 
speed up the solution, but the iterative method may not converge and could cause the program 
to stop after reaching its maximum iteration limits. 
Generally, PCG method performs well in most cases, but when it has erratic convergence 
behavior either due to poor preconditioning treatment or ill-conditioned equations due to the 
multi-physics properties, other methods have proven to be more stable. More detailed 
reference about these methods can be found in general numerical methods literature. 
 
Model>System>Solution Control>Time Stepping/Pseudo Time Controls 
For all analyses, the user specifies a time step size, the analysis start time and the finish time 
to control the solution.  In the steady state analysis or static analysis, these time controls are 
pseudo time steps in the sense that they are used to control how the specific boundary 
conditions or loads are applied.  For dynamic or transient analysis, the time controls should be 
the real analysis start/stop/increment that control the analysis.  The program, by default, 
assumes the analysis is static or steady-state and fills in the default values for the user at the 
beginning. 
 
Model>System>Solution Control>Time Stepping/Pseudo Time Controls>Analysis Start/Finish 
Time 
The user specifies the analysis start and finish time here. For restart analysis, the start time will 
come from the restart file, and the start time control will automatically change to the values 
specified in the restart file. 
 
Model>System>Solution Control>Time Stepping/Pseudo Time Controls>Max Iteration limit per 
step, Convergence Error Norm 
This will limit the iteration during a equilibrium iteration in a single step.  An equilibrium check is 
performed to ensure the error norm is under the specified values 
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Model>System>Solution Control>Time Stepping/Pseudo Time Controls>Initial Time Step, At 
Time, Optional Step Size Controls 
The solution starts from the analysis start time, and advances by the specified time step size 
as specified using this step size control.  Other than the Initial Step Size, 3 additional pairs of 
Step Size n/At Time n can be use to specify the step size during the analysis. The actual step 
size used in the analysis is then interpolated from these controls.  Note that the during the 
analysis, results are available at time/steps corresponding to the step size control here too. 
 
Model>System>Iteration Control>Time Stepping/Pseudo Time Controls>Automatic Step Size 
Control 
This is the automatic time step control.  During an analysis step, if the analysis failed to 
converge in the specified error norm, and the "Use Automatic Stepping Controls" check box is 
selected, the program will automatically decrease the time step size and try to solve the 
problem again using this refined step size. This process will continue till a successful analysis 
can be established.  The program then advanced till these refined time steps reach the end of 
original failed step. At that time, the next time step will start again and continue. The user can 
control the maximum/minimum automatic step size that this automatic stepping control is 
allowed to take. 

 
Model>System>Iteration Control>Initial Time/step Increment Size 
This is the initial time/step size control.  When the analysis starts, it will use the specified 
increment size as the initial size. Additional stepping size after the initial time can be set by 
pressing the "Additional Time Stepping Size Controls" button. 
 
Model>System>Iteration Control>Optional Result Output Interval Controls 
Normally, the processor will write a result data set for each successful time/step increment for 
AMPView to display the results. Sometimes, when the time increment is very small as in the 
case of transient dynamic analysis, it is very desirable not to perform the result output per step 
increment, but only to do so after couple more steps.  This button provides a way to specify the 
output interval controls.  In such case, the processor will only write out the results for AMPView 
only after the time/step increment reaches the specified count. 
 
Model>System>Solution Control>Restrart/Initialize from result file / Suppress restart 
support/Neglect Restart File Time Setting 
By checking this box, the user can specify a restart analysis from a previous finished analysis, 
if the restart file *.rs is available.  The user can also suppress the writing of the restart 
information if the available disk space is limited, or the restart ability is not desired. If the 
"Neglect Restart File Time Setting" is set, when the restart file is read, the processor will ignore 
the analysis time stored in the restart file. 
 

The Model/System/Inertia Effects 

The Inertia effects are specified in the following Menu 
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Fig. 4.5 The Model>System>Inertia Effect page. 
 
The user specifies the inclusion of the Mass Effects by means of a checked box. 
If the inertia effect is included, there is the provision to add an Acceleration/Gravitational Field. 
Defining the starting and ending times of such a scaling may scale the applied accelerations. 
Provisions are made for additional time/step to scale the accelerations, and there is no limit to 
the number of the intermediate scaling factor sets. 

The Model/System/Reference Frame Controls 

The Reference Frame Controls in the following Menu 
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Fig. 4.5 The Model>System>Reference Frame. 
 
When the model is spinning about a certain axis, and the interest of the analysis is in the 
behavior relative to this rotational frame, it is easier to solve the problem by attach the frame of 
reference to the model. The Rotation Reference method is one of the most commonly used 
methods for this type of spinning motion analysis.  
When the Rotational Reference Frame is used, the boundary conditions and the computed 
results are referred to the spinning reference frame with the specified rotational speed.  In the 
rotational reference frame formulation, the acceleration of the continuum/fluid is: 

xdtdxvtv ×Ω+×Ω×Ω+×Ω+∂∂ /)(2/  

The symbols x and v are the position and velocity vectors with respect to this spinning 
reference frame, and Ω  is the rotation axis vector. Note that when large deformation effect is 
included, the position vector refers to the updated position. The term v×Ω2  is the Coriolis 
acceleration effect, and )( x×Ω×Ω  is the centrifugal acceleration effect.  Since the reframe 
of rotation is fixed with a given rotation frequency, the last term vanishes in the steady state 
solution. 
 
The data needed for this Rotation Reference Frame formulation are: 
Center of Rotation: this is the origin of the rotation frame. 
Axis of Rotation: this refers to the vector about which the reference frame is spinning. 
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Rotation Speed in RPM: this is the scalar number of the rotation speeds in revolutions per 
minute. 
Include Centrifugal Effect: this is the check box for the additional control to include/exclude 
the centrifugal effect. 
Include Coriolis Effect: this is the check box for the additional control to include/exclude the 
Coriolis effect. 

 
Finally, a scaling factor is allowed to defining the starting and ending times of the rotation 
speed effect. Provisions are made for additional time/step to scale the accelerations, and there 
is no limit to the number of the intermediate scaling factor sets. 

The Model/System/Adaptive Controls 

The adaptive controls are specified in the following spreadsheet page 

 
 

The Model>System>Adaptive Controls>Use h-Adaptive, Use p-Adaptive 
Active the h-Adaptive and/or p-Adaptive refinement.  The default setting will be used.  
 
Possible setting for h_Adaptive are: 
 
The Model>System>Adaptive Controls>Automatic h_Division Based on Error Estimate 
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When this default h-Adaptive option is selected, each element will be divided according to the 
error estimated computed, could be different in each spatial direction.  Currently, up to 5 
division in the each direction is supported. If an element is split, the neighboring element will 
also be divided to match the mesh conforming criterion.  Note that if there is a triangular face, 
each side can only split into 2 division.  
 
The Model>System>Adaptive Controls>Uniform h_Division Based on the Highest Error 
When this h-Adaptive option is selected, all elements are divided based on the highest element 
error.  This will generate large amount of elements. 
 
The Model>System>Adaptive Controls>Uniform h_Division as Specified 
When this h-Adaptive option is selected, all elements are divided based on the specified 
division (in each element direction). For example, specifying 2 will split a 2D QUAD4 element 
into 4 QUAD4 elements.  
 
Possible setting for p_Adaptive are: 
 
The Model>System>Adaptive Controls>Use Specified p_Order 
When this default p-Adaptive option is selected, each element will be transform upward or 
downward into a 2nd order Lagrangian family elements of QUAD9, HEXA27, TRI6, SHELL6 
accordingly. This default setting is used since they produce the fastest error convergence with 
the least amount of problem size based on empirical tests. Currently, the highest p_order 
supported is three since beyond that further mesh refinement is usually more desirable rather 
than polynomial order increase. If triangular-faced elements are detected, the maximum 
p_Order can be used for such face is two on such elements. 
 
The Model>System>Adaptive Controls>Inrease p_Order as Specified 
When this p-Adaptive option is selected, the element family is increased by the p_Order 
amount specified. For example, when p_Order is one, QUAD4 will turn into QUAD9, and 
HEXA8 will become HEXA27. 
 
The Model>System>Adaptive Controls> Highest Automatic p_Order 
When this h-Adaptive option is selected, all elements are transformed into the highest 
polynomial order (three for the current version, unless triangular-face elements are detected. In 
such case, the highest possible order is two). 
 
The Model>System>Adaptive Controls> Refinement Target Error Norm 
The mesh error of the analysis is based on the assumption that the error norm can be 
computed from the approximation 

||e|| ∝ h**p 

Where ||e|| is the computed error_norm from AMPSol based on the energy error estimate, with 
h being the mesh size, and p being the element's polynomial order.  The target h and p can be 
computed based on the specified error_norm ||e|| desired. 
 
The Model>System>Adaptive Controls> Step Interval for New Refinement 
This specifies the step interval when a refinement should take place for a time stepping 
analysis. In such case, the current step result is mapped into the new mesh, and the analysis 
starts from the refined mesh based on the interpolated results generated from the current step. 
Since mesh refinement could generate large amount of elements and nodes, care should be 
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taken to limit the maximum amount of mesh refinement step allowed (see Maximum Mesh 
Refinement Allowed).  
During such time/step analysis, new models will be generated when a refinement interval is 
encountered. If the original model name is "old_model", and the count of the refinement is N, 
the new model generated will be stored as "old_model_hpN" (for both h-/p-Adaptive), or 
"old_model_hN" (for h-Adaptive only), or "old_model_pN" (for p_Adaptive only). 

 
The Model>System>Adaptive Controls> Maximum Mesh Refinement Allowed 
This specifies the maximum mesh refinement process can take place during an analysis. After 
reaching this limit number, the mesh refinement process will be skipped. 
 
The Model>System>Adaptive Controls>Restart Analysis after Refinement (single step or linear 
problem) 
Instruct AMPSol to restart the analysis using the refined mesh.  This should only be used for a 
single step linear problem.  Also, this option can not be used in conjunction with a restart 
analysis (see Model>System>Solution Control) since the older result file will not contain the 
refined mesh result. 
 
The Model>System>Adaptive Controls> Optimize Mesh After Refinement 
This control specifies a mesh optimization should be immediately performed on the refined 
mesh to minimize the runtime memory requirement and speed. 
 
The Model>System>Adaptive Controls> Refine Mesh Base on Current Error Norm Now 
If an analysis result is available, a new refined mesh can be generated based on the analysis 
error term.  The new mesh will be created based on the current adaptive controls, and a new 
model will be generated. If the original model name is "old_model", the new model generated 
will be stored as "old_model_hp0" (for both h-/p-Adaptive), or "old_model_h0" (for h-Adaptive 
only), or "old_model_p0" (for p_Adaptive only). 
 

The Model/System/Unit Scaling Controls 

The adaptive controls are specified in the following spreadsheet page 
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The Model>System>Unit/Scaling 
This is the optional menu for unit scaling.  Since AMPS product is designed to allow the user to 
choose their own units specification, there is no additional unit conversion used in all 
calculations. However, to facilitate the ease of using data from different CAD/CAE system, the 
unit scaling options are provided to convert the input data into the appropriate unit in 
computing. The conversion is process as: 
 

New data = (input data * scaling) + offset 
 

Currently, only length conversion is active as of AMPS version 3.0. 
 

Time/Step Dependent Data Control 

This is a general data entry table for time/step dependent data control.  By entering the specific 
time/step value with the desired data value and pressing the "Add/Update" button, the data set 
will be recorded and sorted in an increasing order. To modify the data, move the mouse cursor 
into the data display area and click on the desired data to modify. The entry's values will be 
retrieved into the current editing entry area for modifications.  To delete an undesirable item, 
simple choose the item and press the "Delete Selected" button. The "Delete All Entries" button 
will clear all data entries. 
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Model/Define Menu 

The Model Define Properties Menu 

The Model> Define>Element Properties Menu is shown below 
To use this define operation, the user starts by selecting the geometry to be defined, then 
create/change the appropriate material index and name, then assign the element behaviors by 
selecting the proper "Constitutive Behavior"  check boxes. Additional pages will appear when 
new Constitutive Behavior is used for entering the actual material data. 

 

  
Fig. 4.6 The Model>Define>Element Properties page 
 
When a material is assigned to a selected geometry region, the region changes its color to 
indicate that there is a material property assigned to the elements associated with the 
geometry. At the bottom of this Define Sheet, there is a Mat ID/Name pull-down list for 
convenient direct access to the already defined material properties with the associated 
material region color. There are also "Previous" and "Next Mat ID" buttons to quickly navigate 
through different material indexes. 
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When a geometry region has no material association, a grey color is assigned to the geometry 
to indicate that it needs to be defined. The region with material properties already defined will 
show up with color matching the current Mat ID to easy identification. 
 
Model>Define>Element Properties>Material Index (Mat ID) 
This index is the number assigned to the material defined under Element Behavior. This index 
is assigned when the user use the "New Mat ID with Selected Geometry" button, or can be 
changed by directly entering an index number, or by pull down the dropdown list, if available. 
 
Model>Define>Element Properties>Name 
This is the user defined material name for the selected geometry region. By default, it is 
assigned as "User n" where n corresponds to the Mat ID, and the user can change this name 
into a more meaningful way to identify the material region. 
 
Model>Define>Element Properties>New Mat ID with Selected Geometry 
Use this button to create a new Mat ID and apply the new material index/name to the selected 
geometry regions. The user will generally select the geometry (usually the BodyElement or the 
FaceElement geometry) and click this button. If the selection buffer is empty, a new material is 
created with no associated geometry. 
 
Model>Define>Element Properties>Update Mat ID, add Selected Geometry 
Use this button to add the selected geometry to the current Mat ID.  If the Mat ID specified 
does not exist, it will be created with the Name as specified. 
 
Model>Define>Element Properties>Delete Material Index 
This button can be used to delete unused material type.  If there are regions using this material 
Index, their material index association will become undefined. 
 
Model>Define>Element Properties>Undefine Geometry for Mat ID 
Press this button to make all existing geometry items associated with the current material 
index Mat ID to become undefined in material definition. Their default material color will 
become a grey undefined color. 
 
Model>Define>Element Properties>Show Only Mat ID / Select Mat ID 
These two check boxes are mainly for material association review. If "Show Only Mat ID" is 
selected, only the geometry associated with the current Mat ID will be displayed. The "Select 
Mat ID", when selected, will automatically select the geometry associated with the current Mat 
ID so it will be shown with a highlight color. If the global "Display/Zoom to Selection" function is 
active, the selected geometry will be properly placed in a zoom mode that fits all elements in 
the material region. 

 
Model>Define>Element Properties> Show Selection / FE Grouping 
The will bring up the "FE Group/Display" dialog box so the user can examine the selected 
elements, geometry items, or groups.  This is usually for confirming the visual geometry 
selection items with the underlying element or geometry numerical information. For detailed 
information, please refer to the Finite Element/FE Group/Display control. 

 
Model>Define>Element Properties>Constitutive Behavior>Cointinuum Stress || Thermal Heat 
Transfer || Fluid Flow || Electric Potential || Magnetic Field 
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These check boxes are for selecting the type of constitutive behaviors.  Multiple element 
behaviors can be selected if the elements are to be used for multi-physic simulations. The 
grayed out items are either the existing license does not allow it, or not implemented. When a 
material physics is activated, the spreadsheet will add more pages to allow the input of the 
material data. 

 
Model>Define>Element Properties>Integration Control>Element Default || Gaussian Scheme || 
Lobatto Scheme || Reduced Integration || B-Bar with Hourglass Control 
This selects the numerical integration scheme to be used.  Using the default scheme is 
recommended since the material group could contain different elements. The available 
methods are the Gaussian, the Lobatto, the Reduced, and the B-Bar with hourglass control 
schemes. These different integration schemes generally produce the same results when the 
element meshes are refined. When the mesh is coarse or when extremely nonlinear 
geometry/material properties exist, some schemes could improve the accuracy. For different 
type of elements, the default integration is selected for best performance, e.g. B-Bar for low 
order HEX8 or QUAD4 elements, Gaussian for TETRA4, TETRA10 TRI3, and TRI6 elements. 
 
Model>Define>Element Properties>Planar/Plane Stress/Shell Thickness 
Specify the planar type model, plane stress or shell element thickness. If not specified and the 
planar, plane stress or shell model is used, it is defaulted to be a unit thickness, the same as 
the default thickness values of 2D problems. 
 
Model>Define> Element Properties >Initiate Material Data from Library 
If the material data had previously been defined in the material Lib. Simply selecting from the 
drop down list may specify the material.  In such case, the field associated with the material 
library data will be initialized. Note that the material library may not contain all information 
needed to initialize the needed data for analysis. 
 
Model>Define> Element Properties >Apply 
If the material data are changed, this button will become active. Pressing it will save the 
changed data back to system memory. To permanently save the changed model, the user still 
need to use File/Save command to save it back to the computer storage. 

 

The Model Define Element Behavior - Stress Menu 

This menu spreadsheet is shown below. This dialog page is mainly for assign the associated 
material properties to the material index type. 
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Fig. 4.7 The Model>Define>Element Behavior page 
 
Model>Define>Element Behavior>Material Property Index 
This index is the number assigned to the material index. This index can be changed by directly 
entering an index number, or by pull down the dropdown list. If available, and select one from 
the list. 
 
Model>Define>Element Behavior>Add/Apply/Update/Delete Material Index 
The desired material index is selected from the dropdown list or by entering it at the editable 
index space.  After entering all associated information, clicking the Apply/Update button will 
update the material information of the material index selected.  If "add" option is used, a new 
index is created by adding one to the highest existing material index, and then the data 
entered are then saved. The "delete" button can be used to delete unused material index type, 
and the associated material data.  
 
Model>Define>Element Behavior>Constitutive Behavior>Isotropic Elastic 
This specifies an isotropic elastic property. 
 
Model>Define>Element Behavior>Constitutive Behavior>von Mises Plastic 
This specifies the metal Von Mises plastic behavior.  The isotropic hardening and/or kinematic 
hardening options can be used together with this plastic material model. 
 
Model>Define>Element Behavior>Constitutive Behavior>Platic Mohr Coulomb 
This specifies the cohesive material with cohesion and the friction angle.  The friction angle 
should be between 0 and 90 degrees. 
 
Model>Define>Element Behavior>Constitutive Behavior>Incompressible Mooney Rivlin 
This specifies the hyperelastic Mooney Rivlin incompressible material model. The C1 and C2 
coefficients define the strain energy equation 
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W = C1 (I1-3) + C2 (I2-3) 
Where I1 is the first principal strain invariant, and I2 is the second principal strain invariant.  
When C2=0, the model degenerated into a neo-Hookean material. More information about this 
material model can be found in "Finite Element in Nonlinear Continuua", J. T. Oden, or other 
popular references. 
 
Model>Define>Element Behavior>Constitutive Behavior>User Constitutive Material Model 
This specifies the material model is defined in the user-supplied material model routine. 
Additional material property data can be stored and passed into the user-defined routine by 
clicking the button "User Constitutive Material".  When this option is used, the user is 
responsible to carefully define the constitutive material model following the model development 
guideline. Details of the user-defined material model can be found in the AMPS User 
Application Interface Reference Manual. 
 
Model>Define>ElementBehavior>Young's Module, Poisson's Ratio, Linear Expansion Coeff., 
Mass density. 
Specify the isotropic material's stress property, the mass property is necessary only if inertia 
effect is included, or a modal or dynamic response is active. 
 
Model>Define>ElementBehavior>Mass Damping Coefficient 
This is the damping coefficient applied to the mass matrix to for computing of the damping 
matrix. This hysteric damping coefficient can be found using the Rayleigh damping matrix 
formula from the damping factor.  If the Rayleigh damp matrix C is 
 
C = a0 M + a1K 
 
Where M is the FE mass matrix and K is the stiffness matrix, then the mass damping 
coefficient a0 can be computed from 
 

ξ = 0.5 (a0/ω + a1ω) 
 

Where ξ is the damping factor from the test, and ω is the frequency of the vibration test. For 
more information, refer to "Structural Dynamics, An Introduction to Computer Methods", R. R. 
Craig, Jr., or other popular references. 
 
Model>Define>ElementBehavior>Plastic Yield Stress 
Specify the initial yield stress 
 
Model>Define>ElementBehavior>Isotropic Hardening Modulus 
Specify the isotropic hardening modulus. This modulus can be computed from the uniaxial test 
result E and Et. The tangent modulus Et is the apparent slope of the stress-strain curve after 
the initial yield, and E is the initial modules (Young's modulus). The hardening modulus H is 
defined as 
 
H  = Et/(1-Et/E) 
 
Effectively, the yield stress is then computed from 

 

σy  = σy0 + H εp 
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where σy0 is the initial yield stress, and εp is the accumulated effective plastic strain computed.   
 
Model>Define>ElementBehavior>Plastic Hardening Factor 
This factor β controls the kinematic Bauschinger hardening effect in the cyclic loading 
behavior.  The effective yield stress is computed from 
 

σy  = σy0 + (1-β) H εp 

 

where σy0 is the initial yield stress, εp is the accumulated effective plastic strain computed, and 
H is the isotropic hardening modulus. When β=0, the kinematic hardening effect is excluded, 
and when β=1, the full kinematic effect is applied. 

 
Model>Define>Element Behavior>Nonlinear Multiplier Index 
This index allows the control of the material data to be dependent on the available system 
variables such as time or stress or strain, etc. For further information see the nonlinear 
property multiplier dialog session. 

 
Model>Define>ElementBehavior>Beam/Rod Section Properties 
This button will show a control menu to set the cross section property specification menu. The 
data are only necessary if the material properties are dealing with either beam or rod/truss 
elements. 
 
Model>Define>ElementBehavior>Anisotropic/Orthotropic Material 
Specify the anisotropic material's property is active. To specify the material's anisotropy, click 
the "Setting" button to define the material data. 
 
Model>Define>ElementBehavior>With Creep Effect (thermal/elasto/plastic) 
When this option is checked, the thermal-elasto-plastic creep strain is computed based on the 
power creep law as specified in the creep material data. To specify the power creep law data, 
click the "Setting" button. 
 
Model>Define>ElementBehavior>Initial Stress/Strain 
When this option is checked, the default initial stress and strain can be set for each element. 
This is usually used for problems that require initial pre-stress or need the strain history for 
specific material model. For details, please refer to the User Defined Initial Stress and Strain 
section. 

 
Model>Define>ElementBehavior>User Defined Plasticity 
The USRAPP user interface routine can be used to defined any plasticity material model if the 
provided material library is not applicable. In such case, by checking this box, the user can 
enter additional material parameters to be sent to the USRAPP API interface. For detailed 
information about user interface functions, please refer to the "AMPS User Application 
Interface Reference Manual."  

 

The Model Define Element Behavior - Thermal/FLow Menu 
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Model>Define>ElementBehavior>Thermal Conductivity, Specific Heat Capacity 
Specify the isotropic material's thermal property, the specific heat capacity is necessary for 
transient response analysis. 
 

Model>Define>ElementBehavior>Volume Heat Flux Density 
Specify a volume distributed heat flux associated with the material index. This is usually used 
to simulate a heat sink or a heat source situation. Note that the same effect could also be 
achieved using the nodal-based heat load (but it then require the user to specify the integrated 
nodal value. So, it is not as convenient as the volume based heat flux density). 
 
Model>Define>ElementBehavior>Linear Expansion Coeff, Expansion Reference Temperature 
This option allows the user to specify the thermal expansion coefficient and the reference 
temperature. It is mainly applicable for thermal-stress coupling, or when buoyancy effect in the 
fluid is expected. Note that when in thermal fluid application, the buoyancy effect is computed 
based on the Boussinesq assumption - i.e. the thermal expansion term only affects the density 
variation in the gravity calculation, and not in the momentum terms. 
 
Model>Define>ElementBehavior>Mass density. 
For fluid flow analysis, the mass property is always necessary. For a pure thermal analysis, the 
mass density is only necessary when the transient response is desired. 
 
Model>Define>Element Behavior>Nonlinear Multiplier Index 
This index allows the control of the material data to be dependent on the available system 
variables such as time or stress or strain, etc. For further information see the nonlinear 
property multiplier dialog session. 
 
Model>Define>Element Behavior>Anisotropic/Orthotropic Material 
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Specify the anisotropic material's property is active. To specify the material's anisotropy, click 
the "Setting" button to define the material data. Please note that anisotropic thermal material 
property only apply to thermal continuum, not to the fluid material properties. 
 

The Model Define Element Behavior - Electro/Magneto Menu 

  
 

Model>Define>ElementBehavior>Electric Conductivity/Dielectricity 
Depending on the system control setting, this specifies either the electrical conductivity (for 
conductive analysis) or the absolute dielectric property (for the dielectricity analysis).  
 

Model>Define>ElementBehavior>Volume Charge Density 
For a dielectric analysis, the user can specify a volume-distributed charge associated with the 
material index. Note that the same effect could also be achieved using the nodal-based charge 
load (but it then requires the user to specify the integrated nodal value. So, it is not as 
convenient as the volume based heat flux density). 
 
Model>Define>ElementBehavior>Magnetic Permeability 
This specifies either the magnetic permeability property.  
 
Model>Define>Element Behavior>Nonlinear Multiplier Index 
This index allows the control of the material data to be dependent on the available system 
variables such as time or stress or strain, etc. For further information see the nonlinear 
property multiplier dialog session. 
 
Model>Define>Element Behavior>Electrical Joule Heating to Thermal Energy Conversion 
Factor 
Since the energy unit conversion among different forms of energy (such as electrical, thermal, 
or mechanical) is dependent on the unit used in the model, it is necessary to use a energy 
conversion factor to convert the electrical Joulian heat to the equivalent thermal energy.  The 
electrical joule energy is computed from the heat generation E=IV (per unit volume sense), and 
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the conversion factor is used to convert this electrical Joulian energy into the thermal energy 
unit. For example, the energy unit Joule to BTU conversion factor is 0.00094845166 since one 
Joule equals 0.00094845166 BTU. 
 

Anisotropic/Orthotropic Material Definition 

Model>Define>Element Behavior>Anisotropic/Orthotropic Material/Setting 
This dialog is for general anisotropic or orthotropic material data input. It could be one of the 
follow types. 
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Fig. 4.8 The anisotropic/orthotropic material dialog 
 
Model>Define>Stress>Setting>Directoin a/b vector 
General anisotropic material with material axes "a", "b", and "c" data can be entered here.  The 
orientation of the main material axis "a" vector direction must be entered followed by the 
material axis "b" vector direction.  The "a" and "b" axis vectors now define the material "ab" 
plane formed by this two vectors. The third material axis direction "c" is indicated by the normal 
direction of this plane "ab". If vector "b" is not perfectly orthogonal to the "a" axis, it will be 
adjusted during the AMPSol solution calculations, so it will be normal to both axis "a" and the 
internally computed normal "c" axis. 
 
The 2D orthotropic material following exactly the same definition as the 3D anisotropic material 
axis orientation, and the user has to enter a meaningful vector "a" and "b" direction in the 
global XY plane.  
 
For shell material in the 3-dimensional space, the vector "a" direction as entered will be 
projected to the shell surface to indicate the shell orthotropic major axis "a" direction. If the "a" 
axis projection is zero (e.g., happen to be in the shell's normal direction), the 2nd orthogonal 
axis "b" is then used to project to the shell and to indicate the 2nd orthotropic direction.   
 
Using this method, all 2d/3d/shell anisotropic material definition can be shortened into this 
simple consistent dialog for material definition. 
 
Model>Define>Stress>Setting>Young' Modulus, Poisson's Ratio, Shear Modulus 
Enter General anisotropic material's Young's modulus, Poisson's ratio, and the shear modulus 
in the material axes a, b, and c directions.  Note that even if you are analyzing a 2D or shell 
material, all 3 directions material +data must be entered since they are necessary for the 
material property transformation calculations. 
 
The entered material property must follow the following constitutive equations: 

σ = C ε 
where 

σ = {σaa, σbb, σcc, τab, τbc, τca }T  and ε = {εaa, εbb, εcc, γaa, γaa, γaa }T  are the engineering stress and 
strain tensors.  The Poisson's ratio is defined as νij = - εj / εI  as interpreted as the strain 
reduction in the J direction subjected to the uniaxial stress test in the I direction.  And the 
constitutive matrix C is entered as: 
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Note that the coefficient of these material constants must satisfy 

νab/Ea = νba/Eb, νca/Ec = νac/Ea,  and νcb/Ec = νbc/Eb. 

Further more, νba < sqrt(Eb/Ea), νca < sqrt(Ec/Ea), and νcb < sqrt(Ec/Eb). 
 
For shell problem, since the local material axes "a" and "b" are always parallel to the shell mid-
plane curvilinear surface, and the "c" axis is always the normal direction, it is common to use 
the shear shape factor reduction by applying Gbc' = Gbc/1.2 and Gca' = Gca/1.2. 
 
Model>Define>Thermal/Fluid>Setting>Thermal Conductivity, Thermal Linear Expansion 
Coefficient 
Enter the anisotropic thermal conductivity and the thermal expansion coefficient in the local 
material axes a, b, and c directions. If both thermal and stress anisotropic materials are 
defined, the local axes are shared in both definition. 
 
Model>Define>Thermal/Fluid>Setting>Conductivity, Dielectricity, or Permeability 
Enter the electrical conductivity or dielectricity, or magnetic permeability coefficient in the local 
material axes a, b, and c directions. 
 
 
Model>Define>Stress>Setting>Nonlinear Multiplier Index 
This index allows the control of the material data to be dependent on the available system 
variables such as time or stress or strain, etc. For further information see the nonlinear 
property multiplier dialog session. 
 

Creep Material Data and Controls Menu 

The creep effect uses a power creep law to compute the creep strain, or εcreep = c1 σ c2 t c3  

in a one-dimensional uniaxial creep law, σ being the uniaxial stress, and t is the time scale. 
Usually, these coefficients c1, c2, and c3 can be obtained from a creep test, or from a material 
data sheet.  
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Model>Define>Stress>Setting>c1, c2, c3 
These are the uni-axial creep law constant to control the creep strain calculation. The constant 
c2 is the power constant applied to the effective uniaxial stress, and c3 is the power constant 
for the time dependent effect. The c1 constant controls the total scaling. If these constants are 
also dependent on the system run time variables, then additional Nonlinear Multiplier Index 
can be assigned to each constant. Note only non-zero multiplier index indicates the need for 
scaling, and the corresponding index must be entered in the Define property sheet. 
 
Model>Define>Stress>Setting>Creep Strain Integration Control per Time Step: Automatic 
Based on Creep Starain/Equal SubSteps 
Sometimes, the creep behavior is very nonlinear, especially when the stress or time 
dependency power constant are greater than one.  In the conversion of the multi-axial stress 
state into the effective stress and the effective strain in order to compute the effective time, the 
process may not converge due to the inelastic behavior. As such, sub stepping must be used. 
The automatic sub stepping uses the incremental creep strain computed and automatically 
decreases or increases the step size to achieve the time step creep strain calculation based on 
the request accuracy. The equal sub stepping method uses the specified sub step size to 
compute the creep strain.  Since the creep strain rate is not always equal in all time/steps, it is 
suggested to use the automatic sub stepping to control the sub step size automatically. 
 
Model>Define>Stress>Setting>Auto Max SubSteps/Equal SubSteps 
This is maximum sub steps that the automatic stepping algorithm is allowed to take, or the total 
sub steps that the manual equally sub stepping controls. 
 
Model>Define>Stress>Setting>Max Iterations per SubStep 
This is maximum iteration allowed for the nonlinear creep strain calculation. 
 
Model>Define>Stress>Setting>Creep Strain Time/Step Integration Control 
This is the Euler integration parameter.  It's value must be between 0.0 and 1.0. When this 
parameter is 0.0, the elasto-plasto-thermo-strain is computed based on the previous step 
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value, i.e., an explicit approach. When it is 1.0, it becomes an implicit method assuming the full 
projected strain based on the previous step. The default setting is 0.5. 
 
Model>Define>Stress>Setting>Error Tolerance for Stress and Strain 
This is the error tolerance setting for each sub step stress and strain calculations. 
 
Model>Define>Stress>Setting>Follow ORNL NE F9-5T Guidelines (ORNL3) 
When this check box is active, the creep strain calculation procedure follows the most recent 
1986 DOE Nuclear Standard NE F 9-5T "Guidelines and Procedures for Design of Class I 
Elevated Temperature Nuclear System Components" published by Oak Ridge National 
Laboratory recommends criteria for creep strain hardening and calculation procedure (the so 
called ORNL3).  The computed results following these guidelines are most noticeable in cyclic 
loading situations since the strain hardening calculation guidelines require the tracking of the 
stress reversal and strain origin and uses that for the creep strain hardening calculations. 
 

Piezoelectrical Material Data 

The piezoelectrical material must be supplied by the user for the stress-electrical coupled 
analysis. There are two possible types of data format: piezo-strain or piezo-stress matrix 
formats. This is usually based on the manufacturer's supplied information. The piezo-strain 
matrix relates the electrical potential gradient to the S11, S12, S12, S22, S23, S33 strain for 
each gradient component, while the piezo-stress matrix relate the potential gradient directly to 
the stress tensor. 

  
 

Nonlinear Property Multiplier 

Model>Define>Element Behavior>Edit Nonlinear Multiplier Data. 
Other than a specified value, each material property value may be multiplied with a nonlinear 
function of any computed variable. This nonlinear multiplier is defined by this option and 
assigned a nonlinear multiplier index to the associated material property. The following dialog 
will show up 
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Fig. 4.9 The nonlinear property multiplier dialog 
 
The Multiplier Index is the index to be used.  Add/Apply/Update/delete options will add or 
update the index's data, or delete the index information.  The multiplier's dependent variable is 
specified from the drop-down box "Multiplier Variable".  The availability of the variable will 
depend on the type of the analysis performed, and the material models used.  After that, there 
are three type of multiplier functions 
 
1. Piece-wise linear interpolated 

Pairs of the dependent variable values and the multiple values must be entered in the 
multi-list box corresponding to the variable and multiplier. 

2. Polynomial expansion 
This allow the multiplier to be computed as 
M(v) = c0 + c1v + c2 v^2 + c3 v^3 … + cn v^n 
Where v is the dependent variable and M(v) is the multiplier function's value. The 
coefficients are entered in the multi-list box. 

3. Exponential expansion 
This allow the multiplier to be computed as 
M(v) = c0 v^c1 
Where v is the dependent variable and M(v) is the multiplier function's value. The 
coefficients are entered in the multi-list box. 

Beam/Rod Section Properties Menu 

The sectional property menu is designed to specify all beam/rod section properties and the 
optional member loading controls. The main difference between beam and rod is the rigidity of 
bending associated with the rotational degree of freedom in beam. Both beam and rod can be 
used in either 3D or 2D. The beam element has three rotational and translational DOF's in 3D, 
but only have two translational DOF's in 2D analysis, and one rotational DOF (rotation about 
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the Z-axis). The rod element has three translational DOF's in 3D, and two in 2D, both without 
any rotational DOF. 

 
Model>Define>Beam/Rod Cross Section Type 
There are total of four types of predefined beam/rod cross section types: 
1) User defined sectional properties: enter the pre-computed data of area, torsional 

rigidity, and the moment of inertia about the local a and b axes. 
2) Rectangular section: enter the width and the height of the cross section and the shear 

shape factor if shear stress correction for deep beam is desired. 
3) Circular section: enter the diameter of the cross section and the shear shape factor if 

shear stress correction for deep beam is desired. 
4) Tubular section: enter the outer and the inner diameters of the cross section and the 

shear shape factor if shear stress correction for deep beam is desired. 
If the shear stress correction is desired, enter the shear shape factor or enter zero to bypass 
shear stress correction. The shape factor accounts for the discrepancy of actual parabolic 
shear stress distribution profile as compared with the simple uniform shear stress assumption. 
The shape factor is the ratio of the actual shear force over the uniform average shear force, 
and is dependent on the Possions' ratio. For rectangular cross section, it is (12+11v)/(10(1+v)), 
and for the circular cross section, it is (7+6v)/(6(1+v)), and for tube, (4+3v)/(2(1+v)), where v is 
Possions' ratio. More information of this shape factor can be found in the traditional elasticity 
theory. 
 
For "User Defined Sectional Properties", these are the general terminology used: 
Area: the cross section area. 
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Moment of Inertia M.I: This is the bending flexibility of the beam cross section. For a 
rectangular section, it is M.I.=width*hight^3/12 about the major axis bending (local axis b), or 
M.I.=height*width^3/12 about the minor axis (axis 3). 
Tensional Rigidity J: It is the torsional rigidity needed to compute the torsional rotation angle 
from the applied torque based on the formula θ = TL/GJ, where T is the applied torque, L 
being the length of the beam, and G being the shear modulus of the beam. For a circular 
section it is 0.5∗仗r4 (and the Moment of Inertia for such section is 02.5∗仗r4) where r is the 
radius.  
 
For a general section property, an elasticity textbook or AISC Design Handbook is useful in 
finding the section properties. Please also note that that the user-defined section properties 
can be used in the large deformation/rotation analysis, but can not be used in the elasto-plastic 
analysis since the exact integration point plastic strain history can not be tracked in the such a 
section where geometry shape is unknown. If plasticity is expected in the beam section, only 
the sections of know shapes shape can be used. An exception is the rod element since the 
cross section is either tensile or compressive, so the plastic state of user-defined input section 
can also be used in plasticity. 

 
Model>Define>Beam/Rod Section Property>Sectional Property Orientation 
The beam/rod local uses local axes a, b and c (sometimes are also referred to as the local 
axes 1,2,3 in some output nomenclature) system to identify the orientation of the section. The 
a-axis direction is along the beam/road axial direction. The user enters the local b-axis 
direction through the local b-vector component. An additional b-axis vector specification is 
used is the b-axis vector specified happens to be coincident with the beam/rod member axis. 
 
Model>Define>Beam/Rod Section Property>Member Loading 
Other than the regular boundary condition control, the beam/rod element has the additional 
member loading ability.  
1) Uniformly Distributed Local Axis Loads: this allows the user to specify a uniformly 

distributed load along the local a, b and c direction.  The total force will be calculated from 
the integration of these uniformly distributed loads after axes transformation. It is 
necessary to enter the Time Function index to control the time multiplier.  For more 
information about the Time Function, please refer to the Model/Condition section. 

2) Initial Tension and/or Tension/Compression Only: this setting is only applicable to rod 
element. To specify an initial tension, enter a positive tensile stress, and enter a negative 
stress for initial compressive state. The rod can also function as a tension-only state (such 
as a rope) or a compression-only mode (such as a compression-only spring contact).  In 
such modes, the rigidity of the rod is scaled by a factor of 1e-30 till the rod element 
become active again, and the corresponding external loads/forces are redistributed during 
the calculation.  For further flexibility, the user can enter a slack distance to specify the 
initial tensile/compressive length change before the tension/compression mode will 
engage. A typical application of this control is when trying to model a directional opening 
gap when a compressive rod must travel through the initial opening before the 
compression only mode engages. 

 

User Defined Constutive Material Model 

When the user select the user-defined constitutive model, additional material property data can 
be stored in AMPView and then later pass to the user supplied routines. This dialog box is used 
to store such property array data in the model. 
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User Defined Initial Stress and Strain 
 

When this option is checked, the default initial stress and strain can be initialized for each 
element at each integration point. This is usually used for problems that require initial pre-
stress or need the strain history for specific material model. 
 

 
 

Additionally, if these stress and strain initialization is not enough, and more other properties 
need to be initialized, the user can select the "Use USRAPP…" check box, and initialize the 
desired variable in the USRAPP interface routine Detailed of this user interface application can 
be found in the "AMPS User Application Interface Reference Manual." 
 

User Defined Plasticity Material 

Fro general plasticity, AMPS provides a quick way for the user to define a user defined plasticity 
material model. Instead of writing a full constitutive material model, the user can just supply the 
plastic yield function and the flow rule (flow function). Usually, the yield and flow rule are the 
same for metal, and non-associated flow rules are used for britle and geological materials. 
When the user selects the user-defined plasticity model, additional plasticity property data can 
be stored in AMPView and later pass to the user supplied routines during program excution. 
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This dialog box is used to store such property array data in the model. For more details, please 
refer to "AMPS User Application Interface Reference Manual." 

 

  
 

Material model and data 

The material type is defined in the input file (*.dat file) is specified by first defining the type 
index, field1,field2 …The field variables refer to the parameters associated with the field 
governing equations. Currently the continuum stress field and the thermal field are the only two 
types of property that are supported. After this declaration the user also has to specify the 
property type according to the following specifications. 
Property Data 
Plane stress 
thickness 

plane stress thickness 

Integration points Gauss/Lobotto/Reduce/Default  
Density Rho, the material density 
Elastic Poisson's 
ratio 

Nu, Poisson's rato 

Elastic Young's 
modulus 

E 

Linear Expansion 
Coeff. 

beta coefficient 

Hyper Mooney 
Rivlin  

C1,C2,  hyperealstic type, Mooney Rivlin 

Plastic kinematic 
hardening 

Beta_ratio 
This controls the kinematic hardening ratio (0 to 1) 

Plastic Mohr 
Coulomb 

Cohesion, friction angle 

Plastic Von Mises Initial yield stress 
Thermal capacity C 
Thermal 
conductivity 

K 

 

Model/Conditions Menu 

The Boundary Condition Menu 

The Conditions Sheet allows the boundary conditions to be defined interactively.  The user first 
selects a F.E. geometric entity or multiple entities by graphical selections, and then the type of 
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boundary condition to be applied is then defined. After that, the specific values associated with 
the boundary condition type are assigned. Then the user specifies the time range in which the 
boundary condition is to be applied. Each of the above activity, referred as "geometry", "type", 
"value", or "time", is assigned an index or a name. The boundary condition is actually applied 
by the selection of the combinations of the four type and then specified as the final "boundary 
condition" index. Using this approach, the boundary conditions can be specified by selecting 
the combinations of different geometry, type, value, and time indexes. 
 
It is helpful for the user to turn both the node and the element side display on in order to review 
the applied boundary conditions.  

The Model Condition Menu 

The boundary condition is defined by a combination of Geometry, Time, Type and the 
associated additional data. Once these boundary condition data are set, the Condition page is 
used to define a complete set of boundary condition. When the user enter the Condition page 
the first time, most of the menu are disabled till the Geometry, Time and Type pages are 
specified, then a New Condition button will be enabled to create a new boundary condition. 
Once a boundary condition set has been defined, this is the best place to quickly review what 
the boundary conditions of a model, especially when there are many condition sets. If you 
switch the combination set, the geometry set associated with the boundary condition will be 
automatically brought up and shown in highlight, and the type/value/time page will be 
automatically recalled ready for review. 
 

  
Fig. 4.17 Condition Combination Page 
 
Model>Condition>Condition>Condition Name 
This name is generated automatically by the "New Condition" button. The user can also enter 
a Custom Name to better indicate the Condition Name. It is also used as a pull-down list to 
select one from the existing available selections, if any. 
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The Model>Condition>Combination>Custom Name 
This is an optional name that the user can enter to specify a meaningful name to a Condition 
set. 
 
Model>Condition>Condition>New Condition 
This will generate a new Condition Name based on the already define Geometry, Time, Type 
data as listed in the bottom pull-down list. name is generated automatically by the "New 
Condition" button. The user can also enter a Custom Name to better indicate the Condition 
Name. It is also used as a pull-down list to select one from the existing available selections, if 
any. 
 
Model>Condition>Combination>Update Condition 
If there are any changes to the combination of the Condition, this Update Condition button will 
be enabled to allow the saving of the changes. 
 
Model>Condition>Combination>Delete Condition 
This will delete the selected Condition set. 
 
Model>Condition>Combination>Sort by Name/Geometry/Order 
When there are many boundary condition set, this is a convenient way to sort the pull down list 
of the condition either by their name, geometry name, or order it was entered. 
 
Model>Condition>Combination>Restore Saved 
If there is any change to the Condition set, the different Geometry, Time or Type will be shown. 
If the user wants to revert to the originally setting, the "Restore Saved" button will retrieve the 
saved data and restore the Condition setting. 
 
Model>Condition>Combination>Old ID Names 
These areas are mainly for users who are familiar the previous versions (earlier than 3.03 
version) that use index rather than the condition name for geometry/time/type indications. They 
are displayed here mainly for informational purpose. It is also used to indicate the generation 
sequence index of the internal Geometry, Time, and Type names for information purpose. 
 
Model>Condition>Combination>New BC, Prev, Next 
These are the general Condition Sheet control button. The New BC is the same as the New 
Condition button, except it can be accessed from any page. The Prev and Next are two useful 
buttons to page throw the defined boundary condition sets. The pull-down load at the bottom of 
the Condition Sheet is for the quick identification of the condition set, and it tries to use the 
abbreviation so the user can quickly capture the nature of the geometry, time, and type values. 
This pull-down list of the Condition set at the bottom of this Condition page is accessible from 
any Condition page for convenience. 
 

The Model Condition Geometry Menu 

This menu allows geometric F.E. entities to be created 
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Fig. 4.11 Geometric Condition 
 
Model>Condition>Geometry>Geometry Name 
This name is generated automatically by the "New" button. The user can also enter a Custom 
Name to better indicate the Condition Name. It is also used as a pull-down list to select one 
from the existing available selections, if any. 
 
The Model>Condition>Geometry>Custom Name 
This is an optional name that the user can enter to specify a meaningful name to a Geometry  
set 
 
Model>Condition>Geometry>New 
This will add the current Graphic selection(s) to the next available Geometry Condition Index 
and create a new Geometry Name. The geometry condition is usually created by first 
specifying the geometric selection using any of the graphic selection tools, and then click on 
this button to store the selected geometric items into the geometry condition selection. 

 
Model>Condition>Geometry>Update/Save || Delete 
The update/save button is used to update the graphic selection associated with the Geometry 
Name.  The delete button will delete the current Geometry Name and the associated data. 
 
Model>Condition>Geometry>Add Selection to Geom 
This will add the current graphic selection(s) to the current geometry name index. This is 
usually used to add more geometry items to the existing geometry name due to some situation 
that not all geometry can be easily selected in one time, e.g., multiple internal faces selection 
for contact/glue boundary condition since they are originally invisible unless some elements 
are temporarily hidden for internal faces selection. 
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Model>Condition>Geometry>Remove from Curr Geom 
This will remove the current graphic selection(s) from the current geometry name index. 
 
Model>Condition>Geometry>BC Geometry Item Information 
This area describes the details of the geometric entity in the geometry set. The details of each 
item will appear in the 'Selected Type" area with details of the geometry. 
 
Model>Condition>Geometry>Previous Item/Next Item 
If there are multiple geometry items, the current item may be advanced or reversed by the 
Previous item button or next item button. The information will include the type of the geometry 
such as the basic FE Element, Side, Node, or the grouped geometric selection BodyElement, 
FaceElement, EdgeElSide, etc.  It also contains information about its index. If a face or a side 
of an element is selected, it will also show the associated face count within the element, or the 
node numbers associated with the side. 
 
Model>Condition>Geometry>Add Geometry to Selection Buffer 
This will add the current graphic selection(s) to the global selection buffer. This is usually used 
to automatically set the global selection buffer from the stored the geometry index so they can 
be used for subsequent selection operations. existing Geometry Condition Index. 

 
Model>Condition>Geometry>Show Selection / FE Grouping 
The will bring up the "FE Group/Display" dialog box so the user can examine the selected 
elements, geometry items, or groups.  This is usually for confirming the visual geometry 
selection items with the underlying element or geometry numerical information. For detailed 
information, please refer to the Finite Element/FE Group/Display control. 

 
Model>Condition>Auxiliary Analytical Geometry 
This session defines the analytical geometry that can be used in the analysis.  Current, only 
contact/slide definition uses analytical geometry.  The pull-down list will list the available 
geometry for selection, and the "Create New" button can used to add new analytical geometry. 
Clicking the "Add->" button will include the selected geometry into the "Included Geometry 
Items" list, and the "Remove Item" button will remove the selected item in the list. 
 
** Note: Sometimes it is necessary to select the geometry entities that are very close together, 
or some of the items are hidden inside the body.  In such case, it is usually easier to select the 
visible items first, and store the selections into the geometry index.  After that, use the 
FiniteElement/FE Group/Display display grouping and hiding control to hide the undesirable 
portion of the model so the desired element/node/geometry become visible.  After that, use the 
"Add Selection to Geom" button to add the new selection to the previous stored the geometry 
selection. For more information about finite element graphic selection, refer to the Selection 
Menu section. 
 

The Model Condition Time Menu 

The time range over which the condition applies is specified in this menu. 
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Fig. 4.16 The Condition Time Page 
 
Model>Condition>Time>Time Name 
This name is generated automatically by the "New" button. The user can also enter a Custom 
Name to better indicate the Time condition name. It is also used as a pull-down list to select 
one from the existing available selections, if any. 
 
The Model>Condition>Time>Custom Name 
This is an optional name that the user can enter to specify a meaningful name to a Time data  
set 

 
The Model>Condition>Time>New 
This will create a new Time Name based on the current time definitions entered. 
 
Model>Condition>Time>Update/save || delete 
This button updates and save the time data associated with the Time Name. The delete button 
will delete the current Time Name and all associated data. 
 
Model>Condition>Time>Initial Boundary Condition 
This options specifies the boundary condition is only for the initial condition only, and will not 
be applied in the subsequence analysis steps. This is usually used to specify the initial 
deformation, temperature, velocity or other nodal based variables' initial values. 
 
Model>Condition>Time>Time, Load Factors 
The index is associated with a time range and a load scaling factor at the start and one at the 
end. The load factor is interpolated in between. The user may optionally specify any 
intermediate breakpoints. 
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The Model Condition Type Menu 

This menu specifies the type of the boundary condition desired. Additional values needed for 
the type specified can then be entered in the next page immediately following this page. The 
Type selection can be classified into the following categories: Continuum, Thermal, Fluid, 
Electro/Magnetic, and General. To avoid unnecessary choices, some of the boundary 
condition types will be disabled from selection. Once the user chooses the Type category, the 
available boundary condition Type will be active for selection. 

  
Fig. 4.12 The Condition Type menu 
 

The Model>Condition>Type>Type Name 
This name is generated automatically by the "New" button. The user can also enter a Custom 
Name to better indicate the Condition Name. It is also used as a pull-down list to select one 
from the existing available selections, if any. 
 
The Model>Condition>Type>Custom Name 
This is an optional name that the user can enter to specify a meaningful name to the Type set 
 
The Model>Condition>Type>New 
This button creates a new Type Name and stored the selected condition Type under the index. 
The user can also enter a custom Type name to better indicate the type of the condition. 
 
The Model>Condition>Type>Update/Save || Delete 
The update/save button is used to update the Type selection associated with the Type Name.  
The delete button will delete the current Type Name and the associated data. 
 
The Model>Condition>Type>Kinematic (LHS) || Applied (RHS) 
The user may select one type from any of these radio buttons. The Applied (RHS) refers to the 
nature that these conditions generally contribute to the right-hand-side of the system equation, 
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and the kinematic conditions usually restrict the left-hand-side solution unknown to be 
restrained to certain specified values. 
 
Model>Condition>Type>Prescribed Values 
This selection applies a LHS nodal unknown.  This is normally used to specify nodal 
displacement, temperature, voltage, etc. Depending on the geometric dimension of analysis, 
either 3 (3D) or 2 (2D) magnitude values must be entered in the directional value page. 
 
Model>Condition>Type>Thermal Convective || Radiative Flux 
This applies a convective or radiative boundary condition in the thermal problem. The 
convective or radiative coefficient and the associated ambient condition must be entered in the 
corresponding value page. 
 
Model>Condition>Type>Nodal Stiffness || Nodal Mass || Nodal Damping 
This specifies the additional nodal values to a specific node or nodes for physics. Depending 
on the geometric dimension of analysis, either 3 (3D) or 2 (2D) magnitude values must be 
entered in the directional value page 

 
Model>Condition>Type>Tie/Glue 
This specifies a tie/glue boundary condition to be enforced on the geometry selected.  Tie/Glue 
can only be specified on the boundary of the model. In 2D analysis, the allowed geometry can 
be geometry side, element side, or nodes and element. In 3D, this also includes element face. 
In general, at least two geometric selections are required to construct a tie/glue (a master and 
one of multiple slave geometry). The nodes on the slave geometry are then kinematically 
constrained to the master surface/side based on the relative initial geometry, and will be 
enforced throughout the analysis unless a time-controlled tie/glue is specified. Details controls 
can be found in the Tie/Glue setup page. 
 
Model>Condition>Type>Surface Contact 
This specifies a contact boundary condition based on the geometry selected.  Contact can only 
be specified on the boundary of the model. In 2D analysis, the contact geometry can be 
geometry side, element side, analytical geometric line or planes. In 3D, this includes geometry 
surface, element face, or analytical geometric plane.  Possible contact parameters for stress 
and thermal setting must be entered in the surface contact value page. 
 
Model>Condition>Type>Constraint Equation 
This specifies a constraint equation condition among the selected nodal geometry. The 
constraint equation condition can only be applied to finite element nodes or geometry vertices. 
Details controls can be found in the Constraint Equation setup page. 
 
Model>Condition>Type>OverSet/VOF 
This specifies an advanced boundary condition when a finite element group (OverSet Entity) is 
moving across another finite element group (OverSet Domain). The user must specify the 
OverSet type and select the proper geometry association. It can also be used as the traditional 
VOF (volume of the fluid) method specification for applications such as bubbling in water. In 
such case, the air bubble is the OverSet Entity, and the water is the OverSet Domain. 
 
Model>Condition>Type>Point Force/Source 
This selection is to apply a RHS nodal value.  This is normally used to apply nodal forces, 
nodal heat flow, current etc. Depending on the geometric dimension of analysis, either 3 (3D) 
or 2 (2D) magnitude values must be entered in the directional value page. 
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Model>Condition>Type>Global Pressure/Traction 
A global pressure/traction applies uniform traction (general pressure) to the surface (3D) or 
edge (2D) to the model. The traction magnitude is specified by the components in the global 
direction in the value page.  Depending on the geometric dimension of analysis, either 3 (3D) 
or 2 (2D) magnitude values must be entered in the directional value page. 

 
Model>Condition>Type>Normal Pressure 
A normal pressure/traction applies uniform pressure normal to the surface (3D) or edge (2D) to 
the model. The positive value follows the stress convention point away from the model. 
Global Pressure/Traction. A single scalar value is expected in the directional value page. 

 
Model>Condition>Type>Surface Flux/Charge/Source 
A distributed thermal heat flux or dielectric surface charge, or surface distributed source term 
to the surface (3D) or edge (2D) of the model.  A single scalar value is expected in the 
directional value page. 
 
Model>Condition>Type>EM Surface Charge Coulomb Pressure 
This selection is used only when a dielectric electrical analysis is active and when electrical-
stress coupled analysis is desired.  In such case, on the surface of the conductor, the user can 
specify the electrical Coulomb force of the surface charge in the electrical field to be computed. 
The integrated Coulomb force (based on the Maxwell stress tensor and the electrical field 
intensity) is then applied as a pressure load to the stress continuum equation of the conductor. 
The associated BC geometry must be either a side (2D) or a surface (3D) for this Coulomb 
pressure to be meaningful. 
 
Model>Condition>Type>EM Lorentz Volume Force 
This selection is used only when a electromagnetic analysis is active and when stress-coupled 
analysis is desired. In such case, on the specified volume, the Lorentz force is computed and 
integrated into the stress equations for analysis. 
 
Model>Condition>Type>User Defined Nodal Load/RHS/User Defined Distributed 
Load/Flux/RHS 
This specifies the nodal loads or the distributed loads are defined in the user-supplied nodal 
load routine. Additional load property data can be stored and passed into the user-defined 
routine in the subsequent spreadsheet. The distributed load can be used to calculate 
distributed pressure/flux/LHS/RHS for either a surface (3D) or a side (2D). When this option is 
used, the user is responsible to carefully define the nodal load following the user interface 
development guideline. Details of the user-defined material model can be found in the AMPS 
User Application Interface Reference Manual. 
 
Model>Condition>Type>BC Components Refer to Nodal Local/Axis Directions (if defined) 
If this check box is active, then the boundary condition values as specified are referring to the 
local coordinate system, if it exist for the selected geometry.  This is usually useful when trying 
to specify a directional load/deformation/velocity magnitude on non-global oriented direction. In 
such case, the user can first define a local coordinate system (see Nodal Local Coordinate 
System Controls), then check this box to inform the program that the magnitude refers to the 
local axis directions 
 
Model>Condition>Type>Trace Load Multiplier Using Arc-Length Control From Initial RHS 
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This specifies an arc-length control loading scheme for the Applied RHS terms.  When this is 
activated, the time/step function no longer controls the RHS applied load. In stead, the 
program will automatic increases or decreases the load multiplier as is required for the 
time/step solution.  This is usually necessary for models that contain softening point such that 
a fixed load will generate no solution, or cause the program to diverge since the system can 
not withstand the applied load. The result from the analysis will be given in the output along 
with the load multiplier as the result instead of the time/step value.  Additional controls of the 
arc-length method can be set in the Arc-Length dialog entries. For details refer to the 
"Additional Arc- Length Controls" section. 
 

Additional Arc-Length Controls 

 
Normally, specifying arc length control for a loading type and use the default setting will 
perform well enough. However, in a very nonlinear problem, additional settings can be 
achieved to control of the arc length marching method: 
Arc-Length Method: The default is the Rik''s method. Alternatively, the Crisfield's method is 
also available. In the Crisfield arc-length, dual solution path is possible, and a forward 
marching algorithm is used. For details about both methods, see "A Fast Incremental/Iterative 
Solution Procedure That Handles Snap Through", M. A. Crisfield, IJNME, 1981, pp.55-62. 
Maximum Load Increase Factor After a Successful Arc Marching Step (default=3.0): 
After a successful arc-length load increase and iteration is successful, the next load increment 
is taken computed based on the ratio of the iteration error norm and the desired error norm.  
The next arc-length load increment size is computed from this estimated load multiplier based 
on the specified initial load magnitude. This maximum increase load factor will limit the amount 
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load to be applied in the new arc-length step. The recommended 3.0 (300% increase) factor is 
based on several average nonlinear problems we have tested, and usually is a recommended 
setting.  However, if the problem softens or stiffens a lot, i.e. extremely nonlinear, then a 
smaller setting such as value close to 1.0 is recommended. For a extremely nonlinear 
softening/stiffening, if the load marching increment is too big, the resultant load-displacement 
curve will have erratic jump or oscillation, and that's also a good indication of smaller 
increment is necessary. 
Minimum Load Decrease Factor After an UnSuccessful Arc Step (default=0.001): similar 
to the above setting, this specifies the minimum load factor will be used when the arc-length 
loading step size is cutting back during a very nonlinear analysis. 
Desired Deformation Increment: The user can directly input the desired incremental 
deformation size. In such case, the deformation corresponding to the specified incremental 
load will be scaled so the incremental arc-length size will be roughly equal to the desired 
deformation size. 
Maximum Deformation Increment Size: When this is entered, the arc-length deformation will 
not march larger than the specified size. If not specified, the program will initially limit the size 
to no more than 5 times the initial increment. 
Minimum Deformation Increment Size: specify the minimum size of the arc-length 
deformation magnitude to take when the load step is cutting back. 

Nodal Local Coordinate System Controls 

 
Model>Condition>Type>Nodal Local Coordinate>Nodal Local Coord Index 
The assigns an index number by entering a value or select one from the dropdown list if there 
are existing indexes. Note that at the first opening of this page, if there are Geometric 
Condition Indexes that have been previously defined, the program will automatically switch to 



AMPView 

51 

the highest index and highlight geometric entities associated with that index for user's 
information. 

 
Model>Condition>Type>Nodal Local Coordinate>Add 
This is a short-cut button. Its purpose is to add the current Graphic selection(s) to the next 
available Nodal Local Coordinate Index. This is the recommended way of adding a new Nodal 
Local Coordinate index to avoid overwriting the existing ones. The Nodal Local Coordinate 
index is usually created by first specifying the geometric selection using any of the graphic 
selection tool, then store the selected geometric items into the database. 

 
Model>Condition>Type>Nodal Local Coordinate>Update/Save || Delete 
The appropriate action is selected to link and update the graphic selection with the Nodal Local 
Coordinate index.  The delete button will delete the Nodal Local Coordinate index. 
 
Model>Condition>Type>Nodal Local Coordinate>Show/Refresh Selection Info 
Press this button will refresh the 'Selection Item Information' for reference purpose. It is also 
automatically updated whenever the graphic index is changed. However, if the selection is 
changed later, it is necessary to press this button to get the most recent update.  
 
Model>Condition>Type>Nodal Local Coordinate>Selected Item Information/Total Selected 
Items/Current Item Index 
This provides the user with details of the type of geometric entity selected. The details of the 
selected item will appear on the 'Selected Item Information" area. 
 
Model>Condition>Type>Nodal Local Coordinate>Previous Item/Next Item 
If there are multiple selections, the current item may be advanced or reversed by the Previous 
item button or next item button. The information will include the type of the geometry such as 
the basic FE Element, Side, Node, or the grouped geometric selection BodyElement, 
FaceElement, EdgeElSide, etc.  It also contains information about its index. If a face or a side 
of an element is selected, it will also show the associated face count within the element, or the 
node numbers associated with the side. 
 
Model>Condition>Type>Nodal Local Coordinate>Nodal Local Coordinate Data 
There are total of four different types of user defined nodal coordinate system options. The 
local coordinate system refers to the local a, b and c orthogonal axes. 
(1) User specified vector 1 as the a-axis and vector 2 as the b-axis. Later in the processor 
calculations, the b direction vector is orthogonalized to vector a, and third local axis  c is 
calculated from the cross product of axes a and b, 
(2) Use Computed Surface/Side Normal as the local a-axis. Vector 1 is orthogonalized to the 
normal as the b-axis direction. Vector 2 is used if vector 1 is in the normal direction. 
(3) Cylindrical coordinate system. Defined from the Origin and the Cylinder Axis Direction. In 
such system the local a-axis is along the radial direction, and the b-axis is tangent to the radial 
in the rotational theta direction. The local c-axis is always along the specified z-axis direction. 
(4) Spherical coordinate system. Defined from the Origin and the North Pole Axis Direction. 
The local a-axis is along the radial direction, and the b-axis is tangent to the radial in the 
rotational theta direction. The third tangential direction is the projection of the z-axis vector 
tangent to the local a-axis (radial) direction. 
 
Model>Condition>Type>Nodal Local Coordinate>Skip LHS Transformation 
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This options specifies that the nodal coordinate specification should not be applied to the LHS 
transformation, and only applicable to the RHS (applied) data if local components information 
is intended, as specified in the Condition/Type specification. 

 

Basic nodal DOF choices 

The following table specifies the nodal DOF as well as the state of the material properties. 
These properties are all stored at the nodes.  The stresses are calculated from the element 
integration locations and extrapolated to the nodal position. 
Field quantity Definitions 
Displacement Dx, Dy, Dz are included in the nodal dof freedom. These are the 

dependent unknown variables in the FE continuum problem. 
Velocity Vx, Vy, Vz these are sometimes included in the unknown dof. At other 

time they are implicitly calculated from the incremental dof. 
Temperature The temperature field is included in the nodal dof. These are solved as 

part of a combined mechanics, thermal diffusion and convection 
problem. 

Thermal Flux Nodal property computed from the thermal gradient 
Stress tensor Nodal property, retrieved from solution 
Yield function State property of material, used for plasticity. 
Isotropic hardening State property defining an isotropic work hardening material 
Kinematic 
Hardening 

State property defining an alpha scalar that determines the state of a 
kinematic hardening elastic plastic material 

Elastic strain 
tensor 

State property describing elastic strains 

Plastic strain 
tensor 

State property, describes plastic strains 

Total strain tensor State property defining total strains 
Velocity/Vorticity Fluid flow Eulerian formulation velocity and vorticity. At the interface 

between the fluid and continuum, the velocity value become 
consistent between the Eulerian and the Lagrangian measurement. 

Fluid Pressure Fluid pressure scalar value 
 

The Model Condition Values Menu 

The values menu is dependent on the type of condition chosen. In the diagram we show the 
menu obtained by specifying the first option in the Kinematic (LHS) Prescribed Values.   
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There are other types of Values menu page will show up: 
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Fig. 4.13 The Directional Values Condition. 
 
This menu allows the user to enter vector data or scalar data, pending on the BC Type that is 
specified in the Condition Type page.  The user is required to check the appropriate variable to 
associate the entered value to the proper physical variables. 
 
The Model>Condition>Directional Value>Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
 
The Model>Condition>Directional Value>New Type+Value 
This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>Directional Value>Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field.  

 
Model>Condition>Directional Values>Displacement, Rotation, Velocity, Vorticity, Voltage, 
Temperature, Point Force, Rotational Load, Current/Charge, Global Pressure, Normal 
Pressure, Heat Flux, Source, Current/Charge Density, Nodal Stiffness/Mass/Damping, Surface 
Charge 
These are the list of possible items need to be entered pending on the type of condition Type 
page. These fields will only show up for user data input, and pending on the problem 
dimension size, the data length could vary.  For data requiring angle measurement, they must 
be in "radian" unit. The rotational DOF's (either rotational deformation or applied moment) can 
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only apply to model with shell or beam continuum element with such degree of freedom Due to 
the expanded usage of the code, there are possible new items will appear as the analysis 
capability of the program expands. 

 
Model>Condition>Directional Value>Shell Pressure/Source Position 
This option is specifically for normal pressure or flux boundary conditions that involve shell 
element or for the 3D-line pressure/flux when a unique normal direction can not be identified 
without user specification. This locator is a point located at the pressure/flux side of the 
shell/line so the pressure/flux integrator can determine the normal orientation from the locator 
position. The positive pressure/flux is interpreted as direction pointing away from the locator 
position (like a ray).  For the 3D line, the computed normal vector will lie on the plane formed 
by this locator position and the end points of the line.  If this option is not specified for shell 
normal pressure loading, it is defaulted to be at location (0,0,0). For 3D-line, it is always 
necessary to set this locator position. This option is not necessary for shell or line with global 
pressure loading since in such case, the pressure components (Px,Py,Pz) are supplied by the 
user. 
 
Model>Condition>Directional Value>Geometry Follower 
By default, all integrated condition types such as pressure/flux are follower types if nonlinear 
geometric strains are used. Currently, all nodal values are not follower in nature that they are 
in the global direction sense. As a result, this check box is not necessary for nodal control, but 
is reserved for future use. 
For all distributed properties such as pressure or flux, if large deformation (either Update 
Lagrangian or Total Lagrangian) is active, the follower nature of the property is automatically 
activated. 

The Model/Condition Thermal Convective/Radiative Page 

The thermal convective/radiative value page is specific for thermal boundary conditions. 
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Fig. 4.14 The Thermal Convection/Radiation Page 
 

The convective/radiative heat transfer is computed from the equation 

)()()( 442 TrTesTcThTvTCgTk p −+−+∇+=+∇ &ρ  

Where 
k is the conductivity 
g is the heat generation in the domain 
ρ is the mass density 
v is the convective velocity 
h is the convective heat transfer coefficient 
Tc is the convective ambient temperature 
s is the Stefan-Boltzman constant 
e is the emissivity coefficient 
Tr is the radiative ambient temperature (relative to Kelvin absolute zero temperature). 
 
The Model>Condition>Convection/Radiation>Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
 
The Model>Condition>Convection/Radiation >New Type+Value 
This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>Convection/Radiation >Update 
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This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field.  

 
The Model>Condition>Directional Value>Update/Save 
This will updates the database of the current Thermal Convection/Radiation values page.  
 
Model>Condition>Thermal Convection/Radiation>Thermal Convective/Radiative Values 
These specify a convective or radiative boundary condition in the thermal problem. Depending 
on the type of the condition, only the convective or the radiative values are necessary. 
 

The Model/Condition Surface Contact Condition 

The surface contact value page is specific for contact boundary conditions. 

  
Fig. 4.15 The Surface Contact Page 
 

The Model>Condition>Surface Contact >Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
 
The Model>Condition>Surface Contact>New Type+Value 
This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>Surface Contact >Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field. 
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The Model>Condition>Surface Contact>Selected geometry defines contact boundary 
This defines the selected geometry as the contact surface. In 2D analysis, the contact 
geometry can be geometry side, element side, analytical geometric line or planes. In 3D, this 
includes geometry surface, element face, or analytical geometric plane. These contact surface 
are used for penetration or sliding checking.  Note that to be more efficient, not all nodes are 
checked against these contact surfaces. Only nodes specified as contact nodes are checked. 
By default, the nodes associated with the contact surface are also defined as nodes to be 
checked for contact.  Note that once a geometry side/face is define as a contact boundary, it 
will be used as a potential contact target in all other contact checking, even they are not in a 
same set. 
 
The Model>Condition>Surface Contact>Examine selections' associated nodes for contact. 
This specifies that the nodes associated with the geometry selected are to be checked for 
contact penetration.   In certain situations, it is necessary to specify additional nodes that are 
not associated with contact surface, but they should be checked against other contacting 
surface by using this assignment. Unless the contact surface will curl back and potentially 
penetrate/contact itself, it is not necessary to include the contact surface's nodes for contact 
checking. The default flag is to check this for self-contact. 

 
The Model>Condition>Surface Contact>Solid Continuum Contact 
When checked, solid contact detection is activated.  The friction coefficient is used to calculate 
the friction force from the normal force between the contacting surfaces.  Since the contact 
formulation is based on the numerical penalty method, the penalty value is automatically 
chosen if the Penalty Coefficient is left to be zero.  In such case, the penalty value is 
automatically computed based on the solid's stiffness at the point of the contact. It is usually is 
a value about 3 magnitude higher than the maximum stiffness detected. However, if it 
becomes necessary to specify a more suitable weight penalty in numerical calculations, it 
should be entered here. If the penalty coefficient is a non-zero value, it refers to the relative 
magnitude to the default computed value. For example, enter a value of 0.1 will request the 
program to use only 1/10 of the computed penalty value. Usually, if a value is too low, some 
slight penetration could be observed. A higher value usually will have a better result, but at the 
cost of more numerical iterations, and lead to possible instability if the penalty value is too 
high. 
 
The Model>Condition>Surface Contact>Thermal Contact 
When checked, thermal contact checking is activated. The thermal continuity is enforced 
through the contacting face if solid deformation contact is detected. Optionally, since the 
contact friction will generate thermal energy and becomes a heat source, a frictional energy to 
thermal energy conversion constant can be supplied to take into this consideration. Since the 
contact formulation is based on the numerical penalty method, the penalty value is 
automatically chosen if the Penalty Coefficient is left to be zero.  In such case, the penalty 
value is automatically computed based on the solid's conductivity, and it is about 5 magnitude 
higher than the maximum conductivity detected. However, it is sometimes necessary to specify 
a more suitable weight penalty in numerical calculation, and it should be entered here. 
 
The Model>Condition> Surface Contact>Apply Movement to Geometry Time Scale Motion 
Control, if movable. 
When the geometry condition specified is an auxiliary analytical geometry with possible 
movement control, this option will control the time scaled motion of the geometry using the 
time index specified.  This is best used to specify contact situation such as a moving contact 
boundary such as squeezing/crushing of a solid in a mold pressing simulation. Note that the 
default time index control in the combined condition will control all other parameters, except 
the penalty coefficient. 
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The Model>Condition> Surface Contact>Skip other contact geometry set (faster check) 
In large problems, a quick proximity check is first performed for contact penetration test. The 
user can help speed up this process by putting contact boundary conditions in different sets, 
so the checking can be accelerated if this "skip other contact geometry set" check box is 
selected. The default setting is to perform the contact checking unless this check box is active. 
 

The Model/Condition Tie/Glue Condition 

The Tie/Glue value page is specific for Tie/Glue boundary conditions. 

  
 
Tie/Glue condition is often used to connect two separate geometric objects together. This is 
done by specifying a "master" geometric entity along with one or multiple "slave" geometry 
objects to be tied/glued. In 2D analysis, the tie geometry can be geometry side, element side, 
or node, and in 3D analysis, it can be geometry surface, element face/side, or nodes.  Only 
one master geometry per Tie/Glue condition can be used, and the rest of the geometric objects 
are then tied to the master geometry based on the geometric compatibility or an optional user 
tie factor.  Note that if initially these objects are not in contact, the tie/glue condition will not be 
established and will be ignored. If there are any initial contact/penetration detected, the relative 
geometric ratio will be preserved by the tie/glue constraint. Also, unlike the contact condition, 
the definition of the master/slave geometry will be valid in the current set only, and will not 
influence other tie/glue condition. 
 
The Model>Condition> Tie/Glue >Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
 
The Model>Condition> Tie/Glue >New Type+Value 
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This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition> Tie/Glue >Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field.  

 
The Model>Condition>Tie/Glue>Master Geometry Setting 
The user must select at least two geometric entities for tie/glue definition.  By default, the first 
selection is the master geometry, and the rest of the selections are tied to the master 
geometry. All nodes associated with the slave geometry (face/slide/node) are first extracted, 
and their relative geometric position with respect to the master geometry (could be either a 
face/side) are computed.  If the slave node and the master geometry are initially in contact, the 
geometry compatibility is enforced using the initial geometry constraint through out the entire 
analysis with the optional time factor control. 
 
The Model>Condition>Tie/Glue>Tie all active DOF's (default) 
This specifies the tie/glue DOF's that should be enforced between the master/slave finite 
element data.  For a geometric compatible tie/glue, the default "All DOF"s" tie should be used. 
 
The Model>Condition>Tie/Glue>Ratio of the slave DOF to the Master DOF 
This specifies the factor that will be applied on top of the geometric compatibility constraint, 
and it should not be used unless specific master/slave tie factor is desired.  In the case that the 
master geometry is a node, the initial slave/master contact search is skipped, and this ratio 
(default to be 1.0) is applied to the slave/master tie relationship.  
  
The Model>Condition>Tie/Glue>Apply time/step factor to Tie/Glue 
This option will apply the time/step factor to the tie/glue relationship.  Normally, it is only 
meaningful when the factor is either one (a fully geometric compatible tie/glue) or zero (a 
completely disengaged tie/glue). This could be used to control the release/engage of the 
tie/glue condition by assigning a Time/Step index with proper factor between 1.0 and 0.0. 
 
The Model>Condition>Tie/Glue>Apply transformation to the salve geometry before processing 
tie constraint 
This option will apply the specified translation/rotation to the slave geometry before the 
processing the tie constraint. This is usually necessary when trying to perform some boundary 
constraint such as periodic or cyclic symmetric boundary conditions. In such cases, the master 
and the slave geometry items are on different areas of the model, and the proper constraint 
must be computed by translating or rotating the slave geometry to the master geometry region 
so a proper geometric tie constraint coefficients can be automatically computed. 
 

The Constraint Equation Condition 

The Constraint value page is specific for Constraint boundary conditions. 
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Constraint condition is used to construct an equational constraint among different nodal DOF's 
so a specific boundary condition can be enforced.  For example, in the above constraint 
boundary condition, the node stored in the first geometry selection position is constrained by 
the equation 

Dispx-dispy+0=0. 
Physically, this is equivalent to rotating the node by 45 degrees (using Local Coordinate 
controls), and specifies a zero normal deformation condition.  The general formation of the 
constraint equation is 
 Sum (NiDi * Ci) + h = 0. 
Where NI refers to the selection count order in the geometric selection. The geometry selection 
items have to be finite element nodes or geometric vertices since the condition casts a 
constraint among the nodal DOF's. Di is the nodal DOF specification, and can be selected from 
the pull-down list based on the available runtime-dependent solution variables. Ci is the 
coefficient of the DOF of the constraint equation. The constant term h, if non-zero, is the non-
homogeneous terms of the constraint. 
Internally, the constraint condition converts the equation by choosing a dependent variable and 
expresses it in terms of the rest of the DOF' variables and the constant term.  By default, the 
first DOF is set as the dependent variable, and can be changed by selecting a different DOF 
as shown in the edit field.  
Couple special notes about the constraint condition. If there are multiple constraints specified 
on a same dependent nodal DOF, the last one is always a dominating one. In addition, the 
independent DOF variable as specified can not be the dependent variable of another 
constraint equation. Finally, if a local coordinate system is assigned to a node, the constraint 
equation always refers to this local coordinate format 
 
The Model>Condition>Constraint Equation>Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
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The Model>Condition>Constraint Equation >New Type+Value 
This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>Constraint Equation >Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field. 

 
The Model>Condition>Constraint Equation >Apply time/step factor to Constraint 
This option will apply the time/step factor to the Constraint condition.  Normally, it is only 
meaningful when the factor is either one or zero (a non-existent constraint). This could be used 
to control the release/engage of the constraint condition by assigning a Time/Step index with 
proper factor between 1.0 and 0.0. 

User Defined Load/Flux/RHS/LHS Condition 

The user defined load value page is specific designed to store any necessary load control data 
from the user so these data can be passed into the user routines during runtime for load 
calculation. 

  
 

These user load data are stored in an array as defined in the list box. The array has the index 
range from zero to index n. If any one of the index data is missing, it is considered to be zero. 
In such case, the whole data array is expanded and stored in the model so during runtime, 
they are retrieved and passed to the user routines.  For more details of the user defined load 
boundary condition, please refer to "AMPS User Application Interface Reference Manual." 
 
The Model>Condition>UserDefinedLoad>Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
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The Model>Condition>UserDefinedLoad >New Type+Value 
This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>UserDefinedLoad >Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field. 
 

The OverSet Condition 

The OverSet boundary condition is an advanced condition set that is mainly used for large 
deformation motion such as bullet penetrating through air or bubble rising in a pond type 
application. In such cases,  a finite element group (OverSet Entity) is moving across another 
finite element group (OverSet Domain). The user must specify the OverSet type and select the 
proper geometry association. It can also be used as the traditional VOF (volume of the fluid) 
method specification for applications such as bubbling in water. In such case, the air bubble is 
the OverSet Entity, and the water is the OverSet Domain. The problem is extremely nonlinear 
due to the geometric constraint and fluid-solid interaction on the interface. To use this feature, 
please contact technical support for further assistance. 

  
 
The Model>Condition>OverSet/VOF>Name 
This name is the same as the one have been created in the condition Type page. It is 
displayed here for information purpose. 
 
The Model>Condition>OverSet/VOF>New Type+Value 



AMPView Reference Manual 

64 

This will create a new Type Name and save the current data entered this page into the 
condition new Type Name condition set. This is a quick way of creating a new Type Name if 
the user has not created a new Type Name in the previous Type page. 
 
The Model>Condition>OverSet/VOF>Update 
This will save the entered data and updates the database of the current active Type Name as 
shown in the Name field. 
 
The Model>Condition>OverSet/VOF>Overset Domain || OverSet Entities 
The user must specify whether the selected geometry is an OverSet Entity that moves across 
the OverSet Domain, or the OverSet Domain that form the region that the OverSet Entity will 
move through. 

Model/Material Library Operations 

The Model Define Material Library Menu 

The Material library is created and maintained by this menu. SagreView has a built-in material 
library that is included in the original installation. By default, the name of the library is 
"material.lib". The user can use this material library editor to create/modify the library to tailor 
the material data. 

 

 
Model>Define>Material Library>Material Library Name 
The material data are entered here and must be given a name.  The material database is 
stored by the name. 
 
Model>Define>Material Library>Material Data 
The user may specify any of the material items. Only data that will be used by a type of 
analysis needs to be specified here. Note that this data is used as a lookup table in the 
AMPSol/Define element behavior section. 
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Model>Define>Material Library>Apply/UpdateMaterial||Delete Material Index 
These options allows the material data to be created /or edited. 
 
Model>Define>Material Library>Save material data to file 
This saves the up to date material library to the material.lib file.  This is the file that is always 
used when AMPView look for a material information. 
 
Model>Define>Material Library>Import from Material Data File 
If the user has multiple material data file stored under different filename, this utility will read the 
information stored on the file, and then append them to the current material database. Note 
that it should be save back to the material database file so the future AMPView session will 
automatically use the newly merged material database.  

Result Menu 

The Results Menu 

This performs the post-processing of the model results. 

 
Fig. 5.1 The Model result Menu 
 
Model Result>Contour Display>Select TimeStep… 
This allows the user to select the time/step for result examination, inquiry, animation.  A dialog 
box is presented with the available time/step selection as below. 

 
Note that this value shown could be either a time/step value, or a eigenvalue corresponding to 
a eigen analysis mode, or could be a load multiplier from an arc length analysis. It really 
depends on the nature of the output file being read in. Choosing this value will automatically 
update the corresponding nodal results to match the selected time/step/mode/multiplier. 

Contour Display 

Result Contour Controls 

Model Result>Contour Display>Contour Type 
This allows the user to select the quantity to be contoured from a dropdown list as show below. 
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The user may also elect to use fixed bands or interpolated colors for the contouring. 
The following types can be displayed in all their x, y, z components (note that additional items 
may be available based on different version of AMPSol processor): 
 
Displacement    disp 
Temperature    temp 
Velocity    velx,vely, velz 
Reactions/RHS summation  sum  
Stress     sig 
Strain     eps 
Von Mises Equivalent Stress  sig_equiv 
Tresca Equivalent Stress  Tresca 
Principal Stresses   SigMax, SigMin, SigInt 
Equivalent Plastic Strains  eps_plastic 
Thermal Flux    tflux 
Yield function    yield_func 
Error Norm    error_norm 
Nodal balance    sumX,sumY,sumZ 
 
Note that disp, vel, sum, tflux are in the vector component format (x,y,z), sig, eps are in 
tensor format, and the rest are in scalar format. Specifically, 
 

sig_equiv = √(3/2 σij'σij') where σij' is the deviatoric stress 
SigMax, SigInt, SigMin these are the principal stresses. They are arranged in their value such 

that SigMix > SigInt > SigMin in value format (not in magnitude format) 
Tresca = SigMax-Sigmin 

eps_plastic is computed from the time step integral of  dεp = √(2/3 dεij
p dεij

p)  
yield_func is the difference of the material yield criterion to the yield stress, e.g. in Von Mises,     

yield_func = sig_equiv - σy 
error_norm this is an error distribution (square-root of sum of squares of energy error) based 

on a energy theory by comparing the finite element result to a estimated theoretical 
solution based on the equivalent-energy theory. 
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sumx, symy, symz these are the results from the equilibrium check. They represent the total 
net RHS at the end of the analysis.  In stress problem, these are the total net 
forces on the nodes, and for diffusive heat transfer problem, the net flux flow at the 
node.  For node without any boundary condition, the value should be close the 
error tolerance as specified, and normally is very near zero.  For the nodes with 
the boundary condition, this reflects the net RHS value of the boundary node, or 
reaction from the boundary condition. 

 
If the check box "Automatic from result" is specified, the contour range will be automatically 
selected based on the specified result type. Otherwise, select the desired minimum and the 
maximum range to be color contoured. 
 
Model Result>Contour Display>Contour Elements Within Range Only 
In situation that only a certain range of contour values are of interest, the user can check 
"Contour Element Within Range Only", and the contour shading will show only on the elements 
that contains nodal results that are within the range.  Those out of range will be hidden. To 
show all elements again,  please use the "Finite Element/FEGroup/Display/UnHideAll" option 
to reset the hidden elements (since they are internally temporarily marked as hidden element 
without any contour). 

 
When examining shell element's result, all properties show are referring to the shell's mid-
plane result, or can be considered as approximately the average of the result across the shell's 
depth.  To examine the shell elements' top or bottom surface's results, use the optional 
"Shell/Element Contour" menu. 
 
Model Result>Contour Display>Show Contour 
This initiates the contour plot. 
 
Model Result>Contour Display>Show Model Only 
This removes the contour plots from the model. 
 
Model Result>Contour Display>Time/Step Animate 
When there are multiple time step results, this menu is active and can be used to activate color 
contouring in steps. 
 

Shell/Element Contour 

Model Result>Contour Display>Shell/Element Contour 
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This contouring control dialog is specifically designed for shell element-based result display.  
For shell element, the front/back side result display will contour the result on the selected side, 
and are only visible from the side specified, and invisible from the other side in order to give 
the user the idea which side he/she is viewing 
Since the finite element results are usually nodal based (deformation, temperature, voltage, 
etc), those results involving derivative such as stress, strain, flux, etc. are computed after the 
basic nodal solutions are obtained.  These derivative type results are then computed based on 
volume averaging from different elements' projection. Element based results are directly from 
the analysis without any extrapolation, as compared with the nodal results that are based on 
the volume averaging. They usually have slightly more oscillation than the nodal based result, 
but will give out more specific information for a specific element of interest. In the AMPS 
version 1.74 and above, the shell element results also contain the global element end-forces, 
or forces and moments in the global direction.  This is convenient for design purpose. Note that 
for all element-based result, you can also inquire each element's corner value using the 
ModelResult/FE_Inquire/by_Element inquiry dialog to find out the exact value of each element. 

Beam/Rod Contour 

Model Result>Contour Display>Beam/Rod Contour 

 
This contouring control dialog is specifically designed for beam/rod element-based result 
display. If there is no beam/rod element in the model, this menu item can not be selected. The 
available beam/rod results will be shown in the pull-down list. For beam/rod elements, the 
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contour result magnitude is plotted in scale in the local axis 2 or 3 direction as defined in the 
beam property orientation vector.  This is for easy identification of the result, and to ensure the 
result display can be examined based on the relationship to the major/minor axis orientation. 
For axial or torsional result, it is plot on the local axis 2 direction, and for shear-dir2/dir3 and for 
moment-dir2/dir3, their magnitude variation will be plotted along the beam axis direction and in 
the corresponding 2 or 3 local axis direction. Note that for all element-based result, you can 
also inquire each element's corner value using the ModelResult/FE_Inquire/by_Element 
inquiry dialog to find out the exact value of each element. When 2D-beam element is used, the 
result is also treated as a three-dimensional beam and shown in the corresponding local 1, 2, 
and 3 orientation. 
 
The beam/rod contour is shown with shaded plot drawn on the corresponding local axis 
direction. Sometimes, it is easier to turn of the shading and show only the outline if necessary. 
In certain situation when the contour plot showing the relative magnitude is too small to 
observe, the user can use the ModelResult/Vector_Display/Set_Scale to change the 
magnitude size. The default ratio is one, which will make the largest element result value 
shown as roughly corresponding to about 5% of the screen size. 
 

  
 

Vector Display 

Vector Display 

This performs the post-processing of the Model Solver results. 

 
Fig. 5.1 The Model result Vector Display Menu 
 
Model Result>Vector Display>Show/Update Velocity Vector 
This allows the user to display results containing velocity information.  
 
Model Result>Vector Display>Vector Display by Component 
It is sometimes convenient to display the result in the flow vector format even there is no 
velocity result available.  This menu allows you to specify each vector component and to 
perform an arrow vector display. For each node, an flow vector arrow will show the relative 
magnitude of the flow magnitude. 
 
Model Result>Vector Display>Remove Vector Display 
Clicking this menu will remove vector arrow display from the screen. 
 
Model Result>Vector Display>Set Scale 
This menu allows the user to set the scale of the vector arrow length.  Normally, the longest 
vector arrow is about 5% of the screen size, and this vector size is interpreted as the unit 
length of the vector arrow display.  The program will apply the scaling to this unit vector length, 
if it set.  
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Vector Display by Compoment 

 
This dialog box allows the user to enter the vector components necessary to construct a user 
specified vector display.  Three pull-down lists are available to select each vector component.  
If the vector component in the 3rd global Z-direction is not necessary or not meaningful, the 
check box "Neglect Direction 3" check box should be checked. For each node, an vector arrow 
will show the relative magnitude of the specified vector. 
 

Deformation 

The Results Deformation Display Menu 

This allows the user to choose to include change of shape calculated by the solver. 

 
Fig. 5.2 The Model Result Deformation Page 
 
Model Result>Deformation>Show displacement. 
This will display the deformed shape of the solid.  If the "Auto Scale" is on, the deformation 
scale is automatically computed such that they will show visible change on the screen. 
 
Model Result>Deformation>Show undeformed 
This shows the finite element model on the original solid. 
 
Model Result>Deformation>Set Scale 
The user can change the scaling factor at any time.  A deformation scale control dialog will be 
show for setting. 
 
Model Result>Deformation>Auto Scale 
When this flag is on, the program will automatically scale the deformation pattern such that the 
displacement is scaled to about 5% of the screen size. 

Deformation Animation 
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Model Result>Deformation>Animate 

  
 

This animates deformation of the selected step result on a continuous basis. The user can 
choose from a dialog box either to alter the scaling factor or to terminate the animation, or to 
apply a full/half sinusoidal variation of the deformation pattern for visual effect.  When the Full 
Sine option is used, the current deformation will oscillate from scale factor of –1 to 1, while the 
default Half Sine option varies from 0 to 1 scaling.  
This animation process is designed as a multi-threaded task, so the user can continue to do 
other graphic operations such as changing the color contour type or rotate the scene for a 
better view while this animation is on.  If the animation is too fast, the user can limit the refresh 
rate "Frame per Sec" to a lower rate, but the animation will not be as smooth. 
The buttons <<, <, >=, >, >> are for animation fast backward, backward, pause/play, forward, 
and fast forward correspondingly. Clicking the pause button will activate other motion control 
buttons, and the subsequent clicking of the pause button will resume to normal animation. 
When the model is very large, it is useful to turn off the face display to speed up the animation 
and uses only the element sides and nodes. This is useful for examining result since when the 
color contouring of the result on FE sides and nodes is still available. Reducing the "Frames 
per Cycle" will also increase the animation speed. 

 
Model Result>Deformation>Time/Step Animate 

  
This animates deformation from the available time/step results on a continuous basis, as 
compared to the single step deformation scaling animation. The user can choose from a dialog 
box either to alter the scaling factor or to terminate the animation, or to select the step 
increment number in order to speed up the animation when lots of time steps results are 
produced. When the Full Sine option is used, the result animation will start from step 0 to step 
n at an increment as specified, then decrease back to step 0 with the decreasing steps 
entered.  The Half Sine will just repeat from step 0 again, instead of gradually decreasing the 
result step animated. 

 
The Save AVI option will capture the animation frame and convert them into Windows' movie 
AVI animation for later viewing. When this button is pressed, an optional dialog box will pop up 
for AVI capturing setup for either a single or multiple animation cycle capturing.  
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The AVI format contains a wide spectrum of compression methods pending on the installed 
AVI COM tools on the Windows system. Usually, the "Microsoft Video 1" 75% compression is 
a reliable choice. 

 

User Result Type 

User Results 

 
This menu provides tools to create additional results that the user may create from the current 
available results. The "User Defined Result Type" allows a symbolic math type operation on 
the existing result variables. The "Normal/Shear by Direction" allows the user to create stress 
result on a specific direction so they cab be used for additional contouring or inquiry purpose.  
Once the additional results are created, they will be in the active section till the user deletes it 
from the memory by using the "Delete User Result" menu. 

Customized User Result Type 

This option allows the generation of a new user defined result type by specifying a 
mathematical expression of how to compute the value from the existing result types that are 
created by AMPSol calculations. The user can create a new result type using the provided 
mathematical expression and the existing result type names. After the result type is created, it 
can then be used in contouring, node/element result inquiry, plotting, or integral inquiry. 
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Currently, the support expressions are: 
 +  Addition 
  -  Subtraction 
  *   Multiplication 
  /  Division 
  %  Mod (remainder) 
  ^  Power 
  (  Left parenthesis 
  )  Right parenthesis 
  sin()  Sine function 
  cos()  Cosine function 
  tan()  Tangent function 
  abs()  Absolute function 
  ln()  Natural log 
  exp()  Natural power 
  atan() Arc-tangent 
  sqrt()  Square root 
  0..9  Numerical numbers 
  e  Scientific number (e.g. 1.e-5) 
  
For example, the deformation magnitude can be defined as  
disp_mag = sqrt(dispx^2+dispy^2+dispz^2) 
Currently, only five lots of user defined variables are available, but they can re-use or deleted.  
User Result Type>Generate/Compute New Result Type for all Nodes 
Pressing this button will create a new result item base don the result expression give. It is 
suggested that the user test the result expression by pressing the "Test/Evaluate New Result 
for the Specified Node" to check the validity of the expression. 
 
User Result Type>Delete the Specified user Result Type 
Delete the already specified result item, if exist. 
 
User Result Type>Retrieve the Expression of the User Result Name 
If the specified result type name is valid and exist, pressing this key will retrieve the original 
result expression and put the numerical expression into the equation field at the lower portion 
of the dialog box edit field. 
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User Result Type>Test/Evaluate New Result for the Specified Node 
Usually, after enter the numerical expression in the equation edit field at the bottom of the 
dialog box edit field, it is recommended to test the expression by checking the numerical result 
at the node user specified. This is to ensure a correct expression before the program compute 
and generate the new results for all nodes. 

 

Normal/Shear Stress by direction 

 
This control allows the user to generate normal and shear stress at the direction that of interest 
in interpreting the result.  The default result names generated are "NormalStress" and 
"ShearStress".  The normal stress direction is computed on the specified Normal Direction, 
and the shear stress is computed on the Shear Direction as entered.  Before the normal and 
shear stresses are computed, both direction vectors are first normalized, and the Shear 
Direction vector is adjusted to make sure it is perpendicular to the normal direction. The user 
can examine this normalization process by clicking the "Normalized and check direction 
vector" to see the new direction vectors to be used in the calculations. 
After the direction vectors are entered, clicking the "Compute Stresses…" button will start the 
generation of these two additional stress results to be used in contouring or inquiry. 

Deleting Generated User Result 

 
This menu allows the user to delete the user-generated results after they are no longer 
needed. This is meant to conserve the limited user result slots initially allocated by the system. 

FE Inquirer 

FE Inquirer by Node 

This option allows the user to select a node and display type. Its value will be displayed in a 
dialog window as shown. For more information about the Result Type, please refer to the 
descriptions in the Contour display session.  
While the inquirer is active, as the cursor move across the model, the nodal result is 
automatically retrieved. The information includes the node number, the coordinate values, and 
the associated value of the selected result type and time/step. If the user assigns the mouse to 
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other pointing function such as rotation, the inquirer becomes inactive sleep mode. It can be 
activated again with the Activate/inquirer button. 
Another good use of the inquirer is to add the result value of different nodes.  To use this 
function, first switch the mouse function to the FE entity selection, then select the nodes of 
interest, then press the button of "Sum Selected Nodes' Result".  This is useful for user to find 
out data such as the total reaction on a fixed face, or the total heat flow from the convective 
boundary condition, or merely to sum the nodal results. 
 

  
 
Plot Selected Nods' History 
The FE Inquirer is also used to produce nodal time/step history plots. The user first selects a 
node or nodes using the node selection control. The node selection control may be found in 
the Selection>FE select>node only option or its icon. Then the user selects a desired type from 
the Result Type pull-down list. Finally, the plot Selected Node's History is pressed in the FE 
Inquirer. This produces a time/step history plot for the node with the selected result type. The 
history plot can be deleted and a plot can then be repeated by selecting another result variable 
or by selecting another node.  If you select multiple nodes by depressing the shift key, these 
nodes' history will be shown as multiple curves with different colors. 
Plot Selected Nodes Results along geom Line index 
The FE Inquirer can also generate a nodal result plots along a user define line based on the 
distance from the line origin.  The nodal coordinate is first projected to this geometry line by the 
closest position to the line, and the distance of this projected point to the line origin is 
computed as the horizontal coordinate of the history plot diagram.  If the geometry line ID 
specified does not exist, the user is prompted to enter the required information to define the 
analytical geometry line. This process is repeated for all nodes selected and the current 
time/load step nodal result values are plotted along based on their distance from the line's 
origin. 
 
 

FE Inquire by Element 

This option allows the user to inquire an element's connectivity and, if available, the result 
closest to the point under the cursor.  
While the inquirer is active, as the cursor move across the model, the element's connectivity 
nodes are automatically retrieved. The nodes defining the current element is displayed in the 
dialog box, and the node number is also shown graphically next to the node's position for easy 
inspection. If the user assign the mouse to other pointing function such as rotation, the inquirer 
becomes inactive sleep mode. It can be activated again with the Activate/inquirer button. 
When there are element-based results available, the "Result" box will show the result closest 
to the cursor position, usually at the corner node area.  Note that element-based results could 
be discontinuous across the element boundary, as compared with node-based results that are 
shared across the element connecting to that node. Typically, these element-based results are 
at the integration location without any additional extrapolation. For beam/rod element, the 
result type is their end forces (local forces and moments). For shell element, the results are 
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their nodal end forces (global forces and moments), and the closest integration point result for 
the shell's front and back face.  When contouring the result using the default "Contour Type" 
option, the shell's mid-plane results are shown.  Using this element inquiry option will allow you 
to see the results of the front and the backsides of shell element analysis.  
 

 
 

Inquirer Time Plot 

The FE Inquirer is also used to produce nodal time/step history plots. The user first selects a 
node using the node selection control, and selects a desired type from Result Type pull-down 
list. Then the plot Selected Node's History is pressed in the FE Inquirer. This produces a 
time/step history plot for the selected result type. The history plot can be deleted and a plot can 
then be repeated by selecting another result variable or by selecting another node.  If you 
select multiple nodes, then these nodes' history will be shown as multiple curves with different 
colors.  
 

 
FE Inquirer by Integral 

This option allows the user to perform an integral calculation over the specified surface (3D) or 
side (2D).  To perform the integral calculation, specify the integral type, then select the 
geometry surfaces or edges, or element faces or sides where integration is desired. 
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Two special integration calculations are provided. The heat flow calculation integrates dot 
product of the heat flux and the surface normal over the specified area/side. The result is the 
total heat flow across the surface/side. The second special heat flow integral uses the user-
specified normal instead of the surface normal. The resultant integral is the heat toward the 
direction of the user normal.  For the rest of the result type integral, it simply integrated the 
result over the specified region. 
If multiple-step results are available, "Plot Integrated Result History" will also plot the 
integrated result against time/step to give a history diagram for examination. 

Finite Element Menu 

FE Group/Display 

Selection>FE Group/Display 
Bring up a dialog box for finite element nodes and elements grouping and display control. 

 
Finite Element>FE Group/Display>Display Grouping 
The radio selection button selects the "Node" or "Element" type to control 
 
Finite Element>FE Group/Display> 
HideSelected/UnHideSelected/ShowSelectoinInfo/UnHideAll 
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After making a graphic element or node selections, clicking the hide button will automatic 
remove their's appearance, or to show index info/unhide the selected index group. UnHideAll 
button can be used to show all hidden FE items. 
 
Finite Element>FE Group/Display>Add/Update/Save/Delete 
After select the elements or nodes graphically, clicking the Add button to add a new group to 
the database. The index display will increase by one to show the index used in storing this 
display group. The Update/Save button will replace the current shown index group with the 
selected items.  Delete will delete the current database index. 
 
Finite Element >FE Group/Display>HideGroup/UnHideGroup 
Hide or unhide/display the element or node group items stored in the current database index. 
 
Finite Element >FE Group/Display>Show Selection Info/Previous Item/Next Item 
If there are highlighted selected items, clicking the "Show Selection Info" will display the total 
items in the selections, their index value or element/node/Face/Side index. This is strictly for 
information purpose.  If there are more than one items selected, clicking "Previous" or "Next" 
item button will cycle through selection list and display the proper info. 
 
Finite Element >FE Group/Display>Optional Numeric Selection 
Instead of using graphic mouse selection, the user can enter the items desired by using this 
numeric selection by specifying range of "Start No" and "End No", and optionally specifying the 
increment during this range calculation.  Press the "Set" button to activate the selection 
highlight for visual inspection and for later hiding or grouping function. This numeric selection 
method is useful when you want to precisely select a range of elements or nodes. 
 
Finite Element >FE Group/Display>ANALYSIS Database Grouping 
AMPView maintains a geometry database for geometry items such as solid body, face, edge, 
and vertices selection. The geometry database relates the geometry to the element, element 
face, element side, or nodes. This database is automatically created within the 
AMPS/AMPSolid mesh generator and is shown here for user reference. These 
insert/remove/replace/create/delete geometry database button can also served as a tool for 
the advanced to modify these geometric relation to the finite elements and nodes. Sometimes, 
if an external mesh is imported into AMPView, these geometry database may not exist, and 
these database grouping tools can be used to create the elements and nodes relationship to 
the geometric entities.  
 
Currently, the geometry database entities used in AMPS system are: 
 
BODYMATERIAL 
Assigns the association of the 3D elements' material type 
BODYELEMENT 
Relate the association of the 3D elements to the geometric solid entity 
FACEMATERIAL 
Assigns the association of the 2D/shell elements' material type 
FACEELEMENT 
Relate the association of the 2D/shell elements to the geometric face entity 
FACEELFACE 
Relate the association of the 3D elements' face to the geometric face entity 
EDGEELSIDE 
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Relate the association of the 2D/shell elements' side to the geometric edge entity 
FACENODE 
Relate the association of the FE nodes to the geometric face entity 
EDGENODE 
Relate the association of the FE nodes to the geometric edge entity 
VERTEXNODE 
Relate the association of the FE node to the geometric vertex entity 

 

Create/Modify/Inquire Nodes 

This menu allows the user to create/modify/inquire the node, also informs the user of the 
maximum node number used so far. To create/change the node, enter the node number and 
coordinates desired. Sometimes when the mouse function is switched into other function, it is 
necessary to "Activate Inquirer" to attach the mouse function back to this dialog control.  
Since it is not safe to delete node, the unused nodes will only be deleted internally when 
"Optimize Mesh" is performed after checking the nodes are not used and are safe to delete. 

 

Create/Modify/Inquire Element 

This menu allows the user to create/modify/delete/inquire the element, also informs the user of 
the maximum node number used so far. To create/change the element, enter the node number 
of the element. Sometimes when the mouse function is switched into other function, it is 
necessary to "Activate Inquirer" to attach the mouse function back to this dialog control. 
 
When creating/modifying the nodes, the user can enter the node numbers desired, or use the 
node selection mouse function to selected the nodes in the sequence forming the connectivity 
of the element, and click the "Fill node from selection" button. 

 

Coat Shell Elem on the Selected Elem Faces 

This menu allows the user to create the 3D shell element on the solid elements' face.  Using 
this option, the shell element is created on the pre-selected solid element face and will share 
the same nodes with the underneath solid element to ensure tight continuity in the constitutive 
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behavior.  The user has the choices of changing the shell elements' starting number and the 
material property group, also the geometric association of the FACEELEMENT group if 
desired. 

 

Coat Beam/Rod element on the Slected Element Sides 

This menu allows the user to create the 2D/3D beam or rod elements on the existing element 
side or geometry edges.  Using this option, the beam/rod element is created on the pre-
selected edge will share the same nodes with the existing 2d/3d element to ensure tight 
continuity in the constitutive behavior.  The user has the choices of changing the elements' 
starting number and the material property group, also the geometric association of the 
LINEELEMENT group if desired. 

 

Finite Element Graphic Display 

  
 

Finite Element>Graphic Display>Hide Hidden Elements' Edges 
When this option is checked, the element's side will not be shown if it is a hidden element. This 
option is useful if very complex elements exist in the model and the user desire a different 
option of displaying the hidden elements. 
 
Finite Element>Graphic Display>Hide Hidden Elements' Faces 
When this option is checked, all elements' internal sides that are shared with other elements 
are hidden. It is mainly used to show only the solid surface without showing the internal faces. 
This option is useful when checking whether there is an internal gap or void in the solid 
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elements. It is also useful in large model animation since the internal invisible faces are 
removed from the view scene for faster display.  When it is activated the first time, an internal 
database will check these internal faces and hide them after sorting, for large model, this may 
cause a little delay in graphic response. However, subsequence operations will no longer need 
this sorting. In AMPS version 1.72 and above, a fast hashing table searching algorithm is used 
to quickly find out these internal faces, but may still last for couple seconds if a large model is 
being viewed. 
 
Finite Element>Graphic Display>Precise Hidden Faces Sort 
The menu is an obsolete control since all models are now processed through a precise hidden 
faces sort since a very fast sorting algorithm is used and examining millions of elements only 
take few seconds.  
 
Finite Element>Graphic Display>Use Automatic Graphic Update/Update Display Now 
When this option is checked, if any element or node is modified, the graphic will be 
automatically updated.  However, in situation of a very large model, it may be desirable to 
disable this function during the element or node editing/modifying process, and manually 
update the graphics using the "Update Display Now" option. 
 
Finite Element>Graphic Display>Update Display Now 
Clicking on this menu will force the program to regenerate all graphic display and refresh the 
screen as if it has just been freshly loaded. The main use of this control is to overcome 
situation when a corrupted display may occur due to poor graphic card's update ability or any 
unexpected runtime error.  
 

Optimize Mesh 

AMPView will try to optimize the finite element ordering by reordering the nodes and elements 
using a customized graph optimization method, and then remove the gap in the order, if any.  If 
there are dummy nodes that are not used in the elements' connectivity, the user will be 
prompted to either delete them, or to attached them at the end of the model. It is 
recommended to always optimize the mesh for medium and large problem since the cost of 
the optimization is fast, and the saving in solution time cold usually be as high as 50% or more.  
If the model contains nodes that are not used in any element reference, they will be removed 
after the user confirm that these nodes are not necessary.  
AMPView uses an advanced graph traversal scheme to optimize the node and element 
numbering scheme so they will produce both the minimum frontal width and the smallest 
direct/profile solver storage requirement.  Usually, one pass of the graph searching will 
produce the optimum ordering, and subsequent optimization will not produce any 
improvement. More information of the graph traversal theory can be found in "Fundamental of 
Computer Algorithms," E. Horowitz and S. Sahni. 
 

Import External Model 

This menu allows the user to import another AMPSol model into the current active model in 
AMPView.  The new model is attached to the existing model by renumbering their nodes and 
elements after the existing ones. Since there are geometric entities associate with the AMPSol 
finite element model, these data are also appended after the existing one.  To avoid conflict 
with the current model definition, only the mesh-associated information is merged into the 
current model, and the external model's material and boundary condition are neglected. 
 

View Menu 
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The View Menu 

The view menu allows the user to select the details of the graphic components 

  
Fig. 6.1 The View Menu 
 
These menu items are used to rotate, zoom, pan the view camera, and they have their 
associated icons for more convenient activation.  There are several preset camera view angles 
predefined for common view settings. 
To use the view camera orbit/zoom/pan feature, hold the left mouse button, and move the 
mouse's cursor across the screen. This will trigger the camera rotation, panning and zooming 
function. 
. 

Display Menu 

The Display Menu 

This menu allows the user to choose some display controls. 

  
Fig. 7.1 The display Menu 
 

Display>Orthographic, Perspective 
The user can change whether to use an orthographic or a perspective display. The default 
setting is to use the perspective display with depth effect. 

 
Display>Display Lists 
On some machines with high end display memory controls, it is much faster to store the 
OpenGL data in a display list memory buffer and then, as the user refresh the screen, just to 
reuse these objects from the display list buffer.  The user can compare the difference and 
select this option if it helps in displaying large models. 
 
Display>Smooth View Transition 
When this option is on, when the user change from one view camera angle to another one, the 
program will use a transitional effect to rotate the view from the old position into the new 
position. Using such effect, it is usually easier to follow the geometry details of the model. 
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Display>Zoom to Selection 
When this option is on, the selected entities (elements, nodes, face, sides) will be 
automatically placed in the center of the screen and magnified. This option is useful when the 
user is reviewing a model, and prefers the program to automatically change the view and zoom 
into the geometry selection corresponding to the items being reviewed. For a very large model, 
sometimes this automatic zooming may take some time, and can be optionally turned off, if 
necessary. 
 
Display>Zoom+Rotate to Selection 
Other than just zoom to the selected items, if this option is used, a proper camera angle will be 
computed for the best viewing angle to these items. Since some selections contain only nodes 
or items are hidden inside the body, the computed angle may not be the optimal view angle for 
some cases. 
 
Display>Transparent View 
Sometimes, it is difficulty to identify the object/entity buried in the model (such as internal 
faces, side, etc). Normally, it is necessary to hide the exterior elements so the inner elements 
faces/side can be selected or examined. The transparency is another convenient way of 
identifying such selection. If the option is on, the user can examine the internal semi-
transparent object to ensure whether they selected or not, or to examine their results. This 
option is also very useful when it is used in Selection Filter (see Selection/SelectionFilter) 
control to confirm the Depth Selection operations. 

 
Display>Level of Detail 
To speed up the display of some extremely large model, the "Level of Detail" option can be 
constraint can be used.  To use this option, activate this selection, and the desired level of 
details in the "Level of Detail Options" slide bar. 
 
Display>Level of Detail Options 
This will show up a slide bar to control the selection of the desired level of detail. 
 

 
Cutting Plane 

Cutting Plane Menu 

These cutting plane toolbar icons allow the user to insert/define/translate/rotate/delete a cutting 
plane. 

  
The cutting plane passes through the centroid of the solid model and is normal to the screen. 
All parts closest to the user are eliminated. To be precise all elements cut by the slicing plane 
are hidden. Contours are then redrawn on all the faces. The user may also display a grid on 
the cutting plane. Multiple cutting planes can be specified in order to zoom in to the desired 
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region. Details of the display controls can also be found in 
Options/Visibility/Cutplanes/cutlines/cutgeometry 

  
There are three preset cutting planes, XY, XZ and YZ cut planes. After clicking on each icon, 
the cut plane will show up. By clicking the icon again, the cut plane will be removed. Three 
cutting planes can all be active. For each cutting plane, there is a tri-axis cut plane translation 
arrow along the cut-plane normal direction, and two cut-plane rotation control arrows. By 
holding the mouse left button while pointing the cursor at the either the rotational or 
translational arrow and move the mouse, the cut-plane can be placed into the desired 
orientation. 

 

Options Menu 

The Options Menu 

This menu allows the user to control the display of the F.E. geometric entities such as 
elements and nodes 

 
Fig.8.1 The Options Selection Level Menu 
 
Options>Display Axis 
When this option is turn on, the Cartesian coordinate axes are displayed at the origin. Note 
that for easy manipulation and identification, a mini axes display is always available at the 
upper right corner. 

Option Visibility 
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Fig. 8.2 The Options Visibility Menu 
 
Options>Visibility>items 
This allows the user to select or deselect the geometric and control entities to be displayed by 
toggling the appropriate menu item.  
Points/Markers: these are used for nodes and geometric vertex display. 
Lines: Toggles geometric line display. 
Edges: Toggles edge display. They are usually for display F.E. sides 
Faces: Toggles face display. These are for displaying element surfaces/faces 
Lights: These are the light effect display controls 
Grids: Grids are used to display objects such as cutting planes 
Text: Text strings 
Cutting Planes: The switch toggles the cut-plane filler visibility. 
Cutting Lines: The cutting plane creates a cutting lines when it cuts across the elements. This 
option toggles the cutting line display. 
Cutting Plane Geometry: This option toggle the visibility of the transparent cut-plane image. 
Hidden Lines: Toggle the hidden line display option.  

Option Render Mode 

Options>Render Mode 
This allows the user to select the type of rendering 
 

 
Fig. 8.3 The Options Render Mode Menu 
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Wireframe: display only the element sides 
Flat shaded: this is the default option of shading for F.E. display. Although more complex 
shading options such as Gouraud/Phong shading can be used, flat shading represent the 
discrete nature of element surface best. 
Gouraud Shaded: This is an option for a geometry object rendering. 
Phong Shaded: Another option for geometry object rendering. 
Hidden Line: display only hidden lines. 
Color Interpolation: this option allows changing the coloring algorithm. For finite element 
objects, the color setting is completely automatic, and this option does not affect all F.E. 
display, except for imported geometry objects (such as data from AutoCad metafile). In such 
case, the coloring can be either by value or by an index mapping. 

Option Color 

Options>Color 
This allows the user to change the screen background color and the highlight color used in the 
selection operation. 
 

  
 

Options>Color>Material Color 
When selected, the model will be color coded to represent different material property 
assignment. 
Options>Color>Background 
When selected, a color menu will pop up to allow background color selection. 
Options>Color>Background Bottom 
When selected, a color menu will pop up to allow the optional bottom background color 
selection. 
Options>Color>Highlight 
When selected, a color menu will pop to allow the selection of the color to be used in selection 
highlight. 
Options>Color>BC Display 
When selected, a color menu will pop to allow the selection of the color to be used in display 
Boundary Condition Geometry highlight. 
 

Option Size 

Options>Size 
This allows the user to change the default node or element side display size for visibility 
convenience. 
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Options>Text>Node/Point Size 
This will bring up a menu to inform the user of the current node/point display size. Depending 
on the graphic hardware, this is usually the pixel size. The user can change it to larger or 
smaller to ease the visibility. To reset to the default setting, enter zero size. 
Options>Text>Side/Line Size 
This will bring up a menu to inform the user of the side/line display weight. The default weight 
is one.  The user can increase or decrease it to ease the visibility. To reset to the default 
setting, enter zero weight (or one). 
 

Option Text 

Options>Text 
This allows the user to insert an annotation text into the scene and control the type of text to be 
displayed 
 

 
Fig. 8.4 The options text transform menu. 
 
Options>Text>Insert Text Notation 
This allows the insertion of a string of text with pointing line to annotate the model for additional 
clarity or presentation purpose.  After activate this icon, click on the part of the object where 
the root of the pointing line should be, then click a 2nd time to indicate the text location. A 
pointing line will be immediately inserted to the scene.  Finally, finish this operation by typing a 
string of text to be inserted at the end of the pointing line. 
 
Options>Text>Transforms>off || Character Position || On 
The inserted text string can be applied with transformation matrix. It is normally not necessary 
to do so, and the default is off. If desired, the transformation can be applied. 
 
Options>Text>Fonts>Roman || Aerial || Cave 
The inserted text string's font can be changed using this option. 
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Fig. 8.5 The options Text Fonts Menu 
 
Options>Color>Background || Highlight || Default 
These options are not active as of the current release, but have been included in the next 
development planning. 
 

Window Control Menu 

The Window Control Menu 

This allows the user to control the contents and view of the active window. The active view is 
always display at the end of this menu with a check mark, and can be selected to activate the 
view focus, that is, a view that has the mouse/keyboard attention. 

 
Fig. 9.1 The Window Control Menu 
 
Window>New Window 
This New Window feature allows adding additional view of the same model to the view list.  
Using this multiple-view option, the user has more flexibility to examine the model and results.  
There is no limit to the number of additional views can be added, as long the system has 
enough memory.  Care should be exercised when multiple views are active, because each 
view window has it own associated selector, inquirer, etc. 
 
The current version of AMPView is designed to handle a single model, but can have multiple 
views for model display. This is due to the internal animation control design. If the user desire 
to view a different model, the current model will need to close and the new model opened, or to 
activate another instance of AMPView and examine the new model there.  The future version 
will allow multiple models to be opened in the same AMPView execution. 
 
Window>Cascade 
When multiple views are active, this option will cascade the view windows. 
 



AMPView 

89 

Window>Tile Horizontal/Vertical 
When multiple views are active, this option will arrange the view windows in the desired tile 
fashion. 
 
Window>Arrage Icons 
When multiple views are active and ionized, this option will arrange these icon so they will be 
visible and in order. 
 
Window>Toobar/Status Bar 
These are options to turn on/off the toolbars.  

File Toolbar 

   
File control bar. The first icon saves the model data into a file. The second icon allows copying 
the scene image to the Windows' clipboard for other standard applications image pasting. The 
last icon prints the scene in the current display window. 
 

  
Help bar. The first icon selects the online help file. The second is the interactive context 
sensitive "What is this" help. To use this feature, click on the menu, icon, or dialog, or position, 
and the program will automatically bring up the related help information. 

 

View Toolbar 

 
View bar. This gives us the isometric and the three standard views. 

 

Display Toolbar 

   
Display Control bar. The first icon allows a prefixed zoom-all view, while the second is a zoom 
by window control.  The next 3 icons are the interactive pan, rotate, and zoom size control 
icons. To use these three controls, hold the left-hand-side button and drag the mouse across 
the screen to achieve the desired motion. 

 

  
Finite element display control bar. This bar allows the various finite element features to be 
displayed. These are element faces, sides and nodes display controls. The last icon, when 
clicked, will display the model in transparent mode. 
 

 
Annotation bar.  This allows the insertion of a string of text with pointing line to annotate the 
model for additional clarity or presentation purpose.  After activate this icon, click on the part of 
the object where the root of the pointing line should be, then click a 2nd time to indicate the text 
location. A pointing line will be immediately inserted to the scene.  Finally, finish this operation 
by typing a string of text to be inserted at the end of the pointing line. 

Select Geometry FE Toolbar 
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Geometry selection bar. This selection bar defines the type of finite element entities that can 
be selected by referring to the solid model entities. The first allows all solid elements to be 
selected through solid block selection. The second allows all 2D elements corresponding to a 
surface to be selected. The third allows all 3D element faces matching a solid face to be 
selected. The fourth allows all solid element sides corresponding to the geometry edge to be 
selected. The fifth allows all solid element nodes corresponding to the geometry edge to be 
selected. The sixth allows all 2D element sides corresponding to the surface edge to be 
selected, while the last allows a solid element node matching the solid vertex to be selected. 
 
By using these type solid/surface model based element, face, side, node selections, the user 
can use the FE property or boundary condition even after the meshes are refined. Also, a 
single solid, face, or edge selection will immediately include all associated elements, element 
faces, element sides, or nodes.  
  

  
F.E. selection bar. This filter bar defines the type of finite element entities that can be selected 
based on the finite element mesh. The first allows selection of elements. The second allows 
selection of element faces. The third allows selection of element edges. The fourth and last 
allows selection of nodes. 
 

  
Select clear bar. The will clear all the current selection. 
 

Result Display Toolbar 

  
Result Display toolbar. These are the toolbar for quick access to result display.  The first one 
select the type of contour display option, and the second one remove the contour display. The 
3rd one presents a dialog box for vector result plotting control, and the 4th one remove the 
vector result display. 
For animation, the camcorder icon (the 5th one) will animate the current result with an 
animation controls. The last camcorder icon is for multi-step result display control. 

Cut Plane Toolbar 
 

  
 
Cutting Plane Bar.  These are the transparent cutting plane control icons. The first three icons 
activate a cutting plane insertion operation in the predefined YZ, XZ, and XY planes.  When 
the cutting plane is active, the user can drag the cutting plane translation handle to move the 
cutting plane, and to rotate the rotational handle to rotate the plane.  To remove the cutting 
plane, click the corresponding active cutting plane icon. 
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For precise cutting plane placement, an additional cutting plane placement control can be 
activated by clicking the last cutting plane icon to manually input the cutting plane's normal 
direction and an origin of the cutting plane. 

Help Menu 

The Help Menu 

This allows the opening of the online Users manual or a brief description of the AMPView 
Program 
 

 
Fig. 10.1 The Help Menu 

 

Help>Help Topics 
This will bring up the on-line reference help. 
 
Help>About AMPView 
This will bring up the AMPView version and user's system information. They are necessary 
and useful when a user run into a problem, and need technical assistance.  
 

Finite Element Features of the Solvers 

The finite Element features of the solver are listed here. The actual implementation is by 
means of the appropriate selection in AMPView. Where possible, the online version of this 
document will have links to the relevant section of AMPView. 
 
Element features 
The current supported element types are: 
ROD, 
BEAM, 
TRI3, TRI6 
QUAD4, QUAD9, QUAD16, QUAD25 
HEXA8, HEXA27, HEXA64, HEXA125, 
TETRA4, TETRA10 
PYRAMID5,PYRAMID13 
SHELL3, SHELL4, SHELL6, SHELL9, SHELL16, SHELL25 

Element side or surface Boundary Condition Types 
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The boundary conditions that can be applied to the side or surface are given in the following 
table. 
Bc element side BC type description 
Global Force  Force1,force2,force3. Surface global direction traction (s11,s22,s33) 
Normal Pressure Surface normal pressure (positive when applied away from surface) 
Radiation Alpha and T ambient. Radiation=alpha(t**4-Tamb**4) 
Convection Conv. coeff and tconv required, conv to ambient heat flux=a(t-tconv) 
Flux Flux value 
Velocity/Vorticity Fluid Velocity or Vorticity values 
Pressure Fluid flow pressure scalar value 

 

Tutorials 

AMPSol Tutorial 

If you are first time user of AMPS AMPSolid AMPSol and AMPView, we strongly recommend 
that you run through the AMPSolid and AMPSol tutorial included in the AMPS package. That 
will give you a more overall view of how the program is designed to help you solve real life 
problem, and the suggested method of performing finite element analysis using AMPS. 
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