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MxConverter installs its icon into Programs folder in Start menu. Please notice and take advantage 
of following advanced features in MxConverter:  

• Converting multiple units at once  
• In place expression evaluation  
• Supports of various unit formats beside default numeric: compound values, date time, 

computer bases.  

To convert between units: 

1. Select Open from File menu to find and open an unit category (MxConverter starts the first 
time with currency conversion). 

2. Tap on the check list icon on the upper right corner to elect units you want in the calculation 
list. There is no limit on number of units. 

3. Highlight an unit then enter its value. 

Results for other units are calculated simultaneously as you type. Some units display values in 
multiple formats. Tap on the format icon on the left side to change its formats. 

See Also: 

• Entering values and expressions 
• Customizing formats 
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Depend on the unit, you can enter its value in the format of numeric expression, compound values, 
date time or other computer bases. 

Numeric 

In numeric/calc tab, any arithmetical expression that includes numbers and built-in operators and 
functions is accepted. 

Numbers must be entered in following formats: 

[-][digits][.digits][e[-]digits]  

Following examples are valid numbers:  
-10.25 
.25 
2e-15 
-123.456e78 

Value ranges: 

Min/Max: -10e300 to 10e300 
Maximum exponent: 300 
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Minimum exponent -300 

Compound values 

MxConverter provides a masked compound edit box for certain units. For example with US/UK 
pound, you can enter 1 lbs 4 oz. 

Compound values can also be entered in a numeric expression if you enable default decimal 
format for the unit.  To write the value, surround the values in a pair of square brackets. With the 
above example, you can enter [1 lbs 4 oz] in a numeric expression. 

For example, [1 lbs 4 oz] + 1 will give you the equivalent result of [2 lbs 4 oz]. 

Date time 

MxConverter by default provides a masked date time edit box so you can enter the values in 
easiest way. 

Date can also be entered in a numeric expression if you enable default decimal format for the unit. 
Please read more in this section to learn more about how to work with date values in numeric 
expression. 
 
Values within a pair of curly brackets “{}” will be parsed as a date value. The day/month order 
complies with the machine regional setting. For example on computer with US setting date format 
is mm/dd/yyyy, where mm is month, dd is day, yyyy is 4 digits year. The symbol is separate parts 
of a date is flexible. In fact you can use any symbols. 
 
Followings are valid dates in a numeric expression: 
{5/18/2002} 
{05/18/2002} 
{5.18.02} 
{5-18-2002} 
 
Followings are not valid and will not be accepted: 
{18may2002} 
{May 18, 2002} 
 
Numeric equivalent value of a date is based on the number of days since 4713 BC. This value is 
also known as Julian date. January 1st, 0001 has Julian date value of 1721423 and January 1st 
2000 has Julian date value of 2451544. 
 
On that basis, you can do date calculation. Followings are some examples: 
{02/01/2004} + 7  result is {02/08/2004} or 2452313 (Julian date) 
{02/01/2002} – {01/20/2002}  result is 12 
 
One of the files you can use to calculate date values is “Date Calculator”. 

Computer bases (Hexadecimal, Octal, Binary) 

For some units, MxConverter provides special input tab for Hexadecimal, Octal or Binary format. 
For example if you enter A0 in Hexadecimal tab, it will be translated as 160 in decimal. 
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You can also enter Hexadecimal, Octal and Binary numbers in default decimal tab, provided that 
you follow following formats: 

Format: [0]digits[base signature] 
Signatures: h = Hex b = Bin o = Oct 
For example:  
123 (decimal),  
0AF56h (hexadecimal),  
010110110b (binary),  
765231o (octal) 

Integer internal storage: 32 bits  
(80000000h to 7FFFFFFFh 
 or -2147483648 to 2147483647) 

See also: 

• Built-in operators and functions 
• Customizing formats 
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To create a new blank unit conversion file: 

1. Select New, Unit Conversion from File menu 
2. Enter a title of the file in Title field 
3. Enter a new category or select an existing category in Category field 
4. Enter a new file name 
5. Select OK to create the new file. 

With the blank conversion file, start adding units to it: 

1. Select Add Unit from Edit menu 
2. Enter unit full name in Name field. 
3. Enter unit short name in Identifier field 
4. Enter default value expression (usually 0) in Value field. 
5. Select OK to save new unit. 

After the unit is added to the conversion, you need to define formula to connect it to other units. In 
other words you need to tell MxConverter how to calculate its value from or to other existing 
units. To add a conversion formula: 

1. Select Conversions from Edit menu 
2. Select Add button to add a new conversion formula. If the conversion is as simple as multiply 

other's value with a constant (linear), select standard. If the formula involve more complex 
calculation, select Advanced.   

3. Select the first unit in From field, and second unit in To field. Enter constant or formula in 
formula fields. 

4. Select OK to save. 

With every new unit, you need to add one formula to calculate its value from another one. 
MxConverter is smart enough to compute between 2 units that do not directly connected. For 
example if you have a new currency called XYZ, all you need to do is adding a conversion 
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formula from XYZ to USD (or another currency). MxConverter knows how to convert from EUR 
to XYZ by using 2 formulas: EUR to USD then USD to XYZ. 

If you select Advanced to create a complex formula between 2 units, use variable named x as an 
input value of the calculation. There will be 2 formulas to enter: 

• Forward: Convert value from Unit 1 (From) to Unit 2 (To) with x being value in Unit 1 
• Reverse: Convert value from Unit 2 (To) back to Unit 1 (From) with x being value in Unit 2. 

For example converting between Miles per Gallon and Gallons per Mile: 

Forward formula: 1/x 
Reverse formula: 1/x 

See also: 

• Creating new calculation 
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Calculation is a special variation that work differently compare to unit conversions. With a 
calculation, you can enter several input rows (parameters) then let MxConverter calculate other 
output rows. 

Calculation is one way. You enter values in some rows and see results in other rows, but not 
reverse way. 

To create a new blank calculation file: 

1. Select New, Calculation from File menu 
2. Enter title text in Title field 
3. Enter a new category or select an existing category in Category field 
4. Enter a new file name 
5. Select OK to create the new file. 

With the blank calculation file, start adding rows to it: 

1. Select Add Unit from Edit menu 
2. Enter row full name Name field. Let's call each row a parameter. A parameter can be output 

(computed from other values) or input (you will enter its value) 
3. Enter an unique identifier in Identifier field. Identifier is the name you will use in formulas to 

compute other rows. 
4. Enter default value if the parameter type is input or a formula if the parameter type is output. 
5. Select OK to save. 

Suppose we are creating a calculation to calculate area of a rectangle. Follow the instructions 
above to create a new file, then: 

1. Select Add Unit from Edit menu to add first parameter with Name: Length, Identifier: length, 
Type: Input, Value: 0 

2. Select Add Unit again to add second parameter with Name: Width, Identifier: width, Type: 
Input, Value: 0 
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3. Select Add Unit again to add output with Name: Area, Identifier: Area, Type: Output, Value: 
length * width 

See also: 

• Creating new conversions and units 
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To customize formats of an unit (for both displaying and inputting):  

1. Select format icon on the left side of the unit item to open the popup menu, then select 
Customize. 

2. Check boxes to select the formats desired. 
3. For compound format, enter series of fraction numbers and suffix labels. See below for more 

information 
4. Select OK to save changes. 

Fraction numbers of a compound format determine how the value splits up to smaller subsequent 
units. For example Day unit in Time conversion can be written in compound values as [2 days 3 
hours 4 minutes 5 seconds]. In that case the Fraction Numbers are: 1, 24, 60, 60 and the suffix 
labels are days, hours, minutes and seconds. 
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Operators: 

+    Addition 
- Subtraction 
* Multiplication 
/ Division 
^ Power 
\ Modulation 
! Factory 
2 Square 
3 Cube 
& Bit wise AND 
| Bit wise OR 
# Bit wise XOR 
~ Bit wise NOT 
> Greeter than, return 0 if false, -1 if true 
< Less than, return 0 if false, -1 if true 
= Equal, return 0 if false, -1 if true 

Functions: 

iif(c, x1, x2)  Return x1 if c is other than zero, x2 if c is zero 
err  Return immediately and display Error 
abs(x) Return absolute of x 
round(x) Return round of x 
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rand  Return a random number between 0 and 1. 
sqrt(n)  Square root of n 
E Return e number 
lg(x)  Return decimal logarithm n of x 
Pi Return pi number 
sin(x) Return sine of x 
cos(x)  Return cosine of x 
tan(x) Return tangent of x 
asin(x) Return arc sine of x 
acos(x) Return arc cosine of x 
atan(x)  Return arc tangent of x 
sinh(x) Return sine hyperbolic of x 
cosh(x) Return cosine hyperbolic of x 
tanh(x) Return tangent hyperbolic of x 
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MxConverter provides a built-in feature to download live Currency Exchange Rates from the 
Internet. In order to download the update, your device needs an Internet connection. It can be: 

• Active Sync pass through connection with a desktop PC that is connected to the Internet. 
• Direct Internet connection on your device (GPRS, WiFi, Bluetooth network access...). 

To initiate a download, select Download Exchange Rate from Edit menu when the connection is 
available. 

To find about the age of the current currency exchange rate data, open Currency conversion then 
select Properties from File menu. 

Tip: 

• To test the Internet connection on your device before downloading, open Pocket Internet 
Explorer then enter www.trancreative.com on address field. If you see TranCreative home 
page, then the connection is good. 
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After paying for the software, you will receive a registration key that includes your name and a 
number. The name is submitted by you and should be the same as the Pocket PC owner name in 
your device. In some software shopping stores it is called Pocket PC ID. The number is uniquely 
generated for the name. 

With the registration key, don't remove/reinstall the software if you have already had it installed. 
Entering the registration key successfully will unlock the software to fully functional mode. 

To enter registration key: 

• Start MxConverter 
• Open File menu, About MxConverter 
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• Tap on Register button 
• Enter the name and number exactly as in the order. The name must be in exact case as you 

submitted in the order form, without leading or trailing spaces. Please include all 
punctuations. 

After successfully enter registration, write down the name and number and keep it in a safe place. 
You will need the registration key again if you hard-reset the device or install the software to a 
new device. 

Common problems: 

1. Message: "The name or number is not valid": 
This usually because that you did not enter the name as you entered in the order form. We 
generate the number base on the name you submitted to us, not the name currently on your 
device. For example if you submitted in the order "John Smith", but now in your Pocket PC it 
shows "Mr. John Smith", then please enter "John Smith" to register. 
 
If you are sure the name and number are correct, please verify that the software version you 
are you using is correct. You can not use registration key of version 1.0 in version 2.0.  
 
There is a case when you don't know what was the name in the first place, then please contact 
the website where you placed the order. Most web sites have customer's area to lookup orders 
and registration keys. 
 

2. Lost registration key: 
You can contact the website where you purchased the software. If they can't find the record, 
please send proof of your purchase to TranCreative and we will issue new registration key for 
you.  


