
Importing Center



This manual is intended to help Lawn Monkey 2001 (LM) users import client
information from other software programs. The scenarios provided should be
used as guidelines to familiarize you with the importing process.  It is important to
realize that although the scenarios provided cover the major issues that most
users will encounter, they do not cover every imaginable step that could be
involved in your particular import process.

Before, reading this manual, we strongly recommend that you read the LM User’s
Manual p.p. 35-42.  This will familiarize you with the various fields used in LM’s
client information screen.  Being aware of the names, and the information
contained in each of these fields will help ensure a quick and error-free import.  It
is also strongly recommended that you read this manual through in its entirety
before beginning your actual importing of data.
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Creating an Import File

The process required to create an Import File that can be imported into LM is
detailed below.  Of the two scenarios provided, choose the one that most
accurately describes your situation and follow the pertinent steps.

Scenario 1

Your client information is currently entered a QuickBooks accounting
package.  You would like to create an export file from your
QuickBooks information that can be entered into LM 2001.

To create an export file from the QuickBooks information:

1) If you are using QuickBooks 99 or older: Click on File > Export.
Continue at #3.

2) If you are using QuickBooks 2000: Click on File > Utility > Export.
Continue at #3.

3) The Export screen will appear.  Click on the box to the left of
Customer List so that a check appears in the box.

4) Click on Ok.
5) Click on the drop down list in the Save In box and select Desktop.
6) Enter LM Import into the File Name box.
7) Click on Save.
8) Click on Ok.
9) The export file LM Import has now been created and placed on

your Desktop.

Scenario 2

Your client information is currently entered in a FoxPro program.
You would like to create an export file from your FoxPro information
that can be entered into LM 2001.

To create an export file from the FoxPro information:

1) Open your Microsoft Excel.
2) Click on File > Open.
3) Click on the drop down list in the Files of type: box and select All

Files.
4) Click on the drop down list in the Look in: box and select (C:).
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5) Click on the folder with the name of your program to the right of it.
For example, if the name of your FoxPro program is Lawn Basics,
click on the file named Lawn Basics.

6) Click on the Maindbf folder.
7) Click on the Customer.dbf file.
8) Your customer information will now appear in Microsoft Excel.
9) Click on File > Save as…
10) Click on the drop down list in the Save as type: box and select Text

(Tab delimited).
11) Enter LM Import into the File name: box.
12) Click on the drop-down list in the Save in: box and select Desktop.
13) Click on Save.
14) The export file LM Import has now been created and placed on

your Desktop.
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Importing the Newly Created File into LM 2001

The process required to import the newly created file is detailed in the scenarios
below.  The scenarios provided are applicable to imports from all software
packages.

Remember: These scenarios are guidelines intended to demonstrate the process
of importing into LM 2001.  Due to the fact that not all imports are identical, some
of the scenarios may not apply to your situation.

Scenario 1

You have created an export file that contains all of your client
information.  You would like to import that file into LM 2001’s
spreadsheet so that you can eventually have that information
entered into LM 2001.

To get the export file into LM 2001:

1) Start LM 2001.
2) Click on Start in the Login Form.
3) Click on File > New Company Database.
4) Enter Customer Database into the File name: box.
5) Click on Ok.
6) Click on Start in the Login Form.
7) Click on File > Import > Customer Lists from Other Software

Packages…
8) Click on the drop down list in the Look in: box and select Desktop.
9) Click on LM Import.
10) Click on Open.  The Lawn Monkey Import Center screen will

appear.
11) NOTE: If you are importing from a QuickBooks program, there may

be some extraneous information in the columns shown.  Identify the
row of information that contains column headings such as !CUST,
NAME, REFNAME, TIMESTAMP, BADDR1.  Delete all of the
information above this row.  To do this, click on the gray cell to the
left of the row immediately above the column heading !CUST.
Next, scroll to the top of the Lawn Monkey Import Center screen.
Hold down the Shift key and click on the gray cell to the left of the
first row of information shown.  Click on Remove at the bottom of
the screen.
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Scenario 2

Now that your client information has been entered into LM 2001’s
spreadsheet, you would like to match, or “map”, the information from
your QuickBooks or FoxPro program to the information in LM 2001.
For example, there may be a column of information from
QuickBooks that is titled Cust Num that contains all of your customer
phone numbers.  In LM 2001, customer phone numbers are kept in
a column titled Phone1.  Therefore, you have to tell LM 2001 to
place the information from QuickBook’s column Cust Num into LM
2001’s column Phone1.  This process is called “mapping”.

You would like to “map” all of the information from your QuickBooks
or FoxPro  program to LM 2001.  You notice that there is a column
labeled PHONE1 that contains your client’s phone numbers.  You
figure that this would be a safe place to start your “mapping”.  You
would like to find the column in LM 2001 that contains client’s phone
numbers and map PHONE1 to that column.

In addition to your client’s phone numbers, you notice a column
labeled BADDR1 that contains your client’s names.  You remember
from reading LM 2001 User’s Manual that LM 2001 refers to client’s
names as Full Name.  Therefore, you would like to map the
BADDR1 column to LM 2001’s Full Name column so that your
client’s names can be entered into LM 2001 correctly.

To map PHONE1 to an appropriate column in LM 2001:

1) Click on one of the phone numbers listed under the heading
PHONE1.

2) Click on Map.
3) Scroll down the Mapping Columns to Fields page until you see

Phone 1.
4) Click on Phone 1.
5) Click on Apply.
6) The column PHONE1 will be highlighted to indicate that it has been

mapped to a column in LM 2001.

To map the column BADDR1 to the LM 2001 column Full Name:

1) Click on one of the names listed under the heading BADDR1.
2) Click on Map.
3) Scroll down the Mapping Columns to Fields page until you see Full

Name.
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4) Click on Full Name.
5) Click on Apply.
6) The column BADDR1 will be highlighted to indicate that it has been

mapped to a column in LM 2001.

Scenario 3

You would like to enter the city, state and zip code of each of your
clients into LM 2001.  However, there appears to be a little bit of a
setback.  The program from which you exported held all of this
information in one column labeled BADDR3.  LM 2001 holds city
and state information in one column labeled Billing City, State and
zip code information in a separate column labeled Billing Zip Code.
First, you would like to separate the city and state information from
the zip code information.  Second, you would like to map the city
and state information to LM’s Billing City, State  and map the zip
code information to LM’s Billing Zip Code.

To separate the city and state information in the BADDR3 column from the zip
code information in that column:

1) Scroll through the columns in the spreadsheet, and identify one
that has no information entered.

2) Click on one of the cells under the column heading BADDR3.
3) Click on Tools > Copy this Column to Another.
4) Enter the name of the blank column into the box provided.  For

example, if the name of the column was col52, enter col52 into the
box provided.

5) Click on one of the city, state and zip code entries in col52.
6) Click on Tools > Remove Non-numeric Characters.  Only the zip

code information will remain in col52.
7) Click on one of the city, state and zip code entries in the BADDR3

column.
8) Click on Tools > Remove Numeric Characters.  Only the city and

state information will remain in the BADDR3 column.

To map the city and state information in column BADDR3 to a column in LM
2001:

1) Click on one of the city and state entries in column BADDR3.
2) Click on Map.
3) Scroll through the Mapping Columns to Fields screen until you see

Billing City, State.
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4) Click on Billing City, State.
5) Click on Apply.

To map the zip code information in col52 to a column in LM 2001:

1) Click on one of the zip code entries in col52.
2) Click on Map.
3) Scroll through the Mapping Columns to Fields screen until you see

Billing Zip Code.
4) Click on Billing Zip Code.
5) Click on Apply.

Scenario 4

You have almost mapped all of your customer information to
columns in LM 2001 when you come across a column labeled
REFNUM.  You know that this column contains your customer
number information.  You believe that REFNUM should be mapped
to a column in LM 2001 labeled Sort Code, so you want to map
these two columns together.  Once you do this you would like to
take a break and save the mapping you have done.  You plan on
coming back to finish in about an hour.

To map the column REFNUM to LM 2001’s Sort Code column:

1) Click on one of the entries in the column REFNUM.
2) Click on Map.
3) Scroll through the Mapping Columns to Fields screen until you see

Sort Code.
4) Click on Sort Code.
5) Click on Apply.

To save the mapping information so that you can return to it later:

1) Click on Close (Esc).
2) The information will be automatically saved.
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Scenario 5

An hour and a half passed since you last worked on the mapping
procedure.   In that time, you realized that the column REFNUM
should not have been mapped to LM 2001’s column Sort Code.
Instead, the column REFNUM should have been mapped to the LM
2001 column Customer Number.  You would like unmap the column
REFNUM and then map it to the LM 2001 column Customer
Number.

To recall the mapped information that you saved in the last scenario:

1) Start LM 2001.
2) Click on File > Import  > Existing Import File…
3) Click on the last dbimport file listed.
4) Click on Open.

To unmap the column REFNUM:

1) Click on one of the entries in the REFNUM column.
2) Click on Remove Map.

To map the column REFNUM to the LM 2001 column Customer Number:

1) Click on one of the entries in the REFNUM column.
2) Click on Map.
3) Scroll through the Mapping Columns to Fields screen until you see

Customer Number.
4) Click on Customer Number.
5) Click on Apply.

Scenario 6

You have one last set of information that you would like to map.  You want
to ensure that your clients File Names are the same in LM 2001 as they
were in your last program.  Your File Names usually consist of your
client’s name and their phone number.  Therefore, you would like to
combine the Name column and the Phone 1 column from your last
program.  You would then like to map the new combined column to the
column File Name in LM 2001.
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To combine the Name column and the Phone 1 column from your last program:

1) Click on Tools > Combine Two Columns.
2) Enter the Column Caption of the Name column into the box

provided.  For example, if the Name column is under the column
caption col1, enter col1 into the box provided.

3) Click on Ok.
4) Enter the Column Caption of the Phone column into the box

provided.  For example, if the Phone column is under the column
caption col14, enter col14 into the box provided.

5) Click on Ok.
6) Enter an appropriate “spacer” into the box provided.
7) Click on Ok.
8) Enter the Column Caption of the column into which Name and

Phone will be combined.  For example, if you want this information
entered into col 52, enter col 52 into the box provided.

9) Click on Ok.

To map col 52 to the File Name column in LM 2001:

1) Click on one of the entries in the col52 column.
2) Click on Map.
3) Scroll through the Mapping Columns to Fields screen until File

Name appears.
4) Click on Apply.
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Importing the Mapped Data into Lawn Monkey 2001

The process required to import the mapped data into LM 2001 is detailed below.
Once this process has been completed, LM 2001 will be updated with all of your
client information.

Scenario 1

You have completed the mapping process.  All of your client
information has been mapped to the appropriate column in LM
2001.  You would like to complete the importing procedure by
Importing Data.

To begin the Importing Data process:

1) Click on the gray square to the left of the first row of information
(i.e. the row that contains the column headings !CUST, NAME,
BADDR1 etc.).  This will highlight the entire row.

2) Click on Remove.
3) Click on Import Data.
4) The data will begin entering into LM 2001.  One or more of the

following steps may need to be taken:

If: You receive a message that reads “Invalid ‘Phone1’. This must
be numeric.”
Then: Click on one of the cells in the Phone Number column.  Click
on Tools > Remove Non-numeric Characters.  Click on Import
Data.

If:  You receive a message asking you to set a default invoice type.
Then: Enter the number of the invoice type preferred into the box
provided and click on Ok.

If:  You receive a message stating that “Lawn Monkey could not
detect one of your tax codes.  Do you want to add this tax code?”
Then:  Click on Yes.  Click on Add New.  Enter the appropriate tax
information into boxes provided.  Click on Close (Esc).

If:  You receive a message stating that “Lawn Monkey could not
detect one of your primary / secondary groupings.  Do you want to
add this primary / secondary grouping?”
Then:  Click on Yes.  Click on Add New.  Enter the appropriate
information into the boxes provided.  Click on Close (Esc).
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5) Once the Import Center indicates that the import has been
completed, go to the LM 2001 Client Form to verify that your client
information has indeed successfully entered into the program.

Note: You LM 2001’s Import Center allows you to import data
more than once.  This can be done in one of two ways:

I. Start the entire process over again.  This would involve
creating a new export file and working back through the
steps outlined in this manual.

II. Create a new database by clicking on File > New Company
Database.  Next, recall your saved import file as described
on p.7 of this manual.


