
Captaris RightFAX   
 

 

 

9/21/2009 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Captaris RightFAX  2 

 

 

 

Table of Contents 

About the Captaris RightFAX Plugin.................................................................................3 

System Requirements .....................................................................................................3 

Installation ......................................................................................................................3 

Setting up your First RightFAX-Enabled Form ..................................................................3 

Attachment Setup ................................................................................................. 15 

Fax Cover Page ...................................................................................................... 15 

Optional Test................................................................................................................. 15 

RightFAX Connection Test Utility ................................................................................... 16 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 



Captaris RightFAX  3 
 

 

 

About the Captaris RightFAX Plugin 

The Captaris RightFAX plugin will allow Reform 12 Enterprise/PDC to interact with a 

RightFAX server in order to automatically distribute documents to your fax system. 

 

System Requirements 

• Reform 12 Enterprise or Reform 12 PDC 

• Windows 2003 Server, Windows 2000, or Windows XP (64-bit editions of 

Windows are NOT supported) 

• RightFAX FaxUtil application installed (for client) 

 

Installation 

To install the Captaris RightFAX plugin to your existing Reform 12 installation, download 

and run the Captaris RightFAX installation executable. 

 

 

 

Step through the prompts, and the installation will begin. Allow the installation to 

complete and then read on to the next section to learn how to implement Captaris 

RightFAX to your forms. 

 

Setting up your First RightFAX-Enabled Form 

In this tutorial, we are going to create a new form from an existing template, and then 

configure it to send a document to a RightFAX server to be sent out. The RightFAX Plugin 

uses data located in Special Fields on your form to push your fax job up to the RightFAX 

server. These Special Fields can be automatically added and configured by using the 

included setup wizard. 

 

First, the Reform Designer must be started.  To open it, go to 

Start>Programs>Reform…>Designer. 

1. For the example, we will be creating a new form with an existing template. Go to 

File>New>New. Select the Fax template and click OK. 

 

 
2. When it asks if you would like to open a text file for designing, select No. 
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3. Next, go to File>Save to save your form. Name it Fax.fom. 

4. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to fulfill the desired RightFax workflow using 

the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform…>Workflow-Designer>Workflow 

Designer. 

6. Once open, we must go to File > New… 

 

7. At the below screen, select “Document Automation” and click Ok. 
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8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plugins you have installed (RightFax being one of the Outputs) 

 

9. Once opened, we can start adding the necessary components to the workflow.  

First, drag and drop a Form and File object onto the workflow by clicking and 

holding your mouse on Form and File and then moving your mouse over to the 

workflow and releasing the mouse button.  

 

*You will be prompted with the following dialog: 
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10. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “RightFax Demo” and click Finish. This will take you back to 

your workflow. 

11. Now we are ready to configure the “RightFax Demo” form and input file.  To do so, 

right click on the newly added object and select “Configuration…” or simply 

double-click on it. 

 

 
 

12. You are now presented with the Input Setup window.  First, we want to select the 

TextFile or data stream that our form will be using.  To do so, you can simply begin 

typing in the box, or you can browse to find it.  We are interested in the Fax.out 

file.  Click the small folder icon to bring up a window which will let us choose that 

file.  Select the file and click Open.   
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13. After choosing the text file, you are taken back to the Input Setup page so that you 

can now select a form.  Click the small folder icon to bring up a window which will 

let us choose the desired Fax.FOM form file.  Select the FOM file and click Open.  
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14. Now that you have both your Input Text File and Reform Form selected, the setup 

of Form and File is complete.  You can quickly double check that the correct files 

are selected and then click Finish.  

 
 

15. You will also be prompted to add a page-break field to the forms.  At this point, we 

want to select No. 

 

16. To finish the Fax workflow, we want to add a RightFax Output.  We use the same 

drag and drop procedure as with the Form and File (see step 9).  Take your mouse 

and drag the “RightFax” object from under Output onto the workflow somewhere 

below your Input.  Once you release your mouse, you will be prompted to describe 

RightFax.  Type “RightFax” in the box and then click Finish. 
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17. Once you click Finish, you are taken back to your workflow.  Your RightFax will 

have a Red Caption because it is not yet configured. To configure RightFax, you 

must first connect the Form and File object titled “RightFax Demo”.  To do so, first 

select the “Add Connector” button from the menu bar.  Next, drag your mouse 

from the small “x” underneath “RightFax Demo” to the small “x” above “RightFax” 

as pictured below. When the connection is complete, the connecter will turn black 

(if red, connection has not been made correctly, try again) and the “RightFax 

Demo” caption will turn green. 

 
18. You will be prompted to configure RightFax upon completing the connection.  Click 

Yes.   You can also double click on the RightFax object or rightclick and select 

“Configuration…” if you chose not to.  This configuration will step you through all 

the settings necessary for RightFax to successfully connect to your RightFax server 

and send faxes. The first page will ask for the server name and the user name that 

will be used to connect to the RightFax server. Fill in both boxes, and then click the 

Start Wizard button.  
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19. The next piece of information the configuration required is the FaxNumber where to 

send the fax to.  Enter in a valid fax number by typing it in the provided box and then 

click Next. 

 

20. Next is the “Recipient’s Name”.  Here we would like to use data that is available in 

the data stream instead of a static value.  To do so, we first must click the “Click 

here to select variable information” button.  

 

*Note-After doing so, we see that a list will appear with the different fields that you can 

choose for your variable data.  We will be selecting from this list, but if you needed to 
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still type static data, you can do so by clicking the appropriate button for static 

information and then typing it in. 

21. We want to use the dynamic field ClientName as the “Recipient Name”.  Select 

ClientName from the list and click Next. 

 
22. For “Recipient’s Company Name”, we would like to again use variable data from the 

print stream.  To do so, first click the button “Click here to select variable data”.  

From the list that appears, select ShipToName (scroll down) and click Next. 
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23. Type in a value for the Recipient’s Phone Number, and click Next.  

 
 

24. Type in “Quote Information” for the Subject and click Next. 
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25. For “Notes”, we would like to again use variable data from the print stream.  To do 

so, first click the button “Click here to select variable data”.  From the list that 

appears, select Description and click Finish. 

 

 
 

26. You have completing configuring your simple RightFax workflow.  Your 2 objects 

(“RightFax Demo” and “RightFax”) should all be green meaning they have been 

successfully configured and the workflow is ready to be created. 

 



Captaris RightFAX  14 
 

 

 

27. To make all the appropriate forms and changes, execution must be carried out.  

This is done by clicking the “Execute” button  on the menu bar.   After 

execution, you will be notified about what has taken place.  Click OK. 

 

 

 

28. You can now close the Workflow Designer. Your form has been saved in your 

default forms directory.  A backup of your original Fax.FOM file has been copied to 

the “Workflow Designer Original Forms” folder in your forms directory.  Any 

permanent form changes should be made to this original form as it is used 

throughout the form configuration process as a template. 

 

29. To test out your settings and make sure that faxes can be sent, first we should open 

the form with the Reform Designer.  Navigate to your Forms directory and double 

click on Fax.FOM.  When asked to open the associated TextFile, click Yes. Verify that 

the special fields exist on the right hand side of your form.  Then go to File>Print. 

Reform will use the information of the objects that were just added to your form to 

process and send the fax. 

 

*Check your RightFAX server to make sure the fax was successfully sent. 
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Attachment Setup 

To configure Reform to use attachments with Captaris RightFAX, click on the 

Attachment Setup button beside the Transport Type dropdown list in Page Setup to call 

up the Attachment Setup dialog box. The Attachment Setup dialog allows you to choose 

from various file types, resolutions and color formats for your attachments. 

 

The recommended attachment type for the RightFAX plugin is a TIFF image with Group 4 

compression. 

 

Note: You can change the Color format to Gray Scale or Color, but you will 

experience a noticeable speed difference. 

 

Fax Cover Page  

To use the RightFAX cover page in your faxes, select Fax Cover Page under the 

Automation submenu of the Options menu as usual. Instead of browsing for a cover 

page, type in the fax cover name that exists in your RightFAX System. To use RightFAX’s 

default cover page, type System Default in the Cover Page File box, as pictured below. 

 

 
 

Note: The RightFAX Client must be installed on the computer running Reform. 

Reform communicates with RightFAX using Port 445; this port must be white listed 

if any firewalls are running. 

 

Optional Test 

To test the functionality of RightFAX once you have followed the directions above:  

Start the Reform Spooler by clicking the Spooler icon under Reform in your programs 

list.  

 

Copy the RightFAXPO.out file from the C:\Program Files\Reform…\Backups directory 

into the C:\Program Files\Reform…\Spooler directory. At this point, the Reform Spooler 

should send 15 Purchase Orders in 10 separate fax jobs to RightFAX using the phone 

number 555-555-5555. 
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To view the form used for this test, open RightFAXPO.fom in Reform Designer and 

select Yes when prompted to open the associated text file. 

 

To view fax results, use Windows NotePad to view PrintResults.txt in the Reform 

directory after the fax job is completed. 

 

RightFAX Connection Test Utility 

This included Connection Test Utility is used to check the integrity of various settings 

when setting up a MOST server to work together with RightFAX. It checks several 

settings to make sure that they are configured properly. If there is some kind of issue 

with the MOST and RightFAX servers communicating, this utility can be used to isolate a 

problem and fix it. 

 

Keep in mind that this Connection Test Utility is only intended for workflows that are 

using RightFAX integration together with MOST. 

 

 

 

1. Displays some information that should be read before proceeding.  

2. Checks to see that you have correctly set the necessary Global Variables from 

within the MOST Designer application. 

3. Verifies that you are able to write to the shared directory on the RightFAX Server 

where fax jobs are sent. 

4. Checks to make sure that a connection can be established between the MOST 

server and the RightFAX server. 

5. Checks the integrity of the connection between the MOST server and the 

RightFAX database. 

 

 

Other company or product names mentioned herein may be trademarks or registered 

trademarks of their respective companies 


