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Getting Started

Welcome to solidThinking™ , the breakthrough 3D environment!

solidThinking combines unique and powerful modeling and
design communication tools surrounded by an interface that is at
once familiar, intuitive and informative.

The robust combination of NURBS curve, surface, and solid
modeling tools, as well as polygonal and pointcloud creation
and manipulation tools, work together to expand the possibilities
of what you can achieve within a single 3D design application.

The photorealistic and sketch rendering technologies, along with
web-ready interactive exports, combine to produce stunning
images of your models for easy communication and approval.

And finally, the unparalleled and interactive Construction
History which completes the parametric modeling environment,
gives you the freedom to create and evaluate more design
possibilities in less time.

The solidThinking product line consists of four packages for
each level of need in your design modeling workflow. We are
providing here a list of the main features included. Some of
them are not available in each solidThinking version.
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USER INTERFACE

solidThinking user interface is a carefully designed
environment where you work in luxurious comfort. In fact, not
only does it have clear and self-explicative icons but it also
reduces the number of commands required to specify
operations. The program console guides you through the
creation process prompting you on steps to follow. The perfect
OpenGL integration grants you the best interaction with your
models.

Views

e Standard orthographic views (Top, Front, Right, Left, Rear,
and Bottom) plus a user defined number of independent
perspective views.

* Interactive editing with full-shaded, texture mapped real
time visualization.

* Transparent drawing mode. It is a variant of the Shaded and
Textured modes.

e Texture management options to exploit hardware texture
mapping of accelerated graphic cards. Three textures
formats supported: RGBA, RGB and BGR.

* High quality NURBS tessellation.

Camera

* Dolly, field of view, focal length, roll, track, rectangular
zoom, and cursor zoom.

* Interactive editing with full-shaded, texture mapped real
time visualization.

* Numerical input of the camera coordinates, show/hide
camera, on/off display update, on/off show points, adjustable
resolution, true colors or selection/ deselection colors
visualization.
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Construction Aids

Units of measure.

Advanced grid settings for defining up to four different
grids, each with its own origin and spacing, grid type, color.
Snaps to grid, angle, scale%, translate, point, midpoint,
center, curve, tangent. Snap to 3D and Snap disabled
options.

Unlimited number of Construction Planes.

Axes Align to 3 Points. Align the local axes of a
construction plane/object to three points.

Axes Align to Object. Align the local axes of a construction
plane/object to another object local axes.

Axes Align to NURBS surface. Align the local axes of a
construction plane/ object to be tangent to a NURBS surface.
Align to axis. Align a set of objects along X, Y, or Z
directions with spacing options.

Align to curve. Align a set of objects along a curve with
spacing options.

Global/local modeling tolerance.

Objects Hierarchy Browser

Advanced hierarchical browser.

Unlimited number of layers.

Select/deselect, toggle, delete, group/ungroup, show/hide
objects and groups of objects, on/off bounding box, and
cast/receive shadow options.

On-Line Help

Reference manual on line (HTML formats).
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NURBS MODELING

Full NURBS-based modeling and Construction Tree make of
solidThinking a matchless tool for designers and graphics
professionals.

solidThinking uses NURBS (Non Uniform Rational B-Splines)
as its geometry type. This curve and surface definition method
offers the greatest flexibility and precision. NURBS are capable
of representing any desired shape, both analytic and free form,
and their algorithms are extremely fast and stable.

The Construction Tree gives you real-time update when
modifications are made to curves, parameters or surfaces.
Browse the graphic representation of the Construction Tree to
identify and select source objects and actions. Add, remove, or
replace source objects within the Tree with immediate
reconstruction. Manipulate both the parameters and points of all
objects freely. And never forget the steps involved in
construction - the entire tree is saved inside the file and is
accessible at any time.

Thanks to the possibility to freely manipulate your models, you
can easily experiment new shapes and improve your creativity.
Once you have tried how the Construction Tree improves your
productivity you will not do without it.

The most advanced modeling tools and the numerous
construction aids make it possible for you to create any shape
you can think about.

Main features include:

* Simultaneous point editing on multiple objects.

* Unlimited undo levels.

* Un-edit. Allows to remove any editing from selected points
of a curve/surface independently from any other successive
modification of the curve/ surface.

Primitives
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Plane, disc, cylinder, sphere, cube, cone, toroid, prism,
3D text.

Curves

High quality freeform NURBS curves of order 2 to 7.
Real-time adjustment of curve tangency and curvature at any
given point. Any curvature radius can be set.

METAcurves. Interpolation of points using a smooth curve.
Ability to specify cusps at points.

Arcs (center-2 points, 2 points-radius, 3 points, fillet arc,
tangent-2points, line-arc, fillet curves).

Circles (center-radius, 3 points, tangent-2 points, point-2
tangents, center-tangent).

Ellipses (center-2 axes, point-2 focuses).

Lines (single, perpendicular to segment, parallel to segment,
fillet segment, segment from center, inclined segment,
segment tangency align, bisector, bitangent segment).
Polylines (open, closed, rounded).

Regular polygons.

Helix and spiral.

Curve Offset. Create the copy of a curve at a fixed distance.
options: Symmetric,

Closed, Rounded corners and Rounded ends.

Split curve. Splits two intersecting curves into more parts.
Divide curve. Divides a curve into two independent curves.
Break curve. Breaks a curve into two joined curves.

Blend Curves. Create a blend curve connecting two existing
curves.

Curve Tangency Align. Establish tangent continuity between
two curves. Optionally modify incidence of curve to
tangency plane.

Extend curve. Extends a curve for a user-defined length to a
given point or to

another curve.

EdgeExtract. Extract a surface edge into a 3D curve.

Extract isoparametric curve. Extract an isoparametric curve
from a surface.

Curves from Intersection. Extracts a curve from the
intersection of two surfaces.
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Section. Extract any number of sections from a set of
NURBS surfaces along a specified direction.

Silhouette. Extract a silhouette curves from a set of NURBS
surfaces given a direction and a viewpoint.

PathCast. Project a curve onto a surface in order to obtain a
3D curve on a surface.

Curve to Plane. Project a 3D curve onto a user-defined 2D
plane.

Join curve entities. Join two curve endpoints.

Refine curve. Increase curve detail.

Rebuild curve. Rebuilds a curve with a user-defined number
of points distributing them at a constant distance while still
keeping the curve original shape.

Simplify curve. Reduce number of points of a curve given
the target number or a tolerance.

Curve to Arcs. Starting from any planar curve you can create
a new curve made up of a series of accurate arcs.

Transformations

Translate. Move one or more pickable items to a new
location. Magnet options: Constant, Linear, Smooth.

Rotate. Rotate one or more items.

Scale. Change the size of one or more items.

Mirror. Mirror objects.

Replicate. Replicate any object along a path or over a
surface.

Matrix copy. Replicate an object along X, Y, Z to create a
box-like array.

DynaMatrix. Dynamic matrix copy with Construction Tree.
Polar copy. Replicate an object along a circular path of any
given radius.

Step copy. Replicate an object applying incremental
transformations (translation, rotation, scale).

DynaStep. Dynamic step copy with Construction Tree.
Combine. Combine two or more selected objects into one
single object.

Uncombine. Create a separate object for each entity of an
object.

solidThinking User Manual



Getting Started

Deformations

Twist. Twist an object along a user-defined axis.

Taper. Widen or narrow one side of an object.

Warp. Warp all points of an object comprised in a user-
defined distance and with respect to a user-defined axis.
Shear. Shear an object with respect to a user-defined axis.
Bend. Bend an object with respect to a user-defined axis.
Linear Stretch. Stretch an object along a path curve.

Lattice. Free object deformation.

PixelMap. Deform any selected NURBS surface based on
the brightness intensity of each pixel of a bitmap image that
you use as a map.

SurfDrape. Drape a NURBS surface over another surface.

Surface Creation Tools

G2-continuity surfaces.

Extrude. Create a surface by extruding a profile along a
specified direction.

Surface Extrusion. Create a surface by extruding a cross
sectional profile along a specified direction.

Lathe. Create a surface by revolving a profile curve around
its X, Y, or Z-axis or any user-defined vector.

RadialSweep. Creates a surface by sweeping one or more
profile curves along a rail curve and a common rotational
point in space.

Rule. Create a surface that fits across a number of cross-
sectional curves by a linear interpolation.

Skin. Create a surface that fits across a number of cross-
sectional curves by a smooth interpolation.

Lofting. Create a surface that fits across a number of cross-
sectional curves by a spine-controlled interpolation.

Pipe. Create a surface by sweeping a cross sectional profile
curve along a second path.

Birail. Create a surface by sweeping a profile curve along
two rail curves.

MultiSweep. Creates a surface by sweeping one or more
profile curves between one or more rail curves.

3sides. Create a surface blended between three boundary
curves.
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Coons. Create a surface that is fitted between four arbitrary
boundary curves.

N-Side modeling tool. Create a surface that is fitted between
"n" arbitrary boundary curves.

Curves Network. Create a surface by interpolating a network
of curves.

FillPath. Create a surface by filling one or more selected
curves.

Patch. Create a G1 surface from a list of surface edges and,
optionally, from separate curves.

Close hole. Close a hole in a NURBS surface where the hole
is defined as a loop of at least three edges.

Surface from Curves. Create a surface that fits across one or
two sets of curves.

Blending. Create a surface forming a blending between two
surface edges.

Surface Tangency Align modeling tool. Align a surface
border to any other surface trim edge, with the ability to
specify the incident angle between the two surfaces.

Extend Surface. Extend a surface along one or more
boundaries for a user-defined distance or to a given curve.
Surface Offset. Create the copy of a surface at a fixed
distance.

Solid offset. Offset or inset a solid.

Shell. Shell a solid by just selecting the object to work on
and defining which faces shall be made open for the Shell.
Trim surface. Interactively trim a surface and retain
specified regions of it while discarding others by projecting
a curve on it.

Trim solid. Interactively trim a solid and retain specified
regions of the solid while discarding others by projecting a
curve on it.

Trim Convert. Converts a four-sided trimmed surface into an
untrimmed (natural) surface.

Intersect. Surfaces intersection.

Intersect CT. Surfaces intersection maintaining Construction
Tree.

Make Manifold. The Make Manifold command produces a
manifold solid topology from a non-manifold topology. It

10
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deletes excess faces, edges and vertices to get to a manifold
topology.

* Interactive Boolean Operations of Intersection, Difference,
and Union.

* Round. A topology-based technique to build constant or
variable radius round with G3 blend option while
maintaining the Construction History.

* Chamfer. Perform filleting with a linear cross section
(constant or variable) rather than a circular cross section.

* Approx Round. A faster round technique at the price of a
mathematical approximation.

* Fillet. Create a fillet between two intersecting surfaces.

* Surface Refine. Increase detail of surfaces.

* Simplify Surface. Reduce number of points of a surface
given a tolerance.

* Join surfaces. Join two or more surfaces into a single
surface.

POLYGONAL MODELING

solidThinking also features an advanced polygonal modeler
with support of n-side polygons. It is possible to create and
extrude polygons, split faces and edges, refine, decimate, and
perform any other operation.

The possibility to convert a NURBS surface into a polygonal
model and vice versa is great for virtual reality and video game
developers.

The unique implementation of Interactive Subdivision Surfaces
with Construction Tree gives the user maximum power for
refinement and smoothing of polygonal meshes. solidThinking
Subdivision Surfaces fully adheres to the Pixar standard.

solidThinking User Manual
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Features include:

Advanced polygonal modeling with support of n-side
polygons.

Polygonal primitives: sphere, cylinder, torus, cube, plane
and disc.

Create single polygons.

NURBS to poly: tessellate any NURBS surface. Optional
creation of quadrilaterals whenever possible and welding of
coincident vertices.

NURBS CVs to poly: create a PolyMesh from the control
vertices of a NURBS surface.

Vertices editing. Translate, rotate, scale, delete, split,
welding, normal direction.

Edges editing. Translate, rotate, scale, smoothing, delete,
relax, split.

Edge welding. Merge coincident edges.

Faces editing. Translate, rotate, scale, delete, extract, split,
normal direction.

Face normal editing. Invert or unify the specified face
normals.

Refine edges.

Simplify. Reduce the number of faces to a specified
percentage of the original, optionally preserving edge
sharpness and curvature.

Fill hole: close holes in a polyhedron using an N-Side
polygon.

Smooth. Applies a smoothing filtering on a polygonal
object. Very useful for 3D scanner data processing.
Interactive ~ Subdivision  Surfaces.  User-controllable
refinement and smoothing of polygonal meshes.

12
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ANALYSIS TOOLS

Analysis tools are useful for finding distances, lengths, areas,
and volume. They also allows you to analyze curve/surface
curvature and tangency.

solidThinking Curvature Display also offers the possibility to
dynamically analyze smoothness, curvature and other important
properties of your models by evaluating surface curvature,
reflection lines and environment mapping.

* Evaluation tools: distance between two points; length of a
curve; length of a part of a curve; interactive curve
curvature/tangency; interactive surface curvature/tangency;
surface area; volume.

* Surface curvature evaluation shaders for automotive and
product design, including shaders using analytical anti-
aliasing.

* Mold design false color shader, for evaluating draft angles of
mold designs.

* Tolerance check. Detects any gaps between surface patches.
Thanks to the Construction Tree, tolerance can be adjusted
to make the model "water tight".

* Tools for evaluating draft angles of mold designs.

* Interactive curvature display. Interactive visualization of
surface curvature while editing. The following methods:
mean curvature, gaussian curvature, absolute curvature.

* Interactive reflection lines display. Allows to analyze
surface smoothness and curvature by using zebra stripes.

* Interactive environment mapping display. Allows to analyze
the surface curvature by using environment mapping.

* Curvature Plot. To visualize how the curvature vary along
the curve.

Continuity Check. Allows to check surface continuity at joined

edges, and in particular you can check gaps, tangency and

curvature at any point.

solidThinking User Manual
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RE VERSE ENGINEERING

Fit points. Create a surface from a point cloud data sets.

* PointsCloud from object. Create a PointsCloud given a
surface.

* Planar Clouds from PointsCloud. Creates a specified number
of points clouds lying on parallel planes from a given points
cloud. This command can be useful to simplify a points
cloud derived from 3d scanning. Beside section planes
direction, the user can specify either the number of planes or
the distance between planes.

* Curve from PointsCloud. Creates a curve from a points
cloud. This tool creates a curve starting from a selected point
and approximating the points ordered by minimal distance.

* Minolta Vivid 3D scanner front-end. Remotely controls (via
SCSI interface) Minolta Vivid 3D scanner. Data can be
imported as a point cloud or a polygonal object.

* Advanced MicroScribe-3D support.

e Sketch on planes. Using Microscribe-3D scanner, creates
point clouds by "sketching" a real object. The tool samples
the points derived from the Microscribe-3D digitizer.

ASSOCIATIVE DIMENSIONING

Associative Dimensioning for the automatic creation of
horizontal, vertical, aligned linear dimensions, arcs and circle
radii, curvature radii of NURBS curves at any given point,
diameters, edges, angular dimensions. Leader command for
quickly creating leaders (text annotations).

You will realize the great power of the Dynamic Associative
Dimensioning when a revision to a drawing comes through, or a
design changes. With Associative Dimensioning on your model,
you can edit your entities and have the dimensioning change as
well, in real time.

14
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DRAWING

Connection from Design to Documentation. You can now
compose drawings and pictures on a virtual sheet of paper and
configure plot scale, paper size, plot area, paper orientation.
Multiple drawing layouts are possible.

RENDERING

Once you have created your models you can take advantage of a
truly comprehensive rendering system for the most advanced of
graphics  professionals, integrating all industry-leading
rendering techniques. The most efficient memory management
functions, unlimited output resolution as well as multi-threaded
and multi-processor rendering make of solidThinking the
perfect tool for generating photorealistic images.

Final Gather is a new, exclusive global illumination method that
improves both the quality and ease of generation of images. Its ease-
of-use means that there is no need to be an expert in rendering,
simply press a button and solidThinking will calculate the lighting
for you automatically. The increased breadth of functionality
introduced means that solidThinking can match the fastest and the
best global illumination solutions, and is now significantly faster
than other rendering engines for a given quality of image.

Techniques

*  Wireframe.

e Fast hidden-line.

* Flat, Gouraud and Phong shaded.

* Preview scan-line.

* Full scan-line.

* Preview ray-trace.

* Full ray-trace rendering (multi-threaded).

* Hybrid rendering for integrating radiosity with ray-tracing
and other rendering methods.

* Sketch rendering for stylised presentations.

* Preview quality post-processing and full quality post-processing.

solidThinking User Manual
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Radiosity

Radiosity for simulating real light effects.

Progressive simulation allowing to balance speed and accuracy.
Generation of the solution for a view-dependent illumination
model allowing the fastest result possible.

Support of industry standards for the definition of the
luminous intensity distribution of a luminaire.

Sketch rendering

A technique for supporting rendering at the conceptual
design stage or for stylised presentations.

Support of various styles such as cartoon, pencil, ink, hatch
and paint.

Shaders

Advanced parameterized procedural shaders with high
quality noise function.

Shade trees for combining multiple shaders.

Color Source, Reflectance Model, Transparency Source,
Displacement, Texture Space, Light Source, Background,
Foreground, and Post-processing Shaders.

Highly realistic simulation of a wide range of wood surfaces,
for ease of visualizing furniture, doors, cabinets, and even
parquet floors.

Leather shader, giving users the ability to simulate the
surface finish of a wide range of leather materials. They can
decide on the complexity and detail of the surface of the
leather, including creasing, smoothness, color and regularity.
Multi-layer paints, to simulate the multiple highlight and
color shift effects of multi-layer paints used in the
automotive industry. Designers can specify the composition
of each paint layer to simulate a wide range of paints and
finishes, including metallic.

Anisotropic reflectance shader for woven materials, to
produce physically based simulations of the anisotropic
reflectance properties of woven textiles and materials, such
as satin.

Environment-mapped and mixed backgrounds.

16
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Environment mapping (e.g., reflection mapping).

Wrapped mirror map for changing the reflection of a surface
from a texture map.

Wrapped filtered image shader for adjusting color contrast
and brightness of textures.

Interactive transformations (translation, rotation, and scale)
of textures and materials in the views.

Procedural and image-based transparency effects.

Decal support for combining different materials and
wrapping images around surfaces.

Anti-aliasing

Anti-aliasing shader class for applying different anti-aliasing
per material.

Feature following anti-aliasing for the highest-quality image
output (brute-force over-sampling to perform extra anti-
aliasing around any areas of intensity change).

Enhanced analytical anti-aliasing, while using minimal
processing time and resources.

Lights

Unlimited number of lights.

Ambient, distant, eye, goniometric, point, projector, sky,
spot, and sun light sources.

Simple sky. A special light providing a fast approximation
to a true sky light. It allows you to quickly reach realistic
lighting results with just one light.

Area lights.

Volumetric lighting effects.

Global lighting effects using real sky conditions.
Radiometric or photometric measurement.

Light sources using goniometric data in lighting industry-
standard formats.

Expanded physically accurate lighting range. Goniometric
lights allow users to define accurate light beam shapes (such
as fluorescent lights) using manufacturer's lighting data.
Perceptual tone mapping, for physically accurate re-
creations of the eye's response to brightness levels.

solidThinking User Manual
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Shadows

Shadow mapping.

Soft shadows.

Shadow ray casting.

Shadows cast by semi-transparent objects.

Hybrid shadow creation, combining ray-tracing and scan-line
rendering for fast, efficient production of ray-traced shadows.

Post-processing operations

Physically based depth of field.

Post-Processing depth cue, variable fog and snow foregrounds.
Advanced atmospheric effects.

Lens flares (Glows, Ghosts, and Halos).

Direct output of QuickTime VR panoramic and object movies.

Support of third-party renderers

Third-party renderers are supported through continuously
enhanced plug-ins. Already available:

solidMaxwell. Plug-in for integrating Maxwell Render.
Windows and Mac OS X.

ThinkMan.  Plug-in  for integrating PhotoRealistic
RenderMan. Windows only.Physically based depth of field.

ANIMATION

Keyframing animation.

Animation of translation, Rotation, and Scale attributes.
Animation of lights.

Animation of cameras with control of position and target.
Speed interpolation options.

Path interpolation options.

18
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WEB AUTHORING ENVIRONMENT

solidThinking offers a sophisticated web authoring
environment which allows you to export and integrate your 3D
objects or scenes into HTML pages through the Viewpoint
Media Player developed by Viewpoint.

This technology creates a compelling and interactive user
experience for many e-business applications, from advertising
and e-commerce to online customer service and internal
training.

Objects can be easily manipulated and visualized with textures,
reflections, transparencies, and shadows. Besides, it permits the
immediate streaming display of content.

DATA EXCHANGE

* Support for industry standard data formats allows you to
share data with other software packages using neutral file
formats.

* Color palette RGB and HSL.

* Image Formats: BMP, JPEG, TIF, High Dynamic Range and
OpenEXR.

* Import/Export Object Formats: 3DS, DWG, DXF, IGES,
Lightwave, Maya, Rhino3D, RIB,

* STEP, STL, VDA-FS, VRML. Optional modules.

e Support of different IGES flavors.

* SolidWorks plug-in for importing/exporting solidThinking
scene files from/to SolidWorks.

* J/O plug-in for 3DStudioMAX.

PDK

* Plug-Ins Development Kit. Documentation for developers
and users that want to create their own modeling tools and
plug-ins. Code samples are included.
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1.1

About this manual

solidThinking User Manuals are organized in four volumes
and nine distinct sections. They are as follows:

Volume 1 - Modeling I

Section 1, “Getting Started”, gives you a short overview of
solidThinking and includes information to help you get started with
solidThinking and understand the way the program communicates.

Section 2, “The Pull-Down Menus”, describes the menus
available from the menu bar located at the top of the window.
Menu items allow you to save and retrieve files, display control
panels, and perform many other operations.

Section 3, “General User Interface”, itemizes solidThinking
user interface, defines the purpose of panels and toolbars, shows
you the use of different view modes and layouts, and teaches
you to customize the user interface.

Section 4, “Modeling in solidThinking’, explains the
Construction Tree approach and describes all the tools available to
apply transformations/deformations and to create NURBS curves.

Volume 2 - Modeling I

Section 4, “Modeling in solidThinking”, describes all the tools
available to create NURBS surfaces as well as polygonal
objects. It also describes analysis tools, construction planes,
dimensioning and drawing environment.

Volume 3 - Rendering

Section 5, “Rendering in solidThinking’, defines tools for
adding cameras and lights, and explains how to create materials,
use textures, and render a 3D scene.
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At the end, you will find a list of keyboard Shortcuts that can be
used to speed up the program workflow and a Glossary that will
be practical when searching for the meaning of terms that you
will find throughout this manual.

Conventions

To help you find and interpret information readily, this manual
makes use of conventions and displays them in various modes.
Their definitions are specified below.

* The descriptions of various commands can be easily
recognized as they will appear in the margins of this manual
as shown below.

Object Mode

-

When an icon is associated to a command, a such icon
appears in the margin adjacent to the text

* Each time we refer to a command, both in the form of an
icon or a menu item, we will show it in bold as follows:

Switch to Object Mode.

* Keys demanded to perform an operation will appear in the
text surrounded by a border as in the example below:

Press to stop points insertion.

* Shortcuts are combinations of keys that, used in conjunction
with other keys or mouse clicks, let you quickly access
specific commands and menu functions. You will find them,
near the command description, represented as below:

[Ctrl] + [ sift] + [D]

solidThinking User Manual
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Text that is displayed as a prompt in the console is shown in
the same font type, style, and size of the following example:

Pick profile curve:
Values to be typed in the console or in any other entry field

are shown in the same font type, style, and size of the
following example:

Then type 1, 1, 1 in the console.
From time to time some important notes may integrate the

description of commands or functions. They are always
displayed in ifalics as in the example below:

Note: Weight modification should be used very carefully.
If you plan to exchange your projects, you should...
Filenames and file extensions are also in italics:

filename.stm
dxf
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Starting solidThinking

After completing the guided installation as specified in the
Installation Notes, move to the /solidThinking directory.

In this directory, you will find the solidThinking file
(solidThinking.exe on Windows) as well as the following main
folders created by the installation program:

Demos (This folder is currently available in the Windows
version only). Animated tutorials that can be loaded using File >
Open Macro.

Examples. Examples files.

Help (This folder can be found in the Mac version only). Help
files that can be read using Help > Help.

Images. Renderings are saved here with progressive numbering
(filename.st~n.bmp where n is a progressive numbering).
Renderings are saved as .fif (TIFF format) files.

MaterialsLib. Materials saved in the Materials library.
ModelsLib. Models saved in the Models library.

Plug-In. Here you will find the rendering engines as well as the
file format I/O modules.

Projects (This folder is currently available in the Windows
version only). You can use this folder to store your project files.

Textures. Use this folder to store textures.

Double-clicking the solidThinking icon launches the
application and displays the copyright panel for a few seconds.

solidThinking user interface is then displayed at full screen.
The program is ready to be used.

solidThinking User Manual
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1.3 Screen Components

solidThinking uses multiple viewing windows. Each of these
windows shows you a view of your 3D scene.

Four are the modeling views displayed by default. Each of them
occupies almost a quarter of the screen. Basic elements of the
screen display are shown in the picture below:

Libraries
toolbar
(displays
alternatively
Modeling,
Materials,
or Models
libraries)

Orthoganal Views Perspective
View
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Getting Started

Using the Mouse
and the Keyboard

Most of your communications with selidThinking require you to
use the mouse or the keyboard. When you move the mouse, a cursor
on the screen matches any movement.

The left mouse button is the standard button for most interactions,
but the right button ( key + mouse button on the Mac) are
also used in some cases.

You issue commands by pressing the mouse button when you
are over some area of the screen. Commands respond differently
depending on how you press the button.

Basic mouse actions can be summarized as follows:

Clicking. Pressing the left mouse button and releasing it
immediately. This action is also called Picking when it is used,
for example, to select a point or an object.

Double-Clicking. Pressing the left mouse button twice in quick
succession.

Clicking-and-Dragging. Pressing the left mouse button and holding
it down while moving the mouse button to a new screen position.
Release the button to stop. Also called Picking-and-Dragging.

Keyboard entries as well let you interact with solidThinking.
Each value you type must be separated from the previous value
by a single space and confirmed by pressing [Enter|.
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The keyboard is also used to perform various shortcuts for quick
access to specific commands and many menu functions.

Learning the keyboard shortcuts can significantly speed up
operations.

A shortcut list is provided at the end of this guide. Available
shortcuts to menu options are also listed next to the menu items.
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1.5

Getting Started

Message Boxes

One of the ways solidThinking communicates is through
message boxes, of which there are four main types.

Info box

An info box provides information on operations that you have to
perform before activating a new command. Click OK and
follow instructions. An example of an info box is that appearing
when you click a Transformation Tool before selecting an
object.

Translate

':\l) Select some objects before choosing this Modeling Toaol.

Decision box

A decision box provides information that allows you to make a
Yes/No decision. A Cancel button is also displayed. Confirm by
clicking the Yes button. Select no by clicking the No button.
Click Cancel to cancel the command and remove the box. An
example of a decision box is the one that appears when you quit
the program.

solidT hinking E3

':\?) Do you want to save the changes you made to the model?

No | Annulla |
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Alert

An alert tells you something you need to know before
proceeding with an operation. After reading the message
carefully, you can press Yes to confirm the operation or No to
cancel it. An example of alert is that appearing when you
choose the NURBS Surface Editing tool.

NURBS surface editing

The selected surface is part of a Construction Tree. In order to edit with this Modeling Tool, the surface need not be a
part of a Construction Tree. Do you want the surface to be set as hidden and a copy to be created for editing?

Dialog box
A dialog box usually contains one or more controls through
which you can enter text, choose options, or direct the action of
the command. An example of dialog box is the Modeling Tool

panel.
Point =)
| [ [ Entry fields
Remove |
Check button — 1™ et
|
F_'del <«4—— Scroll bar
Slider bar Iy o~
\I
New entity |
Join : _J Push button
Un-join l
FCutve type
Radio button = qc,
‘r‘ Closed
=l
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Dialog panels share some components, and in particular:

Push button. A button you have to push to perform an action.

Check button. A button you can switch on/off to enable/disable
an option.

Radio button. A round button you can use to choose from a set
of related but mutually exclusive options. The check mark for a
radio button is a black dot. A radio button can assume two
states: checked (dot) or unchecked (no dot).

Slider bar. A horizontal rectangle with a sliding bar inside. By
moving the sliding bar, you alter values.

Scroll bar. Vertical rectangles with a sliding bar inside used to
shift the content of a window area. It is also a visual hint of the
length of the area.

Entry-fields. Two are the entry-field types: text fields that
accept alphanumerical entries and numeric fields that accept
only numbers. When a dialog box appears the first field has
text/numbers highlighted. It means that any valid character you
will type will replace the content of the field.

You can click the mouse to move the insertion point within or
between fields or you can use the following keys to move
around fields:

moves to the next field.

+ moves to the previous field.

deletes the character on the left of the cursor.
/ moves the cursor one character left or right.

/ [ V] increases/decreases values of the active parameter.

Most command names in a dialog box have an underlined letter.
If you press the corresponding letter key while holding the key
down, you can automatically move the insertion point to a such
command field.
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1.6

Saving your Work

Before exiting solidThinking, you should save your work using
the File » Save menu command.

A file selector is brought up allowing you to name the document
and save it either in solidThinking file format (.sf) or in
another supported format.

If the file already has a name, the program will overwrite it. If
you don’t want to overwrite it, but rather assign a new name,
you must instead use the File » Save as... menu command.

solidThinking native file format is characterized by the .st
extension and includes the geometry at the time you save, plus
the following information:

- materials,

- lights,

- camera settings.

You can exit solidThinking by selecting the File b Exit
command. If the current document is not saved, the program
prompts you on whether you want to save it or not. Options are:
Yes, No or Cancel to cancel the command and remove the box.

30

solidThinking User Manual



Section 2

The
Pull-Down Menus

solidThinking User Manua

31



Section 2

32 solidThinking User Manual



2

The Pull-Down
Menus

The menu options are displayed on the top left of the screen,
from left to right.

When you click a main menu item and hold the mouse button
down, a sub-menu appears showing more options. To select a
menu option, keep the mouse button pressed, move the cursor
over the item, and then release the mouse button.

Wi Managers Render [nfo

’* Trarsform  » [ @) 01E @

Curves Curves ’
- Surfaces 4 Arc ’
Pohes » Cortr ras
PontsCloud *  Ellipse v Circle: diameter
Primitives 4 Line ’ Circle: 3 points
Texturing *|  Polyline ¥ Circle; 2 points, tangent
Camlight *  Helix Circle: 2 tangents, point
Analyze b Offset Circle: center, tangent
1 CPlanes  »  Braak/divide ' |

Before we examine in detail each menu item, you should know
that most of the menu commands have keyboard shortcuts that
give you prompt access to their relative functions.
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Once you are familiar with the program, you will probably find
these shortcuts much faster and efficient to work with.

Most shortcuts are listed next to the items in each menu.

You can find a complete list of all keyboard shortcuts at the end
of this manual.
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2.1

New

Open...

The Pull-Down Menus

File menu

The File menu provides the tools for storing, retrieving, and
saving. In other words, it allows you to manage different types
of files. It also provides tools for printing and exiting the
program.

Deletes the current file. Before deleting it, the program prompts
you if you want to save it. Options are Yes, No or Cancel to skip
the command.

Brings up a file selector allowing you to retrieve any document
you previously saved with one of the Save commands.

Opening a new file replaces the current document. Before it, the
program prompts you if you want to save it. Options are Yes,
No or Cancel to skip the command.

The file selector offers the possibility to choose any supported
file format. Once you have chosen it, select the document, then
press Open.

Open macro

Brings up a file selector allowing you to retrieve macros,
animated tutorials that you can find in the /solidThinking/Demos
directory  (this menu command and the folder
/solidThinking/Demos directory are currently available only in
the Windows version).
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Merge...

Save

Brings up a file selector allowing you to specify a previously
saved document whose content will be merged with the current
document. Merge ignores views configuration information from
the incoming file.

Just as the Open command, the Merge file selector lets you
choose any supported file format. Once you have chosen it,
select the document, and then press Open.

Saves the current document either in the solidThinking file
format or in another supported format. A file selector is brought
up allowing you to name it. If the file already has a name, the
program will overwrite it.

In the Preferences panel (Info b Preferences...) you can
enable the Autosave option for automatically saving the current
scene every “n” minutes. You can also use the Safe save, which
is useful to avoid accidental savings. In fact, every time you
save a previously named scene, a decision box will prompt you

if you are sure to save.

Note: when you save a file, you save not only its geometry but
also materials and display information, which includes views
mode, zoom level, snap and grids status.

Save as...

Names and saves the current document. A file selector is
brought up allowing you to name it.
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Save selected...

Saves selected objects either in solidThinking file format or in
another supported format. A file selector is brought up allowing
you to name it. If the file already has a name, the program will
overwrite it.

Save as model...

Revert

Exit

Allows you to save any selected object in the Models library so
that it can be quickly retrieved for any successive use.

A small Save as panel is brought up. Here you can create the
model icon, which will be used in the Library. Right click and
drag to orbit the object. Right click and drag while
simultaneously pressing to adjust the zoom factor. Choose
the Group name where you want to store the new model, then
type the Model name and click OK to confirm. You can choose
a group from the already existing list or create a new one by
simply typing a new name.

If you quickly right click a model icon, the program displays a
pop-up menu that allows you to Delete it or change its
Properties (name and group).

Discards all changes to the current document since you last saved it.

Quits solidThinking. Before quitting, a decision box is
displayed asking whether you want to save changes you made to
the scene or not. Options are: Yes, No or Cancel to skip the
command.
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2.2

Undo

Redo

Cut

Copy

Paste

Edift menu

The Edit menu provides the tools for a precise editing of points
and objects in the scene.

Undoes an operation. The number of commands you can undo
depends on the amount of memory allocated to the undo and
redo operations as set in the Preferences panel (Info
Preferences...). The more complex the commands, the fewer
will be retained in memory.

Cancels the effects of the undo. Redo is only available after you
undo a command.

Removes selected objects from the scene and puts them on the
clipboard.

Copies selected objects and puts them on the clipboard.

Inserts objects on the clipboard into your scene.
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Delete
Deletes the selected objects.

Collapse Construction tree

Unlinks the selected object from the construction tree, leaving it
freely editable. It also deletes any source object that is not used
in another construction tree. Before performing this command,
the program warns you that the source objects will be deleted.
Click Yes to confirm, No to cancel the command.

Uncombine entities

Creates a separate object for each entity of the selected
object/objects. Uncombine can only be applied to objects that
are NOT involved in a Construction Tree.

Prune

Deletes the selected object and all its source objects that are not
used in another construction tree.

Toggle Object/Edit mode

Lets you toggle between Object mode (for selecting objects and
apply transformations to selected ones) and Edit mode (for
working on hotSpots.
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Active snaps

Opens a submenu allowing you to activate the following snap options:

Grid #1
Grid #2
Grid #3
Grid #4
To snap any entity to the closest grid intersection.

o Point
To snap any entity to curves and surfaces control points, endpoints
of curves, midpoints of lines, and centers of circles, arcs, ellipses.

e Translate

e Rotate

e Scale

To translate, rotate, and scale only by steps of the measure you
have set in the Grid Setup panel.

e Curve
To snap whatever you are moving (a point, a light, or a camera)
to any point on a curve.

e Tangent
To snap whatever you are moving (a point, a light, or a camera)
to a given curve tangent.

e Endpoint
To snap whatever you are moving (a point, a light, or a camera)
to the endpoint of a line.

e Midpoint
To snap whatever you are moving (a point, a light, or a camera)
to the midpoint of a line.
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e 3D Snap

When you enable 3D Snap, snapping on the view-disabled axis
(the axis perpendicular to the view plane) is allowed. Otherwise,
snap is enabled only in the view plane, i.e. XY in the Top view,
XZ 1in the Front view, and so on.

e Snap disabled

When pressed, disables all the snap options you activated. This
way, you can quickly enable/disable your preferred snap
configuration without having to enable/disable each single option.

Grid setup...

Displays the Grid setup panel that is used to define up to four
different grids, each with its own origin and spacing, grid type,
and color.
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2.3 Selection menu

The Selection menu provides the tools for selecting objects and
controlling selected ones.

All

Selects all objects, cameras, and lights in the scene in Object
mode. All points of a selected curve or surface in Edit mode.

All geometry

Selects all the objects in the scene.

All lights
Selects all the lights in the scene.

All cameras

Selects all the cameras in the scene.

None

Deselects a) all the objects in the scene if you are in Object mode,
b) all the control points of selected objects if you are in Edit mode.

Invert

Swaps the selection of objects or points according to the
working mode.
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Group
Groups the selected objects into a more complex object so that
any transformations can be applied to all of them at once.

Grouping objects is also useful to put in order your scene.

You can select a group by simply picking it from the World
Browser.

World Bro

ﬂﬁll,@

I.Default layer j IF'iu:kinng.Eu:u:-: j

=¥ ‘world

‘ Perzpective camera #1
=-Ea R
F- i Suf #2
F- i Suf #3
-l Sl #1
@ Cameras
----- @ Lights
EEI---@ Layers

If you create a new object while a group is selected, the object
will be added to the currently selected group.

You can move an existing object into a group by just clicking

and dragging it.
=43 Wworld =-&3 World
. Perspective camera #1 ' Perspective camera #1
% [=1-=3 Group #1
=2 Group #1 -l Surf #2
- il Surf #2 F- il Surf #1
- il Surf 1 G-l Surf #3
G-l Surf #3 - Surf #4
-l Cameras -] Cameras
----- @ Lights @ Lights
-5 Layers it Lapers
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To simply copy the object into a group, instead of moving it,
click and drag it while pressing the left mouse button and the

key simultaneously.

|_:_|ﬂ whorld =¥ wWorld
-l Perspective camera #1 - Perspective camera #1
© S o 8 suf
=8 4 Group #1 =23 Group #1
Bl Surf #2 G- il Surf #2
-l Surf 41 G- il Surf #1
-l Surf #3 ﬂ Surf #3
-] Cameras - il Sur #4
..... ‘e Lights - Cameras
Eﬂ"'@ Layers i @ Lights

Once you have selected a group of objects, you can move it,
rotate it, or scale it by clicking in any view in a point free of any
item and dragging with the mouse.

In the next examples, we are applying a rotation to a group of
primitives.

Ungroup

Separates parts of a group that you can select from the World
browser.
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Center in view

Centers selected objects in the active view so that only selected
components are displayed.

Center in all views

Centers selected objects in all orthographic views so that only
selected components are displayed.

Hide from rendering

Disables the rendering of selected objects. Once hidden from
rendering, selected objects are transparent but already pickable.

Hide from view

Disables the visualization of selected objects in the views.
Selected objects are hidden only after you deselect them. Once
hidden from views, they can be selected again through the
browser.
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2.4 View menu

The View menu provides the tools for a complete control of the
visual representation of objects in the scene.

Layouts...

Opens a graphic panel allowing you to choose your preferred
views layout.

Detail...

Opens the View Detail panel, allowing you to adjust the level of
detail in the visual representation of objects.

Background image...

Opens the Background Image panel, allowing you to display
any selected image as a background for the active view.

Curvature

Opens the Curvature Display panel, allowing you to
dynamically analyze smoothness, curvature and other important
properties of your models by evaluating surface curvature,
reflection lines and environment mapping.
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Curvature Plot

Opens the Curvature Plot panel, which shows how the
curvature vary along a curve.

Zoom extent

Zooms the active view in or out so that all graphic components
are displayed.

Zoom extent all

Zooms all the orthographic views in or out so that all graphic
components are displayed.

Ortho adjust

Forces all the orthographic views to have the same zoom and
view point as the selected one.
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2.5 Tools menu

The Tools menu provides the tools for creating and modifying
curves, primitives, and surfaces. It also provides the tools for
adding cameras and lights to the scene.

Transform

Opens a submenu listing transformation commands.

Curves

Opens a submenu listing curves creation commands.

Surfaces

Opens a submenu listing surfaces creation commands.

PolyMesh

Opens a submenu listing commands for editing polygonal
surfaces.

PointsCloud

Opens a submenu listing the commands for editing points
clouds.
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Primitives

Opens a submenu listing primitives creation commands.

Texturing

Opens a submenu offering the Texture Positioning command
which allows you to position textures and more in general any
material containing a texture mapping shader. Note that this tool
is NOT provided for applying materials (for this purpose you
must use the shading panel) but only for positioning materials
that you have already assigned.

Cam/Light

Opens a submenu listing the following commands:

e Perspective Camera. Allows you to add and position a new
camera in the 3D scene.

e Light. Lets you add and position a light source in the 3D
scene.

Analyze

Opens a submenu listing the commands for analyzing curves
and surfaces.

CPlanes

Opens a submenu listing the commands for creating and
disabling construction planes.

Digitizer

Opens a submenu for calibrating the MicroScribe-3D digitizer.

solidThinking User Manual 49



Section 2

2.6 Managers menu

The Managers menu gives you access to specific windows
called Managers. Managers are used in different working phases
and they are fundamental to the use of the program. Please,
note that Managers shortcuts work only if panels are floating.

Browser

Displays/hides the Shape Hierarchy panel which allows you to
view the objects in your scene in their hierarchical structure, as
well as in relation to other elements. It lets you perform
numerous operations and change the hierarchy of the scene.

Modeling Tool

Displays/hides the Modeling Tool panel which gives you
access to the numerous parameters and/or options of each
Modeling Tool. Content of these panel changes depending on
the Modeling Tool you select.

Shading

Displays/hides the Shading panel that gives you access to
surface, light, and image shaders allowing you to choose
shaders you want to apply and set their various parameters. Post
processing effects can be tuned here as well.
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Application toolbar
Displays/hides the Application toolbar when it is floating.

Snaps toolbar

Displays/hides the Snaps toolbar when it is floating. The Snaps
toolbar contains all the snap options available.

Modeling toolbar

Displays/hides the Modeling toolbar when it is floating. The
Modeling toolbar lets you scroll modeling tools sorted in
categories whose names appear on blue tabs.

Materials toolbar

Displays/hides the Materials toolbar when it is floating. The
Materials toolbar lets you scroll materials sorted in categories
whose names appear on blue tabs.

Models toolbar

Displays/hides the Models toolbar when it is floating. The
Materials toolbar lets you scroll materials sorted in categories
whose names appear on blue tabs.

Devices

Opens a submenu that lists supported external devices. To start
up a device, just choose it. To stop it, choose it again.
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2.7

Render menu

Once you have created your models, assigned materials,
positioned lights and camera, you are ready to use the Render
menu. Options are:

Render current view

Renders a still image of the geometry as seen through the active
view. The rendering technique used is that chosen in the
Rendering Options panel.

Render selected objects

Renders selected objects using the rendering technique specified
in the Rendering Options panel.

Render animation

Renders the current animation.

Options...

Opens the Rendering Options panel, which allows you to
specify rendering methods and resolution.

Browse renderings

Opens the Renderings Browser, which shows you all the
pictures you have rendered since you launched solidThinking.
Pictures can then be saved or deleted.

Renderers...

Opens a panel that allows you to choose among the available
renderers.
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2.8

Environment menu

You can use the Environment menu to switch from the
Modeling environment to Animation environment and vice-
versa. In solidThinking VANTAGE you also find the Drawing
menu item.
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2.9 Help menu

General information, various optional settings, and the
registration panel can be found here.

Info
Opens the About solidThinking panel, which displays the
program version number, copyright notices. Press the OK
button to remove it from the screen.

Preferences
Opens the Preferences panel that lets you modify default values
of various optional settings.

Help

Opens solidThinking on-line help.
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General
User Interface
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General
User Interface

solidThinking user interface has been carefully designed to
reduce to the absolute minimum the number of commands
required to perform operations. It has been designed bearing in
mind that different working phases bring you to complete your
3D project: modeling, light settings, assignment of materials,
preview renderings, and final image.

Four modeling views are displayed. They occupy most of the
working space: it is here that you interact with the 3D scene.

Orthogonal and perspective views allow you to determine
position and shape of a 3D model.

When you launch solidThinking for the first time, the basic
layout is displayed and, with a screen resolution of 1024x768,
the user interface appears as in the following picture:
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Working with a higher screen resolution will give you more
working space and will allow you to visualize all the modeling
tools without having to scroll the toolbar.

On the top left of the screen, you can see the menu bar, which is
a constant element of the user interface.

Another constant presence is the console on the top right: it
prompts the next action to be performed when you activate a
modeling tool and lets you enter numerical values.

On the left of the screen, you find the Application toolbar and,
below, the Libraries toolbar that gives you access to Modeling
Tools, Materials, or Models.

You can float/dock these panels by simply picking and dragging
their borders according to your needs and/or preferences. When
floating, a toolbar displays its name and close button in the title
bar. Thus, the basic layout of the solidThinking user interface
may change as in the next picture:
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If you hide all panels, operations can still be performed by using
the menu commands. With this layout, modeling views have the
maximum space possible.

£ (Untitled) - solidT hinking
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A number of floating panels is used in different phases of a
working session. Learning the keyboard shortcuts that allows
you to quickly show/hide them will improve your workflow.

Color [<None>]
Reflectance [<None>]

Transparency [<None>]
Displacement [<None>]
Testure space [<Nane>]
Erission [<None>]

solidThinking offers several different layouts; thus you can
adopt the one you prefer. Pictures in the next page show some
possible customizations of solidThinking user interface.
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B2 (Untitled) - solidT hinking

olidT hinking

ERTIERINEF| Perspective #1

8 Perspective #1

) Curve #1
Sut 42
B
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3.1

Space in
solidThinking

To define the three-dimensional space, solidThinking, just as
most computer graphics applications, uses the FEuclidean-
Cartesian coordinate system: three perpendicular axes (X, Y, Z)
intersecting at one point called origin (whose coordinates are 0,
0, 0).

In the Cartesian coordinate system, also known as XYZ
coordinate system, any point in the 3D scene is identifiable by
one coordinate in the X direction, one in the Y direction, and
one in the Z direction.

The coordinate system adopted in solidThinking is a Z-up
world: it means that, in a world representation where the X and
the Y directions are on the same horizontal plane, Z represents
the up direction.

The Z-up world is certainly the most used by designers and
architects, while the Y-up world, another world representation
where Y represents the up direction, is often preferred by
animators.

/Y

N
~
<V
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The mathematical representation of space here described can be
applied to either a global or a local coordinate system.

The global (also called world) coordinate system is a coordinate
system that is used to locate an object in relation to a world
origin. The world origin is a reference point unique for all the
objects in the 3D space.

The local (also called object) coordinate system is a coordinate
system that is applicable to a single object having its own center

as origin.

Any object in a 3D space has both local and global coordinates.
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3.2 The Modeling Views

Most of your work in solidThinking is performed in the
Modeling Views.

By default, three orthographic views describe the 3D scene as
seen from the Top, Front, and Right side.

One perspective view displays the 3D scene as seen from the
active Camera.

It is possible to choose what is displayed in each view by just
clicking the view name on the left of the title bar. Six different
orthographic views and any defined perspective camera are
possible.

DR poonceivecone b
Right k

Front

Top

Perspective camera #1
Left

Rear

Bottom

I

You could have, for example, four perspective views using four
different cameras instead of three orthographic and one
perspective.
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The origin of the Global Coordinate system is represented by
the intersection of the white lines at the center of each
orthographic view.

Each orthographic modeling view has its own plane shown on
the bottom left of every view:

Top and Bottom views use a XY plane.

Front and Rear use a XZ plane.

Right and Left use a YZ plane.

A view can be enlarged to fill all the space inside the main
window by simply double-clicking its title bar. Double click it
again to restore it to its normal size.

Only one view at a time can accept mouse input. The active
view has the title bar drawn with the standard Windows color
used for active windows. A view can be activated by clicking
either inside it, its title bar, or by pressing the | Ctrl | key ([ Apple |
on the Mac) while the mouse is positioned anywhere in the view
to be activated.

The small buttons on the right side of the view title bar control
the area displayed in the view and various parameters such as
position, orientation, field of view, etc.

To activate them, just click the icons with the left mouse button
and drag the mouse, or click inside the view while holding
down the appropriate shortcut keys and right mouse button.
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Track

Zoom

Orthogonal Views

Drag the mouse horizontally to move the view from side to side.
Drag it vertically to move the view up and down.

Win [Right Mouse Button |

Mac |Apple]+[Mouse Button|

Drag the mouse up to enlarge the view. Drag it down to shrink
the view.

Win |[Shift| + | Right Mouse Button |

Mac |Apple|+|Shift|+ | Mouse Button |

Area Zoom

Click in any view to set a corner, then drag the mouse
diagonally to define the area that will be magnified.

Win |Alt] +|Right Mouse Button |

Mac |Apple|+ |Alt]+ | Mouse Button |
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Dolly

General User Interface

Perspective View

Lets you pivot the camera around its point of interest.

Win |Right Mouse Button |

Mac |Apple|+|Mouse Button|

Drag the mouse up to move the camera forward. Drag it down
to move the camera backward. This action does not change the
viewing angle: perspective distortions may result at the edges of
the scene.

Win |Shift|+ |Right Mouse Button |

Mac |Apple|+|Shift|+ | Mouse Button |

F.O.V. (Field Of View)

g

Drag the mouse up to zoom in. Drag it down to zoom out. This action
changes the camera field of view and increases the size of the point
of interest by increasing the lens length.

Dolly / F.O.V.

12

Track
5

This function combines Dolly and F.O.V.

Drag the mouse horizontally to move the view from side to side.
Drag it vertically to move the view up and down.

Win |[Ctrl| + |Right Mouse Button |

Mac |Apple]+|[Ctrl| + | Mouse Button |
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Area Zoom

Click in any view to set a corner, then drag the mouse
diagonally to define the area that will be magnified.

Win |Alt]+|Right Mouse Button |

Mac |Apple]+|Alt] +|Mouse Button |
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Using local coordinate systems

When you create an object, you are prompted to position its
local coordinate origin. Any coordinate specified from then on,
refers to this local coordinate system. Translating or rotating the
object (while in Object mode) does not actually moves its
points, but rather changes the position and orientation of the
local axes. Since the object is defined in its local coordinate
system, it moves according to its axes. The x, y, and z axes of
each selected object are depicted in red, green and blue,
respectively.

Thus, an object can be drawn with a particular alignment in
relation to its local axes. For example a rectangle can be drawn
on the XY plane aligned to the X and Y-axes. It can then be
rotated 45 degrees and translated to the right position in the
world. Since the rectangle is still aligned to its local axes, you
can modify its width and height by moving its points along its
local X and Y-axis.

solidThinking allows you to draw in different coordinate
systems: local, global, but also in the system of a parent object
or of any other object. By default, solidThinking draws in local
coordinate system in the perspective views and in world
coordinates in the orthographic views.

The coordinate system orientation is shown on the lower left
corner of each view. Since the mouse moves on a two-
dimensional plane, only movements along two axes at a time
can be specified with the mouse. You will find these axes on the
lower left corner: the two active in red, while the other in green.

By rotating the perspective camera around an object, the current
local axes rotates too, and the two active axes change depending
on the orientation of the camera.
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When you implement a transformation, a parameter called
“reference axes” lets you specify which coordinate system you
wish to use. For further details, refer to modeling tools,
transformations.

By using local coordinate systems, you do not need to define a
construction plane each time you want to edit an object; simply
let the construction plane "follow" the object around the world.
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View Modes

You can select different viewing modes in which to display
your scene. By default, the Wireframe view mode is displayed
in each window.

If you want to modify only one view at a time, you can click the
W (Wireframe), S (Shaded) or T (Textured) icons displayed on
the title bar of each view.

The Wireframe mode offers the fastest display. Objects are
displayed as a curve meshes.

The Shaded mode is useful to see the shape of the objects and
how lights illuminate the scene.

The Textured mode displays not only the shape but also the
texture and/or the procedural material assigned to objects. In
case of procedural materials, which have no textures, the
representation does not exactly fit the final effect being only
aimed to give you an idea of what to expect. The textured mode
takes the longest time for refreshing the display but it can be
very useful for previewing your scene before starting the
rendering session.
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3.4

View Layouts

solidThinking offers several view layouts options, so that you
can easily find the ideal configuration for your project. They are
displayed in the Layouts panel that appears when you choose
the View » Layouts... command.

Layouts E3
P E P
Flp
R P R
T p p |1 100z P
F F P TIF
1 bl bt
R Flr|P F] P P [E
3 R R
P TIF R TIP
e P Flr

To choose a view division layout, just click the corresponding
icon: the panel closes and the views are redrawn.

You can enlarge one view to fill all the space inside the main
window by simply double-clicking its title bar. Double click it
again to restore its normal size.
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View Deftail

Detail can be usefully modified when moving complex models.
A low level of detail allows a faster representation of an object
speeding up modeling operations. A high level of detail can be
useful for a better visualization, but it will slowdown the
redrawing process. The level of detail you can reach without
compromising the redraw performance depends on your
hardware configuration. You should avoid increasing the level
of detail too much if your hardware is not powerful enough.

solidThinking lets you adjust the level of detail in the visual
representation of objects through the View Detail panel, which
can be selected from the View main menu item.

View Detail [ X|

, ........... |__ OW ........... \I Medium l ﬂ|gh I Eustom I

..................................

Customize... I

Low, Medium, and High are preset while Custom stores any
detail setting defined through the Customize View Detail panel
that appears when you click the Customize button.

The Transparent surfaces drawing mode can be enabled by
switching the check box on.

You can move through the options using the left and right
arrows. Each command name has an underlined letter. If you
press the corresponding letter key, you can directly apply that
command.

Note: Changing the visual representation of your model does
not affect in any way its geometry.
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Customize View Detail

NURBS curves and surfaces are curved in a continuous manner,
while computer display better deals with straight lines and flat
polygons. For this reason, NURBS curves and surfaces are
tessellated into polylines and polygons at redrawing time.

The representation quality of the object improves as the number
of subdivisions of a surface grows. The number of subdivisions
generally depends on the number of control points defining a
surface.

The Customize View Detail panel allows you to define your
preferred detail setting.

Customize View Detail E3

—Wireframe———— [~ Shaded/Textured — Lines
Method: m Method: Im Method: m
Resolution: |247 Resolution: Izg— Resolution: Izai
Minimum: |47 Minimum: |17 Minirnum: ’1f
I aximum: IW Magimum:  |200 Maxzimurn: IW

Cancel | Apply |

In particular, the Wireframe, Shaded/Textured sections of the
panel give you control over surface detail, while the Lines
section is used to adjust curves detail.
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Three different methods can be chosen from the Method pull-
down menu. They are: Fixed, Linear, and Log10.

Fixed method

The number of control points does not affect the number of
subdivision, which is fixed and corresponds to the parameter
Resolution.

subdivisions A

detail

Fixed method

} control points

Linear method

The number of subdivisions is linearly proportional to the
number of control points according to the formula: subdivision
= resolution * control points.

subdivisions A

detail

Linear method

> control points
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Log10 method

The number of subdivisions is linearly proportional to the
number of control points according to the formula: subdivision
= resolution * log10 (control points)

Compared to Linear, the Logl0 method allows you to contain
the number of subdivisions in case of surfaces with numerous
control points.

subdivisions A

detail

Log10 method

> control points

After choosing the method, for each section of the Customize
View Detail, you can set other visualization parameters.

Resolution determines the level of detail. The effect of this
setting changes depending on the method you choose. See the
above discussion and related charts.

You can limit the number of subdivisions in a range comprised
between a minimum and a maximum value. In particular,
Minimum determines the minimum number while Maximum
determines the maximum number of subdivisions allowed, even
though a high level of detail has been set in the resolution field.
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Press OK to confirm all changes and close the panel, Apply to
apply changes without closing the panel, Cancel to cancel any
changes.
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3.6 Background Image

The Background Image panel allows you to choose an image
that will be displayed as reference in the active view.

To open it, select the Image Plane... command from the View

menu.
x
~Image-
File name:
I Browse... I
—Visibility——  — Origin- -
V View Horizontal: I[]
Vertical IU
—Ref. space - =
: —Size- |
* View ‘
C a0 Horizontal: 11
Vertical |1
~ Paosition—— [V Keep aspect ratio
" Free - >
& Center -~ Rotation
C Fi &ngle: IU
— Transparency -
Slpha: I1
| 0K I Apply I Cancel |

Press the Browse... button to choose the reference image.
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You can so use any sketch to help you draw lines and curves of
your project. Note that this image will not be used for the final
rendering, in which case you should use the Image shaders from
the Background shader class.

If you want to remove the image as background of a view, just
switch off the Visibility check button.

Ref. Space (Reference Space) should be used to determine
whether the image size should be independent from the zoom
factor (View) or bound to the zoom factor (3D).

The position section offers three options: Free if you want to
freely position the image within the view, Center if you want it
centered, Fit to adapt it to the entire view.

The Origin section lets you set the position of the image origin
in case you have chosen the Free option in the Position section.

Adjusting the Horizontal and Vertical value modifies size of
the image plane. Leave the Keep aspect ratio option switched
on if you want to maintain proportions.

The image plane can be rotated by simply setting the Angle
degree in the Rotation section.

The Transparency section allows you to control the
transparency level (alpha) of background images for better
visibility when modeling.

Press Apply to display the image plane or to update settings
without closing the panel or OK if you also want to close the
panel.
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3.7

Grid Settings

Grids help you place points and objects into the scene with
precision. Grids do not appear in rendered images: they are
only temporary drawing aids, extremely useful to place and
align objects in an accurate manner.

solidThinking lets you adjust grid settings through the Grid
setup panel that can be displayed by choosing the Edit » Grid
setup command.

Modifications to grids and snaps settings in the Grid setup
panel are immediately drawn in the views.

i Grid #2 | Gii i
Grid #1  Grid #2 | Grid #3 | Grid #4 | T
—XYZ IV Grid #1
Origin: IU IU vV Grd #2
Spacing: I1 I-I I-] IV Grid #3
IV Grid #4
ad R
@ iaa || 588 | I Choose... | —Active snap—
* Grid #1
O G
—Angles—— [ Scale% el
: s : T " Grid #3
tep: I tep: I . C Grid #4
—Translate——————— [~ Defaults
Step: |0.1 Restore defaults
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Here you can define up to four different grids, each with its own
origin and spacing, grid type, and color.

As default, all construction grids are based on the Global
Coordinates origin, but they can be shifted individually.

You can set the spacing of the grids to match the scale you work
in. For small mechanical parts, use small grid spacing for the
first grid and increase the spacing for the second, third and
fourth grid. Similarly, for a building the basic grid spacing can
decrease for additional grids. If you set all the spacing values to
zero, the grid will not be drawn.

The three grid icons define the type of line for the selected grid.

To define the color of the grid lines for the selected grid just
click the Choose button and select your preferred color from the
Colors panel. Once confirmed, the color appears in the color
field on the left.

The Visible grids section allows you to check the grids you
want to make visible and the ones you don’t.

The Active snap section allows you to define the grid to which
the snap will be applied.

When snaps are activated, Angles, Scale %, and Translate
allow you to rotate, scale, and move only by steps of the
measure you typed in the numeric.
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3.8

Snap Options

To activate snaps choose Active snaps from the Edit menu item
or open the Snaps toolbar by choosing Managers » Snaps
toolbar

Options are:

Grid # 1

Grid # 2
2
Grid # 3

+t

3

e
Grid # 4

4] Snap to grid lets you snap any entity to the closest grid intersection.

Point
Cal Snap to points allows snapping any entity to:
- curves and surfaces control points;

- endpoints of curves;

- midpoints of lines;

- centers of circles, arcs, ellipses.
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Translate
t, 2

+,
Rotate

¢

Scale

$

O+ These snaps allow you to translate, rotate, and scale only by
steps of the measure you have set in the Grid Setup panel.

Curve
oh Snap to curve allows you to snap whatever you are moving (a
point, a light, or a camera) to any point on a curve. It takes
precedence over the above mentioned snap options.

After you have enabled this snap option, click the curve you
want to snap to. Without releasing the mouse button, slide the
snap point along the curve. Release the mouse button when you
have reached the desired position.

To set the point free from the curve, just press the key. To
snap to another curve in the scene press again the key
when you are over it.

Snap to curve makes achieving intersections easy. You are
suggested to disable this option when you do not need it.
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Tangent

Snap to tangent allows you to snap whatever you are moving (a
point, a light, or a camera) to a given curve tangent. It takes
precedence over any other snap options. You are suggested to
disable it once you have used it.

After you have enabled this snap option, and positioned the local
axis, click on the curve you want to snap to.

Without releasing the mouse button, slide the snap point along
the tangent of the curve until you have reached the desired
position. Then, release the mouse button.

Repeat the same steps for the second point: click the curve you
want to be tangent to and, without releasing the mouse button,
slide the snap point along the tangent of the curve.
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Release the mouse button once you have reached the desired
position. You can insert all successive points normally. The new
curve remains tangent to the first one.

If you want the first point of the new curve to coincide with the
last point of the first curve, you must also enable snap to point.
Place the first point of the new curve out of the first curve and,
without releasing the mouse button, drag it until it snaps.
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Then, position the second point: click on the curve and, without
releasing the mouse button, slide the snap point along the
tangent of the curve. Release the mouse button when you have
reached the desired position.

Snap in 3D

When you enable Snap in 3D, snapping on the view's disabled
axis (the axis perpendicular to the view plane) is allowed.
Otherwise, snap is enabled only in the active plane, i.e. XY in
the Top view, XZ in the Front view, and so on.

Snap disabled

[‘[‘ Disables all the snap options you activated. This way, you can
quickly enable/disable your preferred snap configuration
without having to enable/disable each single option.
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The Application
toolbar

When you start solidThinking, the Application toolbar is
displayed by default on the upper left of the screen.

If you click its border, you can drag it and obtain a floating panel
that can be quickly shown/hidden by choosing the Managers
» Application toolbar menu item.

File Edit Selecton Yiew Tools Managers Render Info File Edit Selecton Yiew Tools Managers Render Info

os| =
: b= T55
08¢ M| xvyz

Qe+
oae

The Application toolbar includes two icons used to identify the
two main working modes of the program: Object mode and
Edit mode. A third icon on the same row is used for the Group
mode. They are explained in the next paragraph.

In the row below, three icons, used in combination with the
transformation tools, let you constrain points insertion and
transformations as follows:
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X-axis
x Transformations are applied only to the X-axis.

Y-axis
Y Transformations are applied only to the Y-axis.

Z-axis
z Transformations are applied only to the Z-axis.

The next three icons are:

Zoom extent all

Zooms all the orthographic views in or out so that all graphic

@ components are displayed. The same icon, but smaller, appears
on the titlebar of each view. Click this small icon to apply the
zoom extent to a single view.

Center selected all

Centers selected objects in all the orthographic views so that

X only selected components are displayed. The same icon, but
smaller, appears on the titlebar of each view. Click this small
icon to apply the center selected to a single view.

Ortho adjust

Forces all the orthographic views to have the same zoom and
: view point as the selected one.

e~
I R
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The last three icons represent the three main libraries whose
contents are displayed in the Libraries toolbar:

Actions

The Actions library contains numerous modeling tools that

ﬁ‘ allow you to apply transformations, deform shapes, draw
curves, create surfaces from curves, edit surfaces, work on tri-
meshes, add primitives, cameras, and lights.

Materials
2, The Materials library holds a number of materials provided with
fd the package. This library can however be expanded and be used

to store any of your custom materials.

Models

Just as the Materials, the Models library is easily extensible and
G it can be used to store 3D models.
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3.10

Working Modes

As we have seen, the Application toolbar displays three icons
that represent the main working modes:

Object mode

-

Used to select objects and to apply transformations to selected
objects (translate, rotate, scale, mirror, etc...). To select an
object, you can click any point of its surface.

Object mode can also be selected by toggling the menu
command Edit » Toggle object/edit mode.

Edit mode

J

Used to work on hotSpots. The hotSpots are displayed in blue
and allow you to interactively modify object/action parameters
by dragging/selecting hotSpots in any view.

Edit mode can also be selected by toggling the menu command
Edit » Toggle object/edit mode.

HotSpots can be associated to any parameter. They can be
control points, vertices, isoparametric curves on a surface, the
focuses of an ellipse, or anything that can be associated to a
parameter. Some can be dragged while others may only be
selected.
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When you are over a hotSpot, a yellow tab displays its name. In
case of a circle, for example, you can modify radius and
start/end angles by just clicking the appropriate hotSpots and
dragging them.

When in Edit mode you cannot select or deselect objects in the
views, unless you resort to the browser.

Important note: You can quickly toggle from Object mode to

Edit mode by pressing [ Spacebar|. Learning to use this shortcut
can dramatically improve your workflow.

Group mode

¥

Used to select groups and to apply transformations and/or
materials to a group as a whole. If you pick an object that is part
of a group, the entire group will be selected. When you are in
Group mode you cannot translate an object or a group by
clicking and dragging in the view, while it is still possible to
apply any transformation by activating the appropriate tool.

Parameter edit / Point Edit

LI

Allows to modify the position of the object’s control points (for
a NURBS primitive) or vertices (for a PolyMesh) even if the
object is the result of a Construction Tree.

This would normally be impossible since the object’s points
positions are determined by the Action that built the object itself.
With this editing mode, which compares to the editing of the
Action’s parameters, it is possible to move these points. What
actually happens is that an offset is attached to every moved
point. This offset is maintained even if the object’s original
points are changed by the source Action.
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To enable object’s points editing, click the I icon or use the

+ shortcut.

Remember that this actually switch from Parameter edit to
Point edit but to effectively see and manipulate object’s points,
Edit mode needs to be selected.

When in Point edit mode, the Multi Edit modeling tool is
automatically invoked. Transformations can be applied using the
standard transformation modeling tools: Translate, Rotate and
Scale (to be invoked by clicking their corresponding icons or by

using the [T |, [R]or [S | shortcuts, respectively).

The Multi Edit modeling tool panel contains two buttons to
remove the editing from the currently selected points (Un-edit
selected) and from all the points of the currently selected objects
(Un-edit all).

The offset is actually bound only to objects that are the result of
an Action. Collapsed objects - objects whose Construction Tree
has been collapsed - will have their points moved. This is to
avoid useless complications: since these objects have no action
behind them, their points can be freely moved. Anyway, all this
“processing” is performed automatically by the program and the
user does not have to take into account these special cases.

The fact that an offset is bound to the point must be taken into
account when using this editing mode. Moving points of
revolution objects (i.e. sphere, circle, lathe) may give
unexpected results if the object is, for example, refined (more
points added along the circumference) or if Start angle or End
angle parameters are changed. The offsets applied are always
specified as (X,Y,Z) values added to the source points, not as
“radial” offsets with respect to the circumference on which the
object is based.
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Selecting Objects

To select an object, choose the Object mode and click its
surface. To pick and drag an object in a window view, just click
it and move the mouse while holding down the mouse button.
Picking a new object automatically deselects any previously
selected object. Picking can be performed in any view,
perspective view included.

An object can also be selected within the hierarchy browser by
simply clicking it. This is very useful especially when objects
coincide or in complex scenes.

In order to understand how solidThinking works, you should
remember that an object could be made of one or more entities
(for example, a cube is formed by six entities called faces).

To represent the status of an object, solidThinking uses the
following colors:

Blue. Object is not selected.

Red/Magenta. Object is selected. The red color is applied to the
selected entity, magenta to the non-selected entity. When the
entity is represented in magenta you cannot delete, copy, or cut
it, but you can apply any other object transformation.

Dark green. Object is involved in the Construction Tree of the
selected object (see also 4.1, The Construction Tree, page 116 ).
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For multiple selections, pick the objects while holding down the

key.

Hold down the mouse button and drag in the view to select any
object included in a selection box. To force selection box even
if you are over an object or a hotSpots (thus avoiding to activate

a translation), hold down + and drag with the mouse.

To select an entity (and not the whole object), pick it while
holding down the [Alt] key.

Consider a NURBS curve, for example: portions of different
order can characterize it. To select an entity and not the entire
curve, pick it while holding down the [Alt] key.
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Selecting Points

To select a point, choose the Edit mode and click it. To pick
and drag a point in a window view, just click it and move the
mouse while holding down the mouse button. Picking a new
point automatically deselect any previously selected point.
Picking can be performed in any view, 3D view included.

To represent the status of a point solidThinking uses the
following colors:

Blue. Point is pickable.
Yellow. Point is selected.

When you apply a transformation to some selected points, these
are displayed in blue but in a smaller size.

Light green. Point is not pickable and is visualized (in a smaller
size) in order to enable snap to point.

For multiple selections, pick points while holding down the

key.

To choose a range of points from the currently selected to the
clicked point, hold down the key.
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Hold down the mouse button and drag in the view to select any
point included in a selection box. To force selection box even if
you are over a control point or another hotSpots (thus avoiding
to activate a translation), hold down +[Shift] and drag with the

mouse.

96

solidThinking User Manual



3.13
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Selecting Groups

When you are in Group mode and pick an object that is part of
a group, the entire group will be selected. When you are in
Group mode you cannot translate an object or a group by
clicking and dragging in the view, while it is still possible to
apply any transformation by activating the appropriate tool.

A group can also be selected within the hierarchy browser by
simply clicking it.
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3.14 The Libraries
Toolbar

Content of the library you select in the Application toolbar is
displayed in the Libraries toolbar.

The Libraries toolbar lets you scroll actions, materials, or
models sorted in categories whose names appear on blue tabs.

By default, at the launch of the program, the Libraries toolbar is
positioned below the Application toolbar and displays the
modeling tools available.

If you click the border, you can drag it and obtain a floating
panel.

File Edit Selection View Tools Managers Render Info
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-~ Info

:Application "7‘

To select the library to be displayed, just click the related icon
in the Application toolbar or choose the Managers menu and
select Modeling toolbar, Materials toolbar, or Models

toolbar.

solidThinking User Manual 99



Section 3

To scroll the content of the toolbar, just click a blue tab
(Transform, Curves, etc.) and drag while holding the LEFT
mouse button down.

Scrolling can be also performed by clicking and dragging any
point of the toolbar while holding the RIGHT mouse button
down (JApple | key and mouse button on the Mac). This way, you
can scroll when no blue tabs are displayed.

When you double click a blue tab, all tools within a category are
displayed/hidden.

o =
R 2
O
-
ezl <

If an icon contains two small blue arrows on the bottom right
corner, you can click and hold to display a pull-out that contains
other tools.

20 H0

| Click here

100 solidThinking User Manual



General User Interface

You can then drag the cursor to choose the tool you want to use.
When you are over each icon, the program displays the tool name.
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3.15

The Console

In the upper right corner of the screen, the console lets you enter
numerical values and prompts you on parameters required by
the active command.

=3

Select curves to fill - Spacebar to end:

To confirm default values, where indicated, just press the
key. To skip the current and all the subsequent prompts
for the current command, press [Ctrl | + | Enter | (| Apple | + | Enter
on the Mac). Default values will be assigned to the skipped
parameters.

Any parameter requiring numerical input can be either set
through the keyboard or specified by working interactively in
any views with the mouse. When you type XYZ coordinates,
values can be separated by a comma (i.e. 1,1,1), a semi-colon, or
any other key except a dot, which is used for decimals. A tab
can be used as well. [ Spacebar], on the contrary, cannot be used

as it puts an end to operations.

[Point #1 (Spacebar to end): 1,11
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By default, values are inserted with respect to the object’s origin
but, if you type the “@” symbol near any coordinate number
(i.e. @2,2,2 or 2,2@,2), they can be inserted with respect to the
previously inserted point.

F‘oint #2 [Spacebar to end]. @2,2,2

By typing X, Y, or Z before the coordinate, you can specify the
relative position respect to the X, Y, or Z axis (i.e. x1). This
way, you don’t have to type all coordinate values when just one
must change.

IE'oint #3 [Spacebar to end]: ®1
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3.16

The World Browser

The World Browser (Managers » Browser command) allows
you to view the objects in your scene in their hierarchical
structure, as well as in the context of their relations with other
elements. This way you can analyze how the scene is
constructed. Moreover, layers can help you organize your work
in an even more flexible manner.

Just as the hierarchical structure of the scene, the world browser
displays the Construction Tree, an important part of
solidThinking. We will look at it closely in section 4 while
discussing modeling. In the meantime, it is sufficient to know
that the Construction Tree shows the connection between a
surface and all its construction curves, and that it makes the
selection of construction curves easy and fast.

World Browser

T . |
!I | §|°||ﬂ|ﬂl _d_’ﬂ _l _3| IDefauIt layer l IPlcklng/B Box I

=- &3 World =i Surf #1

8 Perspective camera #1
@ Curve il
o
3 Cameras
‘e Lights
§3 Layers

- A Extrusion along a vector
=i Curve #1
A Circle: center, radius
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The Browser window can be freely resized and positioned
anywhere in the screen. If you want it floating, you will
certainly find it practical to use its keyboard shortcut to quickly
show it or hide it. The program remembers the last size and
position of the browser. If you prefer, you can dock it by simply
dragging and dropping it on the edge of the screen.

You have a range of possibilities for customizing the World

Browser. Options are displayed in the pop-up menu which
appears when you right-click within its window.

Layer locked

List hidden objects
Horizontal/vertical panes
Show/hide buttons
Show/hide C.Tree

List hidden objects

When you enable this option, hidden objects are not listed in the
Browser.

Horizontal/vertical panes

Organizes the Hierarchy Browser and the Construction Tree
horizontally or vertically.

Show/hide buttons

Shows/hides the buttons on the top of the Browser window.
Hiding them could be useful when you dock the browser
vertically and you need to save space.
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Show/hide Construction Tree

Shows/hides the Construction Tree. Useful to save space when
you have finished the modeling phase and you are working, for
example, on shading attributes.

Modifying the status of an object

The World Browser lets you perform numerous operations and
change the hierarchy of the scene. By right clicking one or more
selected objects in the browser, a pop-up menu appears showing
a number of commands and visualization options. Let’s examine
some of these operations which can also be accomplished by
clicking the appropriate button. Just as it happens in the
interactive views, icons used to represent state of an object turn
red once selected.

Picking disabled

Bounding box only

Hidden in interactive views
Hidden in rendering

Do not receive shadows
Do not cast shadows

Group
Uhareup

Delete

New layer
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Picking disabled

s Makes an object non-pickable. Convenient when you do not
want to accidentally modify the object.

Bounding Box only

m Displays the selected object as a bounding box, speeding up
modeling operations. Very useful when you have to deal with
complex models.

Hidden in interactive views

Disables visualization of selected objects from 3D views and
makes them invisible. Objects are visualized only when
selected, and hidden when deselected.

Hidden in rendering

N Disables rendering of selected objects.

Do not receive shadows

(i Choose this option if you do not want the selected object to
receive shadows.

Do not cast shadows

] Choose this option if you do not want the selected object to cast
shadows.
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Group

| Groups all selected objects. If you add an object to the scene
while a group is selected, the new object will automatically be
added to the group. If you choose this command while no
objects are selected, an empty group will be created. To add
objects to the newly created group, just drag and drop them into
the folder.

Ungroup

| Ungroups objects belonging to the selected group.

Delete

Deletes selected objects or groups.

Status filters

The pull-down menu on the top right of the browser window
allows you to decide which kind of information you want
displayed in the hierarchy browser. The three options available
work as status filters and they are self-exclusive in order to
provide a clear visualization of the scene. They are:

* Visibility Icons show objects that are not visible in
the interactive views or in the rendering.

* Picking/B.Box Icons show objects that are not pickable or
that use a bounding-box display.

* Shadows Icons show objects that do not receive or
do not cast shadows.
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Using the drag’n’drop technique

An object can be easily moved into a group by dragging and
dropping it: pick it with the mouse, drag it while holding the left
mouse button down, and finally drop it by releasing the mouse
button.

You can make a copy, instead of moving it, by clicking and
dragging while holding the key simultaneously.

Any object can be made of one or more entities. For example, a
cube-shaped object is made of six entities called faces. Just as to
objects, you can apply the drag’n’drop technique to entities,
though with some limitations. In fact, they can only be dropped
into objects that are not the result of a construction tree.

This way, you can move or copy entities that belong to an object
into another one. For example, in order to join two curves, you
can move or copy one of the two curve entities into the other
curve. This allows you to successively join the two entities
using the NURBS Curve Modeling Tool panel.

To rename an object, just select it and click it again or select it
and press the key, and then type the new name.

The Browser also lists the cameras and the lights in the scene. If
you select a Perspective camera, it will be displayed in the
views allowing you to interactively adjust both its position and
target hotSpots.

= &3 World '
i Foecive camers 1 EEEREEEmREREzE
i@ Curve #1
@ Suf il £
(8 Cameras [EZESSEET I T |
‘e Lights R
§§ Layers “ﬁw 1 I |
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Layers

The World Browser offers an ulterior tool, which is very useful
for organizing your models and particularly when managing
complex ones: layers.

Layers allow you to associate some objects regardless of any
group hierarchy of your model.

You do not have to necessarily use layers. Nonetheless, objects
are always created on a default layer. If you create other layers
you will have to specify which should be the current layer, i.e.
the one to which objects are automatically assigned when they
are added to the scene.

You can set the current layer by simply selecting it from the
layers pull-down menu.

I Default layer j I New layer j

Default layer
New layer MNew layer
New layer

New layer New layer

The current layer is clearly recognizable in the browser since its
icon is highlighted in yellow.

=-£2 Layers
<= Layeritl
<> Layerif2
<= Layertt3
<> Layertt4

Layers commands are accessible through the pop-up menu that
appears when you right-click within the browser. Some of these
operations can also be performed by clicking the appropriate
button.
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Delete

New layer
Delete layer
Layer color...

Layer on
Layer off
Layer locked

List hidden objects
Harizontal/vertical panes
Show/hide buttons
Show/hide C.Tree

New layer

Creates a new layer. When you create a new layer, it is
automatically set as the current one.

Delete layer

To delete a selected layer. When you delete a layer, the objects
in that layer are deleted as well. You cannot delete the current
layer.

Layer color...

You can assign a color to each layer to increase visibility of the
objects created on different layers. The color you assign is used
when the layer is not selected. In fact, when the layer is
selected, objects are always represented in red.
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Layer on

< Sets the layer on. All the objects assigned to the layer are

visible, pickable, and snappable.

Layer off

o> Sets the layer off. None of the objects assigned to the layer are

displayed, nor are they pickable or snappable. Useful to reduce
the visual clutter in the views.

Layer lock

B When a layer is locked, all the objects assigned to the layer are
displayed and snappable, but they are NOT pickable. Useful
when you want to restrict picking to the part of the model you
are working on.
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General User Interface

The Modeling Tool
panel

The Modeling Tool panel appears when you select Modeling
Tool item from the Managers main menu. Content of the
Modeling Tool panel changes depending on the Modeling Tool
you select.

This panel can be resized and positioned anywhere in the
screen. The program will remember its last size and position.

This panel is a fundamental part of solidThinking and we
encourage you to leave it opened until you become familiar with

the program.

We will look at it closely in the Modeling section.
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3.18 The Shading panel

The Shading panel (Managers » Shading command) gives you
access to surface shaders, light shaders, image shaders allowing
you to choose the ones you want to apply and set their various
parameters.

The Shading panel can be freely resized and positioned
anywhere in the screen. The program remembers the last size

and position of the window.

We will dwell upon this panel in the Rendering section.
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Preferences

The Preferences panel (Info » Preferences command) lets you
modify default values of various optional settings. Once opened,
it displays three tabs: General, Units, and View.

General

Autosave allows you to automatically save the current scene

every "n" minutes. To enable this option, switch on the Enable
check button and set the minutes value in the proper data field.

If you check Safe save on, every time you save a previously
named scene, a decision box will ask you if you are sure to save.
This option is useful to avoid accidental savings.

Switch the Large buttons off if you want icons of half the
default size.

The Texture folder section allows you to choose which folder
should be set as the default resource for textures.

Renderings buffer refers to the maximum number of rendered
pictures that will be displayed in the Rendering browser and
stored in the /solidThinking/Images folder.

Undo buffer lets you set the amount of memory solidThinking
uses to save 'undo' information. Simple commands take less
memory; thus, more simple commands can be undone. As
complexity increases, fewer commands will be retained in
memory.
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Units

The Units section allows you to specify the units of the scene.
solidThinking allows you to choose among various standard
units (Standard Units) as well as to specify your own unit
(Custom Units).

Tolerance

The Continuity tolerances section can be used to set the
Positional 3D tolerance. Such tolerance, expressed in the
current units, is used by the modeling tools that cannot produce
an exact result, such as pipe, birail, trim, intersect, blend, round,
and surface tangency align.

This ensures that surfaces you create do not deviate from the
theoretical result more than the specified tolerance. The lower
the tolerance, the higher the precision but also the slower the
computation. The 0.001 default value should be appropriate for
most cases.

Angular tolerance and Curvature tolerance work with the
same approach.

Changing this value with an open scene will cause all the
Construction Tree to be re-evaluated in order to fit the new
tolerance value.

View
The Fast Redraw check box is automatically disabled if engine
and graphic board do not support such mode.

The Grids in ortho views and Grids in 3D views check boxes
can be switched off in case you want that grids in the
orthographic and/or perspective views are not displayed.
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The Adaptive degradation option allows you to specify a
minimum number of frames per second during camera
movement. When the model is so complex that it could cause
the rate to drop below the specified level, the model will be
redrawn in a simplified manner. This includes wireframe and
bounding box. Set the value to 0 to disable the option.

The Visualization engine section lets you choose between
OpenGL and Direct3D. The Direct3D option is only available
on Windows.

At start up, solidThinking detects if DirectX is installed and if
hardware acceleration is supported. DirectX will only be used
under these two conditions. The DirectX option is only available
on Windows 95 and 98. It is possible to force solidThinking to
start with OpenGL or DirectX by holding down the or
key respectively during the program start up. This setting
will be definitive for all successive sections.

In order to exploit hardware texture mapping of accelerated
graphic cards, it is possible to specify the internal format of the
Textures. Three formats are supported: RGBA, RGB, and
BGR. If your system mounts an accelerated graphic board you
may want to verify which format is better supported. This option
is effective only with OpenGL.

Internal size specifies the dimension of the textures used by the
visualization engine. The higher the values, the slower will be
the redrawing.

Quality allows you to specify additional settings regarding
texture mapping. The Anti-aliasing option forces the texture to
be drawn anti-aliased. This ensures a better quality in texture
mapped visualization mode. On the other side, if the graphic
board does not support hardware anti-aliasing this may produce
a slower redraw.
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Entry-level graphic boards usually perform texture mapping
without taking in consideration the perspective deformation of
the texture over the polygons. This may deform the texture over
a surface. This effect is more evident when the polygons are
relatively large. Switch Force perspective correction on to
avoid this problem. Use this option only if actually needed, as it
will generally slow down redrawing.
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Modeling in
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Modeling iIn
solidThinking

A model is a representation of some features of either a concrete
or abstract entity. The purpose of a model is to let people
visualize and understand the structure or the behavior of the
entity, as well as providing the possibility to experiment and
predict the effects of inputs or changes to the model.

Computer aided modeling permits to design 3D shapes that
actually resemble real objects. They are manipulated by their
geometry, by the mathematical descriptions of the points, lines,
and curves by which they are created.

solidThinking uses NURBS (Non Uniform Rational B-Splines)
as its geometry type. This curve and surface definition method
offers the greatest flexibility and precision. NURBS are capable
of representing any desired shape, both analytic and free form
entities, and their algorithms are fast and numerically stable.
Excellent mathematical and algorithmic properties have
contributed to make of NURBS the de-facto industry standard
for the representation of geometric information processed by
computers.
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4.1

The Construction Tree

Modeling involves numerous concepts such as transformations,
curves, surfaces, primitives, and others. The following
paragraphs will discuss these concepts.

Modeling Tools are solidThinking main methods to create new
objects (Actions) or modify existing ones (Modifiers). The
Modeling Tool usually has parameters that define how the
object has to be created or modified.

The Action Modeling Tool creates the resulting object from the
input parameters. Once the Action has started, it remains active
for the whole life of solidThinking. This means that the object
created is not static. Parameters are maintained and a link is set
between the resulting object and the Action. When you change a
parameter, the resulting object is modified accordingly.

Parameters can be of various types: integer numbers, floating-
point values, 3D coordinates, a number of individual flags and
even other objects. The Extrusion Modeling Tool, for example,
accepts as input a profile curve (object), an extrusion direction
(3D coordinates) and an extrusion length (floating-point value).

When a parameter is an object, an interesting effect occurs. The
source object can be a result of an Action itself, then two actions
appear in sequence. Modifying a parameter in the first Action
causes its resulting object to change.

The resulting object can be a source object of another Action.
When the object changes, the Actions for which it is a source
are notified that the parameter (the object) has changed. They
perform the necessary calculation and modify their resulting
object accordingly.
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This relationship is called Construction Tree and it is a
fundamental structure in solidThinking. The Construction Tree
allows for a complex object to be created while any parameter
in the tree can be adjusted at any time. When a parameter
changes, all the actions down the tree are notified and re-
evaluated, propagating the change along the tree. There are no
limitations on the number of actions or objects involved in the
Tree.

solidThinking Construction Tree amplifies the power of all of
the tools. It allows you to replace source objects within the Tree
with immediate reconstruction.

You can manipulate both the parameters and the points of all
objects freely. And never forget the steps involved in
construction - the entire tree is saved inside the file and is
accessible at any time. You can browse the graphic
representation of the Construction Tree to identify and select
source objects and actions. It is also possible to collapse the
Construction tree so removing the history from an object.

Let’s now take a look at a very simple example as to how this
works. Choose the NURBS curve action, and draw a simple
profile as below. Than, create a revolution surface by selecting
the appropriate surface action.
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Now, select the starting profile by picking it either with the
mouse in any view,

or from the browser (just select Curve #1).

WL efault layper Yizihiliby
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Choose the Edit mode to make the program display control
points of the profile curve.
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Now, click any control point you want to modify and drag it.

Any modification of the starting profile interactively modifies
the revolution surface. You can choose the Shaded view mode
by just clicking the S icon on the title bar of the view.
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4.2

Modeling Tools and
Modeling Tool Panel

When you click the Actions icon from the Application toolbar,
the Libraries toolbar below displays the Modeling Tools
available.

DD
& =5
aqr
4P
DA Ve

To activate a modeling tool just click its icon and follow the
program console prompts.

To skip all console prompts, use the + combination
(_ Apple | + [ Enter | on the Mac). Default values will be used.

Clicking a new modeling tool will produce the same result.

To abort a modeling tool previously activated, press [Esc]. Any
eventually created object will be deleted.

To recall the last modeling tool activated, press the key
((Ctrl] + | Spacebar]| on the Mac).
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Any Modeling Tool has a number of parameters and commands
accessible through the Modeling Tool panel, another
fundamental part of solidThinking (It appears when you select
Modeling Tool item from the Managers main menu). This
panel can be resized and positioned anywhere in the screen. The
program will remember its last size and position.

Content of the Modeling Tool panel changes depending on what
you select. In the following pictures you can see some examples
of the panel appearance: Scale tool in the first picture, NURBS
curve drawing tool in the second, Birail action in the third, and
Torus primitive in the fourth.
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4.3

Modeling = Transformations

Transformations

Operations that move, re-orient, or resize items in a 3D scene are
called transformations. To apply transformations to objects you
must work in Object mode; to apply them to points you must
work in Edit mode. (see also 3.10, Working Modes, page 87).

Transformations include Translation, Rotation, and Scaling.

Deformations are also available and they include: Twist, Taper,
Warp, Shear, Bend, Lattice, Stretch, Linear Stretch,
PixelMap, and SurfDrape.

Mirroring and various Replication methods are included in this
category even though, strictly speaking, they are not
transformations.

Last, the Combine command allows you to merge two or more
separate objects of any type (curves, surfaces, tri-meshes,
primitives) into a single object.

For each parameter/command we will mention all the possibilities
as below:

Views: steps to follow allow you to work interactively with the
mouse in the views only;

Modeling Tool panel: steps to follow allow you to work in the
Modeling Tool panel only;

Views / Modeling Tool panel: steps to follow require you to work
in both views and Modeling Tool panel.
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d

Translate

Moves one or more pickable items in the 3D scene to a new
location.

How fo use

When you pick one or more items (objects or points) and drag, a
translation is always applied regardless of the transformation you
have selected.

Translation can also be applied by following the standard
transformation steps:

1. Pick the items you want to move.
2. Click the Translate icon or choose the Tools » Transform
» Translate menu command. You can also perform a

translation by using the | T [ keyboard shortcut.

3.  To move the items you can use one of the following

methods:

a)  Click directly on the object and drag it to the new
location.

b)  Click an area of the view that is clear of any items and
drag.

c) Input precise XYZ coordinates of the target location
in the Modeling Tool panel.
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4. By default, the translation reference point of an item is
placed in relation to its local axes. Because it may be
desirable to translate an object relative to an arbitrary point
(such as an edge), you may want to relocate it by using one
of the following methods:

a)  Click the Pivot hotSpot of the item in any view and
drag it to the new location.

b)  Choose one of the predefined Origin options in the
Modeling Tool panel.

c) Input the XYZ coordinates in the Pivot field of the
Modeling Tool panel to specify numerically the
location of an arbitrary origin point.

You can constrain movement along one axis by enabling only one
the following icons in the Application toolbar:

To move along the X-axis only (shortcut is the X key).

To move along the Y-axis only (shortcut is the Y key).

N =€ %

To move along the Z-axis only (shortcut is the Z key).

To constrain movement of the selected items along XY, XZ, or
YZ axes, just select two of the above icons at a time. Leave all
three icons selected if you want free translation.

Note: By default, translation is applied with reference to the
origin of the object’s local axes, but the Modeling Tool panel
allows you to choose among several options.
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To

Object

Options

To modify XYZ coordinates of the target location of selected item.
Views. Pick the item whose target location you want to modify
and drag it. Release the mouse button when you have reached the
desired location.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [ Enter].

To define the reference coordinate system.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

Local (default). Each picked item is moved with reference to its
local axis.

Parent. Each picked item is moved with reference to the
coordinate system of its parent node.

World. Items are moved with reference to the world (or global)
coordinate system.

Object. Items are moved according to the axis orientation of a
reference object that you can define in the Object section below.

To define the reference object in case you have switched on the
Object option in the Axis section above.

Views / Modeling Tool panel. Switch the Replace check button on
and pick the reference object in the scene. Then move the item.

Distance

Displays the translation distance.
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This option is available only when you are in Edit mode as it can
be applied to control points, not to objects. It is related to the
influence distance parameter.

Modeling Tool panel. Switch the chosen radio button on. You have
the following options:

Standard for the standard translation. All the selected points are
translated by the amount specified.

The other three options activate the Magnet behavior for points
translation. The center of the selected points will be the reference
point for the translation. Only points with a distance lower than the
one specified in the Influence distance parameter will be actually
translated. The amount of translation will be the same in case of
Constant, inversely proportional to the distance from the reference
point in case of Linear and Smooth. Smooth will provide a smooth
transition from the reference point to the external points.

Influence distance

Maximum distance within which the Magnet translation is applied.
Modeling Tool panel. Move the slider or type the rotation angle in
the Influence distance field.

Apply to

To selectively translate objects/points or axes. This option is
enabled only when you are in Object mode and when collapsed
objects (objects without a Construction Tree) are selected.
Modeling Tool panel. Choose one of the two options:

The Objects/Points option allows you to move objects or points.
Choose Axes if you want to move ONLY the objects axes.

Pivot Point

The start point of the Translation, which is used when you want to
Translate an object in reference to a specific point.

Views. Click on the Pivot hotspot and drag it. Release the mouse
button when you have reached the desired location.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [ Enter].
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@ Rotate

Rotates one or more pickable items in a 3D scene.

How fo use

Pick the item you want to rotate.

Click the Rotate icon or choose the Tools » Transform »
Rotate menu command. You can also perform a rotation by
using the [R] keyboard shortcut.

The views display the center of rotation.

By default, the center of rotation of an item is placed in

relation to its local axes. Since the effect of a rotation of an

item depends on the location of the center of rotation

(origin), you may want to relocate it by using one of the

following methods:

a)  Click the Center hotSpot of the item in any view and
drag it to the new location.

b)  Choose one of the predefined Origin options in the
Modeling Tool panel.

c) Input the XYZ coordinates in the Center field of the
Modeling Tool panel to specify numerically the
location of an arbitrary origin point.

By default, rotation is View dependent, i.e. it is performed
according to the two-dimensional plane of the window view
where you have selected the item to rotate. The plane of
view axis is displayed in the bottom left corner of each view
(for example, XY in the Top view).
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To define a different rotation axis you can choose one of the
Predefined rotation axes (X, Y, and Z) listed in the
Modeling Tool panel or the Custom rotation axis which lets
you input XYZ coordinates in the Custom rotation axis
fields for any arbitrary orientation.

6. To interactively rotate the item, you can use one of the
following methods:

a)  Click an area of the view that is clear of any item and
drag with the mouse (remember that you must not
pick the item as, in this case, a translation is always
applied regardless of the transformation you selected).

b)  Define the degree of rotation by moving the Angle
slider of the Modeling Tool panel.

Note: By default, rotation is applied with reference to the origin
of the object’s local axes, but the Reference Axes section of the
Modeling Tool panel allows you to choose among other options.
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Angle

Origin

Center

Options

To define the rotation angle.

Views. Click an area of the view that is clear of any item and drag.
Modeling Tool panel. Move the slider or type the rotation angle in
the Angle field.

To set the center of rotation (origin).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

Barycenter. The rotation center coincides with the barycenter.
Center of bounding box. The rotation coincides with the center
of the bounding box of the item (or items).

Axes origin (default). The rotation center coincides with the axes
origin.

Point. The rotation center coincides with any arbitrary point that
you can define in the Center section below.

To define an arbitrary location (defined by the XYZ coordinates)
of the origin.

Views. Pick the Center hotSpot of the rotation axes and drag it to
the new location.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter].
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Predefined rotation axis

To set one of the predefined rotation axis.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Rotation about the X-axis.

Y. Rotation about the Y-axis.

Z.. Rotation about the Z-axis.

View dependent (default). Rotation is performed according to the
two-dimensional plane of the view where you have selected the
item to rotate.

Custom. Lets you input XYZ coordinates in the Custom rotation
axis fields below.

Custom rotation axis

To define an arbitrary orientation of the rotation axis.

Views. Pick the Custom rotation axis hotSpot of the rotation axes
and drag it to the new location.

Modeling Tool panel. Input the XYZ coordinates in the Custom
rotation axis fields.

Reference axes

To define the reference coordinate system.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

Local (defaulf). Each picked item is rotated with reference to its
local axes;

Parent. Each picked item is rotated with reference to the
coordinate system of its parent node.

World. Items are rotated with reference to the world (or global)
coordinate system.

Object. Items are rotated according to the axes orientation of a
reference object that you can define in the Object section below.
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Object

To define the reference object in case you have switched on the
Object option in the Reference Axes section above.

Views / Modeling Tool panel. Switch on the Replace check button
and pick the reference object in the scene. Then drag with the
mouse in the scene.

Apply to

To selectively rotate objects/points or axes. This option is enabled
only when you are in Object mode and when collapsed objects
(objects without a Construction Tree) are selected.

Modeling Tool panel. Choose one of the two options:

The Objects/Points option allows you to rotate objects or points.
Choose Axes if you want to rotate ONLY the objects axes.
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@ Scale

Changes the size of one or more pickable items in a 3D scene.

How fo use

1. Pick the item you want to scale.

2. Click the Scale icon or choose the Tools » Transform »
Scale menu command. You can also perform a scale by
using the [S] keyboard shortcut.

3. The views display the center of rotation.
4. Define the origin (center) of the scaling.

By default, scaling is performed according to the item’s

local axes. The scaling effect of an item (and especially of

points) often depends on the location of the origin; thus, you

may want to relocate it using one of the following methods:

a)  Click the Center hotSpot of the item and drag it to the
new location.

b)  Choose one of the predefined Origin options in the
Modeling Tool panel.

c) Input the XYZ coordinates in the Center field of the
Modeling Tool panel to specify numerically the
location of an arbitrary origin point.
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5. To interactively scale the item, you can use one of the
following methods:

a)  Click an area of the view that is clear of any item and
drag with the mouse (remember that you must not
pick the item as, in this case, a translation is always
applied regardless of the transformation you selected).

b)  Define the scale factor by moving the Scale slider of
the Modeling Tool panel.

You can constrain scaling along one axis only by enabling one of
the following icons in the Application toolbar:

To scale along the X-axis only (shortcut is the X key).

To scale along the Y-axis only (shortcut is the Y key).

N <€ %

To scale along the Z-axis only (shortcut is the Z key).

To constrain scaling of the selected items along XY, XZ, or YZ
axes, just select two of the above icons at a time. Leave all the
three icons selected if you want uniform scaling on all three axes
so that only the size changes while the shape remains the same

Note. By default, scaling is applied with reference to the origin of
the object’s local axes, but the Reference Axes section of the
Modeling Tool panel allows you to choose among several options.
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Origin

Center
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Options

To define the scale factor (default value is 1).

Views. Click an area of the view that is clear of any item and drag.
Modeling Tool panel. Move the slider or type the scale factor in
the Scale field.

To define the scaling center (origin).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

Barycenter. The scaling center is located in correspondence with
the barycenter.

Center of bounding box. The scaling center is located in
correspondence with the center of the bounding box of the item
(or items).

Axes origin (defaulf). The rotation center is located in
correspondence with the axes origin.

Point. The rotation center is located in correspondence with any
arbitrary point.

To define an arbitrary location (defined by the XYZ coordinates)
of the origin.

Views. Choose the Edit mode. Pick the Center hotSpot and drag
it to the new location.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter].

solidThinking User Manual

141



Section 4

Reference axes

Object

To define the reference coordinate system.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

Local (default). Each picked item is rotated with reference to its
local axes.

Parent. Each picked item is rotated with reference to the
coordinate system of its parent node.

World. Items are rotated with reference to the world (or global)
coordinate system.

Object. Items are rotated according to the axes orientation of a
reference object.

To define the reference object in case you have switched on the
Object option in the Reference Axes section above.

Views / Modeling Tool panel. Switch on the Replace check button
and pick the reference object in the scene. Then, drag it in the
scene.
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Bounding Box Fitting

Scales a given object to fit it into a user-defined box. Scaling
transformation can be non uniform so that the user can define
exact dimensions for each direction (X, Y, Z) of the box.

How fo use

1. Select a single object (the object can be a NURBS curve, a
NURBS surface, a Polymesh or a Pointmesh). If the object
has a Construction Tree, the program displays an alert
message informing the user that a copy of the object will be
created.

2. Click the Bounding Box Fitting icon or choose Tools »
Transform » Scale » Bounding Box Fitting command.

3. You can set dimensions and other parameters of the
bounding box in the Modeling Tool panel. Dimensions can
be modified also by picking and dragging hotSpots in the
interactive views while you are in Edit mode.

Note. Non-uniform scaling transformations do not maintain
geometric properties like tangency and curvature continuity
between adjacent surfaces.
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Options

Origin
To set the bottom left corner of the bounding box.
Views. Choose the Edit mode. Click the Origin point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter|.

Dim
To set the top right corner of the bounding box.
Views. Choose the Edit mode. Click the point whose position you
want to modify and drag it. Release the mouse button when you
reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data fields
and confirm them by pressing [Enter|.

Width

Depth

Height

To set dimensions of the bounding box along X (width), Y
(depth) and Z (height). By default, the program uses world axis
direction. Local axis direction can be set by checking the Local
bounding box option on.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing
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Options

To specify some useful options for the fitting.

Modeling Tool panel. To enable the available options, switch their
check buttons on:

Constrain Proportions. To maintain original proportions while
modifying the bounding box dimensions (the result is uniform
scaling transformation).

Local bounding box. To set local axes as reference coordinate
system.

Custom scaling center. To set a custom center for the scaling
transformation.

solidThinking User Manual

145



Section 4

Xy Z

Inspector

Displays translation, rotation, and scaling values of a single object or a
group with reference to the world coordinates system allowing you to

edit them.

How fo use

1. Select a single object or a group.

2. Click the Inspector icon or choose the Tools »

Transform » Inspector menu command.

146

solidThinking User Manual



Modeling = Transformations

Options

Object

To change the object or the group whose information you want to
be displayed.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve or object in the scene. Displayed values
will be updated according to the new selected object/group.

Translation

To change XYZ translation values with respect to the world
coordinate system.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter|.

Rotation

To change XYZ rotation values with respect to the world
coordinate system.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter|.

Scaling

To change XYZ scaling values with respect to the world
coordinate system.

Modeling Tool panel. Move the slider or type the scale factor in
the Scale field.
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Combine

Combines two or more selected objects into a single one.

Objects to combine must be of the same type.

How fo use

1. Click the Combine icon or choose the Tools »
Transform » Combine menu command.

2. The program console prompts Pick objects to combine.
3. Pick the objects you want to combine in any view.

4. You can pick as many objects as you want. To end objects

selection, press | Spacebar |.

Note: Combining is different from grouping. Combining allows
you to put different entities in the same object. Only entities of the
same type can be merged (curves with curves, surfaces with
surfaces, etc.). Grouping allows you to group different objects
together, so that, you can apply transformations as to a unique
object. Nonetheless, grouped objects are not really unique
objects; in fact groups cannot be used as source objects in an
action (i.e., you cannot trim a group of surfaces, but you can
apply the same action to combined objects). Objects of different
types can be grouped.
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Options

Remove

To remove a component from the combine object.
Modeling Tool panel. Choose the component of the merge object
you want to remove from the list. Press the Remove button.

Insert

To add a new component to the combined object.

Views / Modeling Tool panel. Switch the Insert check button on
and pick the new object you want to include in the combined
object.
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Multi combine

Combines objects of different types. For each object type, a single
object containing all the selected objects of the same type is
created, i.e. a curve object for all the curves, a surface object for

all the surfaces, etc.

How fo use

1. Select all the objects you want to combine.

2. Click the Multi combine icon or choose the Tools »
Transform » Combine » Multi combine menu command.

3. See the result of this action in the World Browser.
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Mirror

Mirrors curves and surfaces in a 3D scene.

How fo use

Click the Mirror icon or choose the Tools » Transform »
Mirror menu command.

While the views display the mirror plane, the program
console prompts Pick objects to mirror.

Pick the items you want to be mirrored. Press the

to end items picking.

At the Start of mirror plane console prompt, click to specify
the location.

At the End of mirror plane console prompt, click to define
the direction of the mirror plane. The items to be mirrored
will be replicated across the plane from the start point to
this end point. Press the key to snap to the closest

axis.

After completing the mirror operation you can still adjust the
position and orientation of the mirror plane using one of the
following methods:

a)

In the Edit mode, click the Start of Mirror Plane hotSpot
and interactively define the distance of the mirrored copy
from the selected item and its orientation. If you do not
want to modify the distance, but only the orientation, just
click and drag on either the End of Mirror Plane hotSpot, or
the Normal End Point hotSpot.
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b)  Use the Mirror Along option in the Mirror tool panel to
specify the axis (X, Y, or Z) or the direction (Vertical or
Horizontal) along which the mirroring will be performed.

Note. When using the Mirror Along option in the tool panel, by
default the Start of Mirror Plane coincides with the origin of the
selected item’s local axes.
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Options

Remove

Insert

To remove one or more mirrored items obtained with the same
mirror action.

Views / Modeling Tool panel. Select the mirrored item by either
picking it with the mouse or through the browser. Choose the item
you want to remove from the list displayed in the Object section
of the Modeling Tool panel. Press the Remove button.

To add new items after a mirror action has been performed.
Views / Modeling Tool panel. Switch the Insert check button on

and pick the items you want to mirror. Press to end.

Mirror along

To modify the mirror axis and, consequently, the orientation of
the mirror plane.

Views. Select the Edit mode. Click the Start of mirror plane
hotSpot and interactively define the distance from the selected
item and the orientation. If you do not want to modify the distance
but only the orientation, just click and drag the Normal End Point
hotSpot.

Modeling Tool panel. Switch the chosen radio button on. You can
specify the axis (X, Y, Z) or the direction (H for horizontal, V for
vertical) along which the mirroring will be performed. V and H are
referred to the active view.
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Start of Mirror Plane
End of Mirror Plane

Normal End Point

To specify the XYZ coordinates of the mirror plane start and end
points and normal direction, allowing you to determine a custom
vector that defines position and orientation of the mirror plane.

Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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Replicate

Replicates any curve or object along a path or over a surface or on
vertices of a polymesh.

How fo use

Click the Replicate icon or choose the Tools »
Transform » Replicators » Replicate menu command.

The program console prompts Pick object to replicate.

Pick the object you want to replicate in any view. Once
picked, the object becomes green.

The program console prompts Select replication
path/surface.

Pick in any view the replication path, surface, or polymesh.
If you select a path, you control replication along the U
direction only. If you select a surface you control replication
along both U and V directions. If you select a polymesh
object the replicated objects are positioned on vertices of
the polygonal model and U and V parameters are not used.
By default, the selected object is replicated three times but
the Modeling Tool panel allows you to modify the number
of copies as well as numerous other options.
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Object

Path

Options

To change the object to replicate.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve or object in the scene. The new object will
be replicated instead of the previous one.

To change the replication path/surface.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another replication path or surface in the scene.
Replication of the object will be accordingly modified.

Hide source objects

To hide or display source objects (original object to replicate and
replication path/surface).

Modeling Tool panel.If you switch the Hide source objects radio
button on, source objects (the object to replicate and the
replication path/surface) will be hidden but not deleted. In fact,
you can find them in the Hierarchy Browser hidden from both
rendering and views.

Replication method

To specify the replication method. In case of replication over a
polymesh this option is disabled.

Modeling Tool panel. Switch the chosen radio button on:

Copies, if you want to precisely set the number of copies that
must be replicated.

Step, if you prefer to set a constant distance between each
replicated object. In this case the number of copies will depend on
the step you define.
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Copies along U
Copies along V

If you have chosen the Copies replication method, this option
allows you to o change the number of copies to be replicated
along U and/or V directions (V direction is enabled only if you
use a replication surface).

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Step along U
Step along V

If you have chosen the Step replication method, this option allows
you to change the distance between each replicated object along
U and/or V directions (V direction is enabled only if you use a
replication surface).

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Objects transformation

To specify how rotation and scaling transformations will be
applied to the replicated object.

Modeling Tool panel. Switch one of the following radio buttons
on:

Step by step if you want rotation and/or scaling values to be
applied toeach replicated object with respect to the previous one.
Linear if you prefer for rotation and/or scaling values to be
applied to the last replicated object with respect to the first one
(rotation and/or scaling values of intermediate objects will be
automatically interpolated).

Constant when the same rotation and/or scaling values must be
applied to any replicated object.
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Rotation

To set the rotation angle on the X, Y, and Z axes.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [ Enter].

Scaling

To set the scaling factor on the X, Y, and Z axes.
Modeling Tool panel. Type factor values in the XYZ data fields

and confirm them by pressing [ Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Noise seed

This parameter affects the sequence of random numbers that
determine the noise.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Options

To specify how the curve or object will be aligned with respect to
the replication path/surface.

Views. Choose the Edit mode. Click the Origin, X axis, Y axis or
Z axis hotSpots and interactively define the orientation by dragging
them.

Modeling Tool panel. Switch one of the following radio buttons on:
No alignment. No alignment will be applied.

Frenet frame alignment. Replicated objects are oriented along
curve normal if the path is a curve, along surface normal if the path is
a surface and along vertices normal if the path is a polymesh.
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Dir. preserving alignment. To align the curve or object axes to
the replication object normal without any twisting.

Reset axes

To restore the orientation axes to their original position.
Modeling Tool panel. Press the Reset axes button.

Starting point
V Starting point

To set the replication starting point on the path or over the surface.
V starting point is active only in the second case (in this case
Starting point means U Starting point).

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing Enter.
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End point
V End point

To set the replication end point on the path or over the surface. V
end point is active only in the second case (in this case End point
means U End point).

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing Enter.
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! Step copy

Creates a user-defined number of copies in 3D space applying
incremental transformations, i.e. each transformation is applied to
each replicated object with respect to the previous one.

This modeling tool is a modifier, not an action; therefore it does
not feature a construction tree.

How fo use

1.  Select one or more objects or groups.

2. Click the Step copy icon or choose the Tools » Transform »
Replicate » Step copy menu command.

3. In the Modeling Tool panel set the number of copies by
either typing a value in the Copies data field or moving the
slider.

4. In case, set translation, rotation, and scale on the X, Y, and
Z axes as well as noise effects.

5. Press the Go button to perform the operation. Each time you
press the Go button you add new copies to the scene.
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Options

Copies

To specify the number of copies.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Translation

To set XYZ translation values with respect to the world
coordinate system.

Modeling Tool panel. Type translation values in the XYZ data
fields and confirm them by pressing [Enter].

Rotation

To set XYZ rotation values with respect to the world coordinate
system.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [Enter|.

Scaling

To set XYZ scaling values with respect to the world coordinate
system.

Modeling Tool panel. Type scaling factor values in the XYZ data
fields and confirm them by pressing [ Enter].
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Translation noise

To apply a random effect on translation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].
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DynaStep

Creates a user-defined number of copies in 3D space applying
incremental transformations, i.e. each transformation is applied to
each replicated object with respect to the previous one. It is similar
to Step Copy command but it features a Construction Tree.

How fo use

1. Click the DynaStep icon or choose the Tools »
Transform » Replicate » DynaStep menu command.

2. The program console prompts Pick an Object..
3. Pick the object you want to replicate. The Modeling Tool

panel allows you to adjust dynamically various parameters
such as the number of copies.

The following examples show how the use of DynaStep simplifies
common replication tasks. The original object is first replicated 3
times with a translation along Z.
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Now the object is replicated 10 times with a vertical translation
and a rotation around Z axis.

To change the predefined position and orientation of replicated
objects switch to Edit mode and edit direction axes that are, in the
beginning, coincident to the original object local axes. The
direction changes of the replicated objects reflect relative changes
of these axes from original object axes.

Working in the interactive views, it is also possible to control the
total translation of the sequence of replicate objects by picking and
dragging the Direction hot-spot.
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Options

Object

To change the object to replicate.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

Copies

To specify the number of copies.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Translation

To set XYZ translation values with respect to the world
coordinate system.

Modeling Tool panel. Type translation values in the XYZ data
fields and confirm them by pressing [Enter].

Rotation

To set XYZ rotation values with respect to the world coordinate
system.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [Enter].

Scaling

To set XYZ scaling values with respect to the world coordinate
system.

Modeling Tool panel. Type scaling factor values in the XYZ data
fields and confirm them by pressing [Enter].
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Translation noise

To apply a random effect on translation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Noise seed

This parameter affects the sequence of random numbers that
determine the noise.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Reset axes

Set direction axes to be coincident to the original object local axes.
Modeling Tool panel. Just click the Reset axes button.
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i Matrix copy

Creates a user-defined number of copies along XYZ to make a
box-like array.

This modeling tool is a modifier, not an action; therefore it does
not feature a construction tree.

How fo use

1. Select one or more objects or groups.

2. Click the Matrix copy icon or choose the Tools »
Transform » Replicate » Matrix copy menu command.

3. In the Modeling Tool panel, specify the number of copies
that must be replicated by typing XYZ values in the Copies
data fields and the XYZ constant distances between each
replicated object in the Step data fields.

4. In case, set rotation and scale on the X, Y, and Z axes as
well as noise effects.

5. Press the Go button to perform the operation. Each time you
press the Go button you add new copies to the scene.
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Copies

Step

Options

To specify the number of copies along X, Y, and Z.
Modeling Tool panel. Type the XYZ values in the data fields and

press [Enter .

To specify the constant distance between each replicated object.
Modeling Tool panel. Type the XYZ values in the data fields and

press [Enter .

Step by step

Linear

Constant

To specify how rotation and scaling transformations will be
applied to the replicated object.

Modeling Tool panel. Switch one of the following radio buttons
on:

Step by step if you want rotation and/or scaling values to be
applied toeach replicated object with respect to the previous one.
Linear if you prefer for rotation and/or scaling values to be
applied to the last replicated object with respect to the first one
(rotation and/or scaling values of intermediate objects will be
automatically interpolated).

Constant when the same rotation and/or scaling values must be
applied to any replicated object.
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Rotation

To set the rotation angle on the X, Y, and Z axes.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [ Enter].

Scaling

To set the scaling factor on the X, Y, and Z axes.
Modeling Tool panel. Type factor values in the XYZ data fields

and confirm them by pressing [ Enter].

Translation noise

To apply a random effect on translation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter|.
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DynaMatrix

Creates a user-defined number of copies along XYZ to make a
box-like array. It is similar to Matrix Copy command but it
features a Construction Tree.

How fo use

1. Click the DynaMatrix icon or choose the Tools »
Transform » Replicate » DynaMatrix menu command.

2. The program console prompts Pick an Object.
3. Pick the object you want to replicate. The Modeling Tool
panel allows you to adjust dynamically various parameters

such as the number of copies.

The following examples show you how the use of DynaMatrix
simplifies common replication tasks.

The original object is first replicated 3x3x3 times.
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To change the predefined position and orientation of replicated
objects switch to Edit mode and edit direction axes; in the
beginning they are coincident to the original object local axes. The
direction changes of the replicated objects reflect relative changes
of these axes from original object axes.

Working in the interactive views, it is also possible to control the
total length of replication along X, Y and Z (i.e. the dimension of
replication box) by picking and dragging the Direction hot-spot.

solidThinking User Manual

173



Section 4

Object

Copies

Step

Options

To change the object to replicate.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

To specify the number of copies along X, Y, and Z.
Modeling Tool panel. Type the XYZ values in the data fields and

press [Enter],

To specify the constant distance between each replicated object.
Modeling Tool panel. Type the XYZ values in the data fields and

press [Enter].

Step by step

Linear

Constant

To specify how rotation and scaling transformations will be
applied to the replicated object.

Modeling Tool panel. Switch one of the following radio buttons on:
Step by step if you want rotation and/or scaling values to be
applied toeach replicated object with respect to the previous one.
Linear if you prefer for rotation and/or scaling values to be
applied to the last replicated object with respect to the first one
(rotation and/or scaling values of intermediate objects will be
automatically interpolated).
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Constant when the same rotation and/or scaling values must be
applied to any replicated object.

Rotation

To set the rotation angle on the X, Y, and Z axes.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [ Enter].

Scaling

To set the scaling factor on the X, Y, and Z axes.
Modeling Tool panel. Type factor values in the XYZ data fields

and confirm them by pressing [ Enter].

Translation noise

To apply a random effect on translation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].
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Noise seed

This parameter affects the sequence of random numbers that
determine the noise.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Reset axes

Set direction axes to be coincident to the original object local axes.
Modeling Tool panel. Just click the Reset axes button.
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CI Polar copy

Creates a user-defined number of copies along a circular path of
a given radius. Useful for spiral stairs.

This modeling tool is a modifier, not an action; therefore it does
not feature a construction tree.

How fo use

1. Click the Polar copy icon or choose the Tools » Transform »
Replicate » Polar copy menu command.

2. The program console prompts Pick object to copy.

3. Pick the object you want to copy in any view. Once picked,
the object is copied 3 times along a default circle.

4. The program console prompts Copies.

5. Type the number of copies in the console and press [Enter |-

6. The program console prompts Radius.

7. Type the circular path radius value in the console and press
or pick and drag the radius hot-spot (blue circle) in any

interactive view to visually define its value.

8. Find more options in the Modeling Tool panel.
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In the picture below, the original object is replicated 10 times with
a path radius of 5.

To change the predefined position and orientation of replicated
objects, switch to Edit mode and edit direction axes which are, in
the beginning, coincident to the original object local axes.

The direction changes of the replicated objects reflect relative
changes of these axes from original object axes.

Working in the interactive views you can also orient the plane on
which the replicated objects lie by picking and dragging the
Direction hot-spot.

178

solidThinking User Manual



Modeling = Transformations

Options

Object

To change the object to copy.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene. The new object will be
copied instead of the previous one.

Copies

To specify the number of copies along the circular path.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Linear step

To specify the constant distance between each copy.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Angular step

To specify the angle between each copy.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Radius

To change the radius of the circular path.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Start Angle

To change sweep of the arc.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter |. The value can
range from 0 to 360 degrees.

End Angle

To change sweep of the arc.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to 360 degrees.

Transformation

To specify how transformations will be applied to the replicated object.
Modeling Tool panel. Switch one of the following radio buttons on:
Step by step if you want translation, rotation and/or scaling
values to be applied to each replicated object with respect to the
previous one.

Linear if you prefer for rotation and/or scaling values to be
applied to the last replicated object with respect to the first one
(rotation and/or scaling values of intermediate objects will be
automatically interpolated).

Constant when the same rotation and/or scaling values must be
applied to any replicated object.

Translation

To set the translation values on the X, Y, and Z axes.
Modeling Tool panel. Type translation values in the XYZ data
fields and confirm them by pressing [ Enter].
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Rotation

To set the rotation angle on the X, Y, and Z axes.
Modeling Tool panel. Type rotation values in the XYZ data fields

and confirm them by pressing [ Enter].

Scaling

To set the scaling factor on the X, Y, and Z axes.
Modeling Tool panel. Type factor values in the XYZ data fields

and confirm them by pressing [ Enter].

Translation noise

To apply a random effect on translation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random effect on rotation.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter|.
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Noise seed

This parameter affects the sequence of random numbers that
determine the noise.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing .

Axis direction

To set the axis direction of the polar replication (i.e. the direction
of the normal to the plane on which the replicated object lies).
Views. Pick the Axis hotSpot to orient the replication plane.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter].

Default direction

To set one of the predefined orientation of the replication plane.
Modeling Tool panel. Switch one of the following radio buttons
on:

X/Y/Z if you want that replicated objects lie respectively on the
YZ, XZ or XY world planes (Axis direction parallel to X, Y or Z
world axis).

Horizontal/Vertical if you prefer that Axis direction will result
horizontal or vertical in the active view.

Custom if you want that Axis direction assumes non-standard
values that can be set interactively by working in the views or
numerically by modifying the Axis direction option.
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Axes Align to NURBS surface

Orients an object so that its local axes are tangent to a reference
NURBS surface at a specified point.

How fo use

1. Select the object you want to align.

2. Click the Axes Align to NURBS surface icon or choose the
Tools » Transform » Axes Align » Axes Align to NURBS
surface menu command.

3. The program console prompts Pick Reference surface at
tangency point.

4.  Pick the point of the NURBS surface to which the axes of
the original object will be aligned.
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Options

Reference object

To change the reference object.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

To specify the position along the surface U direction of the
tangency point.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter | Value must be
between 0 and 1.

To specify the position along the surface V direction of the
tangency point.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter | Value must be
between 0 and 1.

Position

To specify whether the object axes origin must be coincident to
the tangency point of the reference NURBS surface.
Modeling Tool panel. Switch the Position radio button on.

Orientation

To specify whether the object axes origin must be tangent to a
reference NURBS surface at a specified point.
Modeling Tool panel. Switch the Orientation radio button on.
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i% Axes Align to object

Orients an object so that its local axes are coincident to the local
axes of a reference object.

How fo use

1. Select the object you want to align.

2. Click the Axes Align to object icon or choose the
Tools » Transform » Axes Align » Axes Align to object
menu command.

3. The program console prompts Pick Reference object.

4.  Pick the reference object to which the axes of the original
object must be aligned.
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Options

Reference object

To change the reference object.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

Position

To specify whether the object axes origin must be coincident to
the reference object axes.
Modeling Tool panel. Switch the Position radio button on.

Orientation

To specify whether the object axes must be oriented in the same
way as the reference object axes.
Modeling Tool panel. Switch the Orientation radio button on.
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g b Axes Align to 3 points

Orients an object so that its XY local axes lie on a plane specified
by three points. The three points define the origin of the plane and
the plane local axes, i.e. X and Y axes.

How fo use

Select the object or objects you want to align.

Click the Axes Align to 3 points icon or choose the
Tools » Transform » Axes Align » Axes Align to 3 points
menu command.

The program console prompts Origin.

Locate axes origin of the plane following one of the two

methods:

a) Click and drag in any view and release the mouse
button to confirm placement;

b)  Input the XYZ coordinates in the console and press
to confirm. If you press without typing any
value, the axes origin of the plane will be placed in
correspondence of the XYZ origin.

The program console prompts X axis point.

Define the orientation of the X axis following one of the

two methods:

a) Click and drag in any view and release the mouse
button to confirm placement;
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b)  Input the XYZ coordinates in the console and press
to confirm. If you press without typing any
value, the point that specifies the X coordinate of the
plane will be placed in correspondence of the XYZ
origin.

The program console prompts Y axis point.

Define the orientation of the Y axis following one of the

two methods:

a) Click and drag in any view and release the mouse
button to confirm placement;

b)  Input the XYZ coordinates in the console and press
to confirm. If you press without typing any
value, the point that specifies the Y coordinate of the
plane will be placed in correspondence of the XYZ
origin.
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Options

Origin
To modify the point that specifies the coordinates of the plane
origin.
Views. Choose the Edit mode. Click the Origin hotspot and drag

it. Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [ Enter].

Position

To specify whether the object axes origin must be coincident to
the axes plane or not.
Modeling Tool panel. Switch the Position radio button on.

Orientation

To specify whether the object axes must be oriented in the same
way as the plane axes.
Modeling Tool panel. Switch the Orientation radio button on.
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- Align to Global Axes

Align a selection of objects of any type on XY, XZ or YZ world
planes or along X, Y or Z axes.

How fo use

1. Select the objects you want to align. Make sure that all
objects are not a part of a Construction Tree.

2. Click the Align to Global Axes icon (in the Transform tab)
or choose the Tools » Transform » Align to Global Axes
menu command.

3. Set the parameters of the modeling tool to obtain the
desired result. In particular, check the buttons relative to the
desired alignment planes in the Alignment Planes section.

4. Press the Go button in the modeling tool panel to apply the
alignment.
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Figures above show the alignment of various objects in the
XY and YZ planes. The alignment planes position depends
from the first selected object. Lights can be aligned ike any
other objects.

Note I: Selected objects must not be part of a Construction Tree. If

you want to align such objects you must perform a Collapse
Construction tree command on them.

Note II: Random transformations to the aligned objects are
applied in the following order: scaling, rotation, translation.
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Go

Options

To perform the alignment with given parameters.
Modeling Tool panel. Press the Go button.

Alignment Planes

To define the alignment planes or axes.

Modeling Tool panel. Options can be enabled by switching the
chosen radio button on. Alignment planes can be parallel to the
XY, XZ or YZ world planes passing through the pivot point of the
first selected object. Alignment axes can be parallel to the X, Y or
Z. world axes. The option Axes origin centers all objects in the
same point.

Alignment Options

To set a default point of the object that will be considered the
pivot point for the alignment.

Modeling Tool panel. Switch the chosen radio buttons on. Options
are: Axis Origin, Bounding box and Center of bounding box. If
you choose Bounding box, the Justification section offers more
options.

Justification

To specify whether the objects should be aligned to the top
(B. box max) or to the bottom (B. box min) of the bounding box.
Modeling Tool panel. This parameter is active only if the B. box
radio button in the Alignment Options parameter has been
checked.

192

solidThinking User Manual



Modeling = Transformations

Translation noise

To apply a random effect on translation of each aligned object.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random rotation around the local axis of each aligned
object compared to the default resulting position.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [ Enter].

Scaling noise

To apply a random effect on scaling for each aligned object.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].
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Align to Curve

Align and eventually space a selection of objects of any type along
a NURBS curve.

How fo use

1. Select the objects you want to align. Make sure that all
objects are not a part of a Construction Tree.

2. Click the Align to Curve icon (in the Transform tab) or
choose the Tools » Transform » Align to Curve

command.

3. Pick the NURBS curve along which to align the selected
objects.

4. Set the parameters of the modeling tool to obtain the
desired result.

5. Press the Go button in the modeling tool panel.
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Figures above show the alignment of various objects along a
NURBS curve. Note that also lights can be aligned.

Note I: Selected objects must not be part of a Construction Tree. If

you want to align such objects you must perform a Collapse
Construction tree command on them.

Note II: Random transformations to the aligned objects are
applied in the following order: scaling, rotation, translation.
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Options

Go

To perform the alignment with given parameters.
Modeling Tool panel. Press the Go button.

Alignment Curve

To change the alignment curve.
Modeling Tool panel. Switch the Replace check button on and
pick another NURBS curve in the scene.

Alignment Options

To set a default point of the object that will be considered the
pivot point for the alignment.

Modeling Tool panel. Switch the chosen radio buttons on. Options
are: Axis Origin, Bounding box and Center of bounding box. If
you choose Bounding box, the Justification section offers more
options.

Justification

To specify whether the objects should be aligned to the top
(B. box max) or to the bottom (B. box min) of the bounding box.
Modeling Tool panel. This parameter is active only if the B. box
radio button in the Alignment Options parameter has been
checked.

196 solidThinking User Manual



Modeling = Transformations

Direction

To specify how the aligned objects will be oriented with respect
to the alignment curve.

Modeling Tool panel. Switch the chosen radio buttons on. Options
are:

Original. No changes on object orientation are made. Objects will
be only translated.

Align to Normal. The local Z axis will be aligned to the curve
normal.

Align to Tangent. The local Z axis will be aligned to the curve
tangent.

Align to Binormal. The local Z axis will be aligned to the curve
binormal (i.e. the direction perpendicular to the plane defined by
the tangent and the normal to the curve).

Spacing

Step

To specify positioning of the objects along the curve.

Modeling Tool panel. Switch the chosen radio buttons on. Options
are:

No spacing. Eeach object is projected to the nearest point on the
curve (with respect to its original position).

Fit to curve. Objects will be evenly spaced along the curve so
that the first selected object is positioned at the start of the curve
and the last selected object is positioned at the end.

Custom. Objects will be spaced at a constant distance (defined by
the Step option) from the start of the curve.

To set the distance along the curve between two consecutive
objects.This option is enabled only if the Cusfom spacing option
is enabled.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter|.
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Translation noise

To apply a random effect on translation of each aligned object.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Rotation noise

To apply a random rotation around the local axis of each aligned
object compared to the default resulting position.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].

Scaling noise

To apply a random effect on scaling for each aligned object.
Modeling Tool panel. Type values in the XYZ data fields and

confirm them by pressing [Enter].
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. Advanced Curve Edit

Performs a powerful editing of any NURBS curve.
User can specify position, tangent direction and curvature radius at

any point of a curve both interactively and by numeric input.
These values can be set at any point of a given reference curve.

How fo use

1. Click the Advanced Curve Edit icon or choose the
Tools » Transform » Advanced Curve Edit command.

2. Pick a point on the curve you want to edit and drag it to the
desidered position. When in edit mode, the tool shows
position, tangent direction and the second order derivative
direction of the curve at the specified point.
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3. Pick and drag the Position, Tangent or Curvature hot-
Spots to interactively change the local shape of the curve.

4. To change the point of the curve to edit click near (not on)
the Position hotSpot and drag it in the desired new point.

Note I: The length of the tangent direction vector is proportional
to the curvature radius.

Note II: The curvature vector is, from a mathematical point of
view, the second order derivative of the curve in the specified
point. The length of this vector influences the curvature radius, its
direction defines the changes of curvature radius locally.

Note III: To reduce the influence area of this tool, add control
points to the curve near the point to be edited.
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Options

Object

To change the reference object.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Parameter

To set the parametric point (in the range [0...1]) of the curve to
edit.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter | Value must be
between 0 and 1.

Point
To set the new position of the specified point on the curve with
respect to the local coordinate system..
Modeling Tool panel. Type the new values in the XYZ data fields
and confirm them by pressing [ Enter].

Tangent

To set the new tangent direction and magnitude of the curve at the
specified point. Note that modifications of the tangent magnitude
(Iength) influence also the curvature radius.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [Enter|.

Curvature Radius

To set the curvature radius at the specified point.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Constraint to Object

To set position, tangent direction and/or curvature of the selected
curve at the specified point equal to those of a reference curve at a
reference point.

Modeling Tool panel. Switch the chosen radio buttons on. Options
are: Position. Tangent. Curvature.

Reference Object

To specify the curve to which refer for position, tangency and
curvature radius settings.

Views / Modeling Tool panel. Switch the Replace check button
on, pick a curve in the scene and, holding down the mouse button,
position the reference point on the picked curve.

Reference Point

To specify the point of the reference curve. The point will be
projected on the reference curve.

Views / Modeling Tool panel. Type the new values in the XYZ
data fields and confirm them by pressing [Enter|.

Reference Parameter

To set the parameter of the reference curve.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ] Value must be

between 0 and 1.
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Multi Edit

The MultiEdit Modeling Tool allows to work on the points of
collapsed NURBS curves, surfaces, PolyMeshes and PointMeshes
(points clouds). It is possible to translate, rotate and scale points of
more than one object at the same time.

How fo use

1. Select the objects you want to edit.

2. The Multi edit Modeling Tool should automatically
activate. Eventually, click the Multi edit icon or choose the
Tools » Transform » Multi Edit menu command.

3. Choose the Edit mode and drag the control points you want
to edit.

Note: You should be in Edit mode to actually drag the points.
Press to activate Edit mode. This Modeling Tool is

automatically activated if two to ten objects are selected. In all
other cases it is required to manually activate the Multi edit tool.
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|

Twist

Twists a curve or object along a user-defined axis.

How fo use

1. Click the Twist icon or choose the Tools»
Transform » Deformation » Twist menu command.

2. The program console prompts Select an object.

3. Pick the object you want to twist from any view. A twisted
copy of the object is created. The original object is hidden
but not deleted. In fact, you will find it in Hierarchy
Browser hidden from both rendering and views.

4. The program console prompts Twist angle.
5. Type the number of degrees to twist the object. The

Modeling Tool panel allows you to define the temporary
axis along which the object is twisted.

You can press | Ctrl| + | Enter | ((Apple | + | Enter | on the Mac) to skip
the console prompts, thus accepting the default values.
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Options

Object

To change the object to be twisted.
Views / Modeling Tool panel. Switch on the Replace check button
and pick another curve or object in the scene.

Default twist axis

To define the temporary axis along which the object is twisted.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Twists along the X-axis.

Y. Twists along the Y-axis.

Z.. Twists along the Z-axis.

Vertical. Twists vertically.

Horizontal. Twists horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points
therefore allowing you to determine a custom vector that defines
position and orientation of the twist axis.

Views. Choose the Edit mode. Click the Axis Start Point or Axis
End Point hotSpots of the axis and interactively define its
orientation by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and
confirm them by pressing [Enter].

Twist angle

To define the twist angle
Modeling Tool panel. Move the slider or type the number of
degrees in the field.
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Q

Taper

Widens or narrows one side of an object by tapering it.

How fo use

1. Click the Taper icon or choose the Tools)»
Transform » Deformation » Taper menu command.

2. The program console prompts Select an object.

3. Pick the object to which you want to apply the taper action
from any view. A twisted copy of the object is created. The
original object is hidden but not deleted. In fact, you will
find it in Hierarchy Browser hidden from both rendering
and views.

4. The program console prompts Scale factor along X.

5. Type the value of the scale factor along X in the console
(default is 2).

6.  The program console prompts Scale factor along Y.

7. Type the value of the scale factor along Y in the console
(default is 2).

You can press | Ctrl| + | Enter | ((Apple | + | Enter | on the Mac) to skip
the console prompts, so accepting the default values.
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Options

Object

To change the object you want to taper.
Views / Modeling Tool panel. Switch on the Replace check button
and pick another curve or object in the scene.

Default taper axis

To define the temporary axis along which the object is tapered.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Tapers along the X-axis.

Y. Tapers along the Y-axis.

Z.. Tapers along the Z-axis.

Vertical. Tapers vertically.

Horizontal. Tapers horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points,
hence allowing you to determine a custom vector defining
position and orientation of the taper axis.

Views. Choose the Edit mode. Click the Axis Start Point or the
Axis End Point and interactively define the orientation by
dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and
confirm them by pressing [ Enter].
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Taper along X

To define the scale factor along X
Modeling Tool panel. Move the slider or type the factor value in
the field.

Taper along Y

To define the scale factor along X
Modeling Tool panel. Move the slider or type the factor value in
the field.

Taper X dir.

To define the taper X direction.

Views. Choose the Edit mode. Click the Taper X dir. hotSpot and
interactively define its orientation by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [ Enter].
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Warp

Warps all points of a curve or object comprised in a user-defined
distance and according to a user-defined axis.

How fo use

6.

7.

Click the Warp icon or choose the Tools » Transform »
Deformation » Warp menu command.

The program console prompts Select an object.

Pick the object you want to warp from any view. A warped
copy of the object is created. The original object is hidden
but not deleted. In fact, you will find it in Hierarchy
Browser hidden from both rendering and views.

The program console prompts Warp distance.

At this point you can define the Warp distance using one of

the following methods:

a)  Click the Warp distance point hotSpot in any view
and interactively adjust it. Working in the same way
you can define the Warp axis by adjusting the Axis
start point and Axis end point hotSpots.

b)  Specify in the console the Warp distance value. Press

to confirm.

The program console prompts Warp angle.

Type the Warp angle in the console. Press to confirm.

You can press | Ctrl| + | Enter | ((Apple | + | Enter | on the Mac) to skip
the console prompts, so accepting the default values.
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Options

Object

To change the object you want to warp.
Views / Modeling Tool panel. Switch on the Replace check button
and pick another curve or object in the scene.

Default warp axis

To define the temporary axis respect to which the object is bent.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Bends respect to the X-axis.

Y. Bends respect to the Y-axis.

Z.. Bends respect to the Z-axis.

Vertical. Bends vertically.

Horizontal. Bends horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points thus
allowing you to determine a custom vector that defines position
and orientation of the warp axis.

Views. Choose the Edit mode. Click the Axis Start Point or the
Axis End Point of the axis and interactively define its orientation
by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and
confirm them by pressing [ Enter].
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Warp distance
To define the warp distance. Points included within this value will

be affected by the warp deformation.
Modeling Tool panel. Move the slider or type the number of

degrees in the field.

Warp angle

To define the warp angle.
Modeling Tool panel. Move the slider or type the number of

degrees in the field.
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i Shear

Shears a curve or object with respect to a user-defined axis.

How fo use

Click the Shear icon or choose the Tools » Transform p
Deformation » Shear menu command.

1.  The program console prompts Select an object.

2. Pick the object you want to shear from any view. A sheared
copy of the object is created. The original object is hidden
but not deleted. In fact, you will find it in Hierarchy
Browser hidden from both rendering and views.

3. The program console prompts Shear direction.

4. At this point you can define the Shear direction using one of

the following methods:

a)  Click the Shear direction hotSpot in any view and
interactively adjust it. Likewise, you can define the
Shear axis by adjusting the Axis start point and Axis
end point hotSpots.

b)  Specify in the console X, Y, and Z coordinates
defining the shear direction. Press to confirm.

You can press [ Ctrl| + Enter | ((Apple]+ [Enter] on the Mac) to skip
the console prompts, so accepting the default values.
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Options

Object

To change the object you want to shear.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve or object in the scene.

Default shear axis

To define the temporary axis according to which the object is
sheared.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Shears according to the X-axis.

Y. Shears according to the Y-axis.

Z.. Shears according to the Z-axis.

Vertical. Shears vertically.

Horizontal. Shears horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points so
allowing you to determine a custom vector that defines position
and orientation of the shear axis.

Views. Choose the Edit mode. Click the Axis Start Point or the
Axis End Point of the axis and interactively define its orientation
by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and
confirm them by pressing [ Enter].
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Shear direction

To define the shear direction.

Views. Select the Edit mode. Click the Shear direction hotSpot
and interactively define its orientation by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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‘) Bend

Bends a curve or object with respect to a user-defined axis.

How fo use

1. Click the Bend icon or choose the Tools » Transform »
Deformation » Bend menu command.

2. The program console prompts Select an object.

3. Pick the object you want to bend from any view. A bent
copy of the object is created. The original object is hidden
but not deleted. In fact, you will find it in Hierarchy
Browser hidden from both rendering and views.

4. The program console prompts Bend reference point.

5. At this point you can define the Bend reference point
position using one of the following methods:

a)  Click the Bend reference point hotSpot in any view
and interactively adjust it. Similarly, you can define
the Bend axis by adjusting the Axis start point and
Axis end point hotSpots.

b)  Specify in the console X, Y, and Z coordinates of the
bend reference point. Press to confirm.

You can press | Ctrl | + | Enter] (|Apple ] + | Enter| on the Mac) to skip
the console prompts, so accepting the default values.
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Options

Object

To change the object you want to bend.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve or object in the scene.

Default bend axis

To define the temporary axis in relation to which the object is
bent.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X. Bends with respect to the X-axis.

Y. Bends with respect to the Y-axis.

Z.. Bends with respect to the Z-axis.

Vertical. Bends vertically.

Horizontal. Bends horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points thus
allowing you to determine a custom vector defining position and
orientation of the bend axis.

Views. Choose the Edit mode. Click the Axis Start Point or the
Axis End Point and interactively define its orientation by dragging
it.

Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [ Enter].
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Bend reference point

To define position of the bend reference point.

Views. Choose the Edit mode. Click the Bend reference point
hotSpot and interactively define its orientation by dragging it.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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Lattice

Lets you apply a free deformation to an object.
This deformation is applied with the help of a lattice defining a

parallelepipedal space volume that can be freely deformed
working on a user-defined number of control points.

How fo use

Click the Lattice icon or choose the Tools » Transform »
Deformation » Lattice menu command.

The program console prompts Pick object to deform.

Pick the object you want to freely deform. A copy of the
object is created. The original object is hidden but not
deleted. In fact, you will find it in Hierarchy Browser
hidden from both rendering and views.

Choose the Edit mode.
A lattice is displayed around the selected object. At this

point you can pick any point defining the lattice and drag it
to deform the original object.

Note: Before applying the lattice deformation to an object, you
should remember that the object capability of being deformed
depends on how the control points are distributed over its surface.
The more the control points of the object, the more the control
over shape and the precision of the deformation.
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Options

Object

To change the object you want to freely deform.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve or object in the scene.

Control points

To modify XYZ coordinates of lattice control points.

Views. Choose the Edit mode. Click the point/points whose
position you want to modify and drag it/them. Release the mouse
button when you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in
the XYZ data fields and confirm them by pressing [Enter].

Origin
To modify XYZ coordinates of lattice origin.
Views. Choose the Edit mode. Click and drag the Origin hotSpot.

Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing [ Enter].
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Orientation

Width

To define XYZ rotation values of the lattice axes as regards to the
world coordinate system.

Views. Pick the )X, Y, and Z hotSpots and drag.

Modeling Tool panel. Input X, Y, and Z rotation angles (in
degrees) in their respective fields.

To define the width of the lattice.

Views. Choose the Edit mode. Click the X dim. hotSpot that is
displayed at the end of the X axis and drag it. Release the mouse
button when you reach the desired dimension.

Modeling Tool panel. Move the slider or type the numerical value
in the field.

Thickness

To define the thickness of the lattice.

Views. Choose the Edit mode. Click the Y dim. hotSpot that is
displayed at the end of the Y axis and drag it. Release the mouse
button when you reach the desired dimension.

Modeling Tool panel. Move the slider or type the numerical value
in the field.
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Height

To define the height of the lattice.

Views. Choose the Edit mode. Click the Z dim. hotSpot that is
displayed at the end of the Z axis and drag it. Release the mouse
button when you reach the desired dimension.

Modeling Tool panel. Move the slider or type the numerical value
in the field.

Points along X
Points along Y
Points along Z

To define the number of control points of the lattice along X, Y,
or Z.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Order along X
Order along Y
Order along Z

To change the lattice order along X, Y, or Z.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing | Enter ] The order values
should never be higher than the number of control points.
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Link lattice to object

To define whether the lattice must be linked or not to the object so
that the lattice will follow the object when you move it.
Modeling Tool panel. Switch the Link lattice to object option.

Show lattice in Object mode

To specify whether the lattice must appear also in Object mode or
only in Edit mode.

Modeling Tool panel. Switch the Show lattice in Object mode
option.

Fit to b.box

To make the lattice fit the object’s bounding box.
Modeling Tool panel. Just press the button to see the lattice
coincide with the bounding box of the object.

Reset lattice

To reset any change made to the lattice and bring it back to the
original status.
Modeling Tool panel. Just press the button.
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ﬁ\) Stretch

Deforms any object with a spine curve according to a stretch
curve.

How fo use

1. Click the Stretch icon or choose the Tools » Transform »
Deformation » Stretch menu command.

2. The program console prompts Select an object.

3. Pick the object you want to stretch from any view.

4. The program console prompts Select the spine curve.
5. Pick the spine curve of the object you want to stretch.
6. The program console prompts Select the stretch curve.

7. Pick the curve according to which the object should be
stretched. A stretched copy of the object is created. The
original object is hidden but not deleted. In fact, you will
find it in Hierarchy Browser hidden from both rendering
and views.
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Options

Object

To change the object you want to stretch.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

Spine curve

To change the spine curve.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Stretch curve

To change the curve according to which the original object will be
stretched.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Angle

To change the rotation angle of the object around the stretch
curve.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Linear stretch

Deforms any object according to a stretch curve.

How fo use

1. Click the Linear stretch icon or choose the Tools »
Transform » Deformation » Linear stretch menu command.

2. The program console prompts Select an object.
3. Pick the object you want to stretch from any view.
4. The program console prompts Select the stretch curve.

5. Pick the curve according to which the object should be
stretched. A stretched copy of the object is created. The
original object is hidden but not deleted. In fact, you will
find it in Hierarchy Browser hidden from both rendering
and views.
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Options

Object

To change the object you want to stretch.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

Default axis

To specify the stretch direction.

Modeling Tool panel. Switch the chosen radio button on.
You have the following options:

X. Stretches along the X-axis.

Y. Stretches along the Y-axis.

Z.. Stretches along the Z-axis.

Vertical. Stretches vertically.

Horizontal. Stretches horizontally.

Axis start point
Axis end point

To modify XYZ coordinates of the axis start and end points
therefore allowing you to determine a custom vector that specifies
the stretch direction.

Views. Choose the Edit mode. Click the Axis Start Point or Axis
End Point hotSpots of the axis and interactively define its
orientation by dragging it.

Modeling Tool panel. Type the values in the XYZ data fields and
confirm them by pressing [Enter].
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Stretch curve

To change the curve according to which the original object will be
stretched.

Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Start position

To position the surface along the stretch curve.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Scaling factor

To scale the surface along the stretch curve.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Normal scaling factor

To scale the surface along its normal.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Angle

To change the rotation angle of the object around the stretch
curve.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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PixelMap

Deforms any selected NURBS surface depending on the
brightness of each pixel of a bitmap image that you use as a map.

How fo use

1. Click the PixelMap icon or choose the Tools »
Transform » Deformation » PixelMap command.

2. The program console prompts Pick a NURBS surface.

3. Pick the NURBS object you want to deform. A copy of the
object is created. The original object is hidden but not
deleted. In fact, you will find it in Hierarchy Browser
hidden from both rendering and views.

4.  In the Modeling Tool panel and click the Browse... button
on the Image section. A file requester is displayed allowing
you to choose a .bmp image that will be used to deform the
NURBS surface on the ground of the luminance of each
pixel.
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Image

Depth

Modeling = Transformations

Options

To change the object to deform.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

To choose the image that will be used as a deforming map.
Modeling Tool panel. Press the Browse... button and choose a
bitmap image that will be used to deform the NURBS surface
according to the luminance of each pixel.

To specify the deformation range.

Views. Choose the Edit mode. Click one of the construction
vertices and drag it. Release the mouse button when you reach the
desired width.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter |. The value can

range from 0 to .

Sampling X res.
Sampling Y res.

To increase or decrease the sampling factor (i.e. the number of
control points), along X and Y, of the image used as a map.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter|.
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Constrained sampl.

To maintain X and Y sampling factors dependent.
Modeling Tool panel. Switch off the check button to disable this
option, which is enabled by default.

Smoothness

To increase or decrease smoothness of the new surface.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [ Enter .

To flip the image map along either axis.

Modeling Tool panel. Switch on the check button to enable either
option. Both check buttons can be used to effectively rotate the
image 180 degrees.
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SurfDrape

Deforms any object, starting from a spine NURBS surface,
according to a stretch NURBS surface.

The target object will be shaped according to a reference NURBS
surface. Similar to the Stretch modeling tool, SurfDrape uses
surfaces as reference objects instead of curves.

How fo use

1. Click the SurfDrape icon or chose the Tools » Transform
» Deformation » SurfDrape command.

2. Pick the object to deform (it can be a surface, a curve or a
polymesh).

3.  Pick the spine surface. It must be a NURBS surface
consisting of only one NURBS surface. If the object is made
up of more than one surface only the first will be taken into
consideration.

4.  Pick the reference surface (stretch surface). It must be a
NURBS surface object consisting of only one NURBS
surface.

5. A stretched copy of the object is created. The original object
is hidden but not deleted. In fact, you will find it in
Hierarchy Browser hidden from both rendering and views.
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In most cases, the spine surface should be a plane. The larger the
plane in comparison with the stretch surface, the smaller the
deformed object and vice-versa. This deformation is similar to a
texture UV-mapping (the spine surface) over the stretch surface.

If the original surface has a “non-rectilinear shape”, the spine
surface should be non-planar so that the object to deform “lies” on
such surface. See picture below.
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Options

Object

To change the object to deform.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another object in the scene.

Spine Surface

To change the spine surface.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Stretch Surface

To change the stretch surface.
Views / Modeling Tool panel. Switch the Replace check button on
and pick another curve in the scene.

Normal scaling factor

To change the “thickness” of the deformed object along the
direction of the normal to the stretch surface.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Options

To change the rotation angle of the object around the stretch
curve.

Modeling Tool panel. Check the Hide source objects check box if
you want to hide from view and from rendering the spine surface
and the stretch surface. Check the Interactive Changes check box
if you want that changes apply at every mouse move and not only
when mouse button is released.

Note I: If the original object is a shell of stitched NURBS surface
trimmed at boundaries, this deformation can introduce gaps. In
this cases, to obtain the best result, is useful to transform the
original object in a polymesh.

Note II: If the object “comes out” from the spine surface (like in
the figure below), the deformed object will lie on a rectilinear
extension of the stretch surface.
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Curves

In this section we will explain purpose and use of the curve tools
available.

A curve can be defined as the path of a point moving through
space. solidThinking lets you draw curves by placing control
points. Since they are just lines, they are not rendered even
though they are the basis for any 3D geometry.

Curves have only one dimension in space: it is called U and it
corresponds to the length of the curve.

Once you have drawn a curve, you have a number of options to
modify parameters and/or apply new commands. Each
parameter/command can be modified/applied by working in the
views only, in the Modeling Tool panel, or in both Views and
Modeling Tool panel.

For each parameter/command we will mention all the
possibilities as follows:

Views: steps to follow allow you to work interactively with the
mouse in the views only;

Modeling Tool panel: steps to follow allow you to work in the
Modeling Tool panel only;

Views / Modeling Tool panel: steps to follow require you to
work in both views and Modeling Tool panel.
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You can constrain insertion of control points along one axis by
enabling only one the following icons in the Application toolbar:

To insert along the X-axis only (shortcut is the X key).

To insert along the Y-axis only (shortcut is the Y key).

To insert along the Z-axis only (shortcut is the Z key).

To constrain insertion of control points of the selected items
along XY, XZ, or YZ planes, just select two of the above icons
at a time. Leave all the three icons selected if you want to freely
insert points.
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NURBS curve

Lets you define different segments of NURBS (Non-Uniform
Rational B-Spline) curves.

A NURBS curve is characterized by control points and knots.

You can change the shape of a curve by moving or editing its
control points.

Knots are points on a curve or surface where segments join.
Unlike control points, knots cannot be interactively manipulated
but they are important for a better understanding of curves
behavior.

In general, the distance between knots is approximated to the
distance between the control points.
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How to use

Click the NURBS curve icon or choose the Tools »
Curves » NURBS curve command.

The program console prompts Local axes origin.

Locate axes origin of the curve following one of the two
methods:

a) Click and drag in any view and release the mouse
button to confirm placement.

b) Type its XYZ coordinates in the console (values
must be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in relation to the XYZ origin.

Successive clicks add control points. You can add points in
any view regardless of where you started drawing the
curve.

If you prefer, you can type exact coordinates from the
keyboard. Separate each value with a comma. Your input
is immediately displayed in the console. Relative
coordinate values can be inserted by typing “@” before
numbers (i.e. @2,2,2).

Press to stop points insertion.

To interactively define the arc hold the mouse button down
after the click or click while pressing the key.
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Options

XYZ coordinates

To modify XYZ coordinates of a curve point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in
the XYZ data fields and confirm them by pressing [Enter|.

Remove

Insert

To remove a curve point.

Views. Choose the Edit mode. Pick the point you want to
remove. Choose the Edit p Delete command.

Modeling Tool panel. Click the [...] button and select the point
you want to remove from the scroll list (the views will display it
in yellow). Press the Remove button.

To add new points to a curve.

Views / Modeling Tool panel. Switch on the Insert check button
and click in any view. If you have previously selected two
adjacent points, you can add points between them.
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Order

To set the order of a curve.
Modeling Tool panel. Move the slider or type the value in the
Order data field. Press to confirm. Default value is 3. The

order of a curve can be modified at any moment.

The following pictures show how the same curve changes by
modifying the order value from 2 to 7.

240

solidThinking User Manual



Modeling = Curves

New Entity

To add a new portion of the curve even with a different order.
Views / Modeling Tool panel. Press the New Curve Entity
button and click in any view to add points.

Here is an example on how to use this command. Draw a

NURBS curve as in the picture and press to end
points insertion.

Select a curve endpoint, then press the New Curve Entity
button. Modify Order to 2 and press [Enter].

Add new points to the selected curve by clicking in the view.

Press to end point insertion.

The first point of the New Curve Entity is the endpoint of the
starting curve and it is called keypoint.
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Select the endpoint of the curve you have just drawn and press
again the New Curve Entity button. Modify Order to 4. Add

new points by clicking in any view. Press [Spacebar].

To pick one curve entity only (and not the whole curve), press
the right mouse button while holding down the key, or select
it from the browser.
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Join can be used for two purposes:

a) To join the start and the end point of the same curve entity.
Views / Modeling Tool panel. Select the end points (see the
Selection paragraph for multiple selections) of the same curve
and press the Join button. You can then use the Un-join
command to unjoin them.

b) To join two end points of two entities belonging to different
curves. This operation requires you to work also in the browser
in order to combine the two entities by dragging and dropping
one curve entity into the other curve.

Let’s look at an example: we want to join the endpoints of two
given curves.

7
o

We can move one entity from one curve to another by just
clicking and dragging it. To simply copy the entity, instead of
moving it, click and drag it while simultaneously holding down

the key.
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In the pictures below we have moved the entity belonging to
Curve#2.

World Browser

(WorldBrowser  __________H|
W WD X<
|.Defau|t layer J IVISlblhl_',J LI

-4 World
- -8 Perspective #1
= Curve #1
- g Curve entity
=l ﬂ Curve #2
‘ 1
l . Cameras
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£2 Layers

World Browser

World Browser |
WO = Q@ 17X
I J I\-"lsublllty j

= 0 World
- A Perspective 1

E] @ Curve #1

;’l Curve entity

: ,..| Curve entity
l . Cameras

‘@ Lights
&'3 Layers

Note: You can obtain the same result by using the Combine
command to merge the two curves and then collapsing the

Construction Tree.
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Once we have combined the two entities and made them
components of the same curve, switch to Edit mode and select
the two end points you are interested in joining by either picking
them while holding down the key or dragging in order to

include them in the selection box.

l

Open the Modeling Tool panel and press the Join button. The
Join is performed as shown in the pictures of the next page.
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Un-join

To unjoin two previously joined points.

To break a curve into two pieces at a keypoint.

Views / Modeling Tool panel. Choose Edit mode. Pick the joined
points and press the Un-join button. Click the joined points to
deselect them. Click again and drag to move the first point. This
command can be used in the same way to break a curve obtained
with New Curve Entity into two pieces at a keypoint.

Curve Type

To open/close any selected curve.
Modeling Tool panel. Just switch the related radio button on.

Invert direction

Weight

To invert the direction or sequence of control points on a curve.
Inverting curve directions can be very important when you use
modeling tools like Skin and you have curves with different
directions.

Modeling Tool panel. Just press the button.

To adjust the weight of one or more control points of a curve.
Views / Modeling Tool panel. Select the control point or points
whose weight factor you want to modify. Move the slider or type
the weight factor in the Weight data field. Press to
confirm.

Default weight factor is 1. The more you increase this value, the
greater the pulling effect that the control point exerts on the
curve. Weight factor should not be lower than 0.0001. In fact, 0 is
not a valid weight factor.

The following pictures show how the same curve changes by
modifying the weight factor of a control point.
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When all control points on a curve have the same weight, the
curve is called Non-rational. When control points have different
weight factors, the curve is called Rational.

Note: Weight modification should be used very carefully. If you
plan to exchange your projects, you should remember that many
CAD systems do not support modified weight values. Placing two
points close to one another, but not one over the other, grants
almost the same result.
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?J MetaCURVE

It is an interpolation of points using a smooth curve.
MetaCURVE is useful when a curve must pass through specified
points.

How fto use

Click the MetaCURVE icon or choose the Tools »
Curves » MetaCURVE command.

The program console prompts Local axes origin.

Locate axes origin of the curve following one of the two
methods:

a) Click and drag within any view and release the
mouse button to confirm placement;

b) Type its XYZ coordinates in the console (values
should be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in correspondence with the XYZ
origin.

Successive clicks add control points. You can add points in
any view regardless of where you started drawing the
curve.

If you prefer, you can type exact coordinates from the
keyboard. Separate each value with a comma. Your input
is immediately displayed in the console. Relative
coordinate values can be inserted by typing “@” before
numbers (i.e. @2,2,2).
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Press to stop points insertion.

Hold the mouse button down after the click to interactively
model the curve.

If you press the key, there is no need to hold the
mouse button down to interactively draw the curve: just
click to place control points.

solidThinking User Manual

249



Section 4

Options

Point XYZ coordinates

To modify XYZ coordinates of a curve point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in
the XYZ data fields and confirm them by pressing [Enter|.

Remove

Insert

Cusp

To remove a curve point.

Views. Choose the Edit mode. Pick the point you want to
remove. Choose the Edit p Delete command.

Modeling Tool panel. Click the [...] button and select the point
you want to remove from the scroll list (the views will display it
in yellow). Press the Remove button.

To add new points to the curve.

Views / Modeling Tool panel. Switch the Insert check button on
and click in any view. If you have previously selected two
adjacent points, you can add points between them.

To create a corner at selected control point/points.
Views / Modeling Tool panel. Select the point you want to make
cuspid and press the button.
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Smooth

To smooth the curve at any selected control point/points.
Views / Modeling Tool panel. Select the point/points you want to
smooth and press the button.

Curve Type

To open/close the selected curve.
Modeling Tool panel. Just switch the related radio button on.

Invert direction

To invert the direction or sequence of control points on the curve.
Modeling Tool panel. Just press the button.

Start/End Condition

Controls the location and orientation of the ends of the
MetaCurve. Both the start point and end point of a MetaCurve
can have their interpolation and location controlled with the
following options:

Auto (default). Uses the position in space of the start or endpoint
to set the interpolation of the curve to the next point.

Free. Uses an arbitrary Tangent direction to set the orientation of
the start/ end point in the interpolation to the next point. The
position of the start/ end point remains the same.

(Start/ End) Tangent Angle. Controls the rotation of the
tangent direction around the effected point on the XY
plane.

(Start/ End) Tangent Length. Controls the size of the
tangent region between the effected point and the next
interior point.
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(Start/ End) Tangent Elevation. Controls the rotation of the
tangent direction around the effected point on the YZ
plane.

Clamped. Clamps the start/ end point to another curve in the
scene, with controls for the location, tangency and continuity of
the interpolation.

Start/End Curve. To change the Start Curve that the
MetaCurve will be clamped to.

Views / Modeling Tool panel. Switch the Replace check
button on and pick another curve in the scene.

Point on Start/End Curve. To adjust the location point
along the Start/ End curve that the MetaCurve start or end
point will be attached or tangentto.

Modeling Tool panel. Move the slider or type the position
value (in a 0 to 1 range where 0 and 1 represent the
endpoints) in the data field and press Enter to confirm.
Changes are interactively displayed in the views.

Start/End Constraint. To control the continuity of the start
or end point of the MetaCurve. You can either select Attach
for positional continuity for Tangent -continuity for
controlling position and tangency as well.

Invert Tangent Direction. To invert direction of the tangent
for the Clamped condition.

Modeling Tool panel. Switch the Invert tangent dir. check
box on where convenient.
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/> Open Polyline

Draws a sequence of straight lines.

How to use

Click the Open Polyline icon or choose the Tools b
Curves » Polyline » Open polyline command.

The program console prompts Local axes origin.

Locate axes origin of the curve following one of the two

methods:

a) Click and drag in any view and release the mouse
button to confirm placement.

b) Type its XYZ coordinates in the console (values
must be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in correspondence with the XYZ
origin.

Successive clicks define point in the polyline. Each point
defines a new node and segment in the polyline. You can
add points working in any view regardless of where you
have started drawing.

Press to stop points insertion.

To interactively define the point position hold the mouse
button down after the click or click while pressing the

key.
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Options

XYZ coordinates

To modify XYZ coordinates of a point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in
the XYZ data fields and confirm them by pressing [Enter|.

Remove

Insert

To remove a polyline point.

Views. Choose the Edit mode. Pick the point you want to
remove. Choose the Edit » Delete command.

Modeling Tool panel. Click the [...] button and select the point
you want to remove from the scroll list (the views will display it
in yellow). Press the Remove button.

To add new points to a polyline.

Views / Modeling Tool panel. Switch the Insert check button on
and click in any view. If you have previously selected two
adjacent points, you can add points between them.
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[y Rounded PolyLine

Draws a sequence of straight or rounded lines.

How to use

Click the Rounded Polyline icon or choose the Tools »
Curves » Polyline » Rounded polyline command.

The program console prompts Local axes origin.

Locate axes origin of the curve following one of the two

methods:

c) Click and drag in any view and release the mouse
button to confirm placement.

d) Type its XYZ coordinates in the console (values
must be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in correspondence with the XYZ
origin.

Successive clicks define point in the polyline. Each point
defines a new node and segment in the polyline. You can
add points working in any view regardless of where you
have started drawing.

Press to stop points insertion.

The Modeling Tool panel allows you to round any selected
point node by adjusting the Radius value.
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Options

XYZ coordinates

To modify XYZ coordinates of a point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in

the XYZ data fields and confirm them by pressing [Enter|.

Remove

Insert

Radius

To remove a polyline point.

Views. Choose the Edit mode. Pick the point you want to
remove. Choose the Edit » Delete command.

Modeling Tool panel. Click the [...] button and select the point
you want to remove from the scroll list (the views will display it
in yellow). Press the Remove button.

To add new points to a polyline.

Views / Modeling Tool panel. Switch the Insert check button on
and click in any view. If you have previously selected two
adjacent points, you can add points between them.

To define the radius value of selected point nodes.
Modeling Tool panel. Move the slider or type the radius value in
the data field and press to confirm.
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Options

To close the selected curve.
Modeling Tool panel. Just switch the Closed check box on.

Arc type

Points

To specify whether the arcs must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option the number of control points is automatically defined.
With the second option you can set the number of control points
in the Points section.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit it.

To determine the number of control points of the arcs in case you
have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the arcs).
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/ Single Line

Draws a line at any angle and defined by its endpoints.

How to use

Click the Single Line icon or choose the Tools » Curves
» Line » Single line command.

The program console prompts Local ax origin.

Locate axes origin of the curve following one of the two
methods:

a) Click and drag in any view and release the mouse
button to confirm placement.
b) Type its XYZ coordinates in the console and press

to confirm. Press without typing any

value in the console, to place the axes origin of the
curve in correspondence with the XYZ origin.

The program console prompts Point #1.

Place the first endpoint either by clicking and dragging in
any view or by typing its XYZ coordinates in the console.

Repeat step 5 at the Point #2 console prompt.

You can insert points in any view regardless of where you
have started drawing your line.

To interactively define the arc, hold the mouse button
down after the click or click while pressing the key.
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Options

Point #1
Point #2

To modify XYZ coordinates of the end points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].
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x/ Perpendicular Line

Draws a perpendicular line to another line you select.

How to use

1. Click the Perpendicular Line icon or choose the Tools »
Curves » Line » Line: perpendicular to segment command.

2. The program console prompts Point.
3. Locate axes origin of the curve following one of the two
methods:

a) Click and drag in any view and release the mouse
button to confirm placement.

b) Type its XYZ coordinates in the console (values
must be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in correspondence with the XYZ
origin.

4.  The program console prompts Line.

5. Pick the line to which the one you are drawing will be
perpendicular.

260 solidThinking User Manual



Modeling = Curves

Options

Point

To modify XYZ coordinates of the endpoint.

Views. Choose the Edit mode. Click the endpoint and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

To change the line to which the one you have drawn is

perpendicular.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another line in the scene.
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A Parallel Line

Draws a straight line parallel to another line you select.

How to use

Click the Parallel line icon or choose the Tools » Curves
» Line » Line: parallel to segment command.

The program console prompts Point.

Locate axes origin of the curve following one of the two

methods:

a) Click and drag in any view and release the mouse
button to confirm placement.

b) Type its XYZ coordinates in the console (values
must be separated by a comma, i.e. 1,2,3) and press
to confirm. If you press without typing
any value in the console, the axes origin of the curve
will be placed in correspondence with the XYZ
origin.

The program console prompts Line.

Pick the line to which the one you are drawing will be
parallel.

262

solidThinking User Manual



Modeling = Curves

Options

Point

To modify XYZ coordinates of the point on the parallel line.
Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

To change the line to which the one you have drawn must be
parallel.

Views / Modeling Tool panel. Switch the Replace check button
on and pick another line in the scene.

The Modeling Tool panel also displays XYZ coordinates of the
endpoints of the parallel line. These are not modifiable.
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T\

Fillet Segment

Draws the shortest line possible from a curve to another.

How to use

Click the Fillet segment icon or choose the Tools b
Lines » Line: fillet segment command.

The program console prompts Line #1.
Pick the first line.
The program console prompts Point on line #1.

Define the point on line #1 that will be the starting point of
the fillet segment.

The program console prompts Line #2.
Pick the second line.
The program console prompts Point on line #2.

Define the point on line #2 that will be the ending point of
the fillet segment.
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Options

Line #1

To change the first line from which the segment starts.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another line in the scene.

Point on line 1

To modify XYZ coordinates of the point on line 1.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Line #2

To change the second line to which the segment ends.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another line in the scene.

Point on line 2

To modify XYZ coordinates of the point on line 2.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].
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Distance

To change the position of the segment with respect to the lines.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

The Modeling Tool panel also displays XYZ coordinates of the
endpoints of the fillet segment. These are not modifiable.
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v Segment from center

Draws a segment defined by one end point and its center point.

How to use

1.  Click the Segment from center icon or choose the
Tools » Curves » Line » Segment from center
command.

2. The program console prompts Local ax origin.

3. Locate axes origin of the curve following one of the two
methods:

c) Click and drag in any view and release the mouse
button to confirm placement.

d) Type its XYZ coordinates in the console and press
to confirm. Press without typing any
value in the console, to place the axes origin of the
curve in correspondence with the XYZ origin.

4.  The program console prompts End point.

5. Place the endpoint either by clicking and dragging in any
view or by typing its XYZ coordinates in the console.
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Options

Center point

To modify coordinates of the center point.

Views. Choose the Edit mode. Click the Center point hotspot
and drag it. Release the mouse button when you reach the
desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

End point

To modify XYZ coordinates of one end point.

Views. Choose the Edit mode. Click the End point hotspot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Length

To change the segment length.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Azimuthal angle

To change the azimuthal angle of the segment with the local axes
origin.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].
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Polar angle

To change the polar angle of the segment with the local axes
origin..

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].
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/ Inclined Segment

Draws a segment at any angle and defined by its endpoints.

How to use

Click the Inclined segment icon or choose the Tools »
Curves » Line » Inclined segment command.

The program console prompts Local ax origin.

Locate axes origin of the curve following one of the two
methods:

a) Click and drag in any view and release the mouse
button to confirm placement.
b) Type its XYZ coordinates in the console and press

to confirm. Press without typing any value

in the console, to place the axes origin of the curve in
correspondence with the XYZ origin.

The program console prompts Azimuthal Angle.
Set the azimuthal angle by typing its value in the console.

At the Length console prompt, define the segment length
by typing its value in the console
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Options

Azimuthal angle

To change the azimuthal angle of the segment with the local axes
origin.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].

Polar angle

To change the polar angle of the segment with the local axes
origin..

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].

Point #1

To modify coordinates of the center point or local axes origin.
Views. Choose the Edit mode. Click the Point #1 hotspot and
drag it. Release the mouse button when you reach the desired
position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Point #2

To modify XYZ coordinates of one end point.

Views. Choose the Edit mode. Click the Point #2 hotspot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].
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Length

To change the segment length.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Segment Tangency Align

Allows you to establish tangent continuity between any given
curve and a newly created segment.

How to use

1.  Click the Segment tangency align icon or choose the
Tools » Curves » Line » Segment tangency align menu
command.

2. The program console prompts Point on curve.

3. Pick the curve you want to align at tangency point, whose
position can be defined by sliding along the curve without
releasing the mouse button. The curve turns green.

4.  The program console prompts End point.

5. Place the endpoint either by clicking and dragging in any
view or by typing its XYZ coordinates in the console.

6. A new segment establishing tangent continuity with the
curve is created.

This segment is automatically updated at any modification
of the curve. If you set the angle parameter at 90 degrees
you can make the segment perpendicular to the curve.
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Curve

Options

To change the curve to which the segment must be tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Parameter

To move the start point of the segment along the curve.
Modeling Tool panel. Move the slider or type the position value
(in a 0 to 1 range where 0 and 1 represent the endpoints) in the
data field and press to confirm. Changes are interactively
displayed in the views.

The Modeling Tool panel also displays XYZ coordinates of the
tangency Point on curve. These are not directly modifiable.

End point

Length

To modify XYZ coordinates of the segment end point.

Views. Choose the Edit mode. Click the End point hotspot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

To modify the segment length.
Modeling Tool panel. Move the slider or type the degree value in
the data field and press to confirm.
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Angle

To set the angle of the segment with the curve at the specified
point.

Modeling Tool panel. Move the slider or type the degree value in
the data field and press to confirm. Set 0 for tangency, 90

for perpendicularity.

Angle on perp.plane

To set the rotation angle of the segment around the curve tangent.
Modeling Tool panel. Move the slider or type the degree value in
the data field and press to confirm.

Distance from curve

To define the distance between the point on curve and the
segment starting point (in the direction defined by the Angle on
perp. plane parameter).

Modeling Tool panel. Move the slider or type the distance value
in the data field and press to confirm.

Options

To enable some useful options.

Modeling Tool panel. Check the Extend specular check box if
you want to extend the segment by doubling its length.

Check the Add normal segment check box if you want to create
a segment between the point on curve and the main segment
starting point (useful when Distance from curve is not 0).

Cutting

To specify whether to cut part of the curve or not.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: No cutting, Cut above, and Cut
below. If you choose the second or the third option, the segment
will cut the curve at the tangency point. Segment and curve will
be joined in a single element.
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Segment Bisector

Draws a segment which is the bisector of two user-defined
vectors.

How fto use

1.  Click the Segment bisector icon or choose the Tools »
Curves » Line » Segment bisector command.

2. The program console prompts Local axes origin.

3. Locate axes origin of the curve following one of the two
methods:

a)  Click and drag in any view and release the mouse
button to confirm placement.

b) Type its XYZ coordinates in the console and press
to confirm. Press without typing any
value in the console, to place the axes origin of the
curve in correspondence with the XYZ origin.

4. At the program Direction console prompt, define the first
direction vector either by clicking and dragging in any
view or by typing its XYZ coordinates in the console.

5. At the new Direction console prompt, define the second
direction vector.

6.  The program console prompts End point.
7.  Define the length of the segment by placing its endpoint:

click and drag in any view or type its XYZ coordinates in
the console.
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Options

To modify coordinates of the center point or local axes origin.
Views. Choose the Edit mode. Click the Center hotSpot and
drag it. Release the mouse button when you reach the desired
position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Direction #1

To define the first direction vector by modifying XYZ
coordinates.

Views. Choose the Edit mode. Click the Direction #1 hotSpot
and drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Direction #2

To define the second direction vector by modifying XYZ
coordinates.

Views. Choose the Edit mode. Click the Direction #2 hotSpot
and drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

End point

To modify XYZ coordinates of the segment end point.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].
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Length

To change the segment length.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

The Modeling Tool panel also displays the Aperture angle of the
two direction vectors. This is not directly modifiable.
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Ob Bi-tangent Segment

Allows you to create a segment tangent to two given curves.

How to use

1.  Click the Bi-tangent segment icon or choose the Tools »
Curves » Line ) Bi-tangent segment command.

2. The program console prompts Pick tangent line #1.

3. Pick the first curve to which the segment must be tangent.
The curve turns green.

4. At the End point console prompt, pick the other curve to
which the segment must be tangent. The curve turns green.

5. A new segment tangent to both the two curves is created.

This segment is automatically updated at any modification
of the curves.
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Options

Tangent line #1

To change the first curve to which the segment must be tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

End point #1

To modify XYZ coordinates of the first reference point. This
point is not exactly the segment end point. The segment end
point is positioned as near as possible to this point to respect
tangent conditions.

Views. Choose the Edit mode. Click the End point hotspot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Tangent line #2

To change the second curve to which the segment must be
tangent.

Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

End point #2

To modify XYZ coordinates of the reference point on the second
curve. This point is not exactly the segment end point. The
segment end point is positioned as near as possible to this point
to respect tangent conditions.

Views. Choose the Edit mode. Click the End point hotspot and
drag it until you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].
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Options

Cutting

To enable trimming of the reference curves.

Modeling Tool panel. Check the Trim tangents check box if you
want to trim the curves at the intersection with the segment.
Segment and curves will be joined in a single element.

To change the part of the curve to keep after cutting.

Modeling Tool panel. You have the following options: Invert tangent
#1 inverts cutting on the first curve and Invert tangent #2 which
inverts cutting on the second curve.
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Preferred Arc

Draws a circular arc by defining a center point and two end
points.

How fto use

1.  Click the Preferred Arc icon or choose the Tools »
Curves » Arc » Arc: center, point, point command.

2. The program console prompts Local axes origin.

3.  Place the centerpoint of the arc either by clicking and
dragging in any view (release the mouse button to confirm
placement) or by typing its XYZ coordinates in the
console. Values must be separated by a comma, i.e. 1,2,3,
and confirmed by pressing [ Enter |. If you press
without typing any value, the axes origin of the curve will
be placed in correspondence with the XYZ origin.

4. The program console prompts Start point.

5. Place the start point either by clicking and dragging in any
view or by typing its XYZ coordinates in the console.

6. In the same way, place the end point at the End point
console prompt.

To interactively define the arc, hold the mouse button down
after the click or click while pressing the key.
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Options

Start point
End point

Angle

Radius

To modify XYZ coordinates of the two arc end points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to 360 degrees, in which case the arc becomes a
circle.

To change the preferred radius.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you reach the desired
radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 0 to .

solidThinking User Manual

283



Section 4

Extra

To specify whether you want to visualize the arc contour only or
also the radii that make it appear as a pie slice.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Contour and Pie Slice.

Arc type

Points

To specify whether the arc must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the Points section.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the arc in case you
have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the arc).

Direction

To specify the direction of the arc.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Counter-clockwise and Clockwise
(starting from the Start point).
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Arc: 3 points
Arc: 3 points (ordered)

Draws an arc by defining three points in space.

The difference between Arc: 3 points and Arc: 3 points (ordered)
is only in the order you insert points. The first tool prompts you
to insert point in the following order: start point, end point,
middle point; in the second tool the order is: start point, middle
point, end point.

Although the difference may appear minimal, it can be important
to improve the workflow.

How to use

1. Click the Are: 3 points icon or choose the Tools » Curves
» Arc » Arc: 3 points command.

2. The program console prompts Point #1.

3. Place the first point either by clicking and dragging in any
view (release the mouse button to confirm placement) or
by typing its XYZ coordinates in the console. Values must
be separated by a comma, i.e. 1,2,3, and confirmed by
pressing [ Enter |. If you press without typing any
value, the point will be placed in correspondence with the
XYZ origin.

4.  Place the second point at the Point #2 console prompts.
This will be the second end point of the arc.
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Place the third point at the Point #3 console prompts. This
point can be anywhere on the arc.

You can insert points in any view regardless of where you
have started.

To interactively define the arc, hold the mouse button
down after the click or click while pressing the key.
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Options

Point #1
Point #2
Point #3

To modify XYZ coordinates of perimeter points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Extra
To specify whether you want to visualize the arc contour only or
also the radii that make it appear as a pie slice.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Contour and Pie Slice.

Arc type

To specify whether the arc must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option the number of control points is automatically defined.
With the second option you can set the number of control points
in the Points section.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit it.
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Points

To determine the number of control points of the arc in case you
have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the arc).

The Modeling Tool panel also displays XYZ coordinates of the
Center of the circle, the arc Angle, and the Radius value. These
are not directly modifiable.
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Fillet Arc

Draws an arc tangent to two selected lines.

How to use

1. Click the Fillet arc icon or choose the Tools »
Curves » Circle » Fillet arc: 2 lines command.

2. The program console prompts Tangent line #1.

3. Pick the first line to which the circle will be tangent. Keep
the mouse button pressed and drag for positioning the arc
end point along the tangent. Release the mouse button
when you have reached the desired position.

4.  The program console prompts Tangent line #2.

5. Pick the second line to which the circle will be tangent.
Keep the mouse button down and drag interactively for
defining the arc and positioning the other arc end point
along the tangent. Release the mouse button when you
have reached the desired position.
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Options

Tangent line #1

To change the first line to which the arc is tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

End point # 1

To modify XYZ coordinates of the arc end point on line 1.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Tangent line #2

To change the second line to which the arc is tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

End point # 2

To modify XYZ coordinates of the arc end point on line 2.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].
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Radius

To change the preferred radius.

Views. Choose the Edit mode. Click the Radius point hotSpot
and drag it. Release the mouse button when you reach the
desired radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 0 to .

Arc type

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option the number of control points is automatically defined.
With the second option you can set the number of control points
in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

Points

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the circle).
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Options

To specitfy various options.

Modeling Tool panel. To enable the available options, switch
their check buttons on:

Invert arc. To invert the arc direction.

Fit tangents. The fillet arc will cut the tangents at the
intersection points. Fillet arc and tangents will be joined to a
single element. If you enable this option, you have two more
possibilities:

Invert tangent #1. To invert the portion of tangent to be cut.
Invert tangent #2. To invert the portion of tangent to be cut.

The Modeling Tool panel also displays the sweep Angle of the
arc. This is not directly modifiable.
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Arc: 2 points, radius

Draws an arc by defining two points in space and the arc radius.

How to use

Click the Arc: 2 points, radius icon or choose the
Tools » Curves » Arc » Arc: 2 points, radius
command.

The program console prompts Local axes origin.

Place the axes origin of the arc either by clicking and
dragging in any view (release the mouse button to confirm
placement) or by typing its XYZ coordinates in the
console. Values must be separated by a comma, i.e. 1,2,3,
and confirmed by pressing [ Enter |. If you press
without typing any value, the axes origin of the curve will
be placed in correspondence with the XYZ origin.

The program console prompts Point #1.
Place the first point either by clicking and dragging in any
view (release the mouse button to confirm placement) or

by typing its XYZ coordinates in the console.

Place the second point at the Point #2 console prompt. This
will be the second end point of the arc.

The program console prompts Radius.

Define the preferred radius by typing the radius value in
the console.
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Radius

Options

Point #1
Point #2

To modify XYZ coordinates of perimeter points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

To change the preferred radius.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

The Modeling Tool panel also displays the arc Angle and the
XYZ coordinates of the Center of the circle. These are not
directly modifiable.

Side/Direction

To invert side or direction of the arc.
Modeling Tool panel. To enable the available options, switch the
Invert side or Invert direction check box.
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To specify whether you want to visualize the arc contour only or
also the radii that make it appear as a pie slice.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Contour and Pie Slice.

Arc type

Points

To specify whether the arc must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option the number of control points is automatically defined.
With the second option you can set the number of control points
in the Points section.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit it.

To determine the number of control points of the arc in case you
have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the arc).
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(

Tangent Arc

Draws an arc by defining a tangent curve, a point on such a
curve and another point in space.

How fto use

1. Click the Tangent arc icon or choose the Tools » Curves
» Arc » Arc: tangent, two points command.

2. The program console prompts Curve.
3. Pick the curve to which the arc will be tangent.
4.  Click a point on the curve at the Point on curve console

prompts. This will be the start point of the arc.

5. Place the second point at the Point console prompt. This
point can be anywhere in the space.

You can insert points in any view regardless of where you
have started.

To interactively define the arc, hold the mouse button
down after the click or click while pressing the key.
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Options

Curve

To change the curve to which the arc is tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Point on curve

To modify XYZ coordinates of the arc point on curve.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Point

To modify XYZ coordinates of the second arc point.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter|.
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Direction

To specify the direction of the arc from the tangent point.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Tangent, Normal, and Binormal.

Invert direction

To invert the direction of the arc.
Modeling Tool panel. Just press the button and observe the result
in any view.
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Arc type

Points

Cutting

To specify whether the arc must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option, the number of control points is automatically
defined. With the second option you can set the number of
control points in the Points section.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the arc in case you
have chosen Non-weighted in the above section.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing (remember: the
more the control points, the more approximated the arc).

To specify whether the tangent arc should cut the tangent curve or not.
Modeling Tool panel. Switch the chosen radio button on. You have the
following options: No cutting, Cut above, and Cut below. If you
choose the second or the third option, the arc will cut the tangent at the
intersection point. Arc and tangent will be joined in a single element.

/5//3 )
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/’) Line-Arc

Draws a sequence of lines and arcs or, anyway, a curve
composed of lines and arcs.

How fto use

Click the Line-Arc icon or choose the Tools » Curves
» Arcs p Line-Arc command.

The program console prompts Local axes origin.

Place the local axes of the composite curve either by
clicking and dragging in any view (release the mouse
button to confirm placement) or by typing its XYZ
coordinates in the console. Values must be separated by a
comma, i.e. 1,2,3, and confirmed by pressing [Enter]. If you
press without typing any value, the axes origin of
the curve will be placed in correspondence with the XYZ
origin.

Successive clicks will define the composite curve
alternating lines to arcs, each arc being tangent to the
preceding line. If you prefer, you can type exact
coordinates from the keyboard at the console prompts. You
can add points in any view regardless of where you have
started drawing.

Press to stop points insertion.

To interactively define the point position, hold the mouse
button down after the click or click while pressing the

key.
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Options

XYZ coordinates

To modify XYZ coordinates of a point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Select the point from the scroll list that
appears when you click the [...] button. Type the new values in
the three XYZ data fields and confirm them by pressing [ Enter .

Remove

Insert

To remove a point.

Views. Choose the Edit mode. Pick the point you want to
remove. Choose the Edit » Delete command.

Modeling Tool panel. Click the [...] button and select the point
you want to remove from the scroll list (the views will display it
in yellow). Press the Remove button.

To add new points to the composite curve.

Views / Modeling Tool panel. Switch the Insert check button on
and click in any view. If you have previously selected two
adjacent points you can add points between them.

Curve type

To open/close the selected curve.
Modeling Tool panel. Just switch the related radio button on.
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On insert

To create a composite curve only with lines or arcs.

Views / Modeling Tool panel. Terminate points insertion by
pressing [Spacebar]. Switch the Insert check button on, followed
by one of these options: Alternated (default), Line, Arec. Start
clicking within any view to insert points that define the curve.

On remove

To specify whether the arcs must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option, the number of control points is automatically
defined. With the second option you can set the number of
control points in the section below.

Snap
To make lines tangent to arcs.
Modeling Tool panel. Switch off the check button to disable this
option, which is enabled by default.

Arc type

To specify whether the arcs must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option, the number of control points is automatically
defined. With the second option you can set the number of
control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.
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Points

To determine the number of control points of the arcs in case you
have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).
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Fillet Curves

Draws an arc tangent to two selected curves.

How to use

1. Click the Fillet curves icon or choose the Tools p
Curves » Circle » Fillet curves command.

2. The program console prompts Pick tangent #1.

3. Pick the first curve to which the arc will be tangent. Keep
the mouse button pressed and drag for positioning the arc
end point along the tangent. Release the mouse button
when you have reached the desired position.

4.  The program console prompts Pick tangent #2.

5. Pick the second curve to which the arc will be tangent.
Keep the mouse button down and drag interactively for
defining the arc and positioning the other arc end point
along the tangent. Release the mouse button when you
have reached the desired position.
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Options

Tangent #1

To change the first curve to which the arc is tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

Point #1

To modify XYZ coordinates of the arc end point on curve 1.
Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Tangent #2

To change the second curve to which the arc is tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

Point #2

To modify XYZ coordinates of the arc end point on curve 2.
Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Radius

To change the preferred radius.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Options

To specitfy various options.

Modeling Tool panel. To enable the available options, switch
their check buttons on:

Fixed radius. To constrain radius to a fixed value while moving
the arc end points. In order to fit the fixed radius, the arc can be
created far from reference points.

Invert arc. To invert the arc direction.

Trim tangents. The fillet arc will cut the tangents at the
intersection points. Fillet arc and tangents will be joined to a
single element. If you enable this option, you have two more
possibilities:

Invert tangent #1. To invert the portion of tangent to be cut.
Invert tangent #2. To invert the portion of tangent to be cut.

The Modeling Tool panel also displays the sweep Angle of the
arc. This is not directly modifiable.

Arc type

To specify whether the arc must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
can choose either Weighted or Non-weighted. If you choose the
first option the number of control points is automatically defined.
With the second option you can set the number of control points
in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

306

solidThinking User Manual



Modeling = Curves

Points

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).
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Preferred Circle

Draws a circle by defining its centerpoint and the preferred
radius.

How fto use

Click the Preferred Circle icon or choose the Tools
Curves » Circle » Circle: center, radius command.

The program console prompts Local axes origin.

Place the centerpoint of the circle either by clicking and
dragging in any view (release the mouse button to confirm
placement) or by typing its XYZ coordinates in the
console. Values must be separated by a comma, i.e. 1,2,3,
and confirmed by pressing [ Enter ]. If you press
without typing any value, the axes origin of the curve will
be placed in correspondence with the XYZ origin.

The program console prompts Radius.

Define the preferred radius by either clicking and dragging
the Radius point hotSpot of the circle or by typing the
radius value in the console.

Hold the mouse button down after the click to interactively
draw the circle.

If you press the key, there is no need to hold the
mouse button down to draw the circle: just click to define
the preferred radius.
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Options

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to 360 degrees.

End angle

Radius

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data and pressing [Enter]. The value can range
from 0 to 360 degrees.

To change the preferred radius.

Views. Choose the Edit mode. Click the Radius point hotSpot
and drag it. Release the mouse button when you reach the
desired radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing | Enter ]. The value can

range from 0 to .
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Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the circle).
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@ Circle: diameter

Draws a circle by defining its local axes and the preferred
diameter.

How fto use

Click the Circle: diameter icon or choose the Tools
Curves » Circle » Circle: diameter command.

The program console prompts Local axes origin.

Place the local axes origin which is also the diameter start
point either by clicking and dragging in any view (release
the mouse button to confirm placement) or by typing its
XYZ coordinates in the console. Values must be separated
by a comma, i.e. 1,2,3, and confirmed by pressing [ Enter |.
If you press without typing any value, the axes
origin of the curve will be placed in correspondence with
the XYZ origin.

The program console prompts Diameter end.

Define the preferred diameter by either clicking and
dragging the Diameter end hotSpot of the circle or by
typing the radius value in the console.

Hold the mouse button down after the click to interactively
draw the circle.

If you press the key, there is no need to hold the
mouse button down to draw the circle: just click to define
the preferred radius.
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Options

Diameter start
Diameter end

To modify XYZ coordinates of diameter start end end points.
Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to 360 degrees.

End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data and pressing [Enter]. The value can range
from 0 to 360 degrees.

The Modeling Tool panel also displays XYZ coordinates of the
Center of the circle. These are not directly modifiable.
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To change the preferred radius.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to .

Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).
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O 3 Point Circle

Draws a circle by defining three points on its perimeter.

How fto use

Click the 3 Point Circle icon or choose the Tools
Curves » Circle » Circle: 3 point command.

The program console prompts Point #1.

Place the first point either by clicking and dragging within
any view (release the mouse button to confirm placement)
or by typing its XYZ coordinates in the console. Values
must be separated by a comma, i.e. 1,2,3, and confirmed by
pressing [ Enter |. If you press without typing any
value, the point will be placed in correspondence with the
XYZ origin.

Place the second and third point at the Point #2 and Point
#3 console prompts.

You can insert points in any view regardless of where you
have started.

Hold the mouse button down after the click to interactively
model the circle.

If you press the key there is no need to hold the
mouse button down to draw the circle: just click to define
points placement.

314

solidThinking User Manual



Modeling = Curves

Options

Point #1
Point #2
Point #3

To modify XYZ coordinates of perimeter points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button once you have reached the
desired angle.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to 360 degrees.

End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button once you have reached the
desired angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter |. The value can

range from 0 to 360 degrees.
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Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).

The Modeling Tool panel also displays XYZ coordinates of the
Center of the circle and the Radius value. These are not
modifiable.
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\Q 2 Point Tangent Circle

Draws a circle tangent to an existing line by defining two
perimeter points.

How fto use

I. Click the 2 Point Tangent Circle icon or choose
the Tools » Curves » Circle » Circle: 2 points, tangent
command.

2. The program console prompts Point #1.

3.  Place the first perimeter point either by clicking and
dragging within any view (release the mouse button to
confirm placement) or by typing its XYZ coordinates in
the console. Values must be separated by a comma, i.e.
1,2,3, and confirmed by pressing [Enter]. If you press
without typing any value, the point will be placed in
correspondence with the XYZ origin.

4.  Repeat step 3 at the Point #2 console prompt.
5. The program console prompts Tangent line.

6.  Pick in the view the line to which the circle will be tangent.
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Options

Point #1
Point #2

To modify XYZ coordinates of perimeter points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you have reached the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Tangent line

To change the line to which the circle will be tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse once you have reached the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter |. The value can

range from 0 to 360 degrees.

318

solidThinking User Manual



Modeling = Curves

End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter]. The value can
range from 0 to 360 degrees.

Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted in the above section.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the

more the control points, the more approximated the circle).

The Modeling Tool panel also displays XYZ coordinates of the
Center of the circle and the Radius value. These are not
modifiable.
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O Point Bitangent Circle

Draws a circle by defining one perimeter point and two points of
tangency on two existing lines.

How fto use

1. Click the Point Bitangent Circle icon or choose
the Tools » Curves » Circle » Circle: point, 2 tangents
command.

2. The program console prompts Point.

3. Place the perimeter point either by clicking and dragging in
any view (release the mouse button to confirm placement)
or by typing its XYZ coordinates in the console. Values
must be separated by a comma, i.e. 1,2,3, and confirmed by
pressing [ Enter |. If you press without typing any
value, the point will be placed in correspondence with the
XYZ origin.

4.  The program console prompts Tangent line #1.

5. Pick in the view the first line to which the circle will be
tangent.

6.  Repeat step 5 at the Tangent line #2 console prompt.
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Options

To modify XYZ coordinates of the perimeter point.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you have reached the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Tangent line #1
Tangent line #2

To change the lines to which the circle will be tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you have reached the
desired angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 0 to 360 degrees.
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End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can
range from 0 to 360 degrees.

Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted as the arc type.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).

The Modeling Tool panel also displays XYZ coordinates of the
Center of the circle and the Radius value. These are not
modifiable.
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O Tangent Circle

Draws a circle tangent to an existing line by defining a specified
centerpoint.

How fto use

1.  Click the Tangent Circle icon or choose the Tools »
Curves » Circle » Circle: center, tangent command.

2. The program console prompts Center.

3. Place the centerpoint either by clicking and dragging in
any view (release the mouse button to confirm placement)
or by typing its XYZ coordinates in the console. Values
must be separated by a comma, i.e. 1,2,3, and confirmed by
pressing [ Enter |. If you press without typing any
value, the center of the circle will be placed in
correspondence with the XYZ origin.

4. The program console prompts Tangent line.

5. Pick the line to which the circle will be tangent.
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Center

Options

To modify XYZ coordinates of the centerpoint.

Views. Choose the Edit mode. Click the centerpoint and drag it.
Release the mouse button once you have reached the desired
position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Tangent line

To change the line to which the circle will be tangent.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another tangent line in the scene.

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you have reached the
desired angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 0 to 360 degrees.

End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to 360 degrees.
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Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted as the arc type.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).

The Modeling Tool panel also displays the Radius value. This is
not modifiable.
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O

Focal Point Ellipse

Draws an ellipse by defining its focal points and a point on the
perimeter.

How fto use

1.  Click the Focal Point Ellipse icon or choose the Tools »
Curves » Ellipse » Ellipse: focuses, point command.

2. The program console prompts Focus #1.

3. Place the first focal point either by clicking and dragging in
any view (release the mouse button to confirm placement)
or by typing its XYZ coordinates in the console. Values
must be separated by a comma, i.e. 1,2,3, and confirmed by

pressing [Enter|.

4.  Repeat step 3 at the Focus #1console prompt placing the
second focal point.

5. The program console prompts Point.

6.  Define a perimeter point either by clicking and dragging in
any view or by typing its XYZ coordinates in the console.

You can insert points in any view regardless of where you
have started.

To interactively define the ellipse, hold the mouse button
down after the click or click while pressing [ Shift].
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Options

Focus #1
Focus #2

Point

To modify XYZ coordinates of the focal points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

To modify XYZ coordinates of the perimeter point.

Views. Choose the Edit mode. Click the point and drag it.
Release the mouse button when you have reached the desired
position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter .

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to 360 degrees.
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End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it until you reach the desired angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to 360 degrees.

Arc type

Points

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.

To determine the number of control points of the circle in case
you have chosen Non-weighted as the arc type.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing (remember: the
more the control points, the more approximated the circle).

The Modeling Tool panel also displays XYZ coordinates of the
Center of the ellipse and the length of Half Axis #1 and Half
Axis #2. These are not directly modifiable.
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Preferred Ellipse

Draws an ellipse by defining the centerpoint and the preferred
major and minor half axes.

How fto use

I. Click the Preferred Ellipse icon or choose the
Tools » Curves » Ellipse » Ellipse: center, axis 1, axis 2
command.

2. The program console prompts Center.
3. Place the centerpoint either by clicking and dragging in
any view (release the mouse button to confirm placement)

or by typing its XYZ coordinates in the console. Values
must be separated by a comma, i.e. 1,2,3, and confirmed by

pressing [Enter .

4.  The program console prompts Axis endpoint #1.

5. Define the axis endpoint either by clicking and dragging in
any view or by typing its XYZ coordinates in the console.

6.  Repeat step 5 at the Axis endpoint #2 console prompt.

You can insert points in any view regardless of where you
have started.

To interactively define the ellipse, hold the mouse button
down after the click or click while pressing the key.
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Center

Options

To modify XYZ coordinates of the centerpoint of the ellipse.
Views. Choose the Edit mode. Click the centerpoint and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Axis endpoint #1
Axis endpoint #2

To modify XYZ coordinates of the axes endpoints.

Views. Choose the Edit mode. Click the endpoint and drag it.
Release the mouse button when you reach the desired position.
Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Start angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the Start point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to 360 degrees.
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End angle

To change sweep of the arc.

Views. Choose the Edit mode. Click the End point hotSpot and
drag it. Release the mouse button when you reach the desired
angle.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 0 to 360 degrees.

Half Axis #1
Half Axis #2

To modify length of the half axes.
Modeling Tool panel. Set values either by moving the slider or
by typing it in the data field and pressing [ Enter | Values can

range from 0 to .

Arc type

To specify whether the circle must be weighted (exact) or non-
weighted (approximated).

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: Weighted and Non-weighted. If you
choose the first option, the number of control points is
automatically defined. With the second option you can set the
number of control points in the section below.

Note: in general, you could use Weighted if you do not plan to
modify the original shape and Non-weighted if you want to edit
it.
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Points

To determine the number of control points of the circle in case
you have chosen Non-weighted as the arc type.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter | (Remember:
the more the control points, the more approximated the circle).
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% Rect: 3 points

Draws a rectangle by defining its opposite corners and one more
point defining the angle of the rectangle.

How fto use

I. Click the Rect: 3 points icon or choose the Tools »
Curves » Polyline » Rect: 3 point command.

2. The program console prompts Point #1.
3. Place the first point either by clicking and dragging in any
view (release the mouse button to confirm placement) or

by typing its XYZ coordinates in the console.

4.  Place the second and the third point at the Point #2 and
Point #3 console prompts.

You can insert points in any view regardless of where you
have started.

solidThinking User Manual 333



Section 4

Options

Point #1
Point #2
Point #3

To modify XYZ coordinates of the three points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing | Enter].

Width

To change width of the recatngle.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Height

To change height of the rectangle.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Rectangle

Draws a rectangle by defining its opposite corners.

How to use

1. Click the Rectangle icon or choose the Tools » Curves »
Polyline » Rectangle command.

2. The program console prompts Local axes origin.

3. This is the first corner of the rectangle and you can place it
either by clicking and dragging in any view (release the
mouse button to confirm placement) or by typing its XYZ
coordinates in the console.

4.  Place the second point at the Point #2 console prompt.

You can insert points in any view regardless of where you
have started.
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Options

Point #1
Point #2

Width

Height

To modify XYZ coordinates of the two points.

Views. Choose the Edit mode. Click the point whose position
you want to modify and drag it. Release the mouse button when
you reach the desired position.

Modeling Tool panel. Type the new values in the XYZ data fields

and confirm them by pressing | Enter|

To change width of the rectangle.

Views. Choose the Edit mode. Click the Width hotSpot and drag
it. Release the mouse button when you reach the desired width.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

To change height of the rectangle.

Views. Choose the Edit mode. Click the Height hotSpot and
drag it. Release the mouse button when you reach the desired
width.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].
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Regular Polygon

Draws a regular polygon, that is a closed polygon with three or
more equal sides.

How fto use

Click the Regular Polygon icon or choose the Tools »
Curves » Polyline » Regular Polygon command.

The program console prompts Local axes origin.

Position the polygon either by clicking and dragging in any
view (release the mouse button to confirm placement) or
by typing its XYZ coordinates in the console. Values must
be separated by a comma, i.e. 1,2,3, and confirmed by
pressing | Enter |. If you press without typing any
value, the axes origin of the cylinder will be placed in
correspondence with the XYZ origin.

The program console prompts Sides.

Type the number of sides of the polygon in the console and

press [Enter]

The program console prompts Radius.

Define the radius by either clicking and dragging the
Radius point hotSpot of the polygon or by typing the radius
value in the console.

Hold the mouse button down after the click in the view to
interactively define the radius value.
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Options

Sides

To define the number of sides of the polygon,
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can

range from 3 to oo.

Radius

To change the radius.

Views. Choose the Edit mode. Click the Radius point hotSpot
and drag it. Release the mouse button when you have reached the
desired radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can

range from 0 to oo.
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Helix

Draws a helix (or a spiral if top and bottom radius are different).

How to use

Click the Helix icon or choose the Tools » Curves »
Helix command.

The program console prompts Local axes origin.

Position the helix either by clicking and dragging in any
view (release the mouse button to confirm placement) or
by typing its XYZ coordinates in the console. Values must
be separated by a space or a comma, i.e. 12 3 or 1,2,3, and
confirmed by pressing [Enter ]. If you press without
typing any value, the axes origin of the helix will be placed
in correspondence with the XYZ origin.

The program console prompts Bottom radius.
Define the bottom radius by either clicking and dragging
the Bottom radius hotSpot or by typing the radius value in

the console.

Hold the mouse button down after the click to interactively
define the bottom radius value.

Repeat step 5 at the Top radius console prompt.
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10.

The program console prompts Height.
Define the height by either clicking and dragging the
Height point hotSpot in a view or by typing the height

value in the console.

Hold the mouse button down after the click in the view to
interactively define the height value.

The program console prompts Turns.

Define the number of turns by typing it in the console.
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Options

Bottom radius

To change the radius of the first turn of the helix.

Views. Choose the Edit mode. Click the Bottom radius hotSpot
and drag it. Release the mouse button when you reach the
desired radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to oo

Top radius

Height

To change the radius of the last turn of the helix.

Views. Choose the Edit mode. Click the Top radius hotSpot and
drag it. Release the mouse button when you reach the desired
radius.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter ]. The value can
range from 0 to oo

Note: Set the top radius value lower than the bottom radius one
or viceversa to obtain a spiral.

To change the height.

Views. Choose the Edit mode. Click the Height hotSpot and
drag it. Release the mouse button when you reach the desired
height.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter ]. The value can
range from 0 to oo
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Turns

Pitch

To determine the number of turns of the helix.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

To determine the distance between two turns.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [ Enter |. This value is
inversely proportional to the number of turns. The higher the
pitch value, the lower the number of turns.

Turning

To make the helix clockwise or counterclockwise.
Modeling Tool panel. Switch on the preferred radio button
option.

Points per turn

To determine the number of control points that will be created
per each turn of the helix if you use the Collapse Construction
Tree command.

Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing | Enter ]. The value can
range from 4 to 20.
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—+ Offset

Creates a copy of a curve at a specified distance.

How fto use

1. Click the Offset icon or choose the Tools » Curves »
Offset command.

2. The program console prompts Pick Curve.

3. Pick the curve you want to offset. The curve will be
displayed in green.

4. The program console prompts to define the Offset distance.

5. Type the distance value in the console or determine it by
clicking and dragging the Offset point hotSpot.

Hold the mouse button down after the click to interactively
define the distance.
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Curve

Offset

Options

To change the curve to offset.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

To modify the offset distance

Views. Choose the Edit mode. Click the Offset point hotSpot and
drag it. Release the mouse button when you reach the preferred
distance.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Options

Modeling Tool panel. Switch one of the following radio buttons on:
Symmetric creates the offset on both sides of the curve.

Closed automatically connects the offset endpoints with the
original curve or the simmetric offset endpoints in order to create
a closed path.

Rounded corners rounds the corners of the offset caused by
sharp corners of the original curve.

Rounded ends is used in conjunction with Closed and allows to
close with half-circles the endpoints of the offset.
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@ Split curve

Splits two intersecting curves into more parts.

How fto use

I. Click the Split curve icon or choose the Tools »
Curves » Split curve command.

2. The program console prompts Pick curve #1.
3. Pick the first intersecting curve. It turns red.
4.  The program console prompts Pick curve #2.
5. Pick the second intersecting curve. It turns red.

6.  The Console prompts Choose which curves will be split and
offers you three options: Both, 1%, 2™

7. If you type B (Both), you will split both curve #1 and curve
#2. By choosing 1% or 2" you will only split the curve #1
or the curve #2 respectively.
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Q Divide curve

Divides a curve into two independent curves whose respective
lengths are displayed in the Modeling Tool panel.

How fto use

1. Click the Divide curve icon or choose the Tools »
Curves » Divide curve command.

2. The program console prompts Pick a curve at break point.

3. Position the cursor and drag along the curve. Release the
mouse button when you reach the point to divide the curve
at.
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Break curve

Breaks a curve into two joined curves whose respective lengths
are displayed in the Modeling Tool panel.

How fto use

1. Click the Break curve icon or choose the Tools p»
Curves » Break curve command.

2. The program console prompts Pick a curve at break point.

3. Position the cursor and drag along the curve. Release the
mouse button when you reach the point to break the curve
at.
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Blend Curves

Creates a new blend curve between two existing curves.

How to use

1. Click the Blend curves icon or choose the Tools »
Curves » Blend curves command.

2. The program console prompts Pick curve #1 near endpoint.

3. Pick the first curve near the endpoint where you want the
blend curve to start. Once picked, the curve turns green.

4. The program console prompts Pick curve #2 near endpoint.
5. Pick the second curve near the endpoint where you want

the blend curve to end. Once picked, the curve turns green
and the new blend curve is created.

Thanks to the Construction Tree even if you move and
modify the two original curves, the blend curve is
interactively updated and stays attached as shown in the
next pictures.
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While a blended curve is selected, the Modeling Tool panel
offers you several options for adjusting it.
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Options

Curve #1

To change the curve #1.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Endpoint #1

To change the curve #1 point to which the blend curve is
attached.

Modeling Tool panel. Switch one of the two radio buttons on to
choose the Start or the End of the curve.

Smoothness #1

To control smoothness of the blend curve at curve #1 endpoint.
Modeling Tool panel. Move the slider or type the smoothness
value in the data field and press to confirm. Changes are

interactively displayed in the views.

Curve #2

To change the curve #2.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Endpoint #2

To change the curve #2 point to which the blend curve is
attached.

Modeling Tool panel. Switch one of the two radio buttons on to
choose the Start or the End of the curve.
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Smoothness #2

To control smoothness of the blend curve at curve #2 endpoint.
Modeling Tool panel. Move the slider or type the smoothness
value in the data field and press to confirm. Changes are

interactively displayed in the views.

Tangents

To invert direction of tangents.
Modeling Tool panel. Switch on the Invert curve #1 or Invert
curve #2 radio buttons where convenient.
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f Curve Tangency Align

Allows you to establish tangent continuity between two curves.

How to use

Click the Curve tangency align icon or choose the
Tools » Curves » Curve tangency align command.

The program console prompts Pick master curve at
tangency point.

Pick the first curve you want to align at tangency point,
whose position can be defined by sliding along the curve
without releasing the mouse button. The curve turns green.

1 0 Lx

The program console prompts Pick slave curve near
endpoint.

Pick the second curve you want to align near the desired
endpoint.
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A new curve establishing tangent continuity with the
master curve is created in place of the original slave curve.

The new curve is automatically updated at any
modification of the master curve. If you set the angle
parameter at 90 degrees you can make the new curve
perpendicular to the master curve.

The original slave curve is hidden but not deleted. Thus,
you can select it from the browser and modify its shape
working in Edit mode. The newly created curve will be
updated at any change.

By default, the new curve is attached to the master curve,
but you can also disable this option, in which case the new
curve will have tangency alignment to the master curve but
will not be attached.
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Options

Master curve

To change the master curve.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Point on master

To adjust the tangency point along the master curve.

Modeling Tool panel. Move the slider or type the position value
(in a 0 to 1 range where 0 and 1 represent the endpoints) in the
data field and press to confirm. Changes are interactively
displayed in the views.

Slave curve

To change the slave curve.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Endpoint on slave

To change the desired endpoint of the slave curve.
Modeling Tool panel. Switch one of the two radio buttons on to
choose the Start or the End of the curve.
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Angle

To set the angle of the new curve with respect tothe master one.
Modeling Tool panel. Move the slider or type the degree value in
the data field and press to confirm. Set 0 for tangency, 90
for perpendicularity.

You can slide the new curve along the master one by simply
dragging Point on master curve.
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Attach

To join master and slave curves by attaching the tangency point
on master curve and the endpoint on slave curve.

Modeling Tool panel. Switch off the check button to disable this
option, which is enabled by default.

G2 continuity
To compute G2 continuity (tangency and curvature) between
master and slave curve.
Modeling Tool panel. Switch the G2 continuity check box on.

Invert tangent dir.
To invert direction of the tangents.
Modeling Tool panel. Switch the Invert tangent dir. check box
on where convenient.

Tangency plane

To define your preferred tangency plane.
Modeling Tool panel. Switch the chosen radio button on to
specify one of the following options: Auto, XY, XZ, YZ, User.

Tangency plane normal

If you have chosen the User option in the above Tangency plane
section, you can define any custom tangency plane by typing the
XYZ coordinates that determine the plane normal orientation.

Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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EdgeExtract

Extracts a curve from a surface and outputs a 3D curve.

How to use

1. Click the EdgeExtract icon or choose the Tools »
Curves p EdgeExtract command.

2. The program console prompts Pick Surface.

3. Pick the target surface. Once picking is performed, the
surface is displayed in dark green and the surface edges in
blue.
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4. The program console prompts Pick Edges.

5. Pick the edges you want to extract by either clicking
related hotSpots directly in the views or by selecting paths
listed in the Modeling Tool panel. To select multiple paths,
just pick them while holding the key down. Picked

edges are displayed in yellow.

358 solidThinking User Manual



Modeling = Curves

6.  To end edge selection press [Spacebar].

Selected edges will be now displayed in magenta, ready to
be used for any other action (in the example below, for an
extrusion).
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Options

Surface

To change the target surface.
Views / Modeling Tool panel. Switch the Replace check button
on, and pick another surface in the scene.

Edges
To select the edges you want to extract
Views. Choose the Edit mode. Click the hotSpot of the curve

you want to extract.
Modeling Tool panel. Select edges from the list.
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Extract isoparametric

Extracts an isoparametric curve from a surface in U or V
direction. This command creates a curve that is not attached to
the surface although it exactly runs on the surface.

This command is useful for creating trimming curves on
surfaces. Isoparametric curves can also be used to recreate a
given surface with different parameterization. Extract several
isoparms and use the Loft or Skin command to create a surface
through them.

An isoparametric curve extracted from a surface can be used as a
snappable location when you need to place an object on such
surface.

How to use

1. Select a NURBS surface.

2. Click the Extract isoparametric curve icon or choose the
Tools » Curves » Extract isoparametric curve command.

3. Open the Modeling Tool panel (shortcut is Ctrl + 2) and
specify the direction (U or V). In the Parameter section,
type a value between 0 and 1 or move the slider to
interactively change the position of the isoparametric curve
over the surface. The isoparametric curve is displayed in
dark green.

4.  Press the Go button when you have reached the desired
position.
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Options

Isoparm direction

To choose whether to extract the isoparm in the U or V direction.
Modeling Tool panel. Switch one of the following radio buttons on:
U direction if you want to extract a curve in the U direction.

V direction if you want to extract a curve in the V direction.

Parameter

To choose where to extract the curve along the U or V direction.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter]. The value can

range from 0 to 1.
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v Curves from intersection

Extracts a curve from the intersection of two surfaces.

How to use

1. Click the Curves from surface intersection icon or choose
the Tools » Curves p Curves from surface intersection
command.

2. The program console prompts Pick Surface 1.

3. Pck the first surface. It turns red.

4.  The program console prompts Pick Surface 2

5. Pck the second surface. It turns red.

6. The program will generate the curves defined by the
intersection of the two surfaces. You can then use the

resulting curves by either leaving the Construction Tree or
collapsing it (shortcut for collapsing the Construction Tree

is[C]).
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Options

Surface 1

To change the first surface.
Views / Modeling Tool panel. Switch the Replace check button
on, and pick another surface in the scene.

Surface 2

To change the second surface.
Views / Modeling Tool panel. Switch the Replace check button
on, and pick another surface in the scene.
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. Sections

Creates an object containing the section curves of a NURBS
surface object. User can specify the direction and the position of
the section planes as well as the number of the planes and the
distance between them. This modelling tool mantains the
Construction History.

How to use

1. Click the Sections icon or choose the Tools »
Curves » Sections menu command.

2. Pick the NURBS surface whose section or sections you
want to calculate.

Choose Edit mode to interactively change direction of
section planes.
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Object

Options

To change the object to section.
Views/ Modeling Tool panel. Switch the Replace check button on
and pick another NURBS surface object in the scene.

Default directions

Origin

To set a default direction for the section planes.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: X, Y, Z local axes, Vertical, and
Horizontal. These two options are the up and the right direction
of the active view.

To change the starting point of the section plane normal direction.
Views. Choose the Edit mode. Click the Origin hotSpot and drag
it. Release the mouse button when you reach the preferred position.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].

Planes dir.

To change the ending point of the section planes normal direction.

Views. Choose the Edit mode. Click the Planes dir. hotSpot and
drag it. Release the mouse button when you reach the preferred direction.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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Distance between sections

To set the distance between each section
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].

Number of sections

To specify the total number of sections.
Modeling Tool panel. Set the value either by moving the slider or
by typing it in the data field and pressing [Enter].

Options
To change some defaults for user interaction.
Modeling Tool panel. Check the Show section planes check box if
you want to visualize the section planes.
Check the Interactive Changes check box if you want that

changes are applied at every mouse movement and not only when
the mouse button is released.
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Silhouette

Creates an object containing the silhouette curves and the
boundary curves of a NURBS surface object. Curves can be
calculated by a parallel or perspective projection. This modelling
tool maintains the Construction History.

How to use

1. Click the Silhouette icon or choose the Tools » Curves »
Silhouette menu command.

2. Pick the NURBS surface whose silhouette you want to
calculate.
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Options

To change the object whose silhouette you want to calculate..
Views/ Modeling Tool panel. Switch the Replace check button on
and pick another NURBS surface object in the scene.

Default directions

Start

End

To set a default direction for the silhouette.

Modeling Tool panel. Switch the chosen radio button on. You
have the following options: X, Y, Z local axes, Vertical, and
Horizontal. These two options are the up and the right direction
of the active view. View dependent should be enabled if you
want that Start and End points of the silhouette direction match
Position and Look at hotSpots of the active camera.

To change the starting point of the silhouette direction.

Views. Choose the Edit mode. Click the Start hotSpot and drag it.
Release the mouse button when you reach the preferred position.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].

To change the ending point of the silhouette direction.

Views. Choose the Edit mode. Click the Start hotSpot and drag it.
Release the mouse button when you reach the preferred position.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter].
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Direction

To change the silhouette computation method.
Modeling Tool panel. Check the Perspective projection check

box if you want that the silhouette direction is calculated using a

perspective projection view instead of a parallel projection view
(default).
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PathCast

Projects a curve onto a surface in order to obtain a 3D curve on
surface.

How to use

1. Click the PathCast icon or choose the Tools » Curves »
PathCast command.

2. The program console prompts Pick curve.

3. Pick the curve you want to be projected along a vector on
the target surface.

Once picked, the curve turns green.
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4.  The program console prompts Pick surface.

5. After you pick the target surface, the program will display
it in green and the curve projection in magenta.

Note: By default, the curve is projected along both the
curve normal and its opposite, but you have several

options to modify this (see Projection Direction in the
Options list).
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Options

Curve
To change the curve to be projected.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Surface

To change the target surface.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another surface in the scene.

Projection direction

To determine the vector along which the curve will be projected.
Modeling Tool panel. Switch the chosen radio button on. You
have the following options:

X axis. The curve is projected along the X-axis.

Y axis. The curve is projected along the Y-axis.

Z axis. The curve is projected along the Z-axis.

Current view. The curve is projected along the axis that is
perpendicular (normal) to the current active view.

Curve normal. The curve is projected along its normal.

Inverse curve normal. The curve is projected in the opposite
direction with respect to the curve normal.

Both curve normals. The curve is projected along both its
normal and opposite direction.
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Projection start point
Projection end point

To modify XYZ coordinates of the projection start and end
points, hence allowing you to determine a custom vector along
which the curve will be projected. and confirm them by pressing

Enter].
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Curve to Plane

Transforms a 3D curve into a planar curve by projecting its
control points on a specified plane. It is not a projection of the
curve but only of its control points.

How fto use

1. Click the Curve to Plane icon or choose the Tools
Curves » Curve to Plane command.

2. The program console prompts Pick curve.
3. Pick the curve you want to make planar.

4. More options are available in the Modeling Tool panel.

solidThinking User Manual 375



Section 4

Options

Curve

To change the curve.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Projection direction

To change the direction of the plane normal. The default
direction is: Best plane.

Modeling Tool panel. Switch the chosen radio button on.

You have the following choices:

Best plane. Approximate a plane on which the curve lies.

XY plane. To project on the XY plane

YZ plane. To project on the XY plane.

XZ plane. To project on the YZ plane.

Custom plane. To freely define the origin and the normal of the
projection plane.

Plane origin
To determine the origin of the plane. Activated only when the
Custom plane option is enabled.
Views. Choose the Edit mode. Click the Plane origin hotSpot
and interactively define its orientation by dragging it.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter]|.
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Plane normal
To determine the normal of the plane. Activated only when the
Custom plane option is enabled.
Views. Choose the Edit mode. Click the Plane normal hotSpot
and interactively define its orientation by dragging it.
Modeling Tool panel. Type the values in the XYZ data fields and

confirm them by pressing [Enter|.
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Join curve entities

Joins the entities of a composed curve in order to form a unique
entity.

How fto use

1. Click the Join curve entities icon or choose the Tools
Curves » Join curve entities command.

2. The program console prompts Pick a curve.
3. Pick the curvewhose entities you want to be joined.

4. More options are available in the Modeling Tool panel.
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Options

To change the curve.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Endpoints tolerance

Cusps

To specify the maximum allowed distance between two endpoints.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [ Enter].

To determine whether the cusps should be maintained or
approximated.

Modeling Tool panel. Switch one of the following radio buttons on:
Approximate. Approximates the cusps of the curve without
discontinuity, depending on the value in the Cusps tolerance
field.

Maintain. Replicates the knots in the curve in order to maintain
the cusps.

Cusps tolerance

To specify the tolerance value of cusps. Activated only when the
Approximate option is enabled. The created curve will not
deviate from the original curve more than this tolerance.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing[Enter].

Parametrization

To specify the knots distribution method. The default is Chord
length.

Views / Modeling Tool panel. Options are:

Uniform, Chord length, Centripetal.
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ee Rebuild Curve

Rebuilds a curve with a user-defined number of points
distributing them at a constant distance while still keeping the
curve original shape.

How fto use

1. Click the Rebuild curve icon or choose the Tools »
Curves » Rebuild curve command.

2. The program console prompts Pick Curve.
3. Pick the curve you want to rebuild.

4.  The program console prompts you to specify the Points
number.

5. Type the number of points in the console and press
to confirm.

6.  More options are available in the Modeling Tool panel.
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Options

Curve

To change the curve to rebuild.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Points number

To change the number of points.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing .

Points distribution

To determine the points distribution method.

Modeling Tool panel. Switch one of the following radio buttons
on. You have the following choices:

Points # for total curve. The specified number of points will be
distributed along the whole curve.

Points # for each entity. The specified number of points will be
distributed along each entity composing the curve.

Invert direction

To invert the direction or sequence of control points on a curve.
Modeling Tool panel. Switch the Invert direction check button on.

Keep original CVs

To rebuild curves with the same number of control points of the
original curve.
Modeling Tool panel. Switch the Invert direction check button on.

Max distance

Shows the maximum distance between the original curve and the
rebuilt one.
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Simplify curve

Reduces the number of points of a curve given a specified
tolerance.

How fto use

1.  Click the Simplify curve icon or choose the Tools »
Curves » Simplify curve command.

2. The program console prompts Pick Curve.

3. Pick the curve you want to simplify. The curve will be
displayed in purple.

4.  In the Modeling Tool panel, adjust the Tolerance value by
typing the value in the data field or by moving the slider.
The Input/Output readout gives you exact feedback on the
reduction as you change the Tolerance value.
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Options

Curve

To change the curve to simplify.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene.

Tolerance

To modify the tolerance value. The higher the value, the bigger
the difference between the original curve and the simplified one.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Input points

The number of points of the original curve.

Output points

The number of points of the simplified curve.

Input/Output %

The percentage of reduction of the simplified curve respect to the
original one.

solidThinking User Manual 383



Section 4

Curve to arcs

Creates a new curve made up of a series of accurate arcs
approximating the original planar curve.

Useful for exporting to a CAM solution, where a succession of
joined arcs is preferred to a generic curve.

The result is a curve composed of more arcs, each of them
separated by a green dot.

How to use

1. Click the Curve to Ares icon or choose the
Tools » Curves » Curve to Arcs command.

2. The program console prompts Pick a planar curve.
3. Pick the curve you want to transform into a sequence of

arcs. If the curve is not planar, the tool attempts to
planarize it.
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Options

Planar curve

To change the curve to transform into a sequence of arcs.

Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene. The sequence of arcs will
automatically be modified.

Tolerance

To modify the tolerance value. The higher the value, the bigger
the difference between the original curve and the resulting arcs.
Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Status

Information about the transformation process.
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?

Extend Curve

Extends a curve for a user-defined length to a given point or to
another curve.

How fto use

1. Click the Extend curve icon or choose the
Tools » Curves » Extend curve command.

2. The program console prompts Pick a curve near the end-
points.

3. Pick the curve near the end point you want to extend.
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Options

Curve
To change the curve to extend.
Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene. The extended curve will
automatically be modified
Extend to
To specify the preferred extension method.
Modeling Tool panel. Switch the chosen radio button on. There
are three options:
Distance. Extension for a user-defined distance.
Point. Extension to a given point.
Curve. Extension to another curve.
Side

To change the side of the curve that will be extended.

Views. Choose the Edit mode. Click the End-point hotspot and
drag it to the other side, then release the mouse button.

Modeling Tool panel. Switch the radio button to select Curve
start or Curve end.

Total curve length
The total length of the extended curve.
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Extension length

To adjust the extension length. Directly modifiable when you
choose Distance in the Extend to section.

Views. Choose the Edit mode. Click the Extension point and
drag it. Release the mouse button when you reach the desired
length.

Modeling Tool panel. Set the value either by moving the slider or

by typing it in the data field and pressing [Enter].

Extension point

To control the extension point. Directly modifiable when you
choose Point in the Extend to section.

Views. Choose the Edit mode. Click the Extension point and
drag it. Release the mouse button when you reach the desired
position.

Modeling Tool panel. Type the new values in the XYZ data
fields and confirm them by pressing [Enter].

Extension curve

To change the curve to which the original curve must be extended.
Active when you choose Curve in the Extend to section.

Views / Modeling Tool panel. Switch the Replace check button
on and pick another curve in the scene. The extended curve will
automatically be modified.

Continuity

To set continuity of the extended curve.

Modeling Tool panel. Switch one of the following radio buttons on:
Tangency (G1). Set tangency continuity. In case of extension
along the distance, the extension is a straight line.

Curvature (G2). Set curvature continuity.

Maximal (C). Set maximum continuity in relation with the curve
order.
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